Subject: Re: [TI994A] OK, let's get going with TI talk.

From: [email-masked]
Date: Sun, 01 Nov 2009 16:08:50 -0600 (CST)

I also have a machine here that runs 24/7. (Not the BBS, a peecee.)

Nov 1, 2009 03:35:35 PM, [email-masked] wrote:

I've got an idea about making the stuff on whtech.com more readily
available, but I'm not the one who can implement it. Hopefully someone
here or one of our 'yet to be' members can carry this through.

My idea involves someone who has downloaded or obtained through other means the contents of the entire site. Hopefully that person is also familiar with torrents. Getting my drift? Create a torrent of the 
entire site so that an individual wouldn't have to spend weeks or months
downloading all the files individually.

Once there are several seeders, anyone could download the entire site contents rather quickly and with little effort. I know I'd be highly interested in this and would be willing to leave a computer on 24/7 indefinitely seeding such a torrent.

Sound like a good idea?

Tony

------------------------------------

Yahoo! Groups Links

---

From: Marc Hull <[email-masked]>
Date: Sun, 1 Nov 2009 14:20:11 -0800 (PST)

This may be an overwhelming addition but I'll ask anyway....

Is there a feasible way to both get the data and maybe clean it up and organize it.  I for one know that getting a specific bit of info from WHT is like looking through a Dewey Decimal cabinet while it's on fire.  This most likely has to do with the fact that I haven't been on the scene for very long but I also know that there are other incompetents out there in the same boat as I am.  I'll help where I can but I am geared more to wood chips than computer chips.

--- On Sun, 11/1/09, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] OK, let's get going with TI talk.
To: [email-masked]
Date: Sunday, November 1, 2009, 4:08 PM

    

Nov 1, 2009 03:35:35 PM, TI994A@yahoogroups. com wrote:

Sound like a good idea?

Tony

------------ --------- --------- ------

Yahoo! Groups Links

---

From: "Tony Knerr" <[email-masked]>
Date: Sun, 01 Nov 2009 22:30:53 -0000

--- In [email-masked], swim4home@... wrote:
> ...

--- In [email-masked], rmcarmany@... wrote:
>
> I have a set of the CDs but I'm not sure how current they are.
> ...

OK, looks like we're on the right track.

Bob, it doesn't matter if the files are real current or not. 
The torrent can just be updated from time to time without having to
re-download anything but the newer files. 
The MAME romset as updated by Pleasuredome.org.uk is a perfect example of how to implement this idea.
 
Are both you guys familiar with torrents and how they work?

Tony

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 1 Nov 2009 16:47:03 -0600

It seems a lot of WHT was re-organized based on emulator or file type versus actual system or use.  My pet peeve is how the Geneve files are spread all over the place based on disk and file format.  I gave up on offering to help re-arrange them a long time ago.  It is fairly easy (once you know the difference) to distinguish between PC99 .dsk files and V9T9 .dsk files.  Separating all these types adds to the duplication of disk images rampant on the site.

Great resource but in need of a spring cleaning IMHO.

To: [email-masked]
From: [email-masked]
Date: Sun, 1 Nov 2009 14:20:11 -0800
Subject: Re: [TI994A] OK, let's get going with TI talk.

  

Sound like a good idea?

Tony

Yahoo! Groups Links

_________________________________________________________________
Hotmail: Trusted email with powerful SPAM protection.
http://clk.atdmt.com/GBL/go/177141665/direct/01/

---

From: "Tony Knerr" <[email-masked]>
Date: Sun, 01 Nov 2009 22:52:21 -0000

> Great resource but in need of a spring cleaning IMHO.

Having the files on one's pc would make organizing them  much easier
than trying to work with them over an ftp server. 'nother good reason 
to pursue the torrent idea. :)

Tony

---

From: "epergrem" <[email-masked]>
Date: Mon, 02 Nov 2009 00:11:04 -0000

Hi Tim, Marc, Tony, etc.
I'll jump in here.

Several months ago I approached Don and he agreed to let me 'organize' the WHT site.

I'm the guy you can blame or credit with some of the new categories (e.g. programming, database, word processing, etc.)  The goal was to orgranize it much like a library.  

It would be emulator independent, meaning all database files (disk and documents) would go into the Database\(specific product).  

However, it became somewhat clear that those looking for just PC99 files would then have to navigate the entire site, looking through each directory.  So, that idea fell by the wayside.

Then you have something like Funnelweb, which applies to multiple categories, so where does it fit in?

There was also an issue that some things were being added without a search to see if it already existed, so we ended up with duplcates.  Also, it would frequently get stuck where the uploaded wanted it, not where it might best go.

So, the project is incomplete as of now, due to it being somewhat overwhelming.  

I still have update access, so if some folks want to submit their recommendations on the best way to organize the site, I'm open to suggestions.   

Ernie

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 1 Nov 2009 18:34:10 -0600

It's a daunting task.  From my cave, all Geneve-related items could fall under one folder with basic sub-categories like MDOS, utilities, etc.  If the program or disk was not Geneve-specific, all bets are off. 9640*News is a good example -- it is a Geneve disk publication with TI files on it, that IMHO belongs in the Geneve folder ;)   I haven't really looked much at the TI side but I guess it depends how you look at the files and categories. I was never a good librarian, so I'll just have to put up the white flag.  Since I'm being cranky anyway, too many folder levels is also hard to deal with.  I think it was Mark Wills' site that I tried but gave up on due to the folder proliferation. Course, as my wife knows, I'm more "linear" with files.  I wonder if I picked that up from Don Walden?  I like my stuff in "stacks" and avoid compartmentalization. 

Just knowing you have access opens up some possibilities to the folks here.  Glad you spoke up :)   

Now I need to go eat before I get grouchy and Tony bans me.

;)-

> From: [email-masked]
> Date: Mon, 2 Nov 2009 00:11:04 +0000
> Subject: [TI994A] Re: OK, let's get going with TI talk.
> 
> 
> 
> Hi Tim, Marc, Tony, etc.
> I'll jump in here.
> 
 		 	   		  
_________________________________________________________________
Hotmail: Trusted email with Microsoft's powerful SPAM protection.
http://clk.atdmt.com/GBL/go/177141664/direct/01/
http://clk.atdmt.com/GBL/go/177141664/direct/01/

---

From: "Tony Knerr" <[email-masked]>
Date: Mon, 02 Nov 2009 00:42:02 -0000

> Now I need to go eat before I get grouchy and Tony bans me.

You have a permanent immunity idol, friend. :)

Tony

---

From: "ti99_forever" <[email-masked]>
Date: Mon, 02 Nov 2009 05:35:32 -0000

Ok, I'm a Linux/OSX junkie, but I don't know how this would work for ftp.

I'm like Tim, Planet-99 was 7-8 layers of folders/clicks to find some empty.

Categorizing these things in folders is a real problem as they fit several categories.

Can't we have a flat-directory with everything in it and then soft-links (shortcuts) from folders of categorization?

Now, before anyone mentions missing shortcuts or broken links, there HAS to be some script already existing out there to update shortcuts/links. I remember seeing files on TI BBSes where for each file there was a description file. Perhaps something like this, whether 1 for each, or a master, where categories could be edited or added to a file and then the script will update the links based upon differences between the old master file and the new?

I will not waste anymore brain time on this subject, because many of my ideas tend to be dead out of the box because of something I overlook...

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:
> > From: epergrem@...
> > --- In [email-masked], Insane Multitasker <insane_m@> wrote:
> > >
> > >

---

From: mark wills <[email-masked]>
Date: Sun, 1 Nov 2009 21:41:47 -0800 (PST)

>I'm like Tim, Planet-99 was 7-8 layers of folders/clicks to find some empty.

True. But the site search facility should anything you are looking for into one single click :-)

Mark

---

From: ti99_forever <[email-masked]>
Date: Sun, 1 Nov 2009 21:46:54 -0800 (PST)

During the Faire, there were several examples where I tried the search and it didn't find the target file, but I could show to my 2 companions that it did indeed exist. We couldn't figure out why the search failed...

--- On Mon, 11/2/09, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Monday, November 2, 2009, 12:41 AM

    

Mark

---

From: mark wills <[email-masked]>
Date: Sun, 1 Nov 2009 21:49:40 -0800 (PST)

If you can let me know the details (what you were looking for, and the search terms you used) I'll look into it.

Thanks

Mark.

>
>From: ti99_forever <[email-masked]>
>Sent: Mon, 2 November, 2009 6:46:54
>--- On Mon, 11/2/09, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>From: mark wills <markrobertwills@ yahoo.co. uk>
>>To: TI994A@yahoogroups. com

---

From: mark wills <[email-masked]>
Date: Sun, 1 Nov 2009 21:51:14 -0800 (PST)

It's probably the GIGO principle in effect.

Unfortunately the search is only as good as the descriptions given in the various fields when files are uploaded. It's up to people to use good descriptions etc, then the search will find it :-)

Mark

---

From: ti99_forever <[email-masked]>
Date: Sun, 1 Nov 2009 21:56:29 -0800 (PST)

I will have to "re-construct" it... I've forgotten many details of the Faire, and my memory is just starting to return...

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Monday, November 2, 2009, 12:49 AM

    

Thanks

Mark.

From: ti99_forever <ti99_forever@ yahoo.com>
To: TI994A@yahoogroups. com
Sent: Mon, 2 November, 2009 6:46:54
Subject: Re: [TI994A] Re: OK, let's get going with TI talk.

 

Mark

---

From: ti99_forever <[email-masked]>
Date: Sun, 1 Nov 2009 21:56:52 -0800 (PST)

I was searching based on the file names...

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Monday, November 2, 2009, 12:51 AM

    

Mark

To:
 TI994A@yahoogroups. com

 

Mark

---

From: "Beery" <[email-masked]>
Date: Thu, 05 Nov 2009 21:30:11 -0000

I used to have a database search engine setup that would search all of whtech whenever you were looking for a search term, word, description, etc.

Then, someone reorganized the whole site.  Also, it never seemed anyone really used the 9640News.com website for the search engine feature so I abandoned the effort.

As far as downloading the whole site, it really doesn't take that long to do if you take an application like WS_FTP.  You can mark the site and probably download it in but a few hours.

Beery

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
> --- On Sun, 11/1/09, swim4home@... <swim4home@...> wrote:
> 
> From: swim4home@... <swim4home@...>

---

From: "Tony Knerr" <[email-masked]>
Date: Thu, 05 Nov 2009 21:54:16 -0000

> As far as downloading the whole site, it really doesn't take that long to do if you take an application like WS_FTP.  You can mark the site and probably download it in but a few hours.

Beery,

I've tried about a dozen different utilities over the past several years to do exactly that. None of them worked, not even a little bit.
I always got an error like "file not found" or something similar to
that. Thinking the error was in the password, I tried a bunch of 
different ones found on the web, "anonymous" being the most common.
Tried different port settings, tried to get one folder at a time, etc.
So there must be a "trick" to this, or one needs a special password 
for the site. Perhaps you will enlighten us.

Anyway, that futility was where my torrent idea was born. And it seems to be working quite well so far. I acquired all 18.9gb (20,144
files) in about 5 hours this morning, and have given about 6gb back to
others so far. 

Wonderful stuff to wade through...

Tony

---

From: "Beery" <[email-masked]>
Date: Thu, 05 Nov 2009 22:04:33 -0000

It took some processing time, but here is what I basically did as I recall.

Once I had all the files on my system, I did a directory to a text file that captured all the filenames and paths.  I think filesize was also captured.  At the time, I think the only file descriptions I had were for the files on the 9640News CD-Rom that was part of whtech.

I then imported that file into a excel spreadsheet, and did some text parsing, as well as some subtitution for drive mapping to a FTP path to the file.

Then, I wrote that file out I belive to an access database where it was subsequently imported into  a mysql database with a php frontend.

About 6 months ago, I did not renew the 9640news.com domain.  Prior to that, I had to setup a robots.txt file as different search engines were trolling the php database and it was the only source of "downloads".  I posted several times on the ti99-4a group to see if anyone was using the feature over several years, and never got back a single, response.  Zip, nothing, null.

Beery

Beery

--- In [email-masked], "Tony Knerr" <tonyknerr@...> wrote:
>
> --- In [email-masked], "Beery" <bmiller@> wrote:
> > ...

---

From: Owen Brand <[email-masked]>
Date: Thu, 5 Nov 2009 18:42:46 -0500

Man, that seems like the way to go.  But you said it was mostly  
unused, eh?  I wonder if such a directory could be set up now, using  
the method you described, and then--though it would be difficult--use  
the information ascertained by the "spiders" or "infobots"  to  
reorganize the files into a more manageable file system.  Was your  
directory system/search engine efficient?  Did it seem to work the way  
you wanted it to?

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 5, 2009, at 5:04 PM, "Beery" <[email-masked]> wrote:

> Once I had all the files on my system, I did a directory to a text  
> file that captured all the filenames and paths. I think filesize was  
> also captured. At the time, I think the only file descriptions I had  
> were for the files on the 9640News CD-Rom that was part of whtech.
>
> I then imported that file into a excel spreadsheet, and did some  
> text parsing, as well as some subtitution for drive mapping to a FTP  
> path to the file.
>
> Then, I wrote that file out I belive to an access database where it  
> was subsequently imported into a mysql database with a php frontend.
>
> About 6 months ago, I did not renew the 9640news.com domain. Prior  
> to that, I had to setup a robots.txt file as different search  
> engines were trolling the php database and it was the only source of  
> "downloads". I posted several times on the ti99-4a group to see if  
> anyone was using the feature over several years, and never got back  
> a single, response. Zip, nothing, null.
>
> Beery
>
> Beery
>
> > > As far as downloading the whole site, it really doesn't take  
> that long to do if you take an application like WS_FTP. You can mark  
> the site and probably download it in but a few hours.
> > >
> > > Beery
> > > ...
> >
> > Beery,
> >
> > I've tried about a dozen different utilities over the past several  
> years to do exactly that. None of them worked, not even a little bit.
> > Anyway, that futility was where my torrent idea was born. And it  
> seems to be working quite well so far. I acquired all 18.9gb (20,144

---

From: "ti99_forever" <[email-masked]>
Date: Fri, 06 Nov 2009 02:24:12 -0000

> files) in about 5 hours this morning, and have given about 6gb back to
Good for you! I'm not having much luck. Stupid Vuze seems to be capping my dl rate at around 18kbps regardless of setting (no limit, 300kpbs, etc).

I had a similar issue with another bittorrent client last year before I moved to Azureus (which is now Vuze).

Ugh!

---

From: ti99_forever <[email-masked]>
Date: Thu, 5 Nov 2009 18:31:11 -0800 (PST)

And now Bittorrent is throwing errors. Files truncated (aborts the download), info locks up the app... fun.

--- On Thu, 11/5/09, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Thursday, November 5, 2009, 9:24 PM

  

      

--- In TI994A@yahoogroups. com, "Tony Knerr" <tonyknerr@. ..> wrote:

> --- In TI994A@yahoogroups. com, "Beery" <bmiller@> wrote:

Ugh!

---

From: "Tursi" <[email-masked]>
Date: Thu, 5 Nov 2009 21:35:17 -0500

> Good for you! I'm not having much luck. Stupid Vuze seems to be 
> capping my dl rate at around 18kbps regardless of setting (no limit, 
> 300kpbs, etc).

Vuze is what I use, so I don't think it's the client's fault. In the 
status line at the bottom, did it detect that your NAT or other 
reachability is okay? If people can't reach you, you will never get good 
speeds.

---

From: Gregory McGill <[email-masked]>
Date: Thu, 5 Nov 2009 18:51:47 -0800

ktorrent works fine..  and my preference in linux..

Greg

---

From: ti99_forever <[email-masked]>
Date: Thu, 5 Nov 2009 18:54:20 -0800 (PST)

Yes, everything *TESTED* fine. But it seemed to cap the speed limit. Set up the port forwarding to my internal ip from 6681 to 6689.I've since tried Bittorrent, with strange file truncation issues.Now trying uTorrent, which started off fine enough, but is slowing down... now at 120mb/s down, with 5 peers... Started at almost 300mb/s

--- On Thu, 11/5/09, Tursi <[email-masked]> wrote:

From: Tursi <[email-masked]>
Subject: Re: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Thursday, November 5, 2009, 9:35 PM

  

> I had a similar issue with another bittorrent client last year before 

> I moved to Azureus (which is now Vuze).

speeds.

---

From: "Tursi" <[email-masked]>
Date: Thu, 5 Nov 2009 22:00:52 -0500

>Yes, everything *TESTED* fine. But it seemed to cap the speed limit. 
>Set up the port forwarding to my internal ip from >6681 to 6689.I've 
>since tried Bittorrent, with strange file truncation issues.Now trying 
>uTorrent, which started off fine >enough, but is slowing down... now at 
>120mb/s down, with 5 peers... Started at almost 300mb/s

A number of ISPs deliberately mess with Bittorrent streams, you could do 
a search to see if yours is one of them?

---

From: Owen Brand <[email-masked]>
Date: Thu, 5 Nov 2009 23:04:47 -0500

Greg, I've got this pentium mac I am trying to get to run an  
emulator...  No luck.  I don't have a Windows OS to install to my  
VirtualBox... Any ideas?

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "Tony Knerr" <[email-masked]>
Date: Fri, 06 Nov 2009 10:00:47 -0000

> Yes, everything *TESTED* fine. But it seemed to cap the speed limit. Set up the port forwarding to my internal ip from 6681 to 6689.I've since tried Bittorrent, with strange file truncation issues.…

Go for a higher numbered port. ISPs block or limit the lower ones sometimes. I suggest somewhere in the 50,000 to 60,000 range.

Tony

---

From: ti99_forever <[email-masked]>
Date: Fri, 6 Nov 2009 03:37:19 -0800 (PST)

What kind of download rate you have Tony?Currently uTorrent has about 350kb/s, and is 50% complete - estimating another 8 hours!I don't see a way to configure uTorrent to change those ports to a higher port #.

--- On Fri, 11/6/09, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Friday, November 6, 2009, 5:00 AM

  

      --- In TI994A@yahoogroups. com, ti99_forever <ti99_forever@ ...> wrote:

Tony

---

From: "Tony Knerr" <[email-masked]>
Date: Fri, 06 Nov 2009 12:10:53 -0000

> What kind of download rate you have Tony?Currently uTorrent has about 350kb/s, and is 50% complete - estimating another 8 hours!I don't see a way to configure uTorrent to change those ports to a hi…

Got to Options >Preferences >Connection
Untick Randomize and type your desired port number in the box,
then click ok.

I was downloading at about 800kb/s.
I have to limit my upload speed to 200kb/s, or everyone in the
house starts screaming that the internet doesn't work. :)
But I seed forever...

Tony

---

From: ti99_forever <[email-masked]>
Date: Fri, 6 Nov 2009 04:21:44 -0800 (PST)

uTorrent for Mac apparently isn't as feature-rich as for the PC.I can change the incoming TCP port, but it is already 30997 (no incoming connections).Randomize checkbox is already unchecked. Automatically map port is checked, but unchecking it does not reveal a way to change it manually. I've not come across much help on the uTorrent forums. But so far, this is the best of three clients I've tried, so maybe I'll just tough it out. At least it isn't killing my system performance like Vuze...

From: Tony Knerr <[email-masked]>
Subject: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Friday, November 6, 2009, 7:10 AM

  

      

--- In TI994A@yahoogroups. com, ti99_forever <ti99_forever@ ...> wrote:

then click ok.

But I seed forever...

Tony

---

From: "epergrem" <[email-masked]>
Date: Fri, 06 Nov 2009 12:21:27 -0000

Hi,
Just to inject in the discussion.  It is very likely that some of the structure of the WHT site will change or that files may be moved on occassion.

For instance, someone has placed a copy of the 'Amerisoft XG BASIC Manual' in the 'datasheets and manual' folder.  It should more correctly be in either the 'graphics' or 'programming' folder.   

What effect will the movement this file, and subsequent ones have on the torrent?

There are also the issues regarding the Geneve specific stuff that Tim mentioned earlier.

As I mentioned earlier.  If you have ideas about what you consider the most useful way the site should be organized then please put the structure on paper and email it to me.

Thanks,
Ernie

---

From: ti99_forever <[email-masked]>
Date: Fri, 6 Nov 2009 04:24:32 -0800 (PST)

Besides, I think my current downrate is max for my connection rate, if my brain is working this morning. And there is no throttling happening at my ISP, according to the faq at uTorrent.
--- On Fri, 11/6/09, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Friday, November 6, 2009, 7:21 AM

  

      uTorrent for Mac apparently isn't as feature-rich as for the PC.I can change the incoming TCP port, but it is already 30997 (no incoming connections) .Randomize checkbox is already unchecked. Automatically map port is checked, but unchecking it does not reveal a way to change it manually. I've not come across much help on the uTorrent forums. But so far, this is the best of three clients I've tried, so maybe I'll just tough it out. At least it isn't killing my system performance like Vuze...

--- On Fri, 11/6/09, Tony Knerr <tonyknerr@comcast. net> wrote:

From: Tony Knerr <tonyknerr@comcast. net>
Subject: [TI994A] Re: OK, let's get going with TI talk.
To: TI994A@yahoogroups. com
Date:
 Friday, November 6, 2009, 7:10 AM

    

--- In TI994A@yahoogroups. com, ti99_forever <ti99_forever@ ...> wrote:

then click ok.

But I seed forever...

Tony

---

From: ti99_forever <[email-masked]>
Date: Fri, 6 Nov 2009 04:32:49 -0800 (PST)

I've noticed that we southerners aren't afforded the massive bandwidths that our northern friends have... lucky we aren't on dial-up here, there are spots where it is dial-up or HughesNet satellite only.

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: OK, let's get going with TI talk.
To: [email-masked]
Date: Friday, November 6, 2009, 7:24 AM

  

      Besides, I think my current downrate is max for my connection rate, if my brain is working this morning. And there is no throttling happening at my ISP, according to the faq at uTorrent.
--- On Fri, 11/6/09, ti99_forever <ti99_forever@ yahoo.com> wrote:

 

 

      

--- In TI994A@yahoogroups. com, ti99_forever <ti99_forever@ ...> wrote:

then click ok.

But I seed forever...

Tony

---

From: "Tony Knerr" <[email-masked]>
Date: Fri, 06 Nov 2009 14:00:43 -0000

> What effect will the movement this file, and subsequent ones have on the torrent?

I had brought up the idea of a batch file to move the necessary files on one's personal computer prior to updating the torrent to a new one.
I assume this can be converted to a unix script and also something usable on a Mac, something I know zero about.
The person moving the files about will have to also be responsible for the batch file.

A torrent update will have the files in their new places and include new files added to the site since the last torrent.
It is advisable to run the batch file before starting the new torrent to avoid duplicate files and unnecessary downloading.

Is there a way to easily tell what files have been uploaded to whtech between torrent updates?

Tony

---

From: "epergrem" <[email-masked]>
Date: Fri, 06 Nov 2009 14:36:04 -0000

Tony,
I don't know if Don keeps some type of an upload log or not. 

At one time he enforced uploading to an 'upload' directory.  I'm not sure if that's the case anymore. 

If so, then the log might only tell you where the file was initially placed, not where it ended up due to a subsequent move.

You might drop him an email.

Ernie

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 6 Nov 2009 09:12:03 -0600

Hi Ernie,

Any chance you could run a directory tree with filenames, of the WHT site?  I'd be happy to identify the files and folders that would be good candidates for the Geneve folder. No rush...

> Date: Fri, 6 Nov 2009 12:21:27 +0000
 		 	   		  
_________________________________________________________________
Find the right PC with Windows 7 and Windows Live. 
http://www.microsoft.com/Windows/pc-scout/laptop-set-criteria.aspx?cbid=wl&filt=200,2400,10,19,1,3,1,7,50,650,2,12,0,1000&cat=1,2,3,4,5,6&brands=5,6,7,8,9,10,11,12,13,14,15,16&addf=4,5,9&ocid=PID24727::T:WLMTAGL:ON:WL:en-US:WWL_WIN_evergreen2:112009

---

From: "epergrem" <[email-masked]>
Date: Fri, 06 Nov 2009 15:20:39 -0000

Hey Tim,
I would be glad to.

---

From: "Beery" <[email-masked]>
Date: Fri, 06 Nov 2009 16:31:42 -0000

Yeah, the search function was very efficient.  For what I thought, it was the perfect setup to try and locate files, and where available, files that had appropriate keywords in their description.

Beery

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Nov 5, 2009, at 5:04 PM, "Beery" <bmiller@...> wrote:
> 
> > --- In [email-masked], "Tony Knerr" <tonyknerr@> wrote:
> > >

---

From: "Tursi" <[email-masked]>
Date: Fri, 6 Nov 2009 11:57:34 -0500

> For instance, someone has placed a copy of the 'Amerisoft XG BASIC 
> Manual' in the 'datasheets and manual' folder.  It should more 
> correctly be in either the 'graphics' or 'programming' folder.

It will obsolete it. But the torrent will continue, it just won't be up 
to date any more.

Although there are numerous ideas for dealing with the inevitable 
updates, ultimately at some point the torrent itself needs to be 
updated. If we script the movements so that every seed can make the same 
changes easily, then it will be a rapid update, otherwise it's a 
re-download.

My suggestion then is that we don't consider reseeding the torrent until 
we have some major changes -- a complete reorganization, removal of 
duplicate data, etc. The latter alone will shrink the size a fair bit.

The trick is figuring out how to do so collaboratively.

---

From: "Tony Knerr" <[email-masked]>
Date: Fri, 06 Nov 2009 19:36:16 -0000

> Any chance you could run a directory tree with filenames, of the WHT site?  I'd be happy to identify the files and folders that would be good candidates for the Geneve folder. No rush...

Anyone that's downloaded the torrent with a Winders machine can do it.
Drop into a command prompt, cd into the proper directory, and 
"TREE >prn" or someplace else than >prn.

Tony

---

From: "epergrem" <[email-masked]>
Date: Fri, 06 Nov 2009 22:24:40 -0000

Hey Tony,

If you don't mind, could you do it and send a copy to Tim?  I didn't have any plans to download the torrent, so I was going to ask Don.

It sounds like your way is much quicker.

Ernie

---

From: mark wills <[email-masked]>
Date: Fri, 6 Nov 2009 20:46:18 -0800 (PST)

The answer might be to re-arrange the data at source: on the FTP site itself.

It just needs one user with the appropriate permissions on the FTP server.

Mark

________________________________
From: Tursi <[email-masked]>
To: [email-masked]
Sent: Fri, 6 November, 2009 17:57:34
Subject: Re: [TI994A] Re: OK, let's get going with TI talk.

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 7 Nov 2009 01:22:54 -0600

OKay guys.  For my last project attempt of the night, I have been trying to set up a UDS-10-IAP to work as a file transfer conduit between the PC and TI. 

1.  I was able to upgrade the UDS10 firmware to the latest revision. 

2.  I am able to connect between the PC and TI using Hyperterminals and Telco, respectively.

3. When I attempt to transfer binary files via XMODEM, I get "short packet" and other errors.

4. The UDS is set to 4800 baud, 8N1. 

I've run through all the UDS10 configuration options and can find nothing that seems to explain this problem.  I have some documentation written by Ben (IIRC) and see nothing out of the ordinary in the config screens.

Any suggestions? 
 		 	   		  
_________________________________________________________________
Bing brings you maps, menus, and reviews organized in one place.
http://www.bing.com/search?q=restaurants&form=MFESRP&publ=WLHMTAG&crea=TEXT_MFESRP_Local_MapsMenu_Resturants_1x1

---

From: ti99_forever <[email-masked]>
Date: Sat, 7 Nov 2009 06:25:16 -0800 (PST)

This is the point where I hit a dead-end with the UDS-10.Various searches for help on the Internet mainly resulted in answers I didn't like, about telnet connections not being "8-bit clean" or some such shit I didn't understand.
One of the issues I've had with the UDS-10 has to do with "flushing", meaning when packets are actually sent. It seems to buffer them, and I've played with the various parameters concerning send chars, and such, with some results outside of actual file transfers.

--- On Sat, 11/7/09, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: [TI994A] UDS10 file transfers
To: [email-masked]
Date: Saturday, November 7, 2009, 2:22 AM

  

      

Any suggestions? 
 		 	   		  
Bing brings you maps, menus, and reviews organized in one place. Try it now.

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 7 Nov 2009 12:24:03 -0600

Hmmm.  Maybe there is a character that needs to be "escaped" that when sent alone is used as a control?  All I know is I was ready to pull out my hair. A second set of instructions came from this site which appears to be offline :  http://www.ti-994a.com/bbs/viewtopic.php?t=31   and the important text read as follows "As soon as I did that the connection was established. I started seeing the MagicFM screens on both my TI and my PC. I was able to transfer files back and forth via XModem."

Perplexing.

To: [email-masked]
From: [email-masked]
Date: Sat, 7 Nov 2009 06:25:16 -0800
Subject: Re: [TI994A] UDS10 file transfers

This is the point where I hit a dead-end with the UDS-10.
Various searches for help on the Internet mainly resulted in answers I didn't like, about telnet connections not being "8-bit clean" or some such shit I didn't understand.

  

 
 
Any suggestions?

---

From: "Tursi" <[email-masked]>
Date: Sat, 7 Nov 2009 13:51:51 -0500

>Hmmm.  Maybe there is a character that needs to be "escaped" that when 
>sent alone is used as a control?  All I know is I >was ready to pull 
>out my hair. A second set of instructions came from this site which 
>appears to be offline :  http://www.ti->994a.com/bbs/viewtopic.php?t=31 
>and the important text read as follows "As soon as I did that the 
>connection was >established. I started seeing the MagicFM screens on 
>both my TI and my PC. I was able to transfer files back and forth via 
> >XModem."

In telnet, there is one character that needs to be escaped to be 8-bit 
clean, CHR$(255). (Escape it by sending two in a row).

If you send files that don't have any 255 characters, like text files, 
keep it under 255 blocks, and no checksums add up to 255, that should 
work over XModem, so that might explain the above statement?

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 7 Nov 2009 13:27:56 -0600

> From: [email-masked]
> Date: Sat, 7 Nov 2009 13:51:51 -0500

I read your message and couldn't figure out why, if this was true, I could not send a file from PC to TI, since the packet escape should be transparent to the receiver.  I think I found the answer.  Hyperterminal appears to be sensitive to the port number.  All the instructions to date have used a port number greater than 4000.  I decided to configure my UDS10 to port 23, reconfigure HT to use the same port, and I was able to successfully transfer a file from PC to TI. 

So... after I get a few things done around the house, I'll do a few more in-depth tests and then modify Mass Transfer or PORT to escape character 255.  That shouldn't take more than a few lines of code.  

Ben, if you have your UDS10 set up, could you try a transfer from PC to TI using port 23?  

Tim

---

From: ti99_forever <[email-masked]>
Date: Sat, 7 Nov 2009 15:09:08 -0800 (PST)

I will try to try tomorrow...My setup was different  - I tried Windows first, then moved onto Fedora Core (back then), setup stty for telnet connections, then used the command-line versions of Xmodem.

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] UDS10 file transfers
To: [email-masked]
Date: Saturday, November 7, 2009, 2:27 PM

  

      

> From: yahoogroup@harmless lion.com
> >appears to be offline : http://www.ti->994a.com/bbs/ viewtopic. php?t=31 

Tim

Hotmail: Trusted email with Microsoft's powerful SPAM protection. Sign up now.

---

From: ti99_forever <[email-masked]>
Date: Sat, 7 Nov 2009 15:11:30 -0800 (PST)

BTW: Where'd you find the UDS-10 update? Do they still have support on the Lantronix site?I will definitely need to do an update at some point... it mainly has been used recently for transferring text to the Mac for inclusion in emails...

--- On Sat, 11/7/09, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: RE: [TI994A] UDS10 file transfers
To: [email-masked]
Date: Saturday, November 7, 2009, 6:09 PM

  

--- On Sat, 11/7/09, Insane Multitasker <insane_m@hotmail. com> wrote:

From: Insane Multitasker <insane_m@hotmail. com>
Subject: RE: [TI994A] UDS10 file transfers
To: ti994a@yahoogroups. com
Date: Saturday, November 7, 2009, 2:27 PM

    

 

> If you
 send files that don't have any 255 characters, like text files, 

Tim

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 7 Nov 2009 17:32:44 -0600

I found the ROM and update program on Lantronix site.  The only problem I've noticed is that when I reboot the device, it loses the port # assigned to the unit.  I thought I had bricked the device until I figured out what was happening.  I might revert to a previous firmware if I can find it. Be certain to look at the under-side of your UDS and determine the true model type. Their are multiple versions and synonyms for the device.  Very confusing at first glance.

I'm off to try modifying the terminal emulator to support Telnet ... wish me luck.

To: [email-masked]
From: [email-masked]
Date: Sat, 7 Nov 2009 15:11:30 -0800
Subject: RE: [TI994A] UDS10 file transfers

BTW: Where'd you find the UDS-10 update? Do they still have support on the Lantronix site?
I will definitely need to do an update at some point... it mainly has been used recently for transferring text to the Mac for inclusion in emails...

  

I will try to try tomorrow...
My setup was different  - I tried Windows first, then moved onto Fedora Core (back then), setup stty for telnet connections, then used the command-line versions of Xmodem.

  

 

Tim

 		 	   		  
_________________________________________________________________
Windows 7: Unclutter your desktop.
http://go.microsoft.com/?linkid=9690331&ocid=PID24727::T:WLMTAGL:ON:WL:en-US:WWL_WIN_evergreen:112009

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 7 Nov 2009 17:42:59 -0600

Just for grins and giggles I tried uploading a file with my UDS10 device.  Would you believe the upload worked?  In fact, the UDS is functioning in both directions!  No changes to the terminal emulator.

Could port 23 have been the key to success?  I look forward to your tests,Ben.  You might want to try them prior to upgrading the firmware.  I'll continue my testing here...  I might just get really ambitious and create a new modem cable for some BBS testing.  

To: [email-masked]
From: [email-masked]
Date: Sat, 7 Nov 2009 17:32:44 -0600
Subject: RE: [TI994A] UDS10 file transfers

  

  

 

Tim

Windows 7: Unclutter your desktop. Learn more.

---

From: ti99_forever <[email-masked]>
Date: Sat, 7 Nov 2009 15:50:40 -0800 (PST)

Yep, that'd really piss me off...

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] UDS10 file transfers
To: [email-masked]
Date: Saturday, November 7, 2009, 6:42 PM

  

      

To: ti994a@yahoogroups. com
From: insane_m@hotmail. com
Date: Sat, 7 Nov 2009 17:32:44 -0600
Subject: RE: [TI994A] UDS10 file transfers

To: TI994A@yahoogroups. com
From: ti99_forever@ yahoo.com
Date: Sat, 7 Nov 2009 15:11:30 -0800
Subject: RE: [TI994A] UDS10 file transfers

--- On Sat, 11/7/09, ti99_forever <ti99_forever@ yahoo.com> wrote:

  

  

 

Tim

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 8 Nov 2009 00:27:15 -0600

For what it is worth, I set up my BBS software on my Geneve and have been able to transfer files back and forth. Been a while since I've had the BBS running on this beast - looks like the hybrid XOP-based XB assembly works with the MDOS 6.70 RC2. Whew. 

Now, what I cannot recall and had trouble locating in the Yahoo archives is whether I used the UDS-10 device or the C64 BBS emulation program (for the PC) to connect my BBS to the internet.   I seem to recall it was the latter but like you, I could never get file transfers to work over telnet.  I also recall some oddball duplicate characters and debounce issues due to packet delay.  I need to figure out how to set up DTR and Carrier detect with the UDS-10 device and then, if I'm really lucky, I can set things up for another test run over the internet.  I had honestly given up on this device long ago...  Tim

To: [email-masked]
From: [email-masked]
Date: Sat, 7 Nov 2009 15:50:40 -0800
Subject: RE: [TI994A] UDS10 file transfers

  

 

  

  

 

Tim

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 8 Nov 2009 22:07:40 -0600

Ok folks... I'm temporarily placing my BBS online using the UDS10 device.  I didn't spend time editing menus, etc. as the idea was to try out the device and get a little feedback.

IP Address:  razorwire.servequake.com  (75.86.158.205)

Port: 23

Recommend using Hyperterminal for generic connectivity.

1. User #2, password "TELNET" is available if you want to bypass new user setup.

2. Give the downloads a try.  Most of the files are Geneve-specific but I'd still love a test ;)

3. Be sure to log out AND disconnect your session. There is no timeout and no auto-hangup. If you drop before logging out, the next person will start where you left off. 

4. Feel free to leave a message in the message base.  I'm interested in lag, delay, repeat chars, etc. 

5. If the BBS refuses connection, try again later. A refused connection is equivalent to a busy signal. Not sure how, if at all, I could make it more friendly.

6. Drop a note here with your results. I'll keep it online for a day or two.

Give it a whirl. 

Tim

To: [email-masked]
From: [email-masked]
Date: Sun, 8 Nov 2009 00:27:15 -0600
Subject: RE: [TI994A] UDS10 file transfers

  

 

  

  

 

Tim

---

From: Barry Boone <[email-masked]>
Date: Mon, 9 Nov 2009 00:33:36 -0500

Here was my initial problem and solution (for anyone who runs into this):

<I telnetted to the BBS, and was greeted as follows>

AT

Booting...The S&T Software BBS

Connected to... S&T BBS v02.10.04!

Name : <insert name>
Baud : 9600 v.32/v.42 bis MNP
Hours: 24 hours a day
SysOp: <insert name>

Enable IBM Graphics and/or COLOR ANSI if available.  This BBS supports Email,
SOFTmail, online games, multiple message and file areas, Xmodem CRC through
Ymodem-g, multiple MXT x/ymodem, and more!   Support for the TI and Geneve
computers is our specialty, but all are welcome!

Last caller was TELNET USER #2

[C]heck userlog [N]ewuser [G]oodbye [I]nfo  [L]ogon : L

<after this point it hangs, echos back everything I type, but nothing happens>

My solution, I had to tell my telnet client to "force character at a time mode" under the advanced options.

Once I did that everything worked fine.  My client is SecureCRT 6.5 beta 3

From: [email-masked] [mailto:[email-masked]] On Behalf Of Insane Multitasker
Sent: Sunday, November 08, 2009 10:08 PM
To: [email-masked]
Subject: [TI994A] BBS over Telnet - test

Give it a whirl.
Tim

&! nbsp;

> clean, CHR$(255). (Escape it by sending two in a row).>

Ben, if ! you have your UDS10 set up, could you try a transfer from PC to TI usi ng port 23?

Tim

________________________________
Hotmail: Trusted email with Microsoft's powerful SPAM protection. Sign up now.<http://clk.atdmt.com/GBL/go/177141664/direct/01/http:/clk.atdmt.com/GBL/go/177141664/direct/01/>

________________________________
Windows 7: Unclutter your desktop. Learn more.<http://go.microsoft.com/?linkid=9690331&ocid=PID24727::T:WLMTAGL:ON:WL:en-US:WWL_WIN_evergreen:112009>

________________________________
Hotmail: Trusted email with Microsoft's powerful SPAM protection. Sign up now.<http://clk.atdmt.com/GBL/go/177141664/direct/01/http:/clk.atdmt.com/GBL/go/177141664/direct/01/>

________________________________
Hotmail: Trusted email with Microsoft's powerful SPAM protection. Sign up now.<http://clk.atdmt.com/GBL/go/177141664/direct/01/http:/clk.atdmt.com/GBL/go/177141664/direct/01/>

________________________________
Windows 7: Unclutter your desktop. Learn more.<http://go.microsoft.com/?linkid=9690331&ocid=PID24727::T:WLMTAGL:ON:WL:en-US:WWL_WIN_evergreen:112009>

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 9 Nov 2009 09:32:22 -0600

Thank you, Barry!  It seems there is a sequence that can be sent to tell the Telnet terminal which mode to use.  I'll do some experimentation later this week, but now we know this setting is most important :)   

I'll have to check the logs later today to see if anyone was able to download a file. I was hoping I'd be able to connect to the BBS from work but it would seem port23 is blocked. Might have to get creative...

>My solution, I had to tell my telnet client to “force character at a time mode” under the >advanced options.

---

From: fdos <[email-masked]>
Date: Mon, 09 Nov 2009 09:13:14 -0700

Tim,

I'm not going to have time any time soon to participate in this 
activity, not to mention the state of my real systems at this moment 
(discussed in another thread on the other OLUG).

Bill S

Insane Multitasker wrote:
>  
> 
> For what it is worth, I set up my BBS software on my Geneve and have 
> been able to transfer files back and forth. Been a while since I've had 
> the BBS running on this beast - looks like the hybrid XOP-based XB 
> assembly works with the MDOS 6.70 RC2. Whew.
>  
> Now, what I cannot recall and had trouble locating in the Yahoo archives 
> is whether I used the UDS-10 device or the C64 BBS emulation program 
> (for the PC) to connect my BBS to the internet.   I seem to recall it 
> was the latter but like you, I could never get file transfers to work 
> over telnet.  I also recall some oddball duplicate characters and 
> debounce issues due to packet delay.  I need to figure out how to set up 
> DTR and Carrier detect with the UDS-10 device and then, if I'm really 
> lucky, I can set things up for another test run over the internet.  I 
> had honestly given up on this device long ago...  Tim
>  
> 
> ------------------------------------------------------------------------
> --- On *Sat, 11/7/09, Insane Multitasker /<[email-masked]>/* wrote:
> 
> 
>     Just for grins and giggles I tried uploading a file with my UDS10
>     device.  Would you believe the upload worked?  In fact, the UDS
>     is functioning in both directions!  No changes to the terminal emulator.
>      
>     Could port 23 have been the key to success?  I look forward to
>     your tests,Ben.  You might want to try them prior to upgrading the
>     firmware.  I'll continue my testing here...  I might just get really
>     ambitious and create a new modem cable for some BBS testing. 
>      
> 
>     ------------------------------------------------------------------------
>      I found the ROM and update program on Lantronix site.  The only
>     problem I've noticed is that when I reboot the device, it loses the
>     port # assigned to the unit.  I thought I had bricked the device
>     until I figured out what was happening.  I might revert to a
>     previous firmware if I can find it. Be certain to look at the
>     under-side of your UDS and determine the true model type. Their are
>     multiple versions and synonyms for the device.  Very confusing at
>     first glance.
>      
>     ------------------------------------------------------------------------
>     I will definitely need to do an update at some point... it mainly
>     has been used recently for transferring text to the Mac for
>     inclusion in emails...
> 
>     --- On *Sat, 11/7/09, ti99_forever /<ti99_forever@ yahoo.com>/* wrote:
> 
> 
>         My setup was different  - I tried Windows first, then moved onto
>         Fedora Core (back then), setup stty for telnet connections, then
>         used the command-line versions of Xmodem.
> 
>         --- On *Sat, 11/7/09, Insane Multitasker /<insane_m@hotmail.
>         com>/* wrote:
> 
> 
>             & gt;
>             I read your message and couldn't figure out why, if this was
>             true, I could not send a file from PC to TI, since the
>             packet escape should be transparent to the receiver.  I
>             think I found the answer.  Hyperterminal appears to be
>             sensitive to the port number.  All the instructions to date
>             have used a port number greater than 4000.  I decided to
>             configure my UDS10 to port 23, reconfigure HT to use the
>             same port, and I was able to successfully transfer a file
>             from PC to TI.
>              
>             So... after I get a few things done around the house, I'll
>             do a few more in-depth tests and then modify Mass Transfer
>             or PORT to escape character 255.  That shouldn't take more
>             than a few lines of code. 
>              
>             Ben, if you h ave your UDS10 set up, could you try a
>             transfer from PC to TI using port 23? 
>              
>             Tim
>              
> 
> 
>             ------------------------------------------------------------------------
>             <http://clk.atdmt.com/GBL/go/177141664/direct/01/http://clk.atdmt.com/GBL/go/177141664/direct/01/>
> 
> 
> 
> 
> 
> 
> 
> 
> 
>     ------------------------------------------------------------------------
>     <http://go.microsoft.com/?linkid=9690331&ocid=PID24727::T:WLMTAGL:ON:WL:en-US:WWL_WIN_evergreen:112009>
> 
> 
> 
>     ------------------------------------------------------------------------
>     Sign up now.
>     <http://clk.atdmt.com/GBL/go/177141664/direct/01/http://clk.atdmt.com/GBL/go/177141664/direct/01/>
> 
> 
> 
> 
> 
> 
> ------------------------------------------------------------------------
> Hotmail: Trusted email with Microsoft's powerful SPAM protection. Sign 
> up now. <http://clk.atdmt.com/GBL/go/177141664/direct/01/ 
> http://clk.atdmt.com/GBL/go/177141664/direct/01/ >
>

---

From: Marc Hull <[email-masked]>
Date: Mon, 9 Nov 2009 08:23:00 -0800 (PST)

Hey Tim...

Using Hyperterm I had no problem except the oddity of the domain name (razorwire.quakenet.com) not working while the 75.86.158.205 worked fine. Of course it could have been something I did or my browser at work (but I am certain the spelling was correct on HT while it may not be now.)

Is this a full time addition or a passing fancy ;-)

--- On Sun, 11/8/09, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: [TI994A] BBS over Telnet - test
To: [email-masked]
Date: Sunday, November 8, 2009, 10:07 PM

  

      

IP Address:  razorwire.servequak e.com  (75.86.158.205)

Port: 23

Give it a whirl. 

Tim

 

  

 

  

  

 
 
Ben, if you have your UDS10 set up, could you try a transfer from PC t!
 o TI usi
ng port 23?  
 
Tim

---

From: fdos <[email-masked]>
Date: Mon, 09 Nov 2009 10:10:52 -0700

Hmm.....  No time anyway.  You'll figure it out.

Bill S

Insane Multitasker wrote:
>  
> 
> Ok folks... I'm temporarily placing my BBS online using the UDS10 
> device.  I didn't spend time editing menus, etc. as the idea was to try 
> out the device and get a little feedback.
>  
> 3. Be sure to log out AND disconnect your session. There is no timeout 
> and no auto-hangup. If you drop before logging out, the next person will 
> start where you left off.
> 5. If the BBS refuses connection, try again later. A refused connection 
> is equivalent to a busy signal. Not sure how, if at all, I could make it 
> more friendly.
> &n bsp;
>              > clean, CHR$(255). (Escape it by sending two in a row).*>
>             Ben, if yo u have your UDS10 set up, could you try a
>             *
>             *Hotmail: Trusted email with Microsoft's powerful SPAM
>             protection. Sign up now.
>             *
> up now.

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 9 Nov 2009 11:48:37 -0600

We shall see.  Were you able to download any files?  ;)

To: [email-masked]
From: [email-masked]
Date: Mon, 9 Nov 2009 08:23:00 -0800
Subject: Re: [TI994A] BBS over Telnet - test

Hey Tim...

  

 

Give it a whirl. 
Tim

 

  

 

  

  

 
 
Ben, if you have your UDS10 set up, could you try a transfer from PC t! o TI usi ng port 23?  
 
Tim

---

From: "Tony Knerr" <[email-masked]>
Date: Mon, 09 Nov 2009 20:51:31 -0000

> Ok folks... I'm temporarily placing my BBS online using the UDS10 device.  I didn't spend time editing menus, etc. as the idea was to try out the device and get a little feedback.

Hi, Tim.

I tried it with the "fresh outta the box" Hyperterminal.
Everything went well logging in and such.
Haven't seen those screens for a few years. :)
I attempted to download PLOP using xmodem crc, which sent what looked like a Tifiles header to the screen and kept repeating it every few seconds. I assume I needed to do something on this end with Hyperterminal to get it to save as a file, but am unfamiliar with
the program, so I did a ctrl x to end the attempt.
But the bbs seemed to run as I remembered it.

Hope that helps,

Tony

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 9 Nov 2009 15:24:14 -0600

Cool.  IIRC, there is a Hyperterminal menu option for receiving files. Select a filename, XMODEM CRC, and see if it starts.  
 
> From: [email-masked]
> Date: Mon, 9 Nov 2009 20:51:31 +0000
> Subject: [TI994A] Re: BBS over Telnet - test
> 
> 
>

---

From: "Tony Knerr" <[email-masked]>
Date: Mon, 09 Nov 2009 21:32:00 -0000

> Cool.  IIRC, there is a Hyperterminal menu option for receiving files. Select a filename, XMODEM CRC, and see if it starts.  

Got it to work. The whopping 15.1k of PLOP made it to my hard drive
and the bbs exited the transfer elegantly.

Looks good, Tim.

Tony

---

From: "Tony Knerr" <[email-masked]>
Date: Mon, 09 Nov 2009 21:38:48 -0000

So what exactly is PLOP? A quick inspection shows it is an MDOS executable. But I'm not going to run it if it's going to count down from 10 and then smoke starts pouring out from my Geneve. ;)

Tony

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 9 Nov 2009 16:07:27 -0600

I think it is the first file of Directory Manager.  If I get things working with my new modem cable, I will put a folder of TI and Geneve files for testing.

Hey Richard, do you have a UDS-10????? I have an idea...  :)))))
 
> Date: Mon, 9 Nov 2009 21:38:48 +0000

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 9 Nov 2009 16:11:21 -0600

Hoooray!!!!!!!   You may have just made TI BBS history, Tony, as the first person to transfer a file from a TI BBS over the internet.   If not a first, it's still exciting!   
 
> Date: Mon, 9 Nov 2009 21:32:00 +0000

---

From: tursi <[email-masked]>
Date: Mon, 9 Nov 2009 14:23:19 -0800 (PST)

> Hoooray!!!!!!!   You may have just made TI BBS history, Tony, as the 
> first person to transfer a file from a TI BBS over the internet.   If 
> not a first, it's still exciting!   

Nope, not first, but still nice to see one current. :)

---

From: ti99_forever <[email-masked]>
Date: Tue, 10 Nov 2009 02:43:41 -0800 (PST)

I downloaded HELPTXT tonight, but I couldn't get an upload to work.
Seemed to fail in the negotiation phase. Using Hyperterm. Left you a message on the BBS itself.

Really nice seeing one up on the Internet again.

--- On Mon, 11/9/09, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Re: BBS over Telnet - test
To: [email-masked]
Date: Monday, November 9, 2009, 5:11 PM

  

      

Hoooray!!!!! !!   You may have just made TI BBS history, Tony, as the first person to transfer a file from a TI BBS over the internet.   If not a first, it's still exciting!   
 
> From: tonyknerr@comcast. net
> --- In TI994A@yahoogroups. com, Insane Multitasker <insane_m@...> wrote:
> >
> > 
 		 	   		  
Hotmail: Trusted email with powerful SPAM protection. Sign up now.

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 10 Nov 2009 20:12:43 -0600

Thanks, Ben, I saw the message in the log a few minutes ago :)  The transfers failed with a receive error.  This could be related to latency, port speed, or some other problem.  MAybe the UDS device is hammering the port with bursts of data and is assuming CTS/RTS is active?  Flow control is uni-directional (outbound) as I never finished the RS232 inbound flow control code.  Alas, activating the ring buffer under XB would be an ugly beast, especially where VDP memory is in short supply and interrupts require a bit of attention.   If I keep this up, it will be to aid in making a new version for Richard to run :)

To: [email-masked]
From: [email-masked]
Date: Tue, 10 Nov 2009 02:43:41 -0800
Subject: RE: [TI994A] Re: BBS over Telnet - test

---

From: ti99_forever <[email-masked]>
Date: Tue, 10 Nov 2009 18:31:54 -0800 (PST)

Yes, of course that is the ultimate goal. I had a good chat with Richard at the Faire, and that was one of the things we talked about...
Sounds like the inbound flow control may be the issue...

--- On Tue, 11/10/09, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Re: BBS over Telnet - test
To: [email-masked]
Date: Tuesday, November 10, 2009, 9:12 PM

  

      

--- On Mon, 11/9/09, Insane Multitasker <insane_m@hotmail. com> wrote:

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 10 Nov 2009 20:53:13 -0600

Any chance of connecting your UDS-10 to a TI to find out if you can use the BBS through Telnet from a TI?  :)-    I know, I'm a stinker for asking.  But maybe by asking you'll be able to find that soldering station.  <grin>

To: [email-masked]
From: [email-masked]
Date: Tue, 10 Nov 2009 18:31:54 -0800
Subject: RE: [TI994A] Re: BBS over Telnet - test

---

From: ti99_forever <[email-masked]>
Date: Wed, 11 Nov 2009 03:38:03 -0800 (PST)

I can't figure out how I lost a whole soldering station in the first place!I just need to want something more that I cannot find and then it will show up...

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Re: BBS over Telnet - test
To: [email-masked]
Date: Tuesday, November 10, 2009, 9:53 PM

  

      

--- On Tue, 11/10/09, Insane Multitasker <insane_m@hotmail. com> wrote:

---

From: "ti99_forever" <[email-masked]>
Date: Sat, 21 Nov 2009 18:56:23 -0000

Damn, I get my video cable fixed and NOW it looks like you've taken it down so I cannot test with my UDS-10!

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:
> From: insane_m@...
> From: ti99_forever@...
> --- On Sat, 11/7/09, Insane Multitasker <insane_m@...> wrote:
> 
> 
> From: Insane Multitasker <insane_m@...>

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 24 Nov 2009 20:45:35 -0600

It's offline while I am out of town.  I try not to spin my Geneve 24/7/365 anymore when I am away. ;)  I'll let you know when it is back online.  Maybe I can coax Owen into doing a video of it, too ;)-
 
> Date: Sat, 21 Nov 2009 18:56:23 +0000

---

From: Owen Brand <[email-masked]>
Date: Tue, 24 Nov 2009 22:00:13 -0500

I'd love to... Just give me what specs and features you want me to  
discuss and go over, and I'll do it.  Absolutely

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 24, 2009, at 9:45 PM, Insane Multitasker <[email-masked]>  
wrote:

> It's offline while I am out of town.  I try not to spin my Geneve  
> 24/7/365 anymore when I am away. ;)  I'll let you know when it is  
> back online.  Maybe I can coax Owen into doing a video of it, too ;)-
>
> > Damn, I get my video cable fixed and NOW it looks like you've  
> taken it down so I cannot test with my UDS-10!
> >
> >
> > > Ok folks... I'm temporarily placing my BBS online using the  
> UDS10 device. I didn't spend time editing menus, etc. as the idea  
> was to try out the device and get a little feedback.
> > >
> > >
> > >
> > > 3. Be sure to log out AND disconnect your session. There is no  
> timeout and no auto-hangup. If you drop before logging out, the next  
> person will start where you left off.
> > >
> > > 4. Feel free to leave a message in the message base. I'm  
> interested in lag, delay, repeat chars, etc.
> > >
> > > 5. If the BBS refuses connection, try again later. A refused  
> connection is equivalent to a busy signal. Not sure how, if at all,  
> I could make it more friendly.
> > >
> > > For what it is worth, I set up my BBS software on my Geneve and  
> have been able to transfer files back and forth. Been a while since  
> I've had the BBS running on this beast - looks like the hybrid XOP- 
> based XB assembly works with the MDOS 6.70 RC2. Whew.
> > >
> > > Now, what I cannot recall and had trouble locating in the Yahoo  
> archives is whether I used the UDS-10 device or the C64 BBS  
> emulation program (for the PC) to connect my BBS to the internet. I  
> seem to recall it was the latter but like you, I could never get  
> file transfers to work over telnet. I also recall some oddball  
> duplicate characters and debounce issues due to packet delay. I need  
> to figure out how to set up DTR and Carrier detect with the UDS-10  
> device and then, if I'm really lucky, I can set things up for  
> another test run over the internet. I had honestly given up on this  
> device long ago... Tim
> > >
> > >
> > >
> > > Just for grins and giggles I tried uploading a file with my  
> UDS10 device. Would you believe the upload worked? In fact, the UDS  
> until I figured out what was happening. I might revert to a previous  
> firmware if I can find it. Be certain to look at the under-side of  
> your UDS and determine the true model type. Their are multiple  
> versions and synonyms for the device. Very confusing at first glance.
> > >
> > > I will definitely need to do an update at some point... it  
> mainly has been used recently for transferring text to the Mac for  
> inclusion in emails...
> > >
> true, I could not send a file from PC to TI, since the packet escape  
> should be transparent to the receiver. I think I found the answer.  
> Hyperterminal appears to be sensitive to the port number. All the  
> instructions to date have used a port number greater than 4000. I  
> decided to configure my UDS10 to port 23, reconfigure HT to use the  
> same port, and I was able to successfully transfer a file from PC to  
> TI.
> > >
> > > So... after I get a few things done around the house, I'll do a  
> few more in-depth tests and then modify Mass Transfer or PORT to  
> escape character 255. That shouldn't take more than a few lines of  
> code.
> > >