Subject: I: Happy Thanksgiving / TI Workshop EPROM released

From: Jon Guidry <[email-masked]>
Date: Thu, 26 Nov 2009 07:21:26 -0600

Happy Thanksgiving to everyone.  I am thankful for all of you, your conversation, friendship, and support!

By permission of Edward Dohmann, I am releasing the EPROM version of TI Workshop and its related documentation.  Edward has graciously agreed that I can put this download on www.hexbus.com.  The only restrictions related to it are that you can't sell his program, and must freely distribute it.  You can burn it to an EPROM, use it in an emulator, whatever.  Please just give him credit if you do redistribute it.

The version available for download is the 74LS379 version, which works with the 64K cartridge board out of the box.  You will need a 27512 or 27C512 EPROM to burn it.

TI Workshop was released in 1986, and is the largest cartridge program ever released for the TI-99/4A.  It includes the following:

1) Full debugger based on SuperBug by Edgar Dohmann
2) A full memory manager (view, edit, and save memory)
3) A full program loader (load, load/run EA/3 and EA/5)
4) A full disk manager 
5) A sector editor
6) A full editor/assembler package

There are some limitations to the module, but Edgar seems OK with us modifying it if needed.  Some that I know of include:

1) Your RAMDisk might get wiped unless it's write protected when using the disk manager
2) You need to use this cart by itself (i.e. not in a Gram Kracker or Cartridge Expander)
3) The Disk Manager and other file operations can only do DSK1 to DSK9

Enjoy the program, and Happy Thanksgiving!

Jon

---

From: Owen Brand <[email-masked]>
Date: Thu, 26 Nov 2009 08:40:56 -0500

Thanks Jon, and happy thanksgiving to you and your family... Today I  
will be eating turkey and showing Alpiner and Parsec to my nieces and  
nephews---they have grown up in th world of Guitar Hero... They must  
be.....corrected.  :).

  By the way--- the 2010 Faire song has written itself without any  
help from me... Expect something VERY different this year.  Mark  
Wills--- if you can find time to be at the Faire in 2010, you will  
have to accompany me in the performance.  :).

And happy thanksgiving to all of you guys/gals.  I hope you all stuff  
yourselves ridiculous and consider what all we have to be thankful  
for...

I'm thankful for all my cohorts here on the list... For the gracious  
manner in which you all have helped me.  God bless you all on this day  
of feasting, family, and fun...

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 26, 2009, at 8:21 AM, Jon Guidry <[email-masked]> wrote:

> By permission of Edward Dohmann, I am releasing the EPROM version of  
> TI Workshop and its related documentation.  Edward has graciously  
> agreed that I can put this download on www.hexbus.com. The only  
> restrictions related to it are that you can't sell his program, and  
> must freely distribute it. You can burn it to an EPROM, use it in an  
> emulator, whatever. Please just give him credit if you do  
> redistribute it.
>
> The version available for download is the 74LS379 version, which  
> works with the 64K cartridge board out of the box. You will need a  
> 27512 or 27C512 EPROM to burn it.
>
> TI Workshop was released in 1986, and is the largest cartridge  
> program ever released for the TI-99/4A. It includes the following:
>
> There are some limitations to the module, but Edgar seems OK with us  
> modifying it if needed. Some that I know of include:
>

---

From: "Postle" <[email-masked]>
Date: Thu, 26 Nov 2009 14:28:33 -0000

Thank You Jon.  Thank you Mr. Edward Dohmann.  Thank You "ALL".  It appears the TI-99/4A Community has traveled a long way in the past year.

Happy Thanksgiving -  As any teacher can explain.  Our rewards are of giving from our hearts.

Enjoy the Day,

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: fdos <[email-masked]>
Date: Thu, 26 Nov 2009 08:45:25 -0700

Great news!

But what do we who only have 16K boards do?  Or are there more 64K 
boards in the works?

Us greedy "takers" want to know. :-)

Happy Thanksgiving.

Bill S

Jon Guidry wrote:
> By permission of Edward Dohmann, I am releasing the EPROM version of TI 
> Workshop and its related documentation. Edward has graciously agreed 
> that I can put this download on www.hexbus.com. The only restrictions 
> related to it are that you can't sell his program, and must freely 
> distribute it. You can burn it to an EPROM, use it in an emulator, 
> whatever. Please just give him credit if you do redistribute it.
> 
> The version available for download is the 74LS379 version, which works 
> with the 64K cartridge board out of the box. You will need a 27512 or 
> 27C512 EPROM to burn it.
> 
> TI Workshop was released in 1986, and is the largest cartridge program 
> ever released for the TI-99/4A. It includes the following:
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 26 Nov 2009 11:12:49 -0500

Hey Bill,
     You have any extra 16k boards you would be interested in  
selling?  I have a couple EPROMs I need boards for... And from what I  
understand--Jon can't keep them on the shelf.  :). On this day, I am  
also thankful for the great work Jon and Tursi put in to get those  
boards made for the community.  :). My 64k cart has Never-Lander  
installed in it now... I am currently thinking about disassembling one  
of my Home Budget Management carts to house the board... It's one of  
the later ones that doesn't have a screw or a spring-loaded gate  
covering the actual connector edge.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 26, 2009, at 10:45 AM, fdos <[email-masked]> wrote:

>> works
>> program
>> 1) Your RAMDisk might get wiped unless it's write protected when  
>> using
>> the disk manager
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: fdos <[email-masked]>
Date: Thu, 26 Nov 2009 09:44:21 -0700

Owen,

I'm sure I'll find a use for them as soon as I find time to assemble 
them.  I only have two.  The timing may be right for a 16K CartForth.  I 
always keep a spare of important stuff.

Bill S

Owen Brand wrote:
> On Nov 26, 2009, at 10:45 AM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  > Great news!
>  >

---

From: "hexbus" <[email-masked]>
Date: Thu, 26 Nov 2009 16:52:21 -0000

On Hexbus.com, I have a wiring diagram for a 16K board that was converted to a 64K one:

http://www.hexbus.com/TI-99_4A_Home_Computer_Page/Hardware_Projects.html#33

Yes, you can do it - but it involves soldering some wires and removing a trace between two pins on the EPROM.

Jon

---

From: fdos <[email-masked]>
Date: Thu, 26 Nov 2009 10:04:08 -0700

Thanks Jon,

I'm still able to do normal component soldering. I just can't handle SMT 
well enough.  So I convert one to 64K for TI Workshop and keep one at 
16K for CartForth, and just procure spare programmed EPROMS as backup.

Bill S

hexbus wrote:
> <http://www.hexbus.com/TI-99_4A_Home_Computer_Page/Hardware_Projects.html#33>
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, fdos 
> <fdosbrs@...> wrote:
>  >
>  > Great news!
>  >

---

From: Owen Brand <[email-masked]>
Date: Thu, 26 Nov 2009 12:43:41 -0500

Cool man... Love to see the cartforth, and I'm also pretty jazzed  
about Workshop!!!  Anyone have a link they can shoot me on Workshop  
and it's features?

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 26, 2009, at 11:44 AM, fdos <[email-masked]> wrote:

>>>> 2) You need to use this cart by itself (i.e. not in a Gram  
>>>> Kracker or
>>>> Cartridge Expander)

---

From: "hexbus" <[email-masked]>
Date: Thu, 26 Nov 2009 19:28:44 -0000

If you download the .zip file from Hexbus.com, there's a complete manual in PDF format along with the EPROM image.

Also, check the feedback section of this Micropendium for a letter from the author:
http://pdf.textfiles.com/zines/MICROPEDIUM/mp9510.max.pdf

Dr. Good does a review in this Micropendium:
http://pdf.textfiles.com/zines/MICROPEDIUM/mp9507.max.pdf

Jon

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Nov 26, 2009, at 11:44 AM, fdos <fdosbrs@...> wrote:
> 
> > Owen,
> >
> >> On Nov 26, 2009, at 10:45 AM, fdos <fdosbrs@...

---

From: "Postle" <[email-masked]>
Date: Thu, 26 Nov 2009 20:35:22 -0000

Bill,

Make purchase of a 64K Board, I would imagine.

Enjoy your Holiday,

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: fdos <[email-masked]>
Date: Fri, 27 Nov 2009 08:46:01 -0700

Thanks Jon,

I, for one, sure hope someone is able and willing to take on the task.

Bill S

hexbus wrote:
>  
> 
> If you download the .zip file from Hexbus.com, there's a complete manual 
> in PDF format along with the EPROM image.
> 
> <http://pdf.textfiles.com/zines/MICROPEDIUM/mp9510.max.pdf>
> 
> <http://pdf.textfiles.com/zines/MICROPEDIUM/mp9507.max.pdf>
> 
> Jon
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, Owen 
> Brand <owenbrand@...> wrote:
>  >