Subject: Beating the VDP question to death ;-)

From: "Marc H" <[email-masked]>
Date: Sat, 14 Nov 2009 21:22:44 -0000

At the risk of.....

I ran some practical tests today shoveling data into the VDP as quick as possible using the new(to me) methods discussed earlier.  The loop moved 8 bytes at a time (8 movb r1,*r13) and incremented a counter.

when 16384 bytes had been written they were then read back and verified.  I did this with numbers 0-255 and the results are....

Even with 16Bit CPU memory and a 14.3 crystal the VDP reads were perfect.  I ran this test 3 times and got the same results each time.

---

From: Brian Tristam Williams <[email-masked]>
Date: Sat, 14 Nov 2009 23:30:54 +0200

Sounds more like an answer than a question ;)

2009/11/14 Marc H <[email-masked]>

>
>
> At the risk of.....
>
> I ran some practical tests today shoveling data into the VDP as quick as
> possible using the new(to me) methods discussed earlier. The loop moved 8
> bytes at a time (8 movb r1,*r13) and incremented a counter.
>
> when 16384 bytes had been written they were then read back and verified. I
> did this with numbers 0-255 and the results are....
>
> Even with 16Bit CPU memory and a 14.3 crystal the VDP reads were perfect. I
> ran this test 3 times and got the same results each time.
>
>  
>

-- 
Brian Tristam Williams

"One man can make a difference."

---

From: Owen Brand <[email-masked]>
Date: Sat, 14 Nov 2009 16:35:35 -0500

I think this thread has really become more about the weaknesses of the  
9900 rather than the 9918...  What do you think?

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 14, 2009, at 4:30 PM, Brian Tristam Williams  
<[email-masked]> wrote:

> I ran some practical tests today shoveling data into the VDP as  
> quick as possible using the new(to me) methods discussed earlier.  
> The loop moved 8 bytes at a time (8 movb r1,*r13) and incremented a  
> counter.
>
> when 16384 bytes had been written they were then read back and  
> verified. I did this with numbers 0-255 and the results are....
>
> Even with 16Bit CPU memory and a 14.3 crystal the VDP reads were  
> perfect.  I ran this test 3 times and got the same results each time.
>
>
>
>
> -- 
> Brian Tristam Williams
>

---

From: Marc Hull <[email-masked]>
Date: Sat, 14 Nov 2009 14:03:17 -0800 (PST)

Well I don't think I would say that.  The processor while not as speedy at some tasks can outwork most processors of it's genre (it gets more done with it's instructions)......IMHO.  There is no moving data to and from accumulators or messing with index registers (It's been about 25 years since my last Z-80 experience so don't burn me down on the details...)  I think the biggest problem with the 9900 was the lack of programmers at the time (and now...)

--- On Sat, 11/14/09, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Beating the VDP question to death ;-)
To: "[email-masked]" <[email-masked]>
Date: Saturday, November 14, 2009, 3:35 PM

  

      I think this thread has really become more about the weaknesses of the 9900 rather than the 9918...  What do you think?

Owen Brand**Oprysoft**Opry99er.com
On Nov 14, 2009, at 4:30 PM, Brian Tristam Williams <briantw@briantw. com> wrote:

    

2009/11/14 Marc H <marc.hull@sbcglobal .net>

  

      At the risk of.....

    

  

-- 
Brian Tristam Williams