Subject: Mystery project finished... sort of....

From: "Marc H" <[email-masked]>
Date: Sun, 13 Dec 2009 04:01:08 -0000

I have finally finished (or gotten to a more finished point) with my first hardware project.  I have managed (with more than a passing bit of help from Mike, Stuart and others) to interface a Commodore SID chip to the TI through a homemade PEB card (tentatively named the "SID blaster 99" (I know it's a total rip off.)  Please see the low production standards video for a demonstration (I should have enlisted Owens' help with the camera work..)

http://www.youtube.com/watch?v=cxqvE3-d0jg...

It is working in all respects but there is one major issue that I really never thought about until now.  My ignorance as to how to properly massage this beast to get the most out of it.  It is a complicated sound synthesizer and although I understand the basics, I could use some help on several fronts....

1) If anybody understands in detail the principles of ADSR, and pulse rate I would sure listen.

2) Ditto for the functions of the pass filters and resonance features of the chip.

3) If anyone has knowledge of the file formats for any of the many SID players that have been developed over the years I would appreciate a tutorial.  This part is the most important as there are thousands (literally tens of thousands) of SID based songs that could be available to play on the TI with presumably little effort.

Thanks for looking and while I'm at it I really want to thank both Mike and Stuart for their patience and tutorials.  Two brilliant minds in our community!

---

From: ti99_forever <[email-masked]>
Date: Sat, 12 Dec 2009 20:29:55 -0800 (PST)

Brilliant! Only problem is most SID tunes make my ears bleed. Sure that is only a personal issue... and it isn't bias. They really do!

Which SID chip did you go with? The earlier one (starting with a "6") or the later one (starting with an "8")?

--- On Sat, 12/12/09, Marc H <[email-masked]> wrote:

> From: Marc H <[email-masked]>
> Subject: [TI994A] Mystery project finished... sort of....
> To: [email-masked]
> Date: Saturday, December 12, 2009, 11:01 PM
> I have finally finished (or gotten to
> a more finished point) with my first hardware project. 
> I have managed (with more than a passing bit of help from
> Mike, Stuart and others) to interface a Commodore SID chip
> to the TI through a homemade PEB card (tentatively named the
> "SID blaster 99" (I know it's a total rip off.)  Please
> see the low production standards video for a demonstration
> (I should have enlisted Owens' help with the camera work..)
> 
> It is working in all respects but there is one major issue
> that I really never thought about until now.  My
> ignorance as to how to properly massage this beast to get
> the most out of it.  It is a complicated sound
> synthesizer and although I understand the basics, I could
> use some help on several fronts....
> 
> 3) If anyone has knowledge of the file formats for any of
> the many SID players that have been developed over the years
> I would appreciate a tutorial.  This part is the most
> important as there are thousands (literally tens of
> thousands) of SID based songs that could be available to
> play on the TI with presumably little effort.
> 
> Thanks for looking and while I'm at it I really want to
> thank both Mike and Stuart for their patience and
> tutorials.  Two brilliant minds in our community!
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: Owen Brand <[email-masked]>
Date: Sun, 13 Dec 2009 00:09:26 -0500

Congratulations Marc!!!  I am thrilled at the possibilities this opens  
up.  I bought a Commodore 64 manual and have learned a bit about some  
of this stuff...  Although I cannot help on the hardware side---  
thanks for your work, brother.

Owen Brand
**Oprysoft**
Opry99er.com

On Dec 12, 2009, at 11:01 PM, "Marc H" <[email-masked]> wrote:

> I have finally finished (or gotten to a more finished point) with my  
> first hardware project. I have managed (with more than a passing bit  
> of help from Mike, Stuart and others) to interface a Commodore SID  
> chip to the TI through a homemade PEB card (tentatively named the  
> "SID blaster 99" (I know it's a total rip off.) Please see the low  
> production standards video for a demonstration (I should have  
> enlisted Owens' help with the camera work..)
>
> It is working in all respects but there is one major issue that I  
> really never thought about until now. My ignorance as to how to  
> properly massage this beast to get the most out of it. It is a  
> complicated sound synthesizer and although I understand the basics,  
> I could use some help on several fronts....
>
> 3) If anyone has knowledge of the file formats for any of the many  
> SID players that have been developed over the years I would  
> appreciate a tutorial. This part is the most important as there are  
> thousands (literally tens of thousands) of SID based songs that  
> could be available to play on the TI with presumably little effort.
>
> Thanks for looking and while I'm at it I really want to thank both  
> Mike and Stuart for their patience and tutorials. Two brilliant  
> minds in our community!
>
>

---

From: "Tursi" <[email-masked]>
Date: Sun, 13 Dec 2009 02:05:16 -0500

> 2) Ditto for the functions of the pass filters and resonance features of 

ADSR is pretty straight forward - it stands for Attack, Decay, Sustain, 
Release. Basically, these are four "stages" for the generation of a tone 
that the chip automatically deals with (and we can do the same on our chip 
in software.) For looking at how it works, you can ignore the names, and 
just call them 1, 2, 3, 4, since, like me, you are not an audio expert! The 
names are conventions for HOW the stages are usually used. It works 
something like this:

When you start playing a note, the initial volume is zero (because it hasn't 
started yet). The attack specifies how FAST the volume rises, and what level 
it rises TO. In other words, it starts the note.

As soon as the attack is complete, there is a DECAY period. It's basically 
the same idea - it specifies how fast the volume lowers, and to what level 
it lowers TO.

These two pieces give you your main instrument shape.

Sustain begins immediately after the decay ends -- this is where the volume 
of the note will stay for as long as the note is being played.

Release begins when the note is ended, and indicates how quickly the volume 
drops back off to zero.

Wikipedia should have pictures of waveforms.. and my own knowledge is so 
rudimentary it probably has a few errors, but that's the basic basics. Every 
other function of that chip I can't help at all with.

> 3) If anyone has knowledge of the file formats for any of the many SID 
> players that have been developed over the years I would appreciate a 
> tutorial.  This part is the most important as there are thousands 
> (literally tens of thousands) of SID based songs that could be available 
> to play on the TI with presumably little effort.
>

This is a HARD one. SID files are not file formats! They are actually 6502 
programs, and SID players are C64 emulators (that omit unneeded bits like 
video and IO) that run the program. (The NSF format for Nintendo files is 
the same deal.)

I only see two ways to convert SID files:

1) Attempt to convert (possibly mechanically) the 6502 code to 9900 code. 
This has a low probability of success, I believe. The C64 has access to high 
resolution timers and other hardware oddities that would be very hard to 
reproduce on the 4A. I'm told that the code in SID files tends to be pretty 
hairy. Timing may be an issue in some. Would be awesome to see someone try 
though!

2) Generate SID recordings, files consisting of timestamps and the register 
writes to the chip. This is analogous to the VGM file format (which supports 
our sound chip). All we'd have to do here is hack a SID player to write out 
the data, and play the file we were interested in. Upsides: very, very easy 
to play back, fairly easy to get the recording, too. Downsides: file sizes 
will grow quickly for some music, depends on the complexity. We don't 
benefit from looping and so on. But given the power of the SID, it's pretty 
likely that once the initial setup is done, the register writes will likely 
all be the note data, keeping the filesize reasonable. I could help with 
this, since I did the same thing for the NES music conversion. ;)

Have you thought about hitting some C64 groups and looking for a SID 
composer crazy enough to take on the TI directly? :)

---

From: R Halter <[email-masked]>
Date: Sun, 13 Dec 2009 08:54:32 -0600

> http://www.youtube.com/watch?v=cxqvE3-d0jg...

Wow!  So when does the "SID Blaster 99" hit the retail shelves?  Does it 
come bundled with a CD-ROM drive and some CD games?  ^_~

Seriously, though, that's a nice little card for the TI!  Is it capable 
of doing multiple "voices" (like the TI's 3 voices and 1 noise channel)?

-- 
  I want to die peacefully in my sleep like my grandfather... not 
screaming and yelling like the passengers in his car.

---

From: R Halter <[email-masked]>
Date: Sun, 13 Dec 2009 09:08:19 -0600

Oh, BTW...  I now have "Michael Row the Boat Ashore stuck in my head.  >_<

Thaaaaanks...

---

From: Marc Hull <[email-masked]>
Date: Sun, 13 Dec 2009 07:12:15 -0800 (PST)

I have 6581's  The others (8580's ?) should work but require a different voltage regulator. 

--- On Sat, 12/12/09, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Mystery project finished... sort of....
To: [email-masked]
Date: Saturday, December 12, 2009, 10:29 PM

  

--- On Sat, 12/12/09, Marc H <marc.hull@sbcglobal .net> wrote:

> From: Marc H <marc.hull@sbcglobal .net>

> To: TI994A@yahoogroups. com

> http://www.youtube. com/watch? v=cxqvE3- d0jg...

> 1) If anybody understands in detail the principles of ADSR,

> and pulse rate I would sure listen.

> 2) Ditto for the functions of the pass filters and

> resonance features of the chip.

> ------------ --------- --------- ------

>     TI994A-fullfeatured @yahoogroups. com

---

From: Marc Hull <[email-masked]>
Date: Sun, 13 Dec 2009 07:16:42 -0800 (PST)

--> Seriously, though, that's a nice little card for the TI!  Is it capable 

The SID has 3 voices that can be either 3 tone waves or a noise wave.  Each channel can have it's own specific tone quality such as ADSR and waveform.  Combined with the TI that yields 6 tone channels and 1 noise channel.  Sorry about the tune stuck in your noodle but you will have to blame the good people over at CBM (about 1983 or so...)  MRYBA is an example out of the manual......

--- On Sun, 12/13/09, R Halter <[email-masked]> wrote:

From: R Halter <[email-masked]>
Subject: Re: [TI994A] Mystery project finished... sort of....
To: [email-masked]
Date: Sunday, December 13, 2009, 8:54 AM

  

-- 

  I want to die peacefully in my sleep like my grandfather. .. not

---

From: R Halter <[email-masked]>
Date: Sun, 13 Dec 2009 09:42:47 -0600

Marc Hull wrote:
> The SID has 3 voices that can be either 3 tone waves or a noise wave.  
> Each channel can have it's own specific tone quality such as ADSR and 
> waveform.  Combined with the TI that yields 6 tone channels and 1 noise 
> channel.

So, you can access both at the same time?  You could make some *wicked* 
chords...  Not to mention sounds/BGM for video games...

 > Sorry about the tune stuck in your noodle but you will have to
 > blame the good people over at CBM (about 1983 or so...)  MRYBA is an
 > example out of the manual......

That's okay, I turned on Winamp, opened my Christmas music folder, and 
now I'm listening to "Christmas In the Stars" to get it out of my head.

Fake edit:  Winamp does some funny things sometimes; at the end of 
"Christmas In the Stars," R2-D2 beeps and burbles.  C-3PO says, "What is 
that?  That, my silly friend, is the sound of bells."  R2 beeps and 
twitters some more, and 3PO translates, incredulously, "What are bells?" 
  Then Winamp moves to the next randomly-selected track and Jon Bon Jovi 
starts singing, "Bells will be ringing/The glad, glad news..."  ^_^

---

From: Marc Hull <[email-masked]>
Date: Sun, 13 Dec 2009 07:43:27 -0800 (PST)

Sorry Mike, my post was deceptive on the file formats.  It's a little confusing but what I should have posted is file information for SID player files (.MUS) and I think there are a couple more file types.  These are indeed data files that could be converted to be used with a TI player.  I have just DL a zip package of 12,000+ of these files.  A player should be fairly easy to write in 9900.  The difficulty comes in understanding the format and converting data from PC form to TI (that's where you come in ;-)

--- On Sun, 12/13/09, Tursi <[email-masked]> wrote:

From: Tursi <[email-masked]>
Subject: Re: [TI994A] Mystery project finished... sort of....
To: [email-masked]
Date: Sunday, December 13, 2009, 1:05 AM

  

      > 1) If anybody understands in detail the principles of ADSR, and pulse rate 

> I would sure listen.

> 2) Ditto for the functions of the pass filters and resonance features of 

> the chip.

something like this:

it lowers TO.

drops back off to zero.

the same deal.)

though!

---

From: "Tursi" <[email-masked]>
Date: Sun, 13 Dec 2009 15:18:05 -0500

> Sorry Mike, my post was deceptive on the file formats.  It's a little 
> confusing but what I should have posted is file information for SID player 
> files (.MUS) and I think there are a couple more file types.  These are 
> indeed data files that could be converted to be used with a TI player.  I 
> have just DL a zip package of 12,000+ of these files.  A player should be 
> fairly easy to write in 9900.  The difficulty comes in understanding the 
> format and converting data from PC form to TI (that's where you come in 
> ;-)
>

I researched all this years ago... but I'm looking again.  :) First 
reference I found with anything useful is here: 
http://www.unusedino.de/ec64/technical/formats/sidplay.html

The archive you found, is that the Compute Gazette SID Collection? The only 
12,000 file pack I know of is the High Voltage collection, and I thought 
much of that was PSID?

PSID format is definitely an emulator format, and can not be converted 
trivially. This is the largest source (but like I said, we could make 
recordings of them...)

MUS and STR apparently do cover what you're looking for there. It's a format 
done by Compute! called SidPlayer. It looks simple enough:

----
  The overall file layout is as follows:
    The first two bytes contain the load address.
    The next two bytes contain the length of the data for Voice 1
    The next two bytes contain the length of the data for Voice 2
    The next two bytes contain the length of the data for Voice 3
    Then the data for Voice 1 follows immediately
    Then the data for Voice 2 follows immediately
    Then the data for Voice 3 follows immediately
    Then the text description of the music file (upto 5 lines)

  The data for each Voice consists of a stream of  two  byte  commands  and
should be terminated with a HALT code which is 01 4F.
----

STR apparently is a second track for stereo SID, so just MUS.

Looks like this would be the format to save PSID files into, hehe. ;) 
Finding information on the voice streams is a little harder. I'm a bit at a 
loss, short of digging through the source code to the players out there. 
Even that's a pain.. they mostly focus on PSID so just finding the MUS code 
is tricky. :) I've spent about 90 mins here and that's all I can do right 
now. :)

If you can't find docs.. most likely it's a frame based format. Might be 
worth just trying to write two bytes per frame per channel and see if it 
sounds right? :)

---

From: Marc Hull <[email-masked]>
Date: Sun, 13 Dec 2009 12:34:31 -0800 (PST)

<The archive you found, is that the Compute Gazette SID Collection?> ......

10-4.  Most of it (that I have looked through anyway) is in .mus.  And as I said earlier these are data files for use by Computes Sid Player.64.  I have verified this as I also happen to have a C64 with the Sid player and a few songs on floppy.   My understanding is that the SP.64 uses the raster for timing so that shouldn't be an issue.  The most daunting task at this point would be getting the data off the archive and onto a TI floppy in a format the TI could access.

From: Tursi <[email-masked]>
Subject: Re: [TI994A] Mystery project finished... sort of....
To: [email-masked]
Date: Sunday, December 13, 2009, 2:18 PM

  

http://www.unusedin o.de/ec64/ technical/ formats/sidplay. html

much of that was PSID?

recordings of them...)

----

----

now. :)

sounds right? :)

---

From: ti99_forever <[email-masked]>
Date: Sun, 13 Dec 2009 13:49:46 -0800 (PST)

I have always heard the 6581's were the better of the two (sound-wise, especially for those songs using digitized sound), although the 8580's are a later part.

--- On Sun, 12/13/09, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Mystery project finished... sort of....
To: [email-masked]
Date: Sunday, December 13, 2009, 10:12 AM

---

From: Marc Hull <[email-masked]>
Date: Sun, 13 Dec 2009 14:29:59 -0800 (PST)

Your correct Ben.  My research pointed to the fact that the 8580's were patched to reduce/eliminate the volume change "pop" among other things. This results in a very low volume Sample and eliminates a lot of "tricks" used in the earlier songs.

 BTW I believe what may be making your ears bleed (I assume you bleed silver and black...;-) is the Techno sound of the later SID music (SID synthesizers etc..)  There are tons of earlier C64 songs that are not as edgy (If I can use that term in 2009.)  From classical to 80's POP !  

--- On Sun, 12/13/09, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Mystery project finished... sort of....
To: [email-masked]
Date: Sunday, December 13, 2009, 3:49 PM

  

--- On Sun, 12/13/09, Marc Hull <marc.hull@sbcglobal .net> wrote:

From: Marc Hull <marc.hull@sbcglobal .net>
Subject: Re: [TI994A] Mystery project finished... sort of....
To: TI994A@yahoogroups. com
Date: Sunday, December 13, 2009, 10:12 AM

 

--- On Sat, 12/12/09, ti99_forever <ti99_forever@ yahoo.com> wrote:

From: ti99_forever <ti99_forever@ yahoo.com>
Subject: Re: [TI994A] Mystery project finished... sort of....
To: TI994A@yahoogroups. com
Date: Saturday, December 12, 2009, 10:29 PM