Subject: Weekend warrior Latch/LED question....

From: "Marc H" <[email-masked]>
Date: Sat, 07 Nov 2009 21:07:02 -0000

Is it acceptable/dangerous to run an LED directly off of the output of a 74ls273 latch?  It appears to work but I'd like some engineering (or practical) advise....

Thanks...Marc

---

From: "Matthew" <[email-masked]>
Date: Sat, 07 Nov 2009 22:16:43 -0000

> Is it acceptable/dangerous to run an LED directly off of the output of a 74ls273 latch?  It appears to work but I'd like some engineering (or practical) advise....

You should use a current limiting resistor to prevent damage to your LED.  A diode is a constant voltage device in that once you forward bias the diode, it will increase or decrease the current flow through it to keep its voltage drop constant.

If you have a datasheet for your LED, it will have the forward bias voltage (usually somewhere between 1.2VDC and 1.6VDC) and also the max current flow at the forward bias voltage (usually somewhere between 20ma and 100ma depending on the LED's brightness).  So, if you just stick 5VDC across your 1.5VDC LED, I=ER and the resistance of a forward biased LED is very low, so you see max current flow (which won't be good for your 273 either.)

To find the proper resistor to use with your LED, take the forward bias voltage of the LED, subtract that from Vcc (probably 5VDC) and use R=E/I.  The value for current (I) will be the max of the LED (again from the datasheet).

So, let's assume you have a 1.5VDC @ 20ma LED:

5VDC - 1.5VDC = 3.5VDC

3.5VDC / 20ma = 175 Ohms

You can use larger values, since resistors under 1K Ohm are usually a special order (although I seem to have a lot of small resistance value resistors...)  But generally, the larger the resistor's resistance, the dimmer your LED will be (depending on the LED's max current flow.)

I Hope this helps.  There are some good websites out there dedicated to LED electronics - they can be more complicated than they seem sometimes.

Matthew