Subject: Honeycomb screen parameters

From: Owen Brand <[email-masked]>
Date: Fri, 8 Jan 2010 20:46:25 -0500

I have been reading through my XB manual and have come across an idea  
for my game.  If someone has suggested this previously, just forgive  
my density from time to time.  My difficulty with setting up screen  
parameters is well documented, and I have done more than my fair share  
of gnashing if teeth over this... But I posted the following message  
to the atariage forum and I will re-post here...

Can I just set up a CALL LOCATE inside my loop to make sure the SPRITE  
is within parameters? For instance

300 CALL POSITION(#1,XPOS,YPOS)
310 IF XPOS<192 THEN GOSUB 1000
*
*
(rest of program)

1000 CALL LOCATE(#1,192,YPOS)

if I'm right, this will stop the SPRITE from going off the bottom of  
the screen, and let it maintain the Y position (dot column). If I also  
included a line and subprogram for the Y axis as well, this should  
work, yes?!? (excited... Think I may have figured out my problem)

Owen Brand
**Oprysoft**
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Fri, 8 Jan 2010 20:49:52 -0500

Sorry, I meant ::

IF XPOS>192.....

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 8, 2010, at 8:46 PM, Owen Brand <[email-masked]> wrote:

> I have been reading through my XB manual and have come across an  
> idea for my game.  If someone has suggested this previously, just  
> forgive my density from time to time.  My difficulty with setting up  
> screen parameters is well documented, and I have done more than my  
> fair share of gnashing if teeth over this... But I posted the  
> following message to the atariage forum and I will re-post here...
>
> Can I just set up a CALL LOCATE inside my loop to make sure the  
> SPRITE is within parameters? For instance
>
> the screen, and let it maintain the Y position (dot column). If I  
> also included a line and subprogram for the Y axis as well, this  
> should work, yes?!? (excited... Think I may have figured out my  
> problem)
>
> Owen Brand
> **Oprysoft**
> Opry99er.com

---

From: ti99_forever <[email-masked]>
Date: Fri, 8 Jan 2010 18:05:44 -0800 (PST)

If you are using LOCATE to move your sprites, you'd correct the variable before the LOCATE.If you are using MOTION, using LOCATE will just reposition it temporarily and then the sprite will keep moving out of bounds, unless you change its motion parameters.

--- On Fri, 1/8/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: [TI994A] Re: Honeycomb screen parameters
To: [email-masked]
Date: Friday, January 8, 2010, 8:49 PM

Sorry, I meant ::
IF XPOS>192.....

Owen Brand**Oprysoft**Opry99er.com
On Jan 8, 2010, at 8:46 PM, Owen Brand <[email-masked]> wrote:

I have been reading through my XB manual and have come across an idea for my game.  If someone has suggested this previously, just forgive my density from time to time.  My difficulty with setting up screen parameters is well documented, and I have done more than my fair share of gnashing if teeth over this... But I posted the following message to the atariage forum and I will re-post here...
Can I just set up a CALL LOCATE inside my loop to make sure the SPRITE is within parameters? For instance

300 CALL POSITION(#1,XPOS,YPOS)
310 IF XPOS<192 THEN GOSUB 1000**
(rest of program)
1000 CALL LOCATE(#1,192,YPOS)

if I'm right, this will stop the SPRITE from going off the bottom of the screen, and let it maintain the Y position (dot column). If I also included a line and subprogram for the Y axis as well, this should work, yes?!? (excited... Think I may have figured out my problem)

Owen Brand**Oprysoft**Opry99er.com