Subject: Re: [TI994A] who let me in?

From: ti99_forever <[email-masked]>
Date: Mon, 2 Nov 2009 01:59:20 -0800 (PST)

Except there are 4 groups...

Oops, maybe he isn't a member of the super-secret-TI-society...

--- On Mon, 11/2/09, kabldb <[email-masked]> wrote:

From: kabldb <[email-masked]>
Subject: Re: [TI994A] who let me in?
To: [email-masked]
Date: Monday, November 2, 2009, 4:52 AM

    
                  That's hilarious.

--- In TI994A@yahoogroups. com, swim4home@.. . wrote:

> Rolling on floor laughing.

> Nov 2, 2009 12:55:19 AM, TI994A@yahoogroups. com wrote:

> I'm a whore, and I'll be all over all 3 groups like an STD!

> "Me love you long time!"

---

From: mark wills <[email-masked]>
Date: Mon, 2 Nov 2009 02:03:27 -0800 (PST)

WHY WASNT I TOLD ;-)

I demand an explanation!

>
>From: ti99_forever <[email-masked]>
>Sent: Mon, 2 November, 2009 10:59:20
>>Oops, maybe he isn't a member of the super-secret- TI-society. ..
>
>>--- On Mon, 11/2/09, kabldb <kabldb@yahoo. dk> wrote:
>
>>From: kabldb <kabldb@yahoo. dk>
>>To: TI994A@yahoogroups. com

---

From: mark wills <[email-masked]>
Date: Mon, 2 Nov 2009 02:21:34 -0800 (PST)

Anyone have any good suggestions on the inner workings of TCP/IP? Books or web links, to understand the protocol, packets, theory, etc?

I was thinking the new 64K cartridges might make a good host for an IP stack, using some CPU ram (Or a block of ram in the cartridge) as buffer.

I know nothing about the low level protocol, however.

M

---

From: ti99_forever <[email-masked]>
Date: Mon, 2 Nov 2009 02:28:05 -0800 (PST)

Start with the RFC's. I'm taking Network I now, but it is mainly concerned with Round Trip Time, not big on the format or theory.

Also, Michael Zapf did a bit of work on such for the TI, implementing UDP protocol (TCP? Can't remember) over SLIP (serial line IP). He did not appear to use hardware flow-control, though it has been available for a few years, like in Jeff Brown's Term-80 or ZT4.

--- On Mon, 11/2/09, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: [TI994A] TCP/IP
To: [email-masked]
Date: Monday, November 2, 2009, 5:21 AM

    

M

---

From: Owen Brand <[email-masked]>
Date: Mon, 2 Nov 2009 08:28:06 -0500

If there is a super secret, ultra covert, skull and crossbones TI  
club, I'll do whatever I gotta do to get in...  I just wanna know the  
TI secret handshake!!

Owen Brand
**Oprysoft**
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Mon, 2 Nov 2009 05:31:08 -0800 (PST)

> I just wanna know the TI secret handshake!!

FCTN + QUIT 

:-)

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Mon, 2 November, 2009 14:28:06
>If there is a super secret, ultra covert, skull and crossbones TI club, I'll do whatever I gotta do to get in...  I just wanna know the TI secret handshake!!  
>
>Owen Brand
>**Oprysoft**
>Opry99er.com
>
>On Nov 2, 2009, at 5:03 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>
>>
>>  >> 
>>WHY WASNT I TOLD ;-)
>>
>>I demand an explanation!
>>
>>
>>
>>
>>>

---

From: "Tursi" <[email-masked]>
Date: Mon, 2 Nov 2009 10:57:46 -0500

Besidess the RFCs already mentioned, you can also look at uIP. uIP is 
small enough that it could run on a stock TI without any need for bank 
switching. Focus on the UDP code to begin with, as it's somewhat simpler 
than TCP (it's very simple, in fact).

http://www.sics.se/~adam/uip/index.php/Main_Page

The issue with TCP/IP stacks is not usually code space, but data space. 
(ie: RAM is more important than ROM in most implementations). But the 
problem on the TI is what it's going to talk to, we don't have a lot of 
hardware that it's any good for. Serial is the best most people have 
available, meaning you need to connect to a PC or remote server, and to 
do that, you'll also need to implement PPP or SLIP or a similar protocol 
to negotiate and carry the connection.

>Anyone have any good suggestions on the inner workings of TCP/IP? Books 
>or web links, to understand the protocol, >packets, theory, etc?

---

From: "Jon Vogel" <[email-masked]>
Date: Tue, 3 Nov 2009 21:07:57 -0600

From: "mark wills" <[email-masked]>

> Anyone have any good suggestions on the inner workings of TCP/IP? Books or 
> web links, to understand the protocol, packets, theory, etc?

"TCP/IP Lean" by Jeremy Bentham is a good book.  I used it to develop a 
TCP/IP stack on an 8051 micro.  IIR, I only implemented the UDP protocol, 
but the book explains the whole thing.

Regards,

Jon