Subject: The bank switched 128K Multicart

From: Jon Guidry <[email-masked]>
Date: Sat, 12 Dec 2009 09:23:47 -0600

http://www.facebook.com/photo.php?pid=2927226&l=f57916b909&id=571432449

A combination of TI Workshop (64K), DM2K (32K), Arcturus (32K), using the 74LS379 for bank switching, and two switches (TI Workshop on/off, and when TI Workshop is off, the other one is either DM2K or Arcturus).

Thanks to Tursi and Stuart for being a sounding board while I was working out my addressing issues to determine where to put the switches and such. :)

Jon

---

From: fdos <[email-masked]>
Date: Sat, 12 Dec 2009 09:19:54 -0700

Hi Jon,

Is it for sale?  If so, how much?

Bill S

Jon Guidry wrote:
> <http://www.facebook.com/photo.php?pid=2927226&l=f57916b909&id=571432449>
> 
> 
> A combination of TI Workshop (64K), DM2K (32K), Arcturus (32K), using 
> the 74LS379 for bank switching, and two switches (TI Workshop on/off, 
> and when TI Workshop is off, the other one is either DM2K or Arcturus).
> 
> Thanks to Tursi and Stuart for being a sounding board while I was 
> working out my addressing issues to determine where to put the switches 
> and such. :)
> 
> Jon
> 
> 
>

---

From: Owen Brand <[email-masked]>
Date: Sat, 12 Dec 2009 11:53:32 -0500

That's too cool....  Wish that were available in quantity

Owen Brand
**Oprysoft**
Opry99er.com

On Dec 12, 2009, at 10:23 AM, Jon Guidry <[email-masked]> wrote:

> A combination of TI Workshop (64K), DM2K (32K), Arcturus (32K),  
> using the 74LS379 for bank switching, and two switches (TI Workshop  
> on/off, and when TI Workshop is off, the other one is either DM2K or  
> Arcturus).
>
> working out my addressing issues to determine where to put the  
> switches and such. :)
>
> Jon
>
>
>

---

From: "hexbus" <[email-masked]>
Date: Sat, 12 Dec 2009 17:46:56 -0000

Nope, at this point, it's just a hack.  Anyone can do it with their 64K cart. :)

Jon

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Dec 12, 2009, at 10:23 AM, Jon Guidry <jon@...> wrote:
>

---

From: "hexbus" <[email-masked]>
Date: Sat, 12 Dec 2009 17:46:31 -0000

No, it's just a hacked 64K cart.  I simply added four new pins to support a 27C010 EPROM.

The 64K cart *can* actually support a pure 128K bank switched ROM.  You just have to add the aforementioned four extra EPROM pins as well as two wires (inv Q3 and D3 on the 74LS379) as well as jump some +5V to the 27C010 (pins #1, 31, and 32).  It's not pretty, but it works.

Or, you can do like I did in this picture - I simply 'segmented' the ROM into 64K and 32K segments, and let the 74LS379 do it's bank switching job within the segments (i.e. 64K is TI Workshop [banked 8K x 8], and is controlled by A16, and 32K/32K is Arcturus [8K x 4] and DM2K [8K x 4], and is controlled by flipping A16, and grounding or not grounding A15.)

Jon