Subject: Re: [TI994A] Re: Mattel keyboard

From: Marc Hull <[email-masked]>
Date: Fri, 8 Jan 2010 14:54:53 -0800 (PST)

go here...    http://www.btinternet.com/~pweighill/music/

open and unzip this...  CGSC_v116.7z

Dink around with the sid player (songs don't sound as good as they do on the real deal !!)

try transferring some of the song files to the TI and keep us apprised !!

--- On Fri, 1/8/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "[email-masked]" <[email-masked]>
Date: Friday, January 8, 2010, 3:56 PM

  

      I was thinking the same thing, but wasWilling to try other options.  I have a few ways to get files from PC to TI.
Owen Brand**Oprysoft**Opry99er.com
On Jan 8, 2010, at 4:49 PM, ti99_forever <ti99_forever@ yahoo.com> wrote:

    

      Hyperterm on the PC, MFM on the TI will work. If there is no TIFILES header, they are saved as Display/Fixed 128. Worked since the early 1980's with the first TI terminal programs that supported Xmodem...
--- On Fri, 1/8/10, Marc Hull <marc.hull@sbcglobal .net> wrote:

From: Marc Hull <marc.hull@sbcglobal .net>
Subject: Re: [TI994A] Re: Mattel keyboard
To: TI994A@yahoogroups. com
Date: Friday, January 8, 2010, 2:31 PM

 

Well I've been called a lot of things but men-tor ??? maybe men-tal....; -)

Tell ya what....  I'll EM you some files tonight and see if you can basically download them from your PeeCee to your TI.  I don't think MFM will work, You will have to use some sort of telenetting (I think.)  Maybe Greg can chime in.  He'll most likely know how to help.

--- On Fri, 1/8/10, Owen Brand <owenbrand@opry99er. com> wrote:

From: Owen Brand <owenbrand@opry99er. com>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "TI994A@yahoogroups .com"
 <TI994A@yahoogroups. com>
Date: Friday, January 8, 2010, 11:22 AM

    

      Hell Marc, all you gotta do is ask.  Anything you need, I would be happy to help.  You just let me know what you need done, and I would be stoked to do it. You've been so helpful to me in my learning--- I would have never been able to finish Lemonade Stand in time for the Faire last year were it not for your help and instruction.  There are but a couple people in my life who I consider to be mentors.  My father on life issues, Tony McElwain on guitar, and Marc ****ing Hull on the TI.  Thanks, and anything I can do, just let me know.  

Owen Brand**Oprysoft**Opry99er.com
On Jan 8, 2010, at 12:10 PM, Marc Hull <marc.hull@sbcglobal .net>
 wrote:

    

      See, I have managed to confuse everyone with my Boomhower talk ;-)

.MUS files are not programs nor do they contain any 6502 instructions so they should be directly portable to any system that has a SID.  Like in the C=64, the SID in the TI is memory mapped meaning that the different SID registers look like memory locations. They are not the same locations as in the C=64 but none the less same basic set up.  The player itself references these locations indirectly so the .MUS files should be usable with no other manipulation.  These compose the 8000 files I have mentioned and they are ones that will have to be downloaded (not translated)
 to the TI. 

The player is what needs to be ported to 9900 AL.  The reason I say ported is because if a player is written for the TI it needs to contain all the timing, nuances and mistakes
 contained in the original in order for the sound to be correct.  It's like listening to an emulator play SID music versus a SID playing SID music.  If the emulator is not perfect then a lot is lost in the translation.

Seems you are the man to talk to about file transfer Owen.  You interested?

--- On Fri, 1/8/10, Owen Brand <owenbrand@opry99er. com> wrote:

From: Owen Brand <owenbrand@opry99er. com>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "TI994A@yahoogroups .com" <TI994A@yahoogroups. com>
Date: Friday, January 8, 2010, 10:38 AM

    

      Marc,   I noticed in your YouTube video that you were able to translate the test program from the C64 manual (if I remember correctly). Based on what you learned from that conversion, is it possible to write a program that will translate C64 audio commands over to the TI?  By this I mean: can SID audio files (.MUS) be converted from their current form into TI form??  Or is this the whole point of this conversation and I missed it completely?  :) I can be Dr. Dense sometimes...

Owen Brand**Oprysoft**Opry99er.com
On Jan 8, 2010, at 11:32 AM, Marc Hull <marc.hull@sbcglobal .net> wrote:

    

      ---> in all the players I've looked at, the main focus was on playing the 

version with embedded code, which we can't do. Besdies, 6502 ported 

directly to 9900 asm will be very inefficient. I know both chips and would 

not be interested in that approach myself. (machine translation maybe, not 

by hand ;) ). The 6502 also has some concepts (like decimal mode) that the 

9900 has no analog for. Luckily it's unlikely to be used.

I think I have caused some confusion here by not specifying what I mean by SID player.  The player I am talking about (SID PLAYER.64 IE.. Compute!'s music system blah blah blah...) was one written for the C=64 in the eighties and runs on the C=64 itself.  The files it uses (.MUS files) are composed of freq's and "player commands"  interpreted by the player itself not  imbeded 6502 commands.  The origional author has confirmed that it is more or less a bunch of bit masking, shifting, counting and writing that is done using the raster interrupt for timing.  

I am definitely not talking about the programs written in 6502 that are analaguos to a TI-XB music program nor tunes ripped from games or other programs.  That would require reinventing the wheel each and every time.  Nor am I talking about music files in other formats (for now at least....)

.MUS files are similar to TI sound list files used
 by the console sound list processor just more complex because of the greater range and features of the SID chip.  Therefore once a player is properly built all the files in ..MUS format (about 8000 according to web info) should be available to play.  I do have this particular player on my C=64 (sorry TI loyalists... ) and about 20 music files so I can verify the voracity of my info (unless I'm mistaken ;-)

Sorry if I restated what you all ready knew....

--- On Fri, 1/8/10, tursi <[email-masked]> wrote:

From: tursi <[email-masked]>
Subject: Re:
 [TI994A] Re: Mattel keyboard
To: TI994A@yahoogroups. com
Date: Friday, January 8, 2010, 8:46 AM

    

      > The reason I was thinking that the player should be ported

> is to maintain compatibility with the existing files out

> there.  I do have some information on the file structure

in all the players I've looked at, the main focus was on playing the 

version with embedded code, which we can't do. Besdies, 6502 ported 

directly to 9900 asm will be very inefficient. I know both chips and would 

not be interested in that approach myself. (machine translation maybe, not 

by hand ;) ). The 6502 also has some concepts (like decimal mode) that the 

9900 has no analog for. Luckily it's unlikely to be used.

> but it is fairly cryptic (to me any way.)  I'll shoot the

> link your way (actually found out that I wasn't getting

> anything that was not posted all ready...)  Not being in

From what I saw it looked reletively straightforward, with the questions 

that were open solvable by quick experimentation, I think.

> the trade I find it very difficult to decipher what others

> have done in their programs,  especially in unknown

> languages. 

Nothing to do with the trade, nobody likes trying to fgure out someone 

else's code. You have to pay me to do it. ;)

> Perhaps someone with experience can fiddle with shooting

> these files from their PeeCee to the TI.  I am guessing it

> would have to involve Teleneting on the PC side and a TE on

> the TI side.  How do you do this and bypass the modem

> connection?

Owen and Bill, among others, have been talking about how they transfer 

files for months.. I think Owen posted some videos, go take a look at the 

archives. There's serial links (using Xmodem is simplest if you have an 

xmodem client - no telnet), there's PC99, now Windows compatible, there's 

Fred's serial card ROM replacement (whose name escapes me), there's the 

CF7 with TI99Dir.... and more.

> There is also a SID editor available in the link but I

> don't see that being a useful port as it does not take into

> consideration the 4 channels of sound available in the

> console as well as the three SID channels.  Maybe later eh

I would suggest that there are probably more powerful tools on the PC, 

having an editor on the TI might be more effort than it's worth, IMO.

---

From: Owen Brand <[email-masked]>
Date: Fri, 8 Jan 2010 18:02:20 -0500

Will do.  Is there any way to view the source on these files?  Or view  
the data?

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 8, 2010, at 5:54 PM, Marc Hull <[email-masked]> wrote:

> I was thinking the same thing, but was
> Willing to try other options.  I have a few ways to get files from  
> PC to TI.
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
>> Hyperterm on the PC, MFM on the TI will work. If there is no  
>> TIFILES header, they are saved as Display/Fixed 128. Worked since  
>> the early 1980's with the first TI terminal programs that supported  
>> Xmodem...
>>
>> Tell ya what....  I'll EM you some files tonight and see if you can  
>> basically download them from your PeeCee to your TI.  I don't think  
>> MFM will work, You will have to use some sort of telenetting (I  
>> think.)  Maybe Greg can chime in.  He'll most likely know how to  
>> help.
>>
>>
>>
>>
>> Hell Marc, all you gotta do is ask.  Anything you need, I would be  
>> happy to help.  You just let me know what you need done, and I  
>> would be stoked to do it. You've been so helpful to me in my  
>> learning--- I would have never been able to finish Lemonade Stand  
>> in time for the Faire last year were it not for your help and  
>> instruction.  There are but a couple people in my life who I  
>> consider to be mentors.  My father on life issues, Tony McElwain on  
>> guitar, and Marc ****ing Hull on the TI.  Thanks, and anything I  
>> can do, just let me know.
>>
>> Owen Brand
>> **Oprysoft**
>> Opry99er.com
>>
>>> .MUS files are not programs nor do they contain any 6502  
>>> instructions so they should be directly portable to any system  
>>> that has a SID.  Like in the C=64, the SID in the TI is memory  
>>> mapped meaning that the different SID registers look like memory  
>>> locations. They are not the same locations as in the C=64 but none  
>>> the less same basic set up.  The player itself references these  
>>> locations indirectly so the .MUS files should be usable with no  
>>> other manipulation.  These compose the 8000 files I have mentioned  
>>> and they are ones that will have to be downloaded (not translated)  
>>> to the TI.
>>>
>>> The player is what needs to be ported to 9900 AL.  The reason I  
>>> say ported is because if a player is written for the TI it needs  
>>> to contain all the timing, nuances and mistakes contained in the  
>>> original in order for the sound to be correct.  It's like  
>>> listening to an emulator play SID music versus a SID playing SID  
>>> music.  If the emulator is not perfect then a lot is lost in the  
>>> translation.
>>>
>>> Marc,
>>>    I noticed in your YouTube video that you were able to translate  
>>> the test program from the C64 manual (if I remember correctly).  
>>> Based on what you learned from that conversion, is it possible to  
>>> write a program that will translate C64 audio commands over to the  
>>> TI?  By this I mean: can SID audio files (.MUS) be converted from  
>>> their current form into TI form??  Or is this the whole point of  
>>> this conversation and I missed it completely?  :) I can be Dr.  
>>> Dense sometimes...
>>>
>>> Owen Brand
>>> **Oprysoft**
>>> Opry99er.com
>>>
>>>> I think I have caused some confusion here by not specifying what  
>>>> I mean by SID player.  The player I am talking about (SID PLAYER. 
>>>> 64 IE.. Compute!'s music system blah blah blah...) was one  
>>>> written for the C=64 in the eighties and runs on the C=64  
>>>> itself.  The files it uses (.MUS files) are composed of freq's  
>>>> and "player commands"  interpreted by the player itself not   
>>>> imbeded 6502 commands.  The origional author has confirmed that  
>>>> it is more or less a bunch of bit masking, shifting, counting and  
>>>> writing that is done using the raster interrupt for timing.
>>>>
>>>> I am definitely not talking about the programs written in 6502  
>>>> that are analaguos to a TI-XB music program nor tunes ripped from  
>>>> games or other programs.  That would require reinventing the  
>>>> wheel each and every time.  Nor am I talking about music files in  
>>>> other formats (for now at least....)
>>>>
>>>> .MUS files are similar to TI sound list files used by the console  
>>>> sound list processor just more complex because of the greater  
>>>> range and features of the SID chip.  Therefore once a player is  
>>>> properly built all the files in ..MUS format (about 8000  
>>>> according to web info) should be available to play.  I do have  
>>>> this particular player on my C=64 (sorry TI loyalists... ) and  
>>>> about 20 music files so I can verify the voracity of my info  
>>>> (unless I'm mistaken ;-)
>>>>

---

From: ti99_forever <[email-masked]>
Date: Fri, 8 Jan 2010 15:04:00 -0800 (PST)

How? It tells me I'm already signed into Yahoo! and asks me if I know that I can get an internet connected through BT Yahoo!
Looks like a signup page to me... like maybe I was redirected due to not being a member of the British empire... ;)

--- On Fri, 1/8/10, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: [email-masked]
Date: Friday, January 8, 2010, 5:54 PM

 

 

 

        

 

 

..MUS files are not programs nor do they contain any 6502 instructions so they should be directly portable to any system that has a SID.  Like in the C=64, the SID in the TI is memory mapped meaning that the different SID registers look like memory locations. They are not the same locations as in the C=64 but none the less same basic set up.  The player itself references these locations indirectly so the .MUS files should be usable with no other manipulation.  These compose the 8000 files I have mentioned and they are ones that will have to be downloaded (not translated)
 to the TI. 

 

 

..MUS files are similar to TI sound list files used
 by the console sound list processor just more complex because of the greater range and features of the SID chip.  Therefore once a player is properly built all the files in ..MUS format (about 8000 according to web info) should be available to play.  I do have this particular player on my C=64 (sorry TI loyalists.... ) and about 20 music files so I can verify the voracity of my info (unless I'm mistaken ;-)

---

From: fdos <[email-masked]>
Date: Fri, 08 Jan 2010 16:08:05 -0700

BT is the British Telecom which has not been a part of the British Post 
Office for a decade or two, so a private corporation.

Bill S

ti99_forever wrote:
>  
> 
> How? It tells me I'm already signed into Yahoo! and asks me if I know 
> that I can get an internet connected through BT Yahoo!
> 
> Looks like a signup page to me... like maybe I was redirected due to not 
> being a member of the British empire... ;)
> 
> --- On *Fri, 1/8/10, Marc Hull /<[email-masked]>/* wrote:
> 
> 
>     open and unzip this...  *CGSC_v116.7z
>     <http://www.btinternet.com/%7Epweighill/music/CGSC_v116.7z%3Cspan%20id=>
> 
>     *
>     --- On *Fri, 1/8/10, Owen Brand /<[email-masked]>/* wrote:
> 
> 
>         Willing to try other options.  I have a few ways to get files
>         from PC to TI.
> 
>         Owen Brand
>         **Oprysoft**
>         Opry99er.com <http://Opry99er.com>
> 
>>         TIFILES header, they are saved as Display/Fixed 128. Worked
>>         since the early 1980's with the first TI terminal programs
>>         that supported Xmodem...
>>
>>         --- On *Fri, 1/8/10, Marc Hull /<marc.hull@sbcglobal ..net>/*
>>         wrote:
>>
>>
>>             Tell ya what....  I'll EM you some files tonight and see
>>             if you can basically download them from your PeeCee to
>>             your TI.  I don't think MFM will work, You will have to
>>             use some sort of telenetting (I think.)  Maybe Greg can
>>             chime in.  He'll most likely know how to help.
>>
>>
>>
>>
>>             --- On *Fri, 1/8/10, Owen Brand /<owenbrand@opry99er.
>>             com>/* wrote:
>>
>>
>>                 Hell Marc, all you gotta do is ask.  Anything you
>>                 need, I would be happy to help.  You just let me know
>>                 what you need done, and I would be stoked to do it.
>>                 You've been so helpful to me in my learning--- I would
>>                 have never been able to finish Lemonade Stand in time
>>                 for the Faire last year were it not for your help and
>>                 instruction.  There are but a couple people in my life
>>                 who I consider to be mentors.  My father on life
>>                 issues, Tony McElwain on guitar, and Marc ****ing Hull
>>                 on the TI.  Thanks, and anything I can do, just let me
>>                 know.  
>>
>>                 Owen Brand
>>                 **Oprysoft**
>>                 <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>
>>                 On Jan 8, 2010, at 12:10 PM, Marc Hull
>>                 <marc.hull@sbcglobal .net> wrote:
>>
>>>                  
>>>
>>>                 .MUS files are not programs nor do they contain any
>>>                 6502 instructions so they should be directly portable
>>>                 to any system that has a SID.  Like in the C=64, the
>>>                 SID in the TI is memory mapped meaning that the
>>>                 different SID registers look like memory locations.
>>>                 They are not the same locations as in the C=64 but
>>>                 none the less same basic set up.  The player itself
>>>                 references these locations indirectly so the .MUS
>>>                 files should be usable with no other manipulation. 
>>>                 These compose the 8000 files I have mentioned and
>>>                 they are ones that will have to be downloaded (not
>>>                 translated) to the TI.
>>>
>>>                 The player is what needs to be ported to 9900 AL. 
>>>                 The reason I say ported is because if a player is
>>>                 written for the TI it needs to contain all the
>>>                 timing, nuances and mistakes contained in the
>>>                 original in order for the sound to be correct.  It's
>>>                 like listening to an emulator play SID music versus a
>>>                 SID playing SID music.  If the emulator is not
>>>                 perfect then a lot is lost in the translation.
>>>
>>>                 --- On *Fri, 1/8/10, Owen Brand /<owenbrand@opry99er.
>>>                 com>/* wrote:
>>>
>>>
>>>                        I noticed in your YouTube video that you were
>>>                     able to translate the test program from the C64
>>>                     manual (if I remember correctly). Based on what
>>>                     you learned from that conversion, is it possible
>>>                     to write a program that will translate C64 audio
>>>                     commands over to the TI?  By this I mean: can SID
>>>                     audio files (.MUS) be converted from their
>>>                     current form into TI form??  Or is this the whole
>>>                     point of this conversation and I missed it
>>>                     completely?  :) I can be Dr. Dense sometimes...
>>>
>>>                     Owen Brand
>>>                     **Oprysoft**
>>>                     <http://Opry99er.com>
>>>                     <http://Opry99er.com>Opry99er.com
>>>                     <http://Opry99er.com>
>>>
>>>>                     I think I have caused some confusion here by not
>>>>                     specifying what I mean by SID player.  The
>>>>                     player I am talking about (SID PLAYER.64 IE..
>>>>                     Compute!'s music system blah blah blah....) was
>>>>                     one written for the C=64 in the eighties and
>>>>                     runs on the C=64 itself.  The files it uses
>>>>                     (.MUS files) are composed of freq's and "player
>>>>                     commands"  interpreted by the player itself not 
>>>>                     imbeded 6502 commands.  The origional author has
>>>>                     confirmed that it is more or less a bunch of bit
>>>>                     masking, shifting, counting and writing that is
>>>>                     done using the raster interrupt for timing. 
>>>>
>>>>                     I am definitely not talking about the programs
>>>>                     written in 6502 that are analaguos to a TI-XB
>>>>                     music program nor tunes ripped from games or
>>>>                     other programs.  That would require reinventing
>>>>                     the wheel each and every time.  Nor am I talking
>>>>                     about music files in other formats (for now at
>>>>                     least....)
>>>>
>>>>                     .MUS files are similar to TI sound list files
>>>>                     used by the console sound list processor just
>>>>                     more complex because of the greater range and
>>>>                     features of the SID chip.  Therefore once a
>>>>                     player is properly built all the files in ..MUS
>>>>                     format (about 8000 according to web info) should
>>>>                     be available to play.  I do have this particular
>>>>                     player on my C=64 (sorry TI loyalists... ) and
>>>>                     about 20 music files so I can verify the
>>>>                     voracity of my info (unless I'm mistaken ;-)
>>>>
>>>>                     --- On *Fri, 1/8/10, tursi /<yahoogroup@harmless
>>>>                     <http://lion.com> <http://lion.com>lion.com
>>>>                     <http://lion.com>>/* wrote:
>>>>
>>>>
>>>>                         From: tursi <yahoogroup@harmless
>>>>                         <http://lion.com>< /a>
>>>>                         <http://lion.com>lion.com <http://lion.com>>

---

From: Marc Hull <[email-masked]>
Date: Fri, 8 Jan 2010 15:34:47 -0800 (PST)

http://www.btinternet.com/~pweighill/music/CGSC_v116.7z   

Ty this..........

--- On Fri, 1/8/10, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: [email-masked]
Date: Friday, January 8, 2010, 5:04 PM

  

        

go here...    http://www.btintern et.com/~pweighil l/music/

From: Owen Brand <owenbrand@opry99er. com>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "TI994A@yahoogroups .com" <TI994A@yahoogroups. com>
Date: Friday, January 8, 2010, 3:56
 PM

    

 

      Hyperterm on the PC, MFM on the TI will work. If there is no TIFILES header, they are saved as Display/Fixed 128. Worked since the early 1980's with the first TI terminal programs that supported Xmodem...
--- On Fri, 1/8/10, Marc Hull <marc.hull@sbcglobal ..net> wrote:

        

 

 

 

 

I think I have caused some confusion here by not specifying what I mean by SID player.  The player I am talking about (SID PLAYER.64 IE.. Compute!'s music system blah blah blah....) was one written for the C=64 in the eighties and runs on the C=64 itself.  The files it uses (.MUS files) are composed of freq's and "player commands"  interpreted by the player itself not  imbeded 6502 commands.  The origional author has confirmed that it is more or less a bunch of bit masking, shifting, counting and writing that is done using the raster interrupt for timing.

---

From: Owen Brand <[email-masked]>
Date: Fri, 8 Jan 2010 18:45:28 -0500

If I can get a look at the actual code, I might be able to do  
something as simple as a copy and paste to notepad and use TI99Dir to  
convert it to DV80 or DF128...

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 8, 2010, at 6:34 PM, Marc Hull <[email-masked]> wrote:

> How? It tells me I'm already signed into Yahoo! and asks me if I  
> know that I can get an internet connected through BT Yahoo!
>
> Looks like a signup page to me... like maybe I was redirected due to  
> not being a member of the British empire... ;)
>
>>>> 64 IE.. Compute!'s music system blah blah blah....) was one

---

From: Marc Hull <[email-masked]>
Date: Fri, 8 Jan 2010 15:57:03 -0800 (PST)

Fuuuuuuuuu*74656ck !!!
try this !!!

http://www.btinternet.com/~pweighill/music/

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: [email-masked]
Date: Friday, January 8, 2010, 5:34 PM

  

      http://www.btintern et.com/~pweighil l/music/CGSC_ v116.7z   

Ty this........ ..

--- On Fri, 1/8/10, ti99_forever <ti99_forever@ yahoo.com> wrote:

From: ti99_forever <ti99_forever@ yahoo.com>
Subject: Re: [TI994A] Re: Mattel keyboard
To: TI994A@yahoogroups. com
Date: Friday, January 8, 2010, 5:04 PM

    

        

From: Owen Brand <owenbrand@opry99er.
 com>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "TI994A@yahoogroups .com" <TI994A@yahoogroups. com>
Date: Friday, January 8, 2010, 3:56
 PM

---

From: mark wills <[email-masked]>
Date: Sat, 9 Jan 2010 02:53:14 -0800 (PST)

Yeah, but the bit about the British Empire was actually correct ;-)

If you're IP address doesn't originate from an Emprical state, you're out! ;-)

GOD SAVE THE QUEEN!

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Fri, 8 January, 2010 23:08:05
> > --- On *Fri, 1/8/10, Marc Hull //* wrote:
> > 
> > 
> >    From: Marc Hull 
> >    --- On *Fri, 1/8/10, Owen Brand //* wrote:
> > 
> > 
> >        From: Owen Brand 
> >        To: "[email-masked]" 
> >        On Jan 8, 2010, at 4:49 PM, ti99_forever > >        yahoo.com> wrote:
> > 
> >>          
> >>
> >>        --- On *Fri, 1/8/10, Marc Hull //*
> >>        wrote:
> >>
> >>
> >>            From: Marc Hull 
> >>            --- On *Fri, 1/8/10, Owen Brand /> >>            com>/* wrote:
> >>
> >>
> >>                From: Owen Brand 
> >>>                --- On *Fri, 1/8/10, Owen Brand /> >>>                com>/* wrote:
> >>>
> >>>
> >>>                    From: Owen Brand 
> >>>                    On Jan 8, 2010, at 11:32 AM, Marc Hull
> >>>                    wrote:
> >>>
> >>>>                      
> >>>>
> >>>>                    --- On *Fri, 1/8/10, tursi /> >>>>                    lion.com
> >>>>                    >/* wrote:
> >>>>
> >>>>
> >>>>                        From: tursi > >>>>                        < /a>
> >>>>                        lion.com >
> >>>>                        > The reason I was thinking that the player
> >>>>                        should be ported
> >>>>                        > is to maintain compatibility with the
> >>>>                        existing files out
> >>>>                        > there.  I do have some information on the
> >>>>                        file structure
> >>>>
> >>>>                        > but it is fairly cryptic (to me any way.) 
> >>>>                        I'll shoot the
> >>>>                        > link your way (actually found out that I
> >>>>                        wasn't getting
> >>>>                        > anything that was not posted all
> >>>>                        ready...)  Not being in
> >>>>
> >>>>                        >From what I saw it looked reletively
> >>>>                        straightforward, with the questions
> >>>>                        > the trade I find it very difficult to
> >>>>                        decipher what others
> >>>>                        > have done in their programs,  especially
> >>>>                        in unknown
> >>>>                        > languages. 
> >>>>
> >>>>                        > Perhaps someone with experience can fiddle
> >>>>                        with shooting
> >>>>                        > these files from their PeeCee to the TI. 
> >>>>                        I am guessing it
> >>>>                        > would have to involve Teleneting on the PC
> >>>>                        side and a TE on
> >>>>                        > the TI side.  How do you do this and
> >>>>                        bypass the modem
> >>>>                        > connection?
> >>>>
> >>>>                        > There is also a SID editor available in
> >>>>                        the link but I
> >>>>                        > don't see that being a useful port as it
> >>>>                        does not take into
> >>>>                        > consideration the 4 channels of sound
> >>>>                        available in the
> >>>>                        > console as well as the three SID
> >>>>                        channels.  Maybe later eh
> >>>>
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: fdos <[email-masked]>
Date: Sat, 09 Jan 2010 08:05:58 -0700

Wow!  A little bit uppity, aren't we (rhetorical)? :-)

mark wills wrote:
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > >    To: [email-masked] <mailto:TI994A%40yahoogroups.com>
> <http://www.btinternet.com/~pweighill/music/>
>  > >
>  > >        To: "[email-masked] <mailto:TI994A%40yahoogroups.com>"
>  > >>>>                    >/* wrote:
>  > >>>>                        From: tursi > >>>>                        
> < /a>

---

From: mark wills <[email-masked]>
Date: Sat, 9 Jan 2010 07:19:59 -0800 (PST)

Ha ha! :-)

----- Original Message ----
> Sent: Sat, 9 January, 2010 15:05:58
> >  > From: fdos >
> >  > >        To: "[email-masked] "

---

From: Owen Brand <[email-masked]>
Date: Sat, 9 Jan 2010 10:28:06 -0500

You guys gave us the Beatles, Pink Floyd, and crumpets... You have the  
right to be uppity.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 9, 2010, at 10:19 AM, mark wills <[email-masked]>  
wrote:

> > > If you're IP address doesn't originate from an Emprical state,  
> you're
> > > out! ;-)
> > >
> > > GOD SAVE THE QUEEN!
> > >
> > > > > Looks like a signup page to me... like maybe I was  
> redirected due
> > > to not
> > > > > Dink around with the sid player (songs don't sound as good  
> as they
> > > > > do on the real deal !!)
> > > > >

---

From: fdos <[email-masked]>
Date: Sat, 09 Jan 2010 08:53:59 -0700

I should be a honorary member of the "uppity society" as I visited 
England 13 times in 1983.  Much fewer in earlier and later years as the 
company I worked for at that time was working out a manufacturing 
license with Plessey PLC, so most of my time was spent in Liverpool. 
Later I assisted Plessey market the licensed product in South Africa.

Bill S

mark wills wrote:
>  > > > > To: "[email-masked] <mailto:TI994A%40yahoogroups.com> "

---

From: mark wills <[email-masked]>
Date: Sat, 9 Jan 2010 11:33:27 -0800 (PST)

And Margaret Thatcher :-)

>Sent: Sat, 9 January, 2010 15:28:06
>You guys gave us the Beatles, Pink Floyd, and crumpets... You have the right to be uppity.  :)
>
>Owen Brand 
>**Oprysoft**
>Opry99er.com
>
>On Jan 9, 2010, at 10:19 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>  
>>Ha ha! :-)
>>
>>> From: fdos <fdosbrs@frontiernet .net>
>>> Wow! A little bit uppity, aren't we (rhetorical) ? :-)
>>> 
>>> mark wills wrote:
>>> > 
>>> > 
>>> > > > To: "TI994A@yahoogroups. com "
>>> > > ------------ --------- --------- ------
>>> > >
>>> > > Yahoo! Groups Links
>>> > >
>>> > >
>>> > >
>>> > 
>>> > 
>>> 
>>> 
>>> ------------ --------- --------- ------
>>> 
>>> Yahoo! Groups Links
>>> 
>>> 
>>> 
>>
>

---

From: mark wills <[email-masked]>
Date: Sat, 9 Jan 2010 11:35:43 -0800 (PST)

How times have changed. I fear visiting our country 13 times in one year in this day and age will get you on some sort of watch-list.

:-(

----- Original Message ----
> Sent: Sat, 9 January, 2010 15:53:59
> >  > From: fdos >
> >  > To: [email-masked] 
> >  > Sent: Sat, 9 January, 2010 15:05:58
> >  > Subject: Re: [TI994A] Re: Mattel keyboard
> >  >
> >  > Wow! A little bit uppity, aren't we (rhetorical)? :-)
> >  >
> >  > mark wills wrote:
> >  > >
> >  > >
> >  > > Yeah, but the bit about the British Empire was actually correct ;-)
> >  > >
> >  > > If you're IP address doesn't originate from an Emprical state, you're
> >  > > out! ;-)
> >  > >
> >  > > GOD SAVE THE QUEEN!
> >  > >
> >  > > ----- Original Message ----
> >  > > > From: fdos >
> >  > > > To: [email-masked] 
> >  > > > Sent: Fri, 8 January, 2010 23:08:05
> >  > > > Subject: Re: [TI994A] Re: Mattel keyboard
> >  > > >
> >  > > > BT is the British Telecom which has not been a part of the 
> > British Post
> >  > > > Office for a decade or two, so a private corporation.
> >  > > >
> >  > > > Bill S
> >  > > >
> >  > > > ti99_forever wrote:
> >  > > > >
> >  > > > >
> >  > > > > How? It tells me I'm already signed into Yahoo! and asks me if 
> > I know
> >  > > > > that I can get an internet connected through BT Yahoo!
> >  > > > >
> >  > > > > Looks like a signup page to me... like maybe I was redirected due
> >  > > to not
> >  > > > > being a member of the British empire... ;)
> >  > > > >
> >  > > > > --- On *Fri, 1/8/10, Marc Hull //* wrote:
> >  > > > >
> >  > > > >
> >  > > > > From: Marc Hull
> >  > > > > Subject: Re: [TI994A] Re: Mattel keyboard
> >  > > > > To: [email-masked] 
> >  > > > > Date: Friday, January 8, 2010, 5:54 PM
> >  > > > >
> >  > > > >
> >  > > > >
> >  > > > > go here... http://www.btinternet.com/~pweighill/music/ 
> > 
> >  > >
> >  > > > >
> >  > > > > open and unzip this... *CGSC_v116.7z
> >  > > > >
> >  > > > >
> >  > > > > Dink around with the sid player (songs don't sound as good as they
> >  > > > > do on the real deal !!)
> >  > > > >
> >  > > > > try transferring some of the song files to the TI and keep us
> >  > > > > apprised !!
> >  > > > > *
> >  > > > >
> >  > > > >
> >  > > > >
> >  > > > >
> >  > > > > --- On *Fri, 1/8/10, Owen Brand //* wrote:
> >  > > > >
> >  > > > >
> >  > > > > From: Owen Brand
> >  > > > > Subject: Re: [TI994A] Re: Mattel keyboard
> >  > > > > To: "[email-masked] "
> >  > > > > Date: Friday, January 8, 2010, 3:56 PM
> >  > > > >
> >  > > > >
> >  > > > >
> >  > > > > I was thinking the same thing, but was
> >  > > > > Willing to try other options. I have a few ways to get files
> >  > > > > from PC to TI.
> >  > > > >
> >  > > > > Owen Brand
> >  > > > > **Oprysoft**
> >  > > > > Opry99er.com
> >  > > > >
> >  > > > > On Jan 8, 2010, at 4:49 PM, ti99_forever > >
> >  > > yahoo.com> wrote:
> >  > > > >
> >  > > > >>
> >  > > > >>
> >  > > > >> Hyperterm on the PC, MFM on the TI will work. If there is no
> >  > > > >> TIFILES header, they are saved as Display/Fixed 128. Worked
> >  > > > >> since the early 1980's with the first TI terminal programs
> >  > > > >> that supported Xmodem...
> >  > > > >>
> >  > > > >> --- On *Fri, 1/8/10, Marc Hull //*
> >  > > > >> wrote:
> >  > > > >>
> >  > > > >>
> >  > > > >> From: Marc Hull
> >  > > > >> Subject: Re: [TI994A] Re: Mattel keyboard
> >  > > > >> To: TI994A@yahoogroups. com
> >  > > > >> Date: Friday, January 8, 2010, 2:31 PM
> >  > > > >>
> >  > > > >>
> >  > > > >>
> >  > > > >> Well I've been called a lot of things but men-tor ???
> >  > > > >> maybe men-tal....; -)
> >  > > > >>
> >  > > > >> Tell ya what.... I'll EM you some files tonight and see
> >  > > > >> if you can basically download them from your PeeCee to
> >  > > > >> your TI. I don't think MFM will work, You will have to
> >  > > > >> use some sort of telenetting (I think.) Maybe Greg can
> >  > > > >> chime in. He'll most likely know how to help.
> >  > > > >>
> >  > > > >>
> >  > > > >>
> >  > > > >>
> >  > > > >> --- On *Fri, 1/8/10, Owen Brand /> >> com>/*
> >  > > wrote:
> >  > > > >>
> >  > > > >>
> >  > > > >> From: Owen Brand
> >  > > > >> Subject: Re: [TI994A] Re: Mattel keyboard
> >  > > > >> To: "TI994A@yahoogroups .com"
> >  > > > >> Date: Friday, January 8, 2010, 11:22 AM
> >  > > > >>
> >  > > > >>
> >  > > > >>
> >  > > > >> Hell Marc, all you gotta do is ask. Anything you
> >  > > > >> need, I would be happy to help. You just let me know
> >  > > > >> what you need done, and I would be stoked to do it.
> >  > > > >> You've been so helpful to me in my learning--- I would
> >  > > > >> have never been able to finish Lemonade Stand in time
> >  > > > >> for the Faire last year were it not for your help and
> >  > > > >> instruction. There are but a couple people in my life
> >  > > > >> who I consider to be mentors. My father on life
> >  > > > >> issues, Tony McElwain on guitar, and Marc ****ing Hull
> >  > > > >> on the TI. Thanks, and anything I can do, just let me
> >  > > > >> know.
> >  > > > >>
> >  > > > >> Owen Brand
> >  > > > >> **Oprysoft**
> >  > > > >> Opry99er.com
> >  > > > >>
> >  > > > >> On Jan 8, 2010, at 12:10 PM, Marc Hull
> >  > > > >> wrote:
> >  > > > >>
> >  > > > >>>
> >  > > > >>>
> >  > > > >>> See, I have managed to confuse everyone with my
> >  > > > >>> Boomhower talk ;-)
> >  > > > >>>
> >  > > > >>> .MUS files are not programs nor do they contain any
> >  > > > >>> 6502 instructions so they should be directly portable
> >  > > > >>> to any system that has a SID. Like in the C=64, the
> >  > > > >>> SID in the TI is memory mapped meaning that the
> >  > > > >>> different SID registers look like memory locations.
> >  > > > >>> They are not the same locations as in the C=64 but
> >  > > > >>> none the less same basic set up. The player itself
> >  > > > >>> references these locations indirectly so the .MUS
> >  > > > >>> files should be usable with no other manipulation.
> >  > > > >>> These compose the 8000 files I have mentioned and
> >  > > > >>> they are ones that will have to be downloaded (not
> >  > > > >>> translated) to the TI.
> >  > > > >>>
> >  > > > >>> The player is what needs to be ported to 9900 AL.
> >  > > > >>> The reason I say ported is because if a player is
> >  > > > >>> written for the TI it needs to contain all the
> >  > > > >>> timing, nuances and mistakes contained in the
> >  > > > >>> original in order for the sound to be correct. It's
> >  > > > >>> like listening to an emulator play SID music versus a
> >  > > > >>> SID playing SID music. If the emulator is not
> >  > > > >>> perfect then a lot is lost in the translation.
> >  > > > >>>
> >  > > > >>> Seems you are the man to talk to about file transfer
> >  > > > >>> Owen. You interested?
> >  > > > >>>
> >  > > > >>>
> >  > > > >>>
> >  > > > >>>
> >  > > > >>> --- On *Fri, 1/8/10, Owen Brand /> >>>
> >  > > com>/* wrote:
> >  > > > >>>
> >  > > > >>>
> >  > > > >>> From: Owen Brand
> >  > > > >>> Subject: Re: [TI994A] Re: Mattel keyboard
> >  > > > >>> To: "TI994A@yahoogroups .com"
> >  > > > >>>
> >  > > > >>> Date: Friday, January 8, 2010, 10:38 AM
> >  > > > >>>
> >  > > > >>>
> >  > > > >>>
> >  > > > >>> Marc,
> >  > > > >>> I noticed in your YouTube video that you were
> >  > > > >>> able to translate the test program from the C64
> >  > > > >>> manual (if I remember correctly). Based on what
> >  > > > >>> you learned from that conversion, is it possible
> >  > > > >>> to write a program that will translate C64 audio
> >  > > > >>> commands over to the TI? By this I mean: can SID
> >  > > > >>> audio files (.MUS) be converted from their
> >  > > > >>> current form into TI form?? Or is this the whole
> >  > > > >>> point of this conversation and I missed it
> >  > > > >>> completely? :) I can be Dr. Dense sometimes...
> >  > > > >>>
> >  > > > >>> Owen Brand
> >  > > > >>> **Oprysoft**
> >  > > > >>>
> >  > > > >>> Opry99er.com
> >  > > > >>>
> >  > > > >>>
> >  > > > >>> On Jan 8, 2010, at 11:32 AM, Marc Hull
> >  > > > >>> wrote:
> >  > > > >>>
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>> ---> in all the players I've looked at, the main
> >  > > > >>>> focus was on playing the
> >  > > > >>>> version with embedded code, which we can't do.
> >  > > > >>>> Besdies, 6502 ported
> >  > > > >>>> directly to 9900 asm will be very inefficient. I
> >  > > > >>>> know both chips and would
> >  > > > >>>> not be interested in that approach myself.
> >  > > > >>>> (machine translation maybe, not
> >  > > > >>>> by hand ;) ). The 6502 also has some concepts
> >  > > > >>>> (like decimal mode) that the
> >  > > > >>>> 9900 has no analog for. Luckily it's unlikely to
> >  > > > >>>> be used.
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>> I think I have caused some confusion here by not
> >  > > > >>>> specifying what I mean by SID player. The
> >  > > > >>>> player I am talking about (SID PLAYER.64 IE..
> >  > > > >>>> Compute!'s music system blah blah blah....) was
> >  > > > >>>> one written for the C=64 in the eighties and
> >  > > > >>>> runs on the C=64 itself. The files it uses
> >  > > > >>>> (.MUS files) are composed of freq's and "player
> >  > > > >>>> commands" interpreted by the player itself not
> >  > > > >>>> imbeded 6502 commands. The origional author has
> >  > > > >>>> confirmed that it is more or less a bunch of bit
> >  > > > >>>> masking, shifting, counting and writing that is
> >  > > > >>>> done using the raster interrupt for timing.
> >  > > > >>>>
> >  > > > >>>> I am definitely not talking about the programs
> >  > > > >>>> written in 6502 that are analaguos to a TI-XB
> >  > > > >>>> music program nor tunes ripped from games or
> >  > > > >>>> other programs. That would require reinventing
> >  > > > >>>> the wheel each and every time. Nor am I talking
> >  > > > >>>> about music files in other formats (for now at
> >  > > > >>>> least....)
> >  > > > >>>>
> >  > > > >>>> .MUS files are similar to TI sound list files
> >  > > > >>>> used by the console sound list processor just
> >  > > > >>>> more complex because of the greater range and
> >  > > > >>>> features of the SID chip. Therefore once a
> >  > > > >>>> player is properly built all the files in ..MUS
> >  > > > >>>> format (about 8000 according to web info) should
> >  > > > >>>> be available to play. I do have this particular
> >  > > > >>>> player on my C=64 (sorry TI loyalists... ) and
> >  > > > >>>> about 20 music files so I can verify the
> >  > > > >>>> voracity of my info (unless I'm mistaken ;-)
> >  > > > >>>>
> >  > > > >>>> Sorry if I restated what you all ready knew....
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>> --- On *Fri, 1/8/10, tursi /> >>>>
> >  > > lion.com
> >  > > > >>>> >/* wrote:
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>> From: tursi > >>>>
> >  > > < /a>
> >  > > > >>>> lion.com >
> >  > > > >>>> Subject: Re: [TI994A] Re: Mattel keyboard
> >  > > > >>>> To: TI994A@yahoogroups. com
> >  > > > >>>> Date: Friday, January 8, 2010, 8:46 AM
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>>
> >  > > > >>>> > The reason I was thinking that the player
> >  > > > >>>> should be ported
> >  > > > >>>> > is to maintain compatibility with the
> >  > > > >>>> existing files out
> >  > > > >>>> > there. I do have some information on the
> >  > > > >>>> file structure
> >  > > > >>>>
> >  > > > >>>> in all the players I've looked at, the main
> >  > > > >>>> focus was on playing the
> >  > > > >>>> version with embedded code, which we can't
> >  > > > >>>> do. Besdies, 6502 ported
> >  > > > >>>> directly to 9900 asm will be very
> >  > > > >>>> inefficient. I know both chips and would
> >  > > > >>>> not be interested in that approach myself.
> >  > > > >>>> (machine translation maybe, not
> >  > > > >>>> by hand ;) ). The 6502 also has some
> >  > > > >>>> concepts (like decimal mode) that the
> >  > > > >>>> 9900 has no analog for. Luckily it's
> >  > > > >>>> unlikely to be used.
> >  > > > >>>>
> >  > > > >>>> > but it is fairly cryptic (to me any way.)
> >  > > > >>>> I'll shoot the
> >  > > > >>>> > link your way (actually found out that I
> >  > > > >>>> wasn't getting
> >  > > > >>>> > anything that was not posted all
> >  > > > >>>> ready...) Not being in
> >  > > > >>>>
> >  > > > >>>> >From what I saw it looked reletively
> >  > > > >>>> straightforward, with the questions
> >  > > > >>>> that were open solvable by quick
> >  > > > >>>> experimentation, I think.
> >  > > > >>>>
> >  > > > >>>> > the trade I find it very difficult to
> >  > > > >>>> decipher what others
> >  > > > >>>> > have done in their programs, especially
> >  > > > >>>> in unknown
> >  > > > >>>> > languages.
> >  > > > >>>>
> >  > > > >>>> Nothing to do with the trade, nobody likes
> >  > > > >>>> trying to fgure out someone
> >  > > > >>>> else's code. You have to pay me to do it. ;)
> >  > > > >>>>
> >  > > > >>>> > Perhaps someone with experience can fiddle
> >  > > > >>>> with shooting
> >  > > > >>>> > these files from their PeeCee to the TI.
> >  > > > >>>> I am guessing it
> >  > > > >>>> > would have to involve Teleneting on the PC
> >  > > > >>>> side and a TE on
> >  > > > >>>> > the TI side. How do you do this and
> >  > > > >>>> bypass the modem
> >  > > > >>>> > connection?
> >  > > > >>>>
> >  > > > >>>> Owen and Bill, among others, have been
> >  > > > >>>> talking about how they transfer
> >  > > > >>>> files for months.. I think Owen posted some
> >  > > > >>>> videos, go take a look at the
> >  > > > >>>> archives. There's serial links (using Xmodem
> >  > > > >>>> is simplest if you have an
> >  > > > >>>> xmodem client - no telnet), there's PC99,
> >  > > > >>>> now Windows compatible, there's
> >  > > > >>>> Fred's serial card ROM replacement (whose
> >  > > > >>>> name escapes me), there's the
> >  > > > >>>> CF7 with TI99Dir.... and more.
> >  > > > >>>>
> >  > > > >>>> > There is also a SID editor available in
> >  > > > >>>> the link but I
> >  > > > >>>> > don't see that being a useful port as it
> >  > > > >>>> does not take into
> >  > > > >>>> > consideration the 4 channels of sound
> >  > > > >>>> available in the
> >  > > > >>>> > console as well as the three SID
> >  > > > >>>> channels. Maybe later eh
> >  > > > >>>>
> >  > > > >>>> I would suggest that there are probably more
> >  > > > >>>> powerful tools on the PC,
> >  > > > >>>> having an editor on the TI might be more
> >  > > > >>>> effort than it's worth, IMO.
> >  > > > >>>>
> >  > > > >>
> >  > > > >>
> >  > > > >>
> >  > > > >
> >  > > > >
> >  > > > >
> >  > > > >
> >  > > >
> >  > > >
> >  > > > ------------------------------------
> >  > > >
> >  > > > Yahoo! Groups Links
> >  > > >
> >  > > >
> >  > > >
> >  > >
> >  > >
> >  >
> >  >
> >  > ------------------------------------
> >  >
> >  > Yahoo! Groups Links
> >  >
> >  >
> >  >
> > 
> > 
> 
>