Subject: Mattel keyboard

From: Owen Brand <[email-masked]>
Date: Wed, 6 Jan 2010 18:56:29 -0500

**Mattel also introduces a 49-key music keyboard which converts the  
Intellivision to a music synthesizer.

Hey, could this be done to work with Marc Hull's new SID card for the  
TI?  If we could interface a music keyboard-- we could develop a  
program that converts each "keystroke" into a frequency and a length--- 
these values could be made to be integrated into either AL or XB...  
This would be huge.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "killroy732000" <[email-masked]>
Date: Thu, 07 Jan 2010 09:54:04 -0000

Owen, do you know Mod2PSG2 ?

It's a tracker for the SN76489 sound chip and runs in windows.
According to the feature list it has MIDI keyboard support.

Now the interesting part is that Tursi made a player for the TI-99/4A. 
In other words you can compose the tune with the tracker and then
export it for running on the TI. 

Myself I have zero music skills, so can't give you much details.
However, I was able to use this tracker to rip some tunes from the
colecovision and get them to run on the TI-99/4A.

I have the player from Tursi included in my SPECTRA game library in
a slightly modified form. Also included is the code for a little
conversion utility that generates the necessary assembly "BYTE" 
statements.

You might want to check here:
http://www.kontechs.de/product?name=mod2psg2 
http://www.x68000.de/music-creation/composing-with-mod2psg2/
http://www.youtube.com/watch?v=lI4c0-mSdYM
http://spectra99.sourceforge.net/

Cheers
Filip

---

From: Owen Brand <[email-masked]>
Date: Thu, 7 Jan 2010 08:49:28 -0500

i am aware of Tursi's player, but unaware of how to do it....  I'll  
look into it today.  I liked the music I heard from the  
"Arcturus" (maybe) cart....  Very cool.  I saw the video on YouTube  
and was very impressed.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: tursi <[email-masked]>
Date: Thu, 7 Jan 2010 10:06:41 -0800 (PST)

> i am aware of Tursi's player, but unaware of how to do
> it....  I'll look into it today.  I liked the music I heard
> from the "Arcturus" (maybe) cart....  Very cool.  I saw the
> video on YouTube and was very impressed.

I wish I would have thought of that. Owen, Mod2Psg is a traditional 
tracker, four tracks wide. you define your instruments by means of a 
simple shape ediotr, then go ahead and play. Shiru ios the only artist I 
found whodid original music for it, everyone else is playing music from 
other systems (which works but is less efficient in memory use). If you 
could make use of it I'd happily make a tsr for XB, and it would benefit 
others who can use it too!

---

From: Owen Brand <[email-masked]>
Date: Thu, 7 Jan 2010 13:36:11 -0500

I could put out a ridiculous amount of music with an interface like  
that...  And coupled with the SID chip, we are looking at 7-10  
channels instead of 3.  You wanna talk cool.....  Of course we will  
all have to buy one of Marcs PEB boards.... (plug?)

Owen Brand
**Oprysoft**
Opry99er.com

---

From: ti99_forever <[email-masked]>
Date: Thu, 7 Jan 2010 10:50:10 -0800 (PST)

Tursi's board is for the TI sound chip, so you'd want a Forti card - and Tursi would have to modify his player for multiple TI sound chips.That part shouldn't be too hard, they just respond at different port addresses is all....
--- On Thu, 1/7/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "[email-masked]" <[email-masked]>
Date: Thursday, January 7, 2010, 1:36 PM

I could put out a ridiculous amount of music with an interface like that...  And coupled with the SID chip, we are looking at 7-10 channels instead of 3.  You wanna talk cool.....  Of course we will all have to buy one of Marcs PEB boards.... (plug?)
Owen Brand**Oprysoft**Opry99er.com
On Jan 7, 2010, at 1:06 PM, tursi <[email-masked]> wrote:

---

From: tursi <[email-masked]>
Date: Thu, 7 Jan 2010 14:04:36 -0800 (PST)

> I could put out a ridiculous amount of music with an
> interface like that...  And coupled with the SID chip, we
> are looking at 7-10 channels instead of 3.  You wanna talk
> cool.....  Of course we will all have to buy one of Marcs
> PEB boards.... (plug?)

well, if you want to compose SID music, you will need to find a SID 
tracker, which I suspect are very likely to exist. ;)

---

From: Marc Hull <[email-masked]>
Date: Thu, 7 Jan 2010 14:29:24 -0800 (PST)

What a segway.......

The truth of the matter is that there is all ready a sidplayer (I assume that is what a tracker is) available to play about 8000 (or abouts)  .MUS (music) files currently available on the Internet.  The problem is that it is written in 6502.  The source is available and I have contacted the original author who has said he will answer any questions he can while porting to TMS.  There are three issues...

1)  I don't speak 6502 (I barely understand 9900.)
2)  The files are in a format that will have to be brought from a PC and written to a TI disk (Again I have no idea...)
3)  The file format although somewhat documented is still fairly mysterious to me.  I have a couple books on the way to help out but alas my music knowlege died when my forced piano lessons ended in the fifth grade (to the delight of poor Mrs Erlich...)

Anybody want to help out ?

--- On Thu, 1/7/10, tursi <[email-masked]> wrote:

From: tursi <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "[email-masked]" <[email-masked]>
Date: Thursday, January 7, 2010, 4:04 PM

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 14:51:08 -0800 (PST)

You'd just need a MIDI keyboard and maybe a MIDI interface. I think you can get USB based MIDI intefaces these days.

I've just invested a major wad of cash into my home studio and bought some *SERIOUS* midi kit. I just took delivery of a gorgeous fully expanded Roland JV-1080 Midi module: 64 voices at the same time! http://www.rolandus.com/products/productdetails.php?ProductId=495&ParentId=73

Of course, the retro geek in me means I ccouldn't possibly use a PC for running all my midi kit. So I went ahead and bought a 1MB Atari STe (it's beautiful, looks brand new) upgraded to 4MB with Hi-res Mono monitor and Cubase midi software. I now have a really nice home studio, coupled with my awesome AW4416 (see http://www.barryrudolph.com/utilities/prorec/akaw4416.html ) 

The Atari is still regarded as the best machine ever made for MIDI use, and still graces many professional studios. The single tasking OS, lack of viruses, and silent running, as well as rock solid midi timing, due to the MIDI being done in Hardware still makes it un-beatable.

I've also got a nice Korg MIDI guitar rig. Can't wait to get into that! I've got to finish my TI projects first though, before I start playing with this stuff. It's all waiting for me!

Mark

>Sent: Thu, 7 January, 2010 18:36:11
>On Jan 7, 2010, at 1:06 PM, tursi <yahoogroup@harmless lion.com> wrote:
>
>
>

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 14:51:52 -0800 (PST)

The FORTi board is coded and controlled with FORTH :-)

>
>From: ti99_forever <[email-masked]>
>To: [email-masked]
>Sent: Thu, 7 January, 2010 18:50:10
>Tursi's board is for the TI sound chip, so you'd want a Forti card - and Tursi would have to modify his player for multiple TI sound chips.That part shouldn't be too hard, they just respond at different port addresses is all... 
>
>--- On Thu, 1/7/10, Owen Brand <owenbrand@opry99er. com> wrote:
>
>
>>From: Owen Brand <owenbrand@opry99er. com>
>>To: "TI994A@yahoogroups .com" <TI994A@yahoogroups. com>

---

From: Owen Brand <[email-masked]>
Date: Thu, 7 Jan 2010 17:56:34 -0500

i need to get my ass across the pond then and record in your studio.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 7, 2010, at 5:51 PM, mark wills <[email-masked]>  
wrote:

> You'd just need a MIDI keyboard and maybe a MIDI interface. I think  
> you can get USB based MIDI intefaces these days.
>
> I've just invested a major wad of cash into my home studio and  
> bought some *SERIOUS* midi kit. I just took delivery of a gorgeous  
> fully expanded Roland JV-1080 Midi module: 64 voices at the same  
> time! http://www.rolandus.com/products/productdetails.php?ProductId=495&ParentId=73
>
> Of course, the retro geek in me means I ccouldn't possibly use a PC  
> for running all my midi kit. So I went ahead and bought a 1MB Atari  
> STe (it's beautiful, looks brand new) upgraded to 4MB with Hi-res  
> Mono monitor and Cubase midi software. I now have a really nice home  
> studio, coupled with my awesome AW4416 (see http://www.barryrudolph.com/utilities/prorec/akaw4416.html 
>  )
>
> The Atari is still regarded as the best machine ever made for MIDI  
> use, and still graces many professional studios. The single tasking  
> OS, lack of viruses, and silent running, as well as rock solid midi  
> timing, due to the MIDI being done in Hardware still makes it un- 
> beatable.
>
> I've also got a nice Korg MIDI guitar rig. Can't wait to get into  
> that! I've got to finish my TI projects first though, before I start  
> playing with this stuff. It's all waiting for me!
>
> Mark
>
>
>

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 15:00:07 -0800 (PST)

6502 is pretty yucky. You only have three registers. A X and Y. It has lots of addressing modes. Its been years since I did any 6502. 8 bit AL is just a PITA after working with the TMS9900

;-)

>
>From: Marc Hull <[email-masked]>
>Sent: Thu, 7 January, 2010 22:29:24
>--- On Thu, 1/7/10, tursi <yahoogroup@harmless lion.com> wrote:
>
>
>>From: tursi <yahoogroup@harmless lion.com>

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 15:10:44 -0800 (PST)

Yeah, you're welcome any time. I've got 6 strats, two Les Pauls, and a few others (a gorgeous Kort active electric), MIDI drum machines, a really nice Korg electronic drum kit, and loads of other stuff. Now just need some time ;-)

Now need to invest in some nice vocal mikes, stands, and a decent vocal compressor, but the AW4416 desk can do that anyway with it's built in effects...

The 16 track desk is nice - it has full automation - you can sit and watch the sliders move by themselves when it replays your mix!

Somewhere I've got a POD guitar processor or two, but I now want the rack mount version ;-)

Mark

>Sent: Thu, 7 January, 2010 22:56:34
>Subject: Re: [TI994A] MIDI stuff
>
>  
>On Jan 7, 2010, at 5:51 PM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>  
>>I've just invested a major wad of cash into my home studio and bought some *SERIOUS* midi kit. I just took delivery of a gorgeous fully expanded Roland JV-1080 Midi module: 64 voices at the same time! http://www.rolandus .com/products/ productdetails. php?ProductId= 495&ParentId=73
>>
>>Of course, the retro geek in me means I ccouldn't possibly use a PC for running all my midi kit. So I went ahead and bought a 1MB Atari STe (it's beautiful, looks brand new) upgraded to 4MB with Hi-res Mono monitor and Cubase midi software. I now have a really nice home studio, coupled with my awesome AW4416 (see http://www.barryrud olph.com/ utilities/ prorec/akaw4416. html ) 
>>

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 15:12:50 -0800 (PST)

Marc

There is a free eBook on the web to learn 6502... It's very simple assembly language, being such a simple chip... 

http://forum.6502.org/viewtopic.php?p=7992

Mark

>
>From: mark wills <[email-masked]>
>Sent: Thu, 7 January, 2010 23:00:07
>>From: Marc Hull <marc.hull@sbcglobal .net>
>>To: TI994A@yahoogroups. com

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 15:24:39 -0800 (PST)

Actually, this migt be better: http://6502.org/tutorials/

The previous link was pitched at a much lower beginner level.

Mark

>Sent: Thu, 7 January, 2010 23:12:50
>Subject: [TI994A] 6502 programming (SID)
>
>  
>Marc
>
>http://forum. 6502.org/ viewtopic. php?p=7992
>
>Mark
>
>
>>
>>From: mark wills <markrobertwills@ yahoo.co. uk>

---

From: ti99_forever <[email-masked]>
Date: Thu, 7 Jan 2010 17:36:01 -0800 (PST)

That is what came with it, but essentially these are just TI sound chips at different addresses. They can even be controlled from Basic...

--- On Thu, 1/7/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: [email-masked]
Date: Thursday, January 7, 2010, 5:51 PM

 

  

I could put out a ridiculous amount of music with an interface like that....  And coupled with the SID chip, we are looking at 7-10 channels instead of 3.  You wanna talk cool.....  Of course we will all have to buy one of Marcs PEB boards.... (plug?)

Owen Brand
**Oprysoft**
Opry99er.com

---

From: tursi <[email-masked]>
Date: Thu, 7 Jan 2010 18:26:15 -0800 (PST)

> The truth of the matter is that there is all ready a sidplayer (I assume that is what a tracker is) available to play about

No. A tracker is for MAKING the music.

> 8000 (or abouts)  .MUS (music) files currently available on the Internet.  The problem is that it is written in 6502.  The
> source is available and I have contacted the original author who has said he will answer any questions he can while porting
> to TMS.  There are three issues...

I'm willing to write a player (better than porting 6502 unless it's that 
complex a format, and it doesn't look like it.) But I need to add SID 
support to Classic99 for debugging. So unless someone does it first, wait 
till I get to California and I'll ask for the hardware interface notes to 
the SID chip. ;)

> 2)  The files are in a format that will have to be brought from a PC and written to a TI disk (Again I have no idea...)

We do this all the time. It's nothing magical. Files without a TIFILES 
header become DIS/FIX 128 (IIRC) on the TI when transferred via XModem. 
Transfer via any means you use to transfer TI files.

---

From: tursi <[email-masked]>
Date: Thu, 7 Jan 2010 18:30:32 -0800 (PST)

> The Atari is still regarded as the best machine ever made for MIDI use, and still graces many professional studios. The
> single tasking OS, lack of viruses, and silent running, as well as rock solid midi timing, due to the MIDI being done in
> Hardware still makes it un-beatable.

"lack of viruses" - no. Be careful, there are a few hundred viruses for 
that machine. :) Was the first system I got into after the TI.

The best one was the one which, at random intervals, inverted the Y axis 
on the mouse. ;)

---

From: Brian Tristam Williams <[email-masked]>
Date: Fri, 8 Jan 2010 07:47:47 +0200

I've tinkered with Z80, TMS9900, 8086 (eugh), 8051, 6502, and the latter is
one of the simplest evarrr. :)

2010/1/8 mark wills <[email-masked]>

> *From:* mark wills <[email-masked]>
> *To:* [email-masked]
> *Sent:* Thu, 7 January, 2010 23:00:07
> *Subject:* Re: [TI994A] Re: Mattel keyboard
>
>
>
>  6502 is pretty yucky. You only have three registers. A X and Y. It has
> lots of addressing modes. Its been years since I did any 6502. 8 bit AL is
> just a PITA after working with the TMS9900
>
> ;-)
>
>
>
>
> *From:* Marc Hull <marc.hull@sbcglobal .net>
> *To:* TI994A@yahoogroups. com
> *Sent:* Thu, 7 January, 2010 22:29:24
> *Subject:* Re: [TI994A] Re: Mattel keyboard
>
>
>
>   What a segway.......
>
> The truth of the matter is that there is all ready a sidplayer (I assume
> that is what a tracker is) available to play about 8000 (or abouts)  .MUS
> (music) files currently available on the Internet.  The problem is that it
> is written in 6502.  The source is available and I have contacted the
> original author who has said he will answer any questions he can while
> porting to TMS.  There are three issues...
>
> 2)  The files are in a format that will have to be brought from a PC and
> written to a TI disk (Again I have no idea...)
> 3)  The file format although somewhat documented is still fairly mysterious
> to me.  I have a couple books on the way to help out but alas my music
> knowlege died when my forced piano lessons ended in the fifth grade (to the
> delight of poor Mrs Erlich...)
>
> --- On *Thu, 1/7/10, tursi <yahoogroup@harmless lion.com>* wrote:
>
>

-- 
Brian Tristam Williams

"One man can make a difference."

---

From: mark wills <[email-masked]>
Date: Fri, 8 Jan 2010 02:19:37 -0800 (PST)

Sure, but not these days! Yester-years atari script-kiddies re balding pot-bellied fathers!

Anyways, I'll only be running the one application on it. There is a nice hardware mod for it that allows the ST motherboard to be mounted inside a 1U rack case! Rack mounted ST - nice ;-)

Mark 

>Sent: Fri, 8 January, 2010 2:30:32

---

From: Marc Hull <[email-masked]>
Date: Fri, 8 Jan 2010 06:10:12 -0800 (PST)

---> I'm willing to write a player (better than porting 6502 unless it's that 

the SID chip. ;)

Excellent Mikey........
The reason I was thinking that the player should be ported is to maintain compatibility with the existing files out there.  I do have some information on the file structure but it is fairly cryptic (to me any way.)  I'll shoot the link your way (actually found out that I wasn't getting anything that was not posted all ready...)  Not being in the trade I find it very difficult to decipher what others have done in their programs,  especially in unknown languages.  

Perhaps someone with experience can fiddle with shooting these files from their PeeCee to the TI.  I am guessing it would have to involve Teleneting on the PC side and a TE on the TI side.  How do you do this and bypass the modem connection?

There is also a SID editor available in the link but I don't see that being a useful port as it does not take into consideration the 4 channels of sound available in the console as well as the three SID channels.  Maybe later eh ;-)

And before this riles up any old timers.... =)  I'm not trying to discount the MIDI program or the ForTI card (in fact I was originally going to do a variation of the Forti card before I found out about the SID.)  It's just something new and different (like this group here!) 

Marcus

From: tursi <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: [email-masked]
Date: Thursday, January 7, 2010, 8:26 PM

  

the SID chip. ;)

---

From: tursi <[email-masked]>
Date: Fri, 8 Jan 2010 06:46:34 -0800 (PST)

> The reason I was thinking that the player should be ported
> is to maintain compatibility with the existing files out
> there.  I do have some information on the file structure

in all the players I've looked at, the main focus was on playing the 
version with embedded code, which we can't do. Besdies, 6502 ported 
directly to 9900 asm will be very inefficient. I know both chips and would 
not be interested in that approach myself. (machine translation maybe, not 
by hand ;) ). The 6502 also has some concepts (like decimal mode) that the 
9900 has no analog for. Luckily it's unlikely to be used.

> but it is fairly cryptic (to me any way.)  I'll shoot the
> link your way (actually found out that I wasn't getting
> anything that was not posted all ready...)  Not being in

From what I saw it looked reletively straightforward, with the questions 
that were open solvable by quick experimentation, I think.

> the trade I find it very difficult to decipher what others
> have done in their programs,  especially in unknown
> languages. 

Nothing to do with the trade, nobody likes trying to fgure out someone 
else's code. You have to pay me to do it. ;)

> Perhaps someone with experience can fiddle with shooting
> these files from their PeeCee to the TI.  I am guessing it
> would have to involve Teleneting on the PC side and a TE on
> the TI side.  How do you do this and bypass the modem
> connection?

Owen and Bill, among others, have been talking about how they transfer 
files for months.. I think Owen posted some videos, go take a look at the 
archives. There's serial links (using Xmodem is simplest if you have an 
xmodem client - no telnet), there's PC99, now Windows compatible, there's 
Fred's serial card ROM replacement (whose name escapes me), there's the 
CF7 with TI99Dir... and more.

> There is also a SID editor available in the link but I
> don't see that being a useful port as it does not take into
> consideration the 4 channels of sound available in the
> console as well as the three SID channels.  Maybe later eh

I would suggest that there are probably more powerful tools on the PC, 
having an editor on the TI might be more effort than it's worth, IMO.

---

From: "Ksarul" <[email-masked]>
Date: Fri, 08 Jan 2010 10:17:59 -0500

Or you could go really extreme and do a ForTI card with a SID chip to go
with all of the TI sound chips. . .

Jim, who has a ForTI card and likes it!

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Marc Hull
Sent: Friday, January 08, 2010 9:10 AM
To: [email-masked]
Subject: Re: [TI994A] Re: Mattel keyboard

---> I'm willing to write a player (better than porting 6502 unless it's
that 
complex a format, and it doesn't look like it.) But I need to add SID 
support to Classic99 for debugging. So unless someone does it first, wait 
till I get to California and I'll ask for the hardware interface notes to 
the SID chip. ;)

Excellent Mikey........
The reason I was thinking that the player should be ported is to maintain
compatibility with the existing files out there.  I do have some information
on the file structure but it is fairly cryptic (to me any way.)  I'll shoot
the link your way (actually found out that I wasn't getting anything that
was not posted all ready...)  Not being in the trade I find it very
difficult to decipher what others have done in their programs,  especially
in unknown languages.  

Perhaps someone with experience can fiddle with shooting these files from
their PeeCee to the TI.  I am guessing it would have to involve Teleneting
on the PC side and a TE on the TI side.  How do you do this and bypass the
modem connection?

There is also a SID editor available in the link but I don't see that being
a useful port as it does not take into consideration the 4 channels of sound
available in the console as well as the three SID channels.  Maybe later eh
;-)

And before this riles up any old timers.... =)  I'm not trying to discount
the MIDI program or the ForTI card (in fact I was originally going to do a
variation of the Forti card before I found out about the SID.)  It's just
something new and different (like this group here!) 

Marcus

> The truth of the matter is that there is all ready a sidplayer (I assume
that is what a tracker is) available to play about

> 8000 (or abouts)  .MUS (music) files currently available on the Internet.
The problem is that it is written in 6502.  The
> source is available and I have contacted the original author who has said
he will answer any questions he can while porting

---

From: Marc Hull <[email-masked]>
Date: Fri, 8 Jan 2010 08:32:31 -0800 (PST)

---> in all the players I've looked at, the main focus was on playing the 

I think I have caused some confusion here by not specifying what I mean by SID player.  The player I am talking about (SID PLAYER.64 IE.. Compute!'s music system blah blah blah...) was one written for the C=64 in the eighties and runs on the C=64 itself.  The files it uses (.MUS files) are composed of freq's and "player commands"  interpreted by the player itself not  imbeded 6502 commands.  The origional author has confirmed that it is more or less a bunch of bit masking, shifting, counting and writing that is done using the raster interrupt for timing.  

I am definitely not talking about the programs written in 6502 that are analaguos to a TI-XB music program nor tunes ripped from games or other programs.  That would require reinventing the wheel each and every time.  Nor am I talking about music files in other formats (for now at least....)

.MUS files are similar to TI sound list files used by the console sound list processor just more complex because of the greater range and features of the SID chip.  Therefore once a player is properly built all the files in .MUS format (about 8000 according to web info) should be available to play.  I do have this particular player on my C=64 (sorry TI loyalists...) and about 20 music files so I can verify the voracity of my info (unless I'm mistaken ;-)

Sorry if I restated what you all ready knew....

--- On Fri, 1/8/10, tursi <[email-masked]> wrote:

From: tursi <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: [email-masked]
Date: Friday, January 8, 2010, 8:46 AM

---

From: Owen Brand <[email-masked]>
Date: Fri, 8 Jan 2010 11:38:53 -0500

Marc,
    I noticed in your YouTube video that you were able to translate  
the test program from the C64 manual (if I remember correctly). Based  
on what you learned from that conversion, is it possible to write a  
program that will translate C64 audio commands over to the TI?  By  
this I mean: can SID audio files (.MUS) be converted from their  
current form into TI form??  Or is this the whole point of this  
conversation and I missed it completely?  :) I can be Dr. Dense  
sometimes...

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 8, 2010, at 11:32 AM, Marc Hull <[email-masked]> wrote:

> I think I have caused some confusion here by not specifying what I  
> mean by SID player.  The player I am talking about (SID PLAYER.64  
> IE.. Compute!'s music system blah blah blah...) was one written for  
> the C=64 in the eighties and runs on the C=64 itself.  The files it  
> uses (.MUS files) are composed of freq's and "player commands"   
> interpreted by the player itself not  imbeded 6502 commands.  The  
> origional author has confirmed that it is more or less a bunch of  
> bit masking, shifting, counting and writing that is done using the  
> raster interrupt for timing.
>
> I am definitely not talking about the programs written in 6502 that  
> are analaguos to a TI-XB music program nor tunes ripped from games  
> or other programs.  That would require reinventing the wheel each  
> and every time.  Nor am I talking about music files in other formats  
> (for now at least....)
>
> .MUS files are similar to TI sound list files used by the console  
> sound list processor just more complex because of the greater range  
> and features of the SID chip.  Therefore once a player is properly  
> built all the files in .MUS format (about 8000 according to web  
> info) should be available to play.  I do have this particular player  
> on my C=64 (sorry TI loyalists...) and about 20 music files so I can  
> verify the voracity of my info (unless I'm mistaken ;-)
>

---

From: Marc Hull <[email-masked]>
Date: Fri, 8 Jan 2010 09:10:14 -0800 (PST)

See, I have managed to confuse everyone with my Boomhower talk ;-)

.MUS files are not programs nor do they contain any 6502 instructions so they should be directly portable to any system that has a SID.  Like in the C=64, the SID in the TI is memory mapped meaning that the different SID registers look like memory locations. They are not the same locations as in the C=64 but none the less same basic set up.  The player itself references these locations indirectly so the .MUS files should be usable with no other manipulation.  These compose the 8000 files I have mentioned and they are ones that will have to be downloaded (not translated) to the TI. 

The player is what needs to be ported to 9900 AL.  The reason I say ported is because if a player is written for the TI it needs to contain all the timing, nuances and mistakes contained in the original in order for the sound to be correct.  It's like listening to an emulator play SID music versus a SID playing SID music.  If the emulator is not perfect then a lot is lost in the translation.

Seems you are the man to talk to about file transfer Owen.  You interested?

--- On Fri, 1/8/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "[email-masked]" <[email-masked]>
Date: Friday, January 8, 2010, 10:38 AM

  

      Marc,   I noticed in your YouTube video that you were able to translate the test program from the C64 manual (if I remember correctly). Based on what you learned from that conversion, is it possible to write a program that will translate C64 audio commands over to the TI?  By this I mean: can SID audio files (.MUS) be converted from their current form into TI form??  Or is this the whole point of this conversation and I missed it completely?  :) I can be Dr. Dense sometimes...

Owen Brand**Oprysoft**Opry99er.com
On Jan 8, 2010, at 11:32 AM, Marc Hull <marc.hull@sbcglobal .net> wrote:

    

.MUS files are similar to TI sound list files used
 by the console sound list processor just more complex because of the greater range and features of the SID chip.  Therefore once a player is properly built all the files in .MUS format (about 8000 according to web info) should be available to play.  I do have this particular player on my C=64 (sorry TI loyalists... ) and about 20 music files so I can verify the voracity of my info (unless I'm mistaken ;-)

---

From: Owen Brand <[email-masked]>
Date: Fri, 8 Jan 2010 12:22:04 -0500

Hell Marc, all you gotta do is ask.  Anything you need, I would be  
happy to help.  You just let me know what you need done, and I would  
be stoked to do it. You've been so helpful to me in my learning--- I  
would have never been able to finish Lemonade Stand in time for the  
Faire last year were it not for your help and instruction.  There are  
but a couple people in my life who I consider to be mentors.  My  
father on life issues, Tony McElwain on guitar, and Marc ****ing Hull  
on the TI.  Thanks, and anything I can do, just let me know.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 8, 2010, at 12:10 PM, Marc Hull <[email-masked]> wrote:

> .MUS files are not programs nor do they contain any 6502  
> instructions so they should be directly portable to any system that  
> has a SID.  Like in the C=64, the SID in the TI is memory mapped  
> meaning that the different SID registers look like memory locations.  
> They are not the same locations as in the C=64 but none the less  
> same basic set up.  The player itself references these locations  
> indirectly so the .MUS files should be usable with no other  
> manipulation.  These compose the 8000 files I have mentioned and  
> they are ones that will have to be downloaded (not translated) to  
> the TI.
>
> The player is what needs to be ported to 9900 AL.  The reason I say  
> ported is because if a player is written for the TI it needs to  
> contain all the timing, nuances and mistakes contained in the  
> original in order for the sound to be correct.  It's like listening  
> to an emulator play SID music versus a SID playing SID music.  If  
> the emulator is not perfect then a lot is lost in the translation.
>
> the test program from the C64 manual (if I remember correctly).  
> Based on what you learned from that conversion, is it possible to  
> write a program that will translate C64 audio commands over to the  
> TI?  By this I mean: can SID audio files (.MUS) be converted from  
> their current form into TI form??  Or is this the whole point of  
> this conversation and I missed it completely?  :) I can be Dr. Dense  
> sometimes...
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
>> and every time.  Nor am I talking about music files in other  
>> formats (for now at least....)
>>
>> info) should be available to play.  I do have this particular  
>> player on my C=64 (sorry TI loyalists... ) and about 20 music files  
>> so I can verify the voracity of my info (unless I'm mistaken ;-)
>>

---

From: Marc Hull <[email-masked]>
Date: Fri, 8 Jan 2010 11:31:02 -0800 (PST)

Well I've been called a lot of things but men-tor ??? maybe men-tal....;-)

Tell ya what....  I'll EM you some files tonight and see if you can basically download them from your PeeCee to your TI.  I don't think MFM will work, You will have to use some sort of telenetting (I think.)  Maybe Greg can chime in.  He'll most likely know how to help.

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: "[email-masked]" <[email-masked]>
Date: Friday, January 8, 2010, 11:22 AM

  

      Hell Marc, all you gotta do is ask.  Anything you need, I would be happy to help.  You just let me know what you need done, and I would be stoked to do it. You've been so helpful to me in my learning--- I would have never been able to finish Lemonade Stand in time for the Faire last year were it not for your help and instruction.  There are but a couple people in my life who I consider to be mentors.  My father on life issues, Tony McElwain on guitar, and Marc ****ing Hull on the TI.  Thanks, and anything I can do, just let me know.  

Owen Brand**Oprysoft**Opry99er.com
On Jan 8, 2010, at 12:10 PM, Marc Hull <marc.hull@sbcglobal .net> wrote:

    

The player is what needs to be ported to 9900 AL.  The reason I say ported is because if a player is written for the TI it needs to contain all the timing, nuances and mistakes
 contained in the original in order for the sound to be correct.  It's like listening to an emulator play SID music versus a SID playing SID music.  If the emulator is not perfect then a lot is lost in the translation.

--- On Fri, 1/8/10, Owen Brand <owenbrand@opry99er. com> wrote:

---

From: fdos <[email-masked]>
Date: Fri, 08 Jan 2010 12:47:22 -0700

Me too, because I use it on my Geneve!  Not reinstalled yet, but soon. 
Yes, the software had to be patched for 2MB GenMod Geneve operation.

Bill S

Ksarul wrote:
> ------------------------------------------------------------------------
> 
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Marc Hull
> *Sent:* Friday, January 08, 2010 9:10 AM
> The reason I was thinking that the player should be ported is to 
> maintain compatibility with the existing files out there.  I do have 
> some information on the file structure but it is fairly cryptic (to me 
> any way.)  I'll shoot the link your way (actually found out that I 
> wasn't getting anything that was not posted all ready...)  Not being in 
> the trade I find it very difficult to decipher what others have done in 
> their programs,  especially in unknown languages. 
> 
> Perhaps someone with experience can fiddle with shooting these files 
> from their PeeCee to the TI.  I am guessing it would have to involve 
> Teleneting on the PC side and a TE on the TI side.  How do you do this 
> and bypass the modem connection?
> 
> There is also a SID editor available in the link but I don't see that 
> being a useful port as it does not take into consideration the 4 
> channels of sound available in the console as well as the three SID 
> channels.  Maybe later eh ;-)
> 
> And before this riles up any old timers.... =)  I'm not trying to 
> discount the MIDI program or the ForTI card (in fact I was originally 
> going to do a variation of the Forti card before I found out about the 
> SID.)  It's just something new and different (like this group here!)
> 
> Marcus
> 
> 
> 
> --- On *Thu, 1/7/10, tursi /<[email-masked]>/* wrote:
> 
> 
>>  The truth of the matter is that there is all ready a sidplayer (I 
> assume that is what a tracker is) available to play about
> 
>>  8000 (or abouts)  .MUS (music) files currently available on the 
> Internet.  The problem is that it is written in 6502.  The
>>  source is available and I have contacted the original author who has 
> said he will answer any questions he can while porting
>>  2)  The files are in a format that will have to be brought from a PC 
> and written to a TI disk (Again I have no idea...)
>

---

From: fdos <[email-masked]>
Date: Fri, 08 Jan 2010 12:47:34 -0700

Bill S

---

From: ti99_forever <[email-masked]>
Date: Fri, 8 Jan 2010 13:49:41 -0800 (PST)

Hyperterm on the PC, MFM on the TI will work. If there is no TIFILES header, they are saved as Display/Fixed 128. Worked since the early 1980's with the first TI terminal programs that supported Xmodem...
--- On Fri, 1/8/10, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Re: Mattel keyboard
To: [email-masked]
Date: Friday, January 8, 2010, 2:31 PM

 

 

Owen Brand**Oprysoft**Opry99er.com
On Jan 8, 2010, at 12:10 PM, Marc Hull <marc.hull@sbcglobal .net>
 wrote:

    

..MUS files are not programs nor do they contain any 6502 instructions so they should be directly portable to any system that has a SID.  Like in the C=64, the SID in the TI is memory mapped meaning that the different SID registers look like memory locations. They are not the same locations as in the C=64 but none the less same basic set up.  The player itself references these locations indirectly so the .MUS files should be usable with no other manipulation.  These compose the 8000 files I have mentioned and they are ones that will have to be downloaded (not translated)
 to the TI. 

 

 

..MUS files are similar to TI sound list files used
 by the console sound list processor just more complex because of the greater range and features of the SID chip.  Therefore once a player is properly built all the files in .MUS format (about 8000 according to web info) should be available to play.  I do have this particular player on my C=64 (sorry TI loyalists.... ) and about 20 music files so I can verify the voracity of my info (unless I'm mistaken ;-)

From: tursi <[email-masked]>
Subject: Re:
 [TI994A] Re: Mattel keyboard
To: TI994A@yahoogroups. com
Date: Friday, January 8, 2010, 8:46 AM

---

From: Owen Brand <[email-masked]>
Date: Fri, 8 Jan 2010 16:56:15 -0500

I was thinking the same thing, but was
Willing to try other options.  I have a few ways to get files from PC  
to TI.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 8, 2010, at 4:49 PM, ti99_forever <[email-masked]> wrote:

> Hyperterm on the PC, MFM on the TI will work. If there is no TIFILES  
> header, they are saved as Display/Fixed 128. Worked since the early  
> 1980's with the first TI terminal programs that supported Xmodem...
>
> Tell ya what....  I'll EM you some files tonight and see if you can  
> basically download them from your PeeCee to your TI.  I don't think  
> MFM will work, You will have to use some sort of telenetting (I  
> think.)  Maybe Greg can chime in.  He'll most likely know how to help.
>
>
>
>
> Faire last year were it not for your help and instruction.  There  
> are but a couple people in my life who I consider to be mentors.  My  
> father on life issues, Tony McElwain on guitar, and Marc ****ing  
> Hull on the TI.  Thanks, and anything I can do, just let me know.
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
>> meaning that the different SID registers look like memory  
>> locations. They are not the same locations as in the C=64 but none  
>> the less same basic set up.  The player itself references these  
>> locations indirectly so the .MUS files should be usable with no  
>> other manipulation.  These compose the 8000 files I have mentioned  
>> and they are ones that will have to be downloaded (not translated)  
>> to the TI.
>>
>> this conversation and I missed it completely?  :) I can be Dr.  
>> Dense sometimes...
>>
>> Owen Brand
>> **Oprysoft**
>> Opry99er.com
>>
>>> IE.. Compute!'s music system blah blah blah...) was one written  
>>> for the C=64 in the eighties and runs on the C=64 itself.  The  
>>> files it uses (.MUS files) are composed of freq's and "player  
>>> commands"  interpreted by the player itself not  imbeded 6502  
>>> commands.  The origional author has confirmed that it is more or  
>>> less a bunch of bit masking, shifting, counting and writing that  
>>> is done using the raster interrupt for timing.
>>>
>>> I am definitely not talking about the programs written in 6502  
>>> that are analaguos to a TI-XB music program nor tunes ripped from  
>>> games or other programs.  That would require reinventing the wheel  
>>> each and every time.  Nor am I talking about music files in other  
>>> sound list processor just more complex because of the greater  
>>> range and features of the SID chip.  Therefore once a player is  
>>> properly built all the files in ..MUS format (about 8000 according  
>>> to web info) should be available to play.  I do have this  
>>> particular player on my C=64 (sorry TI loyalists... ) and about 20  
>>> music files so I can verify the voracity of my info (unless I'm  
>>> mistaken ;-)
>>>
>>> CF7 with TI99Dir.... and more.
>>>

---

From: "Dan O'Quinn" <[email-masked]>
Date: Fri, 8 Jan 2010 17:07:29 -0500

Get it while ya can
TI-99/4a CompactFlash Drive/PIO Port

http://tinyurl.com/yc6ndd2

or ebay item # 200425884075

sorry for cross posting, but.

---

From: fdos <[email-masked]>
Date: Fri, 08 Jan 2010 15:19:41 -0700

Ben,

Which version of Hyperterm supports network connections?  Even though I 
use TI99-PC on my TI Win98SE PC peripheral for file transfers.  I have 
lost a PC floppy disk controller in the past, so I want an alternative 
method available using MFM via the wireless PC network connection.

Bill S

ti99_forever wrote:
> --- On *Fri, 1/8/10, Marc Hull /<[email-masked]>/* wrote:
> 
> 
>     --- On *Fri, 1/8/10, Owen Brand /<[email-masked]>/* wrote:
> 
> 
>         Hell Marc, all you gotta do is ask.  Anything you need, I would
>         be happy to help.  You just let me know what you need done, and
>         I would be stoked to do it. You've been so helpful to me in my
>         learning--- I would have never been able to finish Lemonade
>         Stand in time for the Faire last year were it not for your help
>         and instruction.  There are but a couple people in my life who I
>         consider to be mentors.  My father on life issues, Tony McElwain
>         on guitar, and Marc ****ing Hull on the TI.  Thanks, and
>         anything I can do, just let me know.  
> 
>         Owen Brand
>         **Oprysoft**
>         Opry99er.com <http://Opry99er.com>
> 
>>         instructions so they should be directly portable to any system
>>         that has a SID.  Like in the C=64, the SID in the TI is memory
>>         mapped meaning that the different SID registers look like
>>         memory locations. They are not the same locations as in the
>>         C=64 but none the less same basic set up.  The player itself
>>         references these locations indirectly so the .MUS files should
>>         be usable with no other manipulation.  These compose the 8000
>>         files I have mentioned and they are ones that will have to be
>>         downloaded (not translated) to the TI.
>>
>>         The player is what needs to be ported to 9900 AL.  The reason
>>         I say ported is because if a player is written for the TI it
>>         needs to contain all the timing, nuances and mistakes
>>         contained in the original in order for the sound to be
>>         correct.  It's like listening to an emulator play SID music
>>         versus a SID playing SID music.  If the emulator is not
>>         perfect then a lot is lost in the translation.
>>
>>         --- On *Fri, 1/8/10, Owen Brand /<owenbrand@opry99er. com>/*
>>         wrote:
>>
>>
>>                I noticed in your YouTube video that you were able to
>>             translate the test program from the C64 manual (if I
>>             remember correctly). Based on what you learned from that
>>             conversion, is it possible to write a program that will
>>             translate C64 audio commands over to the TI?  By this I
>>             mean: can SID audio files (.MUS) be converted from their
>>             current form into TI form??  Or is this the whole point of
>>             this conversation and I missed it completely?  :) I can be
>>             Dr. Dense sometimes...
>>
>>             Owen Brand
>>             **Oprysoft**
>>             <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>
>>>             I think I have caused some confusion here by not
>>>             specifying what I mean by SID player.  The player I am
>>>             talking about (SID PLAYER.64 IE.. Compute!'s music system
>>>             blah blah blah...) was one written for the C=64 in the
>>>             eighties and runs on the C=64 itself.  The files it uses
>>>             (.MUS files) are composed of freq's and "player
>>>             commands"  interpreted by the player itself not  imbeded
>>>             6502 commands.  The origional author has confirmed that
>>>             it is more or less a bunch of bit masking, shifting,
>>>             counting and writing that is done using the raster
>>>             interrupt for timing. 
>>>
>>>             I am definitely not talking about the programs written in
>>>             6502 that are analaguos to a TI-XB music program nor
>>>             tunes ripped from games or other programs.  That would
>>>             require reinventing the wheel each and every time.  Nor
>>>             am I talking about music files in other formats (for now
>>>             at least....)
>>>
>>>             .MUS files are similar to TI sound list files used by the
>>>             console sound list processor just more complex because of
>>>             the greater range and features of the SID chip. 
>>>             Therefore once a player is properly built all the files
>>>             in ..MUS format (about 8000 according to web info) should
>>>             be available to play.  I do have this particular player
>>>             on my C=64 (sorry TI loyalists... ) and about 20 music
>>>             files so I can verify the voracity of my info (unless I'm
>>>             mistaken ;-)
>>>
>>>             --- On *Fri, 1/8/10, tursi /<yahoogroup@harmless
>>>             <http://lion.com>lion.com <http://lion.com>>/* wrote:
>>>
>>>
>>>                 From: tursi <yahoogroup@harmless
>>>                 <http://lion.com>lion.com <http://lion.com>>

---

From: R Halter <[email-masked]>
Date: Fri, 08 Jan 2010 16:23:58 -0600

> or ebay item # 200425884075

*sigh* And once again, right after I spent my entire paycheck on 
something useless, like rent...

-- 
"You keep using that word.  I do not think it means what you think it 
means."
  -- Inigo Montoya (Mandy Patinkin), "The Princess Bride"

---

From: ti99_forever <[email-masked]>
Date: Fri, 8 Jan 2010 14:31:03 -0800 (PST)

I was talking over the serial port, as we were talking MFM.
But some versions support network connections as I've used them before...

--- On Fri, 1/8/10, fdos <[email-masked]> wrote:

> From: fdos <[email-masked]>
> Date: Friday, January 8, 2010, 5:19 PM
> Ben,
> 
> >     Well I've been called a lot of
> things but men-tor ??? maybe
> >     men-tal....;-)
> > 
> >     Tell ya what.....  I'll EM
> you some files tonight and see if you can
> >     think.)  Maybe Greg can
> chime in.  He'll most likely know how to help.
> > 
> > 
> > 
> > 
> >     --- On *Fri, 1/8/10, Owen
> Brand /<[email-masked]>/*
> wrote:
> > 
> > 
> >         From: Owen Brand
> <[email-masked]>
> >         Subject: Re:
> >         Hell Marc, all
> you gotta do is ask.  Anything you need, I would
> >         be happy to
> help.  You just let me know what you need done, and
> >         I would be
> stoked to do it. You've been so helpful to me in my
> >         learning--- I
> would have never been able to finish Lemonade
> >         Stand in time
> for the Faire last year were it not for your help
> >         and
> instruction.  There are but a couple people in my life
> who I
> >         consider to be
> mentors.  My father on life issues, Tony McElwain
> >         on guitar, and
> <http://Opry99er.com>
> >         On Jan 8, 2010,
> at 12:10 PM, Marc Hull <marc.hull@sbcglobal
> >         .net> wrote:
> > 
> >>          
> >>
> >>         See, I have
> managed to confuse everyone with my Boomhower talk ;-)
> >>
> >>         .MUS files
> are not programs nor do they contain any 6502
> >>         instructions
> so they should be directly portable to any system
> >>         that has a
> SID.  Like in the C=64, the SID in the TI is memory
> >>         mapped
> locations. They are not the same locations as in the
> >>         C=64 but
> none the less same basic set up.  The player itself
> >>         references
> these locations indirectly so the .MUS files should
> >>         be usable
> with no other manipulation.  These compose the 8000
> >>         files I have
> mentioned and they are ones that will have to be
> >>         downloaded
> >>         The player
> is what needs to be ported to 9900 AL.  The reason
> >>         I say ported
> is because if a player is written for the TI it
> >>         needs to
> contain all the timing, nuances and mistakes
> >>         contained in
> the original in order for the sound to be
> >>     
> >>         versus a SID
> playing SID music.  If the emulator is not
> >>         perfect then
> >>         Seems you
> are the man to talk to about file transfer Owen. 
> >>         You
> interested?
> >>
> >>
> >>
> >>
> >>         --- On *Fri,
> 1/8/10, Owen Brand /<owenbrand@opry99er. com>/*
> >>         wrote:
> >>
> >>
> >>         
>    On Jan 8, 2010, at 11:32 AM, Marc Hull
> >>         
>    <marc.hull@sbcglobal .net> wrote:
> >>
> >>>           
>   
> >>>
> >>>         
>    ---> in all the players I've looked at,
> the main focus
> >>>         
>    was on playing the
> >>>         
>    version with embedded code, which we can't
> do. Besdies,
> >>>         
>    6502 ported
> >>>         
>    directly to 9900 asm will be very
> inefficient. I know
> >>>         
>    both chips and would
> >>>         
>    not be interested in that approach myself.
> (machine
> >>>         
>    translation maybe, not
> >>>         
>    by hand ;) ). The 6502 also has some
> concepts (like
> >>>         
>    decimal mode) that the
> >>>         
>    specifying what I mean by SID
> player..  The player I am
> >>>         
>      > The reason I was thinking that
> the player should be
> >>>           
>      ported
> >>>           
>      > is to maintain compatibility
> with the existing
> >>>           
>      files out
> >>>           
>      > there.  I do have some
> information on the file
> >>>           
>      structure
> >>>
> >>>           
>      in all the players I've looked at,
> the main focus was
> >>>           
>      on playing the
> >>>           
>      version with embedded code, which
> we can't do.
> >>>           
>      Besdies, 6502 ported
> >>>           
>      directly to 9900 asm will be very
> inefficient. I know
> >>>           
>      both chips and would
> >>>           
>      not be interested in that approach
> myself. (machine
> >>>           
>      translation maybe, not
> >>>           
>      by hand ;) ). The 6502 also has
> some concepts (like
> >>>           
>      decimal mode) that the
> >>>           
>      > but it is fairly cryptic (to
> me any way.)  I'll
> >>>           
>      shoot the
> >>>           
>      > link your way (actually found
> out that I wasn't getting
> >>>           
>      > anything that was not posted
> all ready...)  Not
> >>>           
>      being in
> >>>
> >>>           
>      >From what I saw it looked
> reletively
> >>>           
>      straightforward, with the
> questions
> >>>           
>      that were open solvable by quick
> experimentation, I
> >>>           
>      think.
> >>>
> >>>           
>      > the trade I find it very
> difficult to decipher what
> >>>           
>      others
> >>>           
>      > have done in their
> programs,  especially in unknown
> >>>           
>      > languages. 
> >>>
> >>>           
>      Nothing to do with the trade,
> nobody likes trying to
> >>>           
>      fgure out someone
> >>>           
>      > Perhaps someone with
> experience can fiddle with
> >>>           
>      shooting
> >>>           
>      > these files from their PeeCee
> to the TI.  I am
> >>>           
>      guessing it
> >>>           
>      > would have to involve
> Teleneting on the PC side and
> >>>           
>      a TE on
> >>>           
>      > the TI side.  How do you
> do this and bypass the modem
> >>>           
>      > connection?
> >>>
> >>>           
>      Owen and Bill, among others, have
> been talking about
> >>>           
>      how they transfer
> >>>           
>      files for months.. I think Owen
> posted some videos,
> >>>           
>      go take a look at the
> >>>           
>      archives. There's serial links
> (using Xmodem is
> >>>           
>      simplest if you have an
> >>>           
>      xmodem client - no telnet), there's
> PC99, now Windows
> >>>           
>      compatible, there's
> >>>           
>      Fred's serial card ROM replacement
> (whose name
> >>>           
>      escapes me), there's the
> >>>           
>      > There is also a SID editor
> available in the link but I
> >>>           
>      > don't see that being a useful
> port as it does not
> >>>           
>      take into
> >>>           
>      > consideration the 4 channels
> of sound available in the
> >>>           
>      > console as well as the three
> SID channels.  Maybe
> >>>           
>      later eh
> >>>
> >>>           
>      I would suggest that there are
> probably more powerful
> >>>           
>      tools on the PC,
> >>>           
>      having an editor on the TI might be
> more effort than
> >>>           
>      it's worth, IMO.
> >>>
> > 
> > 
> > 
> > 
> 
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: fdos <[email-masked]>
Date: Fri, 08 Jan 2010 15:46:05 -0700

Yes, I used Hyperterm over a network connection at one time or another, 
but I don't remember which version.  I do think it was the one I used in 
Win2K, but I originally used a direct serial cable connection at the 
time back in California when I also used CAT5 for the network 
connection.  Here in Arizona I have both my VISTA and Win98SE computers 
connected via wireless as the VISTA PC is in another room, and the 
Win98SE is separated from the LAN devices by a heavy traffic aisle.  I 
know I could cable up and over using sky-hooks, but I hope to make my 
Geek Room into a showcase some day.

Bill S

ti99_forever wrote:
> --- On Fri, 1/8/10, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > > --- On *Fri, 1/8/10, Marc Hull /<[email-masked] 
> <mailto:marc.hull%40sbcglobal.net>>/*
>  > wrote:
>  > >
>  > >
>  > >     From: Marc Hull <[email-masked] 
> <mailto:marc.hull%40sbcglobal.net>>
>  > >     To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > Brand /<[email-masked] <mailto:owenbrand%40opry99er.com>>/*
>  > wrote:
>  > >
>  > >
>  > >         From: Owen Brand
>  > <[email-masked] <mailto:owenbrand%40opry99er.com>>
>  > >         Subject: Re:
>  > >         To: "[email-masked] <mailto:TI994A%40yahoogroups.com>"
>  > <[email-masked] <mailto:TI994A%40yahoogroups.com>>
>  > >         Date: Friday,
>  > <http://Opry99er.com <http://Opry99er.com>>
>  > >
>  > >         On Jan 8, 2010,
>  >    <http://Opry99er.com <http://Opry99er.com>>Opry99er.com
>  > <http://Opry99er.com <http://Opry99er.com>>
>  > >>
>  > >>         
>  >    <http://lion.com <http://lion.com>>lion.com <http://lion.com 
> <http://lion.com>>>/* wrote:
>  > >>>
>  > >>>
>  > >>>           
>  >      From: tursi
>  > <yahoogroup@harmless
>  > >>>           
>  >      <http://lion.com <http://lion.com>>lion.com <http://lion.com 
> <http://lion.com>>>
>  > >>>           
>  >      > The reason I was thinking that
>  > the player should be
>  > >>>           
>  >      ported
>  > >>>           
>  >      > is to maintain compatibility
>  > with the existing
>  > >>>           
>  >      files out
>  > >>>           
>  >      > there.  I do have some
>  > information on the file
>  > >>>           
>  >      structure
>  > >>>
>  > >>>           
>  >      > but it is fairly cryptic (to
>  > me any way.)  I'll
>  > >>>           
>  >      shoot the
>  > >>>           
>  >      > anything that was not posted
>  > all ready...)  Not
>  > >>>           
>  >      being in
>  > >>>
>  > >>>           
>  >      >From what I saw it looked
>  > reletively
>  > >>>           
>  >      > the trade I find it very
>  >      > Perhaps someone with
>  >      > these files from their PeeCee
>  > to the TI.  I am
>  > >>>           
>  >      guessing it
>  > >>>           
>  >      > would have to involve
>  >      > don't see that being a useful
>  > port as it does not
>  > >>>           
>  >      take into
>  > >>>           
>  >      > console as well as the three
>  > SID channels.  Maybe
>  > >>>           
>  >      later eh
>  > >>>
>  > >>>           
> <mailto:TI994A-fullfeatured%40yahoogroups.com>
>  >
>  >
>  >
> 
>

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 8 Jan 2010 17:21:12 -0600

I use the IDS10 device, connected to my Geneve and to my home network, then transfer files between the PC and Geneve using XP's hyperterminal and PORT, respectively.  Fred's TIDIR has been handy to add TIFILES headers where needed, and transferring Ymodem-G has its advantages in speed.  

I suppose some day I need to modify PORT to stop it from adding an extension to each file; the same may be true of the Richard's BBS, come to think of it.  I'll have to check the code there, too.   With long filename support prevalant, there is no real need for 8.3 filenames and the angst it brings to the TIFILES header. 

Tim

> From: [email-masked]
> Date: Fri, 8 Jan 2010 15:46:05 -0700
 		 	   		  
_________________________________________________________________
Hotmail: Trusted email with powerful SPAM protection.
http://clk.atdmt.com/GBL/go/196390707/direct/01/

---

From: fdos <[email-masked]>
Date: Fri, 08 Jan 2010 16:42:53 -0700

Tim,

Originally, I too used PORT at 38,400bps using hardware hand-shaking 
when I had my Geneve connected to my Linux LAN Server via a 4 port 
Communications server (hooked up, but not in use yet).  Later I went to 
MFM and didn't mind the drop to 19.2Kbps due to how friendly the user 
interface is.  I was archiving the files I transferred anyway, so no 
filename(s) issue either.

Bill S

Insane Multitasker wrote:
>  
> 
> I use the IDS10 device, connected to my Geneve and to my home 
> network, then transfer files between the PC and Geneve using XP's 
> hyperterminal and PORT, respectively.  Fred's TIDIR has been handy to 
> add TIFILES headers where needed, and transferring Ymodem-G has its 
> advantages in speed. 
>  
> I suppose some day I need to modify PORT to stop it from adding an 
> extension to each file; the same may be true of the Richard's BBS, come 
> to think of it.  I'll have to check the code there, too.   With long 
> filename support prevalant, there is no real need for 8.3 filenames and 
> the angst it brings to the TIFILES header. 
>  
> Tim
>  
>  
>  
>  > > I was talking over the se rial port, as we were talking MFM.
>  > > > lost a PC floppy disk controller in the past, so I want an
>  > > > alternati ve
>  > > &g t; > Subject: Re: [TI994A] Re:
>  > > > Mattel keyboard
> & gt; > > help. You just let me know what you need done, and
>  > > > > I would be
>  > > > <http://Opry99er.com <http://Opry99er.com>&g t;
>  > > > >
>  > > > > On Jan 8, 2010,
>  > > > correct. It's like listening to an
>  > > > emulator play SID mu sic
>  > > > >> versus a SID
>  > > > To: "TI994A@yahoogroups .com"
>  > > > ; <TI994A@yahoogroups. com>
>  > > > >>
>  > > > & gt;>
> &g t; > > ---> in all the players I've looked at,
>  > > > the main focus
>  > > > >>>
>  > > > was on playing the
>  > > > >>>
>  > > > 9900 has no anal og for. Luckily it's
>  > > > unlikely to be used.
>  > > > >>>
>  > > > >>>
>  > > > >>>
>  > > &g t; >>>
>  > > & gt; am I talking about music files in other
>  > > > formats (for now
>  > > > >>>
>  > > > at least....)
>  > > > >>>
>  > > > >>>
>  > > > on my C=64 (sorry TI loy alists... ) and
>  > > > about 20 music
>  > > > >>>
>  > > > t ranslation maybe, not
> &g t; > > >
> Hotmail: Trusted email with powerful SPAM protection. Sign up now. 
> <http://clk.atdmt.com/GBL/go/196390707/direct/01/>
>