Subject: ftp.whtech.com torrent

From: "Tony Knerr" <[email-masked]>
Date: Tue, 03 Nov 2009 22:15:01 -0000

I think it's time to resurrect this idea now that there are more members here than the original few when I first brought it up.

First of all, I've been in contact with Don O'Neil regarding the idea.
He has given the ok to distribute the files from ftp.whtech.com in a torrent, including the directory structure.

Why do this? So an individual can easily have all the files from the site on their pc in the same directory structure as the site, without the effort involved to download each file individually from the site. 

I assume some of you don't know what a torrent is, so here's the basic idea:

It's a file sharing system.
There's a 'control' file that the user downloads, it's got a .torrent file extension, which includes the information about all the files in the torrent. It's generally a small file.
The user loads the .torrent file into their torrent client, or program. I use "utorrent", as it seems to be the best one for large groups of files.
That's basically all you have to do. The torrent client creates the directory structure in a directory of your choice, downloads all the files in the torrent from other torrent participants and allows you to upload the files you have to the others. 
As files are added to the website, the torrent can be easily updated so users can download only the updated files.

So in order to get this started, we need willing participants, hopefully one of which already has all the files from the site.
That person will be the initial "seeder" or uploader. Once several users have the completed torrent, downloading becomes extremely fast.

I've heard from a few members already. Bob C has an older set of CD's which we can use to get started if we have to, but an up-to-date set is preferable. Richard B as well as myself have volunteered to be 24/7 seeders.

So who can help with the project?

Tony

---

From: fdos <[email-masked]>
Date: Tue, 03 Nov 2009 15:29:53 -0700

Tony,

My last WHTECH update from Don is one DVD and one CD-ROM from 4-15-2003, 
so also not very recent.  FYI I know nothing about torrent.

Bill S

Tony Knerr wrote:
>  
> 
> I think it's time to resurrect this idea now that there are more members 
> here than the original few when I first brought it up.
> 
> He has given the ok to distribute the files from ftp.whtech.com in a 
> torrent, including the directory structure.
> 
> Why do this? So an individual can easily have all the files from the 
> site on their pc in the same directory structure as the site, without 
> the effort involved to download each file individually from the site.
> 
> There's a 'control' file that the user downloads, it's got a .torrent 
> file extension, which includes the information about all the files in 
> the torrent. It's generally a small file.
> The user loads the .torrent file into their torrent client, or program. 
> I use "utorrent", as it seems to be the best one for large groups of files.
> That's basically all you have to do. The torrent client creates the 
> directory structure in a directory of your choice, downloads all the 
> files in the torrent from other torrent participants and allows you to 
> upload the files you have to the others.
> As files are added to the website, the torrent can be easily updated so 
> users can download only the updated files.
> 
> So in order to get this started, we need willing participants, hopefully 
> one of which already has all the files from the site.
> That person will be the initial "seeder" or uploader. Once several users 
> have the completed torrent, downloading becomes extremely fast.
> 
> I've heard from a few members already. Bob C has an older set of CD's 
> which we can use to get started if we have to, but an up-to-date set is 
> preferable. Richard B as well as myself have volunteered to be 24/7 seeders.
>

---

From: tursi <[email-masked]>
Date: Tue, 3 Nov 2009 15:10:39 -0800 (PST)

> So who can help with the project?

Now that permission is granted... :)

I have a fairly high speed server with plenty of space. I can mirror the 
system and set up a seed this weekend if you guys want to start with that. 
I've mirrored whtech a few times over the years already anyway.

---

From: "Tony Knerr" <[email-masked]>
Date: Tue, 03 Nov 2009 23:15:23 -0000

--- In [email-masked], tursi <yahoogroup@...> wrote:
> ...
> ...

If you happened to be anywhere near me right now, you'd be getting a man hug. ;)

Tony

---

From: Owen Brand <[email-masked]>
Date: Tue, 3 Nov 2009 18:59:39 -0500

Awesome man.  I use bittorrent...  Is this compatible?

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "Tursi" <[email-masked]>
Date: Tue, 3 Nov 2009 20:03:13 -0500

> Awesome man.  I use bittorrent...  Is this compatible?

Yep. Bittorrent is the basic client, I still use Vuze, there are lots of 
compatible clients. :)

The mirror is progressing nicely, I'll update when it's done and publish 
the torrent.

---

From: ti99_forever <[email-masked]>
Date: Tue, 3 Nov 2009 17:22:51 -0800 (PST)

Sure, once someone starts seeding...

--- On Tue, 11/3/09, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: [TI994A] ftp.whtech.com torrent
To: [email-masked]
Date: Tuesday, November 3, 2009, 5:15 PM

    

Tony

---

From: "Tony Knerr" <[email-masked]>
Date: Wed, 04 Nov 2009 01:28:28 -0000

Nice work, Tursi.

It's probably a good time now to point out that people with CD's and
DVD's of the site, regardless of their age, won't need to download
all the files. Before starting the torrent, have your torrent client check the folder that your existing files are in first.
In utorrent this is done by a 'Force Re-check', I'm sure other clients have a similar function. This will allow you to just get the files you don't have. If you need help, just ask.

There's other stuff like 'Port Forwarding' involved, but no need to scare anyone off yet. :)

Tony

---

From: "Tursi" <[email-masked]>
Date: Tue, 3 Nov 2009 22:03:06 -0500

Question:

as far as I can tell, there's no real advantage to the MAX files over 
the PDF files that are now there.. do we want to leave them in the 
torrent for later filtering? Or does anyone object to my stripping them 
out now? I don't mind too much either way, but it'd be nice not to 
duplicate the disk space. :)

---

From: ti99_forever <[email-masked]>
Date: Tue, 3 Nov 2009 19:37:59 -0800 (PST)

I'd dump the MAX files from the torrent as long as a duplicate PDF exists for it.

--- On Tue, 11/3/09, Tursi <[email-masked]> wrote:

From: Tursi <[email-masked]>
Subject: Re: [TI994A] Re: ftp.whtech.com torrent
To: [email-masked]
Date: Tuesday, November 3, 2009, 10:03 PM

    
                  Question:

---

From: Owen Brand <[email-masked]>
Date: Tue, 3 Nov 2009 22:51:08 -0500

Agreed.  Not necessary to have dupes.  ***Question.  Once we have the  
torrent on our respective computers, we will have the ability to set  
up the directories as we see fit, correct?  The FTP site is a maze of  
insanity to me, and if I could set it up to suit my fancy, it would be  
very helpful.  Not saying I can do better than anyone else, but I
Could certainly make it more useful for ME.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Tue, 3 Nov 2009 22:59:46 -0500

Of course if it were to be switched around, the torrent updates would  
reset it to the standard configuration... Right?  Probably the best  
course of action would be to take all the files, save them to DVD, and  
then manually update my DVD as new files become available... This  
would in turn negate part of the usefulness of the torrent anyway... I  
think I just answered my own question

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "Tursi" <[email-masked]>
Date: Tue, 3 Nov 2009 23:05:21 -0500

Well, Torrents don't continually update, once you have it all, it's 
yours. However, if you move files around, you won't be able to seed it 
any more. That's one issue with this... we can get it to people, but 
every reorg is going to be a bit of a pain. :)

Of course, if you just want a local copy, that's cool too, and you 
aren't restricted then. :)