Subject: New poll for TI994A

From: [email-masked]
Date: 24 Nov 2009 05:10:47 -0000

Enter your vote today!  A new poll has been created for the 
TI994A group:

Should we make the message archives public on this list server?

Tony had created a poll in the past, but now that we have more members, with Tony's blessing, let's discuss again the pro's and the con's to making the messages public.  Please take time to read and respond to this poll.

Pros:

a) The archives are available to outsiders (without logging in) so they can determine whether they want to join this group
b) Google will index this, so it'll be a lot easier to use their search function than Yahoo's
c) The RSS feed for the group will be publicly available, and those of us with RSS Aggregators (such as Newsgator, Google Reader, etc) will be able to keep up with the group.
d) People will probably find this group via Google and other search engines

Cons:

a) Discussions will be visible to non-members
b) You will have to login to read messages.

Since Yahoo masks the e-mail addresses of everyone whether you are logged in or not, the only risks of our addresses getting harvested are from people who subscribe to the list and get the actual e-mails/digests with the unmasked addresses.

I am submitting this poll with Tony's blessing, and the outcome will directly affect how this group will be configured.

Thank you for your time and consideration.

  o Yes 
  o No 

To vote, please visit the following web page:
http://groups.yahoo.com/group/TI994A/surveys?id=2250752 

Note: Please do not reply to this message. Poll votes are 
not collected via email. To vote, you must go to the Yahoo! Groups 
web site listed above.

Thanks!

---

From: "hexbus" <[email-masked]>
Date: Tue, 24 Nov 2009 18:09:12 -0000

Everyone,

I created this poll to see if we can open up the group a little.  We really have nothing to hide, and keeping it closed means that we can't use RSS readers, and we make it hard for newer folks to find us through search engines.  As our technology keeps getting older and older, we lose people, and we need to continue to gain folks so that our vision and future doesn't dim as time passes.

Thanks :)
Jon

---

From: fdos <[email-masked]>
Date: Tue, 24 Nov 2009 11:17:08 -0700

Jon,

You and Tony can decide as far as I'm concerned.  I don't want to log in 
just to vote in a poll.  No that I'm disinterested--it's precious time 
that concerns me due to all that I have on my plate to do.

Bill S

hexbus wrote:
>  
> 
> Everyone,
> 
> I created this poll to see if we can open up the group a little. We 
> really have nothing to hide, and keeping it closed means that we can't 
> use RSS readers, and we make it hard for newer folks to find us through 
> search engines. As our technology keeps getting older and older, we lose 
> people, and we need to continue to gain folks so that our vision and 
> future doesn't dim as time passes.
> 
> Thanks :)
> Jon
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, 
> [email-masked] <mailto:TI994A%40yahoogroups.com> wrote:
>  >
>  >
>  > Tony had created a poll in the past, but now that we have more 
> members, with Tony's blessing, let's discuss again the pro's and the 
> con's to making the messages public. Please take time to read and 
> respond to this poll.
>  >
>  > Pros:
>  >
>  > a) The archives are available to outsiders (without logging in) so 
> they can determine whether they want to join this group
>  > c) The RSS feed for the group will be publicly available, and those 
> of us with RSS Aggregators (such as Newsgator, Google Reader, etc) will 
> be able to keep up with the group.
>  > Since Yahoo masks the e-mail addresses of everyone whether you are 
> logged in or not, the only risks of our addresses getting harvested are 
> from people who subscribe to the list and get the actual e-mails/digests 
> with the unmasked addresses.
>  >
>  > I am submitting this poll with Tony's blessing, and the outcome will 
> directly affect how this group will be configured.
>  >
> <http://groups.yahoo.com/group/TI994A/surveys?id=2250752>
>  >

---

From: Owen Brand <[email-masked]>
Date: Tue, 24 Nov 2009 14:05:30 -0500

I didn't vote in the first poll on this issue, but I voted in the  
affirmative this time around... If we are trying to grow our base, we  
need a publically accessible forum.  I vote "yea"

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 24, 2009, at 1:09 PM, "hexbus" <[email-masked]> wrote:

> really have nothing to hide, and keeping it closed means that we  
> can't use RSS readers, and we make it hard for newer folks to find  
> us through search engines. As our technology keeps getting older and  
> older, we lose people, and we need to continue to gain folks so that  
> our vision and future doesn't dim as time passes.
>
> Thanks :)
> Jon
>
> > c) The RSS feed for the group will be publicly available, and  
> those of us with RSS Aggregators (such as Newsgator, Google Reader,  
> etc) will be able to keep up with the group.
> logged in or not, the only risks of our addresses getting harvested  
> are from people who subscribe to the list and get the actual e-mails/ 
> digests with the unmasked addresses.
> >
> > I am submitting this poll with Tony's blessing, and the outcome  
> will directly affect how this group will be configured.
> >

---

From: "Postle" <[email-masked]>
Date: Tue, 24 Nov 2009 19:13:24 -0000

I do membership in telescope groups.  Almost all if not most have gone by the way side with death by smut postings.  I don't know if this is because of the the lack of participation by the owner's and moderator's.  Or...  If stuff is or just did happen.  A reason I liked the other OLUG as this did not happen.  When it did there was corrections and removals.  Legislators, Congressmen, Senators state and federal in a society where honesty and integrity no longer exists.  Souls and votes offered up to the highest bidder.  Sorry  to move from subject matter to off topic.  If an open group offers a place for the aforementioned, then leave it closed.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: "kabldb" <[email-masked]>
Date: Tue, 24 Nov 2009 19:16:09 -0000

We had a poll with much the same question created Nov. 7.

Let's keep this a secret society. We have to be different. Don't we ?

:-)

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 24 Nov 2009 13:26:53 -0600

If the poll is voted affirmative this time around, when will the tie-breaker poll be created?   ;)
 
> From: [email-masked]
> To: [email-masked]
> Date: Tue, 24 Nov 2009 05:10:47 +0000
> Subject: [TI994A] New poll for TI994A
> 
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
> 
 		 	   		  
_________________________________________________________________
Windows 7: It works the way you want. Learn more.
http://www.microsoft.com/Windows/windows-7/default.aspx?ocid=PID24727::T:WLMTAGL:ON:WL:en-US:WWL_WIN_evergreen:112009v2

---

From: Brian Tristam Williams <[email-masked]>
Date: Tue, 24 Nov 2009 21:30:28 +0200

Secret Schmecret. It's not like what we're indulged in is hot property. What
is this fetish of furtiveness? Go public. Get out there! How are we meant to
be found by passionate ex-TIers around the world if we're gonna play cloak
and dagger? This is not a game.

2009/11/24 kabldb <[email-masked]>

> --- In [email-masked] <TI994A%40yahoogroups.com>, "hexbus" <jon@...>
> wrote:
> >
> > Everyone,
> >
> really have nothing to hide, and keeping it closed means that we can't use
> RSS readers, and we make it hard for newer folks to find us through search
> engines. As our technology keeps getting older and older, we lose people,
> and we need to continue to gain folks so that our vision and future doesn't
> dim as time passes.
> >
> > Thanks :)
> > Jon
> >
> > --- In [email-masked] <TI994A%40yahoogroups.com>,
> [email-masked] <TI994A%40yahoogroups.com> wrote:
> > >
> > >
> > > Tony had created a poll in the past, but now that we have more members,
> with Tony's blessing, let's discuss again the pro's and the con's to making
> the messages public. Please take time to read and respond to this poll.
> > >
> > > Pros:
> > >
> > > a) The archives are available to outsiders (without logging in) so they
> can determine whether they want to join this group
> > > c) The RSS feed for the group will be publicly available, and those of
> us with RSS Aggregators (such as Newsgator, Google Reader, etc) will be able
> to keep up with the group.
> logged in or not, the only risks of our addresses getting harvested are from
> people who subscribe to the list and get the actual e-mails/digests with the
> unmasked addresses.
> > >

-- 
Brian Tristam Williams

"One man can make a difference."

---

From: "Jon P Vogel" <[email-masked]>
Date: Tue, 24 Nov 2009 13:34:00 -0600

People might be getting confused on the group settings here.

Just because this group might be set as "open" for reading does not mean 
that it needs to be set to "open" for writing.  Tony can continue to approve 
all membership requests and he can continue to only allow members to post. 
This would keep the SPAM down.  Anyone who violates the posting rules can be 
banned from the group and posting rights removed.

So, to summarize:  opening up the group for public reading does not mean it 
has to be open for public writing.

Here is how I set up the TI99er Group:

Posting Options

      Who can post:    Members
      Reply-to:    All members
      Moderation:    New members
      Attachments:    Exclude from site and emails
      What's This?  Spam Filtering:    On

Archive Options        Access:    Anyone

As you can see, this setup allows maximum flexibility with maximum 
protection.

Regards,

Jon

From: "Postle" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, November 24, 2009 1:13 PM
Subject: [TI994A] Re: New poll for TI994A

>I do membership in telescope groups.  Almost all if not most have gone by 
>the way side with death by smut postings.  I don't know if this is because 
>of the the lack of participation by the owner's and moderator's.  Or...  If 
>stuff is or just did happen.  A reason I liked the other OLUG as this did 
>not happen.  When it did there was corrections and removals.  Legislators, 
>Congressmen, Senators state and federal in a society where honesty and 
>integrity no longer exists.  Souls and votes offered up to the highest 
>bidder.  Sorry  to move from subject matter to off topic.  If an open group 
>offers a place for the aforementioned, then leave it closed.
>
> Postle

---

From: Marc Hull <[email-masked]>
Date: Tue, 24 Nov 2009 11:36:26 -0800 (PST)

Excellent point !

--- On Tue, 11/24/09, Brian Tristam Williams <[email-masked]> wrote:

From: Brian Tristam Williams <[email-masked]>
Subject: Re: [TI994A] Re: New poll for TI994A
To: [email-masked]
Date: Tuesday, November 24, 2009, 1:30 PM

  

      Secret Schmecret. It's not like what we're indulged in is hot property. What is this fetish of furtiveness? Go public. Get out there! How are we meant to be found by passionate ex-TIers around the world if we're gonna play cloak and dagger? This is not a game.

2009/11/24 kabldb <kabldb@yahoo. dk>

  

:-)

--- In TI994A@yahoogroups. com, "hexbus" <jon@...> wrote:

> --- In TI994A@yahoogroups. com, TI994A@yahoogroups. com wrote:

> > http://groups. yahoo.com/ group/TI994A/ surveys?id= 2250752 

    

  

-- 
Brian Tristam Williams

---

From: Marc Hull <[email-masked]>
Date: Tue, 24 Nov 2009 11:35:46 -0800 (PST)

Bill.

That is exactly what caused the dysfunction of the other group!  One person unilaterally deciding the fate of many based on allegiances, friendship and politics is ill advised.  Surely you vote in elections and surely you have the minute it would take to log in....

--- On Tue, 11/24/09, fdos <[email-masked]> wrote:

From: fdos <[email-masked]>
Subject: Re: [TI994A] Re: New poll for TI994A
To: [email-masked]
Date: Tuesday, November 24, 2009, 12:17 PM

Jon,

Bill S

hexbus wrote:
>  >
>  >
>  > Enter your vote today! A new poll has been created for the
>  > TI994A group:
>  >
>  > Should we make the message archives public on this list server?
>  >
>  > Tony had created a poll in the past, but now that we have more 
>  >
>  > Pros:
>  >
>  > a) The archives are available to outsiders (without logging in) so 
>  > b) Google will index this, so it'll be a lot easier to use their 
> search function than Yahoo's
>  > c) The RSS feed for the group will be publicly available, and those 
>  > d) People will probably find this group via Google and other search 
> engines
>  >
>  > Cons:
>  >
>  > a) Discussions will be visible to non-members
>  > b) You will have to login to read messages.
>  >
>  > Since Yahoo masks the e-mail addresses of everyone whether you are 
>  >
>  > I am submitting this poll with Tony's blessing, and the outcome will 
>  >
>  > Thank you for your time and consideration.
>  >
>  >
>  > o Yes
>  > o No
>  >
>  >
>  > To vote, please visit the following web page:
>  > http://groups.yahoo.com/group/TI994A/surveys?id=2250752 
>  >
>  > Note: Please do not reply to this message. Poll votes are
>  > not collected via email. To vote, you must go to the Yahoo! Groups
>  > web site listed above.
>  >
>  > Thanks!
>  >
> 
> 

Yahoo! Groups Links

---

From: "killroy732000" <[email-masked]>
Date: Tue, 24 Nov 2009 20:18:51 -0000

I voted "yes", there is a lot of valuable information in here,
no reason to keep it secret. 

Filip

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
>
> Excellent point !
> 
> --- On Tue, 11/24/09, Brian Tristam Williams <briantw@...> wrote:
> 
> From: Brian Tristam Williams <briantw@...>
> Â 
> Â 
> --- In TI994A@yahoogroups. com, "hexbus" <jon@> wrote:
> 
> >
> 
> > Everyone,
> 
> > 
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 24 Nov 2009 15:29:10 -0500

Yea... My thoughts exactly

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 24, 2009, at 3:18 PM, "killroy732000" <filip.van- 
[email-masked]> wrote:

> > Secret Schmecret. It's not like what we're indulged in is hot  
> property. What is this fetish of furtiveness? Go public. Get out  
> there! How are we meant to be found by passionate ex-TIers around  
> the world if we're gonna play cloak and dagger? This is not a game.
> >
> >
> > > I created this poll to see if we can open up the group a little.  
> We really have nothing to hide, and keeping it closed means that we  
> > > > a) The archives are available to outsiders (without logging  
> in) so they can determine whether they want to join this group
> >
> > > > Since Yahoo masks the e-mail addresses of everyone whether you  
> are logged in or not, the only risks of our addresses getting  
> harvested are from people who subscribe to the list and get the  
> actual e-mails/digests with the unmasked addresses.
> >
> >
> > > >
> >
> > > > I am submitting this poll with Tony's blessing, and the  
> outcome will directly affect how this group will be configured.
> >
> > > >
> >

---

From: fdos <[email-masked]>
Date: Tue, 24 Nov 2009 13:36:25 -0700

OK, I vote NO preference.

Bill S

Marc Hull wrote:
>  
> 
> Bill.
> 
> That is exactly what caused the dysfunction of the other group!  One 
> person unilaterally deciding the fate of many based on allegiances, 
> friendship and politics is ill advised.  Surely you vote in elections 
> and surely you have the minute it would take to log in....
> 
> 
> 
> 
> 
> --- On *Tue, 11/24/09, fdos /<[email-masked]>/* wrote:
> 
> 
>     can't
>      > --- In [email-masked]
>     </mc/compose?to=[email-masked]>
>     <mailto:TI994A%40yahoogroups.com>,
>      > [email-masked] </mc/compose?to=[email-masked]>
>     <mailto:TI994A%40yahoogroups.com> wrote:
>      >  >
>      >  >
>     in) so
>     those
>      >  > d) People will probably find this group via Google and other
>     search
>      > engines
>      >  >
>      >  > Cons:
>      >  >
>     are
>     outcome will
>      > <http://groups.yahoo.com/group/TI994A/surveys?id=2250752
>     <http://groups.yahoo.com/group/TI994A/surveys?id=2250752>>
>      >  >
>         (Yahoo! ID required)
>         [email-masked]
>     </mc/compose?to=[email-masked]>
> 
> 
> 
>

---

From: "Tony Knerr" <[email-masked]>
Date: Tue, 24 Nov 2009 20:39:42 -0000

Just to clear up what may be a misunderstanding, this is a public group. The name is listed in the Yahoo directory, and to check it I did a search - the group did come up in the results. 

While on the subject, I've tried to add the group to the TI web ring, with the result being only the little "hosted by web ring" button showing up. Apparently the html code they supplied isn't compatible with Yahoo. For a price, they'll do it for you, but I'm cheap and ain't goin' that way. Anyone with some html skill want to take a crack at it?
The code they supplied is below. Of course Yahoo will probably reformat it. :(

Tony 

<center><script type="text/javascript"
src="http://ss.webring.com/navbar?f=j;y=tonyknerr;u=defurl"></script>
Powered by <a href="http://dir.webring.com/rw" target=_top>WebRing</a>.</center>

<!--optional-->
<noscript><center><table bgcolor=gray cellspacing=0 border=2 bordercolor=red>
<tr><td><table cellpadding=2 cellspacing=0 border=0><tr><td align=center>
<font face=arial size=-1>This site is a member of WebRing. 
To browse visit <a href="http://ss.webring.com/navbar?f=l;y=tonyknerr;u=defurl">
here</a>.</font></td></tr></table></td></tr></table></center></noscript>

---

From: "hexbus" <[email-masked]>
Date: Tue, 24 Nov 2009 21:06:44 -0000

Yep.  The only thing we would be changing is that the message base would be publicly accessible for reading.  This means that people could read the posts here, but not write before joining.

This also enables anonymous (without logging in) ability to read the message base, as well as enables RSS readers (such as Google Reader) to work with the message base.

Without it, we're published and there, but until someone joins and gets approved, in essence, we are a secret society... (Skull and Bones society?) :-)

Jon

---

From: fdos <[email-masked]>
Date: Tue, 24 Nov 2009 14:44:40 -0700

BTW Yes, I do vote in elections as that is my duty as a citizen of this 
great nation, and I take that duty very seriously.  However, there are 
some issues that I pass on as they are not my concern, and if I flipped 
a coin and voted on them I would be diluting the vote for those it does 
concern and effect.

Bill S

---

From: "Postle" <[email-masked]>
Date: Tue, 24 Nov 2009 22:21:31 -0000

The group came forward and the lights came on.  Yes, means read only.  Members only can  post.  Okay, its a good idea.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: Marc Hull <[email-masked]>
Date: Tue, 24 Nov 2009 16:33:14 -0800 (PST)

Hmmmmm.... So your saying you would let a guy like me decide your fate ?  Sounds ill advised....

From: fdos <[email-masked]>
Subject: Re: [TI994A] Re: New poll for TI994A
To: [email-masked]
Date: Tuesday, November 24, 2009, 2:36 PM

Bill S

Marc Hull wrote:
>      > Everyone,
>      > I created this poll to see if we can open up the group a little. We
>      > really have nothing to hide, and keeping it closed means that we
>     can't
>      > use RSS readers, and we make it hard for newer folks to find us
>     through
>      > search engines. As our technology keeps getting older and older,
>     we lose
>      > people, and we need to continue to gain folks so that our vision and
>      > future doesn't dim as time passes.
>      >
>      > Thanks :)
>      > Jon
>      >
>      > --- In [email-masked]
>      > [email-masked] </mc/compose?to=[email-masked]>
>      >  >
>      >  >
>      >  > Enter your vote today! A new poll has been created for the
>      >  > TI994A group:
>      >  >
>      >  > Should we make the message archives public on this list server?
>      >  >
>      >  > Tony had created a poll in the past, but now that we have more
>      > members, with Tony's blessing, let's discuss again the pro's and the
>      > con's to making the messages public. Please take time to read and
>      > respond to this poll.
>      >  >
>      >  > Pros:
>      >  >
>      >  > a) The archives are available to outsiders (without logging
>     in) so
>      > they can determine whether they want to join this group
>      >  > b) Google will index this, so it'll be a lot easier to use their
>      > search function than Yahoo's
>      >  > c) The RSS feed for the group will be publicly available, and
>     those
>      > of us with RSS Aggregators (such as Newsgator, Google Reader,
>     etc) will
>      > be able to keep up with the group.
>      >  > d) People will probably find this group via Google and other
>     search
>      > engines
>      >  >
>      >  > Cons:
>      >  >
>      >  > a) Discussions will be visible to non-members
>      >  > b) You will have to login to read messages.
>      >  >
>      >  > Since Yahoo masks the e-mail addresses of everyone whether you
>     are
>      > logged in or not, the only risks of our addresses getting
>     harvested are
>      > from people who subscribe to the list and get the actual
>     e-mails/digests
>      > with the unmasked addresses.
>      >  >
>      >  > I am submitting this poll with Tony's blessing, and the
>     outcome will
>      > directly affect how this group will be configured.
>      >  >
>      >  > Thank you for your time and consideration.
>      >  >
>      >  >
>      >  > o Yes
>      >  > o No
>      >  >
>      >  >
>      >  > To vote, please visit the following web page:
>      >  > http://groups.yahoo.com/group/TI994A/surveys?id=2250752
>      > <http://groups.yahoo.com/group/TI994A/surveys?id=2250752
>      >  >
>      >  > Note: Please do not reply to this message. Poll votes are
>      >  > not collected via email. To vote, you must go to the Yahoo! Groups
>      >  > web site listed above.
>      >  >
>      >  > Thanks!
>      >  >
>      >
>      >
> 
> 

Yahoo! Groups Links

---

From: fdos <[email-masked]>
Date: Tue, 24 Nov 2009 18:21:50 -0700

Marc,

Pray tell, where is my fate involved in this matter?  Why do you believe 
that you're the only one voting?  How is it that you don't understand 
that it does not matter to me by which means this group will be 
available to the public and others?  I get the e-mail messages from this 
group, and I can send e-mail messages to this group.  I'm very happy! :-)

Bill S

Marc Hull wrote:
>      > --- On *Tue, 11/24/09, fdos /<[email-masked]
>     </mc/compose?to=[email-masked]>>/* wrote:
>      >
>      >
>      >     From: fdos <[email-masked]
>     </mc/compose?to=[email-masked]>>
>      >      > use RSS readers, and we make it hard for newer folks to
>     find us
>      >     through
>      >      > search engines. As our technology keeps getting older and
>     older,
>      >     we lose
>      >     </mc/compose?to=[email-masked]
>     </mc/compose?to=[email-masked]>>
>      >      > [email-masked]
>     </mc/compose?to=[email-masked]> </mc/compose?to=TI994A
>     @yahoogroups.com </mc/compose?to=[email-masked]>>
>      >      >  > b) Google will index this, so it'll be a lot easier to
>     use their
>     <http://groups.yahoo.com/group/TI994A/surveys?id=2250752>>>
>      >      >  >
>      >     </mc/compose?to=[email-masked]
>     </mc/compose?to=[email-masked]>>
>      >
>      >
>      >
>      >
> 
>

---

From: Keith Bergman <[email-masked]>
Date: Tue, 24 Nov 2009 20:51:19 -0500

Can we start a "who thinks you should quit picking on Bill?" poll?  :)

On Tue, Nov 24, 2009 at 8:21 PM, fdos <[email-masked]> wrote:

> >      >     You and Tony can decide as far as I'm concerned.  I don't want
> to
> >      >     log in
> >      >     <mailto:TI994A%40yahoogroups.com <TI994A%2540yahoogroups.com>
> >,
> >      >      > [email-masked]
> >      >     <mailto:TI994A%40yahoogroups.com <TI994A%2540yahoogroups.com>>
> wrote:
> >      >      >  >
> >      >      >  >
> >      >      > of us with RSS Aggregators (such as Newsgator, Google
> Reader,
> >      >     etc) will

---

From: Marc Hull <[email-masked]>
Date: Tue, 24 Nov 2009 18:48:05 -0800 (PST)

Well actually Bill.... I haven't voted.   Hmmmm....mind sending me the link ?   

From: fdos <[email-masked]>
Subject: Re: [TI994A] Re: New poll for TI994A
To: [email-masked]
Date: Tuesday, November 24, 2009, 7:21 PM

Marc,

Bill S

Marc Hull wrote:
>      > Bill.
>      > That is exactly what caused the dysfunction of the other group!  One
>      > person unilaterally deciding the fate of many based on allegiances,
>      > friendship and politics is ill advised.  Surely you vote in
>     elections
>      > and surely you have the minute it would take to log in....
>      >
>      >
>      >
>      >
>      >
>      > --- On *Tue, 11/24/09, fdos /<[email-masked]
>      >     From: fdos <[email-masked]
>      >     Subject: Re: [TI994A] Re: New poll for TI994A
>      >     To: [email-masked]
>      >     Date: Tuesday, November 24, 2009, 12:17 PM
>      >
>      >     Jon,
>      >
>      >     You and Tony can decide as far as I'm concerned.  I don't want to
>      >     log in
>      >     just to vote in a poll.  No that I'm disinterested--it's
>     precious time
>      >     that concerns me due to all that I have on my plate to do.
>      >
>      >     Bill S
>      >
>      >     hexbus wrote:
>      >      >
>      >      >
>      >      > Everyone,
>      >      >
>      >      > I created this poll to see if we can open up the group a
>     little. We
>      >      > really have nothing to hide, and keeping it closed means
>     that we
>      >     can't
>      >      > use RSS readers, and we make it hard for newer folks to
>     find us
>      >     through
>      >      > search engines. As our technology keeps getting older and
>     older,
>      >     we lose
>      >      > people, and we need to continue to gain folks so that our
>     vision and
>      >      > future doesn't dim as time passes.
>      >      >
>      >      > Thanks :)
>      >      > Jon
>      >      >
>      >      > --- In [email-masked]
>      >     </mc/compose?to=[email-masked]
>      >     <mailto:TI994A%40yahoogroups.com>,
>      >      > [email-masked]
>      >     <mailto:TI994A%40yahoogroups.com> wrote:
>      >      >  >
>      >      >  >
>      >      >  > Enter your vote today! A new poll has been created for the
>      >      >  > TI994A group:
>      >      >  >
>      >      >  > Should we make the message archives public on this list
>     server?
>      >      >  >
>      >      >  > Tony had created a poll in the past, but now that we
>     have more
>      >      > members, with Tony's blessing, let's discuss again the
>     pro's and the
>      >      > con's to making the messages public. Please take time to
>     read and
>      >      > respond to this poll.
>      >      >  >
>      >      >  > Pros:
>      >      >  >
>      >      >  > a) The archives are available to outsiders (without logging
>      >     in) so
>      >      > they can determine whether they want to join this group
>      >      >  > b) Google will index this, so it'll be a lot easier to
>     use their
>      >      > search function than Yahoo's
>      >      >  > c) The RSS feed for the group will be publicly
>     available, and
>      >     those
>      >      > of us with RSS Aggregators (such as Newsgator, Google Reader,
>      >     etc) will
>      >      > be able to keep up with the group.
>      >      >  > d) People will probably find this group via Google and
>     other
>      >     search
>      >      > engines
>      >      >  >
>      >      >  > Cons:
>      >      >  >
>      >      >  > a) Discussions will be visible to non-members
>      >      >  > b) You will have to login to read messages.
>      >      >  >
>      >      >  > Since Yahoo masks the e-mail addresses of everyone
>     whether you
>      >     are
>      >      > logged in or not, the only risks of our addresses getting
>      >     harvested are
>      >      > from people who subscribe to the list and get the actual
>      >     e-mails/digests
>      >      > with the unmasked addresses.
>      >      >  >
>      >      >  > I am submitting this poll with Tony's blessing, and the
>      >     outcome will
>      >      > directly affect how this group will be configured.
>      >      >  >
>      >      >  > Thank you for your time and consideration.
>      >      >  >
>      >      >  >
>      >      >  > o Yes
>      >      >  > o No
>      >      >  >
>      >      >  >
>      >      >  > To vote, please visit the following web page:
>      >      >  > http://groups.yahoo.com/group/TI994A/surveys?id=2250752
>      >      > <http://groups.yahoo.com/group/TI994A/surveys?id=2250752
>      >      >  >
>      >      >  > Note: Please do not reply to this message. Poll votes are
>      >      >  > not collected via email. To vote, you must go to the
>     Yahoo! Groups
>      >      >  > web site listed above.
>      >      >  >
>      >      >  > Thanks!
>      >      >  >
>      >      >
>      >      >
>      >
>      >
>      >     ------------------------------------
>      >
>      >     Yahoo! Groups Links
>      >
>      >
>      >         (Yahoo! ID required)
>      >
>      >         [email-masked]
>      >     </mc/compose?to=[email-masked]

Yahoo! Groups Links

---

From: Keith Bergman <[email-masked]>
Date: Wed, 25 Nov 2009 02:25:08 -0500

So are you drunk, or is this your way of boldly calling out "the takers" as
you so longed to do the other night?

On Wed, Nov 25, 2009 at 2:23 AM, kabldb <[email-masked]> wrote:

>
>
> I think I might be voting by postal mail. Just thought I let you all know.
>
> :-)
>
> --- In [email-masked] <TI994A%40yahoogroups.com>, Marc Hull
> <marc.hull@...> wrote:
> >
> > --- On Tue, 11/24/09, fdos <fdosbrs@...> wrote:
> >
> > From: fdos <fdosbrs@...>
> > To: [email-masked] <TI994A%40yahoogroups.com>
> > > --- On *Tue, 11/24/09, fdos /<fdosbrs@...>/* wrote:
> > >
> > >
> > >     From: fdos <fdosbrs@...>
> > >     To: [email-masked] <TI994A%40yahoogroups.com>
> > >      > --- On *Tue, 11/24/09, fdos /<fdosbrs@...
> > >     </mc/compose?to=fdosbrs@...>>/* wrote:
> > >      >
> > >      >
> > >      >     From: fdos <fdosbrs@...
> > >     </mc/compose?to=fdosbrs@...>>
> > >      >     To: [email-masked] <TI994A%40yahoogroups.com>
> > >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A%40yahoogroups.com>
> >
> > >      >     You and Tony can decide as far as I'm concerned.  I don't
> want to
> > >      >     log in
> > >      >      > --- In [email-masked] <TI994A%40yahoogroups.com>
> > >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A%40yahoogroups.com>
> >
> > >      >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A%40yahoogroups.com>
> > >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A%40yahoogroups.com>
> >>
> > >      >     <mailto:TI994A%40yahoogroups.com<TI994A%2540yahoogroups.com>
> >,
> > >      >      > [email-masked] <TI994A%40yahoogroups.com>
> > >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A%40yahoogroups.com>>
> </mc/compose?to=TI994A
> > >     @yahoogroups.com </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A%40yahoogroups.com>
> >>
>  > >      >     <mailto:TI994A%40yahoogroups.com<TI994A%2540yahoogroups.com>>
> wrote:
> > >      >      >  >
> > >      >      >  >
> > >      >      >  > Should we make the message archives public on this
> list
> > >     server?
> > >      >      >  >
> > >      >         [email-masked]<TI994A-fullfeatured%40yahoogroups.com>
> > >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A-fullfeatured%40yahoogroups.com>
> >
> > >      >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A-fullfeatured%40yahoogroups.com>
> > >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A-fullfeatured%40yahoogroups.com>
> >>
> > >      >
> > >      >
> > >      >
> > >      >
> > >
> > >
> > >         [email-masked]<TI994A-fullfeatured%40yahoogroups.com>
> > >     </mc/compose?to=[email-masked]<%2Fmc%2Fcompose%3Fto%3DTI994A-fullfeatured%40yahoogroups.com>
> >
> > >
> > >
> > >
> > >
> >
> >

---

From: Brian Tristam Williams <[email-masked]>
Date: Wed, 25 Nov 2009 09:54:55 +0200

Sorry if I was a bit harsh, but it irks me that we have the tiny rudiments
of a once-great community, and there are still calls to make it even more
exclusionary. We can get around moderation issues. Obvious spam is easily
deleted. Off-topics can be warned. And a bit of democracy doesn't hurt - we
could do online polls (form-based) :-)

In these days of Web 2.0 and social networking, we can't hide the stuff away
from those who are interested - we have to get it out there! Ok, well, I
suppose we can, but in that case I'm taking my ball and going off to make a
group just for me :p

2009/11/25 kabldb <[email-masked]>

>
>
> So it not a game, and it's not hot property. So what is it ? Just another
> copycat list ? For what reasons ? So another moderator can have his fun ?
>
> Whatever. No big deal to me.
>
> :-)
>
>
> --- In [email-masked] <TI994A%40yahoogroups.com>, Brian Tristam
> Williams <briantw@...> wrote:
> >
> > 2009/11/24 kabldb <kabldb@...>
>
> >
> > >
> > >
> > > --- In [email-masked] <TI994A%40yahoogroups.com> <TI994A%
> 40yahoogroups.com>, "hexbus" <jon@>
>
> > > wrote:
> > > >
> > > > Everyone,
> > > >
> use
> > > > --- In [email-masked] <TI994A%40yahoogroups.com> <TI994A%
> 40yahoogroups.com>,
>
> > > [email-masked] <TI994A%40yahoogroups.com> <TI994A%
> 40yahoogroups.com> wrote:
> > > > >
> > > > >
> members,
> they
> > > > > b) Google will index this, so it'll be a lot easier to use their
> search
> > > function than Yahoo's
> of
> from
> will

-- 
Brian Tristam Williams

---

From: ti99_forever <[email-masked]>
Date: Wed, 25 Nov 2009 00:00:28 -0800 (PST)

I'll be glad when the politics are over and we get back down to business. Didn't come here for politics & polls.
In the meantime, maybe we can move the more important discussions about software and programming to swpb...

--- On Wed, 11/25/09, Brian Tristam Williams <[email-masked]> wrote:

From: Brian Tristam Williams <[email-masked]>
Subject: Re: [TI994A] Re: New poll for TI994A
To: [email-masked]
Date: Wednesday, November 25, 2009, 2:54 AM

 

Sorry if I was a bit harsh, but it irks me that we have the tiny rudiments of a once-great community, and there are still calls to make it even more exclusionary. We can get around moderation issues. Obvious spam is easily deleted. Off-topics can be warned. And a bit of democracy doesn't hurt - we could do online polls (form-based) :-)

In these days of Web 2.0 and social networking, we can't hide the stuff away from those who are interested - we have to get it out there! Ok, well, I suppose we can, but in that case I'm taking my ball and going off to make a group just for me :p

 

    

      So it not a game, and it's not hot property. So what is it ? Just another copycat list ? For what reasons ? So another moderator can have his fun ?

:-)

--- In [email-masked], Brian Tristam Williams <briantw@...> wrote:

> > --- In [email-masked] <TI994A%40yahoogroups.com>, "hexbus" <jon@>

> > > > b) Google will index this, so it'll be a lot easier to use their search

> > > > d) People will probably find this group via Google and other search

    

  

-- 
Brian Tristam Williams

---

From: Brian Tristam Williams <[email-masked]>
Date: Wed, 25 Nov 2009 10:15:18 +0200

Hear, hear!

2009/11/25 ti99_forever <[email-masked]>

> --- On *Wed, 11/25/09, Brian Tristam Williams <[email-masked]>*wrote:
>
>
> In these days of Web 2.0 and social networking, we can't hide the stuff
> away from those who are interested - we have to get it out there! Ok, well,
> I suppose we can, but in that case I'm taking my ball and going off to make
> a group just for me :p
>
> 2009/11/25 kabldb <[email-masked] <http://mc/compose?to=[email-masked]>>
>
>>
>>
>> --- In [email-masked]<http://mc/compose?to=TI994A%40yahoogroups.com>,
>> Brian Tristam Williams <briantw@...> wrote:
>> >
>> > > --- In [email-masked]<http://mc/compose?to=TI994A%40yahoogroups.com><TI994A%
>> > > > --- In [email-masked]<http://mc/compose?to=TI994A%40yahoogroups.com><TI994A%
>> 40yahoogroups.com>,
>>
>> > > [email-masked]<http://mc/compose?to=TI994A%40yahoogroups.com><TI994A%
>> those of
>> are from

-- 
Brian Tristam Williams

---

From: mark wills <[email-masked]>
Date: Wed, 25 Nov 2009 00:52:23 -0800 (PST)

...working on my Forth project.

Sorry guys. I seem to jump between projects! It just depends which takes my interest at the time. I wish I could concentrate on one and just get it finished... Oh well, that's the nice thing about *hobby* programming I guess :-)

It's taking shape nicely.

Yesterday, in an old Forth article, I came across a Forth word called PAIRS? The word compares the top two stack items, and returns true (-1) if they are the same, or false (0) if they are different.

In my Forth, there are at least three ways to write that word:

: PAIRS? DUP ROT DUP -ROT = ;

That works nicely:

10 20 PAIRS? . <press enter>
0 ok
10 10 PAIRS? . <press enter>
-1 ok

Hmmm... Is there a more efficient way without stack juggling? Yes:

: PAIRS? OVER OVER = ;
10 20 PAIRS? .
0 ok
99 99 PAIRS? .
-1 ok

Cool. Is there an even more efficient way? Yep:

: PAIRS? 2DUP = . ;
10 20 PAIRS? .
0 ok
99 99 PAIRS? .
-1 ok

COOL!

It's nice to know (and see) my little Forth engine behaving logically and correctly with all three solutions.

I then did a fancy one:

: PAIRS? 2DUP = IF ." SAME" ELSE ." DIFFERENT" THEN CR ;
10 20 PAIRS?
DIFFERENT
ok
99 99 PAIRS?
SAME
ok

Oh yeah!

Ok, so now on to disk access. I already have it creating a disk blocks file:

MKDSK DSK2.BLOCKS 80

This creates an 80K block file (Forth source is stored in blocks, but you can store anything you want in them).

Next word to do: BLOCK - for example:

23 BLOCK

Will load block 23 from the currently USEd block file: USE DSK2.BLOCKS *IF* if it is not in memory. If it is in memory, it does nothing - no disk access - it's intelligent.

You can have up to 6 blocks in RAM at any time. If it needs to load the block from disk and there is no space, it will replace one of the blocks in memory with the new one. If the block that is about to be overwritten is 'dirty' (i.e. has been changed in RAM, meaning the copy on disk is out of date) then it is first FLUSHed back to disk. It's all automatic and taken care of for you.

I've written USE and tested it. I've also written BLOCK, but not tested it. I wrote it in China about 3 months ago so I will have to re-visit the code and see how it works. No doubt I'll discover some optimisations at the same time. I normally do. ("Who wrote this crap? Oh. It was me!")

Mark.

---

From: ti99_forever <[email-masked]>
Date: Wed, 25 Nov 2009 01:53:54 -0800 (PST)

Yep, been following that thread on comp.lang.forth, nice to see the hijackers haven't taken over your thread yet!

I, too, have come across a couple of interesting programs in Forth Dimensions from back then that I have printed out and stored in my backpack, for when I am bored. Unfortunately, I have plenty to do at the moment.

Drifting is fun, but it can be hard to finish something that way! But I'm not the one to lecture, not at all! ;)

--- On Wed, 11/25/09, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: [TI994A] Today I am... FORTHing
To: [email-masked]
Date: Wednesday, November 25, 2009, 3:52 AM

That works nicely:

-1
 ok

: PAIRS? OVER OVER = ;
10 20 PAIRS? .
0 ok
99 99 PAIRS? .
-1 ok

: PAIRS? 2DUP = . ;
10 20 PAIRS? .
0 ok
99 99 PAIRS? .
-1 ok

COOL!

I then did a fancy one:

Oh yeah!

MKDSK DSK2.BLOCKS 80

23 BLOCK

Will load block 23 from the currently USEd block file: USE
 DSK2.BLOCKS *IF* if it is not in memory. If it is in memory, it does nothing - no disk access - it's intelligent.

Mark.

---

From: mark wills <[email-masked]>
Date: Wed, 25 Nov 2009 04:58:26 -0800 (PST)

Hmmm... My code path isn't following the path I thought it would... A return address being corrupted somewhere methinks...

Classic99 debugger to the rescue ;-)

>
>From: ti99_forever <[email-masked]>
>Sent: Wed, 25 November, 2009 10:53:54
>Subject: Re: [TI994A] Today I am... FORTHing
>
> >
>
>
>
>
>  >
>>      
> 
>--- On Wed, 11/25/09, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>From: mark wills <markrobertwills@ yahoo.co. uk>
>>To: TI994A@yahoogroups. com

---

From: fdos <[email-masked]>
Date: Wed, 25 Nov 2009 08:44:26 -0700

Mark,

Now reading this is what I call real hobby fun!  I'm very glad you're 
having such great fun with Forth.

May the Forth be with you.

Bill S

mark wills wrote:
> Sorry guys. I seem to jump between projects! It just depends which takes 
> my interest at the time. I wish I could concentrate on one and just get 
> it finished... Oh well, that's the nice thing about *hobby* programming 
> I guess :-)
> 
> Yesterday, in an old Forth article, I came across a Forth word called 
> PAIRS? The word compares the top two stack items, and returns true (-1) 
> if they are the same, or false (0) if they are different.
> 
> This creates an 80K block file (Forth source is stored in blocks, but 
> you can store anything you want in them).
> 
> Will load block 23 from the currently USEd block file: USE DSK2.BLOCKS 
> *IF* if it is not in memory. If it is in memory, it does nothing - no 
> disk access - it's intelligent.
> 
> You can have up to 6 blocks in RAM at any time. If it needs to load the 
> block from disk and there is no space, it will replace one of the blocks 
> in memory with the new one. If the block that is about to be overwritten 
> is 'dirty' (i.e. has been changed in RAM, meaning the copy on disk is 
> out of date) then it is first FLUSHed back to disk. It's all automatic 
> and taken care of for you.
> 
> I've written USE and tested it. I've also written BLOCK, but not tested 
> it. I wrote it in China about 3 months ago so I will have to re-visit 
> the code and see how it works. No doubt I'll discover some optimisations 
> at the same time. I normally do. ("Who wrote this crap? Oh. It was me!")
> 
> Mark.
>

---

From: fdos <[email-masked]>
Date: Wed, 25 Nov 2009 09:00:45 -0700

Sorry to hear about your trouble in fun land.  Best wishes for a 
successful recovery.

Bill S

mark wills wrote:
>  
> 
> Hmmm... My code path isn't following the path I thought it would... A 
> return address being corrupted somewhere methinks...
> 
>     *From:* ti99_forever <[email-masked]>
>     *To:* [email-masked]
>     *Sent:* Wed, 25 November, 2009 10:53:54
>     *Subject:* Re: [TI994A] Today I am... FORTHing
> 
>      
> 
>     Yep, been following that thread on comp.lang.forth, nice to see the
>     hijackers haven't taken over your thread yet!
> 
>     I, too, have come across a couple of interesting programs in Forth
>     Dimensions from back then that I have printed out and stored in my
>     backpack, for when I am bored. Unfortunately, I have plenty to do at
>     the moment.
> 
>     Drifting is fun, but it can be hard to finish something that way!
>     But I'm not the one to lecture, not at all! ;)
> 
> 
>     --- On *Wed, 11/25/09, mark wills /<markrobertwills@ yahoo.co. uk>/*
>     wrote:
> 
> 
>         Sorry guys. I seem to jump between projects! It just depends
>         which takes my interest at the time. I wish I could concentrate
>         on one and just get it finished... Oh well, that's the nice
>         thing about *hobby* programming I guess :-)
> 
>         Yesterday, in an old Forth article, I came across a Forth word
>         called PAIRS? The word compares the top two stack items, and
>         returns true (-1) if they are the same, or false (0) if they are
>         different.
> 
>         It's nice to know (and see) my little Forth engine behaving
>         logically and correctly with all three solutions.
> 
>         I then did a fancy one:
> 
>         This creates an 80K block file (Forth source is stored in
>         blocks, but you can store anything you want in them).
> 
>         DSK2.BLOCKS *IF* if it is not in memory. If it is in memory, it
>         does nothing - no disk access - it's intelligent.
> 
>         You can have up to 6 blocks in RAM at any time. If it needs to
>         load the block from disk and there is no space, it will replace
>         one of the blocks in memory with the new one. If the block that
>         is about to be overwritten is 'dirty' (i.e. has been changed in
>         RAM, meaning the copy on disk is out of date) then it is first
>         FLUSHed back to disk. It's all automatic and taken care of for you.
> 
>         I've written USE and tested it. I've also written BLOCK, but not
>         tested it. I wrote it in China about 3 months ago so I will have
>         to re-visit the code and see how it works. No doubt I'll
>         discover some optimisations at the same time. I normally do.
>         ("Who wrote this crap? Oh. It was me!")
> 
>         Mark.
> 
> 
> 
>

---

From: Owen Brand <[email-masked]>
Date: Wed, 25 Nov 2009 12:10:46 -0500

I found some system disks for something called "Super Forth" today  
along with 2 big 3 ring binders with Forth documentation and some TI  
Forth info pages as well.  Bill, Mark--- you guys familiar with Super  
Forth?

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 25, 2009, at 11:00 AM, fdos <[email-masked]> wrote:

>>        Ok, so now on to disk access. I already have it creating a  
>> disk
>>        blocks file:
>>
>>        MKDSK DSK2.BLOCKS 80
>>

---

From: fdos <[email-masked]>
Date: Wed, 25 Nov 2009 11:51:40 -0700

Owen,

Yes, I have Super 4th from DataBioTics, Inc.  It was developed by Jim 
Wray and Edgar Dohmann of the Johnson Space Center Users Group.  I was 
also communicating with Edgar Dohmann during the development, and made 
several suggestions that were used, and a few that were not used, in the 
released product.

I used it for several years on my Myarc WDS-100 hard disk system, but 
once Mike McCann released TI Forth for MDOS, I brought the useful stuff 
over to the Geneve, and never looked back.  It is just a set of 
enhancements to TI Forth--requires Super Cart, and that is the reason 
for the name.  There are some useful enhancements, and some not so 
useful enhancements.  It does, however, make it a little easier for the 
novice to learn Forth.

If you have any specific questions please ask.

Bill S

Owen Brand wrote:
> On Nov 25, 2009, at 11:00 AM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  >> *From:* ti99_forever <[email-masked] 
> <mailto:ti99_forever%40yahoo.com>>
>  >> *To:* [email-masked] <mailto:TI994A%40yahoogroups.com>

---

From: "computerclassics2000" <[email-masked]>
Date: Wed, 25 Nov 2009 19:02:28 -0000

A niece piece of historical trivia. Thanks!!!

--- In [email-masked], fdos <fdosbrs@...> wrote:
> > On Nov 25, 2009, at 11:00 AM, fdos <fdosbrs@... 
> >  >> *From:* ti99_forever <ti99_forever@...

---

From: fdos <[email-masked]>
Date: Wed, 25 Nov 2009 13:42:05 -0700

Thanks.  I'm glad I managed to say something meaningful.  My old gray 
matter is not totally gone after all.

Bill S

computerclassics2000 wrote:
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, fdos 
> <fdosbrs@...> wrote:
>  >
>  > Owen,
>  >
> <mailto:TI994A%40yahoogroups.com>

---

From: mark wills <[email-masked]>
Date: Thu, 26 Nov 2009 00:28:41 -0800 (PST)

Good progress.

Blocks can be loaded from disk into one of 4 block buffers.

If I change a few bytes in a buffer and set that buffers' 'dirty' flag, then type FLUSH, the buffer is written back to disk in the correct place, and the buffer freed for re-use.

Cool!

So far so good. 

Need to check edge cases and see if there are any gotchas. I'm impressed with the code I wrote in China though - It was a lonely sunday in my hotel. I wrote all the file handling in one hit (in assembler), plus some other stuff, but by the afternoon my brain was swimming and I didn't have the energy to test it.

I made one silly error - put a label in the wrong place. Other than that (so far) all the file IO code has worked first time.

Amazing! I could *not* have done this without the Classic99 debugger though... How those guys did it in the 80's with just a TI is beyond me... Patience of saints...

I have 1.3K left in the 8K cartridge space. Assembler (and Forth) is remarkably compact. There are currently 178 words defined at power up. In addition, there is the compiler, console stuff (cursor handling, screen scrolling, keyboard handling) utilities, file io etc etc. 

The majority of the Forth words are written in assembler. They're fast. Some are written in Forth. It actually bends peoples minds when you say that Forth can be written in Forth, but it can. Anyway, the only ones written in Forth are ones that I consider to be not speed critical: DUMP : ; QUIT etc. All stack, math, comparison words and the like are written in assembly. Some flow control words are written in Forth, but there is no speed penalty. This is because (in Forth parlance) they are 'immediate' words, and actually run at *compile* time (they modify your code), not run time. They add code to your code, which is run at run-time. Mind-bending for a while, but clever.

Forth seriously rocks. And to think, Chuck Moore had all this down in 1970.

Things to do:

1) Implement a backspace (delete) facility at the command line (it's harder than it sounds, which is why I have left it so long!)
2) Block editor (hope it will fit - it will be very simple - you could always load another one from disk ;-)
3) Support loading source in from disk (can only load source via the keyboard at the moment)
4) 80 column support (space permitting - the infrastructure: screen scrolling, cursor handling etc is already built to support it)
5) 32 column mode - as above
6) Impliment MEANING_OF_LIFE? routine... Tricky one... (answer is 42)

If I go over 8K I don't know what I'm going to do. I mean, if I have to go to 16K then I have a lot more space - I could include hi res graphics primitives and sprite routines (currently there are no graphics commands at all, but all the primitives are there to implement them, including words like VDP@ (VDP fetch) and VDP! (VDP store). But it will also mean extensive re-factoring to a certain extent to handle bank-switching.

Hmmm... I guess a better approach would be to split the functionality of the two banks... Put the compiler, the block editor, and disk IO in the second bank. This would free up space in the main bank, meaning bank switching would only occur for non-speed essential operations...

Lot's of things to consider...

Hope you don't mind me brain-dumping like this. I didn't see the point in a blog for this project, since it's a good way in already... The list seems a good a place as any...

Mark

---

From: Owen Brand <[email-masked]>
Date: Thu, 26 Nov 2009 08:22:31 -0500

Brilliant, mate!  Although, I personally think you should go 16 k...  
Make it all you can right off the top... If that pushes the ETA by 6  
months, who gives a shit... Cuz this is something that has never  
existed before---I say do it as perfectly as you can... I would love  
to use your Forth cart to write games... But can't do that without  
SPRITEs or hi-res graphics.... By the way, VDP@ and VDP!... Are these  
just like VSBW, VSBR, VMBW, VMBR?

Definitely keep us posted... "The Forth us stroooong in this one..."

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 26, 2009, at 3:28 AM, mark wills <[email-masked]>  
wrote:

> If I change a few bytes in a buffer and set that buffers' 'dirty'  
> flag, then type FLUSH, the buffer is written back to disk in the  
> correct place, and the buffer freed for re-use.
>
> Cool!
>
> So far so good.
>
> Need to check edge cases and see if there are any gotchas. I'm  
> impressed with the code I wrote in China though - It was a lonely  
> sunday in my hotel. I wrote all the file handling in one hit (in  
> assembler), plus some other stuff, but by the afternoon my brain was  
> swimming and I didn't have the energy to test it.
>
> I made one silly error - put a label in the wrong place. Other than  
> that (so far) all the file IO code has worked first time.
>
> Amazing! I could *not* have done this without the Classic99 debugger  
> though... How those guys did it in the 80's with just a TI is beyond  
> me... Patience of saints...
>
> I have 1.3K left in the 8K cartridge space. Assembler (and Forth) is  
> remarkably compact. There are currently 178 words defined at power  
> up. In addition, there is the compiler, console stuff (cursor  
> handling, screen scrolling, keyboard handling) utilities, file io  
> etc etc.
>
> The majority of the Forth words are written in assembler. They're  
> fast. Some are written in Forth. It actually bends peoples minds  
> when you say that Forth can be written in Forth, but it can. Anyway,  
> the only ones written in Forth are ones that I consider to be not  
> speed critical: DUMP : ; QUIT etc. All stack, math, comparison words  
> and the like are written in assembly. Some flow control words are  
> written in Forth, but there is no speed penalty. This is because (in  
> Forth parlance) they are 'immediate' words, and actually run at  
> *compile* time (they modify your code), not run time. They add code  
> to your code, which is run at run-time. Mind-bending for a while,  
> but clever.
>
> 1) Implement a backspace (delete) facility at the command line (it's  
> harder than it sounds, which is why I have left it so long!)
> 2) Block editor (hope it will fit - it will be very simple - you  
> could always load another one from disk ;-)
> 4) 80 column support (space permitting - the infrastructure: screen  
> scrolling, cursor handling etc is already built to support it)
> If I go over 8K I don't know what I'm going to do. I mean, if I have  
> to go to 16K then I have a lot more space - I could include hi res  
> graphics primitives and sprite routines (currently there are no  
> graphics commands at all, but all the primitives are there to  
> implement them, including words like VDP@ (VDP fetch) and VDP! (VDP  
> store). But it will also mean extensive re-factoring to a certain  
> extent to handle bank-switching.
>
> Hmmm... I guess a better approach would be to split the  
> functionality of the two banks... Put the compiler, the block  
> editor, and disk IO in the second bank. This would free up space in  
> the main bank, meaning bank switching would only occur for non-speed  
> essential operations...
>
> Hope you don't mind me brain-dumping like this. I didn't see the  
> point in a blog for this project, since it's a good way in  
> already... The list seems a good a place as any...
>
> Mark
>
>
>

---

From: fdos <[email-masked]>
Date: Thu, 26 Nov 2009 08:42:40 -0700

Mark,

Most Forths only have 7 primitives written in AL.  After that most words 
are written in Forth (except for a few speed critical words), so you're 
going beyond the standard.  I also agree with your analysis and intent.

Keep in mind that my original Forth+ kernel was just under 11K, and most 
of the library functionality and virtual BLOCK BUFFERS were loaded as a 
binary code file from the boot screen buffer.  And even that file has a 
load screen for defining paths and setting a few variable values, and 
finally switching from the standard 7 x 1K BLOCK BUFFER zone to the 
virtual (up to 898 as I recall, version 2.0 up to 1024) BLOCK BUFFER 
zone (full 8K page of virtual 8 x buffers), and to the virtual 8K 
library system (only one in version 1.01 and two in version 2.00).

I think I've pointed out before that I know two ways of arranging bank 
switching for your cartridge Forth.  The choice would depend on what 
your final goal for your Forth is (Bill C can define "is" for you;-).

Keep at it and the Forth will be with you.

Bill S

mark wills wrote:
> If I change a few bytes in a buffer and set that buffers' 'dirty' flag, 
> then type FLUSH, the buffer is written back to disk in the correct 
> place, and the buffer freed for re-use.
> 
> Cool!
> 
> So far so good.
> 
> Need to check edge cases and see if there are any gotchas. I'm impressed 
> with the code I wrote in China though - It was a lonely sunday in my 
> hotel. I wrote all the file handling in one hit (in assembler), plus 
> some other stuff, but by the afternoon my brain was swimming and I 
> didn't have the energy to test it.
> 
> I made one silly error - put a label in the wrong place. Other than that 
> (so far) all the file IO code has worked first time.
> 
> remarkably compact. There are currently 178 words defined at power up. 
> In addition, there is the compiler, console stuff (cursor handling, 
> screen scrolling, keyboard handling) utilities, file io etc etc.
> 
> The majority of the Forth words are written in assembler. They're fast. 
> Some are written in Forth. It actually bends peoples minds when you say 
> that Forth can be written in Forth, but it can. Anyway, the only ones 
> written in Forth are ones that I consider to be not speed critical: DUMP 
> : ; QUIT etc. All stack, math, comparison words and the like are written 
> in assembly. Some flow control words are written in Forth, but there is 
> no speed penalty. This is because (in Forth parlance) they are 
> 'immediate' words, and actually run at *compile* time (they modify your 
> code), not run time. They add code to your code, which is run at 
> run-time. Mind-bending for a while, but clever.
> 
> If I go over 8K I don't know what I'm going to do. I mean, if I have to 
> go to 16K then I have a lot more space - I could include hi res graphics 
> primitives and sprite routines (currently there are no graphics commands 
> at all, but all the primitives are there to implement them, including 
> words like VDP@ (VDP fetch) and VDP! (VDP store). But it will also mean 
> extensive re-factoring to a certain extent to handle bank-switching.
> 
> Hmmm... I guess a better approach would be to split the functionality of 
> the two banks... Put the compiler, the block editor, and disk IO in the 
> second bank. This would free up space in the main bank, meaning bank 
> switching would only occur for non-speed essential operations...
> 
> Hope you don't mind me brain-dumping like this. I didn't see the point 
> in a blog for this project, since it's a good way in already... The list 
> seems a good a place as any...
> 
> Mark
> 
> 
>