Subject: First and last Hardware question this weekend

From: "Marc H" <[email-masked]>
Date: Fri, 13 Nov 2009 21:29:33 -0000

Ahhh. ya fell for it....First and last.....HA...

I am at a point of needing to incorporate a 245 logic chip and I believe I know a way to do it but not sure if it is the correct way.

My plan is to run my >ALL READY BUFFERED AND THEN INVERTED< WE* signal from the TI to the DIR pin on a 245.  Should this work?

---

From: "sconner3uk" <[email-masked]>
Date: Sat, 14 Nov 2009 19:52:54 -0000

It is more customary I believe to use the DBIN signal to control the direction of the buffers. Whether you use an inverted signal or not depends on which way you wire up the chip - inputs on the left or inputs on the right.

When interfacing memory, the controls signals I normally use are:

-- /MEMEN in conjunction with the required address lines to generate the /CS (chip select) signal for the memory and the /G signal for the data buffers.

-- DBIN for the memory /OE (output enable) and/or the data buffer /DIR signal.

-- /WE for the memory /WE input.

Another book you might want to look at - it deals specifically with the TMS9900:

<http://www.amazon.com/Build-Your-Working-16-Bit-Microcomputer/dp/0830698132>

Stuart.