Subject: Speech Synth oddity

From: "opry99er" <[email-masked]>
Date: Mon, 02 Nov 2009 02:06:29 -0000

As soon as I can get my stuff unpacked, I am going to post a pic of a Speech Synth I own that is fairly unique, I believe.  It has a small button on the back of it that seems to reset the console.  There are a series of small wires visible in the mysterious "door" of the Speech Synth that seem to facilitate this function.  My issue is, last time I packed up the thing and moved it, the functionality ceased to be useful.  It now just seems to freeze the console and it must be manually reset.  I am not sure why this happened, but I am interested in getting it operational
again.  Anyone hear of this mod and/or know how to recreate it?

---

From: "eolson22" <[email-masked]>
Date: Mon, 02 Nov 2009 05:00:51 -0000

It might be a LOAD interrupt switch. This was probably the easiest
expansion port project to do --the speech synth provided a nice
experimental board to piggyback onto. A small momentary switch
(preferably debounced) connects the LOAD interrupt line to ground,
causing the console to do a BLWP @FFFC (if I recall correctly). If you
don't have anything in particular loaded there, you might get lucky and
end up back at the title screen, but most likely you just lock up.
Some uses of this are: screen dump programs, assembly language debugger
"break" keys, and game cheats.
I wrote a game cheat for TI-Runner where pushing the button would cause
the hidden ladder to become visible. In a different form, this became a
simple ISR that automatically revealed the hidden ladder every 15
seconds, no button required.

--- In [email-masked], "opry99er" <owenbrand@...> wrote:
>
> As soon as I can get my stuff unpacked, I am going to post a pic of a
Speech Synth I own that is fairly unique, I believe.  It has a small
button on the back of it that seems to reset the console.  There are a
series of small wires visible in the mysterious "door" of the Speech
Synth that seem to facilitate this function.  My issue is, last time I
packed up the thing and moved it, the functionality ceased to be useful.
It now just seems to freeze the console and it must be manually reset. 
I am not sure why this happened, but I am interested in getting it
operational

---

From: mark wills <[email-masked]>
Date: Sun, 1 Nov 2009 21:25:01 -0800 (PST)

Yeah, almost certainly. It's a useful little tool if you are doing assembly programming.

Mark

>
>From: eolson22 <[email-masked]>
>To: [email-masked]
>Sent: Mon, 2 November, 2009 6:00:51
>Subject: [TI994A] Re: Speech Synth oddity
>
> >
>
>
>
>  
>>
>
>
>It might be a LOAD interrupt switch. This was probably the easiest expansion port project to do --the speech synth provided a nice experimental board to piggyback onto. A small momentary switch (preferably debounced) connects the LOAD interrupt line to ground, causing the console to do a BLWP @FFFC (if I recall correctly). If you don't have anything in particular loaded there, you might get lucky and end up back at the title screen, but most likely you just lock up. 
>
>
>Some uses of this are: screen dump programs, assembly language debugger "break" keys, and game cheats.
>
>
>I wrote a game cheat for TI-Runner where pushing the button would cause the hidden ladder to become visible. In a different form, this became a simple ISR that automatically revealed the hidden ladder every 15 seconds, no button required.
>
>
>
>
>
>--- In TI994A@yahoogroups. com, "opry99er" <owenbrand@.. .> wrote:
>>

---

From: Owen Brand <[email-masked]>
Date: Mon, 2 Nov 2009 00:26:48 -0500

So can I assume that it is not broken, but functioning properly... And  
that I simply misunderstood it's original purpose?

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 2, 2009, at 12:25 AM, mark wills <[email-masked]>  
wrote:

> causing the console to do a BLWP @FFFC (if I recall correctly). If  
> you don't have anything in particular loaded there, you might get  
> lucky and end up back at the title screen, but most likely you just  
> lock up.
>
> Some uses of this are: screen dump
>  programs, assembly language debugger "break" keys, and game cheats.
>
> I wrote a game cheat for TI-Runner where pushing the button would  
> cause the hidden ladder to become visible. In a different form, this  
> became a simple ISR that automatically revealed the hidden ladder  
> every 15 seconds, no button required.
>
>
>
> > As soon as I can get my stuff unpacked, I am going to post a pic  
> of a Speech Synth I own that is fairly unique, I believe. It has a  
> small button on the back of it that seems to reset the console.  
> There are a series of small wires visible in the mysterious "door"  
> of the Speech Synth that seem to facilitate this function. My issue  
> is, last time I packed up the thing and moved it, the functionality  
> ceased to be useful. It now just seems to freeze the console and it  
> must be manually reset. I am not sure why this happened, but I am  
> interested in getting it operational

---

From: Gregory McGill <[email-masked]>
Date: Sun, 1 Nov 2009 21:29:18 -0800

Yep it's most likely a Load Interrupt. I have a snazzy little board that
goes between with a button on it for mine. And theres one on the back of the
corcomp clock sidecar too.  I used to use mine to print game screens.. had a
little assy program you loaded in to ram and then hit the LI button in a
cartridge game and it'd output the screen to the printer.

Greg

On Sun, Nov 1, 2009 at 9:26 PM, Owen Brand <[email-masked]> wrote:

>
>
> So can I assume that it is not broken, but functioning properly... And that
> I simply misunderstood it's original purpose?
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
>

---

From: Owen Brand <[email-masked]>
Date: Mon, 2 Nov 2009 00:35:50 -0500

Fascinating...  Thanks for the info.  I have some research to do on  
LOAD interrupt I guess.  Any pix available of your setup and/or uses  
of the LOAD interrupt with the printer linkup?

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 2, 2009, at 12:29 AM, Gregory McGill <[email-masked]>  
wrote:

> Yep it's most likely a Load Interrupt. I have a snazzy little board  
> that goes between with a button on it for mine. And theres one on  
> the back of the corcomp clock sidecar too.  I used to use mine to  
> print game screens.. had a little assy program you loaded in to ram  
> and then hit the LI button in a cartridge game and it'd output the  
> screen to the printer.
>
> Greg
>
>
> So can I assume that it is not broken, but functioning properly...  
> And that I simply misunderstood it's original purpose?
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
>
>

---

From: mark wills <[email-masked]>
Date: Sun, 1 Nov 2009 21:38:15 -0800 (PST)

Yep. FFFC to FFFF probably contain 0's, so it will just reset I think.

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Mon, 2 November, 2009 6:26:48
>Subject: Re: [TI994A] Re: Speech Synth oddity
>
> >
>
>
>
>  
>So can I assume that it is not broken, but functioning properly... And that I simply misunderstood it's original purpose?
>
>Owen Brand
>**Oprysoft**
>Opry99er.com
>
>On Nov 2, 2009, at 12:25 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>
>>
>>  >> 
>>>From: eolson22 <[email-masked]. com>
>>>To: TI994A@yahoogroups. com
>>>Subject: >>> [TI994A] Re: Speech Synth oddity
>>>
>>>  >>> 
>>>>>>
>>>
>>>

---

From: ti99_forever <[email-masked]>
Date: Sun, 1 Nov 2009 21:41:29 -0800 (PST)

If you choose to learn assembly, it is great for debugging. IIRC, the TI Debug program set up the LOAD vector to call itself. And if I don't, it is an easy mod.
So if your program freaks, you hit the button and look at the workspace registers to see where you came from...

--- On Mon, 11/2/09, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: Speech Synth oddity
To: "[email-masked]" <[email-masked]>
Date: Monday, November 2, 2009, 12:26 AM

    
                  So can I assume that it is not broken, but functioning properly... And that I simply misunderstood it's original purpose?
Owen Brand**Oprysoft**Opry99er.com
On Nov 2, 2009, at 12:25 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:

Mark

From: eolson22 <[email-masked]. com>
To: TI994A@yahoogroups. com
Sent: Mon, 2 November, 2009 6:00:51
Subject:
 [TI994A] Re: Speech Synth oddity

---

From: Gregory McGill <[email-masked]>
Date: Sun, 1 Nov 2009 21:41:12 -0800

ftp://ftp.whtech.com/datasheets%20and%20manuals/Hardware/CorComp/corcomp%20load%20interrupt%20switch%20manual.pdf

On Sun, Nov 1, 2009 at 9:35 PM, Owen Brand <[email-masked]> wrote:

>
>
> Fascinating...  Thanks for the info.  I have some research to do on LOAD
> interrupt I guess.  Any pix available of your setup and/or uses of the LOAD
> interrupt with the printer linkup?
>
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
>>  <http://Opry99er.com>Opry99er.com
>>
>>
>   
>