Subject: Re: [TI994A] One stop shop (was IDE)

From: mark wills <[email-masked]>
Date: Wed, 4 Nov 2009 03:06:55 -0800 (PST)

>I know, I'm a scab ...

Yeah, but we still love ya!

>
>From: kabldb <[email-masked]>
>To: [email-masked]
>Sent: Wed, 4 November, 2009 11:12:00
>Subject: [TI994A] One stop shop (was IDE)
>
> >
>
>
>
>  
>TommyGun is indeed nice. And I might very well use it when it supports 9918A.
>
>>An IDE normally consists of
>
>>* a source code editor 
>>* a compiler and/or an interpreter 
>>* build automation tools 
>>* a debugger
>
>http://en.wikipedia .org/wiki/ Integrated_ development_ environment
>
>>For an IDE (I'm a kid in a sweetshop) I would like things like breakpoints (normally set in source), single stepping, that quick step into, the lovely step over, most wonderful local watches etc.
>
>>I know, I'm a scab ...
>
>>--- In TI994A@yahoogroups. com, Owen Brand <owenbrand@. ..> wrote:
>
>>I asked Tony a few questions about his program that a couple of you raised...  He started by saying there was not a native emulator (which I asked him). The rest of the email is below.  Peace.
>
>>You can use any emulator you like, best if it supports command line arguments. TommyGun is not just a graphics design program, it is intended as a one stop shop for all game creation. It falls short of this because I have not completed the sound creation editor(s). So at the moment it does graphics, maps, string tables and source code. It also translates your graphics, maps, string tables (and eventually sounds) in code for you. Make a change to a sprite and hit the run emulator button, and if you have the options selected TommyGun will update your source code, rebuild the program and run it for you. No other IDE for retro game development does that for you.
>
>
> > >

---

From: ti99_forever <[email-masked]>
Date: Wed, 4 Nov 2009 03:27:46 -0800 (PST)

Reminds me of my first IDE - QuickC, circa 1986/87 (Microsoft!). What a wonderful IDE that was. Had everything you mention below. It set the standard for me.
I did get to play with Turbo Pascal, and it wasn't even close

--- On Wed, 11/4/09, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] One stop shop (was IDE)
To: [email-masked]
Date: Wednesday, November 4, 2009, 6:06 AM

    

From: kabldb <kabldb@yahoo. dk>
To: TI994A@yahoogroups. com
Sent: Wed, 4 November, 2009 11:12:00
Subject: [TI994A] One stop shop (was
 IDE)

* a source code editor 

* build automation tools 

* a debugger

I know, I'm a scab ...

---

From: mark wills <[email-masked]>
Date: Wed, 4 Nov 2009 03:34:15 -0800 (PST)

Yeah, QuickBasic was every bit as good, almost identical. And ran very well even on the most lowly PCs.

>
>From: ti99_forever <[email-masked]>
>Sent: Wed, 4 November, 2009 12:27:46
>Reminds me of my first IDE - QuickC, circa 1986/87 (Microsoft!) . What a wonderful IDE that was. Had everything you mention below. It set the standard for me.
>--- On Wed, 11/4/09, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>From: mark wills <markrobertwills@ yahoo.co. uk>

---

From: "ti99_forever" <[email-masked]>
Date: Wed, 04 Nov 2009 12:08:32 -0000

I was running QuickC on a PC Factory XT, with NEC V20 chip (*almost* 8mz). It flew...

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> >From: ti99_forever <ti99_forever@...>
> >>>>>>--- In TI994A@yahoogroups. com, Owen Brand <owenbrand@ ..> wrote:
> >>>

---

From: fdos <[email-masked]>
Date: Wed, 04 Nov 2009 07:21:20 -0700

Gee!  The only professional software development I ever did was in 
QuickBasic 4.0 in the very early '90's.  It was so large I had to use 
overlays.  The QuickBasic compiler didn't include that capability, so I 
had to use one from PocketSoft.  It was still a little "buggy", so I 
submitted a Bug report.  They didn't accept it to begin with, but 
eventually I was able to convince them, and received the first upgrade 
for beta testing--it worked.  I don't recall what the "bug" was so don't 
ask.

Bill S

mark wills wrote:
>     *From:* ti99_forever <[email-masked]>
>     *To:* [email-masked]
>     *Sent:* Wed, 4 November, 2009 12:27:46
>     *Subject:* Re: [TI994A] One stop shop (was IDE)
> 
>      
> 
>     Reminds me of my first IDE - QuickC, circa 1986/87 (Microsoft!) .
>     What a wonderful IDE that was. Had everything you mention below. It
>     set the standard for me.
>     --- On *Wed, 11/4/09, mark wills /<markrobertwills@ yahoo.co. uk>/*
>     wrote:
> 
> 
>             *From:* kabldb <kabldb@yahoo. dk>
>             *To:* TI994A@yahoogroups. com
>             *Sent:* Wed, 4 November, 2009 11:12:00
>             *Subject:* [TI994A] One stop shop (was IDE)
> 
>              
> 
>             <http://en.wikipedia.org/wiki/Integrated_development_environment>
> 
>             For an IDE (I'm a kid in a sweetshop) I would like things
>             like breakpoints (normally set in source), single stepping,
>             that quick step into, the lovely step over, most wonderful
>             local watches etc.
> 
>             I know, I'm a scab ...
> 
>             I asked Tony a few questions about his program that a couple
>             of you raised... He started by saying there was not a native
>             emulator (which I asked him). The rest of the email is
>             below. Peace.
> 
>             You can use any emulator you like, best if it supports
>             command line arguments. TommyGun is not just a graphics
>             design program, it is intended as a one stop shop for all
>             game creation. It falls short of this because I have not
>             completed the sound creation editor(s). So at the moment it
>             does graphics, maps, string tables and source code. It also
>             translates your graphics, maps, string tables (and
>             eventually sounds) in code for you. Make a change to a
>             sprite and hit the run emulator button, and if you have the
>             options selected TommyGun will update your source code,
>             rebuild the program and run it for you. No other IDE for
>             retro game development does that for you.
> 
> 
>