Subject: 'JH' Bug in Asm99a V3.009

From: "sconner3uk" <[email-masked]>
Date: Mon, 14 Dec 2009 21:39:24 -0000

Just following up on Tursi's post on the 99er forum (<http://www.99er.net/cgi-bin/ikonboard/ikonboard.cgi?act=ST;f=17;t=6>) about the JH instruction generating the wrong opcode in Asm99a V3.009. [I don't have an account on 99er.net and I don't want to set up *yet another* user name and password ...  ;-)]

This bug isn't in V3.008 that I am using. Looking at WinAsm99.exe with a hex editor, there is a table of opcode values. In V3.008, the opcode value for the JH instruction is at byte 0x246E1. This byte has the value >1B, and if I change this and save the file then it changes the opcode value for the assembled JH instruction. So you might be able to use this technique to correct the bug in V3.009. (The address of the byte to change is probably different in V3.009. Looking at V3.008, the table of opcode values is just before another table of the mnemonics - all interspersed with various other bytes but immediately recognisable if you view the data as both hex and ASCII. Trace through both tables locating opcode value with mnemonic to find the byte for the JH instruction.)

Stuart.

---

From: mark wills <[email-masked]>
Date: Mon, 14 Dec 2009 21:03:34 -0800 (PST)

Damn. I didn't know that. Thanks for posting about it here.

I've just looked at my Forth source: Guess what, in 20 source files (150K of source) I don't use the JH instruction anywhere.

I wonder why? Do I have a particular programming 'style' I wonder?

I just looked in my source code for handling double length numbers. I was sure there would be a JH or two in there, but no, I used JOC and JNC.

I then searched the listing file... Not used ANYWHERE in 5151 lines of source code!

Makes me think I could be missing something... :-(

I believe our very own Mr. Bray has a direct channel of communication with Cory Burr. He may be able to get a message to Cory with the view to a patch being released. Would you be willing to do that Eric?

Stuart, did you notice the enchanced assembly instructions in the assembler, as documented in the PDFs that accompany Win994A? There's some lovely instructions in there, shame the real TI doesn't have them!

Mark

>
>From: sconner3uk <[email-masked]>
>To: [email-masked]
>Sent: Mon, 14 December, 2009 22:39:24
>Subject: [TI994A] 'JH' Bug in Asm99a V3.009
>
> >
>
>
>
>
>  >
>>      
> 
>Just following up on Tursi's post on the 99er forum (<http://www.99er. net/cgi-bin/ ikonboard/ ikonboard. cgi?act=ST; f=17;t=6>) about the JH instruction generating the wrong opcode in Asm99a V3.009. [I don't have an account on 99er.net and I don't want to set up *yet another* user name and password ...  ;-)]
>
>>This bug isn't in V3.008 that I am using. Looking at WinAsm99.exe with a hex editor, there is a table of opcode values. In V3.008, the opcode value for the JH instruction is at byte 0x246E1. This byte has the value >1B, and if I change this and save the file then it changes the opcode value for the assembled JH instruction. So you might be able to use this technique to correct the bug in V3.009. (The address of the byte to change is probably different in V3.009. Looking at V3.008, the table of opcode values is just before another table of the mnemonics - all interspersed with various other bytes but immediately recognisable if you view the data as both hex and ASCII. Trace through both tables locating opcode value with mnemonic to find the byte for the JH instruction. )
>
>>Stuart.
>
>
>

---

From: "Tursi" <[email-masked]>
Date: Tue, 15 Dec 2009 00:23:02 -0500

> I believe our very own Mr. Bray has a direct channel of communication with 
> Cory Burr. He may be able to get a message to Cory with the view to a 
> patch being released. Would you be willing to do that Eric?
>

Cory is already aware of the problem and has offered me a patched version 
already. No need to take extra action. :)

---

From: mark wills <[email-masked]>
Date: Mon, 14 Dec 2009 21:27:38 -0800 (PST)

Brilliant news. Can I get a copy of the patch when it's available? (Assuming he doesn't do a public update)

:-)

Thanks

Mark.

>
>From: Tursi <[email-masked]>
>Sent: Tue, 15 December, 2009 6:23:02
>Subject: Re: [TI994A] 'JH' Bug in Asm99a V3.009
>
> >
>
>
>
>
>  >
>>      
>