Subject: Frederick Hawkins Letter to BYTE Magazine

From: "computerclassics2000" <[email-masked]>
Date: Mon, 21 Dec 2009 05:19:22 -0000

Long time 99ers will remember the name Frederick Hawkins as one of the early contributors to the Altman Fairware List with his X_Disassembler package (AFL #006) that was released in 1984. 

The text below is a letter that Mr. Hawkins wrote to BYTE columnist Jerry Pournelle, published in the December 1983 issue, voicing among other things Hawkins' frustration with the 99/4A and it's GROM. A bit of history...

99/4A Notes
December 1983 BYTE Magazine pages 500-501

Dear Jerry,
Thanks for kicking TI in "Interstellar Drives, Osborne Accessories, DEDICATE/32, and Death Valley" (July, page 323). Like you, I owned one of their calculators—the SR-56—with 100-step programming and always thought highly of it and TI.

The difference between the calculators and the 99/4A turns on the observation that we could make the calculators do everything they could. Not so with the 99/4A, yet it seems not surprising from the perhaps mistaken viewpoint that the 99 is really a ROMed-up version of the TI 990 computer system. 

If the 99/4A is really just part of that series with a clumsy BASIC-GROM system, it seems imperative that these third-party software people get hacking on a chip-replacement set for the operating system. 

There are three reasons:
First, it looks like an inexpensive concurrent computer is right on the shelves (the 99/4A is $70 at local stores). 

Second, it seems to be the most direct approach to both the third-party licensing and hobbyist problems with GROM/GPL. By replacing GROM and the OS with a relocatable OS monitor, TI might just have to back down. (A software-interrupt driven 9900 is very attractive and it's right there to be taken.) And, more personally, as a newcomer to owning a computer, I resent being sold a system with a resident GROM.

Anyway, here are some books that point to better things:

For an explanation about why the 99/4A is really a 990 and, interestingly, a floppy-disk control program, use Microprocessors/ Microcomputers/System Design published by McGraw-Hill.

For a glimpse of a concurrent 990 (and therefore, 99/4A) as well as what might be a description of where GROM came from, read chapter 5: "Component Software" from Software Development (TI #MPA29).

For a tutorial with software and hardware theory and explanation, read Fundamentals of Microcomputer Design (TI #MPB30A) and 16-Bit Microprocessor Systems, published by McGraw-Hill.

I bought these books to augment TI's Editor/Assembler manual. For learning assembly language they've been a great help. However, it'll take real expertise to do anything about the 99/4A. I hope that the right people will get working. It'll be a while before my 99/4A deserves a name; I'm jealous.

Frederick Hawkins
1020 North 6th St.
Allentown, PA 18102

Jerry Pournelle's reply:
We've yet to get a TI 99/4A, although I in-tend to buy one so that I can include at least a few words about it in upcoming books and columns. You obviously know a great deal more about the TI machines than I do; I wouldn't have the faintest idea of how to re-place the operating system, and I don't advise anyone to try it.

However, if there's anyone out there who's both mad enough and expert enough to accomplish this, I'd love to hear from him.
Thanks for the tip on books. (See Jerry's article, "The User Looks at Books," on page 519.) I haven't seen those yet; given the explosion in computer books, it's nearly impossible to keep up. . . . 

Jerry

---

From: "Ksarul" <[email-masked]>
Date: Mon, 21 Dec 2009 08:14:31 -0500

I will have to take a close look at chapter 5 of my copy of the Software
Development book he referenced. . .

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
computerclassics2000
Sent: Monday, December 21, 2009 12:19 AM
To: [email-masked]
Subject: [TI994A] Frederick Hawkins Letter to BYTE Magazine

Long time 99ers will remember the name Frederick Hawkins as one of the early
contributors to the Altman Fairware List with his X_Disassembler package
(AFL #006) that was released in 1984. 

The text below is a letter that Mr. Hawkins wrote to BYTE columnist Jerry
Pournelle, published in the December 1983 issue, voicing among other things
Hawkins' frustration with the 99/4A and it's GROM. A bit of history...

99/4A Notes

Dear Jerry,
Thanks for kicking TI in "Interstellar Drives, Osborne Accessories,
DEDICATE/32, and Death Valley" (July, page 323). Like you, I owned one of
their calculators-the SR-56-with 100-step programming and always thought
highly of it and TI.

The difference between the calculators and the 99/4A turns on the
observation that we could make the calculators do everything they could. Not
so with the 99/4A, yet it seems not surprising from the perhaps mistaken
viewpoint that the 99 is really a ROMed-up version of the TI 990 computer
system. 

If the 99/4A is really just part of that series with a clumsy BASIC-GROM
system, it seems imperative that these third-party software people get
hacking on a chip-replacement set for the operating system. 

There are three reasons:
First, it looks like an inexpensive concurrent computer is right on the
shelves (the 99/4A is $70 at local stores). 

Second, it seems to be the most direct approach to both the third-party
licensing and hobbyist problems with GROM/GPL. By replacing GROM and the OS
with a relocatable OS monitor, TI might just have to back down. (A
software-interrupt driven 9900 is very attractive and it's right there to be
taken.) And, more personally, as a newcomer to owning a computer, I resent
being sold a system with a resident GROM.

For an explanation about why the 99/4A is really a 990 and, interestingly, a
floppy-disk control program, use Microprocessors/ Microcomputers/System
Design published by McGraw-Hill.

For a glimpse of a concurrent 990 (and therefore, 99/4A) as well as what
might be a description of where GROM came from, read chapter 5: "Component
Software" from Software Development (TI #MPA29).

For a tutorial with software and hardware theory and explanation, read
Fundamentals of Microcomputer Design (TI #MPB30A) and 16-Bit Microprocessor
Systems, published by McGraw-Hill.

I bought these books to augment TI's Editor/Assembler manual. For learning
assembly language they've been a great help. However, it'll take real
expertise to do anything about the 99/4A. I hope that the right people will
get working. It'll be a while before my 99/4A deserves a name; I'm jealous.

Frederick Hawkins
1020 North 6th St.
Allentown, PA 18102

Jerry Pournelle's reply:
We've yet to get a TI 99/4A, although I in-tend to buy one so that I can
include at least a few words about it in upcoming books and columns. You
obviously know a great deal more about the TI machines than I do; I wouldn't
have the faintest idea of how to re-place the operating system, and I don't
advise anyone to try it.

However, if there's anyone out there who's both mad enough and expert enough
to accomplish this, I'd love to hear from him.
Thanks for the tip on books. (See Jerry's article, "The User Looks at
Books," on page 519.) I haven't seen those yet; given the explosion in
computer books, it's nearly impossible to keep up. . . . 

Jerry