Subject: Re: [TI994A] Re: The bank switched 128K Multicart

From: [email-masked]
Date: Sat, 12 Dec 2009 12:06:00 -0600 (CST)

Nice work, Jon.  :)

Dec 12, 2009 12:51:14 PM, [email-masked] wrote:

No, it's just a hacked 64K cart. I simply added four new pins to support a 27C010 EPROM.

The 64K cart *can* actually support a pure 128K bank switched ROM. You just have to add the aforementioned four extra EPROM pins as well as two wires (inv Q3 and D3 on the 74LS379) as well as jump some +5V to the 27C010 (pins #1, 31, and 32). It's not pretty, but it works.

Or, you can do like I did in this picture - I simply 'segmented' the ROM into 64K and 32K segments, and let the 74LS379 do it's bank switching job within the segments (i.e. 64K is TI Workshop [banked 8K x 8], and is controlled by A16, and 32K/32K is Arcturus [8K x 4] and DM2K [8K x 4], and is controlled by flipping A16, and grounding or not grounding A15.)

Jon

---

From: "hexbus" <[email-masked]>
Date: Sat, 12 Dec 2009 20:03:52 -0000

You guys can also thank Tursi and Stuart for lending an ear when I have technical questions.  They rock!

I did get some 27C040 chips in today, so it's likely that I can and make some major multicarts... think every 8K ROM ever made would be on one cart, and every 16K ROM cart ever made on another cart. :-)  Stay tuned....

Jon