Subject: Re: [TI994A] I: Happy Thanksgiving / TI Workshop EPROM released

From: [email-masked]
Date: Thu, 26 Nov 2009 14:08:36 EST

Bill,
 
I just have a label on each of the EPROMs covering the erase port and it is 
 easily seen from the top.
 
Bob  Carmany

In a message dated 11/26/2009 11:50:09 A.M. Eastern Standard Time,  
[email-masked] writes:

Bob,

What a great idea!  How about slide in labels for the  front, so I won't 
have to pull out the cartridge to determine what's  plugged into my TI?

Bill S

[email-masked]  wrote:
>  
> 
> Owen,
>  
> The  easiest thing to do is what I have done. Install a ZIF socket in the 
>  EPROM socket on the board and cut out a corresponding portion of the 
>  cartridge top. You can then swap EPROMs quickly and easily. I have done  
> that since I mainly use mine for testing and development of EPROMs  but 
> it works fine as a regular cartridge as well.
>   
> *Bob Carmany
> In a message dated 11/26/2009 11:16:55 A.M.  Eastern Standard Time, 
> [email-masked] writes:
>  
>     Hey Bill,
>         You have any extra 16k boards you would be interested in 
>   selling?  I have a couple EPROMs I need boards for... And  from what I 
>     understand--Jon can't keep them on the  shelf.  :). On this day, I am 
>     also thankful  for the great work Jon and Tursi put in to get those 
>   boards made for the community.  :). My 64k cart has  Never-Lander 
>     installed in it now... I am currently  thinking about disassembling 
one 
>     of my Home Budget  Management carts to house the board... It's one of 
>      the later ones that doesn't have a screw or a spring-loaded gate  
>     covering the actual connector edge.   :)
> 
>     Owen Brand
>      **Oprysoft**
>     Opry99er.com
> 
>  *
> 
>  

------------------------------------

Yahoo! Groups  Links

---

From: [email-masked]
Date: Fri, 27 Nov 2009 12:13:11 EST

They are in the "Photo" section of the forum.
 
Bob  Carmany

In a message dated 11/27/2009 10:47:33 A.M. Eastern Standard Time,  
[email-masked] writes:

Bob,

Me, me too (not two and no tutus please :-).

Bill  S

[email-masked] wrote:
>  
> 
>  Owen,
>  
> I'll try to take some pictures over the weekend  and send them directly 
> to you as attachments - or to anyone else who  is interested.
>  
> *Bob Carmany
> In a message dated  11/26/2009 11:37:32 A.M. Eastern Standard Time, 
>   Thanks Bob... Yea, I need to get these other EPROMs on boards so  I
>     can think about getting more EPROMs... As of  right now, I've got 3
>     great game EPROMs that are  sitting idly by... Definitely need to get
>     them  operational... Are there pix of what you're talking about
>   online?  Mainbyte maybe?  Is Ron lurking around  still?
> 
>     Owen Brand
>   **Oprysoft**
>     Opry99er.com  <http://opry99er.com/>
> 
>     On Nov 26,  2009, at 11:22 AM, [email-masked]
>      <mailto:[email-masked]> wrote:
> 
>>     
>>
>>     Owen,
>>   
>>     The easiest thing to do is what  I have done. Install a ZIF socket
>>     in the EPROM  socket on the board and cut out a corresponding
>>      portion of the cartridge top. You can then swap EPROMs quickly  and
>>     easily. I have done that since I mainly use  mine for testing and
>>     development of EPROMs but  it works fine as a regular cartridge as
>>      well.
>>      
>>     *Bob  Carmany
>>     installed in it now... I am currently thinking  about
>>         disassembling one  
>>         Opry99er.com  <http://opry99er.com/>
>>
>>      *
>>
> *
> 
>  

Yahoo! Groups  Links

---

From: [email-masked]
Date: Fri, 27 Nov 2009 18:18:55 -0600 (CST)

Nice work, Jon. Happy Thanksgiving to you too. :)

Nov 26, 2009 08:24:28 AM, [email-masked] wrote:

Happy Thanksgiving to everyone. I am thankful for all of you, your conversation, friendship, and support!

By permission of Edward Dohmann, I am releasing the EPROM version of TI Workshop and its related documentation. Edward has graciously agreed that I can put this download on www.hexbus.com. The only restrictions related to it are that you can't sell his program, and must freely distribute it. You can burn it to an EPROM, use it in an emulator, whatever. Please just give him credit if you do redistribute it.

The version available for download is the 74LS379 version, which works with the 64K cartridge board out of the box. You will need a 27512 or 27C512 EPROM to burn it.

TI Workshop was released in 1986, and is the largest cartridge program ever released for the TI-99/4A. It includes the following:

1) Full debugger based on SuperBug by Edgar Dohmann
2) A full memory manager (view, edit, and save memory)
3) A full program loader (load, load/run EA/3 and EA/5)
4) A full disk manager 
5) A sector editor
6) A full editor/assembler package

There are some limitations to the module, but Edgar seems OK with us modifying it if needed. Some that I know of include:

1) Your RAMDisk might get wiped unless it's write protected when using the disk manager
2) You need to use this cart by itself (i.e. not in a Gram Kracker or Cartridge Expander)
3) The Disk Manager and other file operations can only do DSK1 to DSK9

Enjoy the program, and Happy Thanksgiving!

Jon