Subject: Tonights hardware questions.....

From: "Marc H" <[email-masked]>
Date: Wed, 04 Nov 2009 00:19:52 -0000

I have found some devious logic errors (mine not the chips) with what I thought was the perfect CRU decoding plan (imagine that) so I need to know a couple of things before proceeding.....

1).... when the console does it's keyboard scan, and intterupt processing and cassette stuff etc does the CRUCLK go low at some point?  I have a feeling that the answer is yes but....

2).... I don't know why but I assumed that when one device comes on the others go off.  I am pretty sure that this is not the case so what I want to know is worst case scenario if two cards are on at the same time(aside from locking up the console.)

I have plan 3 in the works but really need the answer to #1 before proceeding and would like the answer to #2 in order to determine how adventurous I could/should be....

Thanks group

Marc....

---

From: "Tursi" <[email-masked]>
Date: Tue, 3 Nov 2009 20:04:42 -0500

> 1).... when the console does it's keyboard scan, and intterupt 
> processing and cassette stuff etc does the CRUCLK go low at some 
> point?  I have a feeling that the answer is yes but....
>

Definately so, because these operations manipulate CRU bits in the 9901.

> 2).... I don't know why but I assumed that when one device comes on 
> the others go off.  I am pretty sure that this is not the case so what 
> I want to know is worst case scenario if two cards are on at the same 
> time(aside from locking up the console.)
>

You will likely have two devices driving the bus. Most of the time, this 
just means bad data and a crash, but it is possible to damage the chips 
involved (the console /should/ be well enough protected.)

---

From: Marc Hull <[email-masked]>
Date: Tue, 3 Nov 2009 19:13:48 -0800 (PST)

Thanks for the confirmation Mike.  I looked at my logic tree during wrestling practice tonight (my sons not mine ;-) and have come to the conclusion that I have way overcomplicated the CRU for what I am trying to do.  I have a new plan that turns the card on with any write below >1000 and turns it off with any write above  >0FFF.  This should prevent any conflict with the PEB cards and since all I plan to do is output some data to another chip mapped @>4000 I think it should be OK as no memory exists in the console at that location.........correct ?

--- On Tue, 11/3/09, Tursi <[email-masked]> wrote:

From: Tursi <[email-masked]>
Subject: Re: [TI994A] Tonights hardware questions.....
To: [email-masked]
Date: Tuesday, November 3, 2009, 7:04 PM

---

From: "Tursi" <[email-masked]>
Date: Tue, 3 Nov 2009 22:43:56 -0500

I wonder, though, do you deliberately want to break the standard that 
you turn the card on, use it, then turn it off?

Your plan does mean any traditional PEB access will automatically 
disable your device, which is good if that's what you mean, but remember 
that the console CRU is all less than >0400, so your less than >1000 
plan may be triggered by that.

----- Original Message ----- 
From: "Marc Hull" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, November 03, 2009 10:13 PM
Subject: Re: [TI994A] Tonights hardware questions.....

Thanks for the confirmation Mike. I looked at my logic tree during 
wrestling practice tonight (my sons not mine ;-) and have come to the 
conclusion that I have way overcomplicated the CRU for what I am trying 
to do. I have a new plan that turns the card on with any write below 
 >1000 and turns it off with any write above >0FFF. This should prevent 
any conflict with the PEB cards and since all I plan to do is output 
some data to another chip mapped @>4000 I think it should be OK as no 
memory exists in the console at that location.........correct ?

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 3 Nov 2009 22:55:19 -0600

I might be late to practice (grin) but have you already considered mirroring an existing design, such as that of a Horizon RAMdisk or the IDE card, where a schematic is available? Seems you could strip out all but a few chips and play with that?  If you are planning to create a DSR of sorts, you might want to play with an EPROM or RAM chip for good measure.    Not knowing what your electronic cauldron is brewing, and drowning in the email flood of good responses, I realize I might be trampling all over your design plans. 

Tim
 		 	   		  
_________________________________________________________________
Bing brings you maps, menus, and reviews organized in one place.
http://www.bing.com/search?q=restaurants&form=MFESRP&publ=WLHMTAG&crea=TEXT_MFESRP_Local_MapsMenu_Resturants_1x1

---

From: "fredkaal" <[email-masked]>
Date: Wed, 04 Nov 2009 06:09:15 -0000

IDE schematics are available here:

http://members.ziggo.nl/fgkaal/Hardware/hw_ide_card.html#ThN_idecard

Fred ;-)

---

From: fdos <[email-masked]>
Date: Wed, 04 Nov 2009 07:51:54 -0700

Besides those of us with WHT AT keyboard mods in our TI console will 
have this exact conflict as it uses CRU address >400.

Bill S

Tursi wrote:
> From: "Marc Hull" <[email-masked] 
> <mailto:marc.hull%40sbcglobal.net>>
> To: <[email-masked] <mailto:TI994A%40yahoogroups.com>>

---

From: Marc Hull <[email-masked]>
Date: Wed, 4 Nov 2009 07:44:11 -0800 (PST)

That would be a good argument to upgrade to Mikes PS/2 adapter.  (That will cost you 10 percent for the plug Tursi.....;-)

--- On Wed, 11/4/09, fdos <[email-masked]> wrote:

From: fdos <[email-masked]>
Subject: Re: [TI994A] Tonights hardware questions.....
To: [email-masked]
Date: Wednesday, November 4, 2009, 8:51 AM

    

Bill S

Tursi wrote:

> From: "Marc Hull" <marc.hull@sbcglobal .net 

> <mailto:marc. hull%40sbcglobal .net>>

> To: <TI994A@yahoogroups. com <mailto:TI994A% 40yahoogroups. com>>

> Subject: Re: [TI994A] Tonights hardware questions... ..

> memory exists in the console at that location.... .....correct ?

---

From: fdos <[email-masked]>
Date: Wed, 04 Nov 2009 09:46:34 -0700

Marc,

I'm already committed to do two TI consoles with Mike's PS/2 adapter, 
but not three.  I'm not in the habit of throwing away my TI peripherals 
unless they're in an unrepairable state--some times not even then.:-)

Bill S

Marc Hull wrote:
>  
> 
> That would be a good argument to upgrade to Mikes PS/2 adapter.  (That 
> will cost you 10 percent for the plug Tursi.....;-)
> 
> --- On *Wed, 11/4/09, fdos /<[email-masked]>/* wrote:
> 
> 
>     </mc/compose?to=marc.hull%40sbcglobal.net>
>      > To: <TI994A@yahoogroups. com
>     </mc/compose?to=TI994A%40yahoogroups.com> <mailto:TI994A%
>     40yahoogroups. com>>

---

From: Marc Hull <[email-masked]>
Date: Wed, 4 Nov 2009 09:04:22 -0800 (PST)

Bill....

I understand. 

I have never seen a WHT keyboard adapter.  Does it have ROM or RAM paged in @ >4000-5FFF?

Marc...

From: fdos <[email-masked]>
Subject: Re: [TI994A] Tonights hardware questions.....
To: [email-masked]
Date: Wednesday, November 4, 2009, 10:46 AM

    
                  Marc,

Bill S

Marc Hull wrote:

> will cost you 10 percent for the plug Tursi.....;- )

> --- On *Wed, 11/4/09, fdos /<fdosbrs@frontiernet .net>/* wrote:

>     From: fdos <fdosbrs@frontiernet .net>

>     To: TI994A@yahoogroups. com

>      > disable your device, which is good if that's what you mean, but

>     remember

>      > From: "Marc Hull" <marc.hull@sbcgloba l .net

>     </mc/compose? to=marc.hull% 40sbcglobal. net>

>      > To: <TI994A@yahoogroups . com

>     </mc/compose? to=TI994A% 40yahoogroups. com> <mailto:TI994A%

>      > conclusion that I have way overcomplicated the CRU for what I am

>     trying

>      > >1000 and turns it off with any write above >0FFF. This should

>     prevent

---

From: tursi <[email-masked]>
Date: Wed, 4 Nov 2009 09:29:27 -0800 (PST)

hehe.. so far as I know, Bill is waiting. I need to figure out the cable 
sourcing situation so we can do a run here. :)

---

From: fdos <[email-masked]>
Date: Wed, 04 Nov 2009 11:44:52 -0700

Either.  User can select.

Bill S

Marc Hull wrote:
>      > --- On *Wed, 11/4/09, fdos /<fdosbrs@frontiernet .net
>     </mc/compose?to=fdosbrs%40frontiernet.net>>/* wrote:
>      >
>      >
>      > From: fdos <fdosbrs@frontiernet .net
>     </mc/compose?to=fdosbrs%40frontiernet.net>>
>      > To: TI994A@yahoogroups. com </mc/compose?to=TI994A%40yahoogroups.com>
>      > > that the console CRU is all less than >0400, so your less than
>      >1000

---

From: Marc Hull <[email-masked]>
Date: Wed, 4 Nov 2009 11:02:28 -0800 (PST)

Explain that to me.  Is it totally a user selected option or does the functionality of the device depend on it ?

From: fdos <[email-masked]>
Subject: Re: [TI994A] Tonights hardware questions.....
To: [email-masked]
Date: Wednesday, November 4, 2009, 12:44 PM

  

      Either.  User can select.

Bill S

Marc Hull wrote:

> I have never seen a WHT keyboard adapter.  Does it have ROM or RAM paged 

> in @ >4000-5FFF?

>      > That would be a good argument to upgrade to Mikes PS/2 adapter.

>     (That

>      > --- On *Wed, 11/4/09, fdos /<fdosbrs@frontiern et .net

>     </mc/compose? to=fdosbrs% 40frontiernet. net>>/* wrote:

>      > From: fdos <fdosbrs@frontierne t .net

>     </mc/compose? to=fdosbrs% 40frontiernet. net>>

>      > To: TI994A@yahoogroups. com </mc/compose? to=TI994A% 40yahoogroups. com>

>      > > I wonder, though, do you deliberately want to break the

>     standard that

>      > > wrestling practice tonight (my sons not mine ;-) and have come

>     to the

>      > > to do. I have a new plan that turns the card on with any write

>     below

>      > > any conflict with the PEB cards and since all I plan to do is

>     output

>      > > some data to another chip mapped @>4000 I think it should be OK

>     as no

---

From: fdos <[email-masked]>
Date: Wed, 04 Nov 2009 14:24:32 -0700

Marc,

I suggest you download the TI Hardware Manual from WHTECH.  You'll find 
"Western Horizon Technology AT Keyboard Interface" in the index, and 
then answer your own question(s).

Bill S

Marc Hull wrote:
>  
> 
> Explain that to me.  Is it totally a user selected option or does the 
> functionality of the device depend on it ?
>

---

From: Marc Hull <[email-masked]>
Date: Wed, 4 Nov 2009 14:50:09 -0800 (PST)

I wasn't being flippant Bill.  You seemed to have knowledge about it and  I was just asking.

From: fdos <[email-masked]>
Subject: Re: [TI994A] Tonights hardware questions.....
To: [email-masked]
Date: Wednesday, November 4, 2009, 3:24 PM

  

      Marc,

Bill S

Marc Hull wrote:

>      > I have never seen a WHT keyboard adapter. Does it have ROM or RAM

>     paged

>      > but not three. I'm not in the habit of throwing away my TI

>     peripherals

>      > > To: TI994A@yahoogroups. com </mc/compose? to=TI994A%

>     40yahoogroups. com>

>      > > Besides those of us with WHT AT keyboard mods in our TI console

>     will

>      > > > Thanks for the confirmation Mike. I looked at my logic tree

>     during

---

From: fdos <[email-masked]>
Date: Wed, 04 Nov 2009 19:39:42 -0700

Marc,

I didn't think you were being flippant about it.  I just knew I wouldn't 
have time to explain it and respond to a few other posts, as my 
granddaughter was pestering me constantly, so I had to keep it brief, 
and because I wanted time to get ready to go out this evening (back now).

Besides that Hardware Manual is full of interesting information, so take 
a look at it anyway.

Bill S

---

From: Marc Hull <[email-masked]>
Date: Wed, 4 Nov 2009 20:03:17 -0800 (PST)

I'll do... would you mind pointing it out....

From: fdos <[email-masked]>
Subject: Re: [TI994A] Tonights hardware questions.....
To: [email-masked]
Date: Wednesday, November 4, 2009, 8:39 PM

Marc,

Bill S

Marc Hull wrote:
>      >
>      >
>      > Explain that to me. Is it totally a user selected option or does the
>      > functionality of the device depend on it ?
>      >
>      > --- On *Wed, 11/4/09, fdos /<fdosbrs@frontiernet .net
>      >
>      >
>      > From: fdos <fdosbrs@frontiernet .net
>      > Subject: Re: [TI994A] Tonights hardware questions... ..
>      > To: TI994A@yahoogroups. com </mc/compose?to=TI994A%40yahoogroups.com>
>      > Date: Wednesday, November 4, 2009, 12:44 PM
>      >
>      >
>      >
>      > Either. User can select.
>      >
>      > Bill S
>      >
>      > Marc Hull wrote:
>      > >
>      > >
>      > > Bill....
>      > >
>      > > I understand.
>      > >
>      > > I have never seen a WHT keyboard adapter. Does it have ROM or RAM
>      > paged
>      > > in @ >4000-5FFF?
>      > >
>      > > Marc...
>      > >
>      > >
>      > > --- On *Wed, 11/4/09, fdos /<fdosbrs@frontiern et .net
>      > </mc/compose? to=fdosbrs% 40frontiernet. net>>/* wrote:
>      > >
>      > >
>      > > From: fdos <fdosbrs@frontierne t .net
>      > </mc/compose? to=fdosbrs% 40frontiernet. net>>
>      > > Subject: Re: [TI994A] Tonights hardware questions... ..
>      > > To: TI994A@yahoogroups. com </mc/compose? to=TI994A%
>     40yahoogroups. com>
>      > > Date: Wednesday, November 4, 2009, 10:46 AM
>      > >
>      > >
>      > >
>      > > Marc,
>      > >
>      > > I'm already committed to do two TI consoles with Mike's PS/2
>     adapter,
>      > > but not three. I'm not in the habit of throwing away my TI
>      > peripherals
>      > > unless they're in an unrepairable state--some times not even
>     then.:-)
>      > >
>      > > Bill S
>      > >
>      > > Marc Hull wrote:
>      > > >
>      > > >
>      > > > That would be a good argument to upgrade to Mikes PS/2 adapter.
>      > > (That
>      > > > will cost you 10 percent for the plug Tursi.....;- )
>      > > >
>      > > > --- On *Wed, 11/4/09, fdos /<fdosbrs@frontiern et .net
>      > > </mc/compose? to=fdosbrs% 40frontiernet. net>>/* wrote:
>      > > >
>      > > >
>      > > > From: fdos <fdosbrs@frontierne t .net
>      > > </mc/compose? to=fdosbrs% 40frontiernet. net>>
>      > > > Subject: Re: [TI994A] Tonights hardware questions... ..
>      > > > To: TI994A@yahoogroups. com </mc/compose? to=TI994A%
>      > 40yahoogroups. com>
>      > > > Date: Wednesday, November 4, 2009, 8:51 AM
>      > > >
>      > > >
>      > > >
>      > > > Besides those of us with WHT AT keyboard mods in our TI console
>      > will
>      > > > have this exact conflict as it uses CRU address >400.
>      > > >
>      > > > Bill S
>      > > >
>      > > > Tursi wrote:
>      > > > >
>      > > > >
>      > > > > I wonder, though, do you deliberately want to break the
>      > > standard that
>      > > > > you turn the card on, use it, then turn it off?
>      > > > >
>      > > > > Your plan does mean any traditional PEB access will
>     automatically
>      > > > > disable your device, which is good if that's what you mean, but
>      > > > remember
>      > > > > that the console CRU is all less than >0400, so your less than
>      > > >1000
>      > > > > plan may be triggered by that.
>      > > > >
>      > > > > ----- Original Message -----
>      > > > > From: "Marc Hull" <marc.hull@sbcgloba l .net
>      > > > </mc/compose? to=marc.hull% 40sbcglobal. net>
>      > > > > <mailto:marc. hull%40sbcglobal .net>>
>      > > > > To: <TI994A@yahoogroups . com
>      > > > </mc/compose? to=TI994A% 40yahoogroups. com> <mailto:TI994A%
>      > > > 40yahoogroups. com>>
>      > > > > Sent: Tuesday, November 03, 2009 10:13 PM
>      > > > > Subject: Re: [TI994A] Tonights hardware questions... ..
>      > > > >
>      > > > > Thanks for the confirmation Mike. I looked at my logic tree
>      > during
>      > > > > wrestling practice tonight (my sons not mine ;-) and have come
>      > > to the
>      > > > > conclusion that I have way overcomplicated the CRU for what
>     I am
>      > > > trying
>      > > > > to do. I have a new plan that turns the card on with any write
>      > > below
>      > > > > >1000 and turns it off with any write above >0FFF. This should
>      > > > prevent
>      > > > > any conflict with the PEB cards and since all I plan to do is
>      > > output
>      > > > > some data to another chip mapped @>4000 I think it should be OK
>      > > as no
>      > > > > memory exists in the console at that location....
>     .....correct ?
>      > > > >
>      > > > >
>      > > >
>      > > >
>      > >
>      > >
>      >
>      >
> 
> 

------------------------------------

Yahoo! Groups Links

---

From: fdos <[email-masked]>
Date: Wed, 04 Nov 2009 22:02:44 -0700

Marc,

Here: 
ftp://ftp.whtech.com/datasheets%20and%20manuals/Hardware/ti%20hardware%20compendium.txt

Bill S

Marc Hull wrote:
>      > --- On *Wed, 11/4/09, fdos /<[email-masked]
>     </mc/compose?to=[email-masked]>>/* wrote:
>      >
>      >
>      >     From: fdos <[email-masked]
>     </mc/compose?to=[email-masked]>>
>     </mc/compose?to=[email-masked]>
>     </mc/compose?to=TI994A%40yahoogroups.com>
>      > ;      > > I have never seen a WHT keyboard adapter. Does it have
>     ROM or RAM
>      >      > paged
>      >      > > in @ >4000-5FFF?
>      >      > >
>      >      > > Marc...
>      >      > >
>      >      > >
>      >      > > > > conclusion that I have way overcomplicated the CRU
>     for what
>      >     I am
>      >      > > > trying
>         (Yahoo! I D required)
>         [email-masked]
>     </mc/compose?to=[email-masked]>
> 
> 
> 
>