Subject: Re: [TI994A] Re: New file uploaded to TI994A

From: mark wills <[email-masked]>
Date: Mon, 2 Nov 2009 04:46:25 -0800 (PST)

'Twas Classic99 versus Win994a.

I don't know if you can run TI Forth in Classic99 - last time I tried it wasn't possible, and I'm too pathetic to lift the files off the Win994A "disk" for use with Classic99

M

>
>From: kabldb <[email-masked]>
>To: [email-masked]
>Sent: Mon, 2 November, 2009 13:34:39
>Subject: [TI994A] Re: New file uploaded to TI994A
>
> >
>
>
>
>  
>That woz Classic99 vs. ?
>
>>--- In TI994A@yahoogroups. com, TI994A@yahoogroups. com wrote:
>>>
>>> 
>>> Hello,
>>> 
>>> This email message is a notification to let you know that
>>> a file has been uploaded to the Files area of the TI994A 
>>> group.
>>> 
>>>   File        : /Forth Head to Head/Movie_0001. wmv 
>>>   Uploaded by : markrobertwills <markrobertwills@ ...> 
>>>   Description : TI Forth and my Forth head to head 
>>> 
>>> You can access this file at the URL:
>>> http://groups. yahoo.com/ group/TI994A/ files/Forth% 20Head%20to% 20Head/Movie_ 0001.wmv 
>>> 
>>> To learn more about file sharing for your group, please visit:
>>> http://help. yahoo.com/ l/us/yahoo/ groups/original/ general.htmlfile s
>>> 
>>> Regards,
>>> 
>>> markrobertwills <markrobertwills@ ...>
>>>
>
>
> > >

---

From: "Tursi" <[email-masked]>
Date: Mon, 2 Nov 2009 11:03:26 -0500

>I don't know if you can run TI Forth in Classic99 - last time I tried 
>it wasn't possible, and I'm too pathetic to lift the files off >the 
>Win994A "disk" for use with Classic99

Why wasn't it possible?

---

From: mark wills <[email-masked]>
Date: Mon, 2 Nov 2009 20:43:34 -0800 (PST)

Because of the special non standard format of the TI Forth system disk.

>
>From: Tursi <[email-masked]>
>Sent: Mon, 2 November, 2009 17:03:26
>Subject: Re: [TI994A] Re: New file uploaded to TI994A
>
> >
>
>
>
>

---

From: fdos <[email-masked]>
Date: Tue, 03 Nov 2009 10:37:37 -0700

Which is what I call a "Mongrel" disk, as it is formatted to TI 
standard, but only two normal files (FORTH & FORTHSAVE) are written to 
the disk.  The third file (SYS-SCRNS) is fake, as all it does is 
allocate all the remaining sectors, so Disk Managers won't accidentally 
copy files to what would otherwise be considered free sectors.  The 
Forth system uses the remainder of the disk for sector i/o (1024 BYTE 
BLOCK BUFFERS).  X4th99 won't normally use "Mongrel" disks, but can if 
called on to do so.

Bill S

mark wills wrote:
>     *From:* Tursi <[email-masked]>
>     *To:* [email-masked]
>     *Sent:* Mon, 2 November, 2009 17:03:26
>     *Subject:* Re: [TI994A] Re: New file uploaded to TI994A
> 
>      
>

---

From: tursi <[email-masked]>
Date: Tue, 3 Nov 2009 11:09:55 -0800 (PST)

Interesting... you know, if it accesses that SYS-SCRNS using the 
file-based sector IO rather than disk-based, then it should indeed work in 
Classic99. Not that it matters with two better alternatives on the 
horizon. ;)

---

From: fdos <[email-masked]>
Date: Tue, 03 Nov 2009 12:17:35 -0700

Tursi,

Sorry, but not the case, it is disk sector I/O, not file I/O.  This is 
why I refer to it as a "Mongrel" disk.  If TI FORTH used file I/O to 
access a real file named "SYS-SCRNS" it would not be a "Mongrel" disk.

Bill S