Subject: Found strange cartridge

From: Owen Brand <[email-masked]>
Date: Tue, 24 Nov 2009 22:06:06 -0500

Hey all... Recently picked up a strange cartridge I've never seen  
before and don't have any info on...  It's a beige cart with a hand- 
written label that says "Disk Fixer 2.1". Anyone have info on this  
cart?  Know where a manual can be found?

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "Bryan Roppolo Boulder" <[email-masked]>
Date: Tue, 24 Nov 2009 22:10:15 -0500

Sounds like a Navarone cart from the ECPC machine?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Owen Brand
Sent: Tuesday, November 24, 2009 10:06 PM
To: [email-masked]
Subject: [TI994A] Found strange cartridge

Owen Brand
**Oprysoft**
Opry99er.com

------------------------------------

Yahoo! Groups Links

---

From: Owen Brand <[email-masked]>
Date: Tue, 24 Nov 2009 22:31:47 -0500

Thanks Gary!!!

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 24, 2009, at 10:10 PM, "Bryan Roppolo Boulder" <[email-masked] 
 > wrote:

---

From: Owen Brand <[email-masked]>
Date: Tue, 24 Nov 2009 22:31:23 -0500

Hmmm... Mainbyte has some cool info... Apparently it allows you to  
"fix" any diskette by working sector by sector as opposed to filename  
by filename... Says "allows full manipulation of binary contents and  
bytes".  Very cool.  :). Sounds like something I could find some use  
for... Not that I know what to do with all that stuff....... But I cam  
learn.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Tue, 24 Nov 2009 22:33:04 -0500

Actual info from Mainbyte...

<snip>
Unlocks the secrets of the disk and lets you access hidden or "lost"  
information. Disk Fixer is a must for the serious TI 99/4A user who  
has a "sick disk" which suffers from a damaged directory. This program  
lets you recover unscathed information by searching your disk by  
sector rather than file name. Disk Fixer lets you diplay/print the  
actual binary contents with a single command. It allows you to change  
any byte on any sector, even move data from one sector to another.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "computerclassics2000" <[email-masked]>
Date: Wed, 25 Nov 2009 05:37:59 -0000

Hi Owen,
As a collectible cartridge, Navarone Industries' Disk Fixer is a keeper. They rarely surface on eBay, and they were not heavily advertised by Navarone during their prime. Rarity rating is a subjective assessment at best because neither TI nor any company supplying the 99/4A ever released sales figures, but Disk Fixer has a RARE rating in Rich Polivka's www.99er.net website, and an UNCOMMON rating on Ron Reuter's mainbyte.com website. Bottom line...it is not at least a 'common' find.

As a 'tool' for use in disk sector editing and the recovery work that 
Navarone 'hawked' in their ads...there are MUCH better and MUCH easier to use tools available. Disk Fixer has no ASCII display, only HEX. To see the contents of a sector in ASCII you must print hardcopy for the sector. That kind of requirement/limitation is a pretty tall order for someone who can't read hexidecimal arithmetic. A much better choice for sector editing is DSKU by the late John Birdwell, or Disk Edit (my favorite) by Colin Christensen.

Disk Fixer is among the oldest sector editors for the TI-99 in existence, pre-dated perhaps only by DISKO, which was created by (then) TI employee Paul Urbanas. But age is no excuse for the unfriendly manner in which Disk Fixer must be used, nor for the poor documentation that came with it.

As Bob Carmany said in his post, Disk Fixer was originally offered on disk when first released in 1983 and it came with a poorly written 8-page manual. One of the earliest references to the disk version can be found on page 40 of the July 1983 issue of Enthusiast'99 Magazine. It also shows up on page 15 of the "99'er Directory" that came bound inside the Sep 1983 issue of 99'er Magazine. The disk version carried an MSRP of $29.95.

Assembly language programmer Bill Gronos, who was also a Senior Technical Editor for Enthusiast '99 Magazine, reviewed the disk version of Disk Fixer in the Sep 1983 issue of that magazine on page 39. Gronos talks about a well-written 10-page manual that is easy to understand? Maybe for an A/L programmer? I have the disk version manual, and I would not use the adjective 'easy' to describe it.

Gronos would later (1984) write a booklet entitled "The Hidden Powers 
of Disk Fixer". It was on the market less that a year before Navarone 
struck a deal with Gronos to include "Hidden Powers..." as part of the docs that came with the cartridge version of Disk Fixer.

So, in your quest to find the docs for the cartridge you have, there
are docs pre-"Hidden Powers" deal, and docs post-"Hidden Powers" deal. The pre-"Hidden Powers" docs are approximately 5.5" X 6.5" (mine has beige cardstock for the cover) usually made to fit into a shrink-wrapped package that had a retail-shelf backing card for hanging the package, with the instruction manual on top of that followed by the cartridge, and all surrounded by shrink-wrapped plastic.

The post-"Hidden Powers" docs are glossy white, a little larger than  a typical Texas Instruments cartridge manual, and have "Includes HIDDEN POWERS by Bill Gronos" printed right on the cover. These packages were sold in Navarone's blue and white cartridge box similar to how the Navarone DBMS was packaged.

The earliest reference I have for the cartridge version comes from Navarone's own October 1983 "Product Catalog", where it states, "Available on cartridge only.)". The MSRP jumped to $39.95 in cartridge form.

An interesting sidebar on the cartridge version is that they can be found in white TI GROM style cartridge casings with gold labels, black ROMOX ECPC (Edge Connector Programable Cartridge) style casings
with two completely different design gold labels, and it sounds like
you found a white ROMOX ECPC version.

The story behind the "why" of the GROM style and ECPC cartridge casings is an interesting bit of history in itself, but I will save that for another time.

BillG

---

From: Owen Brand <[email-masked]>
Date: Wed, 25 Nov 2009 01:20:28 -0500

Human encyclopedia.  :). Man, you rock.  Thanks for the superb info  
AGAIN Bill... Looking forward to the next timeline99 article!!!

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 25, 2009, at 12:37 AM, "computerclassics2000" <[email-masked] 

> Hi Owen,
> As a collectible cartridge, Navarone Industries' Disk Fixer is a  
> keeper. They rarely surface on eBay, and they were not heavily  
> advertised by Navarone during their prime. Rarity rating is a  
> subjective assessment at best because neither TI nor any company  
> supplying the 99/4A ever released sales figures, but Disk Fixer has  
> a RARE rating in Rich Polivka's www.99er.net website, and an  
> UNCOMMON rating on Ron Reuter's mainbyte.com website. Bottom  
> line...it is not at least a 'common' find.
>
> Navarone 'hawked' in their ads...there are MUCH better and MUCH  
> easier to use tools available. Disk Fixer has no ASCII display, only  
> HEX. To see the contents of a sector in ASCII you must print  
> hardcopy for the sector. That kind of requirement/limitation is a  
> pretty tall order for someone who can't read hexidecimal arithmetic.  
> A much better choice for sector editing is DSKU by the late John  
> Birdwell, or Disk Edit (my favorite) by Colin Christensen.
>
> Disk Fixer is among the oldest sector editors for the TI-99 in  
> existence, pre-dated perhaps only by DISKO, which was created by  
> (then) TI employee Paul Urbanas. But age is no excuse for the  
> unfriendly manner in which Disk Fixer must be used, nor for the poor  
> documentation that came with it.
>
> As Bob Carmany said in his post, Disk Fixer was originally offered  
> on disk when first released in 1983 and it came with a poorly  
> written 8-page manual. One of the earliest references to the disk  
> version can be found on page 40 of the July 1983 issue of  
> Enthusiast'99 Magazine. It also shows up on page 15 of the "99'er  
> Directory" that came bound inside the Sep 1983 issue of 99'er  
> Magazine. The disk version carried an MSRP of $29.95.
>
> Assembly language programmer Bill Gronos, who was also a Senior  
> Technical Editor for Enthusiast '99 Magazine, reviewed the disk  
> version of Disk Fixer in the Sep 1983 issue of that magazine on page  
> 39. Gronos talks about a well-written 10-page manual that is easy to  
> understand? Maybe for an A/L programmer? I have the disk version  
> manual, and I would not use the adjective 'easy' to describe it.
>
> struck a deal with Gronos to include "Hidden Powers..." as part of  
> the docs that came with the cartridge version of Disk Fixer.
>
> are docs pre-"Hidden Powers" deal, and docs post-"Hidden Powers"  
> deal. The pre-"Hidden Powers" docs are approximately 5.5" X  
> 6.5" (mine has beige cardstock for the cover) usually made to fit  
> into a shrink-wrapped package that had a retail-shelf backing card  
> for hanging the package, with the instruction manual on top of that  
> followed by the cartridge, and all surrounded by shrink-wrapped  
> plastic.
>
> The post-"Hidden Powers" docs are glossy white, a little larger than  
> a typical Texas Instruments cartridge manual, and have "Includes  
> HIDDEN POWERS by Bill Gronos" printed right on the cover. These  
> packages were sold in Navarone's blue and white cartridge box  
> similar to how the Navarone DBMS was packaged.
>
> The earliest reference I have for the cartridge version comes from  
> Navarone's own October 1983 "Product Catalog", where it states,  
> "Available on cartridge only.)". The MSRP jumped to $39.95 in  
> cartridge form.
>
> An interesting sidebar on the cartridge version is that they can be  
> found in white TI GROM style cartridge casings with gold labels,  
> black ROMOX ECPC (Edge Connector Programable Cartridge) style casings
> The story behind the "why" of the GROM style and ECPC cartridge  
> casings is an interesting bit of history in itself, but I will save  
> that for another time.
>
> BillG
>

---

From: fdos <[email-masked]>
Date: Wed, 25 Nov 2009 08:08:09 -0700

So you say that the Black Navarone Romox ECPC with black on gold labels 
I have, including both documents you describe, is rare?   How can one be 
sure when I can't find a date stamp on it?  Just curious.

Bill S

computerclassics2000 wrote:
>  
> 
> Hi Owen,
> As a collectible cartridge, Navarone Industries' Disk Fixer is a keeper. 
> They rarely surface on eBay, and they were not heavily advertised by 
> Navarone during their prime. Rarity rating is a subjective assessment at 
> best because neither TI nor any company supplying the 99/4A ever 
> released sales figures, but Disk Fixer has a RARE rating in Rich 
> Polivka's www.99er.net website, and an UNCOMMON rating on Ron Reuter's 
> mainbyte.com website. Bottom line...it is not at least a 'common' find.
> 
> Navarone 'hawked' in their ads...there are MUCH better and MUCH easier 
> to use tools available. Disk Fixer has no ASCII display, only HEX. To 
> see the contents of a sector in ASCII you must print hardcopy for the 
> sector. That kind of requirement/limitation is a pretty tall order for 
> someone who can't read hexidecimal arithmetic. A much better choice for 
> sector editing is DSKU by the late John Birdwell, or Disk Edit (my 
> favorite) by Colin Christensen.
> 
> existence, pre-dated perhaps only by DISKO, which was created by (then) 
> TI employee Paul Urbanas. But age is no excuse for the unfriendly manner 
> in which Disk Fixer must be used, nor for the poor documentation that 
> came with it.
> 
> As Bob Carmany said in his post, Disk Fixer was originally offered on 
> disk when first released in 1983 and it came with a poorly written 
> 8-page manual. One of the earliest references to the disk version can be 
> found on page 40 of the July 1983 issue of Enthusiast'99 Magazine. It 
> also shows up on page 15 of the "99'er Directory" that came bound inside 
> the Sep 1983 issue of 99'er Magazine. The disk version carried an MSRP 
> of $29.95.
> 
> Technical Editor for Enthusiast '99 Magazine, reviewed the disk version 
> of Disk Fixer in the Sep 1983 issue of that magazine on page 39. Gronos 
> talks about a well-written 10-page manual that is easy to understand? 
> Maybe for an A/L programmer? I have the disk version manual, and I would 
> not use the adjective 'easy' to describe it.
> 
> struck a deal with Gronos to include "Hidden Powers..." as part of the 
> docs that came with the cartridge version of Disk Fixer.
> 
> are docs pre-"Hidden Powers" deal, and docs post-"Hidden Powers" deal. 
> The pre-"Hidden Powers" docs are approximately 5.5" X 6.5" (mine has 
> beige cardstock for the cover) usually made to fit into a shrink-wrapped 
> package that had a retail-shelf backing card for hanging the package, 
> with the instruction manual on top of that followed by the cartridge, 
> and all surrounded by shrink-wrapped plastic.
> 
> The post-"Hidden Powers" docs are glossy white, a little larger than a 
> typical Texas Instruments cartridge manual, and have "Includes HIDDEN 
> POWERS by Bill Gronos" printed right on the cover. These packages were 
> sold in Navarone's blue and white cartridge box similar to how the 
> Navarone DBMS was packaged.
> 
> "Available on cartridge only.)". The MSRP jumped to $39.95 in cartridge 
> form.
> 
> found in white TI GROM style cartridge casings with gold labels, black 
> ROMOX ECPC (Edge Connector Programable Cartridge) style casings
> The story behind the "why" of the GROM style and ECPC cartridge casings 
> is an interesting bit of history in itself, but I will save that for 
> another time.
> 
> BillG
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, Owen 
> Brand <owenbrand@...> wrote:
>  >

---

From: "computerclassics2000" <[email-masked]>
Date: Wed, 25 Nov 2009 18:59:59 -0000

Hi Bill,
Virtually no manufacturer except TI and the 3rd Party partners who had their cartridges actually manufactured at TI facilities (Milton Bradley, Scott, Foresman) kept track of serial numbers, manufacturing runs, plant codes or dates, so date stamps have no real meaning in the realm of rarity determination. They are best used as Bryan Roppolo does, to determine if he has obtained a true 1979 version of a cartridge to go with his splendid collection.

As I mentioned in the earlier post, determination of Rarity Status is subjective at best, because we will likely never know "how many" of any particular cartridge title was produced by its manufacturer. This assumes of course that one agrees with the idea that scarcity equates to rarity.

As part of my research for the creation of the TI-99 Cartridge Collection Kit that I offered back in 2005-2006, I created a spreadsheet that listed the name of every known cartridge title in the X axis, and the name of 85 different TI-99 retailer catalogs I own in the Y axis. A value was entered in to a corresponding cell each time a particular cartridge was listed for sale in a particular catalog.

The thought process here was that if a cartridge was heavily advertised in these catalogs, that meant it would have been available for a longer period of time, in a greater number of catalogs, so the chance that it sold more copies was greater than a cartridge that showed up in the catalogs only a few times.

Out of this data came what I called the CCSR (Catalog Cartridge Scarcity Rating) which is the number that appears in the far right column of the Collecting Cartridges Kit Guide Book.

CCSR------------Category
5.01 – 8.00-----Super Common
2.51 - 5.00-----Common
1.00 – 2.50-----Uncommon
0.50 - 0.99-----Rare
0.01 - 0.49-----Extremely Rare

Navarone's Disk Fixed cartridge has a CCSR of 0.97. TI Invaders by comparison has a CCSR of 7.42.

BillG

--- In [email-masked], fdos <fdosbrs@...> wrote:
> > Brand <owenbrand@> wrote:
> >  >

---

From: Owen Brand <[email-masked]>
Date: Wed, 25 Nov 2009 14:35:23 -0500

Excellent info!  Thanks

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 25, 2009, at 1:59 PM, "computerclassics2000" <[email-masked] 

> Hi Bill,
> Virtually no manufacturer except TI and the 3rd Party partners who  
> had their cartridges actually manufactured at TI facilities (Milton  
> Bradley, Scott, Foresman) kept track of serial numbers,  
> manufacturing runs, plant codes or dates, so date stamps have no  
> real meaning in the realm of rarity determination. They are best  
> used as Bryan Roppolo does, to determine if he has obtained a true  
> 1979 version of a cartridge to go with his splendid collection.
>
> As I mentioned in the earlier post, determination of Rarity Status  
> is subjective at best, because we will likely never know "how many"  
> of any particular cartridge title was produced by its manufacturer.  
> This assumes of course that one agrees with the idea that scarcity  
> equates to rarity.
>
> As part of my research for the creation of the TI-99 Cartridge  
> Collection Kit that I offered back in 2005-2006, I created a  
> spreadsheet that listed the name of every known cartridge title in  
> the X axis, and the name of 85 different TI-99 retailer catalogs I  
> own in the Y axis. A value was entered in to a corresponding cell  
> each time a particular cartridge was listed for sale in a particular  
> catalog.
>
> The thought process here was that if a cartridge was heavily  
> advertised in these catalogs, that meant it would have been  
> available for a longer period of time, in a greater number of  
> catalogs, so the chance that it sold more copies was greater than a  
> cartridge that showed up in the catalogs only a few times.
>
> Out of this data came what I called the CCSR (Catalog Cartridge  
> Scarcity Rating) which is the number that appears in the far right  
> column of the Collecting Cartridges Kit Guide Book.
>
> CCSR------------Category
> keeper.
> easier
> (then)
> version
> deal.
> cartridge
> black
> casings

---

From: fdos <[email-masked]>
Date: Wed, 25 Nov 2009 13:22:13 -0700

Thanks Bill,

For this excellent and complete explanation on how you arrived at and 
categorized cartridge firmware status.  I do appreciate your efforts in 
doing this type of cataloging for everyone's benefit.

Bill S

computerclassics2000 wrote:
>  
> 
> Hi Bill,
> Virtually no manufacturer except TI and the 3rd Party partners who had 
> their cartridges actually manufactured at TI facilities (Milton Bradley, 
> Scott, Foresman) kept track of serial numbers, manufacturing runs, plant 
> codes or dates, so date stamps have no real meaning in the realm of 
> rarity determination. They are best used as Bryan Roppolo does, to 
> determine if he has obtained a true 1979 version of a cartridge to go 
> with his splendid collection.
> 
> As I mentioned in the earlier post, determination of Rarity Status is 
> subjective at best, because we will likely never know "how many" of any 
> particular cartridge title was produced by its manufacturer. This 
> assumes of course that one agrees with the idea that scarcity equates to 
> rarity.
> 
> Collection Kit that I offered back in 2005-2006, I created a spreadsheet 
> that listed the name of every known cartridge title in the X axis, and 
> the name of 85 different TI-99 retailer catalogs I own in the Y axis. A 
> value was entered in to a corresponding cell each time a particular 
> cartridge was listed for sale in a particular catalog.
> 
> The thought process here was that if a cartridge was heavily advertised 
> in these catalogs, that meant it would have been available for a longer 
> period of time, in a greater number of catalogs, so the chance that it 
> sold more copies was greater than a cartridge that showed up in the 
> catalogs only a few times.
> 
> Out of this data came what I called the CCSR (Catalog Cartridge Scarcity 
> Rating) which is the number that appears in the far right column of the 
> Collecting Cartridges Kit Guide Book.
> 
> CCSR------------Category
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, fdos 
> <fdosbrs@...> wrote:
>  >
>  > > --- In [email-masked] <mailto:TI994A%40yahoogroups.com> 
> <mailto:TI994A%40yahoogroups.com>, Owen

---

From: "ksarulofpurdimal" <[email-masked]>
Date: Wed, 25 Nov 2009 20:57:45 -0000

ROMOX dropped out of the market pretty fast due to some issues with failure to pay royalties to programmers, IIRC.  Navarone was using the ECPC cases for their modules, but once ROMOX disappeared, they ran out pretty quickly and switched to the TI style cases.  If the case is a cream one with a hand-written label, it was probably bought as a retail blank and programmed at one of the ROMOX ECPC stations.  Disk Fixer was one of the programs you could burn into them that way in stores.  I've seen both black and cream cases in the retail packaging.

I also have a black ECPC programmed as an E/A cart.  I haven't opened it to figure out what they did there, but it was also with a hand-written label.

All ECPC carts are relatively rare.  I have about a dozen different carts in ECPC cases, with the ROMOX titles being the most common (except for TYPO II, which has only come up for sale a couple of times ocer the last 10 years).

Jim