Subject: Twitter from a C64??

From: Owen Brand <[email-masked]>
Date: Wed, 6 Jan 2010 08:40:10 -0500

http://drc801171444.alkoottam.com/2010/01/06/twitter-from-your-commodore-64/

Richard needs to get on this asap...  ;)

Owen Brand
**Oprysoft**
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Wed, 6 Jan 2010 05:59:16 -0800 (PST)

Try following the links on that blog post... Looks like it's been hacked, or the whole thing is BS...!

>
>From: Owen Brand <[email-masked]>
>To: [email-masked]; [email-masked]
>Sent: Wed, 6 January, 2010 13:40:10
>Subject: [TI994A] Twitter from a C64??
>
> >
>
>
>
>
>  >
>>      
> 
>http://drc801171444 .alkoottam. com/2010/ 01/06/twitter- from-your- commodore- 64/
>

---

From: Keith Bergman <[email-masked]>
Date: Wed, 6 Jan 2010 09:35:12 -0500

I've seen a YouTube video of the C64 Twitter client, for what that's worth.
I recall hearding about a way to access the 'net on a very limited,
text-based way with a C64 as well, but don't quote me on that one.

On Wed, Jan 6, 2010 at 8:59 AM, mark wills <[email-masked]>wrote:

> *From:* Owen Brand <[email-masked]>
> *To:* [email-masked]; [email-masked]
> *Sent:* Wed, 6 January, 2010 13:40:10
> *Subject:* [TI994A] Twitter from a C64??
>
>
>
> http://drc801171444 .alkoottam. com/2010/ 01/06/twitter- from-your-
> commodore- 64/<http://drc801171444.alkoottam.com/2010/01/06/twitter-from-your-commodore-64/>
>

---

From: "Tursi" <[email-masked]>
Date: Wed, 6 Jan 2010 11:09:40 -0500

> text-based way with a C64 as well, but don't quote me on that one.

Yeah, via Contiki, which this twitter client runs on. :) Contiki was written 
for the C64 first. It includes a web browser and uses uIP (MicroIP) for its 
stack.

Here's the actual tool: 
http://www.vandenbrande.com/wp/2009/06/breadbox64-a-twitter-client-for-the-c64/

---

From: Brian Tristam Williams <[email-masked]>
Date: Thu, 7 Jan 2010 01:24:04 +0200

Did that TCP/IP stack for the TI-99/4A project ever come to fruition?

2010/1/6 Tursi <[email-masked]>

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>
>

-- 
Brian Tristam Williams

"One man can make a difference."

---

From: Owen Brand <[email-masked]>
Date: Wed, 6 Jan 2010 18:37:48 -0500

Willsy is probably farther along with the design than anyone else  
right now.  I would love to see it but lack the practical knowledge to  
help or contribute....  Guess I should get off my aZZ and learn some  
AL or GPL or something other than how to transfer Pitfall! To my TI  
via serial connection.  (That is a shameless plug for the newest  
upcoming Opry99er YouTube video). Anyway, if we could use a TCP/IP  
stack to Tweet (or Twitter or whatever) from the TI, I would seriously  
start up a text only webpage specifically for the TI.  I would love to  
operate a BBS, but don't have much knowledge of how to do that  
either.  I guess what I'm saying is that I'm waiting for others to do  
all the real hard work so I can reap the benefits.... Hehehe

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "Ksarul" <[email-masked]>
Date: Wed, 06 Jan 2010 20:15:11 -0500

I saw a link a year or two ago that had a C64 acting as a WEB server.
Slower than dirt and only accepted a max of two connections, but it DID
work. . .I tested it while they had it up.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Keith Bergman
Sent: Wednesday, January 06, 2010 9:35 AM
To: [email-masked]
Subject: Re: [TI994A] Twitter from a C64??

 

 

On Wed, Jan 6, 2010 at 8:59 AM, mark wills <markrobertwills@
<mailto:[email-masked]> yahoo.co.uk> wrote:

Try following the links on that blog post... Looks like it's been hacked, or
the whole thing is BS...!

From: Owen Brand <owenbrand@opry99er. <mailto:[email-masked]> com>
To: ti99-4a@yahoogroups <mailto:[email-masked]> .com;
TI994A@yahoogroups. <mailto:[email-masked]> com
Sent: Wed, 6 January, 2010 13:40:10
Subject: [TI994A] Twitter from a C64??

http://drc801171444 .alkoottam. com/2010/ 01/06/twitter-
<http://drc801171444.alkoottam.com/2010/01/06/twitter-from-your-commodore-64
/>  from-your- commodore- 64/

Owen Brand
**Oprysoft**
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 6 Jan 2010 19:57:04 -0500

Really....  We have a pretty wicked system.  Why shouldn't it be  
possible to access Internet sites (ACSII only of course)?  Richards  
BBS is amazing and truly a great asset... I also understand (but don't  
quote me) that the TI can also access thekeep--- Greg's BBS--- but a  
website could be another great tool.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 6, 2010, at 8:15 PM, "Ksarul" <[email-masked]> wrote:

> I saw a link a year or two ago that had a C64 acting as a WEB  
> server.  Slower than dirt and only accepted a max of two  
> connections, but it DID work. . .I tested it while they had it up.
>
>
>
> Jim
>
>
>
> From: [email-masked] [mailto:[email-masked]] On  
> Behalf Of Keith Bergman
> I've seen a YouTube video of the C64 Twitter client, for what that's  
> worth.  I recall hearding about a way to access the 'net on a very  
> limited, text-based way with a C64 as well, but don't quote me on  
> that one.
>
>
>
>
>
>
>
>
>
>
>
>
> On Wed, Jan 6, 2010 at 8:59 AM, mark wills <[email-masked] 
> > wrote:
>
>
>
> commodore- 64/

---

From: tursi <[email-masked]>
Date: Wed, 6 Jan 2010 17:39:22 -0800 (PST)

> TCP/IP stack to Tweet (or Twitter or whatever) from the TI,
> I would seriously start up a text only webpage specifically
> for the TI.  I would love to operate a BBS, but don't have

i don't know hopw far anyone else got, but I abandoned my work on this 
some time ago. First, there's no hardware it's worth doing forIMO, all we 
have is serial. second, and I think people often forget this, a TCP stack 
doesn't do anything by itself - you bstill need software written to 
support it. True that a twitter client isn't much more on top of the 
stack, but I don't know that that's so big a deal.

the real reason we don't have all this stuff is bec@ause you can't port it 
without an ANSI C compiler. if we really want to do a group effort, that's 
where we really need some energy. I got GCC as far as compiling my first 
test ap, but it's still pretty broken. :/

---

From: Brian Tristam Williams <[email-masked]>
Date: Thu, 7 Jan 2010 03:40:58 +0200

You could connect a microcontroller to the TI's serial port, or make an
Ethernet adapter for it, or for slow stuff like twitter, maybe even connect
it to the cassette port :) Not a good idea, I know

2010/1/7 tursi <[email-masked]>

-- 
Brian Tristam Williams

---

From: Owen Brand <[email-masked]>
Date: Wed, 6 Jan 2010 20:46:33 -0500

Hmmm... How would that come to be?  Would it be a PC program that spit  
out TMS9900 code or would it be a TI app?

Owen Brand
**Oprysoft**
Opry99er.com

---

From: tursi <[email-masked]>
Date: Wed, 6 Jan 2010 17:59:11 -0800 (PST)

> You could connect a microcontroller to the TI's serial
> port, or make an Ethernet adapter for it, or for slow stuff
> like twitter, maybe even connect it to the cassette port :)
> Not a good idea, I know

actually it's a good idea. Xport makes a nice little module that has a 
stack and everyuthing on it, and connects to the host via serial. That's 
what I'm expecting to use for my little expansion device, whenever I build 
build it. I don't have a way to get the url from my phone, but a search 
will find it. I believe Lantronix makes it. there are other embedded 
ethernet devices too, but at the time I last looked this was the cheapest 
complete one.

---

From: tursi <[email-masked]>
Date: Wed, 6 Jan 2010 18:01:04 -0800 (PST)

> Hmmm... How would that come to be?  Would it be a PC
> program that spit out TMS9900 code or would it be a TI app?

either one, but a pc based app would be easier to build.

---

From: Brian Tristam Williams <[email-masked]>
Date: Thu, 7 Jan 2010 04:09:46 +0200

Yeah, I meant the cassette port idea wasn't great, but it would at least run
on an unexpanded TI :)

*****100 OPEN #1:"CS1",INTERNAL,OUTPUT,FIXED
110 PRINT #1:"username":"password":"This is my first Tweet :-)"*

I've written PHP code to update Twitter, so that side of it is pretty easy.

-- 
Brian Tristam Williams

---

From: "Tursi" <[email-masked]>
Date: Wed, 6 Jan 2010 21:54:25 -0500

> Yeah, I meant the cassette port idea wasn't great, but it would at least 

heheh! I've looked at using the cassette port as an interface for other 
things, but I need to spend a little more time on it. I wasn't getting the 
results I expected from it.

I suppose using the cassette DSR and decoding it wouldn't be too hard.. we 
have applications that decode the waveforms on the PC now (are any of them 
open source?) Of course, as you note, the speed would be pretty abysmal. :)

---

From: Owen Brand <[email-masked]>
Date: Wed, 6 Jan 2010 21:56:10 -0500

Abysmal speed....  That sounds like the perfect name for a rock band

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 6, 2010, at 9:54 PM, "Tursi" <[email-masked]> wrote:

> > Yeah, I meant the cassette port idea wasn't great, but it would at  
> least
> > run
> > on an unexpanded TI :)
>

---

From: ti99_forever <[email-masked]>
Date: Wed, 6 Jan 2010 21:22:00 -0800 (PST)

Michael Zapf had the UDP portion finished, but he didn't use hardware handshaking... Still got the code somewhere. That was many years ago now.

--- On Wed, 1/6/10, tursi <[email-masked]> wrote:

> From: tursi <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Date: Wednesday, January 6, 2010, 8:39 PM
>     [email-masked]
> 
> 
>

---

From: "killroy732000" <[email-masked]>
Date: Thu, 07 Jan 2010 09:08:08 -0000

<snip>
Guess I should get off my aZZ and learn some AL or GPL or something other than how to transfer Pitfall! To my TI via serial connection.  (That is a shameless plug for the newest upcoming Opry99er YouTube video).
</snip>

hehe, if it wouldn't be for my CF7+ I wouldn't know how to get
anything transferred to the TI. So yes, I am looking forward seeing
your YouTube video :-)

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> <briantw@...> wrote:
> > 2010/1/6 Tursi <yahoogroup@...>
> > > worth.

---

From: fdos <[email-masked]>
Date: Thu, 07 Jan 2010 06:23:54 -0700

Owen,

You have to be a better con artist to get others to do the hard work 
that you specifically will benefit from.  Have you not noticed all the 
help I get with my specific software projects, and I'm no newbie, but 
then they probably feel sorry for this old guy with the deteriorating 
gray matter, and insufficient time to meet his goals without serious 
assistance.  They will help the programming handicapped with good ideas 
like I have. :-)  Sometimes a good challenge helps.

The truth is, we are just blessed with a great bunch of talented guys 
willing to help when they have the time--so timing has a lot to do with it.

Bill S

Owen Brand wrote:
>  
> 
> Willsy is probably farther along with the design than anyone else right 
> now.  I would love to see it but lack the practical knowledge to help or 
> contribute....  Guess I should get off my aZZ and learn some AL or GPL 
> or something other than how to transfer Pitfall! To my TI via serial 
> connection.  (That is a shameless plug for the newest upcoming Opry99er 
> YouTube video). Anyway, if we could use a TCP/IP stack to Tweet (or 
> Twitter or whatever) from the TI, I would seriously start up a text only 
> webpage specifically for the TI.  I would love to operate a BBS, but 
> don't have much knowledge of how to do that either.  I guess what I'm 
> saying is that I'm waiting for others to do all the real hard work so I 
> can reap the benefits.... Hehehe    
> 
> Owen Brand
> **Oprysoft**
> Opry99er.com <http://Opry99er.com>
> 
> On Jan 6, 2010, at 6:24 PM, Brian Tristam Williams <[email-masked] 
> <mailto:briantw @briantw.com>> wrote:
> 
>>  
>>
>> 2010/1/6 Tursi <yahoogroup@harmless 
>> <mailto:[email-masked]>lion.com <http://lion.com>>
>>
>>     <http://www.vandenbrande.com/wp/2009/06/breadbox64-a-twitter-client-for-the-c64/>http://www.vandenbrande.com/wp/2009/06/breadbox64-a-twitter-client-for-the-c64/
>>
>>
>>
>>
>>
>>     <http://yahoo.com/>group/TI994A/
>>
>>     <http://yahoo.com/>group/TI994A/join
>>        (Yahoo! ID required)
>>
>>     <mailto:[email-masked]>
>>
>>
>>
>>
>>
>>
>> -- 
>> Brian Tristam Williams
>>

---

From: Owen Brand <[email-masked]>
Date: Thu, 7 Jan 2010 08:55:09 -0500

Cool... Then keep your eyes peeled... I can do that one without much  
time or effort.  :). Got my serial connection rockin now and my MFM is  
humming at full capacity.  :). Love Pitfall.  I already have it on my  
TI, but I am re-doing it from the start to document the process.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 7, 2010, at 4:08 AM, "killroy732000" <[email-masked]>  
wrote:

>
>
> <snip>
> Guess I should get off my aZZ and learn some AL or GPL or something  
> other than how to transfer Pitfall! To my TI via serial connection.  
> (That is a shameless plug for the newest upcoming Opry99er YouTube  
> video).
> </snip>
>
> > > Yeah, via Contiki, which this twitter client runs on. :) Contiki  
> was
> > > written
> > > for the C64 first. It includes a web browser and uses uIP  
> (MicroIP)
> > > for its
> > > stack.
> > >
> > > Here's the actual tool:

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 14:09:47 -0800 (PST)

If we had a working IP stack on the TI, the first thing I would do would be to create a custom scripting language to deliver on-line content to TI machines. Maybe like HTML, but with a lot of the crud that the TI couldn't do removed. Custom server services/daemons on the server would serve the pages. We could host the servers on, say, port 99, and hey presto... You're off... Writing a scripting language in Forth is nut-droppingly easy.

Mark

>Sent: Wed, 6 January, 2010 23:37:48
>Willsy is probably farther along with the design than anyone else right now.  I would love to see it but lack the practical knowledge to help or contribute.. ..  Guess I should get off my aZZ and learn some AL or GPL or something other than how to transfer Pitfall! To my TI via serial connection.  (That is a shameless plug for the newest upcoming Opry99er YouTube video). Anyway, if we could use a TCP/IP stack to Tweet (or Twitter or whatever) from the TI, I would seriously start up a text only webpage specifically for the TI.  I would love to operate a BBS, but don't have much knowledge of how to do that either.  I guess what I'm saying is that I'm waiting for others to do all the real hard work so I can reap the benefits.... Hehehe    
>
>Owen Brand 
>**Oprysoft**
>Opry99er.com
>
>On Jan 6, 2010, at 6:24 PM, Brian Tristam Williams <briantw@briantw. com> wrote:
>
>
>  
>>>http://www.vandenbr ande.com/ wp/2009/06/ breadbox64- a-twitter- client-for- the-c64/
>>>
>>>
>>>
>>>
>>>
>>>------------ --------- --------- ------
>>>
>>>Yahoo! Groups Links
>>>
>>>
>>>
>>>
>>
>>
>>-- 
>>Brian Tristam Williams
>>