Subject: For the less technically challenged....

From: "Marc H" <[email-masked]>
Date: Mon, 02 Nov 2009 19:08:20 -0000

Ever since my better half decided to package our telephone (now VOIP....what ever that is), TV and internet together I have been unable to dial in to THR.  Is there some technical reason why my 1200 baud racehorse won't operate well on VOIP?  I'd sure like to get connected again through the console...

---

From: Owen Brand <[email-masked]>
Date: Mon, 2 Nov 2009 14:21:17 -0500

Digital vs. Analog.  I tried this with a Magic Jack and was unable to  
connect.  I forget who I was talking to about it, but essentially I  
learned that if it is a digital connection, for some reason the pure  
analog modems will not work properly.  It ends up scrambling the  
signal.  Richard might know a more technical reason.  But yea...  
Wasted money on a magic Jack...  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 2, 2009, at 2:08 PM, "Marc H" <[email-masked]> wrote:

> Ever since my better half decided to package our telephone (now  
> VOIP....what ever that is), TV and internet together I have been  
> unable to dial in to THR. Is there some technical reason why my 1200  
> baud racehorse won't operate well on VOIP? I'd sure like to get  
> connected again through the console...
>
>

---

From: "Tursi" <[email-masked]>
Date: Mon, 2 Nov 2009 14:59:21 -0500

This is what I do for a living (telephony). The previous explanation is 
essentially correct -- compression causes too much corruption of the 
tones for modems to work. This affects modems, fax, secure phones, and 
even normal touch-tone DTMF digits.

Digits are usually handled by detecting on one end, translating it to a 
message or command, and regenerating on the other end. For everything 
else, the modem signal itself usually needs to be demodulated, sent as 
data (rather than audio), and regenerated on the other side. There are a 
number of techniques for how that is handled, but then you get deep into 
modem theory. (Our team has a patent on one of them because it can deal 
with doppler shift from moving aircraft. ;) ).

If you can negotiate G.711 from end to end (ie: if you can configure 
Magic Jack to /only/ use G.711), then your modem should work too, as 
long as they don't compress it in the middle. G.711 is standard 
uncompressed telephone quality. (In fact, it's slightly compressed using 
A-Law or mu-Law, which is a simple translation that maps 13-bit audio 
down to 8-bits. It runs at 8kHz and modems are designed within its 
limits.)

Magic Jack is a waste of money anyway, in my professional opinion (with 
10 years in the field, can I say that yet?). Everything it does you can 
do with free software. If you really need a physical phone, a SIP phone 
is a better buy than an adapter to an analog phone, as it will use less 
power, connect directly to the network, and run more efficiently. You 
can get them pretty cheap these days and they look like standard phones. 
I've tried to say this before, but I got drowned out by its advocates 
when I did.

Of course, if you need to interwork with the real phone system, you do 
need to pay somebody to carry the calls. I use sipphone.com, and have 
done so for years, though I rarely actually make calls. There are no 
monthly fees, you prepay however much you like and it sits there till 
you use it (I think it may expire after a year or two.. I've put $10 on 
it twice in the last three years and never run out.) They also let you 
buy a PSTN number if you want to /receive/ calls, that's about $35 a 
year. You can also forward unanswered inbound calls to any number you 
like - I route mine to my cell phone (this costs the same as placing a 
call to the PSTN, though, but it's pennies a minute). As an example, I 
called Australia for 20 minutes and it cost me roughly 70 cents. If you 
don't want to interact with the PSTN (ie: just SIP to SIP calls), it's 
completely free.

There are numerous other services and I wouldn't necessarily recommend 
one over the other. I think even Skype interacts with the PSTN now, but 
I liked sipphone back in the day because they didn't use any proprietary 
protocols (ie: my standard SIP phone connects right to their server, 
don't know if that is true with Skype yet, but it wasn't 3 years ago.)

---

From: Gregory McGill <[email-masked]>
Date: Mon, 2 Nov 2009 13:36:12 -0800

1200 baud's codec is incompatible with the codec used for voip.. try 300 or
2400 or faster.. they are usually optimized for higher rates as that's what
fax machines used.

Greg

On Mon, Nov 2, 2009 at 11:08 AM, Marc H <[email-masked]> wrote:

> VOIP....what ever that is), TV and internet together I have been unable to
> dial in to THR. Is there some technical reason why my 1200 baud racehorse
> won't operate well on VOIP? I'd sure like to get connected again through the
> console...
>
>

---

From: Gregory McGill <[email-masked]>
Date: Mon, 2 Nov 2009 13:38:01 -0800

Funny.. I use a voip for thekeep.net :)  course it's a real one.. 8x8
(packet 8)   MagicJack just isn't capable of data.. its bearly capable of
voice..but then what do you expect for 2$ a month      8x8 or vonage both
work for data fine.

Greg

On Mon, Nov 2, 2009 at 11:21 AM, Owen Brand <[email-masked]> wrote:

> connect.  I forget who I was talking to about it, but essentially I learned
> that if it is a digital connection, for some reason the pure analog modems
> will not work properly.  It ends up scrambling the signal.  Richard might
> know a more technical reason.  But yea... Wasted money on a magic Jack...
>  :)
>
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>

---

From: ti99_forever <[email-masked]>
Date: Mon, 2 Nov 2009 13:39:44 -0800 (PST)

And remember, even voice doesn't work on MagicJack.Besides, I really don't want to contribute to Eric's commissions...I haven't tried it with Google Voice...Reminds me, I have two invites left...

--- On Mon, 11/2/09, Gregory McGill <[email-masked]> wrote:

From: Gregory McGill <[email-masked]>
Subject: Re: [TI994A] For the less technically challenged....
To: [email-masked]
Date: Monday, November 2, 2009, 4:36 PM

    
                  1200 baud's codec is incompatible with the codec used for voip.. try 300 or 2400 or faster.. they are usually optimized for higher rates as that's what fax machines used.  

Greg

On Mon, Nov 2, 2009 at 11:08 AM, Marc H <marc.hull@sbcglobal .net> wrote:

---

From: Barry Boone <[email-masked]>
Date: Mon, 2 Nov 2009 16:44:36 -0500

There are all sorts of flavors of VOIP.  If you want to run data across one reliably, you're better off using a VOIP provider that uses lossless encoding (i.e. no compression), and even then you can fall victim to jitter.   On compressed VOIP, different data speeds will behave differently depending on how well the analog encoding meshes with the compression method.

The VOIP lines provided by local cable companies usually do a little better since latency and jitter is much more controlled at that level and they tend to not compress, but they do tend to cost more.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Gregory McGill
Sent: Monday, November 02, 2009 3:38 PM
To: [email-masked]
Subject: Re: [TI994A] For the less technically challenged....

Funny.. I use a voip for thekeep.net<http://thekeep.net> :)  course it's a real one.. 8x8 (packet 8)   MagicJack just isn't capable of data.. its bearly capable of voice..but then what do you expect for 2$ a month      8x8 or vonage both work for data fine.

Greg
On Mon, Nov 2, 2009 at 11:21 AM, Owen Brand <[email-masked]<mailto:[email-masked]>> wrote:

Digital vs. Analog.  I tried this with a Magic Jack and was unable to connect.  I forget who I was talking to about it, but essentially I learned that if it is a digital connection, for some reason the pure analog modems will not work properly.  It ends up scrambling the signal.  Richard might know a more technical reason.  But yea... Wasted money on a magic Jack...  :)

Owen Brand
**Oprysoft**
Opry99er.com<http://Opry99er.com>

On Nov 2, 2009, at 2:08 PM, "Marc H" <[email-masked]<mailto:[email-masked]>> wrote:

---

From: Owen Brand <[email-masked]>
Date: Mon, 2 Nov 2009 16:58:51 -0500

Great... Where was Greg McGill when I bought my stupid worthless magic  
Jack??  :) Guess I should have asked the three experts first.. But  
hey, it works great to level out my desk!!!

Owen Brand
**Oprysoft**
Opry99er.com

On Nov 2, 2009, at 4:38 PM, Gregory McGill <[email-masked]>  
wrote:

> Funny.. I use a voip for thekeep.net :)  course it's a real one..  
> 8x8 (packet 8)   MagicJack just isn't capable of data.. its bearly  
> capable of voice..but then what do you expect for 2$ a month       
> 8x8 or vonage both work for data fine.
>
> Greg
>
>
> Digital vs. Analog.  I tried this with a Magic Jack and was unable  
> to connect.  I forget who I was talking to about it, but essentially  
> I learned that if it is a digital connection, for some reason the  
> pure analog modems will not work properly.  It ends up scrambling  
> the signal.  Richard might know a more technical reason.  But yea...  
>> unable to dial in to THR. Is there some technical reason why my  
>> 1200 baud racehorse won't operate well on VOIP? I'd sure like to  
>> get connected again through the console...
>
>

---

From: Marc Hull <[email-masked]>
Date: Mon, 2 Nov 2009 14:21:02 -0800 (PST)

what about 9600.  I have one of those race cars out in the garage somewhere.  Do you think that might work ?  And while we are talking 9600.... will Telco and an RS232 do 9600 ?  Blllllindiiiiing speed

From: Gregory McGill <[email-masked]>
Subject: Re: [TI994A] For the less technically challenged....
To: [email-masked]
Date: Monday, November 2, 2009, 3:36 PM

    

Greg

---

From: Barry Boone <[email-masked]>
Date: Mon, 2 Nov 2009 17:22:54 -0500

It's all very dependent on the codec, latency, and jitter.  Some VOIP providers have a mode they can be put in to be more fax compatible, which will help, but best results come from no compression at all.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Marc Hull
Sent: Monday, November 02, 2009 4:21 PM
To: [email-masked]
Subject: Re: [TI994A] For the less technically challenged....

Greg
On Mon, Nov 2, 2009 at 11:08 AM, Marc H <marc.hull@sbcglobal .net</mc/compose?to=[email-masked]>> wrote:

---

From: ti99_forever <[email-masked]>
Date: Mon, 2 Nov 2009 14:32:31 -0800 (PST)

Telco may lose data at that rate. I've had better results at 4800. Depends on what you are doing. A protocol like Xmodem make work fine, since it does software handshaking. XON/XOFF may help if the remote supports it. Raw data transfer at top speed will likely result in data loss.If you use TERM-80, you can do 19.2kbps without losing data with the proper cable.

--- On Mon, 11/2/09, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] For the less technically challenged....
To: [email-masked]
Date: Monday, November 2, 2009, 5:21 PM

    

--- On Mon, 11/2/09, Gregory McGill <arcadeshopper@ gmail.com> wrote:

From: Gregory McGill <arcadeshopper@ gmail.com>
Subject: Re: [TI994A] For the less technically challenged.. ..
To: TI994A@yahoogroups. com
Date: Monday, November 2, 2009, 3:36 PM

Greg

---

From: Gregory McGill <[email-masked]>
Date: Mon, 2 Nov 2009 15:02:38 -0800

9600 is FAX speed :)  so yeah it should work better.  It will always not be
as good as a true analog connection but what do you expect for cheap..

Greg

On Mon, Nov 2, 2009 at 2:21 PM, Marc Hull <[email-masked]> wrote:

>
>
> what about 9600.  I have one of those race cars out in the garage
> somewhere.  Do you think that might work ?  And while we are talking
> 9600.... will Telco and an RS232 do 9600 ?  Blllllindiiiiing speed
>

---

From: Gregory McGill <[email-masked]>
Date: Mon, 2 Nov 2009 15:03:41 -0800

Its not worthless :) I use magic jack every day at home. Its about as usable
as my cell is..

Greg

On Mon, Nov 2, 2009 at 1:58 PM, Owen Brand <[email-masked]> wrote:

> Jack??  :) Guess I should have asked the three experts first.. But hey, it
> works great to level out my desk!!!
>
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>

---

From: "Tursi" <[email-masked]>
Date: Mon, 2 Nov 2009 20:34:59 -0500

If you can set your codec to G.711, any speed will work. Otherwise, 
you're taking a crap-shot at it. If it works, it's by fluke, none of the 
modem protocols are designed to be compressed.

Telco does 9600 all right in my experience, using it for local file 
transfers.

>somewhere.  Do you think that might work ?  And while >we are talking