Subject: New version Cf2k v1.4

From: "fredkaal" <[email-masked]>
Date: Sun, 03 Jan 2010 14:02:45 -0000

Hi all,

A new version (again) of Cf2k v1.4 is available here:

http://members.ziggo.nl/fgkaal/Software/sw_cf2k.html#cf2k

It seems that when creating v1.3 I had overwritten v1.2 with v1.1 instead of making a backup of v1.2. Result of this is that all the additions I did in v1.2 (keyboard mode 5 and execute function) disappeared in v1.3 So ... this functionality is back again (I hope)

Fred ;-)

---

From: "hexbus" <[email-masked]>
Date: Sun, 03 Jan 2010 23:48:09 -0000

Hi, Fred -

Do you set up the lower case character set or the keyboard scan in these new versions?  Just wanted to know before I made EPROMs out of them. :-)

Thanks,
Jon

---

From: "fredkaal" <[email-masked]>
Date: Mon, 04 Jan 2010 09:24:01 -0000

Jon,
I added something like call key(5,k,s). This is the same as the path I did!

Fred !

--- In [email-masked], "hexbus" <jon@...> wrote:
> --- In [email-masked], "fredkaal" <fgkaal@> wrote:
> >
> > Hi all,
> >

---

From: ti99_forever <[email-masked]>
Date: Mon, 4 Jan 2010 01:35:34 -0800 (PST)

If you run direct from the title screen, you likely will get the LARGE character set, that on a 4A uses the whole 8 rows, and will run together.
As for the small caps, I believe they are loaded automatically too, but I cannot recall.

--- On Mon, 1/4/10, fredkaal <[email-masked]> wrote:

> From: fredkaal <[email-masked]>
> Subject: [TI994A] Re: New version Cf2k v1.4
> To: [email-masked]
> Date: Monday, January 4, 2010, 4:24 AM
> Jon,
> --- In TI994A@yahoogroups..com,
> "hexbus" <jon@...> wrote:
> >
> > Hi, Fred -
> > 
> > Do you set up the lower case character set or the
> keyboard scan in these new versions?  Just wanted to
> know before I made EPROMs out of them. :-)
> > 
> > Thanks,
> > Jon
> > 
> > > It seems that when creating v1.3 I had
> overwritten v1.2 with v1.1 instead of making a backup of
> v1.2. Result of this is that all the additions I did in v1.2
> (keyboard mode 5 and execute function) disappeared in v1.3
> So ... this functionality is back again (I hope)
> > > 
> > > Fred ;-)
> > >
> >
> 
> 
> 
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: "hexbus" <[email-masked]>
Date: Mon, 04 Jan 2010 12:44:54 -0000

No issues - I have the assembly code that Tursi wrote to load a lower case character set.  If you run DM2K or CF2K without the code, only the larger caps show up (there's a good example of that in the 2009 TI Faire video.)  The problem is that I was testing on a Corcomp 9900 mini PES, which *did* set up the lower case video on its title screen.

Since Fred put the keyboard setup routine in there, the CTRL key will work right off of the bat, now.  I just have to add the lower case, split up the program data, copy it to 32K, make an EPROM out of it, and voila, voila... DM2K and CF2K in a cart :-)

I'll update cart images for both in the next week and put them on hexbus.com.  I'm looking forward to CF2K on a cart to manage my CF2K.

Jon

--- In [email-masked], ti99_forever <ti99_forever@...> wrote:
> --- On Mon, 1/4/10, fredkaal <fgkaal@...> wrote:
> 
> > From: fredkaal <fgkaal@...>
> > --- In TI994A@...,
> > "hexbus" <jon@> wrote: