Subject: RE: [TI994A] a way to (partly) de fu......dge WHT.....

From: Marc Hull <[email-masked]>
Date: Mon, 16 Nov 2009 10:25:16 -0800 (PST)

There are many wrenches in WHT  currently.  I don't mean to disparage any ones format,  work or ideas.  They are almost all without fault ;-)  My suggestion was aimed really at one huge problem IMHO with the site.....

It's impossible for a new guy and a lot of not so new guys to A) navigate that beast with any efficiency at all and B) know if what you are looking at does what you hope it does.  A data area combined with a converting area and a special needs area seems ideal for me.  Ernie is taking the time to do this mission impossible so perhaps it is best left up to him.

Two cents....

--- On Sat, 11/14/09, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] a way to (partly) de fu......dge WHT.....
To: [email-masked]
Date: Saturday, November 14, 2009, 12:09 PM

  

      

Tiny wrench time! (yes, there is an 'r' in that word)

One thing that could get us in trouble is the many cartridges that were "fixed" for the Geneve and/or 80 column devices (ie, V9938, V9958 video).  I would presume most of them are contained on disk images specific to the offending device.  (Geneve carts are loaded by disk and not through the emulator menu).  If true, they just need to be maintained separately. 

The disks then become a special case for your suggestion, Marc.  I seem to recall running across one or two good compilations that might be a good starting point.   Looks like picking a proper, common format and understanding how (or if) that format can be converted are two important steps to work through :)

Tim

> To: TI994A@yahoogroups. com
> From: marc.hull@sbcglobal .net
> Date: Sat, 14 Nov 2009 01:40:37 +0000
> Subject: [TI994A] a way to (partly) de fu......dge WHT.....
> 
> What if instead of trying to store every version of the same cart, The actual cart dumps were stored in the most popular format in one area and in a separate area the instructions and tools for conversion to the many emulator formats were kept. This would eliminate much of the front end confusion and put the responsibility for compatibility on the emulator supporters (who would be more than happy to comply in order to keep up to date.) If a tool for conversion does not exist for a specific emulator then it's time to build one or let that format go...... 
> 
> 
> 
> ------------ --------- --------- ------
> 
> Yahoo! Groups Links
> 
 http://groups. yahoo.com/ group/TI994A/
 		 	   		  
Hotmail: Trusted email with Microsoft's powerful SPAM protection. Sign up now.

---

From: mark wills <[email-masked]>
Date: Mon, 16 Nov 2009 20:28:33 -0800 (PST)

I agree. Frustration with WHT was what led to me to make planet-99 - planet-99 is searchable and includes descriptions of the files.

I would suggest that re-organisation of WHT should be a priority. If it were me, I would organise it by category. I.e:

(taking a games directory as a hypothetical example)
Games
--Arcade
----TI Basic
----Extended Basic
----Assembly
--Adventure
----TI BAsic
----Extended Basic
----Assembly
----TOD Games

A documents folder:
Documents
--Programming
----TI Basic Programming
----Extended Basic Programming
----Assembly Language Programming
----C Programming
----Forth Programming
--Manuals
----TI Equipment
------TI RS232 Controller
------TI Disk Controller
------UCSD Pascal Card
----Corcomp
------Disk Controller

etc etc

That might be a little 'over normalised' for some tastes. In that case, taking the manuals folder as an example, it could be organised thus:

Manuals
--Disk Controllers
--Serial Cards
--RAM Disks

etc etc.

Of course, on an FTP site, it is not really possible include descriptions of the files - you are just given a file directory - very long file names could be used (e.g. TI-PHP-1234-5678-0-Disk-Controller-Manual.pdf) but that would be cumbersome. A better approach would be to have a CONTENTS.TXT file in each directory that listed each file, with a short description.

Just some suggestions....

Mark.

>
>From: Marc Hull <[email-masked]>
>To: [email-masked]
>Sent: Mon, 16 November, 2009 19:25:16
>--- On Sat, 11/14/09, Insane Multitasker <insane_m@hotmail. com> wrote:
>
>
>>From: Insane Multitasker <insane_m@hotmail. com>
>>To: ti994a@yahoogroups. com
________________________________
Hotmail: Trusted email with Microsoft's powerful SPAM protection. Sign up now.

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 16 Nov 2009 22:38:44 -0600

Mission Impossible... now what sort of positive reinforcement is that?  >grin<   

I've been working through the Geneve file list and will give that info to Ernie, hopefully before the end of the week, just to separate what I know is Geneve related from the rest of the files.  Ultimately Ernie's Adventure (wow, another text adv. possibility?) maybe needs some helpers.   Like you said, much of that is in his hands.  

To: [email-masked]
From: [email-masked]
Date: Mon, 16 Nov 2009 10:25:16 -0800
Subject: RE: [TI994A] a way to (partly) de fu......dge WHT.....

Two cents....

_________________________________________________________________
Hotmail: Free, trusted and rich email service.
http://clk.atdmt.com/GBL/go/171222984/direct/01/