Subject: "Circuit bent" TI-99

From: "opry99er" <[email-masked]>
Date: Mon, 21 Dec 2009 21:23:23 -0000

Check this out... I'm guessing this is cool... But it might just be a broke console with knobs that affect the VDP and sound chip

http://iphone.ebay.com/Pages/ViewItem.aspx?aid=160385981474&ebayref=http%3A%2F%2Fcgi.ebay.com%3A80%2FCircuit-Bent-TI99-Video-Instrument-Unique-Free-Ship_W0QQitemZ160385981474QQcmdZViewItemQQptZLH_DefaultDomain_0%3Fhash%3Ditem2557bfdc22%26autoredirect%3Doff

---

From: Owen Brand <[email-masked]>
Date: Mon, 21 Dec 2009 16:24:44 -0500

If that is an iPhone only page, search for this item number

Item number:	160385981474

Owen Brand
**Oprysoft**
Opry99er.com

On Dec 21, 2009, at 4:23 PM, "opry99er" <[email-masked]> wrote:

> Check this out... I'm guessing this is cool... But it might just be  
> a broke console with knobs that affect the VDP and sound chip
>

---

From: ti99_forever <[email-masked]>
Date: Mon, 21 Dec 2009 13:43:25 -0800 (PST)

Seen it - it kind of reminds me of torture... poor little TI, I don't know what it did to deserve becoming a cyberTI.

--- On Mon, 12/21/09, opry99er <[email-masked]> wrote:

> From: opry99er <[email-masked]>
> Subject: [TI994A] "Circuit bent" TI-99
> To: [email-masked]
> Date: Monday, December 21, 2009, 4:23 PM
> Check this out... I'm guessing this
> is cool... But it might just be a broke console with knobs
> that affect the VDP and sound chip
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: tursi <[email-masked]>
Date: Mon, 21 Dec 2009 14:30:32 -0800 (PST)

> Check this out... I'm guessing this is cool... But it might just be a 
> broke console with knobs that affect the VDP and sound chip

Yeah.. it's kind of a joke. Circuit bending is this weird thing that has 
popped up where, basically, people short and break old hardware to see if 
it will do anything interesting. IIRC, this guy is mostly screwing with 
the VRAM lines. it's true enough that if you fed audio in there you could 
get some kind of feedback going.

They've tried to sell these on EBay for ridiculous amounts over the years.

---

From: "computerclassics2000" <[email-masked]>
Date: Mon, 21 Dec 2009 23:00:28 -0000

If it helps, one of the Circuit Bent auctioneers in Jan 2009 included a photo of the 'manual' provided with his console. I saved the image and keyed in the text. After reading it, I understand so little of what it is trying to convey, that I wondered why I bothered typing it all in. :-)

I have a 99er friend in Phoenix who makes these. Apparently they are all the rage with a certain crowd of young folks? I see that this seller is from Wisconsin, so I don't know if the info below is universal to ALL Circuit Bent consoles, or just the one being auctioned in Jan 2009? Here is the 'manual'.
======
Getting Started:
1 - plug in the provided power adapter to the back of the device.
2 - turn all the knobs to their off (full CCW) position.
3 - connect a video monitor or projector to the composite RCA video output jack.
4 - connect the audio output on the side to an amp or mixer then power on the device.

What you should see is the standard TI-99/4A boot screen. If the screen is black or solid blue, turn off and wait 5 seconds before powering back on. If the screen continues to hold light blue, check that the "sub" knob is turned off.

Using the Audio input to drive the video:
1 - connect a line level audio signal (from a mixer of other line elvel device) into the audio in 1/4 jack.
2 - turn the hi, mid, low and sub knobs until the indicator LEDs start flashing.

The video should be changing in response to the audio signal. The sub frequencies will randomly shuffle the pixels, the LOX will cycle through colors, and the mid and hi will create scrolling bars. A bit of tweeking will be needed to find the proper setting for your taste. The sub frequencies need to be triggered in order to prevent the video buffer from clearing. If the video buffer does clear, the screen will go solid light blue. In the event that this happens, power off the device and wait 5 seconds before powering back on.

Oscillators and the Patchbay:
The oscillators have individual pitch controls and outputs for routing in the pitchbay. You'll need several RCA patch cords to fully utilize the sound generating features. Any RCA cable will do.

You'll need to turn on each of the oscillators on with the switches. The oscillators were not meant to be patched into the mixer directly. To get sound out, you must patch the oscillators into the ring modulator inputs (ax-y, bx-y, cx-y, dx-y). So patch the ring modulator outs a,b,c and d into the passive mixer jacks. Then patch the oscillators into the ring modulator inputs. If you want all the oscillators to be independent, then patch osc 1 out to ringmod in ax, osc 2 to bx, osc 3 to cx, osc 4 to dx. Try mixing the oscillators by patching osc 1 into to ax and osc 2 into ay. You can see now that the ring mod patches have two inputs and one out. That is ring mod out a is the result of combining signals from ax and ay.

Where it gets interesting is with the top row of the patchbay. The audio input will trigger a series of pulses as it crosses the thresholds set with the knobs on the right. These pulses can be patched into the ring modulators to mix with the normal oscillator signals for some added grit. I typically patch the oscillators into the x inputs of the ring mods and the audio trigger pulses into the y inputs of the ring mods.

Feedback:
You can create feedback within the device just by simply connecting the audio output to its input. You must use a mixer to accomplish this. Plug the TI99 audio out into a free channel on your mixer and then run a cable from the aux send on the mixer to the audio input on the TI99. Turn up the aux send so that the TI99 is sending its audio signal back into itself. Now try patching the oscillators and audio trigger outputs into the ring mod inputs in various ways. You can also adjust he audio triggering threshold for more control.

DO NO PLUG ANYTHING INTO THE RCA JACKS OR AUDIO JACKS THAT IS NOT MENTIONED ABOVE. dAMAGE MAY OCCUR IF YOU DO.
======

BillG

---

From: Owen Brand <[email-masked]>
Date: Mon, 21 Dec 2009 18:10:29 -0500

That's fascinating stuff... It essentially turns the console into a  
light show for a DJ.  Rather than have motion activated lights, the DJ  
has a TI all jazzed up to do this....  According to some info online,  
these are often hooked up to a projector screen and used as visual  
accompaniment to live or prerecorded music...  I could actually use  
one of these at one of my shows to provide a classic visual.  :). Neat

Owen Brand
**Oprysoft**
Opry99er.com

On Dec 21, 2009, at 6:00 PM, "computerclassics2000" <[email-masked] 
 > wrote:

> If it helps, one of the Circuit Bent auctioneers in Jan 2009  
> included a photo of the 'manual' provided with his console. I saved  
> the image and keyed in the text. After reading it, I understand so  
> little of what it is trying to convey, that I wondered why I  
> bothered typing it all in. :-)
>
> I have a 99er friend in Phoenix who makes these. Apparently they are  
> all the rage with a certain crowd of young folks? I see that this  
> seller is from Wisconsin, so I don't know if the info below is  
> universal to ALL Circuit Bent consoles, or just the one being  
> auctioned in Jan 2009? Here is the 'manual'.
> ======
> Getting Started:
> What you should see is the standard TI-99/4A boot screen. If the  
> screen is black or solid blue, turn off and wait 5 seconds before  
> powering back on. If the screen continues to hold light blue, check  
> that the "sub" knob is turned off.
>
> 1 - connect a line level audio signal (from a mixer of other line  
> elvel device) into the audio in 1/4 jack.
> The video should be changing in response to the audio signal. The  
> sub frequencies will randomly shuffle the pixels, the LOX will cycle  
> through colors, and the mid and hi will create scrolling bars. A bit  
> of tweeking will be needed to find the proper setting for your  
> taste. The sub frequencies need to be triggered in order to prevent  
> the video buffer from clearing. If the video buffer does clear, the  
> screen will go solid light blue. In the event that this happens,  
> power off the device and wait 5 seconds before powering back on.
>
> The oscillators have individual pitch controls and outputs for  
> routing in the pitchbay. You'll need several RCA patch cords to  
> fully utilize the sound generating features. Any RCA cable will do.
>
> You'll need to turn on each of the oscillators on with the switches.  
> The oscillators were not meant to be patched into the mixer  
> directly. To get sound out, you must patch the oscillators into the  
> ring modulator inputs (ax-y, bx-y, cx-y, dx-y). So patch the ring  
> modulator outs a,b,c and d into the passive mixer jacks. Then patch  
> the oscillators into the ring modulator inputs. If you want all the  
> oscillators to be independent, then patch osc 1 out to ringmod in  
> ax, osc 2 to bx, osc 3 to cx, osc 4 to dx. Try mixing the  
> oscillators by patching osc 1 into to ax and osc 2 into ay. You can  
> see now that the ring mod patches have two inputs and one out. That  
> is ring mod out a is the result of combining signals from ax and ay.
>
> Where it gets interesting is with the top row of the patchbay. The  
> audio input will trigger a series of pulses as it crosses the  
> thresholds set with the knobs on the right. These pulses can be  
> patched into the ring modulators to mix with the normal oscillator  
> signals for some added grit. I typically patch the oscillators into  
> the x inputs of the ring mods and the audio trigger pulses into the  
> y inputs of the ring mods.
>
> Feedback:
> You can create feedback within the device just by simply connecting  
> the audio output to its input. You must use a mixer to accomplish  
> this. Plug the TI99 audio out into a free channel on your mixer and  
> then run a cable from the aux send on the mixer to the audio input  
> on the TI99. Turn up the aux send so that the TI99 is sending its  
> audio signal back into itself. Now try patching the oscillators and  
> audio trigger outputs into the ring mod inputs in various ways. You  
> can also adjust he audio triggering threshold for more control.
>
> DO NO PLUG ANYTHING INTO THE RCA JACKS OR AUDIO JACKS THAT IS NOT  
> MENTIONED ABOVE. dAMAGE MAY OCCUR IF YOU DO.
> ======
>
> BillG
>

---

From: "Tursi" <[email-masked]>
Date: Mon, 21 Dec 2009 19:53:30 -0500

> one of these at one of my shows to provide a classic visual.  :). Neat

Yeah.. or you could just use a PC with WinAmp and any of ten thousand* 
software visualizers, which will run higher resolution, more predictable 
patterns, less manual fiddling, and not require the destruction of a working 
console. :)

I dunno. While some, like the one Bill typed up about, clearly put a lot of 
work into it, a lot of the so-called circuit bending I've seen is just kids 
shorting out boards till they die.

FWIW, though, Atari first did something like these way back in the 70s. :)
http://en.wikipedia.org/wiki/Atari_Video_Music

(* - literally!!)

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 21 Dec 2009 21:14:11 -0600

Poor TI.  Reminds me of the Myarc-card-turned-cheese-grater from long ago...

;)
 
> From: [email-masked]
> Date: Mon, 21 Dec 2009 13:43:25 -0800
> Subject: Re: [TI994A] "Circuit bent" TI-99
> 
 		 	   		  
_________________________________________________________________
Hotmail: Trusted email with powerful SPAM protection.
http://clk.atdmt.com/GBL/go/177141665/direct/01/

---

From: mark wills <[email-masked]>
Date: Mon, 21 Dec 2009 20:28:37 -0800 (PST)

Looks like it's been Borged. Resistance clearly was futile.

Dreadful 

>
>From: tursi <[email-masked]>
>Sent: Mon, 21 December, 2009 23:30:32

---

From: Owen Brand <[email-masked]>
Date: Mon, 21 Dec 2009 23:33:10 -0500

Ahhh another Trekkie.....  Thanks Mark...  You freaking rock even more  
than I thought you did.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Mon, 21 Dec 2009 20:34:54 -0800 (PST)

As it's Christmas and all that, I thought why not have a bit of fun.

So, I thought we could make a list of 10 TI Commandments? And lo, verily, it could be much fun.

I'll start the ball rolling (if we get more than 10 we'll form a TI Cult, disappear into a corner to argue about which ones are the best, and grow long beards).

Ok, here we go:

1) THOU SHALT NOT COVET THY COMMODORE 64

---

From: Owen Brand <[email-masked]>
Date: Mon, 21 Dec 2009 23:39:36 -0500

2) Thou shalt not plug thy wired remote
Controllers into the CS1 port.

Owen Brand
**Oprysoft**
Opry99er.com

On Dec 21, 2009, at 11:34 PM, mark wills <[email-masked]>  
wrote:

> I'll start the ball rolling (if we get more than 10 we'll form a TI  
> Cult, disappear into a corner to argue about which ones are the  
> best, and grow long beards).
>
> Ok, here we go:
>

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 21 Dec 2009 22:54:38 -0600

3) Thou shalt not remove thy peripheral cards nor thy flex cable nor thy sidecar devices whilst electrons are flowing throughout the system. 

To: [email-masked]
From: [email-masked]
Date: Mon, 21 Dec 2009 23:39:36 -0500
Subject: Re: [TI994A] FUN: TI Commandments

Owen Brand
**Oprysoft**
Opry99er.com

On Dec 21, 2009, at 11:34 PM, mark wills <[email-masked]> wrote:

Ok, here we go:

 		 	   		  
_________________________________________________________________
Your E-mail and More On-the-Go. Get Windows Live Hotmail Free.
http://clk.atdmt.com/GBL/go/171222985/direct/01/

---

From: mark wills <[email-masked]>
Date: Mon, 21 Dec 2009 20:59:43 -0800 (PST)

Verily brother. For to do so there would be much wailing and gnashing of teeth!

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Tue, 22 December, 2009 5:39:36
>On Dec 21, 2009, at 11:34 PM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>>

---

From: mark wills <[email-masked]>
Date: Mon, 21 Dec 2009 21:01:37 -0800 (PST)

Forsooth. It shall be so!

>
>From: Insane Multitasker <[email-masked]>
>To: [email-masked]
>Sent: Tue, 22 December, 2009 5:54:38
>Subject: RE: [TI994A] FUN: TI Commandments
>
> >
>
>
>
>
>  >
>>      
> 
>>
>
________________________________
 >To: TI994A@yahoogroups. com
>From: owenbrand@opry99er. com
>________________________________
Your E-mail and More On-the-Go. Get Windows Live Hotmail Free. Sign up now. >

---

From: Owen Brand <[email-masked]>
Date: Tue, 22 Dec 2009 00:03:58 -0500

I would like to propose an amendment to my commandment.  I would like  
to add "and neither shalt thou plug thy cassette player into the holy  
joystick port... For if thou do-est so, the earth shall crack and hell  
shall spilleth over". We can have a parliamentary vote on this  
amendment if it so pleases the court.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "Jacques Groslouis" <[email-masked]>
Date: Tue, 22 Dec 2009 06:21:59 -0400

How about:

Thou shall not criticize thou neighbour's TI emulator or simulator.

Jacques

----- Original Message ----- 
From: "mark wills" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, December 22, 2009 12:34 AM
Subject: [TI994A] FUN: TI Commandments

So, I thought we could make a list of 10 TI Commandments? And lo, verily, it 
could be much fun.

I'll start the ball rolling (if we get more than 10 we'll form a TI Cult, 
disappear into a corner to argue about which ones are the best, and grow 
long beards).

Ok, here we go:

---

From: Marc Hull <[email-masked]>
Date: Tue, 22 Dec 2009 06:18:04 -0800 (PST)

<SNIP>   (if we get more than 10 we'll form a TI
Cult, disappear into a corner to argue about which ones are the best,
and grow long beards).

ROFLMAO !!  I think I might have even shit my pants a bit......

Gracias K......

--- On Mon, 12/21/09, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: [TI994A] FUN: TI Commandments
To: [email-masked]
Date: Monday, December 21, 2009, 10:34 PM

  

Ok, here we go:

---

From: "jesse_slicer" <[email-masked]>
Date: Tue, 22 Dec 2009 14:58:02 -0000

Thou shalt release thine Alpha Lock key before attempting to use joystick UP and verily, thou shalt re-engage thine Alpha Lock for thy programming tasks.

---

From: fdos <[email-masked]>
Date: Tue, 22 Dec 2009 08:08:15 -0700

Thou shalt not remove one iota of FUN from TI computing!

---

From: Owen Brand <[email-masked]>
Date: Tue, 22 Dec 2009 10:23:37 -0500

Thou shalt not use important software diskettes without first making  
backup copies first--- lest ye be banished to the seventh ring of  
hell.... Wherein thy GRAM Kracker shall crumble and thy speech synth  
shall go mute.

Owen Brand
**Oprysoft**
Opry99er.com

On Dec 22, 2009, at 9:58 AM, "jesse_slicer" <[email-masked]> wrote:

> Thou shalt release thine Alpha Lock key before attempting to use  
> joystick UP and verily, thou shalt re-engage thine Alpha Lock for  
> thy programming tasks.
>
> > I'll start the ball rolling (if we get more than 10 we'll form a  
> TI Cult, disappear into a corner to argue about which ones are the

---

From: "hjalmarii" <[email-masked]>
Date: Wed, 23 Dec 2009 00:42:55 -0000

Thou shall not stick thy hand in thy P-Box before 120 grains of sand have flowed through thy hour glass.  --Hal

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Dec 22, 2009, at 9:58 AM, "jesse_slicer" <jslicer@...> wrote:
> 
> > --- In [email-masked], mark wills <markrobertwills@> wrote:
> > >

---

From: Keith Bergman <[email-masked]>
Date: Tue, 22 Dec 2009 19:47:49 -0500

Thou shalt not measure thine screen from the same place for DISPLAY AT as
for CALL VCHAR, to do so will be an abomination which will render thy
carefully plotted displays abominable in the eyes of the end-user.

On Tue, Dec 22, 2009 at 7:42 PM, hjalmarii <[email-masked]> wrote:

> --- In [email-masked] <TI994A%40yahoogroups.com>, Owen Brand
> <owenbrand@...> wrote:
> >
> > > --- In [email-masked] <TI994A%40yahoogroups.com>, mark wills
> <markrobertwills@> wrote:
> > > >

---

From: "ti99_forever" <[email-masked]>
Date: Wed, 23 Dec 2009 01:15:17 -0000

Ha! That is funny as hell!

--- In [email-masked], "hjalmarii" <hals12@...> wrote:
> --- In [email-masked], Owen Brand <owenbrand@> wrote:
> >
> > On Dec 22, 2009, at 9:58 AM, "jesse_slicer" <jslicer@> wrote:
> >

---

From: R Halter <[email-masked]>
Date: Sat, 26 Dec 2009 14:27:02 -0600

> Seen it - it kind of reminds me of torture... poor little TI, I don't know what it did to deserve becoming a cyberTI.

I've seen it before.  Poor thing looks like it's been captured by the 
Borg...  :(

-- 
  I want to die peacefully in my sleep like my grandfather... not 
screaming and yelling like the passengers in his car.

---

From: R Halter <[email-masked]>
Date: Sat, 26 Dec 2009 14:32:19 -0600

> Looks like it's been Borged. Resistance clearly was futile.

I now have this urge to plug in my TE-II cartridge and make my TI say "I 
am Locutus of Borg," etc.

---

From: ti99_forever <[email-masked]>
Date: Sat, 26 Dec 2009 12:39:20 -0800 (PST)

It really isn't robotic enough. Now there *was* a PC text-to-speech translator from the mid-80's that surely was robotic... it is all it could do.

----- Original Message ----
> From: R Halter <[email-masked]>
> Sent: Sat, December 26, 2009 3:32:19 PM

---

From: ti99_forever <[email-masked]>
Date: Sat, 26 Dec 2009 12:55:13 -0800 (PST)

Although Borg's weren't all that robotic, were they? Certainly not like the Cybermen, which left only a human brain and a very robotic voice.

----- Original Message ----
> From: ti99_forever <[email-masked]>
> Sent: Sat, December 26, 2009 3:39:20 PM
> It really isn't robotic enough. Now there *was* a PC text-to-speech translator 
> from the mid-80's that surely was robotic... it is all it could do.
> 
> 
> 
> > From: R Halter

---

From: mark wills <[email-masked]>
Date: Sat, 26 Dec 2009 14:49:48 -0800 (PST)

Nah, for Robotic, you want Daleks (Dr. Who?) - not the Borg ;-)

Mark

>Sent: Sat, 26 December, 2009 20:39:20
>>> From: R Halter <rheahalter@att. net>
>>>   I want to die peacefully in my sleep like my grandfather. .. not 
>>> ------------ --------- --------- ------
>>> 
>>> Yahoo! Groups Links
>>> 
>>> 
>>> 
>
>
>