Subject: Updates to WHT

From: "epergrem" <[email-masked]>
Date: Sat, 07 Nov 2009 19:03:25 -0000

Hi,
Sorry to do this to you guys, but we need to get an idea of how the torrents will deal with changes to the WHT site. 

I have made the following minor modifications to the WHT site:

New directory:
Hardware\Dijit

Move -> avpcdoc.mac & *.pdf
From -> Hardware
To -> Hardware\Dijit 

New directories:
Software manuals - Third Party\Amerisoft
Software manuals - Third Party\Republic Software

Move -> 3d World (Amerisoft) manual.max & *.pdf
From ->Software manuals - Third Party
To -> Software manuals - Third Party\Amerisoft

Move -> Republic Software - Util 1.pdf, Utilities 1(Republic) manual.max & *.pdf
To ->Software manuals - Third Party\Republic Software

Thanks,
Ernie

---

From: "Tursi" <[email-masked]>
Date: Sat, 7 Nov 2009 14:20:54 -0500

> Sorry to do this to you guys, but we need to get an idea of how the 
> torrents will deal with changes to the WHT site.

They simply don't. Changes require the torrent to be regenerated. They 
are completely detached from the WHT site, except to refer to it by 
name.

Changes made on the FTP don't affect anyone's local data. People who 
have already downloaded the torrent have the option of trying to make 
the changes locally, then downloading a new torrent (when it's created) 
to the same location. The torrent client will check the existing data, 
and only download the pieces it doesn't already have in place. Note that 
if anyone makes local changes without updating the torrent, they will 
break their seed.

So, we either need to track all the changes made with the goal of 
handling it manually, or re-download from scratch, or some newer clever 
scheme (rsync?). :)

---

From: "Tony Knerr" <[email-masked]>
Date: Sat, 07 Nov 2009 20:08:15 -0000

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> ...

When an updated torrent is created (I'd wait a few months for this),
the person creating the new torrent from the site will do so having all the changes in place. I now have the ability to do so, so there are at least 2 of us. 

Someone downloading the new torrent can make the changes (moved files) manually in the directories on their pc, or run a batch file to do so. This is important to do _before_ starting to download the new torrent, or the downloader will end up with copies of the files in 2 places in their whtech directory.

So the changes need to be well documented between torrent versions.

Batch files are not my forte, but the following one should work for the changes you've just reported. It is untested and will only work if your torrent directory is "C:\ftp.whtech.com". I'm sure someone more skilled can tweak it. Note - do not run this file if you are currently uploading or downloading the torrent, wait until a new version is released, this is only an example of how we can accomplish the task. 

*start of batch file*

md "c:\ftp.whtech.com\datasheets and manuals\hardware\digit"

move "c:\ftp.whtech.com\datasheets and manuals\hardware\avpcdoc.mac" "c:\ftp.whtech.com\datasheets and manuals\hardware\digit\avpcdoc.mac"

move "c:\ftp.whtech.com\datasheets and manuals\hardware\avpcdoc.pdf" "c:\ftp.whtech.com\datasheets and manuals\hardware\digit\avpcdoc.pdf"

md "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\Amerisoft"

md "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\Republic Software"

move "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\3d World (Amerisoft) manual.max" "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\Amerisoft\3d World (Amerisoft) manual.max"

move "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\3d World (Amerisoft) manual.pdf" "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\Amerisoft\3d World (Amerisoft) manual.pdf"

move "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\Republic Software - Util 1.max" "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\Republic Software\Republic Software - Util 1.max"

move "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\Republic Software - Util 1.pdf" "c:\ftp.whtech.com\datasheets and manuals\Software manuals - Third Party\Republic Software\Republic Software - Util 1.pdf"

*end of batch file*
  
Tony

---

From: "epergrem" <[email-masked]>
Date: Sat, 07 Nov 2009 22:11:42 -0000

Thanks,  

It's probably best not to worry about it then.  I would guess(?) that due to new files being posted the torrent will have to be generated periodically to keep it up to date.  

In those cases the moved files would simply show up in their new location.  At worst I guess you might end up with the same file in multiple locations.

---

From: "Tony Knerr" <[email-masked]>
Date: Sat, 07 Nov 2009 22:28:47 -0000

> In those cases the moved files would simply show up in their new location.  At worst I guess you might end up with the same file in multiple locations.
 
We will definitely end up with the same file in multiple locations, Ernie. That's not desirable. Could you please record the changes you make? I know it's a pita, but would help the torrent idea to continue.

Tony

---

From: ti99_forever <[email-masked]>
Date: Sat, 7 Nov 2009 15:00:33 -0800 (PST)

Would generating a new sitelist each time be enough? Store multiple versions?Then a diff against a newest and next newest will show what changed.Trying to keep Ernie's workload down. Unlike me, I think he has time for a life! ;)

--- On Sat, 11/7/09, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: [TI994A] Re: Updates to WHT
To: [email-masked]
Date: Saturday, November 7, 2009, 5:28 PM

  

      --- In TI994A@yahoogroups. com, "epergrem" <epergrem@.. .> wrote:

Tony

---

From: "Tursi" <[email-masked]>
Date: Sat, 7 Nov 2009 19:00:23 -0500

> the person creating the new torrent from the site will do so having 
> all the changes in place. I now have the ability to do so, so there 
> are at least 2 of us.
>

An alternative, if we're going to let whtech be the central repository, 
is to just use a technology like rsync to handle the updates. That way 
we don't have to track changes, and rsync can handle new files, deleted 
files, and changed files. That way the machine deals with the changes. 
(Unfortunately I believe rsync server will need to run at whtech.)

---

From: "epergrem" <[email-masked]>
Date: Sun, 08 Nov 2009 00:44:46 -0000

A sitelist comparison is certainly my preference since it means less work for me.:-)  

However, I am willing to track the changes, but someone who actually downloaded the torrent needs to be the keeper of the change list.

Give me name and I'll email the list to that person as I make the changes, or I can post them to this group as I did the last batch if that's preferable.

Thanks,
Ernie

---

From: "Tony Knerr" <[email-masked]>
Date: Sun, 08 Nov 2009 00:47:59 -0000

> (Unfortunately I believe rsync server will need to run at whtech.)

I'm not familiar with rsync, so maybe more explanation would be in order. You don't like the idea of Ernie being "slave boy"? I was 'sorta getting used to that. ;)

There's some other issues that I discovered today. I ran "Easy Duplicate Finder" on my whtech directory. It's a free program, just search for it and you'll find it. I set it for exact byte matches.

Here's the results:
930 files have duplicates.
There are 966 duplicate files, so some files have multiple duplicates.
That accounts for about 4.8% of the total number of files being duplicates.

The space those duplicate files takes up is 93mb, which is about 0.5% of the directory. I guess that's the good part.

The "export list to file" function in Easy Duplicate Finder does not provide enough information to make corrections, so it's pretty useless.

The question now is do we want those duplicate files?
They're of no use and are just taking up space.

Tony

---

From: "Tony Knerr" <[email-masked]>
Date: Sun, 08 Nov 2009 00:51:28 -0000

> Give me name and I'll email the list to that person as I make the changes, or I can post them to this group as I did the last batch if that's preferable.

I volunteer to be the keeper until and unless a better method is found.

Tony

---

From: "Tursi" <[email-masked]>
Date: Sat, 7 Nov 2009 20:08:17 -0500

I'd say nuke duplicate files. Ideally, before we go to the trouble of 
re-seeding the torrent, we should have:

-Significant layout changes that make it easier to navigate
-Duplicate files removed
-Filenames corrected (unfortunately I lost the three PDF files that had 
the same filename except for 1 letter of case... we'll have that issue 
again when we reseed unless we compare a list now).
-New files added

As noted before, at least a few months before we worry about it.

RSync is a program whose sole purpose in life it is to keep two folders 
in sync, whether local or remote machines. It works by comparing and 
even hashing files at both ends, so that only changes are ever 
transferred (even if that's just part of a larger file). Plenty of 
information on Google that explain it far better than I ever could. :) 
It's available for everything.

---

From: "epergrem" <[email-masked]>
Date: Sun, 08 Nov 2009 03:09:32 -0000

Hi Tony,
I too use Easy Duplicate Finder (check the donation list).  Highly recommended, as is Allway Sync, which while not free is pretty reasonable.

At one time I kept a copy of WHT on my hard drive, but decided to save some space since it was available online.

I may be forced to download the contents again to check for dupes.

The dupes come about mostly because of the ambiguity of some of the directories.  The 'datasheet and manuals' being a prime offender. Also, the person uploading doesn't always check the sitelist.txt file to see if the file already exists prior to uploading it.  

Darn! I forgot about that file when Tim asked for a listing of files and directories.

Ernie

---

From: TIMOTHY KIRSCH <[email-masked]>
Date: Sat, 7 Nov 2009 21:30:53 -0600

The first thing you need to do is look over the files and then decide how to set it up. 
You need to set up directory in advance and move file to new location
As you move them scan document for clarity and being corrupt.
Now I have wht backup on my computer.
But having them setup would make it allot easier to locate files
Separate pc99,win99,v9t9 files  module and disk.
pdf and max
Just a suggestion.

. 

_________________________________________________________________
Hotmail: Trusted email with Microsoft's powerful SPAM protection.
http://clk.atdmt.com/GBL/go/177141664/direct/01/
http://clk.atdmt.com/GBL/go/177141664/direct/01/

---

From: fdos <[email-masked]>
Date: Mon, 09 Nov 2009 09:02:10 -0700

Please be sure that they are duplicates and not different programs or 
different file types with the same name before deleting.

Bill S

---

From: Brian Tristam Williams <[email-masked]>
Date: Mon, 9 Nov 2009 18:04:04 +0200

I remember navigating this minefield 10 years ago with the TI-CD. Use a
duplicate file finder, such as Advanced Space Hunter. It's old, but it
works.

2009/11/9 fdos <[email-masked]>

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>
>

-- 
Brian Tristam Williams

"One man can make a difference."