Subject: Cartridge Board - 3rd run?

From: Jon Guidry <[email-masked]>
Date: Fri, 4 Dec 2009 16:51:11 -0600

Please feel free to forward this to Atari Age, other forums, etc.

I met with the fine folks over at ACC Electronix this morning about getting a quote for a third run of the cartridge board, (the second run of the 64K cartridge board).

The difference with the third run is that ACC will assemble the boards.  The boards will be finished with a Sn RoHS compliant finish.  Cost might go up a couple bucks for this run, since approx $300 of the cost is for a test fixture (they will test all PCBs at the PCB factory) and PCB setup (i.e. the template for the boards will be 'on file' after this), plus a small charge for assembly.  The only design change on the board itself is that a 16 pin socket will be included for the 74LS379, in case someone doesn't want to put one in (for a multicart, etc), or needs to change the 74LS379.  Boards will come from ACC in a 4x6 ASD bag just like the ones that you guys got when I shipped them.

ACC knows that my target for assembled boards is around the ~$14-16 price point, so they will be finalizing the quote and giving it to me after they finish everything up.  I'll let everyone know when that happens.  Subsequent runs will be less expensive due to the fact that there aren't any setup costs by the PCBExpress company that will be manufacturing the boards for ACC.  Divide $300 by 100 and price for each board will drop by $3 on the 4th and subsequent runs.

Now, here's where I need you folks if you want this to happen -

1) Preorders - does someone want to take the initiative to track pre-orders sort of like I did with the last batch?  Anyone have a Google Apps account they can use?  The form was pretty simple and dumped everything into a spreadsheet.  I'd let you use the one I had from last time, but I'm unsure on how to make someone the 'administrator' of the form and spreadsheet. 
2) Capital - I'm willing to throw in some of the money up front, but if someone (or two-three people) want to split the up-front costs to get the boards made, the rest of the costs will be Net 30 (i.e. the assembly and component parts).  I'll know more about this when I get the final quote from ACC.  Otherwise, we will need to have people to pay up-front for the boards.  My credit card was the way that we did this last time, and ACC doesn't take credit cards.  Someone would need to be in charge of taking the payments so we could pay ACC.
3) Invoicing/shipping - One person could invoice and one person could ship, or whatever.  I'm game for whatever you guys want to work out.

This is about as much coordination I can provide for a 3rd run of the board - keeping harmony in my family is of utmost importance.  So, let's see about getting this TI Community ready to roll so that we can do this!!! :)

Let me know if you have any questions, concerns, etc....

Thanks!
Jon

---

From: Owen Brand <[email-masked]>
Date: Fri, 4 Dec 2009 19:49:20 -0500

Jon, your efforts are greatly appreciated and certainly worthy of  
acclaim.  I would love to help this most worthy and NECESSARY cause.   
Once you have a final quote, let us know...  If any of us or many of  
us have time or $$$ to spare, I am sure we as a group will step up to  
the plate here.  I will be happy to contribute some of the upfront  
costs... Amount to be determined upon a final quote, AND after next  
week's gigs... Not sure how much dough I'll actually have until  
then.  :)  Jon, you're worthy of high acclaim here.  Without your  
efforts, who knows where the homebrew cart project would be.!?  Thanks  
alot... There are really 2 or 3 people on this list who drive me and  
inspire me to program... Marc's games and his generosity really made  
me inspired to program.....and the ability to put my own games on  
cart--- that drives me hard on this Assembly stuff.  :). Thank you Jon!

Owen Brand
**Oprysoft**
Opry99er.com

On Dec 4, 2009, at 5:51 PM, Jon Guidry <[email-masked]> wrote:

> I met with the fine folks over at ACC Electronix this morning about  
> getting a quote for a third run of the cartridge board, (the second  
> run of the 64K cartridge board).
>
> The difference with the third run is that ACC will assemble the  
> boards. The boards will be finished with a Sn RoHS compliant finish.  
> Cost might go up a couple bucks for this run, since approx $300 of  
> the cost is for a test fixture (they will test all PCBs at the PCB  
> factory) and PCB setup (i.e. the template for the boards will be 'on  
> file' after this), plus a small charge for assembly. The only design  
> change on the board itself is that a 16 pin socket will be included  
> for the 74LS379, in case someone doesn't want to put one in (for a  
> multicart, etc), or needs to change the 74LS379. Boards will come  
> from ACC in a 4x6 ASD bag just like the ones that you guys got when  
> I shipped them.
>
> ACC knows that my target for assembled boards is around the ~$14-16  
> price point, so they will be finalizing the quote and giving it to  
> me after they finish everything up. I'll let everyone know when that  
> happens. Subsequent runs will be less expensive due to the fact that  
> there aren't any setup costs by the PCBExpress company that will be  
> manufacturing the boards for ACC. Divide $300 by 100 and price for  
> each board will drop by $3 on the 4th and subsequent runs.
>
> 1) Preorders - does someone want to take the initiative to track pre- 
> orders sort of like I did with the last batch? Anyone have a Google  
> Apps account they can use? The form was pretty simple and dumped  
> everything into a spreadsheet. I'd let you use the one I had from  
> last time, but I'm unsure on how to make someone the 'administrator'  
> of the form and spreadsheet.
> 2) Capital - I'm willing to throw in some of the money up front, but  
> if someone (or two-three people) want to split the up-front costs to  
> get the boards made, the rest of the costs will be Net 30 (i.e. the  
> assembly and component parts). I'll know more about this when I get  
> the final quote from ACC. Otherwise, we will need to have people to  
> pay up-front for the boards. My credit card was the way that we did  
> this last time, and ACC doesn't take credit cards. Someone would  
> need to be in charge of taking the payments so we could pay ACC.
> 3) Invoicing/shipping - One person could invoice and one person  
> could ship, or whatever. I'm game for whatever you guys want to work  
> out.
>
> This is about as much coordination I can provide for a 3rd run of  
> the board - keeping harmony in my family is of utmost importance.  
> So, let's see about getting this TI Community ready to roll so that  
> we can do this!!! :)
>

---

From: "computerclassics2000" <[email-masked]>
Date: Sat, 05 Dec 2009 15:13:11 -0000

May I second Owen's accolades to Mr. Guidry for the wonderful contributions that Jon has made to the community. 

In years past I would NEVER have believed that I would one day be the proud owner of Robotron:2084 and Super Storm cartridges. They were simply 'entries in history' to me, something read about but never seen. Today that is no longer true. Jon Guidry made that possible. Thank you, sir!

BillG   

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Dec 4, 2009, at 5:51 PM, Jon Guidry <jon@...> wrote:
>

---

From: fdos <[email-masked]>
Date: Sat, 05 Dec 2009 09:16:50 -0700

Not to mention that he's making it possible for some of us to still 
obtain a 64K board or two.  I had hoped that the project would have been 
done with FLASH, but Bob Carmany's solution will also do well for those 
of us with limited hobby budgets.

Sot hats off to Jon and Bob.

Bill S

computerclassics2000 wrote:
>  
> 
> May I second Owen's accolades to Mr. Guidry for the wonderful 
> contributions that Jon has made to the community.
> 
> In years past I would NEVER have believed that I would one day be the 
> proud owner of Robotron:2084 and Super Storm cartridges. They were 
> simply 'entries in history' to me, something read about but never seen. 
> Today that is no longer true. Jon Guidry made that possible. Thank you, sir!
> 
> BillG
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, Owen 
> Brand <owenbrand@...> wrote:
>  >

---

From: "hexbus" <[email-masked]>
Date: Sat, 05 Dec 2009 20:47:40 -0000

Yep, but re-doing the entire board, retooling, etc, is a lot harder than using an established board design.  I'll leave it up to everyone for the time being who wants to hack on it, to hack on it. :)

I'm going to take a 27C010 next week and try it out on my board.  I'll have to to put four more pins for the socket somehow on the board (27C010 = 128K, 32 pin), but I think I can jumper and use the last pair of I/O on the 74LS379 and get a 128K bank switched ROM to work. :)  (I think I'll put a piece of Kapton tape to the left of the ROM, put the section of a ROM socket that has the four pins with the pins bent out, sticky tape below to keep it in place, and the solder some short wires from there.)

I need to work on some source code (with community help) of a PoC set of Bank Switching assembly to prove that the different banks indeed do work.  The PoC will include what addresses to write to for 16K, 32K, 64K, (and for people that really want to hack their boards -128K) to get to each 8K bank.

Jon

--- In [email-masked], fdos <fdosbrs@...> wrote:
> > Brand <owenbrand@> wrote:
> >  >
> >  > On Dec 4, 2009, at 5:51 PM, Jon Guidry <jon@> wrote:
> >  >

---

From: "hexbus" <[email-masked]>
Date: Sat, 05 Dec 2009 20:49:43 -0000

On a side note, how hard would it be to take a WE pin from a flash (29C010, for example) and have the TI control that to flash the FEPROM on the cart port?  (i.e. how much extra circuitry do you think we need?)

That might be a good hack for the 64K board if it's relatively easy.  

Jon

---

From: fdos <[email-masked]>
Date: Sat, 05 Dec 2009 14:01:59 -0700

Jon,

Sounds great!  Best wishes for complete success, guy.

Bill S

hexbus wrote:
>  
> 
> Yep, but re-doing the entire board, retooling, etc, is a lot harder than 
> using an established board design. I'll leave it up to everyone for the 
> time being who wants to hack on it, to hack on it. :)
> 
> I'm going to take a 27C010 next week and try it out on my board. I'll 
> have to to put four more pins for the socket somehow on the board 
> (27C010 = 128K, 32 pin), but I think I can jumper and use the last pair 
> of I/O on the 74LS379 and get a 128K bank switched ROM to work. :) (I 
> think I'll put a piece of Kapton tape to the left of the ROM, put the 
> section of a ROM socket that has the four pins with the pins bent out, 
> sticky tape below to keep it in place, and the solder some short wires 
> from there.)
> 
> I need to work on some source code (with community help) of a PoC set of 
> Bank Switching assembly to prove that the different banks indeed do 
> work. The PoC will include what addresses to write to for 16K, 32K, 64K, 
> (and for people that really want to hack their boards -128K) to get to 
> each 8K bank.
> 
> Jon
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, fdos 
> <fdosbrs@...> wrote:
>  >
>  > > --- In [email-masked] <mailto:TI994A%40yahoogroups.com> 
> <mailto:TI994A%40yahoogroups.com>, Owen

---

From: fdos <[email-masked]>
Date: Sat, 05 Dec 2009 14:09:41 -0700

Jon,

Someone a lot more knowledgeable than I will have to answer this 
question.  I switched to software development between IC and LSI, so 
most of my work in this area was with discrete logic circuits!  A long 
time ago, I know, but understand that when I went trough basic 
electronics it was the last class at Keesler AFB teaching vacuum tube 
theory.  I had to take transistor theory later.

Bill S

hexbus wrote:
>  
> 
> On a side note, how hard would it be to take a WE pin from a flash 
> (29C010, for example) and have the TI control that to flash the FEPROM 
> on the cart port? (i.e. how much extra circuitry do you think we need?)
>