Subject: CTIUG Meeting

From: "epergrem" <[email-masked]>
Date: Sat, 02 Jan 2010 20:45:48 -0000

Not sure when it started, but the CTIUG meeting is online at

http://www.ustream.tv/channel/chicagotiusersgroup%27s-show

---

From: mark wills <[email-masked]>
Date: Sat, 2 Jan 2010 15:41:41 -0800 (PST)

Does anyone know: Can the 9938/9958 use 'ordinary' RAM for it's video ram? (Preferably static rather than dynamic).
 
I know yeras ago they had to use special VRAMS. Was this simply because in those days the rams were considered fast access, or is it more specialised than that (e.g. do the rams have to be dual-port for H/V column/row select?)
 
I ask because at some point i'd like to build a 9995 based home brew computer. This idea of mine is about 18 months old now. It is what led me to study Forth, (in pursuit of an OS for it) and develop the Forth system that I am currently working on for the 4A
 
When the Forth system I am working on is done (not much more to do, although bug testing and documentation might take a while) all I have to do to run it on a homebrew 9995 board is:
 
Change the address for DOCOL NEXT and EXIT (unless you know about Forth, that won't mean much)
Change the screen io code to target an 9938
Change key scan code to read a homebrew keyboard (4A keyboards work nicely ;-)
Change Disk IO code. Easy enough. I'll provide 512k of flash ram, divided into 64k 'disks'.
I'v already got the 9995 and 9938 (it might be a 9958, can't remember) - the rest of the hardware is simple enough. I chose the 9995 because it is:
 
* Faster
* Only needs a single phase clock
* Has an 8 bit data bus (easier to wire-wrap and design PCB for)
 
It would be relatively easy to build such a system onto a PEB board, ala Geneve, though it would have a fraction of the chip count these days. You'd almost have a Geneve type machine, though it would be Forth based (which is *much* more powerful than DOS anyway)
 
Mark

---

From: fdos <[email-masked]>
Date: Sat, 02 Jan 2010 17:33:04 -0700

Mark,

You devil.  First your own Forth and now your own Geneve!  How 
wonderful.  Where do these crazy ideas come from anyway? :-)  ;-)  :-)

Bill S

mark wills wrote:
>  
> 
> Does anyone know: Can the 9938/9958 use 'ordinary' RAM for it's video 
> ram? (Preferably static rather than dynamic).
> 
>  
> 
> I know yeras ago they had to use special VRAMS. Was this simply because 
> in those days the rams were considered fast access, or is it more 
> specialised than that (e.g. do the rams have to be dual-port for H/V 
> column/row select?)
> 
>  
> 
> I ask because at some point i'd like to build a 9995 based home brew 
> computer. This idea of mine is about 18 months old now. It is what led 
> me to study Forth, (in pursuit of an OS for it) and develop the Forth 
> system that I am currently working on for the 4A
> 
>  
> 
> When the Forth system I am working on is done (not much more to do, 
> although bug testing and documentation might take a while) all I have to 
> do to run it on a homebrew 9995 board is:
> 
>  
> 
> I'v already got the 9995 and 9938 (it might be a 9958, can't remember) - 
> the rest of the hardware is simple enough. I chose the 9995 because it is:
> 
>  
> 
> * Faster
> 
> It would be relatively easy to build such a system onto a PEB board, ala 
> Geneve, though it would have a fraction of the chip count these days. 
> You'd almost have a Geneve type machine, though it would be Forth based 
> (which is *much* more powerful than DOS anyway)
> 
>  
> 
> Mark
> 
>  
> 
>  
> 
>

---

From: "sconner3uk" <[email-masked]>
Date: Sun, 03 Jan 2010 00:45:37 -0000

The 9938/58 (and the 9918 for that matter) are designed to interface specifically with dynamic RAM, and have the necessary RAM interface/control signals to do this (/RAS, /CAS, etc). I think you'd struggle to interface it to static RAM (probably need lots of glue logic), for no benefit.

Getting a video out signal will also require some analog circuitry, which could be tricky if you're not used to designing that sort of thing. A different approach you might want to consider is fitting a TMS9902 to interface to an RS-232 terminal (e.g. HyperTerminal on a Windows PC). You'd slash the need for the keyboard and video interface, but of course you'd lose any graphics capability you might intend to build into Forth. Might be worth including this option anyway to help in inital debugging to get the keyboard and video interfaces working ...

Stuart.

---

From: ti99_forever <[email-masked]>
Date: Sat, 2 Jan 2010 16:54:56 -0800 (PST)

I think you could do just that with TI Forth and Wycove Forth, redirect I/O to a remote device. I need to try it. I remember a printer word for Wycove that redirected output.

I remember doing the same with the P-system remin and remout, although it wasn't as useful as Forth would be. Every single little error that occurred turned off all redirection, "just in case" that caused the error.

--- On Sat, 1/2/10, sconner3uk <ti99@stuartconner..me.uk> wrote:

> From: sconner3uk <[email-masked]>
> Subject: [TI994A] Re: 9938/9958 musings
> To: [email-masked]
> Date: Saturday, January 2, 2010, 7:45 PM
> The 9938/58 (and the 9918 for that
> matter) are designed to interface specifically with dynamic
> RAM, and have the necessary RAM interface/control signals to
> do this (/RAS, /CAS, etc). I think you'd struggle to
> interface it to static RAM (probably need lots of glue
> logic), for no benefit.
> 
> Getting a video out signal will also require some analog
> circuitry, which could be tricky if you're not used to
> designing that sort of thing. A different approach you might
> want to consider is fitting a TMS9902 to interface to an
> RS-232 terminal (e.g. HyperTerminal on a Windows PC). You'd
> slash the need for the keyboard and video interface, but of
> course you'd lose any graphics capability you might intend
> to build into Forth. Might be worth including this option
> anyway to help in inital debugging to get the keyboard and
> video interfaces working ...
> 
> Stuart.
> 
> > Does anyone know: Can the 9938/9958 use 'ordinary' RAM
> for it's video ram? (Preferably static rather than
> dynamic).
> >  
> > I know yeras ago they had to use special VRAMS. Was
> this simply because in those days the rams were considered
> fast access, or is it more specialised than that (e.g. do
> the rams have to be dual-port for H/V column/row select?)
> >  
> > I ask because at some point i'd like to build a 9995
> based home brew computer. This idea of mine is about 18
> months old now. It is what led me to study Forth, (in
> pursuit of an OS for it) and develop the Forth system that I
> am currently working on for the 4A
> >  
> > When the Forth system I am working on is done (not
> much more to do, although bug testing and documentation
> might take a while) all I have to do to run it on a homebrew
> 9995 board is:
> >  
> > I'v already got the 9995 and 9938 (it might be a 9958,
> can't remember) - the rest of the hardware is simple enough.
> I chose the 9995 because it is:
> >  
> > * Faster
> > It would be relatively easy to build such a system
> onto a PEB board, ala Geneve, though it would have a
> fraction of the chip count these days. You'd almost have a
> Geneve type machine, though it would be Forth based (which
> is *much* more powerful than DOS anyway)
> >  
> > Mark
> >
> 
> 
> 
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: mark wills <[email-masked]>
Date: Sun, 3 Jan 2010 02:52:46 -0800 (PST)

Hmmmm... Any idea where I'd get those RAMs from these days Scott?

And of course, you are right about the analog bits for the video. I'll get you to design that ;-)

IIRC there might be a circuit in one the data books... Then of course there is audio... ;-)

The serial port is a good idea. 

Mark

>Sent: Sun, 3 January, 2010 0:45:37
>--- In TI994A@yahoogroups. com, mark wills <markrobertwills@ ...> wrote:
>>

---

From: mark wills <[email-masked]>
Date: Sun, 3 Jan 2010 02:50:21 -0800 (PST)

He he! It's been turning over for a while in my head. Hopefully I'll get to build it. It's basically born of my desire to understand digital hardware more.

It won't be Geneve or 4A compatible - we have our beloved consoles and emulators for that - it will be entirely 'of itself'. But, with a Forth based OS from power on, imagine the power!

Scott mentioned adding a serial port, a great idea. I'll sit down and sketch out a block diagram when I have a quiet moment. But I mustn't get too distracted, I still need to finish Forth on the TI

Still haven't finished the editor, but shouldn't take too long. I've just re-factored CREATE VARIABLE and CONSTANT. Actually, I've completely re-written them. Much more efficient now (and lots faster). Next I will implement DOES> now that CREATE works like it's supposed to.

All good fun!

Mark

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Sun, 3 January, 2010 0:33:04
> Subject: Re: [TI994A] 9938/9958 musings
> 
> Mark,
>

---

From: "Ksarul" <[email-masked]>
Date: Sun, 03 Jan 2010 07:40:17 -0500

That would make it a Powertran Cortex. . .some folks on the Vintage Computer
Forum are busy trying to read the Forth ROMS for that one to copy them now
that someone with that version of the ROMS has turned up. . .

You might need to include a 9901 to allow CRU addressing too, especially if
you want to use any of TI's PEB boards with it.  Most of them have specific
CRU addresses and expected responses. . .

Jim Fetzner

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
mark wills
Sent: Sunday, January 03, 2010 5:50 AM
To: [email-masked]
Subject: Re: [TI994A] 9938/9958 musings

He he! It's been turning over for a while in my head. Hopefully I'll get to
build it. It's basically born of my desire to understand digital hardware
more.

It won't be Geneve or 4A compatible - we have our beloved consoles and
emulators for that - it will be entirely 'of itself'. But, with a Forth
based OS from power on, imagine the power!

Scott mentioned adding a serial port, a great idea. I'll sit down and sketch
out a block diagram when I have a quiet moment. But I mustn't get too
distracted, I still need to finish Forth on the TI

Still haven't finished the editor, but shouldn't take too long. I've just
re-factored CREATE VARIABLE and CONSTANT. Actually, I've completely
re-written them. Much more efficient now (and lots faster). Next I will
implement DOES> now that CREATE works like it's supposed to.

All good fun!

Mark

----- Original Message ----
> From: fdos <fdosbrs@frontiernet <mailto:fdosbrs%40frontiernet.net> .net>
> To: TI994A@yahoogroups. <mailto:TI994A%40yahoogroups.com> com

> > Change the address for DOCOL NEXT and EXIT (unless you know about Forth,

> > that won't mean much)

---

From: "sconner3uk" <[email-masked]>
Date: Sun, 03 Jan 2010 13:03:40 -0000

Scott? Scott? Did my name change over the New Year and I didn't notice?  ;-)

The dynamic RAMs are nothing special. There should be plenty on e-bay etc. I suspect they were referred to as 'VRAM' because at the time they were only used with video chips - the main processors themselves still using static RAM. Then along came the Z80 which was quite happy using dynamic RAM for the main system memory.

Stuart.

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> >From: sconner3uk <ti99@...>

---

From: mark wills <[email-masked]>
Date: Sun, 3 Jan 2010 05:47:06 -0800 (PST)

Thanks Scott

Er, Stuart!

Stuart.

Damn it! ;-^

>Sent: Sun, 3 January, 2010 13:03:40
>> >To: TI994A@yahoogroups. com
>> >Â  
>> >> Â 
>> >> Â 
>> >> Â 
>> >> Â 
>> >> Change the screen io code to target anÂ 9938
>> >> Â 
>> >> Â 
>> >> Â

---

From: fdos <[email-masked]>
Date: Mon, 04 Jan 2010 09:40:37 -0700

Mark,

I never had the desire to reinvent the wheel or anything else for that 
matter, but I was keen on using existing inventions as building blocks 
for grand scale ideas that popped into my head from time to time.  Some 
of them popped out just as quickly, because the project was beyond my 
budget or beyond my pay scale (my mind doesn't get beyond KISS).

Anyway, be a little more creative, please.  Substitute USB for the 
serial port as there are all kinds of USB to RS-232 serial ports 
available at your local Wal*Mart.  With USB you can really make good use 
of all that power you're creating.

Yes, by all means complete your Forth before getting too involved in 
creating an MDOS replacement Geneve; FDOS (Ah, my name sake)  Oh what 
fun it will be.... :-)

Bill S

mark wills wrote:
>  
> 
> He he! It's been turning over for a while in my head. Hopefully I'll get 
> to build it. It's basically born of my desire to understand digital 
> hardware more.
> 
> Scott mentioned adding a serial port, a great idea. I'll sit down and 
> sketch out a block diagram when I have a quiet moment. But I mustn't get 
> too distracted, I still need to finish Forth on the TI
> 
> Still haven't finished the editor, but shouldn't take too long. I've 
> just re-factored CREATE VARIABLE and CONSTANT. Actually, I've completely 
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>