Subject: More hardware nuts and bolts questions

From: "Marc H" <[email-masked]>
Date: Tue, 01 Dec 2009 20:05:12 -0000

The total lack of prior experience is really a bitch! I have some questions....

1)  I have measured the voltage of a running oscillator with a 5V power source and am getting a reading of 2.5V (on a cheap dial multi-meter.) Does this indicate that the voltage drop is high through an oscillator or that my meter isn't sensitive enough to weed through the high speed switching?

2)  As a rule of thumb (if there is one)  how many TTL inputs can be run from a single TTL output..

3)  Should all IC's including 74LS logic chips have their own bypass capacitors or only ones that rely on a clock signal.

4)  Do any extra precautions need to be taken on a PCB that has two separate clock signals present IE a 1 MHZ oscillator and TI's 3MHZ signal

5)  I am pretty sure I know this one but just to verify... Does the Clock signal on the PEB bus that is the inverted PH3 signal from the 9904 occur every .000,000,3 of a second or every .000,750 of a second ?

Thank you in advance

Marcus

---

From: "Ksarul" <[email-masked]>
Date: Tue, 01 Dec 2009 16:36:54 -0500

ftp://ftp.whtech.com/datasheets%20and%20manuals/Specifications/Peripheral%20
Expansion%20System%20Theory%20Of%20Operation%20and%20Technical%20Traning%20G
uide%201982-09-03.pdf <ftp://ftp.whtech.com/datasheets and
manuals/Specifications/Peripheral Expansion System Theory Of Operation and
Technical Traning Guide 1982-09-03.pdf> 

You might want to look at this document on WHTech, it will tell you more
about the PEB and the card signaling than you ever knew to ask. . .

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Marc H
Sent: Tuesday, December 01, 2009 3:05 PM
To: [email-masked]
Subject: [TI994A] More hardware nuts and bolts questions

The total lack of prior experience is really a bitch! I have some
questions....

1) I have measured the voltage of a running oscillator with a 5V power
source and am getting a reading of 2.5V (on a cheap dial multi-meter.) Does
this indicate that the voltage drop is high through an oscillator or that my
meter isn't sensitive enough to weed through the high speed switching?

2) As a rule of thumb (if there is one) how many TTL inputs can be run from
a single TTL output..

3) Should all IC's including 74LS logic chips have their own bypass
capacitors or only ones that rely on a clock signal.

4) Do any extra precautions need to be taken on a PCB that has two separate
clock signals present IE a 1 MHZ oscillator and TI's 3MHZ signal

5) I am pretty sure I know this one but just to verify... Does the Clock
signal on the PEB bus that is the inverted PH3 signal from the 9904 occur
every .000,000,3 of a second or every .000,750 of a second ?

Thank you in advance

Marcus

---

From: tursi <[email-masked]>
Date: Tue, 1 Dec 2009 13:37:03 -0800 (PST)

I can answer some of these with varying levels of confidence.

> source and am getting a reading of 2.5V (on a cheap dial multi-meter.) 
> Does this indicate that the voltage drop is high through an oscillator 
> or that my meter isn't sensitive enough to weed through the high speed 
> switching?

That means your meter is pretty good. ;) It's averaging the square wave 
nicely. Some meters end up all over the place. Unless you have a sample 
and hold in there (or it can display the highest voltage received), you 
won't get a clean reading on a varying signal. Without that, or a scope, 
it can be hard to get a voltage reading from a varying signal.

> from a single TTL output..

I don't know if there is one, but by looking at your datasheets you can 
work out what's safe - it will tell you what the output pins can source, 
and what the input pins draw. I've heard values as low as '3', but even 
the PEB buffers are configured to drive up to 7 (one buffer per card) (7 
means 8 slots, am I remembering right? More than 3 was my point).

> capacitors or only ones that rely on a clock signal.

My understanding is all of them. The point is that when TTL logic 
switches, it draws power. If a lot switches at the same time, as often 
happens in computer circuits, it can draw enough current to cause a 
voltage drop, which in turn may cause malfunction in chips that lose 
power. The capacitor just smooths out any such drops to prevent problems. 
They also filter out any AC that may be induced in the power lines, for 
the same reason.

> 4)  Do any extra precautions need to be taken on a PCB that has two 
> separate clock signals present IE a 1 MHZ oscillator and TI's 3MHZ 
> signal

I'm shakey here, but the main advice I do know is don't run them too close 
together, to avoid interference.

> 5)  I am pretty sure I know this one but just to verify... Does the 
> Clock signal on the PEB bus that is the inverted PH3 signal from the 
> 9904 occur every .000,000,3 of a second or every .000,750 of a second ?

I measured in the console, not the PEB, but it should be the same line. 
Each of the four lines toggles at 3MHz, they're just out of phase with 
each other. So every 0.0000003333... of a second.

---

From: "sconner3uk" <[email-masked]>
Date: Tue, 01 Dec 2009 23:45:41 -0000

In addition to Tursi's reply ...

"2)  As a rule of thumb (if there is one)  how many TTL inputs can be run from a single TTL output.."

The term used to describe this is 'fan-out'. Take a look about half way down this page - http://www.kpsec.freeuk.com/components/ic.htm - and there is a table stating the fan-out of the different logic families. Should be OK as a rule of thumb.

Stuart.

---

From: Marc Hull <[email-masked]>
Date: Tue, 1 Dec 2009 16:29:23 -0800 (PST)

Thanks again Mike & Stuart.  I'll have to get both of you some worlds greatest mentor mugs for the Holidays.  Patience of the saints I tell ya...

BTW for those reading..... If your a hardware tard like me then the website below is for you.  It is written at our level ;-)

--- On Tue, 12/1/09, sconner3uk <[email-masked]> wrote:

From: sconner3uk <[email-masked]>
Subject: [TI994A] Re: More hardware nuts and bolts questions
To: [email-masked]
Date: Tuesday, December 1, 2009, 5:45 PM

  

The term used to describe this is 'fan-out'. Take a look about half way down this page - http://www.kpsec. freeuk.com/ components/ ic.htm - and there is a table stating the fan-out of the different logic families. Should be OK as a rule of thumb.

Stuart.

--- In TI994A@yahoogroups. com, "Marc H" <marc.hull@. ..> wrote:

> The total lack of prior experience is really a bitch! I have some questions... .

> 1)  I have measured the voltage of a running oscillator with a 5V power source and am getting a reading of 2.5V (on a cheap dial multi-meter. ) Does this indicate that the voltage drop is high through an oscillator or that my meter isn't sensitive enough to weed through the high speed switching?