Subject: Missing 8K ROMs?

From: "hexbus" <[email-masked]>
Date: Tue, 08 Dec 2009 04:09:34 -0000

Can anyone tell me any 8K ROMs (that I'm missing out of this list) that were made for the TI?  I have, at last count, 57.  I'm trying to get up to 64 if there's that many that I'm missing... :)

Jon

4A Flyer (1986)(Triton).C
99 Home Sentry (1986)(Corcomp).C
Ambulance (1983)(Funware).C
Ant Colony(Funware).C
Ant-Eater (1983)(Romox).C
Black Hole (1983)(DaTaBioTics).C
Boxer (1987)(DaTaBioTics).C
Break Thru (1989)(DaTaBioTics)[AKA Tile Breaker].C
Burger Builder (1983)(DaTaBioTics).C
Centipede (1983)(Atarisoft).C
Chicken Coop (1986)(Navarone)[AKA Hen Pecked].C
Console Writer v2.1 (1984)(Navarone).C
D-Station I (1988)(DaTaBioTics).C
D-Station II - The Conflict Continues! (1988)(DaTaBioTics).C
Data Base Management System v2.0 (1984)(Navarone).C
Defender (1983)(Atarisoft).C
Disk Fixer v2.0 (1984)(Navarone).C
Driving Demon (1983)(Funware - Romox).C
Edu-Pack (1990)(Asgard).C
Escape (1984)(DaTaBioTics)[AKA King of the Castle].C
Face Chase(John Phillips).C
Frog Stickers (1982)(Navarone).C
Henhouse (1982)(Funware).C
Homework Helper+ (1984)(Navarone).C
Link v0.99 (1990)(Asgard).C
Midnite Mason (1984)(Software Specialties).C
Munch Man II (1987)(John Phillips).C
Paint 'N' Print A (1985)(Navarone).C
Paint 'N' Print C (1985)(Navarone).C
Peripheral Diagnostic Module (1985)(Corcomp).C
Princess and Frog (1982)(Romox).C
Pro Typer (1987)(DaTaBioTics).C
Rabbit Trail (1983)(Funware - Romox).C
Romox Demo (1983)(Romox).C
Rotor Raiders (1983)(Romox).C
Schnoz-ola (1983)(Funware).C
Shanghai (1983)(Funware).C
Space Patrol(Unknown).C
Speed Reading A (1984)(Navarone)[adults].C
Speed Reading B (1984)(Navarone)[children].C
Spy's Demise (1987)(CSI Design Group).C
St. Nick (1983)(Funware).C
Star Gazer I (1984)(Video Magic).C
Star Gazer II (1984)(Video Magic).C
Star Gazer III (1984)(Video Magic).C
Star Trap(John Phillips).C
Star Wars(John Phillips).C
Super Duper v1.1 (1984)(Navarone).C
Super Sketch - Model G2400 (1984)(Personal Peripherals).C
TI Planner (1987)(DaTaBioTics)[AKA Console Calc].C
TI-IBM Connection (1987)(Corcomp)[b][a].C
TI-Toad (1982)(Software Specialties).C
Topper (1986)(Navarone).C
Tris 2(Asgard).C
Typo II (1983)(Romox).C
Typoman (1987)(Navarone).C
Video Vegas (1982)(Funware - Romox).C

---

From: "Ksarul" <[email-masked]>
Date: Tue, 08 Dec 2009 06:59:12 -0500

Typewriter 99 (Asgard)

FigForth v2.1 

DOS

I hope that helps. . .

Jim Fetzner-who has all but the Typwriter99 module. . .

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
hexbus
Sent: Monday, December 07, 2009 11:10 PM
To: [email-masked]
Subject: [TI994A] Missing 8K ROMs?

Can anyone tell me any 8K ROMs (that I'm missing out of this list) that were
made for the TI? I have, at last count, 57. I'm trying to get up to 64 if
there's that many that I'm missing... :)

Jon

---

From: mark wills <[email-masked]>
Date: Tue, 8 Dec 2009 03:39:20 -0800 (PST)

FigForth on a cartridge?... Woa!

>
>From: Ksarul <[email-masked]>
>Sent: Tue, 8 December, 2009 12:59:12
>Subject: RE: [TI994A] Missing 8K ROMs?
>
> >
>
>
>
>
>  >
>>      
> 
>>
>
>
>
>
>>
>Typewriter 99 (Asgard)
>FigForth v2.1 
>DOS
> 
>I hope that helps. . .
> 
>Jim Fetzner—who has all but the
>Typwriter99 module. . .
> 
> 
>>
>>
________________________________
 >
>From:>TI994A@yahoogroups. com [mailto:TI994A@ yahoogroups. com] On Behalf Of hexbus
>To: TI994A@yahoogroups. com
>Can anyone tell me any 8K ROMs (that I'm missing out
>of this list) that were made for the TI? I have, at last count, 57. I'm trying
>to get up to 64 if there's that many that I'm missing... :)
>
>>Jon
>
>>4A Flyer (1986)(Triton) .C
>>99 Home Sentry (1986)(Corcomp) .C
>>Ambulance (1983)(Funware) .C
>>Ant Colony(Funware) .C
>>Ant-Eater (1983)(Romox) .C
>>Black Hole (1983)(DaTaBioTics) .C
>>Boxer (1987)(DaTaBioTics) .C
>>Break Thru (1989)(DaTaBioTics) [AKA Tile Breaker].C
>>Burger Builder (1983)(DaTaBioTics) .C
>>Centipede (1983)(Atarisoft) .C
>>Chicken Coop (1986)(Navarone) [AKA Hen Pecked].C
>>Console Writer v2.1 (1984)(Navarone) .C
>>D-Station I (1988)(DaTaBioTics) .C
>>D-Station II - The Conflict Continues! (1988)(DaTaBioTics) .C
>>Data Base Management System v2.0 (1984)(Navarone) .C
>>Defender (1983)(Atarisoft) .C
>>Disk Fixer v2.0 (1984)(Navarone) .C
>>Edu-Pack (1990)(Asgard) .C
>>Escape (1984)(DaTaBioTics) [AKA King of the Castle].C
>>Frog Stickers (1982)(Navarone) .C
>>Henhouse (1982)(Funware) .C
>>Homework Helper+ (1984)(Navarone) .C
>>Link v0.99 (1990)(Asgard) .C
>>Midnite Mason (1984)(Software Specialties) .C
>>Paint 'N' Print A (1985)(Navarone) .C
>>Paint 'N' Print C (1985)(Navarone) .C
>>Peripheral Diagnostic Module (1985)(Corcomp) .C
>>Princess and Frog (1982)(Romox) .C
>>Pro Typer (1987)(DaTaBioTics) .C
>>Romox Demo (1983)(Romox) .C
>>Rotor Raiders (1983)(Romox) .C
>>Schnoz-ola (1983)(Funware) .C
>>Shanghai (1983)(Funware) .C
>>Space Patrol(Unknown) .C
>>Speed Reading A (1984)(Navarone) [adults]. C
>>Speed Reading B (1984)(Navarone) [children] .C
>>St. Nick (1983)(Funware) .C
>>Super Duper v1.1 (1984)(Navarone) .C
>>Super Sketch - Model G2400 (1984)(Personal Peripherals) .C
>>TI Planner (1987)(DaTaBioTics) [AKA Console Calc].C
>>TI-IBM Connection (1987)(Corcomp) [b][a].C
>>TI-Toad (1982)(Software Specialties) .C
>>Topper (1986)(Navarone) .C
>>Tris 2(Asgard).C
>>Typo II (1983)(Romox) .C
>>Typoman (1987)(Navarone) .C

---

From: fdos <[email-masked]>
Date: Tue, 08 Dec 2009 08:54:49 -0700

Mark,

I just checked my download of Michael's RPK carts for MESS, and it does 
include a FigForth cart.  I don't recall hearing about or seeing such a 
module previously, so I will have to check this out as soon as I have 
some time to spare.

Bill S

mark wills wrote:
>     *From:* Ksarul <[email-masked]>
>     *To:* [email-masked]
>     *Sent:* Tue, 8 December, 2009 12:59:12
>     *Subject:* RE: [TI994A] Missing 8K ROMs?
> 
>      
> 
>     Typewriter 99 (Asgard)
> 
>     FigForth v2.1
> 
>     DOS
> 
>      
> 
>     I hope that helps. . .
> 
>      
> 
>     Jim Fetzner—who has all but the Typwriter99 module. . .
> 
>      
> 
>      
> 
>     ------------------------------------------------------------------------
> 
>     *From:* TI994A@yahoogroups. com [mailto:TI994A@ yahoogroups. com]
>     *On Behalf Of *hexbus
>     *Sent:* Monday, December 07, 2009 11:10 PM
>     *To:* TI994A@yahoogroups. com
>     *Subject:* [TI994A] Missing 8K ROMs?
> 
>      
> 
>      
> 
>     Can anyone tell me any 8K ROMs (that I'm missing out of this list)
>     that were made for the TI? I have, at last count, 57. I'm trying to
>     get up to 64 if there's that many that I'm missing... :)
> 
>     Jon
>

---

From: fdos <[email-masked]>
Date: Tue, 08 Dec 2009 09:54:49 -0700

Mark,

I took a quick look at this module (fig FORTH Weiand 1986 REL 2.0), and 
it's worth investigating further as it is not a modified version of TI 
or Wycove Forth.  I think it may be difficult to figure out without 
documentation, so unless someone has it or it's on-line somewhere please 
let us know.

Bill S

fdos wrote:
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
> 
>

---

From: mark wills <[email-masked]>
Date: Tue, 8 Dec 2009 08:57:10 -0800 (PST)

Yes please, Bill. I'd be very interested to hear a report on it.

Thanks

Mark

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Tue, 8 December, 2009 15:54:49
> Subject: Re: [TI994A] Missing 8K ROMs?
> 
> Mark,
> 
> >     *From:* Ksarul 
> >     Jim Fetznerâ€”who has all but the Typwriter99 module. . .
> > 
> >      
> > 
> >      
> >

---

From: mark wills <[email-masked]>
Date: Tue, 8 Dec 2009 08:58:57 -0800 (PST)

There's lot's of FIG documentation on line. If it's FIG 79 compliant, it should be a cinch to use. Try www.forthworks.com for information on the FIG (and other) standards.

Regards

Mark

----- Original Message ----
> Sent: Tue, 8 December, 2009 16:54:49
> Subject: [TI994A] FigForth Cart (was: Missing 8K ROMs?)
> 
> Mark,
>

---

From: mark wills <[email-masked]>
Date: Tue, 8 Dec 2009 08:59:26 -0800 (PST)

Could you send me a copy of the ROM, Bill?

Thanks

Mark

---

From: fdos <[email-masked]>
Date: Tue, 08 Dec 2009 10:19:50 -0700

Mark,

I'm familiar with those versions.  The difference are related to TI 
specific forth words and I/O implementation.  It has VLIST so I can see 
the words I know, and I've determined that it has 6 BLOCK BUFFERs in low 
memory, but does not access TI Forth disks.  It doesn't have DISK_SIZE 
or DISK_HI or DISK_LOW, DR0, DR1 OR DR2, etc.  It has words like OLD and 
SAVE, so more BASIC minded in the disk I/O area.  I can guess at the 
usage of some of the strange words, but I have no idea about stack 
requirements, etc.

Bill S

mark wills wrote:
>  
> 
> There's lot's of FIG documentation on line. If it's FIG 79 compliant, it 
> should be a cinch to use. Try www.forthworks.com for information on the 
> FIG (and other) standards.
> 
> Regards
> 
> Mark
> 
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > >> *To:* [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > >> ----------------------------------------------------------
>  > >>

---

From: fdos <[email-masked]>
Date: Tue, 08 Dec 2009 10:22:10 -0700

Mark,

I don't know when I can get to it as I would have to extract the ROM 
from the RPK, and I have to go run some errands now.  After that I will 
have to pick up mail and my granddaughter from school.

Bill S

---

From: "hexbus" <[email-masked]>
Date: Wed, 09 Dec 2009 04:30:44 -0000

Sweet.  I saw that the FigForth RPK was somewhere.  I need to find Typewriter 99, and I'm assuming that the original Tris is around somewhere as well (it's 8K).

That'll bring me to 60...

Jon

---

From: "killroy732000" <[email-masked]>
Date: Fri, 11 Dec 2009 17:14:24 -0000

Hi TI friends,

seems the TI'ers are not the only ones doing stuff with Forth ;-)
http://www.msx.org/forumtopicl10584.html

I wonder how well Forth could be used as a runtime environment for  compact games; Write the forth game code via cross-compiler and put the game code with the runtime environment in the cartridge (no need for screen editor and file IO?).

I know that some RAM memory would be required for the stack, but I think such combination could be quite powerful. 

On a sidenote: I got myself the O'reilly book "Masterminds of Programming". It's a series of interviews with the creators of the best known programming languages (Java, BASIC, c++, Python, ... and Forth)

The interview with Charles H. Moore (Forth creator) is really
interesting. It seems Forth is still being used and nowadays is
getting more attention. It lends itself very well for very small,
linked forth computers (e.g. "smart dust").

Very interesting stuff if you ask me ;-)

Cheers
Filip

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> > From: fdos <fdosbrs@...>

---

From: fdos <[email-masked]>
Date: Fri, 11 Dec 2009 10:46:41 -0700

I found this article, that they referenced, interesting and pretty fare:
http://www.inventio.co.uk/forthvsc.htm

I would have a few objections because I've overcome a some of the 
weakness mentioned, but them my Forth+ and X4th99 are extensions to 
Forth, so not known outside our community.

Bill S

killroy732000 wrote:
> <http://www.msx.org/forumtopicl10584.html>
> 
> I wonder how well Forth could be used as a runtime environment for 
> compact games; Write the forth game code via cross-compiler and put the 
> game code with the runtime environment in the cartridge (no need for 
> screen editor and file IO?).
> 
> I know that some RAM memory would be required for the stack, but I think 
> such combination could be quite powerful.
> 
> On a sidenote: I got myself the O'reilly book "Masterminds of 
> Programming". It's a series of interviews with the creators of the best 
> known programming languages (Java, BASIC, c++, Python, ... and Forth)
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, mark 
> wills <markrobertwills@...> wrote:
>  >
>  > There's lot's of FIG documentation on line. If it's FIG 79 compliant, 
> it should be a cinch to use. Try www.forthworks.com for information on 
> the FIG (and other) standards.
>  >
>  > Regards
>  >
>  > Mark
>  >
>  >
>  >

---

From: mark wills <[email-masked]>
Date: Fri, 11 Dec 2009 10:50:47 -0800 (PST)

Some Forths have a TURNKEY command which does exactly what you describe. It's quite easy to do with ITC Forths.

I have the same book. Chuck Moore talks a lot of sense. He has his own website: www.colorfoth.com

These days, his Forth has moved on... He uses colour to show meaning, as well as the words themselves. So, instead of [COMPILE] LIT you can just write LIT in red. Nice. His sight is well worth checking out.

Also check out the history of Forth at www.forth.com - fascinating.

Another Forth site is www.ultraforth.com - I have spent days reading everything on that site. There is some really interesting stuff on there.

Mark

>
>From: killroy732000 <[email-masked]>
>Sent: Fri, 11 December, 2009 17:14:24
>Subject: [TI994A] Re: FigForth Cart (was: Missing 8K ROMs?)
>
> >
>
>
>
>
>  >
>>      
> 
>
>
>>Hi TI friends,
>
>http://www.msx. org/forumtopicl1 0584.html
>
>>On a sidenote: I got myself the O'reilly book "Masterminds of Programming" . It's a series of interviews with the creators of the best known programming languages (Java, BASIC, c++, Python, ... and Forth)
>
>>--- In TI994A@yahoogroups. com, mark wills <markrobertwills@ ...> wrote:
>>>
>>> There's lot's of FIG documentation on line. If it's FIG 79 compliant, it should be a cinch to use. Try www.forthworks. com for information on the FIG (and other) standards.
>>> 
>>> Regards
>>> 
>>> Mark
>>> 
>>> 
>>> 
>>> > From: fdos <fdosbrs@... >
>>> > >> FigForth on a cartridge?.. . Woa!
>>> > >>
>>> > >>
>>> > >>
>>> > >>     *From:* Ksarul 
>>> > >>     ------------ --------- --------- --------- --------- --------- -
>>> > >>
>>> > > ------------ --------- --------- ------
>>> > > 
>>> > > Yahoo! Groups Links
>>> > > 
>>> > > 
>>> > > 
>>> > > 
>>> > 
>>> > 
>>> > ------------ --------- --------- ------
>>> > 
>>> > Yahoo! Groups Links
>>> > 
>>> > 
>>> >
>>>
>
>
>

---

From: ti99_forever <[email-masked]>
Date: Fri, 11 Dec 2009 11:56:12 -0800 (PST)

If you are talking about a runtime startup, both TI Forth and Wycove Forth support that and document it as well.

--- On Fri, 12/11/09, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Re: FigForth Cart (was: Missing 8K ROMs?)
To: [email-masked]
Date: Friday, December 11, 2009, 1:50 PM

Another Forth site is www.ultraforth.com - I have spent days reading everything on
 that site. There is some really interesting stuff on there.

Mark

 

      

Hi TI friends,

Cheers

Filip

--- In TI994A@yahoogroups. com, mark wills <markrobertwills@ ...> wrote:

---

From: "killroy732000" <[email-masked]>
Date: Sat, 12 Dec 2009 08:25:37 -0000

Hi Mark, 

I can't reach the ultraforth site. Also google didn't bring
anything up.
Can you please confirm/verify the URL. 

Thanks

Filip

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> >From: killroy732000 <filip.van-vooren@...>
> >>> > From: fdos <fdosbrs@ >

---

From: mark wills <[email-masked]>
Date: Sat, 12 Dec 2009 04:40:05 -0800 (PST)

Sorry Filip, I got my URLs mixed up!

It's www.ultratechnology.com

Lots of interesting info about the philosophy behind forth. Also lots of information about Forth processors, which run Forth code natively - their 'machine code' is Forth.

Mark

>Sent: Sat, 12 December, 2009 9:25:37
>>> I have the same book. Chuck Moore talks a lot of sense. He has his own website: www.colorfoth. com
>>> 
>>> Another Forth site is www.ultraforth. com - I have spent days reading everything on that site. There is some really interesting stuff on there.
>>> 
>>> Mark
>>> 
>>> 
>>> 
>>> >
>>> >From: killroy732000 <filip.van-vooren@ ...>