Subject: New TI Information

From: "Bryan Roppolo Boulder" <[email-masked]>
Date: Mon, 23 Nov 2009 04:46:48 -0500

Here's some things I found out recently:

1. A person name Mary Schenck designed all the original game/user manuals
for the TI-99/4 in 1979, designed the original cardboard boxes with the
"doors" on them,  designed the TI title screen. She also designed (not
coded) Demonstration, Early Learning Fun and Beginning Grammar.

2. Tom Merrow programmed the TI-99/4 title screen and sent me a code snippet
that he found in a box of items left over from those days. His code still
has a 1978 copyright on the title screen, which is what one very early
brochure shows (before it was updated to 1979).

3. I'm still looking for a prototype TI-99/4 computer :) That would be a
museum piece for sure, the mother of all TI-99's! 

              ---DELIVERED BY---      
                     \|/
                   o(O O)o
                     \^/
            --ooOo---(_)---oOoo---
             HOTMAIL WEB COURIER

---

From: ti99_forever <[email-masked]>
Date: Mon, 23 Nov 2009 03:00:37 -0800 (PST)

#2 is of great interest, concerning the TMS9985 and delays. So, original Title Screen with 1978 date. A year was a long time back then. Wonder what month of 1978 the machine could have been ready if the 9985 passed initial testing. How long did the retro-fit of a 9900 into the 99/4 cost TI?

What month was it shipped in 1979?

;)

--- On Mon, 11/23/09, Bryan Roppolo Boulder <[email-masked]> wrote:

> From: Bryan Roppolo Boulder <[email-masked]>
> Subject: [TI994A] New TI Information
> To: [email-masked]
> Date: Monday, November 23, 2009, 4:46 AM
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: ti99_forever <[email-masked]>
Date: Mon, 23 Nov 2009 04:26:14 -0800 (PST)

Ah! So it could really be almost 2 years of setbacks...!
;)

--- On Mon, 11/23/09, kabldb <[email-masked]> wrote:

> From: kabldb <[email-masked]>
> Subject: [TI994A] Re: New TI Information
> Date: Monday, November 23, 2009, 7:18 AM
> JUN 1979:
> Texas Instruments unveils the TI-99/4 Home Computer, but it
> doesn't actually make it to market until early 1980 because
> of pre-production bugs that TI is not able to work out in
> time for the Christmas season.
> 
> JAN 1980:
> Despite the fact that the TI-99/4 was "officially"
> available in January 1980, it was in short supply as
> evidenced by the following ad in the January 1980 Byte
> Magazine, page 88.
> 
> ref.:
> http://www.ti99ers.org/timeline/timeline.htm
> 
> :-)
> 
> 
> 
> --- In [email-masked],
> ti99_forever <ti99_forever@...> wrote:
> >
> > #2 is of great interest, concerning the TMS9985 and
> delays. So, original Title Screen with 1978 date. A year was
> a long time back then. Wonder what month of 1978 the machine
> could have been ready if the 9985 passed initial testing.
> How long did the retro-fit of a 9900 into the 99/4 cost TI?
> > 
> > --- On Mon, 11/23/09, Bryan Roppolo Boulder
> <brop99@...> wrote:
> > 
> > > From: Bryan Roppolo Boulder <brop99@...>
> > > 1. A person name Mary Schenck designed all the
> original
> > > game/user manuals
> > > for the TI-99/4 in 1979, designed the original
> cardboard
> > > boxes with the
> > > "doors" on them,  designed the TI title screen.
> She
> > > also designed (not
> > > coded) Demonstration, Early Learning Fun and
> Beginning
> > > Grammar.
> > > 
> > > 2. Tom Merrow programmed the TI-99/4 title screen
> and sent
> > > me a code snippet
> > > that he found in a box of items left over from
> those days.
> > > His code still
> > > has a 1978 copyright on the title screen, which
> is what one
> > > very early
> > > 3. I'm still looking for a prototype TI-99/4
> computer :)
> > > That would be a

---

From: mark wills <[email-masked]>
Date: Mon, 23 Nov 2009 04:51:19 -0800 (PST)

Is there any truth to the rumour (I think it may have reported in the Orphan Chronicles) that other candidates for the Home Computer were presented, running on a different processor (e.g. Z80)?

IIRC The Orphan Chronicles stated that these were rejected as they thought there would be more margin (i.e. $) in using a processor that was manufactured internally (I.e. the TMS99xx) and buying it from themselves at cost.

Of course, the semi-conductor manufacturing division had different ideas (they have profit margin targets too!) and sold them (the Consumer Division) the chip at close to third party prices! Bang goes the profit margin...

I've seen this a lot over the years. When I was doing freelance work for ABB, they had the cheek to think that they could buy in large power gear (kilo-volt heavy transformers and switch gear) at cost from the ABB power division, and quoted on that basis and won a large subway power contract.

Then they learned that the Power Division also has a profit to make!

Woops!

>
>From: ti99_forever <[email-masked]>
>Sent: Mon, 23 November, 2009 13:26:14
>Subject: Re: [TI994A] Re: New TI Information
>
> >
>
>
>
>
>  >
>>      
> 
>>--- On Mon, 11/23/09, kabldb <kabldb@yahoo. dk> wrote:
>
>>> From: kabldb <kabldb@yahoo. dk>
>>> To: TI994A@yahoogroups. com
>>> http://www.ti99ers. org/timeline/ timeline. htm
>>> 
>>> :-)
>>> 
>>> 
>>> 
>>> --- In TI994A@yahoogroups. com,
>>> ti99_forever <ti99_forever@ ...> wrote:
>>> >
>>> > > To: TI994A@yahoogroups. com
>>> ------------ --------- --------- ------
>>> 
>>> Yahoo! Groups Links
>>> 
>>> 
>>>     TI994A-fullfeatured @yahoogroups. com
>>> 
>>> 
>>> 
>
>
>

---

From: "Bryan Roppolo Boulder" <[email-masked]>
Date: Mon, 23 Nov 2009 13:24:15 -0500

All I know is that Tom Merrow left in December 1978, and he even knew about
Hunt The Wumpus then! I guess some projects took longer to get out the door.
As to when the 99/4 actually came out, it's not documented well but it looks
like somewhere between October-December 1979.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ti99_forever
Sent: Monday, November 23, 2009 6:01 AM
To: [email-masked]
Subject: Re: [TI994A] New TI Information

#2 is of great interest, concerning the TMS9985 and delays. So, original
Title Screen with 1978 date. A year was a long time back then. Wonder what
month of 1978 the machine could have been ready if the 9985 passed initial
testing. How long did the retro-fit of a 9900 into the 99/4 cost TI?

;)

      

Yahoo! Groups Links

---

From: "Bryan Roppolo Boulder" <[email-masked]>
Date: Mon, 23 Nov 2009 13:27:24 -0500

Well, that's what Bill Gaskill has written down, but since he wrote that I
found an article from December 1979 where two women recommend buying the
TI-99/4 for $1150 at Bloomingdale's where it was available...

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
kabldb
Sent: Monday, November 23, 2009 7:19 AM
To: [email-masked]
Subject: [TI994A] Re: New TI Information

JUN 1979:
Texas Instruments unveils the TI-99/4 Home Computer, but it doesn't actually
make it to market until early 1980 because of pre-production bugs that TI is
not able to work out in time for the Christmas season.

JAN 1980:
Despite the fact that the TI-99/4 was "officially" available in January
1980, it was in short supply as evidenced by the following ad in the January
1980 Byte Magazine, page 88.

ref.:

:-)

> --- On Mon, 11/23/09, Bryan Roppolo Boulder <brop99@...> wrote:
> 

Yahoo! Groups Links

---

From: "computerclassics2000" <[email-masked]>
Date: Tue, 24 Nov 2009 07:01:39 -0000

Excerpt from "Death of a Computer" by Joseph Nocera, Texas Monthly magazine, Jun 1984, page 61.

By fall 1980, with Texas Instruments selling fewer than 1,000 computers a month, the people in the consumer-products group had come to the not-unexpected conclusion that it was time to go back to the drawing board. Peter Bonfield, then the head of the home-computer division, felt that the most critical flaws in the 99/4 were its price and its 9900 microprocessor, so he asked his engineers to design a computer that used a different microprocessor and that cut the cost in half. The chip they chose was the Z-80, first manufactured by the Zilog Corporation, one of the most widely used 8-bit microprocessors. The design for the computer they came up with was so good that they thought they might get TI to bend its rules a 
little. But Bonfield had to get the new design past Bucy and Shepherd — and past an engineer named Don Bynum.

Bynum was 36 years old and a newcomer at TI. He stood out from the gray mass of TI engineers because he had a little more talent than most of them and a little more drive and a little more flair. But what he had most of all was compelling personal presence. Bynum was a great one for rallying the troops. When things were going badly, he liked to give what he called his General Patton speeches, and the people under him would stay later and work harder until everything was right again.

When Bonfield's new computer design began making the rounds at TI's Dallas headquarters, Bynum was assigned to the company's Corporate Engineering Center, where research-and-development proposals were evaluated. This position allowed him not only to see the design but also to take sides. He sided against Bonfield and quickly became the leading in-house critic of the new computer. His entire argument was based on the idea that the 9900 micro-processor should not be abandoned, precisely what Bucy and Shepherd wanted to hear, of course. To prove his point, he put together his own redesign of the 99/4. called the Ranger. The Ranger did not solve the price problem or the keyboard problem or the software problem, but it did address another nagging problem, the haphazard way the peripherals fit together with the computer.

When Shepherd and Bucy shot down the Z-80 design, they also shipped Peter Bonfield off to the calculator division (he left TI soon thereafter) and replaced him with Don Bynum. In November 1980 Bynum moved to Lubbock to run the home-computer division, and the first thing he did was confiscate all the prototypes of the Z-80 computer. The second thing he did was trot out his Ranger designs. And the third thing he did was realize that the Ranger was a mistake.

A couple of months after he arrived, the Ranger was as dead as the Z-80 computer, for Bynum had seen designs for yet another computer, and he had fallen in love.

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> >From: ti99_forever <ti99_forever@...>
> >>> <brop99@> wrote:
> >>> > > From: Bryan Roppolo Boulder <brop99@>

---

From: mark wills <[email-masked]>
Date: Mon, 23 Nov 2009 23:31:15 -0800 (PST)

Aggghhhhhhhh! Why did the story end there?

KEEP POSTING!!!!!

>
>From: computerclassics2000 <[email-masked]>
>Sent: Tue, 24 November, 2009 8:01:39
>Subject: [TI994A] Re: Z80 TI?
>
> >
>
>
>
>
>  >
>>      
> 
>>When Bonfield's new computer design began making the rounds at TI's Dallas headquarters, Bynum was assigned to the company's Corporate Engineering Center, where research-and- development proposals were evaluated. This position allowed him not only to see the design but also to take sides. He sided against Bonfield and quickly became the leading in-house critic of the new computer. His entire argument was based on the idea that the 9900 micro-processor should not be abandoned, precisely what Bucy and Shepherd wanted to hear, of course. To prove his point, he put together his own redesign of the 99/4. called the Ranger. The Ranger did not solve the price problem or the keyboard problem or the software problem, but it did address another nagging problem, the haphazard way the peripherals fit together with the computer.
>
>>--- In TI994A@yahoogroups. com, mark wills <markrobertwills@ ...> wrote:
>>>
>>> >From: ti99_forever <ti99_forever@ ...>

---

From: "Tursi" <[email-masked]>
Date: Tue, 24 Nov 2009 05:16:47 -0500

> This *confirms* it is a permissions issue, but isolating the problem
> further is going to be difficult as Tursi cannot repproduce the issue on
> his development machine (hardly surprising).
>

Um, just to be clear, the reason I haven't reproduced the issue is as simple 
as "I haven't had time to try to yet". :) It hasn't "just happened" for me 
was all I meant to communicate when I said it doesn't crash on my test 
machines. I have not tried in a restricted environment.

It should not crash anyway.. especially not for permissions. First I need to 
fix the crash, then I'll see if the permissions issue is my fault
too. What path do you install to?

I appreciate the time spent, and I asked you to dig in partly 
tongue-in-cheek, partly because if you found it before I left on my trip I 
might be able to squeeze the fix in. :) If nothing else, your hints may help 
others till I get it fixed. :)

> Pure hunch: The major mods to this editiom of Classic99 were to the sound
> engine. I am *guessing* it gets to the part where it tries to issue the
> standard TI 'beep' (just as the title screen is displayed) and something
> goes bang.

This at least answers the question I asked previously, "Do old versions work 
on the same machine?" I never got a clear yes or no to that. :)

The problem is that the sound engine begins before the cyan screen appears - 
even though you don't hear anything, the sound channels are running and the 
sound chip is being emulated. The screen should be black until that happens. 
My own theory is leaning towards ROM loading, which is why I asked about 
trying with a deleted Classic99.ini.

> Tursi: We can put it to the test if you are prepared to make a custom
> build for me. If you 'short circuit' the sound code, such that it just
> returns (or whatever) without touching the sound hardware, then it might
> tell us *something*. Are you different some different/new API calls that
> you have not used before?
>

The new sound engine is the main difference, but we don't need to go to that 
level. In the time it will take to make a special build, I should be able to 
reproduce it. The API calls are pretty much the same, but I am passing in a 
different set of flags. I still suspect its got more to do with the file 
system.

> Question: Is there any code in Classic99 that attempts to enumerate the
> sound cards in the system? Is a specific permission required to allow code
> such as that to run? I'd be suprised if that was the nature of the problem
> however, since I would expect Classic99 to enumerate it's audio (and
> other) devices way before it drew the screen. It would also mean that a
> lot of other programs would not run.
>

No, Classic99 uses the default sound device. It /may/ be sound, since that 
changed the most, but it might still be something simpler since that API was 
in use before (the speech system always used streaming, now all sound does).

Thanks for helping out! I'll save these notes for when I get home.

---

From: mark wills <[email-masked]>
Date: Tue, 24 Nov 2009 02:24:54 -0800 (PST)

Ok, just tried renaming classic99.ini - same result - *bang*

Also, a new classic99.ini file is *not* created

Unfortunately I don't have an earlier version of classic99 on this machine to try. Are they available on harmlesslion anywhere? (Only seems to be the latest version available on the site)

HTH

Mark

>
>From: Tursi <[email-masked]>
>Sent: Tue, 24 November, 2009 11:16:47
>Subject: [TI994A] Classic99 permissions issue
>
> >
>
>
>
>
>  >
>>      
>

---

From: mark wills <[email-masked]>
Date: Tue, 24 Nov 2009 02:30:02 -0800 (PST)

>What path do you install to?

C:\TI Stuff\classic99

:-)

---

From: "Tursi" <[email-masked]>
Date: Tue, 24 Nov 2009 05:33:14 -0500

> Ok, just tried renaming classic99.ini - same result - *bang*

That's good.. it's not something stupid in the config file.

> Also, a new classic99.ini file is *not* created

That's not surprising, the file is only written at program close. If you 
don't exit cleanly, you don't write. :)

> Unfortunately I don't have an earlier version of classic99 on this machine 
> to try. Are they available on harmlesslion anywhere? (Only seems to be the 
> latest version available on the site)
>

No, for better or for worse, I don't keep old versions around. No worries, 
I'll get it sorted when I get home. I think at least three people have 
reported this issue.

What folder path do you install it in?

---

From: ti99_forever <[email-masked]>
Date: Tue, 24 Nov 2009 02:36:39 -0800 (PST)

That not nice!
Aren't you supposed to install this under your folder? Even on XP it would steer you in that direction...

How about trying it under your user folder?

--- On Tue, 11/24/09, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Classic99 permissions issue
To: [email-masked]
Date: Tuesday, November 24, 2009, 5:30 AM

C:\TI Stuff\classic99

:-)

---

From: "Tursi" <[email-masked]>
Date: Tue, 24 Nov 2009 05:34:22 -0500

>>What path do you install to?

Try getting rid of the space in the pathname?

Should be the last thing I ask for a while. ;)