Subject: Tweak....

From: Owen Brand <[email-masked]>
Date: Wed, 6 Jan 2010 22:13:49 -0500

Question of the day: "If you can run an XB program off a CF7 with The  
XB cart plugged into the console, why would it be impossible to use  
some of the same components from the CF7 (the IO connector and related  
circuitry) and build a sidecar cartridge containing XB programs?"

*This would eventually go to serve a far greater purpose than my XB  
offerings... But I am just wondering if it is theoretically  
possible... The components can't be that expensive.... Maybe he would  
be interested in utilizing his manufacturer to perhaps distribute  
parts to us... He could be of great assistance and make some money in  
the process.... I want to be able to run my game on an unexpanded  
TI... And without requiring a CF7.  This is the only thing I can think  
of...  Is it possible? Reasonable? Probable?

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "kabldb" <[email-masked]>
Date: Thu, 07 Jan 2010 07:35:30 -0000

I can understand a certain desire for seeing your own programs in cartridge format. And though the suggested project may very well be plausible, I would go and learn assembler instead. Maybe when your Honeycomb Rapture game is finished, you could start a blog for translating it into assembler. I would help you break it down, translate the bits and tie it all together. I'm sure many other assembler TI programmers would peek and poke.

:-)

---

From: Owen Brand <[email-masked]>
Date: Thu, 7 Jan 2010 08:52:28 -0500

Whatever...  :). You are such a motivator...  :). I have many great AL  
tools now---just haven't had much time lately to do anything  
constructive.  The idea of doing a blog specifically for thy project--  
I really like that, and I will do so--- if I can ever finish the XB  
version.  A ten month old makes it hard to do anything that takes any  
time.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 7, 2010, at 2:35 AM, "kabldb" <[email-masked]> wrote:

> I can understand a certain desire for seeing your own programs in  
> cartridge format. And though the suggested project may very well be  
> plausible, I would go and learn assembler instead. Maybe when your  
> Honeycomb Rapture game is finished, you could start a blog for  
> translating it into assembler. I would help you break it down,  
> translate the bits and tie it all together. I'm sure many other  
> assembler TI programmers would peek and poke.
>
> :-)
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 7 Jan 2010 11:21:42 -0500

With AL, it would be possible to greatly enhance my graphics.  But we  
will start with the simple conversion first, I think... Then The next  
game--- AL?  We shall see. :). Thanks for your support and  
encouragement. Your "Destroyer" game looks flippin incredible.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 14:16:44 -0800 (PST)

Yep, that's the way forward. Assembly. "Onward and upward*"

* Alpiner ;-)

>
>From: kabldb <[email-masked]>
>To: [email-masked]
>Sent: Thu, 7 January, 2010 7:35:30
>Subject: [TI994A] Re: Tweak....
>
>  
>--- In TI994A@yahoogroups. com, Owen Brand <owenbrand@. ..> wrote:
>>
>> possible... The components can't be that expensive... . Maybe he would

---

From: mark wills <[email-masked]>
Date: Thu, 7 Jan 2010 14:29:28 -0800 (PST)

Once you get into AL and you see for yourself just how much FASTER it is, you'll be hooked.

Additionally, we are lucky. The TMS9900 is a LOVELY chip to code on, with the MOST beautiful instruction set of ANY processor (IMHO). Coding on it is really no harder than in BASIC!

The 68K processors have some nice instructions. The Z80 too (single instruction move loops for example), but the Z80 architecture (and Intel) is just vile.

We are truly spoiled with the 9900 ;-)

And have you looked at the instruction set on the 99000? Holy COW ;-) That's NICE!

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Thu, 7 January, 2010 16:21:42
>Subject: Re: [TI994A] Re: Tweak....
>
>  
>With AL, it would be possible to greatly enhance my graphics.  But we will start with the simple conversion first, I think... Then The next game--- AL?  We shall see. :). Thanks for your support and encouragement. Your "Destroyer" game looks flippin incredible.
>
>Owen Brand 
>**Oprysoft**
>Opry99er.com
>
>On Jan 7, 2010, at 2:35 AM, "kabldb" <kabldb@yahoo. dk> wrote:
>
>
>