Subject: AORG question

From: Owen Brand <[email-masked]>
Date: Fri, 12 Feb 2010 16:45:07 -0500

Assuming I have several bytes loaded into memory from a previous  
subroutine, would it be necessary to "clear" them out of that block of  
memory before loading another similar routine?  By this I mean (and I  
am doing this by hand) if I load a particular piece if music into  
memory starting at say >701C (imaginary memory location--- Just an  
example) an then need another piece of music loaded into that same  
starting memory location later in the program, would there be any  
carry over?  If the first is longer or shorter than the second (take  
up more bytes) then will this be problematic?  I am trying to  
determine if a template is possible, or if I need to be more specific  
per each piece of music.... This might be a dumb question, but I am  
trying to learn-- and right now I don't know much about this.   
Thanks.  ;)

Owen Brand
Opry99er.com

---

From: "Matthew" <[email-masked]>
Date: Fri, 12 Feb 2010 22:14:44 -0000

Well, what you are doing has nothing to do with the assembler's AORG directive.

As for the new sound data, if you don't care about the old data, just write over it.  There is no reason to "clear" old data if you are just writing on top of it completely.  You do, however, need some way to know you are at the end of your sound data, ie. you need to know the length of each sound and when to stop processing bytes.

Matthew

---

From: Owen Brand <[email-masked]>
Date: Fri, 12 Feb 2010 17:24:33 -0500

Just wasn't sure if I needed to set another origin to my second  
file---  i believe in the sample source I have, there is a check for  
length of bytes and a "marker" for the end of soundlist.... (Forgive  
my syntax---im not very good with assembly terminology yet)  I'll  
double check. But my primary reason for asking the question was would  
it be any faster to CALL LOAD the two or three separate soundlists  
into separate locations, or would it be equally as efficient to just  
write over top if them every time?  I am wondering whether I can use  
the sample source I have as a template for all my pieces, or whether I  
need to be setting up a new location for each piece and then run the  
program.  It's a question of whether it loads a piece of music each  
time a new level is reached or it loads them all in different  
locations before program execution.

Owen Brand
Opry99er.com

On Feb 12, 2010, at 5:14 PM, "Matthew" <[email-masked]> wrote:

> As for the new sound data, if you don't care about the old data,  
> just write over it. There is no reason to "clear" old data if you  
> are just writing on top of it completely. You do, however, need some  
> way to know you are at the end of your sound data, ie. you need to  
> know the length of each sound and when to stop processing bytes.
>
> Matthew
>

---

From: ti99_forever <[email-masked]>
Date: Fri, 12 Feb 2010 14:33:37 -0800 (PST)

Sound lists supported by the interrupt routine in the console have a 0 at the end for end of list (or two other flag values for looping). Each piece of a sound list has a length byte preceding the bytes to be loaded during that particular duration.

--- On Fri, 2/12/10, Matthew <[email-masked]> wrote:

> From: Matthew <[email-masked]>
> Subject: [TI994A] Re: AORG question
> To: [email-masked]
> Date: Friday, February 12, 2010, 5:14 PM
> Well, what you are doing has nothing
> to do with the assembler's AORG directive.
> 
> As for the new sound data, if you don't care about the old
> data, just write over it.  There is no reason to
> "clear" old data if you are just writing on top of it
> completely.  You do, however, need some way to know you
> are at the end of your sound data, ie. you need to know the
> length of each sound and when to stop processing bytes.
> 
> Matthew
> 
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: Marc Hull <[email-masked]>
Date: Fri, 12 Feb 2010 16:48:33 -0800 (PST)

Owen.... Did you write your own player as well? IIRC (and I usually don't on Friday nights..)... sound lists must be in VDP memory (or GROM) in order for the console sound list player to work on them so maybe you need to redirect....

--- On Fri, 2/12/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: AORG question
To: "[email-masked]" <[email-masked]>
Date: Friday, February 12, 2010, 4:24 PM

  

      Just wasn't sure if I needed to set another origin to my second file---  i believe in the sample source I have, there is a check for length of bytes and a "marker" for the end of soundlist... . (Forgive my syntax---im not very good with assembly terminology yet)  I'll double check. But my primary reason for asking the question was would it be any faster to CALL LOAD the two or three separate soundlists into separate locations, or would it be equally as efficient to just write over top if them every time?  I am wondering whether I can use the sample source I have as a template for all my pieces, or whether I need to be setting up a new location for each piece and then run the program.  It's a question of whether it loads a piece of music each time a new level is reached or it loads them all in different locations before program execution.   

Owen BrandOpry99er.com
On Feb 12, 2010, at 5:14 PM, "Matthew" <matthew@mundomateo. com> wrote:

    

Matthew

--- In TI994A@yahoogroups. com, Owen Brand <owenbrand@. ..> wrote:

---

From: Owen Brand <[email-masked]>
Date: Sat, 13 Feb 2010 00:09:03 -0500

My lists are written to VDP.  I have been really studying to make this  
converter a solid tool... Willsy has just taken over development while  
I focus on Honeycomb... He has apparently made some great mods to it,  
but I haven't seen them yet.  The focus now is finishing Honeycomb,  
and that's really all I can focus on right now.  I have 2.5 days, and  
I'm still a
Good 5 or 6 hours away worth
of coding, testing and debugging... Hope I can find the time.... Shit  
has been hectic lately.  The sticking point for me has really been  
developing an engine to delete my DDT SPRITEs when they hit the bottom  
of the screen.... I cannot allow them to wrap to the top.... Just  
can't.  Anyway, I'll keep you updated my friend.  Stuff has been crazy  
lately, and I'm sharpening my skills.  This time next year, I'll be a  
monster with this shit.  :). I'm dreaming in XB syntax now.   
Whatever. :)

Owen Brand
Opry99er.com

On Feb 12, 2010, at 7:48 PM, Marc Hull <[email-masked]> wrote:

> Owen.... Did you write your own player as well? IIRC (and I usually  
> don't on Friday nights..)... sound lists must be in VDP memory (or  
> GROM) in order for the console sound list player to work on them so  
> maybe you need to redirect....
>
> length of bytes and a "marker" for the end of soundlist... .  
> (Forgive my syntax---im not very good with assembly terminology  
> yet)  I'll double check. But my primary reason for asking the  
> question was would it be any faster to CALL LOAD the two or three  
> separate soundlists into separate locations, or would it be equally  
> as efficient to just write over top if them every time?  I am  
> wondering whether I can use the sample source I have as a template  
> for all my pieces, or whether I need to be setting up a new location  
> for each piece and then run the program.  It's a question of whether  
> it loads a piece of music each time a new level is reached or it  
> loads them all in different locations before program execution.
>
> Owen Brand
> Opry99er.com
>
>> are just writing on top of it completely. You do, however, need  
>> some way to know you are at the end of your sound data, ie. you  
>> need to know the length of each sound and when to stop processing  
>> bytes.
>>
>> Matthew
>>

---

From: mark wills <[email-masked]>
Date: Fri, 12 Feb 2010 21:42:06 -0800 (PST)

Are you using the assembly based sprite detection that I knocked up?

If you are, we could easily extend it to include checking the DDT sprite Y location and removing it (move it off the bottom of the screen, or it set its Y value to >D0 (if its the highest sprite number used in your program))

If you are using normal XB sprite collision detection, then we could add a simple interrupt driven routine...

M

>Sent: Sat, 13 February, 2010 6:09:03
>My lists are written to VDP.  I have been really studying to make this converter a solid tool... Willsy has just taken over development while I focus on Honeycomb... He has apparently made some great mods to it, but I haven't seen them yet.  The focus now is finishing Honeycomb, and that's really all I can focus on right now.  I have 2.5 days, and I'm still a
>of coding, testing and debugging... Hope I can find the time.... Shit has been hectic lately.  The sticking point for me has really been developing an engine to delete my DDT SPRITEs when they hit the bottom of the screen.... I cannot allow them to wrap to the top.... Just can't.  Anyway, I'll keep you updated my friend.  Stuff has been crazy lately, and I'm sharpening my skills.  This time next year, I'll be a monster with this shit.  :). I'm dreaming in XB syntax now.  Whatever. :) 
>
>Owen Brand
>Opry99er.com
>
>On Feb 12, 2010, at 7:48 PM, Marc Hull <marc.hull@sbcglobal .net> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>--- On Fri, 2/12/10, Owen Brand <owenbrand@opry99er. com> wrote:
>>
>>
>>>From: Owen Brand <owenbrand@opry99er. com>
>>>To: "TI994A@yahoogroups .com" <TI994A@yahoogroups. com>

---

From: Owen Brand <[email-masked]>
Date: Sat, 13 Feb 2010 00:45:12 -0500

Wow... Yea man!!!  I am really pumped about that idea.... And yea, I'm  
using your COINC routine... :). Do you have an updated BETA if  
Honeycomb?  Maybe you could look at it and let me know your opinion.  :)

Owen Brand
Opry99er.com

On Feb 13, 2010, at 12:42 AM, mark wills <[email-masked]>  
wrote:

> If you are, we could easily extend it to include checking the DDT  
> sprite Y location and removing it (move it off the bottom of the  
> screen, or it set its Y value to >D0 (if its the highest sprite  
> number used in your program))
>
> My lists are written to VDP.  I have been really studying to make  
> this converter a solid tool... Willsy has just taken over  
> development while I focus on Honeycomb... He has apparently made  
> some great mods to it, but I haven't seen them yet.  The focus now  
> is finishing Honeycomb, and that's really all I can focus on right  
> now.  I have 2.5 days, and I'm still a
> of coding, testing and debugging... Hope I can find the time....  
> Shit has been hectic lately.  The sticking point for me has really  
> been developing an engine to delete my DDT SPRITEs when they hit the  
> bottom of the screen.... I cannot allow them to wrap to the top....  
> Just can't.  Anyway, I'll keep you updated my friend.  Stuff has  
> been crazy lately, and I'm sharpening my skills.  This time next  
> year, I'll be a monster with this shit.  :). I'm dreaming in XB  
> syntax now.  Whatever. :)
>
> Owen Brand
> Opry99er.com
>
>> file---  i believe in the sample source I have, there is a check  
>> for length of bytes and a "marker" for the end of soundlist... .  
>> for all my pieces, or whether I need to be setting up a new  
>> location for each piece and then run the program.  It's a question  
>> of whether it loads a piece of music each time a new level is  
>> reached or it loads them all in different locations before program  
>> execution.
>>
>> Owen Brand
>> Opry99er.com
>>

---

From: mark wills <[email-masked]>
Date: Fri, 12 Feb 2010 21:57:01 -0800 (PST)

Zip up all your HR code (everything) and send it to me via private email.

It looks like I deleted the COINC source code that I did for you, so please send me that as well...

It won't take long to modify that code. So, you just want:

IF DDT_Y > Something THEN REMOVE DDT_SPRITE

Kind of thing, yes?

>Sent: Sat, 13 February, 2010 6:45:12
>Wow... Yea man!!!  I am really pumped about that idea.... And yea, I'm using your COINC routine... :). Do you have an updated BETA if Honeycomb?  Maybe you could look at it and let me know your opinion.  :)
>
>Owen Brand
>Opry99er.com
>
>On Feb 13, 2010, at 12:42 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>>