Subject: MBX games

From: Owen Brand <[email-masked]>
Date: Tue, 19 Jan 2010 22:39:10 -0500

Hey all... Anyone know which MBX games came with overlays for the  
"keyboard"?  If I buy a game that requires the overlay, I want to make  
sure it comes with....

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "Ksarul" <[email-masked]>
Date: Wed, 20 Jan 2010 07:29:16 -0500

Baseball, Honey Hunt, Soundtrack Trolley, and I'm Hiding.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Owen Brand
Sent: Tuesday, January 19, 2010 10:39 PM
To: [email-masked]
Subject: [TI994A] MBX games

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "hexbus" <[email-masked]>
Date: Wed, 20 Jan 2010 12:37:11 -0000

Speaking of MBX stuff... the DC in jack on my unit needs to be replaced.

Does anyone know the exact ID/OD of the jack?  If not, I'll just have to order a handful of them until I find the right size :-)

Jon

---

From: Owen Brand <[email-masked]>
Date: Wed, 20 Jan 2010 09:23:06 -0500

Here's the other question then.... Anyone have any MBX games/overlays  
or just games or just overlays they'd like to sell?  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 20, 2010, at 7:29 AM, "Ksarul" <[email-masked]> wrote:

> Baseball, Honey Hunt, Soundtrack Trolley, and I’m Hiding.
>
>
>
> Jim
>
>
>
> From: [email-masked] [mailto:[email-masked]] On  
> Behalf Of Owen Brand

---

From: Keith Bergman <[email-masked]>
Date: Wed, 20 Jan 2010 09:25:20 -0500

Not to hijack your topic, Owen, but does anyone know of any third-party A.D.
(after discontinuation) development on the MBX?  It seems like such a case
of wasted potential.  I realize the audience for any new projects would be
limited, but it seems like someone has to have gotten curious and tried to
program the thing themselves, at some point.

On Wed, Jan 20, 2010 at 9:23 AM, Owen Brand <[email-masked]> wrote:

>
>
> Here's the other question then.... Anyone have any MBX games/overlays or
> just games or just overlays they'd like to sell?  :)
>
> Owen Brand
> **Oprysoft**
> Opry99er.com <http://opry99er.com/>
>
>  ------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Owen Brand
> *Sent:* Tuesday, January 19, 2010 10:39 PM
> *To:* [email-masked]
> *Subject:* [TI994A] MBX games
>
>
>
>
>
> Opry99er.com <http://opry99er.com/> <http://opry99er.com/>
>
>  
>

---

From: Owen Brand <[email-masked]>
Date: Wed, 20 Jan 2010 09:27:31 -0500

You're not hijacking.... I was just about to get to that very  
subject.  :). You
Know the interface for this MBX thing is the cassette port!!!  That  
right there gets me thinking'.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 20, 2010, at 9:25 AM, Keith Bergman <[email-masked]>  
wrote:

> Not to hijack your topic, Owen, but does anyone know of any third- 
> party A.D. (after discontinuation) development on the MBX?  It seems  
> like such a case of wasted potential.  I realize the audience for  
> any new projects would be limited, but it seems like someone has to  
> have gotten curious and tried to program the thing themselves, at  
> some point.
>
>
>
>
> Here's the other question then.... Anyone have any MBX games/ 
> overlays or just games or just overlays they'd like to sell?  :)
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>

---

From: Marc Hull <[email-masked]>
Date: Wed, 20 Jan 2010 06:46:05 -0800 (PST)

I had to replace the VR and buffers in my MBX a couple of weeks ago and while it was open I did a bit of looking around and research...  It appears (important word...)  that the only function of the MBX console itself is to record sound data (from the mic and the joyport, play back said sound (through the MBX speaker NOT the TI ), convert the analog joystick to normal digital inputs and MUX that input with the MBX keyboard input (sending same to the TI.)  Apparently most of the work is still done in the TI and the code contained in the carts  I am guessing that all TI to MBX communication is done via pulsing the common wire in the joystick port.  MBX  to TI communication is done by a CRU scanning routine contained in the cart.   Anybody confirm that? 

--- On Wed, 1/20/10, Keith Bergman <[email-masked]> wrote:

From: Keith Bergman <[email-masked]>
Subject: Re: [TI994A] MBX games
To: [email-masked]
Date: Wednesday, January 20, 2010, 8:25 AM

  

      Not to hijack your topic, Owen, but does anyone know of any third-party A.D. (after discontinuation) development on the MBX?  It seems like such a case of wasted potential.  I realize the audience for any new projects would be limited, but it seems like someone has to have gotten curious and tried to program the thing themselves, at some point.

On Wed, Jan 20, 2010 at 9:23 AM, Owen Brand <owenbrand@opry99er. com> wrote:

Here's the other question then.... Anyone have any MBX games/overlays or just games or just overlays they'd like to sell?  :)

Owen Brand 
**Oprysoft**
Opry99er.com

On Jan 20, 2010, at 7:29 AM, "Ksarul" <vze23g4a@verizon. net> wrote:

 
Jim

From: TI994A@yahoogroups. com [mailto:TI994A@yahoogroups. com] On Behalf Of Owen Brand

Sent: Tuesday, January 19, 2010 10:39 PM
To: TI994A@yahoogroups. com

sure it comes with....

Owen Brand
**Oprysoft**
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 20 Jan 2010 10:07:18 -0500

Here's a question---"Will regular TI games work using the MBX  
joystick, or are the MBX carts equipped with special code to access  
it?".

I ask because if you CAN play regular games via the MBX system, it  
shouldn't be too difficult to decipher the interface.  AL programs  
could potentially be written that would allow for these specific  
commands.  Also, the extra keyboard would allow for alot of  
flexibility to programmers.  Just a thought..... And like Keith  
said--/ there is a very limited number of MBX systems in use right  
now, so at this point, it is all conjecture.  :). Just curious.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 20, 2010, at 9:46 AM, Marc Hull <[email-masked]> wrote:

> I had to replace the VR and buffers in my MBX a couple of weeks ago  
> and while it was open I did a bit of looking around and research...   
> It appears (important word...)  that the only function of the MBX  
> console itself is to record sound data (from the mic and the  
> joyport, play back said sound (through the MBX speaker NOT the TI ),  
> convert the analog joystick to normal digital inputs and MUX that  
> input with the MBX keyboard input (sending same to the TI.)   
> Apparently most of the work is still done in the TI and the code  
> contained in the carts  I am guessing that all TI to MBX  
> communication is done via pulsing the common wire in the joystick  
> port.  MBX  to TI communication is done by a CRU scanning routine  
> contained in the cart.   Anybody confirm that?
>
>
>
>
>
>
>
>
>
>
>

---

From: tursi <[email-masked]>
Date: Wed, 20 Jan 2010 08:51:09 -0800 (PST)

> shouldn't be too difficult to decipher the interface.  AL programs could 
> potentially be written that would allow for these specific commands. 
>  Also, the extra keyboard would allow for alot of flexibility to 
> programmers.  Just a thought..... And like Keith said--/ there is a very 
> limited number of MBX

Barry Boone released a programmer's library for the MBX back in the day, 
and then again on the other list a few years ago.

Here are some of his posts:
http://tech.groups.yahoo.com/group/ti99-4a/message/54862
http://tech.groups.yahoo.com/group/ti99-4a/message/51262
http://tech.groups.yahoo.com/group/ti99-4a/message/44767
http://tech.groups.yahoo.com/group/ti99-4a/message/24791
http://tech.groups.yahoo.com/group/ti99-4a/message/19318

This last includes a note that his code is up on WHTech. You'll find it 
under "source -> MBX utilities and source code".

He's already reversed most of it for you. ;)