Subject: Re: [TI994A] Help Tony etal...

From: ti99_forever <[email-masked]>
Date: Mon, 22 Mar 2010 21:30:41 -0700 (PDT)

If by TIA files you mean TI Artist, then they are a straight memory dump without the headers that Mark speaks of. In any event, you just load the relevant file using the LOAD opcode into VDP memory at >0000 or >2000 (depending on how your bitmap mode is setup). If you get it backwards (loading the pattern file into the color buffer or vice versa) you will know, or you can call it modern art. ;)

--- On Mon, 3/22/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Help Tony etal...
To: [email-masked]
Date: Monday, March 22, 2010, 7:52 PM

They're not in any format per-se, they
 are simply a raw memory dump, in 8K chunks.

A six byte header at the top of the file depicts:

* word 0=eof file indicator (0=no more files to load)
* word 1=length of data in bytes
* word 2=destination address in cpu ram

Attached is a program image loader I did ages ago. It was later improved by our Tursi.

View with Notepad++ and the TMS9900 syntax hilighting if you can ;-)

Mark

----- Original Message ----
> From: Marc H <[email-masked]>
> To: [email-masked]
> Sent: Mon, 22 March, 2010 23:41:53
> Subject: [TI994A] Help Tony etal...
> 
> Tony,

I think it was either you or Ben who helped me out last time I 
> asked this
 question...  If you or Ben don't mind....  What format are 
> program files stored in (more specifically TIA files.)  This info would be 
> appreciated and I'll store it this time 
> ;-)

Marcus...

------------------------------------

Yahoo! 
> Groups Links

>   
> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/

------------------------------------

Yahoo! Groups Links

---

From: "Marc H" <[email-masked]>
Date: Tue, 23 Mar 2010 17:49:23 -0000

Sorry but I haven't quite explained what I am needing to do.  I want to take a TI Artist file and read it into an XB program and then rewrite it to a DV80 file to be used by the E/A.  I did just that last year sometime and must have slept because I cannot remember the format of the open statement I used to open up the TIA file for reading by XB.  I promise it has been done and if I figure it out again I'll post the procedure in the files section.  I posted it on the old group in an EM but I can't find it anymore (I believe I have been purged there ;-)  I am almost certain that it was either Tony or Ben or Bob or possibly someone else who gave me the last piece of the puzzle last time.....

--- In [email-masked], ti99_forever <ti99_forever@...> wrote:
> --- On Mon, 3/22/10, mark wills <markrobertwills@...> wrote:
> 
> From: mark wills <markrobertwills@...>
> > From: Marc H <marc.hull@...>

---

From: ti99_forever <[email-masked]>
Date: Tue, 23 Mar 2010 12:42:09 -0700 (PDT)

You cannot open a PROGRAM IMAGE file like a TI Artist file using OPEN in Basic. Only the LOAD opcode from DSRLNK can load such a file, or a lower-level routine like Access Direct Input File (all from assembly).You CAN change it to a DF128 file, and read it that way. That requires a sector edit - easy to do. You could, for example, use the RAW (read and write) sector routines for XB to do that, using it to edit the file descriptor record of the file you are opening.
So it sounds like you want it in DATA statements for an assembly program?
Assembly is required - sorry, couldn't resist!
Off the machine, you could use one of the newer utility programs to change the TI Artist file to DF128. Then your Basic program could read it and spit out some DATA statements.
--- On Tue, 3/23/10, Marc H <[email-masked]> wrote:

From: Marc H <[email-masked]>
Subject: [TI994A] Re: Help Tony etal...
To: [email-masked]
Date: Tuesday, March 23, 2010, 1:49 PM

Yahoo! Groups Links

---

From: Marc Hull <[email-masked]>
Date: Tue, 23 Mar 2010 12:46:55 -0700 (PDT)

Ya know Ben.  Great minds think alike.  I just this instant remembered that I needed to delete the first 6 bytes of the file in TIDIR (smacks head in half disgust/ half exuberance.)

Must have been a reverse AH HA moment ;-) Thanks for the help...

Marcus

--- On Tue, 3/23/10, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: Help Tony etal...
To: [email-masked]
Date: Tuesday, March 23, 2010, 2:42 PM

  

--- On
 Tue, 3/23/10, Marc H <marc.hull@sbcglobal .net> wrote:

From: Marc H <marc.hull@sbcglobal .net>
Subject: [TI994A] Re: Help Tony etal...
To: TI994A@yahoogroups. com
Date: Tuesday, March 23, 2010, 1:49 PM

Sorry but I haven't quite explained what I am needing to do.  I want to take a TI Artist file and read it into an XB program and then rewrite it to a DV80 file to be used by the E/A.  I did just that last year sometime and must have slept because I cannot remember the format of the open statement I used to open up the TIA file for reading by XB.  I promise it has been done and if I figure it out again I'll post the procedure in the files section.  I posted it on the old group in an EM but I can't find it anymore (I believe I have been purged there ;-)  I am
 almost certain that it was either Tony or Ben or Bob or possibly someone else who gave me the last piece of the puzzle last time.....

--- In TI994A@yahoogroups. com, ti99_forever <ti99_forever@ ...> wrote:
> --- On Mon, 3/22/10, mark wills <markrobertwills@ ...> wrote:
> 
> From: mark wills <markrobertwills@ ...>
> To: TI994A@yahoogroups. com
> > From: Marc H <marc.hull@.. .>
> > To: TI994A@yahoogroups. com
> >!
  Subject
: [TI994A] Help Tony etal...
> ------------ --------- --------- ------
> 
> Yahoo! 
> > Groups Links
> 
> >   
> > >http://groups. yahoo.com/ group/TI994A/
> 
> 
> > href="http://groups. yahoo.com/ group/TI994A/ join" target=_blank 
> > >http://groups. yahoo.com/ group/TI994A/ join
>     (Yahoo! ID 
> > required)
> 
> > href="mailto:TI994A-digest@ yahoogroups. com">TI994A-digest@ yahoogroups. com 
> > 
>     
> > href="mailto:TI994A-fullfeatured @yahoogroups. com">TI994A-fullfeatured @yahoogroups. com
>
 
> > ymailto="mailto:TI994A-unsubscribe@ yahoogroups. com" 
> > href="mailto:TI994A-unsubscribe@ yahoogroups. com">TI994A-unsubscribe@ yahoogroups. com
> 
> > href="http://docs. yahoo.com/ info/terms/" target=_blank 
> > >http://docs. yahoo.com/ info/terms/
> 
> ------------ --------- --------- ------
> 
> Yahoo! Groups Links
>

------------ --------- --------- ------

Yahoo! Groups
 Links

---

From: ti99_forever <[email-masked]>
Date: Tue, 23 Mar 2010 12:52:07 -0700 (PDT)

Are you sure? Not sure what that would do - the first 6 bytes of a TI Artist file are part of the data.You need to edit the file descriptor record, changing the flag byte that says it is Program to DF128 (or any factor of 256, like 64) so every byte in the 256-byte sector is correctly mapped to 2 or more records.I think you are thinking about taking an Editor/Assembler program image file that contains 6 extra bytes at the front (2 flag, 2 load address, 2 length) and removing them to get at the data itself in a program image file.

--- On Tue, 3/23/10, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Re: Help Tony etal...
To: [email-masked]
Date: Tuesday, March 23, 2010, 3:46 PM

 

Marcus

 

Assembly is required - sorry, couldn't
 resist!

  Subject

Yahoo! Groups
 Links

---

From: Marc Hull <[email-masked]>
Date: Tue, 23 Mar 2010 13:18:29 -0700 (PDT)

Your right,  Did not work,  I could kick myself for not writing the process down in my book-o-facts.  I'll search the old list again ;-)   (in my best Chris Farley voice.... Damn... I'm stoopid!)

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: Help Tony etal...
To: [email-masked]
Date: Tuesday, March 23, 2010, 2:52 PM

  

--- On Tue, 3/23/10, Marc Hull <marc.hull@sbcglobal .net> wrote:

From: Marc Hull <marc.hull@sbcglobal .net>
Subject: Re: [TI994A] Re: Help Tony etal...
To:
 TI994A@yahoogroups. com
Date: Tuesday, March 23, 2010, 3:46 PM

 

Marcus

--- On Tue, 3/23/10, ti99_forever <ti99_forever@ yahoo.com> wrote:

From: ti99_forever <ti99_forever@ yahoo.com>
Subject: Re: [TI994A] Re: Help Tony etal...
To: TI994A@yahoogroups. com
Date: Tuesday, March 23, 2010, 2:42 PM

    

  Subject

Yahoo! Groups
 Links

---

From: Marc Hull <[email-masked]>
Date: Wed, 24 Mar 2010 06:25:45 -0700 (PDT)

Well that only took till 11:00 last night but I oiled my brain cells and remembered it....

I used Mr. Birdwell's Disk Utils to print the TIA file to disk and this converted it to DV 132 which My little XB program then dissected to get to the pertinent data.  I will post the entire process to the files section later for any one who is interested and for my future benefit...

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Re: Help Tony etal...
To: [email-masked]
Date: Tuesday, March 23, 2010, 3:18 PM

  

 

        

Marcus

 

  Subject

Yahoo! Groups
 Links