Subject: Mechatronics XBII+ dump?

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 11:13:42 -0500

Has this cart been dumped?  Any chance it could be reproduced?  I  
found a manual for it at my local thrift store--- but alas, no cart.   
Anyway, unless I can somehow pull out an upset in the retroclouds game  
contest and win the cart that way, I'll need to find one elsewhere...   
The hi res graphic capabilities on this cart are pretty wild.... I  
know alot of that stuff can be done using the regular XB cart and alot  
of math.... But it kills speed.  Just curious

Owen Brand
**Oprysoft**
Opry99er.com

Owen Brand
**Oprysoft**
Opry99er.com

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 10:14:42 -0700

Owen,

So you get this enhanced XB and create the best ever game using it.  How 
many TI'ers will ever be able to play your game with their TI XB? 
You'll have to create the "slower than molasses" version anyway.  If you 
want to produce speedy games you'll have to choose another language; AL, 
Forth, etc. or use CALL LINK()s to AL you or someone else creates.

I went through this dilemma decades ago.  In my mind the total XB 
solution came in the form of a Myarc XB II v2.12 using a Myarc 128K - 
512K card.  It has all the bells and whistles you dream of, and it is 
very fast as it is programmed in 100% AL.  The 128KOS worked well and I 
could do everything I wanted to do using this XB.  Unfortunately, very 
few folks were willing to pay the price, so not many of us have Myarc XB 
II v2.12 laying around.  It doesn't work with AMS/SAMS, and it can't 
work with a CF7A+ either, so once in a while I remove the AMS/SAMS card 
and install my Foundation 128K card (modified with a Myarc EPROM for 
this purpose as my Myarc 512K card was modified for Geneve use), so I 
can remember when...  Dream on. :-(

More total fun doing it in Forth. :-)

Bill S

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 13:54:46 -0500

That's why I was asking if it would be possible to put this ROM dump  
onto cart.  I have been made to understand that it would work in a GK  
format, but I am not sure about cart.... If it could be reproduced, I  
would buy up 20 or so of Jons boards and start putting all these carts  
together.... If the XBII+ was readily available, I bet quite a few  
folks would love to give it a whirl....  :) I know of at least 4 or 5  
people who would buy one right now, were it available.... Obviously it  
will not be a collectors item, but it could be available for use.  I  
would even be willing to produce the manuals for it.  Anyone think it  
is possible to put XBII+ on a Guidry cart board?

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 28, 2010, at 12:14 PM, fdos <[email-masked]> wrote:

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 14:00:13 -0500

My next game will be in Forth, by the way Bill.... If one is available  
that doesn't require SAMS support---as I do not have one of those  
cards.  I have a ton of documentation on TI Forth and some system  
diskettes as well... But I am quite impressed by the comparirive speed  
tests between Mark's Forth and TI Forth.... I'd like to use  
turboForth... But who knows... I am having a bunch of fun using AL  
calls in XB for the time being.  :) Just curious about XBII+.... Seems  
like something the community could use, were it made available in cart  
for a wider user base.... The original carts are pretty rare.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 12:29:33 -0700

Owen,

As far as I know Mechatronics XBII+ was a commercial product, so I'm not 
sure it would be legal unless you have a license to produce it or know 
someone who does.

Bill S

Owen Brand wrote:
> On Jan 28, 2010, at 12:14 PM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  > Owen,
>  >

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 14:33:50 -0500

Well---I would be willing to put in the legwork.... However, many  
things were commercial products at one point... And many of those same  
things are being distributed now.  I'm not looking to make a million  
dollars in profit--- I just want to be able to have it, write games  
for it, and have others play them and write their own programs in  
turn....  Anyone know anything about Mechateonics?  Aside from the 30  
year old address on the manual, I'm in the dark.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 12:35:59 -0700

Owen,

You can begin with TI Forth (32K) and learn what Forth is all about, and 
even start developing application code until Mark's Forth becomes 
available.  I suspect only minor differences in words and usage.  Speed 
is another issue, so you can expect your application to fly faster after 
the upgrade.

Have all the fun you can.

Bill S

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 14:45:40 -0500

Thanks Bill....  By the way, do you have any documentation on BASIC+  
available?  I am curious....

Owen Brand
**Oprysoft**
Opry99er.com

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 13:18:58 -0700

Owen,

Not really.  All I have currently is the syntax for most of the CALL 
LINK()s, which doesn't include Mark's Sprite and Graphics CALL LINK()s 
from TGWTK.  The reason being that I haven't updated my stuff to use VDP 
the way he has it to support Sprites.  This is so I, or others like me, 
can exclude the Sprite stuff for non-game applications, yet be 
compatible in all circumstances.  I have stuff for throwing up menu 
screens with borders and window pop-ups very rapidly, that would be 
useful in some games.

I won't get around to doing formal documentation until after I get CALL 
LINK("CHAIN",FILESPEC$) working, which will require a smooth transition 
from a BCART BASIC program to a VDP program after executing CALL 
LINK("CHAIN",FILESPEC$) from within the running BCART program.

Bill S

Owen Brand wrote:
> On Jan 28, 2010, at 2:35 PM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>

---

From: Mezzaluna3000 <[email-masked]>
Date: Thu, 28 Jan 2010 22:34:16 +0100

Hello, i write for my acknologe of john guidry pcb.. is possible create 
only cartdrige that no use Grom.. the original ext-basic, mechatronic 
extbasic and other all have Grom.. the dump rom good for mess for more 
ext basic type, last year i look that are present on ti-shelf site 
(walid master). For create a mechatronic ext basic 2+ is need rewrite 
the code for work with never grom. It is for me impossible .. but  
maybe  i wrong .. i no good in software.. sure if one create a guidry 
forth cartdrige no have sense have extbasic plus (also is beatiful have 
all two ;-D).. just now the expert in software say thanks a john for 
have published workshop .. the supremacy cartdrige for program in 
assembler with real ti99.
An info.. but is bill (alias fdos) that want create a forth cartdrige.. 
sorry if no understand well  in english i have more difficult..Good work 
at all, regards Ermanno

---

From: "Tony Knerr" <[email-masked]>
Date: Thu, 28 Jan 2010 22:07:34 -0000

This idea would not be currently feasible with the existing Rom-only carts. There's Grom on the original cart. Actually that's not quite true, there's a Grom emulator on the original cart, along with the 2 banks of Rom. 

What would be necessary is for someone to design a cart that supports a Grom emulator and 2 banks of Rom.

Dumps are below:

ftp://ftp.whtech.com/emulators/mess/old/Complete%20MESS%20Geneve%20emulation/mess/software/ti99_4a/Extended%20Basic%20II%20Plus%20(1985)(Mechatronic)(Part%201%20of%203).zip

ftp://ftp.whtech.com/emulators/mess/old/Complete%20MESS%20Geneve%20emulation/mess/software/ti99_4a/Extended%20Basic%20II%20Plus%20(1985)(Mechatronic)(Part%202%20of%203).zip

ftp://ftp.whtech.com/emulators/mess/old/Complete%20MESS%20Geneve%20emulation/mess/software/ti99_4a/Extended%20Basic%20II%20Plus%20(1985)(Mechatronic)(Part%203%20of%203).zip

Tony

---

From: "Tony Knerr" <[email-masked]>
Date: Thu, 28 Jan 2010 23:10:11 -0000

As I read this thread a little closer, it looks like the point of interest is the Apesoft graphics routines. Is that so?

If so, you do not need the Mechatronic XB cart to use them.
They are simply stored in grom in the cart and moved to low memory
by the CALL APESOFT command.

So...

Load up the cart in your emulator of choice.

Do a CALL APESOFT.

Dump low memory.

Disassemble the dump into data statements.

Assemble the code into uncompressed object code.

Voila! You can now CALL LOAD the object file into plain old vanilla XB and have all the Apesoft CALL LINKS available. You could even
ALSAVE or SYSTEX that code to embed it in your program.

Alternately, you could look for the original Apesoft distribution disk. The Apesoft routines were not part of the original release of
Mechatronic XB, but added in a later release. Apparently they wanted to do something with the as-yet-unused Grom 7.
 
If the interest in Mechatronic XB is not the Apesoft graphics, just use XB v2.7, it has all the Mechatronic stuff and more - minus the Apesoft routines.

Tony

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 18:30:49 -0500

Thanks Tony... Your suggestions make perfect sense--- I hope to learn  
how to DO all that stuff... Yes, I am referring to the Apesoft  
routines alongside the standard Mechatronics upgrades... So, if I can  
find a way to dump low memory from the Apesoft software and change it  
over to data statements, it can be CALL LOADed, eh?  Well, once I  
learn that technique, I don't imagine I will need much else...  :). I  
am so eager to learn all this stuff... I have been studying my aZZ off  
on this XB/AL stuff--- trying to get every ounce I can out of XB...  
There are really some brilliant and kind people on here who are as  
eager to teach as I am to learn.  :) How lucky we are in this  
community to have such great influences!!!

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 28, 2010, at 6:10 PM, "Tony Knerr" <[email-masked]> wrote:

> As I read this thread a little closer, it looks like the point of  
> interest is the Apesoft graphics routines. Is that so?
>
> Voila! You can now CALL LOAD the object file into plain old vanilla  
> XB and have all the Apesoft CALL LINKS available. You could even
> Alternately, you could look for the original Apesoft distribution  
> disk. The Apesoft routines were not part of the original release of
> Mechatronic XB, but added in a later release. Apparently they wanted  
> to do something with the as-yet-unused Grom 7.
>
> If the interest in Mechatronic XB is not the Apesoft graphics, just  
> use XB v2.7, it has all the Mechatronic stuff and more - minus the  
> Apesoft routines.
>
> Tony
>
>

---

From: "Ksarul" <[email-masked]>
Date: Thu, 28 Jan 2010 19:55:12 -0500

The APESoft routines were also sold separately in the US as Amerisoft
Expanded Graphics BASIC. . .

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Owen Brand
Sent: Thursday, January 28, 2010 6:31 PM
To: [email-masked]
Subject: Re: [TI994A] Re: Mechatronics XBII+ dump?

Thanks Tony... Your suggestions make perfect sense--- I hope to learn how to
DO all that stuff... Yes, I am referring to the Apesoft routines alongside
the standard Mechatronics upgrades... So, if I can find a way to dump low
memory from the Apesoft software and change it over to data statements, it
can be CALL LOADed, eh?  Well, once I learn that technique, I don't imagine
I will need much else...  :). I am so eager to learn all this stuff... I
have been studying my aZZ off on this XB/AL stuff--- trying to get every
ounce I can out of XB... There are really some brilliant and kind people on
here who are as eager to teach as I am to learn.  :) How lucky we are in
this community to have such great influences!!!

Owen Brand

**Oprysoft**

Opry99er.com

On Jan 28, 2010, at 6:10 PM, "Tony Knerr" <tonyknerr@comcast.
<mailto:[email-masked]> net> wrote:

As I read this thread a little closer, it looks like the point of interest
is the Apesoft graphics routines. Is that so?

So...

Do a CALL APESOFT.

Dump low memory.

Voila! You can now CALL LOAD the object file into plain old vanilla XB and
have all the Apesoft CALL LINKS available. You could even
ALSAVE or SYSTEX that code to embed it in your program.

Alternately, you could look for the original Apesoft distribution disk. The
Apesoft routines were not part of the original release of
Mechatronic XB, but added in a later release. Apparently they wanted to do
something with the as-yet-unused Grom 7.

If the interest in Mechatronic XB is not the Apesoft graphics, just use XB
v2.7, it has all the Mechatronic stuff and more - minus the Apesoft
routines.

Tony

---

From: Gregory McGill <[email-masked]>
Date: Thu, 28 Jan 2010 16:28:15 -0800

Wasn't that available as an addon for xbasic?  I probably have that on disk
somewhere.

Greg

---

From: mark wills <[email-masked]>
Date: Thu, 28 Jan 2010 21:30:07 -0800 (PST)

Aye. And Forth will excercise your brain in ways you never thought possible!

Forth: Reaches the parts other programming languages cannot reach!

Mark

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Thu, 28 January, 2010 18:14:42
> Subject: Re: [TI994A] Mechatronics XBII+ dump?
> 
> Owen,
>

---

From: Owen Brand <[email-masked]>
Date: Fri, 29 Jan 2010 00:39:19 -0500

i heard forth was kind of like getting dressed by putting on your hat  
and jacket first, then your shoes, then your socks and shirt, followed  
by your pants and then concluding with your underwear....  That about  
sum it up?  :)

Owen Brand
**Oprysoft**
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Thu, 28 Jan 2010 21:57:37 -0800 (PST)

Yep. There shoulddn't be too many changes to make. But how would he transfer the source? Hmmm....

Yesterday I added VCHAR HCHAR DCHAR (equivalent of CHAR in XB - Forth already has a word called CHAR that means something else!) SPRITE SPRLOC SPRLOC? and SPRPAT.

Also (FINALLY!) Added GMODE - so you can switch between 40 and 32 column mode. I didn't add bitmap yet, as I know very little about it... I'm not sure if I will add bitmap or not. It depends if I can sort out line drawing and stuff. It looks like a lot of work in an area I have no experience with.

M

----- Original Message ----
> Sent: Thu, 28 January, 2010 20:35:59
> > On Jan 28, 2010, at 12:14 PM, fdos 
> > > wrote:
> > 
> >  > Owen,
> >  >

---

From: mark wills <[email-masked]>
Date: Thu, 28 Jan 2010 22:10:28 -0800 (PST)

Yep! That's about right!

Its because Forth passes its data around on a stack. With normal programming, you are managing PROGRAM FLOW, with no real care about how DATA is passed/managed. In Forth, you also manage the data flow, via the stack.

This causes brain pain, getting things on the stack in the order in which you want them. But there are techniques (i.e. factoring) that make it easier.

There's no doubt, it's harder than XB. Think of it as an uber-powerful assembly language (of the sort that would run on a single register machine) and you are about there...!

But don't be scared... Forth is FAST. That's the payoff. Even on our machines, it's quick.And I find I am becoming more comfortable with stack programming as I do more of it. But yes, it's a face-melting, arse imploding experience until you get used to it!

M

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Fri, 29 January, 2010 6:39:19
>i heard forth was kind of like getting dressed by putting on your hat and jacket first, then your shoes, then your socks and shirt, followed by your pants and then concluding with your underwear... .  That about sum it up?  :)
>
>Owen Brand
>**Oprysoft**
>Opry99er.com
>
>On Jan 29, 2010, at 12:30 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>>>> From: fdos <fdosbrs@frontiernet .net>
>>>>> To: TI994A@yahoogroups. com
>>>>> ------------ --------- --------- ------
>>>>> 
>>>>> Yahoo! Groups Links
>>>>> 
>>>>> 
>>>>> 
>>
>

---

From: fdos <[email-masked]>
Date: Fri, 29 Jan 2010 08:54:45 -0700

The disk BLOCKS used by TI Forth can be extracted to a DF 128 disk file, 
so transfer of user source should not be a problem unless you're using a 
different file type for Forth source.  Let me know.

Check out the hi-res & split modes in TI Forth for solutions.

Bill S

mark wills wrote:
> Yesterday I added VCHAR HCHAR DCHAR (equivalent of CHAR in XB - Forth 
> already has a word called CHAR that means something else!) SPRITE SPRLOC 
> SPRLOC? and SPRPAT.
> 
> Also (FINALLY!) Added GMODE - so you can switch between 40 and 32 column 
> mode. I didn't add bitmap yet, as I know very little about it... I'm not 
> sure if I will add bitmap or not. It depends if I can sort out line 
> drawing and stuff. It looks like a lot of work in an area I have no 
> experience with.
> 
> M
> 
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>

---

From: fdos <[email-masked]>
Date: Fri, 29 Jan 2010 09:32:49 -0700

Owen,

The real pay off in using Forth for all your programing is that it is a 
software development environment as all aspects of the development is 
done in Forth!  The editor, all the debugging tools, the BLOCK copy 
utilities and the modular compiler that allows you to compile a single 
word (a snippet of code) at a time and test it right at the keyboard. 
The Forth interpreter is far superior and much more powerful than XB's 
immediate mode.  You don't have to leave Forth for any reason except to 
go to the John. :-)

Bill S

mark wills wrote:
>  
> 
> Yep! That's about right!
> 
> Its because Forth passes its data around on a stack. With normal 
> programming, you are managing PROGRAM FLOW, with no real care about how 
> DATA is passed/managed. In Forth, you also manage the data flow, via the 
> stack.
> 
> This causes brain pain, getting things on the stack in the order in 
> which you want them. But there are techniques (i.e. factoring) that make 
> it easier.
> 
> There's no doubt, it's harder than XB. Think of it as an uber-powerful 
> assembly language (of the sort that would run on a single register 
> machine) and you are about there...!
> 
> But don't be scared... Forth is FAST. That's the payoff. Even on our 
> machines, it's quick. And I find I am becoming more comfortable with 
> stack programming as I do more of it. But yes, it's a face-melting, arse 
> imploding experience until you get used to it!
> 
> M
> 
> 
>     *From:* Owen Brand <[email-masked]>
>     *To:* "[email-masked]" <[email-masked]>
>     *Sent:* Fri, 29 January, 2010 6:39:19
>     *Subject:* Re: [TI994A] Mechatronics XBII+ dump?
> 
>      
> 
>     i heard forth was kind of like getting dressed by putting on your
>     hat and jacket first, then your shoes, then your socks and shirt,
>     followed by your pants and then concluding with your underwear... .
>      That about sum it up?  :)
> 
>     Owen Brand
>     **Oprysoft**
>     Opry99er.com <http://Opry99er.com>
> 
>     On Jan 29, 2010, at 12:30 AM, mark wills <markrobertwills@ yahoo.co.
>     uk <mailto:[email-masked]>> wrote:
> 
>>      
>>
>>     > From: fdos <fdosbrs@frontiernet .net
>>     <mailto:fdosbrs%40frontiernet.net>>
>>     > To: TI994A@yahoogroups. com <mailto:TI994A%40yahoogroups.com>
>>     > > <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>     > >
>>     > > Owen Brand
>>     > > **Oprysoft**
>>     > > <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>     > >
>>     > >
>>     >
>>     >

---

From: "killroy732000" <[email-masked]>
Date: Fri, 29 Jan 2010 18:33:09 -0000

The many Extended Basic versions floating around really confuse me.
Is there a document or overview available of what the differences are?

If not, perhaps we should put a page on ninerpedia.org describing the
differences. What is the "fastest" Extended Basic version available 
for the TI-99/4A ?

Filip

--- In [email-masked], Gregory McGill <arcadeshopper@...> wrote:
> On Thu, Jan 28, 2010 at 3:10 PM, Tony Knerr <tonyknerr@...> wrote:
> 
> >
> >

---

From: "Tony Knerr" <[email-masked]>
Date: Fri, 29 Jan 2010 23:16:55 -0000

What a coincidence, look at this ebay listing.
Apparently it's a genuine TI Grom emulator cart.
Looks like only logic chips involved.
Perhaps it could be copied and developed?
Jon, you there?

Tony

http://cgi.ebay.com/TI-Lubbock-Development-Cartridge-TI-99-4a-TI99-Invaders_W0QQitemZ130361914540QQcmdZViewItemQQptZLH_DefaultDomain_0?hash=item1e5a2cf4ac

--- In [email-masked], "Tony Knerr" <tonyknerr@...> wrote:
> ...

---

From: mark wills <[email-masked]>
Date: Fri, 29 Jan 2010 19:42:36 -0800 (PST)

Hi Bill, I'm using IF128 for file format, but someone said that it didn't really make any difference. I could change the file type with no other code changes required as far as I know... The important thing is that they are fixed length records, as I'm sure you can appreciate...

Mark

----- Original Message ----
> Sent: Fri, 29 January, 2010 16:54:45
> Subject: Re: [TI994A] Mechatronics XBII+ dump?/Forth
> 
> >  > From: fdos >

---

From: mark wills <[email-masked]>
Date: Fri, 29 Jan 2010 20:03:48 -0800 (PST)

Whoa! It would be REALLY cool to get that and then reverse engineer it. It looks quite simple.

Looks like it has one ROM and one GROM... LOvely! Unfortunately I'm an british ex-pat in Uzbekistan, so I won't be bidding on it ;-(

But, please, SOMEONE GET IT! Let's reverse the mother! WE OWE IT TO OURSELVES! YOU KNOW IT MAKES SENSE!

M

>
>From: Tony Knerr <[email-masked]>
>Sent: Sat, 30 January, 2010 0:16:55
>Subject: [TI994A] Re: Mechatronics XBII+ dump?
>
> >
>
>
>
>
>  >
>>      
> 
>http://cgi.ebay. com/TI-Lubbock- Development- Cartridge- TI-99-4a- TI99-Invaders_ W0QQitemZ1303619 14540QQcmdZViewI temQQptZLH_ DefaultDomain_ 0?hash=item1e5a2 cf4ac
>
>>--- In TI994A@yahoogroups. com, "Tony Knerr" <tonyknerr@. ..> wrote:
>>>

---

From: Owen Brand <[email-masked]>
Date: Fri, 29 Jan 2010 23:16:07 -0500

I've got it on watch... But I'm sure someone will jack up the price on  
it, selfishly buy it and sit on it. Why don't we all decide which one  
of us will be bidding on it so as not to Jack up the price?  It should  
be a community piece for study and engineering.  Alas, however, I know  
someone will be wringing their dirty little hands in anticipation of  
getting a one of a kind unique item from the depths of Lubbock, TX.   
Whatever.  Its the beauty of a free market.... I just wish Jon G could  
get ahold of this thing... Who knows what we could learn?!?!?  We  
might have GROM available to us for cartridges if this IS what it  
appears to be and if we can make sure it gets into the right hands.....

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 29, 2010, at 11:03 PM, mark wills <[email-masked]>  
wrote:

> Looks like it has one ROM and one GROM... LOvely! Unfortunately I'm  
> an british ex-pat in Uzbekistan, so I won't be bidding on it ;-(
>
> http://cgi.ebay. com/TI-Lubbock- Development- Cartridge- TI-99-4a-  
> TI99-Invaders_ W0QQitemZ1303619 14540QQcmdZViewI temQQptZLH_  
> DefaultDomain_ 0?hash=item1e5a2 cf4ac
>
> > This idea would not be currently feasible with the existing Rom- 
> only carts. There's Grom on the original cart. Actually that's not  
> quite true, there's a Grom emulator on the original cart, along with  
> the 2 banks of Rom.
> >
> > What would be necessary is for someone to design a cart that  
> supports a Grom emulator and 2 banks of Rom.
> > ...
>
>

---

From: Owen Brand <[email-masked]>
Date: Fri, 29 Jan 2010 23:19:44 -0500

Alright... I have a high bid on the cart.  If I win, I will send it  
free if charge to whomever feels like working on the reverse  
engineering.  I have no use for it, but WE do.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Fri, 29 Jan 2010 20:40:25 -0800 (PST)

Totally agree. How about we appoint one person to watch and bid on it? Since Owen is already watching it... What would it be worth to us as a group? $50? $100? I'd be willing to contribute some moolah if others were ready to reverse it. The GROM logic is done with discretes, so we could reverse it, produce a logic diagram, and then code that into a single chip. Or, just leave it as it is if using programmable logic is an issue.

>Sent: Sat, 30 January, 2010 5:16:07
>I've got it on watch... But I'm sure someone will jack up the price on it, selfishly buy it and sit on it. Why don't we all decide which one of us will be bidding on it so as not to Jack up the price?  It should be a community piece for study and engineering.  Alas, however, I know someone will be wringing their dirty little hands in anticipation of getting a one of a kind unique item from the depths of Lubbock, TX.  Whatever.  Its the beauty of a free market.... I just wish Jon G could get ahold of this thing... Who knows what we could learn?!?!?  We might have GROM available to us for cartridges if this IS what it appears to be and if we can make sure it gets into the right hands.....  
>
>Owen Brand
>**Oprysoft**
>Opry99er.com
>
>On Jan 29, 2010, at 11:03 PM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>>From: Tony Knerr <tonyknerr@comcast. net>

---

From: Owen Brand <[email-masked]>
Date: Fri, 29 Jan 2010 23:56:04 -0500

I've got the high bid now, Mark.  I'll go as high as I can afford, but  
that's not much.  I'll be happy to pay what I can for it and get it to  
a guru....

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 29, 2010, at 11:40 PM, mark wills <[email-masked]>  
wrote:

> Totally agree. How about we appoint one person to watch and bid on  
> it? Since Owen is already watching it... What would it be worth to  
> us as a group? $50? $100? I'd be willing to contribute some moolah  
> if others were ready to reverse it. The GROM logic is done with  
> discretes, so we could reverse it, produce a logic diagram, and then  
> code that into a single chip. Or, just leave it as it is if using  
> programmable logic is an issue.
>
>
>
> I've got it on watch... But I'm sure someone will jack up the price  
> on it, selfishly buy it and sit on it. Why don't we all decide which  
> one of us will be bidding on it so as not to Jack up the price?  It  
> should be a community piece for study and engineering.  Alas,  
> however, I know someone will be wringing their dirty little hands in  
> anticipation of getting a one of a kind unique item from the depths  
> of Lubbock, TX.  Whatever.  Its the beauty of a free market.... I  
> just wish Jon G could get ahold of this thing... Who knows what we  
> could learn?!?!?  We might have GROM available to us for cartridges  
> if this IS what it appears to be and if we can make sure it gets  
> into the right hands.....
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
>> quite true, there's a Grom emulator on the original cart, along  
>> with the 2 banks of Rom.
>> >

---

From: Keith Bergman <[email-masked]>
Date: Sat, 30 Jan 2010 00:14:21 -0500

I haven't really even been following this conversation, as most of it's over
my head, but I'll kick in $20 toward a collective buy if it helps get things
done.

On Fri, Jan 29, 2010 at 11:56 PM, Owen Brand <[email-masked]> wrote:

> that's not much.  I'll be happy to pay what I can for it and get it to a
> guru....
>
>
> Owen Brand
> **Oprysoft**
> Opry99er.com <http://opry99er.com/>
>
>  Totally agree. How about we appoint one person to watch and bid on it?
> Since Owen is already watching it... What would it be worth to us as a
> group? $50? $100? I'd be willing to contribute some moolah if others were
> ready to reverse it. The GROM logic is done with discretes, so we could
> reverse it, produce a logic diagram, and then code that into a single chip.
> Or, just leave it as it is if using programmable logic is an issue.
>
>
>
> *Sent:* Sat, 30 January, 2010 5:16:07
> *Subject:* Re: [TI994A] Re: Mechatronics XBII+ dump?
>
>
>
> I've got it on watch... But I'm sure someone will jack up the price on it,
> selfishly buy it and sit on it. Why don't we all decide which one of us will
> be bidding on it so as not to Jack up the price?  It should be a community
> piece for study and engineering.  Alas, however, I know someone will be
> wringing their dirty little hands in anticipation of getting a one of a kind
> unique item from the depths of Lubbock, TX.  Whatever.  Its the beauty of a
> free market.... I just wish Jon G could get ahold of this thing... Who
> knows what we could learn?!?!?  We might have GROM available to us for
> cartridges if this IS what it appears to be and if we can make sure it gets
> Opry99er.com <http://opry99er.com/> <http://opry99er.com/>
>
> On Jan 29, 2010, at 11:03 PM, mark wills <markrobertwills@ yahoo.co. uk<[email-masked]>>
> wrote:
>
>
>
> Looks like it has one ROM and one GROM... LOvely! Unfortunately I'm an
> british ex-pat in Uzbekistan, so I won't be bidding on it ;-(
>
> *From:* Tony Knerr <tonyknerr@comcast. net>
> *To:* TI994A@yahoogroups. com
> *Sent:* Sat, 30 January, 2010 0:16:55
> *Subject:* [TI994A] Re: Mechatronics XBII+ dump?
>
>
>
> <http://cgi.ebay.com/TI-Lubbock-Development-Cartridge-TI-99-4a-TI99-Invaders_W0QQitemZ130361914540QQcmdZViewItemQQptZLH_DefaultDomain_0?hash=item1e5a2cf4ac>
> TI99-Invaders_ W0QQitemZ1303619 14540QQcmdZViewI temQQptZLH_ DefaultDomain_
> 0?hash=item1e5a2 cf4ac
>
> --- In TI994A@yahoogroups. com <TI994A%40yahoogroups.com>, "Tony Knerr"
> <tonyknerr@. ..> wrote:
> >
> > This idea would not be currently feasible with the existing Rom-only
> carts. There's Grom on the original cart. Actually that's not quite true,
> there's a Grom emulator on the original cart, along with the 2 banks of Rom.
>
> >

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 00:18:00 -0500

I'll bump my high bid accordingly.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 30, 2010, at 12:14 AM, Keith Bergman <[email-masked]>  
wrote:

> I haven't really even been following this conversation, as most of  
> it's over my head, but I'll kick in $20 toward a collective buy if  
> it helps get things done.
>
>
>
>
> I've got the high bid now, Mark.  I'll go as high as I can afford,  
> but that's not much.  I'll be happy to pay what I can for it and get  
> it to a guru....
>
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
> On Jan 29, 2010, at 11:40 PM, mark wills  
> <[email-masked]> wrote:
>
>>
>> discretes, so we could reverse it, produce a logic diagram, and  
>> then code that into a single chip. Or, just leave it as it is if  
>> using programmable logic is an issue.
>>
>>
>>
>> on it, selfishly buy it and sit on it. Why don't we all decide  
>> which one of us will be bidding on it so as not to Jack up the  
>> price?  It should be a community piece for study and engineering.   
>> Alas, however, I know someone will be wringing their dirty little  
>> hands in anticipation of getting a one of a kind unique item from  
>> the depths of Lubbock, TX.  Whatever.  Its the beauty of a free  
>> market.... I just wish Jon G could get ahold of this thing... Who  
>> knows what we could learn?!?!?  We might have GROM available to us  
>> for cartridges if this IS what it appears to be and if we can make  
>> sure it gets into the right hands.....
>>
>> Owen Brand
>> **Oprysoft**
>> Opry99er.com
>>
>>> Looks like it has one ROM and one GROM... LOvely! Unfortunately  
>>> I'm an british ex-pat in Uzbekistan, so I won't be bidding on it ;-(
>>>

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 29 Jan 2010 23:45:54 -0600

You guys seriously tempt me to bid just to see how high it will go <grin>

To: [email-masked]
From: [email-masked]
Date: Sat, 30 Jan 2010 00:18:00 -0500
Subject: Re: [TI994A] Re: Mechatronics XBII+ dump?

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 30, 2010, at 12:14 AM, Keith Bergman <[email-masked]> wrote:

I haven't really even been following this conversation, as most of it's over my head, but I'll kick in $20 toward a collective buy if it helps get things done.

  

I've got the high bid now, Mark.  I'll go as high as I can afford, but that's not much.  I'll be happy to pay what I can for it and get it to a guru.... 

Owen Brand 
**Oprysoft**
Opry99er.com

On Jan 29, 2010, at 11:40 PM, mark wills <[email-masked]> wrote:

Owen Brand 
**Oprysoft**
Opry99er.com

  

M

Tony

> What would be necessary is for someone to design a cart that supports a Grom emulator and 2 banks of Rom.

_________________________________________________________________
Your E-mail and More On-the-Go. Get Windows Live Hotmail Free.
http://clk.atdmt.com/GBL/go/196390709/direct/01/

---

From: "Tursi" <[email-masked]>
Date: Sat, 30 Jan 2010 00:51:11 -0800

>> it. It looks quite simple.

Not to be negative.. but why do we need to reverse engineer it? We know how 
GROM works and how to simulate it....

Historically valuable, but what do we hope to learn?

---

From: mark wills <[email-masked]>
Date: Sat, 30 Jan 2010 00:55:35 -0800 (PST)

I thought there was some questions as to how the address logic/auto inc stuff worked?

>
>From: Tursi <[email-masked]>
>Sent: Sat, 30 January, 2010 9:51:11

---

From: "Tursi" <[email-masked]>
Date: Sat, 30 Jan 2010 00:59:56 -0800

> I thought there was some questions as to how the address logic/auto inc 

We've been reproducing GROMs in software for years... there are a number of 
us who know how they work. :)

Thierry even describes one discrete logic approach in his description of the 
P-GRAM card: http://nouspikel.group.shef.ac.uk//ti99/pgram.htm

---

From: mark wills <[email-masked]>
Date: Sat, 30 Jan 2010 01:07:08 -0800 (PST)

Yeah, but we still don't have any homebrew boards that can utilise GROM/GRAM!

/grumble ;-)

>Sent: Sat, 30 January, 2010 9:59:56
>>P-GRAM card: http://nouspikel. group.shef. ac.uk//ti99/ pgram.htm
>
>
>

---

From: "Tursi" <[email-masked]>
Date: Sat, 30 Jan 2010 01:16:13 -0800

> Yeah, but we still don't have any homebrew boards that can utilise 

I haven't finished unpacking yet. ;)

---

From: fdos <[email-masked]>
Date: Sat, 30 Jan 2010 08:05:33 -0700

Tursi & Mark,

Have you not read any of Jim Fetzner's (Ksarul) posts?  He has a GROM 
simulator like the one posted on eBay.  WAKE UP!

Bill S

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 10:09:33 -0500

I just woke up this morning myself.... :) Jim, I sure would love to  
see it in action sometime!!! You have any inclination to make a small  
video for YouTube???  It would warm my cold cold heart to see that  
crazy thing operating!!! :).

Owen Brand
**Oprysoft**
Opry99er.com

---

From: fdos <[email-masked]>
Date: Sat, 30 Jan 2010 08:15:20 -0700

Besides that Brad Snyder's BCART allows TI BASIC programs to run out of 
a Super Cart (EA cart + 8K RAM battery backed), so he must be simulating 
GRAM, no?

Bill S

---

From: fdos <[email-masked]>
Date: Sat, 30 Jan 2010 08:26:26 -0700

Mark,

Yes, fixed length records are the important aspect, but it might be wise 
to be totally compatible with TI FORTH, Super4th, Forth+ and X4th99 by 
using DF 128, please.

Bill S

mark wills wrote:
>  
> 
> Hi Bill, I'm using IF128 for file format, but someone said that it 
> didn't really make any difference. I could change the file type with no 
> other code changes required as far as I know... The important thing is 
> that they are fixed length records, as I'm sure you can appreciate...
> 
> Mark
> 
>  > > > > > So you get this enhanced XB and create the best ever game 
> using it.
>  > > > > > How
>  > > > > > You'll have to create the "slower than molasses" version 
> anyway. If
>  > > > > > you
>  > > > > > want to produce speedy games you'll have to choose another 
> language;
>  > > > > > AL,
>  > > > > > work with a CF7A+ either, so once in a while I remove the 
> AMS/SAMS
>  > > > > > card
>  > > > > >> Anyway, unless I can somehow pull out an upset in the 
> retroclouds
>  > > > > >> game
>  > > > > >> know alot of that stuff can be done using the regular XB 
> cart and
>  > > > > >> alot

---

From: Gregory McGill <[email-masked]>
Date: Sat, 30 Jan 2010 08:33:07 -0800

Owen will fly out and help you :)

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 11:47:40 -0500

Hahaha.... Yea I will... But it'll have to be before March 6.... Gotta  
play 2 weeks in Key West starting the 8th, we are leaving on the  
6th.  :)

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "LARRY CORREA" <[email-masked]>
Date: Sat, 30 Jan 2010 09:12:24 -0800

Boy you sure do get around don't you

Have a great day

Larry

  ----- Original Message ----- 
  From: Owen Brand<mailto:[email-masked]> 
  To: [email-masked]<mailto:[email-masked]> 
  Sent: Saturday, January 30, 2010 8:47 AM
  Subject: Re: [TI994A] Re: Mechatronics XBII+ dump?

  Hahaha.... Yea I will... But it'll have to be before March 6.... Gotta play 2 weeks in Key West starting the 8th, we are leaving on the 6th.  :)

  Owen Brand 
  **Oprysoft**
  Opry99er.com<http://opry99er.com/>

  On Jan 30, 2010, at 11:33 AM, Gregory McGill <[email-masked]<mailto:[email-masked]>> wrote:

---

From: "Ksarul" <[email-masked]>
Date: Sat, 30 Jan 2010 12:45:30 -0500

Not exactly true.  The Wiesbaden Supermodul and Supermodul II both did it in
a cartridge format, as did the SEB cartridge and the Extended BASIC III
cartridge.

The Wiesbaden modules were homebrew items.  I have the schematics for those.
. .and one of the Supermodul II cartridges.  I'm looking at building a
variant using flash ala the 512K Guidry board. . .with one chip for GROM and
one for ROM, 512K each.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
mark wills
Sent: Saturday, January 30, 2010 4:07 AM
To: [email-masked]
Subject: Re: [TI994A] Re: Mechatronics XBII+ dump?

Yeah, but we still don't have any homebrew boards that can utilise
GROM/GRAM!

/grumble ;-)

P-GRAM card: http://nouspikel. group.shef. ac.uk//ti99/ pgram.htm
<http://nouspikel.group.shef.ac.uk/ti99/pgram.htm>

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 12:20:03 -0500

Fascinating!!!  I do hope you can find the time to get that work  
done.  Such a creation would boat certainly be a great step forward!!!

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 30, 2010, at 12:45 PM, "Ksarul" <[email-masked]> wrote:

> Not exactly true.  The Wiesbaden Supermodul and Supermodul II both  
> did it in a cartridge format, as did the SEB cartridge and the  
> Extended BASIC III cartridge.
>
>
>
> The Wiesbaden modules were homebrew items.  I have the schematics  
> for those. . .and one of the Supermodul II cartridges.  I’m looking  
> at building a variant using flash ala the 512K Guidry board. . .with 
>  one chip for GROM and one for ROM, 512K each.
>
>
>
> Jim
>
>
>
> From: [email-masked] [mailto:[email-masked]] On  
> Behalf Of mark wills
> > I thought there was some questions as to how the address logic/ 
> auto inc
> > stuff worked?
>

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 12:24:26 -0500

yessir.... I am a ramblin man, as the fella says.  I've played  
everywhere from Grand Junction CO to Bottineau ND to Key West FL....  
And everywhere in between.  Wish I'd have known Bill G lived out there  
when I played the Whiskey River out there in Grand Junction... Would  
have been nice to meet him in person.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 30, 2010, at 12:12 PM, "LARRY CORREA" <[email-masked]> wrote:

> From: Owen Brand
> Hahaha.... Yea I will... But it'll have to be before March 6....  
> Gotta play 2 weeks in Key West starting the 8th, we are leaving on  
> the 6th.  :)
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
> On Jan 30, 2010, at 11:33 AM, Gregory McGill  
> <[email-masked]> wrote:
>
>>

---

From: "Ksarul" <[email-masked]>
Date: Sat, 30 Jan 2010 12:56:10 -0500

Between a two-year-old, a four-year-old, work, and three classes a term
towards my Master's Degree, time is a premium. . .so it will be a slow slog.
But it keeps me busy at 51, so it's all good!

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Owen Brand
Sent: Saturday, January 30, 2010 12:20 PM
To: [email-masked]
Subject: Re: [TI994A] Re: Mechatronics XBII+ dump?

Fascinating!!!  I do hope you can find the time to get that work done.  Such
a creation would boat certainly be a great step forward!!!

Owen Brand

**Oprysoft**

Opry99er.com

On Jan 30, 2010, at 12:45 PM, "Ksarul" <vze23g4a@verizon.
<mailto:[email-masked]> net> wrote:

Jim

  _____  

  

/grumble ;-)

P-GRAM card:  <http://nouspikel.group.shef.ac.uk/ti99/pgram.htm>
http://nouspikel. group.shef. ac.uk//ti99/ <http://ac.uk/ti99/>  pgram.htm

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 12:31:15 -0500

Well, hey--- I know about time crunches.... :) if I can be of any  
assistance (don't know what I could offer) I would be happy to help.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 30, 2010, at 12:56 PM, "Ksarul" <[email-masked]> wrote:

> Between a two-year-old, a four-year-old, work, and three classes a  
> term towards my Master’s Degree, time is a premium. . .so it will be 
>  a slow slog.  But it keeps me busy at 51, so it’s all good!
>
>
>
> Jim
>
>
>
> Behalf Of Owen Brand
>> for those. . .and one of the Supermodul II cartridges.  I’m lookin 
>> g at building a variant using flash ala the 512K Guidry board. . . 
>> with one chip for GROM and one for ROM, 512K each.
>>
>>
>>
>> Jim
>>
>>
>>

---

From: "LARRY CORREA" <[email-masked]>
Date: Sat, 30 Jan 2010 10:16:21 -0800

I would like to hear your music sometime. Have a good day.

Larry

  ----- Original Message ----- 
  From: Owen Brand<mailto:[email-masked]> 
  To: [email-masked]<mailto:[email-masked]> 
  Sent: Saturday, January 30, 2010 9:24 AM
  Subject: Re: [TI994A] Re: Mechatronics XBII+ dump?

  yessir.... I am a ramblin man, as the fella says.  I've played everywhere from Grand Junction CO to Bottineau ND to Key West FL.... And everywhere in between.  Wish I'd have known Bill G lived out there when I played the Whiskey River out there in Grand Junction... Would have been nice to meet him in person.  :)  

  Owen Brand 
  **Oprysoft**

  On Jan 30, 2010, at 12:12 PM, "LARRY CORREA" <[email-masked]<mailto:[email-masked]>> wrote:

    Have a great day

    Larry

      ----- Original Message ----- 
      From: Owen Brand<mailto:[email-masked]> 
      To: [email-masked]<mailto:[email-masked]> 
      Sent: Saturday, January 30, 2010 8:47 AM
      Subject: Re: [TI994A] Re: Mechatronics XBII+ dump?

      Owen Brand 
      **Oprysoft**

      On Jan 30, 2010, at 11:33 AM, Gregory McGill <arcadeshopper@<mailto:[email-masked]>gmail.com<http://gmail.com/>> wrote:

---

From: "Tursi" <[email-masked]>
Date: Sat, 30 Jan 2010 12:41:46 -0800

> simulator like the one posted on eBay.  WAKE UP!

Yes, I'm aware he has one. Have you read MY posts? I don't see the need to 
pursue one.

You wake up! ;)

---

From: "Ksarul" <[email-masked]>
Date: Sat, 30 Jan 2010 16:49:46 -0500

Note: I have an EGROM Box (a little bit bigger than a case for 10 5.25
floppies), one of the aluminum pizza box GRAM devices now up to $500+ on
eBay (there are something like 10-15 of those in circulation still, so they
aren't totally rare), a GRAM Kracker, a Mechatronics GRAM Karte, a PGRAM+,
an HSGPL, and a Wiesbaden Super Modul II.  All of these devices (as well as
Gramulators, the interesting TI GROM simulator devices Jon has or the
European TI GRAM Card Gerd has) simulate GROMs, so Tursi is quite right that
the basic problem is solved and the cartridge-sized device is more a
curiosity than a solution.  There are LOTS of solutions out there; the next
step is just to get one of them onto a new cartridge board and into
production. . .for everyone to be able to use.  :)

Jim

-----Original Message-----
On Behalf Of Tursi
Sent: Saturday, January 30, 2010 3:42 PM

You wake up! ;)

---

From: fdos <[email-masked]>
Date: Sat, 30 Jan 2010 15:09:38 -0700

Right.  I shouldn't have included your name.

---

From: ti99_forever <[email-masked]>
Date: Sat, 30 Jan 2010 14:23:45 -0800 (PST)

Wow... what have I missed?

--- On Sat, 1/30/10, fdos <[email-masked]> wrote:

> Date: Saturday, January 30, 2010, 5:09 PM
> Right.  I shouldn't have
> included your name.
> 
> Tursi wrote:
> >> Tursi & Mark,
>     [email-masked]
> 
> 
>

---

From: Tony Knerr <[email-masked]>
Date: Sat, 30 Jan 2010 18:38:29 -0500

Ok, apparently the knowledge is there to emulate Grom on a cart.
Here's an apparently easy wish list, then.
Show me a cart board that emulates Grom from >6000 to >FFFF and two 
banks of Rom at >6000.
The board has a socket for a 64k eprom, the first 5 banks respond to 
Grom adresses >6000 to >FFFF.
The next two banks are TI banked switched Rom at >6000.
The last bank can be unused or you can come up with a special use for 
it, perhaps Grom page 2 at >6000 to put the EA cart.

I'd like to put XB v2.7 in it. And the EA cart on page 2 if possible.

I'll buy a couple, and I'll bet you'll have a pretty good market for a 
few more. :)
Somebody might actually want to put RXB in it, though I'm not sure why. ;)

Tony

---

From: ti99_forever <[email-masked]>
Date: Sat, 30 Jan 2010 17:21:30 -0800 (PST)

If you are taking requests...

You can either clean my house, keep my kids and wife happy... good luck with the wife!

or

take my three courses at VSU:
database 1 - taught by an idiot that tries to run executables directly from zip files
e-commerce - taught by a guy that pronounces "world wide web" as "wool wy weh" and it takes him three tries to get that out
marketing - taught by a guy that is hyped up on "nutritional" stimulants. Actually like this guy...

Then maybe I can do more than I have...

--- On Sat, 1/30/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: Mechatronics XBII+ dump?
To: "[email-masked]" <[email-masked]>
Date: Saturday, January 30, 2010, 12:31 PM

Well, hey--- I know about time crunches.... :) if I can be of any assistance (don't know what I could offer) I would be happy to help.  

Owen Brand**Oprysoft**Opry99er.com
On Jan 30, 2010, at 12:56 PM, "Ksarul" <[email-masked]> wrote:

    

Between a two-year-old, a four-year-old, work,
and three classes a term towards my Master’s Degree, time is a premium. . .so
it will be a slow slog.  But it keeps me busy at 51, so it’s all good! 

Jim 

From: TI994A@yahoogroups. com [mailto: TI994A@yahoogroups. com ] On Behalf Of Owen Brand

Sent: Saturday, January 30, 2010
12:20 PM

Subject: Re: [TI994A] Re:
Mechatronics XBII+ dump? 

Fascinating! !!  I do hope you can find the time to get that
work done.  Such a creation would boat certainly be a great step
forward!!!

Owen Brand 

**Oprysoft** 

Opry99er.com 

On Jan 30, 2010, at 12:45 PM, "Ksarul" <vze23g4a@verizon. net> wrote: 

Not exactly true.  The Wiesbaden Supermodul and Supermodul II
both did it in a cartridge format, as did the SEB cartridge and the Extended
BASIC III cartridge. 

The Wiesbaden 
modules were homebrew items.  I have the schematics for those. . .and one
of the Supermodul II cartridges.  I’m looking at building a variant using
flash ala the 512K Guidry board. . .with one chip for GROM and one for ROM,
512K each. 

Jim 

From: TI994A@yahoogroups. com 
[mailto: TI994A@yahoogroups. com ]
On Behalf Of mark wills

Sent: Saturday, January 30, 2010
4:07 AM

Subject: Re: [TI994A] Re:
Mechatronics XBII+ dump? 

Yeah,
but we still don't have any homebrew boards that can utilise GROM/GRAM!

/grumble ;-)

 

Sent: Sat, 30 January, 2010
9:59:56

Subject: Re: [TI994A] Re:
Mechatronics XBII+ dump?

> I
thought there was some questions as to how the address logic/auto inc 

P-GRAM card: http://nouspikel.
group.shef. ac.uk//ti99/ pgram.htm

---

From: "Ksarul" <[email-masked]>
Date: Sat, 30 Jan 2010 21:38:09 -0500

And now you understand what I'm working on now, Tony-with all of this in
Flash.  I'll probably put a pair of DIP switches inside the cart case to
allow a reprogram while connected to a TI too. . .that is my current goal,
anyway.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Tony Knerr
Sent: Saturday, January 30, 2010 6:38 PM
To: [email-masked]
Subject: Re: [TI994A] GRAM devices, was Re: Mechatronics XBII+ dump?

Ok, apparently the knowledge is there to emulate Grom on a cart.
Here's an apparently easy wish list, then.
Show me a cart board that emulates Grom from >6000 to >FFFF and two banks of
Rom at >6000.
The board has a socket for a 64k eprom, the first 5 banks respond to Grom
adresses >6000 to >FFFF.
The next two banks are TI banked switched Rom at >6000.
The last bank can be unused or you can come up with a special use for it,
perhaps Grom page 2 at >6000 to put the EA cart.

I'll buy a couple, and I'll bet you'll have a pretty good market for a few
more. :)
Somebody might actually want to put RXB in it, though I'm not sure why. ;) 

Tony 

Ksarul wrote: 

Jim

---

From: fdos <[email-masked]>
Date: Sat, 30 Jan 2010 21:42:24 -0700

Jim,

That's great!  I've been saying all along that these home brew carts 
need to be made with FLASH, so we poor folks that don't have EPROM 
burners can reprogram the cart.

Bill S

Ksarul wrote:
>  
> 
> And now you understand what I’m working on now, Tony—with all of this in 
> Flash.  I’ll probably put a pair of DIP switches inside the cart case to 
> allow a reprogram while connected to a TI too. . .that is my current 
> goal, anyway.
> 
>  
> 
> Jim
> 
>  
> 
>  
> 
>  
> 
> ------------------------------------------------------------------------
> 
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Tony Knerr
> *Sent:* Saturday, January 30, 2010 6:38 PM
> *To:* [email-masked]
> *Subject:* Re: [TI994A] GRAM devices, was Re: Mechatronics XBII+ dump?
> 
>  
> 
>  
>

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 23:45:58 -0500

So.... I should not bid up on that TI Lubbock cart.... As I said, I am  
not purchasing it for it's collectibility or posterity/-/ the goal was  
to get a unique item that we did not yet have to learn from it's  
electronics and make/up... If we already have one and Jim is working  
so diligently on the FLASH, does that mean this item is of less  
educational value, and we are not needing to pursue?

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 30, 2010, at 11:42 PM, fdos <[email-masked]> wrote:

>> --- 
>> ---------------------------------------------------------------------
>>
>>> eBay (there are something like 10-15 of those in circulation  
>>> still, so
>>> they

---

From: mark wills <[email-masked]>
Date: Sun, 31 Jan 2010 20:15:20 -0800 (PST)

Yes, saw that, but frankly is of no interest to me. I want a CARTRIDGE that I can fit TWO ROMS to: One CPU ROM, and the other will be treated as GROM. If they are multi-banked, so much the better.

Tursi is already a way down the line with a microcontroller based project...

Mark

----- Original Message ----
> Sent: Sat, 30 January, 2010 16:05:33

---

From: mark wills <[email-masked]>
Date: Sun, 31 Jan 2010 20:17:18 -0800 (PST)

Noted. I think I can change the file-type with no code impact whatsoever. So consider it done!

Mark

----- Original Message ----
> Sent: Sat, 30 January, 2010 16:26:26

---

From: mark wills <[email-masked]>
Date: Sun, 31 Jan 2010 20:21:50 -0800 (PST)

modules were homebrew items.  I have the schematics for those. . .and one
of the Supermodul II cartridges.  I’m looking at building a variant
using flash ala the 512K Guidry board. . .with one chip for GROM and one for
ROM, 512K each.

OH YEAH... COME TO MAMA.

NOW THATS WHAT I'M TALKING ABOUT!

Where do I send the money?

---

From: mark wills <[email-masked]>
Date: Sun, 31 Jan 2010 20:34:26 -0800 (PST)

That'e exactly the kind of thing I specced out last year, but there wasn't much interest (not that I was offering to design it, so fair enough really ;-)

I like the idea of flash. If it's done right, you can 'program' your cartridge by simply loading a file from disk. Since it's flash, it will be retained. No need to burners.

This means, with games like Pitfall etc, people can program them *themselves*, and even change/cycle the contents from time to time with different programs as their needs change.

My project is designed to be distributed on Cartridge. I would like it to be flash based, simply because 'it's not set in stone'. If I do a new release, to fix a bug or whatever, people can just download it 'into' their cartridge themselves, with no need to for organising distribution of ROMs, return of old ones etc...

Just my 2 pence (pence, being British you understand!)

Mark

>Sent: Sun, 31 January, 2010 0:38:29
>>Show me a cart board that emulates Grom from >6000 to >FFFF and
>two banks of Rom at >6000.

---

From: Owen Brand <[email-masked]>
Date: Sun, 31 Jan 2010 23:38:07 -0500

Very exciting.... These are good times. :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 31, 2010, at 11:34 PM, mark wills <[email-masked]>  
wrote:

> That'e exactly the kind of thing I specced out last year, but there  
> wasn't much interest (not that I was offering to design it, so fair  
> enough really ;-)
>
> I like the idea of flash. If it's done right, you can 'program' your  
> cartridge by simply loading a file from disk. Since it's flash, it  
> will be retained. No need to burners.
>
> This means, with games like Pitfall etc, people can program them  
> *themselves*, and even change/cycle the contents from time to time  
> with different programs as their needs change.
>
> My project is designed to be distributed on Cartridge. I would like  
> it to be flash based, simply because 'it's not set in stone'. If I  
> do a new release, to fix a bug or whatever, people can just download  
> it 'into' their cartridge themselves, with no need to for organising  
> distribution of ROMs, return of old ones etc...
>
> The last bank can be unused or you can come up with a special use  
> for it, perhaps Grom page 2 at >6000 to put the EA cart.
>
> I'll buy a couple, and I'll bet you'll have a pretty good market for  
> a few more. :)

---

From: R Halter <[email-masked]>
Date: Sun, 31 Jan 2010 22:53:06 -0600

> Just my 2 pence (pence, being British you understand!)

(Translated to USD) "Just my 5 cents."

So how much is that in Euros?  ^_~

-- 
"You keep using that word.  I do not think it means what you think it 
means."
  -- Inigo Montoya (Mandy Patinkin), "The Princess Bride"

---

From: fdos <[email-masked]>
Date: Sun, 31 Jan 2010 23:39:16 -0700

Very well, I rest all my effort on this one.  I'll be quiet now.

Bill S

mark wills wrote:
>  
> 
> Yes, saw that, but frankly is of no interest to me. I want a CARTRIDGE 
> that I can fit TWO ROMS to: One CPU ROM, and the other will be treated 
> as GROM. If they are multi-banked, so much the better.
>

---

From: fdos <[email-masked]>
Date: Sun, 31 Jan 2010 23:46:09 -0700

Thanks.  Keep on Forthing.

Bill S

mark wills wrote:
>  > > > > > > calls in XB for the time being. :) Just curious about 
> XBII+....
>  > > Seems
>  > > > > > > > very fast as it is programmed in 100% AL. The 128KOS 
> worked well
>  > > > > > > > and I
>  > > > > > > > few folks were willing to pay the price, so not many of 
> us have
>  > > > > > > > Myarc XB
>  > > > > > > > II v2.12 laying around. It doesn't work with AMS/SAMS, 
> and it
>  > > can't

---

From: fdos <[email-masked]>
Date: Sun, 31 Jan 2010 23:48:36 -0700

Mark,

Hmm?  And now you agree?  I'm confused.

Bill S

mark wills wrote:
>  
> 
>  >The Wiesbaden modules were homebrew items.  I have the schematics for 
> those. . .and one of the Supermodul II cartridges.  I’m looking at 
> building a variant using flash ala the 512K Guidry board. . .with one 
> chip for GROM and one for ROM, 512K each.
> 
> OH YEAH... COME TO MAMA.
>

---

From: fdos <[email-masked]>
Date: Sun, 31 Jan 2010 23:52:37 -0700

Even more total agreement.  Put FLASH in those cartridges.  If I said it 
once I said it maybe 6 or 7 times, so my fingers are raw. :-)

Bill S

mark wills wrote:
> cartridge by simply loading a file from disk. Since it's flash, it will 
> be retained. No need to burners.
> 
> *themselves*, and even change/cycle the contents from time to time with 
> different programs as their needs change.
> 
> My project is designed to be distributed on Cartridge. I would like it 
> to be flash based, simply because 'it's not set in stone'. If I do a new 
> release, to fix a bug or whatever, people can just download it 'into' 
> their cartridge themselves, with no need to for organising distribution 
> of ROMs, return of old ones etc...
> 
>     *From:* Tony Knerr <[email-masked]>
>     *Sent:* Sun, 31 January, 2010 0:38:29
>>     still, so they

---

From: mark wills <[email-masked]>
Date: Sun, 31 Jan 2010 23:00:29 -0800 (PST)

Yes! I like *this* idea, because they are cartridges! Not a 15" x 15" metal box under the monitor!

Mark

----- Original Message ----
> Sent: Mon, 1 February, 2010 7:48:36
> > those. . .and one of the Supermodul II cartridges.  Iâ€™m looking at

---

From: mark wills <[email-masked]>
Date: Sun, 31 Jan 2010 23:02:15 -0800 (PST)

FLASH! AAAAAAHH HAAAAA! SAVIOUR OF THE UNIVERSE!

<what a RUBBISH film that was!>

----- Original Message ----
> Sent: Mon, 1 February, 2010 7:52:37
> >     *From:* Tony Knerr

---

From: fdos <[email-masked]>
Date: Mon, 01 Feb 2010 00:09:20 -0700

I wasn't interested in that part.  Only folks who wanted to preserve it 
were willing to bid on that item.  I've been on the FLASH kick for the 
home brew cartridges for a long time.

Bill S

---

From: "Tursi" <[email-masked]>
Date: Sun, 31 Jan 2010 23:20:38 -0800

> home brew cartridges for a long time.

A lot of people have been. I offered up the Skunkboard 
(http://harmlesslion.com/software/skunkboard) I helped with for the Atari 
Jaguar last year as a reference design for ideas, but it met with the 
typical lack of interest. It features a nice USB interface as well as a 5v 
tolerant flash chip. (I actually considered whether I could just reprogram 
the CPLD for the TI port, but it's a 16-bit device so it would take some 
fiddling or waste some space.)

We have no shortage of good ideas... we have a shortage of people who take 
the ideas and create product. :) I think those who have taken on the task 
lately can appreciate how much work it is! :) That said, we can also see 
that the community appreciates the opportunity to support the new product!

---

From: mark wills <[email-masked]>
Date: Mon, 1 Feb 2010 00:06:09 -0800 (PST)

So, you can upload code via USB interface, direct into the chip, yes?

Sounds nice! I've never heard of this board! I must have been asleep!

M

----- Original Message ----
> Sent: Mon, 1 February, 2010 8:20:38

---

From: fdos <[email-masked]>
Date: Mon, 01 Feb 2010 08:01:38 -0700

It seems some of us have been like "passing trains in the night", as I 
don't recall anything about a "Skunkboard", but then on weekends that I 
have my grandkids I fall behind, and in my rush to catch up I'm missing 
interesting ideas and project proposals.  In those cases I need a "wake 
up call".  Seems we have a consensus of sorts.

There is also the Thierry USB/SMART CARD board, that's missing only DSR 
code.  Of course, the "SMART CARD" part is probably not going to be in 
high demand, but it may still be worth taking another look at.

Bill S

---

From: tursi <[email-masked]>
Date: Mon, 1 Feb 2010 11:31:23 -0800 (PST)

> high demand, but it may still be worth taking another look at.

Smart Card is actually the easy side of that. Implementing USB is very, 
very difficult. I've been eyeing it for two years because the Jaguar 
community would like to use the USB ports on the Skunkboard, but 
ultimately I am leaning towards "no way, never, too much work". And that's 
on a system where I /can/ port existing driver code. I can't imagine the 
effort that the TI card is taking, and those working on it have my utmost 
respect.