Subject: TurboForth

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 10:01:22 -0500

Hey Willsy... Question for you my brother.... With your Forth cart---  
I wonder if it would be possible to leave some addressable space  
open---perhaps an 8k bank or even a second EPROM to save your programs  
to.... Like a built in MiniMem.... Just for storing a game or  
program.... The cart would then act as both a Language cart (like XB)  
and like a disk.  This might be a question to ask Jon---but I'm sure  
you have a few ideas as well.... Might be a cool way to distribute  
games written in your language.... Just a thought.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 28, 2010, at 8:24 AM, mark wills <[email-masked]>  
wrote:

> Am I right in thinking the 9938 & 58 can display more than one  
> colour in text mode?
>
> If so, how are the colours specified?
>
> M
>
> [Non-text portions of this message have been removed]
>
>

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 08:50:30 -0700

Owen,

I'm not responding for Mark, but I can tell you that what you ask can be 
done, but it will require FLASH or the programmer will require an EPROM 
programmer or it will require a cart with EPROM and battery backed RAM 
that will eventually fail loosing the stored application.

As far as I know Mark's Forth will require expansion memory, therefore 
disk drives will likely be available to the user.  If Mark has or will 
incorporate BSAVE & BLOAD then applications can be loaded very fast from 
disk.  Very large programs can be accommodated using virtual memory 
and/or overlays.  Forth makes it easy, and therefore fun. :-)

Bill S

Owen Brand wrote:
>  
> 
> Hey Willsy... Question for you my brother.... With your Forth cart--- I 
> wonder if it would be possible to leave some addressable space 
> and like a disk.  This might be a question to ask Jon---but I'm sure you 
> have a few ideas as well.... Might be a cool way to distribute games 
> written in your language.... Just a thought.  :)
> 
> Owen Brand
> **Oprysoft**
> Opry99er.com <http://Opry99er.com>
> 
> On Jan 28, 2010, at 8:24 AM, mark wills <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>>  
>>
>> Am I right in thinking the 9938 & 58 can display more than one colour 
>> in text mode?
>>

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 10:58:32 -0500

Thanks bill.  I was not aware that turboForth would require 32k  
expansion.... That certainly would make my suggestion unnecessary.  I  
had thought about an EPROM burner to put both the language AND a  
specifically addressed game program into separate banks for the happy  
dance I was envisioning.  But it's all good--- only a thought.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 28, 2010, at 10:50 AM, fdos <[email-masked]> wrote:

>>> colour
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 09:43:09 -0700

Sorry, my response was not what you were hoping for, but Mark's Forth is 
intended to put Forth in a cart, so the programmer could have more 
conventional memory for applications.  The Forth virtual memory requires 
a minimum of two (the more, the merrier) BLOCK BUFFERS of 1024 bytes 
each to be functional, so they have to reside in RAM.  They can be 
loaded from disk or cassette.  This means that an all cart version would 
require the cart to include some RAM for the virtual memory.  There are 
some versions of Forth designed as embedded controllers that don't have 
the virtual memory operation, so they could do what you want.

However, I really like virtual memory (when used with hard drives or a 
RAM disk) and overlays--lots of flexibility, and no real memory limitations.

Bill S

Owen Brand wrote:
> On Jan 28, 2010, at 10:50 AM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  > Owen,
>  >
>  >> Opry99er.com <http://Opry99er.com <http://Opry99er.com>>
>  >>
> <mailto:markrobertwills%40yahoo.co.uk>
>  >> <mailto:[email-masked] 
> <mailto:markrobertwills%40yahoo.co.uk>>> wrote:
>  >>
>  >>>
>  >>>

---

From: "Ksarul" <[email-masked]>
Date: Thu, 28 Jan 2010 19:48:22 -0500

I have a possible Flash mod idea for the cart that I plan to test out soon.
. .

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Owen Brand
Sent: Thursday, January 28, 2010 10:59 AM
To: [email-masked]
Subject: Re: [TI994A] TurboForth

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 28, 2010, at 10:50 AM, fdos <fdosbrs@frontiernet
<mailto:fdosbrs%40frontiernet.net> .net> wrote:

>> Opry99er.com <http://Opry99er. <http://Opry99er.com> com>
>>
>> On Jan 28, 2010, at 8:24 AM, mark wills <markrobertwills@
<mailto:markrobertwills%40yahoo.co.uk> yahoo.co.uk
>> <mailto:markrobertwills@ <mailto:markrobertwills%40yahoo.co.uk>

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 19:27:12 -0500

Alright now THAT is exciting!!  :). Keep us appraised!!

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 28, 2010, at 7:48 PM, "Ksarul" <[email-masked]> wrote:

> I have a possible Flash mod idea for the cart that I plan to test  
> out soon. . .
>
>
>
> Jim
>
>
>
> From: [email-masked] [mailto:[email-masked]] On  
> Behalf Of Owen Brand

---

From: mark wills <[email-masked]>
Date: Thu, 28 Jan 2010 21:09:05 -0800 (PST)

I would like to have a bettery ram on the cart, but it looks a bit demanding technically. And the system would require a lot of re-work to run a program from a different bank.

So, it looks like it won't happen. Still, it just means that programs are distributed on disk, same as all other programs. And can happily talk to ram disks, hard disks, CF7A, etc... 

Mark

>
>From: Owen Brand <[email-masked]>
>Sent: Thu, 28 January, 2010 16:01:22
>Subject: [TI994A] TurboForth
>
> >
>
>
>
>
>  >
>>      
> 
>Hey Willsy... Question for you my brother.... With your Forth cart--- I wonder if it would be possible to leave some addressable space open---perhaps an 8k bank or even a second EPROM to save your programs to.... Like a built in MiniMem.... Just for storing a game or program.... The cart would then act as both a Language cart (like XB) and like a disk.  This might be a question to ask Jon---but I'm sure you have a few ideas as well.... Might be a cool way to distribute games written in your language.... Just a thought.  :)
>
>Owen Brand
>**Oprysoft**
>Opry99er.com
>
>On Jan 28, 2010, at 8:24 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>Am I right in thinking the 9938 & 58 can display more than one colour in text mode?
>>

---

From: mark wills <[email-masked]>
Date: Thu, 28 Jan 2010 21:14:10 -0800 (PST)

If I have the memory, I'll do BSAVE and BLOAD. At the moment (as per design, that is to say) programs are loaded as source, and compiled on the fly, the 'old fashioned' Forth way.

It looks like I will soon have to take a scalpel to the code, and move code into a second 8K bank.

Hrmph. It actually looks like a real PITA. My plan is to move all the Disk IO routines into a seperate bank. That will give me about 1K of free space in the main bank. Which is becoming full (~400 bytes free).

I actually filled it up completely yesterday, so I chopped the 32 bit math routines... I can't really see poeple wanting to use this for ray tracing or gourad shading! I left 2DUP and 2DROP, as they come in handy ;-)

Mark

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Thu, 28 January, 2010 16:50:30
> > On Jan 28, 2010, at 8:24 AM, mark wills 
> > > wrote:
> > 
> >>  
> >>

---

From: fdos <[email-masked]>
Date: Fri, 29 Jan 2010 08:46:42 -0700

Mark,

I think you should go ahead and do your Forth as a 16K cart.  I have 2 
or 3 ideas for the bank switching mechanism, but I'll need to know your 
current/planned layout location specifics; parm stack, return stack, TIB 
& BLOCK BUFFERS (beginning/ending addresses), likewise for user memory.

BSAVE & BLOAD will be important to Forth users with real hardware and 
floppy drives only, and you'll be real surprised how often the 32bit 
math will be, so not a good idea to chuck those routines.  In fact and 
in both cases, Forth+ & X4th99 I have to have many (not all) of the 
32bit routines to support my library control structures.

400 bytes is quite a bit of memory, as I recall Forth+ 2.0 was at 368 
bytes when I ceased development on it.  Of course, I now know how to 
recover tons of conventional memory for it, if I ever get back to that 
project.  X4th99 is another story unless I change the simple banking 
technique used for the kernel code to that which I use for the 2 library 
zones and 1 virtual BUFFERS zone.  It's more complex but slower; not 
noticeable on the Geneve, but I don't know yet about the TI.

Anyway shoot the info requested to me ASAP, so I can work out the best 
banking solution.

Bill S

mark wills wrote:
>  
> 
> If I have the memory, I'll do BSAVE and BLOAD. At the moment (as per 
> design, that is to say) programs are loaded as source, and compiled on 
> the fly, the 'old fashioned' Forth way.
> 
> Hrmph. It actually looks like a real PITA. My plan is to move all the 
> Disk IO routines into a seperate bank. That will give me about 1K of 
> free space in the main bank. Which is becoming full (~400 bytes free).
> 
> I actually filled it up completely yesterday, so I chopped the 32 bit 
> math routines... I can't really see poeple wanting to use this for ray 
> tracing or gourad shading! I left 2DUP and 2DROP, as they come in handy ;-)
> 
> Mark
> 
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
> you