Subject: Craigslist

From: Owen Brand <[email-masked]>
Date: Sat, 13 Feb 2010 11:29:32 -0500

http://portland.craigslist.org/mlt/sys/1598227782.html

Yea.......

Owen Brand
Opry99er.com

---

From: Gregory McGill <[email-masked]>
Date: Sat, 13 Feb 2010 08:32:44 -0800

Silly wabbit

---

From: Keith Bergman <[email-masked]>
Date: Sat, 13 Feb 2010 11:43:11 -0500

I dunno, if the P-code system's included it might be worth something near
that much.  I don't like when someone expects that much money out of
anything, though, and can't be bothered to snap a few photos or write out a
more detailed description.  You see that on Ebay all the time.  One line of
text for (allegedly) $200 worth of stuff.  HUGE LOT OF KUMPUTUR STUFF BOT AT
ESTATE SAIL THEY TOLD ME IT WORKS LOOKS PRETTY KOOL!!111  $960734 SHIPPING.

Might be worth a look for someone who lives in the area, though.

On Sat, Feb 13, 2010 at 11:32 AM, Gregory McGill <[email-masked]>wrote:

>
>
> Silly wabbit
>
>
> On Sat, Feb 13, 2010 at 8:29 AM, Owen Brand <[email-masked]>wrote:
>
>>
>>

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 13 Feb 2010 19:19:12 -0600

Today I ventured into the TI dungeon and figured out a way to resolve a termination problem with my SCSI card & TI.   It seems that my 50pin to centronics cable was flaky and not having another, I found my old, Faire-corrupted SCSI 100MB drive and connected it in-line with an EZ135 drive.  Since the 100MB had terminating resistors, I placed it at the end of the chain and with some luck, the system is functional again ;) Both drives are working properly.

Once fixed, I spent some time fixing the 100MB drive's FDRs and VIB.  I would like to backup the files to a platter.  Here's my question:

Is there a program for the TI, similar to XCOPY, that will allow me to copy the folders without manually re-creating the entire directory structure/copying folder by folder?  

Tim
 		 	   		  
_________________________________________________________________
Hotmail: Free, trusted and rich email service.
http://clk.atdmt.com/GBL/go/201469228/direct/01/

---

From: Marc Hull <[email-masked]>
Date: Sat, 13 Feb 2010 17:31:22 -0800 (PST)

Well I'm glad someone else gets to feel my pain !  short answer is no.  Long answer is sorry charlie your out of luck.  Thanks for playing, please come again (AFAIK anyway.)  

I think the concensus is that the TI DSR is buggy and shoots craps at 16 (or so) recursive calls.  I am venturing that this is the reason there is no Disk copy program.

You will most likely need to get your hands on a Geneve, but I understand they are rare and hard to get these days.  I wish you the best of luck on that one ;-)

3,2.....1

--- On Sat, 2/13/10, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: [TI994A] SCSI folder copy
To: [email-masked]
Date: Saturday, February 13, 2010, 7:19 PM

  

      

Tim
 		 	   		  
Hotmail: Free, trusted and rich email service. Get it now.

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 13 Feb 2010 19:36:51 -0600

Hey Marc, 

I am trying Fred's DM2K copy functionality and it SEEMS to be working.

What I did not realize is that you cannot try to "C"opy folders directly, you must first select them with FCTN-2.   I actually happened on it by mistake, even after looking at the help screen.  I'm not sure if the copy will crash thanks to the DSR bug - guess that depends on how Fred wrote his copy routine.   But so far, so good!

as for the Geneve..well.. let's just say I'm trying to do some things with the TI.  Sure, it would be easy to use another Geneve, but where is the fun in that?  Grin

To: [email-masked]
From: [email-masked]
Date: Sat, 13 Feb 2010 17:31:22 -0800
Subject: Re: [TI994A] SCSI folder copy

3,2.....1

Subject: [TI994A] SCSI
 folder copy

    

Tim

    

    

_________________________________________________________________
Hotmail: Trusted email with powerful SPAM protection.
http://clk.atdmt.com/GBL/go/201469227/direct/01/

---

From: ti99_forever <[email-masked]>
Date: Sat, 13 Feb 2010 17:45:19 -0800 (PST)

It craps out on mine, like Marc says. I brought it up when I found the issue and had Bill test it out with the same result. Mine always crashed at the same place when starting at the top. Started when I wrote a little "tree" program in XB, then tried the DM2k copy like you are doing.

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] SCSI folder copy
To: [email-masked]
Date: Saturday, February 13, 2010, 8:36 PM

Hey Marc, 

#yiv1757786884 .ExternalClass .ecxygrp-photo-title
{clear:both;font-size:smaller;height:15px;overflow:hidden;text-align:center;width:75px;}
#yiv1757786884 .ExternalClass div.ecxygrp-photo
{background-position:center;background-repeat:no-repeat;background-color:white;border:1px solid black;height:62px;width:62px;}
#yiv1757786884 .ExternalClass div.ecxphoto-title 
         a, #yiv1757786884 .ExternalClass div.ecxphoto-title a:active, #yiv1757786884 .ExternalClass div.ecxphoto-title a:hover, #yiv1757786884 .ExternalClass div.ecxphoto-title a:visited
{text-decoration:none;}
#yiv1757786884 .ExternalClass div.ecxattach-table div.ecxattach-row
{clear:both;}
#yiv1757786884 .ExternalClass div.ecxattach-table div.ecxattach-row div
{float:left;}
#yiv1757786884 .ExternalClass p
{clear:both;padding:15px 0 3px 0;overflow:hidden;}
#yiv1757786884 .ExternalClass div.ecxygrp-file
{width:30px;}
#yiv1757786884 .ExternalClass div.ecxattach-table div.ecxattach-row div div a
{text-decoration:none;}
#yiv1757786884 .ExternalClass div.ecxattach-table div.ecxattach-row div div span
{font-weight:normal;}
#yiv1757786884 .ExternalClass div.ecxygrp-file-title
{font-weight:bold;}

#yiv1757786884 .ExternalClass #ecxygrp-mkp
{border:1px solid #d8d8d8;font-family:Arial;padding:0 10px;}
#yiv1757786884 .ExternalClass #ecxygrp-mkp hr
{border:1px solid #d8d8d8;}
#yiv1757786884 .ExternalClass #ecxygrp-mkp #ecxhd
{color:#628c2a;font-size:85%;font-weight:700;line-height:122%;}
#yiv1757786884 .ExternalClass #ecxygrp-mkp #ecxads
{margin-bottom:10px;}
#yiv1757786884 .ExternalClass #ecxygrp-mkp .ecxad
{padding:0 0;}
#yiv1757786884 .ExternalClass #ecxygrp-mkp .ecxad a
{color:#0000ff;text-decoration:none;}

3,2.....1

 

      

Tim

    

    

Hotmail: Trusted email with powerful SPAM protection. Sign up now.

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 13 Feb 2010 19:53:58 -0600

darn ;(   I'll let you know how far it gets.  It is still copying as I type - there are quite a few folders to deal with.  I recall the DSR conversation from the past, though for some reason I thought it was limited to catalogs and basic IO.  

To: [email-masked]
From: [email-masked]
Date: Sat, 13 Feb 2010 17:45:19 -0800
Subject: RE: [TI994A] SCSI folder copy

        

Hey Marc, 

        

3,2.....1

 

      

Tim

---

From: "Tony Knerr" <[email-masked]>
Date: Sun, 14 Feb 2010 02:04:54 -0000

1. Unplug 100mb drive from TI.

2. Walk with said drive in hand over to Geneve.

3. Plug said drive into Geneve.

4. Run XCOPY to copy said drive onto removable platter.

5. Unplug said drive from Geneve.

6. Walk with said drive in hand back to TI.

7. Reconnect said drive to TI.

Voila! Simple as pie.

Yes, you may slap me upside the head next time we see each other. ;)

Tony

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 13 Feb 2010 20:52:15 -0600

If Bill Sullivan's gremlins* visit my Geneve system as a result of your
voice of reason, be sure I will take you up on your offer.

NCIS Style.

Operation XCOPY to commence at 22:00 hours.

> From: [email-masked]
> Date: Sun, 14 Feb 2010 02:04:54 +0000
> Subject: [TI994A] Re: SCSI folder copy
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 13 Feb 2010 20:57:00 -0600

Hate to admit this but you were right.  The copy failed - spectacularly. 

After choking on the sixteenth folder, Fred's program allowed the copy to 
continue until the next cycle.  Then it ran into a circular buffer problem, at
which time DM2K created a kaleidoscope of epic proportions, a cornucopia
of 16 colors no eye should have had to behold.  And the sound generators
were wailing away with a delightful tune that I doubt even Tursi could
reproduce.  

;)-

To: [email-masked]
From: [email-masked]
Date: Sat, 13 Feb 2010 19:53:58 -0600
Subject: RE: [TI994A] SCSI folder copy

        

        

Hey Marc, 

        

3,2.....1

 

      

Tim

    

    

    

      

 		 	   		  

 		 	   		  
_________________________________________________________________
Hotmail: Powerful Free email with security by Microsoft.
http://clk.atdmt.com/GBL/go/201469230/direct/01/

---

From: Gregory McGill <[email-masked]>
Date: Sat, 13 Feb 2010 19:03:38 -0800

I live locally sent him an email offering for him to donate it to me.

Greg

---

From: ti99_forever <[email-masked]>
Date: Sat, 13 Feb 2010 19:16:37 -0800 (PST)

Yep. 16 sounds right...

There is an easy fix. Only have 15 directories on your hard drive... ;)

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] SCSI folder copy
To: [email-masked]
Date: Saturday, February 13, 2010, 9:57 PM

;)-

#yiv1724995312 .ExternalClass .ecxygrp-photo-title
{clear:both;font-size:smaller;height:15px;overflow:hidden;text-align:center;width:75px;}
#yiv1724995312 .ExternalClass div.ecxygrp-photo
{background-position:center;background-repeat:no-repeat;background-color:white;border:1px solid black;height:62px;width:62px;}
#yiv1724995312 .ExternalClass div.ecxphoto-title 
         a, #yiv1724995312 .ExternalClass div.ecxphoto-title a:active, #yiv1724995312 .ExternalClass div.ecxphoto-title a:hover, #yiv1724995312 .ExternalClass div.ecxphoto-title a:visited
{text-decoration:none;}
#yiv1724995312 .ExternalClass div.ecxattach-table div.ecxattach-row
{clear:both;}
#yiv1724995312 .ExternalClass div.ecxattach-table div.ecxattach-row div
{float:left;}
#yiv1724995312 .ExternalClass p
{clear:both;padding:15px 0 3px 0;overflow:hidden;}
#yiv1724995312 .ExternalClass div.ecxygrp-file
{width:30px;}
#yiv1724995312 .ExternalClass div.ecxattach-table div.ecxattach-row div div a
{text-decoration:none;}
#yiv1724995312 .ExternalClass div.ecxattach-table div.ecxattach-row div div span
{font-weight:normal;}
#yiv1724995312 .ExternalClass div.ecxygrp-file-title
{font-weight:bold;}

#yiv1724995312 .ExternalClass .ecxhmmessage P
{padding:0px;}
#yiv1724995312 .ExternalClass body.ecxhmmessage
{font-size:10pt;font-family:Verdana;}

#yiv1724995312 .ExternalClass .ecxygrp-photo-title
{clear:both;font-size:smaller;height:15px;overflow:hidden;text-align:center;width:75px;}
#yiv1724995312 .ExternalClass div.ecxygrp-photo
{background-position:center;background-repeat:no-repeat;background-color:white;border:1px solid black;height:62px;width:62px;}
#yiv1724995312 .ExternalClass div.ecxphoto-title 
         a, #yiv1724995312 .ExternalClass div.ecxphoto-title a:active, #yiv1724995312 .ExternalClass div.ecxphoto-title a:hover, #yiv1724995312 .ExternalClass div.ecxphoto-title a:visited
{text-decoration:none;}
#yiv1724995312 .ExternalClass div.ecxattach-table div.ecxattach-row
{clear:both;}
#yiv1724995312 .ExternalClass div.ecxattach-table div.ecxattach-row div
{float:left;}
#yiv1724995312 .ExternalClass p
{clear:both;padding:15px 0 3px 0;overflow:hidden;}
#yiv1724995312 .ExternalClass div.ecxygrp-file
{width:30px;}
#yiv1724995312 .ExternalClass div.ecxattach-table div.ecxattach-row div div a
{text-decoration:none;}
#yiv1724995312 .ExternalClass div.ecxattach-table div.ecxattach-row div div span
{font-weight:normal;}
#yiv1724995312 .ExternalClass div.ecxygrp-file-title
{font-weight:bold;}

#yiv1724995312 .ExternalClass #ecxygrp-mkp
{border:1px solid #d8d8d8;font-family:Arial;padding:0 10px;}
#yiv1724995312 .ExternalClass #ecxygrp-mkp hr
{border:1px solid #d8d8d8;}
#yiv1724995312 .ExternalClass #ecxygrp-mkp #ecxhd
{color:#628c2a;font-size:85%;font-weight:700;line-height:122%;}
#yiv1724995312 .ExternalClass #ecxygrp-mkp #ecxads
{margin-bottom:10px;}
#yiv1724995312 .ExternalClass #ecxygrp-mkp .ecxad
{padding:0 0;}
#yiv1724995312 .ExternalClass #ecxygrp-mkp .ecxad a
{color:#0000ff;text-decoration:none;}

#yiv1724995312 .ExternalClass #ecxyiv1757786884  
#ecxyiv1757786884 .ecxygrp-photo-title
{clear:both;font-size:smaller;height:15px;overflow:hidden;text-align:center;width:75px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxygrp-photo
{background-position:center;background-repeat:no-repeat;background-color:white;border:1px solid black;height:62px;width:62px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxphoto-title 
         a, #yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxphoto-title a:active, #yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxphoto-title a:hover, #yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxphoto-title a:visited
{text-decoration:none;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxattach-table div.ecxattach-row
{clear:both;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxattach-table div.ecxattach-row div
{float:left;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 p
{clear:both;padding:15px 0 3px 0;overflow:hidden;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxygrp-file
{width:30px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxattach-table div.ecxattach-row div div a
{text-decoration:none;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxattach-table div.ecxattach-row div div span
{font-weight:normal;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 div.ecxygrp-file-title
{font-weight:bold;}

#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxhmmessage P
{padding:0px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884
{font-size:10pt;font-family:Verdana;}

Hey Marc, 

#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass .ecxecxygrp-photo-title
{clear:both;font-size:smaller;height:15px;overflow:hidden;text-align:center;width:75px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxygrp-photo
{background-position:center;background-repeat:no-repeat;background-color:white;border:1px solid black;height:62px;width:62px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxphoto-title 
         a, #yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxphoto-title a:active, #yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxphoto-title a:hover, #yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxphoto-title a:visited
{text-decoration:none;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxattach-table div.ecxecxattach-row
{clear:both;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxattach-table div.ecxecxattach-row div
{float:left;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass p
{clear:both;padding:15px 0 3px 0;overflow:hidden;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxygrp-file
{width:30px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxattach-table div.ecxecxattach-row div div a
{text-decoration:none;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxattach-table div.ecxecxattach-row div div span
{font-weight:normal;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass div.ecxecxygrp-file-title
{font-weight:bold;}

#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass #ecxecxygrp-mkp
{border:1px solid #d8d8d8;font-family:Arial;padding:0 10px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass #ecxecxygrp-mkp hr
{border:1px solid #d8d8d8;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass #ecxecxygrp-mkp #ecxecxhd
{color:#628c2a;font-size:85%;font-weight:700;line-height:122%;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass #ecxecxygrp-mkp #ecxecxads
{margin-bottom:10px;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass #ecxecxygrp-mkp .ecxecxad
{padding:0 0;}
#yiv1724995312 .ExternalClass #ecxyiv1757786884 .ecxExternalClass #ecxecxygrp-mkp .ecxecxad a
{color:#0000ff;text-decoration:none;}

3,2.....1

 

      

Tim

    

    

    

      

 		 	   		  

 		 	   		  
Hotmail: Powerful Free email with security by Microsoft. Get it now.

---

From: "Postle" <[email-masked]>
Date: Sun, 14 Feb 2010 03:28:23 -0000

I think that must be the most beautiful discription of ugly ever recorded.  "16 Colors of which no eye should have to behold."

Okay.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], ti99_forever <ti99_forever@...> wrote:
> --- On Sat, 2/13/10, Insane Multitasker <insane_m@...> wrote:
> 
> From: Insane Multitasker <insane_m@...>
> From: insane_m@...
> From: ti99_forever@...
> --- On Sat, 2/13/10, Insane Multitasker <insane_m@...> wrote:
> 
> From: Insane Multitasker <insane_m@...>
> From: marc.hull@...
> --- On Sat, 2/13/10, Insane Multitasker <insane_m@...> wrote:
> 
> From: Insane Multitasker <insane_m@...>
> Subject: [TI994A] SCSI
>  folder copy

---

From: Marc Hull <[email-masked]>
Date: Sat, 13 Feb 2010 19:43:43 -0800 (PST)

Ya know Timmer,  I tried to get you to fix the DSR months ago but you just didn't listen ! Perhaps now you will be more reasonable and repair that damn broken code ;-)

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] SCSI folder copy
To: [email-masked]
Date: Saturday, February 13, 2010, 8:57 PM

  

      

;)-

To: ti994a@yahoogroups. com
From: insane_m@hotmail. com
Date: Sat, 13 Feb 2010 19:53:58 -0600
Subject: RE: [TI994A] SCSI folder copy

To: TI994A@yahoogroups. com
From: ti99_forever@ yahoo.com
Date: Sat, 13 Feb 2010 17:45:19 -0800
Subject: RE: [TI994A] SCSI folder copy

--- On Sat, 2/13/10, Insane Multitasker <insane_m@hotmail. com> wrote:

From: Insane Multitasker <insane_m@hotmail. com>
Subject: RE: [TI994A] SCSI folder copy
To: ti994a@yahoogroups. com
Date: Saturday, February 13, 2010, 8:36 PM

Hey Marc, 

as for the Geneve..well. . let's just say I'm trying to do some things with the TI.  Sure, it would be easy to use another Geneve, but where is the fun in that?  Grin

To: TI994A@yahoogroups. com
From: marc.hull@sbcglobal .net
Date: Sat, 13 Feb 2010 17:31:22 -0800
Subject: Re: [TI994A] SCSI folder copy

3,2.....1

--- On Sat, 2/13/10, Insane Multitasker <insane_m@hotmail. com> wrote:

From: Insane Multitasker <insane_m@hotmail. com>
Subject: [TI994A] SCSI
 folder copy
To: ti994a@yahoogroups. com
Date: Saturday, February 13, 2010, 7:19 PM

    

Tim

---

From: fdos <[email-masked]>
Date: Sat, 13 Feb 2010 21:11:05 -0700

Tim,

You took my name in vain!  After I tried so hard to stay out of this 
discussion.  I always do XCOPY backups of my TI drives on the Geneve. 
Only the IDE is tough (I would move the drive and IDE card to the 
Geneve, but it only works in GPL mode Tim ;-), but it will move over to 
a CF drive then it will be backed up on a PC with TI99dir.  Finding a CF 
card to work with the IDE on the TI is also tough--some day.

Bill S

Insane Multitasker wrote:
>  > --- In TI994A@yahoogroups. com, Insane Multitasker <insane_m@...> wrote:
>  > >
>  > >
>  > > Today I ventured into the TI dungeon and figured out a way to 
> resolve a termination problem with my SCSI card & TI. It seems that my 
> 50pin to centronics cable was flaky and not having another, I found my 
> old, Faire-corrupted SCSI 100MB drive and connected it in-line with an 
> EZ135 drive. Since the 100MB had terminating resistors, I placed it at 
> the end of the chain and with some luck, the system is functional again 
> ;) Both drives are working properly.
>  > >
>  > > Once fixed, I spent some time fixing the 100MB drive's FDRs and 
> VIB. I would like to backup the files to a platter. Here's my question:
>  > >
>  > > Is there a program for the TI, similar to XCOPY, that will allow me 
> to copy the folders without manually re-creating the entire directory 
> structure/copying folder by folder?
>  > >
>  > > Tim
>  > >
>  > *>
>  >
>  >
> *
> ------------------------------------------------------------------------
> *Hotmail: Trusted email with p owerful SPAM protection. Sign up now. 
> <http://clk.atdmt.com/GBL/go/201469227/direct/01/> *
> * *
> **
> * *

---

From: "fredkaal" <[email-masked]>
Date: Sun, 14 Feb 2010 09:50:14 -0000

Ha ... Ok, you find out for yourself.

The C (M P U) was in the very first releases of Dm2k. I´m thinking about to add it again for a direct copy (C) or move (M) protect (P) or unprotect (U) files or directory structures.

Fred ;-)

---

From: "Postle" <[email-masked]>
Date: Sun, 14 Feb 2010 15:01:08 -0000

Fred,

I have a most difficult time with the use of DM2K.  If you are stating that I will have a new and easier way to use: COPY (C); MOVE (M); PROTECT (P) and UNPROTECT (U) files, then I am all for it.  Send me a copy, please.

"For me", the DM2K program is the best I have.  But, the most difficult to use.

It is the only program I have which allows me to work with SCSI Files on a 256MB CF Memory Card.  A modern day Hard Drive for the TI-99/4A.  For which I wish to thank you.  Fred Kaal, Making things possible in a modern way, in a modern day.  Twenty-Seven years of progress.  That is why I just love using my TI-99/4A System Three.  It has a functioning SCSI Card System.

Postle

--- In [email-masked], "fredkaal" <fgkaal@...> wrote:
> --- In [email-masked], Insane Multitasker <insane_m@> wrote:
> >
> > 
> > Hey Marc, 
> > 
> > From: marc.hull@
> > --- On Sat, 2/13/10, Insane Multitasker <insane_m@> wrote:
> > 
> > From: Insane Multitasker <insane_m@>
> > Subject: [TI994A] SCSI
> >  folder copy

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 15 Feb 2010 16:34:34 -0600

Now now, there's plenty of bug eradication for all of us to join in :)

I did some testing today but ran out of time, partly because I couldn't find a program that would properly load SBUG from XB without crashing and/or properly setting the display, SIT, etc.  I want to inspect the FDR and open file cache buffers.  My program loop consists of opening a directory, reading the first record, and optionally closing the file.  A few observations: 

1. Open max directory files without closing:
The SCSI DSR will open up to 16 directory "files" before telling you too many files are open. This is expected.  I did not close any "files" during the loop.  After XB informs you of the error, editing the program will cause XB to close all open files; the SCSI card does its thing to flush/clear the buffers.  If you run the program again, system freezes.

If, however, I point the program from SCS1 to SCS2 after the error, where I have the same folder names (a copy of the disk), the program will run again.  I can swap between drives without an issue.  

2. Open max directory files, closing after each read
The SCSI DSR merrily cataloged 19 folders using this method.  Execution stops properly. If I restart the program on the same drive, system freezes; if I restart it but use SCS2, the program operates as expected. 

3. The crash occurs during the OPEN phase.  An "OPEN" call from XB will not return once the crash condition is met. 

Conclusion:
Since the problem can be delayed by changing devices, I suspect there is a device comparison routine and/or file status routine at fault, or the file closure routine is flawed. I did not see any code in the DSR that will close a catalog file when the end is reached; this may or may not be normal.

When the opportunity arises, maybe I'll stick an EPROM in my Geneve SCSI card and try to use hotbug to trace DSR execution.  That won't happen in the near future. 

Tim

To: [email-masked]
From: [email-masked]
Date: Sat, 13 Feb 2010 19:43:43 -0800
Subject: RE: [TI994A] SCSI folder copy

 

      

;)-

        

        

        

Hey Marc, 

        

3,2.....1

--- On Sat, 2/13/10, Insane Multitasker <insane_m@hotmail.
 com> wrote:

 

      

Tim

---

From: Marc Hull <[email-masked]>
Date: Tue, 16 Feb 2010 06:01:18 -0800 (PST)

----> If, however, I point the program from SCS1 to SCS2 after the error,
where I have the same folder names (a copy of the disk), the program
will run again.  I can swap between drives without an issue.  
  
I was hesitant to mention this earlier because I didn't think it relevent but apparantly it may be. I have found when doing large copy jobs with DM2K you can avoid the Noid so to speak by forcing an error  every so often (I would attempt to catalog a nonexistant directory.)  Forcing an error seems to reset whatever is boogering up the DSR and you can avoid the lock up.  

--- On Mon, 2/15/10, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] SCSI folder copy
To: [email-masked]
Date: Monday, February 15, 2010, 4:34 PM

  

      

Conclusion:

Tim

        

 

      

;)-

        

        

        

Hey Marc, 

        

3,2.....1

 

      

Tim

---

From: mark wills <[email-masked]>
Date: Tue, 16 Feb 2010 08:33:40 -0800 (PST)

Thats an important clue. By examining the error routine and seeing what it re-initialises, you might be able to work backwards and find the error source.

I don't suppose there is commented source?

>
>From: Marc Hull <[email-masked]>
>Sent: Tue, 16 February, 2010 14:01:18
>----> If, however, I point the program from SCS1 to SCS2 after the error, where I have the same folder names (a copy of the disk), the program will run again.  I can swap between drives without an issue.  
>  
>--- On Mon, 2/15/10, Insane Multitasker <insane_m@hotmail. com> wrote:
>
>
>>>________________________________
>>>________________________________
>>>>________________________________
>>>>>________________________________
>>>>> 
>>>>
>>>>
>>>>________________________________
>>>>
>>>> 
>>>
>>>
>>>
>>>________________________________
>>>
>>>
>>>________________________________
>>
>>
>>________________________________