Subject: Direct Read and Write from Basic

From: Dan Eicher <[email-masked]>
Date: Wed, 24 Mar 2010 06:40:54 -0400

Mike Write cracked the Doom of Mondular. for me about 10 years ago.
Here are three lines you might find interesting.

The full article can be found on the cyc\articles\wright\symbiote\doommond

We had stumbled across something that we didn't even know could be
done in Basic. The statement:
OPEN #1:N$,UPDATE,RELATIVE,INTERNAL,FIXED 255
with an FDR as set up above, essentially allows Basic to read and
write disk sectors!

d.

---

From: ti99_forever <[email-masked]>
Date: Wed, 24 Mar 2010 04:24:55 -0700 (PDT)

Umm - but aren't you missing a byte?
When you setup a record length as FIXED, then there is no length byte in the sector. Program Image has 256 bytes/sector. A FIXED means you can access all 256, because VARIABLE will assume length bytes out of band. But 255 means you are ignoring the last byte. Which is why we use DISPLAY/FIXED 128, and read two records at a time - we get all 256.

When you say "with an FDR as set up above", you are saying to modify the FDR to make it INTERNAL, FIXED 255?
Why INTERNAL? The first byte of an INTERNAL record (in band) will be taken as the length of a field within a record, meaning you will get some nasty stuff.

I'm going to need to read more than a section of code in the article, and it is pretty much based on cracking DOM itself, without much explanation of the OPEN statement that I could find!

--- On Wed, 3/24/10, Dan Eicher <[email-masked]> wrote:

From: Dan Eicher <[email-masked]>
Subject: [TI994A] Direct Read and Write from Basic
To: [email-masked]
Date: Wednesday, March 24, 2010, 6:40 AM

d.

------------------------------------

Yahoo! Groups Links

---

From: Owen Brand <[email-masked]>
Date: Wed, 24 Mar 2010 08:01:33 -0400

Apparently I need a copy of Doom of Mondular. :) this one is unknown  
to me on a first person-experience basis.  I shall find it on wht I  
assume?

Owen Brand
Opry99er.com