Subject: Fred Kaal's TiDir oddity

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 00:21:02 -0500

I am having an issue... I am using TiDir to read the contents so I can  
copy, paste, and edit in Notepad.  (yes, I am one of those that edits  
a bit in notepad--- primarily while on my MAC and don't have ready  
access to an emulator)  My issue comes when I copy and paste the  
contents into notepad.... I have a few lines in the title screen of  
"Honeycomb Rapture" that occupy every allowable space of the line....  
When I copy from the pad, it somehow adds a space between a closed  
parenthesis ")" and the following statement separator "::".  I may  
have a older version of this program... But when you try to copy and  
paste into Classic99, it kicks out errors because the last couple of  
characters on the line are erased and moved around.... Is this  
normal?  It is causing me grief.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: "Tursi" <[email-masked]>
Date: Wed, 27 Jan 2010 22:48:30 -0800

This is probably normal... it could happen on the real TI as well. The issue 
is that you can type a line compactly without spaces, but when it is listed, 
spaces are inserted around tokens like the :: statement separator. On lines 
that are already approaching the 4 line input limit, these extra spaces can 
push you over the edge. Although you can do numerous tricks to make longer 
lines (remove spaces, edit a line already at 4 lines long to get 5), for 
straight copy and paste operation it would be best to keep the lines 
shorter, no more than 2-3 lines long.

--------------------------------------------------
From: "Owen Brand" <[email-masked]>
Sent: Wednesday, January 27, 2010 9:21 PM
To: <[email-masked]>
Subject: [TI994A] Fred Kaal's TiDir oddity

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: ti99_forever <[email-masked]>
Date: Wed, 27 Jan 2010 22:54:35 -0800 (PST)

Should be easy enough to use find...replace to remove the spaces. Just look for " :: " and replace it with "::".

Gee, I need to write a sed script to do stuff like that. Or Applescript. Too many choices, can't make up my mind! (Yes, 2 is to many. I'm a TIer. One solution is enough!) ;)

--- On Thu, 1/28/10, Tursi <[email-masked]> wrote:

> From: Tursi <[email-masked]>
> Subject: Re: [TI994A] Fred Kaal's TiDir oddity
> To: [email-masked]
> Date: Thursday, January 28, 2010, 1:48 AM
>     [email-masked]
> 
> 
>

---

From: mark wills <[email-masked]>
Date: Wed, 27 Jan 2010 22:57:47 -0800 (PST)

Yes, I used to use that 'feature' a lot years ago...

A line of code, once it has been tokenised, takes up less memory. SO you could:

Enter a line of code until the BEEP! sound
Press enter
Edit the line
Remove blank spaces
Keep adding code to the end of the line!
You could get 5 lines of code to one line number that way!

More compact, a possibly a little faster.

M

>Sent: Thu, 28 January, 2010 7:48:30
>>------------ --------- --------- --------- --------- --
>>From: "Owen Brand" <owenbrand@opry99er. com>
>>To: <TI994A@yahoogroups. com>
>>> ------------ --------- --------- ------
>>>
>>> Yahoo! Groups Links
>>>
>>>
>>>
>
>

---

From: ti99_forever <[email-masked]>
Date: Wed, 27 Jan 2010 23:25:37 -0800 (PST)

I just timed the following two programs:
1.
10 for i=1 to 1000::print i::next i
and
2. 
10 for i=1 to 1000::print i
20 next i

both came out to 1:33.48 exactly. Hmm.

Oh, and btw: Perhaps Owen should try RXB. It allows longer lines. Although I really do miss the REDO function.

And remind me to tell you about the MagicJack sometime... ;)

--- On Thu, 1/28/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Fred Kaal's TiDir oddity
To: [email-masked]
Date: Thursday, January 28, 2010, 1:57 AM

M

---

From: mark wills <[email-masked]>
Date: Wed, 27 Jan 2010 23:36:31 -0800 (PST)

How about
10 for i=1 to 1000
20 print i
30 next i

However, a better test might be to remove the print line completely, as the screen update takes the majority of the time.

I *presume* code on seperate lines is slower, because there are more calls deep into the interpreter to fetch a line of code from memory and decode it...?

>
>From: ti99_forever <[email-masked]>
>Sent: Thu, 28 January, 2010 8:25:37
>--- On Thu, 1/28/10, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>From: mark wills <markrobertwills@ yahoo.co. uk>
>>To: TI994A@yahoogroups. com
>>>From: Tursi
>>> <yahoogroup@harmless lion.com>
>>>To: TI994A@yahoogroups. com

---

From: ti99_forever <[email-masked]>
Date: Wed, 27 Jan 2010 23:50:01 -0800 (PST)

Knock yourself out... I don't have patience to time an empty loop.

I was more interested in the truth or myth. We need a "TI Mythbusters" group. I remember all the rags of the newsgroups publishing stuff about faster code in XB, and it turns out a lot of it is myth.

I really need to be doing my work now instead of this right now... ;)

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Fred Kaal's TiDir oddity
To: [email-masked]
Date: Thursday, January 28, 2010, 2:36 AM

How about
10 for i=1 to 1000
20 print i
30 next i

 

To:
 TI994A@yahoogroups. com

M

From: Tursi

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 08:26:08 -0500

I know it's easy to do a backspace.... But every time I get farther  
along and I want to post new code to atariage or here, I have to do  
the backspaces EVERY time on EVERY statement of EVERY line that is 4  
lines long.... Drag

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 28, 2010, at 1:54 AM, ti99_forever <[email-masked]>  
wrote:

> Should be easy enough to use find...replace to remove the spaces.  
> Just look for " :: " and replace it with "::".
>
> Gee, I need to write a sed script to do stuff like that. Or  
> Applescript. Too many choices, can't make up my mind! (Yes, 2 is to  
> many. I'm a TIer. One solution is enough!) ;)
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 28 Jan 2010 08:42:28 -0500

I would certainly miss the REDO function as well.... I use it  
constantly.  :) Thanks for all the tips guys--- I may be well on my  
way to being a game programmer if things keep up this way.  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 28, 2010, at 2:25 AM, ti99_forever <[email-masked]>  
wrote:

> Oh, and btw: Perhaps Owen should try RXB. It allows longer lines.  
> Although I really do miss the REDO function.
>

---

From: "Jacques Groslouis" <[email-masked]>
Date: Thu, 28 Jan 2010 10:25:48 -0400

Owen,

I do not know if it would make a difference if Word Wrap was turned off in 
NotePad.

Also there is a TI program called Text Loader by Curtis Provance that will 
convert a text listing to a running XB program. I use it if I want to 
convert a program listing that someone sends me in an email message that I 
have transferred to my TI as a DV80 file. I then load this text file into 
Text Loader and an XB program is produced that I can SAVE and RUN. It will 
fail with some line transfers but I would say that it works well 99% of the 
time It is usually fairly easy to correct failed lines. Originally the 
program had a four line limit but the author posted a patch to correct this. 
I have never tried to run this program on an emulator.

Regards,

Jacques

----- Original Message ----- 
From: "Owen Brand" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, January 28, 2010 9:42 AM
Subject: Re: [TI994A] Fred Kaal's TiDir oddity

Owen Brand
**Oprysoft**
Opry99er.com

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 08:38:31 -0700

Jacques,

Where might one find Text Loader by Curtis Provance?  Is it on WHTECH? 
Or Planet99, etc.?

This would be a great utility if it's not similar to XLATE by John Ford 
that converts the DV80 to DV 163 MERGE format.  Does it work as well 
with TI BASIC as with XB?  Could I list a TI BASIC or XB program to a 
disk file, modify it with TI Writer or the EA editor, save it, then use 
Text Loader to convert and bring back the modified program to TI BASIC 
or XB?

I'm guessing that Text Loader is an XB program, yes?

Bill S

Jacques Groslouis wrote:
> From: "Owen Brand" <[email-masked] 
> <mailto:owenbrand%40opry99er.com>>
> To: <[email-masked] <mailto:TI994A%40yahoogroups.com>>
> On Jan 28, 2010, at 2:25 AM, ti99_forever <[email-masked] 
> <mailto:ti99_forever%40yahoo.com>>
> wrote:
> 
>  > --- On Thu, 1/28/10, mark wills <[email-masked] 
> <mailto:markrobertwills%40yahoo.co.uk>> wrote:
>  >
>  > From: mark wills <[email-masked] 
> <mailto:markrobertwills%40yahoo.co.uk>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > From: Tursi <[email-masked] 
> <mailto:yahoogroup%40harmlesslion.com>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>

---

From: "Jacques Groslouis" <[email-masked]>
Date: Thu, 28 Jan 2010 12:12:11 -0400

Bill,

 Text Loader is disk 82 in the BCS section of Whtech. The LOAD file on the 
disk runs a demo . Just revise the LOAD file so that only TEXTLOADER is 
loaded and the demo is bypassed.

It is not like XLATE because it creates the XB program direct from the DV80 
file and avoids the MERGE step. The program is a series of imbedded assembly 
routines that are accessed by entering in command mode CALL 
LINK('OLD","DSK1.your DV80 text file". Your text file then scrolls onto the 
screen as if you were typing in the lines. Then SAVE and RUN.

The BCS might not include the multiple line fix. Here is the fix from a past 
issue of Computer Shopper.
Curtis Alan Provance of Paragon Computing (17 Constance Street, Merrimack, 
NH 03054) wrote in to let us know of a bug in his excellent TextLoader 
program. "It seems that the original version only allowed multiple line 
entry up to 127 characters," explained Provance. "Since this is less than 
the length of the maximum Extended Basic line, it certainly wasn't a very 
attractive option."

The following commands entered after the TextLoader program is loaded will 
extend the maximum number of multiple lines to 162 characters, or almost six 
lines:

CALL INIT

CALL LOAD(-2094,9)

Save the program back to disk and the fix is done.

Have fun,

Jacques

----- Original Message ----- 
From: "fdos" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, January 28, 2010 11:38 AM
Subject: Re: [TI994A] Fred Kaal's TiDir oddity

>> I have never tried to run this program on an emulator.
<SNIP>

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 09:49:56 -0700

Thanks Jacques,

That is good news.  I take it that the patch means that source code is 
not available?  My only purpose for source code would be to adapt it for 
use with TI BASIC, and permanently fix the line length to 162 
characters, of course.

Bill S

---

From: "Jacques Groslouis" <[email-masked]>
Date: Thu, 28 Jan 2010 13:00:18 -0400

Bill,

The source code is on the BCS disk.

Jacques

----- Original Message ----- 
From: "fdos" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, January 28, 2010 12:49 PM
Subject: Re: TEXTLOADER was [TI994A] Fred Kaal's TiDir oddity

>>>> convert a program listing that someone sends me in an email message 
>>>> that
>>>> I

---

From: fdos <[email-masked]>
Date: Thu, 28 Jan 2010 10:15:35 -0700

Wow!  That's great.  Thanks.

Bill S

Jacques Groslouis wrote:
> From: "fdos" <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  >> extend the maximum number of multiple lines to 162 characters, or 
> almost
>  >> six
>  >> lines:
>  >>
>  >> CALL INIT
>  >>
>  >> CALL LOAD(-2094,9)
>  >>
>  >> From: "fdos" <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>>
>  >>>> I do not know if it would make a difference if Word Wrap was 
> turned off
>  >>>> in
>  >>>> NotePad.
>  >>>>
>  >>>> fail with some line transfers but I would say that it works well 
> 99% of
>  >>>> the

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 29 Jan 2010 00:12:09 -0600

I have a few lines in my BBS software that are 9+ lines long.  Standard XB. Depending on the tokens and variables, you can really pack a lot into one line number.  :)

To: [email-masked]
From: [email-masked]
Date: Wed, 27 Jan 2010 22:57:47 -0800
Subject: Re: [TI994A] Fred Kaal's TiDir oddity

M

_________________________________________________________________
Hotmail: Trusted email with Microsoft’s powerful SPAM protection.
http://clk.atdmt.com/GBL/go/196390706/direct/01/