Subject: Re: [TI994A] Re: Need help WHT file broken

From: [email-masked]
Date: Fri, 26 Feb 2010 15:10:43 EST

I don't know if that is strictly true. As long as you have a TOD game on  
the disk along with the editor files, it works - at least on a real TI. I  
extracted the files from WHT, converted them with TI99Dir, transferred all of  
them over to a TI disk with PC-TRANSFER and everything worked fine.
 
Bob  Carmany  

In a message dated 2/26/2010 3:02:46 P.M. Eastern Standard Time,  
[email-masked] writes:

Easy!
The TOD editor assumes your TOD game is the first on a fresh  disk.
It does DIRECT SECTOR reads on the disk (NOT ADIF/ADOF).
If you  extracted the files, this isn't going to work - it has to be on a 
disk  IMAGE.

---

From: Owen Brand <[email-masked]>
Date: Fri, 26 Feb 2010 15:33:39 -0500

I think Ben got that out of the manual.  It's in the manual that the  
game file should be first in the diskette, if I remember correctly.   
My editor manual is gone too.  :). I think it's in WHT also.

Owen Brand
Opry99er.com

On Feb 26, 2010, at 3:10 PM, [email-masked] wrote:

> I don't know if that is strictly true. As long as you have a TOD  
> game on the disk along with the editor files, it works - at least on  
> a real TI. I extracted the files from WHT, converted them with  
> TI99Dir, transferred all of them over to a TI disk with PC-TRANSFER  
> and everything worked fine.
>
> Bob Carmany
>
> In a message dated 2/26/2010 3:02:46 P.M. Eastern Standard Time, [email-masked] 
>  writes:
> Easy!
> If you extracted the files, this isn't going to work - it has to be  
> on a disk IMAGE.
>
>

---

From: mark wills <[email-masked]>
Date: Fri, 26 Feb 2010 12:37:05 -0800 (PST)

Owen

Can you re-create a *real* disk from image, the same way Robert did? At least you could run it on a real console...

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Fri, 26 February, 2010 20:33:39
>Subject: Re: [TI994A] Re: Need help WHT file broken
>
> >
>
>
>
> >
>
>
>
>
>
>
>I think Ben got that out of the manual.  It's in the manual that the game file should be first in the diskette, if I remember correctly.  My editor manual is gone too.  :). I think it's in WHT also.
>
>Owen Brand
>Opry99er.com
>
>>Bob 
>>Carmany 
>>>If you 
>>>  extracted the files, this isn't going to work - it has to be on a disk 
>>>  IMAGE.
>>>
>>> 
>
>
>

---

From: ti99_forever <[email-masked]>
Date: Fri, 26 Feb 2010 12:58:10 -0800 (PST)

Guys, I just tried it in PC99. Besides finding a corrupted version of XB, and having to edit a config file to add RXB, it runs fine.

Note to Bob: IF you run a sector editor and run a report, you will find the TOD file is the first on the disk. This was a limitation of the original program. I tore that program apart when I got it, even considered rewriting it to use ADIF/ADOF or rewriting for UCSD Pascal.

--- On Fri, 2/26/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Re: Need help WHT file broken
To: [email-masked]
Date: Friday, February 26, 2010, 3:37 PM

Owen

        

Owen BrandOpry99er.com

    

 
Bob 
Carmany 

The TOD editor assumes your TOD game is the first on a fresh 
  disk.

---

From: Owen Brand <[email-masked]>
Date: Fri, 26 Feb 2010 15:36:28 -0500

BUT.... If it works on the real deal....  :)

Owen Brand
Opry99er.com

---

From: ti99_forever <[email-masked]>
Date: Fri, 26 Feb 2010 13:13:23 -0800 (PST)

It does hang often on line 1 (appears to be testing if assembly code is already loaded) with RXB, so I've had to load it and do a RUN 2 to get it to run.
But once running, it "appears" to work. One thing I don't like is the lack of feedback - what was there before and what it just wrote.

But no errors. It may be wiping out another program for all I know.

--- On Fri, 2/26/10, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: Need help WHT file broken
To: [email-masked]
Date: Friday, February 26, 2010, 3:58 PM

 

        

Owen

        

Owen BrandOpry99er.com

    

 
Bob 
Carmany