Subject: WHT Website

From: "atrax27407" <[email-masked]>
Date: Fri, 26 Mar 2010 12:38:58 -0000

Anyone know if the WHT website is functioning? I had some problems accessing parts of it and downloading material and today I can't even access the site.

---

From: "Jon Vogel" <[email-masked]>
Date: Fri, 26 Mar 2010 08:47:39 -0500

Seems to be fine.