Subject: Re: [TI994A] New version Dm2k, Du2k, Cf2k

From: Marc Hull <[email-masked]>
Date: Wed, 20 Jan 2010 16:35:30 -0800 (PST)

Hello Fred.  I finally DL'd your new version of DM2K.  Excellent !!  It is really nice to be able to run all EA5's from DM2K now (no more remembering path names...)  I have noticed one new bit of a gotcha now that games can be run straight from the running manager.  Seems that DM2K runtime environment does not match what a lot of games are expecting.  I would think this is because many programmers assumed where tables were and what the reg settings would be (not all but evidently some.)  for your next update would it be possible to set the VDP tables and registers and the scratch pad up like they would be at the E/A cart start-up ?  No good deed goes unpunished huh ;-)

--- On Thu, 12/24/09, fredkaal <[email-masked]> wrote:

From: fredkaal <[email-masked]>
Subject: [TI994A] New version Dm2k, Du2k, Cf2k
To: [email-masked]
Date: Thursday, December 24, 2009, 9:01 AM

  

      Hi all,

There are new version available of:

Dm2k V2.4 here http://members. ziggo.nl/ fgkaal/Software/ sw_dm2k.html# dm2k

Du2k V2.0 here http://members. ziggo.nl/ fgkaal/Software/ sw_du2k.html# du2k

Cf2k V2.0 here http://members. ziggo.nl/ fgkaal/Software/ sw_cf2k.html# cf2k

All three programs now first initialize the keyboard to mode 5. This

is specially don for the John Guidry 64/128K card project.

I have spent some time on the program loader in Dm2k. There was a part in upper and lower ram, so if one of these parts got overwritten the system crashed.

Now the loader first loads the first part of the program to execute in VDP ram in the normal way. This way the system's DSRLNK figured out what device to use in the case of executing a program from DSK1. WDS1.DSK1 or IDE1.DSK1. The CRU address of this device is left at >83D0. This CRU address is used to find the entry point of the device name in the DSR (DSK1..DSK3, WDS1.., SCS1.., IDE1..) so that this address can be used directly to load the rest of the program and bypassing the DSRLNK function.

Before the loaded part of the program is moved to CPU ram it is first checked if it does not overwrite the loader. If it does, this part is saved for last and all other parts are loaded first.

At the end of the load session, the overlapping part of the program is loaded again, a small piece of code is copied to scratch pad to copy this part from VDP to CPU and the program is executed.

So ... now Dm2k can load itself, and because it looks to work so well this code is also added to Cf2k so that Cf2k can also load itself and can also load Dm2k wich in his turn can load Cf2k so that ...

anyway ... enjoy

and have a Merry Christmas and a happy newyear!

Fred ;-)

---

From: "fredkaal" <[email-masked]>
Date: Thu, 21 Jan 2010 06:18:20 -0000

Hi Mark,

I also noticed that. A lot of TI99 programs asumes that everything is always setup correctly. I also noticed that with the XB loader I'm creating: Du2k, Dm2k and Cu2k also expects that. Loaded from XB The programs did work but the screen was blue with strange black things.
Setting up the EA environment first and loading a character set at the right place cured this problem.

I suppose(d) that if Dm2k is running (in a EA environment) and it starts another program that it inherrits the same environment. I can't think about anything that is different. But I will have a look anyway about this matter.

Fred ;-)

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
> --- On Thu, 12/24/09, fredkaal <fgkaal@...> wrote:
> 
> From: fredkaal <fgkaal@...>

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 22 Jan 2010 20:57:06 -0600

Are you flipping to 40 column mode? ;)

> From: [email-masked]
> Date: Thu, 21 Jan 2010 06:18:20 +0000
> Subject: [TI994A] Re: New version Dm2k, Du2k, Cf2k
> 
> Hi Mark,
> 

_________________________________________________________________
Hotmail: Trusted email with Microsoft’s powerful SPAM protection.
http://clk.atdmt.com/GBL/go/196390706/direct/01/

---

From: "fredkaal" <[email-masked]>
Date: Sat, 23 Jan 2010 10:32:51 -0000

Yes,

First thing I do after loading a EA program is to set all VDP registers as the EA environment and load a character set.
Now I have to make it to load the loader a bit faster. call load() the loader takes ages. Also poking the loader into memory takes some time.

Fred ;-)

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:
> > From: fgkaal@...
> Hotmail: Trusted email with Microsoft's powerful SPAM protection.

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 23 Jan 2010 11:48:32 -0600

When loading from EA, isn't the system using 32-column graphics mode at that point?  This difference may explain why the loader within DM2K, used to launch another EA program, may need to change the environment back to ensure things "look right" for those programs that relied upon the cartridge to set things for them  ;)

> Date: Sat, 23 Jan 2010 10:32:51 +0000
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
> 
 		 	   		  
_________________________________________________________________
Hotmail: Trusted email with powerful SPAM protection.
http://clk.atdmt.com/GBL/go/196390707/direct/01/

---

From: mark wills <[email-masked]>
Date: Sun, 24 Jan 2010 23:45:28 -0800 (PST)

Tursi and I worked on a SuperDuper loader for Bill Sullivan. It's loads EA5 files and runs them. I developed it intially then Tursi took it to another level ;-)

I'm sure we could dig up the source code - most (all?) of the problems were solved... It can load anything ;-)

Mark

>
>From: Insane Multitasker <[email-masked]>
>To: [email-masked]
>Sent: Sat, 23 January, 2010 18:48:32
>Subject: RE: [TI994A] Re: New version Dm2k, Du2k, Cf2k
>
> >
>
>
>
>
>  >
>>      
> 
>>
>
>> To: TI994A@yahoogroups. com
>> From: fgkaal@ziggo. nl
>> --- In TI994A@yahoogroups. com, Insane Multitasker <insane_m@...> wrote:
>> >
>> > 
>> > > To: TI994A@yahoogroups. com
>> > > From: fgkaal@...
>> > ____________ _________ _________ _________ _________ _________ ________
>> > http://clk.atdmt. com/GBL/go/ 196390706/ direct/01/
>> >
>> 
>> 
>> 
>> 
>> ------------ --------- --------- ------
>> 
>> Yahoo! Groups Links
>> 
>> 
>> 
>
>
________________________________
Hotmail: Trusted email with powerful SPAM protection. Sign up now.

---

From: fdos <[email-masked]>
Date: Mon, 25 Jan 2010 07:54:10 -0700

Mark,

Tim knows about that Super Duper loader, and has the source as he added 
the final touch that made that TI BASIC EA5 loader Magical.  I provided 
Fred with information about it and where to get it, but I don't think he 
used it in his latest release of DM2k & CF2K.

Bill S

mark wills wrote:
>  
> 
> Tursi and I worked on a SuperDuper loader for Bill Sullivan. It's loads 
> EA5 files and runs them. I developed it intially then Tursi took it to 
> another level ;-)
> 
>     *From:* Insane Multitasker <[email-masked]>
>     *To:* [email-masked]
>     *Sent:* Sat, 23 January, 2010 18:48:32
>     *Subject:* RE: [TI994A] Re: New version Dm2k, Du2k, Cf2k
> 
>      
> 
>     When loading from EA, isn't the system using 32-column graphics mode
>     at that point?  This difference may explain why the loader within
>     DM2K, used to launch another EA program, may need to change the
>     environment back to ensure things "look right" for those programs
>     that relied upon the cartridge to set things for them  ;)
>      
> 
>      
>      > First thing I do after loading a EA program is to set all VDP
>     registers as the EA environment and load a character set.
>      > Now I have to make it to load the loader a bit faster. call
>     load() the loader takes ages. Also poking the loader into memory
>     takes some time.
>      >
>      > Fred ;-)
>      >
>      > > > I also noticed that. A lot of TI99 programs asumes that
>     everything is always setup correctly. I also noticed that with the
>     XB loader I'm creating: Du2k, Dm2k and Cu2k also expects that.
>     Loaded from XB The programs did work but the screen was blue with
>     strange black things.
>      > > > Setting up the EA environment first and loading a character
>     set at the right place cured this problem.
>      > > >
>      > > > I suppose(d) that if Dm2k is running (in a EA environment)
>     and it starts another program that it inherrits the same
>     environment. I can't think about anything that is different. But I
>     will have a look anyway about this matter.
>      > > >
>      > > > Fred ;-)
>      > > >
>      > >
>      > >
>     ------------------------------------------------------------------------
>     <http://clk.atdmt.com/GBL/go/196390707/direct/01/>
> 
>

---

From: "fredkaal" <[email-masked]>
Date: Mon, 25 Jan 2010 18:53:55 -0000

32 columns while loading! Never thought of that, but ...
who or what sets the display to 40 column mode when a EA opt 5 program is started?

Fred ;-)

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:
> > --- In [email-masked], Insane Multitasker <insane_m@> wrote:
> > >
> > > 
> > > > From: fgkaal@

---

From: "fredkaal" <[email-masked]>
Date: Mon, 25 Jan 2010 18:59:38 -0000

I found a loader on a disk wich can load a lot, also found some(the) source (can't remember where it is). One of the comments in the source I remember is: "Now move the loader to the end to get it out of the way". When loading Dm2k it wasn't out of the way enough unfortunetly. So I started again from scratch ... stumbling against every problem somebody allready solved many many moons ago.

But ... this story doesn't say it is about the SuperDuper loader! That one could be far superior!

Fred ;-)

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> >From: Insane Multitasker <insane_m@...>
> >> --- In TI994A@yahoogroups. com, Insane Multitasker <insane_m@> wrote:
> >> >
> >> >

---

From: Marc Hull <[email-masked]>
Date: Mon, 25 Jan 2010 11:09:25 -0800 (PST)

I think the E/A cart is always in 32 column mode Fred.  If you are not switching to 32 column mode when you fire off your loader then that may be one of the problems.  I think Tony has some pretty good info on the VDP state in the E/A environment.

--- On Mon, 1/25/10, fredkaal <[email-masked]> wrote:

From: fredkaal <[email-masked]>
Subject: [TI994A] Re: New version Dm2k, Du2k, Cf2k
To: [email-masked]
Date: Monday, January 25, 2010, 12:53 PM

  

Fred ;-)

--- In TI994A@yahoogroups. com, Insane Multitasker <insane_m@.. .> wrote:

> > > ____________ _________ _________ _________ _________ _________ _

> ____________ _________ _________ _________ _________ _________ _

> http://clk.atdmt. com/GBL/go/ 196390707/ direct/01/

---

From: ti99_forever <[email-masked]>
Date: Mon, 25 Jan 2010 12:06:03 -0800 (PST)

Yes, and you cannot trust EA#3 and EA#5 to do the same things. How annoying.

--- On Mon, 1/25/10, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Re: New version Dm2k, Du2k, Cf2k
To: [email-masked]
Date: Monday, January 25, 2010, 2:09 PM

 

 

Fred ;-)

--- In TI994A@yahoogroups. com, Insane Multitasker <insane_m@.. .> wrote: