Subject: Re: 720K Disks in Windows XP (not strictly off-topic)

From: [email-masked]
Date: Wed, 10 Feb 2010 15:51:58 EST

For some years, I have been happily transferring downloaded files and  
programs from my PC to my TI. Fred's TIDIR has been a real pleasure to work  
with. My procedure is to take the programs that I have downloaded and transfer  
them to a 3.5" 720K PC-Formatted disk with TIDIR for the final transfer 
using  PCTRANSFER. That worked fine - until the advent of Windows XP. Not only 
could  you not simply format a disk to 720K but it also didn't have DOS with 
it. When  my supply of PC-Formatted disks began to diminish to an alarming 
level, I was  faced with the prospect of either find an older PC with 
Windows 95/98 or coming  up with an alternative solution.
 
After some searching (and significant help from my daughter-in-law  
"computer expert"). I happened along the following solution. I thought it was  good 
enough to share with the TI community since not everyone chooses to use a  
modem to transfer files between computers, Here it is:

1)  Cover the square hole in the corner of the 1.44M floppy with a piece of 
tape  (there should be two holes - you want to cover the one WITHOUT  the
write-protect shutter). If you hold the disk parallel to the floor,  with
the label side up and the metal shutter away from you, it will be the  hole
on the right.

2) Open a DOS window. DOS  command-line tools must be run at the prompt of 
the CMd.exe command Interpreter.  To open Command prompt, click Start, click 
RUN, type cmd, and then click  OK.  

3) Use the DOS command "FORMAT A: /T:80 /N:9"

Windows XP doesn't  even support the /F:720 switch anymore, but explicitly 
defining the number of  sectors and tracks works just fine. 
Windows XP  has a pseudo-DOS that is usable. Enjoy!
 
Bob  Carmany

---

From: "Postle" <[email-masked]>
Date: Wed, 10 Feb 2010 23:23:38 -0000

Thanks Bob,

You POST is not a subject being off topic.

I just printed it for safe keepping.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: ti99_forever <[email-masked]>
Date: Wed, 10 Feb 2010 15:28:17 -0800 (PST)

Bob,

I remember doing this, and it working... but ISTR that if I overlapped to the OTHER side that PC Transfer wouldn't work anymore. Do you concur?
So I had to keep it within the limits of one side. I think maybe because TI disks on side 0 go from outside to inside (just like a PC), but inside to outside on side 1 (backwards from a PC).

Been a long time though. PC Transfer only worked with a Corcomp, right? I think I tried it with my BwG and it didn't work. Again, been a while.

But I like seeing the real stuff do the things that we think only PCs can do.

--- On Wed, 2/10/10, Postle <[email-masked]> wrote:

> From: Postle <[email-masked]>
> Subject: [TI994A] Re: 720K Disks in Windows XP (not strictly off-topic)
> To: [email-masked]
> Date: Wednesday, February 10, 2010, 6:23 PM
> Thanks Bob,
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: fdos <[email-masked]>
Date: Wed, 10 Feb 2010 16:40:19 -0700

Ben,

It seems to my that the Myarc FDC (not HFDC) also works with PC 
Transfer, as I do recall transfers from 720K to 720K in either 
direction.  It's just been several decades since I've used PC-Transfer. 
  I do come across the diskettes I used for the transfers from time to 
time, and they're all 720K (5.25" & 3.5").

Bill S

ti99_forever wrote:
>  
> 
> Bob,
> 
> I remember doing this, and it working... but ISTR that if I overlapped 
> to the OTHER side that PC Transfer wouldn't work anymore. Do you concur?
> So I had to keep it within the limits of one side. I think maybe because 
> TI disks on side 0 go from outside to inside (just like a PC), but 
> inside to outside on side 1 (backwards from a PC).
> 
> Been a long time though. PC Transfer only worked with a Corcomp, right? 
> I think I tried it with my BwG and it didn't work. Again, been a while.
> 
> --- On Wed, 2/10/10, Postle <[email-masked] 
> <mailto:postle%40roadrunner.com>> wrote:
> 
>  > From: Postle <[email-masked] <mailto:postle%40roadrunner.com>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > --- In [email-masked] <mailto:TI994A%40yahoogroups.com>,
>  > rmcarmany@... wrote:
>  > >
> <mailto:TI994A-fullfeatured%40yahoogroups.com>
>  >
>  >
>  >
> 
>

---

From: "Ksarul" <[email-masked]>
Date: Wed, 10 Feb 2010 19:10:57 -0500

Bill, I used it for 720 transfers too--but with a CorComp controller on a
Geneve.  I do remember that it preferred the IBM disks to be formatted on
the IBM machine--PC Transfer didn't always get them quite right.  Sometimes
the PC could read them, sometimes not.  It wasn't limited to a specific
drive either, it was pretty much random.  I haven' done any transfers in a
while, so maybe I should try again.  The Geneve thinks the BwG (or the
Atronic, for that matter) is a CorComp, and I seem to remember my BwG worked
fine for PC Transfer as well. 

Note: this is only tested/applicable on a Geneve--Ben may be right about it
failing on a regular TI with the BwG.

Jim 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
fdos
Sent: Wednesday, February 10, 2010 6:40 PM
To: [email-masked]
Subject: Re: [TI994A] Re: 720K Disks in Windows XP (not strictly off-topic)

Ben,

Bill S

Yahoo! Groups Links

---

From: Barry Peterson <[email-masked]>
Date: Wed, 10 Feb 2010 17:15:52 -0700

On Wed, Feb 10, 2010 at 4:28 PM, ti99_forever <[email-masked]>wrote:

> I think I tried it with my BwG and it didn't work. Again, been a while
>

ISTR that the original PC Transfer disk had programs for both, but I made my
own disk with only the CorComp files.

---

From: fdos <[email-masked]>
Date: Wed, 10 Feb 2010 19:23:57 -0700

Jim,

I don't believe I tried to use PC Transfer on the Geneve as most of the 
time I've had a Myarc HFDC in the Geneve system.

PC Transfer was written long before the BwG FDC was created.  It uses 
the same controller as the Corcomp, but it's likely that many other 
aspects are different, so probably wouldn't work.  One of these days (my 
back burner is really getting stacked high) I'll have to test all these 
possibilities out as I do have a BwG FDC, a Corcomp FDC with MG EPROMS 
(I do have the original Corcomp EPROMS also), and two Myarc 80 track FDC 
cards.

Maybe I should mark "one of these days" on my calendar (2021 or so). :-)

Bill S

Ksarul wrote:
> From: [email-masked] <mailto:TI994A%40yahoogroups.com> 
> [mailto:[email-masked] <mailto:TI994A%40yahoogroups.com>] On 
> Behalf Of
> fdos
> <mailto:postle%40roadrunner.com>
>  > > From: Postle <[email-masked] 
> <mailto:postle%40roadrunner.com> <mailto:postle%40roadrunner.com>>
> <mailto:TI994A%40yahoogroups.com>
>  > > --- In [email-masked] <mailto:TI994A%40yahoogroups.com> 
> <mailto:TI994A%40yahoogroups.com>,
>  > > rmcarmany@... wrote:
>  > > >

---

From: fdos <[email-masked]>
Date: Wed, 10 Feb 2010 19:41:52 -0700

Out to the garage again to fetch my original PC-Transfer diskette and 
PC-Transfer Utilities diskette.

There are files for the Myarc FDC and the Corcomp FDC (TI specific & 
Geneve specific).

Now we know.

Bill S

Barry Peterson wrote:
>  
> 
> On Wed, Feb 10, 2010 at 4:28 PM, ti99_forever <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Been a long time though. PC Transfer only worked with a Corcomp,
>     right? I think I tried it with my BwG and it didn't work. Again,
>     been a while
> 
>  
>  
> ISTR that the original PC Transfer disk had programs for both, but I 
> made my own disk with only the CorComp files.
>  
>  
>

---

From: "Ksarul" <[email-masked]>
Date: Wed, 10 Feb 2010 23:03:06 -0500

Right you are Bill--but for whatever reason, the Geneve Master DSR thinks
the BwG Card is a CorComp card--so nice little things like formatting 720K
disks and working with PC transfer are beneficial side effects. . .I've had
one in my primary Geneve system for years, along with my HFDC.

Jim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
fdos
Sent: Wednesday, February 10, 2010 9:24 PM
To: [email-masked]
Subject: Re: [TI994A] Re: 720K Disks in Windows XP (not strictly off-topic)

Jim,

Bill S

Yahoo! Groups Links

---

From: mark wills <[email-masked]>
Date: Wed, 10 Feb 2010 20:06:26 -0800 (PST)

Do TI Ram Disks actually simulate floppy disks at a low level?

Sorry if that's a rather nieve question.

It occurs to me that since one has to 'format' them, then they must be writing track and sector information into the RAM. Or, are they simply wiping the RAM clean?

I ask the question because, I'm wondering the following: Do RAM disks support all the low-level direct sector access commands that one can expect to be present with, say, the TI disk controller?

I appreciate that the DSR in the RAM disk is different from the DSR in the TI FDC, and is free to implement anything it wants, however, it would still have to 'simulate' those low level routines if it were to maintain compatibility and transparency.

Just curious...

Mark

---

From: ti99_forever <[email-masked]>
Date: Wed, 10 Feb 2010 21:35:29 -0800 (PST)

Yes, they do. But a format is pretty stand-alone, so once you call it, a Ramdisk is free to do what it wants - whether it is wipe the RAM and write the tables, or actually do what a TICC would do - use other low-level routines to access the RAM as a disk drive and lay down track info and write the tables using sector I/O. But you can be sure the "track info" isn't writing to a controller chip, but replaced with code to probably not do much of anything...

But it does all the normal stuff you expect. I cannot say this of early Ramdisks, having only had experience with Myarc and it not being "normal" in all respects. I never pushed it to the limit, having issues with bank-switching every interrupt causing problems with a lot of programs not running properly so it didn't see much use. Actually, I sent my original back for a refund and later picked up one second-hand...

--- On Wed, 2/10/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: [TI994A] Question about Ram Disks
To: [email-masked]
Date: Wednesday, February 10, 2010, 11:06 PM

Just curious...

Mark

---

From: mark wills <[email-masked]>
Date: Wed, 10 Feb 2010 21:52:47 -0800 (PST)

Is there a way to find the location of a character in a string, or do I have to roll my own?

I want to do:

A$="HELLO THERE"
PRINT "Space found at":INSTR(A$," ")

...type thang...

I thought it was SEG$, but of course, that just returns sub-strings...

:~(

---

From: Owen Brand <[email-masked]>
Date: Thu, 11 Feb 2010 00:57:35 -0500

A$="HELLO THERE"

DISPLAY AT (Y,X):SEG$(A$,6,1)

That won't work?

Owen Brand
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Wed, 10 Feb 2010 22:04:04 -0800 (PST)

Re-posting as I forgot to change the subject line...

>Sent: Thu, 11 February, 2010 6:52:47
>Subject: Re: [TI994A] Question about Ram Disks
>
> >
>
>
>
>
>  >
>>      
> 
>PRINT "Space found at":INSTR(A$ ," ")
>
>...type thang...
>
>I thought it was SEG$, but of course, that just returns sub-strings. ..
>
>:~(
>
>
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 11 Feb 2010 01:07:44 -0500

Ahhh, i see.... You need the inverse of the SEG$ function, yes?

Owen Brand
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Wed, 10 Feb 2010 22:18:33 -0800 (PST)

Yes, I want it to search the string and tell me where a character occurs...

I can roll my own, but I thought XB had it... I had a quick look in the XB manual, but nothing jumped out at me...

M

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Thu, 11 February, 2010 7:07:44
>Subject: Re: [TI994A] XB String Functions
>
> >
>
>
>
>
>  >
>>      
> 
>On Feb 11, 2010, at 1:04 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>>From: mark wills <markrobertwills@ yahoo.co. uk>
>>>To: TI994A@yahoogroups. com

---

From: ti99_forever <[email-masked]>
Date: Wed, 10 Feb 2010 22:20:59 -0800 (PST)

X=POS(STR1$,STR2$,BEGIN)

Returns position of STR2$ in STR1$ starting at BEGIN into X...

--- On Thu, 2/11/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] XB String Functions
To: [email-masked]
Date: Thursday, February 11, 2010, 1:18 AM

M

From: Owen Brand <[email-masked]>
To: "[email-masked]"
 <[email-masked]>
Sent: Thu, 11 February, 2010 7:07:44
Subject: Re: [TI994A] XB String Functions

    

Owen BrandOpry99er.com

    

Subject: Re: [TI994A]
 Question about Ram Disks

    

I want to do:

A$="HELLO THERE"

...type thang...

:~(

---

From: mark wills <[email-masked]>
Date: Wed, 10 Feb 2010 22:26:02 -0800 (PST)

He he! I *thought* it did!! Thanks!

Mark

>
>From: ti99_forever <[email-masked]>
>Sent: Thu, 11 February, 2010 7:20:59
>X=POS(STR1$, STR2$,BEGIN)
>
>--- On Thu, 2/11/10, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>
>>>From: Owen Brand <owenbrand@opry99er. com>
>>>To: "TI994A@yahoogroups .com"
>>> <TI994A@yahoogroups. com>

---

From: Insane Multitasker <[email-masked]>
Date: Thu, 11 Feb 2010 00:23:32 -0600

You probably want the POS function, Mark. (there's a joke in here somewhere)

A$="Where is my space?"

Print "space found at":POS(A$," ",1)

You may use the result to iteratively parse the string.  When result is 0, string 
not found. You could use a variable for the second string. The third 
variable is the starting search position. 

A$="Hello Computer"

B$="llo"

Print POS(A$,B$,1)

To: [email-masked]
From: [email-masked]
Date: Wed, 10 Feb 2010 22:04:04 -0800
Subject: [TI994A] XB String Functions

 

      

I want to do:

A$="HELLO THERE"

...type thang...

:~(

    

_________________________________________________________________
Hotmail: Free, trusted and rich email service.
http://clk.atdmt.com/GBL/go/201469228/direct/01/

---

From: mark wills <[email-masked]>
Date: Wed, 10 Feb 2010 22:34:17 -0800 (PST)

Cool, thanks!

Mark

>
>From: Insane Multitasker <[email-masked]>
>To: [email-masked]
>Sent: Thu, 11 February, 2010 7:23:32
>Subject: RE: [TI994A] XB String Functions
>
> >
>
>
>
>
>  >
>>      
> 
>>
>
________________________________
To: TI994A@yahoogroups. com
>From: markrobertwills@ yahoo.co. uk
>________________________________
Hotmail: Free, trusted and rich email service. Get it now. >

---

From: Insane Multitasker <[email-masked]>
Date: Thu, 11 Feb 2010 00:39:31 -0600

Now let's see you translate this into HEX for Tursi's benefit!

:)-

To: [email-masked]
From: [email-masked]
Date: Wed, 10 Feb 2010 22:20:59 -0800
Subject: Re: [TI994A] XB String Functions

X=POS(STR1$,STR2$,BEGIN)

        

M

 

      

Owen BrandOpry99er.com

    

 

      

I want to do:

A$="HELLO THERE"

...type thang...

:~(

    

    

    

    

_________________________________________________________________
Your E-mail and More On-the-Go. Get Windows Live Hotmail Free.
http://clk.atdmt.com/GBL/go/201469229/direct/01/

---

From: "killroy732000" <[email-masked]>
Date: Thu, 11 Feb 2010 12:29:10 -0000

Yes, this is very useful info. 

Why not add it to ninerpedia ?

Filip

--- In [email-masked], "Postle" <postle@...> wrote:
> --- In [email-masked], rmcarmany@ wrote:
> >