Subject: Re: [TI994A] Re: creating XB code in a backhanded way...

From: [email-masked]
Date: Sun, 14 Mar 2010 11:51:53 EDT

Why re-invent the wheel? I have attached some programs that may be of help  
in tokenizing, writing, and saving XB programs. PROGRAM WRITER is one that  
I wrote years ago (it is also in the 'Files' section of the OLUG), CALL KEY 
is  one written by Ray Kazmer that will allow you to explore various key  
combinations - just change the key-code in the statement CALL KEY(x,K,S) to 
get  the entire range of keypresses. DATA ENTRY is for entering data directly 
 as LINPUT and saving it to disk. They are zipped using WINZip and then  
archived with a TIFILES header. 
 
Bob  Carmany

---

From: Marc Hull <[email-masked]>
Date: Sun, 14 Mar 2010 10:10:28 -0700 (PDT)

I have been messing around with the files you sent me.  I am not sure they will do exactly what I want which is this

10 FOR C=1 TO 100::READ A::A$=A$&CHR$(A)::NEXT C
20 A$="100 DATA"&A$

at this point A$ should look like this....

100 DATA selg9  etc... with characters from ASCII 32 to 255

I then want to save the string in a manner in which it can be merged with another XB program...

Thanks for the help....

Marc 

--- On Sun, 3/14/10, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] Re: creating XB code in a backhanded way... [1 Attachment]
To: [email-masked]
Date: Sunday, March 14, 2010, 10:51 AM

  

        [Attachment(s) from [email-masked] included below]

Why re-invent the wheel? I have attached some programs that may be of help 
in tokenizing, writing, and saving XB programs. PROGRAM WRITER is one that 
I wrote years ago (it is also in the 'Files' section of the OLUG), CALL KEY is 
one written by Ray Kazmer that will allow you to explore various key 
combinations - just change the key-code in the statement CALL KEY(x,K,S) to get 
the entire range of keypresses. DATA ENTRY is for entering data directly 
as LINPUT and saving it to disk. They are zipped using WINZip and then 
archived with a TIFILES header. 
 
Bob 
Carmany

---

From: mark wills <[email-masked]>
Date: Sun, 14 Mar 2010 10:55:46 -0700 (PDT)

Hang fire - should have a solution for you in a couple of minutes....

>
>From: Marc Hull <[email-masked]>
>Sent: Sun, 14 March, 2010 17:10:28
>Subject: Re: [TI994A] Re: creating XB code in a backhanded way...
>
> >
>
>
>
> >
> >
>
>
>
>
>
>
>

---

From: mark wills <[email-masked]>
Date: Sun, 14 Mar 2010 11:44:24 -0700 (PDT)

I give you..........

*** SELF MODIFYING XB CODE :-) ***

1) Type this in EXACTLY AS SEEN: (or, even better, paste it into XB in Classic99)

10 CALL INIT :: FA=-268 :: SA=-398
20 FOR I=0 TO 129 :: CALL LOAD(FA,I):: FA=FA+1 :: NEXT I
30 FOR I=130 TO 255 :: CALL LOAD(SA,I):: SA=SA+1 :: NEXT I
40 DATA "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZ"
50 DATA "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTU"

1a) Line 40 is the alphabet 5 times - line 50 is the aplhabet 5 times, less the last five characters
That gives you (26*5)+((26*5)-5)=255
Note: Yahoo will break the formatting, but just keep typing the alphabet with no spaces

2) Run the program
3) List it

You will see that the stuff in the DATA lines has changed... There's some crap in there, but don't worry, it works fine (XB is seeing the higher byte values as tokens). It has modified itself and replaced the A-Z stuff with characters 0 to 255

4) Delete lines 10, 20, & 30
5) Do something like: RES 32000
6) Do something like: SAVE DSK1.THING,MERGE

You now have those data statements in merge format at line 32000

Rock on.

>
>From: mark wills <[email-masked]>
>Sent: Sun, 14 March, 2010 17:55:46
>>Subject: >> Re: [TI994A] Re: creating XB code in a backhanded way...
>>
>> >>
>> >>
>>
>>
>>
>>
>>
>>
>>

---

From: Owen Brand <[email-masked]>
Date: Sun, 14 Mar 2010 14:48:10 -0400

damn willsy!!!  That's freakin cool!

Owen Brand
Opry99er.com

On Mar 14, 2010, at 2:44 PM, mark wills <[email-masked]>  
wrote:

> 40 DATA  
> "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZ"
> 50 DATA  
> "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTU"
>
>
> You will see that the stuff in the DATA lines has changed... There's  
> some crap in there, but don't worry, it works fine (XB is seeing the  
> higher byte values as tokens). It has modified itself and replaced  
> the A-Z stuff with characters 0 to 255
>
> I have been messing around with the files you sent me.  I am not  
> sure they will do exactly what I want which is this
>
>
> Why re-invent the wheel? I have attached some programs that may be  
> of help in tokenizing, writing, and saving XB programs. PROGRAM  
> WRITER is one that I wrote years ago (it is also in the 'Files'  
> section of the OLUG), CALL KEY is one written by Ray Kazmer that  
> will allow you to explore various key combinations - just change the  
> key-code in the statement CALL KEY(x,K,S) to get the entire range of  
> keypresses. DATA ENTRY is for entering data directly as LINPUT and  
> saving it to disk. They are zipped using WINZip and then archived  
> with a TIFILES header.
>
> Bob Carmany
>
>
>
>
>
>
>