Subject: New TI game in progress: Herding Cats screenshots

From: Keith Bergman <[email-masked]>
Date: Fri, 12 Feb 2010 14:10:01 -0500

For those of you not following the excitement over on the Atariage
programming forum, I wanted to share a few screenshots of my
soon-to-be-finished game, Herding Cats.

The game is in Extended BASIC, and has been coded on real hardware.  In it,
you must "herd cats" (thus the snappy title) to the red exit on the screen.
Since you can't make cats do anything (they are, after all, cats), you
instead manipulate the environment around them and hope for the best.  Every
"tool" you use -- shaking the table, filling in holes, building walls,
setting up a "cat-apult" or a catnip magnet -- costs you in points, and your
goal is to save enough cats to advance to the next level.  There are 30
levels in all.  The links below are of screenshots to the each of the first
three.

http://i198.photobucket.com/albums/aa269/exiletoledo/herdingcatslevel1.jpg

http://i198.photobucket.com/albums/aa269/exiletoledo/herdingcatslevel2.jpg

http://i198.photobucket.com/albums/aa269/exiletoledo/herdingcatslevel3.jpg

This version of the game should be ready in beta form by the end of the
weekend.

The ultimate plan is to refine it, then create a two-player version,
playable against the computer, where you compete to get the most cats to
your exit, while undermining your opponent.  My goal is to release both
games in a limited-edition physical package, with box and instructions, at
the 2010 Faire.

Besides the physical form, they'll be freely available as
"cup-of-coffee-ware" -- if you like 'em, and you feel like it, PayPal me two
bucks for a cup of joe.  ;)

Very excited to be back in programming mode, and finishing up a new TI
project.  This will be the first of many.

Keith

---

From: "Bryan Roppolo Boulder" <[email-masked]>
Date: Fri, 12 Feb 2010 14:47:24 -0500

Holy cow this looks like a good one! 

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Keith Bergman
Sent: Friday, February 12, 2010 2:10 PM
To: [email-masked]
Subject: [TI994A] New TI game in progress: Herding Cats screenshots

 

Keith

---

From: "killroy732000" <[email-masked]>
Date: Fri, 12 Feb 2010 20:25:32 -0000

And here is where the action is at:

http://www.atariage.com/forums/forum/119-ti-994a-programming/

Filip

---

From: mark wills <[email-masked]>
Date: Fri, 12 Feb 2010 21:14:46 -0800 (PST)

Yeah, this looks awesome... I don't play games much, but I'm really looking forward to Honeycomb Rapture and Herding Cats.

Was it you Bryan that wrote a game about a year ago that was actually programmable? You programmed robots IIRC?

I *must* try that one out... It sounds great... Trouble is, before you know it, you've blow an hour playing games! I blew 30 minutes yesterday on Lemonade Stand... Bloody thing!

>
>From: Bryan Roppolo Boulder <[email-masked]>
>To: [email-masked]
>Sent: Fri, 12 February, 2010 20:47:24
>Subject: RE: [TI994A] New TI game in progress: Herding Cats screenshots
>
> >
>
>
>
>
>  >
>>      
> 
>>
>
>
>
>
>>
________________________________
 >
>From:TI994A@yahoogroups. com [mailto: TI994A@yahoogroups. com ] On Behalf Of Keith Bergman
>To: ti994a@yahoogroups. com
>The game is in Extended BASIC, and has been coded on real
>hardware.  In it, you must "herd cats" (thus the snappy title)
>to the red exit on the screen.  Since you can't make cats do anything
>(they are, after all, cats), you instead manipulate the environment around them
>and hope for the best.  Every "tool" you use -- shaking the
>table, filling in holes, building walls, setting up a "cat-apult" or
>a catnip magnet -- costs you in points, and your goal is to save enough cats to
>advance to the next level.  There are 30 levels in all.  The links
>below are of screenshots to the each of the first three.
>>
> 
>>
>http://i198. photobucket. com/albums/ aa269/exiletoled o/herdingcatslev el1.jpg
>>
> 
>>
>http://i198. photobucket. com/albums/ aa269/exiletoled o/herdingcatslev el2.jpg
>>
> 
>>
>http://i198. photobucket. com/albums/ aa269/exiletoled o/herdingcatslev el3.jpg
>>
> 
>>
> 
>>
>playable against the computer, where you compete to get the most cats to your
>exit, while undermining your opponent.  My goal is to release both games
>in a limited-edition physical package, with box and instructions, at the 2010
>Faire.
>>
> 
>>
>"cup-of-coffee- ware" -- if you like 'em, and you feel like it, PayPal
>me two bucks for a cup of joe.  ;)
>>
> 
>>

---

From: Keith Bergman <[email-masked]>
Date: Sat, 13 Feb 2010 00:46:30 -0500

I think you're referring to Robot War, which Walid Maalouli made (and was
kind enough to send me on disk, in my pre-emulator dark ages).

On Sat, Feb 13, 2010 at 12:14 AM, mark wills <[email-masked]>wrote:

>
>
>  Yeah, this looks awesome... I don't play games much, but I'm really
> looking forward to Honeycomb Rapture and Herding Cats.
>
> Was it you Bryan that wrote a game about a year ago that was actually
> programmable? You programmed robots IIRC?
>
> I *must* try that one out... It sounds great... Trouble is, before you know
> it, you've blow an hour playing games! I blew 30 minutes yesterday on
> Lemonade Stand... Bloody thing!
>
>
>
>
>
> *From:* Bryan Roppolo Boulder <[email-masked]>
> *To:* [email-masked]
> *Sent:* Fri, 12 February, 2010 20:47:24
> *Subject:* RE: [TI994A] New TI game in progress: Herding Cats screenshots
>
>
>
>  ------------------------------
>
> *From:* TI994A@yahoogroups. com [mailto: TI994A@yahoogroups. com ] *On
> Behalf Of *Keith Bergman
> *Sent:* Friday, February 12, 2010 2:10 PM
> *To:* ti994a@yahoogroups. com
> *Subject:* [TI994A] New TI game in progress: Herding Cats screenshots
>
>
>
>
>
>
> http://i198. photobucket. com/albums/ aa269/exiletoled o/herdingcatslev
> el1.jpg<http://i198.photobucket.com/albums/aa269/exiletoledo/herdingcatslevel1.jpg>
>
>
>
> http://i198. photobucket. com/albums/ aa269/exiletoled o/herdingcatslev
> el2.jpg<http://i198.photobucket.com/albums/aa269/exiletoledo/herdingcatslevel2.jpg>
>
>
>
> http://i198. photobucket. com/albums/ aa269/exiletoled o/herdingcatslev
> el3.jpg<http://i198.photobucket.com/albums/aa269/exiletoledo/herdingcatslevel3.jpg>
>
>
>
>
>
> Besides the physical form, they'll be freely available as "cup-of-coffee-
> ware" -- if you like 'em, and you feel like it, PayPal me two bucks for a
> cup of joe.  ;)
>
>
>

---

From: mark wills <[email-masked]>
Date: Fri, 12 Feb 2010 21:58:22 -0800 (PST)

Ah! Yes, apologies to Walid for the mix-up.

Hmmm... That's on my 'chill' list for tonight after I have spoken to Her Indoors on Skype :-)

>
>From: Keith Bergman <[email-masked]>
>Sent: Sat, 13 February, 2010 6:46:30
>Subject: Re: [TI994A] New TI game in progress: Herding Cats screenshots
>
> >
>
>
>
>
>  >
>>      
> 
>I think you're referring to Robot War, which Walid Maalouli made (and was kind enough to send me on disk, in my pre-emulator dark ages).
>
>
>On Sat, Feb 13, 2010 at 12:14 AM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>
>  
>>>From: Bryan Roppolo Boulder <brop99@hotmail. com>
>>>To: TI994A@yahoogroups. com
 
>>>For those of you not following the excitement over on the Atariage programming forum, I wanted to share a few screenshots of my soon-to-be-finished game, Herding Cats.
>>> 
>>>The game is in Extended BASIC, and has been coded on real hardware.  In it, you must "herd cats" (thus the snappy title) to the red exit on the screen.  Since you can't make cats do anything (they are, after all, cats), you instead manipulate the environment around them and hope for the best.  Every "tool" you use -- shaking the table, filling in holes, building walls, setting up a "cat-apult" or a catnip magnet -- costs you in points, and your goal is to save enough cats to advance to the next level.  There are 30 levels in all.  The links below are of screenshots to the each of the first three.
>>> 
>>>This version of the game should be ready in beta form by the end of the weekend.
>>> 
>>>The ultimate plan is to refine it, then create a two-player version, playable against the computer, where you compete to get the most cats to your exit, while undermining your opponent.  My goal is to release both games in a limited-edition physical package, with box and instructions, at the 2010 Faire.
>>> 
>>>Besides the physical form, they'll be freely available as "cup-of-coffee- ware" -- if you like 'em, and you feel like it, PayPal me two bucks for a cup of joe.  ;)
>>> 
>>>Very excited to be back in programming mode, and finishing up a new TI project.  This will be the first of many.
>>> 
>>>Keith
>>> 
>>>
>>> 
>
>

---

From: Keith Bergman <[email-masked]>
Date: Sat, 13 Feb 2010 01:00:26 -0500

Is Walid around these parts?  I don't seem to recall seeing his name pop up
much recently.  I need to revisit Robot War myself... once I finish making
this game and can use other people's programs for a while again.  :P

On Sat, Feb 13, 2010 at 12:58 AM, mark wills <[email-masked]>wrote:

> *From:* Keith Bergman <[email-masked]>
> *Sent:* Sat, 13 February, 2010 6:46:30
> *Subject:* Re: [TI994A] New TI game in progress: Herding Cats screenshots
>
>
>
> On Sat, Feb 13, 2010 at 12:14 AM, mark wills <markrobertwills@ yahoo.co.
> uk <[email-masked]>> wrote:
>
>>
>>
>> I *must* try that one out... It sounds great... Trouble is, before you
>> know it, you've blow an hour playing games! I blew 30 minutes yesterday on
>> *From:* Bryan Roppolo Boulder <brop99@hotmail. com <[email-masked]>>
>> *To:* TI994A@yahoogroups. com <[email-masked]>
>> The game is in Extended BASIC, and has been coded on real hardware.  In
>> it, you must "herd cats" (thus the snappy title) to the red exit on the
>> screen.  Since you can't make cats do anything (they are, after all, cats),
>> you instead manipulate the environment around them and hope for the best.
>> Every "tool" you use -- shaking the table, filling in holes, building walls,