Subject: Asm994a bug

From: "Matthew" <[email-masked]>
Date: Mon, 22 Feb 2010 04:24:35 -0000

Does anyone know if Cory Burr takes bug requests and/or fixes them?  I hope he at least lurks in these forums.  There seems to be a bug in Asm994a with the JH opcode, it gets written as a JNE.  It really sucks trying to troubleshoot assembly language when you have to first make sure the assembler and emulator are not causing the problem.

At any rate, my work flow just changed... ugh.

Matthew

---

From: mark wills <[email-masked]>
Date: Sun, 21 Feb 2010 20:38:03 -0800 (PST)

Oh, and to answer your other question, Cory seems to have vanished for good...

Mark

----- Original Message ----
> From: Matthew <[email-masked]>
> To: [email-masked]
> Sent: Mon, 22 February, 2010 5:24:35
> Subject: [TI994A] Asm994a bug
> 
> Does anyone know if Cory Burr takes bug requests and/or fixes them?  I hope he 
> at least lurks in these forums.  There seems to be a bug in Asm994a with the JH 
> opcode, it gets written as a JNE.  It really sucks trying to troubleshoot 
> assembly language when you have to first make sure the assembler and emulator 
> are not causing the problem.
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: mark wills <[email-masked]>
Date: Sun, 21 Feb 2010 20:37:27 -0800 (PST)

Yeah,

I got hit by that bug just last week. It wasn't until I dropped into Classic99's debugger to single step the code, and I was like "HUH?" - then I remembered ;-)

I *think* either Filip or Tursi have a home-patched version of ASM99 that fixes the bug... Filip? Tursi?

:-)

---

From: "Tursi" <[email-masked]>
Date: Sun, 21 Feb 2010 20:52:09 -0800

I have a Cory-patched version, actually... but he did not give me permission 
to post it anyway. I mailed Matthew a copy.

He followed up on the 99er.net post, IIRC, so double-check there.

--------------------------------------------------
From: "mark wills" <[email-masked]>
Sent: Sunday, February 21, 2010 8:37 PM
To: <[email-masked]>
Subject: Re: [TI994A] Asm994a bug

> Yeah,
>
> I got hit by that bug just last week. It wasn't until I dropped into 
> Classic99's debugger to single step the code, and I was like "HUH?" - then 
> I remembered ;-)
>

---

From: "Matthew" <[email-masked]>
Date: Mon, 22 Feb 2010 05:00:51 -0000

Hmm, maybe it is time to dust off my assembler...  I was about 3/4 of the way done with it when I stopped working on it.  Really it was being built in to my emulator, but all of a sudden I find myself in need of a reliable PC-based assembler (PC means "personal computer", since I code in C it would be cross platform.)

Matthew

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> > From: Matthew <matthew@...>

---

From: "kabldb" <[email-masked]>
Date: Mon, 22 Feb 2010 09:38:33 -0000

Wow ! Sounds great !!!

:-P

--- In [email-masked], "Matthew" <matthew@...> wrote:
> --- In [email-masked], mark wills <markrobertwills@> wrote:
> >
> > Yeah,
> > 
> > > From: Matthew <matthew@>