Subject: Ipad development kit

From: Owen Brand <[email-masked]>
Date: Mon, 29 Mar 2010 22:19:07 -0400

http://www.apple.com/ipad/sdk/

Not ENTIRELY proprietary--- I'm glad to see this.  Shame Classic99  
won't be on the ipad.  :). Or MESS

Owen Brand
Opry99er.com

---

From: "Matthew" <[email-masked]>
Date: Tue, 30 Mar 2010 03:10:04 -0000

> won't be on the ipad.  :). Or MESS

And to you know why?  Not because Tursi or the MESS guys won't port their emulators, but because Apple won't allow any applications that run arbitrary code!  They even disable Flash in their browser on the iPhone and made a special app specifically for watching YouTube videos.

The only way to run an emulator on the iPhone, iTouch, or iPad is to jail-break the device (which is *not* the same as unlocking.)

Matthew

---

From: Owen Brand <[email-masked]>
Date: Mon, 29 Mar 2010 23:26:30 -0400

Very true my friend.  My bass player just recently jail-broke his  
iPhone and we played Mike Tyson's Punch Out and RC Pro Am on his fancy  
little NES emulator all the way to Key West.  :)   The whole time I  
was thinking, "Classic99 on an iPhone......." Just struck me.  :)

Owen Brand
Opry99er.com

On Mar 29, 2010, at 11:10 PM, "Matthew" <[email-masked]> wrote:

> And to you know why? Not because Tursi or the MESS guys won't port  
> their emulators, but because Apple won't allow any applications that  
> run arbitrary code! They even disable Flash in their browser on the  
> iPhone and made a special app specifically for watching YouTube  
> videos.
>
> The only way to run an emulator on the iPhone, iTouch, or iPad is to  
> jail-break the device (which is *not* the same as unlocking.)
>
> Matthew
>
>

---

From: Owen Brand <[email-masked]>
Date: Mon, 29 Mar 2010 23:52:37 -0400

Are you saying here that if one jailbreaks one's iPhone, a standard  
emulator will run on it?  More likely it would have to be ported first  
to run on the platform... I don't imagine that jailbreaking turns the  
iPhone into a laptop.... But still, with the flexibility of the  
iPhone, the ability to manipulate the screen and keyboard, an emulator  
could work quite nicely on an iPhone.  Especially since jailbreaking  
sets up hard drive partitions for storage--- DSK1?  :)

Owen Brand
Opry99er.com

---

From: "Tursi" <[email-masked]>
Date: Mon, 29 Mar 2010 20:58:29 -0700

Unfortunately, I won't be developing Jailbreak applications for the iPhone 
or iPad. :)

---

From: Owen Brand <[email-masked]>
Date: Tue, 30 Mar 2010 00:05:07 -0400

I didn't assume you would.  :) I was merely pointing out my personal  
desire to have Classic99 on a handheld device.  Something with the  
power of Internet access coupled with a good emulator-- :) Just  
wishful thinking.  But soon there will be a tablet or a handheld  
Internet device that WILL run Classic99.  And when that happens, you  
bet your sweet aZZ I'll be utilizing it to the fullest.  :)

Owen Brand
Opry99er.com

---

From: "Matthew" <[email-masked]>
Date: Tue, 30 Mar 2010 05:15:38 -0000

Well, you don't have to jailbreak your phone to *develop* the app.  You just would not be able to get it approved by Apple for sale on the AppStore, but you could run it all day long on your own development iPhone. :-)

Matthew

---

From: "Matthew" <[email-masked]>
Date: Tue, 30 Mar 2010 05:22:46 -0000

An iPhone is basically a hand-held 400MHz unix box.  It runs a stripped back version of OSX, but it is a complete unix machine.  Once jail broken, you could run a web server on your iPhone, SSH into it, develop on it, or whatever.  The device is really nice, its problem is Apple.  But yes, Tursi would have to port Classic99 to OSX for it to work on the iPhone.

Matthew

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Mar 29, 2010, at 11:10 PM, "Matthew" <matthew@...> wrote:
> 
> > --- In [email-masked], Owen Brand <owenbrand@> wrote:
> > >

---

From: Gregory McGill <[email-masked]>
Date: Mon, 29 Mar 2010 22:24:12 -0700

Better yet, port it to SDL, then it will run on everything, windows, linux,
my psp.. you name it

Greg

On Mon, Mar 29, 2010 at 10:22 PM, Matthew <[email-masked]> wrote:

>
>
> An iPhone is basically a hand-held 400MHz unix box. It runs a stripped back
> version of OSX, but it is a complete unix machine. Once jail broken, you
> could run a web server on your iPhone, SSH into it, develop on it, or
> whatever. The device is really nice, its problem is Apple. But yes, Tursi
> would have to port Classic99 to OSX for it to work on the iPhone.
>
> Matthew
>
>
> --- In [email-masked] <TI994A%40yahoogroups.com>, Owen Brand
> <owenbrand@...> wrote:
> >
> > > --- In [email-masked] <TI994A%40yahoogroups.com>, Owen Brand
> <owenbrand@> wrote:
> > > >

---

From: "Tursi" <[email-masked]>
Date: Mon, 29 Mar 2010 22:44:28 -0700

> Better yet, port it to SDL, then it will run on everything, windows, 
> linux, my psp.. you name it

I don't really like SDL. Classic99 stands a better chance of being ported to 
Mono, but at this time there are no plans for cross platform support. MESS 
already fills that role, and gets credit as being a more accurate emulation 
than Classic99, so why should I compete? ;) The only non-Windows port of 
Classic99 is for the XBox, and that was done without permission. The porter 
further completely ignored my attempts to contact him.

I'm not ignorant of other systems, I just have quite enough platforms to 
work with right now. I happen to like Windows and the various Windows APIs, 
though it took me a long time to get there. ;) Besides, cross-platform app 
means cross-platform support, which gets annoying very fast, and Wine 
already covers most Linux users. But someday, probably.

---

From: Gregory McGill <[email-masked]>
Date: Mon, 29 Mar 2010 23:11:49 -0700

yeah, i understand :) if classic99 worked in Wine I wouldn't even suggest :)

On Mon, Mar 29, 2010 at 10:44 PM, Tursi <[email-masked]> wrote:
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>
>