Subject: New A.L. Sound converter!!!

From: Owen Brand <[email-masked]>
Date: Wed, 10 Feb 2010 09:19:48 -0500

Spent the majority of the day yesterday working on a new tool to  
convert XB "CALL SOUNDs" to AL format to be CALL LOADed. With some  
learning pains and with some marvellous help from Tursi, I was able to  
complete the program in a day.
I had a soundlist in XB, Tursi wrote me a little tutorial on how to  
convert it by hand, and Mark Wills inspired me to write a converter  
tool. It started as just a little text input and output and grew from  
there. Now it is done for the most part (it does the job) but it has a  
couple little bugs, for instance--it is not safeguarded against user  
error.... If you don't input the info correctly and receive an ERROR,  
you will have to reatart the program.... But it's pretty fast. As this  
is the BETA release, I am hoping some of you would be willing to give  
me some debug ideas. Feel free to suggest changes, whatnot. Version  
1BETA (the current version) supports 1 CALL SOUND at a time, and  
copies directly to the CLIP in Classic99. This version is primary for  
emulation, as I have not implemented DV80 DSK support yet for saving  
your assembly BYTE list. It WILL run on a real TI, but you would have  
to write the converted values down, as they can not yet be saved to  
DSK. I would love some suggestions for V1.1, which I intend to release  
at the Faire as part of a special package I'm working on. Here are the  
planned upgrades for the next version...

1) Added DSK support
2) Ability to convert multiple CALL SOUNDs At once
3) "Import" function.... Load a pre-saved XB MERGE file into the  
program and it will kick out the info automatically.
4) a complete automation of the AL implementation. I want the next  
version to not just give you the BYTEs, but to write a complete  
sourcefile and save it to DV80 format.

As of now, it's a bit tedious to type all the fields in by hand, but  
it is MUCH MUCH faster than doing it by hand. .  Thanks to Tursi again  
for being a teacher and to Mark Wills for inspiring this program.

I hope some of you XBers can get some use out of this. I am in the  
process of writing the short "How To" manual for using the program and  
how to convert the output BYTEs into an assembly sourcefile.

Within the next hour, I will post the zipfile containing the program  
HERE.... Feel free to DL it and report back to me.  :)
http://www.atariage.com/forums/topic/157933-al-sound-converter/

Owen Brand
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 10 Feb 2010 09:50:12 -0500

Program is now uploaded.  This will run on any emulator, or the TI.   
If you are using a newer version of Classic99, it saves you a step by  
copying the output BYTEs to the CLIP.  Click this link, DL it, and  
have some good Conversion fun!!!

Owen Brand
Opry99er.com

On Feb 10, 2010, at 9:19 AM, Owen Brand <[email-masked]> wrote:

> learning pains and with some marvellous help from Tursi, I was able  
> to complete the program in a day.
> tool. It started as just a little text input and output and grew  
> from there. Now it is done for the most part (it does the job) but  
> it has a couple little bugs, for instance--it is not safeguarded  
> against user error.... If you don't input the info correctly and  
> receive an ERROR, you will have to reatart the program.... But it's  
> pretty fast. As this is the BETA release, I am hoping some of you  
> would be willing to give me some debug ideas. Feel free to suggest  
> changes, whatnot. Version 1BETA (the current version) supports 1  
> CALL SOUND at a time, and copies directly to the CLIP in Classic99.  
> This version is primary for emulation, as I have not implemented  
> DV80 DSK support yet for saving your assembly BYTE list. It WILL run  
> on a real TI, but you would have to write the converted values down,  
> as they can not yet be saved to DSK. I would love some suggestions  
> for V1.1, which I intend to release at the Faire as part of a  
> special package I'm working on. Here are the planned upgrades for  
> the next version...
>
> 1) Added DSK support
> it is MUCH MUCH faster than doing it by hand. .  Thanks to Tursi  
> again for being a teacher and to Mark Wills for inspiring this  
> program.
>
> process of writing the short "How To" manual for using the program  
> and how to convert the output BYTEs into an assembly sourcefile.
>

---

From: ti99_forever <[email-masked]>
Date: Wed, 10 Feb 2010 10:01:29 -0800 (PST)

Anybody bother to look at the tool I programmed years ago, for XB, on whtech under my directory?

Just saying - feel free to reinvent the wheel, but check out the wheels out there already...

--- On Wed, 2/10/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: [TI994A] New A.L. Sound converter!!!
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Wednesday, February 10, 2010, 9:19 AM

Spent the majority of the day yesterday working on a new tool to convert XB "CALL SOUNDs" to AL format to be CALL LOADed. With some learning pains and with some marvellous help from Tursi, I was able to complete the program in a day. 
I had a soundlist in XB, Tursi wrote me a little tutorial on how to convert it by hand, and Mark Wills inspired me to write a converter tool. It started as just a little text input and output and grew from there. Now it is done for the most part (it does the job) but it has a couple little bugs, for instance--it is not safeguarded against user error.... If you don't input the info correctly and receive an ERROR, you will have to reatart the program.... But it's pretty fast. As this is the BETA release, I am hoping some of you would be willing to give me some debug ideas. Feel free to suggest changes, whatnot. Version 1BETA (the current version) supports 1 CALL SOUND at a time, and copies directly to the CLIP in Classic99. This version is primary for emulation, as I have not implemented DV80 DSK support yet for saving your assembly BYTE list. It WILL run on a real TI, but you would have to write the converted values down, as they can not yet be saved to
 DSK. I would love some suggestions for V1.1, which I intend to release at the Faire as part of a special package I'm working on. Here are the planned upgrades for the next version...

1) Added DSK support
2) Ability to convert multiple CALL SOUNDs At once
3) "Import" function.... Load a pre-saved XB MERGE file into the program and it will kick out the info automatically.
4) a complete automation of the AL implementation. I want the next version to not just give you the BYTEs, but to write a complete sourcefile and save it to DV80 format. 

As of now, it's a bit tedious to type all the fields in by hand, but it is MUCH MUCH faster than doing it by hand. .  Thanks to Tursi again for being a teacher and to Mark Wills for inspiring this program. 

I hope some of you XBers can get some use out of this. I am in the process of writing the short "How To" manual for using the program and how to convert the output BYTEs into an assembly sourcefile. 

Within the next hour, I will post the zipfile containing the program HERE.... Feel free to DL it and report back to me.  :)http://www.atariage.com/forums/topic/157933-al-sound-converter/

Owen BrandOpry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 10 Feb 2010 13:12:52 -0500

Maybe if there were a whtech directory.... But no, I didn't.  Never  
heard of your program... But I will certainly take a look now.

Owen Brand
Opry99er.com

---

From: "killroy732000" <[email-masked]>
Date: Thu, 11 Feb 2010 12:25:49 -0000

Could have used your program back while I was working on the Pitfall sounds. I started with the demo program that was included in the Lotrup book and converted it to an excel spreadsheet. 

I think the main problem is that a lot of great software is burried away inside some disk images residing on whtech.

The problem is to find it when you need it.

Too bad we don't have a software collection database reachable from
the web (e.g. with screen shots, category, author). 

Filip

--- In [email-masked], ti99_forever <ti99_forever@...> wrote:
> --- On Wed, 2/10/10, Owen Brand <owenbrand@...> wrote:
> 
> From: Owen Brand <owenbrand@...>

---

From: mark wills <[email-masked]>
Date: Thu, 11 Feb 2010 04:32:01 -0800 (PST)

Ahem... Planet-99.net is fully searchable ;-)

Just got to upload the stuff and make sure you give a good description. The search routine will do the rest. Gotta love SQL...