Subject: Help Tony etal...

From: "Marc H" <[email-masked]>
Date: Mon, 22 Mar 2010 23:41:53 -0000

Tony,

I think it was either you or Ben who helped me out last time I asked this question...  If you or Ben don't mind....  What format are program files stored in (more specifically TIA files.)  This info would be appreciated and I'll store it this time ;-)

Marcus...

---

From: mark wills <[email-masked]>
Date: Mon, 22 Mar 2010 16:52:17 -0700 (PDT)

They're not in any format per-se, they are simply a raw memory dump, in 8K chunks.

A six byte header at the top of the file depicts:

* word 0=eof file indicator (0=no more files to load)
* word 1=length of data in bytes
* word 2=destination address in cpu ram

Attached is a program image loader I did ages ago. It was later improved by our Tursi.

View with Notepad++ and the TMS9900 syntax hilighting if you can ;-)

Mark

----- Original Message ----
> From: Marc H <[email-masked]>
> To: [email-masked]
> Sent: Mon, 22 March, 2010 23:41:53
> Subject: [TI994A] Help Tony etal...
> 
> Tony,

I think it was either you or Ben who helped me out last time I 
> asked this question...  If you or Ben don't mind....  What format are 
> program files stored in (more specifically TIA files.)  This info would be 
> appreciated and I'll store it this time 
> ;-)

Marcus...

------------------------------------

Yahoo! 
> Groups Links

>   
> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/