Subject: .bin?

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 10:59:35 -0500

How do I take a .bin and unarchive it?  I have ARC303G, but it  
apparently doesn't Open these files.  I know it's something simple---  
I'll probably feel like a jackass once I'm properly informed....

Owen Brand
**Oprysoft**
Opry99er.com

---

From: fdos <[email-masked]>
Date: Sat, 30 Jan 2010 09:07:28 -0700

Owen,

The .bin files are usually TI-99/4(A) cartridge dumps used by emulators.

Bill S

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 11:14:47 -0500

Well, this .bin is a XB game called Missile Defense.  MISDEF_ARC.BIN

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 30, 2010, at 11:07 AM, fdos <[email-masked]> wrote:

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: fdos <[email-masked]>
Date: Sat, 30 Jan 2010 09:33:10 -0700

I did say "usually".  Per the name we would be led to believe that an 
archived file is contained in the .bin file, so I don't know what this 
should mean.  Can you catalog it with TI99dir or TI99-PC?  If not maybe 
it's an archive of a TI XB program in PC format without a TI files 
header, so maybe it can be ported to the TI as a DF 128 file, and then 
extracted using ARCHIVER.  Otherwise, I have absolutely no idea.

Sorry.

Bill S

Owen Brand wrote:
> On Jan 30, 2010, at 11:07 AM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  > Owen,
>  >

---

From: Gregory McGill <[email-masked]>
Date: Sat, 30 Jan 2010 08:42:44 -0800

Hmm open the file in say notepad and look at the first few bytes

If you see
TIFILES it's a TI file (ark or otherwise)

if you don't it's probably a peecee binary

G

On Sat, Jan 30, 2010 at 8:14 AM, Owen Brand <[email-masked]> wrote:

> On Jan 30, 2010, at 11:07 AM, fdos <[email-masked]<fdosbrs%40frontiernet.net>>
> wrote:
>
> > Owen,
> >

---

From: "Jacques Groslouis" <[email-masked]>
Date: Sat, 30 Jan 2010 12:40:36 -0400

Owen,

I have found that .bin files could be just about anything. Examine the .bin 
file with TI99DIR and that should give you some clue. It may turn out to be 
no different that a PC file with a .ARC or .ARK extension. Then you should 
be able to extract the file. If you are doing the extracting on an emulator 
you might have to ensure that it has a TIFILES header. I have never used 
ARCHIVER with an emulator because I always transfer files to my TI-99/4A 
before doing so.

Jacques

---

From: Owen Brand <[email-masked]>
Date: Sat, 30 Jan 2010 11:49:03 -0500

Excellent... I'll get back with you guys when I get home this evening.  
Got several things TI related to finish this weekend, so this will  
fall right in there.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: Barry Peterson <[email-masked]>
Date: Sat, 30 Jan 2010 16:26:06 -0600

On Sat, Jan 30, 2010 at 9:59 AM, Owen Brand <[email-masked]> wrote:

>
>
> How do I take a .bin and unarchive it?
>

Unfortunately there's no standard for file extensions in the TI community,
unfortunately.

(And I suspect that it's far too late now)

---

From: "Michael Zapf" <[email-masked]>
Date: Sat, 30 Jan 2010 23:02:43 -0000

> (And I suspect that it's far too late now)

Is it? We are a living community. At least we could agree on extensions for new files. 

I remember I suggested to discuss file name extensions some time ago, i.e. to mark TIFILES files by ".tifile" (or short ".tfi", but this did not find too much support). 

Michael

---

From: ti99_forever <[email-masked]>
Date: Sat, 30 Jan 2010 15:23:06 -0800 (PST)

Before we were all on PCs, many of us used extensions or pre-pensions to tell what a file was.

I remember being one of the first to use "@" for an archive: "@files". All the archives would show up at the beginning of a catalog.

But with a 10 character limitation, you had issues. /txt took 4 characters, _P left you with 8 (which was good at the time DOS was limited to 8 anyway), etc.

Do I care now? I'd say the milk was already spilt. We can't even get Ernie to organize WHT, what would he say if we tasked him with researching each file type and renaming them to the proper extension?

(big wide GRIN @ Ernie) ;)

--- On Sat, 1/30/10, Michael Zapf <[email-masked]> wrote:

> From: Michael Zapf <[email-masked]>
> Subject: [TI994A] Re: .bin?
> To: [email-masked]
> Date: Saturday, January 30, 2010, 6:02 PM
>  
> I remember I suggested to discuss file name extensions some
> time ago, i.e. to mark TIFILES files by ".tifile" (or short
> ".tfi", but this did not find too much support). 
> 
> Michael
> 
> 
> 
>     [email-masked]
> 
> 
>

---

From: "epergrem" <[email-masked]>
Date: Sun, 31 Jan 2010 00:23:20 -0000

Ah... that would be a NFW good buddy.. ;-)

Ernie

---

From: Gregory McGill <[email-masked]>
Date: Sat, 30 Jan 2010 16:47:07 -0800

Yes it's difficult on the 4/a esp.. since your limited in chars. I tried [A
on archives on there..

pc's i do .ark since .arc is a pc format archive

Greg

On Sat, Jan 30, 2010 at 2:26 PM, Barry Peterson <[email-masked]>wrote:

>
>
> On Sat, Jan 30, 2010 at 9:59 AM, Owen Brand <[email-masked]>wrote:
>
>>
>>

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 31 Jan 2010 14:38:51 -0000

> pc's i do .ark since .arc is a pc format archive

But normally this should not clash as the "outer format" of TI files on a PC should be TIFILES. So, a proper naming could be 

- myarchive.arc.tifile 
- myarchive.arc.tfi 
- myarch_arc.tfi

(similar like *.tar.gz; this is a gzipped tar file)

Regardless of how you rename them at your local site, we could have this scheme for storing files on a server.

Michael

---

From: Owen Brand <[email-masked]>
Date: Sun, 31 Jan 2010 11:10:14 -0500

On the .bin file I was talking about, I simply removed the extension  
".bin, replaced the "underscore" with a "." and BOOM...  
Unarchivable .arc file.

Was: MISDEF_ARC.bin
Now: MISDEF.ARC

Thanks for the help guys.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 31, 2010, at 9:38 AM, "Michael Zapf" <[email-masked]>  
wrote:

> But normally this should not clash as the "outer format" of TI files  
> on a PC should be TIFILES. So, a proper naming could be
>
> - myarchive.arc.tifile
> - myarchive.arc.tfi
> - myarch_arc.tfi
>
> Regardless of how you rename them at your local site, we could have  
> this scheme for storing files on a server.
>
> Michael
>
>

---

From: Owen Brand <[email-masked]>
Date: Sun, 31 Jan 2010 11:41:43 -0500

I am considering just that for my site.  I just started my DL Library  
on Opry99er, and I am trying to decide on a uniform format for all the  
files in it.  There is also a project I have in the works which will  
require a great deal of files, and therefore a great deal of  
organization as well.  For my download site, I am still trying to  
figure out the best and most acceptable format extensions....  
Obviously it won't matter to some of us who know precisely what to do  
with all the files we come across, but my objective is to make a table  
of existing file formats and extensions and break them down into just  
a few uniform ones.  It will not affect the usefulness or  
accessibility for the majority of us, but it will make it all a bit  
more understandable for a newcomer or a beginning programmer.  That  
being said, I am considering the following extensions for the site::

"Test"--- any executable BASIC or XB program
"Test.arc.tfi"---any TIFILES archive
"Test.tfi.zip"---any zipfile containing TI related files
       *.arc archives
       *BASIC or XB executables
       *any TI documentation (txt, etc)
"Test.cs1.tfi"---audio data for CS1

This is just a start.... But I will have to get real organized real  
fast here in the next month.... Any thoughts you guys/gals may have  
would be greatly appreciated.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: Gregory McGill <[email-masked]>
Date: Sun, 31 Jan 2010 08:45:57 -0800

Yeah my standard was in the 8.3 days..

I still have systems that require that so i use it for that..

On Sun, Jan 31, 2010 at 6:38 AM, Michael Zapf <[email-masked]> wrote:

>
>
>
>
> --- In [email-masked] <TI994A%40yahoogroups.com>, Gregory McGill
> <arcadeshopper@...> wrote:
> >
> But normally this should not clash as the "outer format" of TI files on a
> PC should be TIFILES. So, a proper naming could be
>
> - myarchive.arc.tifile
> - myarchive.arc.tfi
> - myarch_arc.tfi
>