Subject: Dumb question

From: Owen Brand <[email-masked]>
Date: Wed, 27 Jan 2010 13:43:52 -0500

I'm sure this is the simplest question you have heard all week... But  
I have tried every solution and this group is my last hope.

I am in the final stages of implementing my full game screen for  
"Honeycomb Rapture" and I have run against a snag.... I was forced to  
call my screen yellow because the flowers that I drew negated my  
canola field pattern. So I erased the canola screen pattern and called  
my screen yellow. Then to draw the sky (blue) I used a call HCHAR 
(1,1,136,224). However, in displaying my level lives and score on rows  
1,2, and 3, the blue sky following any displayed character turned  
yellow (the color of the screen). I have tried the following trouble  
shooting methods:
1. Changed character set color for all capital letters and numbers to  
(2,e)
2. I tried moving the scores down to the bottom left screen, but that  
erased a portion of my flower bed.
3. Tried calling screen (8) and call HCHAR for the canola field but  
ended up with the same problem I started with.

I know there is a fix for this, but I can't seem to figure it out  
right now. If anyone has any suggestions or wants to view the code,  
please let me know.
Thanks.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: ti99_forever <[email-masked]>
Date: Wed, 27 Jan 2010 10:48:43 -0800 (PST)

Are you using DISPLAY AT?

If so, end what you are printing with a trailing semicolon or use the SIZE argument to define the size of your print area.

--- On Wed, 1/27/10, Owen Brand <[email-masked]> wrote:

> From: Owen Brand <[email-masked]>
> Subject: [TI994A] Dumb question
> To: "[email-masked]" <[email-masked]>
> Date: Wednesday, January 27, 2010, 1:43 PM
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: Owen Brand <[email-masked]>
Date: Wed, 27 Jan 2010 13:56:18 -0500

Well that's f**king easy!! And yes, I am using "DISPLAY AT" function.  
So, adding a trailing semicolon after my closed parenthesis will fix  
the problem, eh?

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 27, 2010, at 1:48 PM, ti99_forever <[email-masked]>  
wrote:

> If so, end what you are printing with a trailing semicolon or use  
> the SIZE argument to define the size of your print area.
>

---

From: Owen Brand <[email-masked]>
Date: Wed, 27 Jan 2010 13:58:44 -0500

Sorry for language.... Thought I was writing to Ben directly.

Owen Brand
**Oprysoft**
Opry99er.com

---

From: ti99_forever <[email-masked]>
Date: Wed, 27 Jan 2010 12:10:15 -0800 (PST)

A trailing semicolon after your print list (directly after the last print item).
DISPLAY AT(10,1):"THIS IS WHAT I MEAN"; ! <- trailing semicolon
Without that trailing semicolon, XB clears out the rest of the row, replacing the characters with the SPACE character.

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Dumb question
To: "[email-masked]" <[email-masked]>
Date: Wednesday, January 27, 2010, 1:56 PM

Well that's f**king easy!! And yes, I am using "DISPLAY AT" function. So, adding a trailing semicolon after my closed parenthesis will fix the problem, eh? 

Owen Brand**Oprysoft**Opry99er.com
On Jan 27, 2010, at 1:48 PM, ti99_forever <[email-masked]> wrote:

    

--- On Wed, 1/27/10, Owen Brand <owenbrand@opry99er. com> wrote:

> From: Owen Brand <owenbrand@opry99er. com>

> To: "TI994A@yahoogroups. com" <TI994A@yahoogroups. com>

> I'm sure this is the simplest

> question you have heard all week... But  

> I have tried every solution and this group is my last

> hope.

> I am in the final stages of implementing my full game

> screen for  

> "Honeycomb Rapture" and I have run against a snag.... I was

> forced to  

> call my screen yellow because the flowers that I drew

> negated my  

> canola field pattern. So I erased the canola screen pattern

> and called  

> my screen yellow. Then to draw the sky (blue) I used a call

> HCHAR 

> (1,1,136,224) . However, in displaying my level lives and

> score on rows  

> 1,2, and 3, the blue sky following any displayed character

> turned  

> yellow (the color of the screen). I have tried the

> following trouble  

> 1. Changed character set color for all capital letters and

> numbers to  

> 2. I tried moving the scores down to the bottom left

> screen, but that  

> 3. Tried calling screen (8) and call HCHAR for the canola

> field but  

> I know there is a fix for this, but I can't seem to figure

> it out  

> right now. If anyone has any suggestions or wants to view

> the code,  

> ------------ --------- --------- ------

>     TI994A-fullfeatured @yahoogroups. com

---

From: Owen Brand <[email-masked]>
Date: Wed, 27 Jan 2010 15:19:01 -0500

Well..... That is perfect....  Thanks boss.  :). I'll have screenshots  
up and available on my site later today.

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 27, 2010, at 3:10 PM, ti99_forever <[email-masked]>  
wrote:

> Without that trailing semicolon, XB clears out the rest of the row,  
> replacing the characters with the SPACE character.
>
> Well that's f**king easy!! And yes, I am using "DISPLAY AT"  
> function. So, adding a trailing semicolon after my closed  
> parenthesis will fix the problem, eh?
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>