Subject: Re: [TI994A] MBX games

From: jerome norman <[email-masked]>
Date: Wed, 20 Jan 2010 10:40:50 -0800 (PST)

that,s correct you hit on the head as i once remembered going over some wht papers and specs from other system using code like it ;yes it uses not only the cru scan control but some code built into the ti994/A only {4A} the older one doesn't have it TI was somewhat ahead of its time. i don't know where my papers are but will look and will send them to you guys or upload to site.

--- On Wed, 1/20/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] MBX games
To: "[email-masked]" <[email-masked]>
Date: Wednesday, January 20, 2010, 9:07 AM

Here's a question---" Will regular TI games work using the MBX joystick, or are the MBX carts equipped with special code to access it?". 

I ask because if you CAN play regular games via the MBX system, it shouldn't be too difficult to decipher the interface.  AL programs could potentially be written that would allow for these specific commands.  Also, the extra keyboard would allow for alot of flexibility to programmers.  Just a thought..... And like Keith said--/ there is a very limited number of MBX systems in use right now, so at this point, it is all conjecture.  :). Just curious.

Owen Brand 
**Oprysoft**
Opry99er.com

On Jan 20, 2010, at 9:46 AM, Marc Hull <marc.hull@sbcglobal .net> wrote:

I had to replace the VR and buffers in my MBX a couple of weeks ago and while it was open I did a bit of looking around and research...  It appears (important word...)  that the only function of the MBX console itself is to record sound data (from the mic and the joyport, play back said sound (through the MBX speaker NOT the TI ), convert the analog joystick to normal digital inputs and MUX that input with the MBX keyboard input (sending same to the TI.)  Apparently most of the work is still done in the TI and the code contained in the carts  I am guessing that all TI to MBX communication is done via pulsing the common wire in the joystick port.  MBX  to TI communication is done by a CRU scanning routine contained in the cart.   Anybody confirm that? 

--- On Wed, 1/20/10, Keith Bergman <[email-masked]> wrote:

From: Keith Bergman <[email-masked]>
Subject: Re: [TI994A] MBX games
To: TI994A@yahoogroups. com
Date: Wednesday, January 20, 2010, 8:25 AM

Not to hijack your topic, Owen, but does anyone know of any third-party A.D. (after discontinuation) development on the MBX?  It seems like such a case of wasted potential.  I realize the audience for any new projects would be limited, but it seems like someone has to have gotten curious and tried to program the thing themselves, at some point.

On Wed, Jan 20, 2010 at 9:23 AM, Owen Brand <owenbrand@opry99er. com> wrote:

Here's the other question then.... Anyone have any MBX games/overlays or just games or just overlays they'd like to sell?  :)

Owen Brand 
**Oprysoft**
Opry99er.com

On Jan 20, 2010, at 7:29 AM, "Ksarul" <vze23g4a@verizon. net> wrote:

Baseball, Honey Hunt, Soundtrack Trolley, and I’m Hiding.
 
Jim

From: TI994A@yahoogroups. com [mailto:TI994A@yahoogroups. com] On Behalf Of Owen Brand
Sent: Tuesday, January 19, 2010 10:39 PM
To: TI994A@yahoogroups. com
Subject: [TI994A] MBX games

Hey all... Anyone know which MBX games came with overlays for the 
"keyboard"? If I buy a game that requires the overlay, I want to make 
sure it comes with....

Owen Brand
**Oprysoft**
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 20 Jan 2010 13:56:47 -0500

That's great!  Thanks for helpin out!!!

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 20, 2010, at 1:40 PM, jerome norman <[email-masked]>  
wrote:

>
> that,s correct you hit on the head as i once remembered going over  
> some wht papers and specs from other system using code like it ;yes  
> it uses not only the cru scan control but some code built into the  
> ti994/A only {4A} the older one doesn't have it TI was somewhat  
> ahead of its time. i don't know where my papers are but will look  
> and will send them to you guys or upload to site.
>
> Here's a question---" Will regular TI games work using the MBX  
> joystick, or are the MBX carts equipped with special code to access  
> it?".
>
> I ask because if you CAN play regular games via the MBX system, it  
> shouldn't be too difficult to decipher the interface.  AL programs  
> could potentially be written that would allow for these specific  
> commands.  Also, the extra keyboard would allow for alot of  
> flexibility to programmers.  Just a thought..... And like Keith  
> said--/ there is a very limited number of MBX systems in use right  
> now, so at this point, it is all conjecture.  :). Just curious.
>
> Owen Brand
> **Oprysoft**
> Opry99er.com
>
>> I had to replace the VR and buffers in my MBX a couple of weeks ago  
>> and while it was open I did a bit of looking around and  
>> research...  It appears (important word...)  that the only function  
>> of the MBX console itself is to record sound data (from the mic and  
>> the joyport, play back said sound (through the MBX speaker NOT the  
>> TI ), convert the analog joystick to normal digital inputs and MUX  
>> that input with the MBX keyboard input (sending same to the TI.)   
>> Apparently most of the work is still done in the TI and the code  
>> contained in the carts  I am guessing that all TI to MBX  
>> communication is done via pulsing the common wire in the joystick  
>> port.  MBX  to TI communication is done by a CRU scanning routine  
>> contained in the cart.   Anybody confirm that?
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> Not to hijack your topic, Owen, but does anyone know of any third- 
>> party A.D. (after discontinuation) development on the MBX?  It  
>> seems like such a case of wasted potential.  I realize the audience  
>> for any new projects would be limited, but it seems like someone  
>> has to have gotten curious and tried to program the thing  
>> themselves, at some point.
>>
>>
>>
>>
>> Here's the other question then.... Anyone have any MBX games/ 
>> overlays or just games or just overlays they'd like to sell?  :)
>>
>> Owen Brand
>> **Oprysoft**
>> Opry99er.com
>>