Subject: console BASIC and Classic99 question

From: Keith Bergman <[email-masked]>
Date: Sun, 24 Jan 2010 15:56:42 -0500

There are a couple TI games made in console BASIC which, to fit into the
existing memory space, loaded data from side B of the tape after the main
program code was loaded.  The two I'm thinking of specifically are Hordes
(Not-Polyoptics) and Atlantis, a UK game I found from a company called
Intrigue Software.

I'd like to save both of these games from dying off when my tapes eventually
disintegrate, and of course I'd love to play them without spending 10
minutes loading each one (Atlantis takes at least that long to load and
initialize).

My idea was to load them, save the main program to my CF drive, then
retrieve the data files by figuring out what's in them based on the BASIC
listings of each program, and creating a disk file with that data instead.
Modify the game code to load from disk instead of tape, and...

If I did all that, would I still be stymied in Classic99 by the 16K limit,
or is there a way around that for a game written in TI BASIC?

Apologies if this is an obvious answer, I've literally been using Classic99
for less than a week.  I finally got off my "real hardware or nothing" high
horse when I wanted to post some screenshots of my game in progress.  :)

Keith

---

From: tursi <[email-masked]>
Date: Sun, 24 Jan 2010 13:45:58 -0800 (PST)

> If I did all that, would I still be stymied in Classic99 by
> the 16K limit, or is there a way around that for a game
> written in TI BASIC?

classic99 can't do too much for you in its current form, but it should be 
possible to copy the files to disk files and modify the game to load from 
disk without too much trouble.

whenever i get around to save states, you could use thse to bypass the 
startup time, but that's a low priority for Classic99 (but doesn't MESS 
support them alreaddy?)

---

From: Keith Bergman <[email-masked]>
Date: Sun, 24 Jan 2010 16:48:42 -0500

I just tried to at least load the game in with CF attached, and got a MEMORY
FULL when it tried to load its data in.

I'll be able to save it, and figure out what's in the data file on side B to
salvage that data, but I won't be able to run it, as TI BASIC can't use
extra memory and XB can't use the extra character sets 15 and 16.

I need to find that BXB program and see if it'll work to allow me to run the
game in XB... Bill Gaskill and I talked about it ages ago but I don't recall
if I ever actually found the program or not.

---

From: ti99_forever <[email-masked]>
Date: Sun, 24 Jan 2010 13:59:41 -0800 (PST)

ftp://ftp.whtech.com/9640news/CAT37/BXB.ARK 

--- On Sun, 1/24/10, Keith Bergman <[email-masked]> wrote:

From: Keith Bergman <[email-masked]>
Subject: Re: [TI994A] console BASIC and Classic99 question
To: [email-masked]
Date: Sunday, January 24, 2010, 4:48 PM

 

I just tried to at least load the game in with CF attached, and got a MEMORY FULL when it tried to load its data in.
 
I'll be able to save it, and figure out what's in the data file on side B to salvage that data, but I won't be able to run it, as TI BASIC can't use extra memory and XB can't use the extra character sets 15 and 16.

I need to find that BXB program and see if it'll work to allow me to run the game in XB... Bill Gaskill and I talked about it ages ago but I don't recall if I ever actually found the program or not.

  

support them alreaddy?)

---

From: ti99_forever <[email-masked]>
Date: Sun, 24 Jan 2010 14:05:15 -0800 (PST)

The hard part is getting it in XB, it has less VDP memory available. You tried a CALL FILES(1)?

Would you be happy using Win994a's cassette emulation? I don't know if there is a conversion available or not.
A Horizon Ramdisk makes it easier. You can turn off the disk controller card with a poke, load it, and then save the program to the Ramdisk. Or once you get it loaded, turn on the controller again, either with the poke or combination with a CALL FILES(3) to force it to save it in INT/VAR 254 format.
As for preserving your tape, have you thought of loading it onto an mp3 player? I've heard some that have had positive results with that.
--- On Sun, 1/24/10, Keith Bergman <[email-masked]> wrote:

        

 

 

support them alreaddy?)

---

From: tursi <[email-masked]>
Date: Sun, 24 Jan 2010 14:32:06 -0800 (PST)

>       I just tried to at least load the game in with CF attached, and got a MEMORY FULL when it tried to load its data

Ooh.. I see what you're saying. Yes, it should run in Classic99 since 
Classic99 doesn't allocate VDP RAM for the disk controller (ie: it has the 
same amount of VDP memory as with cassette). I would find it interesting 
to help reduce the memory requirements to make it run with the disk 
system, if you'd like help. :)

---

From: Keith Bergman <[email-masked]>
Date: Sun, 24 Jan 2010 17:47:44 -0500

I'd love the help.  I may not have time till tomorrow, but I will try to at
least get the program SAVEd to CF, and get the data from the data file,
tomorrow.  When I get that far, I'll post the program listing and the data
file, and see what we need to do from there.

On Sun, Jan 24, 2010 at 5:32 PM, tursi <[email-masked]> wrote:

>
>
> > I just tried to at least load the game in with CF attached, and got a
> MEMORY FULL when it tried to load its data
> > in.
>

---

From: ti99_forever <[email-masked]>
Date: Sun, 24 Jan 2010 20:09:28 -0800 (PST)

Run the old "Fastass Program Compressor" on it, eh? Or Shrink? Or both?

Modified those two programs, so Shrink read from DSK1.1 output to DSK1.2 then FPC read from DSK1.2 and output to DSK1.3... so I could run them in sequence.

--- On Sun, 1/24/10, tursi <[email-masked]> wrote:

> From: tursi <[email-masked]>
> Date: Sunday, January 24, 2010, 5:32 PM
> >       I
> just tried to at least load the game in with CF attached,
> and got a MEMORY FULL when it tried to load its data
> >       in.
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: ti99_forever <[email-masked]>
Date: Sun, 24 Jan 2010 23:36:36 -0800 (PST)

Another tool on the "real thing" - I have an assembly program that runs in TI Basic (requires EA or Minimem) that will save your Basic program in Merge format...

Once saved, you can Merge it into XB with memory expansion (or run it through the programs I mentioned).

Just go have a picnic while the merge is running. Almost forgot about that little gem!

--- On Sun, 1/24/10, ti99_forever <[email-masked]> wrote:

> From: ti99_forever <[email-masked]>
> Date: Sunday, January 24, 2010, 11:09 PM
> Run the old "Fastass Program
> Compressor" on it, eh? Or Shrink? Or both?
> 
> Modified those two programs, so Shrink read from DSK1.1
> output to DSK1.2 then FPC read from DSK1.2 and output to
> DSK1.3... so I could run them in sequence.
> 
> > Classic99 doesn't allocate VDP RAM for the disk
> controller
> > (ie: it has the 
> > same amount of VDP memory as with cassette). I would
> find
> > it interesting 
> > to help reduce the memory requirements to make it run
> with
> > the disk

---

From: fdos <[email-masked]>
Date: Mon, 25 Jan 2010 07:46:23 -0700

Ben,

Where do I find this gem?  I've gone through this thread very fast 
(still in process for that matter), so I'll have to back track to learn 
about the other programs you mentioned here.

Bill S

ti99_forever wrote:
>  
> 
> Another tool on the "real thing" - I have an assembly program that runs 
> in TI Basic (requires EA or Minimem) that will save your Basic program 
> in Merge format...
> 
> --- On Sun, 1/24/10, ti99_forever <[email-masked] 
> <mailto:ti99_forever%40yahoo.com>> wrote:
> 
>  > From: ti99_forever <[email-masked] 
> <mailto:ti99_forever%40yahoo.com>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > --- On Sun, 1/24/10, tursi <[email-masked] 
> <mailto:yahoogroup%40harmlesslion.com>>
>  > wrote:
>  >
>  > > From: tursi <[email-masked] 
> <mailto:yahoogroup%40harmlesslion.com>>
>  > > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
> <mailto:TI994A-fullfeatured%40yahoogroups.com>
>  > >
>  > >
>  > >
>  >
>  >
>  >      
>  >
>  >
>  >
> <mailto:TI994A-fullfeatured%40yahoogroups.com>
>  >
>  >
>  >
> 
>

---

From: ti99_forever <[email-masked]>
Date: Mon, 25 Jan 2010 06:52:08 -0800 (PST)

Oh, it came as a tool with another program... Guess I will have to "dig it out" and put it somewhere! Could be quite useful in this type situations!

--- On Mon, 1/25/10, fdos <[email-masked]> wrote:

> From: fdos <[email-masked]>
> Date: Monday, January 25, 2010, 9:46 AM
> Ben,
> 
> > Once saved, you can Merge it into XB with memory
> expansion (or run it 
> > through the programs I mentioned).
> > 
> > Just go have a picnic while the merge is running.
> Almost forgot about 
> > that little gem!
> > 
> >  > From: ti99_forever <[email-masked]
> 
> >  > Subject: Re: [TI994A] console BASIC and
> Classic99 question
> >  > To: [email-masked]
> <mailto:TI994A%40yahoogroups.com>
> >  > Date: Sunday, January 24, 2010, 11:09 PM
> >  > Run the old "Fastass Program
> >  > Compressor" on it, eh? Or Shrink? Or both?
> >  >
> >  > Modified those two programs, so Shrink read
> from DSK1.1
> >  > output to DSK1.2 then FPC read from DSK1.2
> and output to
> >  > DSK1.3... so I could run them in sequence.
> >  >
> >  > --- On Sun, 1/24/10, tursi <[email-masked]
> 
> >  > wrote:
> >  >
> >  > > From: tursi <[email-masked]
> 
> >  > > Subject: Re: [TI994A] console BASIC
> and Classic99
> >  > question
> >  > > To: [email-masked]
> <mailto:TI994A%40yahoogroups.com>
> >  > > Date: Sunday, January 24, 2010, 5:32
> PM
> >  > > >       I
> >  > > just tried to at least load the game
> in with CF
> >  > attached,
> >  > > and got a MEMORY FULL when it tried to
> load its data
> >  > > >   
>    in.
> >  > >
> >  > > Ooh.. I see what you're saying. Yes,
> it should run in
> >  > > Classic99 since
> >  > > Classic99 doesn't allocate VDP RAM for
> the disk
> >  > controller
> >  > > (ie: it has the
> >  > > same amount of VDP memory as with
> cassette). I would
> >  > find
> >  > > it interesting
> >  > > to help reduce the memory requirements
> to make it run
> >  > with
> >  > > the disk
> >  > > system, if you'd like help. :)
> >  > >
> >  > >
> >  > >
> >  > > ------------------------------------
> >  > >
> >  > > Yahoo! Groups Links
> >  > >
> >  > >
> >  > >     [email-masked]
> 
> >  > >
> >  > >
> >  > >
> >  >
> >  >
> >  >      
> >  >
> >  >
> >  >
> >  > ------------------------------------
> >  >
> >  > Yahoo! Groups Links
> >  >
> >  >
> >  >     [email-masked]
> 
> >  >
> >  >
> >  >

---

From: Owen Brand <[email-masked]>
Date: Mon, 25 Jan 2010 09:56:48 -0500

Can't you load BASIC programs from the XB cart, RES them and then save  
them as MERGE?  It's one extra step, but it works great.... Perhaps  
I'm missing the point here....  :)

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 25, 2010, at 9:52 AM, ti99_forever <[email-masked]>  
wrote:

> Oh, it came as a tool with another program... Guess I will have to  
> "dig it out" and put it somewhere! Could be quite useful in this  
> type situations!
>
> > >  > > Subject: Re: [TI994A] console BASIC
> > and Classic99
> > >  > question
> > >  > > just tried to at least load the game
> > in with CF
> > >  > attached,
> > >  > > Ooh.. I see what you're saying. Yes,
> > it should run in
> > >  > > Classic99 since

---

From: fdos <[email-masked]>
Date: Mon, 25 Jan 2010 08:39:07 -0700

Owen,

In my case, if it works well I might be enticed to write a CALL 
LINK("MERGE","filename") for TI BASIC+.  It would probably require 
moving all used VDP memory, up to 16K, to memory expansion (might also 
require optional AMS/SAMS) to do it, as a buffer that large probably 
won't be available.  Then adjust the line number table accordingly.  For 
me this would be quite a task, so I might have to con someone else into 
doing it for me--as usual. :-)

Bill S

Owen Brand wrote:
> them as MERGE?  It's one extra step, but it works great.... Perhaps I'm 
> missing the point here....  :)
> 
> Owen Brand
> **Oprysoft**
> Opry99er.com <http://Opry99er.com>
> 
> On Jan 25, 2010, at 9:52 AM, ti99_forever <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>>  
>>
>> "dig it out" and put it somewhere! Could be quite useful in this type 
>> situations!
>>
>> --- On Mon, 1/25/10, fdos <[email-masked] 
>> <mailto:fdosbrs%40frontiernet.net>> wrote:
>>
>> > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>> > > --- On Sun, 1/24/10, ti99_forever <ti99_forever@ 
>> <mailto:ti99_forever%40yahoo.com>yahoo.com <http://yahoo.com>
>> >
>> > >  > From: ti99_forever <ti99_forever@ 
>> <mailto:ti99_forever%40yahoo.com>yahoo.com <http://yahoo.com>
>> >
>> > >  > --- On Sun, 1/24/10, tursi <yahoogroup@harmless 
>> <mailto:yahoogroup%40harmlesslion.com>lion.com <http://lion.com>
>> >
>> > >  > > From: tursi <yahoogroup@harmless 
>> <mailto:yahoogroup%40harmlesslion.com>lion.com <http://lion.com>
>> >

---

From: mark wills <[email-masked]>
Date: Mon, 25 Jan 2010 07:46:23 -0800 (PST)

Is merge format just a 'stream' of the program as it sits in memory, just in DV163 instead of program image? Or is there more to it?

M

----- Original Message ----
> Sent: Mon, 25 January, 2010 16:39:07
> > On Jan 25, 2010, at 9:52 AM, ti99_forever 
> > > wrote:
> > 
> >>  
> >>
> >> --- On Mon, 1/25/10, fdos 
> >> > wrote:
> >>
> >> > From: fdos >
> >> > > --- On Sun, 1/24/10, ti99_forever 
> >> yahoo.com 
> >> >
> >> > > > wrote:
> >> > >
> >> > >  > From: ti99_forever 
> >> yahoo.com 
> >> >
> >> > > >
> >> > >  > --- On Sun, 1/24/10, tursi 
> >> lion.com 
> >> >
> >> > > >
> >> > >  > wrote:
> >> > >  >
> >> > >  > > From: tursi 
> >> lion.com 
> >> >
> >> > > >

---

From: fdos <[email-masked]>
Date: Mon, 25 Jan 2010 08:59:49 -0700

Ben,

I take it that the other two programs are FPC and SHRINK?  How do they work?

Bill S

ti99_forever wrote:
>  
> 
> Oh, it came as a tool with another program... Guess I will have to "dig 
> it out" and put it somewhere! Could be quite useful in this type situations!
> 
> <mailto:ti99_forever%40yahoo.com>
>  >
> <mailto:ti99_forever%40yahoo.com>
>  >
> <mailto:yahoogroup%40harmlesslion.com>
>  >
> <mailto:yahoogroup%40harmlesslion.com>
>  >

---

From: fdos <[email-masked]>
Date: Mon, 25 Jan 2010 09:11:00 -0700

Mark,

I vaguely remember using MERGE once or twice back in the early 1980's, 
but once I got my hands on TI Forth after TI released it to PD, my use 
of XB dwindled to just loading EA5 programs that included an XB EA 
loader.  Which means I don't the answer to your question.

Right now I am using SEB to edit and MERGE files for TI BASIC+ programs, 
as I don't plan to enhance the TI BASIC editing capabilities, so a MERGE 
capability in TI BASIC+ could almost eliminate the need for SEB.

Another idea just came to mind as I was writing this, but I need to go 
do some TI files searching first.

Bill S

mark wills wrote:
>  
> 
> Is merge format just a 'stream' of the program as it sits in memory, 
> just in DV163 instead of program image? Or is there more to it?
> 
> M
>

---

From: Owen Brand <[email-masked]>
Date: Mon, 25 Jan 2010 11:20:54 -0500

I made up a little "MERGE" video on my YouTube channel a year or so  
ago--- video quality sucks.... But it's primarily designed to show new  
users how to merge 2 programs on the real hardware.  It's actually a 2  
part video---

Owen Brand
**Oprysoft**
Opry99er.com

On Jan 25, 2010, at 11:11 AM, fdos <[email-masked]> wrote:

>>>>> type

---

From: fdos <[email-masked]>
Date: Mon, 25 Jan 2010 12:04:09 -0700

The idea I had was in regards to an old program "XLATE" by John Ford. 
The idea is to LIST a TI BASIC or XB program to a disk file, and then to 
use TI Writer, or in my case, an 80 column ED/ASM editor to manipulate 
the DV80 program file using the editing, line move, etc. capabilities of 
these superior editors.  After saving your mods the "XLATE" program 
would convert it to a DV163 MERGE file, which of course, would require 
XB (the "XLATE" program is XB anyway) to merge it into TI BASIC/XB, so 
it can be saved in program image format.

Not so useful if I don't have CALL LINK("MERGE","filename"), and  a TI 
BASIC(+) version of "XLATE".  Something I'll have to ponder the value of 
versus SEB.

Bill S

fdos wrote:
> loader.  Which means I don't know the answer to your question.
>

---

From: ti99_forever <[email-masked]>
Date: Mon, 25 Jan 2010 12:00:41 -0800 (PST)

You will find that XB sometimes cannot load programs that Basic can - less available VDP memory. This would be useful in those cases - and you might suppose they are "edge cases", but I've come across this too many times.
It would work best with a Horizon Ramdisk, where you can turn off the disk controller, save your Basic program as merge, then restart in XB and merge it - as if you just save the Basic program in Program format, it will still be too big without editing it.
Of course you could always use Classic99. I don't remember how much space is available there, so it still may be useful. XB takes up more space because of the graphic tables and sprite motion, plus other memory locations in VDP used by XB.

--- On Mon, 1/25/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] console BASIC and Classic99 question
To: "[email-masked]" <[email-masked]>
Date: Monday, January 25, 2010, 9:56 AM

Can't you load BASIC programs from the XB cart, RES them and then save them as MERGE?  It's one extra step, but it works great.... Perhaps I'm missing the point here....  :)

Owen Brand**Oprysoft**Opry99er.com
On Jan 25, 2010, at 9:52 AM, ti99_forever <[email-masked]> wrote:

    

--- On Mon, 1/25/10, fdos <fdosbrs@frontiernet .net> wrote:

> From: fdos <fdosbrs@frontiernet .net>

> To: TI994A@yahoogroups. com

> Where do I find this gem?  I've gone through this

> thread very fast 

> (still in process for that matter), so I'll have to back

> track to learn 

> > Another tool on the "real thing" - I have an assembly

> program that runs 

> > in TI Basic (requires EA or Minimem) that will save

> your Basic program 

> > <mailto:ti99_ forever%40yahoo. com>> wrote:

> > <mailto:ti99_ forever%40yahoo. com>>

> >  > To: TI994A@yahoogroups. com

> <mailto:TI994A% 40yahoogroups. com>

> > <mailto:yahoogroup% 40harmlesslion. com>>

> > <mailto:yahoogroup% 40harmlesslion. com>>

> >  > > To: TI994A@yahoogroups. com

> <mailto:TI994A% 40yahoogroups. com>

> >  > > ------------ --------- --------- ------

> >  > >     TI994A-fullfeatured @yahoogroups. com

> > <mailto:TI994A- fullfeatured% 40yahoogroups. com>

> >  > ------------ --------- --------- ------

> >  >     TI994A-fullfeatured @yahoogroups. com

> > <mailto:TI994A- fullfeatured% 40yahoogroups. com>

> ------------ --------- --------- ------

>     TI994A-fullfeatured @yahoogroups. com

---

From: ti99_forever <[email-masked]>
Date: Mon, 25 Jan 2010 12:01:30 -0800 (PST)

That is pretty much it, in my understanding.

--- On Mon, 1/25/10, mark wills <[email-masked]> wrote:

> From: mark wills <[email-masked]>
> Date: Monday, January 25, 2010, 10:46 AM
> Is merge format just a 'stream' of
> the program as it sits in memory, just in DV163 instead of
> program image? Or is there more to it?
> 
> M
> 
> 
> 
> 
> > >> > >  > From: ti99_forever 
> > >> > >  > --- On Sun, 1/24/10,
> tursi 
> > >> > >  > > From: tursi 
> > >> > >  > > Yahoo! Groups
> Links

---

From: ti99_forever <[email-masked]>
Date: Mon, 25 Jan 2010 12:03:31 -0800 (PST)

FPC and Shrink are actually from the IUG library.
I just made some small mods to automate the disk filenames it used, and IRC, added "-ass" to the actual name of the program...

--- On Mon, 1/25/10, fdos <[email-masked]> wrote:

> Date: Monday, January 25, 2010, 10:59 AM
> Ben,
> 
> >  > From: fdos <[email-masked]
> <mailto:fdosbrs%40frontiernet.net>>
> >  > Date: Monday, January 25, 2010, 9:46 AM
> >  > Ben,
> >  >
> >  > Where do I find this gem?  I've gone
> through this
> >  > thread very fast
> >  > (still in process for that matter), so I'll
> have to back
> >  > track to learn
> >  > about the other programs you mentioned
> here.
> >  >
> >  > Bill S
> >  >
> >  > ti99_forever wrote:
> >  > > 
> >  > >
> >  > > Another tool on the "real thing" - I
> have an assembly
> >  > program that runs
> >  > > in TI Basic (requires EA or Minimem)
> that will save
> >  > your Basic program
> >  > > in Merge format...
> >  > >
> >  > > Once saved, you can Merge it into XB
> with memory
> >  > expansion (or run it
> >  > > through the programs I mentioned).
> >  > >
> >  > > Just go have a picnic while the merge
> is running.
> >  > Almost forgot about
> >  > > that little gem!
> >  > >
> >  > > --- On Sun, 1/24/10, ti99_forever
> <[email-masked]
> 
> >  > >  > From: ti99_forever <[email-masked]
> 
> >  > >  > Subject: Re: [TI994A]
> console BASIC and
> >  > Classic99 question
> >  > >  > To: [email-masked]
> >  > <mailto:TI994A%40yahoogroups.com>
> >  > >  > Date: Sunday, January 24,
> 2010, 11:09 PM
> >  > >  > Run the old "Fastass
> Program
> >  > >  > Compressor" on it, eh? Or
> Shrink? Or both?
> >  > >  >
> >  > >  > Modified those two
> programs, so Shrink read
> >  > from DSK1.1
> >  > >  > output to DSK1.2 then FPC
> read from DSK1.2
> >  > and output to
> >  > >  > DSK1.3... so I could run
> them in sequence.
> >  > >  >
> >  > >  > --- On Sun, 1/24/10, tursi
> <[email-masked]
> 
> >  > >  > wrote:
> >  > >  > > From: tursi <[email-masked]
> 
> >  > >  > > Subject: Re: [TI994A]
> console BASIC
> >  > and Classic99
> >  > >  > question
> >  > >  > > To: [email-masked]
> >  > <mailto:TI994A%40yahoogroups.com>
> >  > >  > > Date: Sunday, January
> 24, 2010, 5:32
> >  > PM
> >  > >  > > >   
>    I
> >  > >  > > just tried to at least
> load the game
> >  > in with CF
> >  > >  > attached,
> >  > >  > > and got a MEMORY FULL
> when it tried to
> >  > load its data
> >  > >  > >
> >   
> >  >    in.
> >  > >  > >
> >  > >  > > Ooh.. I see what
> you're saying. Yes,
> >  > it should run in
> >  > >  > > Classic99 since
> >  > >  > > Classic99 doesn't
> allocate VDP RAM for
> >  > the disk
> >  > >  > controller
> >  > >  > > (ie: it has the
> >  > >  > > same amount of VDP
> memory as with
> >  > cassette). I would
> >  > >  > find
> >  > >  > > it interesting
> >  > >  > > to help reduce the
> memory requirements
> >  > to make it run
> >  > >  > with
> >  > >  > > the disk
> >  > >  > > system, if you'd like
> help. :)
> >  > >  > >
> >  > >  > >
> >  > >  > >
> >  > >  > >
> >  > >  > >
> >  > >  > > Yahoo! Groups Links
> >  > >  > >
> >  > >  > >
> >  > >  > > 
> >  > >  > >
> >  > >  > >
> >  > >  > >
> >  > >  > Yahoo! Groups Links
> >  > >  >
> >  > >  >
> >  > >  >     [email-masked]
>

---

From: ti99_forever <[email-masked]>
Date: Mon, 25 Jan 2010 12:04:55 -0800 (PST)

Bill,

Sorry to burst you bubble, but this program does the "SAVE DSK1.FILENAME,MERGE" portion, but not the "MERGE DSK1.FILENAME" portion.

So you'd need to use XB to merge it back in anyway.

--- On Mon, 1/25/10, fdos <[email-masked]> wrote:

> Date: Monday, January 25, 2010, 11:11 AM
> Mark,
> 
> >  > Sent: Mon, 25 January, 2010 16:39:07
> >  > Owen,
> >  > In my case, if it works well I might be
> enticed to write a CALL
> >  > LINK("MERGE","filename") for TI BASIC+. It
> would probably require
> >  > moving all used VDP memory, up to 16K, to
> memory expansion (might also
> >  > require optional AMS/SAMS) to do it, as a
> buffer that large probably
> >  > won't be available. Then adjust the line
> number table accordingly. For
> >  > me this would be quite a task, so I might
> have to con someone else into
> >  > doing it for me--as usual. :-)
> >  >
> >  > Bill S
> >  >
> >  > Owen Brand wrote:
> >  > >
> >  > >
> >  > > Can't you load BASIC programs from the
> XB cart, RES them and then save
> >  > > them as MERGE? It's one extra step,
> but it works great.... Perhaps I'm
> >  > > missing the point here.... :)
> >  > >
> >  > > Owen Brand
> >  > > **Oprysoft**
> >  > > Opry99er.com
> >  > >
> >  > > On Jan 25, 2010, at 9:52 AM,
> ti99_forever
> >  > > > wrote:
> >  > >
> >  > >>
> >  > >>
> >  > >> Oh, it came as a tool with another
> program... Guess I will have to
> >  > >> "dig it out" and put it somewhere!
> Could be quite useful in this type
> >  > >> situations!
> >  > >>
> >  > >> --- On Mon, 1/25/10, fdos
> >  > >> > wrote:
> >  > >>
> >  > >> > From: fdos >
> >  > >> > Subject: Re: [TI994A] console
> BASIC and Classic99 question
> >  > >> > To: [email-masked]
> >  > >> > Date: Monday, January 25,
> 2010, 9:46 AM
> >  > >> > Ben,
> >  > >> >
> >  > >> > Where do I find this gem?
> I've gone through this
> >  > >> > thread very fast
> >  > >> > (still in process for that
> matter), so I'll have to back
> >  > >> > track to learn
> >  > >> > about the other programs you
> mentioned here.
> >  > >> >
> >  > >> > Bill S
> >  > >> >
> >  > >> > ti99_forever wrote:
> >  > >> > >
> >  > >> > >
> >  > >> > > Another tool on the
> "real thing" - I have an assembly
> >  > >> > program that runs
> >  > >> > > in TI Basic (requires EA
> or Minimem) that will save
> >  > >> > your Basic program
> >  > >> > > in Merge format...
> >  > >> > >
> >  > >> > > Once saved, you can
> Merge it into XB with memory
> >  > >> > expansion (or run it
> >  > >> > > through the programs I
> mentioned).
> >  > >> > >
> >  > >> > > Just go have a picnic
> while the merge is running.
> >  > >> > Almost forgot about
> >  > >> > > that little gem!
> >  > >> > >
> >  > >> > > --- On Sun, 1/24/10,
> ti99_forever
> >  > >> yahoo.com
> >  > >> >
> >  > >> > > > wrote:
> >  > >> > >
> >  > >> > > > From: ti99_forever
> >  > >> yahoo.com
> >  > >> >
> >  > >> > > >
> >  > >> > > > Subject: Re:
> [TI994A] console BASIC and
> >  > >> > Classic99 question
> >  > >> > > > To: [email-masked]
> >  > >> >
> >  > >> > > > Date: Sunday,
> January 24, 2010, 11:09 PM
> >  > >> > > > Run the old
> "Fastass Program
> >  > >> > > > Compressor" on it,
> eh? Or Shrink? Or both?
> >  > >> > > >
> >  > >> > > > Modified those two
> programs, so Shrink read
> >  > >> > from DSK1.1
> >  > >> > > > output to DSK1.2
> then FPC read from DSK1.2
> >  > >> > and output to
> >  > >> > > > DSK1.3... so I
> could run them in sequence.
> >  > >> > > >
> >  > >> > > > --- On Sun,
> 1/24/10, tursi
> >  > >> lion.com
> >  > >> >
> >  > >> > > >
> >  > >> > > > wrote:
> >  > >> > > >
> >  > >> > > > > From: tursi
> >  > >> lion.com
> >  > >> >
> >  > >> > > >
> >  > >> > > > > Subject: Re:
> [TI994A] console BASIC
> >  > >> > and Classic99
> >  > >> > > > question
> >  > >> > > > > To: [email-masked]
> >  > >> >
> >  > >> > > > > Date: Sunday,
> January 24, 2010, 5:32
> >  > >> > PM
> >  > >> > > > > > I
> >  > >> > > > > just tried to
> at least load the game
> >  > >> > in with CF
> >  > >> > > > attached,
> >  > >> > > > > and got a
> MEMORY FULL when it tried to
> >  > >> > load its data
> >  > >> > > > > >
> >  > >> > in.
> >  > >> > > > >
> >  > >> > > > > Ooh.. I see
> what you're saying. Yes,
> >  > >> > it should run in
> >  > >> > > > > Classic99
> since
> >  > >> > > > > Classic99
> doesn't allocate VDP RAM for
> >  > >> > the disk
> >  > >> > > > controller
> >  > >> > > > > (ie: it has
> the
> >  > >> > > > > same amount of
> VDP memory as with
> >  > >> > cassette). I would
> >  > >> > > > find
> >  > >> > > > > it
> interesting
> >  > >> > > > > to help reduce
> the memory requirements
> >  > >> > to make it run
> >  > >> > > > with
> >  > >> > > > > the disk
> >  > >> > > > > system, if
> you'd like help. :)
> >  > >> > > > >
> >  > >> > > > >
> >  > >> > > > >
> >  > >> > > > >
> >  > >> > > > >
> >  > >> > > > > Yahoo! Groups
> Links
> >  > >> > > > >
> >  > >> > > > >
> >  > >> > > > > [email-masked]
> 
> >  > >>
> >  > >> >
> >  > >> > >
> >  > >> > > > >
> >  > >> > > > >
> >  > >> > > > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > > > Yahoo! Groups
> >  > >> > > >
> >  > >> > > >
> >  > >> > > > [email-masked]
> 
> >  > >>
> >  > >> >
> >  > >> > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > > >
> >  > >> > >
> >  > >> > >
> >  > >> >
> >  > >> >
> >  > >> >
> >  > >> >
> >  > >> > Yahoo! Groups Links
> >  > >> >
> >  > >> >
> >  > >> > [email-masked]
> 
> >  > >>
> >  > >> >
> >  > >> >
> >  > >> >
> >  > >>

---

From: fdos <[email-masked]>
Date: Mon, 25 Jan 2010 13:21:16 -0700

Ben,

No bubble to burst.  You may have missed one of my messages that talked 
about me or someone I con into doing the task, would have to write CALL 
LINK('MERGE",'FILENAME") for it to improve my current scenario of 
editing TI BASIC(+) programs and using MERGE in SEB.

Bill S

ti99_forever wrote:
>  
> 
> Bill,
> 
> Sorry to burst you bubble, but this program does the "SAVE 
> DSK1.FILENAME,MERGE" portion, but not the "MERGE DSK1.FILENAME" portion.
> 
>  > >  > From: fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>
>  > >  > >> > > > Subject: Re:
>  > >  > >> > > > Modified those two
>  > >  > >> > > > output to DSK1.2
>  > >  > >> > > > > Date: Sunday,
>  > >  > >> > > > > and got a
>  > >  > >> > > > > Classic99
>  > >  > >> > > > > Classic99
>  > >  > >> > > > > (ie: it has
>  > >  > >> > > > > same amount of
>  > >  > >> > > > > it
>  > >  > >> > > > > to help reduce
>  > >  > >> > > > > Yahoo! Groups
>  > >  > >> > > > Yahoo! Groups

---

From: mark wills <[email-masked]>
Date: Mon, 25 Jan 2010 20:42:42 -0800 (PST)

Bill,

Respectfully, why would you ever want to edit an XB program (or TIB) in a text editor?

Ok, sure, the text editors in EA etc are far more capable, but you completely lose your interactive connection to the computer.

The great thing about BASIC (and Forth) compared to other compiled languages is the interactivity. You can try out your solutions at the keyboard, immediately. You are intimately connected to the program that you are developing.

Editing code in an editor completely changes the dynamic, for the worse in my opinion.

Just my two cents, or rather, pence, humbly and respectfully submitted. :-)

TIB+ already has some cool features, but, (for *me* (i.e. just me, others may disagree)) offline editing would not be a persuasive reason to use the language.

Regards

Mark

>Sent: Mon, 25 January, 2010 20:04:09
>>Not so useful if I don't have CALL LINK("MERGE" ,"filename" ), and  a TI 
>>>>  > From: fdos <fdosbrs@frontiernet .net <mailto:fdosbrs% 40frontiernet. net>>
>>>>  > To: TI994A@yahoogroups. com <mailto:TI994A% 40yahoogroups. com>
>>>>  > LINK("MERGE" ,"filename" ) for TI BASIC+. It would probably require
>>>>  > >> > To: TI994A@yahoogroups. com <mailto:TI994A% 40yahoogroups. com>
>>>>  > >> > > > To: TI994A@yahoogroups. com <mailto:TI994A% 40yahoogroups. com>
>>>>  > >> >
>>>>  > >> > > > > To: TI994A@yahoogroups. com <mailto:TI994A% 40yahoogroups. com>
>>>>  > >> >

---

From: Keith Bergman <[email-masked]>
Date: Tue, 26 Jan 2010 00:08:13 -0500

Someone mentioned doing this on the Atariage forum, related to the game
programming contest over there.  I could see offline text editing for, say,
an odd or partial resequencing of line numbers.  But otherwise, the ability
to edit "on the fly" is definitely one of the good things about the
language.  The idea of editing on the fly seemed totally foreign to the guy
who brought it up (I think he's used to coding for other machines, in
compiled languages) - like it hadn't occurred to him at all.

On Mon, Jan 25, 2010 at 11:42 PM, mark wills <[email-masked]>wrote:

> Ok, sure, the text editors in EA etc are far more capable, but you
> completely lose your interactive connection to the computer.
>
> The great thing about BASIC (and Forth) compared to other compiled
> languages is the interactivity. You can try out your solutions at the
> keyboard, immediately. You are intimately connected to the program that you
> are developing.
>
> TIB+ already has some cool features, but, (for *me* (i.e. just me, others
> may disagree)) offline editing would not be a persuasive reason to use the
> language.
>
> Regards
>
> Mark
>
>
>  *From:* fdos <[email-masked]>
> *To:* [email-masked]
> *Sent:* Mon, 25 January, 2010 20:04:09
>
> *Subject:* Re: [TI994A] console BASIC and Classic99 question
>
>
>
> >> > From: fdos <fdosbrs@frontiernet .net <fdosbrs%40frontiernet.net><mailto:
> fdosbrs% <fdosbrs%25> 40frontiernet. net>>
> >> > To: TI994A@yahoogroups. com <TI994A%40yahoogroups.com> <mailto:
> TI994A% <TI994A%25> 40yahoogroups. com>
> >> > >> > To: TI994A@yahoogroups. com <TI994A%40yahoogroups.com> <mailto:
> TI994A% <TI994A%25> 40yahoogroups. com>
> >> > >> > > > To: TI994A@yahoogroups. com <TI994A%40yahoogroups.com><mailto:
> TI994A% <TI994A%25> 40yahoogroups. com>
> >> > >> >
> >> > >> > > > > To: TI994A@yahoogroups. com <TI994A%40yahoogroups.com><mailto:
> TI994A% <TI994A%25> 40yahoogroups. com>
> >> > >> >
> >> > >> > > > > TI994A-fullfeatured @yahoogroups. com<TI994A-fullfeatured%40yahoogroups.com>
> >> > >> > > > TI994A-fullfeatured @yahoogroups. com<TI994A-fullfeatured%40yahoogroups.com>
> >> > >> > TI994A-fullfeatured @yahoogroups. com<TI994A-fullfeatured%40yahoogroups.com>

---

From: fdos <[email-masked]>
Date: Mon, 25 Jan 2010 23:20:59 -0700

Mark,

It's not intended as a primary way to edit TI BASIC+ programs.  Only a 
way to make serious revisions to the code arrangement, and/or to add 
large pieces of code from another program.  Normal editing will take 
place in the usual way.

Besides, it's not likely to happen as the effort would be great versus 
limited benefit considering I can do these infrequent revisions and or 
additions in SEB which has line range copy/move capability in addition 
to MERGE.

Bill S

mark wills wrote:
> keyboard, immediately. You are intimately connected to the program that 
> you are developing.
> 
> TIB+ already has some cool features, but, (for *me* (i.e. just me, 
> others may disagree)) offline editing would not be a persuasive reason 
> to use the language.
> 
> Regards
> 
> Mark
> 
> 
>      >> > From: fdos <fdosbrs@frontiernet .net
>     <mailto:fdosbrs%40frontiernet.net> <mailto:fdosbrs% 40frontiernet. net>>
>      >> > To: TI994A@yahoogroups. com <mailto:TI994A%40yahoogroups.com>
>     <mailto:TI994A%40yahoogroups.com> <mailto:TI994A% 40yahoogroups. com>
>     <mailto:TI994A%40yahoogroups.com> <mailto:TI994A% 40yahoogroups. com>
>      >> > >> >
>     <mailto:TI994A%40yahoogroups.com> <mailto:TI994A% 40yahoogroups. com>
>      >> > >> >

---

From: mark wills <[email-masked]>
Date: Mon, 25 Jan 2010 22:28:15 -0800 (PST)

Ok Bill, understood. Yes, I would agree, it is probably quite a large effort for a 'marginal' gain, in the sense that it would be an infrequently used feature.

regards

Mark

----- Original Message ----
> Sent: Tue, 26 January, 2010 7:20:59
> >     *From:* fdos 
> >      >> > From: fdos

---

From: "kabldb" <[email-masked]>
Date: Tue, 26 Jan 2010 06:38:05 -0000

Hehe, this one made me laugh.

For more than 10 lines of code I'm moving offline XB.

:-)

--- In [email-masked], Keith Bergman <exiletoledo@...> wrote:
> On Mon, Jan 25, 2010 at 11:42 PM, mark wills <markrobertwills@...>wrote:
> 
> >
> >
> >  Bill,
> >
> >  *From:* fdos <fdosbrs@...>

---

From: ti99_forever <[email-masked]>
Date: Tue, 26 Jan 2010 01:41:45 -0800 (PST)

Ran the following little memory test in Classic99:
10 a=a*8
20 gosub 10

TI Basic: 14536
XB: 13952

TI Basic shows 584  more bytes than XB using this method. You can assume that TI Basic has about that many more bytes free. 13928 is the normal report in XB via the SIZE command, don't know the discrepancy.