Subject: TI-99/4 (no a) Power Connections

From: "epergrem" <[email-masked]>
Date: Wed, 23 Jun 2010 15:05:50 -0000

I retrieved a TI-99/4 from Dave's estate that wasn't working.  I have tracked the problem to a bad internal power supply (board).  The 99/4 uses a different connector to connect the power board to the main board  that the 4A, but I was able to swap connectors from the old to the new.  

The console now powers up, albeit I did it only briefly for now.  Before I declare it done I need to confirm that the wiring is correct and that the newer model power boards are truly compatible with the 99/4.

The 99/4 power board has four wires; Red, Black, White, Green. Of the three voltages only the -5 was working, so I know that black is ground and green is -5v.  I'm almost, but not quite, certain that Red is +5v and White is +12v.   

Can anyone, who has knowledge of the 99/4, confirm this?  Please don't take this as my being rude, but this is where trying to be helpful, but not being 100% certain could result in the frying of irreplaceable item. 

Thanks,
Ernie

---

From: "Postle" <[email-masked]>
Date: Wed, 23 Jun 2010 17:14:32 -0000

Ernie,  I am not a Richard Bell.  I asked the same question when I swapped the new from the old power supply.  Point being it works.  And... Still working.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: "epergrem" <[email-masked]>
Date: Wed, 23 Jun 2010 17:32:07 -0000

Hi,
Just to clarify.  You replaced the 'internal' power board that plugs into the mainboard on a TI-99/4(no A), with one that was made for the TI-99/4A.  Not the 'external' power supply that plugs into the wall?

Thanks,
Ernie

---

From: "Postle" <[email-masked]>
Date: Wed, 23 Jun 2010 18:43:29 -0000

Ernie,

We have replaced the coffe cup warmer series with the newer cooler running power supply.  That works.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> --- In [email-masked], "Postle" <postle@> wrote:
> >

---

From: "Stuart" <[email-masked]>
Date: Wed, 23 Jun 2010 21:47:52 -0000

I have what appears to be an early 4A with a 4 power supply arrangement. You are right in that white is +12V and red (or orange in my case) is +5V.

Stuart.

---

From: "epergrem" <[email-masked]>
Date: Wed, 23 Jun 2010 23:10:22 -0000

Thanks.. 

The confusion arose because on the 99/4A power supply or at least the later ones, Texas Instruments replaced the the four individually colored wires with all brown wires and a keyed connector.  I say later because I do recall seeing a 99/4A with the 99/4 type connector.

There were also some design changes to allow for more machine soldering and less hand soldering.  I just want to be sure that I don't fry this thing once I decide to leave it on for more than 5 seconds. :-)

Ernie

---

From: "Ksarul" <[email-masked]>
Date: Wed, 23 Jun 2010 19:24:31 -0400

There were also at least two different /4 internal power supplies. . .the
later ones worked like the ones in the /4A, but the ones with the speaker in
the console were different.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
epergrem
Sent: Wednesday, June 23, 2010 7:10 PM
To: [email-masked]
Subject: [TI994A] Re: TI-99/4 (no a) Power Connections

Thanks.. 

The confusion arose because on the 99/4A power supply or at least the later
ones, Texas Instruments replaced the the four individually colored wires
with all brown wires and a keyed connector. I say later because I do recall
seeing a 99/4A with the 99/4 type connector.

There were also some design changes to allow for more machine soldering and
less hand soldering. I just want to be sure that I don't fry this thing once
I decide to leave it on for more than 5 seconds. :-)

Ernie

--- In [email-masked] <mailto:TI994A%40yahoogroups.com> , "Stuart"
<ti99@...> wrote:
>
> I have what appears to be an early 4A with a 4 power supply arrangement.
You are right in that white is +12V and red (or orange in my case) is +5V.

---

From: "epergrem" <[email-masked]>
Date: Thu, 24 Jun 2010 00:46:34 -0000

Thanks Jim,
This one has the headphone jack, but no speaker.. or at least I don't recall seeing one!  The production imprint is LTA0880, so I'm guessing that it's a later one.  

--- In [email-masked], "Ksarul" <vze23g4a@...> wrote:
> <ti99@> wrote:

---

From: "Ksarul" <[email-masked]>
Date: Wed, 23 Jun 2010 22:19:54 -0400

The real issues between them were between the power supply and the external
wall wart.  As long as both the power supply and the wall wart are of the
same type, there should be no issues whatsoever.  The early /4 machines were
easily identified by looking into the connector at the back of the machine.
One of the four pins was a whole lot thicker than the other three-almost
twice as thick IIRC.  I seem to remember that the input to that version was
DC.  I'll have to dig up the one and only power supply I have of that type
and take a look if you really want to know.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
epergrem
Sent: Wednesday, June 23, 2010 8:47 PM
To: [email-masked]
Subject: [TI994A] Re: TI-99/4 (no a) Power Connections

Thanks Jim,
This one has the headphone jack, but no speaker.. or at least I don't recall
seeing one! The production imprint is LTA0880, so I'm guessing that it's a
later one. 

--- In [email-masked] <mailto:TI994A%40yahoogroups.com> , "Ksarul"
<vze23g4a@...> wrote:
> From: [email-masked] <mailto:TI994A%40yahoogroups.com>
[mailto:[email-masked] <mailto:TI994A%40yahoogroups.com> ] On Behalf
Of
> To: [email-masked] <mailto:TI994A%40yahoogroups.com> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>
<mailto:TI994A%40yahoogroups.com> , "Stuart"

---

From: "epergrem" <[email-masked]>
Date: Thu, 24 Jun 2010 12:27:35 -0000

I was concerned about that also, but it appears to be the original power supply since if fits nicely into the imprint in the foam.

It's the type where the brick itself plugged into the wall, rather than those that used cords to plug into the wall.  Voltages were all similar to the 4a supplies and it has three inputs; red-white-black

TI did love using voltage regulators.  The input voltages from the transformer are something like 29v and 9v.  You would have thought that TI could have found a vendor to supply something a little less 'hot'.

Ernie