Subject: Dead TI-99/4

From: "epergrem" <[email-masked]>
Date: Thu, 27 May 2010 03:01:31 -0000

I have a TI-99/4 in almost pristine condition that I retrieved from Dave Connery's home that I agreed to sell on eBay for the estate.

Unfortunately, when I tried to turn it on.. nothing.  No sound, no picture.  It didn't even cause the monitor to flicker.  The monitor and cables are not the problem.  Pressing the keys with the unit on also does not result in a beep.

The power light is on and I have checked the wall power supply voltages.  I have disassembled it to see if there are any obvious problems, but my biggest concern was perhaps it was a bad 9918, but then I realized no sound, so it's likely something else.  

I have not checked any of the voltages exiting the onboard power supply because there are four wires (red, white, gray, black) and I'm not sure that the measurements should be.

I've got John Guion's troubleshoot guide and will start on that tomorrow, but I was hoping some in the group might have some thoughts also.

I would hate to see Dave's estate get junk value for something as nice as this.

As for other items from his estate. I'm working with the attorney to recover some more, but it's virtually impossible to get to the TI stuff because of the stacks in front of it.

Thanks,
Ernie

---

From: mark wills <[email-masked]>
Date: Thu, 27 May 2010 08:53:43 +0000 (GMT)

Just thinking out aloud here...

One would normally expect to hear a short sound at power up, until the processor runs the ROM code and switches off the sound chip. Even with a blown video chip, it is a good indicator that the processor is running.

If you hear a constant sound, then the processor isn't running - either a processor fault or a ROM/GROM fault.

However, you are getting nothing at all. I would therefore be tempted to look at the clock crystals. I wonder if the entire board is being clocked at all? I don't know the 99/4's architecture... Is there one single crystal that drives the 9900 and the (divided down?) clocks the video chip and/or sound chip?

I think that's where I would start. You will need an oscilloscope though...

Good luck...

Mark

----- Original Message ----
> From: epergrem <[email-masked]>
> To: [email-masked]
> Sent: Thu, 27 May, 2010 4:01:31
> Subject: [TI994A] Dead TI-99/4
> 
> I have a TI-99/4 in almost pristine condition that I retrieved from Dave 
> Connery's home that I agreed to sell on eBay for the 
> estate.

Unfortunately, when I tried to turn it on.. nothing.  No 
> sound, no picture.  It didn't even cause the monitor to flicker.  The 
> monitor and cables are not the problem.  Pressing the keys with the unit on 
> also does not result in a beep.

The power light is on and I have checked 
> the wall power supply voltages.  I have disassembled it to see if there are 
> any obvious problems, but my biggest concern was perhaps it was a bad 9918, but 
> then I realized no sound, so it's likely something else.  

I have 
> not checked any of the voltages exiting the onboard power supply because there 
> are four wires (red, white, gray, black) and I'm not sure that the measurements 
> should be.

I've got John Guion's troubleshoot guide and will start on 
> that tomorrow, but I was hoping some in the group might have some thoughts 
> also.

I would hate to see Dave's estate get junk value for something as 
> nice as this.

As for other items from his estate. I'm working with the 
> attorney to recover some more, but it's virtually impossible to get to the TI 
> stuff because of the stacks in front of 
> it.

Thanks,
Ernie

------------------------------------

Yahoo! 
> Groups Links

>   
> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 28 May 2010 19:17:45 -0500

This weekend I was planning to do a bit of programming but in my effort to recover some software files, got sidetracked with some hardware-related work.  I'm curious if anyone with an HFDC has encountered this scenario:

I have an one MFM hard drive and one floppy drive connected to an HFDC.  I "discovered" that with termination installed on the floppy drive, the hard drive will not read/write properly.  If I remove floppy termination, it works OK. 

I'm going back to the repair dungeon for a while to do some more testing with alternate hardware. I feel like I've corrected this problem once before by replacing one or more buffer 
chips (e.g., LS240)  on the HFDC but I can't be sure and so far, review of my notes has
 turned up little.  I do not recall ever having to "worry" about termination between hard and floppy devices.  

So... anyone ever run across this or have any ideas?   Back to the repair dungeon I go...

_________________________________________________________________
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_2

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 29 May 2010 01:33:53 -0500

Well, after some experimentation it seems that too strong a terminating resistor can interfere with the HFDC operation. Additionally, it is important that terminating resistors are installed only on the last floppy and last hard drive.  

When tested with my Myarc FDC, floppy termination did not matter.  When tested with the HFDC, problems occured when more than one floppy had termination.  Tolerance decreased if one or more hard drives were attached.

Moral of the story: termination is important.   And for giggles I checked the HFDC manual -- proper setup is documented there.

Tim

To: [email-masked]; [email-masked]
From: [email-masked]
Date: Fri, 28 May 2010 19:17:45 -0500
Subject: [TI-99/4A] Myarc HFDC

 		 	   		  
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox. See how.

---

From: Marc Hull <[email-masked]>
Date: Sat, 29 May 2010 07:25:53 -0700 (PDT)

You are correct my friend.  My experience has been that the HFDC is pretty much like your average beauty queen.  If ya don't treat her perfectly she simply won't perform.

Conversely I think you could hook the Myarc FDC up to a rock and it will perform flawlessly ;-)

--- On Sat, 5/29/10, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: [TI994A] RE: [TI-99/4A] Myarc HFDC
To: [email-masked], [email-masked]
Date: Saturday, May 29, 2010, 1:33 AM

  

      

Tim

To: ti994a@yahoogroups. com; ti99-4a@yahoogroups .com
From: insane_m@hotmail. com
Date: Fri, 28 May 2010 19:17:45 -0500
Subject: [TI-99/4A] Myarc HFDC

---

From: Tony Knerr <[email-masked]>
Date: Sat, 29 May 2010 10:29:45 -0400

Marc Hull wrote:
>  
>
> You are correct my friend.  My experience has been that the HFDC is 
> pretty much like your average beauty queen.  If ya don't treat her 
> perfectly she simply won't perform.
>
>
Yes, but it couldn't be a high density rock. :)

Tony