Subject: Re: [TI994A] I: Multicart info....

From: [email-masked]
Date: Sat, 17 Apr 2010 21:55:22 -0500 (CDT)

Funny how devices that are supposedly built to a "standard" don't always work like you expect.

Apr 17, 2010 10:35:51 PM, [email-masked] wrote:

For those of you burning or making multicarts out of some of the newer boards...

There are a few different kind of 74LS379 chips, and they all behave slightly different from each other when it comes to what power up bank you're going to land in when the system comes up. (There is no documented power-up state, and it looks like different manufacturers do different things.)

The NTE and TI branded 74LS379's that I have seen will almost always come up in bank 7 (the highest bank on the EPROM.)

The Motorola* and AMD branded 74LS379's seem to come up in bank 0 (the lowest bank on the EPROM.)

* Most of the Motorolas... I've seen some come up in bank 7, but very few.

So, if you're using our friend Tursi's Multicart program to make a 64K EPROM (8 x 8K), you need to have the MULTICART 8K segment in the bank 0 for Motorola and AMD 74LS379s, and bank 7 for NTE and TI 74LS379s.

If you put your multicart EPROM in and find that you have a module listed instead of MULTICART, then you have one of two choices:

1) Buy a NTE 74LS379 chip if you're currently using a Motorola or AMD 74LS379. They are here: http://www.mouser.com/ProductDetail/NTE/NTE74LS379/?qs=xRTSnXjzBs7y56R0txmVYg%3d%3d
2) Buy a Motorola 74LS379 chip if you're currently using a NTE or TI 74LS379. They are here: http://unicornelectronics.com/IC/74LS.html
2) Reprogram your EPROM and put MULTICART in bank 0 or 7 (whichever it wasn't in before). I use 0xED for OS X and it works great for cutting/pasting.
3) If you can't reprogram your EPROM, send it to someone who can (like me, or several other people on the list who have EPROMs and erasers.)

This is just one of those oddball things we have to deal with, since we're assuming a lot by the default power up state of a chip, and that power up state isn't documented!

Note that this idiosyncrasy doesn't have any effect on a properly written bank switched program (that by default switches where it needs to go), such as TI Workshop, Pitfall, Arcturus, etc. It just affects multicarts using Tursi's program. :)

Jon

------------------------------------

Yahoo! Groups Links

<*> To visit your group on the web, go to:
http://groups.yahoo.com/group/TI994A/

<*> Your email settings:
Individual Email | Traditional

<*> To change settings online go to:
http://groups.yahoo.com/group/TI994A/join
(Yahoo! ID required)

<*> To change settings via email:
[email-masked]
[email-masked]

<*> To unsubscribe from this group, send an email to:
[email-masked]

<*> Your use of Yahoo! Groups is subject to:
http://docs.yahoo.com/info/terms/

---

From: "Tursi" <[email-masked]>
Date: Sat, 17 Apr 2010 21:50:31 -0700

> Funny how devices that are supposedly built to a "standard" don't always 

There's no standard.. the power up state of a 379 is undefined. We went over 
this many, many times during the design, but there's no simple way to 
provide a startup hardware reset. We went over a few different ideas but 
always came back to easy to find cases that wouldn't do the trick, and the 
ones that covered them need too much hardware to be worth it. A CPLD is the 
best way forward if you really need that level of control.

It's better done in software - but that software needs to get control. The 
current method of building the multicarts doesn't modify any of the programs 
copied into it, so the Multicart software needs to manually be located in 
the power-up bank.

---

From: "Postle" <[email-masked]>
Date: Sun, 18 Apr 2010 16:19:37 -0000

This is fine and I am glad you guys agree.  My questions is where can I send my board with shell to have the Multicart installed?  In the desert without a programer.

Postle