Subject: LOOP question

From: Owen Brand <[email-masked]>
Date: Sun, 2 May 2010 13:37:19 -0400

I'm using multiple data statements in a program to write several files  
to diskette.  I need to create 6 datafiles from the data statements  
I've placed in this program.  So, I have one simple "write" program  
that uses
OPEN "DSK1.FOR", OUTPUT, INTERNAL

Then the loop starts with a READ statement that reads DATA into an  
equation which then PRINTs the numbers to the file I've just created.   
What I'm wondering is, is there a way to include the OPEN "DSK1.xxx"  
into the loop, making xxx FOR1, FOR2, FOR3, FOR4, FOR5, and FOR6?   
Usually I would use a Loop to make something like "FOR"&X, but when  
working with a string like "FOR," and a numerical variable "X" inside  
an OPEN statement... I don't know how that would work.  Any ideas?

Owen Brand

        **webmaster**
http://www.Opry99er.com

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 2 May 2010 12:49:07 -0500

Check out STR$   ;)

> To: [email-masked]
> From: [email-masked]
> Date: Sun, 2 May 2010 13:37:19 -0400
> Subject: [TI994A] LOOP question
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
> 
 		 	   		  
_________________________________________________________________
The New Busy is not the too busy. Combine all your e-mail accounts with Hotmail.
http://www.windowslive.com/campaign/thenewbusy?tile=multiaccount&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_4

---

From: Owen Brand <[email-masked]>
Date: Sun, 2 May 2010 14:00:09 -0400

Ugh.... I'm a wanker. Sometimes I wonder how I remember my own name...  
Thanks bud.

Owen Brand

        **webmaster**
http://www.Opry99er.com

On May 2, 2010, at 1:49 PM, Insane Multitasker <[email-masked]>  
wrote:

> The New Busy is not the too busy. Combine all your e-mail accounts  
> with Hotmail. Get busy.
>

---

From: mark wills <[email-masked]>
Date: Mon, 3 May 2010 08:46:20 +0000 (GMT)

Ah! A very British colloquialism there Owen me old son. We'll make a Brit out of you yet!

Something like:

FOR I=1 to 10
OPEN #1:"FOR"&STR$(I),OUTPUT,INTERNAL
...
...
NEXT I

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Sun, 2 May, 2010 19:00:09
>Subject: Re: [TI994A] LOOP question
>
> >
>
>
>
> >
>
>
>
>
>
>
>Ugh.... I'm a wanker. Sometimes I wonder how I remember my own name... Thanks bud.
>
>Owen Brand
>
>
>       **webmaster** 
>http://www.Opry99er.com
>
>On May 2, 2010, at 1:49 PM, Insane Multitasker <[email-masked]> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>>>
>>
>>Check out STR$   ;)
>>
>>> To: TI994A@yahoogroups. com
>>> From: owenbrand@opry99er. com
>>>         **webmaster* *
>>> http://www.Opry99er .com
>>> ------------ --------- --------- ------
>>> 
>>> Yahoo! Groups Links
>>> 
>>> 
>>> 
>>
>>
________________________________
The New Busy is not the too busy. Combine all your e-mail accounts with Hotmail. Get busy.

---

From: Owen Brand <[email-masked]>
Date: Mon, 3 May 2010 06:39:49 -0400

Thanks Willsy.... I got we down now--I think I emailed you the DSK1  
file.  :). Agh, but you are curious about the "generation" program I  
used to create those map dadafiles, no?
  :) Well, if you wanna know, "Its no bloody bother of yours,  
Markis...."

Tea and crumpets, cricket?  You limey Brits need more baseball, beer,  
and brats!!!  :)
Owen Brand

        **webmaster**
http://www.Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Mon, 3 May 2010 06:50:05 -0400

Yea man-// if I can scroll this baby, I have no need for lightning  
fast assembly screen draws... Problem is all 6 of these maps in memory  
at once eats all my RAM.... Perhaps not though... See, there's no real  
way to test it (yet) because It would require sole insanely long  
strings...  Your window scrolling concept is pretty awesome--- but  
scrolling in XB sucks man... The freaking redraw takes forever...  
Which is why I switched to a full screen view.  I don't mind the full  
screen mode as long as I can draw the "next" screen a he'll of alot  
faster than what this demo I sent you goes...  You'll see what I mean.

Owen Brand

        **webmaster**
http://www.Opry99er.com