Subject: Single or Double sided disk drive? TI99-PC and stock TI drive?

From: "Charlie" <[email-masked]>
Date: Sat, 17 Apr 2010 19:19:52 -0000

I was told when I purchased my PEB that it had the stock TI drive and controller. Was the drive used a SS or DS drive?

When I make TI disks on my PC that are SS,SD they work great.

When I make TI disks on my PC that are DS,SD they don't seem to work.
I can get a catalog but it will fail with an error.
When I use DM2 and do an error check I get bad address on everything over 360. All the way up to 720.
These are the disk images I'm using Ti99-pc to make:
ftp://ftp.whtech.com/emulators/v9t9/Funnelweb/

When I formatted a disk in the Ti with DM2 and it asked me Single Sided I answered no, but when I put that disk in the PC ti9-pc says its a SS,SD disk. I think I did something wrong though...
Tracks per side 40
Single sided N
Single density Y
Does that yield a DS,SD disk?

Also when I catalog the DS,SD disk in ti99-pc I get a full list of the files with no error.

Could it be a single sided drive? I have a few in a couple of my TRS-80 drive units... Maybe something is broken?

---

From: Gregory McGill <[email-masked]>
Date: Sat, 17 Apr 2010 12:27:09 -0700

Stock TI drives are Single Sided.. either single or double density

The TI controller can't do more than SS/SD if memory serves someone will
correct me if I'm wrong..

If you have the opportunity, pick up a better drive like this one:
http://texintreasures.com/shop/product_info.php?cPath=23&products_id=406

And a better controller, either the corcomp or myarc so you can do ds/dd or
a hfdc :)

Greg

On Sat, Apr 17, 2010 at 12:19 PM, Charlie <[email-masked]> wrote:

>
>
> I was told when I purchased my PEB that it had the stock TI drive and
> controller. Was the drive used a SS or DS drive?
>
> When I formatted a disk in the Ti with DM2 and it asked me Single Sided I
> answered no, but when I put that disk in the PC ti9-pc says its a SS,SD
> disk. I think I did something wrong though...
> Tracks per side 40
> Single sided N
> Single density Y
> Could it be a single sided drive? I have a few in a couple of my TRS-80
> drive units... Maybe something is broken?
>
>  
>

---

From: Jon Yahoo <[email-masked]>
Date: Sat, 17 Apr 2010 14:48:39 -0500

It can do DS/SD if you have the drive.

Regards,

Jon

On Apr 17, 2010, at 2:27 PM, Gregory McGill <[email-masked]>  
wrote:

> The TI controller can't do more than SS/SD if memory serves someone  
> will correct me if I'm wrong..
>
> And a better controller, either the corcomp or myarc so you can do  
> ds/dd or a hfdc :)
>
> Greg
>
>
> I was told when I purchased my PEB that it had the stock TI drive  
> and controller. Was the drive used a SS or DS drive?
>
> When I formatted a disk in the Ti with DM2 and it asked me Single  
> Sided I answered no, but when I put that disk in the PC ti9-pc says  
> its a SS,SD disk. I think I did something wrong though...
> Tracks per side 40
> Single sided N
> Single density Y
> Could it be a single sided drive? I have a few in a couple of my  
> TRS-80 drive units... Maybe something is broken?
>
>
>

---

From: "Charlie" <[email-masked]>
Date: Sat, 17 Apr 2010 19:50:04 -0000

This site here says to should do DS,SD......

http://www.mainbyte.com/ti99/hardware/peb/disk_controller_card.html

Can the TI use any 360K drive or does it need to be a special drive?
I noticed it had connections on the drive I was not familiar with.

Charlie

--- In [email-masked], Gregory McGill <arcadeshopper@...> wrote:
> On Sat, Apr 17, 2010 at 12:19 PM, Charlie <chazbeenhad@...> wrote:
> 
> >
> >

---

From: Marc Hull <[email-masked]>
Date: Sat, 17 Apr 2010 12:57:04 -0700 (PDT)

The card you have is capable of single density only.   The drive you have is capable of single side only (assuming it is original.)  The best you can hope for with the TI controller is double side/ single density (not taking into account 80 track mods) but you will need a drive that is double sided.  In order to achieve Double density you will need a different controller card.

Your controller card has no idea what kind of drive you are using which is why you are getting the errors.  It is blindly groping for data that is not there (on the other side of the disk.) 

--- On Sat, 4/17/10, Charlie <[email-masked]> wrote:

From: Charlie <[email-masked]>
Subject: [TI994A] Single or Double sided disk drive? TI99-PC and stock TI drive?
To: [email-masked]
Date: Saturday, April 17, 2010, 2:19 PM

  

ftp://ftp.whtech. com/emulators/ v9t9/Funnelweb/

Tracks per side 40

Single sided N

Single density Y

---

From: "Charlie" <[email-masked]>
Date: Sat, 17 Apr 2010 20:23:54 -0000

Long Story short... I threw a 360K drive in the PEB and sure enough, I'm reading DS,SD disks with no trouble. Thanks all for the replies.

Here is my next question. If I want to add another 360k Drive, do i simply crimp another floppy connector on the ribbon cable?

I understand they need to be set up as drive 0 and 1 with jumpers on the drives, but is another card edge connector all thats needed on the floppy cable?

Charlie

---

From: "Tony Knerr" <[email-masked]>
Date: Sat, 17 Apr 2010 21:11:48 -0000

Yes, just add another connector.
Do not use a cable with a twist, it must be a straight cable.
You'll also need to remove the termination pack, usually a resistor pack in a sip or dip package, from the drive that's connected to the connector in the middle of the cable.

Tony

---

From: "Ksarul" <[email-masked]>
Date: Sat, 17 Apr 2010 17:29:02 -0400

BTW, for those who use the 80-track mod, there is a guy selling TEAC FD-55F
drives on eBay for $25 each right now.  Half-height 80-track drives that are
TI compatible with the appropriate controller or modification. . .and he has
a lot of them.  I bought four.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Marc Hull
Sent: Saturday, April 17, 2010 3:57 PM
To: [email-masked]
Subject: Re: [TI994A] Single or Double sided disk drive? TI99-PC and stock
TI drive?

The card you have is capable of single density only.   The drive you have is
capable of single side only (assuming it is original.)  The best you can
hope for with the TI controller is double side/ single density (not taking
into account 80 track mods) but you will need a drive that is double sided.
In order to achieve Double density you will need a different controller
card.

Your controller card has no idea what kind of drive you are using which is
why you are getting the errors.  It is blindly groping for data that is not
there (on the other side of the disk.) 

From: Charlie <[email-masked]>
Subject: [TI994A] Single or Double sided disk drive? TI99-PC and stock TI
drive?
To: [email-masked]
Date: Saturday, April 17, 2010, 2:19 PM

When I make TI disks on my PC that are DS,SD they don't seem to work.
I can get a catalog but it will fail with an error.
When I use DM2 and do an error check I get bad address on everything over
360. All the way up to 720.
These are the disk images I'm using Ti99-pc to make:
ftp://ftp.whtech. <ftp://ftp.whtech.com/emulators/v9t9/Funnelweb/>
com/emulators/ v9t9/Funnelweb/

Also when I catalog the DS,SD disk in ti99-pc I get a full list of the files
with no error.

---

From: "Charlie" <[email-masked]>
Date: Sun, 18 Apr 2010 03:29:48 -0000

I used a straight floppy cable from a spare TRS-80 external disk drive setup I have. I had to crimp the end connector on because the trs-80 uses a card edge connector at the end as well as for the drives. I hooked up 2 360K drives and now everything is working great. I had to layout and drill a couple holes in the peb frame to hold the drives in place of the big single sided drive. It all worked out well! :-)

Charlie

--- In [email-masked], "Tony Knerr" <tonyknerr@...> wrote:
> --- In [email-masked], "Charlie" <chazbeenhad@> wrote:
> >

---

From: Owen Brand <[email-masked]>
Date: Sat, 17 Apr 2010 23:45:41 -0400

Excellent!!!  Congrats brother!  You're kickin a** already!  :) Let me  
know when you want to start programming... Come see us at  
Atariage.com... Crazy good stuff going on over there.  :)

Owen Brand
Opry99er.com

On Apr 17, 2010, at 11:29 PM, "Charlie" <[email-masked]> wrote:

> I used a straight floppy cable from a spare TRS-80 external disk  
> drive setup I have. I had to crimp the end connector on because the  
> trs-80 uses a card edge connector at the end as well as for the  
> drives. I hooked up 2 360K drives and now everything is working  
> great. I had to layout and drill a couple holes in the peb frame to  
> hold the drives in place of the big single sided drive. It all  
> worked out well! :-)
>
> Charlie
>
> > You'll also need to remove the termination pack, usually a  
> resistor pack in a sip or dip package, from the drive that's  
> connected to the connector in the middle of the cable.
> >
> > Tony
> >
> >
> > > Long Story short... I threw a 360K drive in the PEB and sure  
> enough, I'm reading DS,SD disks with no trouble. Thanks all for the  
> replies.
> > >
> > > Here is my next question. If I want to add another 360k Drive,  
> do i simply crimp another floppy connector on the ribbon cable?
> > >
> > > I understand they need to be set up as drive 0 and 1 with  
> jumpers on the drives, but is another card edge connector all thats  
> needed on the floppy cable?
> > >
> > > Charlie
> >
>
>

---

From: "Dan O'Quinn" <[email-masked]>
Date: Sun, 18 Apr 2010 18:50:00 -0400

you might find some usefull info on floppies here
http://web.lowcountry.com/~compdr/

----- Original Message ----- 
From: "Charlie" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, April 17, 2010 11:29 PM
Subject: [TI994A] Re: Single or Double sided disk drive? TI99-PC and stock 
TI drive?

>I used a straight floppy cable from a spare TRS-80 external disk drive 
>setup I have. I had to crimp the end connector on because the trs-80 uses a 
>card edge connector at the end as well as for the drives. I hooked up 2 
>360K drives and now everything is working great. I had to layout and drill 
>a couple holes in the peb frame to hold the drives in place of the big 
>single sided drive. It all worked out well! :-)
>
> Charlie
>
>> You'll also need to remove the termination pack, usually a resistor pack 
>> in a sip or dip package, from the drive that's connected to the connector 
>> in the middle of the cable.
>>
>> Tony
>>
>>
>> > Long Story short... I threw a 360K drive in the PEB and sure enough, 
>> > I'm reading DS,SD disks with no trouble. Thanks all for the replies.
>> >
>> > Here is my next question. If I want to add another 360k Drive, do i 
>> > simply crimp another floppy connector on the ribbon cable?
>> >
>> > I understand they need to be set up as drive 0 and 1 with jumpers on 
>> > the drives, but is another card edge connector all thats needed on the 
>> > floppy cable?
>> >
>> > Charlie
>>
>