Subject: Geneve 2 ???

From: "kory" <[email-masked]>
Date: Tue, 06 Jul 2010 22:08:39 -0000

Hi All!

After being away for quite some time.. away from the Ti994a world, I decided to do a bit of browsing on the net and came across something that really caught my eye.. the Geneve 2.. Is this a "real" project, and does anyone have any idea on cost etc..

It really amazes me that there is so much love and dedication this many years later for the TI/Geneve. I will be introducing my daughter to the TI very soon. She is still too young. My hopes are that she may hold some interest in it and ask me to help her program it like I asked my dad so many years ago. The thought of having a new computer that we can both learn on at the same time is a priceless thought, especially if it is related to my first computer! 

Anyway, if anyone has any info on the G2 or if there is a thread related to it here, please point me in the proper direction!

Thanks!
-Kory

---

From: Owen Brand <[email-masked]>
Date: Tue, 6 Jul 2010 18:14:50 -0400

Welcome back!!  I don't know about the Geneve 2... Never heard of it.   
If you like programming, this is a great place to get info... Another  
place to check is Atariage.com--- TI-99/4a programming subforum.  All  
kinds of new games coming out regularly over there.  :)

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jul 6, 2010, at 6:08 PM, "kory" <[email-masked]> wrote:

> Hi All!
>
> After being away for quite some time.. away from the Ti994a world, I  
> decided to do a bit of browsing on the net and came across something  
> that really caught my eye.. the Geneve 2.. Is this a "real" project,  
> and does anyone have any idea on cost etc..
>
> It really amazes me that there is so much love and dedication this  
> many years later for the TI/Geneve. I will be introducing my  
> daughter to the TI very soon. She is still too young. My hopes are  
> that she may hold some interest in it and ask me to help her program  
> it like I asked my dad so many years ago. The thought of having a  
> new computer that we can both learn on at the same time is a  
> priceless thought, especially if it is related to my first computer!
>
> Anyway, if anyone has any info on the G2 or if there is a thread  
> related to it here, please point me in the proper direction!
>
> Thanks!
> -Kory
>
>

---

From: "kory" <[email-masked]>
Date: Tue, 06 Jul 2010 22:24:39 -0000

I read something earlier today about a G2 (Geneve 2) being shown this year at TREFF. I cut and pasted the info below. 

Yes,  we are getting a brand new TI super computer that is compatible with the TI 99/4a software and beyond. 

This project has been kept secret until today.. The TI User Group UK shows you the spec... however we are looking to add an Gigabit Ethernet Controller to the machine so that it can connect to the internet. With this we can add products like the wnce2001 Ethernet wireless adaptor which is a universal self connecting device. If you have any technical knowledge regarding low level ethernet implementation then let us know..
Any way here we go with the spec.

1 ) PEB interface. The board can run in the PEB or stand alone with a disk drive power connector ( allows use in PC case etc ).
2 ) 2 * SD card slots. No VHDL has been created for this yet but the connections are there anyway. Opencores.org may have VHDL we can use.
3 ) 1 * USB connector. No VHDL exists for this but the MSX people have a connection like this so I thought why the hell not !
4 ) IDE interface. Again no VHDL but I'm sure we can ask a certain Mr Nouspikel if we can copy his design. ( Allows 2 drives )
5 ) 64 MB DDR SDRAM for the CPU - this should be enough ;-)
6 ) 512KB VRAM. Looks like the 9958 will be used - not the 9938 as there is no mouse interface on the MSX 9938 :-(
7 ) 1 * audio output from the sound generator. Don't know about speech just yet - can use existing PEB mounted speech if the worst comes to the worst.
8 ) 18 bit RGB output with Hsync and Vsync. Should work on normal VGA monitor. May get SVideo also at some point - depends of FPGA pin count.
9 ) Joystick interface.
10 ) PS2 Keyboard interface.
11 ) PS2 mouse interface. No VHDL for this but doesn't seem too difficult.
12 ) Centronics PIO interface like RS232 card.
13 ) 9 pin RS232 channel. No VHDL yet.
14 ) Regulators to get 5V, 3V3, and 1V2. 1 Switching regulator used for efficiency.
15 ) 1 config device to program both FPGAs.
16 ) 12MHz oscillator - multiplied internally to get higher frequency operation.
17 ) 21MHz Xtal for video.

Production of the PCB starts shortly...

If you visit the TREFF we hope to have a large demo of the unit for you to see... 

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Jul 6, 2010, at 6:08 PM, "kory" <shortbusalaboard@...> wrote:
> 
> > Hi All!
> >

---

From: Owen Brand <[email-masked]>
Date: Tue, 6 Jul 2010 18:52:59 -0400

Ahh--- the super secret UK project is going to be called "Geneve  
2".  :). Those sneaky buggers. :). It's supposed to be un-freaking  
believable.  :).  Can't wait to see it

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jul 6, 2010, at 6:24 PM, "kory" <[email-masked]> wrote:

>
>
> I read something earlier today about a G2 (Geneve 2) being shown  
> this year at TREFF. I cut and pasted the info below.
>
> This project has been kept secret until today.. The TI User Group UK  
> shows you the spec... however we are looking to add an Gigabit  
> Ethernet Controller to the machine so that it can connect to the  
> internet. With this we can add products like the wnce2001 Ethernet  
> wireless adaptor which is a universal self connecting device. If you  
> have any technical knowledge regarding low level ethernet  
> implementation then let us know..
> 1 ) PEB interface. The board can run in the PEB or stand alone with  
> a disk drive power connector ( allows use in PC case etc ).
> 2 ) 2 * SD card slots. No VHDL has been created for this yet but the  
> connections are there anyway. Opencores.org may have VHDL we can use.
> 3 ) 1 * USB connector. No VHDL exists for this but the MSX people  
> have a connection like this so I thought why the hell not !
> 4 ) IDE interface. Again no VHDL but I'm sure we can ask a certain  
> Mr Nouspikel if we can copy his design. ( Allows 2 drives )
> 6 ) 512KB VRAM. Looks like the 9958 will be used - not the 9938 as  
> there is no mouse interface on the MSX 9938 :-(
> 7 ) 1 * audio output from the sound generator. Don't know about  
> speech just yet - can use existing PEB mounted speech if the worst  
> comes to the worst.
> 8 ) 18 bit RGB output with Hsync and Vsync. Should work on normal  
> VGA monitor. May get SVideo also at some point - depends of FPGA pin  
> count.
> 9 ) Joystick interface.

---

From: mark wills <[email-masked]>
Date: Tue, 6 Jul 2010 23:18:48 +0000 (GMT)

Yes. It's just taken a major leap forward, but I'm not saying anything more than 
that, vapour is my anathema!

Mark

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Tue, 6 July, 2010 23:52:59
>Subject: Re: [TI994A] Re: Geneve 2 ???
>
>  
>
>
>Ahh--- the super secret UK project is going to be called "Geneve 2".  :). Those 
>sneaky buggers. :). It's supposed to be un-freaking believable.  :).  Can't wait 
>to see it
>
>Owen Brand
>
>
>       **webmaster** 
>http://www.Opry99er.com
>
>>This project has been kept secret until today.. The TI User Group UK shows you 
>>the spec... however we are looking to add an Gigabit Ethernet Controller to the 
>>machine so that it can connect to the internet. With this we can add products 
>>like the wnce2001 Ethernet wireless adaptor which is a universal self connecting 
>>device. If you have any technical knowledge regarding low level ethernet 
>>1 ) PEB interface. The board can run in the PEB or stand alone with a disk drive 
>>power connector ( allows use in PC case etc ).
>>2 ) 2 * SD card slots. No VHDL has been created for this yet but the connections 
>>are there anyway. Opencores.org may have VHDL we can use.
>>3 ) 1 * USB connector. No VHDL exists for this but the MSX people have a 
>>connection like this so I thought why the hell not !
>>4 ) IDE interface. Again no VHDL but I'm sure we can ask a certain Mr Nouspikel 
>>if we can copy his design. ( Allows 2 drives )
>>7 ) 1 * audio output from the sound generator. Don't know about speech just yet 
>>- can use existing PEB mounted speech if the worst comes to the worst.
>>8 ) 18 bit RGB output with Hsync and Vsync. Should work on normal VGA monitor. 
>>May get SVideo also at some point - depends of FPGA pin count.
>>9 ) Joystick interface.

---

From: fdos <[email-masked]>
Date: Wed, 07 Jul 2010 08:06:02 -0700

Kory,

I've not heard of this Geneve 2 development.  Is there any connection 
with RetrOS?  Which is a Geneve/Power9 development that phases from a 
TMS9995 up to dual TMS99105/TMS991110 with MDOS as the initial OS.

Bill S

kory wrote:
> that really caught my eye.. the Geneve 2.. Is this a "real" project, and 
> does anyone have any idea on cost etc..
> 
> It really amazes me that there is so much love and dedication this many 
> years later for the TI/Geneve. I will be introducing my daughter to the 
> TI very soon. She is still too young. My hopes are that she may hold 
> some interest in it and ask me to help her program it like I asked my 
> dad so many years ago. The thought of having a new computer that we can 
> both learn on at the same time is a priceless thought, especially if it 
> is related to my first computer!
> 
> Anyway, if anyone has any info on the G2 or if there is a thread related 
> to it here, please point me in the proper direction!
> 
> Thanks!
> -Kory
> 
>

---

From: fdos <[email-masked]>
Date: Wed, 07 Jul 2010 08:13:45 -0700

Mark,

You're in the know, and didn't tell me?  Is it likely to use MDOS 
(initially)?  A reason to continue Forth+ 2.0 development?

I understand about vapor ware, but a little hint wouldn't have hurt the 
cause.  Are you involved in the development?

Bill S

mark wills wrote:
>  
> 
> Yes. It's just taken a major leap forward, but I'm not saying anything 
> more than that, vapour is my anathema!
> 
> Mark
> 
> 
> 
>     *From:* Owen Brand <[email-masked]>
>     *To:* "[email-masked]" <[email-masked]>
>     *Sent:* Tue, 6 July, 2010 23:52:59
>     *Subject:* Re: [TI994A] Re: Geneve 2 ???
> 
> 
> 
>     Ahh--- the super secret UK project is going to be called "Geneve 2".
>      :). Those sneaky buggers. :). It's supposed to be un-freaking
>     http://www.Opry99er.com <http://www.Opry99er.com>
> 
>     On Jul 6, 2010, at 6:24 PM, "kory" <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>>      
>>
>>
>>
>>     Yes, we are getting a brand new TI super computer that is
>>     compatible with the TI 99/4a software and beyond.
>>
>>     This project has been kept secret until today.. The TI User Group
>>     UK shows you the spec... however we are looking to add an Gigabit
>>     wireless adaptor which is a universal self connecting device. If
>>     you have any technical knowledge regarding low level ethernet
>>     1 ) PEB interface. The board can run in the PEB or stand alone
>>     with a disk drive power connector ( allows use in PC case etc ).
>>     2 ) 2 * SD card slots. No VHDL has been created for this yet but
>>     the connections are there anyway. Opencores.org
>>     <http://Opencores.org> may have VHDL we can use.
>>     VGA monitor. May get SVideo also at some point - depends of FPGA
>>     pin count.
>>     9 ) Joystick interface.
>>     --- In <mailto:TI994A%40yahoogroups.com>[email-masked]
>>     <mailto:[email-masked]>, Owen Brand <owenbrand@...> wrote:
>>     >
>>     > <http://www.Opry99er.com>http://www.Opry99er.com
>>     <http://www.Opry99er.com>
>>     >

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Jul 2010 11:26:21 -0400

Good luck getting any info from these Brits.  :) Theyre keeping this  
thing under wraps pretty hardcore.  As an aside, I think there is a  
tiny bit of info online... Just hit up Google and search.  :) If one  
can find the info, I'm sure many can. Is Richard Twyning on this  
list?  He may allow a tiny bit of info out.

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jul 7, 2010, at 11:13 AM, fdos <[email-masked]> wrote:

>> 2".
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: fdos <[email-masked]>
Date: Wed, 07 Jul 2010 08:39:12 -0700

I'm not sure about this list, but he (Richard Twyning) is on the other list.

Bill S

Owen Brand wrote:
> On Jul 7, 2010, at 11:13 AM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  > Mark,
>  >
>  >> *From:* Owen Brand <[email-masked] 
> <mailto:owenbrand%40opry99er.com>>
>  >> *To:* "[email-masked] <mailto:TI994A%40yahoogroups.com>" 
> <[email-masked] <mailto:TI994A%40yahoogroups.com>>
> <mailto:shortbusalaboard%40aol.com>
>  >> <mailto:[email-masked] 
> <mailto:shortbusalaboard%40aol.com>>> wrote:
>  >>
>  >>>
>  >>>
>  >>>
>  >>>
> <mailto:TI994A%40yahoogroups.com>
>  >>> <mailto:[email-masked] <mailto:TI994A%40yahoogroups.com>>, 
> Owen Brand <owenbrand@...>
>  >>> wrote:
>  >>>>

---

From: mark wills <[email-masked]>
Date: Wed, 7 Jul 2010 15:42:04 +0000 (GMT)

I think it's because the TI has had more than it's fair share of vapour over the 
years!

Not only that, it is (at this point) a one-man operation, and it puts a lot of 
pressure on him. So, we're just trying to keep the heat off and let the genius 
that is Gary Smith do what he does best, without the need for a divorce on the 
way! ;-)

Mark

----- Original Message ----
> Sent: Wed, 7 July, 2010 16:26:21

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Jul 2010 11:48:34 -0400

Ahh--- I was mistaken... I thought Richard was point man here.  See,  
it's THAT secret.  :).

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jul 7, 2010, at 11:42 AM, mark wills <[email-masked]>  
wrote:

> > > I understand about vapor ware, but a little hint wouldn't have  
> hurt
> > > the
> > >>>> Welcome back!! I don't know about the Geneve 2... Never heard  
> of
> > >>> it.
> > >>>> place to check is Atariage.com--- TI-99/4a programming  
> subforum.
> > >>> All

---

From: mark wills <[email-masked]>
Date: Wed, 7 Jul 2010 15:40:10 +0000 (GMT)

Hi Bill

Well, I was sworn to secrecy, so couldn't say anything.

At the moment it looks like Gary Smith in the UK is doing it all by himself, 
including designing a TMS9995 in VHDL (which he has completed). Yes, I believe 
it will use MDOS and will be Geneve compatible. May even have a degree of 4A 
compatability - however, Gary Smith is the man in the know.

I'll probably get involved very much later on, with the MDOS stuff. In fact, I'm 
thinking of a completely new OS for it. Start from scratch. There nothing wrong 
with MDOS, but the code basde is very old, and if I am correctly informed, there 
are some parts of the OS that nobody understands, as well as possibly one or two 
long-standing bugs. The idea of developing a brand new OS, essentially 
compatible with MDOS, but a new code-base, for a processor I am already intimate 
with, is a tempting one!

Yes, I would say Forge on with Forth, for sure. This new Geneve II is pants-down 
fast. Leaves the original Geneve in the dust.

Mark

----- Original Message ----
> From: fdos <[email-masked]>
> To: [email-masked]
> Sent: Wed, 7 July, 2010 16:13:45

---

From: "James W." <[email-masked]>
Date: Wed, 07 Jul 2010 16:22:40 -0000

Yes,

There was, and still is, some secrecy involved. Especially when we were researching Geneve-related items and needed Tim's help. We did have emails sent to Jeff White for some technical data but I don't know if he ever answered to Gary.

This Geneve II Project has been going on for at least 2 1/2 years now. 

Fortunately, alot of what Gary needs is from opencores.org, especially regarding PS/2 VHDL code. We did get a VHDL 9902 model from a Frenchman and that may need to be tweaked.

Joe Delekto was helping out at one time regarding getting a good C compiler up and running-to take advantage of the Contiki system-which will provide alot of what we need regrading TCP/IP, etc. A good C 99, not the c99, compiler will enable us to have alot of programs and even other OS's to run on the Geneve II.

Gary has done a great job and I really believe that his 9995 implementation will be really, really nice-and super fast. Plus he took advantage of the FPU available on opencores.org

I really think that all of the remaining programmers, and emulator programmers-such as Tursi, ought to get together and touch base with Mark and Tim. Pool our resources like they do in the Open Source Community.

James
(secrecy being the best policy until ready to talk)

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> > From: fdos <fdosbrs@...>
> > >     *From:* Owen Brand <owenbrand@...>
> > >     On Jul 6, 2010,  at 6:24 PM, "kory" <shortbusalaboard@...
> > >      <mailto:shortbusalaboard@...>>  wrote:
> > > 
> > >>      
> > >>
> > >>
> > >>
> > >>      <mailto:[email-masked]>, Owen Brand  <owenbrand@> wrote:
> > >>     >
> > >>     > On Jul 6, 2010, at 6:08 PM, "kory"  <shortbusalaboard@> wrote:
> > >>      >
> > >>     > > Hi All!
> > >>     >  >

---

From: fdos <[email-masked]>
Date: Wed, 07 Jul 2010 09:44:08 -0700

Mark,

Understood, I just enjoying stirring the pot at every opportunity. :-)

A one-man operation--seems very tough.  I like to delegate parts to 
others, so I can concentrate on the ones I know best.  I don't mind 
sharing the credit, therefore spreading it around is OK--just that the 
end results will be something I need and will use frequently.  So far 
this works well for me.  I'm still using Forth+ from time to time when I 
go in search of code for X4th99.  I see things I can do better now, so I 
make a note of it as no time to dilly dally.

Time, however, cools interest for others.  I started work on Forth+ in 
mid 1991 and released Forth+ 1.00 in December of 1993.  I think it 
topped at 12 registered users.

Bill S

mark wills wrote:
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
> Owen Brand <owenbrand@...> wrote:
>  > >> >

---

From: "Beery" <[email-masked]>
Date: Wed, 07 Jul 2010 16:49:02 -0000

If someone wants to write a new OS for a "Geneve 2", it shouldn't be all that hard to create a new OS using MESS and the Geneve emulator.  All the tools are already present, just design something new.  Myself though, I would think rewriting the XOP's if you wanted to remain MDOS compatible would be a waste of time.  Rather, one could just write a new command line interpreter where you avoid the MDOS prompt, etc.

Ron Walters before he passed away had a vision of a "super Geneve".  With the TI disk structure and running a 9958, there were options for some unique video security applications that would be hard to crack.  Primarily because it was different than Microsoft.  The 9958 offered opportunities that did not exist with the 9938 with some video handling.

Beery

--- In [email-masked], "James W." <jwkrych@...> wrote:
> --- In [email-masked], mark wills <markrobertwills@> wrote:
> >
> > Hi Bill
> > 
> > > From: fdos <fdosbrs@>
> > > >     *From:* Owen Brand <owenbrand@>
> > > >     On Jul 6, 2010,  at 6:24 PM, "kory" <shortbusalaboard@
> > > >      <mailto:shortbusalaboard@>>  wrote:
> > > > 
> > > >>      
> > > >>
> > > >>
> > > >>

---

From: "Ksarul" <[email-masked]>
Date: Wed, 07 Jul 2010 13:05:40 -0400

And if you really wanted to carry it on further, you could try and use the
Yamaha V9990.  I have a few of those that I plan to tinker with once I get
the time to do so.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Beery
Sent: Wednesday, July 07, 2010 12:49 PM
To: [email-masked]
Subject: [TI994A] Re: Geneve 2 ???

If someone wants to write a new OS for a "Geneve 2", it shouldn't be all
that hard to create a new OS using MESS and the Geneve emulator. All the
tools are already present, just design something new. Myself though, I would
think rewriting the XOP's if you wanted to remain MDOS compatible would be a
waste of time. Rather, one could just write a new command line interpreter
where you avoid the MDOS prompt, etc.

Ron Walters before he passed away had a vision of a "super Geneve". With the
TI disk structure and running a 9958, there were options for some unique
video security applications that would be hard to crack. Primarily because
it was different than Microsoft. The 9958 offered opportunities that did not
exist with the 9938 with some video handling.

Beery

--- In [email-masked] <mailto:TI994A%40yahoogroups.com> , "James W."
<jwkrych@...> wrote:
>
> Yes,
> 
> There was, and still is, some secrecy involved. Especially when we were
researching Geneve-related items and needed Tim's help. We did have emails
sent to Jeff White for some technical data but I don't know if he ever
answered to Gary.
> Fortunately, alot of what Gary needs is from opencores.org, especially
regarding PS/2 VHDL code. We did get a VHDL 9902 model from a Frenchman and
that may need to be tweaked.
> 
> Joe Delekto was helping out at one time regarding getting a good C
compiler up and running-to take advantage of the Contiki system-which will
provide alot of what we need regrading TCP/IP, etc. A good C 99, not the
c99, compiler will enable us to have alot of programs and even other OS's to
run on the Geneve II.
> 
> Gary has done a great job and I really believe that his 9995
implementation will be really, really nice-and super fast. Plus he took
advantage of the FPU available on opencores.org
> 
> I really think that all of the remaining programmers, and emulator
programmers-such as Tursi, ought to get together and touch base with Mark
and Tim. Pool our resources like they do in the Open Source Community.
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com> , mark
wills <markrobertwills@> wrote:
> > > > *To:* "[email-masked] <mailto:TI994A%40yahoogroups.com> "
<[email-masked] <mailto:TI994A%40yahoogroups.com> >
> > > >> <mailto:[email-masked] <mailto:TI994A%40yahoogroups.com> >,

---

From: fdos <[email-masked]>
Date: Wed, 07 Jul 2010 10:38:38 -0700

I don't think trying to go to a new OS is wise initially.  Do we really 
think that a new major OS would be immediately bug free?  MDOS is pretty 
solid and there are a significant number of good applications for it. 
Therefore a good starting point for a new machine.  If it flies well and 
gains a significant user base that believes replacing the OS is a great 
idea.....

What ever happened to ADOS from AEI?  It was suppose to replace that 
early, very buggy MDOS, but it never came along.  I wrote to them when I 
was experiencing so many problems with MDOS during the early days, but 
never heard back from them.  I say, let the machine breathe for a while 
before stuffing too much new vapor ware into it.  Remember Myarc bit off 
more than it could chew (new machine, new OS, new application software, 
etc.), initially.  Lets help Gary not make the same mistake.

Bill S

Beery wrote:
> tools are already present, just design something new. Myself though, I 
> would think rewriting the XOP's if you wanted to remain MDOS compatible 
> would be a waste of time. Rather, one could just write a new command 
> line interpreter where you avoid the MDOS prompt, etc.
> 
> Ron Walters before he passed away had a vision of a "super Geneve". With 
> the TI disk structure and running a 9958, there were options for some 
> unique video security applications that would be hard to crack. 
> Primarily because it was different than Microsoft. The 9958 offered 
> opportunities that did not exist with the 9938 with some video handling.
> 
> Beery
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, "James 
> W." <jwkrych@...> wrote:
>  >
>  > Yes,
>  >
>  > There was, and still is, some secrecy involved. Especially when we 
> were researching Geneve-related items and needed Tim's help. We did have 
> emails sent to Jeff White for some technical data but I don't know if he 
> ever answered to Gary.
>  >
>  > Fortunately, alot of what Gary needs is from opencores.org, 
> especially regarding PS/2 VHDL code. We did get a VHDL 9902 model from a 
> Frenchman and that may need to be tweaked.
>  >
> compiler up and running-to take advantage of the Contiki system-which 
> will provide alot of what we need regrading TCP/IP, etc. A good C 99, 
> not the c99, compiler will enable us to have alot of programs and even 
> other OS's to run on the Geneve II.
>  >
> programmers-such as Tursi, ought to get together and touch base with 
> Mark and Tim. Pool our resources like they do in the Open Source Community.
>  >
>  > James
>  > --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, mark 
> hurt the
>  > > > > *To:* "[email-masked] 
> <mailto:TI994A%40yahoogroups.com>" <[email-masked] 
> <mailto:TI994A%40yahoogroups.com>>
>  > > > >> <mailto:[email-masked] 
> <mailto:TI994A%40yahoogroups.com>>, Owen Brand <owenbrand@> wrote:
>  > > > >> >

---

From: Marc Hull <[email-masked]>
Date: Wed, 7 Jul 2010 11:24:16 -0700 (PDT)

I would suspect that Mr. Smith pretty much has a plan in the works.  How about we wait and see what he is cooking up instead of debating the flavor before the roast is done and risk turning off the cook ;-)

--- On Wed, 7/7/10, fdos <[email-masked]> wrote:

From: fdos <[email-masked]>
Subject: Re: [TI994A] Re: Geneve 2 ???
To: [email-masked]
Date: Wednesday, July 7, 2010, 12:38 PM

Bill S

Beery wrote:
>  >
>  > Yes,
>  >
>  > There was, and still is, some secrecy involved. Especially when we 
>  >
>  > This Geneve II Project has been going on for at least 2 1/2 years now.
>  >
>  > Fortunately, alot of what Gary needs is from opencores.org, 
>  >
>  > Joe Delekto was helping out at one time regarding getting a good C 
>  >
>  > Gary has done a great job and I really believe that his 9995 
>  >
>  > I really think that all of the remaining programmers, and emulator 
>  >
>  > James
>  > (secrecy being the best policy until ready to talk)
>  >
>  > --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, mark 
>  > >
>  > > Hi Bill
>  > >
>  > > Well, I was sworn to secrecy, so couldn't say anything.
>  > >
>  > > At the moment it looks like Gary Smith in the UK is doing it all by 
> himself,
>  > > including designing a TMS9995 in VHDL (which he has completed). 
> Yes, I believe
>  > > it will use MDOS and will be Geneve compatible. May even have a 
> degree of 4A
>  > > compatability - however, Gary Smith is the man in the know.
>  > >
>  > > I'll probably get involved very much later on, with the MDOS stuff. 
> In fact, I'm
>  > > thinking of a completely new OS for it. Start from scratch. There 
> nothing wrong
>  > > with MDOS, but the code basde is very old, and if I am correctly 
> informed, there
>  > > are some parts of the OS that nobody understands, as well as 
> possibly one or two
>  > > long-standing bugs. The idea of developing a brand new OS, essentially
>  > > compatible with MDOS, but a new code-base, for a processor I am 
> already intimate
>  > > with, is a tempting one!
>  > >
>  > > Yes, I would say Forge on with Forth, for sure. This new Geneve II 
> is pants-down
>  > > fast. Leaves the original Geneve in the dust.
>  > >
>  > > Mark
>  > >
>  > >
>  > >
>  > > ----- Original Message ----
>  > > > From: fdos <fdosbrs@>
>  > > > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > > > Sent: Wed, 7 July, 2010 16:13:45
>  > > > Subject: Re: [TI994A] Re: Geneve 2 ???
>  > > >
>  > > > Mark,
>  > > >
>  > > > You're in the know, and didn't tell me? Is it likely to use MDOS
>  > > > (initially)? A reason to continue Forth+ 2.0 development?
>  > > >
>  > > > I understand about vapor ware, but a little hint wouldn't have 
> hurt the
>  > > > cause. Are you involved in the development?
>  > > >
>  > > > Bill S
>  > > >
>  > > > mark wills wrote:
>  > > > >
>  > > > >
>  > > > > Yes. It's just taken a major leap forward, but I'm not saying 
> anything
>  > > > > more than that, vapour is my anathema!
>  > > > >
>  > > > > Mark
>  > > > >
>  > > > >
>  > > > >
>  > > > > *From:* Owen Brand <owenbrand@>
>  > > > > *To:* "[email-masked] 
>  > > > > *Sent:* Tue, 6 July, 2010 23:52:59
>  > > > > *Subject:* Re: [TI994A] Re: Geneve 2 ???
>  > > > >
>  > > > >
>  > > > >
>  > > > > Ahh--- the super secret UK project is going to be called 
> "Geneve 2".
>  > > > > :). Those sneaky buggers. :). It's supposed to be un-freaking
>  > > > > believable. :). Can't wait to see it
>  > > > >
>  > > > > Owen Brand
>  > > > >
>  > > > > **webmaster**
>  > > > > http://www.Opry99er.com <http://www.Opry99er.com>
>  > > > >
>  > > > > On Jul 6, 2010, at 6:24 PM, "kory" <shortbusalaboard@
>  > > > > <mailto:shortbusalaboard@>> wrote:
>  > > > >
>  > > > >>
>  > > > >>
>  > > > >>
>  > > > >>
>  > > > >> I read something earlier today about a G2 (Geneve 2) being shown
>  > > > >> this year at TREFF. I cut and pasted the info below.
>  > > > >>
>  > > > >> Yes, we are getting a brand new TI super computer that is
>  > > > >> compatible with the TI 99/4a software and beyond.
>  > > > >>
>  > > > >> This project has been kept secret until today.. The TI User Group
>  > > > >> UK shows you the spec... however we are looking to add an Gigabit
>  > > > >> Ethernet Controller to the machine so that it can connect to the
>  > > > >> internet. With this we can add products like the wnce2001 Ethernet
>  > > > >> wireless adaptor which is a universal self connecting device. If
>  > > > >> you have any technical knowledge regarding low level ethernet
>  > > > >> implementation then let us know..
>  > > > >> Any way here we go with the spec.
>  > > > >>
>  > > > >> 1 ) PEB interface. The board can run in the PEB or stand alone
>  > > > >> with a disk drive power connector ( allows use in PC case etc ).
>  > > > >> 2 ) 2 * SD card slots. No VHDL has been created for this yet but
>  > > > >> the connections are there anyway. Opencores.org
>  > > > >> <http://Opencores.org> may have VHDL we can use.
>  > > > >> 3 ) 1 * USB connector. No VHDL exists for this but the MSX people
>  > > > >> have a connection like this so I thought why the hell not !
>  > > > >> 4 ) IDE interface. Again no VHDL but I'm sure we can ask a certain
>  > > > >> Mr Nouspikel if we can copy his design. ( Allows 2 drives )
>  > > > >> 5 ) 64 MB DDR SDRAM for the CPU - this should be enough ;-)
>  > > > >> 6 ) 512KB VRAM. Looks like the 9958 will be used - not the 9938 as
>  > > > >> there is no mouse interface on the MSX 9938 :-(
>  > > > >> 7 ) 1 * audio output from the sound generator. Don't know about
>  > > > >> speech just yet - can use existing PEB mounted speech if the worst
>  > > > >> comes to the worst.
>  > > > >> 8 ) 18 bit RGB output with Hsync and Vsync. Should work on normal
>  > > > >> VGA monitor. May get SVideo also at some point - depends of FPGA
>  > > > >> pin count.
>  > > > >> 9 ) Joystick interface.
>  > > > >> 10 ) PS2 Keyboard interface.
>  > > > >> 11 ) PS2 mouse interface. No VHDL for this but doesn't seem too
>  > > > >> difficult.
>  > > > >> 12 ) Centronics PIO interface like RS232 card.
>  > > > >> 13 ) 9 pin RS232 channel. No VHDL yet.
>  > > > >> 14 ) Regulators to get 5V, 3V3, and 1V2. 1 Switching regulator
>  > > > >> used for efficiency.
>  > > > >> 15 ) 1 config device to program both FPGAs.
>  > > > >> 16 ) 12MHz oscillator - multiplied internally to get higher
>  > > > >> frequency operation.
>  > > > >> 17 ) 21MHz Xtal for video.
>  > > > >>
>  > > > >> Production of the PCB starts shortly...
>  > > > >>
>  > > > >> If you visit the TREFF we hope to have a large demo of the unit
>  > > > >> for you to see...
>  > > > >>
>  > > > >> --- In <mailto:TI994A%40yahoogroups.com>[email-masked] 
>  > > > >> <mailto:[email-masked] 
>  > > > >> >
>  > > > >> > Welcome back!! I don't know about the Geneve 2... Never heard of
>  > > > >> it.
>  > > > >> > If you like programming, this is a great place to get info...
>  > > > >> Another
>  > > > >> > place to check is Atariage.com--- TI-99/4a programming subforum.
>  > > > >> All
>  > > > >> > kinds of new games coming out regularly over there. :)
>  > > > >> >
>  > > > >> > Owen Brand
>  > > > >> >
>  > > > >> > **webmaster**
>  > > > >> > <http://www.Opry99er.com>http://www.Opry99er.com
>  > > > >> <http://www.Opry99er.com>
>  > > > >> >
>  > > > >> > On Jul 6, 2010, at 6:08 PM, "kory" <shortbusalaboard@> wrote:
>  > > > >> >
>  > > > >> > > Hi All!
>  > > > >> > >
>  > > > >> > > After being away for quite some time.. away from the Ti994a
>  > > > >> world, I
>  > > > >> > > decided to do a bit of browsing on the net and came across
>  > > > >> something
>  > > > >> > > that really caught my eye.. the Geneve 2.. Is this a "real"
>  > > > >> project,
>  > > > >> > > and does anyone have any idea on cost etc..
>  > > > >> > >
>  > > > >> > > It really amazes me that there is so much love and dedication
>  > > > >> this
>  > > > >> > > many years later for the TI/Geneve. I will be introducing my
>  > > > >> > > daughter to the TI very soon. She is still too young. My hopes
>  > > > >> are
>  > > > >> > > that she may hold some interest in it and ask me to help her
>  > > > >> program
>  > > > >> > > it like I asked my dad so many years ago. The thought of 
> having a
>  > > > >> > > new computer that we can both learn on at the same time is a
>  > > > >> > > priceless thought, especially if it is related to my first
>  > > > >> computer!
>  > > > >> > >
>  > > > >> > > Anyway, if anyone has any info on the G2 or if there is a 
> thread
>  > > > >> > > related to it here, please point me in the proper direction!
>  > > > >> > >
>  > > > >> > > Thanks!
>  > > > >> > > -Kory
>  > > > >> > >
>  > > > >> > >
>  > > > >> >
>  > > > >>
>  > > > >
>  > > > >
>  > > > >
>  > > >
>  > > >
>  > > > ------------------------------------
>  > > >
>  > > > Yahoo! Groups Links
>  > > >
>  > > >
>  > > >
>  > > >
>  > >
>  >
> 
> 

Yahoo! Groups Links

---

From: Insane Multitasker <[email-masked]>
Date: Wed, 7 Jul 2010 18:48:13 -0500

Mmm... roast... will its flavor be RoHS compliant?  ;)

To: [email-masked]
From: [email-masked]
Date: Wed, 7 Jul 2010 11:24:16 -0700
Subject: Re: [TI994A] Re: Geneve 2 ???

I don't think trying to go to a new OS is wise initially.  Do we really 
think that a new major OS would be immediately bug free?  MDOS is pretty 
solid and there are a significant number of good applications for it. 
Therefore a good starting point for a new
 machine.  If it flies well and 
gains a significant user base that believes replacing the OS is a great 
idea.....

Bill S

>  > > are some parts of the OS that nobody
 understands, as well as 
>  > > > > Ahh--- the super secret UK project is
 going to be called 
>  > > > >> 16 ) 12MHz oscillator - multiplied internally to get higher
>  > > > >> frequency
 operation.
>  > > > >> > > new computer that we can both learn on at the same time is a
 priceless thought, especially if it is related to my first
>  > > > >> computer!

Yahoo! Groups Links

 		 	   		  
_________________________________________________________________
The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail. 
http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5

---

From: "computerclassics2000" <[email-masked]>
Date: Thu, 08 Jul 2010 01:52:38 -0000

Wish I knew what RoHS was an acronym for...if I did, I'm thinking I might be able to supply an intelligent reply to Tim's post? :-)

Nonetheless, I wish Gary Smith GROMspeed in his quest to provide us with a revived Geneve (aka Pheonix2, aka Phoenix2) with which to do our 'things TI' bidding.

I am already bolstering my budget and my checkbook for the anticipated purchase of something so wonderful...

BillG

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:
> From: marc.hull@...
> --- On Wed, 7/7/10, fdos <fdosbrs@...> wrote:
> 
> From: fdos <fdosbrs@...>
> > W." <jwkrych@> wrote:

---

From: "Ksarul" <[email-masked]>
Date: Wed, 07 Jul 2010 22:12:00 -0400

Restriction of Hazardous Substances. . .RoHS.

There you go, Bill-it basically deals with the removal of lead from the
board manufacturing process, but it does cover a lot of other things too. .
.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
computerclassics2000
Sent: Wednesday, July 07, 2010 9:53 PM
To: [email-masked]
Subject: [TI994A] Re: Geneve 2 ???

Wish I knew what RoHS was an acronym for...if I did, I'm thinking I might be
able to supply an intelligent reply to Tim's post? :-)

Nonetheless, I wish Gary Smith GROMspeed in his quest to provide us with a
revived Geneve (aka Pheonix2, aka Phoenix2) with which to do our 'things TI'
bidding.

I am already bolstering my budget and my checkbook for the anticipated
purchase of something so wonderful...

BillG

--- In [email-masked] <mailto:TI994A%40yahoogroups.com> , Insane
Multitasker <insane_m@...> wrote:
> I would suspect that Mr. Smith pretty much has a plan in the works. How
about we wait and see what he is cooking up instead of debating the flavor
before the roast is done and risk turning off the cook ;-)

> > --- In [email-masked] <mailto:TI994A%40yahoogroups.com>
<mailto:TI994A%40yahoogroups.com>, "James 

> > > --- In [email-masked] <mailto:TI994A%40yahoogroups.com>
<mailto:TI994A%40yahoogroups.com>, mark 
> > > > > > *To:* "[email-masked] <mailto:TI994A%40yahoogroups.com>

of
subforum.
> > > > > >> > > It really amazes me that there is so much love and
dedication
> > > > > >> this
> > > > > >> > > daughter to the TI very soon. She is still too young. My
hopes
> > > > > >> are
> > > > > >> > > that she may hold some interest in it and ask me to help
her
> > > > > >> program
> __________________________________________________________
> http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar
<http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID2
8326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5>
&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5

---

From: Marc Hull <[email-masked]>
Date: Wed, 7 Jul 2010 19:13:02 -0700 (PDT)

Only in larger department stores or by special offer ;-)

Seems your a bit of a culprit in this play Timbo.  How'd ya keep such a straight face ?  You a bit of a Gibbs-o-nite ?

--- On Wed, 7/7/10, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Re: Geneve 2 ???
To: [email-masked]
Date: Wednesday, July 7, 2010, 6:48 PM

  

      

To: TI994A@yahoogroups. com
From: marc.hull@sbcglobal .net
Date: Wed, 7 Jul 2010 11:24:16 -0700
Subject: Re: [TI994A] Re: Geneve 2 ???

--- On Wed, 7/7/10, fdos <fdosbrs@frontiernet .net> wrote:

From: fdos <fdosbrs@frontiernet .net>
Subject: Re: [TI994A] Re: Geneve 2 ???
To: TI994A@yahoogroups. com
Date: Wednesday, July 7, 2010, 12:38 PM

Bill S

Beery wrote:
> --- In TI994A@yahoogroups. com <mailto:TI994A% 40yahoogroups. com>, "James 
> W." <jwkrych@...> wrote:
>  >
>  > Yes,
>  >
>  >
> programmers- such as Tursi, ought to get together and touch base with 
>  > --- In TI994A@yahoogroups. com <mailto:TI994A% 40yahoogroups. com>, mark 
>  > > > To: TI994A@yahoogroups. com <mailto:TI994A% 40yahoogroups. com>
>  > >
>  > > > > *To:* "TI994A@yahoogroups. com 
> <mailto:TI994A% 40yahoogroups. com>" <TI994A@yahoogroups. com 
> <mailto:TI994A% 40yahoogroups. com>>
>  > > > > **webmaster* *
>  > > > > http://www.Opry99er .com <http://www.Opry99er .com>
>  > > > >
>  > > > > <mailto:shortbusalab oard@>> wrote:
>  > > > >
>  > > > >>
>  > > > >>
>  > > > >>
>  > > >
 >>
>  > > > >> <http://Opencores. org> may have VHDL we can use.
>  > > > >> --- In <mailto:TI994A% 40yahoogroups. com>TI994A@yahoogroups. com 
> <mailto:TI994A% 40yahoogroups. com>
>  > > > >> <mailto:TI994A@yahoogroups. com 
> <mailto:TI994A% 40yahoogroups. com>>, Owen Brand <owenbrand@> wrote:
>  > > > >>
 >
>  > > > >> > place to check is Atariage.com- -- TI-99/4a programming subforum.
>  > > > >> All
>  > > > >> > **webmaster* *
>  > > > >> > <http://www.Opry99er .com>http://www.Opry99er .com
>  > > > >> <http://www.Opry99er .com>
>  > > > >> >
>  > > > ------------ --------- --------- ------
>  >
 > >

------------ --------- --------- ------

Yahoo! Groups Links

 		 	   		  
The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail.  Get busy.

---

From: "James W." <[email-masked]>
Date: Thu, 08 Jul 2010 02:25:00 -0000

Bill,

From what I was told, ADOS failed because Myarc held it's technical data way to close to itself-save for a privileged few.

Something that will be avoided with the Geneve II Project.

James

---

From: "James W." <[email-masked]>
Date: Thu, 08 Jul 2010 02:21:43 -0000

Yes, I totally agree.

Good thing he does the hardware and others will do the software/OS!

James

---

From: "James W." <[email-masked]>
Date: Thu, 08 Jul 2010 02:26:59 -0000

And it makes PCB repairs much more harder and PCB's themselves cannot use alot of the older components due to the much hotter temperatures needed that the older ones cannot handle.

James

---

From: "Stuart" <[email-masked]>
Date: Thu, 08 Jul 2010 11:27:13 -0000

Is anyone able to talk authoritatively about how RoHS affects our sort of 'amateur' activities?

I had a couple of bare prototype PCBs manufactured by www.expresspcb.com a month or two ago and they have a lead solder coating, and they were shipped to me in the UK which I can only assume is 'legal', despite them not being RoHS compliant. I'm guessing I couldn't build these boards up using lead solder and sell them in volume commerically as they would have to be RoHS compliant? Could I get away with selling them in small quantities (a few dozen perhaps) on e-bay, or would that also be breaking RoHS regulations? If I 'kept under the radar' of the authorities and just sold them to individuals? Are RoHS regulations bascially the same in the UK/Europe/US?

Just wondering from a purely academic viewpoint ...

Stuart.

---

From: "Beery" <[email-masked]>
Date: Thu, 08 Jul 2010 13:33:32 -0000

I agree with you Bill 100%.  If however Gary wants something new, I was hoping he wouldn't start from scratch and would leave at least the XOP's in place which is really the core of MDOS.  The CLI is just an application.

Beery

--- In [email-masked], fdos <fdosbrs@...> wrote:
> >  > > > >> frequency operation.

---

From: Marc Hull <[email-masked]>
Date: Thu, 8 Jul 2010 10:36:11 -0700 (PDT)

Not to step on your thread Stuart but....

My feeble research shows that this whole ROHS (as applied to Stuarts issue) is a European Union one.  Doesn't seem to effect the US currently (except in California where they want to ban everything except public drama and marijuana...;-)  Even in that "state of disarray" computer components (such as the one I believe you are talking about) don't seem to be covered by restrictions.  Am I wrong anyone ?? 

I guess if your looking for a way around the laws perhaps you should follow the Chinese model.  Lead doesn't seem to bother them one little bit. ;-)

--- On Thu, 7/8/10, Stuart <[email-masked]> wrote:

From: Stuart <[email-masked]>
Subject: [TI994A] RoHS (was Geneve 2)
To: [email-masked]
Date: Thursday, July 8, 2010, 6:27 AM

  

Stuart.

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:

> > tools are already present, just design something new. Myself

>  though, I 

> > other OS's

>  to run on the Geneve II.

> >  > > At the moment it looks like Gary Smith in the UK is doing it all by 

> >  > > including designing a TMS9995 in VHDL (which he has completed). 

> >  > > it will use MDOS and will be Geneve compatible. May even have a 

> >  > > I'll probably get involved very much later on, with the MDOS stuff. 

> >  > > thinking of a completely new OS for it. Start from scratch. There 

> >  > > with MDOS, but the code basde is very old, and if I am correctly 

> >  > > compatible with MDOS, but a new code-base, for a processor I am 

> >  > > Yes, I would say Forge on with Forth, for sure. This new Geneve II 

> >  > > > > Yes. It's just taken a major leap forward, but I'm not saying 

> >  > > > > more than that,

>  vapour is my anathema!

> >  > > > >> wireless adaptor which is a universal self

>  connecting device. If

> >  > > > >> 11 ) PS2 mouse interface. No VHDL for this but doesn't seem too

> >  > > > >> difficult.

> >  > > > >> 14 ) Regulators to get 5V, 3V3, and 1V2. 1 Switching regulator

> >  > > > >> used for efficiency.

> >  > > > >> If you visit the TREFF we hope to have a large demo of the unit

> >  > > > >> for you to see...

> >  > > > >> > Welcome back!! I don't know about the Geneve 2... Never heard of

> >  > > > >> > If you like programming, this is a great place to get info...

> >  > > > >> Another

> >  > > > >> > place to check is Atariage.com--- TI-99/4a programming subforum.

> >  > > > >> > > After being away for quite some time.. away from the Ti994a

> >  > > > >> world, I

> >  > > > >> > > decided to do a bit of browsing on the net and came across

> >  > > > >> something

> >  > > > >> > > that really caught my eye.. the Geneve 2.. Is this a "real"

> >  > > > >> project,

> >  > > > >> > > It really amazes me that there is so much love and dedication

> >  > > > >> > > daughter to the TI very soon. She is still too young. My hopes

> >  > > > >> > > that she may hold some interest in it and ask me to help her

> >  > > > >> > > it like I asked my dad so many years ago. The thought of 

> >  > > > >> > > Anyway, if anyone has any info on the G2 or if there is a

---

From: "computerclassics2000" <[email-masked]>
Date: Thu, 08 Jul 2010 18:07:45 -0000

A little background/history on Bill Sullivan's mention of AEI and ADOS.
  
On November 28, 1986 an upload to CompuServe announces the formation of Access Engineering Inc. (AEI), a firm founded by Chris Bobbitt, Jim Horn and Richard Roseen. In the announcement Access Engineering officially announces its formation, introduces its principals, and provides detailed technical descriptions of four products; two operating systems; ADOS and AMOS (multi-tasking version of ADOS)and two compiled languages, AC-BASIC and AC-Pascal, are introduced and described.  Opportunities for Value Added Resellers and dealers are briefly mentioned, something new for 99ers. 

-From the R/D Computing Newsletter dated Mar 1987-

Introducing: ACCESS ENGINEERING INC. (AEI).

Description: AEI was founded in the spring of 1986 specifically to produce products for the newly developed Myarc 9640 computer. The creation of this company and the associated risks is based on analysis that concluded that; both the technology and the market potential of the new computer is significant/AEI brings to the Myarc 9640 marketplace not only the expertise of its founders and dealer network, but a development facility that already contains 6 microprocessor types along with a mini computer based development system. AEI has or is in the process of developing a series of professional level products to take advantage of the speed, memory and graphics of the Myarc 9640. We, after careful evaluation, believe to be a superior machine in several levels of the marketplace.

Our Founders:
JIM HORN: The SYSOP (SYStem OPerator) of the H & R Block firm CompuServe for the TIFORUM, a clearinghouse of TI information.

RICHARD ROSEEN: A trained engineer and electronics patent examiner with the U.S. Patent Office, Washington, D.C.

CHRIS BOBBITT: Has experience with the mini and mainframe world, having developed computer requirement specifications for a government agency, the U.S. Naval Research Lab.

GOALS: AEI will produce two operating systems, four computer languages and numerous utilities, business packages and applications for the Myarc 9640.

INTRODUCING ADOS:
AEI Disk Operating System

INTRODUCTION: ADOS is an advanced, modern, disk-oriented operating system that provides a comprehensive set of user services, resource management features, facilities and requests available to program
operating under ADOS control.

DESCRIPTION: Like popular operating systems in the expensive microcomputing world such as MS-DOS and UNIX, ADOS supports a large, comprehensive library of utilities. These include an editor, assembler, file maagement utilities, a smart linker, a BASIC interpreter, file compression utilities and more. The smart linker is capable of resolving all references and declarations as well as supporting linked libraries of routines. Unlike many operating systems, ADOS permits full "wildcards" at all prompts. A wildcard in operating system parlance is the ability to allow the operator to specify an incomplete or imprecise search specification of the item, such as a file, with a symbol being subsituted for the remaining characters. Other available capabilities will be such mini computer like features as mnemonic based command names, a complete set of file, disk and screen input output utilities available to the programmer as well as powerful debugging and diagnostic tools, along with access to all system functions. ADOS is the perfect operating system for the user, programmer and the systems designer. 

ADOS frees the talented users of the 9900 world to enter the world of the "Value Added Reseller", marketing to  profitable vertical markets as recognised as the stand-alone word processor users, or as exotic as any custom business or scientific application imagined.

ADOS can be easily modified for a particular vertical application. User programs can interface with all operating system resources and utilites with an easy to understand, consistent protocol. This allows the development of user shells which are as easy to write as any functional program. A unique file management approach gives the ADOS, by design, a reliable environment, with file loss greatly reduced while disk transfers work faster.

COMPATIBILITY: The power of ADOS is not bought at the cost of compatibility. A complete library of both 99/4A and commercial Texas Instruments DNOS (a mature mini computer system) based applications are compatible. This suite of capabilities include utilities, business, entertainment and educational software.

ADOS will DIRECTLY load	binary files from machines that support these operating systems, thus opening a vast library of documented and tested software to the user at minimal expense and conversion effort.

Many of these products could be	marketed to established professional users used to paying many times the going rate for similar products.

---

From: fdos <[email-masked]>
Date: Fri, 09 Jul 2010 10:05:41 -0700

Beery,

Agreed.  The XOP's are what made Forth+ possible in the time-frame (mid 
1991 start, Dec 1993 release) once I got a handle on MDOS capabilities 
(memory management mostly), that is, and that came from the MDOS gurus 
on Delphi.  If the TI had something similar I could save tons of time 
developing X4th99--maybe a cartridge with MDOS like XOP calls 
(anybody?).  I would be in Forth heaven :-)

Bill S

Beery wrote:
>  
> 
> I agree with you Bill 100%. If however Gary wants something new, I was 
> hoping he wouldn't start from scratch and would leave at least the XOP's 
> in place which is really the core of MDOS. The CLI is just an application.
> 
> Beery
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, fdos 
> <fdosbrs@...> wrote:
>  >
>  > > > > > >> --- In 
> <mailto:TI994A%40yahoogroups.com>[email-masked]

---

From: fdos <[email-masked]>
Date: Fri, 09 Jul 2010 10:10:13 -0700

BillG,

Thanks for posting this AEI and ADOS information.  I know I have it 
somewhere (hot garage probably), but I've not found it yet.

Bill S

computerclassics2000 wrote:
> On November 28, 1986 an upload to CompuServe announces the formation of 
> Access Engineering Inc. (AEI), a firm founded by Chris Bobbitt, Jim Horn 
> and Richard Roseen. In the announcement Access Engineering officially 
> announces its formation, introduces its principals, and provides 
> detailed technical descriptions of four products; two operating systems; 
> ADOS and AMOS (multi-tasking version of ADOS)and two compiled languages, 
> AC-BASIC and AC-Pascal, are introduced and described. Opportunities for 
> Value Added Resellers and dealers are briefly mentioned, something new 
> for 99ers.
> 
> Description: AEI was founded in the spring of 1986 specifically to 
> produce products for the newly developed Myarc 9640 computer. The 
> creation of this company and the associated risks is based on analysis 
> that concluded that; both the technology and the market potential of the 
> new computer is significant/AEI brings to the Myarc 9640 marketplace not 
> only the expertise of its founders and dealer network, but a development 
> facility that already contains 6 microprocessor types along with a mini 
> computer based development system. AEI has or is in the process of 
> developing a series of professional level products to take advantage of 
> the speed, memory and graphics of the Myarc 9640. We, after careful 
> evaluation, believe to be a superior machine in several levels of the 
> marketplace.
> 
> Our Founders:
> JIM HORN: The SYSOP (SYStem OPerator) of the H & R Block firm CompuServe 
> for the TIFORUM, a clearinghouse of TI information.
> 
> CHRIS BOBBITT: Has experience with the mini and mainframe world, having 
> developed computer requirement specifications for a government agency, 
> the U.S. Naval Research Lab.
> 
> GOALS: AEI will produce two operating systems, four computer languages 
> and numerous utilities, business packages and applications for the Myarc 
> 9640.
> 
> INTRODUCING ADOS:
> INTRODUCTION: ADOS is an advanced, modern, disk-oriented operating 
> system that provides a comprehensive set of user services, resource 
> management features, facilities and requests available to program
> DESCRIPTION: Like popular operating systems in the expensive 
> microcomputing world such as MS-DOS and UNIX, ADOS supports a large, 
> comprehensive library of utilities. These include an editor, assembler, 
> file maagement utilities, a smart linker, a BASIC interpreter, file 
> compression utilities and more. The smart linker is capable of resolving 
> all references and declarations as well as supporting linked libraries 
> of routines. Unlike many operating systems, ADOS permits full 
> "wildcards" at all prompts. A wildcard in operating system parlance is 
> the ability to allow the operator to specify an incomplete or imprecise 
> search specification of the item, such as a file, with a symbol being 
> subsituted for the remaining characters. Other available capabilities 
> will be such mini computer like features as mnemonic based command 
> names, a complete set of file, disk and screen input output utilities 
> available to the programmer as well as powerful debugging and diagnostic 
> tools, alon g with access to all system functions. ADOS is the perfect 
> operating system for the user, programmer and the systems designer.
> 
> ADOS frees the talented users of the 9900 world to enter the world of 
> the "Value Added Reseller", marketing to profitable vertical markets as 
> recognised as the stand-alone word processor users, or as exotic as any 
> custom business or scientific application imagined.
> 
> ADOS can be easily modified for a particular vertical application. User 
> programs can interface with all operating system resources and utilites 
> with an easy to understand, consistent protocol. This allows the 
> development of user shells which are as easy to write as any functional 
> program. A unique file management approach gives the ADOS, by design, a 
> reliable environment, with file loss greatly reduced while disk 
> transfers work faster.
> 
> COMPATIBILITY: The power of ADOS is not bought at the cost of 
> compatibility. A complete library of both 99/4A and commercial Texas 
> Instruments DNOS (a mature mini computer system) based applications are 
> compatible. This suite of capabilities include utilities, business, 
> entertainment and educational software.
> 
> ADOS will DIRECTLY load binary files from machines that support these 
> operating systems, thus opening a vast library of documented and tested 
> software to the user at minimal expense and conversion effort.
> 
> Many of these products could be marketed to established professional 
> users used to paying many times the going rate for similar products.
>