Subject: Re: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz

From: [email-masked]
Date: Wed, 07 Apr 2010 15:05:35 -0500 (CDT)

Actually, the SNUG 32k-16 is available as a kit, Owen. Modified consoles also pop up now and then on ebay. The SNUG design replaces the pad rams with a daughter board that has the required memory and support chips on it. In addition to putting the 32k on the 16 bit buss it also has the feature of switching between 8 bit and sixteen bit so you can still run programs that don't like the faster timing. Another switch can toggle the 8k ram located at >6000 - >7FFF on or off and another switch can expand the scratch pad ram area from >8300 - >83FF to >8000 - >83FF.  The console that runs the Hidden Reef BBS has this kit installed since 1996 and has been running 24/7 without problems with the kit so it is a reliable mod as well.

A console with the 32k-16 mod and the 3.58 crystal mod runs about twice as fast as a stock console. (Except for code that doesn't use the expansion RAM and just uses VDP.)

Some games don't like the speed and the joysticks can be a problem sometimes but where the 32k-16 @ 3.58 Mhz really shines in my opinion is when working with file utilities and such. It really speeds up file copy and hard drive backup as well as communications if you install the matching EPROM in the RS232 card which is availble from "Humming Bird".

Nothing like cruising the innernets with a 4A and Jeff Brown's ZT4 terminal at 38.8 through a UNIX shell account. :)

Apr 7, 2010 12:49:03 PM, [email-masked] wrote:

Thanks-- very nice mod, Richard.  Wish those SNUG consoles were more readily available.  Just as a question, the 16 bit buss, does that eliminate the need for the multiplexing?

Owen Brand

Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Apr 2010 16:16:22 -0400

So if I buy the kit, it comes with the faster crystal as well as the  
other components?  Forgive my ignorance on hardware mods.. I've never  
done much with hardware, aside from removing a jumper off the shunt  
pack on a TI disk drive to allow for (2) 3.5" drives to be installed  
as DSK2 and DSK3.  Other than that, I'm pretty much a rookie.  :)

Owen Brand
Opry99er.com

On Apr 7, 2010, at 4:05 PM, [email-masked] wrote:

> Actually, the SNUG 32k-16 is available as a kit, Owen. Modified  
> consoles also pop up now and then on ebay. The SNUG design replaces  
> the pad rams with a daughter board that has the required memory and  
> support chips on it. In addition to putting the 32k on the 16 bit  
> buss it also has the feature of switching between 8 bit and sixteen  
> bit so you can still run programs that don't like the faster timing.  
> Another switch can toggle the 8k ram located at >6000 - >7FFF on or  
> off and another switch can expand the scratch pad ram area from  
> >8300 - >83FF to >8000 - >83FF.  The console that runs the Hidden  
> Reef BBS has this kit installed since 1996 and has been running 24/7  
> without problems with the kit so it is a reliable mod as well.
>
> A console with the 32k-16 mod and the 3.58 crystal mod runs about  
> twice as fast as a stock console. (Except for code that doesn't use  
> the expansion RAM and just uses VDP.)
>
> Some games don't like the speed and the joysticks can be a problem  
> sometimes but where the 32k-16 @ 3.58 Mhz really shines in my  
> opinion is when working with file utilities and such. It really  
> speeds up file copy and hard drive backup as well as communications  
> if you install the matching EPROM in the RS232 card which is  
> availble from "Humming Bird".
> Nothing like cruising the innernets with a 4A and Jeff Brown's ZT4  
> terminal at 38.8 through a UNIX shell account. :)
>
>
> Thanks-- very nice mod, Richard.  Wish those SNUG consoles were more  
> readily available.  Just as a question, the 16 bit buss, does that  
> eliminate the need for the multiplexing?
>
> Owen Brand
> Opry99er.com
>

---

From: Marc Hull <[email-masked]>
Date: Wed, 7 Apr 2010 14:07:16 -0700 (PDT)

->    A console with the 32k-16 mod and the 3.58 crystal mod runs about twice 
as fast as a stock console. (Except for code that doesn't use the 
expansion RAM and just uses VDP.) <-

As an added endorsement...

This is what I use to program in assembly.  Combine this console with a RamDisk (which I think you have) and your save/assemble/run time goes from about five minutes down to about one....  Worth every penny (or burnt finger depending on which way you go ;-).

Sorry to step on your thread Richard.

--- On Wed, 4/7/10, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz
To: [email-masked]
Date: Wednesday, April 7, 2010, 3:05 PM

  

      

 

Apr 7, 2010 12:49:03 PM, TI994A@yahoogroups. com wrote:

Owen Brand

Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Apr 2010 18:53:13 -0400

Thanks Marc.  Sounds like I need to go with this setup.  Did you save  
your assembler diskettes to the HRD?  And yes, I still have my prized  
HRD.  :)

Owen Brand
Opry99er.com

On Apr 7, 2010, at 5:07 PM, Marc Hull <[email-masked]> wrote:

> ->    A console with the 32k-16 mod and the 3.58 crystal mod runs  
> about twice as fast as a stock console. (Except for code that  
> doesn't use the expansion RAM and just uses VDP.) <-
>
> This is what I use to program in assembly.  Combine this console  
> with a RamDisk (which I think you have) and your save/assemble/run  
> time goes from about five minutes down to about one....  Worth every  
> penny (or burnt finger depending on which way you go ;-).
>

---

From: Marc Hull <[email-masked]>
Date: Wed, 7 Apr 2010 16:31:40 -0700 (PDT)

Use Funnel Web and throw your E/A cart in the trash (not really because you will need it as a paper weight ;-)

--- On Wed, 4/7/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz
To: "[email-masked]" <[email-masked]>
Date: Wednesday, April 7, 2010, 5:53 PM

  

      Thanks Marc.  Sounds like I need to go with this setup.  Did you save your assembler diskettes to the HRD?  And yes, I still have my prized HRD.  :)

Owen BrandOpry99er.com
On Apr 7, 2010, at 5:07 PM, Marc Hull <marc.hull@sbcglobal .net> wrote:

    

As an added endorsement. ..

This is what I use to program in assembly.  Combine this console with a RamDisk (which I think you have) and your save/assemble/ run time goes from about five minutes down to about one....  Worth every penny (or burnt finger depending on which way you go ;-).

--- On Wed, 4/7/10, swim4home@verizon. net <swim4home@verizon. net> wrote:

From: swim4home@verizon. net <swim4home@verizon. net>
Subject: Re: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz
To: TI994A@yahoogroups. com
Date: Wednesday, April 7, 2010, 3:05 PM

    

 

Owen Brand

Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Apr 2010 19:41:10 -0400

Funnel web, eh?  :) The new-age crazies have been trying to convince  
me to code in Notepad++ and assemble using ASM9900.  Bunch of  
crazies.  :) I think FW is on the Diskettes I received with my HRD,  
correct?  BTW, my E/A cart is very important to my Crap-game  
programming--- I use it to keep the dot matrix printer paper in the  
tractors so I can print listings.  :)

No but seriously.... I am such a rook on this A/L stuff.  Marc, if I  
buy you a pallet of PBR and drive out to hick country, would you show  
me your magic with the TMS9900?  It will be like King Arthur pulling  
Excalibur from the watered-down lake of cheap beer... Only instead of  
a sword, it would be op-codes.  :)

Owen Brand
Opry99er.com

On Apr 7, 2010, at 7:31 PM, Marc Hull <[email-masked]> wrote:

> Use Funnel Web and throw your E/A cart in the trash (not really  
> because you will need it as a paper weight ;-)
>
> Thanks Marc.  Sounds like I need to go with this setup.  Did you  
> save your assembler diskettes to the HRD?  And yes, I still have my  
> prized HRD.  :)
>
> Owen Brand
> Opry99er.com
>
>> with a RamDisk (which I think you have) and your save/assemble/ run  
>> time goes from about five minutes down to about one....  Worth  
>> every penny (or burnt finger depending on which way you go ;-).
>>
>> bit so you can still run programs that don't like the faster  
>> timing. Another switch can toggle the 8k ram located at >6000 -  
>> >7FFF on or off and another switch can expand the scratch pad ram  
>> area from >8300 - >83FF to >8000 - >83FF.  The console that runs  
>> the Hidden Reef BBS has this kit installed since 1996 and has been  
>> running 24/7 without problems with the kit so it is a reliable mod  
>> as well.
>>
>> Thanks-- very nice mod, Richard.  Wish those SNUG consoles were  
>> more readily available.  Just as a question, the 16 bit buss, does  
>> that eliminate the need for the multiplexing?
>>
>> Owen Brand
>> Opry99er.com
>
>

---

From: Tony Knerr <[email-masked]>
Date: Wed, 07 Apr 2010 19:54:44 -0400

Hold on now! How do I enter into the pallet of PBR sweepstakes? ;)

Tony

Owen Brand wrote:
> me to code in Notepad++ and assemble using ASM9900.  Bunch of crazies. 
>  :) I think FW is on the Diskettes I received with my HRD, correct? 
>  BTW, my E/A cart is very important to my Crap-game programming--- I 
> use it to keep the dot matrix printer paper in the tractors so I can 
> print listings.  :) 
>
> Opry99er.com <http://Opry99er.com>
>

---

From: fdos <[email-masked]>
Date: Wed, 07 Apr 2010 17:08:58 -0700

Why am I developing TI BASIC+ if everyone is going to throw their E/A 
modules away?  There are so few real Mini Memory Modules out there to 
consider using it instead.

Bill S

Marc Hull wrote:
> --- On *Wed, 4/7/10, Owen Brand /<[email-masked]>/* wrote:
> 
> 
>     On Apr 7, 2010, at 5:07 PM, Marc Hull <marc.hull@sbcglobal .net
>     </mc/compose?to=[email-masked]>> wrote:
> 
>>      
>>
>>     with a RamDisk (which I think you have) and your save/assemble/
>>     run time goes from about five minutes down to about one....  Worth
>>     --- On *Wed, 4/7/10, swim4home@verizon. net /<swim4home@verizon.
>>     net>/* wrote:
>>
>>
>>         Actually, the SNUG 32k-16 is available as a kit,
>>         Owen. Modified consoles also pop up now and then on ebay. The
>>         SNUG design replaces the pad rams with a daughter board that
>>         has the required memory and support chips on it. In addition
>>         to putting the 32k on the 16 bit buss it also has the feature
>>         of switching between 8 bit and sixteen bit so you can still
>>         run programs that don't like the faster timing. Another switch
>>         can toggle the 8k ram located at >6000 - >7FFF on or off and
>>         another switch can expand the scratch pad ram area from >8300
>>         - >83FF to >8000 - >83FF.  The console that runs the Hidden
>>         Reef BBS has this kit installed since 1996 and has been
>>         running 24/7 without problems with the kit so it is a reliable
>>         mod as well.
>>          
>>         A console with the 32k-16 mod and the 3.58 crystal mod runs
>>         doesn't use the expansion RAM and just uses VDP.)
>>          
>>         Some games don't like the speed and the joysticks can be a
>>         problem sometimes but where the 32k-16 @ 3.58 Mhz really
>>         shines in my opinion is when working with file utilities and
>>         such. It really speeds up file copy and hard drive backup as
>>         well as communications if you install the matching EPROM in
>>         the RS232 card which is availble from "Humming Bird".
>>         Nothing like cruising the innernets with a 4A and Jeff Brown's
>>         ZT4 terminal at 38.8 through a UNIX shell account. :)
>>          
>>
>>             Thanks-- very nice mod, Richard.  Wish those SNUG consoles
>>             were more readily available.  Just as a question, the 16
>>             bit buss, does that eliminate the need for the multiplexing?
>>
>>             Owen Brand
>>             <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>
>

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Apr 2010 20:10:40 -0400

Tony--- I've been reading all the A/L beginner's books and it just  
seems to roll off my back--- or in one ear, out the other....  
Whatever. I really learn by seeing and hearing.  I offered Marc a  
pallet of PBR to hand me Excalibur from the depths of the great lake  
of PBR.  :) To enter the sweepstakes, you must bring me..... A  
shrubbery.

Owen Brand
Opry99er.com

On Apr 7, 2010, at 7:54 PM, Tony Knerr <[email-masked]> wrote:

>> Funnel web, eh?  :) The new-age crazies have been trying to  
>> convince me to code in Notepad++ and assemble using ASM9900.  Bunch  
>> of crazies.  :) I think FW is on the Diskettes I received with my  
>> HRD, correct?  BTW, my E/A cart is very important to my Crap-game  
>> No but seriously.... I am such a rook on this A/L stuff.  Marc, if  
>> I buy you a pallet of PBR and drive out to hick country, would you  
>> show me your magic with the TMS9900?  It will be like King Arthur  
>> pulling Excalibur from the watered-down lake of cheap beer... Only  
>> instead of a sword, it would be op-codes.  :)
>>
>> Owen Brand
>> Opry99er.com
>>
>
>

---

From: fdos <[email-masked]>
Date: Wed, 07 Apr 2010 17:10:20 -0700

A good tutu joke should do it. :-)

Bill S

Tony Knerr wrote:
>> Â 
>> Funnel web, eh? Â :) The new-age crazies have been trying to convince 
>> me to code in Notepad++ and assemble using ASM9900. Â Bunch of 
>> crazies. Â :) I think FW is on the Diskettes I received with my HRD, 
>> correct? Â BTW, my E/A cart is very important to my Crap-game 
>> tractors so I can print listings. Â :)Â 
>>
>> No but seriously.... I am such a rook on this A/L stuff. Â Marc, if I 
>> me your magic with the TMS9900? Â It will be like King Arthur pulling 
>> a sword, it would be op-codes. Â :)
>>
>> Owen Brand

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Apr 2010 20:17:36 -0400

A nice one... But not too expensive.

Owen Brand
Opry99er.com

On Apr 7, 2010, at 8:10 PM, Owen Brand <[email-masked]> wrote:

>>> convince me to code in Notepad++ and assemble using ASM9900.   
>>> Bunch of crazies.  :) I think FW is on the Diskettes I received  
>>> with my HRD, correct?  BTW, my E/A cart is very important to my  
>>> Crap-game programming--- I use it to keep the dot matrix printer  
>>> paper in the tractors so I can print listings.  :)
>>>

---

From: Marc Hull <[email-masked]>
Date: Wed, 7 Apr 2010 18:26:23 -0700 (PDT)

Uh Owen.... That sounded kinda fruity ;-)

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz
To: "[email-masked]" <[email-masked]>
Date: Wednesday, April 7, 2010, 6:41 PM

  

      Funnel web, eh?  :) The new-age crazies have been trying to convince me to code in Notepad++ and assemble using ASM9900.  Bunch of crazies.  :) I think FW is on the Diskettes I received with my HRD, correct?  BTW, my E/A cart is very important to my Crap-game programming- -- I use it to keep the dot matrix printer paper in the tractors so I can print listings.  :) 
No but seriously... . I am such a rook on this A/L stuff.  Marc, if I buy you a pallet of PBR and drive out to hick country, would you show me your magic with the TMS9900?  It will be like King Arthur pulling Excalibur from the watered-down lake of cheap beer... Only instead of a sword, it would be op-codes.  :)
Owen BrandOpry99er.com
On Apr 7, 2010, at 7:31 PM, Marc Hull <marc.hull@sbcglobal .net> wrote:

    

--- On Wed, 4/7/10, Owen Brand <owenbrand@opry99er. com> wrote:

From: Owen Brand <owenbrand@opry99er. com>
Subject: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz
To: "TI994A@yahoogroups .com" <TI994A@yahoogroups. com>
Date: Wednesday, April 7, 2010, 5:53 PM

    

Owen BrandOpry99er.com

    

 

      

 

Owen Brand

Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Apr 2010 21:29:56 -0400

Ha!  Well, I guess it did.  Funny that you should point that out--  
does it take one to accuse one though?  Hehehe

Owen Brand
Opry99er.com

On Apr 7, 2010, at 9:26 PM, Marc Hull <[email-masked]> wrote:

> programming- -- I use it to keep the dot matrix printer paper in the  
> No but seriously... . I am such a rook on this A/L stuff.  Marc, if  
>>> consoles also pop up now and then on ebay. The SNUG design  
>>> replaces the pad rams with a daughter board that has the required  
>>> memory and support chips on it. In addition to putting the 32k on  
>>> the 16 bit buss it also has the feature of switching between 8 bit  
>>> and sixteen bit so you can still run programs that don't like the  
>>> faster timing. Another switch can toggle the 8k ram located at  
>>> >6000 - >7FFF on or off and another switch can expand the scratch  
>>> pad ram area from >8300 - >83FF to >8000 - >83FF.  The console  
>>> that runs the Hidden Reef BBS has this kit installed since 1996  
>>> and has been running 24/7 without problems with the kit so it is a  
>>> reliable mod as well.
>>>
>>> twice as fast as a stock console. (Except for code that doesn't  
>>> use the expansion RAM and just uses VDP.)
>>>
>>> speeds up file copy and hard drive backup as well as  
>>> communications if you install the matching EPROM in the RS232 card  
>>> which is availble from "Humming Bird".

---

From: Owen Brand <[email-masked]>
Date: Wed, 7 Apr 2010 21:54:16 -0400

Well, one question... Will all cart games work with the modified  
console?  I know the 16 bit bus is only applicable to the 32k block  
(expansion) but what about the faster crystal?  I asked Jon a moment  
ago, but I thought this might be good for the record.  I don't know  
the answer.  Thanks.

Owen Brand
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 09:12:28 +0000 (GMT)

>To enter the sweepstakes, you must bring me..... A shrubbery.

A nice one, and not too expensive!

>Sent: Thu, 8 April, 2010 1:10:40
>Tony--- I've been reading all the A/L beginner's books and it just seems to roll off my back--- or in one ear, out the other.... Whatever. I really learn by seeing and hearing.  I offered Marc a pallet of PBR to hand me Excalibur from the depths of the great lake of PBR.  :) To enter the sweepstakes, you must bring me..... A shrubbery.
>
>Owen Brand
>Opry99er.com
>
>>>convince me to code in Notepad++ and assemble using ASM9900.  Bunch of
>>>programming- -- I use it to keep the dot matrix printer paper in
>>>the tractors so I can print listings.  :) 
>>>
>>>
>>>No but seriously... . I am such a rook on this A/L stuff.
>>> Marc, if I buy you a pallet of PBR and drive out to hick country,
>>>would you show me your magic with the TMS9900?  It will be like King
>>>Arthur pulling Excalibur from the watered-down lake of cheap beer...
>>>Only instead of a sword, it would be op-codes.  :)
>>>
>>>>>>Owen Brand
>>> 
>>>Opry99er.com
>>>
>>>
>>
>
>
>

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 09:14:04 +0000 (GMT)

And first prize will be... A weekend in Castle Anthrax, where you will be exposed to mild peril.

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 05:17:39 -0400

Already beat you to that Willsy!!!  :)

Owen Brand
Opry99er.com

On Apr 8, 2010, at 5:12 AM, mark wills <[email-masked]>  
wrote:

>>> Crap-game programming- -- I use it to keep the dot matrix printer  
>>> No but seriously... . I am such a rook on this A/L stuff.  Marc,  
>>> if I buy you a pallet of PBR and drive out to hick country, would  
>>> you show me your magic with the TMS9900?  It will be like King  
>>> Arthur pulling Excalibur from the watered-down lake of cheap  
>>> beer... Only instead of a sword, it would be op-codes.  :)
>>>
>>> Owen Brand
>>> Opry99er.com
>>>
>>
>
>
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 05:31:42 -0400

Hey Willsy--- Tell me something.... I haven't seen many new updates on  
the TurboForth UG... I'm interested to know more about features.   
SPRITEs, music, etc....  I am trying to determine whether to hold off  
further coding and production on "Beryl" until it's complete... Please  
advise.... Oh, and since I'm a Forth rookie, one more question--- does  
the code compile into standard object code that can be run with the EA  
module, or does playing the game require a TurboForth cart?  :)  I may  
have asked this several months ago, but I don't recall the answer, if  
I DID ask it.  Thanks honky.  :)

Owen Brand
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 10:37:55 +0000 (GMT)

Good point, time for an update.

I have no converted the code into a two banked ROM (16K) and it's now trivial to make it 24K or 32K so space is no longer a problem. The banking emulation works perfectly in Classic99.

To answer your questions:

Sprites: Implemented pretty much as XB.
Pattern mode characters: All 256 characters are available. For example, the equivalent of CALL CHAR(0,"...") is perfectly possible, like was CHALL CHAR(255,"..."). Sprite movement is possible like XB, however it is not interrupt driven. The sprites move by the amount you tell them to, when you tell them. Thus the whole is determinable, unlike XB. And the fact that it's about 50x faster than XB means you don't need interrupt driven movement.

Speech: I have already implemented speaking words from the Speech Synths build in vocab, and it works fine. Just got to add 'SPEAK-STREAM' which will let you use LPC data.

Music: On it's way.

I'm developing what I am calling the 'media engine' which is an engine that you switch on (interrupt driven) which will:

Sprites
-------
Move Sprites automatically, but any sprite can follow a *path* - not the crappy X&Y direction that XB has - you can define a 'path' and tell a sprite to use that path. The sprite will then obey the instructions in the path. So, if you want a sprite(s) moving in a spiral from the outside to the centre of the screen, no problem. This is interrupt driven, so it happens in the background while your Forth program is running.

Speech
------
Interrupt driven speech. Speech *already* works in the background as is, but the media engine will provide a speech queue, allowing you to give it a list of things to say and it will say them one after the other. (Currently, to do this, you would need to poll the synth using the SPEAKING? command to see if it's busy, and hold off if it is.

Music
-----
You will be able to give the media engine a playlist, and it will simply play it, in the background. The playlist will use a meta language to define the notes and their durations. You won't have to byte juggle like you do in assembly language.

Busy busy busy! I'm working on it all the time, as recently as Monday.

Oh, and I finally added the backspace key to the command line, so you can delete your typing errors instead of just hitting enter and starting again ;-)

Oh, and if you're reading this, Bill, I got CREATE DOES> (the ANS/83 version) working :-)

You can do things like:

: MALE CREATE DOES> DROP ." IS MALE!" CR ; ok
: FEMALE CREATE DOES> DROP ." IS FEMALE!" CR ; ok
MALE MARK ok
FEMALE SARAH ok
MARK
IS MALE!
ok
SARAH
IS FEMALE
ok

Mark

>Sent: Thu, 8 April, 2010 10:31:42
>Hey Willsy--- Tell me something.... I haven't seen many new updates on the TurboForth UG... I'm interested to know more about features.  SPRITEs, music, etc....  I am trying to determine whether to hold off further coding and production on "Beryl" until it's complete... Please advise.... Oh, and since I'm a Forth rookie, one more question--- does the code compile into standard object code that can be run with the EA module, or does playing the game require a TurboForth cart?  :)  I may have asked this several months ago, but I don't recall the answer, if I DID ask it.  Thanks honky.  :)   
>
>Owen Brand
>Opry99er.com
>
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 07:21:10 -0400

Holy freakin crap!!!  This things gonna be a monster!!!!! Wills,  
you're a hell of a guy..  I cannot WAIT to teat this beast out and  
start the party!  Thanks for the updates, I hope to see a BETA version  
soon!

Owen Brand
Opry99er.com

On Apr 8, 2010, at 6:37 AM, mark wills <[email-masked]>  
wrote:

> I have no converted the code into a two banked ROM (16K) and it's  
> now trivial to make it 24K or 32K so space is no longer a problem.  
> The banking emulation works perfectly in Classic99.
>
> Pattern mode characters: All 256 characters are available. For  
> example, the equivalent of CALL CHAR(0,"...") is perfectly possible,  
> like was CHALL CHAR(255,"..."). Sprite movement is possible like XB,  
> however it is not interrupt driven. The sprites move by the amount  
> you tell them to, when you tell them. Thus the whole is  
> determinable, unlike XB. And the fact that it's about 50x faster  
> than XB means you don't need interrupt driven movement.
>
> Speech: I have already implemented speaking words from the Speech  
> Synths build in vocab, and it works fine. Just got to add 'SPEAK- 
> STREAM' which will let you use LPC data.
>
> Music: On it's way.
>
> I'm developing what I am calling the 'media engine' which is an  
> engine that you switch on (interrupt driven) which will:
>
> Sprites
> -------
> Move Sprites automatically, but any sprite can follow a *path* - not  
> the crappy X&Y direction that XB has - you can define a 'path' and  
> tell a sprite to use that path. The sprite will then obey the  
> instructions in the path. So, if you want a sprite(s) moving in a  
> spiral from the outside to the centre of the screen, no problem.  
> This is interrupt driven, so it happens in the background while your  
> Forth program is running.
>
> Speech
> ------
> Interrupt driven speech. Speech *already* works in the background as  
> is, but the media engine will provide a speech queue, allowing you  
> to give it a list of things to say and it will say them one after  
> the other. (Currently, to do this, you would need to poll the synth  
> using the SPEAKING? command to see if it's busy, and hold off if it  
> is.
>
> Music
> -----
> You will be able to give the media engine a playlist, and it will  
> simply play it, in the background. The playlist will use a meta  
> language to define the notes and their durations. You won't have to  
> byte juggle like you do in assembly language.
>
> Oh, and I finally added the backspace key to the command line, so  
> you can delete your typing errors instead of just hitting enter and  
> starting again ;-)
>
> Hey Willsy--- Tell me something.... I haven't seen many new updates  
> on the TurboForth UG... I'm interested to know more about features.   
> SPRITEs, music, etc....  I am trying to determine whether to hold  
> off further coding and production on "Beryl" until it's complete...  
> Please advise.... Oh, and since I'm a Forth rookie, one more  
> question--- does the code compile into standard object code that can  
> be run with the EA module, or does playing the game require a  
> TurboForth cart?  :)  I may have asked this several months ago, but  
> I don't recall the answer, if I DID ask it.  Thanks honky.  :)
>
> Owen Brand
> Opry99er.com
>
>

---

From: ti99_forever <[email-masked]>
Date: Thu, 8 Apr 2010 04:22:02 -0700 (PDT)

Mark,

May I point you to the UCSD Pascal manual about Sprites?
They implemented a linked-list record structure to perform certain actions with count-down timers utilized to determine the pacing of the actions.

Not saying it would be best, just to give you ideas...

It also had some pretty impressive library routines for sound processing, although to me it seemed you could write a program with them to produce the finished sound lists that you could simply load with your program to play.

--- On Thu, 4/8/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: [TI994A] TurboForth Update
To: [email-masked]
Date: Thursday, April 8, 2010, 6:37 AM

Speech: I have already implemented
 speaking words from the Speech Synths build in vocab, and it works fine. Just got to add 'SPEAK-STREAM' which will let you use LPC data.

Music: On it's way.

Sprites
-------

Speech
------
Interrupt driven speech. Speech *already* works in the background as is, but the media engine will provide a speech queue, allowing you to give it a list of things to say and it will say them
 one after the other. (Currently, to do this, you would need to poll the synth using the SPEAKING? command to see if it's busy, and hold off if it is.

Music
-----

You can do things like:

IS
 MALE!
ok
SARAH
IS FEMALE
ok

Mark

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 11:27:50 +0000 (GMT)

I think with regards to a Beta, possibly one month and I'll have something ready. You could try it now, but you wouldn't be able to save anything because I still haven't stitched the disk stuff together, and the reason for that is.... I haven't done the editor! You need to have something to save (hence need the editor!) before you can save it, so when I finish the editor, I'll check the disk IO. I've tested the disk io from a reading point of view, it can read any block in the file you nominate, all seems to work...

Development time is a function of how many nappies (diapers) I have to change ;-)

M

>Sent: Thu, 8 April, 2010 12:21:10
>Subject: Re: [TI994A] TurboForth Update
>
> >
>
>
>
> >
>
>
>
>
>
>
>Holy freakin crap!!!  This things gonna be a monster!!!!! Wills, you're a hell of a guy..  I cannot WAIT to teat this beast out and start the party!  Thanks for the updates, I hope to see a BETA version soon!
>
>Owen Brand
>Opry99er.com
>
>On Apr 8, 2010, at 6:37 AM, mark wills <[email-masked]> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>Pattern mode characters: All 256 characters are available. For example, the equivalent of CALL CHAR(0,"..." ) is perfectly possible, like was CHALL CHAR(255,".. ."). Sprite movement is possible like XB, however it is not interrupt driven. The sprites move by the amount you tell them to, when you tell them. Thus the whole is determinable, unlike XB. And the fact that it's about 50x faster than XB means you don't need interrupt driven movement.
>>
>>>Hey Willsy--- Tell me something... . I haven't seen many new updates on the TurboForth UG... I'm interested to know more about features.  SPRITEs, music, etc....  I am trying to determine whether to hold off further coding and production on "Beryl" until it's complete... Please advise.... Oh, and since I'm a Forth rookie, one more question--- does the code compile into standard object code that can be run with the EA module, or does playing the game require a TurboForth cart?  :)  I may have asked this several months ago, but I don't recall the answer, if I DID ask it.  Thanks honky.  :)   
>>>
>>>Owen Brand
>>>Opry99er.com
>>>
>>>
>
>
>

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 11:29:08 +0000 (GMT)

Thanks, I think I have the manual in PDF - I'll check it out!

Mark

>
>From: ti99_forever <[email-masked]>
>Sent: Thu, 8 April, 2010 12:22:02

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 07:47:53 -0400

Ha!!  Understood good buddy.  My little boy is a "nappie" junkie.  I  
certainly understand that.  I'm sure we'll be happy with the product  
when it comes out.  (The Forth product--- not the nappie one)

Owen Brand
Opry99er.com

On Apr 8, 2010, at 7:27 AM, mark wills <[email-masked]>  
wrote:

> I think with regards to a Beta, possibly one month and I'll have  
> something ready. You could try it now, but you wouldn't be able to  
> save anything because I still haven't stitched the disk stuff  
> together, and the reason for that is.... I haven't done the editor!  
> You need to have something to save (hence need the editor!) before  
> you can save it, so when I finish the editor, I'll check the disk  
> IO. I've tested the disk io from a reading point of view, it can  
> read any block in the file you nominate, all seems to work...
>
> start the party!  Thanks for the updates, I hope to see a BETA  
> version soon!
>
> Owen Brand
> Opry99er.com
>
>> example, the equivalent of CALL CHAR(0,"..." ) is perfectly  
>> possible, like was CHALL CHAR(255,".. ."). Sprite movement is  
>> possible like XB, however it is not interrupt driven. The sprites  
>> move by the amount you tell them to, when you tell them. Thus the  
>> whole is determinable, unlike XB. And the fact that it's about 50x  
>> faster than XB means you don't need interrupt driven movement.
>>
>> Move Sprites automatically, but any sprite can follow a *path* -  
>> not the crappy X&Y direction that XB has - you can define a 'path'  
>> and tell a sprite to use that path. The sprite will then obey the  
>> This is interrupt driven, so it happens in the background while  
>> your Forth program is running.
>>
>> Speech
>> ------
>> Interrupt driven speech. Speech *already* works in the background  
>> as is, but the media engine will provide a speech queue, allowing  
>> you to give it a list of things to say and it will say them one  
>> after the other. (Currently, to do this, you would need to poll the  
>> synth using the SPEAKING? command to see if it's busy, and hold off  
>> if it is.
>>
>> Music
>> -----
>> Hey Willsy--- Tell me something... . I haven't seen many new  
>> updates on the TurboForth UG... I'm interested to know more about  
>> features.  SPRITEs, music, etc....  I am trying to determine  
>> whether to hold off further coding and production on "Beryl" until  
>> it's complete... Please advise.... Oh, and since I'm a Forth  
>> rookie, one more question--- does the code compile into standard  
>> object code that can be run with the EA module, or does playing the  
>> game require a TurboForth cart?  :)  I may have asked this several  
>> months ago, but I don't recall the answer, if I DID ask it.  Thanks  
>> honky.  :)
>>
>> Owen Brand
>> Opry99er.com
>>
>
>
>

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 07:05:44 -0700

Mark,

Where to begin?

Glad you got the banking working for you, and your media engine 
description is fantastic! (Let's talk)

Sprite "paths" and speech lists in the background--just short of amazing!

Create DOES> (ANS/F83) or <BUILDS DOES> (Fig/F79) doesn't really matter 
as I have both due to the F83 library in Forth+, and it will also be in 
X4th99.  However, your TurboForth is turning into a mongrel as much of 
your implementation is fig forth and some Forth83.  Don't you think this 
will be confusing to intermediate (those that program in one version or 
the other but not both) Forth'ers?  The vast majority of TI Forth'ers 
(admittedly this is not many) are more tuned into Fig Forth than Forth83 
due to TI FORTH, Super4th & Wycove Forth all being 100% Fig Forth.  This 
is just my personal opinion, so take it for what it's worth to you.

The debate rages on. :-)

Bill S

mark wills wrote:
> I have no converted the code into a two banked ROM (16K) and it's now 
> trivial to make it 24K or 32K so space is no longer a problem. The 
> banking emulation works perfectly in Classic99.
> 
> Pattern mode characters: All 256 characters are available. For example, 
> the equivalent of CALL CHAR(0,"...") is perfectly possible, like was 
> CHALL CHAR(255,"..."). Sprite movement is possible like XB, however it 
> is not interrupt driven. The sprites move by the amount you tell them 
> to, when you tell them. Thus the whole is determinable, unlike XB. And 
> the fact that it's about 50x faster than XB means you don't need 
> interrupt driven movement.
> 
> Speech: I have already implemented speaking words from the Speech Synths 
> build in vocab, and it works fine. Just got to add 'SPEAK-STREAM' which 
> will let you use LPC data.
> 
> Music: On it's way.
> 
> I'm developing what I am calling the 'media engine' which is an engine 
> that you switch on (interrupt driven) which will:
> 
> Sprites
> -------
> Move Sprites automatically, but any sprite can follow a *path* - not the 
> crappy X&Y direction that XB has - you can define a 'path' and tell a 
> sprite to use that path. The sprite will then obey the instructions in 
> the path. So, if you want a sprite(s) moving in a spiral from the 
> outside to the centre of the screen, no problem. This is interrupt 
> driven, so it happens in the background while your Forth program is running.
> 
> Speech
> ------
> Interrupt driven speech. Speech *already* works in the background as is, 
> but the media engine will provide a speech queue, allowing you to give 
> it a list of things to say and it will say them one after the other. 
> (Currently, to do this, you would need to poll the synth using the 
> SPEAKING? command to see if it's busy, and hold off if it is.
> 
> Music
> -----
> You will be able to give the media engine a playlist, and it will simply 
> play it, in the background. The playlist will use a meta language to 
> define the notes and their durations. You won't have to byte juggle like 
> you do in assembly language.
> 
> Oh, and I finally added the backspace key to the command line, so you 
> can delete your typing errors instead of just hitting enter and starting 
> again ;-)
> 
>     *From:* Owen Brand <[email-masked]>
>     *To:* "[email-masked]" <[email-masked]>
>     *Sent:* Thu, 8 April, 2010 10:31:42
>     *Subject:* Re: [TI994A] Running the CF7+ on the SNUG version 32k-16
>     Bit Buss @ 3.58 Mhz
> 
> 
>

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 19:35:14 +0000 (GMT)

Hi Bill,

It's a valid point. Part of the reason is that it has just grown as I learned more, with some sections being re-written from scratch (like CONSTANT, VARIABLE, CREATE, HEADER etc)

However, I think you'll find it pretty much all Forth83* now, *except* Wordlists (vocabularies) for which I am using the ANS "way" as it is actually much better than the rather obtuse FIG syntax.

I've implemented all the words in Forth83 "CORE WORDS" standard, so I can claim Forth83 compliance!

Maybe in the future I'll do an ANS version, just for fun, however, if I do another Forth, it won't be ITC - it will directly lay down machine code, not addresses (the disadvantage is, while probably 50% faster, a Forth program will eat more memory).

Mark

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Thu, 8 April, 2010 15:05:44

Where to begin?

Glad you got the banking working for you, 
> and your media engine 

Sprite 
> "paths" and speech lists in the background--just short of amazing!

Create 
> DOES> (ANS/F83) or <BUILDS DOES> (Fig/F79) doesn't really matter 
as 
> I have both due to the F83 library in Forth+, and it will also be in 
> 
your implementation is fig forth and some Forth83.  Don't you think 
> this 
due to TI FORTH, Super4th & Wycove Forth all being 100% Fig Forth.  
> This 
is just my personal opinion, so take it for what it's worth to 
> you.

The debate rages on. :-)

Bill S

mark wills 
> To 
> answer your questions:
> example, 
> Speech: I have 
> already implemented speaking words from the Speech Synths 
> build in 
> vocab, and it works fine. Just got to add 'SPEAK-STREAM' which 
> will let 
> you use LPC data.
> 
> Music: On it's way.
> 
> I'm 
> developing what I am calling the 'media engine' which is an engine 
> that 
> you switch on (interrupt driven) which will:
> 
> Sprites
> 
> -------
> not the 
> Interrupt 
> driven speech. Speech *already* works in the background as is, 
> but the 
> media engine will provide a speech queue, allowing you to give 
> it a 
> list of things to say and it will say them one after the other. 
> 
> Oh, and if you're 
> reading this, Bill, I got CREATE DOES> (the ANS/83 
> version) working 
> :-)
> 
> You can do things like:
> 
> : MALE CREATE 
>     *From:* Owen 
> Brand <
> href="mailto:[email-masked]">[email-masked]>
>  
>    *To:* "
> href="mailto:[email-masked]">[email-masked]" <
> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]>
>  
>     *Subject:* Re: 
> [TI994A] Running the CF7+ on the SNUG version 32k-16
>     Bit 
> Buss @ 3.58 Mhz
> 
> 
> 
>     Hey Willsy--- 
> Tell me something.... I haven't seen many new updates
>     on 
>     be run with the EA 
> module, or does playing the game require a
>     TurboForth 
> cart?  :)  I may have asked this several months ago, but
>  

------------------------------------

Yahoo! Groups 
> Links

> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 14:23:16 -0700

OK.  Just that my vast experience is with fig Forth, more specifically 
TI FORTH.  The difficulty in going from one to the other is the fact 
that so many words are the same but have a different syntax and in some 
case operate a little differently also, and the difference in the 
vocabulary structure and usage is very Off putting.

Think about stack input must be arranged differently for some of the 
same words and the stack output also be different.  It will definitely 
test the patience of most good programmers to have to go from one 
version to the other based on what they want to accomplish.  You don't 
mind going from one to the other to get certain capabilities, but you'd 
like the basics to be the same.  Which means going from TurboForth to 
X4th99 for the sake of large memory capability probably won't be worth 
the challenge to most.  It won't be for me anyway as I just have way too 
much time doing it the fig Forth way.

Bill S

mark wills wrote:
>  
> 
> Hi Bill,
> 
> It's a valid point. Part of the reason is that it has just grown as I 
> learned more, with some sections being re-written from scratch (like 
> CONSTANT, VARIABLE, CREATE, HEADER etc)
> 
> However, I think you'll find it pretty much all Forth83* now, *except* 
> Wordlists (vocabularies) for which I am using the ANS "way" as it is 
> actually much better than the rather obtuse FIG syntax.
> 
> Maybe in the future I'll do an ANS version, just for fun, however, if I 
> do another Forth, it won't be ITC - it will directly lay down machine 
> code, not addresses (the disadvantage is, while probably 50% faster, a 
> Forth program will eat more memory).
> 
> Mark
> 
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > href="mailto:[email-masked] 
> <mailto:owenbrand%40opry99er.com>">[email-masked] 
> <mailto:owenbrand%40opry99er.com>>
>  >
>  > *To:* "
>  > href="mailto:[email-masked] 
> <mailto:TI994A%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A%40yahoogroups.com>" <
>  > ymailto="mailto:[email-masked] 
> <mailto:TI994A%40yahoogroups.com>"
>  > href="mailto:[email-masked] 
> <mailto:TI994A%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A%40yahoogroups.com>>
>  >
>  > Opry99er.com <
>  > >http://Opry99er.com <http://Opry99er.com>>
>  >
>  >
>  >
> 
> <http://groups.yahoo.com/group/TI994A/>
> 
>  > href="http://groups.yahoo.com/group/TI994A/join 
> <http://groups.yahoo.com/group/TI994A/join>" target=_blank
> <http://groups.yahoo.com/group/TI994A/join>
> (Yahoo! ID
>  > required)
> 
>  > href="mailto:[email-masked] 
> <mailto:TI994A-digest%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-digest%40yahoogroups.com>
>  >
> 
>  > href="mailto:[email-masked] 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>
> 
>  > ymailto="mailto:[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>"
>  > href="mailto:[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>
> 
>  > href="http://docs.yahoo.com/info/terms/ 
> <http://docs.yahoo.com/info/terms/>" target=_blank
>  > >http://docs.yahoo.com/info/terms/ <http://docs.yahoo.com/info/terms/>
> 
>

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 22:33:34 +0000 (GMT)

----- Original Message ----
> Sent: Thu, 8 April, 2010 22:23:16

Possibly true, but TurboForth will professionally documented with a supporting companion website.

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 15:41:57 -0700

Documentation is not the point.  TI FORTH is documented, so it Super4th, 
and Wycove Forth, Forth+ as well, but these are all basically Fig Forth, 
Therefore the syntax of the same words is exactly the same--no confusion 
when going from one to the other except for implementation dependencies 
due to Sprites or Speech being done differently because they did it 
their way.

Bill S

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 23:17:35 +0000 (GMT)

Can you cite any examples of differences between syntax or stack signature FIG and Forth83?

Of course, graphics, speech etc are my own versions.

Mark

----- Original Message ----
> Sent: Thu, 8 April, 2010 23:41:57
their way.

Bill S

mark wills wrote:
>  > From: 
> fdos <
> href="mailto:[email-masked]">[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>>
>  > To: 
> href="mailto:[email-masked]">[email-masked] 
> <mailto:TI994A%40yahoogroups.com>
>  > Sent: Thu, 8 April, 
> 2010 22:23:16
>  > that so many words 
> are the same but have a different syntax and in some
>  > case 
> operate a little differently also, and the difference in the
>  > 
> Possibly 
> true, but TurboForth will professionally documented with a 
> supporting 
> companion website.
> 
> 
> 

Yahoo! Groups 

    (Yahoo! ID

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 08:59:21 -0700

Mark,

Here are a few examples:

1. CREATE is in both languages.  In F83 it is used with DOES> for 
creating CLASS type words, but in Fig Forth <BUILDS is used with DOES> 
for this purpose and CREATE is in the definition of Fig Forth <BUILDS, 
as CREATE just compiles the following name into the dictionary with all 
the necessary header & linkage, but no action is included.

2. VARIABLE creation does not use a stack item for initialization in 
F83, but a stack item is required in Fig Forth.

3. 0< leaves a -1 on the stack in F83 and a 1 in Fig if the value tested 
is less than 0.

4. 0= leaves a -1 on the stack in F83 and a 1 in Fig if the value tested 
is equal to 0.

5. < leaves a -1 on the stack in F83 and a 1 in Fig if the lower of two 
stack items is less than the top stack item.

6. = leave a -1 on the stack in F83 and a 1 in Fig if the two top stack 
items are equal.

7. > leaves a -1 on the stack in F83 and a 1 in Fig if the lower of two 
stack items is greater than the top stack item.

Think about using the result of these logical operators with AND, OR & 
XOR.  Especially, if you use XOR followed by more logical operators--it 
can get ugly.  Is -1 the better TRUE flag?  Yes, of course it is.  Not 
every thing FORML did, standard wise, was bad.  Some things were very good.

There are other areas of concern where F83 renamed Fig words, but the 
function did not change at all.  In other cases, the operation changed 
slightly, like DO LOOP/+LOOP to accommodate the new word ?DO.

More significantly, they use different words to define the dictionary 
structure.  I'm shocked that they didn't just remove the Fig words, and 
keep application programmers from writing their own CLASS type words, 
but the community at large kept them from going that far.  They also 
changed all state smart words into two words each; one to be used in 
compiler definitions and one to be used by the interpreter (TIB or BLOCK 
BUFFERS).

That should be enough for now.  I have better things to do than this.

Bill S

mark wills wrote:
>  > href="mailto:[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>">[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 9 Apr 2010 22:15:07 -0500

F'web and a RAMdisk or two is a fantastic development environment.  For years I used the 40-column Fweb and the TI, later the 80-column Fweb and the Geneve, to write/assemble/test my TI-specific code.  If you want to use real hardware, a setup with RAMdisk or hard disk device makes all the difference in the world.  Nowadays I use either my real Geneve or emulated Geneve, with EDIT and GENPROG, for the majority of my work.  ;)

To: [email-masked]
From: [email-masked]
Date: Wed, 7 Apr 2010 14:07:16 -0700
Subject: Re: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz

 

      

 

Owen Brand

Opry99er.com

 

 		 	   		  
_________________________________________________________________
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_2

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 23:26:36 -0400

Absolutely.  I coded the majority of Lemonade Stand with a RAMDisk.   
Such an incredible difference in speed!!!!  I lost all my data when my  
battery died and subsequently coded Honeycomb Rapture 100% with  
Classic99.  In retrospect, I actually enjoyed doing Lemonade Stand  
more... But Honeycomb was much more convenient... I did most of it on  
a borrowed laptop and the rest of it on my new Win7 unit.  My new game  
will be a combination of real hardware (with RAMDisk) and Classic99.

Owen Brand
Opry99er.com

On Apr 9, 2010, at 11:15 PM, Insane Multitasker <[email-masked]>  
wrote:

> F'web and a RAMdisk or two is a fantastic development environment.   
> For years I used the 40-column Fweb and the TI, later the 80-column  
> Fweb and the Geneve, to write/assemble/test my TI-specific code.  If  
> you want to use real hardware, a setup with RAMdisk or hard disk  
> device makes all the difference in the world.  Nowadays I use either  
> my real Geneve or emulated Geneve, with EDIT and GENPROG, for the  
> majority of my work.  ;)
>
>
> Hotmail is redefining busy with tools for the New Busy. Get more  
> from your inbox. See how.
>

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 20:58:32 -0700

Early on in X4th99 development I ran into file corruption problems on 
all my TI systems, so I moved the AL process to my real GenMod Geneve. 
For Forth+ I used PE in Myword for editing as the files were too big for 
QDE, but I did use GenProg for assembling and linking Forth+.

However, in the case of X4th99 I still use PE in Myword (just use to 
it), but I use Clint Pulley's ASM in MDOS that executes the TI assembler 
from the command line without any file corruption (I always use RLS, so 
the complete listing is also on file).  I've also moved this operation 
to the MESS Geneve emulator where lightning is considered some what 
slow. :-)

Bill S

Insane Multitasker wrote:
>  
> 
> F'web and a RAMdisk or two is a fantastic development environment.  For 
> years I used the 40-column Fweb and the TI, later the 80-column Fweb and 
> the Geneve, to write/assemble/test my TI-specific code.  If you want to 
> use real hardware, a setup with RAMdisk or hard disk device makes all 
> the difference in the world.  Nowadays I use either my real Geneve or 
> emulated Geneve, with EDIT and GENPROG, for the majority of my work.  ;)
> 
> ------------------------------------------------------------------------
> ->    A console with the 32k-16 mod and the 3.58 crystal mod runs about 
> twice as fast as a stock console. (Except for code that doesn't use the 
> This is what I use to program in assembly.  Combine this console with a 
> RamDisk (which I think you have) and your save/assemble/run time goes 
> from about five minutes down to about one....  Worth every penny (or 
> burnt finger depending on which way you go ;-).
> 
> --- On *Wed, 4/7/10, [email-masked] /<[email-masked]>/* wrote:
> 
> 
>         more readily available.  Just as a question, the 16 bit buss,
>         does that eliminate the need for the multiplexing?
> 
>         Owen Brand
> ------------------------------------------------------------------------
> Hotmail is redefining busy with tools for the New Busy. Get more from 
> your inbox. See how. 
> <http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_2> 
> 
>

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 9 Apr 2010 23:34:23 -0500

Indeed.  One of the advantages of the emulators is easy backups.  When I develop in MESS, I put my development files on a disk image, and back that up periodically.  But as Bill recently experienced, having a good backup is invaluable, whether using real or emulated hardware.  Losing one's code due to a mistake or corruption can be heartbreaking.  Unless you code was so crappy that a re-write was advantageous ;)

To: [email-masked]
From: [email-masked]
Date: Fri, 9 Apr 2010 23:26:36 -0400
Subject: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz

Absolutely.  I coded the majority of Lemonade Stand with a RAMDisk.  Such an incredible difference in speed!!!!  I lost all my data when my battery died and subsequently coded Honeycomb Rapture 100% with Classic99.  In retrospect, I actually enjoyed doing Lemonade Stand more... But Honeycomb was much more convenient... I did most of it on a borrowed laptop and the rest of it on my new Win7 unit.  My new game will be a combination of real hardware (with RAMDisk) and Classic99.  

Owen BrandOpry99er.com
On Apr 9, 2010, at 11:15 PM, Insane Multitasker <[email-masked]> wrote:

    

        

 

      

 

Owen Brand

Opry99er.com

 

 		 	   		  
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox. See how.

    

 		 	   		  
_________________________________________________________________
The New Busy is not the old busy. Search, chat and e-mail from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_3

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 9 Apr 2010 23:34:28 -0500

Owen BrandOpry99er.com

    

        

 

      

 

Owen Brand

Opry99er.com

 

 		 	   		  

    

 		 	   		  
_________________________________________________________________
The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail. 
http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5

---

From: mark wills <[email-masked]>
Date: Sat, 10 Apr 2010 08:51:39 +0000 (GMT)

Has anyone seen/heard of this book before?

http://tinyurl.com/ydm5383

Published February 2010... ?????

Mark

---

From: "epergrem" <[email-masked]>
Date: Sat, 10 Apr 2010 12:07:25 -0000

If you expand the cover image it reads "High quality content by Wikipedia articles!".  It look like what you might be paying for is a self-published dump of Wikipedia articles.

BTW, if you click on the hyperlinks for any of the editors you'll find scores of books, all with High quality content by Wikipedia articles!' on the front cover.

Ernie

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 08:42:53 -0400

Interesting!!! I wonder what the quality is like?  How can it self- 
publish without getting a bunch of crap in there?  And how does it  
manage to organize the info into a book format?  Chapters?  Hmmm....  
Someone should buy this.  :)

Owen Brand
Opry99er.com

On Apr 10, 2010, at 8:07 AM, "epergrem" <[email-masked]> wrote:

> If you expand the cover image it reads "High quality content by  
> Wikipedia articles!". It look like what you might be paying for is a  
> self-published dump of Wikipedia articles.
>
> BTW, if you click on the hyperlinks for any of the editors you'll  
> find scores of books, all with High quality content by Wikipedia  
> articles!' on the front cover.
>
> Ernie
>

---

From: mark wills <[email-masked]>
Date: Sat, 10 Apr 2010 16:22:02 +0000 (GMT)

That doesn't make sense. There isn't enough info on the TI on Wikipedia to fill a book. Note, the book is dedicated to the TI-99/4A. So unless it's like, 4 pages long... Well, I just don't know...

----- Original Message ----
> From: epergrem <[email-masked]>
> Sent: Sat, 10 April, 2010 13:07:25
> Subject: [TI994A] Re: New TI-99/4A book?????
> 
> If you expand the cover image it reads "High quality content by Wikipedia 
> articles!".  It look like what you might be paying for is a self-published 
> dump of Wikipedia articles.

BTW, if you click on the hyperlinks for any 
> of the editors you'll find scores of books, all with High quality content by 
> Wikipedia articles!' on the front cover.

Ernie 

--- In 
> href="mailto:[email-masked]">[email-masked], mark wills 
> <markrobertwills@...> wrote:
>

Yahoo! 
> Groups Links

    (Yahoo! ID

---

From: "epergrem" <[email-masked]>
Date: Sat, 10 Apr 2010 18:45:10 -0000

Hi Mark,
It may not make sense, but try doing a Google search on "high quality content by wikipedia articles".  

Ernie

> > From: epergrem <epergrem@...>

---

From: "Ksarul" <[email-masked]>
Date: Sat, 10 Apr 2010 15:16:45 -0400

Note the customer feedback on one of the other books they sell:

http://www.amazon.com/Culture-Pakistan-Pakistan-literature-publishing/dp/613
0076231/

"This book is a hodge podge of otherwise free Wikipedia articles related to
Pakistan, its language, history, literature and culture. These are
encyclopedia type articles but nothing in depth. As with most Wikipedia
material, the articles are good for a very basic understanding of the
subject, but no more. The most diasppointing aspect of this book is that the
Amazon description does not disclose the Wikipedia source -- a serious
ommission in my opinion. Additionally, the price/content ratio is very poor.
The price of this book is way, way too high. Why buy this book when you can
read and/or print off the absolutaly up to date Wikepedia articles for free?
I returned the copy I purchased." E. Dean Butler.

I guess if you wanted the Wikipedia articles in bound form, this would be
OK, but at this price?  Definitely unacceptable..

Jim Fetzner

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
epergrem
Sent: Saturday, April 10, 2010 2:45 PM
To: [email-masked]
Subject: [TI994A] Re: New TI-99/4A book?????

Hi Mark,
It may not make sense, but try doing a Google search on "high quality
content by wikipedia articles". 

Ernie

--- In TI994A@yahoogroups. <mailto:TI994A%40yahoogroups.com> com, mark wills
<markrobertwills@...> wrote:
>
> That doesn't make sense. There isn't enough info on the TI on Wikipedia to
fill a book. Note, the book is dedicated to the TI-99/4A. So unless it's
like, 4 pages long... Well, I just don't know...

> > To: TI994A@yahoogroups. <mailto:TI994A%40yahoogroups.com> com
Wikipedia

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 12:17:22 -0700

Amen!

Ksarul wrote:
> http://www.amazon.com/Culture-Pakistan-Pakistan-literature-publishing/dp/6130076231/ 
> <http://www.amazon.com/Culture-Pakistan-Pakistan-literature-publishing/dp/6130076231/>
> 
>  
> 
> “This book is a hodge podge of otherwise free Wikipedia articles related 
> to Pakistan, its language, history, literature and culture. These are 
> subject, but no more. The most diasppointing aspect of this book is that 
> the Amazon description does not disclose the Wikipedia source -- a 
> serious ommission in my opinion. Additionally, the price/content ratio 
> is very poor. The price of this book is way, way too high. Why buy this 
> book when you can read and/or print off the absolutaly up to date 
> Wikepedia articles for free? I returned the copy I purchased.” E. Dean 
> Butler.
> 
>  
> 
> I guess if you wanted the Wikipedia articles in bound form, this would 
> be OK, but at this price?  Definitely unacceptable..
> 
>  
> 
> Jim Fetzner
> 
>  
> 
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *epergrem
> *Sent:* Saturday, April 10, 2010 2:45 PM
> *To:* [email-masked]
> *Subject:* [TI994A] Re: New TI-99/4A book?????
> 
>  
> 
>  
> 
> Hi Mark,
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, mark 
> wills <markrobertwills@...> wrote:
>>
>>  That doesn't make sense. There isn't enough info on the TI on 
> Wikipedia to fill a book. Note, the book is dedicated to the TI-99/4A. 
> So unless it's like, 4 pages long... Well, I just don't know...
>

---

From: "Tursi" <[email-masked]>
Date: Sat, 10 Apr 2010 12:36:19 -0700

> like, 4 pages long... Well, I just don't know...

Heh... I looked long and hard, look at the subtitle:

Texas Instruments, Home Computer, Chiclet Keyboard, Motherboard, Cartridge

This suggests to me that the book will have article article including every 
one of those terms, so he could probably get 5-10 pages out of the TI 
article alone. Take every even remotely related article and print it, and 
you have 112 pages. They could do it. If you look at some of the Amazon 
reviews on their other books, the articles are pretty broadly included.

Interesting... but always disappointing to run across such obvious scams.

---

From: R Halter <[email-masked]>
Date: Mon, 12 Apr 2010 20:34:23 -0500

Tursi wrote:
> Yahoo! Groups Links
 From a Wikipedia review forum 
(http://wikipediareview.com/index.php?showtopic=26847 ):

"A lot of the books on sale contain wiki mark-up that hasn't been 
removed. And the image on the front of the book about Georgia, the 
country, is of Georgia, the US state!"

Did you notice that the book supposedly about the TI-99/4A shows a 
Microsoft Windows screen?

 From 
http://www.mywikibiz.com/User_talk:MyWikiBiz#Wiki_Editors_Publishing_Wiki_Articles_.28In_a_Book.29 

"I also find it extremely entertaining, as I go to write a review of the 
book on Amazon.com, that after writing my blurb, Amazon suggests the 
following handy 'tags' to annotate my thoughts:

     Tag Suggestions (click to add): rip-off, croatia, wikipedia, lies, 
sham, deceptive, ripoff, john mcbrewster"

-- 
"Well, you've found me.  Congratulations.  Was it worth it?  Because 
despite your violent behavior, the only thing you've managed to break so 
far is my heart."
  -- GLaDOS, "Portal"

---

From: R Halter <[email-masked]>
Date: Mon, 12 Apr 2010 21:01:26 -0500

Guh.  I haven't used my email in so long, I forgot to "snip."  >_<