Subject: Probs with MDM3 (in MESS)

From: "Michael Zapf" <[email-masked]>
Date: Wed, 21 Apr 2010 23:05:15 -0000

Hi all,

I'm currently hunting a problem with the Myarc Disk Manager in MESS. After my reimplementation of the HFDC, everything seems to work so far, even formatting with the TI Disk Manager works. (Remember that the HFDC emulation was unable to format a disk in the earlier MESS versions up to now.)

There's just one problem: MDM refuses to format the disk. MDM uses an own low-level formatting routine (presumably to be able to modify the interleave) with direct controller access - which actually means that it must detect the controller type and then select the correct "driver". 

Strangely, when formatting is about to start, MDM queries a CRU bit (bit 1) for some time, and as it does not become high, it gives up with "NO DISK OR NO DRIVE". I did some investigations on that for some days now, but I still cannot tell why this happens. Even stranger, MDM queries and sets bits that are undefined for the HFDC.

This made me wonder whether MDM3 is able to work with the HFDC controller at all (at least concerning formatting). And then I remembered: Don't I rather have to use MDMV?

I can't find a good image with MDMV on it - could anyone probably send me a disk image by e-mail? (Sector dump or track dump, also known as v9v9 or PC99; both are OK for me.)

Michael

---

From: "Beery" <[email-masked]>
Date: Thu, 22 Apr 2010 21:32:12 -0000

Changing subject here.

I saw where in the MESS WIP someone has written some RS232 code.  Are things progressing where we could eventually have RS232 support?

Beery

---

From: "Beery" <[email-masked]>
Date: Thu, 22 Apr 2010 21:30:16 -0000

I was not aware MDM 3 worked with the HFDC.  I think MDM 5 was good for both Myarc FDC and Myarc HFDC, but MDM 3 was only good for Myarc FDC.

Any chance the bits that are being set were for the unsupported tape drive that was never implemented?

Afraid that is the only help I can offer.

Beery

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 22 Apr 2010 22:43:04 -0000

Hello Beery,

> I was not aware MDM 3 worked with the HFDC.  I think MDM 5 was 
> good for both Myarc FDC and Myarc HFDC, but MDM 3 was only good for 
> Myarc FDC.

OK, this may explain the weird CRU accesses. For instance, there were SBO/SBZ 5 or 6 which are not defined, but may probably make sense with the DDCC.

In the meantime I tried the MDM5, but only to witness that it immediately exists after loading (just showing the welcome screen for a fraction of a second). So there is some more work to be done - although the rest is working, i.e. sector read/write and all higher functions.

> tape drive that was never implemented?

As far as I saw the tape drive is accessed via memory ports. Anyway, tape support is not implemented yet, and after reading the HDC9234 manual I think it's not really worth an effort. It seems to be intended to interface directly to the hard drives for backup and restore, i.e. you could tell it to back up a collection of sectors or to restore them, but it was not planned to send bytes to/from the computer.

Michael

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 22 Apr 2010 22:45:37 -0000

Hello Beery,

> I saw where in the MESS WIP someone has written some RS232 code.  
> Are things progressing where we could eventually have RS232 support?

I did not have a look yet. But right now I won't find time to contribute anyway.

Michael

---

From: "Beery" <[email-masked]>
Date: Fri, 23 Apr 2010 15:34:22 -0000

I do know MDM5 will abort if it does not find a Myarc HFDC present.  The MDM5 source is out there, but I have no idea what MDM5 looks for to confirm whether the HFDC is present or not.

Regarding those bits, while they aren't defined on the HFDC (or as far as anyone knows), would accessing them trigger any specific responses on a TI/CC/Myarc FDC cards?  Perhaps someone was trying to test for presence or lack thereof a card????

Beery

---

From: fdos <[email-masked]>
Date: Fri, 23 Apr 2010 08:38:01 -0700

As I'm several days behind in catching up on OLUG messages I will only 
say that MDM3 is not compatible with the Myarc HFDC, and someone will 
surely have sent you a V9T9/PC99 disk image of MDM5 by now.

Bill S

Michael Zapf wrote:
>  
> 
> Hi all,
> 
> I'm currently hunting a problem with the Myarc Disk Manager in MESS. 
> After my reimplementation of the HFDC, everything seems to work so far, 
> even formatting with the TI Disk Manager works. (Remember that the HFDC 
> emulation was unable to format a disk in the earlier MESS versions up to 
> now.)
> 
> There's just one problem: MDM refuses to format the disk. MDM uses an 
> own low-level formatting routine (presumably to be able to modify the 
> interleave) with direct controller access - which actually means that it 
> must detect the controller type and then select the correct "driver".
> 
> Strangely, when formatting is about to start, MDM queries a CRU bit (bit 
> 1) for some time, and as it does not become high, it gives up with "NO 
> DISK OR NO DRIVE". I did some investigations on that for some days now, 
> but I still cannot tell why this happens. Even stranger, MDM queries and 
> sets bits that are undefined for the HFDC.
> 
> This made me wonder whether MDM3 is able to work with the HFDC 
> controller at all (at least concerning formatting). And then I 
> remembered: Don't I rather have to use MDMV?
> 
> I can't find a good image with MDMV on it - could anyone probably send 
> me a disk image by e-mail? (Sector dump or track dump, also known as 
> v9v9 or PC99; both are OK for me.)
> 
> Michael
> 
>

---

From: Tony Knerr <[email-masked]>
Date: Fri, 23 Apr 2010 12:26:39 -0400

MDM5 looks to see if there's a "WDS" in the dsr device list, else it aborts.
That's one of the reasons it works with a SCSI card.

Tony

Beery wrote:
>  
>
> I do know MDM5 will abort if it does not find a Myarc HFDC present. 
> The MDM5 source is out there, but I have no idea what MDM5 looks for 
> to confirm whether the HFDC is present or not.
>
> Regarding those bits, while they aren't defined on the HFDC (or as far 
> as anyone knows), would accessing them trigger any specific responses 
> on a TI/CC/Myarc FDC cards? Perhaps someone was trying to test for 
> presence or lack thereof a card????
>
> Beery
>

---

From: Gregory McGill <[email-masked]>
Date: Fri, 23 Apr 2010 09:42:39 -0700

Ok so if 5 is for hfdc whats 3 for?  Pers card?

Greg

On Fri, Apr 23, 2010 at 9:26 AM, Tony Knerr <[email-masked]> wrote:

> I do know MDM5 will abort if it does not find a Myarc HFDC present. The
> MDM5 source is out there, but I have no idea what MDM5 looks for to confirm
> whether the HFDC is present or not.
>
> Regarding those bits, while they aren't defined on the HFDC (or as far as
> anyone knows), would accessing them trigger any specific responses on a
> TI/CC/Myarc FDC cards? Perhaps someone was trying to test for presence or
> lack thereof a card????
>
> Beery
>
>
>  
>

---

From: "Ksarul" <[email-masked]>
Date: Fri, 23 Apr 2010 14:28:47 -0400

Myarc DSDD Floppy Controller card.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Gregory McGill
Sent: Friday, April 23, 2010 12:43 PM
To: [email-masked]
Subject: Re: [TI994A] Re: Probs with MDM3 (in MESS)

Greg

On Fri, Apr 23, 2010 at 9:26 AM, Tony Knerr <tonyknerr@comcast.
<mailto:[email-masked]> net> wrote:

Tony

Beery wrote: 

I do know MDM5 will abort if it does not find a Myarc HFDC present. The MDM5
source is out there, but I have no idea what MDM5 looks for to confirm
whether the HFDC is present or not.

Beery

---

From: fdos <[email-masked]>
Date: Fri, 23 Apr 2010 15:02:35 -0700

Which can be 40/80 track dependent on EPROM, and MDM3 supports both.

Bill S

Ksarul wrote:
> ------------------------------------------------------------------------
> 
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Gregory McGill
> *Sent:* Friday, April 23, 2010 12:43 PM
> *To:* [email-masked]
> *Subject:* Re: [TI994A] Re: Probs with MDM3 (in MESS)
> 
>  
> 
>  
> 
> On Fri, Apr 23, 2010 at 9:26 AM, Tony Knerr <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> MDM5 source is out there, but I have no idea what MDM5 looks for to 
> confirm whether the HFDC is present or not.
> 
> as anyone knows), would accessing them trigger any specific responses on 
> a TI/CC/Myarc FDC cards? Perhaps someone was trying to test for presence 
> or lack thereof a card????
> 
> Beery
> 
>  
> 
>  
> 
>

---

From: "Michael Zapf" <[email-masked]>
Date: Fri, 23 Apr 2010 23:20:36 -0000

Hello Beery,

> The MDM5 source is out there, but I have no idea what MDM5 looks 
> for to confirm whether the HFDC is present or not.

That was a very good hint. I found the sources on WHTech and put in some printfs in the MESS code where it accesses the memory expansion. This allowed me to find the location in the code where it quits to the master title screen.

Actually it happened when MDM5 tries to load more files (depending on the version number, here: MDM506). So I downloaded a new copy of it from WHTech and found that this is now actually loading!

And a diff showed the problem: The version that I was sent was patched to load from WDS1. :-) 

So, now let's check formatting.

Michael

---

From: "Michael Zapf" <[email-masked]>
Date: Fri, 23 Apr 2010 23:48:38 -0000

> So, now let's check formatting.

And it does it. Yes! Phew. 

At least for the floppy drives; I'll test the MFM hard disk later.

Interlacing also works, you can only see it in the track dump format (pc99), of course.

Interlace 3 yields sector number sequence 0, 6, c, 1, 7, d, 2, 8, e, 3, 9, f, 4, a, 10, 5, b, 11

Interlace 4 yields sector number sequence 0, 9, 5, e, 1, a, 6, f, 2, b, 7, 10, 3, c, 8, 11, 4, d

That's fun ... the emulation becomes indeed more and more like the real hardware. It works and fails with the same software. :-)

Michael

---

From: Tony Knerr <[email-masked]>
Date: Fri, 23 Apr 2010 19:56:47 -0400

It's good to see you having fun with this, Michael.

Yeehaw!

Tony

Michael Zapf wrote:
> That's fun ... the emulation becomes indeed more and more like the 
> real hardware. It works and fails with the same software. :-)
>
> Michael
>
> _

---

From: fdos <[email-masked]>
Date: Fri, 23 Apr 2010 17:09:45 -0700

Michael,

MDM5 lets you set the path to boot from within the program, but this 
does mean that you should always keep an image of MDM5 that boots from 
DSK1 somewhere.  Just copy the MDM5 files to a hard disk path then boot 
the DSK1 version, goto the config/setup screen to set the path and any 
other preferences you may have.  Now you should be able to boot from the 
  hard disk path, and if you want CALL MDM to work from TI BASIC/XB copy 
MDM5 and MDMV to the DSK1 directory on the first hard drive image. 
There might be another file to copy for CALL MDM to work from XB, but I 
don't recall the name at this moment.

Bill S

Michael Zapf wrote:
> That was a very good hint. I found the sources on WHTech and put in some 
> printfs in the MESS code where it accesses the memory expansion. This 
> allowed me to find the location in the code where it quits to the master 
> title screen.
> 
> Actually it happened when MDM5 tries to load more files (depending on 
> the version number, here: MDM506). So I downloaded a new copy of it from 
> WHTech and found that this is now actually loading!
>

---

From: mark wills <[email-masked]>
Date: Sat, 24 Apr 2010 12:16:37 +0000 (GMT)

That is *totally* cool!

----- Original Message ----
> From: Michael Zapf <[email-masked]>
> Sent: Sat, 24 April, 2010 0:48:38
> Subject: [TI994A] Re: Probs with MDM3 (in MESS)
> 
> 

> So, now let's check formatting.

And it does it. 
> Yes! Phew. 

At least for the floppy drives; I'll test the MFM hard disk 
> later.

Interlacing also works, you can only see it in the track dump 
> format (pc99), of course.

Interlace 3 yields sector number sequence 0, 6, 
> c, 1, 7, d, 2, 8, e, 3, 9, f, 4, a, 10, 5, b, 11

Interlace 4 yields 
> sector number sequence 0, 9, 5, e, 1, a, 6, f, 2, b, 7, 10, 3, c, 8, 11, 4, 
> d

That's fun ... the emulation becomes indeed more and more like the real 
> hardware. It works and fails with the same software. 
> :-)

Michael

------------------------------------

Yahoo! 
> Groups Links

>   
> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/