Subject: Re: [TI994A] Re: E/A question

From: [email-masked]
Date: Fri, 09 Jul 2010 06:41:05 -0500 (CDT)

"The Art of Assembly Series" is also available the way God intended it to be in DV80 format on "The Hidden Reef BBS", 24/7 8n1, 718 448 9402 or via telnet through Greg's thekeep.

Jul 9, 2010 06:50:36 AM, [email-masked] wrote:

"The Art of Assembly Series" by the late bruce Harrison.
A huge collection of articles very well written and detailed.
I have the compiled version as available on the "Cyc".

Too bad this kind of information is not available to everyone.
This is especially very annoying for newbies who are trying to get into assemly language and do not own the Cyc.

IMHO this should be available to every one.
I believe in free information :-)

Filip

--- In [email-masked], "Jacques Groslouis" wrote:
>
> Kory,
>
> The COMPUTE! book is 'Beginner's Guide to Assembly Language on the TI-99/4A'
> by Peter M. L. Lottrup. As others have stated it is an excellent book.
> Although written for use with a Mini Memory cartridge, most of its programs
> can be adapted for use with the E/A cartridge. I found the Lottrup examples
> to be shorter and more numerous than the Molesworth examples. A word of
> caution if you find a hard copy version of the Lottrup book, it contains a
> dozen or so typos that can add to learning frustration. I believe that most
> electronic versions of this books have been corrected. I am probably at the
> same stage in learning assembly language programming as you are. I just find
> that I am not quite there yet but I am still trying.
>
> I also found an (IMHO) excellent series of tutorials written by Steven
> Peacock in past issues of the Chicago TImes. In these tutorials all examples
> are first presented as an Extended Basic program and then as an assembly
> version. Many copies of the Chicago newsletters can be found on the wht
> site. The Peacock tutorials start in the November 1986 issue.
>
> Good luck,
>
> Jacques
>
> Nominate someone to your TI99HOF
> Check out www.ti99hof.org
>
> ----- Original Message -----
> From: "kory"
> To:
> Sent: Friday, July 09, 2010 12:29 AM
> Subject: [TI994A] Re: E/A question
>
>
> >
> >
> > It seems to me like I may have asked this question a few years ago.. The
> > Molesworth and Morley names both seem to ring a bell. I'm going to look
> > for those, and probably look for the articles that you folks have
> > mentioned as well.
> >
> > I'm a ways away from getting "up&running" most stuff has been packed for
> > our move. I'll be setting up a home office soon and hope to have some time
> > to play around with some simple game ideas that I've had for many years.
> >
> > Thanks for the info on the E/A...
> > -Kory
> >
> >
> > --- In [email-masked], "Jon Vogel" wrote:
> >>
> >>
> >> I like the Molesworth book the brown one). He covers the full gamut of
> >> assembly on the TI, including graphics, keyboard and file I/O.
> >>
> >> The Morley book (the blue one) is not so useful. He spends a lot of time
> >> going over some basic stuff and never really gets to the fun stuff.
> >>
> >> I have never found the Compute! book, but it is rumored to be good.
> >>
> >> Regards,
> >>
> >> Jon
> >>
> >> ----- Original Message -----
> >> From: kory
> >> To: [email-masked]
> >> Sent: Thursday, July 08, 2010 4:27 PM
> >> Subject: [TI994A] E/A question
> >>
> >>
> >>
> >> Just wondering if anyone can point out a good book that is specific to
> >> the E/A cart, and not the Mini Memory cart. Something that has examples
> >> that I can code,... with a step by step approach.
> >>
> >> I am looking to program mostly graphics/sounds/game like stuff. I'm
> >> familiar with XB, but have not been sucessful with E/A and the 3ring
> >> binder that it comes with.
> >>
> >> Thanks,
> >> -Kory
> >>
>

------------------------------------

Yahoo! Groups Links

<*> To visit your group on the web, go to:
http://groups.yahoo.com/group/TI994A/

<*> Your email settings:
Individual Email | Traditional

<*> To change settings online go to:
http://groups.yahoo.com/group/TI994A/join
(Yahoo! ID required)

<*> To change settings via email:
[email-masked]
[email-masked]

<*> To unsubscribe from this group, send an email to:
[email-masked]

<*> Your use of Yahoo! Groups is subject to:
http://docs.yahoo.com/info/terms/

---

From: [email-masked]
Date: Fri, 09 Jul 2010 15:41:36 -0500 (CDT)

Actually, the reason the files on the Hidden Reef are in DV80 format is because they came directly from Bruce's own 5.25 original floppy disks. I don't remember if he used the funnelweb editor or his own editor.

Jul 9, 2010 01:38:23 PM, [email-masked] wrote:

Just think of it as a $75 bundle then. It's CaDD's product and they can price it however they want. As a consumer I have the option to buy or not buy.

As for Pitfall, congratulations on the module and your decision to release the source, etc. But, that is my point. It was 'your' decision. I'm not a gamer, but I know that many users appreciate it.

CaDD does not own "Art of Assembly", but they do hold a copyright to the collection which is in their format. Therefore anyone is free to reproduce "Art of Assembly", but would be violating copyright laws if they used the copy on The CYC as the basis for the reproduction.

I'm not sure how the files on The Hidden Reef were produced because they are in DV80 files, but I'm guessing they came from Bruce or another other source.

As for qualifying. I agree that 1300 hours is a lot of time, but it's only a fraction of what Mike has put into The CYC.

Ernie

---

From: [email-masked]
Date: Fri, 9 Jul 2010 16:51:14 EDT

After they appeared in MICROpendium, Bruce distributed "The Art of  
Assembly" to anyone who wanted them as a series of D/V 80 files. I worked  
intermittently with Bruce over the years and have a complete set of his files as  
well as all of the software that he produced.
 
They were produced from both F'WEB editors (the earliest issues) and from  
his own editor as he progressed through the series. It is a relatively easy  
matter to move them into WORD format from the originals. 
 
Bob  Carmany

In a message dated 7/9/2010 4:41:41 P.M. Eastern Daylight Time,  
[email-masked] writes:

Actually, the reason the  files on the Hidden Reef are in DV80 format is 
because they came directly from  Bruce's own 5.25 original floppy disks. I 
don't remember if he used the  funnelweb editor or his own editor.

Just think of it  as a $75 bundle then. It's CaDD's product and they can 
price it however they  want. As a consumer I have the option to buy or not 
buy. 

As for  Pitfall, congratulations on the module and your decision to release 
the  source, etc. But, that is my point. It was 'your' decision. I'm not a 
gamer,  but I know that many users appreciate it.

CaDD does not own "Art of  Assembly", but they do hold a copyright to the 
collection which is in their  format. Therefore anyone is free to reproduce 
"Art of Assembly", but would  be violating copyright laws if they used the 
copy on The CYC as the basis  for the reproduction.

I'm not sure how the files on The Hidden Reef  were produced because they 
are in DV80 files, but I'm guessing they came  from Bruce or another other 
source.

As for qualifying. I agree that  1300 hours is a lot of time, but it's only 
a fraction of what Mike has put  into The CYC.

Ernie