Subject: Title screen and XB question..

From: "kory" <[email-masked]>
Date: Sun, 18 Jul 2010 03:59:24 -0000

Is there a way to change the start up / title screen, and also change the text and background color for basic, or XBasic? Is there also a way to install XB and or E/A into the console, replacing basic?

Thanks, 
-Kory

---

From: Marc Hull <[email-masked]>
Date: Sun, 18 Jul 2010 04:37:37 -0700 (PDT)

#1 yes with a GRAM device of some sort.

#2 you can install GROMS & Roms internally which can then be selected by a rotary switch instead of using the carts.  You need to be handy with a soldering iron though...

--- On Sat, 7/17/10, kory <[email-masked]> wrote:

From: kory <[email-masked]>
Subject: [TI994A] Title screen and XB question..
To: [email-masked]
Date: Saturday, July 17, 2010, 10:59 PM

  

Thanks, 

-Kory

---

From: "Jacques Groslouis" <[email-masked]>
Date: Sun, 18 Jul 2010 09:12:00 -0300

With respect to the first question, I seem to remember a LOAD program that 
made a revision to the title screen without the use of a GRAM device. I 
believe the author's name was Art Gibson and the revision involved replacing 
the word 'TEXAS' with the word "ART'S" on the title screen.

Regards,

Jacques

Nominate someone to your TI99HOF
Check out www.ti99hof.org

----- Original Message ----- 
From: "Marc Hull" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, July 18, 2010 8:37 AM
Subject: Re: [TI994A] Title screen and XB question..

#2 you can install GROMS & Roms internally which can then be selected by a 
rotary switch instead of using the carts. You need to be handy with a 
soldering iron though...

      Is there a way to change the start up / title screen, and also change 
the text and background color for basic, or XBasic? Is there also a way to 
install XB and or E/A into the console, replacing basic?

Thanks,

-Kory

---

From: "kory" <[email-masked]>
Date: Sun, 18 Jul 2010 22:06:11 -0000

Thanks! So, what I am wanting to do is make my own title screen.. My own graphics etc and dump the original. I want to remove TI basic, and have XBasic in its place. This could all be done with a GRAM device? I'm not really looking to install a switch. I just want to turn on my TI and have a menu of TI Xbasic and E/A. I'd like to not have to use a cart in the cartridge slot, but I would be fine with attaching an E/A cart by wiring it and mounting it in the console. Could this be done, by just running a series of wires from each "trace" not sure if that's the right word.. on an E/A cart, to the cart port? If a cart is plugged in after that would there be a third option on the menu?

Example: Xbasic replaced basic in the console, using a Gram Kracker.. It appears as #1 on the menu, E/A has been attached to the cartridge port, and mounted inside of the console.. it appears as #2 on the menu, I plug in Parsec, and it appears as #3 in the menu.. Is that possible without a switch?

Thanks again!
-Kory

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
> #2 you can install GROMS & Roms internally which can then be selected by a rotary switch instead of using the carts.Â  You need to be handy with a soldering iron though...
> 
> 
> 
> --- On Sat, 7/17/10, kory <shortbusalaboard@...> wrote:
> 
> From: kory <shortbusalaboard@...>
> Â

---

From: "epergrem" <[email-masked]>
Date: Sun, 18 Jul 2010 22:27:19 -0000

Kory,
TI Basic can't be replaced with XB.  Two totally different animals in terms of hardware requirements.  

You can however install XB inside the console connect a switch to turn it on/off. It won't show up on the menu unless it's switched on.  

However, based on what you described, you're looking for a GRAM Kracker, or ideally a SNUG HSGPL, since it resides in the pbox.  

Ernie

--- In [email-masked], "kory" <shortbusalaboard@...> wrote:
> --- In [email-masked], Marc Hull <marc.hull@> wrote:
> >
> > --- On Sat, 7/17/10, kory <shortbusalaboard@> wrote:
> > 
> > From: kory <shortbusalaboard@>

---

From: Gregory McGill <[email-masked]>
Date: Sun, 18 Jul 2010 16:54:38 -0700

Yep with gram packer and a gram kracker (or equiv) you can do like you
described.. check out my boot screen:

http://www.thekeep.net/mcgill/images/101_0120.jpg

Xbasic (with some addons like call cat("DSKx") etc) and other programs,
dm1000 is loaded in rom space, some of that list loads off my hd..  gram
packer load screen will load ea5 and xbasic programs off the menu..

Greg

On Sun, Jul 18, 2010 at 3:27 PM, epergrem <[email-masked]> wrote:

> You can however install XB inside the console connect a switch to turn it
> on/off. It won't show up on the menu unless it's switched on.
>
> However, based on what you described, you're looking for a GRAM Kracker, or
> ideally a SNUG HSGPL, since it resides in the pbox.
>
> Ernie
>
>
> --- In [email-masked] <TI994A%40yahoogroups.com>, "kory"
> <shortbusalaboard@...> wrote:
> >
> >
> >
> > Thanks! So, what I am wanting to do is make my own title screen.. My own
> graphics etc and dump the original. I want to remove TI basic, and have
> XBasic in its place. This could all be done with a GRAM device? I'm not
> really looking to install a switch. I just want to turn on my TI and have a
> menu of TI Xbasic and E/A. I'd like to not have to use a cart in the
> cartridge slot, but I would be fine with attaching an E/A cart by wiring it
> and mounting it in the console. Could this be done, by just running a series
> of wires from each "trace" not sure if that's the right word.. on an E/A
> cart, to the cart port? If a cart is plugged in after that would there be a
> third option on the menu?
> >
> > Example: Xbasic replaced basic in the console, using a Gram Kracker.. It
> appears as #1 on the menu, E/A has been attached to the cartridge port, and
> mounted inside of the console.. it appears as #2 on the menu, I plug in
> Parsec, and it appears as #3 in the menu.. Is that possible without a
> switch?
> >
> > Thanks again!
> > -Kory
> >
> >
> >
> > --- In [email-masked] <TI994A%40yahoogroups.com>, Marc Hull
> <marc.hull@> wrote:
> > >
> > > #2 you can install GROMS & Roms internally which can then be selected
> by a rotary switch instead of using the carts.Â  You need to be handy with a
> soldering iron though...
> > >
> > >
> > >
> > > To: [email-masked] <TI994A%40yahoogroups.com>

---

From: "Jacques Groslouis" <[email-masked]>
Date: Sun, 18 Jul 2010 20:56:41 -0300

Kory,

Do not overlook the advantages of using the Funnelweb set of program files. 
FWB loaded from an Extended Basic cartridge also gives you the capability of 
using similar functions to having the EA, TIWriter and  Disk Manager 
cartridges all plugged in at once. This is especially useful when combined 
with a fully loaded Horizon Ram Disk 4000 because FWB can the bypass the 
start up screen when a program has completed running and you are returned to 
the FWB menu.  The HRD can add up to 6 Ram drives to an existing 2 floppy 
drives. As Ernie has pointed out a SNUG HSGPL card is useful because it 
allows you to access 16 cartridges without needing the cartridges.

Funnelweb can be configured to act as an operating system much in the same 
manner that Windows acts on a PC. FWB does not support a mouse or icons but 
its various menus can run the various programs on a HRD card and the modules 
on a HSGPL card from its various menus.

Regards,

Jacques

----- Original Message ----- 
From: "kory" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, July 18, 2010 7:06 PM
Subject: [TI994A] Re: Title screen and XB question..

Thanks again!
-Kory

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
> rotary switch instead of using the carts.Â You need to be handy with a 
> soldering iron though...
>
>
>
>       Is there a way to change the start up / title screen, and also 
> change the text and background color for basic, or XBasic? Is there also a 
> way to install XB and or E/A into the console, replacing basic?
>
>
>
> Thanks,
>
> -Kory
>

---

From: ti99_forever <[email-masked]>
Date: Sun, 18 Jul 2010 18:59:35 -0700 (PDT)

You could get a Gram device, and then use RXB. This includes both a souped-up version of XB and an EA all in one.
When you want to play Parsec, you can load it into your Gram device, or load a stand-alone version from disk instead.

--- On Sun, 7/18/10, kory <[email-masked]> wrote:

From: kory <[email-masked]>
Subject: [TI994A] Re: Title screen and XB question..
To: [email-masked]
Date: Sunday, July 18, 2010, 6:06 PM

Thanks again!
-Kory

>       Is there a way to change the start up / title screen, and also change the text and background color for basic, or XBasic? Is there also a way to install XB and or E/A into the console, replac…

------------------------------------

Yahoo! Groups Links

---

From: fdos <[email-masked]>
Date: Mon, 19 Jul 2010 10:03:13 -0700

Greg,

Unless you have a later version of Gram Packer with a better EA5 loader 
than mine (if so please send my a copy of your Gram Packer loader 
files), you should qualify your statement to "will load some EA5 
programs from created menu).

Bill S

---

From: Gregory McGill <[email-masked]>
Date: Mon, 19 Jul 2010 11:24:05 -0700

I'll check what version I have,  It loads dm2k, dm1k, telco and remindme
fine..

Greg

---

From: fdos <[email-masked]>
Date: Mon, 19 Jul 2010 16:08:20 -0700

Greg,

DM2K is probably clue enough, but to be sure can you load John Johnson's 
BOOT MENU program with yours?  If so, can I get a copy of the two Gram 
Packer EA5 loaders from you?  Do you know which one you use to load DM2K 
(low memory or high memory loader)?

Bill S

---

From: "kory" <[email-masked]>
Date: Tue, 20 Jul 2010 05:41:48 -0000

So.. (I'm not as bright as most of the stars here).. a GRAM device should do what I want to do as far as changing the title screen, and F/B colors. Will these changes "stick" with all other hardware removed.. No GRAM device plugged in, and no cart, or PEB etc.. If I modify a consoles startup screen and F/B colors and give it to a friend, will those changes still be there?

I just want to make sure I'm following!!

I read a bit about the HSGPL card and am wondering if someone can give me a short version.. Get an HSGPL card, and install EPROMS/ROMS?? into banks on the card.. These are ROMS I remove from a cart or buy? I can have 16 of these and when I boot my system I get a menu of the HSGPL banks to choose from? I'm trying here, I'm just not real informed on all the ROM/EPROM stuff. Where is the override for the TI title screen & TI menu, or do I select HSGPL from the standard TI menu?

Thanks for putting up with me on this. It is something I've always wanted to do. The black on cyan gives me a headache. Are HSGPL cards available anywhere? If so, what do they run? I don't mind soldering one up if I can get a kit or something. Same questions as above with a GRAM device!

Thanks guys!

---

From: "epergrem" <[email-masked]>
Date: Tue, 20 Jul 2010 08:17:55 -0000

Answer to question, No. 

Once the GRAM device is removed the title screen, etc. reverts back to the original settings since you aren't modifying the system GROMs, just overriding them.  Gary Bowser's Son of Board (SOB), designed a daughter board to replace the system GROMs, so he could modify the title screen,.  The only way you're going to make anything permanent is though something similar. Besides SOB still wouldn't address you F/B colors.

Give the "German 128K GRAM Karte" section at http://www.nouspikel.com/ti99 a read if you want a better understanding of the HSGPL.  It's not the same device, but the HSGPL was derived from the GRAM Karte.

If you're interested in purchasing a HSPGL, then I would recommend posting a message on the ti99-4a yahoo group, since the designer (Michael Becker) frequents that group. 

Ernie

---

From: "Jacques Groslouis" <[email-masked]>
Date: Tue, 20 Jul 2010 06:59:27 -0300

Kory,

If your main concern is to over-ride the start-up screen, a Horizon Ram Disk
card will do that. With this card you can set the program that will run when
you turn on your TI. The HRD comes with a program called 'MENU' which is an
adaptation for HRD of a program called 'BOOT'. This presents a three page 
menu
of programs that you can select. On my set-up I use Funnelweb as my start-up
menus because it provides a larger set of menus. There are some differences
between the programs that can easily be run from FW compared to MENU and for
this reason I also have MENU as an item on my FW menu.

For a description of the HSGPL card you can go to http://go.to/snug It may
be more difficult to get an HSGPL card than other gram devices.

Jacques

----- Original Message ----- 
From: "kory" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, July 20, 2010 2:41 AM
Subject: [TI994A] Re: Title screen and XB question..

>
>
> So.. (I'm not as bright as most of the stars here).. a GRAM device should
> do what I want to do as far as changing the title screen, and F/B colors.
> Will these changes "stick" with all other hardware removed.. No GRAM
> device plugged in, and no cart, or PEB etc.. If I modify a consoles
> startup screen and F/B colors and give it to a friend, will those changes
> still be there?
>
> I read a bit about the HSGPL card and am wondering if someone can give me
> a short version.. Get an HSGPL card, and install EPROMS/ROMS?? into banks
> on the card.. These are ROMS I remove from a cart or buy? I can have 16 of
> these and when I boot my system I get a menu of the HSGPL banks to choose
> from? I'm trying here, I'm just not real informed on all the ROM/EPROM
> stuff. Where is the override for the TI title screen & TI menu, or do I
> select HSGPL from the standard TI menu?
>
> Thanks for putting up with me on this. It is something I've always wanted
> to do. The black on cyan gives me a headache. Are HSGPL cards available
> anywhere? If so, what do they run? I don't mind soldering one up if I can
> get a kit or something. Same questions as above with a GRAM device!
>
> Thanks guys!
>
>
>
>

---

From: Marc Hull <[email-masked]>
Date: Tue, 20 Jul 2010 06:47:31 -0700 (PDT)

Jacques suggestion is probably the best one yet.  A HRD almost creates a DOS environment where you can pick and chose different programs without switching carts.  If you implant an XB cart into your console then you will not even need most carts as most everything has been dumped/converted to disk anyway.  This set up makes for lightning fast program loads and assembling time (if that's your thing...)

Ernie P. has a RAM disk on Ebay right now.  Should do the trick.  (I'll bill you later for the ad Ern ;-)

Marcus

--- On Tue, 7/20/10, Jacques Groslouis <[email-masked]> wrote:

From: Jacques Groslouis <[email-masked]>
Subject: Re: [TI994A] Re: Title screen and XB question..
To: [email-masked]
Date: Tuesday, July 20, 2010, 4:59 AM

  

      Kory,

menu

Jacques

---

From: "epergrem" <[email-masked]>
Date: Tue, 20 Jul 2010 17:17:24 -0000

Why thank you Marc. :-)

I have one sitting in Germany also, if I could ever get it back from Michael Becker.  He's had it for over 2 years.  A few more months and it will have spent as much time in Germany as I did when I was with the USAF.

Ernie

> 
> Ernie P. has a RAM disk on Ebay right now.Â  Should do the trick.Â  (I'll bill you later for the ad Ern ;-)
>

---

From: "kory" <[email-masked]>
Date: Tue, 20 Jul 2010 19:28:27 -0000

Wow! This is a complicated if not immposible mission I set out on.. :(

I have a MYARC 512k card.. Are there any programs that will allow it to act the way you are describing the HRD can be set up?

Last question... Can a Supercart or similar be set up with say XBasic, E/A, DM etc?

Thanks again! For now, I'm thinking that I might look into the HSGPL card. I'm also planning to install XBasic, and possibly E/A into the console with switches.. 

-Kory

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
> --- On Tue, 7/20/10, Jacques Groslouis <jgroslou@...> wrote:
> 
> From: Jacques Groslouis <jgroslou@...>
> From: "kory" <shortbusalaboard@...>
>

---

From: Marc Hull <[email-masked]>
Date: Tue, 20 Jul 2010 13:09:04 -0700 (PDT)

No it's not complicated nor impossible just kind of intimidating at first.  It's difficult to get out of the color bar mindset but once you do you can see the potential of the machine.

I don't know if ROS will run on a myarc 512K card.  I really doubt it (ROS is what makes all this possible, it stands for Ram Operating System and is a marvel of code writing.)  This piece of software is what bypasses all the TI crud and lets you run what you want almost immediately.

A super-cart most defiantly cannot hold XB nor the GPL of the E/A module (correct me if I'm wrong gents.)

As far as a HSGPL card goes.  I'd bet that there is little if anything that the HSGPL card (or any GRAM device) can do that the HRD and a TI cannot.  As I stated earlier most carts can be run from disk now so GRAM/GROM is kind of a moot point.

My two cents.....  Sell you 512K card,  your 68 Camaro or your first born and get the RAM disk ;-)... I am sure their are other opinions out there, if so please chime in so I may learn something...

The only reason I have implanted the carts into my console (other than something to do) is as a backup when the system bonks out and the ROS needs to be reloaded or to use the E/A loader on some programs that have difficulty running from the other loaders or I need access to the TI DMII.

--- On Tue, 7/20/10, kory <[email-masked]> wrote:

From: kory <[email-masked]>
Subject: [TI994A] Re: Title screen and XB question..
To: [email-masked]
Date: Tuesday, July 20, 2010, 2:28 PM

  

      

-Kory

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

> Jacques suggestion is probably the best one yet.Â  A HRD almost creates a DOS environment where you can pick and chose different programs without switching carts.Â  If you implant an XB cart into your console then you will not even need most carts as most everything has been dumped/converted to disk anyway.Â  This set up makes for lightning fast program loads and assembling time (if that's your thing...)

---

From: Marc Hull <[email-masked]>
Date: Tue, 20 Jul 2010 13:10:24 -0700 (PDT)

Wow.  Hope it still understands commands in English when you get it back ;-)

--- On Tue, 7/20/10, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] Re: Title screen and XB question..
To: [email-masked]
Date: Tuesday, July 20, 2010, 12:17 PM

  

      Why thank you Marc. :-)

Ernie

---

From: fdos <[email-masked]>
Date: Wed, 21 Jul 2010 09:54:27 -0700

Marc,

A standard Super Cart is the E/A Module with 8K of battery backed SRAM, 
so no it can't contain XB or any other GPL module.  BCART will allow 
almost 8K of TI BASIC (GPL code) to run in the battery backed ram of a 
Super Cart.  Usually, the 8K is used for small EA3 object code programs 
(Super Bug II, 4ADOS, etc.) or data storage.  Super Space II has 4 x 8K 
banks of battery backed SRAM.  Wish I had a couple.

Bill S

Marc Hull wrote:
> No it's not complicated nor impossible just kind of intimidating at first.Â  It's difficult to get out of the color bar mindset but once you do you can see the potential of the machine.
> 
> I don't know if ROS will run on a myarc 512K card.Â  I really doubt it (ROS is what makes all this possible, it stands for Ram Operating System and is a marvel of code writing.)Â  This piece of software is what bypasses all the TI crud and lets you run what you want almost immediately.
> 
> As far as a HSGPL card goes.Â  I'd bet that there is little if anything that the HSGPL card (or any GRAM device) can do that the HRD and a TI cannot.Â  As I stated earlier most carts can be run from disk now so GRAM/GROM is kind of a moot point.
> 
> My two cents.....Â  Sell you 512K card,Â  your 68 Camaro or your first born and get the RAM disk ;-)... I am sure their are other opinions out there, if so please chime in so I may learn something...
> 
>> Jacques suggestion is probably the best one yet.Ã‚Â  A HRD almost creates a DOS environment where you can pick and chose different programs without switching carts.Ã‚Â  If you implant an XB cart into your console then you will not even need most carts as most everything has been dumped/converted to disk anyway.Ã‚Â  This set up makes for lightning fast program loads and assembling time (if that's your thing...)
> 
> 
>> Ernie P. has a RAM disk on Ebay right now.Ã‚Â  Should do the trick.Ã‚Â  (I'll bill you later for the ad Ern ;-)
> 
> 
>> Marcus
> 
> 
>> Ã‚Â