Subject: Re: [TI994A] TurboForth preparation

From: [email-masked]
Date: Sat, 10 Apr 2010 06:50:50 EDT

The first edition of Brodie's book "Starting FORTH" uses examples from  
FigFORTH. The second edition uses FORTH 83. Sop there is some confusion!
 
Bob  Carmany

---

From: [email-masked]
Date: Sat, 10 Apr 2010 13:37:11 EDT

Wycove Vn 3.0 came out after 1983 - I'll check my notes and correspondence  
from Tim and see what I can come up with.
 
Bob  Carmany  

In a message dated 4/10/2010 1:05:20 P.M. Eastern Daylight Time,  
[email-masked] writes:

In my  Wycove forth the Starting Forth compatibility screens are 58 ~ 60. 
I don't know if they're referring to the first edition or the second  
edition, so I would guess the first edition as the second edition is  
copyrighted 1987 and the Wycove manual I have is copyrighted 1983.  
Sherlock Holmes would be proud of me. :-)

Bill  S

---

From: [email-masked]
Date: Mon, 12 Apr 2010 08:43:32 EDT

The easiest way is to send a linefeed CHR$(12).
 
Bob  Carmany  

In a message dated 4/12/2010 2:41:03 A.M. Eastern Daylight Time,  
[email-masked] writes:

In TI  FORTH you could write it this way after loading -SYNONYMS:

: PAGE   0 0 GOTOXY CLS ;  ( CLS is a system CALL so very fast )

Bill  S

mark wills wrote:
>  
> 
> In TurboForth you  could do
> 
> : CLEAR 0 0 GOTOXY 768 0 DO SPACE LOOP ;
>  
> or even faster
> 
> : CLEAR 0 0 GOTOXY 24 0 DO 32 SPACES  LOOP ;
> 
> In TurboForth you want PAGE instead of CLS. Of course,  you could define 
> CLS as a synonym:
> 
> : CLS PAGE  ;
> 
> ----- Original Message ----
>  > From: Owen  Brand <[email-masked] 
>  <mailto:owenbrand%40opry99er.com>>
>  > To:  "[email-masked] <mailto:TI994A%40yahoogroups.com>" 
>  <[email-masked]  <mailto:TI994A%40yahoogroups.com>>
>  > Sent: Sat, 10  April, 2010 22:19:58
>  > Subject: Re: [TI994A] TurboForth  preparation
>  >
>  > Wrote my first screen clear  word... It's not an example in the book
>  >
> and there  is probably much faster ways to do it, but I just wanted to
>   >
> see if it worked.
> 
> : CLEAR 768 0 DO 32 EMIT  LOOP
>  > ;
> 
> :)
> 
> Owen  Brand
> Opry99er.com
> 
> On Apr 10, 2010, at  3:15
>  > PM, fdos <
>  >  href="mailto:[email-masked] 
>  <mailto:fdosbrs%40frontiernet.net>">[email-masked] 
>  <mailto:fdosbrs%40frontiernet.net>>
>  > wrote:
>  
>  > Yes, TI did that too. I hate that --> method as  it
>  > doesn't work well
>  > with  THRU.
>  >
>  > Forth+ and X4th99 are  LOAD
>  > and THRU exclusive, and no  SCREENS/BLOCKS
>  > contain the --> word.
>  >  Brodie's book THINKING FORTH forwards the KISS
>  > principle of  Forth style
>  > in a most excellent manner that I  subscribe
>  > to
>  >
>  >  totally.
>  >
>  > Having KISS with Forth fun  here. :-)
>  >
>  >
>  > Bill  S
>  >
>  >
>  >  href="mailto:[email-masked] 
>  <mailto:rmcarmany%40aol.com>">[email-masked] 
>  <mailto:rmcarmany%40aol.com>
>  > wrote:
>   >>
>  >>
>  >> I checked, the screens  are linked so
>  > 58 LOAD will load all three of
>   >> them.
>  >>
>  >>
>   > Bob Carmany
>  >>
>  >> In a message  dated 4/10/2010 1:54:52 P.M.
>  > Eastern Daylight  Time,
>  >>
>  >  href="mailto:[email-masked] 
>  <mailto:fdosbrs%40frontiernet.net>">[email-masked] 
>  <mailto:fdosbrs%40frontiernet.net>
>  >  writes:
>  >>
>  >>
>   >>
>  >
>  >
>   >
>  > ------------------------------------
>   >
>  > Yahoo! Groups
>  > Links
>   >
>  >
>  >
> 
>  ------------------------------------
> 
> Yahoo!
>   > Groups Links
> 
>  >
>  >  >http://groups.yahoo.com/group/TI994A/ 
>  <http://groups.yahoo.com/group/TI994A/>
> 
>  >  href="http://groups.yahoo.com/group/TI994A/join 
>  <http://groups.yahoo.com/group/TI994A/join>" target=_blank
>   > >http://groups.yahoo.com/group/TI994A/join 
>  <http://groups.yahoo.com/group/TI994A/join>
> (Yahoo!  ID
>  > required)
> 
>  >  href="mailto:[email-masked] 
>  <mailto:TI994A-digest%40yahoogroups.com>">[email-masked]  
> <mailto:TI994A-digest%40yahoogroups.com>
>   >
> 
>  >  href="mailto:[email-masked] 
>  
<mailto:TI994A-fullfeatured%40yahoogroups.com>">[email-masked]  
> <mailto:TI994A-fullfeatured%40yahoogroups.com>
>  
>  > ymailto="mailto:[email-masked]  
> <mailto:TI994A-unsubscribe%40yahoogroups.com>"
>   > href="mailto:[email-masked] 
>  
<mailto:TI994A-unsubscribe%40yahoogroups.com>">[email-masked]  
> <mailto:TI994A-unsubscribe%40yahoogroups.com>
>  
>  > href="http://docs.yahoo.com/info/terms/ 
>  <http://docs.yahoo.com/info/terms/>" target=_blank
>  >  >http://docs.yahoo.com/info/terms/  
<http://docs.yahoo.com/info/terms/>

------------------------------------

Yahoo! Groups  Links