Subject: Re: [TI994A] Re: TurboForth preparation

From: [email-masked]
Date: Sun, 11 Apr 2010 12:36:47 EDT

Wrong - it is included in Vn 3.0. You can load options either by string  
comparison or by absolute screen #.
 
Bob  Carmany  

In a message dated 4/11/2010 12:09:20 P.M. Eastern Daylight Time,  
[email-masked] writes:

MENU is a TI-Forthism. With Wycove, it is natural to  refer to the manual 
and load the routines by screen #.

--- On  Sun, 4/11/10, Owen Brand <[email-masked]>  wrote:

From:  Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re:  TurboForth preparation
To: "[email-masked]"  <[email-masked]>
Date: Sunday, April 11, 2010, 12:00  PM

V 3.0. MENU didn't work, still.  I reset the emulator which  I think 
disabled the 58 LOAD from before since I didn't save.  MENU on the commandline 
still returns MENU?

Owen Brand  
 
_Opry99er.com_ (http://opry99er.com/) 

On Apr 11, 2010, at 11:49 AM, [email-masked] 
(mip://03f53520/mc/compose?to=[email-masked])   wrote:

Owen,
 
Which version of Wycove are you working with? Tim included MENU  in Vn 3.0 
inspired by my code through our correspondence over the  years. However, the 
choices need to reside in screen #1 in the  'SCREENS' file. If you are 
using Vn 2.1, you will have to  create the MENU word yourself since it isn't in 
the system.
                              
Here are a couple more versions of GOTOXY;
 
: GOTOXY SCREEN-WIDTH @  * +  >C9C8 !   ;
 
: GOTOXY SCREEN-WIDTH @  * +  [CURSOR-POS] LITERAL !  ;
 
Bob  Carmany

In a message dated 4/11/2010 10:42:19 A.M. Eastern Daylight  Time, 
owenbrand@opry99er. com writes:

How do I go about loading it up?  I'm having a bit of an  issue trying to 
access my menu screen.  MENU returns MENU? I  haven't tried anything like 
this yet... So far i've just been  playing on the command line. 

Owen Brand  
 
 (http://opry99er.com/) _Opry99er.com_ (http://opry99er.com/)

---

From: ti99_forever <[email-masked]>
Date: Sun, 11 Apr 2010 11:15:08 -0700 (PDT)

Vn 3.0 was not widely distributed, nor do I have a manual for it. But synonyms for screens are easy to do.

--- On Sun, 4/11/10, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] Re: TurboForth preparation
To: [email-masked]
Date: Sunday, April 11, 2010, 12:36 PM

 

Bob 
Carmany 

  

      MENU is a TI-Forthism. With Wycove, it is natural to 
        refer to the manual and load the routines by screen #.

--- On 
        Sun, 4/11/10, Owen Brand <[email-masked]> 
        wrote:

From: 
          Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: 
          TurboForth preparation
To: "[email-masked]" 
          <[email-masked]>
Date: Sunday, April 11, 2010, 12:00 
          PM

          

          V 3.0. MENU didn't work, still.  I reset the emulator which 
          I think disabled the 58 LOAD from before since I didn't save. 
           MENU on the commandline still returns MENU?

Owen Brand 
          
          Opry99er.com
          
On Apr 11, 2010, at 11:49 AM, [email-masked] 
          wrote:

            
            
            Owen,
             
            Which version of Wycove are you working with? Tim included MENU 
            in Vn 3.0 inspired by my code through our correspondence over the 
            years. However, the choices need to reside in screen #1 in the 
            'SCREENS' file. If you are using Vn 2.1, you will have to 
            create the MENU word yourself since it isn't in the system.

            : GOTOXY SCREEN-WIDTH @  * +  >C9C8 !  
;
             
            : GOTOXY SCREEN-WIDTH @  * +  [CURSOR-POS] LITERAL ! 
            ;
             
            Bob 
            Carmany

            In a message dated 4/11/2010 10:42:19 A.M. Eastern Daylight 
            Time, owenbrand@opry99er. com writes:

              How do I go about loading it up?  I'm having a bit of an 
              issue trying to access my menu screen.  MENU returns MENU? I 
              haven't tried anything like this yet... So far i've just been 
              playing on the command line. 

Owen Brand 
              
              Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 14:19:11 -0400

Is there a way to view an/or edit my words in Wycove?  I can't find  
the conventions.

Owen Brand
Opry99er.com

On Apr 11, 2010, at 2:15 PM, ti99_forever <[email-masked]>  
wrote:

> Wrong - it is included in Vn 3.0. You can load options either by  
> string comparison or by absolute screen #.
>
> Bob Carmany
>
> In a message dated 4/11/2010 12:09:20 P.M. Eastern Daylight Time, [email-masked] 
>  writes:
>
>
> MENU is a TI-Forthism. With Wycove, it is natural to refer to the  
> manual and load the routines by screen #.
>
> disabled the 58 LOAD from before since I didn't save.  MENU on the  
> commandline still returns MENU?
>
> Owen Brand
> Opry99er.com
>
> On Apr 11, 2010, at 11:49 AM, [email-masked] wrote:
>
>>
>>
>> Owen,
>>
>> Which version of Wycove are you working with? Tim included MENU in  
>> Vn 3.0 inspired by my code through our correspondence over the  
>> 'SCREENS' file. If you are using Vn 2.1, you will have to create  
>> the MENU word yourself since it isn't in the system.
>>
>> How do I go about loading it up?  I'm having a bit of an issue  
>> trying to access my menu screen.  MENU returns MENU? I haven't  
>> tried anything like this yet... So far i've just been playing on  
>> the command line.
>>
>> Owen Brand
>> Opry99er.com
>>
>>
>
>
>
>
>
>
>

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 14:20:40 -0400

"LIST" prints 1-25 on the left side of the screen and says "ok".  Just  
thought i'd try

Owen Brand
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 14:22:40 -0400

EDIT brings up a purple screen with a black cursor.

Owen Brand
Opry99er.com

---

From: "ti99_forever" <[email-masked]>
Date: Sun, 11 Apr 2010 18:38:20 -0000

Remember the Stack, Luke, remember the Stack!
Anyway, VLIST shows the words.
x LIST lists screen x
x EDIT
WHERE is a good word to take you to the position in a screen with an error

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Apr 11, 2010, at 2:15 PM, ti99_forever <ti99_forever@...>  
> wrote:
> 
> > --- On Sun, 4/11/10, rmcarmany@... <rmcarmany@...> wrote:
> >
> > From: rmcarmany@... <rmcarmany@...>
> > In a message dated 4/11/2010 12:09:20 P.M. Eastern Daylight Time, ti99_forever@... 
> >  writes:
> >
> >
> > --- On Sun, 4/11/10, Owen Brand <owenbrand@...> wrote:
> >
> > From: Owen Brand <owenbrand@...>
> > On Apr 11, 2010, at 11:49 AM, rmcarmany@... wrote:
> >
> >>
> >>
> >> Owen,
> >>

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 09:05:20 -0700

Owen,

I'm sure you need to proved the SCREEN/BLOCK number on the stack before 
invoking LIST.

Bill S

Owen Brand wrote:
> Opry99er.com <http://Opry99er.com>
> 
> On Apr 11, 2010, at 2:15 PM, ti99_forever <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>>  
>>
>> --- On *Sun, 4/11/10, [email-masked] /<[email-masked]>/* wrote:
>>
>>
>>     [email-masked] <http://yahoo.com> writes:
>>
>>
>>
>>         MENU is a TI-Forthism. With Wycove, it is natural to refer to
>>         the manual and load the routines by screen #.
>>
>>         --- On *Sun, 4/11/10, Owen Brand /<[email-masked]>/*
>>         wrote:
>>
>>
>>             V 3.0. MENU didn't work, still.  I reset the emulator
>>             which I think disabled the 58 LOAD from before since I
>>             didn't save.  MENU on the commandline still returns MENU?
>>
>>             Owen Brand
>>             <http://opry99er.com/>Opry99er.com <http://Opry99er.com>
>>
>>>             Which version of Wycove are you working with? Tim
>>>             included MENU in Vn 3.0 inspired by my code through our
>>>             correspondence over the years. However, the choices need
>>>             to reside in screen #1 in the 'SCREENS' file. If you are
>>>             using Vn 2.1, you will have to create the MENU word
>>>             yourself since it isn't in the system.
>>>                                         
>>>             In a message dated 4/11/2010 10:42:19 A.M. Eastern
>>>             Daylight Time, owenbrand@opry99er. com writes:
>>>
>>>
>>>
>>>                 How do I go about loading it up?  I'm having a bit of
>>>                 an issue trying to access my menu screen.  MENU
>>>                 returns MENU? I haven't tried anything like this
>>>                 yet... So far i've just been playing on the command
>>>                 line. 
>>>
>>>                 Owen Brand
>>>                 <http://opry99er.com/>
>>>                 <http://opry99er.com/>Opry99er.com <http://Opry99er.com>
>>>
>>>                  
>>>
>>
>>
>>
>>
>>
>>
>

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 09:06:39 -0700

Same for EDIT.  SCREEN/BLOCK number on the stack before invoking EDIT.

Bill S

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 09:08:39 -0700

Excellent in response and presentation.  The Forth is with us. :-)

Bill S

ti99_forever wrote:
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, Owen 
> Brand <owenbrand@...> wrote:
>  >
>  > > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
> ti99_forever@...
>  > > To: "[email-masked] <mailto:TI994A%40yahoogroups.com>" 
> <[email-masked] <mailto:TI994A%40yahoogroups.com>>