Subject: Re: [TI994A] Re: Infocom on the 99/4A

From: [email-masked]
Date: Sat, 17 Apr 2010 18:11:09 EDT

There were apparently eventually more than 3 copies of LGOP. I have had a  
copy for years that I was "leaked" from somewhere and later transported to a 
 3.5" disk when I switched my system many years ago over. In fact, I think 
I have  the complete set of Infocom adventures. There were a number of 
improved loaders  that came out over the years. One of the best is the one that 
Will McGovern put  together.
 
Bob  Carmany  

In a message dated 4/17/2010 5:14:43 P.M. Eastern Daylight Time,  
[email-masked] writes:

I know where all  three of those original copies of Leather Goddesses went 
too, Bill.  I  have one, Chris Bobbitt kept one for his personal collection, 
and the third  went to Jim Horn from Disk Only Software (they were related, 
if I remember  correctly, though I don’t remember how anymore). 
No problem on the  data either—too much valuable information has been lost 
over the years because  it wasn’t shared initially.  I’m actually glad to 
see long-lost folk like  Gary Bowser back on the message boards, because they 
bring a lot of otherwise  unavailable information with them.  Some folk 
might have issues with him  (and I’m pretty sure there are people out there 
with issues against me too,  for that matter), but I greatly respect him for 
being here, as I do every  member of the online TI forums.    
Jim

---

From: "Ksarul" <[email-masked]>
Date: Sat, 17 Apr 2010 18:21:10 -0400

The files were around for a long time in the wild.  I'd seen many of them
floating around on the user-group circuit before I bought mine-so they
apparently escaped early on.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Saturday, April 17, 2010 6:11 PM
To: [email-masked]
Subject: Re: [TI994A] Re: Infocom on the 99/4A

There were apparently eventually more than 3 copies of LGOP. I have had a
copy for years that I was "leaked" from somewhere and later transported to a
3.5" disk when I switched my system many years ago over. In fact, I think I
have the complete set of Infocom adventures. There were a number of improved
loaders that came out over the years. One of the best is the one that Will
McGovern put together.

Bob Carmany 

I know where all three of those original copies of Leather Goddesses went
too, Bill.  I have one, Chris Bobbitt kept one for his personal collection,
and the third went to Jim Horn from Disk Only Software (they were related,
if I remember correctly, though I don't remember how anymore).

No problem on the data either-too much valuable information has been lost
over the years because it wasn't shared initially.  I'm actually glad to see
long-lost folk like Gary Bowser back on the message boards, because they
bring a lot of otherwise unavailable information with them.  Some folk might
have issues with him (and I'm pretty sure there are people out there with
issues against me too, for that matter), but I greatly respect him for being
here, as I do every member of the online TI forums.   

Jim

---

From: "epergrem" <[email-masked]>
Date: Sat, 17 Apr 2010 22:57:24 -0000

Apparently someone released LGOP in a non-Infocom package because I have one.  The manual is the standard half page and says Infocom, but it also says "For the 99/4A and 9640", which doesn't sound like Infocom.  The manual includes the comic in black and white.

BTW, Both the disk and manual say Infocom, but the manual and disk label are very much in the style of Asgard. 

Ernie

--- In [email-masked], rmcarmany@... wrote:
> vze23g4a@... writes:
> if I remember  correctly, though I donâ€™t remember how anymore). 
> No problem on the  data eitherâ€"too much valuable information has been lost 
> over the years because  it wasnâ€™t shared initially.  Iâ€™m actually glad to 
> might have issues with him  (and Iâ€™m pretty sure there are people out there

---

From: Barry Boone <[email-masked]>
Date: Sat, 17 Apr 2010 19:20:16 -0400

All the games that were compatible with the “Version 3” Z-code interpreter (basically all of the ones I ported) had leaked around for the TI/Geneve for quite some time before Asgard came up with a way to officially make them available.  Suffice to say that the conversions and availability were done long before Chris Bobbitt made the deal with Infocom ☺

When I converted the first one, I came to realize that the native 99/4A interpreter had some bugs, the worst was one related to how the interpreter would do a binary search on the vocabulary table when it was parsing input.  If the vocabulary table exceeded a certain size the algorithm would break and start searching inside console ROM space for words.   I also optimized some of the routines a bit related to screen scrolling and internal efficiency (the code was fairly obviously ported to the 9900 from a VAX-like platform, possibly in some automated way, and there were some simple things that were done to speed things up a bit).

After fixing the bugs, I made several additional variants of the interpreter, one for 80 column cards, one for supercart, one for 80 columns plus supercart.  The supercart version was necessary because the native format of the Infocom files were split into two parts, the first part had to fit within the confines of RAM on the computer, and the second part was virtualized.   The first part had to be in RAM due to the need for it to be treated as read/write memory, vs. the rest which was purely code and static data.  Since some of the games had more of a 32K requirement for this space, I had to do a supercart requirement for those ports.

Another detail, the game used 255 byte records for the data files, but placed each record at successive 256 byte boundaries.  The last record of one of the files (which of the two escapes me at this moment) contained all of the 256th bytes of each data block.  The table of “last bytes” was stored in RAM and would be used to complete the VM records as they were pulled off disk. I wrote a program in XB that would take a DIS/FIX 128 file (a datafile download from another platform, usually either the PC or CoCo formats) and convert it to the Infocom native format for the TI.  Very slow but tolerable with my Ramdisk and hard drive.

Final bit of trivia, some of the Asgard games have a phrase containing “The Master” embedded in the credits.  This was left over from the original conversion process.

From: [email-masked] [mailto:[email-masked]] On Behalf Of epergrem
Sent: Saturday, April 17, 2010 5:57 PM
To: [email-masked]
Subject: [TI994A] Re: Infocom on the 99/4A

Ernie

---

From: Barry Boone <[email-masked]>
Date: Sat, 17 Apr 2010 19:21:25 -0400

Oh and about the below, I’ve seen these too, the ones I’ve run across were my ports that someone repackaged.

Ernie

---

From: "computerclassics2000" <[email-masked]>
Date: Sat, 17 Apr 2010 23:53:43 -0000

Wow! A gold mine of information on this topic. Thanks to Keith Bergman for asking the original question, Jim Fetzner for sharing his part in this history, and thanks of course to The Master (Barry Boone) for doing the conversions, the new coding and for sharing the detailed history behind the development with us.

Thanks, guys!!!

BillG

--- In [email-masked], Barry Boone <boone@...> wrote:
> --- In [email-masked]<mailto:TI994A%40yahoogroups.com>, rmcarmany@ wrote:
> >
> > vze23g4a@ writes: