Subject: Weekly Atariage chat

From: Owen Brand <[email-masked]>
Date: Sun, 11 Jul 2010 22:48:28 -0400

We schedule a weekly TI-99 chat over at Atariage every Sunday night, but
nobody's there... anyone wanna come do a live chat?  It's fun fun fun!

http://www.atariage.com/forums/index.php?app=ipchat

---

From: alekin garavia <[email-masked]>
Date: Mon, 12 Jul 2010 07:24:15 +0000 (GMT)

MMM for you is sunday night but for me? I need calculate different hour.. USA vs Italy ;-)

--- Lun 12/7/10, Owen Brand <[email-masked]> ha scritto:

Da: Owen Brand <[email-masked]>
Oggetto: [TI994A] Weekly Atariage chat
A: [email-masked]
Data: Lunedì 12 luglio 2010, 04:48

  

      We schedule a weekly TI-99 chat over at Atariage every Sunday night, but nobody's there... anyone wanna come do a live chat?  It's fun fun fun!
 
http://www.atariage .com/forums/ index.php? app=ipchat

---

From: "kory" <[email-masked]>
Date: Thu, 15 Jul 2010 08:07:13 -0000

I was snooping around in the atariage forums and my heart swelled with excitement as I read the 30 line game program challenge! I wish I could have participated in that. It actually got me thinking that it would be really cool to do one challenge per month and have a newsletter or small booklet at the end of the year with each months winner printed including the program lists, and maybe a few comments on portions of code that are exceptional.. I don't know, just thinking with the keyboard here.. Anyway,I can't wait to move and get set up so I can participate.

---

From: mark wills <[email-masked]>
Date: Thu, 15 Jul 2010 08:13:47 +0000 (GMT)

That's the spirit! The more the merrier!

-----------------------
Toady I will be thinking in Forth!

----- Original Message ----
> From: kory <[email-masked]>
> To: [email-masked]
> Sent: Thu, 15 July, 2010 9:07:13
> Subject: [TI994A] Re: Weekly Atariage chat..A BIT OFF EXACT TOPIC
> 
> 
> 
> I was snooping around in the atariage forums and my heart swelled with  
>excitement as I read the 30 line game program challenge! I wish I could have  
>participated in that. It actually got me thinking that it would be really cool  
>to do one challenge per month and have a newsletter or small booklet at the end  
>of the year with each months winner printed including the program lists, and  
>maybe a few comments on portions of code that are exceptional.. I don't know,  
>just thinking with the keyboard here.. Anyway,I can't wait to move and get set  
>up so I can participate.
> 
> 
> ------------------------------------
> 
> Yahoo!  Groups Links
> 
> 
> 
>

---

From: fdos <[email-masked]>
Date: Fri, 16 Jul 2010 09:26:49 -0700

Kory,

Even I, a non-gamester, appreciate your enthusiasm and idea of rewarding 
exceptional coding methods as a way to encourage "would be", nominal, 
very good and even guru programmers to continue honing their skills in 
this manner and thereby produce non-bloat-ware applications for 
everyone's benefit.  It could entice newbies and old coots to get 
involved. :-)

A great attitude anyway.

Bill S

kory wrote:
> excitement as I read the 30 line game program challenge! I wish I could 
> have participated in that. It actually got me thinking that it would be 
> really cool to do one challenge per month and have a newsletter or small 
> booklet at the end of the year with each months winner printed including 
> the program lists, and maybe a few comments on portions of code that are 
> exceptional.. I don't know, just thinking with the keyboard here.. 
> Anyway,I can't wait to move and get set up so I can participate.
> 
> 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, Owen 
> Brand <owenbrand@...> wrote:
>  >

---

From: fdos <[email-masked]>
Date: Fri, 16 Jul 2010 09:28:15 -0700

Now this is real thinking at it's best.

Bill S

mark wills wrote:
>  > From: kory <[email-masked] <mailto:shortbusalaboard%40aol.com>>
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 16 Jul 2010 22:08:43 -0500

Does someone have documentation handy regarding the installation and use of the load interrupt? I cannot seem to find my docs and have a need to modify a console for repair purposes.  Thx  Tim

_________________________________________________________________
The New Busy is not the too busy. Combine all your e-mail accounts with Hotmail.
http://www.windowslive.com/campaign/thenewbusy?tile=multiaccount&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_4

---

From: "[email-masked]" <[email-masked]>
Date: Sat, 17 Jul 2010 09:27:05 +0200

http://members.ziggo.nl/fgkaal/Hardware/hw_load_interrupt.html

-----Original Message-----

   Does someone have documentation handy regarding the installation
and use of the load interrupt? I cannot seem to find my docs and have
a need to modify a console for repair purposes.  Thx  Tim

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Sat, 17 Jul 2010 11:49:14 +0200

Wow, that surely is the rich man load switch! I was in hurry when I built 
a fully functional load switch by just throwing in a capacitor, a couple 
of resistors and a trimmer for my Geneve.

Of course mine can't compare to Fred's circuit. It may fail sometimes, 
either because the signal is too weak and doesn't trigger anything, or 
because it is not debounced enough: the program does not return properly 
and you've got to reset the Geneve.

Still, you if have no time and you are willing to fine tune the circuit a 
bit with the trimmer, you can adjust the trimmer so that it takes a little 
longer for the line to go LOW. Once you've done that, you will end up with 
a load switch that works 99% of the time, and when it doesn't you just 
pull the trigger a second time and, voila, there you get into your program 
(debugger or whatever that is).

To Load Line   --+--C1--+--R2--TR1--SW1--- To Ground
                 |      |
                 +--R1--+

C1 = 0.1 µF Ceramic Capacitor
R1 = 2.2 MOhm Resistor
R2 = 2.2 KOhm Resistor
TR1 = 1.0 KOhm Trimmer
SW1 = Momentary On Switch

Paolo

---

From: "Michael Zapf" <[email-masked]>
Date: Sat, 17 Jul 2010 12:16:57 -0000

I remember I once had a LOAD interrupt switch on my TI, and it was extremely simple - resistor plus a simple push button - and it worked fairly well.

The debouncing worked by changing the LOAD vector as the first instruction, e.g. by a CLR @>FFFC. The next triggers will shoot the values into ROM. Then you do a pause to wait for the key to be released and restore the vector and the previous workspace pointer.

Michael

---

From: Owen Brand <[email-masked]>
Date: Sat, 17 Jul 2010 08:45:58 -0400

I have one built into my speech synth.... Essentially just a resistor,  
some small wires inside "the mysterious door" and push button on the  
back, as Michael said.  ;) For a while I thought it was a reset button  
that didn't work... But that was me being ignorant..  :). It was done  
by Richard Lauhead, MSP99ers UG former president.  He is also the one  
I got my first PEB (in years) from.  Anyone ever seen a modifed synth  
like this?  If it's unique, I'll send it to someone to document it  
better than I can.

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jul 17, 2010, at 8:16 AM, "Michael Zapf" <[email-masked]>  
wrote:

> I remember I once had a LOAD interrupt switch on my TI, and it was  
> extremely simple - resistor plus a simple push button - and it  
> worked fairly well.
>
> The debouncing worked by changing the LOAD vector as the first  
> instruction, e.g. by a CLR @>FFFC. The next triggers will shoot the  
> values into ROM. Then you do a pause to wait for the key to be  
> released and restore the vector and the previous workspace pointer.
>
> Michael
>
>