Subject: CF7+ ???

From: [email-masked]
Date: Wed, 21 Apr 2010 17:19:38 -0500 (CDT)

A couple of questions for the CF7+ users out there. I have a stock TI console with a box car serial/PIO device and CF7+ setup on it. I just got a CF7+ today from Jamie that he changed the address of the PIO port on the CF7+ to 1E00. With XBasic installed the CF7+ works as it should and file manipulation is possible. When I try to use the TEII cart and choose option 3 the terminal program begins to run but then goes back to the title screen as if it is not able to find the serial port with the modem hooked up to it. If I just remove the CF7+ and only the box car is left connected to the console the TEII cart runs fine and I can dial up the BBS. My question is, does anyone out there have their CF7+ working with a boxcar device and if so how did you get around the obvious conflict with the PIO of the devices?

Also, is anyone out there using a widget with the CF7+? I have tried to use a widget with XBasic and TEII on it and it is very unpredictable after initial power up.

---

From: Owen Brand <[email-masked]>
Date: Wed, 21 Apr 2010 19:08:04 -0400

I never tried to use the PIO port on my CF7.  I use it just as an  
emulated DSK drive and 32k mem.  If I want to print something, I  
transfer it to my PC and print it from there.  Although, there has  
been talk of using the PIO as a communications device to a PC... I  
believe Thierry Nouspikel has a cable design for this.  In any case,  
I'm interested in your CF7 work, Richard.  I'm looking forward to  
using the CF7 with a modified console using the CF7 mod you created  
for switching.  :)

Owen Brand
Opry99er.com

On Apr 21, 2010, at 6:19 PM, [email-masked] wrote:

> A couple of questions for the CF7+ users out there. I have a stock  
> TI console with a box car serial/PIO device and CF7+ setup on it. I  
> just got a CF7+ today from Jamie that he changed the address of the  
> PIO port on the CF7+ to 1E00. With XBasic installed the CF7+ works  
> as it should and file manipulation is possible. When I try to use  
> the TEII cart and choose option 3 the terminal program begins to run  
> but then goes back to the title screen as if it is not able to find  
> the serial port with the modem hooked up to it. If I just remove the  
> CF7+ and only the box car is left connected to the console the TEII  
> cart runs fine and I can dial up the BBS. My question is, does  
> anyone out there have their CF7+ working with a boxcar device and if  
> so how did you get around the obvious conflict with the PIO of the  
> devices?
>
> Also, is anyone out there using a widget with the CF7+? I have tried  
> to use a widget with XBasic and TEII on it and it is very  
> unpredictable after initial power up.
>
>

---

From: "Gary from O.P.A." <[email-masked]>
Date: Thu, 22 Apr 2010 00:44:18 -0000

That is strange, I replied to this topic, but it does not seem to appear.

Anyhow, have you used a program to scan the CRU bases, and make sure the CF7 is repling at the new 1E00 address, that Jamie moved it to.

And are you using a offical TI sidecar (rs232), or is it a third-party one, and if the later is it at the normal 1300 address, or possible another address like (ugh) the 1E00 or 1F00.

And lastly did you try another terminal program besides TE2?

---

From: "Gary from O.P.A." <[email-masked]>
Date: Thu, 22 Apr 2010 00:16:29 -0000

Well, two things to try, try running a EA terminal program like MassTransfer instead of TE2 and see what happens.

Use a Memory Editor program that allows you to control CRU DSR space, and make sure the new modded CF7+ is replying to just the 1E00 space, and not overlapping into the 1300 space of your sidecar.

The sidecar you using an official TI one? -- Or a third-party one? 

(Some third-party ones, don't use the 1300 space but may in fact be at 1E00 or even 1F00, again test using a CRU scan program or memory editor program to see what device appears at the 4000 space when turned on, and at what CRU address!)

---

From: Owen Brand <[email-masked]>
Date: Wed, 21 Apr 2010 22:09:43 -0400

Interesting stuff Gary... So CRU is a low memory address reserved for  
hardware interface?  I know this subject came up with the SIDBlaster  
card Marc Hull built which implements a MOS 6502 SID chip onto a PEB  
card... I'm very curious--- could someone give me a link to a TI- 
specific article or discussion thread that explains CRU addressing?  I  
don't want to clog up the list with stuff everyone already knows.  :).  
Thanks

Owen Brand
Opry99er.com

On Apr 21, 2010, at 8:16 PM, "Gary from O.P.A." <[email-masked]>  
wrote:

>
> Well, two things to try, try running a EA terminal program like  
> MassTransfer instead of TE2 and see what happens.
>
> Use a Memory Editor program that allows you to control CRU DSR  
> space, and make sure the new modded CF7+ is replying to just the  
> 1E00 space, and not overlapping into the 1300 space of your sidecar.
>
> (Some third-party ones, don't use the 1300 space but may in fact be  
> at 1E00 or even 1F00, again test using a CRU scan program or memory  
> editor program to see what device appears at the 4000 space when  
> turned on, and at what CRU address!)
>
>

---

From: mark wills <[email-masked]>
Date: Thu, 22 Apr 2010 08:20:34 +0000 (GMT)

I want a CF7++ i.e. a CF7+ with a serial port on it ;-)

Come on Jamie, the $$$ are a waiting...

>
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]>
>Sent: Thu, 22 April, 2010 0:08:04
>Subject: Re: [TI994A] CF7+  ???
>
> >
>
>
>
> >
>
>
>
>
>
>
>I never tried to use the PIO port on my CF7.  I use it just as an emulated DSK drive and 32k mem.  If I want to print something, I transfer it to my PC and print it from there.  Although, there has been talk of using the PIO as a communications device to a PC... I believe Thierry Nouspikel has a cable design for this.  In any case, I'm interested in your CF7 work, Richard.  I'm looking forward to using the CF7 with a modified console using the CF7 mod you created for switching.  :)   
>
>Owen Brand
>Opry99er.com
>

---

From: "Stuart" <[email-masked]>
Date: Thu, 22 Apr 2010 08:53:11 -0000

Take a look at the 9900 data book that will be on whtech somewhere.  But in short: CRU (Communications Register Unit) is a serial I/O method, which uses the address bus to address a CRU device, and a couple of other lines to transfer data between the device and the processor. Each CRU device has an associated address decoding circuit to enable ('switch on') the device at a certain range of addresses - so a serial port might respond to addresses >1100 - >11xx for example.

Stuart.

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Apr 21, 2010, at 8:16 PM, "Gary from O.P.A." <garyopa@...>  
> wrote:
> 
> >