Subject: Assembly question

From: Owen Brand <[email-masked]>
Date: Tue, 4 May 2010 06:48:42 -0400

In assembly, if I am placing several bytes of data into consecutive  
memory locations and I want to do so with the equivalent of a READ  
loop in XB, I assume the data statements should look like...

BYTE 3FC1, ...., ...., etc

Is using "BYTE" correct?

Owen Brand

        **webmaster**
http://www.Opry99er.com

---

From: "kabldb" <[email-masked]>
Date: Tue, 04 May 2010 10:53:16 -0000

I think I would use

 BYTE >3F, >C1, ...

or

 DATA >3FC1, ...

:-)

---

From: Marc Hull <[email-masked]>
Date: Tue, 4 May 2010 03:53:58 -0700 (PDT)

BYTE   3F,C1,12,34 (8 bit data)

or  

DATA   3FC1,1234 (16 bit data)

notice the separations...

--- On Tue, 5/4/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: [TI994A] Assembly question
To: [email-masked]
Date: Tuesday, May 4, 2010, 5:48 AM

  

Is using "BYTE" correct?

Owen Brand

**webmaster* *

http://www.Opry99er .com

---

From: "Beery" <[email-masked]>
Date: Tue, 04 May 2010 13:11:16 -0000

Owen,

If you are moving "lots" of data, and preferably on an even memory address, I would use the DATA command.

DATA 0,0,0,0,0,0,0,0,0,0

LOCATION DATA   >C000

LOOP0

     LI R1,DATA
     MOV @LOCATION,R2
     LI R3,10      * Count of data to move
LOOP1
     MOV *R1+,*R2+
     DEC R3
     JNE LOOP1

Hopefully, this formats correctly.

---

From: Owen Brand <[email-masked]>
Date: Tue, 4 May 2010 09:35:02 -0400

Thank you, that's quite clear now.  :)

Owen Brand

        **webmaster**
http://www.Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Tue, 4 May 2010 09:39:06 -0400

Thank you very much//-  this is my first try, really, at doing  
anything beyond clearing the screen and displaying "HELLO WORLD" in  
AL.  :). I will be DRINKING information for the next week or so....

Owen Brand

        **webmaster**
http://www.Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Tue, 4 May 2010 09:48:42 -0400

Lots of data.... Well, I think so anyway.  4500 individual bytes  
exactly, if I'm not mistaken

Owen Brand

        **webmaster**
http://www.Opry99er.com