Subject: Re: [TI994A] TurboForth preparation

From: [email-masked]
Date: Thu, 8 Apr 2010 17:19:02 EDT

Owen,
 
You are but the included component words must be defined first.
 
Bob  Carmany

In a message dated 4/8/2010 5:15:59 P.M. Eastern Daylight Time,  
[email-masked] writes:

So if I'm reading this right, a word can be defined as a series  of other 
words as well???  This would make things like screen draws  lightning fast 
and easy to implement!!!  Also, entire sequences of code  that determine 
complex functions can be pieced together and defined as a  word?!?  Holy crap!!  
I hope I'm reading this correctly!

Owen  Brand  
 
_Opry99er.com_ (http://opry99er.com/)

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 17:23:27 -0400

Yea that's what I meant to imply...

: FUNCTION1   What the function does.  ;
: FUNCTION2   What the function does
: SUPERF   FUNCTION1 FUNCTION2

Syntax is wrong, but something like that

Owen Brand
Opry99er.com

On Apr 8, 2010, at 5:19 PM, [email-masked] wrote:

> In a message dated 4/8/2010 5:15:59 P.M. Eastern Daylight Time, [email-masked] 
>  writes:
>
>
> So if I'm reading this right, a word can be defined as a series of  
> other words as well???  This would make things like screen draws  
> lightning fast and easy to implement!!!  Also, entire sequences of  
> code that determine complex functions can be pieced together and  
> defined as a word?!?  Holy crap!!  I hope I'm reading this correctly!
>
> Owen Brand
> Opry99er.com
>
>
>

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 14:35:14 -0700

Or they can be DEFERed words that get defined later also or have various 
definitions that get swapped based on other factors.  Wait until you 
learn how easy it is to patch compiled Forth words. :-)  Oh what fun 
you'll have then.

Bill S

[email-masked] wrote:
> *Bob Carmany
> *
> *In a message dated 4/8/2010 5:15:59 P.M. Eastern Daylight Time, 
> [email-masked] writes:*
> 
> 
> 
>     *So if I'm reading this right, a word can be defined as a series of
>     Owen Brand *
>     *Opry99er.com* <http://opry99er.com/>
> 
>      
> 
>

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 14:40:38 -0700

Each word definition to be compiled in Forth requires the ":" at the 
beginning, followed by the word name, followed by the words that make of 
the word being defined (some or even most will require stack items that 
are included in the definition or extracted from variables or required 
input by the user just before execution), and finally ended by the ";". 
  Thus : starts the Forth modular compiler and ";" stops the compiler 
and returns operation to the Forth interpreter (AMEN).

Bill S

Owen Brand wrote:
> Opry99er.com <http://Opry99er.com>
> 
> On Apr 8, 2010, at 5:19 PM, [email-masked] <mailto:[email-masked]> 
> wrote:
> 
>>  
>>
>> Owen,
>>  
>>     *So if I'm reading this right, a word can be defined as a series
>>     of other words as well???  This would make things like screen
>>     draws lightning fast and easy to implement!!!  Also, entire
>>     sequences of code that determine complex functions can be pieced
>>     together and defined as a word?!?  Holy crap!!  I hope I'm reading
>>     this correctly!
>>
>>     Owen Brand *

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 22:31:09 +0000 (GMT)

Bob is correct. You can't reference a word in another word unless it already exists.

Example:

: WASHER FILL WASH RINSE SPIN ;
: FILL .... ;
etc

is wrong. FILL and friends must be defined FIRST before WASHER can reference them:

: FILL .... ;
: WASH .... ;
: RINSE ... ;
: SPIN .... ;
: WASHER FILL WASH RINSE SPIN ;

There. Much better!

>
>From: "[email-masked]" <[email-masked]>
>To: [email-masked]
>Sent: Thu, 8 April, 2010 22:19:02
>Subject: Re: [TI994A] TurboForth preparation
>
> >
>
>
>
> >
> 
>
>
>
>
>
>
>
>Owen,
> 
>Bob 
>Carmany
>>So if I'm reading this right, a word can be defined as a series 
>>  of other words as well???  This would make things like screen draws 
>>  lightning fast and easy to implement!!!  Also, entire sequences of code 
>>  that determine complex functions can be pieced together and defined as a 
>>  word?!?  Holy crap!!  I hope I'm reading this correctly!
>>
>>Owen 
>>  Brand  
>>Opry99er.com
>>
>>  >
>
>
>
>
>
>
>

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 22:37:39 +0000 (GMT)

Oh yes. And vectored execution!

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Thu, 8 April, 2010 22:35:14
you'll have then.

Bill S

> href="mailto:[email-masked]">[email-masked] wrote:
>  
> 
> 
> Owen,
>  
> You are but the included 
> *Bob 
> href="mailto:[email-masked]">[email-masked] writes:*
> 
> 
> 
> 
>     lightning fast 
> and easy to implement!!!  Also, entire sequences of
>    

------------------------------------

Yahoo! Groups 
> Links

> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/