Subject: Re: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz

From: [email-masked]
Date: Wed, 07 Apr 2010 09:42:53 -0500 (CDT)

A picture of the CF7+ 32k chip mod can be found here.

http://www.facebook.com/album.php?aid=155713&id=752645311&saved#!/album.php?aid=155713&id=752645311&ref=nf

---

From: [email-masked]
Date: Wed, 07 Apr 2010 15:51:38 -0500 (CDT)

Owen, the crystal mod is considered seperate from the 32k-16 mod but is also available on request. This is considered a mid level mod so it may be more than you can handle as it requires a good bit of desoldering and soldering wire to existing chips which could be ruined if overheated. I'd be willing to build you one with a few additional programmer friendly type mods as well if your in no rush as I already have plenty on my plate. We could continue in private if that interests you.

Apr 7, 2010 04:16:38 PM, [email-masked] wrote:

So if I buy the kit, it comes with the faster crystal as well as the other components?  Forgive my ignorance on hardware mods.. I've never done much with hardware, aside from removing a jumper off the shunt pack on a TI disk drive to allow for (2) 3.5" drives to be installed as DSK2 and DSK3.  Other than that, I'm pretty much a rookie.  :)

Owen Brand

Opry99er.com

---

From: [email-masked]
Date: Wed, 07 Apr 2010 21:13:24 -0500 (CDT)

Some will be broken, some will be better (In my experience most AL programs are better.). The thing is as long as the crystal and 32k are switched you can just revert to stock no problem. In time the player will learn which games he likes fast or stock.  :)

Apr 7, 2010 09:54:38 PM, [email-masked] wrote:

Well, one question... Will all cart games work with the modified console?  I know the 16 bit bus is only applicable to the 32k block (expansion) but what about the faster crystal?  I asked Jon a moment ago, but I thought this might be good for the record.  I don't know the answer.  Thanks.

Owen Brand

Opry99er.com

On Apr 7, 2010, at 5:07 PM, Marc Hull <[email-masked]> wrote:

->    A console with the 32k-16 mod and the 3.58 crystal mod runs about twice as fast as a stock console. (Except for code that doesn't use the expansion RAM and just uses VDP.) <-

As an added endorsement...

This is what I use to program in assembly.  Combine this console with a RamDisk (which I think you have) and your save/assemble/run time goes from about five minutes down to about one....  Worth every penny (or burnt finger depending on which way you go ;-).

Sorry to step on your thread Richard.

--- On Wed, 4/7/10, [email-masked] wrote:

From: [email-masked]
Subject: Re: Re: [TI994A] Running the CF7+ on the SNUG version 32k-16 Bit Buss @ 3.58 Mhz
To: [email-masked]
Date: Wednesday, April 7, 2010, 3:05 PM

Actually, the SNUG 32k-16 is available as a kit, Owen. Modified consoles also pop up now and then on ebay. The SNUG design replaces the pad rams with a daughter board that has the required memory and support chips on it. In addition to putting the 32k on the 16 bit buss it also has the feature of switching between 8 bit and sixteen bit so you can still run programs that don't like the faster timing. Another switch can toggle the 8k ram located at >6000 - >7FFF on or off and another switch can expand the scratch pad ram area from >8300 - >83FF to >8000 - >83FF.  The console that runs the Hidden Reef BBS has this kit installed since 1996 and has been running 24/7 without problems with the kit so it is a reliable mod as well.

A console with the 32k-16 mod and the 3.58 crystal mod runs about twice as fast as a stock console. (Except for code that doesn't use the expansion RAM and just uses VDP.)

Some games don't like the speed and the joysticks can be a problem sometimes but where the 32k-16 @ 3.58 Mhz really shines in my opinion is when working with file utilities and such. It really speeds up file copy and hard drive backup as well as communications if you install the matching EPROM in the RS232 card which is availble from "Humming Bird".

Nothing like cruising the innernets with a 4A and Jeff Brown's ZT4 terminal at 38.8 through a UNIX shell account. :)

Apr 7, 2010 12:49:03 PM, TI994A@yahoogroups. com wrote:

Thanks-- very nice mod, Richard.  Wish those SNUG consoles were more readily available.  Just as a question, the 16 bit buss, does that eliminate the need for the multiplexing?

Owen Brand

Opry99er.com