Subject: Re: Re: [TI994A] RoHS (was Geneve 2)

From: [email-masked]
Date: Thu, 08 Jul 2010 12:51:10 -0500 (CDT)

Actually, ROHS compliance is and attempt to get a handle on the waste stream and includes more than just "lead". Google it. We should all be concerned about the waste stream but this was pushed through to fast and we now have inferior products that are ROHS compliant as a result. It's a big mistake for TI equipment to be built for ROHS compliance at this time in my never to be humble opinion.

BTW, I'm willing to give license to the Geneve name for $1.00 US in case anyone is wondering.

Jul 8, 2010 01:36:21 PM, [email-masked] wrote:

Not to step on your thread Stuart but....

My feeble research shows that this whole ROHS (as applied to Stuarts issue) is a European Union one.  Doesn't seem to effect the US currently (except in California where they want to ban everything except public drama and marijuana...;-)  Even in that "state of disarray" computer components (such as the one I believe you are talking about) don't seem to be covered by restrictions.  Am I wrong anyone ??

I guess if your looking for a way around the laws perhaps you should follow the Chinese model.  Lead doesn't seem to bother them one little bit. ;-)

--- On Thu, 7/8/10, Stuart wrote:

From: Stuart
Subject: [TI994A] RoHS (was Geneve 2)
To: [email-masked]
Date: Thursday, July 8, 2010, 6:27 AM

Is anyone able to talk authoritatively about how RoHS affects our sort of 'amateur' activities?

I had a couple of bare prototype PCBs manufactured by www.expresspcb.com a month or two ago and they have a lead solder coating, and they were shipped to me in the UK which I can only assume is 'legal', despite them not being RoHS compliant. I'm guessing I couldn't build these boards up using lead solder and sell them in volume commerically as they would have to be RoHS compliant? Could I get away with selling them in small quantities (a few dozen perhaps) on e-bay, or would that also be breaking RoHS regulations? If I 'kept under the radar' of the authorities and just sold them to individuals? Are RoHS regulations bascially the same in the UK/Europe/US?

Just wondering from a purely academic viewpoint ...

Stuart.

--- In [email-masked], Insane Multitasker wrote:
>
>
> Mmm... roast... will its flavor be RoHS compliant? ;)
>
>
> To: [email-masked]
> From: marc.hull@...
> Date: Wed, 7 Jul 2010 11:24:16 -0700
> Subject: Re: [TI994A] Re: Geneve 2 ???
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> I would suspect that Mr. Smith pretty much has a plan in the works. How about we wait and see what he is cooking up instead of debating the flavor before the roast is done and risk turning off the cook ;-)
>
>
> --- On Wed, 7/7/10, fdos wrote:
>
> From: fdos
> Subject: Re: [TI994A] Re: Geneve 2 ???
> To: [email-masked]
> Date: Wednesday, July 7, 2010, 12:38 PM
>
> I don't think trying to go to a new OS is wise initially. Do we really
> think that a new major OS would be immediately bug free? MDOS is pretty
> solid and there are a significant number of good applications for it.
> Therefore a good starting point for a new
> machine. If it flies well and
> gains a significant user base that believes replacing the OS is a great
> idea.....
>
> What ever happened to ADOS from AEI? It was suppose to replace that
> early, very buggy MDOS, but it never came along. I wrote to them when I
> was experiencing so many problems with MDOS during the early days, but
> never heard back from them. I say, let the machine breathe for a while
> before stuffing too much new vapor ware into it. Remember Myarc bit off
> more than it could chew (new machine, new OS, new application software,
> etc.), initially. Lets help Gary not make the same mistake.
>
> Bill S
>
> Beery wrote:
> >
> >
> > If someone wants to write a new OS for a "Geneve 2", it shouldn't be all
> > that hard to create a new OS using MESS and the Geneve emulator. All the
> > tools are already present, just design something new. Myself
> though, I
> > would think rewriting the XOP's if you wanted to remain MDOS compatible
> > would be a waste of time. Rather, one could just write a new command
> > line interpreter where you avoid the MDOS prompt, etc.
> >
> > Ron Walters before he passed away had a vision of a "super Geneve". With
> > the TI disk structure and running a 9958, there were options for some
> > unique video security applications that would be hard to crack.
> > Primarily because it was different than Microsoft. The 9958 offered
> > opportunities that did not exist with the 9938 with some video handling.
> >
> > Beery
> >
> > --- In [email-masked] , "James
> > W." wrote:
> > >
> > > Yes,
> > >
> > >
> There was, and still is, some secrecy involved. Especially when we
> > were researching Geneve-related items and needed Tim's help. We did have
> > emails sent to Jeff White for some technical data but I don't know if he
> > ever answered to Gary.
> > >
> > > This Geneve II Project has been going on for at least 2 1/2 years now.
> > >
> > > Fortunately, alot of what Gary needs is from opencores.org,
> > especially regarding PS/2 VHDL code. We did get a VHDL 9902 model from a
> > Frenchman and that may need to be tweaked.
> > >
> > > Joe Delekto was helping out at one time regarding getting a good C
> > compiler up and running-to take advantage of the Contiki system-which
> > will provide alot of what we need regrading TCP/IP, etc. A good C 99,
> > not the c99, compiler will enable us to have alot of programs and even
> > other OS's
> to run on the Geneve II.
> > >
> > > Gary has done a great job and I really believe that his 9995
> > implementation will be really, really nice-and super fast. Plus he took
> > advantage of the FPU available on opencores.org
> > >
> > > I really think that all of the remaining programmers, and emulator
> > programmers-such as Tursi, ought to get together and touch base with
> > Mark and Tim. Pool our resources like they do in the Open Source Community.
> > >
> > > James
> > > (secrecy being the best policy until ready to talk)
> > >
> > > --- In [email-masked] , mark
> > wills wrote:
> > > >
> > > > Hi Bill
> >
> > >
> > > > Well, I was sworn to secrecy, so couldn't say anything.
> > > >
> > > > At the moment it looks like Gary Smith in the UK is doing it all by
> > himself,
> > > > including designing a TMS9995 in VHDL (which he has completed).
> > Yes, I believe
> > > > it will use MDOS and will be Geneve compatible. May even have a
> > degree of 4A
> > > > compatability - however, Gary Smith is the man in the know.
> > > >
> > > > I'll probably get involved very much later on, with the MDOS stuff.
> > In fact, I'm
> > > > thinking of a completely new OS for it. Start from scratch. There
> > nothing wrong
> > > > with MDOS, but the code basde is very old, and if I am correctly
> > informed, there
> > > > are some parts of the OS that nobody
> understands, as well as
> > possibly one or two
> > > > long-standing bugs. The idea of developing a brand new OS, essentially
> > > > compatible with MDOS, but a new code-base, for a processor I am
> > already intimate
> > > > with, is a tempting one!
> > > >
> > > > Yes, I would say Forge on with Forth, for sure. This new Geneve II
> > is pants-down
> > > > fast. Leaves the original Geneve in the dust.
> > > >
> > > > Mark
> > > >
> > > >
> > > >
> > > > ----- Original Message ----
> > > > > From: fdos
> > > > > To: [email-masked]
> > > >
> > Sent: Wed, 7 July, 2010 16:13:45
> > > > > Subject: Re: [TI994A] Re: Geneve 2 ???
> > > > >
> > > > > Mark,
> > > > >
> > > > > You're in the know, and didn't tell me? Is it likely to use MDOS
> > > > > (initially)? A reason to continue Forth+ 2.0 development?
> > > > >
> > > > > I understand about vapor ware, but a little hint wouldn't have
> > hurt the
> > > > > cause. Are you involved in the development?
> > > > >
> > > > > Bill S
> > > > >
> > > > > mark wills wrote:
> > > > > >
> > > > > >
> > > > > > Yes. It's just taken a major leap forward, but I'm not saying
> > anything
> > > > > > more than that,
> vapour is my anathema!
> > > > > >
> > > > > > Mark
> > > > > >
> > > > > >
> > > > > >
> > > > > > *From:* Owen Brand
> > > > > > *To:* "[email-masked]
> > " <[email-masked]
> > >
> > > > > > *Sent:* Tue, 6 July, 2010 23:52:59
> > > > > > *Subject:* Re: [TI994A] Re: Geneve 2 ???
> > > > > >
> > > > > >
> > > > > >
> > > > > > Ahh--- the super secret UK project is
> going to be called
> > "Geneve 2".
> > > > > > :). Those sneaky buggers. :). It's supposed to be un-freaking
> > > > > > believable. :). Can't wait to see it
> > > > > >
> > > > > > Owen Brand
> > > > > >
> > > > > > **webmaster**
> > > > > > http://www.Opry99er.com <http://www.Opry99er.com>
> > > > > >
> > > > > > On Jul 6, 2010, at 6:24 PM, "kory" > > > > > > > wrote:
> > > > > >
> > > > > >>
> > > > > >>
> > > > > >>
> > > > >
> >>
> > > > > >> I read something earlier today about a G2 (Geneve 2) being shown
> > > > > >> this year at TREFF. I cut and pasted the info below.
> > > > > >>
> > > > > >> Yes, we are getting a brand new TI super computer that is
> > > > > >> compatible with the TI 99/4a software and beyond.
> > > > > >>
> > > > > >> This project has been kept secret until today.. The TI User Group
> > > > > >> UK shows you the spec... however we are looking to add an Gigabit
> > > > > >> Ethernet Controller to the machine so that it can connect to the
> > > > > >> internet. With this we can add products like the wnce2001 Ethernet
> > > > > >> wireless adaptor which is a universal self
> connecting device. If
> > > > > >> you have any technical knowledge regarding low level ethernet
> > > > > >> implementation then let us know..
> > > > > >> Any way here we go with the spec.
> > > > > >>
> > > > > >> 1 ) PEB interface. The board can run in the PEB or stand alone
> > > > > >> with a disk drive power connector ( allows use in PC case etc ).
> > > > > >> 2 ) 2 * SD card slots. No VHDL has been created for this yet but
> > > > > >> the connections are there anyway. Opencores.org
> > > > > >> <http://Opencores.org> may have VHDL we can use.
> > > > > >> 3 ) 1 * USB connector. No VHDL exists for this but the MSX people
> > >
> > > >> have a connection like this so I thought why the hell not !
> > > > > >> 4 ) IDE interface. Again no VHDL but I'm sure we can ask a certain
> > > > > >> Mr Nouspikel if we can copy his design. ( Allows 2 drives )
> > > > > >> 5 ) 64 MB DDR SDRAM for the CPU - this should be enough ;-)
> > > > > >> 6 ) 512KB VRAM. Looks like the 9958 will be used - not the 9938 as
> > > > > >> there is no mouse interface on the MSX 9938 :-(
> > > > > >> 7 ) 1 * audio output from the sound generator. Don't know about
> > > > > >> speech just yet - can use existing PEB mounted speech if the worst
> > > > > >> comes to the worst.
> > > > > >> 8 ) 18 bit RGB output with Hsync and Vsync. Should work on normal
> > > >
> > >> VGA monitor. May get SVideo also at some point - depends of FPGA
> > > > > >> pin count.
> > > > > >> 9 ) Joystick interface.
> > > > > >> 10 ) PS2 Keyboard interface.
> > > > > >> 11 ) PS2 mouse interface. No VHDL for this but doesn't seem too
> > > > > >> difficult.
> > > > > >> 12 ) Centronics PIO interface like RS232 card.
> > > > > >> 13 ) 9 pin RS232 channel. No VHDL yet.
> > > > > >> 14 ) Regulators to get 5V, 3V3, and 1V2. 1 Switching regulator
> > > > > >> used for efficiency.
> > > > > >> 15 ) 1 config device to program both FPGAs.
> > > > > >> 16 ) 12MHz oscillator - multiplied internally to get higher
> > > > > >> frequency
> operation.
> > > > > >> 17 ) 21MHz Xtal for video.
> > > > > >>
> > > > > >> Production of the PCB starts shortly...
> > > > > >>
> > > > > >> If you visit the TREFF we hope to have a large demo of the unit
> > > > > >> for you to see...
> > > > > >>
> > > > > >> --- In [email-masked]
> >
> > > > > >> [email-masked]
> > >, Owen Brand wrote:
> > > > > >>
> >
> > > > > >> > Welcome back!! I don't know about the Geneve 2... Never heard of
> > > > > >> it.
> > > > > >> > If you like programming, this is a great place to get info...
> > > > > >> Another
> > > > > >> > place to check is Atariage.com--- TI-99/4a programming subforum.
> > > > > >> All
> > > > > >> > kinds of new games coming out regularly over there. :)
> > > > > >> >
> > > > > >> > Owen Brand
> > > > > >> >
> > > > > >> > **webmaster**
> > > > > >> > <http://www.Opry99er.com>http://www.Opry99er.com
> > > > > >> <http://www.Opry99er.com>
> > > > > >> >
> > > > > >> > On Jul 6, 2010, at 6:08 PM, "kory" wrote:
> > > > > >> >
> > > > > >> > > Hi All!
> > > > > >> > >
> > > > > >> > > After being away for quite some time.. away from the Ti994a
> > > > > >> world, I
> > > > > >> > > decided to do a bit of browsing on the net and came across
> > > > > >> something
> > > > > >> > > that really caught my eye.. the Geneve 2.. Is this a "real"
> > > > > >> project,
> > > > >
> >> > > and does anyone have any idea on cost etc..
> > > > > >> > >
> > > > > >> > > It really amazes me that there is so much love and dedication
> > > > > >> this
> > > > > >> > > many years later for the TI/Geneve. I will be introducing my
> > > > > >> > > daughter to the TI very soon. She is still too young. My hopes
> > > > > >> are
> > > > > >> > > that she may hold some interest in it and ask me to help her
> > > > > >> program
> > > > > >> > > it like I asked my dad so many years ago. The thought of
> > having a
> > > > > >> > > new computer that we can both learn on at the same time is a
> > > > > >> > >
> priceless thought, especially if it is related to my first
> > > > > >> computer!
> > > > > >> > >
> > > > > >> > > Anyway, if anyone has any info on the G2 or if there is a
> > thread
> > > > > >> > > related to it here, please point me in the proper direction!
> > > > > >> > >
> > > > > >> > > Thanks!
> > > > > >> > > -Kory
> > > > > >> > >
> > > > > >> > >
> > > > > >> >
> > > > > >>
> > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > > > ------------------------------------
> > >
> > >
> > > > > Yahoo! Groups Links
> > > > >
> > > > >
> > > > >
> > > > >
> > > >
> > >
> >
> >
>
>
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> __________________________________________________________
> The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail.
> http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5
>

---

From: mark wills <[email-masked]>
Date: Thu, 8 Jul 2010 18:37:32 +0000 (GMT)

I'll take you up on your licence offer. Where do I send the money?

Mark

>
>From: "[email-masked]" <[email-masked]>
>Sent: Thu, 8 July, 2010 18:51:10
>Subject: Re: Re: [TI994A] RoHS (was Geneve 2)
>
>  
>
>
>
>Actually, ROHS compliance is and attempt to get a handle on the waste stream and 
>includes more than just "lead". Google it. We should all be concerned about the 
>waste stream but this was pushed through to fast and we now have inferior 
>products that are ROHS compliant as a result. It's a big mistake for TI 
>equipment to be built for ROHS compliance at this time in my never to be humble 
>opinion.
> 
>>My feeble research shows that this whole ROHS (as applied to Stuarts issue) is a 
>>European Union one.  Doesn't seem to effect the US currently (except in 
>>California where they want to ban everything except public drama and 
>>marijuana...;-)  Even in that "state of disarray" computer components (such as 
>>the one I believe you are talking about) don't seem to be covered by 
>>restrictions.  Am I wrong anyone ?? 
>>
>>
>>I guess if your looking for a way around the laws perhaps you should follow the 
>>Chinese model.  Lead doesn't seem to bother them one little bit. ;-)
>>
>>
>>
>>
>>>I had a couple of bare prototype PCBs manufactured by www.expresspcb.com a month 
>>>or two ago and they have a lead solder coating, and they were shipped to me in 
>>>the UK which I can only assume is 'legal', despite them not being RoHS 
>>>compliant. I'm guessing I couldn't build these boards up using lead solder and 
>>>sell them in volume commerically as they would have to be RoHS compliant? Could 
>>>I get away with selling them in small quantities (a few dozen perhaps) on e-bay, 
>>>or would that also be breaking RoHS regulations? If I 'kept under the radar' of 
>>>the authorities and just sold them to individuals? Are RoHS regulations 
>>>bascially the same in the UK/Europe/US?
>>>
>>>> I would suspect that Mr. Smith pretty much has a plan in the works. How about 
>>>>we wait and see what he is cooking up instead of debating the flavor before the 
>>>>roast is done and risk turning off the cook ;-)
>>>> 
>>>> 
>>>> > > > > > On Jul 6, 2010, at 6:24 PM, "kory" 
>>>> > > > > > > wrote:
>>>> > > > > >
>>>> > > > > >>
>>>> > > > > >>
>>>> > > > > >>
>>>> > > > >
>>>> >>
>>>>5