Subject: GRAM Kracker schematics?

From: "Michael Zapf" <[email-masked]>
Date: Mon, 17 May 2010 10:07:10 -0000

Are there any board schematics for the GK? At least not on the WHTech FTP server, as it seems. 

I have the manual, but for creating an emulation, the schematics would be quite useful, and they are not included in the manual.

Alternatively, I'd need a description of internal CRU or port handling, if there is any worth mentioning. AFAIK the device has own software onboard, and from reading the manual it's not fully clear to me whether it makes use of alternative GROM banks.

Michael

---

From: "Ksarul" <[email-masked]>
Date: Mon, 17 May 2010 11:31:30 -0400

Today I received a document in the mail that totally surprised me: the
complete TI technical specifications for the speech synthesizer chip used by
the TI-99/4 and TI-99/4A.  Once I have it scanned, I will put it up on WHT.
This should clear up any remaining ambiguities between it and the related
chips being used by the various emulators so as to eliminate the random
issues with using speech in them.  The same bundle included a lot of
information on the TI-99/4B.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Zapf
Sent: Monday, May 17, 2010 6:07 AM
To: [email-masked]
Subject: [TI994A] GRAM Kracker schematics?

Are there any board schematics for the GK? At least not on the WHTech FTP
server, as it seems. 

I have the manual, but for creating an emulation, the schematics would be
quite useful, and they are not included in the manual.

Alternatively, I'd need a description of internal CRU or port handling, if
there is any worth mentioning. AFAIK the device has own software onboard,
and from reading the manual it's not fully clear to me whether it makes use
of alternative GROM banks.

Michael

---

From: Owen Brand <[email-masked]>
Date: Mon, 17 May 2010 11:26:13 -0400

Wow!!!

Owen Brand

        **webmaster**
http://www.Opry99er.com

On May 17, 2010, at 11:31 AM, "Ksarul" <[email-masked]> wrote:

> Today I received a document in the mail that totally surprised me:  
> the complete TI technical specifications for the speech synthesizer  
> chip used by the TI-99/4 and TI-99/4A.  Once I have it scanned, I  
> will put it up on WHT.  This should clear up any remaining  
> ambiguities between it and the related chips being used by the  
> various emulators so as to eliminate the random issues with using  
> speech in them.  The same bundle included a lot of information on  
> the TI-99/4B.
>
>
>
> Jim
>
>
>
> From: [email-masked] [mailto:[email-masked]] On  
> Behalf Of Michael Zapf
> I have the manual, but for creating an emulation, the schematics  
> would be quite useful, and they are not included in the manual.
>
> Alternatively, I'd need a description of internal CRU or port  
> handling, if there is any worth mentioning. AFAIK the device has own  
> software onboard, and from reading the manual it's not fully clear  
> to me whether it makes use of alternative GROM banks.
>
> Michael
>
>

---

From: fdos <[email-masked]>
Date: Mon, 17 May 2010 11:24:16 -0700

Michael,

I'm not aware that any schematics for the GK are out there any where. 
However, it seems to me that you already have the means to allocate 
appropriate GRAM/GROM & RAM/ROM space, and only need a loader to load GK 
files.  Which could be done by Gram Packer (available for purchase) 
and/or JJ's BOOT MENU program (PD).  You just have to provide a means to 
un-protect/protect the normal GRAM/GROM & RAM/ROM cartridge space memory 
(load a blank RPK file that allocates all GRAM & RAM cartridge space, so 
a maxed out module could be loaded by a GK loader).  You may or may not 
want to support the full capability of an 80K GK which also allows to 
save & load the OP system at GROM0 and TI BASIC at GROM0 & GROM1.

Bill S

Michael Zapf wrote:
> I have the manual, but for creating an emulation, the schematics would 
> be quite useful, and they are not included in the manual.
> 
> Alternatively, I'd need a description of internal CRU or port handling, 
> if there is any worth mentioning. AFAIK the device has own software 
> onboard, and from reading the manual it's not fully clear to me whether 
> it makes use of alternative GROM banks.
> 
> Michael
> 
>

---

From: mark wills <[email-masked]>
Date: Mon, 17 May 2010 18:51:42 +0000 (GMT)

HOLY COW! That sounds great!!

>
>From: Ksarul <[email-masked]>
>Sent: Mon, 17 May, 2010 16:31:30
>Subject: [TI994A] Speech Synthesizer Chip Specifications
>
> >
>
>
>
> >
>
> 
> 
>
> 
>
> >
>
>
>
>
>
>
>
>>
>Today I received a document in the mail
>that totally surprised me: the complete TI technical specifications for the
>speech synthesizer chip used by the TI-99/4 and TI-99/4A.  Once I have it
>scanned, I will put it up on WHT.  This should clear up any remaining
>ambiguities between it and the related chips being used by the various
>emulators so as to eliminate the random issues with using speech in them. 
>The same bundle included a lot of information on the TI-99/4B.
> 
>Jim
> 
>>
>>
________________________________
 >
>From:> [email-masked] [mailto:
> [email-masked] ] On Behalf Of Michael Zapf
>Are there any board schematics for the GK? At least
>not on the WHTech FTP server, as it seems. 
>
>>I have the manual, but for creating an emulation, the schematics would be quite
>useful, and they are not included in the manual.
>
>there is any worth mentioning. AFAIK the device has own software onboard, and
>from reading the manual it's not fully clear to me whether it makes use of
>alternative GROM banks.
>
>>Michael
>>
>
>
>
>
>
>
>
>

---

From: "James" <[email-masked]>
Date: Mon, 17 May 2010 19:37:37 -0000

I've been able to look through the documentation for the TMC 0285, which I've scanned in, and also the data on the TMC 0350 Speech ROMs (which I will scan later).  The manual is 52 pages long, but two pages (9 and 10) are missing.  They cover the read and write timing for the chip, which may or may not be a problem here.  All of the other timing diagrams are present, however.  I will try and put it up on WHT either tonight or tomorrow night.

The documentation in the package I received also had quite a bit of information on the 99/4B, the TI EPROM card, the 99/8 (including some information I'd never seen before), several TI memory cards (a 64K memory card for the /4A and a 512K card for the 99/8), a really interesting set of schematics--including the one for the Thermal Printer someone was looking for a while back and a set for the TI EGROM cartridge.  It also included the manual for the GSIM device (the silver pizza-box GRAM devices) and some notes on using multiple GROM libraries.  

I now have a nearly six-inch thick stack of documents, many of which are totally new to me--and I had what I thought was a pretty comprehensive set of TI documentation, so this amount of new stuff is just mind-boggling. 

Jim, who will be happily burrowing through data for the next couple of weeks. . .

---

From: "Gary from O.P.A." <[email-masked]>
Date: Mon, 17 May 2010 20:10:15 -0000

There is no fancy about the GK, it is just a plain full 80k ram module, it contains two banks of 8k (to support XB), and 8 pages of 8k of GROM (if expanded from the other version sold with only 56k ram)

I have dumps of the GK operating system, which was very small, it just basically was loader.

All the key operation of the GK was "user-controlled" with a series of five three-position toggle switchs, no fancy software control of CRU switching, etc. -- It is up to the user to follow the prompts correctly shown on the screen by the simple GK OS loader.

For example, (start file loading), pause, tell user to push bank switch up, press any key (more file loads), pause, tell user to push bank down, press any key (more file loads), pause, tell user to put bank switch in middle (write-protect), pause, (rest of files loads), pause, tell user to push reset switch. -- Etc.

If the user didn't follow the screen prompts correctly, the GK had no real way to know, it either would overwrite the existing bank, or not be able to write to the bank. -- It was all up to the user.

The closest to schematics for the gram kracker would be the simple gram emulation circuit published in the "bunyard" manual, and of course the offical TI pizza-box version with just more toggle switches, and much larger box.

---

From: "Michael Zapf" <[email-masked]>
Date: Mon, 17 May 2010 20:51:32 -0000

Hello,

> There is no fancy about the GK, it is just a plain full 80k ram
> module, it contains two banks of 8k (to support XB), and 8 pages
> of 8k of GROM (if expanded from the other version sold with 
> only 56k ram)

yes, seems to be less complicated than I first thought. However, I have to exactly learn the meaning of the switches, especially of the "GK Off" and the "Loader" switch. For instance, I'm not quite sure how I can delete the GRAM 1 within the Loader ... ah, wait, I just read (live reading while writing :-) ) that this is only possible from the memory editor which is a machine program running in the memory expansion. 

Seems as if I have to carefully read the manual.

Michael

---

From: "Michael Zapf" <[email-masked]>
Date: Wed, 19 May 2010 20:57:15 -0000

Hi all,

I sketched an architectural diagram of the GRAM Kracker as I understood the manual. Can you approve this reflects the functions of the real device?

The diagram should be self-explaining. You can imagine the color boxes as switches that let pass in/out when the respective physical switch is in the corresponding location and otherwise block.

http://www.mizapf.de/ti99/gk.pdf

(requires that you are not color-blind :-) )

Michael

---

From: fdos <[email-masked]>
Date: Thu, 20 May 2010 08:50:45 -0700

Michael,

It looks really cool to me man.  Kudos!  Hopefully, I'm not color blind. 
  ;-)

Bill S

Michael Zapf wrote:
>  
> 
> Hi all,
> 
> I sketched an architectural diagram of the GRAM Kracker as I understood 
> the manual. Can you approve this reflects the functions of the real device?
> 
> The diagram should be self-explaining. You can imagine the color boxes 
> as switches that let pass in/out when the respective physical switch is 
> in the corresponding location and otherwise block.
>

---

From: fdos <[email-masked]>
Date: Fri, 21 May 2010 10:02:43 -0700

Michael,

After a second look, there is a slight problem with the layout.  It 
doesn't matter electrically, only physically.  The cartridge connector 
for modules on the GK is at the same end as where the GK plugs into the 
TI console cartridge port.

Bill S

fdos wrote:
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
> 
>

---

From: "Michael Zapf" <[email-masked]>
Date: Fri, 21 May 2010 18:33:59 -0000

Hello Bill,
 
> TI console cartridge port.

sure, it's only meant to show the effects of the switches. I need to find out when is which circuit on the bus in order to be able to emulate it correctly.

So let's check: Is it true 

- that I can see console GROM 0 only if the second switch is on "OpSys" (regardless of the other switches and whether a module is inserted or not)?
- that I can see console GROM 1 only if the third switch is on "TI BASIC" and the fifth switch is on "Loader off"?
...
- that I can see GRAM 3-7 in the GK only if no module is inserted and the leftmost switch is on "Normal" (and for writing to it, the fourth switch is not on W/P)?
- that I can see the module ROMs and GROMs always when a module is inserted, regardless of any switch setting? (nota bene that if a module has no GROM (like Atari) this may mean that instead GRAM 3-7 may be visible and probably cause an autostart, so this needs to be prevented by setting the switch to "GK Off".)

Michael

---

From: fdos <[email-masked]>
Date: Fri, 21 May 2010 12:12:58 -0700

Michael,

See below.

Michael Zapf wrote:
> sure, it's only meant to show the effects of the switches. I need to 
> find out when is which circuit on the bus in order to be able to emulate 
> it correctly.
> 
> - that I can see console GROM 0 only if the second switch is on "OpSys" 
> (regardless of the other switches and whether a module is inserted or not)?

True.

> - that I can see console GROM 1 only if the third switch is on "TI 
> BASIC" and the fifth switch is on "Loader off"?

True.

> ...
> - that I can see GRAM 3-7 in the GK only if no module is inserted and 
> the leftmost switch is on "Normal" (and for writing to it, the fourth 
> switch is not on W/P)?

True.

> - that I can see the module ROMs and GROMs always when a module is 
> inserted, regardless of any switch setting? 

True.

(nota bene that if a module
> has no GROM (like Atari) this may mean that instead GRAM 3-7 may be 
> visible and probably cause an autostart, so this needs to be prevented 
> by setting the switch to "GK Off".)

Probably, but I've not saved any modules using the GK in over a decade, 
so I'm not positive.  I may have to perform this operation to verify, 
but I can't do it until next week sometime.  Maybe someone else will 
step up and verify in the meantime.

Bill S

---

From: "Ksarul" <[email-masked]>
Date: Fri, 21 May 2010 19:42:17 -0400

Does anyone know who eventually won the TI Cartridge that was a GROM
simulator from Blaine a few months ago?  I have found something they might
find of interest--the schematics and the manual for it. . .and the data is
for both the ROM/GROM and the GROM only variants of the cartridge. . .

Jim

---

From: "Gary from O.P.A." <[email-masked]>
Date: Sat, 22 May 2010 01:37:41 -0000

That was most likely me. -- Do you still have the picture from ebay, or the item number? - you can contact me via my email if you wish to discuss this more. -- Thanks alot.

---

From: mark wills <[email-masked]>
Date: Sat, 22 May 2010 06:50:53 +0000 (GMT)

Any chance you could upload the docs somewhere? I'd like to see them... :-)

Mark

----- Original Message ----
> Sent: Sat, 22 May, 2010 0:42:17
> Subject: [TI994A] TI GROM Cimulating Cartridge from a few months back (was on eBay)
> 
simulator from Blaine a few months ago?  I have found something 
> they might
find of interest--the schematics and the manual for it. . .and the 
> data is
for both the ROM/GROM and the GROM only variants of the cartridge. . 
> .

Jim

Yahoo! 
> Groups Links

>   
> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/