Subject: TI-99 512K Multicart by Hexbus

From: Owen Brand <[email-masked]>
Date: Tue, 13 Apr 2010 18:39:56 -0400

Just made this video and posted it to YouTube.  :)

http://www.youtube.com/watch?v=syaAGnCJp2Y&feature=youtube_gdata

Owen Brand
Opry99er.com

---

From: Teresa Masters <[email-masked]>
Date: Wed, 14 Apr 2010 01:10:47 -0700

Owen,
Thanks for the memories, Jon Guidry, good job!

Good watching that on a sleepless night.
Hugs,
Terrie