Subject: Midwest Ramdisk Question

From: "epergrem" <[email-masked]>
Date: Sat, 10 Jul 2010 18:27:50 -0000

I posted this on the other group also, just in case not everyone here was a member.

I have a Midwest Engineering ram disk, which was sold both by Horizon and also by Midwest as the "Chicago Ramdisk". It is the precursor to the HRD 3000, so if similar in ways.

The board belonged to Dave Connery and refuses to recognize anymore than the first 8 SRAM chips, or 256K. I have tried switching out the SRAM and other chips and still get the same result. I can't see any visible issues with the board, but that doesn't mean there aren't any.

Any thoughts on where I might look next? I don't own any diagnostic tools other than a multimeter and the test program that came with the ROS.

Thanks,
Ernie

---

From: "Ksarul" <[email-masked]>
Date: Sat, 10 Jul 2010 16:11:17 -0400

I seem to remember the earliest version of the HRD was limited to 256K
without some modifications. . .and the Midwest version would have been
closest to the HRD1000, not the 2000 (only sold for a short while), the 3000
(longest production run after the 1000), or 4000.  You might want to look at
a copy of the HRD1000 manual to see if that gives any clues.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
epergrem
Sent: Saturday, July 10, 2010 2:28 PM
To: [email-masked]
Subject: [TI994A] Midwest Ramdisk Question

I posted this on the other group also, just in case not everyone here was a
member.

I have a Midwest Engineering ram disk, which was sold both by Horizon and
also by Midwest as the "Chicago Ramdisk". It is the precursor to the HRD
3000, so if similar in ways.

The board belonged to Dave Connery and refuses to recognize anymore than the
first 8 SRAM chips, or 256K. I have tried switching out the SRAM and other
chips and still get the same result. I can't see any visible issues with the
board, but that doesn't mean there aren't any.

Any thoughts on where I might look next? I don't own any diagnostic tools
other than a multimeter and the test program that came with the ROS.

Thanks,
Ernie

---

From: "epergrem" <[email-masked]>
Date: Sat, 10 Jul 2010 21:34:22 -0000

Hi Jim,
There may have been an earlier version.  This one uses 12-32K SRAM chips for 384K or can be stacked up to 1 meg.  It's identical to the first ram drive I ever owned and built.  I bought mine at a CTIUG meeting from George Bowman, where it was advertised as the "Chicago Ram drive".   Dave may have acquired this one the same way.

Ernie

---

From: "Ksarul" <[email-masked]>
Date: Sat, 10 Jul 2010 18:12:43 -0400

You're right on the size-the early HRDs were 384K too.  I misremembered.
I've been looking to see if I still had an old HRD 1000 manual around, but I
haven't found it yet.  I built something like half a dozen of the 1000
series way back then. . .

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
epergrem
Sent: Saturday, July 10, 2010 5:34 PM
To: [email-masked]
Subject: [TI994A] Re: Midwest Ramdisk Question

Hi Jim,
There may have been an earlier version. This one uses 12-32K SRAM chips for
384K or can be stacked up to 1 meg. It's identical to the first ram drive I
ever owned and built. I bought mine at a CTIUG meeting from George Bowman,
where it was advertised as the "Chicago Ram drive". Dave may have acquired
this one the same way.

Ernie

--- In [email-masked] <mailto:TI994A%40yahoogroups.com> , "Ksarul"
<vze23g4a@...> wrote:
> From: [email-masked] <mailto:TI994A%40yahoogroups.com>
[mailto:[email-masked] <mailto:TI994A%40yahoogroups.com> ] On Behalf
Of
> To: [email-masked] <mailto:TI994A%40yahoogroups.com>

---

From: "epergrem" <[email-masked]>
Date: Sun, 11 Jul 2010 16:17:22 -0000

Okay, I am flat confused on how chip select works.  I assumed in looking at the schematic that "most" of pins for the SRAM were connected, except for the CS pin.  

That's essentially what the scehmatic shows.  However, if I put a continutity tester across pin 20 of the 62256, they are all connected.  

Also, the continutity tester beeps when I connect the 62256 CS pin to any of the 74HCT154 Y0-Y15 pins.  Now, it's likely that I'm making some wrong assumptions, but I would have thought that each 62256 CS pin would have a unique connection to the 154.  

I'm trying to determine why the ram disk only sees the first 256K, and this isn't helping. :-)

---

From: mark wills <[email-masked]>
Date: Sun, 11 Jul 2010 18:28:17 +0000 (GMT)

Maybe the 154's shot?

Mark

----- Original Message ----
> From: epergrem <[email-masked]>
> Sent: Sun, 11 July, 2010 17:17:22
> Okay, I am flat confused on how chip select works.  I assumed in looking at  
>the schematic that "most" of pins for the SRAM were connected, except for the CS  
>pin.  
>
> 
> That's essentially what the scehmatic shows.  However,  if I put a continutity 
>tester across pin 20 of the 62256, they are all  connected.  
>
> 
> Also, the continutity tester beeps when I connect the  62256 CS pin to any of 
>the 74HCT154 Y0-Y15 pins.  Now, it's likely that I'm  making some wrong 
>assumptions, but I would have thought that each 62256 CS pin  would have a 
>unique connection to the 154.  
>
> 
> ------------------------------------
> 
> Yahoo!  Groups Links
> 
> 
> 
>

---

From: "Stuart" <[email-masked]>
Date: Sun, 11 Jul 2010 19:14:33 -0000

Is the 154 socketed? If so remove it and see what results you get then. Possible that the voltage being used by the tester is forcing the 154 into conduction while it is powered off?

Have you tried replacing the address buffers (probably 7LS244s) in case one has a stuck output?

Stuart.

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> > From: epergrem <epergrem@...>

---

From: "epergrem" <[email-masked]>
Date: Sun, 11 Jul 2010 19:33:52 -0000

Thanks Stuart,
I'll try that.  

As for chips, I've tried three different 154's and have swapped out all of the chips with those from a known good ram disk.

I also tested the originals with a chip tester and none failed.

Thierry shows that Memory Selection (if that's the same as recognition) is controlled by the 138 and 156 at the bottom of the board and the 8K chip.  It looks like a reheat of connections or replacement of the sockets is next.

Ernie

--- In [email-masked], "Stuart" <ti99@...> wrote:
> --- In [email-masked], mark wills <markrobertwills@> wrote:
> >
> > Maybe the 154's shot?
> > 
> > Mark
> > 
> > 
> > 
> > 
> > > From: epergrem <epergrem@>

---

From: "Stuart" <[email-masked]>
Date: Sun, 11 Jul 2010 20:01:33 -0000

The 'Memory Selection' part of Thierry's page is memory selection for the DSR RAM. I would have thought that the areas you need to concentrate on are the 'Page Selection Logic' and 'CRU Logic' sections, as they deal with the SRAMs? If the board has jumper wires to allow for different sizes of RAM chips, I personally check those first.

Stuart.

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> --- In [email-masked], "Stuart" <ti99@> wrote:
> >

---

From: "epergrem" <[email-masked]>
Date: Sun, 11 Jul 2010 22:48:46 -0000

Thanks.  Apparently to solve this I'm going to have to learn more about ram disks that I really wanted to know. :-)

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 11 Jul 2010 17:49:00 -0500

I've encountered bad sockets on a few RAMdisks (I think Marc had the same culprit) so take a look with a 5x or 10x loupe if you have one.  Sometimes a bent wipe, especially on single-wipe sockets, can give intermittent signals.  The same is true for corrosion - look for white-ish green hue on the wipes.  Double-wipe sockets can look deceivingly OK, therefore, if you find one corroded socket, it's likely you'll find another.

Sounds like you have a lot of other good ideas to try from the community.  

Good luck.  :)

> From: [email-masked]
> Date: Sun, 11 Jul 2010 16:17:22 +0000
 		 	   		  
_________________________________________________________________
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_2