Subject: Just got my PEB. A little help please. :)

From: "Charlie" <[email-masked]>
Date: Tue, 13 Apr 2010 22:36:43 -0000

Hello everyone. I just got my PEB. Everything seems to work ok. I can get games to auto run from the disk. However after that I have no idea how to use it. Can someone please tell me the basics, like how to get a directory list, run a basic program or ML program?

Thanks!

Charlie

---

From: Owen Brand <[email-masked]>
Date: Tue, 13 Apr 2010 18:47:22 -0400

Hey Charlie, congrats!!!  Perhaps if you had some specific questions,  
we could help you, "specifically." What are you hoping to accomplish?   
The rs232 allows you to communicate with other computers, the 32k mem  
expansion is transparent, but necessary-- the Disk controller, you  
say, seems to work... So what exactly do you wish to do?  We'll be  
more than happy to help!

Owen Brand
Opry99er.com

On Apr 13, 2010, at 6:36 PM, "Charlie" <[email-masked]> wrote:

> Hello everyone. I just got my PEB. Everything seems to work ok. I  
> can get games to auto run from the disk. However after that I have  
> no idea how to use it. Can someone please tell me the basics, like  
> how to get a directory list, run a basic program or ML program?
>
> Thanks!
>
> Charlie
>
>

---

From: "Ksarul" <[email-masked]>
Date: Tue, 13 Apr 2010 18:55:15 -0400

Step one is to be able to get a directory list (catalog).  For that you need
a program that works as a disk manager, as the capability is not built into
Extended BASIC.  You can use the TI disk manager module or one of several
disk-based managers (if you have a disk already labeled as a disk manager).
That will let you see the disk contents.

Look for the manual for the Disk manager on WHTech to see what it will do
and how the commands work (if you don't have the TI manual for your disk
controller).

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Charlie
Sent: Tuesday, April 13, 2010 6:37 PM
To: [email-masked]
Subject: [TI994A] Just got my PEB. A little help please. :)

Hello everyone. I just got my PEB. Everything seems to work ok. I can get
games to auto run from the disk. However after that I have no idea how to
use it. Can someone please tell me the basics, like how to get a directory
list, run a basic program or ML program?

Thanks!

Charlie

---

From: "Charlie" <[email-masked]>
Date: Wed, 14 Apr 2010 01:23:25 -0000

Thanks guys.
Ok I found a disk catalog program and I can see whats on disks now.
So I have a disk with several programs on it. It doesn't auto start. How do I load a program. To make it easier to explain, I see one called KABOOM on the disk.

Thanks!

Charlie

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Apr 13, 2010, at 6:36 PM, "Charlie" <chazbeenhad@...> wrote:
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 13 Apr 2010 21:28:36 -0400

It depends on what the file is.  If it's XB, just type the following:

RUN "DSK1.KABOOM"
Or
OLD "DSK1.KABOOM"

RUN runs it, OLD loads it up but doesn't run it-- you can run it by  
typing RUN.

If it's an assembly program, then it really depends on what format  
your file is in.  Do you have an XB manual?  It's all in there... If  
you don't have it, it's available in PDF form online.

Owen Brand
Opry99er.com

On Apr 13, 2010, at 9:23 PM, "Charlie" <[email-masked]> wrote:

> So I have a disk with several programs on it. It doesn't auto start.  
> How do I load a program. To make it easier to explain, I see one  
> called KABOOM on the disk.
>
> Thanks!
>
> Charlie
>

---

From: "Charlie" <[email-masked]>
Date: Wed, 14 Apr 2010 02:23:15 -0000

Ok , they are not basic programs. When I try RUN"DSK1.KABOOM"  I get an IO ERROR 50.

I do have an Extended basic manual, but no Idea where to find this stuff. Its so different than the DOS and TRS-80 stuff I know. :)

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Apr 13, 2010, at 9:23 PM, "Charlie" <chazbeenhad@...> wrote:
> 
> > Thanks guys.
> > --- In [email-masked], Owen Brand <owenbrand@> wrote:
> > >
> > > On Apr 13, 2010, at 6:36 PM, "Charlie" <chazbeenhad@> wrote:
> > >

---

From: Keith Bergman <[email-masked]>
Date: Tue, 13 Apr 2010 22:33:35 -0400

Charlie,

I don't know how much or little you know about basic TI conventions, so I'll
lay a couple things out here, I hope they help.

TI BASIC is the built-in BASIC you get by pressing "1" at the main screen.
You can't access expanded memory, or use multi-statement lines, in TI BASIC,
and it's slow as molasses.

TI Extended BASIC is a better, more powerful version of BASIC, which came on
a cartridge.  Extended BASIC programs, if they are too big or use any of the
Extended BASIC features that make it better, won't load or run in TI BASIC.

You've seen how to catalog a disk.  Unfortunately, there's no built-in
catalog feature in BASIC or XB.  A lot of disks you'll find have an
auto-loading program which will show you a catalog of what's on the disk,
and allow you to pick and choose from a menu then load a program.  (Anything
that you save with the name "LOAD" will auto-load when you choose Extended
BASIC).

If you don't have an Extended BASIC cartridge, that's absolutely the next
thing you need.  A lot of programs require it to run, and it unlocks access
to your memory expansion, assembly language subroutines, sprites, etc.

All of us here have been messing with 99/4A's for quite a while, so I think
sometimes we forget how alien the whole system can look to a new recruit.
Kudos to you for taking the plunge on a PEB and getting into it, and
welcome!

Keith

On Tue, Apr 13, 2010 at 10:23 PM, Charlie <[email-masked]> wrote:

> I do have an Extended basic manual, but no Idea where to find this stuff.
> Its so different than the DOS and TRS-80 stuff I know. :)
>
>
> --- In [email-masked] <TI994A%40yahoogroups.com>, Owen Brand
> <owenbrand@...> wrote:
> >
> > > --- In [email-masked] <TI994A%40yahoogroups.com>, Owen Brand
> <owenbrand@> wrote:
> > > >

---

From: Gregory McGill <[email-masked]>
Date: Tue, 13 Apr 2010 20:57:28 -0700

If the program is listed as a PROGRAM file, its either basic, assembly or
propriatary memory image from a game/etc

If its assembly you'll either need an XB loader (such as funnelweb) DM2K or
an Editor Assembler cart to run it..  Eacart pick #5 and then enter
DSK1.KABOOM

if it's a DF or DV file, those are data files which could also be an
assembly program that hasn't been made into a EA5 memory image..

keep at us, give us more data/details so we can help more.

Greg

---

From: "Charlie" <[email-masked]>
Date: Wed, 14 Apr 2010 13:31:26 -0000

Thanks Greg. The file is listed as PROGRAM. I don't have an EA cart, So I'll have to keep checking ebay for one. I will be getting a Disk Manager II cart soon. That should help get me more familiar with this system.

I think the LOAD program on the disk that has KABOOM (and others) is corrupt. I get a FOR-NEXT (?) error. When I try to list it it goes a page or 2 and then the screen corrupts and the TI makes an ugly sound.

Charlie

--- In [email-masked], Gregory McGill <arcadeshopper@...> wrote:
> On Tue, Apr 13, 2010 at 7:23 PM, Charlie <chazbeenhad@...> wrote:
> 
> >
> >
> > > On Apr 13, 2010, at 9:23 PM, "Charlie" <chazbeenhad@> wrote:
> > >
> > > > Thanks guys.

---

From: Owen Brand <[email-masked]>
Date: Wed, 14 Apr 2010 09:36:59 -0400

The LOAD file is an XB Autoload file.  Are you LISTing it with TI  
BASIC or XB?

Owen Brand
Opry99er.com

On Apr 14, 2010, at 9:31 AM, "Charlie" <[email-masked]> wrote:

>
> Thanks Greg. The file is listed as PROGRAM. I don't have an EA cart,  
> So I'll have to keep checking ebay for one. I will be getting a Disk  
> Manager II cart soon. That should help get me more familiar with  
> this system.
>
> I think the LOAD program on the disk that has KABOOM (and others) is  
> corrupt. I get a FOR-NEXT (?) error. When I try to list it it goes a  
> page or 2 and then the screen corrupts and the TI makes an ugly sound.
>
> Charlie
>
> > > Ok , they are not basic programs. When I try RUN"DSK1.KABOOM" I  
> get an IO
> > > ERROR 50.
> > >
> > > > > > The rs232 allows you to communicate with other computers,  
> the 32k
> > > > > mem

---

From: "Charlie" <[email-masked]>
Date: Wed, 14 Apr 2010 13:41:19 -0000

Hi Owen. I'm guessing XB. I list it right where it errors out and leaves me at the XB prompt.

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Apr 14, 2010, at 9:31 AM, "Charlie" <chazbeenhad@...> wrote:
> 
> >
> > --- In [email-masked], Gregory McGill <arcadeshopper@>  
> > wrote:
> > >
> > > On Tue, Apr 13, 2010 at 7:23 PM, Charlie <chazbeenhad@> wrote:
> > >
> > > >
> > > >

---

From: "Charlie" <[email-masked]>
Date: Wed, 14 Apr 2010 13:42:15 -0000

Thanks Jim. I will look for that manual!

Charlie

---

From: "Charlie" <[email-masked]>
Date: Wed, 14 Apr 2010 13:39:52 -0000

Thank you Keith. This system is like no other I've played with. Still, the very little I've done so far, I really am having a good time!

I'd like some information on the 3rd party disk controllers that can do DD. Do I need to also replace my drive? I have the stock drive and controller. I see so many programs on the internet and I am just itching to be able to make disks and play them on the real TI.
Does anyone have a controller/drive for sale?

So far I've played with 4 PC systems and none of them support SD.
So if someone can tell me a specific mobo or controller to get that will allow me to write SD disks for the TI, I'll try to hunt it down and get it. Otherwise it will be the DD controller/drive in the TI. Probably will get both in the end. I can see myself getting hooked on this computer. :)

Charlie

--- In [email-masked], Keith Bergman <exiletoledo@...> wrote:
> On Tue, Apr 13, 2010 at 10:23 PM, Charlie <chazbeenhad@...> wrote:
> 
> >
> >

---

From: Owen Brand <[email-masked]>
Date: Wed, 14 Apr 2010 09:45:49 -0400

Cool--- if you've got that Extended BASIC cart in the cartridge port  
and you're trying to LIST it, does that mean when you started Extended  
BASIC (XB) that it TRIED to autoload immediately after selecting

2) For Extended BASIC

But failed?

Owen Brand
Opry99er.com

On Apr 14, 2010, at 9:41 AM, "Charlie" <[email-masked]> wrote:

> > > > > > RUN runs it, OLD loads it up but doesn't run it-- you can  
> run
> > > it by
> > > > > > typing RUN.
> > > > > >
> > > > > > > How do I load a program. To make it easier to explain, I  
> see
> > > one
> > > > > > > > Hey Charlie, congrats!!! Perhaps if you had some  
> specific
> > > questions,
> > > > > > > > we could help you, "specifically." What are you hoping  
> to
> > > > > > > accomplish?

---

From: Owen Brand <[email-masked]>
Date: Wed, 14 Apr 2010 10:13:42 -0400

Hey Charlie, if it would be easier for you, I'll give you my phone #  
and I can walk you through some of these things--- might be easier to  
do it on the phone, descriptions and such.

Owen Brand
Opry99er.com

---

From: "Charlie" <[email-masked]>
Date: Wed, 14 Apr 2010 15:06:04 -0000

Yes. That is correct. It tried to load and failed.
I'll email you about the phone number thing. Thanks!
Charlie

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Apr 14, 2010, at 9:41 AM, "Charlie" <chazbeenhad@...> wrote:
> 
> >
> > > On Apr 14, 2010, at 9:31 AM, "Charlie" <chazbeenhad@> wrote:
> > >
> > > >

---

From: Gregory McGill <[email-masked]>
Date: Wed, 14 Apr 2010 10:32:01 -0700

Sounds corrupt..

I can mail you a floppy with a loader on it for EA5 games that works on
Xbasic. Or you can download it from my BBS. Also DM2k so you can manage
disks better..

Lmk
Greg

On Wed, Apr 14, 2010 at 6:31 AM, Charlie <[email-masked]> wrote:

>
>
>
> Thanks Greg. The file is listed as PROGRAM. I don't have an EA cart, So
> I'll have to keep checking ebay for one. I will be getting a Disk Manager II
> cart soon. That should help get me more familiar with this system.
>
> corrupt. I get a FOR-NEXT (?) error. When I try to list it it goes a page or
> 2 and then the screen corrupts and the TI makes an ugly sound.
>
> Charlie
>
>
> --- In [email-masked] <TI994A%40yahoogroups.com>, Gregory McGill
> <arcadeshopper@...> wrote:
> >
> > > Ok , they are not basic programs. When I try RUN"DSK1.KABOOM" I get an
> IO
> > > ERROR 50.
> > >
> > > --- In [email-masked] <TI994A%40yahoogroups.com> <TI994A%
> 40yahoogroups.com>, Owen Brand
>
> > > <owenbrand@> wrote:
> > > >
> > > > > --- In [email-masked] <TI994A%40yahoogroups.com> <TI994A%
> 40yahoogroups.com>, Owen Brand
>
> > > <owenbrand@> wrote:
> > > > > >

---

From: "Charlie" <[email-masked]>
Date: Thu, 15 Apr 2010 12:36:58 -0000

Thanks for the offer! I now have the ability to make TI99 disks on an old 386 PC so if you could email a DSK?

chaz70 at version.net

Thank you.

Charlie

--- In [email-masked], Gregory McGill <arcadeshopper@...> wrote:
> On Wed, Apr 14, 2010 at 6:31 AM, Charlie <chazbeenhad@...> wrote:
> 
> >
> >
> >
> > <arcadeshopper@> wrote:

---

From: Gregory McGill <[email-masked]>
Date: Thu, 15 Apr 2010 18:48:41 -0700

emailed some dsk's !

hope they work for you

Greg

On Thu, Apr 15, 2010 at 5:36 AM, Charlie <[email-masked]> wrote:

> page or
> 40yahoogroups.com>, Gregory McGill
>
> > > <arcadeshopper@> wrote:
> > > >
> > > > If its assembly you'll either need an XB loader (such as funnelweb)
> DM2K
> > > or
> 40yahoogroups.com> <TI994A%
>
> > > > > > > --- In [email-masked] <TI994A%40yahoogroups.com><TI994A%
> 40yahoogroups.com> <TI994A%
>
> > > > > > > > The rs232 allows you to communicate with other computers, the
> 32k
> > > > > > > mem
> > > > > > > > expansion is transparent, but necessary-- the Disk
> controller,
> > > you
> > > > > > > > > Hello everyone. I just got my PEB. Everything seems to work
> ok.
> > > I
> > > > > > > > > can get games to auto run from the disk. However after that
> I
> > > have
> > > > > > > > > no idea how to use it. Can someone please tell me the
> basics,
> > > like