Subject: Electronics question: a little OT

From: "Tony Knerr" <[email-masked]>
Date: Sun, 11 Apr 2010 20:40:24 -0000

I have a need to drive a led from 2 different sources, 
namely 2 disk controllers in a PC. I suppose one could
relate this to a TI by using the same design to drive a single
led from 2 pbox cards. Before someone suggests it, I'd prefer not to use a dual color led for this.

I assume it would not be a good idea to just wire the 2 drivers in parallel,as they might damage each other by driving against each other. 
Can I just use diodes on both leads of each driver to isolate them from each other? Or is it more complicated than that?

Tony

---

From: "Tursi" <[email-masked]>
Date: Sun, 11 Apr 2010 13:44:56 -0700

> I assume it would not be a good idea to just wire the 2 drivers in 
> parallel,as they might damage each other by driving against
> each other.
> Can I just use diodes on both leads of each driver to isolate them from 
> each other? Or is it more complicated than that?

I would expect diodes to work...? That's all an OR gate is.

Is the chip driving high or driving low? (I'd expect one lead to be common.)

---

From: Tony Knerr <[email-masked]>
Date: Sun, 11 Apr 2010 16:59:52 -0400

I haven't tested whether they're driving high or low, so I can't answer 
that.
However, if I use 4 diodes total - one on each positive feed and one on 
each negative feed,
I should be ok, I assume?

Tony

---

From: "Tursi" <[email-masked]>
Date: Sun, 11 Apr 2010 14:29:23 -0700

> I should be ok, I assume?

I would be a little dubious of that.. if the voltage drop was small enough 
maybe.

Does this mean your chip(s) output both lines to drive the LED?

Usually, a circuit needs a common ground in order to work, so that's why I'd 
expect at least one lead to be common. I don't think it will work otherwise. 
I'd probably try with just one of them first to see if I can drive the LED 
from just one pin or the other, and then base the resulting circuit on that.

But, keep in mind, my knowledge of electronics is still very low.

---

From: Tony Knerr <[email-masked]>
Date: Sun, 11 Apr 2010 17:56:32 -0400

Maybe I'll just carefully drill a small hole right below the led and hot 
glue another led there. ;)

Tony

Tursi wrote:
> _

---

From: Marc Hull <[email-masked]>
Date: Sun, 11 Apr 2010 16:29:12 -0700 (PDT)

Yes....  The termination point for the LED's will most likely be ground so it doesn't care what powers it and nothing downstream should be effected.  Separating the two power sources with diodes should protect you from most anything...

--- On Sun, 4/11/10, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: [TI994A] Electronics question: a little OT
To: [email-masked]
Date: Sunday, April 11, 2010, 3:40 PM

  

Tony