Subject: TurboForth preparation

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 12:53:29 -0400

In getting prepared for the highly anticipated TurboForth release, I  
have started reading through the SAMS TI Forth beginners guide.  It is  
very limited in content and doesn't actually really teach you Forth. I  
also have a manual and system diskette for Super4th (which I can't  
use... No Supercart).  So I am trying to find some online references  
on Forth development.  Any good tutorials on wht or Internet?  Bill,  
you there?

    I'm gonna start some serious re-tooling of my dev environment,  
hopefully I'll be able to get my hands on a modded 32-16 console--if  
so I'll be modifying my CF7 in the way Richard has done-- All of this  
is geared towards going into high gear with developing my current game  
project, 2 utilities currently in development, and a new game project  
which I'm not talking about right now... All I can say is it's a port  
of a classic arcade game.  Anyway, if I can find some additional Forth  
info, I will attempt this new game project in TurboForth.  :).

Owen Brand
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 19:40:35 +0000 (GMT)

I can *HIGHLY* recommend Starting Forth by Leo Brodie.

http://tinyurl.com/ydqywa4

This book is AWESOME. You will totally "get" Forth by the time you finish it. It's an old book, but don't let that put you off. My (1st edition - woohoo!) copy goes everywhere with me, even the toilet!

M

----- Original Message ----
> From: Owen Brand <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Sent: Thu, 8 April, 2010 17:53:29
> Subject: [TI994A] TurboForth preparation
> 
have started reading through the SAMS TI Forth beginners guide.  It 
> is  
very limited in content and doesn't actually really teach you 
> Forth. I  
also have a manual and system diskette for Super4th (which I 
> can't  
use... No Supercart).  So I am trying to find some online 
> references  
on Forth development.  Any good tutorials on wht or 
> Internet?  Bill,  
you there?

    I'm gonna start 
> some serious re-tooling of my dev environment,  
hopefully I'll be able 
> to get my hands on a modded 32-16 console--if  
so I'll be modifying my 
> CF7 in the way Richard has done-- All of this  
is geared towards going 
> into high gear with developing my current game  
project, 2 utilities 
> currently in development, and a new game project  
which I'm not talking 
> about right now... All I can say is it's a port  
of a classic arcade 
> game.  Anyway, if I can find some additional Forth  
info, I will 
> attempt this new game project in TurboForth.  :).

Owen 
> Brand
Opry99er.com

------------------------------------

Yahoo! 
> Groups Links

>   
> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 16:16:49 -0400

Wow, I'm just a few pages into the first chapter and the concept is so  
simple it's beyond brilliant!!!  This concept seems to be a  
streamlined greased lightning version of user-defined SUBS in XB, only  
much more efficient and straightforward!  It also seems to be the  
perfect language choice for the /4a, as it has absolute ties to ASCII  
and would seem to sit cleanly on top of the machine language.  Very  
good suggestion on this book!!

Owen Brand
Opry99er.com

On Apr 8, 2010, at 3:40 PM, mark wills <[email-masked]>  
wrote:

> This book is AWESOME. You will totally "get" Forth by the time you  
> finish it. It's an old book, but don't let that put you off. My (1st  
> edition - woohoo!) copy goes everywhere with me, even the toilet!
>
> M
>

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 20:33:59 +0000 (GMT)

Yes. Forth really does rock on machines like ours, and is also very suitable for embedded devices. And if you ever get far enough into it to learn how the compiler itself works, your brain will explode. It is SO head smackingly simple, it's beautiful.

Pretty much all the examples (as far as I know) in the book I mentioned will run in TurboForth.

>This concept seems to be a streamlined greased lightning version of 
user-defined SUBS in XB

One of the central practices in Forth is that of Factoring. Factoring is simply breaking your routines to smaller and smaller words, so instead of one word that is 10's of lines long (as you might in C) you tend to break up the routine into smaller chunks, each one a word. This helps with the issue of 'stackrobatics' - when you are having to juggle lots of things on the stack. You also have variables and constants. TurboForth also has VALUEs, which are like VARIABLEs but have a friendlier syntax.

Forth seems difficult at first (don't get me wrong, it's harder than, say XB, but easier than assembly) simply because you have to manage the stack, which doesn't even exist in other languages.

I constantly kick myself that I wrote Forth off as crap for so many years. I was so arrogant. Just because I couldn't understand it at the time.

>Sent: Thu, 8 April, 2010 21:16:49
>Subject: Re: [TI994A] TurboForth preparation
>
> >
>
>
>
> >
>
>
>
>
>
>
>Wow, I'm just a few pages into the first chapter and the concept is so simple it's beyond brilliant!!!  This concept seems to be a streamlined greased lightning version of user-defined SUBS in XB, only much more efficient and straightforward!  It also seems to be the perfect language choice for the /4a, as it has absolute ties to ASCII and would seem to sit cleanly on top of the machine language.  Very good suggestion on this book!!
>
>Owen Brand
>Opry99er.com
>
>On Apr 8, 2010, at 3:40 PM, mark wills <[email-masked]> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>http://tinyurl. com/ydqywa4
>>
>>>>> From: Owen Brand <owenbrand@opry99er. com>
>>>>> To: "TI994A@yahoogroups. com" <TI994A@yahoogroups. com>
>>>>------------ --------- --------- ------
>>
>>>>Yahoo! 
>>>>> Groups Links
>>
>>>>> 
>>>>> >http://groups.yahoo.com/ group/TI994A/
>>
>>>>> href="http://groups.yahoo.com/ group/TI994A/ join" target=_blank 
>>>>> >http://groups.yahoo.com/ group/TI994A/ join
>>>>    (Yahoo! ID 
>>>>> required)
>>
>>>>> href="mailto:TI994A-digest@ yahoogroups. com">TI994A-digest@ yahoogroups. com 
>>>>> 
>>
>>>>> href="mailto:TI994A-fullfeatured @yahoogroups. com">TI994A-fullfeatured @yahoogroups. com
>>
>>>>> ymailto="mailto:TI994A-unsubscribe@ yahoogroups. com" 
>>>>> href="mailto:TI994A-unsubscribe@ yahoogroups. com">TI994A-unsubscribe@ yahoogroups. com
>>
>>>>> href="http://docs.yahoo.com/ info/terms/" target=_blank 
>>>>> >http://docs.yahoo.com/ info/terms/
>>
>
>
>

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 14:02:58 -0700

Like most Forth'ers I know I prefer Starting Forth by Leo Brodie, as it 
is such a delight to read and study, and it really teaches the basics of 
factoring and style (keep it readable).  The second edition is more in 
line with Forth83 than the first edition, and I suspect the first 
edition might be near impossible to find these days.  There are many 
others to consider, but you'll be best served by beginning with Starting 
Forth.

We'll talk about some of the others after you get grip with Starting 
Forth and have questions you need answered.

Bill S

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 17:15:28 -0400

So if I'm reading this right, a word can be defined as a series of  
other words as well???  This would make things like screen draws  
lightning fast and easy to implement!!!  Also, entire sequences of  
code that determine complex functions can be pieced together and  
defined as a word?!?  Holy crap!!  I hope I'm reading this correctly!

Owen Brand
Opry99er.com

On Apr 8, 2010, at 4:33 PM, mark wills <[email-masked]>  
wrote:

> Yes. Forth really does rock on machines like ours, and is also very  
> suitable for embedded devices. And if you ever get far enough into  
> it to learn how the compiler itself works, your brain will explode.  
> It is SO head smackingly simple, it's beautiful.
>
> One of the central practices in Forth is that of Factoring.  
> Factoring is simply breaking your routines to smaller and smaller  
> words, so instead of one word that is 10's of lines long (as you  
> might in C) you tend to break up the routine into smaller chunks,  
> each one a word. This helps with the issue of 'stackrobatics' - when  
> you are having to juggle lots of things on the stack. You also have  
> variables and constants. TurboForth also has VALUEs, which are like  
> VARIABLEs but have a friendlier syntax.
>
> Forth seems difficult at first (don't get me wrong, it's harder  
> than, say XB, but easier than assembly) simply because you have to  
> manage the stack, which doesn't even exist in other languages.
>
> I constantly kick myself that I wrote Forth off as crap for so many  
> years. I was so arrogant. Just because I couldn't understand it at  
> the time.
>
>
>
> Wow, I'm just a few pages into the first chapter and the concept is  
> so simple it's beyond brilliant!!!  This concept seems to be a  
> streamlined greased lightning version of user-defined SUBS in XB,  
> only much more efficient and straightforward!  It also seems to be  
> the perfect language choice for the /4a, as it has absolute ties to  
> ASCII and would seem to sit cleanly on top of the machine language.   
> Very good suggestion on this book!!
>
> Owen Brand
> Opry99er.com
>
>> finish it. It's an old book, but don't let that put you off. My  
>> (1st edition - woohoo!) copy goes everywhere with me, even the  
>> toilet!
>>
>> M
>>

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 14:24:06 -0700

Agreed.

Bill S

mark wills wrote:
> http://tinyurl.com/ydqywa4 <http://tinyurl.com/ydqywa4>
> 
>  > From: Owen Brand <[email-masked] 
> <mailto:owenbrand%40opry99er.com>>
>  > To: "[email-masked] <mailto:TI994A%40yahoogroups.com>" 
> <[email-masked] <mailto:TI994A%40yahoogroups.com>>
> <http://groups.yahoo.com/group/TI994A/>
> 
>  > href="http://groups.yahoo.com/group/TI994A/join 
> <http://groups.yahoo.com/group/TI994A/join>" target=_blank
> <http://groups.yahoo.com/group/TI994A/join>
> (Yahoo! ID
>  > required)
> 
>  > href="mailto:[email-masked] 
> <mailto:TI994A-digest%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-digest%40yahoogroups.com>
>  >
> 
>  > href="mailto:[email-masked] 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>
> 
>  > ymailto="mailto:[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>"
>  > href="mailto:[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>
> 
>  > href="http://docs.yahoo.com/info/terms/ 
> <http://docs.yahoo.com/info/terms/>" target=_blank
>  > >http://docs.yahoo.com/info/terms/ <http://docs.yahoo.com/info/terms/>
> 
>

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 14:25:52 -0700

I pretty much agree.

Bill S

mark wills wrote:
> suitable for embedded devices. And if you ever get far enough into it to 
> learn how the compiler itself works, your brain will explode. It is SO 
> head smackingly simple, it's beautiful.
> 
> One of the central practices in Forth is that of Factoring. Factoring is 
> simply breaking your routines to smaller and smaller words, so instead 
> of one word that is 10's of lines long (as you might in C) you tend to 
> break up the routine into smaller chunks, each one a word. This helps 
> with the issue of 'stackrobatics' - when you are having to juggle lots 
> of things on the stack. You also have variables and constants. 
> TurboForth also has VALUEs, which are like VARIABLEs but have a 
> friendlier syntax.
> 
> Forth seems difficult at first (don't get me wrong, it's harder than, 
> say XB, but easier than assembly) simply because you have to manage the 
> stack, which doesn't even exist in other languages.
> 
> years. I was so arrogant. Just because I couldn't understand it at the time.
> 
> 
> 
>     *From:* Owen Brand <[email-masked]>
>     *To:* "[email-masked]" <[email-masked]>
>     *Sent:* Thu, 8 April, 2010 21:16:49
>     *Subject:* Re: [TI994A] TurboForth preparation
> 
> 
> 
>     Opry99er.com <http://Opry99er.com>
> 
>     On Apr 8, 2010, at 3:40 PM, mark wills <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>>      
>>
>>     <http://tinyurl.com/ydqywa4>http://tinyurl. com/ydqywa4
>>
>>     (1st edition - woohoo!) copy goes everywhere with me, even the toilet!
>>
>>     M
>>
>>     > From: Owen Brand <owenbrand@opry99er. com
>>     > To: "TI994A@yahoogroups. com <mailto:TI994A%40yahoogroups.com>"
>>     <TI994A@yahoogroups. com <mailto:TI994A%40yahoogroups.com>>
>>     <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>
>>     <http://groups.yahoo.com/group/TI994A/>http://groups.yahoo.com/
>>     <http://yahoo.com/> group/TI994A/
>>
>>     > href="
>>     <http://groups.yahoo.com/group/TI994A/join>http://groups.yahoo.com/
>>     <http://yahoo.com/> group/TI994A/ join" target=_blank
>>     > >
>>     <http://groups.yahoo.com/group/TI994A/join>http://groups.yahoo.com/
>>     <http://yahoo.com/> group/TI994A/ join
>>     (Yahoo! ID
>>     > required)
>>
>>     > href="mailto:TI994A-digest@ yahoogroups. com
>>     <mailto:TI994A-digest%40yahoogroups.com>">TI994A-digest@
>>     yahoogroups. com <mailto:TI994A-digest%40yahoogroups.com>
>>     >
>>
>>     > href="mailto:TI994A-fullfeatured @yahoogroups. com
>>     <mailto:TI994A-fullfeatured%40yahoogroups.com>">TI994A-fullfeatured
>>     @yahoogroups. com <mailto:TI994A-fullfeatured%40yahoogroups.com>
>>
>>     > ymailto="mailto:TI994A-unsubscribe@ yahoogroups. com
>>     > href="mailto:TI994A-unsubscribe@ yahoogroups. com
>>     <mailto:TI994A-unsubscribe%40yahoogroups.com>">TI994A-unsubscribe@
>>     yahoogroups. com <mailto:TI994A-unsubscribe%40yahoogroups.com>
>>
>>     > href=" <http://docs.yahoo.com/info/terms/>http://docs.yahoo.com/
>>     <http://yahoo.com/> info/terms/" target=_blank
>>     > > <http://docs.yahoo.com/info/terms/>http://docs.yahoo.com/
>>     <http://yahoo.com/> info/terms/
>>
> 
> 
>

---

From: fdos <[email-masked]>
Date: Thu, 08 Apr 2010 14:32:28 -0700

Absolutely correct as this is the way it is mostly done.  Then later if 
more speed is required test the individual words making up the 
application word and redefine those that can be improved upon by coding 
them with the Forth style assembler.

Bill S

Owen Brand wrote:
>  
> 
> So if I'm reading this right, a word can be defined as a series of other 
> words as well???  This would make things like screen draws lightning 
> fast and easy to implement!!!  Also, entire sequences of code that 
> determine complex functions can be pieced together and defined as a 
> word?!?  Holy crap!!  I hope I'm reading this correctly!
> 
> Owen Brand
> On Apr 8, 2010, at 4:33 PM, mark wills <[email-masked] 
>> suitable for embedded devices. And if you ever get far enough into it 
>> to learn how the compiler itself works, your brain will explode. It is 
>> SO head smackingly simple, it's beautiful.
>>
>> One of the central practices in Forth is that of Factoring. Factoring 
>> is simply breaking your routines to smaller and smaller words, so 
>> instead of one word that is 10's of lines long (as you might in C) you 
>> tend to break up the routine into smaller chunks, each one a word. 
>> This helps with the issue of 'stackrobatics' - when you are having to 
>> juggle lots of things on the stack. You also have variables and 
>> constants. TurboForth also has VALUEs, which are like VARIABLEs but 
>> have a friendlier syntax.
>>
>> say XB, but easier than assembly) simply because you have to manage 
>> the stack, which doesn't even exist in other languages.
>>
>>     Wow, I'm just a few pages into the first chapter and the concept
>>     is so simple it's beyond brilliant!!!  This concept seems to be a
>>     the perfect language choice for the /4a, as it has absolute ties
>>     to ASCII and would seem to sit cleanly on top of the machine
>>     language.  Very good suggestion on this book!!
>>
>>     Owen Brand
>>     On Apr 8, 2010, at 3:40 PM, mark wills
>>     <[email-masked] <mailto:[email-masked]>>
>>     wrote:
>>
>>>      
>>>
>>>     <http://tinyurl.com/ydqywa4> <http://tinyurl>http://tinyurl.
>>>     com/ydqywa4
>>>
>>>     This book is AWESOME. You will totally "get" Forth by the time
>>>     you finish it. It's an old book, but don't let that put you off.
>>>     My (1st edition - woohoo!) copy goes everywhere with me, even the
>>>     toilet!
>>>
>>>     M
>>>
>>>     <http://Opry99er.com> <http://Opry99er.com>Opry99er.com
>>>     <http://Opry99er.com>
>>>
>>>     <http://groups>http://groups. <http://yahoo.com/>yahoo.com/
>>>     > href=" <http://groups.yahoo.com/group/TI994A/join>
>>>     <http://groups>http://groups. <http://yahoo.com/>yahoo.com/
>>>     <http://groups>http://groups. <http://yahoo.com/>yahoo.com/
>>>     > href=" <http://docs.yahoo.com/info/terms/>
>>>     <http://docs>http://docs. <http://yahoo.com/>yahoo.com/
>>>     > > <http://docs.yahoo.com/info/terms/> <http://docs>http://docs.
>>>     <http://yahoo.com/>yahoo.com/ <http://yahoo.com/> info/terms/
>>>
>>
>>
>

---

From: mark wills <[email-masked]>
Date: Thu, 8 Apr 2010 22:28:21 +0000 (GMT)

That's exactly right. Not only is it possible, it is positively encouraged.

And because Forth is interactive, you can test each little word individually at the keyboard, immediately. None of this write code/save/assemble/load object code/try it rubbish!

There's an example in Brodie's book:

: WASHER FILL WASH RINSE SPIN ;

That's the high level definition for a washing machine. Now you define the other words:

: FILL WHILE NOT-FULL BEGIN FAUCET-ON FULL? UNTIL FAUCET-OFF ;
: WASH 20 0 DO CLOCKWISE MOTOR-ON 5 MINUTES WAIT MOTOR-OFF ANTI-CLOCKWISE MOTOR-ON 5 MINUTES WAIT ;
: RINSE EMPTY 5 MINUTES WAIT FILL ;

You get the idea... Then you go and define NOT-FULL FAUCET-ON etc... Your application is built (or rather 'grown') from lots of little words. You test each word as you go and move on when you are happy with it. Notice that RINSE uses FILL to fill the washer after draining it.

When applications are built like this, they are said to be "highly factored". You will notice that the program (at least at this high level) almost reads like english. It doesn't even look like Forth! You have defined your own DSL (domain specific language) for controlling an industrial washing machine!

>Sent: Thu, 8 April, 2010 22:15:28
>So if I'm reading this right, a word can be defined as a series of other words as well???  This would make things like screen draws lightning fast and easy to implement!!!  Also, entire sequences of code that determine complex functions can be pieced together and defined as a word?!?  Holy crap!!  I hope I'm reading this correctly!
>
>Owen Brand
>Opry99er.com
>
>On Apr 8, 2010, at 4:33 PM, mark wills <[email-masked]> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>>To: "TI994A@yahoogroups .com" <TI994A@yahoogroups. com>
>>>On Apr 8, 2010, at 3:40 PM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>>>
>>>
>>>>>>>
>>>>
>>>>
>>>>  >>>>
>>>>
>>>> 
>>>>>>>>      
>>>>

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 21:03:02 -0400

Yes.... Yes.... Yes.... All this stuff is freakin great.  I MUST have  
TurboForth... I cannot tell you how much this excites me to learn  
about. It's like an answer to my prayers, honestly.  :). A fast  
language that is not double interpreted and is readable!!!!!!!  I  
think I'm in love.  And ON CART!!  No coding-assembling-loading object  
code-running it.  No slow crappy XB sluggishness.  Ahhh... I can feel  
a break dance coming on.  :) I will still continue learning assembly,  
but this Forth thing... Wow.  If it has all the features you say (vs.  
TI Forth which is lacking many) then I've found my happy place.

Owen Brand
Opry99er.com

On Apr 8, 2010, at 6:28 PM, mark wills <[email-masked]>  
wrote:

> And because Forth is interactive, you can test each little word  
> individually at the keyboard, immediately. None of this write code/ 
> save/assemble/load object code/try it rubbish!
>
> You get the idea... Then you go and define NOT-FULL FAUCET-ON etc...  
> Your application is built (or rather 'grown') from lots of little  
> words. You test each word as you go and move on when you are happy  
> with it. Notice that RINSE uses FILL to fill the washer after  
> draining it.
>
> When applications are built like this, they are said to be "highly  
> factored". You will notice that the program (at least at this high  
> level) almost reads like english. It doesn't even look like Forth!  
> You have defined your own DSL (domain specific language) for  
> controlling an industrial washing machine!
>
>> >This concept seems to be a streamlined greased lightning version  
>> of user-defined SUBS in XB
>>
>> each one a word. This helps with the issue of 'stackrobatics' -  
>> when you are having to juggle lots of things on the stack. You also  
>> have variables and constants. TurboForth also has VALUEs, which are  
>> like VARIABLEs but have a friendlier syntax.
>>
>> ASCII and would seem to sit cleanly on top of the machine

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Apr 2010 23:01:28 -0400

Okay Mark-- I may be getting ahead of myself here, but in Forth, there  
are a couple unique characteristics that I am reading about in detail  
right now.

1) Postfix notation
2) LIFO stack operation

Both of these are counter-intuitive to my linear brain... But I'm  
practicing them.  :) The postfix notation really just seems to be a  
"symptom" (for lack of a better "word") of the Last In First Out  
methodology.  It seems a bit strange to me, but the more I type and  
practice, the more sense it makes.  Your documentation will, I assume,  
discuss in detail the way this concept works with TurboForth?  I will  
be DLing a Forth terminal emulator in the morning so I can get  
started... :) Fun fun fun!

Owen Brand
Opry99er.com

---

From: mark wills <[email-masked]>
Date: Fri, 9 Apr 2010 09:19:44 +0000 (GMT)

Actually TI Forth probably has more features than TurboForth, however, it's disadvantage on our little memory contrained computer is that Forth itself actually lives in RAM. On my TI-Forth setup I have only 7K free. TurboForth has ~28K of RAM free for your Forth program.

TurboForth is faster on some things. Notably video handling. However, other things seem quite comparable: Loops etc.

When you need more space than TurboForth can give, you will reach for X4th which has awesome memory handling capabilities!

Mark

>Sent: Fri, 9 April, 2010 2:03:02
>Yes.... Yes.... Yes.... All this stuff is freakin great.  I MUST have TurboForth... I cannot tell you how much this excites me to learn about. It's like an answer to my prayers, honestly.  :). A fast language that is not double interpreted and is readable!!!!!!!  I think I'm in love.  And ON CART!!  No coding-assembling-loading object code-running it.  No slow crappy XB sluggishness.  Ahhh... I can feel a break dance coming on.  :) I will still continue learning assembly, but this Forth thing... Wow.  If it has all the features you say (vs. TI Forth which is lacking many) then I've found my happy place.  
>
>Owen Brand
>Opry99er.com
>
>On Apr 8, 2010, at 6:28 PM, mark wills <[email-masked]> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>And because Forth is interactive, you can test each little word individually at the keyboard, immediately. None of this write code/save/assemble/ load object code/try it rubbish!
>>
>>You get the idea... Then you go and define NOT-FULL FAUCET-ON etc... Your application is built (or rather 'grown') from lots of little
>> words. You test each word as you go and move on when you are happy with it. Notice that RINSE uses FILL to fill the washer after draining it.
>>
>>>On Apr 8, 2010, at 4:33 PM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>>>
>>>
>>>>>>>
>>>>
>>>>
>>>>  >>>>
>>>>
>>>> 
>>>>>>>>      
>>>>

---

From: mark wills <[email-masked]>
Date: Fri, 9 Apr 2010 09:33:22 +0000 (GMT)

A good way to practice Forth is with TI-Forth - it's free and it's TI ;-)

Yes, Forth uses a stack, it is the absolute central core running through Forth.

You are correct that postfix notation is a symptom, but it's not unique to Forth. Many scientific calculators use RPN (reverse polish notation, to give it its correct name).

We are taught in school that 2 + 4 + 6 = 12

In RPN 2 4 + 6 + = 12 

OR... 2 4 6 + + = 12

How does that work? Lets take the first example:

2 goes on the stack
4 goes on the stack
+ does it's work. It is programmed to REMOVE the TOP TWO numbers from the stack, add them, put the RESULT on the stack (6)

So now, we have 6 on the stack

Then another 6 is placed on the stack.
Then + runs again, removing the two 6's and placing a single 12 on the stack

Here is a VERY important distinction between Forth and other languages: In XB, for example, things like + - * etc are OPERATORS. They don't work like statements or functions. They are kind of special. It's different in Forth. + is JUST ANOTHER WORD in Forth. It is a little program in it's own right, that removes two values from the top of the stack, adds them, and puts the result on the stack.

You can even CHANGE what + (or ANY other word does):

: + - ." HELLO" ;

Now, + does a subtraction AND says hello!

12 10 +
2 HELLO

Welcome to Forth. You may need to wear a helmet to hold your brains in. My head exploded when I started to 'get it'.

Mark

>Sent: Fri, 9 April, 2010 4:01:28
>Okay Mark-- I may be getting ahead of myself here, but in Forth, there are a couple unique characteristics that I am reading about in detail right now.  
>
>
>1) Postfix notation 
>2) LIFO stack operation
>
>
>Both of these are counter-intuitive to my linear brain... But I'm practicing them.  :) The postfix notation really just seems to be a "symptom" (for lack of a better "word") of the Last In First Out methodology.  It seems a bit strange to me, but the more I type and practice, the more sense it makes.  Your documentation will, I assume, discuss in detail the way this concept works with TurboForth?  I will be DLing a Forth terminal emulator in the morning so I can get started... :) Fun fun fun!
>
>Owen Brand
>Opry99er.com
>
>
>
>

---

From: Viola Jamison <[email-masked]>
Date: Fri, 9 Apr 2010 04:20:22 -0700 (PDT)

Hi gents,
First post....getting back into the TI.......after a 30 yr or so...absence.
 
There's been a number of post re TI forth.  Is this being run on a classic TI-99/4A or on an emulator?
 
Can anyone tell me what is needed to run FORTH on a TI 99/4a?  I'm slowly getting my gear togethr. I don't have a PEB nor disk drive but I do have a CF7.
 
I'm just picking things up slowly.  I did see a PEB for $100. on eb...but there's no guarantee it's in working condition.
 
Back to forth...yes...that's for all input

--- On Fri, 4/9/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] TurboForth preparation
To: [email-masked]
Received: Friday, April 9, 2010, 2:33 AM

In RPN 2 4 + 6 + = 12 

OR... 2 4 6 + + = 12

2 goes on the stack
4 goes on the stack

: + - ." HELLO" ;

12 10 +
2 HELLO

Mark

1) Postfix notation 
2) LIFO stack operation

Owen Brand

Opry99er.com

On Apr 8, 2010, at 6:28 PM, mark wills <markrobertwills@ yahoo.co. uk> wrote:

Owen Brand

Opry99er.com

  

>This concept seems to be a streamlined greased lightning version of user-defined SUBS in XB

Owen Brand

Opry99er.com

  

M

----- Original Message ----
you there?

I'm gonna start 
hopefully I'll be able 
so I'll be modifying my 
is geared towards going 
project, 2 utilities 
which I'm not talking 
of a classic arcade 
info, I will 

Owen 
Opry99er.com

Yahoo! 

(Yahoo! ID 

> >http://docs.yahoo.com/ info/terms/

      __________________________________________________________________
The new Internet Explorer® 8 - Faster, safer, easier.  Optimized for Yahoo!  Get it Now for Free! at http://downloads.yahoo.com/ca/internetexplorer/

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 07:26:48 -0400

Yep... TI Forth was missing some pretty important sh** when it came  
out though.  In reading up on Forth history last night, I came across  
a few unfavorable reviews of TI Forth.  Apparently TI Forth was  
released too early, in the hope to capture some of the excitement  
around Forth at the time.  I also found a reference on this list to  
Craig Miller's influence in this matter.  He convinced them to release  
Forth early.  I'm finding this whole thing VERY interesting.  :)

Owen Brand
Opry99er.com

On Apr 9, 2010, at 5:19 AM, mark wills <[email-masked]>  
wrote:

> Actually TI Forth probably has more features than TurboForth,  
> however, it's disadvantage on our little memory contrained computer  
> is that Forth itself actually lives in RAM. On my TI-Forth setup I  
> have only 7K free. TurboForth has ~28K of RAM free for your Forth  
> program.
>
> TurboForth is faster on some things. Notably video handling.  
> However, other things seem quite comparable: Loops etc.
>
> When you need more space than TurboForth can give, you will reach  
> for X4th which has awesome memory handling capabilities!
>
> Mark
>
> Yes.... Yes.... Yes.... All this stuff is freakin great.  I MUST  
> have TurboForth... I cannot tell you how much this excites me to  
> learn about. It's like an answer to my prayers, honestly.  :). A  
> fast language that is not double interpreted and is readable!!!!!!!   
> I think I'm in love.  And ON CART!!  No coding-assembling-loading  
> object code-running it.  No slow crappy XB sluggishness.  Ahhh... I  
> can feel a break dance coming on.  :) I will still continue learning  
> assembly, but this Forth thing... Wow.  If it has all the features  
> you say (vs. TI Forth which is lacking many) then I've found my  
> happy place.
>
> Owen Brand
> Opry99er.com
>
>> save/assemble/ load object code/try it rubbish!
>>
>> You get the idea... Then you go and define NOT-FULL FAUCET-ON  
>> etc... Your application is built (or rather 'grown') from lots of  
>> little words. You test each word as you go and move on when you are  
>> happy with it. Notice that RINSE uses FILL to fill the washer after  
>> draining it.
>>
>>> Yes. Forth really does rock on machines like ours, and is also  
>>> very suitable for embedded devices. And if you ever get far enough  
>>> into it to learn how the compiler itself works, your brain will  
>>> explode. It is SO head smackingly simple, it's beautiful.
>>>
>>> when you are having to juggle lots of things on the stack. You  
>>> also have variables and constants. TurboForth also has VALUEs,  
>>> which are like VARIABLEs but have a friendlier syntax.
>>>
>>> I constantly kick myself that I wrote Forth off as crap for so  
>>> many years. I was so arrogant. Just because I couldn't understand  
>>> it at the time.
>>>
>>>
>>>

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 07:58:41 -0400

100$ for a populated PEB isn't outrageous.  I would ask the seller if  
the unit "turns on." Even if they can't test it, they can see if it  
powers on.  If it does turn on, this group could help you if anything  
is wrong. TI cards aren't hard to come by... But I would check with  
Mike at Tex*In Treasures online too.  Forth can be emulated, I  
imagine, on any emulator.  It should be able to run fine on your CF7  
also.  If you have a CF7, you are doing well.  There are others on  
this list who can speak more authoritatively on this subject than I.   
Glad to have ya in the group!!!

Owen Brand
Opry99er.com

On Apr 9, 2010, at 7:20 AM, Viola Jamison <[email-masked]>  
wrote:

> Can anyone tell me what is needed to run FORTH on a TI 99/4a?  I'm  
> slowly getting my gear togethr. I don't have a PEB nor disk drive  
> but I do have a CF7.
>
> I'm just picking things up slowly.  I did see a PEB for $100. on  
> eb...but there's no guarantee it's in working condition.
>
> You are correct that postfix notation is a symptom, but it's not  
> unique to Forth. Many scientific calculators use RPN (reverse polish  
> notation, to give it its correct name).
>
> + does it's work. It is programmed to REMOVE the TOP TWO numbers  
> from the stack, add them, put the RESULT on the stack (6)
>
> Here is a VERY important distinction between Forth and other  
> languages: In XB, for example, things like + - * etc are OPERATORS.  
> They don't work like statements or functions. They are kind of  
> special. It's different in Forth. + is JUST ANOTHER WORD in Forth.  
> It is a little program in it's own right, that removes two values  
> from the top of the stack, adds them, and puts the result on the  
> stack.
>
> Welcome to Forth. You may need to wear a helmet to hold your brains  
> in. My head exploded when I started to 'get it'.
>
> Mark
>
> Okay Mark-- I may be getting ahead of myself here, but in Forth,  
> there are a couple unique characteristics that I am reading about in  
> detail right now.
>
> 1) Postfix notation
> 2) LIFO stack operation
>
> practice, the more sense it makes.  Your documentation will, I  
> assume, discuss in detail the way this concept works with  
> TurboForth?  I will be DLing a Forth terminal emulator in the  
> morning so I can get started... :) Fun fun fun!
>
> Owen Brand
> Opry99er.com
>
>
>  Yahoo! Canada Toolbar : Search from anywhere on the web and  
> bookmark your favourite sites. Download it now!
>
>

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 08:41:37 -0400

Hey man--- will you have a built-in, "comment-editable" glossary in  
TurboForth?  Also, is it a 32 column editor?  Sorry for all the  
questions--- just excited.  :)

Owen Brand
Opry99er.com

---

From: ti99_forever <[email-masked]>
Date: Fri, 9 Apr 2010 06:31:10 -0700 (PDT)

No, TI Forth was released unfinished (or it should be said it didn't go through the entire QA process) because TI backed out of the market. We are lucky they gave us so much after leaving.
It had bugs, but if you read the manual you will find it has a full-set of features.
I wouldn't expect an unfinished product to have the rich feature-set of TI Forth. So it didn't have sound. Sound is a poke to a memory-mapped port. Big deal. Check out the graphics capabilities, for example.

--- On Fri, 4/9/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] TurboForth preparation
To: "[email-masked]" <[email-masked]>
Date: Friday, April 9, 2010, 7:26 AM

Yep... TI Forth was missing some pretty important sh** when it came out though.  In reading up on Forth history last night, I came across a few unfavorable reviews of TI Forth.  Apparently TI Forth was released too early, in the hope to capture some of the excitement around Forth at the time.  I also found a reference on this list to Craig Miller's influence in this matter.  He convinced them to release Forth early.  I'm finding this whole thing VERY interesting.  :)  
Owen BrandOpry99er.com
On Apr 9, 2010, at 5:19 AM, mark wills <[email-masked]> wrote:

    

Mark

        

Yes.... Yes.... Yes.... All this stuff is freakin great.  I MUST have TurboForth.. . I cannot tell you how much this excites me to learn about. It's like an answer to my prayers, honestly.  :). A fast language that is not double interpreted and is readable!!!! !!!  I think I'm in love.  And ON CART!!  No coding-assembling- loading object code-running it.  No slow crappy XB sluggishness.  Ahhh... I can feel a break dance coming on.  :) I will still continue learning assembly, but this Forth thing... Wow.  If it has all the features you say (vs. TI Forth which is lacking many) then I've found my happy place.  

Owen BrandOpry99er.com

    

From: Owen Brand <owenbrand@opry99er. com>
To: "TI994A@yahoogroups .com"
 <TI994A@yahoogroups. com>
Sent: Thu, 8 April, 2010 22:15:28
Subject: Re: [TI994A] TurboForth preparation

Owen BrandOpry99er.com

    

user-defined SUBS in XB

        

Owen BrandOpry99er.com

    

M

----- Original Message ----

you there?

I'm gonna start 

hopefully I'll be able 

so I'll be modifying my 

is geared towards going 

project, 2 utilities 

which I'm not talking 

of a classic arcade 

info, I will 

Owen 

Opry99er.com

Yahoo! 

    (Yahoo! ID

---

From: "Ksarul" <[email-masked]>
Date: Fri, 09 Apr 2010 09:39:51 -0400

Note: TI released it at the point that they were pulling out of the TI
market as part of a care package that they sent to the 200 or so user's
groups registered with them at the time.  The package also contained the
files for the Lasso game and a few other interesting things, like SBUG.
Forth wasn't a complete package yet when they pulled out-and they didn't
plan to release it at all because of that (much like the spreadsheet program
for the pSystem that they didn't include and which only surfaced years
later).

Jim Fetzner  

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Owen Brand
Sent: Friday, April 09, 2010 7:27 AM
To: [email-masked]
Subject: Re: [TI994A] TurboForth preparation

Yep... TI Forth was missing some pretty important sh** when it came out
though.  In reading up on Forth history last night, I came across a few
unfavorable reviews of TI Forth.  Apparently TI Forth was released too
early, in the hope to capture some of the excitement around Forth at the
time.  I also found a reference on this list to Craig Miller's influence in
this matter.  He convinced them to release Forth early.  I'm finding this
whole thing VERY interesting.  :)  

Owen Brand

Opry99er.com

On Apr 9, 2010, at 5:19 AM, mark wills <markrobertwills@
<mailto:[email-masked]> yahoo.co.uk> wrote:

Actually TI Forth probably has more features than TurboForth, however, it's
disadvantage on our little memory contrained computer is that Forth itself
actually lives in RAM. On my TI-Forth setup I have only 7K free. TurboForth
has ~28K of RAM free for your Forth program.

TurboForth is faster on some things. Notably video handling. However, other
things seem quite comparable: Loops etc.

When you need more space than TurboForth can give, you will reach for X4th
which has awesome memory handling capabilities!

Mark

Yes.... Yes.... Yes.... All this stuff is freakin great.  I MUST have
TurboForth... I cannot tell you how much this excites me to learn about.
It's like an answer to my prayers, honestly.  :). A fast language that is
not double interpreted and is readable!!!!!!!  I think I'm in love.  And ON
CART!!  No coding-assembling-loading object code-running it.  No slow crappy
XB sluggishness.  Ahhh... I can feel a break dance coming on.  :) I will
still continue learning assembly, but this Forth thing... Wow.  If it has
all the features you say (vs. TI Forth which is lacking many) then I've
found my happy place.  

Owen Brand

 <http://Opry99er.com> Opry99er.com

On Apr 8, 2010, at 6:28 PM, mark wills <markrobertwills@
<mailto:[email-masked]> yahoo.co.uk> wrote:

And because Forth is interactive, you can test each little word individually
at the keyboard, immediately. None of this write code/save/assemble/ load
object code/try it rubbish!

That's the high level definition for a washing machine. Now you define the
other words:

: FILL WHILE NOT-FULL BEGIN FAUCET-ON FULL? UNTIL FAUCET-OFF ;
: WASH 20 0 DO CLOCKWISE MOTOR-ON 5 MINUTES WAIT MOTOR-OFF ANTI-CLOCKWISE
MOTOR-ON 5 MINUTES WAIT ;
: RINSE EMPTY 5 MINUTES WAIT FILL ;

You get the idea... Then you go and define NOT-FULL FAUCET-ON etc... Your
application is built (or rather 'grown') from lots of little words. You test
each word as you go and move on when you are happy with it. Notice that
RINSE uses FILL to fill the washer after draining it.

When applications are built like this, they are said to be "highly
factored". You will notice that the program (at least at this high level)
almost reads like english. It doesn't even look like Forth! You have defined
your own DSL (domain specific language) for controlling an industrial
washing machine!

So if I'm reading this right, a word can be defined as a series of other
words as well???  This would make things like screen draws lightning fast
and easy to implement!!!  Also, entire sequences of code that determine
complex functions can be pieced together and defined as a word?!?  Holy
crap!!  I hope I'm reading this correctly!

Owen Brand

 <http://Opry99er.com>  <http://Opry99er.com> Opry99er.com

On Apr 8, 2010, at 4:33 PM, mark wills <markrobertwills@ yahoo.co. uk
<mailto:[email-masked]> > wrote:

Yes. Forth really does rock on machines like ours, and is also very suitable
for embedded devices. And if you ever get far enough into it to learn how
the compiler itself works, your brain will explode. It is SO head smackingly
simple, it's beautiful.

Pretty much all the examples (as far as I know) in the book I mentioned will
run in TurboForth.

user-defined SUBS in XB

One of the central practices in Forth is that of Factoring. Factoring is
simply breaking your routines to smaller and smaller words, so instead of
one word that is 10's of lines long (as you might in C) you tend to break up
the routine into smaller chunks, each one a word. This helps with the issue
of 'stackrobatics' - when you are having to juggle lots of things on the
stack. You also have variables and constants. TurboForth also has VALUEs,
which are like VARIABLEs but have a friendlier syntax.

Forth seems difficult at first (don't get me wrong, it's harder than, say
XB, but easier than assembly) simply because you have to manage the stack,
which doesn't even exist in other languages.

I constantly kick myself that I wrote Forth off as crap for so many years. I
was so arrogant. Just because I couldn't understand it at the time.

Wow, I'm just a few pages into the first chapter and the concept is so
simple it's beyond brilliant!!!  This concept seems to be a streamlined
greased lightning version of user-defined SUBS in XB, only much more
efficient and straightforward!  It also seems to be the perfect language
choice for the /4a, as it has absolute ties to ASCII and would seem to sit
cleanly on top of the machine language.  Very good suggestion on this book!!

Owen Brand

 <http://Opry99er.com>  <http://Opry99er.com>  <http://Opry99er.com>
Opry99er.com

On Apr 8, 2010, at 3:40 PM, mark wills <markrobertwills@ yahoo.co. uk
<mailto:[email-masked]> > wrote:

 <http://tinyurl.com/ydqywa4>  <http://tinyurl>  <http://tinyurl>
<http://tinyurl> http://tinyurl. com/ydqywa4

This book is AWESOME. You will totally "get" Forth by the time you finish
it. It's an old book, but don't let that put you off. My (1st edition -
woohoo!) copy goes everywhere with me, even the toilet!

M

----- Original Message ----
> From: Owen Brand <owenbrand@opry99er. <mailto:owenbrand%40opry99er.com>
com>
> To: "TI994A@yahoogroups. com <mailto:TI994A%40yahoogroups.com> "
<TI994A@yahoogroups. com <mailto:TI994A%40yahoogroups.com> >
you there?

I'm gonna start 
hopefully I'll be able 
so I'll be modifying my 
is geared towards going 
project, 2 utilities 
which I'm not talking 
of a classic arcade 
info, I will 

Owen 
> Brand
 <http://Opry99er.com>  <http://Opry99er.com>  <http://Opry99er.com>
<http://Opry99er.com> Opry99er.com

Yahoo! 

> 
> > <http://groups.yahoo.com/group/TI994A/>  <http://groups>
<http://groups>  <http://groups> http://groups. <http://yahoo.com/>
<http://yahoo.com/>  <http://yahoo.com/> yahoo.com/ group/TI994A/

> href=" <http://groups.yahoo.com/group/TI994A/join>  <http://groups>
<http://groups>  <http://groups> http://groups. <http://yahoo.com/>
<http://yahoo.com/>  <http://yahoo.com/> yahoo.com/ group/TI994A/ join"
target=_blank 
> > <http://groups.yahoo.com/group/TI994A/join>  <http://groups>
<http://groups>  <http://groups> http://groups. <http://yahoo.com/>
<http://yahoo.com/>  <http://yahoo.com/> yahoo.com/ group/TI994A/ join
(Yahoo! ID 

> href="mailto:TI994A-digest@ <mailto:TI994A-digest%40yahoogroups.com>
yahoogroups. com">TI994A-digest@ <mailto:TI994A-digest%40yahoogroups.com>
yahoogroups. com 

> href="mailto:TI994A-fullfeatured
<mailto:TI994A-fullfeatured%40yahoogroups.com>  @yahoogroups.
com">TI994A-fullfeatured <mailto:TI994A-fullfeatured%40yahoogroups.com>
@yahoogroups. com

> ymailto="mailto:TI994A-unsubscribe@
<mailto:TI994A-unsubscribe%40yahoogroups.com>  yahoogroups. com" 
> href="mailto:TI994A-unsubscribe@
<mailto:TI994A-unsubscribe%40yahoogroups.com>  yahoogroups.
com">TI994A-unsubscribe@ <mailto:TI994A-unsubscribe%40yahoogroups.com>
yahoogroups. com

> href=" <http://docs.yahoo.com/info/terms/>  <http://docs>  <http://docs>
<http://docs> http://docs. <http://yahoo.com/>  <http://yahoo.com/>
<http://yahoo.com/> yahoo.com/ info/terms/" target=_blank 
> > <http://docs.yahoo.com/info/terms/>  <http://docs>  <http://docs>
<http://docs> http://docs. <http://yahoo.com/>  <http://yahoo.com/>
<http://yahoo.com/> yahoo.com/ info/terms/

---

From: mark wills <[email-masked]>
Date: Fri, 9 Apr 2010 15:14:22 +0000 (GMT)

Welcome,

TurboForth is a plug in cartridge and should work with the CF7 just fine. Sounds like you have all you need ;-)

Mark

>
>From: Viola Jamison <[email-masked]>
>Sent: Fri, 9 April, 2010 12:20:22
>Subject: Re: [TI994A] TI Forth
>
> >
>
>
>
> >
> >
>
>
>
>
>
>
>
>Hi gents,
>>Here is a VERY important distinction between Forth and other languages: In XB, for example, things like + - *
>> etc are OPERATORS. They don't work like statements or functions. They are kind of special. It's different in Forth. + is JUST ANOTHER WORD in Forth. It is a little program in it's own right, that removes two values from the top of the stack, adds them, and puts the result on the stack.
>>
>>>>When applications
>>>> are built like this, they are said to be "highly factored". You will notice that the program (at least at this high level) almost reads like english. It doesn't even look like Forth! You have defined your own DSL (domain specific language) for controlling an industrial washing machine!
>>>>
>>>>
>>>>>
>>>>>>>>hopefully I'll be
>>>>>>>> able 
________________________________
 > 
>Yahoo! 
>        Canada Toolbar :Search from anywhere on 
>        the web and bookmark your favourite sites. Download it now!  
>
>
>

---

From: mark wills <[email-masked]>
Date: Fri, 9 Apr 2010 15:16:21 +0000 (GMT)

Yes, that true. Though to TI's credit, they gave it away for free, because they recognised it wasn't complete, or at least, bug free...

>Sent: Fri, 9 April, 2010 12:26:48

---

From: mark wills <[email-masked]>
Date: Fri, 9 Apr 2010 15:23:35 +0000 (GMT)

I don't know what a comment editable glossary is, sorry! :-(

It's a 40 column editor, it windows like FWEB/TI-Writer. If I can get the code to run in TI994W I will add 80 column support too.

Mark

>Sent: Fri, 9 April, 2010 13:41:37
>Hey man--- will you have a built-in, "comment-editable" glossary in TurboForth?  Also, is it a 32 column editor?  Sorry for all the questions--- just excited.  :)
>
>Owen Brand
>Opry99er.com
>
>On Apr 9, 2010, at 5:33 AM, mark wills <[email-masked]> wrote:
>
>
>>>
>>
>>
>>  >>
>>
>> 
>>>>      
>> 
>>Then + runs again,
>> removing the two 6's and placing a single 12 on the stack
>>
>>>On Apr 8, 2010, at
>>> 6:28 PM, mark wills <markrobertwills@ yahoo.co. uk> wrote:
>>>
>>>
>>>>>>>
>>>>
>>>>
>>>>  >>>>
>>>>
>>>> 
>>>>>>>>      
>>>>

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 11:58:46 -0400

The book you suggested discusses a built in "glossary" which is  
essentially a commented dictionary of the user-defined words in  
memory.  If you create "CUT"---

:   CUT  ."This is a cut". ;

Then when you need to look at your defined words, there is a glossary  
which contains "CUT" as well as your other words.  The format looks a  
bit like this

CUT-- this prints "This is a cut"

Or something like that.  Essentially just a way to read your words and  
definitions.  Sorry if I'm not clear-- just mixing a bunch of info  
from the web and the book you suggested and formulating ideas.  :)

Owen Brand
Opry99er.com

On Apr 9, 2010, at 11:23 AM, mark wills <[email-masked]>  
wrote:

> It's a 40 column editor, it windows like FWEB/TI-Writer. If I can  
> get the code to run in TI994W I will add 80 column support too.
>
> Mark
>
>> unique to Forth. Many scientific calculators use RPN (reverse  
>> polish notation, to give it its correct name).
>>
>> there are a couple unique characteristics that I am reading about  
>> in detail right now.
>>
>> 1) Postfix notation
>> 2) LIFO stack operation
>>
>>> little words. You test each word as you go and move on when you  
>>> are happy with it. Notice that RINSE uses FILL to fill the washer  
>>> after draining it.
>>>
>>>> very suitable for embedded devices. And if you ever get far  
>>>> enough into it to learn how the compiler itself works, your brain  
>>>> will explode. It is SO head smackingly simple, it's beautiful.
>>>>
>>>> than, say XB, but easier than assembly) simply because you have  
>>>> to manage the stack, which doesn't even exist in other languages.
>>>>
>>>> only much more efficient and straightforward!  It also seems to  
>>>> be the perfect language choice for the /4a, as it has absolute  
>>>> ties to ASCII and would seem to sit cleanly on top of the machine  
>>>>> My (1st edition - woohoo!) copy goes everywhere with me, even  
>>>>> the toilet!
>>>>>
>>>>> M
>>>>>

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 09:05:56 -0700

Post fix notation; AKA Reverse Polish Notation or just RPN.

LIFO - last in first out (think of a stack and push an item on top then 
pop the top item off.  It is the same item.  Push two items on to the 
stack and pop the top item off.  It is the last item that was pushed on 
to the stack.  Forth has a minimum of two stacks; one is known as the 
parameter stack and the other is known as the return stack.  These two 
stacks are implementation dependent as they may grow up or grow down. 
Read more about these stacks in Starting Forth.

Bill S

Owen Brand wrote:
> discuss in detail the way this concept works with TurboForth?  I will be 
> DLing a Forth terminal emulator in the morning so I can get started... 
> :) Fun fun fun!
> 
> Owen Brand
> On Apr 8, 2010, at 6:28 PM, mark wills <[email-masked] 
> <mailto:mark [email-masked]>> wrote:
> 
>>  
>>
>> individually at the keyboard, immediately. None of this write 
>> code/save/assemble/load object code/try it rubbish!
>>
>> with it. Notice that RINSE uses FILL to fill the washer after draining it.
>>
>> level) almost reads like english. It doesn't even look like Forth! You 
>> have defined your own DSL (domain specific language) for controlling 
>> an industrial washing machine!
>>
>>
>>     *To:* "[email-masked]" <[email-masked]>**Sent:*
>>     Thu, 8 April, 2010 22:15:28
>>     **
>>     *
>>     *So if I'm reading this right, a word can be defined as a series
>>     of other words as well???  This would make things like screen
>>     draws lightning fast and easy to implement!!!  Also, entire
>>     sequences of code that determine complex functions can be pieced
>>     together and defined as a word?!?  Holy crap!!  I hope I'm reading
>>     this correctly!
>>
>>     Owen Brand*
>>     * <http://Opry99er.com>Opry99er.com <http://Opry99er.com>*
>>     *
>>     On Apr 8, 2010, at 4:33 PM, mark wills
>>     *
>>>     * * * *
>>>     * *
>>>     *Yes. Forth really does rock on machines like ours, and is also
>>>     *
>>>         *
>>>         *
>>>         **From:* Owen Brand <owenbrand@opry99er. com>
>>>         *To:* "TI994A@yahoogroups .com" <TI994A@yahoogroups. com>
>>>         *
>>>         *Wow, I'm just a few pages into the first chapter and the
>>>         concept is so simple it's beyond brilliant!!!  This concept
>>>         seems to be a streamlined greased lightning version of
>>>         user-defined SUBS in XB, only much more efficient and
>>>         straightforward!  It also seems to be the perfect language
>>>         choice for the /4a, as it has absolute ties to ASCII and
>>>         would seem to sit cleanly on top of the machine language.
>>>         Owen Brand*
>>>         * <http://Opry99er.com> <http://Opry99er.com>Opry99er.com
>>>         <http://Opry99er.com>*
>>>         *
>>>         On Apr 8, 2010, at 3:40 PM, mark wills <markrobertwills@
>>>         yahoo.co. uk <mailto:[email-masked]>> wrote:
>>>
>>>         *
>>>>         * * * *
>>>>         * *
>>>>
>>>>         *I can *HIGHLY* recommend Starting Forth by Leo Brodie.
>>>>
>>>>         <http://tinyurl.com/ydqywa4> <http://tinyurl>
>>>>         <http://tinyurl>http://tinyurl. com/ydqywa4
>>>>
>>>>         This book is AWESOME. You will totally "get" Forth by the
>>>>         time you finish it. It's an old book, but don't let that put
>>>>         you off. My (1st edition - woohoo!) copy goes everywhere
>>>>         with me, even the toilet!
>>>>
>>>>         M
>>>>
>>>>         > To: "TI994A@yahoogroups. com
>>>>         <mailto:TI994A%40yahoogroups.com>" <TI994A@yahoogroups. com
>>>>         <mailto:TI994A%40yahoogroups.com>>
>>>>         <http://Opry99er.com> <http://Opry99er.com>
>>>>         <http://groups>http://groups. <http://yahoo.com/>
>>>>         <http://yahoo.com/>yahoo.com/ <http://yahoo.com/> group/TI994A/
>>>>
>>>>         <http://groups> <http://groups>http://groups.
>>>>         <http://yahoo.com/> <http://yahoo.com/>yahoo.com/
>>>>         <http://groups> <http://groups>http://groups.
>>>>         <http://yahoo.com/> <http://yahoo.com/>yahoo.com/
>>>>         > href=" <http://docs.yahoo.com/info/terms/> <http://docs>
>>>>         <http://docs>http://docs. <http://yahoo.com/>
>>>>         <http://yahoo.com/>yahoo.com/ <http://yahoo.com/>
>>>>         info/terms/" target=_blank
>>>>         > > <http://docs.yahoo.com/info/terms/> <http://docs>
>>>>         <http://docs>http://docs. <http://yahoo.com/>
>>>>         *
>>>>         * *
>>>>         * *
>>>         *
>>>         *
>>>     * *
>>>     * *
>>     *
>>     *
>> * *
>> * *
> * *
> * *
> **
> * *

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 09:31:49 -0700

Welcome to this OLUG Viola.  Thirty years away is a long time, but 
you'll find all kinds of help to get back in the saddle here.

As you've probably already heard TI FORTH was released into the Public 
Domain before it was completed and thoroughly tested some time after TI 
shut down its Home Computer business.  So it was an "as is" application 
in search of many fixes that came along pretty fast as I got on board 
the TI FORTH bandwagon early on.  I also had a little Fig forth 
experience from on-the-job-training by those (engineering staff) who 
were willing to talk to a marketeer.

TI FORTH can run on real hardware and probably most emulators.  The 
problem is, I believe, that the TI FORTH that is on WHTECH (a massive 
website of TI/Geneve related files) contains the original released files 
with the afore mentioned bugs.  There are no real harmful bugs in the TI 
FORTH kernel.  They are mostly in the source screens provided as 
loadable options that can be compiled into the Forth dictionary as might 
be required by a specific application being developed.

The various fixes can be found in back issues of MICROpendium (also on 
WHTECH), and if you can get your hands on back issues THE SMAR 
PROGRAMMER magazines you will find the fixes along with ways to make TI 
FORTH easier to live with than Bugs Murphy (who has taken up residence 
with me).

If your CF7 includes 32K of expansion memory it will run TI FORTH very 
well after all the bugs are exterminated. :-)  If not the 32K can be 
added to your TI console.  Just ask.

Have fun.

Bill S

Viola Jamison wrote:
> slowly getting my gear togethr. I don't have a PEB nor disk drive but I 
> do have a CF7.
>  
> --- On *Fri, 4/9/10, mark wills /<[email-masked]>/* wrote:
> 
> 
>     from the top of the stack, adds them, and puts the result on the stack.
> 
>         *From:* Owen Brand <owenbrand@opry99er. com>
>         *Sent:* Fri, 9 April, 2010 4:01:28
>         there are a couple unique characteristics that I am reading
>         about in detail right now.  
> 
>         1) Postfix notation 
>         2) LIFO stack operation
> 
>         Both of these are counter-intuitive to my linear brain... But
>         I'm practicing them.  :) The postfix notation really just seems
>         to be a "symptom" (for lack of a better "word") of the Last In
>         First Out methodology.  It seems a bit strange to me, but the
>         more I type and practice, the more sense it makes.  Your
>         documentation will, I assume, discuss in detail the way this
>         concept works with TurboForth?  I will be DLing a Forth terminal
>         emulator in the morning so I can get started... :) Fun fun fun!
> 
>         Owen Brand
>         Opry99er.com <http://opry99er.com/>
> 
> 
>         yahoo.co. uk
>         <http://ca.mc1101.mail.yahoo.com/mc/compose?to=[email-masked]>>
>         wrote:
> 
>>          
>>         And because Forth is interactive, you can test each little
>>         word individually at the keyboard, immediately. None of this
>>         write code/save/assemble/ load object code/try it rubbish!
>>
>>         etc... Your application is built (or rather 'grown') from lots
>>         of little words. You test each word as you go and move on when
>>         you are happy with it. Notice that RINSE uses FILL to fill the
>>         washer after draining it.
>>
>>         When applications are built like this, they are said to be
>>         "highly factored". You will notice that the program (at least
>>         at this high level) almost reads like english. It doesn't even
>>         look like Forth! You have defined your own DSL (domain
>>         specific language) for controlling an industrial washing machine!
>>
>>
>>             *From:* Owen Brand <owenbrand@opry99er. com>
>>             *Sent:* Thu, 8 April, 2010 22:15:28
>>             So if I'm reading this right, a word can be defined as a
>>             series of other words as well???  This would make things
>>             like screen draws lightning fast and easy to implement!!!
>>              Also, entire sequences of code that determine complex
>>             functions can be pieced together and defined as a word?!?
>>              Holy crap!!  I hope I'm reading this correctly!
>>
>>             Owen Brand
>>             <http://opry99er.com/>Opry99er.com <http://opry99er.com/>
>>
>>             <http://ca.mc1101.mail.yahoo.com/mc/compose?to=[email-masked]>>
>>             wrote:
>>
>>>              
>>>             Yes. Forth really does rock on machines like ours, and is
>>>             also very suitable for embedded devices. And if you ever
>>>             get far enough into it to learn how the compiler itself
>>>             works, your brain will explode. It is SO head smackingly
>>>             simple, it's beautiful.
>>>
>>>             One of the central practices in Forth is that of
>>>             Factoring. Factoring is simply breaking your routines to
>>>             smaller and smaller words, so instead of one word that is
>>>             10's of lines long (as you might in C) you tend to break
>>>             up the routine into smaller chunks, each one a word. This
>>>             helps with the issue of 'stackrobatics' - when you are
>>>             having to juggle lots of things on the stack. You also
>>>             have variables and constants. TurboForth also has VALUEs,
>>>             Forth seems difficult at first (don't get me wrong, it's
>>>             harder than, say XB, but easier than assembly) simply
>>>             because you have to manage the stack, which doesn't even
>>>             exist in other languages.
>>>
>>>             I constantly kick myself that I wrote Forth off as crap
>>>             for so many years. I was so arrogant. Just because I
>>>             couldn't understand it at the time.
>>>
>>>
>>>
>>>                 *From:* Owen Brand <owenbrand@opry99er. com>
>>>                 Wow, I'm just a few pages into the first chapter and
>>>                 the concept is so simple it's beyond brilliant!!!
>>>                  This concept seems to be a streamlined greased
>>>                 lightning version of user-defined SUBS in XB, only
>>>                 much more efficient and straightforward!  It also
>>>                 seems to be the perfect language choice for the /4a,
>>>                 as it has absolute ties to ASCII and would seem to
>>>                 sit cleanly on top of the machine language.  Very
>>>                 <http://opry99er.com/>
>>>                 <http://opry99er.com/>Opry99er.com <http://opry99er.com/>
>>>
>>>                 <markrobertwills@ yahoo.co. uk
>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=[email-masked]>>
>>>                 wrote:
>>>
>>>>                  
>>>>                 <http://tinyurl.com/ydqywa4> <http://tinyurl/>
>>>>                 <http://tinyurl/>http://tinyurl <http://tinyurl/>.
>>>>                 com/ydqywa4
>>>>
>>>>                 This book is AWESOME. You will totally "get" Forth
>>>>                 by the time you finish it. It's an old book, but
>>>>                 don't let that put you off. My (1st edition -
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=owenbrand%40opry99er.com>>
>>>>                 > To: "TI994 A@yahoogroups. com
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=TI994A%40yahoogroups.com>"
>>>>                 <TI994A@yahoogroups. com
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=TI994A%40yahoogroups.com>>
>>>>                 <http://opry99er.com/> <http://opry99er.com/>
>>>>                 <http://opry99er.com/>Opry99er.com
>>>>                 <http://opry99er.com/>
>>>>
>>>>                 > > <http://groups. yahoo.com/group/TI994A/>
>>>>                 <http://groups/> <http://groups/>http://groups
>>>>                 <http://groups/>. <http://yahoo.com/>
>>>>                 group/TI994A/
>>>>                 <http://groups/> <http://groups/>http://groups
>>>>                 <http://groups/>. <http://yahoo.com/>
>>>>                 group/TI994A/ join" ta rget=_blank
>>>>                 <http://groups/> <http://groups/>http://groups
>>>>                 <http://groups/>. <http://yahoo.com/>
>>>>                 group/TI994A/ join
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=TI994A-digest%40yahoogroups.com>">TI994A-digest@
>>>>                 yahoogroups. com
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=TI994A-digest%40yahoogroups.com>
>>>>
>>>>                 &g t;
>>>>
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=TI994A-fullfeatured%40yahoogroups.com>">TI994A-fullfeatured
>>>>                 @yahoogroups. com
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=TI994A-fullfeatured%40yahoogroups.com>
>>>>
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=TI994A-unsubscribe%40yahoogroups.com>"
>>>>
>>>>                 <http://ca.mc1101.mail.yahoo.com/mc/compose?to=TI994A-unsubscribe%40yahoogroups.com>">TI994A-unsubscribe@
>>>>                 yahoogroups. com <http://ca.mc1
>>>>                 101.mail.yahoo.com/mc/compose?to=TI994A-unsubscribe%40yahoogroups.com>
>>>>
>>>>                 <http://docs/> <http://docs/>http://docs
>>>>                 <http://docs/>. <http://yahoo.com/>
>>>>                 > > <http://docs.yahoo.com/info/terms/>
>>>>                 <http://docs/> <http://docs/>http://docs
>>>>                 <http://docs/>. <http://yahoo.com/>yahoo.com/
> ------------------------------------------------------------------------
> 
> *Yahoo! Canada Toolbar :* Search from anywhere on the web and bookmark 
> your favourite sites. Download it now! <http://ca.toolbar.yahoo.com/>
> 
>

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 09:35:05 -0700

Yes, TI FORTH did not include sound or speech capabilities, but they 
were all added later by a few of us.  In many different forms.

Bill S

Owen Brand wrote:
> time.  I also found a reference on this list to Craig Miller's influence 
> in this matter.  He convinced them to release Forth early.  I'm finding 
> this whole thing VERY interesting.  :)  
> 
> Owen Brand
> On Apr 9, 2010, at 5:19 AM, mark wills <[email-masked] 
>> Actually TI Forth probably has more features than TurboForth, however, 
>> it's disadvantage on our little memory contrained computer is that 
>> Forth itself actually lives in RAM. On my TI-Forth setup I have only 
>> 7K free. TurboForth has ~28K of RAM free for your Forth program.
>>
>> TurboForth is faster on some things. Notably video handling. However, 
>> other things seem quite comparable: Loops etc.
>>
>> When you need more space than TurboForth can give, you will reach for 
>> X4th which has awesome memory handling capabilities!
>>
>> Mark
>>
>>
>>     *Sent:* Fri, 9 April, 2010 2:03:02
>>     fast language that is not double interpreted and is
>>     readable!!!!!!!  I think I'm in love.  And ON CART!!  No
>>     coding-assembling-loading object code-running it.  No slow crappy
>>     XB sluggishness.  Ahhh... I can feel a break dance coming on.  :)
>>     I will still continue learning assembly, but this Forth thing...
>>     Wow.  If it has all the features you say (vs. TI Forth which is
>>     lacking many) then I've found my happy place.  
>>
>>     Owen Brand
>>     On Apr 8, 2010, at 6:28 PM, mark wills
>>     <[email-masked] <mailto:markrob
>>     [email-masked]>> wrote:
>>
>>>      
>>>
>>>     code/save/assemble/ load object code/try it rubbish!
>>>
>>>     "highly factored". You will notice that the program (at least at
>>>     this high level) almost reads like english. It doesn't even look
>>>     like Forth! You have defined your own DSL (domain specific
>>>     language) for controlling an industrial washing machine!
>>>
>>>
>>>         series of other words as well???  This would make things like
>>>         screen draws lightning fast and easy to implement!!!  Also,
>>>         entire sequences of code that determine complex functions can
>>>         be pieced together and defined as a word?!?  Holy crap!!  I
>>>         hope I'm reading this correctly!
>>>
>>>         Owen Brand
>>>         On Apr 8, 2010, at 4:33 PM, mark wills <markrobertwills@
>>>>         also very suitable for embedded devices. And if you ever get
>>>>         far enough into it to learn how the compiler itself works,
>>>>         your brain will explode. It is SO head smackingly simple,
>>>>         it's beautiful.
>>>>
>>>>         Factoring is simply breaking your routines to smaller and
>>>>         smaller words, so instead of one word that is 10's of lines
>>>>         long (as you might in C) you tend to break up the routine
>>>>         into smaller chunks, each one a word. This helps with the
>>>>         issue of 'stackrobatics' - when you are having to juggle
>>>>         lots of things on the stack. You also have variables and
>>>>         constants. TurboForth also has VALUEs, which are like
>>>>         I constantly kick myself that I wrote Forth off as crap for
>>>>         so many years. I was so arrogant. Just because I couldn't
>>>>         understand it at the time.
>>>>
>>>>
>>>>
>>>>             Wow, I'm just a few pages into the first chapter and the
>>>>             concept is so simple it's beyond brilliant!!!  This
>>>>             concept seems to be a streamlined greased lightning
>>>>             version of user-defined SUBS in XB, only much more
>>>>             efficient and straightforward!  It also seems to be the
>>>>             perfect language choice for the /4a, as it has absolute
>>>>             ties to ASCII and would seem to sit cleanly on top of
>>>>             the machine language.  Very good suggestion on this book!!
>>>>
>>>>             Owen Brand
>>>>             <http://tinyurl> <http://tinyurl>http://tinyurl. com/ydqywa4
>>>>
>>>>             This book is AWESOME. You will totally "get" Forth by
>>>>             the time you finish it. It's an old book, but don't let
>>>>             that put you off. My (1st edition - woohoo!) copy goes
>>>>             everywhere with me, even the toilet!
>>>>
>>>>             M
>>>>
>>>>             <mailto:TI994A%40yahoogroups.com>" <TI994A@yahoogroups.
>>>>             com <mailto:TI994A%40yahoogroups.com>>
>>>>             <http://groups> <http://groups>
>>>>             <http://groups> <http://groups>
>>>>             <http://groups> <http://groups>
>>>>             <http://docs> <http://docs> <http://docs>http://docs.
>>>>             <http://yahoo.com/> <http://yahoo.com/>
>>>>             <http://docs> <http://docs>http://docs.
>>>>             <http://yahoo.com/> <http://yahoo.com/>
>>>>             info/terms/

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 12:39:24 -0400

Thanks--- I understand the concept from reading the book, but I was  
making the point that it seems a bit backwards from my current  
understanding of programming.  It's a GOOD thing though... The more I  
read, the more excited I'm getting about the language.  I think I'm  
going to take up the banner, so to speak.  :) I really love the style  
and nature of XB and I'll always use it... But for features and speed,  
for freshness and fun, I'll be a "Forther" from this point on as  
well.  :)  I hope all of you get a TurboForth cart-- get ready for  
some sweet a** games guys!!!  I think (and I'm not an authority) these  
carts will be very cheap and I bet Tursi will implement a TurboForth  
cart into Classic99 once it's tested and released.  At least I hope he  
will.  This will be Willsy's legacy... I hope, Bill, you finish  
X4th99... With all the new programmers entering the fold over at  
Atariage, this could be massive.  :)

Owen Brand  <-----super excited
Opry99er.com

On Apr 9, 2010, at 12:05 PM, fdos <[email-masked]> wrote:

>> there
>> assume,
>>> That's the high level definition for a washing machine. Now you  
>>> define
>>> the other words:
>>>
>>> You
>>>> smaller
> Yahoo! Groups Links

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 09:50:22 -0700

Eat your own words then floss! :-)  Oops, not quite right.

mark wills wrote:
> It's a 40 column editor, it windows like FWEB/TI-Writer. If I can get 
> the code to run in TI994W I will add 80 column support too.
> 
> Mark
> 
> 
>     *Sent:* Fri, 9 April, 2010 13:41:37
>     On Apr 9, 2010, at 5:33 AM, mark wills <[email-masked]
>>     languages: In XB, for example, things like + - * etc are
>>     OPERATORS. They don't work like statements or functions. They are
>>     kind of special. It's different in Forth. + is JUST ANOTHER WORD
>>     in Forth. It is a little program in it's own right, that removes
>>     two values from the top of the stack, adds them, and puts the
>>     result on the stack.
>>
>>     Welcome to Forth. You may need to wear a helmet to hold your
>>     brains in. My head exploded when I started to 'get it'.
>>
>>     Mark
>>
>>
>>         Okay Mark-- I may be getting ahead of myself here, but in
>>         Forth, there are a couple unique characteristics that I am
>>         reading about in detail right now.  
>>
>>         1) Postfix notation 
>>         2) LIFO stack operation
>>
>>         I'm practicing them.  :) The postfix notation really just
>>         seems to be a "symptom" (for lack of a better "word") of the
>>         Last In First Out methodology.  It seems a bit strange to me,
>>         but the more I type and practice, the more sense it makes.
>>          Your documentation will, I assume, discuss in detail the way
>>         this concept works with TurboForth?  I will be DLing a Forth
>>         terminal emulator in the morning so I can get started... :)
>>         Fun fun fun!
>>
>>         Owen Brand
>>>         etc... Your application is built (or rather 'grown') from
>>>         lots of little words. You test each word as you go and move
>>>         on when you are happy with it. Notice that RINSE uses FILL to
>>>         fill the washer after draining it.
>>>
>>>         at this high level) almost reads like english. It doesn't
>>>         even look like Forth! You have defined your own DSL (domain
>>>>             Yes. Forth really does rock on machines like ours, and
>>>>             is also very suitable for embedded devices. And if you
>>>>             ever get far enough into it to learn how the compiler
>>>>             itself works, your brain will explode. It is SO head
>>>>             smackingly simple, it's beautiful.
>>>>
>>>>             lightning version of user-defined SUBS in XB
>>>>
>>>>             smaller and smaller words, so instead of one word that
>>>>             is 10's of lines long (as you might in C) you tend to
>>>>             break up the routine into smaller chunks, each one a
>>>>             word. This helps with the issue of 'stackrobatics' -
>>>>             when you are having to juggle lots of things on the
>>>>             stack. You also have variables and constants. TurboForth
>>>>             also has VALUEs, which are like VARIABLEs but have a
>>>>             friendlier syntax.
>>>>
>>>>>                 > ymailto="mailto:TI994A-unsubscribe@ yahoogroups.
>>>>>                 com <mailto:TI994A-unsubscribe%40yahoogroups.com>"
>>>>>                 <http://docs> <http://docs>
>>>>>                 <http://docs> <http://docs>

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 09:52:27 -0700

MDOS Forth+ has an on-line glossary!  X4th99 is planned to have it also.

Bill S

Owen Brand wrote:
> essentially a commented dictionary of the user-defined words in memory. 
>  If you create "CUT"---
> 
> definitions.  Sorry if I'm not clear-- just mixing a bunch of info from 
> the web and the book you suggested and formulating ideas.  :) 
> 
> Owen Brand
> On Apr 9, 2010, at 11:23 AM, mark wills <[email-masked] 
> <mailto:[email-masked]>> wrote :
> 
>>  
>>
>>     Hey man--- will you have a built-in, "comment-editable" glossary
>>     in TurboForth?  Also, is it a 32 column editor?  Sorry for all the
>>     On Apr 9, 2010, at 5:33 AM, mark wills
>>>>         You get the idea... Then you go and define NOT-FULL
>>>>         FAUCET-ON etc... Your application is built (or rather
>>>>         'grown') from lots of little words. You test each word as
>>>>         you go and move on when you are happy with it. Notice that
>>>>         "highly factored". You will notice that the program (at
>>>>         least at this high level) almost reads like english. It
>>>>         doesn't even look like Forth! You have defined your own DSL
>>>>         (domain specific language) for controlling an industrial
>>>>         washing machine!
>>>>
>>>>
>>>>             like screen draws lightning fast and easy to
>>>>             implement!!!  Also, entire sequences of code that
>>>>             determine complex functions can be pieced together and
>>>>>             Factoring. Factoring is simply breaking your routines
>>>>>             to smaller and smaller words, so instead of one word
>>>>>             that is 10's of lines long (as you might in C) you tend
>>>>>             to break up the routine into smaller chunks, each one a
>>>>>             stack. You also have variables and constants.
>>>>>             TurboForth also has VALUEs, which are like VARIABLEs
>>>>>             but have a friendlier syntax.
>>>>>
>>>>>             Forth seems difficult at first (don't get me wrong,
>>>>>             it's harder than, say XB, but easier than assembly)
>>>>>             simply because you have to manage the stack, which
>>>>>             doesn't even exist in other languages.
>>>>>
>>>>>                 Wow, I'm just a few pages into the first chapter
>>>>>                 and the concept is so simple it's beyond
>>>>>                 brilliant!!!  This concept seems to be a
>>>>>                 streamlined greased lightning version of
>>>>>                 user-defined SUBS in XB, only much more efficient
>>>>>                 and straightforward!  It also seems to be the
>>>>>                 perfect language choice for the /4a, as it has
>>>>>                 absolute ties to ASCII and would seem to sit
>>>>>>                 <http://tinyurl> <http://tinyurl>
>>>>>>                 <http://groups> <http://groups> <http://groups>
>>>>>>                 <http://groups> <http://groups> <http://groups>
>>>>>>                 group/TI994A/ join" target=_blank
>>>>>>                 <http://groups> <http://groups> <http://groups>
>>>>>>                 <http://docs> <http://docs> <http://docs>
>>>>>>                 <http://docs> <http://docs> <http://docs>

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 09:58:53 -0700

Owen,

Gotcha!  My biggest problem was programming complex algorithms using 
conventional programming languages that use prefix notation with all 
those open and close parenthesis.  I spent days debugging that stuff, 
but post fix notation makes it easy as eating pie once you get the hang 
of it.

Bill S

Owen Brand wrote:
> On Apr 9, 2010, at 12:05 PM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  >> Opry99er.com <http://Opry99er.com <http://Opry99er.com>>
>  >>
>  >>
> <mailto:markrobertwills%40yahoo.co.uk>
>  >> <mailto:mark [email-masked] 
> <mailto:robertwills%40yahoo.co.uk>>> wrote:
>  >>
>  >>>
>  >>>
>  >>> *From:* Owen Brand <[email-masked] 
>  >>> *To:* "[email-masked] <mailto:TI994A%40yahoogroups.com>" 
> <[email-masked] <mailto:TI994A%40yahoogroups.com>>**Sent:*
>  >>> * <http://Opry99er.com <http://Opry99er.com>>Opry99er.com 
> <http://Opry99er.com <http://Opry99er.com>>*
>  >>> *
>  >>> <[email-masked] <mailto:markrobertwills%40yahoo.co.uk>
>  >>> <mailto:[email-masked] 
> <mailto:markrobertwills%40yahoo.co.uk>>>
>  >>> wrote:
>  >>>
>  >>> *
>  >>>> * * * *
>  >>>> * *
>  >>>>
>  >>>> * <http://Opry99er.com <http://Opry99er.com>> <http://Opry99er.com 
> <http://Opry99er.com>>Opry99er.com
>  >>>> <http://Opry99er.com <http://Opry99er.com>>*
>  >>>> *
>  >>>> yahoo.co. uk <mailto:[email-masked] 
> <mailto:markrobertwills%40yahoo.co.uk>>> wrote:
>  >>>>
>  >>>> *
>  >>>>> * * * *
>  >>>>> * *
>  >>>>>
>  >>>>> <http://tinyurl.com/ydqywa4 <http://tinyurl.com/ydqywa4>> 
> <http://tinyurl>
>  >>>>> <http://Opry99er.com <http://Opry99er.com>> <http://Opry99er.com 
> <http://Opry99er.com>>
>  >>>>> <http://Opry99er.com <http://Opry99er.com>>Opry99er.com 
> <http://Opry99er.com <http://Opry99er.com>>
>  >>>>>
>  >>>>>>> <http://groups.yahoo.com/group/TI994A/ 
> <http://groups.yahoo.com/group/TI994A/>> <http://groups>
>  >>>>> <http://groups>http://groups. <http://yahoo.com/ <http://yahoo.com/>>
>  >>>>> <http://yahoo.com/ <http://yahoo.com/>>yahoo.com/ 
> <http://yahoo.com/ <http://yahoo.com/>> group/
>  >>>>> TI994A/
>  >>>>>
>  >>>>>> href=" <http://groups.yahoo.com/group/TI994A/join 
> <http://groups.yahoo.com/group/TI994A/join>>
>  >>>>> <http://yahoo.com/ <http://yahoo.com/>> <http://yahoo.com/ 
> <http://yahoo.com/>>yahoo.com/
>  >>>>> <http://yahoo.com/ <http://yahoo.com/>> group/TI994A/ join" 
> target=_blank
>  >>>>>>> <http://groups.yahoo.com/group/TI994A/join 
> <http://groups.yahoo.com/group/TI994A/join>>
>  >>>>> <http://yahoo.com/ <http://yahoo.com/>> <http://yahoo.com/ 
> <http://yahoo.com/>>yahoo.com/
>  >>>>> <http://yahoo.com/ <http://yahoo.com/>> group/TI994A/ join
>  >>>>> (Yahoo! ID
>  >>>>>> required)
>  >>>>>
>  >>>>>> href=" <http://docs.yahoo.com/info/terms/ 
> <http://docs.yahoo.com/info/terms/>> <http://docs>
>  >>>>> <http://docs>http://docs. <http://yahoo.com/ <http://yahoo.com/>>
>  >>>>> <http://yahoo.com/ <http://yahoo.com/>>yahoo.com/ 
> <http://yahoo.com/ <http://yahoo.com/>>
>  >>>>>>> <http://docs.yahoo.com/info/terms/ 
> <http://docs.yahoo.com/info/terms/>> <http://docs>
>  >>>>> <http://docs>http://docs. <http://yahoo.com/ <http://yahoo.com/>>
>  >>>>> <http://yahoo.com/ <http://yahoo.com/>>yahoo.com/ 
> <http://yahoo.com/ <http://yahoo.com/>> info/
>  >>>>> terms/
>  >>>>> *
>  >>>>>
>  >>>>> * *
>  >>>>> * *
>  >>>> *
>  >>>>
>  >>>> *
>  >>>>
>  >>>> * *
>  >>>> * *
>  >>> *
>  >>>
>  >>> *
>  >>>
>  >>> * *
>  >>> * *
>  >> * *
>  >> * *
>  >> **
>  >> * *
>  >
>  >

---

From: mark wills <[email-masked]>
Date: Fri, 9 Apr 2010 19:18:43 +0000 (GMT)

Yes. I was very surprised at how quickly it felt quite natural thinking in RPN. 

I'm still not getting the glossary. Do you mean help files? like HELP DUP
?

M

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Fri, 9 April, 2010 17:58:53

Gotcha!  My biggest problem was programming complex algorithms 
> using 
of it.

Bill S

Owen Brand wrote:
> <-----super excited
> On Apr 9, 2010, at 
> 12:05 PM, fdos <> href="mailto:[email-masked]">[email-masked] 
> 
>  > 
>  > LIFO - last in first out (think of a stack and push an 
> item on top
>  > then
>  > pop the top item off. It 
> is the same item. Push two items on to the
>  > stack and pop the 
> top item off. It is the last item that was pushed
>  > 
> on
>  > to the stack. Forth has a minimum of two stacks; one is 
> known as the
>  > parameter stack and the other is known as the 
> return stack. These two
>  > stacks are implementation dependent 
> as they may grow up or grow down.
>  > Read more about these 
> stacks in Starting Forth.
>  >
>  > Bill 
> S
>  >
>  > Owen Brand wrote:
>  
> >>
>  >>
>  >> Okay Mark-- I may be 
> getting ahead of myself here, but in Forth,
>  >> 
> there
>  >> are a couple unique characteristics that I am 
> reading about in detail
>  >> right now.
>  
> >>
>  >> 1) Postfix notation
>  >> 2) 
> LIFO stack operation
>  >>
>  >> Both of these 
> are counter-intuitive to my linear brain... But I'm
>  >> 
>  >> methodology. It seems a bit strange to me, but the 
> more I type and
>  >> practice, the more sense it makes. Your 
> documentation will, I
>  >> assume,
>  >> 
> discuss in detail the way this concept works with TurboForth? I
>  
> >> will be
>  >> DLing a Forth terminal emulator in the 
> morning so I can get
>  >> started...
>  >> :) 
> Fun fun fun!
>  >>
>  >> Owen 
> Brand
>  >> Opry99er.com <> target=_blank >http://Opry99er.com <> target=_blank >http://Opry99er.com>>
>  
> >>
>  >>
>  >> On Apr 8, 2010, at 6:28 
> PM, mark wills <> href="mailto:[email-masked]">[email-masked] 
> 
>  >> 
> <mailto:mark > href="mailto:[email-masked]">[email-masked] 
> 
>  >>>
>  >>>
> >>> That's exactly right. Not only is it possible, it is 
> positively
>  >>> encouraged.
>  
> >>>
>  >>> And because Forth is interactive, you 
> can test each little word
>  >>> individually at the 
> keyboard, immediately. None of this write
>  >>> 
>  >>> There's an example in Brodie's 
> book:
>  >>>
>  >>> : WASHER FILL WASH 
> RINSE SPIN ;
>  >>>
>  >>> That's the 
> high level definition for a washing machine. Now you
>  >>> 
> define
>  >>> the other words:
>  
> >>>
>  >>> : FILL WHILE NOT-FULL BEGIN FAUCET-ON 
> FULL? UNTIL FAUCET-OFF ;
>  >>> : WASH 20 0 DO CLOCKWISE 
> MOTOR-ON 5 MINUTES WAIT MOTOR-OFF
>  >>> ANTI-CLOCKWISE 
>  >>> : RINSE EMPTY 5 MINUTES 
> WAIT FILL ;
>  >>>
>  >>> You get the 
> idea... Then you go and define NOT-FULL FAUCET-ON etc...
>  
>  >>> words. You test each word as you go and move 
> on when you are happy
>  >>> with it. Notice that RINSE uses 
> FILL to fill the washer after
>  >>> draining 
> it.
>  >>>
>  >>> When applications are 
> built like this, they are said to be "highly
>  >>> 
>  >>> You
>  >>> have defined 
> your own DSL (domain specific language) for controlling
>  
>  >>>
>  >>> *From:* Owen 
> Brand <> href="mailto:[email-masked]">[email-masked] 
> 
>  >>> *To:* "> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked] 
> <mailto:TI994A%40yahoogroups.com>" 
> <> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked] 
> <mailto:TI994A%40yahoogroups.com>>**Sent:*
>  >>> 
>  >>> *Subject:* Re: [TI994A] 
> TurboForth preparation
>  >>> **
>  
> >>>
>  >>>
>  >>> 
> *
>  >>> *So if I'm reading this right, a word can be 
> defined as a series
>  >>> of other words as well??? This 
> would make things like screen
>  >>> draws lightning fast 
> and easy to implement!!! Also, entire
>  >>> sequences of 
> code that determine complex functions can be pieced
>  >>> 
> together and defined as a word?!? Holy crap!! I hope I'm
>  
> >>> reading
>  >>> this correctly!
>  
> >>>
>  >>> Owen Brand*
>  >>> * 
> <http://Opry99er.com <> href="http://Opry99er.com" target=_blank 
> >http://Opry99er.com>>Opry99er.com 
> <> href="http://Opry99er.com" target=_blank >http://Opry99er.com <> href="http://Opry99er.com" target=_blank 
> >http://Opry99er.com>>*
>  >>> *
>  
>  >>> 
> <> href="mailto:[email-masked]">[email-masked] 
>  >>> 
> <mailto:> href="mailto:[email-masked]">[email-masked] 
> 
>  >>>
>  >>> 
>  >>>> * * * *
>  >>>> * 
>  >>>>
>  >>>> *Yes. Forth 
> really does rock on machines like ours, and is also
>  
>  >>>> enough into it to learn how the compiler 
> itself works, your
>  >>>> brain
>  
>  >>>>
>  >>>> Pretty 
> much all the examples (as far as I know) in the book I
>  
> >>>> mentioned will run in TurboForth.
>  
> >>>>
>  >>>>> This concept seems to be a 
> streamlined greased lightning version
>  >>>> of 
> user-defined SUBS in XB
>  >>>>
>  
> Factoring.
>  >>>> Factoring is simply breaking your 
> routines to smaller and
>  >>>> smaller
>  
>  >>>> might in C) you tend to break up the routine 
> into smaller
>  >>>> chunks,
>  
>  >>>> when you are having to juggle lots of things on 
> the stack. You
>  >>>> also have variables and constants. 
> TurboForth also has VALUEs,
>  >>>> which are like 
>  >>>> Forth seems difficult at first 
> (don't get me wrong, it's harder
>  >>>> than, say XB, 
> but easier than assembly) simply because you have
>  >>>> 
> to manage the stack, which doesn't even exist in other
>  
> >>>> languages.
>  >>>>
>  
> so
>  >>>> many years. I was so arrogant. Just because I 
> couldn't
>  >>>> understand
>  
> >>>> it at the time.
>  >>>>
>  
> >>>>
>  >>>> *
>  
> >>>>
>  >>>> *
>  >>>> 
> *
>  >>>> **From:* Owen Brand <owenbrand@opry99er. 
> com>
>  >>>> *To:* "TI994A@yahoogroups .com" 
>  >>>> *Sent:* Thu, 8 
> April, 2010 21:16:49
>  >>>> *Subject:* Re: [TI994A] 
> TurboForth preparation
>  >>>>
>  
> >>>>
>  >>>>
>  >>>> 
> *
>  >>>> *Wow, I'm just a few pages into the first 
> chapter and the
>  >>>> concept is so simple it's beyond 
> brilliant!!! This concept
>  >>>> seems to be a 
>  >>>> 
>  >>>> choice for the /4a, as it has absolute 
> ties to ASCII and
>  >>>> would seem to sit cleanly on 
> top of the machine language.
>  >>>> Very good suggestion 
> on this book!!
>  >>>>
>  >>>> 
> Owen Brand*
>  >>>> * <> target=_blank >http://Opry99er.com <> target=_blank >http://Opry99er.com>> <> target=_blank >http://Opry99er.com 
> <> href="http://Opry99er.com" target=_blank 
> >http://Opry99er.com>>Opry99er.com
>  >>>> 
> <http://Opry99er.com <> href="http://Opry99er.com" target=_blank 
> >http://Opry99er.com>>*
>  >>>> *
>  
> <markrobertwills@
>  >>>> yahoo.co. uk <mailto:> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked] 
> 
>  >>>>
>  >>>> 
>  >>>>> * * * *
>  >>>>> 
>  >>>>>
>  >>>>> *I can 
> *HIGHLY* recommend Starting Forth by Leo Brodie.
>  
> >>>>>
>  >>>>> <> href="http://tinyurl.com/ydqywa4" target=_blank >http://tinyurl.com/ydqywa4 
> <> >http://tinyurl.com/ydqywa4>> 
> <> target=_blank >http://tinyurl>
>  >>>>> <> href="http://tinyurl" target=_blank >http://tinyurl>> href="http://tinyurl" target=_blank >http://tinyurl. 
> com/ydqywa4
>  >>>>>
>  
> the
>  >>>>> time you finish it. It's an old book, but 
> don't let that
>  >>>>> put
>  
>  >>>>> with me, even the 
>  >>>>>
>  >>>>> 
>  >>>>>
>  >>>>> ----- 
> Original Message ----
>  >>>>>> From: Owen Brand 
> <owenbrand@opry99er. com
>  >>>>> 
>  >>>>> 
>  >>>>>> In getting 
> prepared for the highly anticipated TurboForth
>  
> >>>>> release, I
>  
> >>>>>>
>  >>>>> have started reading 
> through the SAMS TI Forth beginners
>  >>>>> guide. 
> It
>  >>>>>> is
>  >>>>> 
> very limited in content and doesn't actually really teach
>  
> >>>>> you
>  >>>>>> Forth. 
> I
>  >>>>> also have a manual and system diskette for 
> Super4th
>  >>>>> (which I
>  
> >>>>>> can't
>  >>>>> use... No 
> Supercart). So I am trying to find some online
>  
> >>>>>> references
>  >>>>> on Forth 
> development. Any good tutorials on wht or
>  >>>>>> 
> Internet? Bill,
>  >>>>> you there?
>  
> >>>>>
>  >>>>> I'm gonna 
> start
>  >>>>>> some serious re-tooling of my dev 
> environment,
>  >>>>> hopefully I'll be 
> able
>  >>>>>> to get my hands on a modded 32-16 
> console--if
>  >>>>> so I'll be modifying 
> my
>  >>>>>> CF7 in the way Richard has done-- All 
> of this
>  >>>>> is geared towards going
>  
>  >>>>> project, 2 utilities
>  
>  >>>>> which I'm not talking
>  
>  >>>>> of a classic arcade
>  
>  >>>>> info, I will
>  >>>>>
>  >>>>> 
>  >>>>>> Brand
> >>>>> <> >http://Opry99er.com <> >http://Opry99er.com>> <> >http://Opry99er.com 
> <> target=_blank >http://Opry99er.com>>
>  
> >>>>> <> >http://Opry99er.com <> >http://Opry99er.com>>Opry99er.com 
> <> href="http://Opry99er.com" target=_blank >http://Opry99er.com <> href="http://Opry99er.com" target=_blank 
> >http://Opry99er.com>>
>  
> >>>>>
>  >>>>> ------------ --------- 
> --------- ------
>  >>>>>
>  
> >>>>> Yahoo!
>  >>>>>> Groups 
> Links
>  >>>>>
>  
> >>>>>>
>  >>>>>>> <> href="http://groups.yahoo.com/group/TI994A/" target=_blank 
> <> href="http://groups.yahoo.com/group/TI994A/" target=_blank 
> >http://groups.yahoo.com/group/TI994A/>> <> target=_blank >http://groups>
>  >>>>> <> href="http://groups" target=_blank >http://groups>> target=_blank >http://groups. <> >http://yahoo.com/ <> >http://yahoo.com/>>
>  >>>>> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/>>yahoo.com/ 
> 
> <http://yahoo.com/ 
> <http://yahoo.com/>> 
> group/
>  >>>>> TI994A/
>  
> >>>>>
>  >>>>>> href=" <> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> <> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join>>
>  
> >>>>> <> >http://groups> <> >http://groups>> >http://groups.
>  >>>>> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/>> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> <> href="http://yahoo.com/" target=_blank 
> >http://yahoo.com/>>yahoo.com/
>  >>>>> 
> <http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/>> 
> group/TI994A/ join" 
> target=_blank
>  
> >>>>>>> <> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> <> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join>>
>  
> >>>>> <> >http://groups> <> >http://groups>> >http://groups.
>  >>>>> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/>> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> <> href="http://yahoo.com/" target=_blank 
> >http://yahoo.com/>>yahoo.com/
>  >>>>> 
> <http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/>> 
> group/TI994A/ join
>  >>>>> (Yahoo! ID
>  
> >>>>>> required)
>  
> >>>>>
>  >>>>>> 
>  >>>>> 
>  >>>>>
>  >>>>> 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>">TI994A-
>  
> >>>>> fullfeatured
>  >>>>> 
> @yahoogroups. com <mailto:TI994A-fullfeatured
>  
> >>>>> %40yahoogroups.com>
>  
> >>>>>
>  >>>>>> 
>  >>>>> 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>">TI994A-
>  
> >>>>> unsubscribe@
>  >>>>> 
> yahoogroups. com <mailto:TI994A-unsubscribe
>  
> >>>>> %40yahoogroups.com>
>  
> >>>>>
>  >>>>>> href=" <> href="http://docs.yahoo.com/info/terms/" target=_blank 
> <> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/>> <> target=_blank >http://docs>
>  >>>>> <> href="http://docs" target=_blank >http://docs>> target=_blank >http://docs. <> >http://yahoo.com/ <> >http://yahoo.com/>>
>  >>>>> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/>>yahoo.com/ 
> 
> <http://yahoo.com/ 
> <> >http://yahoo.com/>>
>  >>>>> info/terms/" 
> target=_blank
>  >>>>>>> <> href="http://docs.yahoo.com/info/terms/" target=_blank 
> <> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/>> <> target=_blank >http://docs>
>  >>>>> <> href="http://docs" target=_blank >http://docs>> target=_blank >http://docs. <> >http://yahoo.com/ <> >http://yahoo.com/>>
>  >>>>> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/>>yahoo.com/ 
> 
> <http://yahoo.com/ 
> <http://yahoo.com/>> 
> info/
>  >>>>> terms/
>  
> >>>>> *
>  >>>>>
>  
> >>>>> * *
>  >>>>> * *
>  
> >>>> *
>  >>>>
>  >>>> 
> *
>  >>>>
>  >>>> * 
> *
>  >>>> * *
>  >>> *
>  
> >>>
>  >>> *
>  
> >>>
>  >>> * *
>  >>> * 
> *
>  >> * *
>  >> * *
>  >> 
> **
>  >> * *
>  >
>  
> >
>  > ------------------------------------
>  
> >
>  > Yahoo! Groups Links
>  >
>  
> >
>  >
> 
> 
> 

Yahoo! Groups 
> Links

    (Yahoo! ID 

    > href="mailto:[email-masked]">[email-masked]

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 15:26:49 -0400

The examples online look like a simple list.

+ Adds 2 numbers
- Subtracts 2 numbers
ASS Makes me look like an ass
BAIT Baits Mark into a fight
CRACK Forces Mark to smoke crack

Basically it gives you every word in memory and allows you to comment  
on them.  This is sort of a tracking mechanism.  I read something  
about how the Forth in question could save these all to a text file on  
disk and could be called up by a word.

. GLOSSARY

It allows you to keep track of all your words and what they do.  :)

Owen Brand
Opry99er.com

On Apr 9, 2010, at 3:18 PM, mark wills <[email-masked]>  
wrote:

> > 12:05 PM, fdos <>  
> href="mailto:[email-masked]">[email-masked]
> >
> >  > LIFO - last in first out (think of a stack and push an
> > item on top
> >  > then
> >  > pop the top item off. It
> >  > stack and pop the
> >  > Bill
> >  >> Okay Mark-- I may be
> >  >> 2)
> >  >> Both of these
> >  >> DLing a Forth terminal emulator in the
> > morning so I can get
> >  >> started...
> >  >> :)
> > Fun fun fun!
> >  >>
> >  >> Owen
> > Brand
> >  >> Opry99er.com <> target=_blank >http://Opry99er.com <>  
> target=_blank >http://Opry99er.com>>
> >
> > >>
> >  >>
> >  >> On Apr 8, 2010, at 6:28
> > PM, mark wills <>  
> > <mailto:mark >  
> href="mailto:[email-masked]">[email-masked]
> >
> >  >>> encouraged.
> >  >>> individually at the
> >  >>> That's the
> >  >>> : WASH 20 0 DO CLOCKWISE
> >  >>> ANTI-CLOCKWISE
> >  >>> You get the
> >  >>> draining
> >  >>> When applications are
> >  >>> have defined
> >  >>> *From:* Owen
> >  >>> *To:* "> ymailto="mailto:[email-masked]"
> >  >>> sequences of
> > <> href="http://Opry99er.com" target=_blank >http://Opry99er.com  
> > <>  
> > <mailto:>  
> >  >>>> *Yes. Forth
> >  >>>> enough into it to learn how the compiler
> > itself works, your
> >  >>>> brain
> >
> >  >>>> Pretty
> >  >>>> might in C) you tend to break up the routine
> > into smaller
> >  >>>> chunks,
> >
> >  >>>> than, say XB,
> >  >>>> many years. I was so arrogant. Just because I
> > couldn't
> >  >>>> understand
> >
> > >>>> it at the time.
> >  >>>>
> >
> > >>>>
> >  >>>> *
> >
> > >>>>
> >  >>>> *
> >  >>>>
> > *
> >  >>>> * <> target=_blank >http://Opry99er.com <> target=_blank >http://Opry99er.com 
> >> <> target=_blank >http://Opry99er.com
> >  >>>> yahoo.co. uk <mailto:> ymailto="mailto:[email-masked] 
> "
> >  
> >  >>>>> *I can
> >  >>>>> <> href="http://tinyurl.com/ydqywa4" target=_blank >http://tinyurl.com/ydqywa4
> >  >>>>> <> href="http://tinyurl" target=_blank >http://tinyurl>>  
> href="http://tinyurl" target=_blank >http://tinyurl.
> > com/ydqywa4
> >  >>>>>
> >
> >  >>>>> time you finish it. It's an old book, but
> > don't let that
> >  >>>>> put
> >
> >  >>>>> with me, even the
> >  >>>>>> In getting
> >  >>>>> have started reading
> >  >>>>> guide.
> >  >>>>> also have a manual and system diskette for
> > Super4th
> >  >>>>> (which I
> >
> > >>>>>> can't
> >  >>>>> use... No
> >  >>>>> on Forth
> >  >>>>> I'm gonna
> >  >>>>> so I'll be modifying
> > <> href="http://Opry99er.com" target=_blank >http://Opry99er.com  
> >  >>>>>> Groups
> > >http://groups.yahoo.com/group/TI994A/>> <> target=_blank >http://groups 
> >
> >  >>>>> <> href="http://groups" target=_blank >http://groups>>  
> target=_blank >http://groups. <> >http://yahoo.com/ <> >http://yahoo.com/ 
> >>
> >  >>>>> <> href="http://yahoo.com/" target=_blank >http:// 
> yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> >>yahoo.com/
> >
> > <http://yahoo.com/
> > <http://yahoo.com/>>
> > group/
> >  >>>>> TI994A/
> >
> > >>>>>
> >  >>>>>> href=" <> href="http://groups.yahoo.com/group/TI994A/join"  
> target=_blank
> >  >>>>> <> href="http://yahoo.com/" target=_blank >http:// 
> yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> >> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/
> > <http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> >>
> > group/TI994A/ join"
> > target=_blank
> >
> >  >>>>> <> href="http://yahoo.com/" target=_blank >http:// 
> yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> >> <> href="http://yahoo.com/" target=_blank >http://yahoo.com/
> > <http://yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> >>
> > group/TI994A/ join
> >  >>>>> (Yahoo! ID
> >
> > >>>>>> required)
> >
> > >>>>>
> >  >>>>>>
> >  >>>>>> href=" <> href="http://docs.yahoo.com/info/terms/"  
> target=_blank
> >  >>>>> <> href="http://docs" target=_blank >http://docs>>  
> target=_blank >http://docs. <> >http://yahoo.com/ <> >http://yahoo.com/ 
> >>
> >  >>>>> <> href="http://yahoo.com/" target=_blank >http:// 
> yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> >>yahoo.com/
> >
> > <http://yahoo.com/
> > <> >http://yahoo.com/>>
> >  >>>>> info/terms/"
> > target=_blank
> >  >>>>> <> href="http://docs" target=_blank >http://docs>>  
> target=_blank >http://docs. <> >http://yahoo.com/ <> >http://yahoo.com/ 
> >>
> >  >>>>> <> href="http://yahoo.com/" target=_blank >http:// 
> yahoo.com/ <> href="http://yahoo.com/" target=_blank >http://yahoo.com/ 
> >>yahoo.com/
> >
> > <http://yahoo.com/
> > <http://yahoo.com/>>
> > info/
> >  >>>>> terms/
> >
> > >>>>> *
> >  >>>>>
> >
> > >>>>> * *
> >  >>>>> * *
> >
> > >>>> *
> >  >>>>
> >  >>>>
> > *
> >  >>>>
> >  >>>> *
> > *
> >  >>>> * *
> >  >>> *
> >
> > >>>
> >  >>> *
> >
> > >>>
> >  >>> * *
> >  >>> *
> > *
> >  >> * *
> >  >> * *
> >  >>
> > **
> >  >> * *
> >  >
> >
> > >

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 12:35:57 -0700

Owen,

I don't know where that explanation comes from.  Jut look in the TI 
FORTH manual appendix D THE TI FORTH GLOSSARY.  It's every word in the 
Forth resident dictionary, but not any of the words that may be added by 
the user.

Bill S

Owen Brand wrote:
> Basically it gives you every word in memory and allows you to comment on 
> them.  This is sort of a tracking mechanism.  I read something about how 
> the Forth in question could save these all to a text file on disk and 
> could be called up by a word.
> 
> . GLOSSARY
> 
> On Apr 9, 2010, at 3:18 PM, mark wills <[email-masked] 
>> > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>> > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>> > 12:05 PM, fdos <> href="mailto:[email-masked] 
>> <mailto:fdosbrs%40frontiernet.net>">[email-masked] 
>> <mailto:fdosbrs%40frontiernet.net>
>> >
>> >  >> Opry99er.com <http://Opry99er.com> <> target=_blank > 
>> <http://Opry99er.com>http://Opry99er.com <> target=_blank > 
>> <http://Opry99er.com>http://Opry99er.com>>
>> > 
>> > >>
>> >  >>
>> >  >> On Apr 8, 2010, at 6:28
>> > PM, mark wills <> href="mailto:[email-masked] 
>> <mailto:markrobertwills%40yahoo.co.uk>">[email-masked] 
>> > <mailto:markrobertwills%40yahoo.co.uk <http://co.uk>>
>> >  >>
>> > <mailto:mark > href="mailto:[email-masked] 
>> <mailto:robertwills%40yahoo.co.uk>">[email-masked] 
>> <mailto:robertwills%40yahoo.co.uk>
>> >
>> > <mailto:robertwills%40yahoo.co.uk <http://co.uk>>>> wrote:
>> > 
>> > >>
>> >  >>>
>> >  >>>
>> > 
>> > Brand <> href="mailto:[email-masked] 
>> <mailto:owenbrand%40opry99er.com>">[email-masked] 
>> <mailto:owenbrand%40opry99er.com>
>> >
>> >  >>> *To:* "> ymailto="mailto:[email-masked] 
>> > href="mailto:[email-masked] 
>> <mailto:TI994A%40yahoogroups.com>">[email-masked] 
>> <mailto:TI994A%40yahoogroups.com>
>> > <> ymailto="mailto:[email-masked] 
>> > href="mailto:[email-masked] 
>> <mailto:TI994A%40yahoogroups.com>">[email-masked] 
>> <mailto:TI994A%40yahoogroups.com>
>> > < <http://Opry99er.com>http://Opry99er.com <> href=" 
>> <http://Opry99er.com>http://Opry99er.com" target=_blank
>> > > <http://Opry99er.com>http://Opry99er.com>>Opry99er.com
>> > <> href=" <http://Opry99er.com>http://Opry99er.com" target=_blank > 
>> <http://Opry99er.com>http://Opry99er.com <> href=" 
>> <http://Opry99er.com>http://Opry99er.com" target=_blank
>> > > <http://Opry99er.com>http://Opry99er.com>>*
>> >  >>> *
>> > 
>> > <> href="mailto:[email-masked] 
>> <mailto:markrobertwills%40yahoo.co.uk>">[email-masked] 
>> > <mailto:markrobertwills%40yahoo.co.uk <http://co.uk>>
>> >  >>>
>> > <mailto:> href="mailto:[email-masked] 
>> <mailto:markrobertwills%40yahoo.co.uk>">[email-masked] 
>> > <mailto:markrobertwills%40yahoo.co.uk <http://co.uk>>>>
>> > 
>> > >>> wrote:
>> >  >>>
>> >  >>>
>> > *
>> >  >>>> * * * *
>> >  >>>> *
>> > *
>> >  >>>>
>> >  >>>> *Yes. Forth
>> >  >>>> * <> target=_blank > <http://Opry99er.com>http://Opry99er.com 
>> <> target=_blank > <http://Opry99er.com>http://Opry99er.com>> <> 
>> target=_blank > <http://Opry99er.com>http://Opry99er.com
>> > <> href=" <http://Opry99er.com>http://Opry99er.com" target=_blank
>> > > <http://Opry99er.com>http://Opry99er.com>>Opry99er.com
>> >  >>>>
>> > < <http://Opry99er.com>http://Opry99er.com <> href=" 
>> <http://Opry99er.com>http://Opry99er.com" target=_blank
>> > > <http://Opry99er.com>http://Opry99er.com>>*
>> >  >>>> *
>> > 
>> >  >>>> yahoo.co. uk <mailto:> 
>> ymailto="mailto:[email-masked] 
>> <mailto:markrobertwills%40yahoo.co.uk>"
>> > href="mailto:[email-masked] 
>> <mailto:markrobertwills%40yahoo.co.uk>">[email-masked] 
>> > <mailto:markrobertwills%40yahoo.co.uk <http://co.uk>>>>
>> > wrote:
>> >  >>>>
>> >  >>>>
>> > *
>> >  >>>>> * * * *
>> >  >>>>>
>> > * *
>> >  >>>>>
>> >  >>>>> *I can
>> >  >>>>> <> href=" 
>> <http://tinyurl.com/ydqywa4>http://tinyurl.com/ydqywa4" target=_blank 
>> > <http://tinyurl.com/ydqywa4>http://tinyurl.com/ydqywa4
>> > <> > <http://tinyurl.com/ydqywa4>http://tinyurl.com/ydqywa4>>
>> > <> target=_blank > <http://tinyurl>http://tinyurl>
>> >  >>>>> <> href=" <http://tinyurl>http://tinyurl" target=_blank > 
>> <http://tinyurl>http://tinyurl>> href=" 
>> <http://tinyurl>http://tinyurl" target=_blank > 
>> <http://tinyurl.>http://tinyurl.
>> > com/ydqywa4
>> >  >>>>>
>> > 
>> > >>>>> <> > <http://Opry99er.com>http://Opry99er.com <> > 
>> <http://Opry99er.com>http://Opry99er.com>> <> > 
>> <http://Opry99er.com>http://Opry99er.com
>> > <> target=_blank > <http://Opry99er.com>http://Opry99er.com>>
>> > 
>> > >>>>> <> > <http://Opry99er.com>http://Opry99er.com <> > 
>> <http://Opry99er.com>http://Opry99er.com>>Opry99er.com
>> > <> href=" <http://Opry99er.com>http://Opry99er.com" target=_blank > 
>> <http://Opry99er.com>http://Opry99er.com <> href=" 
>> <http://Opry99er.com>http://Opry99er.com" target=_blank
>> > > <http://Opry99er.com>http://Opry99er.com>>
>> > 
>> > >>>>>
>> >  >>>>> ------------ ---------
>> > --------- ------
>> >  >>>>>
>> > 
>> > >>>>> Yahoo!
>> >  >>>>>> Groups
>> > Links
>> >  >>>>>
>> > 
>> > >>>>>>
>> >  >>>>>>> <> href=" 
>> <http://yahoo.com/>group/TI994A/" target=_blank
>> <http://yahoo.com/>group/TI994A/
>> > <> href=" 
>> <http://yahoo.com/>group/TI994A/" target=_blank
>> <http://yahoo.com/>group/TI994A/>> <> target=_blank > 
>> <http://groups>http://groups>
>> >  >>>>> <> href=" <http://groups>http://groups" target=_blank > 
>> <http://groups>http://groups>> target=_blank > 
>> <http://groups.>http://groups. <> > 
>> <http://yahoo.com/>http://yahoo.com/ <> > 
>> <http://yahoo.com/>http://yahoo.com/>>
>> >  >>>>> <> href=" <http://yahoo.com/>http://yahoo.com/" target=_blank 
>> > <http://yahoo.com/>http://yahoo.com/ <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/>>yahoo.com/
>> >
>> > < <http://yahoo.com/>http://yahoo.com/
>> > < <http://yahoo.com/>http://yahoo.com/>>
>> > group/
>> >  >>>>> TI994A/
>> > 
>> > >>>>>
>> >  >>>>>> href=" <> href=" 
>> <http://yahoo.com/>group/TI994A/join" target=_blank
>> > > 
>> <http://yahoo.com/>group/TI994A/join
>> > <> href=" 
>> <http://yahoo.com/>group/TI994A/join" target=_blank
>> > > 
>> <http://yahoo.com/>group/TI994A/join>>
>> > 
>> > >>>>> <> > <http://groups>http://groups> <> > 
>> <http://groups>http://groups>> > <http://groups.>http://groups.
>> >  >>>>> <> href=" <http://yahoo.com/>http://yahoo.com/" target=_blank 
>> > <http://yahoo.com/>http://yahoo.com/ <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/>> <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/
>> > <> href=" <http://yahoo.com/>http://yahoo.com/" target=_blank
>> > > <http://yahoo.com/>http://yahoo.com/>>yahoo.com/
>> >  >>>>>
>> > < <http://yahoo.com/>http://yahoo.com/ <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/>>
>> > group/TI994A/ join"
>> > target=_blank
>> > 
>> > >>>>>>> <> href=" 
>> <http://yahoo.com/>group/TI994A/join" target=_blank
>> > > 
>> <http://yahoo.com/>group/TI994A/join
>> > <> href=" 
>> <http://yahoo.com/>group/TI994A/join" target=_blank
>> > > 
>> <http://yahoo.com/>group/TI994A/join>>
>> > 
>> > >>>>> <> > <http://groups>http://groups> <> > 
>> <http://groups>http://groups>> > <http://groups.>http://groups.
>> >  >>>>> <> href=" <http://yahoo.com/>http://yahoo.com/" target=_blank 
>> > <http://yahoo.com/>http://yahoo.com/ <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/>> <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/
>> > <> href=" <http://yahoo.com/>http://yahoo.com/" target=_blank
>> > > <http://yahoo.com/>http://yahoo.com/>>yahoo.com/
>> >  >>>>>
>> > < <http://yahoo.com/>http://yahoo.com/ <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/>>
>> > group/TI994A/ join
>> >  >>>>> (Yahoo! ID
>> > 
>> > >>>>>> required)
>> > 
>> > >>>>>
>> >  >>>>>>
>> > <mailto:TI994A-digest%40yahoogroups.com 
>> <http://oups.com>>">TI994A-digest@
>> > 
>> > >>>>> yahoogroups. com
>> > <mailto:TI994A-digest%40yahoogroups.com <http://oups.com>>
>> > 
>> > >>>>>>
>> >  >>>>>
>> > 
>> >  >>>>>> href=" <> href=" 
>> <http://yahoo.com/>info/terms/" target=_blank
>> <http://yahoo.com/>info/terms/
>> > <> href=" <http://docs.yahoo.com/info/terms/>http://docs.yahoo.com/ 
>> <http://yahoo.com/>info/terms/" target=_blank
>> <http://yahoo.com/>info/terms/>> <> target=_blank > 
>> <http://docs>http://docs>
>> >  >>>>> <> href=" <http://docs>http://docs" target=_blank > 
>> <http://docs>http://docs>> target=_blank > <http://docs.>http://docs. 
>> <> > <http://yahoo.com/>http://yahoo.com/ <> > 
>> <http://yahoo.com/>http://yahoo.com/>>
>> >  >>>>> <> href=" <http://yahoo.com/>http://yahoo.com/" target=_blank 
>> > <http://yahoo.com/>http://yahoo.com/ <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/>>yahoo.com/
>> >
>> > < <http://yahoo.com/>http://yahoo.com/
>> > <> > <http://yahoo.com/>http://yahoo.com/>>
>> >  >>>>> info/terms/"
>> > target=_blank
>> >  >>>>>>> <> href=" 
>> <http://yahoo.com/>info/terms/" target=_blank
>> <http://yahoo.com/>info/terms/
>> > <> href=" <http://docs.yahoo.com/info/terms/>http://docs.yahoo.com/ 
>> <http://yahoo.com/>info/terms/" target=_blank
>> <http://yahoo.com/>info/terms/>> <> target=_blank > 
>> <http://docs>http://docs>
>> >  >>>>> <> href=" <http://docs>http://docs" target=_blank > 
>> <http://docs>http://docs>> target=_blank > <http://docs.>http://docs. 
>> <> > <http://yahoo.com/>http://yahoo.com/ <> > 
>> <http://yahoo.com/>http://yahoo.com/>>
>> >  >>>>> <> href=" <http://yahoo.com/>http://yahoo.com/" target=_blank 
>> > <http://yahoo.com/>http://yahoo.com/ <> href=" 
>> <http://yahoo.com/>http://yahoo.com/" target=_blank > 
>> <http://yahoo.com/>http://yahoo.com/>>yahoo.com/
>> >
>> > < <http://yahoo.com/>http://yahoo.com/
>> > < <http://yahoo.com/>http://yahoo.com/>>
>> > info/
>> >  >>>>> terms/
>> > 
>> > >>>>> *
>> >  >>>>>
>> > 
>> > >>>>> * *
>> >  >>>>> * *
>> > 
>> > >>>> *
>> >  >>>>
>> >  >>>>
>> > *
>> >  >>>>
>> >  >>>> *
>> > *
>> >  >>>> * *
>> >  >>> *
>> > 
>> > >>>
>> >  >>> *
>> > 
>> > >>>
>> >  >>> * *
>> >  >>> *
>> > *
>> >  >> * *
>> >  >> * *
>> >  >>
>> > **
>> >  >> * *
>> >  >
>> > 
>> > >
>> <http://yahoo.com/>group/TI994A/join
>>     (Yahoo! ID
>> > required)
>>
>> >
>> <http://yahoo.com/>info/terms/
>>
>

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 15:40:10 -0400

Like I said, I dont KNOW anything...  Just asking questions.

Owen Brand
Opry99er.com

On Apr 9, 2010, at 3:35 PM, fdos <[email-masked]> wrote:

>>> [email-masked]
>>> [email-masked]

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 16:03:58 -0400

Well then that does beg the question--- how does one keep track of  
user-defined words?  If these are my defined words...

FUN-  CRACK BAIT

Then how would i reference their definitions later on?

Owen Brand
Opry99er.com

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 13:47:24 -0700

Owen,

If the words added by the user are included in a binary code library the 
user is able to edit the existing HELP file to add these words, and 
there is a library pointer to this area (specific library glossary) of 
the HELP file.  This is not available for words in the user conventional 
dictionary zone.  No way to track this as it is done however the user 
wants, but binary code libraries are done by the A/S LIBRARY word, so 
Forth+/X4th99 can track it.

Bill S

---

From: fdos <[email-masked]>
Date: Fri, 09 Apr 2010 13:53:02 -0700

Which means that the user can provide his/her binary code libraries to 
other Forth+/x4th99 users along with a modified HELP file for those 
libraries.  Normal documentation will be needed for FSAVE'd or BSAVE'd 
application code which only loads into normal conventional user 
dictionary space.

Bill S

---

From: Owen Brand <[email-masked]>
Date: Fri, 9 Apr 2010 17:37:21 -0400

Thanks Bill!

Owen Brand
Opry99er.com

On Apr 9, 2010, at 4:53 PM, fdos <[email-masked]> wrote:

> >>> <mailto:markrobertwills 
> %40yahoo.co.uk>">[email-masked]
> >>> <mailto:markrobertwills 
> %40yahoo.co.uk>">[email-masked]
> >>> <mailto:markrobertwills 
> %40yahoo.co.uk>">[email-masked]
> >>> <mailto:markrobertwills 
> %40yahoo.co.uk>">[email-masked]