Subject: Re: [TI994A] Re: CF7+ ???

From: [email-masked]
Date: Thu, 22 Apr 2010 19:06:47 -0500 (CDT)

Welp, breaking line 33, >CRUIN, didn' make a difference. I'm waiting to hear back from Jamie.

Apr 22, 2010 04:44:25 AM, [email-masked] wrote:
As I said in a previous message, I think the CF7+ is keeping the CRUIN line held high even when it is not being accessed (instead of tri-stating it), which prevents any other CRU device outside the console being read. If you have a soldering iron, carefully cut the track to edge connector pin 33 (the CRUIN line) on the CF7+ and see if the boxcar then works OK with the CF7+ plugged in. You can easily solder the track back together again if no improvement. If you find it does work with the track cut, try bridging the cut with a 1K resistor. I had exactly this problem interfacing to a 9901 connected to the CF7+ on a Y cable side port extender.

Stuart.

---

From: "Gary from O.P.A." <[email-masked]>
Date: Fri, 23 Apr 2010 02:34:54 -0000

You also could try running the CF7 without the EPROM to see if it is hardware issue, or software issue.

I going to build another workbench tomorrow, and dig out some of my own sidecars, and see if I can also figure out what might be the problem.

With the third workbench, I been able to have a CF7 system up and running all the time, thanks to also having now another TI console, since I finally got that 32k16bit fully-assembled-ready-to-go console in from you.

---

From: "Gary from O.P.A." <[email-masked]>
Date: Fri, 23 Apr 2010 04:20:54 -0000

There is also four more CF7+ available on Ebay now from Jamie.

Plus these are all the new SLIM design.

Get them while they are HOT!

http://cgi.ebay.com/TI-99-4a-CompactFlash-Drive-PIO-Port-Slim-Profile-/200464459321?cmd=ViewItem&pt=PCC_Drives_Storage_Internal&hash=item2eac9ce639

---

From: mark wills <[email-masked]>
Date: Fri, 23 Apr 2010 05:12:16 +0000 (GMT)

Whats the story with the CF7 and the speech synth?

Is it not possible to use the SS with the CF7? I can't remember, sorry...

Mark

---

From: alekin garavia <[email-masked]>
Date: Fri, 23 Apr 2010 06:52:33 +0000 (GMT)

I used consolle with speech and cf7.. only that i put 9V in connector near at parallel plug.. work good.. the problem is build a box for cf7....
Question.. One know where is possible buy a connector male / female for build a extension cable in mode of put horizontal the cf7 card? Also i try a change the female plug for  compact flesh card in male, and used a female/female   connector.. work correctly. In this mode one can put the cf card in all position. 

--- Ven 23/4/10, mark wills <[email-masked]> ha scritto:

Da: mark wills <[email-masked]>
Oggetto: Re: [TI994A] Re: CF7+  ???
A: [email-masked]
Data: Venerdì 23 Aprile 2010, 07:12

  

Mark

---

From: "Stuart" <[email-masked]>
Date: Fri, 23 Apr 2010 12:35:51 -0000

Depends on what model of CF7+ you have. The SS doesn't pass the 5V power from one side connector to the other, so a CF7+ that relies on the console power won't work unless you bridge the power across in the SS. A CF7+ that uses an external power supply works OK I believe.

Stuart.

---

From: "Stuart" <[email-masked]>
Date: Fri, 23 Apr 2010 12:46:00 -0000

>>Welp, breaking line 33, >CRUIN, didn' make a difference.<<

Oh well, worth a go anyway. I wouldn't however completely rule out this still being a problem once you get whatever the current problem is (the DSR?) sorted. I could never read anything but a logic 1 over the (external) CRU with my CF7+ connected. What it might be worth doing is disconnecting the CF7+ and then using something like EasyBug on the MiniMem cartridge to peek around the CRU addresses used by the BoxCar and see if you get a mix of logic 0 and logic 1 values, then connecting the CF7+ and see if you still get a mix of values. Jaime might possibly have corrected the problem since I told him ~2 years ago.

Stuart.