Subject: Re: [TI994A] Re: CF7+ ???

From: [email-masked]
Date: Wed, 21 Apr 2010 22:23:19 -0500 (CDT)

Gary, I haven't run a cru scan with the CF7+ but it does display PIO 1E00 at the CF7+ title screen. A CRU scan shows the box car at 1300 and it is the ultracomp systems box car RS232/PIO. I did try TEII and the little Omega terminal. Both work as expected with just the box car attached to the console but as soon as the CF7+ is added to the mix the 4A cannot find the box car.

I've e-mailed Jamie so we'll see what he suggests.

Apr 21, 2010 08:45:30 PM, [email-masked] wrote:

That is strange, I replied to this topic, but it does not seem to appear.

Anyhow, have you used a program to scan the CRU bases, and make sure the CF7 is repling at the new 1E00 address, that Jamie moved it to.

And are you using a offical TI sidecar (rs232), or is it a third-party one, and if the later is it at the normal 1300 address, or possible another address like (ugh) the 1E00 or 1F00.

And lastly did you try another terminal program besides TE2?

---

From: "Gary from O.P.A." <[email-masked]>
Date: Thu, 22 Apr 2010 08:25:29 -0000

Hmm.. -- Only two things I can think of.

1: Either the CF7+ is somehow hardware-wise not keeping the >4000 DSR space clear, when it not enable.

2: The CF7+ DSR is not returning correctly from its "power-up" call (the part that changes the title screen), causing the other DSR's like the sidecar not to be init or "power-up"

To answer #1, you would need to use a DSRDUMP program that turns on CRU 1100, dumps it, turns it off, then CRU 1300, dumps it, turns it off, then CRU 1E00, dumps it, turns it off.

(I think I had that type of diag. program someplace, if not it could easy be written)

Then compare the dumps with and without the CF7, and see if your sidecar DSR is reading perfect when the CF7 is in the line.

To answer #2, I would need to study the "power-up" code of the CF7 and see if this might be the problem.

"power-up" code can be tricky, I had that problem when writing the Horizon DSR, the Corcomp cards like their Ramdisk and Micro-Expansion and Disk Controller, love to change the TI title screen or take over, and the end result was problems unless the Horizon was at CRU 1000 so it got control before the Corcomp cards.

---

From: "Stuart" <[email-masked]>
Date: Thu, 22 Apr 2010 08:39:57 -0000

>>I haven't run a cru scan with the CF7+ but it does display PIO 1E00 at the CF7+ title screen. A CRU scan shows the box car at 1300 and it is the ultracomp systems box car RS232/PIO. I did try TEII and the little Omega terminal. Both work as expected with just the box car attached to the console but as soon as the CF7+ is added to the mix the 4A cannot find the box car.<<

As I said in a previous message, I think the CF7+ is keeping the CRUIN line held high even when it is not being accessed (instead of tri-stating it), which prevents any other CRU device outside the console being read. If you have a soldering iron, carefully cut the track to edge connector pin 33 (the CRUIN line) on the CF7+ and see if the boxcar then works OK with the CF7+ plugged in. You can easily solder the track back together again if no improvement. If you find it does work with the track cut, try bridging the cut with a 1K resistor. I had exactly this problem interfacing to a 9901 connected to the CF7+ on a Y cable side port extender.

Stuart.

---

From: mark wills <[email-masked]>
Date: Thu, 22 Apr 2010 09:39:05 +0000 (GMT)

Good CRU write up here:

http://www.nouspikel.com/ti99