Subject: Floppy Issues

From: "chris20636" <[email-masked]>
Date: Sat, 03 Jul 2010 01:24:39 -0000

I have a PC with BIOS support for 360K and 1.2M 5.25" floppy devices.  I
have a Teac FD55GFR 7149-U5 1.2MB 5.25 Floppy Disk Drive DSHD installed
with the BIOS set to 1.2M 5.25".  Unfortunately I have 64 bit Windows 7
Home.  So that leaves me without access to either TI99-PC or Omniflop. 
However, I also have linux installed.

I can take a Texas Instruments floppy and dump each track like this on
linux:

fdrawcmd rate=1 track=2*LTRACK fm length=2304 read 0 LTRACK 0
STARTSECTOR 1 9 0x1b 0xff need_seek > track

LTRACK is a variable for the logical track holder.  Since this is a
single density disk, each Logical track seems to cover 2 physical tracks
which is why the "track=" parameter is twice the LTRACK number.  LTRACK
gets replaced with one of 0,1,2,3...,39 while track= goes as
0,2,4,6,...78.

STARTSECTOR is the starting sector.  In the case of the TI disks, this
is "0".

So to read the first track, track 0, I would do this,
fdrawcmd rate=1 track=0 fm length=2304 read 0 0 0 0 1 9 0x1b 0xff
need_seek > track01
Track 2 would be
fdrawcmd rate=1 track=2 fm length=2304 read 0 1 0 0 1 9 0x1b 0xff
need_seek > track02
etc.

I then concatenate the 39 tracks into a single disk image.  A hexdump
shows good structure and TI99Dir can read the contents.

Now for the problem:  I did the above for three Texas instruments
floppies just fine.  However, I have some Asgard Software disks that I
want to image.  I do the same procedure and it fails.  This is because I
can read sectors 1-8 on each track, but I can't read sector 0 (or 9?). 
So I'm only able to read 8 of the 9 sectors per track.  A hexdump
reveals that the missing ninth sector is needed to make a valid image.

Any ideas?

Thanks,
Chris

---

From: "epergrem" <[email-masked]>
Date: Sat, 03 Jul 2010 10:36:20 -0000

> want to image.  I do the same procedure and it fails.  This is 
> because I can read sectors 1-8 on each track, but I can't read
> sector 0 (or 9?). 

This may be the "infamous sector zero" issue that Paolo talks about in section 7.03 of the  TI99_PC documentation.  

It's the result of a TI disk being created by one of the third-party disk controllers, though I'm not sure which one.

In any case Paolo came up with a device to try and address it. I'm sure that he would be glad to share the build instructions with you. If you can't find him on this group then try ti99-4a. 

Ernie

THE INFAMOUS ZERO SECTOR PROBLEM
 ================================

Be warned that some TI Floppy Disks formatted with the Ottawa UG
Disk Manager 1000 or similar cannot be easily read on a PC. Please
refer to The Zero Sector Problem On Some Disks section of the
Hardware Requirements Help that can be reached by 4.1 (or 2.9.1,
or 1.9.1) of the Main Program Menu: after the intro screen press 4
and then 1.

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Sat, 3 Jul 2010 12:43:59 +0200

You might have come across the "Unreadable sector problem". If that is so, 
then your problem depends on the length of the pregap that was formatted 
on every track at format time. WD177x (the FDC chip used on a TI) can 
manage very short pregaps, while NEC 765 (the FDC chip and its siblings, 
used on a PC) can't. If the formatter on the TI did use short pregaps, 
then the same disk may not be easily read on a PC.

Please find below a detailed explanation and a possible solution (a 
Floppy-Cable Index-Switch). They come from the manual of TI99-PC.

If you need more assistance, and are willing to build your own 
Floppy-Cable Index-Switch, I could provide you with a drawing and a 
picture of the needed mod.

Paolo

=======================================
07.03.01
 ****    THE UNREADABLE SECTOR PROBLEM ON SOME DISKS     ****
         ===========================================

 Some TI disks have been formatted in such a way that the first
 sector on each track cannot be easily read in a PC. This can happen
 to single density as well as double density disks. Usually the Disk
 Manager 1000 formatter is the culprit, but most other formatters
 that were not made or sold by TI may have the same drawback. Disks
 formatted by Disk Manager 2 and Turbo Copy don't appear to have
 this problem, at least when used with a TI disk controller. Note
 that the problem shows up only on a PC and is due to the different
 floppy disk controller circuit used on the PC.

 If you can read all the sectors of all tracks except the first one
 of every track, chances are good that you have an "unreadable
 sector" problem. The problem has been detected when using Western
 Digital 37C65 family disk controller chips. Sometimes a different
 type of disk controller may solve the problem. Some disk controller
 chips made by Adaptec and SMC have been found to eliminate the
 problem.

 On disks formatted by Disk Manager 2, the first sector of each
 track is the physical sector zero of that track. However, this may
 vary. On some disks, the first sector of each track changes each
 time the track number increases. For example, on disks formatted
 by Disk Manager 1000, the first sector numbers are 0 on track 0, 6
 on track 1, and 3 on track 2. This pattern then repeats on the
 following tracks. This is due to the skew placed on the disk at
 formatting time. This is done to increase the speed of reading and
 writing the disk.

 Skew allows the first sector of a track to be in a position to be
 read or written soon after the head is moved to the next track. A
 short pause is needed after the head is moved to allow vibrations
 to stop. After this pause, the next sector should be close to the
 drive head.

##-07.03.02
 ****    CONNECTING A SWITCH TO THE FLOPPY DRIVE CABLE   ****
         =============================================
                 *** DISCLAIMER ***
                     ==========
 Please don't modify your PC hardware unless you know what to do.
 Any modification and soldering on to your computer must be
 performed with the power supply cable taken off the AC power
 outlet. I take no responsibility for any damage that could result
 from the modifications that are suggested hereafter.

 If you perform the following modification you must know how to
 solder. You'll also need a simple two terminal switch and some
 double wire cable.

 Also, the modification described here has worked well on my
 computer, but it is by no means guaranteed that it will work
 equally well on your computer. Don't say you haven't been warned!!!

 =======================================================

 The solution to the "unreadable sector" problem is quite
 straightforward.

 1) Simply cut wire number 8 on the floppy drive cable near the disk
    controller connector. You count starting from the first wire,
    which is the only one that has a red stripe or dots. Wire number
    1 is normally toward the right side at the disk drive (but not
    on some Teac 1.2 MB drives) and away from the metal bracket on
    the disk controller card.

    Sometimes there will be pin or trace numbers printed at the disk
    drive or disk controller connectors.

    There are a total of 34 wires in the ribbon cable. Sometimes pin
    1 on the disk controller has a square solder spot instead of  a
    round one. Wire number 8 carries the index pulse signal (more on
    this later). The cut should be between the disk controller and
    the first disk drive connector so the modification will be
    effective on both disk drives if you have two. You can separate
    wire 8 from the cable with a razor, then cut it with a wire
    cutter, scissors or razor. Remove some insulation from the two
    ends.

 2) Now solder the two wires of your cable to the two cut ends of
    wire number 8. Insulate the connections with some tape, heat
    shrink tubing or glue. You can cut the wire to a convenient
    length. Simply keep in mind that the other end of the cable has
    to be within your reach. You can decide how long it must be. The
    switch can be mounted at the front or back of the computer or it
    can be left on your desk.

 3) Finally solder the switch to the other end of the double wire.
    Now you're done with the soldering! Insulate these connections
    too to avoid accidentally sending a static shock into your
    computer circuits. For extra protection against static, you can
    also add a grounding wire from the  computer case to the case of
    the switch if it is metal.

 4) Keep the switch in an ON position for all the normal operations,
    even with TI disks, as long as you do not have any problem
    reading them.

 5) If you feel you have an "unreadable sector" problem, remove the
    hard to read disk. Insert a known good floppy disk in the floppy
    disk drive door and let it be read by TI99-PC. This disk must
    have the same density as the hard to read one. You don't need to
    read all of the good disk. Just a few sectors is more than
    enough (press ESC key to stop reading).

 6) Now, move the switch to the OFF position. Insert the hard to
    read disk and start TI99-PC again. Now it should read without
    any problem. If it doesn't work, well, maybe you have a bad disk.
    Or, ... I don't know!
    You're on your own, now.

 Credits: the above modification is a clever suggestion by Andy
 Becker <[email-masked]>.
=======================================

----- Original Message ----- 
From: "chris20636"
Sent: Saturday, July 03, 2010 3:24 AM
Subject: [TI994A] Floppy Issues

Any ideas?

Thanks,
Chris

---

From: "Dan O'Quinn" <[email-masked]>
Date: Sat, 3 Jul 2010 10:55:30 -0400

----- Original Message ----- 
From: "chris20636" <[email-masked]>
Sent: Friday, July 02, 2010 9:24 PM
Subject: [TI994A] Floppy Issues

> I have a Teac FD55GFR 7149-U5 1.2MB 5.25 Floppy Disk  
> Drive DSHD installed with the BIOS set to 1.2M 5.25".  

toss out the 1.2 meg floppy and use a 360k

---

From: "chris20636" <[email-masked]>
Date: Sat, 03 Jul 2010 15:30:53 -0000

I sure is nice to have almost instant access to this wealth of TI knowledge and experience.  Thanks again for the responses.

I plan to go ahead and try all of the above answers.

1) More software games: I plan to play with the Linux software tools a bit more.  This is the parameters list for the read command that I'm sending with fdrawcmd.

read drvsel cyl head sect szcod spt rw-gap szcod2

I used the "rw-gap" value that was recommended in the man page.  However, if that is related to this short pregap problem, then maybe I can play with that value and get something to work.  

2) I'll check out Ebay for some 360K drives.  Can anyone recommend a model that is known to work with this problem?  

3) Try the Paolo Bagnaresi/Andy Becker hardware modification.

Regards,
Chris

---

From: "chris20636" <[email-masked]>
Date: Sat, 03 Jul 2010 15:35:13 -0000

Paolo,

The written instructions appear well written and clear.  However, a drawing/picture would be a good backup.  No Rush.  I'm guessing that this hardware fix can be adapted to use with my Linux fdrawcmd method.  I've almost convinced myself to make my PC a triple boot with a 32 bit XP install added.

I'll send a PM with email address. Thanks.
Chris

--- In [email-masked], "Paolo Bagnaresi" <paul.bagnaresi@...> wrote:
>  Becker <ab31@...>.

---

From: "epergrem" <[email-masked]>
Date: Sat, 03 Jul 2010 15:52:04 -0000

Chris,
It's not a drive issue so switching to a 360K won't solve the issue.  I ran into the problem when using TIPC-99 and OmniFlop to transfer some disks and tried both the GFR and multiple 360K drives.  None of them fixed the problem.

However, there are other issues with write current and such that might make using 360K on a PC a better choice, but I'm not an expert in that area.  
Ernie

---

From: "chris20636" <[email-masked]>
Date: Sat, 03 Jul 2010 16:58:49 -0000

For the record, my motherboard floppy controller seems to be implemented by an ITE IT8720 chip.  This also does the hardware monitoring and other miscellaneous I/O functions.

Posted in case any of the big brained guys are keeping records.

Regards,
Chris

---

From: "chris20636" <[email-masked]>
Date: Sat, 03 Jul 2010 19:45:10 -0000

I would tend to agree with you.  However, I did come across this bit of info from the Intel 82077 data sheet.  A 360 Kbyte disk running in a 1.2 Mbyte drive has a drive speed of 360 RPM and a Data rate of 300 Kbps.  But a 360 Kbyte disk in a 360 drive has a drive speed of 300 RPM and 250 Kbps.  So I would think the slightly lower rotation speed might just be enough for the head to start reading before the end of the shortened pregap.  However, experiment always trumps theory, so your experience with 306K drives indicates that the speed difference isn't enough to overcome the problem.

Regards,
Chris

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Sun, 4 Jul 2010 00:26:45 +0200

Good point, it sounds reasonable to me. On a 360 RPM drive everything 
happens faster. Thus, the magnetic head gets past the pregap before the 
FDC is really ready to read data. On the other hand, a 300 RPM drive 
leaves more time to the FDC.

If you get a 300 RPM drive you could determine yourself if the drive RPM 
difference is important or not.

Paolo

----- Original Message ----- 
From: "chris20636" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, July 03, 2010 9:45 PM
Subject: [TI994A] Re: Floppy Issues

I would tend to agree with you.  However, I did come across this bit of 
info from the Intel 82077 data sheet.  A 360 Kbyte disk running in a 1.2 
Mbyte drive has a drive speed of 360 RPM and a Data rate of 300 Kbps.  But 
a 360 Kbyte disk in a 360 drive has a drive speed of 300 RPM and 250 Kbps. 
So I would think the slightly lower rotation speed might just be enough 
for the head to start reading before the end of the shortened pregap. 
However, experiment always trumps theory, so your experience with 306K 
drives indicates that the speed difference isn't enough to overcome the 
problem.

Regards,
Chris

--- In [email-masked], "epergrem" <epergrem@...> wrote:
>
> Chris,
> It's not a drive issue so switching to a 360K won't solve the issue.  I 
> ran into the problem when using TIPC-99 and OmniFlop to transfer some 
> disks and tried both the GFR and multiple 360K drives.  None of them 
> fixed the problem.
>
> However, there are other issues with write current and such that might 
> make using 360K on a PC a better choice, but I'm not an expert in that 
> area.
> Ernie
>
>
> >
> > 2) I'll check out Ebay for some 360K drives.  Can anyone recommend a 
> > model that is known to work with this problem?
> >

---

From: "epergrem" <[email-masked]>
Date: Sat, 03 Jul 2010 22:48:11 -0000

The GFR series can be strapped to operate at 300 rpm, which is what makes them ideal drives for use with the Myarc 80-track upgrade.  As for the data rate, I'm not sure.  http://www.teac.com/DSPD/pdf/5fd0050a.pdf  

I used a pair of them, provided graciously by Jon Guidry, to transfer  a couple thousand disks from the TI to PC.

Ernie

--- In [email-masked], "chris20636" <chrisas@...> wrote:
> --- In [email-masked], "epergrem" <epergrem@> wrote:
> >
> > Chris,

---

From: "chris20636" <[email-masked]>
Date: Sun, 04 Jul 2010 00:33:31 -0000

Thanks for the link.  However, I ruled that out as a fix.  I jumpered the "I strap" which changes the LOW speed from 360 to 300.  I noticed in the linux command that I needed to change from rate=1 to rate=2 to get a good read, so the jumper did something.  However, the Texas Instruments disks read sectors 0-8, and the Asgard won't read 0, only 1-8 still.

So I guess I'll move on to the on/off switch on the floppy wire 8 as a next attempt.

Chris

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> --- In [email-masked], "chris20636" <chrisas@> wrote:
> >

---

From: "Ksarul" <[email-masked]>
Date: Sat, 03 Jul 2010 20:48:38 -0400

IIRC, the disk read problems came up when Disk Manager 1000 was used to
format disks in single density with a CorComp controller that were then read
on a TI or Myarc controller.  They worked fine on another Corcomp or an
Atronic disk controller (the two were very similar operationally).

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
chris20636
Sent: Saturday, July 03, 2010 8:34 PM
To: [email-masked]
Subject: [TI994A] Re: Floppy Issues

Thanks for the link. However, I ruled that out as a fix. I jumpered the "I
strap" which changes the LOW speed from 360 to 300. I noticed in the linux
command that I needed to change from rate=1 to rate=2 to get a good read, so
the jumper did something. However, the Texas Instruments disks read sectors
0-8, and the Asgard won't read 0, only 1-8 still.

So I guess I'll move on to the on/off switch on the floppy wire 8 as a next
attempt.

Chris

--- In [email-masked] <mailto:TI994A%40yahoogroups.com> , "epergrem"
<epergrem@...> wrote:
>
> The GFR series can be strapped to operate at 300 rpm, which is what makes
them ideal drives for use with the Myarc 80-track upgrade. As for the data
rate, I'm not sure. http://www.teac.com/DSPD/pdf/5fd0050a.pdf 
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com> ,
info from the Intel 82077 data sheet. A 360 Kbyte disk running in a 1.2
Mbyte drive has a drive speed of 360 RPM and a Data rate of 300 Kbps. But a
360 Kbyte disk in a 360 drive has a drive speed of 300 RPM and 250 Kbps. So
I would think the slightly lower rotation speed might just be enough for the
head to start reading before the end of the shortened pregap. However,
experiment always trumps theory, so your experience with 306K drives
indicates that the speed difference isn't enough to overcome the problem.
> > 
> > Regards,
> > Chris
> > 
> > --- In [email-masked] <mailto:TI994A%40yahoogroups.com> ,
> > > It's not a drive issue so switching to a 360K won't solve the issue. I
ran into the problem when using TIPC-99 and OmniFlop to transfer some disks
and tried both the GFR and multiple 360K drives. None of them fixed the
problem.
> > > However, there are other issues with write current and such that might
make using 360K on a PC a better choice, but I'm not an expert in that area.

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Mon, 5 Jul 2010 00:41:28 +0200

Thank you Chris.

There are a bunch of Gigabyte motherboards that use the ITE IT8720 chip 
for FDD:
GA-870A-UD3, GA-P55A-UD4, GA-P55-UD6, GA-EX58-UD3R, GA-MA770T-UD3P, 
GA-M720-US3, GA-EP45 DS4R

Somebody might be interested. ;-)

Paolo

----- Original Message ----- 
From: "chris20636" To: <[email-masked]>
Sent: Saturday, July 03, 2010 6:58 PM
Subject: [TI994A] Re: Floppy Issues

For the record, my motherboard floppy controller seems to be implemented 
by an ITE IT8720 chip.  This also does the hardware monitoring and other 
miscellaneous I/O functions.

Regards,
Chris

---

From: "chris20636" <[email-masked]>
Date: Sun, 01 Aug 2010 21:51:32 -0000

Well, waddya know, it works!

Much procrastination has occurred since you sent me this.  This is primarily due to the fact I didn't want to mess up my only floppy cable and/or my main PC machine.  I eventually came across another floppy cable.  So I dug out an old Asus P3B-F motherboard that was collecting dust in my closet with installed 600 Mhz Pentium III.  So this is not the superIO chipset that was previously used.  

I made a pin 8 "switch".  I wanted to test the concept before doing anything elaborate.  I had a cut ribbon cable that had a 25 pin female connector on one end.  So I soldered two of the cut ribbon cable wires to the cut pin 8 wire of the floppy ribbon.  The "switch" was a precision jumper (i.e. paper clip) that was jammed into the two holes that completed the pin 8 circuit.

I tested floppy operation was normal by using your TI99-PC utility on bootable floppy.  I was able to read a TI disk that did not have the sector read problem.  I followed the instructions to read the problem disk and it worked perfectly!

Thanks,
Chris    

--- In [email-masked], "chris20636" <chrisas@...> wrote:
> --- In [email-masked], "Paolo Bagnaresi" <paul.bagnaresi@> wrote:
> >
> >  Becker <ab31@>.

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Mon, 2 Aug 2010 01:45:56 +0200

I'm glad it did!

Thank you for reporting :-)

Paolo

----- Original Message ----- 
From: "chris20636"
To: <[email-masked]>
Sent: Sunday, August 01, 2010 11:51 PM
Subject: [TI994A] Re: Floppy - Unreadable Sector

Much procrastination has occurred since you sent me this.  This is 
primarily due to the fact I didn't want to mess up my only floppy cable 
and/or my main PC machine.  I eventually came across another floppy cable. 
So I dug out an old Asus P3B-F motherboard that was collecting dust in my 
closet with installed 600 Mhz Pentium III.  So this is not the superIO 
chipset that was previously used.

I made a pin 8 "switch".  I wanted to test the concept before doing 
anything elaborate.  I had a cut ribbon cable that had a 25 pin female 
connector on one end.  So I soldered two of the cut ribbon cable wires to 
the cut pin 8 wire of the floppy ribbon.  The "switch" was a precision 
jumper (i.e. paper clip) that was jammed into the two holes that completed 
the pin 8 circuit.

I tested floppy operation was normal by using your TI99-PC utility on 
bootable floppy.  I was able to read a TI disk that did not have the 
sector read problem.  I followed the instructions to read the problem disk 
and it worked perfectly!

Thanks,
Chris

--- In [email-masked], "chris20636" <chrisas@...> wrote:
>
> Paolo,
>
> The written instructions appear well written and clear.  However, a 
> drawing/picture would be a good backup.  No Rush.  I'm guessing that 
> this hardware fix can be adapted to use with my Linux fdrawcmd method. 
> I've almost convinced myself to make my PC a triple boot with a 32 bit 
> XP install added.
>