Subject: Re: [TI994A] TurboForth preparation

From: [email-masked]
Date: Sat, 10 Apr 2010 12:35:44 EDT

I'll have to check my notes but Wycove added some compatibility screens to  
accommodate Brodie's book. I don't remember which edition, though.
 
Bob  Carmany  

In a message dated 4/10/2010 12:20:35 P.M. Eastern Daylight Time,  
[email-masked] writes:

You're reading the book from Forth Inc at Forth.com, right?

It's a  re-hash of Brodie's book, and is, frankly, rubbish! Get yourself 
the real  thing. I just ordered the second edition to see what the differences 
 are...

Mark

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 10:04:58 -0700

In my Wycove forth the Starting Forth compatibility screens are 58 ~ 60. 
  I don't know if they're referring to the first edition or the second 
edition, so I would guess the first edition as the second edition is 
copyrighted 1987 and the Wycove manual I have is copyrighted 1983. 
Sherlock Holmes would be proud of me. :-)

Bill S

[email-masked] wrote:
>  
> 
> I'll have to check my notes but Wycove added some compatibility screens 
> to accommodate Brodie's book. I don't remember which edition, though.
>  
> Bob Carmany
>  
>     It's a re-hash of Brodie's book, and is, frankly, rubbish! Get
>     yourself the real thing. I just ordered the second edition to see
>     what the differences are...
> 
>     Mark
> 
>          
> 
>

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 13:27:13 -0400

And how would I go about loading those screens so I can start burning  
through this book?  :).

Owen Brand
Opry99er.com

On Apr 10, 2010, at 1:04 PM, fdos <[email-masked]> wrote:

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 10:54:20 -0700

Owen,

If the Forth you are using already has Brodie's THRU then it's simply 58 
60 THRU.  Otherwise just load each screen in order:

58 LOAD
59 LOAD
60 LOAD

Usually, a load screen for a function that requires multiple screen 
loads is written and includes tail comments:

58 LOAD  ( Load words aaaa bbbb & cccc) or ( Starting Forth 
compatibility words)
59 LOAD  ( Load words dddd eeee & ffff)
60 LOAD  ( Load words xxxx yyyy & zzzz)

Brodie also has \ which is a tail remark and doesn't require any close \ 
or ) or what ever after the comment text.

Bill S

Owen Brand wrote:
> On Apr 10, 2010, at 1:04 PM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  > [email-masked] <mailto:rmcarmany%40aol.com> wrote:
>  >>
>  >>
>  >> [email-masked] <mailto:markrobertwills%40yahoo.co.uk> 
> writes:
>  >>
>  >>
>  >>

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 14:16:11 -0400

Great info, thanks Bill!

Owen Brand
Opry99er.com