Subject: Re: [TI994A] Re: TurboForth preparation

From: [email-masked]
Date: Sun, 11 Apr 2010 11:49:02 EDT

Owen,
 
Which version of Wycove are you working with? Tim included MENU in Vn 3.0  
inspired by my code through our correspondence over the years. However, the  
choices need to reside in screen #1 in the 'SCREENS' file. If you are using 
 Vn 2.1, you will have to create the MENU word yourself since it isn't in 
the  system.
                             
Here are a couple more versions of GOTOXY;
 
: GOTOXY SCREEN-WIDTH @  * +  >C9C8 !  ;
 
: GOTOXY SCREEN-WIDTH @  * +  [CURSOR-POS] LITERAL ! ;
 
Bob  Carmany

In a message dated 4/11/2010 10:42:19 A.M. Eastern Daylight Time,  
[email-masked] writes:

How do I go about loading it up?  I'm having a bit of an issue  trying to 
access my menu screen.  MENU returns MENU? I haven't tried  anything like 
this yet... So far i've just been playing on the command  line. 

Owen Brand  
 
_Opry99er.com_ (http://opry99er.com/)

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 12:00:21 -0400

V 3.0. MENU didn't work, still.  I reset the emulator which I think  
disabled the 58 LOAD from before since I didn't save.  MENU on the  
commandline still returns MENU?

Owen Brand
Opry99er.com

On Apr 11, 2010, at 11:49 AM, [email-masked] wrote:

> Owen,
>
> Which version of Wycove are you working with? Tim included MENU in  
> Vn 3.0 inspired by my code through our correspondence over the  
> years. However, the choices need to reside in screen #1 in the  
> 'SCREENS' file. If you are using Vn 2.1, you will have to create the  
> MENU word yourself since it isn't in the system.
>
> In a message dated 4/11/2010 10:42:19 A.M. Eastern Daylight Time, [email-masked] 
>  writes:
>
>
> How do I go about loading it up?  I'm having a bit of an issue  
> trying to access my menu screen.  MENU returns MENU? I haven't tried  
> anything like this yet... So far i've just been playing on the  
> command line.
>
> Owen Brand
> Opry99er.com
>
>
>

---

From: ti99_forever <[email-masked]>
Date: Sun, 11 Apr 2010 09:08:52 -0700 (PDT)

MENU is a TI-Forthism. With Wycove, it is natural to refer to the manual and load the routines by screen #.

--- On Sun, 4/11/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] Re: TurboForth preparation
To: "[email-masked]" <[email-masked]>
Date: Sunday, April 11, 2010, 12:00 PM

V 3.0. MENU didn't work, still.  I reset the emulator which I think disabled the 58 LOAD from before since I didn't save.  MENU on the commandline still returns MENU?

Owen BrandOpry99er.com

    

Owen,
 
Which version of Wycove are you working with? Tim included MENU in Vn 3.0 
inspired by my code through our correspondence over the years. However, the 
choices need to reside in screen #1 in the 'SCREENS' file. If you are using 
Vn 2.1, you will have to create the MENU word yourself since it isn't in the 
system.

 
 
Bob 
Carmany

In a message dated 4/11/2010 10:42:19 A.M. Eastern Daylight Time, 
owenbrand@opry99er. com writes:

  How do I go about loading it up?  I'm having a bit of an issue 
  trying to access my menu screen.  MENU returns MENU? I haven't tried 
  anything like this yet... So far i've just been playing on the command 
  line. 

Owen Brand 
  
  Opry99er.com