Subject: Hard drive dumps for MESS

From: "Tony Knerr" <[email-masked]>
Date: Fri, 13 Aug 2010 14:06:57 -0000

I've just acquired the ability to dump my TI & Geneve Zip disks to PC binary files. I know there is some editing to do to make them usable with MESS. Are there instructions anywhere?

Tony

---

From: "Beery" <[email-masked]>
Date: Fri, 13 Aug 2010 16:08:50 -0000

The first thing to do is to find the source for IMGTOOL.  That will give you the structure of the file.  Modifying the C code for IMGTOOL may be the easiest route if you are into writing code for something under a MS-DOS or Windows system.

There was one gentleman if he decides to speak up, that had written a utility to dump a hard drive to a file.  As I recall, that worked with an older CHD format.  MESS now uses a newer CHD format and I am not sure how easy that can be done as that was several years ago I last heard it mentioned.

Beery

---

From: "Tony Knerr" <[email-masked]>
Date: Fri, 13 Aug 2010 17:04:04 -0000

I've already got the dumps of the drives, Beery. HEX WORKSHOP has the ability to do that. Tim has sent me instructions, Thanks Tim! It involves making sure the sector 0 data is correct and several steps using CHDMAN.

Tony

---

From: "Michael Zapf" <[email-masked]>
Date: Fri, 13 Aug 2010 18:17:42 -0000

Hello Tony,

> I've just acquired the ability to dump my TI & Geneve Zip disks to PC binary files. I know there is some editing to do to make them usable with MESS. Are there instructions anywhere?

www.ninerpedia.org

It's for just this reason, for finding again the information that have popped up here and there, that I try to write everything down. 

Any suggestions how I can make this website more prominent are welcome.

For *everything* related to MESS I recommend to visit www.ninerpedia.org. You will find notes on current and past versions, on how to use it, converting images, and more.

Did I already mention www.ninerpedia.org?

If not, just have a visit at www.ninerpedia.org. I'm currently reorganising some pages at www.ninerpedia.org to make it more usable.

(Not meant so seriously, don't worry :-) )

Michael

---

From: "Tony Knerr" <[email-masked]>
Date: Fri, 13 Aug 2010 19:10:17 -0000

Thank you. The conversion process does indeed work. 

I have SCSI 100mb ZIP drives on my Geneve and TI994/P's. I connected an IDE 100mb ZIP drive to my PC for the dumping process. I opened the ZIP drive in HEX WORKSHOP and dumped all the sectors to a file. I then followed the conversion process from ninerpedia and ended up with a working emulated drive. FYI, if anyone is converting 100mb ZIP disks, the value for cylinders is 768.

Tony

--- In [email-masked], "Michael Zapf" <newsmail09@...> wrote:
>...

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 13 Aug 2010 17:16:18 -0500

Perfect. As I mentioned to Bill, I could not recall where you (Michael) 
had documented the 
process and updated/bettered it, so I just sent
Tony my saved info as
 a starting point. Essentially, if your platter works
 on the TI or Geneve,it 
should work in MESS with a few tweaks, depending
on how it was formatted.

One personal caveat is that I 
started making backups of my platters, both
physical and virtual, and
 have a bit of a library mess (if you
will pardon the pun) to clean 
up.  For example, MDOS RC3 code
got spread across virtual and 
physical disks, making for a very
ugly identification process.  
That's what I get for using the 
two environments too easily for test
 purposes... :(

tim

> To: [email-masked]
> From: [email-masked]
> Date: Fri, 13 Aug 2010 18:17:42 +0000
> Subject: [TI994A] www.ninerpedia.org
> 
> 
> 
> Hello Tony,
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: "Postle" <[email-masked]>
Date: Sat, 14 Aug 2010 15:50:52 -0000

Tony,

Does that mean that TI-99/4A data files can be down loaded from the net via the ZIP Drives?  But, you said that ~ I think!

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], "Tony Knerr" <tonyknerr@...> wrote:
> --- In [email-masked], "Michael Zapf" <newsmail09@> wrote:
> >
> > 
> > 
> > Hello Tony,
> >

---

From: "Tony Knerr" <[email-masked]>
Date: Sat, 14 Aug 2010 17:34:56 -0000

Not exactly. The idea is to transfer the contents of a real TI or Geneve hard drive to a hard drive "file" on a PC. This file can then be used with the MESS emulator to access all of the same data the user has on their real TI or Geneve hard drives.

In my case, I have zip drives on both my TI99/4P and Geneve systems.
By connecting a zip drive to my PC, I can now transfer the contents of those zip disks from my TI & Geneve systems for use with the MESS emulator on my PC.

A whole lot easier than walking back and forth several hundred times to transfer floppies from the TI/Geneve to PC.

Tony

---

From: fdos <[email-masked]>
Date: Mon, 16 Aug 2010 09:46:00 -0700

Exactly, and I have lots of SyQuest EZ135MB & EZFler230MB cartridges 
that I want to do the same with as soon as I mount an internal IDE 
EZFlyer230MB drive in my TI peripheral PC.

Bill S