Subject: Re: [TI994A] TurboForth preparation

From: [email-masked]
Date: Sat, 10 Apr 2010 15:02:49 EDT

I checked, the screens are linked so 58 LOAD will load all three of  them.
 
Bob  Carmany  

In a message dated 4/10/2010 1:54:52 P.M. Eastern Daylight Time,  
[email-masked] writes:

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 12:15:41 -0700

Yes, TI did that too.  I hate that --> method as it doesn't work well 
with THRU.

Forth+ and X4th99 are LOAD and THRU exclusive, and no SCREENS/BLOCKS 
contain the --> word.  Brodie's book THINKING FORTH forwards the KISS 
principle of Forth style in a most excellent manner that I subscribe to 
totally.

Having KISS with Forth fun here. :-)

Bill S

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 15:16:48 -0400

Brilliant!!  Thanks, I'll be Forthing the shift out of some code  
tonight!  :)

Owen Brand
Opry99er.com

On Apr 10, 2010, at 3:02 PM, [email-masked] wrote:

> In a message dated 4/10/2010 1:54:52 P.M. Eastern Daylight Time, [email-masked] 
>  writes:
>
>

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 17:19:58 -0400

Wrote my first screen clear word... It's not an example in the book  
and there is probably much faster ways to do it, but I just wanted to  
see if it worked.

: CLEAR 768 0 DO 32 EMIT LOOP ;

:)

Owen Brand
Opry99er.com

On Apr 10, 2010, at 3:15 PM, fdos <[email-masked]> wrote:

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 14:49:01 -0700

Owen,

You'll need a starting screen location for that to work in all cases. 
Faster ways; by all means yes.  Just type CLS in TI FORTH.  Hint: try 
writing directly to VDP.  Forth doesn't limit you to conventional 
thinking--try THINKING FORTH.

Bill S

Owen Brand wrote:
> On Apr 10, 2010, at 3:15 PM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>> wrote:
> 
>  > [email-masked] <mailto:rmcarmany%40aol.com> wrote:
>  >>
>  >>
>  >> [email-masked] <mailto:fdosbrs%40frontiernet.net> writes:
>  >>
>  >>
>  >>
>  >
>  >

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 17:52:42 -0400

Thanks Bill!  I'm working on that last part... I'm still in XB mode in  
my head right now, but Im learning!  I'm working with Wycove right  
now--- I'll try CLS.  :). As far as using the VDP, I'm not that far  
along yet... Just now learning how to properly use the command line.  :)

Owen Brand
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 17:56:10 -0400

: TEST CLS ." I'M LEARNING FORTH " ;

:)

Owen Brand
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 18:49:05 -0400

Damn!!!! Six chapters of fun and then chapter 7 drops all the math  
crap on me... :) Ive read so many books about computer-speak and I  
STILL hate bits and bytes.  It just doesn't make the kind of sense  
necessary for me to take another step.  That's where I got hung up in  
Molesworth, Lottrup, Morley, etc. Not JUST bits and bytes, but the  
whole "base" concept (other than 10) is foreign.  When I do the  
examples in these books, it always "kinda" makes sense and then the  
next day, it's just as foreign as if I picked up a Chinese textbook.   
How it all applies to the language, how it applies to the hardware,  
etc... That's why I took XB and ran with it... I didn't need to know  
any of that.  I get the concepts okay, but I never could quite firm it  
all up in my head.  So--- this is me expressing my first "BLAH!!!" in  
learning Forth.  :) I'll get through it... Until then, chapter 7 will  
probably take me as long as the first 6 did combined.

Owen Brand
Opry99er.com

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 16:31:45 -0700

Owen,

None of us learned this stuff overnight, so when you hit something that 
bogs you down--stay with it.  Ask questions in respect to what puzzles 
you about the specific subject or behavior.  Someone here will 
eventually explain it in a way that makes sense to you, and it will be 
wonderful when the light comes on and you understand clearly.

Like you say, this part is not much different than what you have to 
learn in AL also.  However, in Forth you can do it right at the terminal 
keyboard.  Don't forget .S and change the BASE from DECIMAL to HEX TO 
BINARY and back to DECIMAL typing .S after each BASE change.  Pay lots 
of attention to HEX output as you proceed.  You will learn to love HEX 
almost as much as SEX--uh, not really! :-)

Bill S

Owen Brand wrote:
> On Apr 10, 2010, at 5:49 PM, fdos <[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>
>  >>> [email-masked] <mailto:rmcarmany%40aol.com> 
> <mailto:rmcarmany%40aol.com> wrote:
>  >>>>
>  >>>>
>  >>>> [email-masked] <mailto:fdosbrs%40frontiernet.net> 
> <mailto:fdosbrs%40frontiernet.net> writes:
>  >>>>
>  >>>>
>  >>>>
>  >>>
>  >>>

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 10 Apr 2010 18:45:54 -0500

I suspect trying to learn XB, assembler, and Forth at the same time might
make the effort a bit more difficult.

> To: [email-masked]
> From: [email-masked]
> Date: Sat, 10 Apr 2010 16:31:45 -0700
> Subject: Re: [TI994A] TurboForth preparation
> 
> Owen,
> 
 		 	   		  
_________________________________________________________________
The New Busy is not the too busy. Combine all your e-mail accounts with Hotmail.
http://www.windowslive.com/campaign/thenewbusy?tile=multiaccount&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_4

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 19:51:08 -0400

Hehehe.... Well, I am really struggling with how all these things  
factor in practically with application building.  All the operators,  
single and double length numbers, many different number bases....  
Here's the page I'm on...

http://www.forth.com/starting-forth/sf7/sf7.html

I just can't see how this stuff relates.  It's just me, lacking a  
deeper understanding of how the computer communicates.  There just  
aren't good examples (in this particular chapter) for how to use this  
knowledge practically.  This is the only chapter so far that left me  
wanting for practical applications.  My natural inclination is to just  
go on to chapter 8.... But there were 20 or so Forth words "explained"  
in this chapter and I'm sure I'll need 'em later.  Please take a look  
at this link I sent and perhaps you could give me an illustration.  :)

Owen Brand
Opry99er.com

On Apr 10, 2010, at 7:31 PM, fdos <[email-masked]> wrote:

>>>>> principle of Forth style in a most excellent manner that I  
>>>>> subscribe
>>>>> to
>>>>> totally.
>>>>>
>>>>>> I checked, the screens are linked so 58 LOAD will load all  
>>>>>> three of
>>>>>> them.
>>>>>>
>>>>>> Bob Carmany
>>>>>>

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 20:01:38 -0400

My issue with the words in this chapter is that they are all applied  
to concepts that are foreign to me.  It's like someone explaining  
Martian grammar conventions.  Hard to understand the grammatical  
conventions for a language that you've never heard.  I just need to  
develop a better understanding of binary, hex, decimal, octal, and all  
the rest of these things... Then I need to figure out why all that is  
important for this language and then the Forth words they defined here  
will (hopefully) make sense.  This one chapter has exploded my  
freaking head.  :)

Owen Brand
Opry99er.com

On Apr 10, 2010, at 7:51 PM, Owen Brand <[email-masked]> wrote:

> aren't good examples (in this particular chapter) for how to use  
> this knowledge practically.  This is the only chapter so far that  
> left me wanting for practical applications.  My natural inclination  
> is to just go on to chapter 8.... But there were 20 or so Forth  
> words "explained" in this chapter and I'm sure I'll need 'em later.   
> Please take a look at this link I sent and perhaps you could give me  
> an illustration.  :)
>
> Owen Brand
> Opry99er.com
>

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 17:11:37 -0700

I learned XB and Forth during the same period of time.  After having 
thrown in the towel on AL.  Now I learn as much AL as I have to when I 
have to otherwise I just have Forth fun until then.

Bill S

Insane Multitasker wrote:
>  > > How it all applies to the language, how it applies to the hardwa re,
>  > > > thinking--try THIN KING FORTH.
>  > > >
>  > > > Bill S
>  > > >
>  > > > Owen Brand wrote:
>  > > >>
>  > > >>
>  > > >>> Yes, TI did that too. I hate that --> method as it doesn't work 
> well< br>> > >>> with THRU.
>  > > >>>
>  > > ; >
> ------------------------------------------------------------------------
> T he New Busy is not the too busy. Combine all your e-mail accounts with 
> Hotmail. Get busy. 
> <http://www.windowslive.com/campaign/thenewbusy?tile=multiaccount&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_4> 
> 
>

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 17:44:30 -0700

Owen,

I think I see the problem, they are explaining using a 32 bit OS while 
we children are using a 16 bit OS,  To us 32 bits is a double number 
that we don't learn until after we thoroughly understand 16 bit signed 
and unsigned numbers.  Also don't get involved with octal numbers at 
this time.  You may never need to know how to deal with octals.  Decimal 
and Hex values will be most important to you for a long time until you 
get into masking bits, ANDing, ORing XORing in order to change 
individual bits in a certain way; likewise with shifting bits.  You 
don't have to know all this to begin with as you can rely on, for the 
time being, the XB logic you've already learned.

In TI BASIC and XB you were living in a RADIX 100 floating point world, 
and even thinking that whole numbers were really integers.  Forth comes 
at number systems from the opposite end of the spectrum.  Real 16 bit 
integers instead of 8 byte floating point values.  This means you need 
the real Starting Forth book (first or second edition) that also uses 16 
bits in the explanations until they get to double numbers.

In most cases, you will be using 16 bit numbers for LOOPs you define and 
  memory addresses, etc.  This will probably always be the case if most 
of the applications you create are just games.  So go easy on yourself 
until you decide to code a spreadsheet application.  I did a checkbook 
program in Forth using double numbers--no floating point.  In time 
you'll understand all that you need to about number systems in Forth.

Bill S

Owen Brand wrote:
> <http://www.forth.com/starting-forth/sf7/sf7.html>
> 
> On Apr 10, 2010, at 7:31 PM, fdos <[email-masked] 
>  >>>>> well
> <mailto:rmcarmany%40aol.com>

---

From: "Ksarul" <[email-masked]>
Date: Sat, 10 Apr 2010 20:59:44 -0400

Sometime last year, there was a question here about the term "Johnny Box"
and what part of the /4A it belonged to.  I now have the definitive answer
to the question: it refers to the Peripheral Expansion Box.  The name was
used for it early in the development cycle.  Johnny was the first name of
one of the programmers working on the /4A, and the name was a reference to
him.  

Jim Fetzner

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 20:58:55 -0400

Excellent, thanks Bill.  I was losing it trying to figure out those  
insanely high numbers and 8 "bit blocks" instead of 4.  Octal was  
bothering me-- and the double length numbers... I need to just get the  
original book... I'll try to find a copy online for now while I wait  
to get a copy in hardback from somewhere... I saw a few on amazon.

Owen Brand
Opry99er.com

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 10 Apr 2010 20:37:54 -0500

That's not to say it is easy to accomplish both though I can see a few
parallels between the languages.  My original comment was related to
learning all three and an observation formed by reviewing all the emails of
late.

> Date: Sat, 10 Apr 2010 17:11:37 -0700
 		 	   		  
_________________________________________________________________
Hotmail has tools for the New Busy. Search, chat and e-mail from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_1

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 21:56:42 -0400

I'm finding that logic is logic.  The design, program flow, and syntax  
are different, but it's so cool how some things parallel one another  
in concept. You're right... The languages are very different... Namely  
the stack concept... But as you said, there are some cool parallels. :)

Owen Brand
Opry99er.com

On Apr 10, 2010, at 9:37 PM, Insane Multitasker <[email-masked]>  
wrote:

> > > > > >>> contain the --> word. Brodie's book THINKING FORTH  
> forwards the
> > > KISS
> --- 
> ---------------------------------------------------------------------
> > > <http://www.windowslive.com/campaign/thenewbusy?tile=multiaccount&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_4 
> >
> > >
> > >
> >
> >
> Hotmail has tools for the New Busy. Search, chat and e-mail from  
> your inbox. Learn more.
>

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 19:19:30 -0700

Yes, just catch your breath for a while, and let everything you're 
comfortable with sink in while you sleep on it.

Bill S

Owen Brand wrote:
> On Apr 10, 2010, at 8:44 PM, fdos <[email-masked] 
>  >> <http://www.forth.com/starting-forth/sf7/sf7.html 
> <http://www.forth.com/starting-forth/sf7/sf7.html>>
>  >>

---

From: fdos <[email-masked]>
Date: Sat, 10 Apr 2010 19:27:51 -0700

I wasn't try to say learning any of these programing languages is a cup 
of tea.  I was fortunate in my situation that I was learning Fig Forth 
ahead of TI BASIC, so my comfort zone was very different than that of 
Owen'x in that I had the hard stuff before the easy stuff.  That 
probably made a big difference.  Besides that I had a couple of real 
Forth gurus looking over my shoulder while I typed in example after example.

Bill S

Insane Multitasker wrote:
>  > > > From: fdosbrs@front iernet.net
>  > > > > next day, it' s just as foreign as if I picked up a Chinese 
> textbook.
> & gt; > > > > You'll need a starting screen location for that to work in 
> all cases.
>  > > > > >> :)< br>> > > > >>
>  > > > > >>> contain the --> word. Brodie's book THINKING FORTH forwards 
> the
>  > > KISS
>  > > > > >>> principle of Forth style in a most excellent m anner that I
>  > > subscribe
>  > > > > >>> to
>  > > > > >>> totally.
>  > > > > >>>
>  > > > > >>>> In a message dated 4/10/2010 1:54:52 P .M. Eastern 
> Daylight Time,
>  > > > > > Yaho o! Groups Links
> Hotmail has tools for the New Busy. Search, chat and e-mail from your 
> inbox. Learn more. 
> <http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:04201 
> 0_1>
>

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 10 Apr 2010 21:50:29 -0500

Which parallels have you seen so far?

To: [email-masked]
From: [email-masked]
Date: Sat, 10 Apr 2010 21:56:42 -0400
Subject: Re: [TI994A] TurboForth preparation

I'm finding that logic is logic.  The design, program flow, and syntax are different, but it's so cool how some things parallel one another in concept. You're right... The languages are very different... Namely the stack concept... But as you said, there are some cool parallels. :)

Owen Brand

Opry99er.com

On Apr 10, 2010, at 9:37 PM, Insane Multitasker <[email-masked]> wrote:

> > > > <mailto:fdosbrs%40frontiernet.net> writes:

Hotmail has tools for the New Busy. Search, chat and e-mail from your inbox. Learn more. 

_________________________________________________________________
The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail. 
http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Apr 2010 23:11:44 -0400

Defining a word is similar to building a SUB in XB.
Loop structure is similar
The nesting concept for the loops is much the same

While many things are different (postfix notation, the stack) I am  
finding it very easy to make "stuff" happen in Forth.  It's fast and  
fun.

Owen Brand
Opry99er.com

On Apr 10, 2010, at 10:50 PM, Insane Multitasker  
<[email-masked]> wrote:

> I'm finding that logic is logic.  The design, program flow, and  
> syntax are different, but it's so cool how some things parallel one  
> another in concept. You're right... The languages are very  
> different... Namely the stack concept... But as you said, there are  
> some cool parallels. :)
>
> Owen Brand
> Opry99er.com
>
> The New Busy think 9 to 5 is a cute idea. Combine multiple calendars  
> with Hotmail. Get busy.
>

---

From: ti99_forever <[email-masked]>
Date: Sat, 10 Apr 2010 20:22:51 -0700 (PDT)

And how are you doing that? Meaning are you using the Forth words that give you Basic-like equivalents? Or are you "rolling your own"?
You realize SUBs have private variables and that Forth words have access globally, except to those things on the stack? And that it is "hard" (not impossible) to nest more than two loops using the DO..LOOP construct?
--- On Sat, 4/10/10, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: Re: [TI994A] TurboForth preparation
To: "[email-masked]" <[email-masked]>
Date: Saturday, April 10, 2010, 11:11 PM

Defining a word is similar to building a SUB in XB.  Loop structure is similar The nesting concept for the loops is much the same
While many things are different (postfix notation, the stack) I am finding it very easy to make "stuff" happen in Forth.  It's fast and fun.  

Owen BrandOpry99er.com
On Apr 10, 2010, at 10:50 PM, Insane Multitasker <[email-masked]> wrote:

    

To: TI994A@yahoogroups. com
From: owenbrand@opry99er. com
Date: Sat, 10 Apr 2010 21:56:42 -0400
Subject: Re: [TI994A] TurboForth preparation

Owen Brand

Opry99er.com

On Apr 10, 2010, at 9:37 PM, Insane Multitasker <insane_m@hotmail. com> wrote:

> To: TI994A@yahoogroups. com
> From: fdosbrs@frontiernet .net
> > > To: TI994A@yahoogroups. com
> > > From: fdosbrs@frontiernet .net
> > > > On Apr 10, 2010, at 5:49 PM, fdos <fdosbrs@frontiernet .net
> > > > <mailto:fdosbrs% 40frontiernet. net>> wrote:
> > > >
> > > > > Owen,
> > > > >
> > > > >> On Apr 10, 2010, at 3:15 PM, fdos <fdosbrs@frontiernet .net
> > > > <mailto:fdosbrs% 40frontiernet. net>
> > > > >> <mailto:fdosbrs% 40frontiernet. net>> wrote:
> > > > >>
> > > > >>> rmcarmany@aol. com <mailto:rmcarmany%40aol.com>
> > > > >>>> fdosbrs@frontiernet .net <mailto:fdosbrs% 40frontiernet. net>
> > > > <mailto:fdosbrs% 40frontiernet. net> writes:
> > > > >>>>
> > > > >>>>
> > > > >>>>
> > > > >>>
> > > > >>>
> > > > >>> ------------ --------- --------- ------
> > > > >>>
> > > > >>> Yahoo! Groups Links
> > > > >>>
> > > > >>>
> > > > >>>
> > > > >>
> > > > >>
> > > > >
> > > > >
> > > > > ------------ --------- --------- ------
> > > > >
> > > > > Yahoo! Groups Links
> > > > >
> > > > >
> > > > ; >
> > > >
> > > >
> > >
> > >
> > > ------------ --------- --------- ------
> > >
> > > Yahoo! Groups Links
> > >
> > >
> > >
> > 
> > ------------ --------- --------- --------- --------- --------- --------- ------
> > <http://www.windowslive.com/campaign /thenewbusy? tile=multiaccoun t&ocid=PID28326: :T:WLMTAGL: ON:WL:en- US:WM_HMP: 042010_4> 
> > 
> > 
> 
> 
> ------------ --------- --------- ------
> 
> Yahoo! Groups Links
> 
> 
> 

 		 	   		  
The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail.  Get busy.

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 00:02:49 -0400

I've been rolling my own, I guess. The IF THEN equivalent is striking,  
and the structure of SUBs and words are similar.

X=5, Y=6

300 CALL EQUA(X,Y)

500 SUB EQUA(X,Y):: X+Y=Z :: CALL CLEAR :: PRINT Z :: SUBEND

: EQUA + CLS . ;

5 6 ->enter

EQUA

In this example, I entered the parameters (5 and 6) from the keyboard,  
but the numbers 5 and 6 would more than likely be passed onto the  
stack by another word for use prior to using EQUA.  Hope that makes  
sense... I'm just learning, but I love the concepts here!

Owen Brand
Opry99er.com

On Apr 10, 2010, at 11:22 PM, ti99_forever <[email-masked]>  
wrote:

> And how are you doing that? Meaning are you using the Forth words  
> that give you Basic-like equivalents? Or are you "rolling your own"?
>
> You realize SUBs have private variables and that Forth words have  
> access globally, except to those things on the stack? And that it is  
> "hard" (not impossible) to nest more than two loops using the  
> DO..LOOP construct?
>
>> > > > > >> and there is probably much faster ways to do it, but I  
>> just
>> > > wanted to
>> > > > > >> see if it worked.
>> > > > > >>
>> > > <http://www.windowslive.com/campaign /thenewbusy? tile=multiaccoun t&ocid=PID28326: :T:WLMTAGL: ON:WL:en- US:WM_HMP: 042010_4 
>> >
>> > >
>> > >
>> >
>> >

---

From: mark wills <[email-masked]>
Date: Sun, 11 Apr 2010 07:32:04 +0000 (GMT)

In TurboForth you could do

: CLEAR 0 0 GOTOXY 768 0 DO SPACE LOOP ;

or even faster

: CLEAR 0 0 GOTOXY 24 0 DO 32 SPACES LOOP ;

In TurboForth you want PAGE instead of CLS. Of course, you could define CLS as a synonym:

: CLS PAGE ;

----- Original Message ----
> Sent: Sat, 10 April, 2010 22:19:58
see if it worked.

: CLEAR 768 0 DO 32 EMIT LOOP 
> ;

:)

Owen Brand
Opry99er.com

On Apr 10, 2010, at 3:15 
> PM, fdos <
> href="mailto:[email-masked]">[email-masked]> 
> wrote:

> Forth+ and X4th99 are LOAD 
> and THRU exclusive, and no SCREENS/BLOCKS
> contain the --> word.  
> Brodie's book THINKING FORTH forwards the KISS
> principle of Forth style 
> in a most excellent manner that I subscribe  
> to
> 
> totally.
>
> href="mailto:[email-masked]">[email-masked] 
> wrote:
>>
>>
>> I checked, the screens are linked so 
> 58 LOAD will load all three of  
>> them.
>>
>> 
> Bob Carmany
>>
> href="mailto:[email-masked]">[email-masked] 
> writes:
>>
>>
>>
>
>
> 
> Yahoo! Groups 
> Links

Yahoo! 
> Groups Links

>   
> >http://groups.yahoo.com/group/TI994A/

> href="http://groups.yahoo.com/group/TI994A/join" target=_blank 
> >http://groups.yahoo.com/group/TI994A/join
    (Yahoo! ID 
> required)

> href="mailto:[email-masked]">[email-masked] 
> 
    
> href="mailto:[email-masked]">[email-masked]

> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]

> href="http://docs.yahoo.com/info/terms/" target=_blank 
> >http://docs.yahoo.com/info/terms/

---

From: mark wills <[email-masked]>
Date: Sun, 11 Apr 2010 07:33:51 +0000 (GMT)

It's not Forth though ;-) You'd have to learn that stuff in any language once you start to get close to the hardware.

What it it you're not getting?

Mark

----- Original Message ----
> Sent: Sat, 10 April, 2010 23:49:05
STILL hate bits and bytes.  It just doesn't make the kind of 
> sense  
necessary for me to take another step.  That's where I got 
> hung up in  
Molesworth, Lottrup, Morley, etc. Not JUST bits and bytes, 
> but the  
whole "base" concept (other than 10) is foreign.  When I 
> do the  
examples in these books, it always "kinda" makes sense and then 
> the  
next day, it's just as foreign as if I picked up a Chinese 
> textbook.  
How it all applies to the language, how it applies to the 
> hardware,  
etc... That's why I took XB and ran with it... I didn't need 
> to know  
any of that.  I get the concepts okay, but I never could 
> quite firm it  
all up in my head.  So--- this is me expressing my 
> first "BLAH!!!" in  
learning Forth.  :) I'll get through it... 
> Until then, chapter 7 will  
probably take me as long as the first 6 did 
> combined.

Owen Brand
Opry99er.com

On Apr 10, 2010, at 5:49 PM, 
> fdos <

>> see if it 
> worked.
>> On Apr 10, 2010, at 3:15 PM, fdos <
> ymailto="mailto:[email-masked]" 
>>> Forth+ and 
> X4th99 are LOAD and THRU exclusive, and no SCREENS/BLOCKS
>>> 
> ymailto="mailto:[email-masked]" 
>>>> I checked, 
> the screens are linked so 58 LOAD will load all three of
>>>> 
> them.
>>>>
>>>> Bob 
> Carmany
>>>>
> ymailto="mailto:[email-masked]" 
> Groups 

Yahoo! 

    (Yahoo! ID

---

From: mark wills <[email-masked]>
Date: Sun, 11 Apr 2010 07:40:43 +0000 (GMT)

Excellent advice from Uncle Bill the Forth Meister!

And the point about being able to do stuff right at the keyboard cannot be overstated.

Assembly can be disheartening when your program doesn't work and you are stuck in that code/assemble/load/test loop with *no clue* at all as to what is wrong.

Not with Forth. You can just tap away at the keyboard!

You can crash Forth pretty good if you do something silly. (as a test, try typing 0 >R on the command line in TI or Wycove forth. It'll probably go off into la la land.) But development in Forth is INCREMENTAL it is a member of the family of incremental languages such as Lisp.

Mark

----- Original Message ----
> From: fdos <[email-masked]>
> Sent: Sun, 11 April, 2010 0:31:45

None of us learned this stuff overnight, so when you hit something 
> that 
bogs you down--stay with it.  Ask questions in respect to what 
> puzzles 

Like 
> you say, this part is not much different than what you have to 
learn in AL 
> also.  However, in Forth you can do it right at the terminal 
> 

Bill S

Owen Brand 
> On 
> Apr 10, 2010, at 5:49 PM, fdos <
>  > Faster ways; by all 
> means yes. Just type CLS in TI FORTH. Hint: try
>  > writing 
> directly to VDP. Forth doesn't limit you to conventional
>  > 
>  > Bill 
> S
>  >> Wrote my first screen 
> clear word... It's not an example in the book
>  >> and there 
> is probably much faster ways to do it, but I just wanted to
>  
> >> see if it worked.
>  >>
>  >> : CLEAR 
> 768 0 DO 32 EMIT LOOP ;
>  >>
>  >> 
> :)
>  >>
>  >> Owen Brand
>  
> >> Opry99er.com
>  >>
>  >> On Apr 10, 
> 2010, at 3:15 PM, fdos <
>  >>> with 
> THRU.
>  >>> Forth+ and X4th99 
> are LOAD and THRU exclusive, and no SCREENS/BLOCKS
>  >>> 
>  >>> principle of Forth style in a most excellent 
> manner that I subscribe
>  >>> to
>  >>> 
> totally.
>  >>>
>  >>> Having KISS with 
> Forth fun here. :-)
>  >>>
>  >>> Bill 
> S
>  >>>
>  >>> 
>  >>>> I checked, the screens are 
> linked so 58 LOAD will load all three of
>  >>>> 
> them.
>  >>>>
>  >>>> Bob 
> Carmany
>  >>>>
>  >>>> In a 
> message dated 4/10/2010 1:54:52 P.M. Eastern Daylight Time,
>  
> >>>> 

Yahoo! Groups 

    (Yahoo! ID

---

From: mark wills <[email-masked]>
Date: Sun, 11 Apr 2010 07:48:47 +0000 (GMT)

I a nutshell, I would advise:

Don't worry about the double length numbers. I'd be very surprised if you have a use for them for games writing.

The binary stuff IS useful information though.

You will need to get your head around signed and unsigned numbers. Signed numbers use the most significant bit as a flag to say "hey, this number is negative".

----- Original Message ----
> Sent: Sun, 11 April, 2010 0:51:08
factor in practically with application building.  All the 
> operators,  
single and double length numbers, many different number 
> bases....  

> href="http://www.forth.com/starting-forth/sf7/sf7.html" target=_blank 

I just can't see 
> how this stuff relates.  It's just me, lacking a  
deeper 
> understanding of how the computer communicates.  There just  
> 
knowledge practically.  This is the only chapter so far that left 
> me  
wanting for practical applications.  My natural inclination is 
> to just  
go on to chapter 8.... But there were 20 or so Forth words 
> "explained"  
in this chapter and I'm sure I'll need 'em later.  
> Please take a look  
at this link I sent and perhaps you could give me 

Owen Brand
Opry99er.com

On Apr 10, 
> 2010, at 7:31 PM, fdos <

> bogs you 
> down--stay with it.  Ask questions in respect to what puzzles
> you 
> about the specific subject or behavior.  Someone here will
> 
> learn in AL also.  However, in Forth you can do it right at the  
> 
> terminal
>> next day, it's just as 
> foreign as if I picked up a Chinese textbook.
>> How it all applies to 
> the language, how it applies to the hardware,
>> etc... That's why I 
> took XB and ran with it... I didn't need to know
>> any of that. I get 
> the concepts okay, but I never could quite firm it
>> all up in my 
> head. So--- this is me expressing my first "BLAH!!!" in
>> learning 
> Forth. :) I'll get through it... Until then, chapter 7 will
>> probably 
> take me as long as the first 6 did combined.
>>
>> Owen 
> Brand
>> Opry99er.com
>>
>> On Apr 10, 2010, at 5:49 
> PM, fdos <
>>> You'll need a starting screen location for 
> that to work in all  
>>> cases.
>>> Faster ways; 
> by all means yes. Just type CLS in TI FORTH. Hint: try
>>> writing 
>>>> Wrote my 
> first screen clear word... It's not an example in the book
>>>> 
> and there is probably much faster ways to do it, but I just  
> 
>>>> wanted to
>>>> see if it 
> worked.
>>>>
> and THRU exclusive, and no SCREENS/ 
>>>>> 
> BLOCKS
>>>>> contain the --> word. Brodie's book THINKING 
> FORTH forwards the  
>>>>> KISS
>>>>> 
>>>>>> In a message 
> dated 4/10/2010 1:54:52 P.M. Eastern Daylight Time,
>>>>>> 
> 

Yahoo! 

    (Yahoo! ID

---

From: mark wills <[email-masked]>
Date: Sun, 11 Apr 2010 07:50:19 +0000 (GMT)

Shifting shouldn't be a foriegn concept to you. You would use it to scroll a character, for example.

----- Original Message ----
> Sent: Sun, 11 April, 2010 1:01:38
conventions for a language that you've never heard.  I just need 
> to  
develop a better understanding of binary, hex, decimal, octal, and 
> all  
the rest of these things... Then I need to figure out why all that 
> is  
important for this language and then the Forth words they defined 
> here  
will (hopefully) make sense.  This one chapter has exploded 
> my  
freaking head.  :)

Owen Brand
Opry99er.com

On 
> Apr 10, 2010, at 7:51 PM, Owen Brand <
> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]> 
> wrote:

> I just 
> can't see how this stuff relates.  It's just me, lacking a  
> 
> an illustration.  
>> None of us learned this 
> stuff overnight, so when you hit something  
>> that
>> 
>> eventually explain it in a way 
> that makes sense to you, and it will  
>> be
>> wonderful 
> when the light comes on and you understand clearly.
>>
>> Like 
>> learn 
> in AL also.  However, in Forth you can do it right at the  
> 
>> terminal
>> BINARY and back to DECIMAL typing .S 
> after each BASE change.  Pay  
>> lots
>> of 
> attention to HEX output as you proceed.  You will learn to love  
> 
>> HEX
>>> Damn!!!! Six chapters of 
> fun and then chapter 7 drops all the math
>>> crap on me... :) Ive 
> read so many books about computer-speak and I
>>> STILL hate bits 
> and bytes. It just doesn't make the kind of sense
>>> necessary for 
> me to take another step. That's where I got hung up in
>>> 
>>> any of that. I get the concepts 
> okay, but I never could quite firm  
>>> it
>>> all 
> up in my head. So--- this is me expressing my first "BLAH!!!" in
>>> 
>>> On Apr 10, 2010, at 5:49 PM, fdos 
> <
>>>> You'll need a starting screen 
> location for that to work in all  
>>>> 
> cases.
> Wrote my first screen clear word... It's not an example in the  
> 
>>>>> book
>>>>> wanted 
>>>>>> Yes, TI did that too. 
> I hate that --> method as it doesn't work  
>>>>>> 
> well
>>>>>> with 
> THRU.
>>>>>>
>>>>>> Forth+ and X4th99 
> are LOAD and THRU exclusive, and no SCREENS/ 
>>>>>> 
> BLOCKS
>>>>>> contain the --> word. Brodie's book 
> THINKING FORTH forwards the  
>>>>>> 
> KISS
> manner that I  

Yahoo! 

    (Yahoo! ID

---

From: mark wills <[email-masked]>
Date: Sun, 11 Apr 2010 08:00:12 +0000 (GMT)

Sorry to contradict, but it's very easy to next loops to any level:

DO
.DO
..DO
...DO
...LOOP
..LOOP
.LOOP
LOOP

However, you cannot access the index's (with I and J) with deeply nested loops, which is probably what you meant. I won't go into why it's difficult because we might explode Owen's head (it's to do 
with the return stack). The solution to that is to factor, and move those loops into their own words, which has the benefit of producing more readable code. 

>
>From: ti99_forever <[email-masked]>
>Sent: Sun, 11 April, 2010 4:22:51
________________________________
>>>> after each BASE change. Pay lots
>>>> 2010, at 5:49 PM, fdos <fdosbrs@frontiernet .net
>>>>________________________________
>>>________________________________

---

From: ti99_forever <[email-masked]>
Date: Sun, 11 Apr 2010 01:50:53 -0700 (PDT)

Exactly. You usually want to access the indexes. And factoring can be a foreign concept to a Basic programmer.

That skill must be mastered first, IMHO, hand-in-hand with bottom-up design in Forth.

--- On Sun, 4/11/10, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] TurboForth preparation
To: [email-masked]
Date: Sunday, April 11, 2010, 4:00 AM

DO
.DO
..DO
...DO
...LOOP
..LOOP
.LOOP
LOOP

 

        

Owen BrandOpry99er.com

    

Owen Brand

Opry99er.com

  

 wanted to

---

From: mark wills <[email-masked]>
Date: Sun, 11 Apr 2010 08:57:28 +0000 (GMT)

>In this example, I entered the parameters (5 and 6) from the keyboard, 
but the numbers 5 and 6 would more than likely be passed onto the stack 
by another word for use prior to using EQUA.  Hope that makes sense... 
I'm just learning, but I love the concepts here! 

You sound almost apologetic, but you shouldn't be. That is EXACTLY what you are supposed to do. You're getting it. You build your "program" word by word, testing as you go by feeding your words data from the stack:

: ODD? DUP 1 AND IF . ." IS ODD" ELSE . ." IS EVEN" THEN CR ;

1 ODD? <enter>
1 IS ODD
ok
200 ODD?
200 IS EVEN
ok

Here, we are testing our word ODD? from the command line. When you have tested it and you happy that it works, you can move on and forget about it.

In this way, programs are built 'incrementally' - as you go. They are "grown" more than written. I tend to write XB programs in the same way using SUBs.

-------

I want to say a little something about "programs" in Forth, but if this blows your head, just forget about it for now. There is no such thing as a "program" really in Forth. They are just a collection of words in a dictionary. What you are actually doing when you write a word is expanding Forth itself...

Think about it. That word we just wrote: ODD? It now exists in your Forth system in exactly the same way as any other word like + - .S DUP etc. They are just words that exist. The art is writing words that call other words that actually do what you want to accomplish. If that makes sense.

The paradigms introduced in Forth are *so* different from other 'rigid' procedural languages, that for a good while the feeling is uncomfortable. It's like God turned gravity the other way up. Nothing feels familiar. Everything is weird and strange. But you start to get used to it. After a while, when you go back to other languages, you will feel limited and constrained and catch yourself uttering "Heck, I could do this in two minutes in Forth".

The 'strange feeling' is one of the reasons (I think) for Forth's limited success. Most languages these days are aimed at dumbing down, and making things easier. Forth puts you in firm control. If you screw up, tough. This perceived difficulty is what turns a lot of people off. That and the stack. As I mentioned in a previous mail, in most languages, you only manage execution flow. In Forth, you manage execution flow, AND data flow, as you have to manage the stack. It is harder, there's no doubt. This turns lazy people off. Myself included. I used to read Forth code posted by Stephen Shaw in TI*MES and think "what a total load of crap", because *I* couldn't understand it, and *I* am a genius programmer, because my mum says so (I was young) therefore if *I* can't understand it, it must be crap.

I wish I had taken the time back then, but, then again, I may have been too young to appreciate Forth fully.

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 07:50:09 -0400

thanks mark!  I really am having fun with this language... I still  
have no idea how to work up and package a game, I have no idea how to  
redefine ASCII and display onscreen, colors, etc... Right now I'm just  
learning how to speak the language in it's most basic sense. I  
sometimes feel as though I don't have the knowledge of numbers and  
mathematical operations to do much with AL, but with Forth and XB, I  
feel like the actual words and syntax are real explanations of  
concepts.  For instance CLS, PAGE, CALL CLEAR all do the same thing  
and it's pretty clear what that is by the short sweet "names" of these  
terms.  In AL, well.... Click this link.
http://www.opry99er.com/clearing-the-screen.php

Matthew Hagerty made an excellent tutorial on clearing the screen  
which is on my website.  While he explains it very elegantly and  
comments very thoroughlly, it takes almost a whole page.  DEF, REQ,  
LI, BL..... just dozens of lines of code to tell the computer how to  
do something...  Now before I get bombarded with "BUT YOU DONT  
UNDERSTAND!!!," I realize the machine code is much faster because of  
the nature of it--- starting from nothing, assigning bits/bytes of  
data to locations in memory, and executing it on that basis is what  
makes AL so intriguing (and confusing) to me.  I know how powerful the  
language is because you're almost physically sitting at a railroad  
terminal and pulling levers to make certain track lanes open and close  
as you design from scratch.  I would love to be able to do this  
because as I read Filip's tutorials and Matthews tutorials etc., it  
seems to me that an AL programmer can get ANYTHING he wants (within  
the framework of the hardware) out of the machine, without regard to  
any language's "shortcomings". That being said--- the only shortcoming  
I find in XB as it applies
To my own game programming is speed and the inability to have 2  
"things" working at once.  (joystick AND music, scrolling, etc). Of
Course you can LINK up with AL, but if you don't speak the latter, you  
are at the mercy of the kindness of AL programmers to help build  
subroutines.   Forth, I think, will solve these issues for me.  :)

Owen Brand
Opry99er.com

On Apr 11, 2010, at 4:57 AM, mark wills <[email-masked]>  
wrote:

> >In this example, I entered the parameters (5 and 6) from the  
> keyboard, but the numbers 5 and 6 would more than likely be passed  
> onto the stack by another word for use prior to using EQUA.  Hope  
> that makes sense...  I'm just learning, but I love the concepts here!
>
>
>
> You sound almost apologetic, but you shouldn't be. That is EXACTLY  
> what you are supposed to do. You're getting it. You build your  
> "program" word by word, testing as you go by feeding your words data  
> from the stack:
>
> Here, we are testing our word ODD? from the command line. When you  
> have tested it and you happy that it works, you can move on and  
> forget about it.
>
> In this way, programs are built 'incrementally' - as you go. They  
> are "grown" more than written. I tend to write XB programs in the  
> same way using SUBs.
>
> -------
>
> I want to say a little something about "programs" in Forth, but if  
> this blows your head, just forget about it for now. There is no such  
> thing as a "program" really in Forth. They are just a collection of  
> words in a dictionary. What you are actually doing when you write a  
> word is expanding Forth itself...
>
> Think about it. That word we just wrote: ODD? It now exists in your  
> Forth system in exactly the same way as any other word like + - .S  
> DUP etc. They are just words that exist. The art is writing words  
> that call other words that actually do what you want to accomplish.  
> If that makes sense.
>
> The paradigms introduced in Forth are *so* different from other  
> 'rigid' procedural languages, that for a good while the feeling is  
> uncomfortable. It's like God turned gravity the other way up.  
> Nothing feels familiar. Everything is weird and strange. But you  
> start to get used to it. After a while, when you go back to other  
> languages, you will feel limited and constrained and catch yourself  
> uttering "Heck, I could do this in two minutes in Forth".
>
> The 'strange feeling' is one of the reasons (I think) for Forth's  
> limited success. Most languages these days are aimed at dumbing  
> down, and making things easier. Forth puts you in firm control. If  
> you screw up, tough. This perceived difficulty is what turns a lot  
> of people off. That and the stack. As I mentioned in a previous  
> mail, in most languages, you only manage execution flow. In Forth,  
> you manage execution flow, AND data flow, as you have to manage the  
> stack. It is harder, there's no doubt. This turns lazy people off.  
> Myself included. I used to read Forth code posted by Stephen Shaw in  
> TI*MES and think "what a total load of crap", because *I* couldn't  
> understand it, and *I* am a genius programmer, because my mum says  
> so (I was young) therefore if *I* can't understand it, it must be  
> crap.
>
> I wish I had taken the time back then, but, then again, I may have  
> been too young to appreciate Forth fully.
>
>
>

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 08:17:28 -0400

Thanks for the advice Ben!  I'll study up on factoring and indexes  
today--- at least START studying.  :)

Owen Brand
Opry99er.com

On Apr 11, 2010, at 4:50 AM, ti99_forever <[email-masked]>  
wrote:

> Exactly. You usually want to access the indexes. And factoring can  
> be a foreign concept to a Basic programmer.
>
> However, you cannot access the index's (with I and J) with deeply  
> nested loops, which is probably what you meant. I won't go into why  
> it's difficult because we might explode Owen's head (it's to do with  
> the return stack). The solution to that is to factor, and move those  
> loops into their own words, which has the benefit of producing more  
> readable code.
>
>
>
>> hardwa re,

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 08:22:03 -0400

Yea, I actually found that paragraph to be readable.  It's a bit vague  
on a couple points-- (from my perspective)-- but I looked up some  
stuff on google and filled out my splotchy understanding.

Owen Brand
Opry99er.com

On Apr 11, 2010, at 3:48 AM, mark wills <[email-masked]>  
wrote:

> Don't worry about the double length numbers. I'd be very surprised  
> if you have a use for them for games writing.
>
> You will need to get your head around signed and unsigned numbers.  
> Signed numbers use the most significant bit as a flag to say "hey,  
> this number is negative".
>

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 09:32:38 -0400

Mark, I'm modifying Wycove to be a bit closer to TurboForth.  GOTOXY  
is not defined in Wycove... I'm trying to find the equivalent.... I've  
already added PAGE so I can get used to it instead of CLS.  GOTOXY  
appears to set the starting screen position to 0,0?  Is that the same  
as 1,1 in XB?  Anyway, I'm just trying to modify Wycove's dictionary  
to be more inline with TurboForth's, so anything you can send me to  
modify my built-in dictionary to be closer to yours, I'd love to have  
it.  You have a word list/glossary I can use to roll these TurboForth  
conventional words into Wycove?  Thanks

Owen Brand
Opry99er.com

---

From: "ti99_forever" <[email-masked]>
Date: Sun, 11 Apr 2010 14:28:43 -0000

I believe it is in the compatibility screens... it may be called AT.

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Apr 11, 2010, at 3:32 AM, mark wills <markrobertwills@...>  
> wrote:
> 
> > > From: Owen Brand <owenbrand@...>
> > > href="mailto:fdosbrs@...">fdosbrs@...>
> > > wrote:
> >
> > > href="mailto:rmcarmany@...">rmcarmany@...
> > > wrote:
> > >>
> > >>
> > > href="mailto:fdosbrs@...">fdosbrs@...
> > > writes:
> > >>
> > >>
> > >>
> > >
> > >
> > >

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 10:32:38 -0400

Thanks!  I'll check that out.

Owen Brand
Opry99er.com

---

From: Owen Brand <[email-masked]>
Date: Sun, 11 Apr 2010 10:41:51 -0400

How do I go about loading it up?  I'm having a bit of an issue trying  
to access my menu screen.  MENU returns MENU? I haven't tried anything  
like this yet... So far i've just been playing on the command line.

Owen Brand
Opry99er.com

---

From: fdos <[email-masked]>
Date: Sun, 11 Apr 2010 23:39:47 -0700

Au contraire mon ami, Forth VOCABULARIES can be used to isolate 
VARIABLES & CONSTANTS just like they isolate ordinary compiled code, so 
quite similar to an XB SUB Program.  Just check out the TI FORTH EDITORA 
VOCABULARY to see what I mean.

It is true that DO LOOPs only provide two variables (I & J) for 
immediate use, but the user is also free to provide as many VARIABLES as 
he cares to create (or just a simple array) within the word containing 
the subject DO LOOPs, but a better way is to factor the DO LOOPs in 
separate words, so I & J can be used normally.

Bill S.

ti99_forever wrote:
>  
> 
> And how are you doing that? Meaning are you using the Forth words that 
> give you Basic-like equivalents? Or are you "rolling your own"?
> 
> You realize SUBs have private variables and that Forth words have access 
> globally, except to those things on the stack? And that it is "hard" 
> (not impossible) to nest more than two loops using the DO..LOOP construct?
> 
> --- On *Sat, 4/10/10, Owen Brand /<[email-masked]>/* wrote:
> 
> 
>     Opry99er.com <http://Opry99er.com>
> 
>     <[email-masked] </mc/compose?to=[email-masked]>> wrote:
> 
>>      
>>
>>     syntax are different, but it's so cool how some things parallel
>>     one another in concept. You're right... The languages are very
>>     different... Namely the stack concept... But as you said, there
>>     are some cool parallels. :)
>>
>>     Owen Brand
>>     <http://opry99er.com/>Opry99er.com <http://Opry99er.com>
>>
>>     On Apr 10, 2010, at 9:37 PM, Insane Multitasker <insane_m@hotmail.
>>     com </mc/compose?to=[email-masked]>> wrote:
>>
>>          
>>         > > > > <http://opry99er.com/>
>>         <http://opry99er.com/>Opry99er.com <http://Opry99er.com>
>>         > > > >
>>         > > > > >> <http://opry99er.com/>
>>         <http://opry99er.com/>Opry99er.com <http://Opry99er.com>
>>         > > > > >>
>>         > > > > >>> rmcarmany@aol. com <mailto:rmcarmany%
>>         <http://40aol.com/>40aol.com <http://40aol.com>>
>>         > > > > ; <mailto:rmcarmany% <http://40aol.com/>40aol.com
>>         <http://40aol.com>> wrote:
>>         > > > > >>>>
>>         > > > > >>>>
>>         > > < <http://www.windowsl/>
>>         <http://www.windowsl/>http://www.windowsl
>>         <http://ive.com/campaign>ive.com/campaign
>>         <http://ive.com/campaign> /thenewbusy? tile=multiaccoun
>>         t&ocid=PID28326: :T:WLMTAGL: ON:WL:en- US:WM_HMP: 042010_4>
>>         > >
>>         > >
>>         >
>>         >
>>         <http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_1>
>>
>>
>>
>>
>>
>>     <http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5>
>>
>>
> 
> 
> 
>

---

From: fdos <[email-masked]>
Date: Sun, 11 Apr 2010 23:40:00 -0700

Owen,

I'm not sure I follow you on this.

Bill S

Owen Brand wrote:
> On Apr 10, 2010, at 11:22 PM, ti99_forever <[email-masked] 
> <mailto:[email-masked]>> wro te:
> 
>>  
>>
>> "hard" (not impossible) to nest more than two loops using the DO..LOOP 
>> construct?
>>
>>     finding it very easy to make "stuff" happen in Forth.  It's fast
>>     and fun.  
>>
>>
>>
>>     Owen Brand
>>     <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>
>>>     <http://opry99er.com/> <http://Opry99er.com>Opry99er.com
>>>     <http://Opry99er.com>
>>>
>>>     On Apr 10, 2010, at 9:37 PM, Insane Multitasker
>>>     <insane_m@hotmail. com </mc/compose?to=[email-masked]>> wrote:
>>>
>>>          
>>>         > > > > <http://opry99er.com/> <http://opry99er.com/>
>>>         <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>>         > > > >
>>>         <fdosbrs@frontiernet .net
>>>         > > > > >> <http://opry99er.com/> <http://opry99er.com/>
>>>         <http://Opry99er.com>Opry99er.com <http://Opry99er.com>
>>>         > > > > >>
>>>         > > > > >>> Yes, TI did that too. I hate that --> method as
>>>         it doesn't work < br>> > well< br>> > >>> with THRU.
>>>         > > > > >>>
>>>         > > > > >>> Forth+ and X4th99 are LOAD and THRU exclusive,
>>>         and no
>>>         > > SCREENS/BLOCKS
>>>         <http://40aol.com/> <http://40aol.com>40aol.com
>>>         <http://40aol.com>>
>>>         > > > > <mailto:rmcarmany% <http://40aol.com/>
>>>         <http://40aol.com>40aol.com <http://40aol.com>> wrote:
>>>         > > > > >>>>
>>>         > > > > >>>>
>>>         > > < <http://www.windowsl/> <http://www.windowsl/>
>>>         <http://www.windowsl>http://www.windowsl
>>>         <http://ive.com/campaign>
>>>         > (Yahoo! ID required)
>>>         *
>>>         *Hotmail has tools for the New Busy. Search, chat and e-mail
>>>         from your inbox. Learn more.
>>>         *
>>>     *
>>>     *
>>>     *
>>>     *
>>>     *The New Busy think 9 to 5 is a cute idea. Combine multiple
>>>     calendars with Hotmail. Get busy.
>>>     *
>>>     * *
>>>     * *
>>     *
>>     *

---

From: fdos <[email-masked]>
Date: Sun, 11 Apr 2010 23:40:12 -0700

In TI FORTH you could write it this way after loading -SYNONYMS:

: PAGE  0 0 GOTOXY CLS ;  ( CLS is a system CALL so very fast )

Bill S

mark wills wrote:
>  > From: Owen Brand <[email-masked] 
> <mailto:owenbrand%40opry99er.com>>
>  > To: "[email-masked] <mailto:TI994A%40yahoogroups.com>" 
> <[email-masked] <mailto:TI994A%40yahoogroups.com>>
>  > href="mailto:[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>">[email-masked] 
>  > href="mailto:[email-masked] 
> <mailto:rmcarmany%40aol.com>">[email-masked] 
>  > href="mailto:[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>">[email-masked] 
> <http://groups.yahoo.com/group/TI994A/>
> 
>  > href="http://groups.yahoo.com/group/TI994A/join 
> <http://groups.yahoo.com/group/TI994A/join>" target=_blank
> <http://groups.yahoo.com/group/TI994A/join>
> (Yahoo! ID
>  > required)
> 
>  > href="mailto:[email-masked] 
> <mailto:TI994A-digest%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-digest%40yahoogroups.com>
>  >
> 
>  > href="mailto:[email-masked] 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>
> 
>  > ymailto="mailto:[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>"
>  > href="mailto:[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>">[email-masked] 
> <mailto:TI994A-unsubscribe%40yahoogroups.com>
> 
>  > href="http://docs.yahoo.com/info/terms/ 
> <http://docs.yahoo.com/info/terms/>" target=_blank
>  > >http://docs.yahoo.com/info/terms/ <http://docs.yahoo.com/info/terms/>
> 
>

---

From: fdos <[email-masked]>
Date: Sun, 11 Apr 2010 23:40:22 -0700

Maybe a little too advanced for now as I didn't learn how to do any bit 
stuff until several years after I was dedicated to Forth programing.  I 
do find it very useful now days.

Bill S

mark wills wrote:
>  > To: [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > ymailto="mailto:[email-masked] 
> <mailto:owenbrand%40opry99er.com>"
>  > href="mailto:[email-masked] 
> <mailto:owenbrand%40opry99er.com>">[email-masked] 
>  > href="http://www.forth.com/starting-forth/sf7/sf7.html 
> <http://www.forth.com/starting-forth/sf7/sf7.html>" target=_blank
>  > ymailto="mailto:[email-masked] <mailto:rmcarmany%40aol.com>"
>  > ymailto="mailto:[email-masked] 
> <mailto:fdosbrs%40frontiernet.net>"

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 00:02:55 -0700

Also wrong.  Forth development is best suited to top down design, but 
bottom up implementation.  See TI FORTH manual Chapter 1 page 3.

Bill S

ti99_forever wrote:
> --- On *Sun, 4/11/10, mark wills /<[email-masked]>/* wrote:
> 
> 
>         *From:* ti99_forever <[email-masked]>
>         *To:* [email-masked]
>         *Sent:* Sun, 11 April, 2010 4:22:51
>         *Subject:* Re: [TI994A] TurboForth preparation
> 
> 
> 
>         And how are you doing that? Meaning are you using the Forth
>         words that give you Basic-like equivalents? Or are you "rolling
>         your own"?
> 
>         You realize SUBs have private variables and that Forth words
>         have access globally, except to those things on the stack? And
>         that it is "hard" (not impossible) to nest more than two loops
>         using the DO..LOOP construct?
> 
>             While many things are different (postfix notation, the
>             stack) I am finding it very easy to make "stuff" happen in
>             Forth.  It's fast and fun.  
> 
> 
> 
>             Owen Brand
>>             I'm finding that logic is logic.  The design, program
>>             flow, and syntax are different, but it's so cool how some
>>             things parallel one another in concept. You're right...
>>             The languages are very different... Namely the stack
>>             concept... But as you said, there are some cool parallels. :)
>>
>>             Owen Brand
>>             <insane_m@hotmail. com> wrote:
>>
>>                  
>>                 that to work in all cases.
>>                 > > > > >>> Forth+ and X4th99 are LOAD and THRU
>>                 exclusive, and no
>>                 > > SCREENS/BLOCKS
>>                 > > > > ; <mailto:rmcarmany%
>>                 <http://40aol.com/>40aol.com <http://40aol.com>> wrote:
>>                 > > > > >>>>
>>                 > > > > >>>>
>>                 <http://ive.com/campaign> /thenewbusy?
>>                 tile=multiaccoun t&ocid=PID28326: :T:WLMTAGL:
>>                 ON:WL:en- US:WM_HMP: 042010_4>
>>                 > >
>>                 > >
>>                 >
>>                 >

---

From: "ti99_forever" <[email-masked]>
Date: Mon, 12 Apr 2010 11:24:31 -0000

Oh, blimey to hell with your "wrongs!"
Never do I come right out and say "Wrong!" to anyone.

Of course I *meant* bottom-up implementation. But you can design bottom-up as well...

--- In [email-masked], fdos <fdosbrs@...> wrote:
> > --- On *Sun, 4/11/10, mark wills /<markrobertwills@...>/* wrote:
> > 
> > 
> >     From: mark wills <markrobertwills@...>
> >         *From:* ti99_forever <ti99_forever@...>
> >         --- On *Sat, 4/10/10, Owen Brand /<owenbrand@...>/* wrote:
> > 
> > 
> >             <insane_m@...> wrote:

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 08:18:18 -0700

Owen,

Your explanation uses the same reasons I had for not using XB and AL as 
my primary chose of programming languages.  I also had another road to 
hoe as I thought my Myarc 512K memory and XB II v2.12 was the final 
solution until I discovered there weren't many others to share with due 
to the high cost of the Myarc system. :-(

Anyway, it's my belief that you're on the right track now, but also 
understand that I thought I was on the right track with TI FORTH as it 
was the rage for some time after it was released to PD.  Then while I 
was developing Forth+ 1.0 on the Geneve most of the interest in Forth 
disappeared from the scene.

Mark Wills' TurboForth cart may be just the ticket that brings Forth 
back--to this community at least.

The Forth is with us again. :-)

Bill S

Owen Brand wrote:
>  
> 
> thanks mark!  I really am having fun with this language... I still have 
> no idea how to work up and package a game, I have no idea how to 
> learning how to speak the language in it's most basic sense. I sometimes 
> feel as though I don't have the knowledge of numbers and mathematical 
> operations to do much with AL, but with Forth and XB, I feel like the 
> actual words and syntax are real explanations of concepts.  For instance 
> CLS, PAGE, CALL CLEAR all do the same thing and it's pretty clear what 
> that is by the short sweet "names" of these terms.  In AL, well.... 
> Click this link.  
> <http://www.opry99er.com/clearing-the-screen.php>
> 
> Matthew Hagerty made an excellent tutorial on clearing the screen which 
> is on my website.  While he explains it very elegantly and comments very 
> thoro ughlly, it takes almost a whole page.  DEF, REQ, LI, BL..... just 
> dozens of lines of code to tell the computer how to do something...  Now 
> before I get bombarded with "BUT YOU DONT UNDERSTAND!!!," I realize the 
> machine code is much faster because of the nature of it--- starting from 
> nothing, assigning bits/bytes of data to locations in memory, and 
> executing it on that basis is what makes AL so intriguing (and 
> confusing) to me.  I know how powerful the language is because you're 
> almost physically sitting at a railroad terminal and pulling levers to 
> make certain track lanes open and close as you design from scratch.  I 
> would love to be able to do this because as I read Filip's tutorials and 
> Matthews tutorials etc., it seems to me that an AL programmer can get 
> ANYTHING he wants (within the framework of the hardware) out of the 
> machine, without regard to any language's "shortcomings". That being 
> said--- the only shortcoming I find in XB as it applie s
> To my own game programming is speed and the inability to have 2 "things" 
> working at once.  (joystick AND music, scrolling, etc). Of
> On Apr 11, 2010, at 4:57 AM, mark wills <[email-masked]> wrote:
> 
>>  
>>
>> onto the stack by another word for use prior to using EQUA.  Hope that 
>> makes sense... I'm just learning, but I love the concepts here!
>>
>>
>>
>> have tested it and you happy that it works, you can move on and forget 
>> about it.
>>
>> In this way, programs are built 'incrementally' - as you go. They are 
>> "grown" more than written. I tend to write XB programs in the same way 
>> using SUBs.
>>
>> -------
>>
>> Forth system in exactly the same way as any other word like + - .S DUP 
>> etc. They are just words that exist. The art is writing words that 
>> call other words that actually do what you want to accomplish. If that 
>> makes sense.
>>
>> uncomfortable. It's like God turned gravity the other way up. Nothing 
>> feels familiar. Everything is weird and strange. But you start to get 
>> used to it. After a while, when you go back to other languages, you 
>> will feel limited and constrained and catch yourself uttering "Heck, I 
>> could do this in two minutes in Forth".
>>
>> limited success. Most languages these days are aimed at dumbing down, 
>> and making things easier. Forth puts you in firm control. If you screw 
>> up, tough. This perceived difficulty is what turns a lot of people 
>> off. That and the stack. As I mentioned in a previous mail, in most 
>> languages, you only manage execution flow. In Forth, you manage 
>> execution flow, AND data flow, as you have to manage the stack. It is 
>> harder, there's no doubt. This turns lazy people off. Myself included. 
>> I used to read Forth code posted by Stephen Shaw in TI*MES and think 
>> "what a total load of crap", because *I* couldn't understand it, and 
>> *I* am a genius programmer, because my mum says so (I was young) 
>> therefore if *I* can't understand it, it must be crap.
>>

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 08:58:03 -0700

Mark has stated that his TurboForth is mostly Forth83 now.  You can 
learn what they are likely to be by checking out the Forth83 Interface 
Library module in the Forth+ manual (on WHTECH) beginning on page 181. 
The word descriptions are good, but they don't tell you how to create 
them except for those that are simply synonyms for Fig Forth words.

I got most of the definitions (non synonyms) from a couple of articles 
by Mariusz Stanczak in THE SMART PROGRAMMER magazines (Oct. 1986 p.10 & 
Jan 1987 p.10).  I don't know of an on-line location for these.

Bill S

Owen Brand wrote:
>  
> 
> Mark, I'm modifying Wycove to be a bit closer to TurboForth.  GOTOXY is 
> not defined in Wycove... I'm trying to find the equivalent.... I've 
> appears to set the starting screen position to 0,0?  Is that the same as 
> 1,1 in XB?  Anyway, I'm just trying to modify Wycove's dictionary to be 
> more inline with TurboForth's, so anything you can send me to modify my 
> built-in dictionary to be closer to yours, I'd love to have it.  You 
> have a word list/glossary I can use to roll these TurboForth 
> On Apr 11, 2010, at 3:32 AM, mark wills <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>>  
>>
>> > > <http://groups.yahoo.com/group/TI994A/>http://groups.yahoo.com/ 
>> <http://yahoo.com/>group/TI994A/
>>
>> > href=" 
>> <http://groups.yahoo.com/group/TI994A/join>http://groups.yahoo.com/ 
>> <http://yahoo.com/>group/TI994A/join" target=_blank
>> > > 
>> <http://groups.yahoo.com/group/TI994A/join>http://groups.yahoo.com/ 
>> <http://yahoo.com/>group/TI994A/join
>> (Yahoo! ID
>> > required)
>>
>> > href=" <http://docs.yahoo.com/info/terms/>http://docs.yahoo.com/ 
>> <http://yahoo.com/>info/terms/" target=_blank
>> > > <http://docs.yahoo.com/info/terms/>http://docs.yahoo.com/ 
>> <http://yahoo.com/>info/terms/
>>
>

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 09:01:13 -0700

I don't think MENU is in my version of Wycove Forth, but then I never 
did use it much, so I can't be sure I remember correctly.

Bill S

Owen Brand wrote:
>  
> 
> How do I go about loading it up?  I'm having a bit of an issue trying to 
> access my menu screen.  MENU returns MENU? I haven't tried anything like 
> this yet... So far i've just been playing on the command line. 
> 
> Owen Brand
> On Apr 11, 2010, at 10:28 AM, "ti99_forever" <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>>  
>>
>> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, Owen 
>> Brand <owenbrand@...> wrote:
>> >
>> <mailto:TI994A-digest%40yahoogroups.com>">TI994A-
>> > > [email-masked] <mailto:digest%40yahoogroups.com>
>> > > >
>> > >
>> <mailto:TI994A-fullfeatured%40yahoogroups.com>">TI994A-
>> > > [email-masked] <mailto:fullfeatured%40yahoogroups.com>
>> > >
>> <mailto:TI994A-unsubscribe%40yahoogroups.com>">TI994A-
>> > > [email-masked] <mailto:unsubscribe%40yahoogroups.com>
>> > >

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 09:16:01 -0700

Ben,

My sincere apologies!  I didn't mean to offend you, and my only excuse, 
if you'll accept it, is it was after my bedtime and I was extremely 
tired, so tired I was unable to read and respond to the others in this 
thread.  Apparently a good thing, as I might have been offensive in 
those also.

Please forgive my bad manners as I truly want to remain your friend as 
you have been so very helpful to me over the years.

Bill S

ti99_forever wrote:
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, fdos 
> <fdosbrs@...> wrote:
>  >
>  > > *To:* [email-masked] <mailto:TI994A%40yahoogroups.com>
>  > > Opry99er.com <http://Opry99er.com <http://Opry99er.com>>
>  > >
>  > >> ----------------------------------------------------------
>  > >> <http://opry99er.com/ <http://opry99er.com/>>Opry99er.com 
> <http://Opry99er.com <http://Opry99er.com>>
>  > >>
>  > >> > > > > <http://opry99er.com/ <http://opry99er.com/>>
>  > >> <http://opry99er.com/ <http://opry99er.com/>>Opry99er.com 
> <http://Opry99er.com <http://Opry99er.com>>
>  > >> > > > >
>  > >> > > > > >> <http://opry99er.com/ <http://opry99er.com/>>
>  > >> <http://opry99er.com/ <http://opry99er.com/>>Opry99er.com 
> <http://Opry99er.com <http://Opry99er.com>>
>  > >> > > > > >>
>  > >> <http://40aol.com/ <http://40aol.com/>>40aol.com <http://40aol.com 
> <http://40aol.com>>>
>  > >> > > > > ; <mailto:rmcarmany%
>  > >> <http://40aol.com/ <http://40aol.com/>>40aol.com <http://40aol.com 
> <http://40aol.com>>> wrote:
>  > >> > > > > >>>>
>  > >> > > > > >>>>
>  > >> > > < <http://www.windowsl/ <http://www.windowsl/>>
>  > >> <http://www.windowsl/ <http://www.windowsl/>>http://www.windowsl
>  > >> <http://ive.com/campaign <http://ive.com/campaign>>ive.com/campaign
>  > >> <http://ive.com/campaign <http://ive.com/campaign>> /thenewbusy?
>  > >> ----------------------------------------------------------
> <http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_1 
> <http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_1>>
>  > >>
>  > >>
>  > >>
>  > >>
>  > >>
>  > >> ----------------------------------------------------------
> <http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5 
> <http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5>>
>  > >>
>  > >>
>  > >
>  > >
>  > >
>  > >
>  > >
>  > >
>  > >
>  > >
>  > >
>  >
> 
>

---

From: "Ksarul" <[email-masked]>
Date: Mon, 12 Apr 2010 13:37:31 -0400

Tha Jan 1987 iss ue is on WHT--the Oct 1986 issue is one of the missing ones
there (maybe you could scan your, Bill?).

ftp://ftp.whtech.com/magazines/smartprogrammer/

Jim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
fdos
Sent: Monday, April 12, 2010 11:58 AM
To: [email-masked]
Subject: Re: [TI994A] TurboForth preparation

Bill S

>> <mailto:fdosbrs%40frontiernet.net>
<mailto:TI994A-fullfeatured%40yahoogroups.com>">TI994A-fullfeatured@yahoogro
ups.com 
>> > href="mailto:[email-masked] 
<mailto:TI994A-unsubscribe%40yahoogroups.com>">TI994A-unsubscribe@yahoogroup
s.com 

Yahoo! Groups Links

---

From: fdos <[email-masked]>
Date: Mon, 12 Apr 2010 11:27:41 -0700

Hi Jim,

Well I see a couple of problems with this idea.  My issues of THE SMART 
PROGRAMMER are heavily marked up--only a little with pencil. 
Especially, the pages of concern to Owen, and the other is that I found 
corrections to several of the words elsewhere that are not included in 
the October issues or the January issue of corrections (lots of them).

The word SYNONYM is found in a number of places with slight differences, 
even so they all have one additional error that I found and corrected 
myself.  This bothers me that this word was highly proliferated yet no 
one else seems to have noticed or found this error or reported it if 
they did.  I made heavy use of this word in Forth+, and I continue to do 
so in X4th99 development.  It removes the problem of nesting words that 
were simple colon definitions of other words that are STATE smart ( : 
NEWWORD  oldword ; ) --not a smiley face.  I suppose the primary reason 
Forth83 redefined/removed STATE smart words.

Bill S

Ksarul wrote:
> <ftp://ftp.whtech.com/magazines/smartprogrammer/>
> 
> Jim
> 
> From: [email-masked] <mailto:TI994A%40yahoogroups.com> 
> [mailto:[email-masked] <mailto:TI994A%40yahoogroups.com>] On 
> Behalf Of
> fdos
<snip>

---

From: mark wills <[email-masked]>
Date: Tue, 13 Apr 2010 21:18:51 +0000 (GMT)

Attached is a very out of date spreadsheet listing the words that are in TurboForth.

As I say, it is out of date. TF currently has 218 words and counting.

I need to add the graphics and speech words, and a few others.

For example, there are words like FFAILM and FFAIHM that are not in the spreadsheet.

FFAILM=First Free Address in Low Memory
FFAIHM=First Free Address in High Memory

You can change where your words/data are compiled like this:

To compile in low memory:
FFAILM @ HERE !

To compile in high memory:
FFAIHM @ HERE !

Mark

----- Original Message ----
> Sent: Mon, 12 April, 2010 16:58:03

I 
> got most of the definitions (non synonyms) from a couple of articles 
by 
> Mariusz Stanczak in THE SMART PROGRAMMER magazines (Oct. 1986 p.10 & 
Jan 
> 1987 p.10).  I don't know of an on-line location for these.

Bill 

Owen Brand wrote:
>  
> 
> Mark, I'm modifying 
> Wycove to be a bit closer to TurboForth.  GOTOXY is 
> not defined in 
> Wycove... I'm trying to find the equivalent.... I've 
> already added PAGE 
> so I can get used to it instead of CLS.  GOTOXY 
> appears to set the 
> starting screen position to 0,0?  Is that the same as 
> 1,1 in 
> XB?  Anyway, I'm just trying to modify Wycove's dictionary to be 
> 
> On Apr 11, 2010, at 3:32 AM, mark 
> wills <
> href="mailto:[email-masked]">[email-masked] 
> 
> <mailto:
> href="mailto:[email-masked]">[email-masked]>> 
> wrote:
> 
>>  
>>
>> In TurboForth you 
> could do
>>
>> In TurboForth you want 
> PAGE instead of CLS. Of course, you could 
>> define CLS as a 
> synonym:
>>
>> : CLS PAGE ;
>>
>> ----- 
> Original Message ----
>> > From: Owen Brand <
> href="mailto:[email-masked]">[email-masked] 
>> 
>> > To: "
> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked] 
> <mailto:TI994A%40yahoogroups.com>" 
>> <
> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked] 
> <mailto:TI994A%40yahoogroups.com>>
>> > Sent: Sat, 10 
> April, 2010 22:19:58
> >http://Opry99er.com>Opry99er.com <
> target=_blank >http://Opry99er.com>
>>
>> On Apr 10, 
> 2010, at 3:15
>> > PM, fdos <
>> > href="mailto:
> <mailto:fdosbrs%40frontiernet.net>">
> <mailto:fdosbrs%40frontiernet.net>>
>> > 
> wrote:
>>
>> > Yes, TI did that too. I hate that --> 
> method as it
>> > doesn't work well
>> > with 
> THRU.
>> >
>> > contain the 
> --> word.
>> > href="mailto:
> <mailto:rmcarmany%40aol.com>">
>> >> In a message dated 4/10/2010 
> 1:54:52 P.M.
>> > Eastern Daylight Time,
>> 
> >>
>> > href="mailto:
> <mailto:fdosbrs%40frontiernet.net>">
> href="http://groups.yahoo.com/group/TI994A/" target=_blank 
> >http://groups.yahoo.com/group/TI994A/>
> target=_blank >http://groups.yahoo.com/ 
>> <
> href="http://yahoo.com/" target=_blank 
> >http://yahoo.com/>group/TI994A/
>>
>> > href=" 
> 
>> <
> target=_blank >http://groups.yahoo.com/group/TI994A/join>
> href="http://groups.yahoo.com/" target=_blank >http://groups.yahoo.com/ 
> 
>> <
> >http://yahoo.com/>group/TI994A/join" target=_blank
>> > > 
> 
>> <
> target=_blank >http://groups.yahoo.com/group/TI994A/join>
> href="http://groups.yahoo.com/" target=_blank >http://groups.yahoo.com/ 
> 
>> <
> >http://yahoo.com/>group/TI994A/join
>> (Yahoo! ID
>> 
> > required)
>>
>> > href="mailto:
> ymailto="mailto:[email-masked]" 
>> <mailto:TI994A-digest%40yahoogroups.com>">
> ymailto="mailto:[email-masked]" 
>> > href="mailto:
> ymailto="mailto:[email-masked]" 
>> <mailto:TI994A-fullfeatured%40yahoogroups.com>">
> ymailto="mailto:[email-masked]" 
> > ymailto="mailto:
> > href="mailto:
>> <mailto:TI994A-unsubscribe%40yahoogroups.com>">
> href=" <
> >http://docs.yahoo.com/info/terms/>
> target=_blank >http://docs.yahoo.com/ 
>> <
> href="http://yahoo.com/" target=_blank >http://yahoo.com/>info/terms/" 
> target=_blank
>> > > <
> >http://docs.yahoo.com/info/terms/>
> target=_blank >http://docs.yahoo.com/ 
>> <
> href="http://yahoo.com/" target=_blank 
> >http://yahoo.com/>info/terms/
>>
> 
> 

Yahoo! Groups 

    (Yahoo! ID

---

From: mark wills <[email-masked]>
Date: Tue, 13 Apr 2010 21:21:50 +0000 (GMT)

State-smart words are generally considered evil, as you don't necessarily know what behaviour you'll get when you tick them and use the xt returned by '

----- Original Message ----
> Sent: Mon, 12 April, 2010 19:27:41

Well I see a couple of problems with this idea.  My issues 
> of THE SMART 
the October issues or the January issue of corrections (lots of 
> them).

The word SYNONYM is found in a number of places with slight 
> differences, 
even so they all have one additional error that I found and 
> corrected 
myself.  This bothers me that this word was highly 
> proliferated yet no 
one else seems to have noticed or found this error or 
> reported it if 
they did.  I made heavy use of this word in Forth+, and 
> I continue to do 
so in X4th99 development.  It removes the problem of 
> nesting words that 
were simple colon definitions of other words that are 
> STATE smart ( : 
NEWWORD  oldword ; ) --not a smiley face.  I 
> suppose the primary reason 
Forth83 redefined/removed STATE smart 
> words.

Bill S

Ksarul wrote:
>  
> 
> Tha 
> Jan 1987 iss ue is on WHT--the Oct 1986 issue is one of the missing ones
> 
> href="ftp://ftp.whtech.com/magazines/smartprogrammer/" 
> target=_blank>ftp://ftp.whtech.com/magazines/smartprogrammer/ 
> 
> <
> target=_blank>ftp://ftp.whtech.com/magazines/smartprogrammer/>
> 
> 
> Jim
> 
> From: 
> <mailto:TI994A%40yahoogroups.com> 
> [mailto:
> <mailto:TI994A%40yahoogroups.com>] On 
> Behalf Of
> 
> fdos
> To: 
> <mailto:TI994A%40yahoogroups.com>
> Brand wrote:
>  > Mark, I'm 
> modifying Wycove to be a bit closer to TurboForth. GOTOXY is
>  > 
>  > more inline with 
> TurboForth's, so anything you can send me to modify my
>  > 
> Opry99er.com <
> >http://Opry99er.com <
> >http://Opry99er.com>>
<snip>

Yahoo! 

    (Yahoo! ID

---

From: "John H. Carver Jr." <[email-masked]>
Date: Tue, 13 Apr 2010 18:00:26 -0400

If I may ask.  What is required for the .xls suffix?

                                                               John

---

From: mark wills <[email-masked]>
Date: Wed, 14 Apr 2010 06:59:13 +0000 (GMT)

Microsoft Excel

----- Original Message ----
> From: John H. Carver Jr. <[email-masked]>
> Sent: Tue, 13 April, 2010 23:00:26

>               John

mark wills 

Yahoo! Groups 

    (Yahoo! ID 

    > href="mailto:[email-masked]">[email-masked]

---

From: "John H. Carver Jr." <[email-masked]>
Date: Wed, 14 Apr 2010 09:21:24 -0400

Thank you very much, sir.  I was afraid it was something like that.

                                                          John

---

From: fdos <[email-masked]>
Date: Wed, 14 Apr 2010 09:37:59 -0700

Mark,

I do hope you realize that if we have this debate it will have to be in 
Fig Forth parlance not Forth83 as Forth83 does not have any state smart 
words.  I've never considered state smart words as evil.  I use them all 
the time, and I still don't think I'm evil for doing so.

State smart words were a problem child until SYNONYM came along for many 
of us who liked renaming words, by way of simple colon definitions, for 
readability of our own code.  The simple colon definition method never 
acknowledged that an IMMEDIATE word or STATE smart word needed special 
handling, so nothing was done differently for these special cases. 
Renamed IMMEDIATE words were no longer immediate in execution during the 
COMPILE state, and STATE smart words were, uh, still STATE smart words 
until they were nested--then they were something else depending on the 
STATE (?).

The ' (tick) word itself, in Fig Forth, is STATE smart, and the only 
problem it can cause is when used with a SYNONYM created word, and all 
that is if the address obtained is used for vectored execution so that 
the new word is executed to execute the old word, therefore a ever so 
slight delay is introduced--that is all.  However, if a simple colon 
redefinition is used to rename a STATE smart word then problems will 
result using the ' (tick) word, but who in their right mind would do 
that when SYNONYM is in the dictionary?

End of the debate as far as I'm concerned, but I had to defend the 
"evil" accusation of STATE smart words.  Just try and get along without 
them in Fig Forth.  It can't be done.  I've been using them since TI 
FORTH was released to PD.  So watch out as I could sneak up on you and 
do something EVIL. Ha Ha ;-)

Bill S

mark wills wrote:
>  
> 
> State-smart words are generally considered evil, as you don't 
> necessarily know what behaviour you'll get when you tick them and use 
> the xt returned by '
> 
>  > From: fdos <[email-masked] <mailto:fdosbrs%40frontiernet.net>>
>  > href="ftp://ftp.whtech.com/magazines/smartprogrammer/ 
> <ftp://ftp.whtech.com/magazines/smartprogrammer/>"
> <ftp://ftp.whtech.com/magazines/smartprogrammer/>>
>  >
>  >
>  > Jim
>  >
>  > ymailto="mailto:[email-masked] 
>  > href="mailto:[email-masked] 
> <mailto:TI994A%40yahoogroups.com>">[email-masked] 
>  > ymailto="mailto:[email-masked] 
>  > href="mailto:[email-masked] 
> <mailto:TI994A%40yahoogroups.com>">[email-masked] 
>  > ymailto="mailto:[email-masked] 
>  > href="mailto:[email-masked] 
> <mailto:TI994A%40yahoogroups.com>">[email-masked] 
>  > >http://Opry99er.com <http://Opry99er.com> <
>  > >http://Opry99er.com <http://Opry99er.com>>>
>  > >>
>  > >
> <snip>
>

---

From: fdos <[email-masked]>
Date: Wed, 14 Apr 2010 10:38:59 -0700

John,

Open Office from SUN Microsystems will do as well and it is free:

http://www.sun.com/software/openoffice/index.jsp

I've used it for over a decade.  All the way back to when it was Star 
Office for Linus, so get on board.

Bill S

---

From: "John H. Carver Jr." <[email-masked]>
Date: Wed, 14 Apr 2010 14:21:10 -0400

Bill, I went to the open office site and they said my OS was not 
supported anymore.  And even if it were I'd be leary of downloading such 
a large file with dial up.

                                                            John

fdos wrote:
> --

---

From: fdos <[email-masked]>
Date: Wed, 14 Apr 2010 11:32:43 -0700

John,

What is your OS?  I have older versions of Open Office and Star Office 
on CD that I can send you, but I need to know your OS, so I can send the 
best one.

Bill S

---

From: "John H. Carver Jr." <[email-masked]>
Date: Wed, 14 Apr 2010 14:49:46 -0400

Bill, as far as I know just plain old Win 98.  Don't believe it's SE.

                                                             John

---

From: fdos <[email-masked]>
Date: Wed, 14 Apr 2010 12:00:31 -0700

John,

I'll have to do some checking as I don't think I have a Star Office for 
Windows, and I'm not when Sun turned Star Office into Open Office.  I 
was planning on loading MS Office97 w/Outlook98 upgrade on my Win98SE 
once it is working reliably, but I'll try Star and Open Office versions 
I have on hand first.

I'll get back to you later.

Bill S

---

From: fdos <[email-masked]>
Date: Wed, 14 Apr 2010 12:28:47 -0700

John,

I got lucky on the first attempt.  I started the install of Open Office 
version 1.1.2 released in 2003, and the important information box 
includes Windows98 no SE, so it will work for you.  If you still live at 
the same place in Bringhurst, IN I have your address.  Please confirm or 
provide update.

Bill S

---

From: mark wills <[email-masked]>
Date: Thu, 15 Apr 2010 09:22:38 +0000 (GMT)

Hi Bill

I'm with you! If you know that a word is state smart, you can program accordingly. However, mention state smart words on comp.lang.forth and see what happens ;-)

S" is state smart in TurboForth - it does different things depending if you are compiling, or just typing at the command line.

----- Original Message ----
> Sent: Wed, 14 April, 2010 17:37:59

I do hope you realize that if we have this debate it will have to 
> be in 
Fig Forth parlance not Forth83 as Forth83 does not have any state 
> smart 
words.  I've never considered state smart words as evil.  I 
> use them all 
the time, and I still don't think I'm evil for doing 
> so.

State smart words were a problem child until SYNONYM came along for 
> many 
STATE (?).

The ' (tick) word itself, in Fig Forth, is STATE smart, 
> and the only 
problem it can cause is when used with a SYNONYM created word, 
> and all 
that is if the address obtained is used for vectored execution so 

End of the debate as far as 
> I'm concerned, but I had to defend the 
"evil" accusation of STATE smart 
> words.  Just try and get along without 
them in Fig Forth.  It 
> can't be done.  I've been using them since TI 
FORTH was released to 
> PD.  So watch out as I could sneak up on you and 
do something EVIL. Ha 
> Ha ;-)

Bill S

mark wills wrote:
> > From: fdos <
> Well 
> I see a couple of problems with this idea. My issues
>  > of THE 
> SMART
> corrections to several of 
> the words elsewhere that are not included in
>  >
> the 
> October issues or the January issue of corrections (lots of
>  > 
> them).
> 
> myself. 
> This bothers me that this word was highly
>  > proliferated yet 
> no
> were simple 
> colon definitions of other words that are
>  > STATE smart ( 
> :
>  > Jan 1987 iss 
> ue is on WHT--the Oct 1986 issue is one of the missing ones
>  
> >
> target=_blank>ftp://ftp.whtech.com/magazines/smartprogrammer/>"
>  
> > target=_blank>
>  > target=_blank>
> target=_blank>ftp://ftp.whtech.com/magazines/smartprogrammer/>>
>  
> >
>  >
>  > Jim
>  >
>  
> <mailto:TI994A%40yahoogroups.com>">
> <mailto:TI994A%40yahoogroups.com>">
>  > Behalf 
> Of
> <mailto:TI994A%40yahoogroups.com>">
>  > Subject: Re: [TI994A] 
> TurboForth
>  > preparation
> Mark has stated that his TurboForth is mostly
>  > Forth83 now. 
> You can
>  > learn what they are likely to be by checking 
> out
>  > the Forth83 Interface
>  > Library module 
> in the Forth+ manual (on WHTECH)
>  > beginning on page 
> 181.
>  > The word descriptions are good, but they 
> don't
>  > tell you how to create
>  > them except 
> for those that are simply synonyms
>  > for Fig Forth 
> words.
>  >
>  > I got most of the definitions 
> (non
>  > synonyms) from a couple of articles
>  > 
> by Mariusz Stanczak in THE SMART
>  > PROGRAMMER magazines (Oct. 
> 1986 p.10 &
>  > Jan 1987 p.10). I don't know
>  
> > of an on-line location for these.
>  >
>  > 
> Bill S
>  >
>  > Owen
>  > Brand 
> wrote:
>  > >
>  > >
>  > > 
> Mark, I'm
>  > not defined in Wycove... 
> I'm trying to find the equivalent....
>  > I've
>  > 
> > already added PAGE so I can get used to it instead of
>  > 
> CLS. GOTOXY
>  > > appears to set the starting screen position 
> to
>  > 0,0? Is that the same as
>  > > 1,1 in 
> XB? Anyway, I'm just trying
>  > to modify Wycove's dictionary to 
> be
>  > > more inline with
>  > TurboForth's, so 
> built-in dictionary to be closer to yours, I'd love to have it.
>  
> > You
>  > > have a word list/glossary I can use to roll 
> these
>  > TurboForth
>  > > conventional words 
> into Wycove?
>  > Thanks
>  > >
>  
> > > Owen Brand
>  > >
>  > Opry99er.com 
> <
>  > >
> >http://Opry99er.com <
> >http://Opry99er.com> <
>  > >
> href="http://Opry99er.com" target=_blank >http://Opry99er.com <
> href="http://Opry99er.com" target=_blank 
> >http://Opry99er.com>>>
>  > >>
>  
> > >
> <snip>
> 
> 
> >http://groups.yahoo.com/group/TI994A/join>" target=_blank
>  
> > >
> >http://groups.yahoo.com/group/TI994A/join>
> (Yahoo! 
> ID
>  > required)
> 
>  > href="mailto:
> target=_blank >http://docs.yahoo.com/info/terms/ 
> <
> >http://docs.yahoo.com/info/terms/>" target=_blank
>  > 
> >
> >http://docs.yahoo.com/info/terms/ <

Yahoo! Groups 

    (Yahoo! ID

---

From: fdos <[email-masked]>
Date: Thu, 15 Apr 2010 09:08:52 -0700

Mark,

If I ever want to restart the old FORML wars I'll know where and how. 
There was, however, a lot more to the intense debate back then than just 
STATE smart words, but I'm not going to rehash them here and now.

Anyway, now you know why I don't hang out on comp.lang.forth (although I 
use to long ago).  We don't have so much in common any more.  The war or 
the final release of Forth83 (as it is) split the Forth community!  I 
stayed with Forth Dimensions as my only link to Fig until it too became 
mostly Forth83 relevant.  The major US vendors had all adapted it, so 
what choice did they have if they wanted to stay in business?  So I 
became a fringe Forth hacker of the worst sort--EVIL in their eyes, but 
I have loads of fun without them anyway. :-)

Take the ' (tick) word for instance.  Say it's the only version in your 
dictionary, so it has to be STATE smart if you want to use it at the 
keyboard and compile it in a word like SEE, otherwise you have to have 
two words that do the same thing, one during the state of interpretation 
and another during the state of compiling because the action to do it 
during one state versus the other state is different.  I don't have to 
remember two words that have the same purpose and which one to use when. 
  If ' (tick) was the only word with dual action parts, two words would 
be alright, but Fig Forth has many, and I've created a few myself.

Very EVIL guy here. :-(

Bill S

mark wills wrote:
>  
> 
> Hi Bill
> 
> I'm with you! If you know that a word is state smart, you can program 
> accordingly. However, mention state smart words on comp.lang.forth and 
> see what happens ;-)
> 
> S" is state smart in TurboForth - it does different things depending if 
> you are compiling, or just typing at the command line.
> 
> <ftp://ftp.whtech.com/magazines/smartprogrammer/>>"
>  >
>  > > target=_blank>
> <ftp://ftp.whtech.com/magazines/smartprogrammer/>>>
>  >
>  > >
>  > >
>  > > Jim
>  > >
>  >
>  > >http://Opry99er.com <http://Opry99er.com>> <
>  > > >
>  > href="http://Opry99er.com <http://Opry99er.com>" target=_blank 
>  > href="http://Opry99er.com <http://Opry99er.com>" target=_blank
>  > >http://Opry99er.com <http://Opry99er.com>>>>
>  > > >>
>  >
>  > > >
>  > <snip>
>  >
>  >
>  > href="http://groups.yahoo.com/group/TI994A/ 
> <http://groups.yahoo.com/group/TI994A/>" target=_blank
>  > href="http://groups.yahoo.com/group/TI994A/ 
> <http://groups.yahoo.com/group/TI994A/>" target=_blank
> <http://groups.yahoo.com/group/TI994A/>>
>  >
>  > >
>  > href="
> <http://groups.yahoo.com/group/TI994A/join>>" target=_blank
>  >
>  > > >
> <http://groups.yahoo.com/group/TI994A/join>>
>  > (Yahoo!
>  > ID
>  > > required)
>  >
>  > > href="mailto:
>  > ymailto="mailto:[email-masked] 
> <mailto:TI994A-digest%40yahoogroups.com>"
>  > ymailto="mailto:[email-masked] 
> <mailto:TI994A-digest%40yahoogroups.com>"
>  > ymailto="mailto:[email-masked] 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>"
>  > ymailto="mailto:[email-masked] 
> <mailto:TI994A-fullfeatured%40yahoogroups.com>"
> <http://docs.yahoo.com/info/terms/>
>  > <
> <http://docs.yahoo.com/info/terms/>>" target=_blank
>  > >
>  > >
>  > >http://docs.yahoo.com/info/terms/ <http://docs.yahoo.com/info/terms/> <
>  > >http://docs.yahoo.com/info/terms/ <http://docs.yahoo.com/info/terms/>>
>  >
>  >
>  >
>

---

From: mark wills <[email-masked]>
Date: Thu, 15 Apr 2010 19:43:00 +0000 (GMT)

Take the 

> ' (tick) word for instance.  Say it's the only version in your 

Indeed. Because TurboForth follows Forth-83, it has ' (immediate) and ['] (for use in a colon def).

It always seemed a pedantic argument to me anyway. I mean, normally, you tick something, when you want to compile it:

' DUP , ( compile comma to HERE )

Well, in Forth-83 you can just do COMPILE DUP - it does exactly the same thing.

I got slammed on CLF when I mentioned that my tick was state smart. They don't have an answer for S" though. They seem to let that one slide, so they're inconsistent, as well as arrogant!

Mark

---

From: fdos <[email-masked]>
Date: Thu, 15 Apr 2010 14:23:51 -0700

Hey Mark,

Ah, sounds like the same crowd as yesteryear.  I could go into all the 
reasons I think it (the great FORML debate) went down the way it did, 
but that would just be a history lesson from my perspective, and I know 
I have better things to do than that, so I'm sure everyone else has 
better things to do than read it.  So not doing it at all is best for 
everyone. :-)

We should resolve to just do the best we can with what we got going 
forward.  I'll make a Forth83 version of SYNONYM available to everyone 
who uses TurboForth along with other compatibility words to allow them 
to program using Fig Forth words and syntax, as X4th99 will come with a 
complete Forth83 binary code library in any case.

What do you think?  Does it sound like tons of Forth fun to you?

Bill S

mark wills wrote:
> It always seemed a pedantic argument to me anyway. I mean, normally, you 
> tick something, when you want to compile it:
> 
> I got slammed on CLF when I mentioned that my tick was state smart. They 
> don't have an answer for S" though. They seem to let that one slide, so 
> they're inconsistent, as well as arrogant!
> 
> Mark
> 
>