Subject: E/A question

From: "kory" <[email-masked]>
Date: Thu, 08 Jul 2010 21:27:21 -0000

Just wondering if anyone can point out a good book that is specific to the E/A cart, and not the Mini Memory cart. Something that has examples that I can code,... with a step by step approach.

I am looking to program mostly graphics/sounds/game like stuff. I'm familiar with XB, but have not been sucessful with E/A and the 3ring binder that it comes with.

Thanks,
-Kory

---

From: Marc Hull <[email-masked]>
Date: Thu, 8 Jul 2010 14:45:05 -0700 (PDT)

Another hardy fool.... ;-)

If you can get your hands on the Compute! book it will help immensely.   It is more of a tutorial than any of the others.  I believe it is on line @ planet-99 or perhaps someone can loan you one.  Mine is currently out at the time.  At any rate pick a nice soft wall to bang your head against because if you stick with TMS9900 speak you will surely need it ;-)

--- On Thu, 7/8/10, kory <[email-masked]> wrote:

From: kory <[email-masked]>
Subject: [TI994A] E/A  question
To: [email-masked]
Date: Thursday, July 8, 2010, 4:27 PM

  

Thanks,

-Kory

---

From: "Jon Vogel" <[email-masked]>
Date: Thu, 8 Jul 2010 16:51:32 -0500

I like the Molesworth book the brown one).  He covers the full gamut of assembly on the TI, including graphics, keyboard and file I/O.

The Morley book (the blue one) is not so useful.  He spends a lot of time going over some basic stuff and never really gets to the fun stuff.

I have never found the Compute! book, but it is rumored to be good.

Regards,

Jon

  ----- Original Message ----- 
  From: kory 
  To: [email-masked] 
  Sent: Thursday, July 08, 2010 4:27 PM
  Subject: [TI994A] E/A question

  Thanks,
  -Kory

---

From: Owen Brand <[email-masked]>
Date: Thu, 8 Jul 2010 17:00:17 -0500

In the TI-99 programming forum at Atariage.com there is a Sticky  
thread full of development resources including this book Marc  
mentioned.  It's an amazing book, really!

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jul 8, 2010, at 4:45 PM, Marc Hull <[email-masked]> wrote:

> If you can get your hands on the Compute! book it will help  
> immensely.   It is more of a tutorial than any of the others.  I  
> believe it is on line @ planet-99 or perhaps someone can loan you  
> one.  Mine is currently out at the time.  At any rate pick a nice  
> soft wall to bang your head against because if you stick with  
> TMS9900 speak you will surely need it ;-)
>
>
>
>
> Just wondering if anyone can point out a good book that is specific  
> to the E/A cart, and not the Mini Memory cart. Something that has  
> examples that I can code,... with a step by step approach.
>
> I am looking to program mostly graphics/sounds/game like stuff. I'm  
> familiar with XB, but have not been sucessful with E/A and the 3ring  
> binder that it comes with.
>
> Thanks,
> -Kory
>
>

---

From: "Ksarul" <[email-masked]>
Date: Thu, 08 Jul 2010 18:30:43 -0400

Wayne Stith did an excellent Assembly tutorial as well—I believe it is up on
WHTech.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Owen Brand
Sent: Thursday, July 08, 2010 6:00 PM
To: [email-masked]
Subject: Re: [TI994A] E/A question

In the TI-99 programming forum at Atariage.com there is a Sticky thread full
of development resources including this book Marc mentioned.  It's an
amazing book, really! 

Owen Brand

       **webmaster** 

http://www.Opry99er <http://www.Opry99er.com> .com

On Jul 8, 2010, at 4:45 PM, Marc Hull <marc.hull@sbcglobal
<mailto:[email-masked]> .net> wrote:

If you can get your hands on the Compute! book it will help immensely.   It
is more of a tutorial than any of the others.  I believe it is on line @
planet-99 or perhaps someone can loan you one.  Mine is currently out at the
time.  At any rate pick a nice soft wall to bang your head against because
if you stick with TMS9900 speak you will surely need it ;-)

--- On Thu, 7/8/10, kory <shortbusalaboard@ <http://aol.com> aol.com> wrote:

From: kory <shortbusalaboard@ <http://aol.com> aol.com>
Subject: [TI994A] E/A question
To: [email-masked]
Date: Thursday, July 8, 2010, 4:27 PM

Just wondering if anyone can point out a good book that is specific to the
E/A cart, and not the Mini Memory cart. Something that has examples that I
can code,... with a step by step approach.

I am looking to program mostly graphics/sounds/game like stuff. I'm familiar
with XB, but have not been sucessful with E/A and the 3ring binder that it
comes with.

Thanks,
-Kory

---

From: "kory" <[email-masked]>
Date: Fri, 09 Jul 2010 03:29:00 -0000

It seems to me like I may have asked this question a few years ago.. The Molesworth and Morley names both seem to ring a bell. I'm going to look for those, and probably look for the articles that you folks have mentioned as well.

I'm a ways away from getting "up&running" most stuff has been packed for our move. I'll be setting up a home office soon and hope to have some time to play around with some simple game ideas that I've had for many years.

Thanks for the info on the E/A...
-Kory

---

From: "killroy732000" <[email-masked]>
Date: Fri, 09 Jul 2010 05:37:54 -0000

Here is the link to the development resources thread, look at the manuals & tutorials section for assembly language stuff:

http://www.atariage.com/forums/topic/153704-ti-994a-development-resources/

... and this is the programming forum which also has a few threads on assembly language:

http://www.atariage.com/forums/forum/119-ti-994a-programming/

Cheers
Filip

--- In [email-masked], Owen Brand <owenbrand@...> wrote:
> On Jul 8, 2010, at 4:45 PM, Marc Hull <marc.hull@...> wrote:
> 
> > --- On Thu, 7/8/10, kory <shortbusalaboard@...> wrote:
> >
> > From: kory <shortbusalaboard@...>

---

From: mark wills <[email-masked]>
Date: Fri, 9 Jul 2010 07:17:07 +0000 (GMT)

There is also a new book in development right now about assembly language on the 
TI-99/4A - not by me - though I will leave it to the author to announce if he 
wishes to do so ;-)

Mark

----- Original Message ----
> From: killroy732000 <[email-masked]>
> Sent: Fri, 9 July, 2010 6:37:54
> Subject: [TI994A] Re: E/A  question
> 
> 
> 
> Here is the link to the development resources thread, look at the  manuals & 
>tutorials section for assembly language stuff:
> 
> ------------------------------------
> 
> Yahoo!  Groups Links
> 
> 
> 
>

---

From: "Jacques Groslouis" <[email-masked]>
Date: Fri, 9 Jul 2010 06:58:38 -0300

Kory,

The COMPUTE! book is 'Beginner's Guide to Assembly Language on the TI-99/4A' 
by Peter M. L. Lottrup. As others have stated it is an excellent book. 
Although written for use with a Mini Memory cartridge, most of its programs 
can be adapted for use with the E/A cartridge. I found the Lottrup examples 
to be shorter and more numerous than the Molesworth examples. A word of 
caution if you find a hard copy version of the Lottrup book, it contains a 
dozen or so typos that can add to learning frustration. I believe that most 
electronic versions of this books have been corrected. I am probably at the 
same stage in learning assembly language programming as you are. I just find 
that I am not quite there yet but I am still trying.

I also found an (IMHO) excellent series of tutorials written by Steven 
Peacock in past issues of the Chicago TImes. In these tutorials all examples 
are first presented as an Extended Basic program and then as an assembly 
version. Many copies of the Chicago newsletters can be found on the wht 
site. The Peacock tutorials start in the November 1986 issue.

Good luck,

Jacques

Nominate someone to your TI99HOF
Check out www.ti99hof.org

----- Original Message ----- 
From: "kory" <[email-masked]>
To: <[email-masked]>
Sent: Friday, July 09, 2010 12:29 AM
Subject: [TI994A] Re: E/A question

>
>
> It seems to me like I may have asked this question a few years ago.. The 
> Molesworth and Morley names both seem to ring a bell. I'm going to look 
> for those, and probably look for the articles that you folks have 
> mentioned as well.
>
> I'm a ways away from getting "up&running" most stuff has been packed for 
> our move. I'll be setting up a home office soon and hope to have some time 
> to play around with some simple game ideas that I've had for many years.
>
>> I like the Molesworth book the brown one).  He covers the full gamut of 
>> assembly on the TI, including graphics, keyboard and file I/O.
>>
>> The Morley book (the blue one) is not so useful.  He spends a lot of time 
>> going over some basic stuff and never really gets to the fun stuff.
>>
>>   Just wondering if anyone can point out a good book that is specific to 
>> the E/A cart, and not the Mini Memory cart. Something that has examples 
>> that I can code,... with a step by step approach.
>>

---

From: "killroy732000" <[email-masked]>
Date: Fri, 09 Jul 2010 10:49:39 -0000

"The Art of Assembly Series" by the late bruce Harrison.
A huge collection of articles very well written and detailed.
I have the compiled version as available on the "Cyc".

Too bad this kind of information is not available to everyone.
This is especially very annoying for newbies who are trying to get into assemly language and do not own the Cyc.

IMHO this should be available to every one. 
I believe in free information :-)

Filip

--- In [email-masked], "Jacques Groslouis" <jgroslou@...> wrote:
> From: "kory" <shortbusalaboard@...>
> > --- In [email-masked], "Jon Vogel" <jon_yahoo@> wrote:
> >>
> >>

---

From: "epergrem" <[email-masked]>
Date: Fri, 09 Jul 2010 12:01:37 -0000

Unfortunately, while the Compute! book is probably (IMHO) the better of the lot of commonly available books, it is also targeted to Mini Memory.

I would save it for the second book.  For me, Ralph Molesworth's book was the easiest to begin with.  It's not at all comprehensive, but provides examples with explanations that can be typed in and ran. It also deals on a basic level with file I/O.

Once you have a grasp of REF/DEF and other Assembly-speak, then you should be able to do the mental translations to get the most use from the Compute! book. 

A truly amazing resource is the Bruce Harrison "Art of Assembly" series. It's available at ftp.whtech.com in the articles folder.  I consider this a must have.

The Wayne Stith is called KWIKFONT and includes the program, plus generously commented source code.  I can provide you with an ASCII copy of the source code if you want to browse it.  Just drop me an email.

In my experience, learning assembly language on the TI is accomplished by using a bunch of sources rather than one comprehensive source. 

Also, don't discount the E/A manual. There is a bunch of information in it, that once you get comfortable with is really great stuff.  You'll just want the foundations that the Molesworth books provides before jumping in.

Ernie

---

From: "epergrem" <[email-masked]>
Date: Fri, 09 Jul 2010 12:18:33 -0000

You must mean "available for free" because The CYC is available to anyone who owns PC99.  

PC99 can be purchased for a very reasonable $49.00 and The CYC for another $24.95.  At a combined priced of $75, you have one of the best deal in TI-dom.

I doubt that the majority of TI users have any idea the amount of time that Mike put into creating and maintaining The CYC.  We're talking thousands of hours, and years of scanning, editing, researching, contacting authors, etc.  

If you truly believe in 'Free', then why not spend the next few years of your life creating your own free version of a CYC-like product? 

While I applaud those who choose to release their products to the community at no cost, I also believe those who choose to sell them are just as noble.

Ernie

---

From: "killroy732000" <[email-masked]>
Date: Fri, 09 Jul 2010 16:34:15 -0000

exactly, I do mean "available for free".

sorry, I don't see a reason why I would need to buy PC99 in order
to get access to the CYC. I don't have a need for that emulator.

And I'm not thinking about myself, but about getting newbies
attracked into the TI scene. That is why I believe there is a need of
good assembly language documentation available for free. 

I was under the impression that the CYC owns the copyright for the 
"Art of Assembly" series? Is that not the case ?
Guess that everyone needs to decide if he releases his work or not.
And that doesn't mean I don't respect Mike's and the huge amount of work he put in there.

But since we are on the subject of "truly free"; I have spent 
2 years of my life and approx. 1300 hours hacking on Pitfall and I
released the ROM image and source code and intend to do the same for
Tutankham and other future projects.

Does that qualify ?

Filip

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> --- In [email-masked], "killroy732000" <filip.van-vooren@> wrote:
> >

---

From: "Dan" <[email-masked]>
Date: Fri, 9 Jul 2010 12:58:30 -0400

I do believe when Mike created PC99 and compiled the material for the CYC, 
he had to PURCHASE the rights to all the TI roms, and other TI specific 
information. The fee's Mike charges are to help defray the cost of the 
licensing from TI.

---

From: "epergrem" <[email-masked]>
Date: Fri, 09 Jul 2010 17:34:00 -0000

Just think of it as a $75 bundle then.  It's CaDD's product and they can price it however they want.  As a consumer I have the option to buy or not buy.  

As for Pitfall, congratulations on the module and your decision to release the source, etc.  But, that is my point.  It was 'your' decision.  I'm not a gamer, but I know that many users appreciate it.

CaDD does not own "Art of Assembly", but they do hold a copyright to the collection which is in their format.  Therefore anyone is free to reproduce "Art of Assembly", but would be violating copyright laws if they used the copy on The CYC as the basis for the reproduction.

I'm not sure how the files on The Hidden Reef were produced because they are in DV80 files, but I'm guessing they came from Bruce or another other source.

As for qualifying.  I agree that 1300 hours is a lot of time, but it's only a fraction of what Mike has put into The CYC.

Ernie

---

From: Marc Hull <[email-masked]>
Date: Fri, 9 Jul 2010 17:19:48 -0700 (PDT)

Great points Ernie.... and if I can add.....

want doe not equal justification.  

--- On Fri, 7/9/10, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] Re: E/A  question
To: [email-masked]
Date: Friday, July 9, 2010, 12:34 PM

  

Ernie

---

From: "hexbus" <[email-masked]>
Date: Sat, 10 Jul 2010 01:14:13 -0000

I found the TI-99/4A and Compute's Assembly guide both scanned in PDF format.

http://www.scribd.com/remow

This guy has scanned the EA manual, the Compute's Assembly, several SAMs manuals, the TI LOGO manual, and more.

I have the Morely book and Molesworth books here - I need to e-mail this guy and see if he has them and wants to scan them or not.

---

From: ti99_forever <[email-masked]>
Date: Fri, 9 Jul 2010 18:38:38 -0700 (PDT)

I scanned Compute's Guide to Assembly in PDF format back in November 2007...Thought it was on whtech, but can't seem to find it now.

--- On Fri, 7/9/10, hexbus <[email-masked]> wrote:

From: hexbus <[email-masked]>
Subject: [TI994A] Re: E/A  question
To: [email-masked]
Date: Friday, July 9, 2010, 9:14 PM

Yahoo! Groups Links

---

From: "killroy732000" <[email-masked]>
Date: Sat, 10 Jul 2010 06:53:57 -0000

Point well taken Ernie and thank you for the clarification on the status of the "Art of Assembly" tutorials.

As mentioned in my first post, the idea is not to do a full CYC-like free product. Which is most likely impossible to do so in the first place. 
But, getting more free assembly language tutorials is a good start.

If no one beats me to it, I'll see if I can do a PDF version starting from the original disk version. Might up ending as a project for the long winter nights.

Filip

---

From: "epergrem" <[email-masked]>
Date: Sat, 10 Jul 2010 11:54:04 -0000

Yeah, creating a resource for tutorials was one of my plans when I started reorganizing the WHT FTP section.  It didn't take long to realize that reorganization was a bigger undertaking than I was willing to undertake. :-)

The PDF of the 'Art of Assembly' is already on the WHT FTP site in the articles folder.  It's CaDD's version, but Mike has graciously allowed it to remain along with some of files from The CYC.

It might be worthwhile to create a 'tutorial' folder on WHT inside the programming directory, where things like Wayne Stith's KWIKFONT source and other tutorials in ASCII or PDF format could be easily accessed.  

If I still have access WHT I would be willing to create the folder and add the first couple of files if there is interest.

Ernie

---

From: "killroy732000" <[email-masked]>
Date: Sat, 10 Jul 2010 14:32:17 -0000

wow, I wasn't aware that the CaDD's PDF version of 'Art of Assembly' 
is already on WHT FTP.

Well, I for one would be interested in seeing more articles.

So, I'm wondering if it would be ok to add a hyperlink pointing 
to the PDF at WHT FTP ? I'm thinking about the development resources
thread at Atariage and its' twin at ninerpedia (which I really need to update again; but that's another story).

Filip

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Jul 2010 11:41:07 -0400

Link it up!!!  If it's free on the Reef, it's fair game anywhere I  
imagine.  I never had the pleasure of meeting Bruce in person, but I'm  
sure he would like it if his work was being read/used.  Judging from  
his written works, he was superbly passionate about the TI and about  
assembly programming.

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jul 10, 2010, at 10:32 AM, "killroy732000" <filip.van- 
[email-masked]> wrote:

> thread at Atariage and its' twin at ninerpedia (which I really need  
> to update again; but that's another story).
>
> Filip
>
> > Yeah, creating a resource for tutorials was one of my plans when I  
> started reorganizing the WHT FTP section. It didn't take long to  
> realize that reorganization was a bigger undertaking than I was  
> willing to undertake. :-)
> >
> > The PDF of the 'Art of Assembly' is already on the WHT FTP site in  
> the articles folder. It's CaDD's version, but Mike has graciously  
> allowed it to remain along with some of files from The CYC.
> >
> > It might be worthwhile to create a 'tutorial' folder on WHT inside  
> the programming directory, where things like Wayne Stith's KWIKFONT  
> source and other tutorials in ASCII or PDF format could be easily  
> accessed.
> >
> > If I still have access WHT I would be willing to create the folder  
> and add the first couple of files if there is interest.
> >
> > Ernie
> >
> >
> > > If no one beats me to it, I'll see if I can do a PDF version  
> starting from the original disk version. Might up ending as a  
> project for the long winter nights.
> > >
> > > Filip
> >
>
>

---

From: "Tursi" <[email-masked]>
Date: Sat, 10 Jul 2010 13:43:54 -0700

Did anyone ever OCR the Compute's Guide to Assembly on the TI? That was the 
book I learned from, and I quite liked it. If it would be helpful, I could 
adapt that book to work with Editor/Assembler, but the copy I have is images 
only.

---

From: "Ksarul" <[email-masked]>
Date: Sat, 10 Jul 2010 18:17:24 -0400

Tursi, were you still looking for the TI GROM timing diagram?  I’ve found
two different sources containing it.  The Bunyard Hardware Manual and an
early hardware book on the TI from Formoral.  The Formoral stuff looks like
it was issued as a booklet with a bunch of attached schematics, all hand
drawn.

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Tursi
Sent: Saturday, July 10, 2010 4:44 PM
To: [email-masked]
Subject: Re: [TI994A] Re: E/A question

only.

---

From: "Michael Zapf" <[email-masked]>
Date: Sat, 10 Jul 2010 23:18:39 -0000

Hello Jim,

> Tursi, were you still looking for the TI GROM timing diagram? 

It was me asking some days ago. So can you send me these documents by mail?

Michael

---

From: "Ksarul" <[email-masked]>
Date: Sat, 10 Jul 2010 19:43:14 -0400

I'll scan the relevant documents/parts when I get back to work in a week and
send them to you Michael.  I did get to put the documentation for the 99/4B
(also known as the LCP) up in the 99/4A folder on WHTech this week, along
with some odd bits of documentation for the TI EPROM Burner card, as I was
able to scan them in before I went on vacation to do my midterm exams. . .

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Zapf
Sent: Saturday, July 10, 2010 7:19 PM
To: [email-masked]
Subject: [TI994A] Re: GROM Timing Diagrams

Hello Jim,

Michael

---

From: Owen Brand <[email-masked]>
Date: Sat, 10 Jul 2010 19:53:46 -0400

EPROM burner card?  Burn EPROMs from the PEB??  Now THAT would be  
cool!  :)

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jul 10, 2010, at 7:43 PM, "Ksarul" <[email-masked]> wrote:

> I’ll scan the relevant documents/parts when I get back to work in a  
> week and send them to you Michael.  I did get to put the documentati 
> on for the 99/4B (also known as the LCP) up in the 99/4A folder on W 
> HTech this week, along with some odd bits of documentation for the T 
> I EPROM Burner card, as I was able to scan them in before I went on  
> vacation to do my midterm exams. . .
>
>
>
> Jim
>
>
>
> From: [email-masked] [mailto:[email-masked]] On  
> Behalf Of Michael Zapf

---

From: "Ksarul" <[email-masked]>
Date: Sat, 10 Jul 2010 20:55:25 -0400

I actually have one of those TI EPROM Burner cards. . .along with the cables
and special chip sockets to go on the end of them.  I've only seen one other
one, though I've heard there are several more of them still within the
community.

I have several odd/rare TI manufactured cards:

EEE-488 Card

DSDD Disk Controller

EPROM Burner

128K Memory Card

FORTI Card

External stuff:

EGROM Box

GSIM

Hexbus Floppy

Hexbus Modem

Hexbus RS-232

Then I have the 99/8 PEB stuff:

128K Card

512K Card

RS-232 (with a 99/8 DSR, otherwise normal)

Armadillo Interface (Round Cable)

Armadillo Interface (Round Cable with integrated 64K memory-though the
memory section isn't populated)

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Owen Brand
Sent: Saturday, July 10, 2010 7:54 PM
To: [email-masked]
Subject: Re: [TI994A] Re: GROM Timing Diagrams

EPROM burner card?  Burn EPROMs from the PEB??  Now THAT would be cool!  :)

Owen Brand

       **webmaster** 

On Jul 10, 2010, at 7:43 PM, "Ksarul" <vze23g4a@verizon.
<mailto:[email-masked]> net> wrote:

Jim

  _____  

  

Hello Jim,

Michael

---

From: "hexbus" <[email-masked]>
Date: Mon, 12 Jul 2010 01:17:31 -0000

The link that I posted on scribd.com has a copy of it, fully searchable.  I can copy/paste from the PDF the plain text.

example:

Foreword
Machine language of computers is nothing more than a series of numbers. Those numbers are what make the computer do what you want it to do. Because it's the language of pref- erence of your II-99/ 4A, programs written in it run far faster than those written in BASIC. And because you can talk to the computer directly, without going through a translator like BASIC, you can create more powerful programs than you can with BASIC.
You write machine language (ML) programs with an assembler. The instructions you give to it are assembled (hence the term assembly language) and thus produce an ML pro- gram. But writing programs in assembly language can be diffi- cult for the beginner. Instructions, operands, and directives can be confusing, even intimidating.
That's why you'll find COMPUTEf's Beginner's Guide to TI Assembly Language such a valuable book.

---

From: "Tursi" <[email-masked]>
Date: Sun, 11 Jul 2010 18:42:31 -0700

> The link that I posted on scribd.com has a copy of it, fully searchable. 
> I can copy/paste from the PDF the plain text.

Thanks, I found it. :)

---

From: fdos <[email-masked]>
Date: Mon, 12 Jul 2010 08:04:11 -0700

The "Art of Assembly" source files should be on WHTECH in DV80 format 
(ready to assemble) on the MP disk image associated with the specific 
article of the month and year it appeared in MP.  The MP disks were 
available for a small copy & handling fee of $4.00 each from 
MICROpendium since April 1989.

Bill S

epergrem wrote:
> started reorganizing the WHT FTP section. It didn't take long to realize 
> that reorganization was a bigger undertaking than I was willing to 
> undertake. :-)
> 
> The PDF of the 'Art of Assembly' is already on the WHT FTP site in the 
> articles folder. It's CaDD's version, but Mike has graciously allowed it 
> to remain along with some of files from The CYC.
> 
> It might be worthwhile to create a 'tutorial' folder on WHT inside the 
> programming directory, where things like Wayne Stith's KWIKFONT source 
> and other tutorials in ASCII or PDF format could be easily accessed.
> 
> If I still have access WHT I would be willing to create the folder and 
> add the first couple of files if there is interest.
> 
> Ernie
> 
>  > If no one beats me to it, I'll see if I can do a PDF version starting 
> from the original disk version. Might up ending as a project for the 
> long winter nights.
>  >
>  > Filip
> 
>