Subject: Direct memory addressing

From: Owen Brand <[email-masked]>
Date: Sun, 1 Aug 2010 23:12:43 -0400

I know you can't technically address specific memory locations in XB  
like in assembly, but could it be possible to write an assembly  
routine that places map data into VDP memory to be utilized by XB  
after program control is passed back to XB?  I'm putting the cart in  
front of the horse on this one, but hopefully my question is  
understandable.  ;). Thanks

Owen Brand

        **webmaster**
http://www.Opry99er.com

---

From: "epergrem" <[email-masked]>
Date: Mon, 02 Aug 2010 11:47:34 -0000

Hi Owen,
Sure.  I've used SYSTEX in the past to embed an assembly routine that writes a new character set to VDP.  I can't see much difference between that and what you want to do other than you'll have to retrieve it.  

SYSTEX embeds the assembly code into your XB program.  The upside is that the assembly code doesn't have to be loaded separately.  Of course, renumbering the lines will trash it, but users shouldn't be doing that anyway.

Ernie

---

From: "Stuart" <[email-masked]>
Date: Mon, 02 Aug 2010 19:19:33 -0000

Assuming you're talking about addressing VDP memory, you can sort of address some of it by using CALL CHAR to write to it and CALL CHARPAT to read it. Character definitions 96-143 are usually unused by XB, giving you 376 bytes to play with, if that is any use ...

Stuart.