Subject: VDP Crystal and Composite Output Questions

From: "Stuart" <[email-masked]>
Date: Mon, 19 Jul 2010 18:51:50 -0000

Two questions that someone might know the answer to:

(1) The TMS9918, according to its datasheet, will happily directly 'drive' a 10.7MHz cystal directly, but on the 99/4A one side of the oscillator circuit is connected to Vcc via a series resistor and inductor. Is there is any reason for this? Are the components forming an external oscillator source, which is better in some way?

(2) The circuit on the TMS9918 composite output, based around Q200 and Q201 - is this just level-shifting the output? Underwhat conditions would you want the link W205 connected to bypass this circuit - when used as a PAL console with external modulator?

Thanks,
Stuart.

---

From: "chris20636" <[email-masked]>
Date: Wed, 21 Jul 2010 00:36:11 -0000

I don't know.  But I'll bump your thread by replying with some nonsense to question (1).  Maybe someone will jump in and tell me how wrong I am (and indirectly answer your questions :).

I can think of two reasons for the inductor.  The first would be to limit current flow during a transient condition, i.e. turn on / turn off.  Maybe the oscillator doesn't like sudden current changes (just a guess since I know nothing about them) or the TMS9918.

Secondly, it could be acting as a filter if noise on VCC entering here can show up as visible artifacts in the video.

Regards,
Chris

---

From: "chris20636" <[email-masked]>
Date: Wed, 21 Jul 2010 02:00:05 -0000

... As for (2)... I just spent some time studying the schematic and the description of the various video outputs located at:
http://www.nouspikel.com/ti99/titechpages.htm

From the link, I learned about 6 pin video outputs that use three video lines R-Y, B-Y, and Y.  Looking at a schematic shows the first two being output with no "stuff" in the middle.  They have dotted connection symbols labelled "W201/W202" and "W203/W204".  So it seems reasonably to assume that when these are in use that "Y" should not go through "stuff" either which is accomplished by "W205/W206".  What I don't know is if these are meant to be used via an RF modulator (PAL version) or if they are there for direct video connect to a monitor without RF modulator.

As for the "stuff" on the "Y" line, that is also used as the composite video for the NTSC version.  It looks to me like an amplifier, see this link,
http://www.allaboutcircuits.com/vol_3/chpt_4/6.html

Regards,
Chris