Subject: Call Color

From: Viola Jamison <[email-masked]>
Date: Tue, 1 Jun 2010 19:18:51 -0700 (PDT)

Is it possible to use different colors within the same character set?
 
For example, if I use char set 2 and use chars 42 (for the *) and 43 for the (+) is there a way to make them different colors (foreground/background) or are the both goverened by the call color?
 
Or, if I want the letter A with a different foreground/background then the letter B??
 
Thanks

---

From: Owen Brand <[email-masked]>
Date: Tue, 1 Jun 2010 22:58:26 -0400

CALL COLOR is set by set. If you're in XB, that's all you have to work  
with, so it's good to try and be creative and think your sets through  
before you go willy nilly setting colors.  :) It might seem very  
constrictive, but there are ways to create magic with our little color  
set here.  :) If you haven't done it yet, go to The TI Gameshelf and  
download the XB games done by Willi Doeltsch.  He created magic with  
XB, man.  Graphically flawless stuff.

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jun 1, 2010, at 10:18 PM, Viola Jamison <[email-masked]>  
wrote:

> For example, if I use char set 2 and use chars 42 (for the *) and 43  
> for the (+) is there a way to make them different colors (foreground/ 
> background) or are the both goverened by the call color?
>

---

From: "Tursi" <[email-masked]>
Date: Tue, 1 Jun 2010 22:26:11 -0700

That's right. But there is an easy way in XB to copy a pattern to another 
character, so if you wanted a plus and asterisk in different character sets, 
you could, for example, copy the plus character to the @ character (64), 
with:

10 CALL CHARPAT(43,A$)
20 CALL CHAR(64,A$)

--------------------------------------------------
From: "Owen Brand" <[email-masked]>
Sent: Tuesday, June 01, 2010 7:58 PM
To: <[email-masked]>
Subject: Re: [TI994A] Call Color

>> Or, if I want the letter A with a different foreground/nobackground
>> then the letter B??
>>
>> Thanks
>>
>>
>>
>

---

From: mark wills <[email-masked]>
Date: Wed, 2 Jun 2010 05:32:30 +0000 (GMT)

Hi Viola

Unfortunately not. This is restricted by how the video processor works. Each call color group effects 8 characters.

Of course, you could arrange your graphics characters (if that is what you are doing) such that you use one character from two groups. For example character 95 (the last character in set 8) and 96 (the first character in set 9). But, as already stated you cannot have individual colours for each character - only groups of 8 are possible.

Hope this helps

Mark

>
>From: Viola Jamison <[email-masked]>
>To: [email-masked]
>Sent: Wed, 2 June, 2010 3:18:51
>Subject: [TI994A] Call Color
>
> >
>
>
>
> >
> >
>
>
>
>
>
>
>

---

From: Owen Brand <[email-masked]>
Date: Wed, 2 Jun 2010 02:08:28 -0400

You need a copy of Magellan!!!  It is a screen/map graphic editor  
which allows you to define/redefine all the characters in the 14 set  
XB limit, the BASIC 16 set limit, and the assembler maximum.  Then, it  
exports to XB code!!!!!  Amazing.  Atariage.com.

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Jun 2, 2010, at 1:32 AM, mark wills <[email-masked]>  
wrote:

> Hi Viola
>
> Unfortunately not. This is restricted by how the video processor  
> works. Each call color group effects 8 characters.
>
> Of course, you could arrange your graphics characters (if that is  
> what you are doing) such that you use one character from two groups.  
> For example character 95 (the last character in set 8) and 96 (the  
> first character in set 9). But, as already stated you cannot have  
> individual colours for each character - only groups of 8 are possible.
>
> Hope this helps
>
> Mark
>
>
>