Subject: Combining DV80 files in Funnelweb

From: "Marc H" <[email-masked]>
Date: Fri, 01 Jul 2011 15:23:33 -0000

My current project has become somewhat of a bloated file mess and I would like to combine several of the smaller ones to clean up my disk area.  Is there a way to simply combine files using the FW editor and save me the trouble of doing it in XB ?

---

From: "jacques" <[email-masked]>
Date: Fri, 1 Jul 2011 13:15:25 -0300

Marc,

Load your first DV80 file in a FW editor and do a PF to a disk file but put 
a A in front of the path name. For example, enter PF and then A DSK1.TEST. 
Then LF your second file and again do a PF again that will show A DSK1.TEST. 
Your second file will be appended to the first.

Jacques

----- Original Message ----- 
From: "Marc H" <[email-masked]>
To: <[email-masked]>
Sent: Friday, July 01, 2011 12:23 PM
Subject: [TI994A] Combining DV80 files in Funnelweb

> My current project has become somewhat of a bloated file mess and I would 
> like to combine several of the smaller ones to clean up my disk area.  Is 
> there a way to simply combine files using the FW editor and save me the 
> trouble of doing it in XB ?
>
>
>
>
>
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>

---

From: mark wills <[email-masked]>
Date: Fri, 1 Jul 2011 17:22:10 +0100 (BST)

I think there is.

One way would be to "print" your files through the formatter - instead of saying PIO for the printer, issue a file name instead.

Backup first though!!!!

>________________________________
>From: Marc H <[email-masked]>
>To: [email-masked]
>Sent: Friday, 1 July 2011, 16:23

---

From: Tony Knerr <[email-masked]>
Date: Fri, 01 Jul 2011 14:07:34 -0400

Yes, I do this all the time with files created from Diskassembler.

Load the first file.

Look for the last line number from the first file, say it is 360 for 
example.

To load the 2nd file, first type LF <enter>.

Then for the filename type:

360 DSKx.2ndfile

Entering the number first tells Funnelweb what line number to load the 
file after.
You can use the function to load a file in the middle of another one, also.

Tony

Marc H wrote:
>  
>
> My current project has become somewhat of a bloated file mess and I 
> would like to combine several of the smaller ones to clean up my disk 
> area. Is there a way to simply combine files using the FW editor and 
> save me the trouble of doing it in XB ?
>

---

From: mark wills <[email-masked]>
Date: Fri, 1 Jul 2011 20:37:32 +0100 (BST)

Ooh! That's cool. I remember that now, just about.... It was around 18 years since I last used FWEB in anger!

Mark

>From: Tony Knerr <[email-masked]>
>Sent: Friday, 1 July 2011, 19:07
>Subject: Re: [TI994A] Combining DV80 files in Funnelweb
>

---

From: Marc Hull <[email-masked]>
Date: Fri, 1 Jul 2011 12:47:54 -0700 (PDT)

Thanks for the answers guys. Saved me a bit of effort ;-) !  Someone needs to write a book over FW....

--- On Fri, 7/1/11, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: Re: [TI994A] Combining DV80 files in Funnelweb
To: [email-masked]
Date: Friday, July 1, 2011, 1:07 PM

  

Load the first file.

example.

360 DSKx.2ndfile

file after.

Tony

Marc H wrote:

---

From: [email-masked]
Date: Fri, 1 Jul 2011 21:17:37 +0000 (UTC)

Another approach will work with Assembly or GPL Assemblers is just at the end of every file keep chaining the files. 

My RXB has source files A-M at the end of the file name. Example: COPY 'SCSI.SRXB.SRXB3-B' 
SRXB3-A... SRXB3-J and that file points to SRXB4-A...SRXB4-M and that file points to SRXB5-A...SRXB5-R and so on 

The only limit I have doing this is reaching the limit of the Symbol table in the Assembler. So far in GPL not a problem. 
Oh and you have to do it on a Hard Drive or Classic99 or Tape in Win99A for the List file. The Object file will never be bigger then 400sectors. 
320 sector Object file is the biggest I have ever made. In printed book form the RXB source code is 4 note book folders of source code. 
On a SCSI drive my list file is the size of 4 floppy DSDD. Send it via RS232 to a PC and you can edit it. 

You can use FWB or RAG editor or AMS Editor, but I just use the RAG as I like it. 
Editing on the PC side sucks as you get format errors with no tabs or it exceeds the DV80 line size. The main problem is characters are not all the same width size. 

Just my thoughts. Good luck. 

----- Original Message -----
From: "Tony Knerr" <[email-masked]> 
To: [email-masked] 
Sent: Friday, July 1, 2011 11:07:34 AM 
Subject: Re: [TI994A] Combining DV80 files in Funnelweb 

Load the first file. 

360 DSKx.2ndfile 

Tony

---

From: "jacques" <[email-masked]>
Date: Fri, 1 Jul 2011 18:59:00 -0300

Just out of curiosity, you make reference to the "RAG editor or AMS Editor'. 
Is the AMS editor that you use the RAG TIW Version 5.0 editor?

Jacques

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, July 01, 2011 6:17 PM
Subject: Re: [TI994A] Combining DV80 files in Funnelweb

Another approach will work with Assembly or GPL Assemblers is just at the 
end of every file keep chaining the files.

My RXB has source files A-M at the end of the file name. Example: COPY 
'SCSI.SRXB.SRXB3-B'
SRXB3-A... SRXB3-J and that file points to SRXB4-A...SRXB4-M and that file 
points to SRXB5-A...SRXB5-R and so on

The only limit I have doing this is reaching the limit of the Symbol table 
in the Assembler. So far in GPL not a problem.
Oh and you have to do it on a Hard Drive or Classic99 or Tape in Win99A for 
the List file. The Object file will never be bigger then 400sectors.
320 sector Object file is the biggest I have ever made. In printed book form 
the RXB source code is 4 note book folders of source code.
On a SCSI drive my list file is the size of 4 floppy DSDD. Send it via RS232 
to a PC and you can edit it.

You can use FWB or RAG editor or AMS Editor, but I just use the RAG as I 
like it.
Editing on the PC side sucks as you get format errors with no tabs or it 
exceeds the DV80 line size. The main problem is characters are not all the 
same width size.

----- Original Message -----
From: "Tony Knerr" <[email-masked]>
To: [email-masked]
Sent: Friday, July 1, 2011 11:07:34 AM
Subject: Re: [TI994A] Combining DV80 files in Funnelweb

Load the first file.

360 DSKx.2ndfile

Tony

---

From: [email-masked]
Date: Fri, 1 Jul 2011 22:11:50 +0000 (UTC)

Jacques 

No the RAG Editor is the one that came with the RAGGPL Assembler package. It is Assembly EDIT and EDIU files. 
The AMS Editor is FIRSTDRAFT that was never released but I had a copy and it uses the AMS memory. 
I got FIRSTDRAFT as some questions were directed to me so a copy was sent to check it out for bugs. 

I never use TI Writer for anything. Only Editor Assembler Editors. Well except for RXB USER DV80 Files. 

----- Original Message -----
From: "jacques" <[email-masked]> 
To: [email-masked] 
Sent: Friday, July 1, 2011 2:59:00 PM 
Subject: Re: [TI994A] Combining DV80 files in Funnelweb 

Jacques 

----- Original Message ----- 
From: "Tony Knerr" < [email-masked] > 
To: [email-masked] 
Sent: Friday, July 1, 2011 11:07:34 AM 
Subject: Re: [TI994A] Combining DV80 files in Funnelweb 

Load the first file. 

360 DSKx.2ndfile 

Tony