Subject: An Afternoon With Scott Adams

From: "Erik Olson" <[email-masked]>
Date: Mon, 28 Mar 2011 06:22:09 -0000

Scott Adams

In the era when the 16k text adventure, using simple verb-noun commands, had the charm to fire the imagination of a home computer user, Scott Adams was the king of the adventure world.

On Sunday, March 26, 2011, he appeared at Midwest Gaming Classic to talk about his early career and computer experiments. And then he stayed to talk about Adventure, and play one of his own games with his grandson on a TI-99/4A.

First, a clue: I was tidying up my TI-99/4 exhibit when I noticed someone had plugged the cassette recorder into the joystick port. I just smiled and put things right before dashing off to hear Scott Adams' talk. 

The talk was mostly recorded and will appear on YouTube, so I'll focus on what happened after that. 

In the Q&A afterward, I asked Scott Adams how much of the porting work was done by his company, and he replied that 99% of it was. When someone asked which platforms were supported, he oddly didn't mention TI, but he laughed when I held up the yellow Adventure manual. So after the talk, I asked Scott how he did the TI port of the Adventure module. 

First he said he coded it using the assembler that TI sent out to him, and he denied having had a GPL assembler or a TI development system (such as a 990 minicomputer.) But later he pointed out with a wry grin that "they misspelled my name on the title screen [of the Adventure cartridge]." Since the Adventure cartridge contains 1 GROM, I find these recollections hard to square, unless maybe TI did the port of the game interpreter to GPL, and Scott remembers working on Return to Pirate's Isle using the home computer Editor/Assembler.

Adventure was announced by TI in November 1981. E/A was announced at CES 1981 but did not ship for another year. (from Bill Gaskill's 99 Timeline.) 

* Return to Pirate's Isle * 

I showed Scott Adams the TI cartridges and manuals, and he got kind of wistful as he explained that he lost quite a bit of money on Return to Pirate's Isle. He had hired an artist to produce the TI graphics in house (literally, in his library.) He remembers the tricky part being the crafting of a fixed set of tiles that could be repeated in the images. The game was developed exclusively for the TI, and Scott was prepared to devote more resources to graphics adventures in cartridge form.  But TI pulled the plug before shipping many copies of the game.

Some other facts about Return to Pirate's Isle:

It was the only graphical adventure which Adventure International produced in cartridge form. The VIC-20 cartridges were ports from the main series of text adventures. 

TI produced only 30,000 copies, of which some unknown number were unsold, making it a rare cartridge, which Scott says I should not leave unattended in a console at a busy show.

I now have the world's only autographed copy of the cartridge, all the more reason not to leave it unattended. 

* Adventure Programming Language *

In the Q&A, I mentioned that we were able to buy an Adventure Editor for the TI in 1985, so, was there ever any plan at Adventure International to market their own editor? In response, I received a long story!  First, the in-house compiler was never in a state to be used by a casual user, and there was no documentation. In fact, some college students recently took on the task of documenting it, and failed. Second, Scott Adams had set up a UK office to work on ports of the games to the British home computers (this would be the Acorn?) When that was done, a certain employee there stole all of the code to the tools used to compile the adventure, and shared it with friends in Europe. So this may have been the origin of (German) Marcus Weiand's editor.  Eventually, this code was used by the author of Scott Free, an interpreter that has now been ported to many platforms. Finally, Scott Adams says that although he retains the copyright, he has no problem with the non-commercial distribution of his old games. In fact, he is amazed that there are still so many fans. 

* Remember that clue? *

During autographs, Scott mentioned that he had seen a cassette player on a TI in the exhibit area and tried to load one of his games for his grandson to play. Unfortunately he hadn't been successful in loading the database.

I chuckled as I realized how the cassette cable had got into the joystick port of my 99/4. You can't know how ironic this was to me! In January 1982, I faced the same dilemma trying to play the Adventure cartridge for the very first time, unable to divine that DSK1.PIRATE was the vital answer to the riddle "Where is the data base?" In fact, I typed FIND DATABASE and other commands since I believed the question was part of a game. I really didn't know a data base from a star base. Or secret rebel base.

I said I would be happy to help load the game for him, and we marched off to the exhibit area to give the cassette another try. It turned out that Scott wasn't interested in waiting for the cassette to load; instead we parked his grandson in front of Return to Pirate's Isle, and proceeded to play the game as a group while chatting about all manner of things. Scott's daughter Meg thanked me, saying it was good for her father to recall these happy memories. 

After 30 years, getting to first meet a living legend, and then to entertain him and his family: nothing else at the gaming show comes close.

---

From: mark wills <[email-masked]>
Date: Mon, 28 Mar 2011 11:36:22 +0100 (BST)

What a GREAT story! Thanks for sharing! I can't wait to see the YouTube video. 
Can you let us know when it's online?

Mark

________________________________
From: Erik Olson <[email-masked]>
To: [email-masked]
Sent: Mon, 28 March, 2011 7:22:09
Subject: [TI994A] An Afternoon With Scott Adams

Scott Adams

In the era when the 16k text adventure, using simple verb-noun commands, had the 
charm to fire the imagination of a home computer user, Scott Adams was the king 
of the adventure world.

On Sunday, March 26, 2011, he appeared at Midwest Gaming Classic to talk about 
his early career and computer experiments. And then he stayed to talk about 
Adventure, and play one of his own games with his grandson on a TI-99/4A.

First, a clue: I was tidying up my TI-99/4 exhibit when I noticed someone had 
plugged the cassette recorder into the joystick port. I just smiled and put 
things right before dashing off to hear Scott Adams' talk. 

The talk was mostly recorded and will appear on YouTube, so I'll focus on what 
happened after that. 

In the Q&A afterward, I asked Scott Adams how much of the porting work was done 
by his company, and he replied that 99% of it was. When someone asked which 
platforms were supported, he oddly didn't mention TI, but he laughed when I held 
up the yellow Adventure manual. So after the talk, I asked Scott how he did the 
TI port of the Adventure module. 

First he said he coded it using the assembler that TI sent out to him, and he 
denied having had a GPL assembler or a TI development system (such as a 990 
minicomputer.) But later he pointed out with a wry grin that "they misspelled my 
name on the title screen [of the Adventure cartridge]." Since the Adventure 
cartridge contains 1 GROM, I find these recollections hard to square, unless 
maybe TI did the port of the game interpreter to GPL, and Scott remembers 
working on Return to Pirate's Isle using the home computer Editor/Assembler.

Adventure was announced by TI in November 1981. E/A was announced at CES 1981 
but did not ship for another year. (from Bill Gaskill's 99 Timeline.) 

I showed Scott Adams the TI cartridges and manuals, and he got kind of wistful 
as he explained that he lost quite a bit of money on Return to Pirate's Isle. He 
had hired an artist to produce the TI graphics in house (literally, in his 
library.) He remembers the tricky part being the crafting of a fixed set of 
tiles that could be repeated in the images. The game was developed exclusively 
for the TI, and Scott was prepared to devote more resources to graphics 
adventures in cartridge form.  But TI pulled the plug before shipping many 
copies of the game.

It was the only graphical adventure which Adventure International produced in 
cartridge form. The VIC-20 cartridges were ports from the main series of text 
adventures. 

TI produced only 30,000 copies, of which some unknown number were unsold, making 
it a rare cartridge, which Scott says I should not leave unattended in a console 
at a busy show.

I now have the world's only autographed copy of the cartridge, all the more 
reason not to leave it unattended. 

In the Q&A, I mentioned that we were able to buy an Adventure Editor for the TI 
in 1985, so, was there ever any plan at Adventure International to market their 
own editor? In response, I received a long story!  First, the in-house compiler 
was never in a state to be used by a casual user, and there was no 
documentation. In fact, some college students recently took on the task of 
documenting it, and failed. Second, Scott Adams had set up a UK office to work 
on ports of the games to the British home computers (this would be the Acorn?) 
When that was done, a certain employee there stole all of the code to the tools 
used to compile the adventure, and shared it with friends in Europe. So this may 
have been the origin of (German) Marcus Weiand's editor.  Eventually, this code 
was used by the author of Scott Free, an interpreter that has now been ported to 
many platforms. Finally, Scott Adams says that although he retains the 
copyright, he has no problem with the non-commercial distribution of his old 
games. In fact, he is amazed that there are still so many fans. 

* Remember that clue? *

During autographs, Scott mentioned that he had seen a cassette player on a TI in 
the exhibit area and tried to load one of his games for his grandson to play. 
Unfortunately he hadn't been successful in loading the database.

I chuckled as I realized how the cassette cable had got into the joystick port 
of my 99/4. You can't know how ironic this was to me! In January 1982, I faced 
the same dilemma trying to play the Adventure cartridge for the very first time, 
unable to divine that DSK1.PIRATE was the vital answer to the riddle "Where is 
the data base?" In fact, I typed FIND DATABASE and other commands since I 
believed the question was part of a game. I really didn't know a data base from 
a star base. Or secret rebel base.

I said I would be happy to help load the game for him, and we marched off to the 
exhibit area to give the cassette another try. It turned out that Scott wasn't 
interested in waiting for the cassette to load; instead we parked his grandson 
in front of Return to Pirate's Isle, and proceeded to play the game as a group 
while chatting about all manner of things. Scott's daughter Meg thanked me, 
saying it was good for her father to recall these happy memories. 

After 30 years, getting to first meet a living legend, and then to entertain him 
and his family: nothing else at the gaming show comes close. 

------------------------------------

Yahoo! Groups Links

    http://docs.yahoo.com/info/terms/

---

From: Owen <[email-masked]>
Date: Mon, 28 Mar 2011 06:57:02 -0400

Erik, thank you so much for this story...  Truly an incredible experience it must have been.  Wish I could have been there.

Owen

Firebrandmusic.net

---

From: ti99_forever <[email-masked]>
Date: Mon, 28 Mar 2011 07:01:17 -0700 (PDT)

Ah, memories!
I lived around the corner from him, in Longwood, FL.
I remember I even sent him a letter asking if he had any positions open. Too bad I didn't hear from him, it would've been fun!

---

From: fdos <[email-masked]>
Date: Mon, 28 Mar 2011 10:03:56 -0700

Erik,

I'm not a gamester, but I Too, found your story to be very inspiring. 
Not enough to change my stripes, however. :-)

Thanks, and do post us when the video is on-line for viewing.

Bill S

On 3/27/2011 11:22 PM, Erik Olson wrote:
> In the Q&A, I mentioned that we were able to buy an Adventure Editor for the TI in 1985, so, was there ever any plan at Adventure International to market their own editor? In response, I received a long story!  First, the in-house compiler was never in a state to be used by a casual user, and there was no documentation. In fact, some college students recently took on the task of documenting it, and failed. Second, Scott Adams had set up a UK office to work on ports of the games to the British home computers (this would be the Acorn?) When that was done, a certain employee there stole all of the code to the tools used to compile the adventure, and shared it with friends in Europe. So this may have been the origin of (German) Marcus Weiand's editor.  Eventually, this code was used by the author of Scott Free, an interpreter that has now been ported to many platforms. Finally, Scott Adams says that although he retains the copyright, he has no problem with the non-commercial d
istribution of his old games. In fact, he is amazed that there are still so many fans.

-- 
Bill R Sullivan (FDOS)
Go Forth+ or X4th99

---

From: "hjalmarii" <[email-masked]>
Date: Mon, 28 Mar 2011 17:32:23 -0000

Wow! What a great day you had.  Thanks for sharing it with us and adding to TI lore.  --Hal