Subject: TI-99/4 (no A) compatible with CF?

From: "Erik Olson" <[email-masked]>
Date: Fri, 25 Mar 2011 14:03:59 -0000

I've got a vintage, working TI-99/4 here. Yes, /4, no bloody A.

And I've got a CF7A+ sidecar loaded up with games thanks to Walid's TI Gameshelf.

Before I introduce the CF7A+ to the 4's sidecar port, *just because I can*, is there any reason this might damage either hardware?  

I don't have any hardware specs specific to the /4, but I know the TI boxcar peripherals were upward compatible. Is the expansion port different in any way?

One software thing that comes to mind is the CF7 seems to override the title screen, so it overrides the console GROM? 

But aside from software problems, I'm trying to suss out if there is a reason to keep the hardware far, far away.

All I know is I woke up this morning with the thought of trying to run 21st century games like Neverlander on a 1981 console (provided they don't need a 9918A - no bitmap mode.)

I'm going to be running the /4 at the Midwest Gaming Classic (MIlwaukee) this weekend next to a souped up Commodore Pet, so I need to make it shine.

---

From: Marc Hull <[email-masked]>
Date: Fri, 25 Mar 2011 07:28:56 -0700 (PDT)

<All I know is I woke up this morning with the thought of trying to run 
21st century games like Neverlander on a 1981 console (provided they 
don't need a 9918A - no bitmap mode.)>

NL is out unfortunately.  Bit map.....

Have fun at the MGC.  Please report afterwords Erik.

--- On Fri, 3/25/11, Erik Olson <[email-masked]> wrote:

From: Erik Olson <[email-masked]>
Subject: [TI994A] TI-99/4 (no A) compatible with CF?
To: [email-masked]
Date: Friday, March 25, 2011, 9:03 AM

---

From: ti99_forever <[email-masked]>
Date: Fri, 25 Mar 2011 09:19:51 -0700 (PDT)

Should be fine! Sorry a 'bout NeverLander being bitmap - it's a sucky game anyway! ;)

(everytime you post, I have to remind myself you're the "good Erik"... you obviously don't post enough! ;)

--- On Fri, 3/25/11, Erik Olson <[email-masked]> wrote:

> Date: Friday, March 25, 2011, 10:03 AM
> Before I introduce the CF7A+ to the 4's sidecar port, *just
> because I can*, is there any reason this might damage either
> hardware?  
> 
> I don't have any hardware specs specific to the /4, but I
> know the TI boxcar peripherals were upward compatible. Is
> the expansion port different in any way?
> 
> One software thing that comes to mind is the CF7 seems to
> override the title screen, so it overrides the console GROM?
> 
> 
> But aside from software problems, I'm trying to suss out if
> there is a reason to keep the hardware far, far away.
> 
> All I know is I woke up this morning with the thought of
> trying to run 21st century games like Neverlander on a 1981
> console (provided they don't need a 9918A - no bitmap
> mode.)
> 
> I'm going to be running the /4 at the Midwest Gaming
> Classic (MIlwaukee) this weekend next to a souped up
> Commodore Pet, so I need to make it shine.
> 
> 
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: Marc Hull <[email-masked]>
Date: Fri, 25 Mar 2011 10:08:02 -0700 (PDT)

At the very least you could have said it was THE suckiest game ever. ;-).

--- On Fri, 3/25/11, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] TI-99/4 (no A) compatible with CF?
To: [email-masked]
Date: Friday, March 25, 2011, 11:19 AM

  

> I've got a vintage, working TI-99/4

> here. Yes, /4, no bloody A.

> And I've got a CF7A+ sidecar loaded up with games thanks to

> Walid's TI Gameshelf.

---

From: "Erik Olson" <[email-masked]>
Date: Fri, 25 Mar 2011 19:01:52 -0000

I can tell you the CF7A+ is compatible with the TI-99/4!  Done that. 

CF7 manager, however, might have issues with its VMBW routine timing. Half the screen writes go missing. Also can't type. Have to use Disk Manager 2 cart.

I tried to load Bubble Plane in XB and it got stuck at the title screen, just before a sound effect. Does the /4 console have the same type of user-defined ISR I wonder? I used my own ISR to play sound lists and music. It's not locked up because SHIFT-Q (quit) works.

I'll go through the TI-Gameshelf titles on the CF7 this weekend testing compatibility. 

Good god, I got my first TI-99/4 almost 30 years ago to the day. Tomorrow I'm probably going to run a cassette player into it. I wish I had my box of cassettes.

Somewhere in those cassettes was a copy of  "Cars and Carcasses" (Not-Polyoptics) that I played on the 99/4. There is somebody at Midwest Gaming Classic that really wants to see that game, mostly because it has a great name.

---

From: "Erik Olson" <[email-masked]>
Date: Fri, 25 Mar 2011 19:36:44 -0000

After trying several that don't work, I found that Star Fort works fine on the 99/4. This was one of my favorites games on the 4A too.

I think the 99/4 is dreaming that it died and went to heaven.

---

From: ti99_forever <[email-masked]>
Date: Fri, 25 Mar 2011 13:14:10 -0700 (PDT)

--- On Fri, 3/25/11, Erik Olson <[email-masked]> wrote:

> Subject: [TI994A] Re: TI-99/4 (no A) compatible with CF?
> Date: Friday, March 25, 2011, 3:01 PM

> 
> I tried to load Bubble Plane in XB and it got stuck at the
> title screen, just before a sound effect. Does the /4
> console have the same type of user-defined ISR I wonder? I
> used my own ISR to play sound lists and music. It's not
> locked up because SHIFT-Q (quit) works.

No user ISR in the 99/4. That was an improvement of the 99/4A.

---

From: tursi <[email-masked]>
Date: Fri, 25 Mar 2011 13:16:30 -0700 (PDT)

> <All I know is I woke up this morning with the thought of trying to run 21st century
> games like Neverlander on a 1981 console (provided they don't need a 9918A - no bitmap
> mode.)>

You should be able to test software compatibility in Classic99, it 
properly disables bitmap mode in 99/4 mode, and you will be able to 
determine whether the ROM/GROM differences cause any problems. Of course, 
remember that that keyboard is different too, but again, that'll be a 
software problem.

I'm not aware of any hardware differences that should bite you.

---

From: tursi <[email-masked]>
Date: Fri, 25 Mar 2011 14:04:30 -0700 (PDT)

> I tried to load Bubble Plane in XB and it got stuck at the title screen, 
> just before a sound effect. Does the /4 console have the same type of 
> user-defined ISR I wonder? I used my own ISR to play sound lists and 
> music. It's not locked up because SHIFT-Q (quit) works.

The 99/4 does NOT support the user ISR. :)

k

---

From: "Erik Olson" <[email-masked]>
Date: Sat, 26 Mar 2011 14:09:20 -0000

I had a nightmare in which I no longer have the source code (I don't) and I have to rewrite this to be backwards compatible with the /4.

Thanks to Bill, I have Cars & Carcasses now. (and a lot of others that sounded really cool when I read the blurbs in the TI catalog.) I just have to transfer it to cassette for the experience to be complete: 99/4 with old TV and cassette.

---

From: tursi <[email-masked]>
Date: Sat, 26 Mar 2011 12:44:53 -0700 (PDT)

> I had a nightmare in which I no longer have the source code (I don't) 
> and I have to rewrite this to be backwards compatible with the /4.

Hehe.. it is a tricky one. About the only way I can think of that you 
would replace the user ISR hook on the /4 would be to disable interrupts 
completely and instead of doing LIMI 2/LIMI 0, to actually check the VDP 
status register yourself. (Then, if an interrupt is pending, you can call 
the console ISR if you need it, plus call your own ISR).

I always figured that the /4 is rare enough that nobody is really using it 
anymore as their primary console. I did put support for it into my version 
of the multicart header, but that was more to see if I could. :)

---

From: "Erik Olson" <[email-masked]>
Date: Sun, 27 Mar 2011 06:35:57 -0000

My sound ISR was mixing 3 sound lists. I was thinking more along the lines of using the existing ISR: mixing lists together into one, or watching the VDP interrupt counter >8379 on each game loop to see when to execute my service routine.