Subject: Re: [TI994A] Long BASIC format

From: [email-masked]
Date: Tue, 19 Apr 2011 00:06:14 +0000 (UTC)

Michael 

Yes you are correct, but like I said with everyone using the same format to save trying to figure out problems is a pain as they are all the same format but each is a different program that runs them. Basic, XB, EA, third party the list goes on and on. Having all XB programs in I/V 254 format really is not a problem as then you can tell Basic and XB and EA5 from each other mostly. Over time using RXB all the XB programs will be I/V 254. This will not affect normal XB at all. And Basic can not load them. 

Rich 

----- Original Message ----- 
From: "ti99_forever" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 4:47:25 PM 
Subject: Re: [TI994A] Long BASIC format 

Wouldn't this "bug" be because you can only save 254 bytes per sector using IV254, whereas Program Image format gives you the entire 256 bytes per sector? So, all the extra "2" bytes per sector overflow into a new sector? 

--- On Mon, 4/18/11, [email-masked] <[email-masked]> wrote: 

From: [email-masked] <[email-masked]> 
Subject: Re: [TI994A] Long BASIC format [1 Attachment] 
To: [email-masked] 
Date: Monday, April 18, 2011, 5:22 PM 

[ Attachment(s) from [email-masked] included below] 

Hello Michael 

I have patch in the next RXB 2011 version that loads Program image files or I/V 254, but RXB version 2011 will only save in I/V 254 format and never save in 
Program Image format. Like everyone else I get sick of attempting to sort by Basic, XB, EA all using Program image formats. Not to mention some other 
apps out there that also use this format. The only bug I have with this is the I/V 254 always is 1 sector larger then the Program Image format. Timing the 
loading of the files shows no real speed difference other then the Program Image files have to be loaded into VDP then moved to RAM so they take a 
little longer to start. 
I am including the Source of the SAVE and OLD and MERGE as a attachment to this message. 

Rich 

----- Original Message ----- 
From: "Michael Zapf" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 5:41:08 AM 
Subject: [TI994A] Long BASIC format 

Hi there, 

does anybody know something about the file format INT/VAR 254 used for long Extended Basic programs? 

Seems to me as if the first record always contains a 10 byte header, probably containing memory pointers. I'm not sure about the second header; whether it starts with the Exbasic program or also has a header. 

It's difficult to find out by experiment since Exbasic automatically uses the format when programs become too long to fit into the VDP space. 

Michael 

Attachment(s) from [email-masked] 

1 of 1 File(s) 

IV254.txt

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 18 Apr 2011 20:44:32 -0500

Actually, IV254 files will load more slowly when used with slower devices such as floppy disks.  I recommend you add the option to save as a program image, perhaps similar to the ",MERGE" option, for those who would find little value in turning programs into IV254 files. 
 
I have always made it a point to keep most programs under the IV254 threshold for the very reason that program image files load faster than record-based IO files. 

[Attachment(s) from [email-masked] included below] 

Hello Michael

Rich

---

From: ti99_forever <[email-masked]>
Date: Mon, 18 Apr 2011 21:34:26 -0700 (PDT)

You're just mean! Stop being mean!
Michael
P.S. - How do you like my new name?

--- On Mon, 4/18/11, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Long BASIC format
To: [email-masked]
Date: Monday, April 18, 2011, 9:44 PM

 

 

Hello Michael

Rich

#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mkp
{border:1px solid #d8d8d8;font-family:Arial;padding:0 10px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mkp hr
{border:1px solid #d8d8d8;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mkp #yiv520013856ecxhd
{color:#628c2a;font-size:85%;font-weight:700;line-height:122%;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mkp #yiv520013856ecxads
{margin-bottom:10px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mkp .yiv520013856ecxad
{padding:0 0;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mkp .yiv520013856ecxad p
{}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mkp .yiv520013856ecxad a
{color:#0000ff;text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-sponsor #yiv520013856ecxygrp-lc
{font-family:Arial;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-sponsor #yiv520013856ecxygrp-lc #yiv520013856ecxhd
{font-weight:700;font-size:78%;line-height:122%;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-sponsor #yiv520013856ecxygrp-lc .yiv520013856ecxad
{margin-bottom:10px;padding:0 0;}
#yiv520013856 .yiv520013856ExternalClass a
{color:#1e66ae;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxactions
{font-family:Verdana;font-size:11px;padding:10px 0;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxactivity
{background-color:#e0ecee;float:left;font-family:Verdana;font-size:10px;padding:10px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxactivity span
{font-weight:700;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxactivity span a
{color:#5085b6;text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxactivity span span
{color:#ff7900;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxactivity span .yiv520013856ecxunderline
{text-decoration:underline;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxattach
{clear:both;display:table;font-family:Arial;font-size:12px;padding:10px 0;width:400px;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxattach div a
{text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxattach img
{border:none;padding-right:5px;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxattach label
{display:block;margin-bottom:5px;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxattach label a
{text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass blockquote
{}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxbold
{font-family:Arial;font-size:13px;font-weight:700;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxbold a
{text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass dd.yiv520013856ecxlast p a
{font-family:Verdana;font-weight:700;}
#yiv520013856 .yiv520013856ExternalClass dd.yiv520013856ecxlast p span
{margin-right:10px;font-family:Verdana;font-weight:700;}
#yiv520013856 .yiv520013856ExternalClass dd.yiv520013856ecxlast p span.yiv520013856ecxyshortcuts
{margin-right:0;}
#yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxattach-table div div a
{text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxattach-table
{width:400px;}
#yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxfile-title a, #yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxfile-title a:active, #yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxfile-title a:hover, #yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxfile-title a:visited
{text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxphoto-title a, #yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxphoto-title a:active, #yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxphoto-title a:hover, #yiv520013856 .yiv520013856ExternalClass div.yiv520013856ecxphoto-title a:visited
{text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass ecxdiv#yiv520013856ygrp-mlmsg #yiv520013856ecxygrp-msg p a span.yiv520013856ecxyshortcuts
{font-family:Verdana;font-size:10px;font-weight:normal;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxgreen
{color:#628c2a;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxMsoNormal
{}
#yiv520013856 .yiv520013856ExternalClass ecxo
{font-size:0;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxphotos div
{float:left;width:72px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxphotos div div
{border:1px solid #666666;height:62px;overflow:hidden;width:62px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxphotos div label
{color:#666666;font-size:10px;overflow:hidden;text-align:center;white-space:nowrap;width:64px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxreco-category
{font-size:77%;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxreco-desc
{font-size:77%;}
#yiv520013856 .yiv520013856ExternalClass .yiv520013856ecxreplbq
{}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mlmsg
{font-size:13px;font-family:Arial, helvetica, clean, sans-serif;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mlmsg table
{font-size:inherit;font:100%;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mlmsg select, #yiv520013856 .yiv520013856ExternalClass input, #yiv520013856 .yiv520013856ExternalClass textarea
{font:99% Arial, Helvetica, clean, sans-serif;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mlmsg pre, #yiv520013856 .yiv520013856ExternalClass code
{font:115% monospace;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mlmsg ecx*
{line-height:1.22em;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mlmsg #yiv520013856ecxlogo
{padding-bottom:10px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-mlmsg a
{color:#1E66AE;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-msg p a
{font-family:Verdana;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-msg ecxp#yiv520013856attach-count span
{color:#1E66AE;font-weight:700;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-reco #yiv520013856ecxreco-head
{color:#ff7900;font-weight:700;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-reco
{margin-bottom:20px;padding:0px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-sponsor #yiv520013856ecxov li a
{font-size:130%;text-decoration:none;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-sponsor #yiv520013856ecxov li
{font-size:77%;list-style-type:square;padding:6px 0;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-sponsor #yiv520013856ecxov ul
{padding:0 0 0 8px;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-text
{font-family:Georgia;}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-text p
{}
#yiv520013856 .yiv520013856ExternalClass #yiv520013856ecxygrp-text tt
{font-size:120%;}

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 19 Apr 2011 00:17:13 -0500

Come on Ben, the last time you brought up this terribly old joke must have been during the 90s... Get with the right decade ;)

To: [email-masked]
From: [email-masked]
Date: Mon, 18 Apr 2011 21:34:26 -0700
Subject: RE: [TI994A] Long BASIC format

Michael

 

Hello Michael

Rich

---

From: ti99_forever <[email-masked]>
Date: Mon, 18 Apr 2011 22:49:54 -0700 (PDT)

No thanks, I like the 90s... my hair wasn't so damn gray back then and a sex life didn't require an Rx!

--- On Tue, 4/19/11, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Long BASIC format
To: [email-masked]
Date: Tuesday, April 19, 2011, 1:17 AM