Subject: Slightly off-topic (maybe :-)

From: "atrax27407" <[email-masked]>
Date: Fri, 21 Jan 2011 21:33:11 -0000

I am currently using Fred Kaal's TI99Dir and PC-TRANSFER to move programs from my desktop PC to my TI. The problem is that the 3.5" drive in the PC (Compaq) went out. In trying to get it replaced, I found that the drive is a "proprietary" drive. I have found a replacement and, while waiting for it to arrive, would like to pose this question. I have a USB TEAC that is "plug and play" in both windows XP and Windows 7. However. it will not read 720K disks even though the packaging clearly says that it will. The problem I believe is in the Microsoft driver software. (TEAC USB UF000x generic driver). Does anyone know of a driver that will enable the TEAC USB drive to read/write 720K disks - or a PC application program that will accomplish the same thing? Or. a way to read the files from a 1.44Mb disk and write them to a TI-Formatted disk?

I would use Paolo's program but both of my machines are 64-bit which precludes using it.

---

From: Gregory McGill <[email-masked]>
Date: Fri, 21 Jan 2011 14:28:58 -0800

Have you tried Fred's cool HDX serial port utility?  Way easy.. you just use
dm2k type interface to pull v9t9 format files down and up from and to the
pc.   Works great

Greg

On Fri, Jan 21, 2011 at 1:33 PM, atrax27407 <[email-masked]> wrote:

>
>
> I am currently using Fred Kaal's TI99Dir and PC-TRANSFER to move programs
> from my desktop PC to my TI. The problem is that the 3.5" drive in the PC
> (Compaq) went out. In trying to get it replaced, I found that the drive is a
> "proprietary" drive. I have found a replacement and, while waiting for it to
> arrive, would like to pose this question. I have a USB TEAC that is "plug
> and play" in both windows XP and Windows 7. However. it will not read 720K
> disks even though the packaging clearly says that it will. The problem I
> believe is in the Microsoft driver software. (TEAC USB UF000x generic
> driver). Does anyone know of a driver that will enable the TEAC USB drive to
> read/write 720K disks - or a PC application program that will accomplish the
> same thing? Or. a way to read the files from a 1.44Mb disk and write them to
> a TI-Formatted disk?
>

---

From: fdos <[email-masked]>
Date: Sun, 23 Jan 2011 15:34:09 -0700

Greg,

You haven't said anything about the cable you are using with your 
TI99HDX serial port utility.  I'm assuming it's a straight through 
cable, not a null modem cable, yes?  Otherwise?

I have two null modem cables that I'm trying to use with my NanoPEB 
system.  Both cables are D9 at one end but D25 at the other end which 
requires a D25 to D9 adapter.  Neither one works, so I've ordered two 
with D9 connectors at both ends, but what I could do, now that I have a 
monitor for my TI-99/4A&P systems, is to connect the TI-99/4P (only one 
with a RS-232 card) to the TI Win2K PC peripheral running TI99HDX, and 
see if that works.  Hopefully, sometime this week.

Bill S

On 1/21/2011 3:28 PM, Gregory McGill wrote:
> On Fri, Jan 21, 2011 at 1:33 PM, atrax27407<[email-masked]>  wrote:
>
>>
>>

---

From: Gregory McGill <[email-masked]>
Date: Sun, 23 Jan 2011 16:19:47 -0800

I did actually. I have a black-box quick cabler 50 ts126a.  It has 4
switches. I switch it around till it works, never have to make an
rs232 cable :).  Unfortunately they don't sell them any longer, and
they were too expensive when they did.  I picked up this one when I
was doing consulting in the 90's and billed the customer :)

You will be much happier making a cable or at least an adaptor
yourself for the TI than trying to buy something off the shelf.
NOTHING is wired correctly for the 4a except for a straight through
cable from the TI, Myarc or Corcomp cards to a PC rs232 port.  And
then CTS DSR DTE may not be correct and handshaking will fail at high
speeds.

Here is way too much information on the subject, you will be tested later.

For more info on rs232 standards and  DCE vs DTE consult this web page
http://www.cableeye.com/Data_Com_Basics/RS232_standard.html

Long story short, DCE devices should connect to DTE devices without
having to swap pins/lines..

The TI RS232 port is DCE meaning that receive data is on pin 2 and
transmit is on pin 3. It's also non-standard since it contains 2 ports
on one DB25.

TI rs232 pinout:
1 - ground
2 - recieve data
3 - transmit data
5 - clear to send
6 - data set ready
7 - ground
9 - data carrier detect
20 - DTR

The PC 25 pin RS232 port is DTE meaning that receive data is on pin 3
and transmit is on pin 2. It follows rs232 standards for the most
part.

25 pin
1 - ground
2 - Transmit Data
3 - Receive Data
4 - Ready To Send
5 - Clear To Send
6 - Data Set Ready
7 - Ground
8 - Carrier Detect
20 - Data Terminal Ready
22 - Ring indicator

9 pin
1 - Carrier Detect
2 - Receive Data
3 - Transmit Data
4 - Data Terminal Ready
5 - Ground
7 - Data Set Ready
8 - Clear to send
9 - ring indicator
Notice the 9pin connector is DCE?  yep they switched it around.

Therefore TI->PC 25 pin to 25 pin you can usually use a normal
straight-through cable and receive and transmit match up.. however,
with serial transmitting you usually want handshaking as well, that
way when you overrun the buffers on one end it can signal to the other
device to hang-on and wait while we empty the buffer.

By the way if you use a 9->25 adapter to get your TI 25 pin to a pc 9
pin, its a null modem inside.. swapping pins 2/3 making the PC side
DTE

http://www.lammertbies.nl/comm/cable/RS-232.html (has nice pictures)

9pin        25pin
1            8           Data Carrier Detect
2            3           Receive Data
3            2           Transmit Data
4            20         Data Terminal Ready
5            7           Ground
6            6           Data Set Ready
7            4           Request To Send
8            5           Clear To Send
9            22         Ring Indicator

The NanoPEB has the following pinout DCE again..

#1 - Not connected
#2 - RXD
#3 - TXD
#4 - Not connected
#5 - GND
#6 - Not connected
#7 - RTS
#8 - CTS
#9 - Not connected

SO! if you hook that to the  9->25 adaptor and you get this

    nanopeb    9               25pin
1                                   8  DCD
2   rxd            2 rxd         3  RXD
3   txd            2 txd         2  TXD
4                                   20 DTR
5   gnd           2 gnd        7  GND
6                                   6  DSR
7   rts             2 rts         4  RTS
8   cts            2 cts         5  CTS
9                                   22 RING

dce                                dte

hook that to a null modem cable and that makes it DCE again, as the
definition of a null modem is a DCE-DTE converter. Assuming the cables
follow the rs232 standard, ymmv.

Since your PC 9pin rs232 is DCE .. it's not going to work.

You need a straight through cable to the PC once you put the 9->25
adaptor on your already putting the null modem in the cable. Both
sides are DCE to start with.

What you should use is a straight 9-9 cable, no null modem. And build
a box or adaptor or just cut the cable and wire the wires to do this
(NOTE THIS IS FROM FRED'S PAGE, FROM HIS DOCS ON MAKING A CABLE FOR
HIS SOFTWARE)

dcd/dsr 1/6 - 4  dtr
rxd        2 - 3    txd
txd        3 - 2    rxd
dtr        4 - 6/1  dsr/dcd
gnd       5 - 5    gnd
rts         7 - 8    cts
cts        8 - 7    rts

dsr and dcd are tied together to dtr on both sides, and rts is tied to
cts on both sides

By the way, on the subject of null modems. There are 3 kinds of null
modems around, there's no handshaking, loop back handshaking and
partial handshaking. No handshaking just wires through pins 2 3 and 5
and that's it swapping 2 and 3 on the way.  Loop back wires those
three through, swapping 2 and 3 again but then wires back the
handshaking lines so that each device's dtr line makes carrier and
data set ready good on it's side. Essentially sticking a quarter in
the fuse panel so it's always clear to send.

Null modems with handshaking usually are wired like this:

cd      1     7/8 rts/cts
rxd      2     3   txd
txd      3     2   rxd
dtr       4     6  dsr
gnd      5     5  gnd
dsr       6     4  dtr
rts/cts 7/8   1   cd

So the cd is tied to RTS and CTS lines, making carrier detect good
when rts or cts are live..  defeating our handshaking None of these
will work properly with this software as it requires the hand shaking
ports wired correctly to work..

whew!
Greg

---

From: ti99_forever <[email-masked]>
Date: Sun, 23 Jan 2011 21:15:15 -0800 (PST)

ISTR that on a real TI rs232 that RTS is not connected. I'm sure if I am wrong (maybe it is CTS), that someone real helpful will reply with "WRONG!" in the beginning of their message... ;)
Does the nanoPEB connect this line? I know to do proper handshaking for, say, Jeff Brown's Term80 (if that is the correct name) you had to use a different line (believe it was DTR), that was controlled by software instead of the 9902.
Always wondered about bringing RTS out to the port, but I believe it required an addtional receiver/driver chip (if that name is correct)
And I remember RTS meaning "Request to Send", not "Ready to Send".

---

From: Gregory McGill <[email-masked]>
Date: Sun, 23 Jan 2011 21:28:21 -0800

Hey cool  no rts on a real ti, and its listed both ways on the references i
was quoting and on my message..so lets agree on request to send

Greg

On Sun, Jan 23, 2011 at 9:15 PM, ti99_forever <[email-masked]>wrote:

>
>
> ISTR that on a real TI rs232 that RTS is not connected. I'm sure if I am
> wrong (maybe it is CTS), that someone real helpful will reply with "WRONG!"
> in the beginning of their message... ;)
>
> Does the nanoPEB connect this line? I know to do proper handshaking for,
> say, Jeff Brown's Term80 (if that is the correct name) you had to use a
> different line (believe it was DTR), that was controlled by software instead
> of the 9902.
>
> Always wondered about bringing RTS out to the port, but I believe it
> required an addtional receiver/driver chip (if that name is correct)
>

---

From: fdos <[email-masked]>
Date: Mon, 24 Jan 2011 08:51:05 -0700

Greg,

Thanks for the great dissertation, But I was only looking for the 
specific connection you used for your TI to PC for TI99HDX operation.  I 
assumed it was just a straight-through D9 serial cable.  I have a big 
book called "Complete Guide to RS232 and Parallel Connections" by Martin 
D. Sayer, touted as "A step-by-step approach to connecting Computer, 
Printers, Terminals and Modems" along with a PC test program that uses 
many different terminations with D9 & D25 connectors to determine the 
operational status of those PC ports.

However, I'm sure many will benefit from this posting as a full 
understanding of all the serial methods that we TI/Geneve hobbyists have 
to communicate with the outside world is important to all of us.  I was, 
however, led to believe that the NanoPEB was DTE and not DCE like our 
PEB RS-232 cards.  Can someone clarify this?

Bill S

On 1/23/2011 5:19 PM, Gregory McGill wrote:
> On Sun, Jan 23, 2011 at 2:34 PM, fdos<[email-masked]>  wrote:
>>
>>
>>
>> Greg,
>>

---

From: Gregory McGill <[email-masked]>
Date: Mon, 24 Jan 2011 08:34:37 -0800

I got my information from Fred's Page on his interface specs with the
device. According to Fred it is DCE and therefore becomes DTE with a 9->25
adapter. And neither a straight through OR null modem cable both do not wire
the cts properly.

Greg

On Mon, Jan 24, 2011 at 7:51 AM, fdos <[email-masked]> wrote:

> > On Sun, Jan 23, 2011 at 2:34 PM, fdos<[email-masked]<fdosbrs%40frontiernet.net>>
> wrote:
> >>
> >>
> >>
> >> Greg,
> >>
> >>> On Fri, Jan 21, 2011 at 1:33 PM, atrax27407<[email-masked]<rmcarmany%40aol.com>>
> wrote:
> >>>
> >>>>
> >
>
>  
>

---

From: fdos <[email-masked]>
Date: Mon, 24 Jan 2011 09:44:22 -0700

Still not forgiven! :-(  It has been a really long time now, and I've 
even removed that word from my vocabulary, so impossible for me to speak 
or type it.

---

From: fdos <[email-masked]>
Date: Mon, 24 Jan 2011 09:46:13 -0700

Thanks Greg,

This is what I needed to know.

Bill S

On 1/24/2011 9:34 AM, Gregory McGill wrote:
> On Mon, Jan 24, 2011 at 7:51 AM, fdos<[email-masked]>  wrote:
>
>>
>>
>> Greg,
>>
>> many different terminations with D9&  D25 connectors to determine the

---

From: Jeffrey White <[email-masked]>
Date: Mon, 24 Jan 2011 12:53:39 -0800 (PST)

Below is a link into comp.sys.ti that discusses the TI RS232-to-modem 
handshaking with RTS/CTS:

http://groups.google.com/group/comp.sys.ti/browse_thread/thread/193d862d7523f5e1/58716cfddb787e83?hl=en&ie=UTF-8&q=comp.sys.ti+jeff+white+brown

Having 2 ports on the 25-pin connector is part of the RS232 standard.

Jeff White

________________________________
From: Gregory McGill <[email-masked]>
To: [email-masked]
Sent: Sun, January 23, 2011 7:19:47 PM
Subject: Re: [TI994A] Slightly off-topic (maybe :-)

TI rs232 pinout:
1 - ground
2 - recieve data
3 - transmit data
5 - clear to send
6 - data set ready
7 - ground
9 - data carrier detect
20 - DTR

25 pin
1 - ground
2 - Transmit Data
3 - Receive Data
4 - Ready To Send
5 - Clear To Send
6 - Data Set Ready
7 - Ground
8 - Carrier Detect
20 - Data Terminal Ready
22 - Ring indicator

9 pin
1 - Carrier Detect
2 - Receive Data
3 - Transmit Data
4 - Data Terminal Ready
5 - Ground
7 - Data Set Ready
8 - Clear to send
9 - ring indicator

9pin        25pin
1            8           Data Carrier Detect
2            3           Receive Data
3            2           Transmit Data
4            20         Data Terminal Ready
5            7           Ground
6            6           Data Set Ready
7            4           Request To Send
8            5           Clear To Send
9            22         Ring Indicator

#1 - Not connected
#2 - RXD
#3 - TXD
#4 - Not connected
#5 - GND
#6 - Not connected
#7 - RTS
#8 - CTS
#9 - Not connected

nanopeb 9 25pin
1 8 DCD
2 rxd 2 rxd 3 RXD
3 txd 2 txd 2 TXD
4 20 DTR
5 gnd 2 gnd 7 GND
6 6 DSR
7 rts 2 rts 4 RTS
8 cts 2 cts 5 CTS
9 22 RING

dce dte

dcd/dsr 1/6 - 4 dtr
rxd 2 - 3 txd
txd 3 - 2 rxd
dtr 4 - 6/1 dsr/dcd
gnd 5 - 5 gnd
rts 7 - 8 cts
cts 8 - 7 rts

cd 1 7/8 rts/cts
rxd 2 3 txd
txd 3 2 rxd
dtr 4 6 dsr
gnd 5 5 gnd
dsr 6 4 dtr
rts/cts 7/8 1 cd

whew!
Greg

---

From: ti99_forever <[email-masked]>
Date: Mon, 24 Jan 2011 13:11:40 -0800 (PST)

Wow, I miss Jeff Brown... he was like a hamster on speed!And I wired a cable like that and used it with Term80 and ZT4, which was never a finished terminal program but very capable, and very fast...

--- On Mon, 1/24/11, Jeffrey White <[email-masked]> wrote:

From: Jeffrey White <[email-masked]>
Subject: Re: [TI994A] Slightly off-topic (maybe :-)
To: [email-masked]
Date: Monday, January 24, 2011, 3:53 PM

Below is a link into comp.sys.ti that discusses the TI RS232-to-modem handshaking with RTS/CTS:

 
Jeff White

Long
 story short, DCE devices should connect to DTE devices without
having to swap pins/lines..

TI rs232 pinout:
1 - ground
2 - recieve data
3 - transmit data
5 - clear to send
6 - data set ready
7 - ground
9 - data carrier detect
20 - DTR

25 pin
1 - ground
2 - Transmit Data
3 - Receive Data
4 - Ready To Send
5 - Clear To Send
6 - Data Set Ready
7 - Ground
8 - Carrier Detect
20 - Data Terminal Ready
22 - Ring indicator

9 pin
1 - Carrier Detect
2 - Receive Data
3 - Transmit Data
4 - Data Terminal Ready
5 - Ground
7 - Data Set Ready
8 - Clear to
 send
9 - ring indicator

9pin        25pin
1            8           Data Carrier Detect
2            3           Receive Data
3          
  2           Transmit Data
4            20         Data Terminal Ready
5            7           Ground
6            6           Data Set Ready
7            4           Request To Send
8            5           Clear To Send
9            22         Ring Indicator

#1 - Not connected
#2 - RXD
#3 - TXD
#4 - Not connected
#5 - GND
#6 - Not connected
#7 - RTS
#8 - CTS
#9 - Not connected

nanopeb 9 25pin
1 8 DCD
2 rxd 2 rxd 3 RXD
3
 txd 2 txd 2 TXD
4 20 DTR
5 gnd 2 gnd 7 GND
6 6 DSR
7 rts 2 rts 4 RTS
8 cts 2 cts 5 CTS
9 22 RING

dce dte

dcd/dsr 1/6 - 4 dtr
rxd 2 - 3 txd
txd 3 - 2 rxd
dtr 4 - 6/1 dsr/dcd
gnd 5 - 5 gnd
rts 7 - 8 cts
cts 8 - 7 rts

dsr and dcd are tied together
 to dtr on both sides, and rts is tied to
cts on both sides

cd 1 7/8 rts/cts
rxd 2 3 txd
txd 3 2 rxd
dtr 4 6 dsr
gnd 5 5 gnd
dsr 6 4 dtr
rts/cts 7/8 1 cd

So the cd is tied to RTS and CTS lines, making carrier detect good
when rts or cts are live.. defeating our handshaking None of these
will work properly with this
 software as it requires the hand shaking
ports wired correctly to work..

whew!
Greg

On Sun, Jan 23, 2011 at 2:34 PM, fdos <[email-masked]> wrote:
> with a
 RS-232 card) to the TI Win2K PC peripheral running TI99HDX, and

---

From: Jeffrey White <[email-masked]>
Date: Mon, 24 Jan 2011 13:10:53 -0800 (PST)

Here is the hardware handshake cable to a modem from TI RS232/1:

RS232  Modem  Name 
  1      1    Protective Ground 
  2 <--  3    Receive Data 
  3 -->  2    Transmit Data 
  5 -->  4    Request to Send 
  6      -    No connection 
  7      7    Logical Ground 
  8 --> 20    Data Terminal Ready 
 20 <--  5    Clear to Send 

Read the thread linked to in my prior message to perhaps understand how the 
cable functions.
 
Jeff White

Sent: Mon, January 24, 2011 12:28:21 AM

Hey cool  no rts on a real ti, and its listed both ways on the references i was 
quoting and on my message..so lets agree on request to send 

Greg

On Sun, Jan 23, 2011 at 9:15 PM, ti99_forever <[email-masked]> wrote:

>ISTR that on a real TI rs232 that RTS is not connected. I'm sure if I am wrong 
>(maybe it is CTS), that someone real helpful will reply with "WRONG!" in the 
>beginning of their message... ;) 
>
>
>
>Does the nanoPEB connect this line? I know to do proper handshaking for, say, 
>Jeff Brown's Term80 (if that is the correct name) you had to use a different 
>line (believe it was DTR), that was controlled by software instead of the 9902.
>
>
>Always wondered about bringing RTS out to the port, but I believe it required an 
>addtional receiver/driver chip (if that name is correct)
>
>

---

From: ti99_forever <[email-masked]>
Date: Mon, 24 Jan 2011 13:15:23 -0800 (PST)

After reading the stuff Jeff posted, it would seem RTS these days is more aptly named "Ready to Send"... which is why the real RTS on a 9902 would not work.

--- On Mon, 1/24/11, Gregory McGill <[email-masked]> wrote:

From: Gregory McGill <[email-masked]>
Subject: Re: [TI994A] Slightly off-topic (maybe :-)
To: [email-masked]
Date: Monday, January 24, 2011, 12:28 AM

 

Hey cool  no rts on a real ti, and its listed both ways on the references i was quoting and on my message..so lets agree on request to send
Greg

---

From: mark wills <[email-masked]>
Date: Mon, 24 Jan 2011 21:35:47 +0000 (GMT)

RTS=Ready to send
CTS=Clear to send

That was what I learned all those years ago!

>
>From: ti99_forever <[email-masked]>
>Sent: Mon, 24 January, 2011 21:15:23
>After reading the stuff Jeff posted, it would seem RTS these days is more aptly 
>named "Ready to Send"... which is why the real RTS on a 9902 would not work.
>