Subject: Re: [TI-99/4A] Annoying keypress repetitioooonnnn

From: "[email-masked]" <[email-masked]>
Date: Wed, 26 Jan 2011 12:55:09 -0800 (PST)

Anyone?

--- On Tue, 1/25/11, gogokikaida <[email-masked]> wrote:

From: gogokikaida <[email-masked]>
Subject: [TI-99/4A] Annoying keypress repetitioooonnnn
To: [email-masked]
Date: Tuesday, January 25, 2011, 8:59 PM

  

      My upgraded TI console is showing a problem with the key presses. Whenever I press a key, it gets repeated. Like thhhhisss. And when I press the back arrow it also sometimes skips a few spaces. Anyone know of a solution to this?

---

From: ti99_forever <[email-masked]>
Date: Wed, 26 Jan 2011 13:30:58 -0800 (PST)

Clean it, if you can  remove the keycaps. This happens through non-use, which can also cause some keys to stop working. Also, working the keys can sometimes fix this.

Worst case - buy a replacement keyboard - texintreasures.com may have them. They have beige ones for $4.95...

--- On Wed, 1/26/11, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: [TI994A] Re: [TI-99/4A] Annoying keypress repetitioooonnnn
To: [email-masked], [email-masked]
Date: Wednesday, January 26, 2011, 3:55 PM

Anyone?

---

From: Marc Hull <[email-masked]>
Date: Wed, 26 Jan 2011 13:53:49 -0800 (PST)

Exactly what is the upgrade ?

From: [email-masked] <[email-masked]>
Subject: [TI994A] Re: [TI-99/4A] Annoying keypress repetitioooonnnn
To: [email-masked], [email-masked]
Date: Wednesday, January 26, 2011, 2:55 PM

  

      Anyone?

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 26 Jan 2011 15:17:30 -0800 (PST)

Thanks, I'll remove the keycaps and give it a cleaning. I hope 91% rubbing alcohol isn't bad, but I can't find 99% locally. Any thoughts?
Yes, I know Mike sells the beige ones...hopefully it won't come to that.

C

--- On Wed, 1/26/11, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: [TI-99/4A] Annoying keypress repetitioooonnnn
To: [email-masked]
Date: Wednesday, January 26, 2011, 4:30 PM

  

        

Anyone?

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 26 Jan 2011 15:20:24 -0800 (PST)

It got upgraded by the previous owner some time in the 80s to 48K memory. I was thinking it was this one http://www.mainbyte.com/ti99/16bit32k/32kconsole.html  but years before.

--- On Wed, 1/26/11, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Re: [TI-99/4A] Annoying keypress repetitioooonnnn
To: [email-masked]
Date: Wednesday, January 26, 2011, 4:53 PM

  

 

      Anyone?

---

From: ti99_forever <[email-masked]>
Date: Wed, 26 Jan 2011 15:27:57 -0800 (PST)

Well, I don't recall that upgrade possibly affecting the keyboard - but the keyboard has to be removed to do it. Perhaps the ribbon cable has been affected. I once had a black keyboard where the ribbon cable slipped right off the keyboard...

In that case, get out your soldering iron...

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] Re: [TI-99/4A] Annoying keypress repetitioooonnnn
To: [email-masked]
Date: Wednesday, January 26, 2011, 6:20 PM

 

 

      Anyone?

---

From: Marc Hull <[email-masked]>
Date: Wed, 26 Jan 2011 15:35:44 -0800 (PST)

I agree.  32K (that's what the mod is) wouldn't effect the key board.  If it's black I'd say give it some pressing exercise.  Sounds like the slides are a bit sticky (keep the Pepsi away from the computer ;-)  Just work it over like a red headed... well keyboard to loosen up the gunk.  If all else fails soak the whole keyboard in alcohol (not scotch please that would be alcohol abuse) for an hour or so and let it dry out (overnight.)  That should loosen up the finger goo and get you back to typing.  I'd make sure all the Alcohol has evaporated before putting it back together unless you are into some high energy excitement.

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: [TI-99/4A] Annoying keypress repetitioooonnnn
To: [email-masked]
Date: Wednesday, January 26, 2011, 5:27 PM

  

        

 

 

      Anyone?

---

From: Gregory McGill <[email-masked]>
Date: Wed, 26 Jan 2011 16:01:29 -0800

My local electronics store sells contact cleaner with teflon .. works great
in that situation

Greg

---

From: ti99_forever <[email-masked]>
Date: Wed, 26 Jan 2011 22:02:00 -0800 (PST)

Has anyone tried the "wash in a dishwasher" solution with a TI keyboard?Just wondering... I've got a couple non-working ones around somewhere, if I stumble across them I might just try it.

---

From: "Tony Knerr" <[email-masked]>
Date: Thu, 27 Jan 2011 11:09:57 -0000

Yes, if the problem is dirt and not mechanical, it works.
I've found that keyboards need at least 4 days to dry out
when doing this. Use just a liitle dishwashing soap (granular)
so that it gets rinsed clean.

Tony

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 27 Jan 2011 09:49:31 -0800 (PST)

I've heard of the "motherboard in the dishwasher" thing only last year and still can't believe people do that. Anyway, I disassembled my TI using these instructions:
http://www.mainbyte.com/ti99/console/console_dis.html

First I removed all the keys from the keyboard and sprayed the holes with dust blowing air spray. Then I sprayed the whole thing with rubbing alcohol. One thing that was bugging me about this TI was that the aluminium trim wasn't sitting flat on it, so I decided I was going to take a look under the bonnet. So I disassembled it and guess what? Whoever took it apart before bent the tabs on the trim. So I pried the tabs back into place and the TI looks great! I don't think I'll be putting it in the dishwasher, it looks good enough and it actually still works! I thought for sure I'd have broken something when I put it back together. But it's working fine and the key press issue appears to have been solved. Thanks all for the suggestions!

Christian

--- On Thu, 1/27/11, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: [TI994A] Re: [TI-99/4A] Annoying keypress repetitioooonnnn
To: [email-masked]
Date: Thursday, January 27, 2011, 6:09 AM

  

Tony

--- In [email-masked], ti99_forever <ti99_forever@...> wrote: