Subject: 2010 Faire report

From: "hjalmarii" <[email-masked]>
Date: Tue, 09 Nov 2010 02:14:26 -0000

The 28th Chicago TI International World Faire has proven to be one of the most interesting and exciting events that I have had the privilege to be a part of.  I am certain that the TI community is alive and well, indeed thriving at the moment.  The amount and variety of innovative software and hardware that was presented this year augurs well for our future.
We got underway this year, as in past years, with a little Friday night gettogether at the local American Legion post for those who arrived in Evanston early.  We had a chance to meet those whom we have only known on the Internet heretofore.  It was great to get acquainted in an informal setting, while having pizza and beer.
The main event, of course, takes place on Saturday, but the preparation has been ongoing for some time.  Berry Harmsen  arrived a few days early in order to help with some of the last minute details, and my son John came in from graduate school to assist as well.  One of those details was the purchase of a "hotspot" to provide what I hoped would be reliable, non-interruptible WiFi, not subject to the outages we often experience at the Evanston Public Library.  More about that later.  We also checked all the TI equipment, and then tried out the connection between Berry's laptop and the TI RS232.  Everything was working perfectly in the dress rehearsal, but maybe that was a bad omen in disguise.  
At any rate, when we met for breakfast at Burger King, we were certain that we had covered all the bases, crossed all the t's and dotted all the i's we could think of.  We make plans, and God laughs…
The Faire opened a few minutes later than advertised, as some of the attendees were a little late in arriving and settling in, but we were glad that so many new faces were here.  After my opening remarks welcoming everyone, we got underway with a rendition of Owen Brand's song, "See You At The Faire."  Berry opened the seminars with the traditional report from Europe.  He described the latest TI meeting in Birkenau, Germany, in April, where 28 TI'ers gathered.  Berry noted that Michael Zapf presented the most recent improvements to MESS, and Fred Kaal showed off some of his recent software.  Berry next brought us up to date about the TI Treff, hosted this year by the TI User Group of the United Kingdom, and held in Nottingham in England.  More than two dozen TI'ers assembled  to see the latest developments.  Stephen Monk, from Texas Instruments UK came to display the most recent chips from TI, and then showed the BeagleBoard, a device developed by TI using their own Omap cpu chip, which impressed all the attendees.  Mark Robert Wills reported on the progress of his latest efforts, Turbo Forth.  Incidentally, Mark was to attend the Faire this year, but visa delays for his wife forced him to cancel his plans.  Gary Smith then unveiled the brand-new upgrade to the Geneve,  nick-named the "Phoenix G2."  He had been working with a small group of TI'ers for several years, in secret, to avoid raising expectations.  It utilizes FPGA chips to perform like the Geneve. Gary displayed  a mockup that was used for the development.  Berry showed us some pictures of the memory maps for the Phoenix, and the board layout.  Fred Kaal was the last presenter at the Treff, and again had new software and hardware to announce to the group.  Berry told us that the next Treff will be organized by Ermano Bertori, and is presently planned to take place in Rome, Italy.
After a short break, Bill Gaskill took the floor to talk about a variety of subjects.  Bill brought a number of items to this year's Faire, including CF7+ devices made by Jaime Malilong, and 64K multicarts designed by Jon Guidry, and containing a collection of utility programs.  Bill also had disks of his various articles and programs.  He demonstrated many of the programs, including the Office Suite originally compiled by Dr. Eric Bray.  Bill thanked all of the many authors by name, but the list is too long to reproduce here.  He showed that the CF7+s were preloaded with 39 disks worth of programs.  All of this represented a huge amount of work on Bill's behalf, and the fact that all of his items were quickly snapped up by attendees showed how much his efforts were appreciated.  Bill gave us some background on the Altman Fairware List, of which he is now the caretaker.  In his capacity as the unofficial historian of the TI community, Bill preserves all the information he researches so that it will not be lost to the "shuffle of time," as he put it.  He discussed the CD he was offering, which contained the articles he had written for "Four A Talk," essentially a 523 page book, and mentioned that it was all designed to be readily searchable by keyword, author, topic, etc.
Again we took a short break to allow for equipment setup, and Berry Harmsen returned  to demonstate the new software and hardware to allow a PC to become a storage device for the TI.  Fred Kaal had written the programs, and modified an RS232 card.  Berry was able to transfer files back and forth, and also to run programs directly from the PC.  Fred's system of hardware and software, known as the "HDX System" can be viewed on his website,  http://www.members.ziggo.nl/fgkaal/  .  Berry announced that he was showing just one of the five elements of Fred's system, which is still partly under development.  The five parts include plans for a new interface for the CF7a+, the nanoPEB, a standard RS232, a home-built RS232, and the modified RS232 that Berry showed.  Berry noted that it is possible to transfer TI-disks using this system to and from the PC.  
Mike Dudek, from Tex*In Treasures http://.texintreasures.com/shop  spoke next and mentioned that he had brought a lot of things for the TI, and invited us all to visit his table and his website.  Mike very kindly also donated a pile of TI goods to be given out as door prizes.  Mike is one of the very few TI dealers left, and is highly thought of in the TI community.
Bill Gaskill was the first speaker after a short break for lunch, and began by returning their money to those who had purchased his Timeline CD. He then held a raffle of disks and CDs, assisted by Vic Steerup, who ran a lottery program on his TI system.  Bill discussed the history of the Faire for awhile.  He outlined a project that he has underway, in which he is taking the Chicago User Group library and producing an illustrated catalogue, complete with screen shots of each program, and an expanded  description of the contents and working of each of the almost 1700 separate items on the almost 200 disks.  He even suggested that we could expand the library with new programs.  Whew!  He admitted that he wouldn't be finished by next week, but he thought he could bring it to the next Faire!  He thanked a number of those he said had helped him in his endeavors, including Walid  Maalouli, Fred Kaal, and Ernie Pergrem.  Amongst the programs Bill then demo'ed  was Bank Book, a program he modified to allow printing of the calculations.  He then showed a cardfile program originally written by Lucie Dorais, to which he had added a front end. Bill also discussed the TI Hall of Fame, and urged everyone to visit the site,  http://ti99hof.org/  where many of those who have contributed to the TI community are honored.
Marc Hull was our next speaker, and he showed a brand-new prototype card for the PEB he had designed and built, known as the SID Blaster 99.  It is a Sound Interface Device (SID) card which uses a Commodore 64 chip to access the more than 8,000 music files available.  Marc was assisted by Tim Tesch, and provided us with several songs.  Marc 
Acknowledged help from several sources, including Jim Fetzner.  Marc showed us the Protoboard that he used to develop the concept, and the finished product.  His software converts the SID files to DF128 files.  Marc said the software is still a work in progress.
Mike Brent, known to many as Tursi was the next presenter, and much of what he showed was beyond my comprehension, so I am going to quote remarks posted by Jon Guidry on the OLUG, " Jim Fetzner and Mike are still working on the cartridge board design. Jim
re-did my hacked 128K design into a permanent board design - a 128K version (or
4x128K, if you install two switches). That design then morphed into a form of
what Mike showed at the Faire - a 4x128K ROM board *with* GROM via a ATmega
chip. It's currently still evolving... the next iteration might just well be a
fully bank switchable 512K ROM (yes, the whole thing - because of replacing the
74LS379 with a GAL) + multiple GROM banks. And, more flexible too. The whole
Linux daughterboard in that 4x128K ROM + ATmega board that Mike did was really
impressive as well."  That says it better than I can.  Mike showed us how the Review Module Library was implemented, which was impressive, but when he showed off the Linux in the TI, those who understand Linux, like Mark Zeman, were jumping out of their seats.  As usual, Mike was very understated in his presentation, but there were ripples of excitement around the room.  More development is in the works, Mike promised.
The last person to address us was Walid Maalouli, who told me just a few weeks ago he would not have anything to show at this Faire.  Instead, he showed up with a fascinating program called "Chaos Musings."  It consisted of three parts, the Logistic Equation, the Hénon Equations, and the Lyapunov Space.  He produced a handsome instruction booklet and disk, which he passed out to the attendees.  He advised that the programs ran much faster on an emulator than on a stock TI.  For instance, the Lyapunov Space program takes 36 days on a real TI.  The purpose of all three programs was to show the capabilities of the TI when modeling chaos.  Don't understand that?  Run the program and sit back and watch the results.  The patterns created by the programs are fascinating to see, and the implications are of the theories are very interesting.  Those who understand fractals may be particularly interested in these programs.
At the end of the Faire, we broke down the equipment, and repaired  down the street to a local restaurant, where we had reserved the back room so we could eat and present  the John Birdwell and Rob Tempelmans Plat  awards.  After we had finished our meals, I had the privilege of presenting the Birdwell Award to Jon Guidry.  It is chosen annually by the John Birdwell Trustees, and represents the oldest, and most prestigious honor in the TI world.  After Jon's brief acceptance speech, I turned the evening over to Berry Harmsen, who promptly chose nine volunteers to judge the six finalist TI sites.  After six ten-minute sessions to view and evaluate each site, the jury chose  "TI-99 Forever" 
www.ti99.com/zoneti.htm by Fabrice Montupet as the winner for 2010.  The contest was very close because all of the sites were well done. 
When dinner was done, a hardy few set off to visit some of the local watering holes.  At first I thought this year's pub crawl was going to fall flat because people seemed to wander off in all directions, but somehow we all managed to reunite and march on to the nightspots of the evening.  All told, we visited nine bistros and tried many different brews.  Some of us, whose names shall remain unknown to protect their virtue, drank water and coke, but the rest of us chose adult beverages, and lots of them.  Almost every place we went, we were pestered by girls who wanted their pictures taken with us.  We finally gave in and obliged them, much as we hate it when that happens.  Jeff White and Mathew Robinson grudgingly accepted their fate as Babe Magnets this year.  The change from Daylight to Standard time gave us another hour to indulge our yearly Bacchanalian revels, and was greatly appreciated.  By the end of the evening, or the beginning of the morning, depending on your view of the world, we were in fine tune and not in any pain.  The latter came when we awoke, but let's not dwell on that.
This year we had some technical problems, but we tried our best.  Perhaps the best course of action is not to try to broadcast in real time, or not broadcast at all.  It would certainly simplify my life, but we'll see.
Now is  time to thank some of those who made the Faire possible.  Our treasurer, Irv Levinson, and our membership chairman, Al Anotonowitz, manned their table all day long, and Irv brought lots of delicious doughnuts. Vic Steerup ran the raffle for Bill Gaskill.  Berry Harmsen came to town five days early, helped in numerous ways, and is even now sitting by my elbow, making sure I finish this before I can have a beer.  So any typos you find in the foregoing are not the result of barley pop, just fatigue.  And lastly, I want to thank my son John for all the technical help, and my wife Almut, for putting up with all the craziness I bring into her life.
Plans are already afoot for next year's Faire, so save the weekend of November 5, 2011, and make your plans to come to Evanston! 
--Hal Shanafield, Faire Chairman

---

From: Owen Brand <[email-masked]>
Date: Mon, 8 Nov 2010 21:31:47 -0500

Thanks for the overview Hal!!!  Very nice to read.  :) 

I gotta write a new song.... I'm sure you guys are tired of the old one.  :). I'm glad to hear it was a good Faire... I won't miss again.  

Owen Brand

www.firebrandmusic.net
www.opry99er.com

---

From: "Beery" <[email-masked]>
Date: Tue, 09 Nov 2010 15:00:51 -0000

Hal,

Thanks for the writeup.

Did the Phoenix G2 run?  Can anyone provide any further details on it's status?

Beery

--- In [email-masked], "hjalmarii" <hals12@...> wrote:
  Gary Smith then unveiled the brand-new upgrade to the Geneve,  nick-named the "Phoenix G2."  He had been working with a small group of TI'ers for several years, in secret, to avoid raising expectations.  It utilizes FPGA chips to perform like the Geneve. Gary displayed  a mockup that was used for the development.  Berry showed us some pictures of the memory maps for the Phoenix, and the board layout.

---

From: "hjalmarii" <[email-masked]>
Date: Wed, 10 Nov 2010 04:43:53 -0000

Beery, Berry Harmsen did not have the actual G2, only a report of having met Gary Smith, and seeing the mock-up at the Treff in Nottingham.  He says it is a reality, not just vaporware.  --Hal

--- In [email-masked], "Beery" <bmiller@...> wrote:
> --- In [email-masked], "hjalmarii" <hals12@> wrote:
> >

---

From: Owen Brand <[email-masked]>
Date: Wed, 10 Nov 2010 00:02:53 -0500

Great news Hal. Thanks for letting us know... I am very interested in the development of this project... I always wanted a Geneve, but didn't want to spend money on a no-longer-supported piece of hardware that has a tendency to be a bit fickle.  (I know some of you will disagree with the "fickle" part). :)

The G2 could be an amazing addition to our family.  :)

Owen Brand

www.firebrandmusic.net
www.opry99er.com

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 9 Nov 2010 23:37:20 -0600

Ahem.  I would disagree with the 'no longer supported' comment as well ;)

To: [email-masked]
From: [email-masked]
Date: Wed, 10 Nov 2010 00:02:53 -0500
Subject: Re: [TI994A] Re: 2010 Faire report

Great news Hal. Thanks for letting us know... I am very interested in the development of this project... I always wanted a Geneve, but didn't want to spend money on a no-longer-supported piece of hardware that has a tendency to be a bit fickle.  (I know some of you will disagree with the "fickle" part). :)
The G2 could be an amazing addition to our family.  :)
Owen Brand
www.firebrandmusic.netwww.opry99er.com

 

--- In [email-masked], "Beery" <bmiller@...> wrote:

---

From: Tony Knerr <[email-masked]>
Date: Wed, 10 Nov 2010 04:58:01 -0500

I gotta go along with Tim on this one. :)

Tony

On 11/10/2010 12:37 AM, Insane Multitasker wrote:
> ------------------------------------------------------------------------
> Great news Hal. Thanks for letting us know... I am very interested in 
> the development of this project... I always wanted a Geneve, but 
> didn't want to spend money on a no-longer-supported piece of hardware 
> that has a tendency to be a bit fickle.  (I know some of you will 
> disagree with the "fickle" part). :)
>
> www.firebrandmusic.net <http://www.firebrandmusic.net>
> www.opry99er.com <http://www.opry99er.com>
>
>

---

From: Owen Brand <[email-masked]>
Date: Wed, 10 Nov 2010 09:01:39 -0500

Well, then I stand corrected.  :) Tony and Tim would know...
Thing is, there is no MYARC anymore.. And parts are becoming scarce.  With FPGA (on the G2), it's as simple as ripping another chip.  

I may have spoken out of ignorance.  :)

Owen Brand

www.firebrandmusic.net
www.opry99er.com

---

From: "Beery" <[email-masked]>
Date: Wed, 10 Nov 2010 14:30:51 -0000

OK, thanks for that info.

Beery

--- In [email-masked], "hjalmarii" <hals12@...> wrote:
> --- In [email-masked], "Beery" <bmiller@> wrote:
> >
> > Hal,
> > 
> > Thanks for the writeup.
> >

---

From: fdos <[email-masked]>
Date: Wed, 10 Nov 2010 09:12:23 -0700

As would I even though I stopped work on Forth+ 2.0 in favor of X4th99 
for the TI as their isn't much interest in new or updated software for 
the Geneve.  If the G2 becomes a reality and it fully supports MDOS then 
I would take Forth+ 2.0 development out of mothballs.

We shall see.

Bill S

On 11/9/2010 10:37 PM, Insane Multitasker wrote:
> On Nov 9, 2010, at 11:43 PM, "hjalmarii"<[email-masked]>  wrote:
>
>
>
>
>
>
>
>
>
>
>
>
>
> --- In [email-masked], "Beery"<bmiller@...>  wrote:
>
>>
>
>> Hal,
>
>>
>
>> Thanks for the writeup.
>
>>
>
>> --- In [email-masked], "hjalmarii"<hals12@>  wrote:
>
>>>
>

---

From: Insane Multitasker <[email-masked]>
Date: Wed, 10 Nov 2010 10:45:21 -0600

No harm, no foul, Owen.  Sometimes its easy to forget there is support for the beastie. 
 
These days I don't repair or upgrade as many boards as Richard yet we both have the means to do so. 
There is still software development and people still use the systems ;)   But you are right, they
are rare and like some of us list server people, can be cantankerous.   All part of the hobby.
 
As for Myarc I'll let Richard speak about that.  Parts are indeed rare though again between Richard
and I, we probably have sufficient gate arrays and specialty parts to keep the board humming long
after we are gone.   How's that for a rosy outlook?  ;)-

To: [email-masked]
From: [email-masked]
Date: Wed, 10 Nov 2010 09:01:39 -0500
Subject: Re: [TI994A] Re: 2010 Faire report

Owen Brand

www.firebrandmusic.net
www.opry99er.com

  

Tony

Owen Brand 

www.firebrandmusic.net
www.opry99er.com