Subject: 32K Card & EA

From: "epergrem" <[email-masked]>
Date: Mon, 21 Feb 2011 16:00:22 -0000

A question for you techies.  I have a 32K card that doesn't report the 24488 bytes of program memory.   I would have assumed that with the bad card in the expansion system, EA would complain of no memory expansion when I tried to load it, but nary a peep.  It will even allow me to load a program, but then the screen goes green.

I'm just curious what EA really checks to determine if there is memory expansion present.  It also leads me to wonder what might be wrong with the card.

Thanks,
Ernie

---

From: fdos <[email-masked]>
Date: Mon, 21 Feb 2011 09:12:33 -0700

Ernie,

I've never had a 32K card go bad and cause this problem, but I have had 
a flaky Flex Cable Interface card do it with my SAMS card, but work with 
several 32K cards, and be iffy with a few other 32K cards and a 
Foundation 128K card.  Some new buffer chips took care of the problem.

BTW can you do a CALL INIT from TI BASIC?

Bill S

---

From: "Stuart" <[email-masked]>
Date: Mon, 21 Feb 2011 16:14:13 -0000

According to Thierry's website:

"It then checks whether a memory expansion is installed (by writing test values at >2000 and reading them back) and issues an error message if this is not the case."

Stuart.

---

From: "epergrem" <[email-masked]>
Date: Mon, 21 Feb 2011 16:38:40 -0000

Thanks Bill,
I've tried two different Flex Cable Interface cards and ran some drive tests using DMII, so I'm thinking they might be okay, but I do have a third, which I haven't tried yet. :-)  

I also tried a known good 32K card and it reported the correct memory.

Ernie

---

From: "epergrem" <[email-masked]>
Date: Mon, 21 Feb 2011 16:41:46 -0000

Ah, so EA isn't complaining because it found something at >2000. 

However if the EA program won't load correctly then the problem may reside in >A000 or higher.  

I guess that it's time to did out that 32K MEMTEST program I have somewhere. :-)

Ernie