Subject: new store/items

From: Gregory McGill <[email-masked]>
Date: Thu, 21 Jul 2011 08:18:41 -0700

I've upgraded my store on cafepress to have all of the items in one place:

http://www.cafepress.com/TIandGeneveStuff

Working on some new ideas but for now, the old stuff plus some new items

Greg

---

From: Gregory McGill <[email-masked]>
Date: Sat, 27 Aug 2011 21:59:52 -0700

Greg