Subject: Re: [TI994A] Re: TurboForth Benchmarks

From: [email-masked]
Date: Sun, 6 Feb 2011 13:33:16 -0500 (EST)

All,
 
Using Mark's TurboForth and the code:
 
: TEST 20000 FOR NEXT ;
 
The elapsed time between typing in TEST <enter> and the re-appearance  of 
the cursor (end of execution) is between 3 and 4 seconds. (Sorry, Mark, I  
couldn't resist sharing this one!)
 
Bob Carmany  

In a message dated 2/6/2011 1:21:54 P.M. Eastern Standard Time,  
[email-masked] writes:

Could  you list the program, and I'll give FIG Forth on the 990 a go  ...

Stuart.

---

From: mark wills <[email-masked]>
Date: Sun, 6 Feb 2011 18:39:31 +0000 (GMT)

:-)

<blush>

Mark

>
>From: "[email-masked]" <[email-masked]>
>To: [email-masked]
>Sent: Sun, 6 February, 2011 18:33:16
>Subject: Re: [TI994A] Re: TurboForth Benchmarks
>
>  
>
>All,
> 
>The elapsed time between typing in TEST <enter> and the re-appearance  of the 
>cursor (end of execution) is between 3 and 4 seconds. (Sorry, Mark, I  couldn't 
>resist sharing this one!)
> 
>Bob Carmany 
>

---

From: "Stuart" <[email-masked]>
Date: Sun, 06 Feb 2011 19:22:39 -0000

So how have you got TurboForth so fast Mark? Is it purely down to coding efficiency, or do you have other tricks up your sleeve?

--- In [email-masked], mark wills <markrobertwills@...> wrote:
>
> :-)
> 
> <blush>
> 
> Mark
> 
> 
> >
> >From: "rmcarmany@..." <rmcarmany@...>
> >ti99@... writes:

---

From: Owen <[email-masked]>
Date: Sun, 6 Feb 2011 21:25:09 -0500

That's flippin' fast......

Sent from my iPhone

On Feb 6, 2011, at 1:33 PM, [email-masked] wrote:

> The elapsed time between typing in TEST <enter> and the re-appearance of the cursor (end of execution) is between 3 and 4 seconds. (Sorry, Mark, I couldn't resist sharing this one!)
>  
> Bob Carmany
>  
> In a message dated 2/6/2011 1:21:54 P.M. Eastern Standard Time, [email-masked] writes: