Subject: Just in time: IDE DSR V10 of 10/10/2010

From: "fredkaal" <[email-masked]>
Date: Wed, 29 Dec 2010 11:58:07 -0000

Hi all,

Aftrer reading an article about finishing stuff before moving on I would like to inform you that IDE DSR V10 of 10/10/2010 is available before I start to finish all the open bottles of liquer and left overs.

V09 contained some additional functionality for using CPU ram instead of VDP ram (never released) and our insane multitasker Tim Tesch found some problems in the IDE DSR according to some file types and record lengths. This is now hopefully fixed in V10.

IDE DSR V10 can be found here:

http://members.ziggo.nl/fgkaal/Software/sw_idedsr.html#idedsr

and this is all the work done:

V09	14/03/2010
Added:	All load, save, read, write functions can use CPU ram
	as described at page 57 of the Myarc Hard and Floppy Disk
	Controller manual:
		
	The IDE card now also supports 2 extensions to the standard
	PAB. The first extension is to support I/O to CPU RAM rather
	than VDP RAM. In other words, the data buffer points to a
	CPU RAM location rather than a VDP RAM location. In order to
	perform CPU I/O, merely set bit 1 (where bit 0 is the MSB bit
	and bit 7 the least LSB) of the OPCODE byte. Everything else
	will remain the same. The second extension to the PAB is to 
	support total CPU RAM use of the PAB and DATA BUFFER. The IDE
	DSR will assume that the PAB is in CPU ram when the MSB of
	>8354 is a "1". You will need an updated DSRLNK function for
	use of this feature.
		
Fixed:	Pointer to File Descriptor Index Record (FDIR) of a File
	Descriptor Record (FDR) now defined instead of leaving >0000. 

v10	10/10/2010
Fixed:  ide-p11h-write.inc::L3WFL$::L3WFV2
	Check on record length of variable file was one to short (JHE
	instead of JH), therefore a record length of 1 was illegal.

Fixed:  ide-p11h-write.inc::L3WFL$::L3WFF2
	Check on writing of last record that fits in sector of a
	fixed file was one to short (JL instead of JLE), therefore 
	that last fraction of a sector was skipped.

Fixed:	ide-p11h-read.inc::L3RFL$::L3RFF3
	Check on reading of last record that fits in sector of a
	fixed file was one to short (JL instead of JLE), therefore
	that last fraction of a sector was skipped.

Fixed:  ide-p11h-write.inc::L3WFL$::L3WFF2
	Added extra test for checking if number of sectors was
	changed since the last write so that the FDR is also marked
	as changed.

Fixed:	ide-p11h-rewind.inc::L3RWF$
	Rewind function always caused an IO error because for RELATIVE
	file R3 was not cleared indicating not EOF and R4 was not
	cleared indicating no errors before return through PGEXIT.

Fixed:  ide-p03h-open.inc::ADDFTP
	Number of records per sector of a D/F file is 256/record
	length. Number of records per sector of a D/V file is
	(256-1)/(record length+1) because of the record length byte
	and a sector must end with a >FF byte.

Fixed:	ide-p11h-misc.inc::GNXTSC::GNXTS6
	When writing to a file and the file needs more AU the DSR
	tries to expand the last chain. This only worked every second
	time because of a pointer in the data chain pointer blocks of
	a FDR was one place to far.

Fixed:	ide-p00h-basic.inc::IDEST$
	IDE version number is above >09 so >0A through >FF must be
	converted to BCD first before printing.

What does this all mean:
If your IDE storage device only contains files wich are copied to this device you are save.

If you have created file yourself on a IDE storage device with a basic program or editor (or whatever) than it is possible that that file become unreadable if it is fragmented.

but anyway ... enjoy.
Fred ;-)

---

From: fdos <[email-masked]>
Date: Wed, 29 Dec 2010 08:49:15 -0700

Fred,

"Just in time"?  My only fully functional systems, at this time, are my 
CF7A+ and NanoPEB (one or the other as they both use the same TI console 
and flat screen monitor, etc.).  Obviously not suitable for an IDE card. 
  All other real systems have monitor problems that I can't throw money 
at due to having drained my reserves on Christmas for family members 
(mostly).

I am, however, very close to having a marvelous Christmas present for 
myself (better late than never) due to all your hobby support work.

So a BIG thanks anyway!

Bill S

On 12/29/2010 4:58 AM, fredkaal wrote:
> 	Descriptor Record (FDR) now defined instead of leaving>0000.
>
> v10	10/10/2010
> 	and a sector must end with a>FF byte.
>
> 	IDE version number is above>09 so>0A through>FF must be

---

From: fdos <[email-masked]>
Date: Wed, 29 Dec 2010 11:02:21 -0700

Hey Fred,

My Christmas present from you is not quite working yet; NanoPEB with 
serial connection to TI99HDX running on a Win2K PC.  The "Null Modem" PC 
serial cable I'm using works with just your PRINT program running on the 
PC.  Meaning I was able to print the complete CF card catalog to my 
network printer.

Of course, I had to stop the PRINT program so that the TI99HDX program 
could get the serial port.  I did all the setups and I do get the 
"Ti99Hdx started ..." message, but I never get the "Ti99Hdx initialized" 
message after numerous resets and power cycling I do of the TI console 
and NanoPEB.  I'm guessing this means that my serial cable is OK for the 
printer connection, but not adequate for the TI99HDX connection.

What do you think?

Bill S

---

From: "fredkaal" <[email-masked]>
Date: Sun, 02 Jan 2011 11:37:43 -0000

Bill,

You will only get the "...initialized" message (hopefully) after starting the CfHdxS1 program ( found here http://members.ziggo.nl/fgkaal/Hardware/hw_ti99hdx_nanopeb.html ) with the nanoPEB installed because the HDX DSR is embedded in the CfHdxS1 program.

Fred ;-)

---

From: fdos <[email-masked]>
Date: Mon, 03 Jan 2011 00:07:48 -0700

Fred,

I am using the CFhdxS1 (1.2) program on the NanoPEB and the TI99hdx.exe 
(6.1a) on the Win2K PC.  I specified SRC: HDX1.  However, I only get 
error 6: Opendir [Device error]

Any other thoughts?  I'm leaving for Las Vegas in the morning to spend 
the day with my older daughter and two granddaughters.  So I won't be 
able to proceed until Tuesday.

Bill S

On 1/2/2011 4:37 AM, fredkaal wrote:
> --- In [email-masked], fdos<fdosbrs@...>  wrote:
>>
>> Hey Fred,
>>

---

From: "fredkaal" <[email-masked]>
Date: Mon, 03 Jan 2011 18:35:35 -0000

Bill,

Have you set the TI99HDX options:

Menu: Options->Communication configuration
(.) Use serial port COMx
Comport: COM?
Baudrate: 38400
Click OK

Menu: Options->Select TI99 files directory
Now select a directory on your harddrive where you save
only, and I do mean ONLY, store V9T9 files.
Click OK

Menu: Options->Select TI99 disks directory
Now select a directory on your harddrive where you save
only, and again I do mean ONLY, store TI-DISK images.
Click OK
(can't use this option with nanoPEB, but better save than sorry).

The moment CfHDXS1 is started and is still in the first help page the message (000) Ti99Hdx #10: <TI99/4a Initialized> should appear.

When CfHdxS1 is running, check menu: Options->Communication status
Output (.) DTR and (.) RTS must be on (Ti99Hdx.exe does this).
When reading a directory (.) CTS is on (it is possible that this is hard to see).

Does your titlescreen also says NANOPEB-SIO V1?

Do you use the correct cable? See Ti99Hdx help or

http://members.ziggo.nl/fgkaal/Pics/ti99hdx/ti99_rs232_splitter_cables.gif

for the correct cross cable.

I also get error 6: opendir [Device error] when I disconnect my cable because CfHdxS1 is missing the DTR/RTS signal!

Hope this helps!

Fred ;-)

--- In [email-masked], fdos <fdosbrs@...> wrote:
> > --- In [email-masked], fdos<fdosbrs@>  wrote:
> >>
> >> Hey Fred,
> >>

---

From: fdos <[email-masked]>
Date: Tue, 04 Jan 2011 09:48:11 -0700

Fred,

See below:

> Menu: Options->Communication configuration
Yes

> only, and I do mean ONLY, store V9T9 files.
Uh, I'll have to clean out some text files or make a new directory, and 
copy only the V9T9 files over.

> only, and again I do mean ONLY, store TI-DISK images.
Yes.  Created new when I began

> The moment CfHDXS1 is started and is still in the first help page the message (000) Ti99Hdx #10:<TI99/4a Initialized>  should appear.
Doesn't ever happen.
> When reading a directory (.) CTS is on (it is possible that this is hard to see).
CTS is on all the time also.  This is why I thought the null cable I'm 
using is the cause as I did read the documentation, and knew that it 
should not be on all the time.
> Does your titlescreen also says NANOPEB-SIO V1?
Yes.
> for the correct cross cable.
The null cable I'm using is suspect, and I intend to replace it in the 
next couple of days.  I will buy one first, and if it fails I will have 
to build it according to your specifications along with a similar 
parllel cable for my CF7A+ device.
> I also get error 6: opendir [Device error] when I disconnect my cable because CfHdxS1 is missing the DTR/RTS signal!
Understood.
> Fred ;-)

Thanks for your time and assistance.

Bill S

---

From: "fredkaal" <[email-masked]>
Date: Tue, 04 Jan 2011 18:18:12 -0000

Hi Bill,

I also think you have a cable problem.

FYI:
CfHdxS1 (or better the HDX DSR) checks (one of) the DTR / RTS signals on powerup. If the signal is not there it means that there is no connection with the PC or Ti99Hdx is not started yet or COM port is closed and the DSR does not even try to send the init message and waits (for a too long time) for an answer. 

Every time a new message is send from the TI to the PC this signal is checked again. The HDX DSR also contains a timeout and retry meganism. All this is done to make sure that the HDX DSR will never hang while waiting for things that will never come.

TI RS232 version checks DSR signal (is connected with PC's DTR signal)

nanoPEB checks CTS signal (is connected with PC's RTS signal) because nanoPEB hasn't got the DSR signal connected to the 9PIN SUBD connector.

Fred ;-)

---

From: "fredkaal" <[email-masked]>
Date: Tue, 04 Jan 2011 18:20:25 -0000

> Uh, I'll have to clean out some text files or make a new directory, 

This is not a disaster but you will only see strange (unknown) file types when reading the directory!

Frd;-)

---

From: fdos <[email-masked]>
Date: Tue, 04 Jan 2011 15:03:35 -0700

Looks like I will be shopping for new null modem cable tomorrow as I 
have to do some other shopping anyway.

Bill S

---

From: fdos <[email-masked]>
Date: Wed, 12 Jan 2011 14:58:35 -0700

Well the new null-modem serial cable behaves the same way as the other, 
and it too is a D9 - D25 cable, so I still have to use a D9 to D25 
adapter (the same one in this case).  Just connecting the adapter to the 
PC side doesn't cause the CTS to be on, but just connecting either 
null-modem cable does (other end not connected to NanoPEB).

Connecting just the D9 connector of either null-modem cable without the 
D-25 side being connected to the adapter or the NanoPEB causes the CTS 
to be on along with DTR and RTS, so neither null-modem cable will work 
with the TI99HDX program.  I will have to look for the parts out in my 
garage to make the cable as Radio Shack no longer carries the preferred 
parts.  Otherwise I will have to order the parts on-line.

Bill S