Subject: Assembly Programming

From: "violajamison" <[email-masked]>
Date: Tue, 17 May 2011 14:35:02 -0000

I'm about to venture into assembly.  I have a question - 

Do assembly programmers actually program (from scratch) in assembly or do they first write a program in basic/xbasic and convert it to assembly?

Is it the same metod of programming (top/down) in assembly?

Could I get some input from assembly programmers also if there's any recommendations you can make regarding learing assembly programming?

Thank you,

---

From: Marc Hull <[email-masked]>
Date: Tue, 17 May 2011 09:19:54 -0700 (PDT)

I find it easier to start from scratch.  One of the issues I had was trying to get away from the comfort level of XB and how it insulates a programmer from many tasks.  Perhaps a clean break will work for you as well.

As far as how you program... that depends on your style.  You basically have assembly equivalents of gotos, and gosubs.  You might want to get into the early habit of breaking your program up into different source files.  May not seem like much now but down the road you will appreciate it.

As far as learning 9900 assembly right now ?  Kind of like learning Latin ;-).  You will have to learn three major subjects.  Obviously 9900 syntax but also the lay out of the TI99 as well as how to use the assembler.

You should get a copy of the E/A reference manual for starters and learn how to use the editor and assembler especially the assembler directives.  It is a great reference but a poor teacher at best.  I found the Compute book most helpful but there are several.  The best resource is really the Y! groups and the Atari Age Forum (just be ready to sift through differing opinions ;-).  My suggest is baby steps at first using examples and the console utilities.  Progress from there.

Good luck and keep us posted.

--- On Tue, 5/17/11, violajamison <[email-masked]> wrote:

From: violajamison <[email-masked]>
Subject: [TI994A] Assembly Programming
To: [email-masked]
Date: Tuesday, May 17, 2011, 9:35 AM

  

Thank you,

---

From: "Tursi" <[email-masked]>
Date: Tue, 17 May 2011 13:23:33 -0700

I've actually done both, but more frequently I code the assembly from 
scratch. Otherwise you are writing the program twice, since conversion is 
not direct.

The Compute Book to Assembly Language is my favourite for learning on the 
TI, I'm on the road so someone will have to help with a link, but if it 
doesn't come up before I get home I will find it for you, there is a PDF 
version floating around.

-----Original Message----- 
From: violajamison
Sent: Tuesday, May 17, 2011 7:35 AM
To: [email-masked]
Subject: [TI994A] Assembly Programming

Do assembly programmers actually program (from scratch) in assembly or do 
they first write a program in basic/xbasic and convert it to assembly?

Could I get some input from assembly programmers also if there's any 
recommendations you can make regarding learing assembly programming?

Thank you,

------------------------------------

Yahoo! Groups Links

---

From: mark wills <[email-masked]>
Date: Tue, 17 May 2011 22:38:24 +0100 (BST)

It's on planet-99.net - use the search facility and search for compute

Mark

>________________________________
>From: Tursi <[email-masked]>
>Sent: Tuesday, 17 May 2011, 21:23
>Subject: Re: [TI994A] Assembly Programming
>

---

From: Jeffrey White <[email-masked]>
Date: Tue, 17 May 2011 19:12:57 -0700 (PDT)

Is BASIC the only computer programming language you haved used?

You can do top/down or bottom/up programming in assembly (or BASIC, for that 
matter).  For assembly, I would suggest bottom/up.

I would also suggest using BASIC or Extended BASIC to test your assembly 
routines.

Bruce Harrison's assembly language series in MICROpendium is a good place to 
start learning.

Jeff White  

Sent: Tue, May 17, 2011 10:35:02 AM

Do assembly programmers actually program (from scratch) in assembly or do they 
first write a program in basic/xbasic and convert it to assembly?

Thank you,

---

From: "killroy732000" <[email-masked]>
Date: Wed, 18 May 2011 06:21:29 -0000

You can find the Compute Book (PDF) and plenty of other books/information in the below thread:

http://www.atariage.com/forums/topic/153704-ti-994a-development-resources/page__view__findpost__p__1881598

retroclouds