Subject: CS1 loading

From: Owen Brand <[email-masked]>
Date: Fri, 12 Nov 2010 12:18:42 -0500

This is a question posed over on Atariage... I don't know the answer and don't have the tech manuals to answer it.  Perhaps you guys can help!!  My buddy John asked:

[quote]
"Here's a question for the TI tech people on here.  

When you load a cassette into the TI, does it start loading the program at a default address and then just continues storing it in sequential memory locations until it is fully loaded?"

[/quote]

Owen Brand

www.firebrandmusic.net
www.opry99er.com

---

From: fdos <[email-masked]>
Date: Sat, 13 Nov 2010 09:59:35 -0700

Owen,

I'm surprised no one has responded to this, yet.

Anyway, not necessarily.  If it's a TI BASIC or XB program for an 
unexpanded TI console, then yes, as it loads into VDP memory.  After 
that most any where the programmer planned AL code to be in an expanded 
system with CPU memory of 32K or more.  TI BASIC would require the E/A 
or Mini Memory module.  XB can, of course, load XB programs into high 
memory and AL code into low memory expansion.  There are XB tricks to 
load AL code in high memory.  I just don't know if it can be done from 
cassette tape as that's not something I did decades ago or at any time.

Bill S

---

From: Owen Brand <[email-masked]>
Date: Sat, 13 Nov 2010 12:07:38 -0500

Thanks alot Bill!  Does anyone know the standard starting address for the console BASIC code when loaded from cassette?  Does it start at the first available VDP location and build forward?

Perhaps TI Intern has this information... Anyone know off the top of their head?

Owen Brand

www.firebrandmusic.net
www.opry99er.com

---

From: fdos <[email-masked]>
Date: Sat, 13 Nov 2010 12:46:15 -0700

Owen,

It depends on how many disk buffers are set for disk files as it starts 
at the high end of VDP just under the disk buffers.  You can set the 
buffers with CALL FILES(x) with 3 being the default.  You can not do a 
CALL FILES(0), however.

Bill S

On 11/13/2010 10:07 AM, Owen Brand wrote:
> On Nov 13, 2010, at 11:59 AM, fdos<[email-masked]>  wrote:
>
>> Owen,
>>

---

From: "Tursi" <[email-masked]>
Date: Sat, 13 Nov 2010 14:09:38 -0800

>Thanks alot Bill!  Does anyone know the standard starting address for the 
>console BASIC code when loaded from cassette?  Does it >tart at the first 
>available VDP location and build forward?
>erhaps TI Intern has this information... Anyone know off the top of their 
>head?

Personally, I looked at this code a couple of weeks ago to see what tricks 
might be possible, but I couldn't make sense of it. (I wanted to know if 
more tricks like Morphy used were possible). Theirry's page covers some of 
the cassette file format, but it doesn't seem to include addresses.

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Sat, 13 Nov 2010 23:52:49 +0100

Yes, TI Intern has it.
Look at GROM address >4641.This section is named 'Basic Load'.

Paolo Bagnaresi

----- Original Message ----- 
From: "Owen Brand" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, November 13, 2010 6:07 PM
Subject: Re: [TI994A] CS1 loading

Thanks alot Bill!  Does anyone know the standard starting address for the 
console BASIC code when loaded from cassette?  Does it start at the first 
available VDP location and build forward?

Perhaps TI Intern has this information... Anyone know off the top of their 
head?

Owen Brand

www.firebrandmusic.net
www.opry99er.com

On Nov 13, 2010, at 11:59 AM, fdos <[email-masked]> wrote:

> > This is a question posed over on Atariage... I don't know the answer 
> > and don't have the tech manuals to answer it. Perhaps you guys can 
> > help!! My buddy John asked:
> >
> > [quote]
> > When you load a cassette into the TI, does it start loading the 
> > program at a default address and then just continues storing it in 
> > sequential memory locations until it is fully loaded?"
> >
> > [/quote]
> >
> >
> >
> >
> >
> > Owen Brand
> >
> > www.firebrandmusic.net
> > www.opry99er.com
> >
> >
> >
>