Subject: fyi tip for new versions of MESS

From: Gregory McGill <[email-masked]>
Date: Fri, 25 Mar 2011 20:58:50 -0700

after downloading and compiling the latest SVN of MESS I found a "feature"

I use a mess.ini file to set my directory paths etc.. in the stock
MESS.INI there's a line that selects the "Partial" keyboard emulation,
allowing you to select things like new disks or carts or even exit
emulation etc..

In the latest version you have to remove some of the string

under

#
# SDL KEYBOARD MAPPING
#

uimodekey                 ITEM_ID_SCRLOCK

now becomes

uimodekey                 SCRLOCK

Without this.. you can't hit scroll-lock to get in the partial
emulation mode to be able to select menus etc.. As you can see they
removed "ITEM_ID" from the selection string, which it's been for
basically forever.

Thanks to Michael for pointing this out to me.

Greg

---

From: "Michael Zapf" <[email-masked]>
Date: Sat, 26 Mar 2011 10:59:58 -0000

Hi Greg,

I just updated that information in ninerpedia:

http://www.ninerpedia.org/index.php/Change_MESS_menu_mode_key

(I'm not sure whether the change was already done for 0.141 or whether it will appear for 0.142.)

Michael

---

From: "Tony Knerr" <[email-masked]>
Date: Sat, 26 Mar 2011 16:16:40 -0000

Looking at the MESS revision history on ninerpedia, I see that the HSGPL emulation was fixed in version 0.139. It has not worked for me
in quite some time, though. I have the hsgpl.mem file in the \memcard
directory and the HSGPL extension flag set to flash. When I load the 
DSRLDR3 file in E/A and attempt to load the DSR, I get a "FlashID not recognized" error. Has anyone actually gotten this to work correctly?
Michael? 

Tony

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 27 Mar 2011 15:01:58 -0000

Hello Tony,

> Looking at the MESS revision history on ninerpedia, I see that the 
> HSGPL emulation was fixed in version 0.139. It has not worked for me
> DSRLDR3 file in E/A and attempt to load the DSR, I get a "FlashID not 
> recognized" error. Has anyone actually gotten this to work correctly?
> Michael? 

Last time I had a look at it, the HSGPL worked correctly, so either it is a regression, or you did something unexpected. I will need to redo the flash process by myself to check that.

Please allow me to have a look at that on next weekend ... I need to prepare some stuff for work right now, quite urgently.

Michael

---

From: Tony Knerr <[email-masked]>
Date: Sun, 27 Mar 2011 11:51:33 -0400

Thanks, Michael.

I have some further information that may help. I just tried an older
version of the HSGPL DSR loader, DSRLDRE2. It's the version
that originally came with my card, in fact it's transferred to MESS
from my original floppy. This version reports the error "FEEPROM
not recognized". Hope this information helps.

Tony

On 3/27/2011 11:01 AM, Michael Zapf wrote:
> Last time I had a look at it, the HSGPL worked correctly, so either it 
> is a regression, or you did something unexpected. I will need to redo 
> the flash process by myself to check that.
>
> Please allow me to have a look at that on next weekend ... I need to 
> prepare some stuff for work right now, quite urgently.
>
> Michael
>
> __

---

From: "Tony Knerr" <[email-masked]>
Date: Sun, 27 Mar 2011 20:58:47 -0000

I managed to get this working on my own. Apparently the instructions 
are not up to date. Instead of the file "hsgpl.mem" being the one that
the emulation works from, it's really "hsgpl.nv". I constructed the
file from scratch with my DSR and GROM files per the definitions on
ninerpedia. If anyone is having trouble with the HSGPL emulation, I 
can email you the "hsgpl.nv" file I've constructed to get you started.
It looks like it'd be tough to get the HSGPL emulation working 
by any other method.

Tony

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 27 Mar 2011 22:31:39 -0000

Hi Tony,
 
> It looks like it'd be tough to get the HSGPL emulation working 

ah yes, right: All memory content of NVRAM or NOVRAM is stored in .nv files. I made use of a core function of MAME/MESS here. MiniMemory, GRAMKracker, SuperSpace and many more devices also store their contents in .nv files.

Somewhere I have some step-by-step instructions how to set up an HSGPL from scratch. Will copy them to ninerpedia as soon as possible.

Michael

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 31 Mar 2011 23:09:38 -0000

Hi Tony,

version 0.141 definitely shows a regression for the HSGPL. I can flash a DSR on the HSGPL with 0.140, but the very same process does not work for 0.141.

Sigh ... that's a bug from me. As I said earlier, I applied some heavy restructurings, and I also tested the HSGPL, but I did not try to recreate it from empty state, and just this one is broken now.

Michael

---

From: "Tony Knerr" <[email-masked]>
Date: Thu, 31 Mar 2011 23:59:52 -0000

Hi Michael.

That explains why my process worked then. If you have a working DSR
emulation, you can reflash it, but it can't be created from scratch.
The file I created with a hex editor worked correctly, and I was 
able to reload the DSR on it in the emulation, but not on the empty
(all zeros) file. So it's only broken a little bit. :)

Tony

---

From: "Dan" <[email-masked]>
Date: Fri, 1 Apr 2011 22:20:52 -0400

You atariage members may have already seen this

The Xbox kinect thing has the "spy" technology in it. As youre standing 
there playing games, it isn't just looking at you, it is looking for things 
in your room. If it sees a Coke label on a can in the room it will register 
that the person at this account drinks Coke and possibly send you coupons. 
If it sees a baby carriage, it will recognize it and register that this 
account has a baby and you will start getting diaper offers etc. This is not 
a conspiracy story, look it up, its on real tech websites.

Microsoft also "reserves the right at all times to disclose any information 
as necessary to satisfy any applicable law, regulation, legal process or 
governmental request, or to edit, refuse to post or to remove any 
information or materials, in whole or in part, in Microsoft's sole 
discretion." Break the law in front of your Kinect system? You could be up 
against the law.

http://www.atariage.com/forums/topic/171885-xbox-kinect-is-spying-on-you/

Heres another...

http://bigdah.gamerkage.com/new-xbox-live-terms-of-service-is-microsoft-using-kinect-to-spy-on-you.html

---

From: Marc Hull <[email-masked]>
Date: Fri, 1 Apr 2011 20:21:49 -0700 (PDT)

Reeeeeeeeeeeeealy ???

--- On Fri, 4/1/11, Dan <[email-masked]> wrote:

From: Dan <[email-masked]>
Subject: [TI994A] OT: xbox and privacy not an April fools joke
To: [email-masked]
Cc: [email-masked]
Date: Friday, April 1, 2011, 9:20 PM

  

against the law.

Heres another...

---

From: Gregory McGill <[email-masked]>
Date: Fri, 1 Apr 2011 21:08:53 -0700

Yep and they will market the copies of your home activities back to you at a
later time.. Since they have a internet enabled color camera of your room
available to them 24/7 if they want it.

Greg

On Fri, Apr 1, 2011 at 8:21 PM, Marc Hull <[email-masked]> wrote:

>
>
> Reeeeeeeeeeeeealy ???
>
> --- On *Fri, 4/1/11, Dan <[email-masked]>* wrote:
>
>

---

From: "Tursi" <[email-masked]>
Date: Sat, 2 Apr 2011 00:09:11 -0700

And with the 3D sensing capability, they can finally replay whatever crime 
you committed in your room in full 3D, just like in CSI!!

It's awesome!

-----Original Message----- 
From: Gregory McGill
Sent: Friday, April 01, 2011 9:08 PM
To: [email-masked]
Subject: Re: [TI994A] OT: xbox and privacy not an April fools joke

Greg

On Fri, Apr 1, 2011 at 8:21 PM, Marc Hull 
<href="mailto:[email-masked]">[email-masked]> wrote:
Reeeeeeeeeeeeealy ???