Subject: TurboForth Benchmarks

From: mark wills <[email-masked]>
Date: Sun, 6 Feb 2011 18:18:43 +0000 (GMT)

----Forwarded Message----
From: [email-masked]
To: [email-masked]
Sent: Sun, 06 Feb 2011 18:11 GMT
Subject: Benchmarks

Bob and I have been doing some benchmarks.

A popular benchmark is finding prime numbers, so we thought it might be fun to benchmark finding, and displaying primes up to 1000, since a routine for this is already published in the wycove forth book.

The test yielded the following results:

TI forth: 10 seconds
Wycove: 8 seconds
Turboforth: 2 seconds

The primes test is a good example because it tests:
* looping efficiency 
* math computation 
* stack juggling 
* displaying numbers (successive division)

So it's looking like turboforth is approximately 4 times faster than wycove, and 5 times faster than TI forth! 

Wowsers!

Bob also tested copying blocks between different drives, to copy 40 blocks between floppy drives: 1 minute 20 seconds. (the disk drives being the bottleneck)

To copy between RAM disks: 12 seconds... not bad!

Mark

On Thu, 03 Feb 2011 18:02 GMT [email-masked] wrote:

>I'll make an announcement when they have been debugged and are ready for  
>distribution.
> 
>Bob  Carmany
>
>
>In a message dated 2/3/2011 12:57:49 P.M. Eastern Standard Time,  
>[email-masked] writes:
>
>
>
>
>Bob:
>I would like to buy one of the TurboForth Carts for the TI when you  are 
>ready.
>How much, and where do I send the payment?
> 
> 
> 
>Rod Van Orden
>San Diego CA
>
>
>
>
>
>

---

From: "Stuart" <[email-masked]>
Date: Sun, 06 Feb 2011 18:21:43 -0000

Could you list the program, and I'll give FIG Forth on the 990 a go ...

Stuart.

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> From: markrobertwills@...
> On Thu, 03 Feb 2011 18:02 GMT rmcarmany@... wrote:
> 
> >rod.vanorden@... writes:

---

From: mark wills <[email-masked]>
Date: Sun, 6 Feb 2011 18:41:11 +0000 (GMT)

Aint no thang!

: PRIMES ( n - )
  2 SWAP 2 . 3 . 5 
  DO DUP DUP * I < 
  IF 1+ THEN 
  1 OVER 1+ 3 
  DO J I MOD 0= 
  IF 1- LEAVE THEN 
  2 +LOOP 
  IF I . THEN 
  2 +LOOP 
  DROP ;

Test it with:

1000 PRIMES

Rock on brotha!

Mark

----- Original Message ----
> From: Stuart <[email-masked]>
> To: [email-masked]
> Sent: Sun, 6 February, 2011 18:21:43
> Subject: [TI994A] Re: TurboForth Benchmarks
> 
> > A popular benchmark  is finding prime numbers, so we thought it might be fun 
>to benchmark finding,  and displaying primes up to 1000, since a routine for 
>this is already published  in the wycove forth book.
> > 
> > Bob also tested copying blocks between different drives, to copy 40  blocks 
>between floppy drives: 1 minute 20 seconds. (the disk drives being the  
>bottleneck)
> > 
> ------------------------------------
> 
> Yahoo!  Groups Links
> 
> 
> 
>

---

From: mark wills <[email-masked]>
Date: Sun, 6 Feb 2011 18:55:12 +0000 (GMT)

Thought I would wack it up on YouTube:

http://www.youtube.com/watch?v=V5VGuNTrDL8

It *could* go a smidge faster than that, but I don't think it would make that 
much difference...

:-)

Mark

---

From: "Stuart" <[email-masked]>
Date: Sun, 06 Feb 2011 19:16:48 -0000

Mark, how can I rewrite the 7th line to avoid the "1-" which isn't in my version of FIG Forth?

Stuart.

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> > From: Stuart <ti99@...>
> > --- In [email-masked], mark wills  <markrobertwills@> wrote:
> > >
> > > 
> > > 
> > > From: markrobertwills@
> > > On Thu, 03 Feb 2011 18:02 GMT  rmcarmany@ wrote:
> > > 
> > >  >rod.vanorden@ writes:

---

From: mark wills <[email-masked]>
Date: Sun, 6 Feb 2011 19:23:41 +0000 (GMT)

Just substitute 1- with 1 -

That's a 1 a space and a minus sign. That should do it.

Mark

----- Original Message ----
> Sent: Sun, 6 February, 2011 19:16:48
> > > > So  it's looking like turboforth is approximately 4 times faster than  
>wycove, 
>
> > >and 5 times faster than TI forth! 
> > >
> > > > 
> > > > Wowsers!
> > > >

---

From: "Stuart" <[email-masked]>
Date: Sun, 06 Feb 2011 19:31:02 -0000

On my system takes around 6-7 seconds. Obviously delayed by the speed of printing the numbers over the RS-232 serial interface ... ;-)  ;-)

Stuart.

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> > > > From: Stuart  <ti99@>

---

From: fdos <[email-masked]>
Date: Mon, 07 Feb 2011 09:04:17 -0700

Mark,

When I find some time I will try thin in Forth+ on the Geneve--turbo 
mode on & off.

Bill S

On 2/6/2011 11:41 AM, mark wills wrote:
>    DO DUP DUP * I<
>> From: Stuart<[email-masked]>
>> --- In [email-masked], mark wills<markrobertwills@...>  wrote:
>>>
>>>
>>>