Subject: Re: [TI994A] Long BASIC format

From: [email-masked]
Date: Mon, 18 Apr 2011 21:22:22 +0000 (UTC)

Hello Michael 

I have patch in the next RXB 2011 version that loads Program image files or I/V 254, but RXB version 2011 will only save in I/V 254 format and never save in 
Program Image format. Like everyone else I get sick of attempting to sort by Basic, XB, EA all using Program image formats. Not to mention some other 
apps out there that also use this format. The only bug I have with this is the I/V 254 always is 1 sector larger then the Program Image format. Timing the 
loading of the files shows no real speed difference other then the Program Image files have to be loaded into VDP then moved to RAM so they take a 
little longer to start. 
I am including the Source of the SAVE and OLD and MERGE as a attachment to this message. 

Rich 

----- Original Message ----- 
From: "Michael Zapf" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 5:41:08 AM 
Subject: [TI994A] Long BASIC format 

Hi there, 

does anybody know something about the file format INT/VAR 254 used for long Extended Basic programs? 

Seems to me as if the first record always contains a 10 byte header, probably containing memory pointers. I'm not sure about the second header; whether it starts with the Exbasic program or also has a header. 

It's difficult to find out by experiment since Exbasic automatically uses the format when programs become too long to fit into the VDP space. 

Michael

---

From: ti99_forever <[email-masked]>
Date: Mon, 18 Apr 2011 16:47:25 -0700 (PDT)

Wouldn't this "bug" be because you can only save 254 bytes per sector using IV254, whereas Program Image format gives you the entire 256 bytes per sector? So, all the extra "2" bytes per sector overflow into a new sector?

--- On Mon, 4/18/11, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] Long BASIC format [1 Attachment]
To: [email-masked]
Date: Monday, April 18, 2011, 5:22 PM

#yiv1734166143 p {margin:0;} 

[Attachment(s) from [email-masked] included below]

Hello Michael

Rich

----- Original Message -----
From: "Michael Zapf" <[email-masked]>
To: [email-masked]
Sent: Monday, April 18, 2011 5:41:08 AM
Subject: [TI994A] Long BASIC format

 

      
      Hi there,

Michael

    

       Attachment(s) from [email-masked]  
    
           1 of 1 File(s) 

     IV254.txt