Subject: Changing file names in XB...

From: "Marc H" <[email-masked]>
Date: Mon, 17 Jan 2011 22:28:41 -0000

Is it possible to change a files name in XB or is that magic reserved for assembly ?  

To clarify I would like to write an XB program that can change the entries in the directory (name only.)  Is there hope or am I pissing in the wind ?

Marc

---

From: Gregory McGill <[email-masked]>
Date: Mon, 17 Jan 2011 14:52:33 -0800

There are assembly routines for XB that can rename files..  and your pissing
in the wind as usual :)

On Mon, Jan 17, 2011 at 2:28 PM, Marc H <[email-masked]> wrote:

> To clarify I would like to write an XB program that can change the entries
> in the directory (name only.) Is there hope or am I pissing in the wind ?
>
> Marc
>
>  
>

---

From: Marc Hull <[email-masked]>
Date: Mon, 17 Jan 2011 15:23:22 -0800 (PST)

Kind of figured as much......  What routine are these and where can they be found pray tell ?

--- On Mon, 1/17/11, Gregory McGill <[email-masked]> wrote:

From: Gregory McGill <[email-masked]>
Subject: Re: [TI994A] Changing file names in XB...
To: [email-masked]
Date: Monday, January 17, 2011, 4:52 PM

  

      There are assembly routines for XB that can rename files..  and your pissing in the wind as usual :)

 

    

Marc

---

From: Gregory McGill <[email-masked]>
Date: Mon, 17 Jan 2011 15:34:23 -0800

The name has rolled off the top of the stack.  I am sure I have it somewhere
at home on disk. If I find it :) I'll let you know. Others may have better
memory.  There were a few packages that did disk related routines one was a
read write sector thing if I remember.

Greg

On Mon, Jan 17, 2011 at 3:23 PM, Marc Hull <[email-masked]> wrote:

> --- On *Mon, 1/17/11, Gregory McGill <[email-masked]>* wrote:
>
>
> On Mon, Jan 17, 2011 at 2:28 PM, Marc H <[email-masked]<http://mc/compose?to=[email-masked]>
> > wrote:
>
>
>

---

From: ti99_forever <[email-masked]>
Date: Mon, 17 Jan 2011 16:21:28 -0800 (PST)

There are many packages. I recently found a set, but can't remember the name - it is on one of the BCS disks.
The file rename routine is actually part of the disk controller DSR, and I never could figure out why they didn't add a CALL for it in XB, like FILES...
Read/Write are sector read/write utilities. If you use these to rename the names in the FDR, then you have to sort the pointers in sector 1...

From: Gregory McGill <[email-masked]>
Subject: Re: [TI994A] Changing file names in XB...
To: [email-masked]
Date: Monday, January 17, 2011, 6:34 PM

 

The name has rolled off the top of the stack.  I am sure I have it somewhere at home on disk. If I find it :) I'll let you know. Others may have better memory.  There were a few packages that did disk related routines one was a read write sector thing if I remember.

Greg

 

    

 

 

    

Marc

---

From: "Tony Knerr" <[email-masked]>
Date: Tue, 18 Jan 2011 01:54:28 -0000

> Read/Write are sector read/write utilities. If you use these to rename the names in the FDR, then you have to sort the pointers in sector 1...

If you use XB v2.5, you can CALL XXB.

Then CALL LINK("READ",A,B,A$,B$) and CALL LINK("WRITE",A,B,A$,B$)
are available. A is the drive number, B is the sector number, A$
is the first 128 bytes of the sector, and B$ is the 2nd 128 bytes of 
the sector.
 
Alternately, find Barry Traver's XXB package in the Lima Disks 
collection. It's used with his permission in XB v2.5.

If you rename a file, you'll have to alphabetize the pointers to the
FDRs in sector 1 like Ben said.

Tony

---

From: ti99_forever <[email-masked]>
Date: Mon, 17 Jan 2011 20:31:31 -0800 (PST)

The package I found had a "RENAME" procedure in it, so you don't have to mess with the links in sector 1. I will look for it tonight, just saw it less than a week ago.

Quality 99 had a software package that loads up during boot that did quite a few things, one being renaming, IIRC. That was one package I actually bought and used it alot until I got SuperXB which had the catalog routine built-in (which was the main thing I wanted).

--- On Mon, 1/17/11, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: [TI994A] Re: Changing file names in XB...
To: [email-masked]
Date: Monday, January 17, 2011, 8:54 PM

 

Tony

------------------------------------

Yahoo! Groups Links

---

From: ti99_forever <[email-masked]>
Date: Mon, 17 Jan 2011 22:10:01 -0800 (PST)

DM99 from Mike Dodd, BCS Disk 048...excerpt from the docs... I imagine this to be a rather huge file, seeing as it can also be used as a disk manager... object file is 83 sectors. It does, however, include the source code.

        The format for each of the commands follows. The lower case letter     "d" will indicate the drive number. Items in brackets are optional.     CALL LINK("UNPROT",d,"filename") - will unprotect "filename"     CALL LINK("PROT",d,"filename") - will protect "filename"     CALL LINK("FRENAM",d,"old  filename","new  filename")  -  renames  "old          filename" as "new filename"     CALL LINK("DRENAM",d,"new diskname") - will rename a disk     CALL  LINK("TEST",d[,"printer name"]) - will test the disk. Will output          to screen, or printer if specified     CALL LINK("CAT",d[,"printer name"])  -  will  catalog  the  disk.  Will          output  to screen, or printer if specified. Press any key to pause          and resume.     CALL LINK("INIT",d,"disk name",#sides,density,"verify?"[,tracks]). Will          initialize  disk.  Can  specify  number  of sides, and the
 density          (1=single, 2=double). If "verify?" = "V" then it will  verify  the          sectors. If number of tracks is not specified, then it will assume          40 tracks.

---

From: ti99_forever <[email-masked]>
Date: Mon, 17 Jan 2011 22:17:20 -0800 (PST)

If anyone wants this file, just click here or copy and paste:http://dl.dropbox.com/u/10438491/BCS%20Disk%20048%20%281988-1989%29%28BCS%29%28PD%29.dsk

--- On Tue, 1/18/11, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Re: Changing file names in XB...
To: [email-masked]
Date: Tuesday, January 18, 2011, 1:10 AM

 

        The format for each of the commands follows. The lower case letter     "d" will indicate the drive number. Items in brackets are optional.     CALL LINK("UNPROT",d,"filename") - will unprotect "filename"     CALL LINK("PROT",d,"filename") - will protect "filename"     CALL LINK("FRENAM",d,"old  filename","new  filename")  -  renames  "old          filename" as "new filename"     CALL LINK("DRENAM",d,"new diskname") - will rename a disk     CALL  LINK("TEST",d[,"printer name"]) - will test the disk. Will output          to screen, or printer if specified     CALL LINK("CAT",d[,"printer name"])  -
  will  catalog  the  disk.  Will          output  to screen, or printer if specified. Press any key to pause          and resume.     CALL LINK("INIT",d,"disk name",#sides,density,"verify?"[,tracks]). Will          initialize  disk.  Can  specify  number  of sides, and the density          (1=single, 2=double). If "verify?" = "V" then it will  verify  the          sectors. If number of tracks is not specified, then it will assume          40 tracks.

---

From: Gregory McGill <[email-masked]>
Date: Mon, 17 Jan 2011 22:52:24 -0800

Thanks!
G

On Mon, Jan 17, 2011 at 10:10 PM, ti99_forever <[email-masked]>wrote:

>
>
> DM99 from Mike Dodd, BCS Disk 048...
> excerpt from the docs... I imagine this to be a rather huge file, seeing as
> it can also be used as a disk manager... object file is 83 sectors. It does,
> however, include the source code.
>
>         The format for each of the commands follows. The lower case letter
>      "d" will indicate the drive number. Items in brackets are optional.
>      CALL LINK("UNPROT",d,"filename") - will unprotect "filename"
>      CALL LINK("PROT",d,"filename") - will protect "filename"
>      CALL LINK("FRENAM",d,"old  filename","new  filename")  -  renames
>  "old
>           filename" as "new filename"
>      CALL LINK("DRENAM",d,"new diskname") - will rename a disk
>      CALL  LINK("TEST",d[,"printer name"]) - will test the disk. Will
> output
>           to screen, or printer if specified
>      CALL LINK("CAT",d[,"printer name"])  -  will  catalog  the  disk.
>  Will
>           output  to screen, or printer if specified. Press any key to
> pause
>           and resume.
>      CALL LINK("INIT",d,"disk name",#sides,density,"verify?"[,tracks]).
> Will
>           initialize  disk.  Can  specify  number  of sides, and the
> density
>           (1=single, 2=double). If "verify?" = "V" then it will  verify
>  the
>           sectors. If number of tracks is not specified, then it will
> assume
>           40 tracks.
>
>  
>