Subject: Options for formating MESS hard drive

From: "wmlucid" <[email-masked]>
Date: Mon, 09 May 2011 19:30:14 -0000

What are the formatting options?

What do I need to do to use a newly made hard drive container file; I believe it needs to be formated.  TI99Dir has the image type as DOS.

Wm

---

From: "Michael Zapf" <[email-masked]>
Date: Mon, 09 May 2011 20:12:35 -0000

Hi Wm,

> What do I need to do to use a newly made hard drive container file; I believe it needs to be formated.  TI99Dir has the image type as DOS.

Use Myarc Disk Manager V. There are disk images somewhere. I'll give you a stepwise description (just doing it live):

Example for a 20 MiB empty disk:

$ chdman -createblankhd newblank.hd 615 4 32 256
$ mess64 ti99_4ae -cart1 editor_assembler.rpk -flop1 mdm150.dsk -hard1 newblank.hd

Option 5, load DSK1.MDM5. Exit date/time setting.

Select Utility->Format->Hard
Enter 1 as hard drive number

Type in a label for the hard disk behind WDS1., like MYHARD

Use the geometry data from createblankhd - this is important,  other values will make formatting fail! Use your values for other sizes. You can get the values with chdman -info.

Sectors = 32
Heads = 4
Cylinders = 615
Reserved sectors = 2048
Write precomp = 464
Reduced write current = 464
Retry = 8
Interlace = 3
Step = 1
Enter the magic code "FORMAT" to initiate formatting.

Watch formatting cylinder 0...1...2...3...  614

Exit

Sometimes I experience display issues with MDM; the screen does not update with new content. Try BACK (FCTN-9) in that case. Blindly, type C(atalog), H(arddisk), 1 (drive number). You should get an empty disk display.

Exit
Quit, Y

** DONE **

Test it with other files.

Michael

---

From: "wmlucid" <[email-masked]>
Date: Mon, 09 May 2011 20:33:19 -0000

Thank you Michael for taking time to described the process.  Hope it helps other MESS new users too...

Wm

---

From: "Michael Zapf" <[email-masked]>
Date: Tue, 10 May 2011 09:36:21 -0000

Hi Wm,
 
> helps other MESS new users too...

I added this to our ninerpedia. There are lots of things still missing which I have just not thought about yet, so your questions are certainly welcome.

Michael

---

From: "Beery" <[email-masked]>
Date: Wed, 11 May 2011 16:20:27 -0000

For Bill's info, be careful if you pull any mess hard drive images from whtech.  I'm not sure anyone has replaced the old (5+ year images) with the slightly revised format that MESS now requires.

I have formatted images (120 MB's) with a bunch of Geneve stuff on it if someone hollers and wants the image.  Not anything on the image for the average TI user though.

Beery