Subject: IDE TESTIFR Results

From: [email-masked]
Date: Sun, 19 Sep 2010 13:37:49 -0500 (CDT)

Tim, this test was an IDE running the BQ4852 chip, I'll test one with the BQ4847 chip later and report.

Sequential
1 REC#0
2
3
4
SKIP REC 0
1 REC#1
2
3
4
5
6
SKIP 0-7
8 REC#8
9
10
SKIP A REC
1 REC#1
3 REC#3
5 REC#5
7 REC#7
9 REC#9

>
> The following file generates a ~16 sector file and then reads it 
>back a few different ways.
>
>If you have an IDE card, I would also be interested in the results of this test. 
>I have sent
>Fred some preliminary results but with only one card in my posession, it would 
>be nice
>to have someone confirm results. 
>
>The program will print the expected record number and what it reads from the 
>file. The
>output is of interest, especially if the two values do not match. 
>
>-Tim
>
>1 !SAVE DSK4.TESTIFR
>100 OPEN #1:"IDE1.TESTFILE",INTERNAL,FIXED 254,RELATIVE
>1000 FOR I=0 TO 15 :: PRINT #1,REC I:"REC#"&STR$(I) 
>:: NEXT I
>1100 CALL RR("SEQUENTIAL",0,4,1)
>1103 CALL RR("SKIP REC 0",1,6,1)
>1104 CALL RR("SKIP 0-7",8,10,1)
>1105 CALL RR("SKIP A REC",1,9,2)
>1110 CLOSE #1 :: END
>1200 SUB RR(B$,A,B,C)::PRINT B$::FOR I=A TO B STEP C::INPUT 
>#1,REC I:A$
>1210 PRINT I;A$ :: NEXT I::SUBEND

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 20 Sep 2010 11:51:49 -0500

Thank you, Richard, this and your subsequent test results have been helpful. Information
has been passed along to Fred and no further testing needed at this time.  :)

Tim

> To: [email-masked]
> From: [email-masked]
> Date: Sun, 19 Sep 2010 13:37:49 -0500
> Subject: [TI994A] IDE TESTIFR Results
> 
>