Subject: Re: [TI994A] Long BASIC format

From: [email-masked]
Date: Tue, 19 Apr 2011 04:07:00 +0000 (UTC)

I kind of do not see the point. As smaller programs load faster anyway, (they are smaller) what advantage is gained? 
With all the XB programs as I/V 254 you gain a standard to use. Presently there is no standard at all. 
Small programs image files 12 sectors or less are BASIC programs. 
I/V 254 files are only XB. 
Program image files larger then 12 sectors are EA5. 
Now you have a standard to write software that can take advantage of this standard. 

----- Original Message ----- 
From: "Insane Multitasker" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 6:44:32 PM 
Subject: RE: [TI994A] Long BASIC format 

Actually, IV254 files will load more slowly when used with slower devices such as floppy disks. I recommend you add the option to save as a program image, perhaps similar to the ",MERGE" option, for those who would find little value in turning programs into IV254 files. 

I have always made it a point to keep most programs under the IV254 threshold for the very reason that program image files load faster than record-based IO files. 

	--- On Mon, 4/18/11, [email-masked] <[email-masked]> wrote: 

From: [email-masked] <[email-masked]> 
Subject: Re: [TI994A] Long BASIC format [1 Attachment] 
To: [email-masked] 
Date: Monday, April 18, 2011, 5:22 PM 

[ Attachment(s) from [email-masked] included below] 

Hello Michael 

I have patch in the next RXB 2011 version that loads Program image files or I/V 254, but RXB version 2011 will only save in I/V 254 format and never save in 
Program Image format. Like everyone else I get sick of attempting to sort by Basic, XB, EA all using Program image formats. Not to mention some other 
apps out there that also use this format. The only bug I have with this is the I/V 254 always is 1 sector larger then the Program Image format. Timing the 
loading of the files shows no real speed difference other then the Program Image files have to be loaded into VDP then moved to RAM so they take a 
little longer to start. 
I am including the Source of the SAVE and OLD and MERGE as a attachment to this message. 

Rich

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 19 Apr 2011 00:28:33 -0500

Rich,
 
A small IV254 program will still load slower than a small Program Image of equivalent size.
 
Again, my recommendation was to provide the option for those who use RXB2011 to save their programs in the standard, "native" format that has been around since XB was introduced.  I strongly doubt anyone is going to return to their libraries to convert the hundreds if not thousands of XB programs already saved as Program Image files. That would be quite an undertaking in itself.  
 
While I applaud your innovation, I am on the other side of the fence -- I don't see the point in forcing the IV254 file format this late in the game. 

To: [email-masked]
From: [email-masked]
Date: Tue, 19 Apr 2011 04:07:00 +0000
Subject: Re: [TI994A] Long BASIC format

----- Original Message -----
From: "Insane Multitasker" <[email-masked]>
To: [email-masked]
Sent: Monday, April 18, 2011 6:44:32 PM
Subject: RE: [TI994A] Long BASIC format

 

[Attachment(s) from [email-masked] included below] 

Hello Michael

Rich

---

From: ti99_forever <[email-masked]>
Date: Mon, 18 Apr 2011 22:47:22 -0700 (PDT)

So, will RXB2011 allow the loading of program image files? I'd hate to convert everything too.But if it loads them, I don't care what format they come out in when I save them.
Even on my old Teac drives, there wasn't much difference in load time for me. ISTM that it cut out the slow move from VDP to the 32k expansion at the end of the load, as each record is put into the 32k as it is read...

--- On Tue, 4/19/11, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Long BASIC format
To: [email-masked]
Date: Tuesday, April 19, 2011, 1:28 AM

 

Rich,

 

#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxygrp-photo-title
{clear:both;font-size:smaller;height:15px;overflow:hidden;text-align:center;width:75px;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxygrp-photo
{background-position:center;background-repeat:no-repeat;background-color:white;border:1px solid black;height:62px;width:62px;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxphoto-title 
         a, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxphoto-title a:active, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxphoto-title a:hover, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxphoto-title a:visited
{text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxattach-table div.yiv1774584678ecxattach-row
{clear:both;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxattach-table div.yiv1774584678ecxattach-row div
{float:left;}
#yiv1774584678 .yiv1774584678ExternalClass p
{clear:both;padding:15px 0 3px 0;overflow:hidden;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxygrp-file
{width:30px;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxattach-table div.yiv1774584678ecxattach-row div div a
{text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxattach-table div.yiv1774584678ecxattach-row div div span
{font-weight:normal;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxygrp-file-title
{font-weight:bold;}

#yiv1774584678 .yiv1774584678ExternalClass p
{}

----- Original Message -----
From: "Insane Multitasker" <[email-masked]>
To: [email-masked]
Sent: Monday, April 18, 2011 6:44:32 PM
Subject: RE: [TI994A] Long BASIC format

 

Hello Michael

Rich

#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mkp
{border:1px solid #d8d8d8;font-family:Arial;padding:0 10px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mkp hr
{border:1px solid #d8d8d8;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mkp #yiv1774584678ecxhd
{color:#628c2a;font-size:85%;font-weight:700;line-height:122%;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mkp #yiv1774584678ecxads
{margin-bottom:10px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mkp .yiv1774584678ecxad
{padding:0 0;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mkp .yiv1774584678ecxad p
{}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mkp .yiv1774584678ecxad a
{color:#0000ff;text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-sponsor #yiv1774584678ecxygrp-lc
{font-family:Arial;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-sponsor #yiv1774584678ecxygrp-lc #yiv1774584678ecxhd
{font-weight:700;font-size:78%;line-height:122%;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-sponsor #yiv1774584678ecxygrp-lc .yiv1774584678ecxad
{margin-bottom:10px;padding:0 0;}
#yiv1774584678 .yiv1774584678ExternalClass a
{color:#1e66ae;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxactions
{font-family:Verdana;font-size:11px;padding:10px 0;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxactivity
{background-color:#e0ecee;float:left;font-family:Verdana;font-size:10px;padding:10px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxactivity span
{font-weight:700;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxactivity span a
{color:#5085b6;text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxactivity span span
{color:#ff7900;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxactivity span .yiv1774584678ecxunderline
{text-decoration:underline;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxattach
{clear:both;display:table;font-family:Arial;font-size:12px;padding:10px 0;width:400px;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxattach div a
{text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxattach img
{border:none;padding-right:5px;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxattach label
{display:block;margin-bottom:5px;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxattach label a
{text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass blockquote
{}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxbold
{font-family:Arial;font-size:13px;font-weight:700;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxbold a
{text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass dd.yiv1774584678ecxlast p a
{font-family:Verdana;font-weight:700;}
#yiv1774584678 .yiv1774584678ExternalClass dd.yiv1774584678ecxlast p span
{margin-right:10px;font-family:Verdana;font-weight:700;}
#yiv1774584678 .yiv1774584678ExternalClass dd.yiv1774584678ecxlast p span.yiv1774584678ecxyshortcuts
{margin-right:0;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxattach-table div div a
{text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxattach-table
{width:400px;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxfile-title a, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxfile-title a:active, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxfile-title a:hover, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxfile-title a:visited
{text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxphoto-title a, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxphoto-title a:active, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxphoto-title a:hover, #yiv1774584678 .yiv1774584678ExternalClass div.yiv1774584678ecxphoto-title a:visited
{text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass ecxdiv#yiv1774584678ygrp-mlmsg #yiv1774584678ecxygrp-msg p a span.yiv1774584678ecxyshortcuts
{font-family:Verdana;font-size:10px;font-weight:normal;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxgreen
{color:#628c2a;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxMsoNormal
{}
#yiv1774584678 .yiv1774584678ExternalClass ecxo
{font-size:0;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxphotos div
{float:left;width:72px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxphotos div div
{border:1px solid #666666;height:62px;overflow:hidden;width:62px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxphotos div label
{color:#666666;font-size:10px;overflow:hidden;text-align:center;white-space:nowrap;width:64px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxreco-category
{font-size:77%;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxreco-desc
{font-size:77%;}
#yiv1774584678 .yiv1774584678ExternalClass .yiv1774584678ecxreplbq
{}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mlmsg
{font-size:13px;font-family:Arial, helvetica, clean, sans-serif;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mlmsg table
{font-size:inherit;font:100%;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mlmsg select, #yiv1774584678 .yiv1774584678ExternalClass input, #yiv1774584678 .yiv1774584678ExternalClass textarea
{font:99% Arial, Helvetica, clean, sans-serif;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mlmsg pre, #yiv1774584678 .yiv1774584678ExternalClass code
{font:115% monospace;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mlmsg ecx*
{line-height:1.22em;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mlmsg #yiv1774584678ecxlogo
{padding-bottom:10px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-mlmsg a
{color:#1E66AE;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-msg p a
{font-family:Verdana;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-msg ecxp#yiv1774584678attach-count span
{color:#1E66AE;font-weight:700;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-reco #yiv1774584678ecxreco-head
{color:#ff7900;font-weight:700;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-reco
{margin-bottom:20px;padding:0px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-sponsor #yiv1774584678ecxov li a
{font-size:130%;text-decoration:none;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-sponsor #yiv1774584678ecxov li
{font-size:77%;list-style-type:square;padding:6px 0;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-sponsor #yiv1774584678ecxov ul
{padding:0 0 0 8px;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-text
{font-family:Georgia;}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-text p
{}
#yiv1774584678 .yiv1774584678ExternalClass #yiv1774584678ecxygrp-text tt
{font-size:120%;}

---

From: [email-masked]
Date: Tue, 19 Apr 2011 06:36:56 +0000 (UTC)

Yes exactly correct, both move the file from VDP to ERAM. IV 254 a record at a time and Program Image the whole thing has to be moved, but Program Image has to also redo the entire line number table and strings and symbol table also, something the IV 254 does not have to do. That is why I said it takes longer to do Program Image as 
it executes much more code to load the file then IV254 does as there is no house keeping to be done after the load with IV 254. 

And yes RXB 2011 loads either Program Image or IV 254, but only saves as IV 254. This will only bug the TI Basic users, but you still have TI BASIC right there in the TI. 

----- Original Message ----- 
From: "ti99_forever" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 10:47:22 PM 
Subject: RE: [TI994A] Long BASIC format 

So, will RXB2011 allow the loading of program image files? I'd hate to convert everything too. 
But if it loads them, I don't care what format they come out in when I save them. 

Rich, 

----- Original Message ----- 
From: "Insane Multitasker" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 6:44:32 PM 
Subject: RE: [TI994A] Long BASIC format 

Hello Michael 

Rich

---

From: [email-masked]
Date: Tue, 19 Apr 2011 06:30:30 +0000 (UTC)

Actually I wrote a simple RXB batch program that does that for you. On a hard drive it does it pretty quickly, just go do something while it works. 

By the way you can still load and save programs with TI Basic, it does not check the program unless you run it. 

So unless you do not have TI Basic you can still save them in that format. There is no disadvantage to this, so forcing it is not really a accurate description. 

RXB will load either but save in IV 254, so unless you are writing BASIC program in XB I do not see any type of issue for the user at all. No harm and no foul. 

----- Original Message ----- 
From: "Insane Multitasker" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 10:28:33 PM 
Subject: RE: [TI994A] Long BASIC format 

Rich, 

----- Original Message ----- 
From: "Insane Multitasker" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 6:44:32 PM 
Subject: RE: [TI994A] Long BASIC format 

Hello Michael 

Rich