Subject: IDE - MESS

From: "epergrem" <[email-masked]>
Date: Mon, 14 Mar 2011 18:47:11 -0000

Speaking of IDE, but 'virtually'.  What is required to get the IDE card working in MESS? 

I have a 248MB file named "ide.hd" and have specified Thierry's IDE controller in configuration, but get "Device IDE harddisk load () failed: unspecified error", when I attempt to open TI99-4A in MESS. 

Thanks,
Ernie

---

From: "Michael Zapf" <[email-masked]>
Date: Mon, 14 Mar 2011 23:41:26 -0000

Hi Ernie,

> I have a 248MB file named "ide.hd" and have specified Thierry's IDE 
> controller in configuration, but get "Device IDE harddisk load () 
> failed: unspecified error", when I attempt to open TI99-4A in MESS. 

don't - at least at the current state. Some time ago I had to detach the link between the IDE controller and the IDE device emulation because there were some issues (don't remember the details, just so far as the IDE emulation blindly assumes that there is exactly one drive that is called "harddisk"). 

I can put that on my todo list, but I cannot promise that I can start working on that within the next weeks. I hope this is not too urgent for you right now.

Michael

---

From: "epergrem" <[email-masked]>
Date: Tue, 15 Mar 2011 02:23:44 -0000

Thanks Michael,
Not urgent at all.  I was just playing around with MESS.   

Ernie