Subject: digi-play and rambo

From: Gregory McGill <[email-masked]>
Date: Wed, 16 Feb 2011 23:14:24 -0800

I just picked up a digi-port off competition computer's ebay auction.. and
was wondering if anybody did any more sw for it, and also if there was any
info on the "rambo" mods for memory cards such as my foundation 128k..  I
have the myarc xbII DSR in there now..

Doesnt seem to work in my geneve but I'm thinking that's the cc rs232 ..  it
works in the 4/a with a TI rs232

Greg

---

From: ti99_forever <[email-masked]>
Date: Wed, 16 Feb 2011 23:24:03 -0800 (PST)

I never remembered seeing any - too bad the software included wasn't the vaporware the documentation was about... it sounded pretty cool.
About the Corcomp RS232 - makes me wonder if the last time I played with mine, before throwing it in the 'parts' box, if I had a TI RS232 in at the time. My first was a Corcomp, I had a TI in for awhile, but got tired of the quirk of form-feeding (can't remember if it was at power-on or power-off or what). I have the Corcomp in there now...
It should be pretty easy to write something, but it gobbles memory. An AMS version would be nice. Or with these new monster bank-switching carts, maybe...

--- On Thu, 2/17/11, Gregory McGill <[email-masked]> wrote:

From: Gregory McGill <[email-masked]>
Subject: [TI994A] digi-play and rambo
To: [email-masked]
Date: Thursday, February 17, 2011, 2:14 AM

 

I just picked up a digi-port off competition computer's ebay auction.. and was wondering if anybody did any more sw for it, and also if there was any info on the "rambo" mods for memory cards such as my foundation 128k..  I have the myarc xbII DSR in there now..  

Doesnt seem to work in my geneve but I'm thinking that's the cc rs232 ..  it works in the 4/a with a TI rs232
Greg

---

From: "epergrem" <[email-masked]>
Date: Thu, 17 Feb 2011 12:22:15 -0000

Hi Greg,
Gary Bowser is the authority on this, but I thought RAMBO was strictly a Horizon RAM disk feature. It was automatically included on the HRD4000 and a daughter board was available for the HRD3000.  

I don't recall seeing upgrades for other RAM disks, but could be wrong.

Ernie

---

From: Gregory McGill <[email-masked]>
Date: Thu, 17 Feb 2011 08:43:48 -0800

Yeah there's some bla bla in the manual about a dsr for other cards.

Greg

On Thu, Feb 17, 2011 at 4:22 AM, epergrem <[email-masked]> wrote:

>
>
> Hi Greg,
> Gary Bowser is the authority on this, but I thought RAMBO was strictly a
> Horizon RAM disk feature. It was automatically included on the HRD4000 and a
> daughter board was available for the HRD3000.
>

---

From: Gregory McGill <[email-masked]>
Date: Sun, 20 Feb 2011 13:42:37 -0800

Ok well I tried converting a WAV from my pc to the Ti using TI-dir to
convert a binary pc file to d/f 128  then copied that to the 4a using
Fred's awesome HDX1 setup.  And it sounds like blended poop..  So I
converted the demo file gameover back to the PC using the opposite
method and its unreadable as a wav.

Anybody know what the format that file might be?

OR what format I should convert to the TI (and recommended method) for sounds?

Greg

---

From: "epergrem" <[email-masked]>
Date: Sun, 20 Feb 2011 22:05:13 -0000

Greg,
There was a set of 10 Sound disks for it.  I'm not sure if they came with the Digi-Port or not.  If you don't have them, then I can convert them to PC99 format, if the disks are good, and upload them to WHT.

Maybe you can figure out from those what the format is.

Ernie

---

From: ti99_forever <[email-masked]>
Date: Sun, 20 Feb 2011 15:26:05 -0800 (PST)

If you do A-->B, B-->A and don't get the same file back, something is being lost or muddled...

Also, be aware of stereo vs mono WAV files. It probably isn't a WAV file format anyway, perhaps one of the older raw formats, like au...

--- On Sun, 2/20/11, Gregory McGill <[email-masked]> wrote:

> Subject: [TI994A] Re: digi-play and rambo
> Date: Sunday, February 20, 2011, 4:42 PM
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: "Tursi" <[email-masked]>
Date: Sun, 20 Feb 2011 15:35:52 -0800

>Also, be aware of stereo vs mono WAV files. It probably isn't a WAV file 
>format anyway, perhaps one of the older raw formats, like au...

Easy enough to tell.. open the file up in anything, hex editor, even 
notepad. If the first four bytes don't spell RIFF, it's not a WAV file.

---

From: Gregory McGill <[email-masked]>
Date: Sun, 20 Feb 2011 16:31:11 -0800

That'd be great thanks a bunch in advance :) whenever you have time this is
just me fiddling around with a new toy.. no priority

Greg

On Sun, Feb 20, 2011 at 2:05 PM, epergrem <[email-masked]> wrote:

>
>
> Greg,
> There was a set of 10 Sound disks for it. I'm not sure if they came with
> the Digi-Port or not. If you don't have them, then I can convert them to
> PC99 format, if the disks are good, and upload them to WHT.
>

---

From: Gregory McGill <[email-masked]>
Date: Sun, 20 Feb 2011 16:32:23 -0800

i did a->b and it didn't work (homeranykey.wav on pc to anykey on ti)
and i did c->d and it didn't work  (gameover on ti to gameover.wav on pc)

but not a-b then b-a ..

Greg

---

From: Gregory McGill <[email-masked]>
Date: Sun, 20 Feb 2011 19:04:57 -0800

Thinking it may be a 16bit vs 8bit issue. Amiga files are 8bit iff .. and
the file i was sending over was DVI ADPCM audio 44100hz probably not 8bit

Greg

---

From: "epergrem" <[email-masked]>
Date: Mon, 21 Feb 2011 12:40:06 -0000

Hi Greg, 
I have an copy if the WHT docs for Digi-Port and this is what it says "A sound file is a PCM (Pulse code modulated) or RAW digital sound file from a Macintosh, IBM PC (sound blaster, etc.), Amiga, or Sun workstation. These files, when downloaded or transferred over to the TI, will be in DV/128 format.  Nearly any sound file from ANY computer (providing it is a raw sample) will work in Digi-Port.  Provisions for converting polarized sound files is included on the main command line.  Digi-Port also provides support for playing samples created for use with Barry Boone's Sound F/X.".

I'm not sure if this will help or just confuse the issue more.  The source for Barry's Sound F/X is on WHT, but I'm not sure if the sound files are.

Ernie

---

From: "Beery" <[email-masked]>
Date: Mon, 21 Feb 2011 15:46:44 -0000

There is also a MDOS version of a program I wrote that uses Barry's sound's routines.  To my knowledge though, the emulation of the sound chip under MESS doesn't allow it to work.

The program was released in 9640News and is probably available in one of the MDOS directory archives.  I think it had some kind of name like SFX.....

Beery

---

From: fdos <[email-masked]>
Date: Mon, 21 Feb 2011 08:54:07 -0700

Beery,

I have the complete Digi-Port system (with PIO device to audio output) 
and sounds diskettes for the Geneve.  I haven't followed the thread due 
to other priorities.

Bill S

On 2/21/2011 8:46 AM, Beery wrote:
> --- In [email-masked], "epergrem"<epergrem@...>  wrote:
>>
>> Hi Greg,

---

From: Tony Knerr <[email-masked]>
Date: Mon, 21 Feb 2011 12:16:54 -0500

It's called PFX, Beery. And it _does_ work in MESS. I use it quite a 
bit, check my hard drive image
in the files section of the Geneve group.

Tony

Beery wrote:
>  
>
> There is also a MDOS version of a program I wrote that uses Barry's 
> sound's routines. To my knowledge though, the emulation of the sound 
> chip under MESS doesn't allow it to work.
>
> The program was released in 9640News and is probably available in one 
> of the MDOS directory archives. I think it had some kind of name like 
> SFX.....
>
> Beery
>

---

From: "Beery" <[email-masked]>
Date: Tue, 22 Feb 2011 20:17:23 -0000

That's the one I wrote that uses the Windows driver?

Beery

---

From: Tony Knerr <[email-masked]>
Date: Tue, 22 Feb 2011 17:06:53 -0500

Windows driver???

Example of usage from the command prompt or within a batchfile:

E:\PFX E:\SOUNDS\soundfile /speed

'soundfile' is the name of the file to play, 'speed' is a number between 
1 and 99 (I think)
for the rate at which the sound is played.

Tony

On 2/22/2011 3:17 PM, Beery wrote:
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, Tony 
> Knerr <tonyknerr@...> wrote:
> >

---

From: "Beery" <[email-masked]>
Date: Thu, 24 Feb 2011 03:37:44 -0000

I found the program on my mess image.  It required the WIN-DRIVE file and was called SFXER.

It played sound files to the sound chip, not a parallel port, in MDOS mode in about 6 bit quality.

Under MESS, that emulation doesn't produce recognizeable sound on any files I have tested.  It hasn't been any big deal to me as Barry pushed the envelope when he developed his sound player.

I'll try to find your file you mentioned to see what it does.

Beery

--- In [email-masked], Tony Knerr <tonyknerr@...> wrote:
> > Knerr <tonyknerr@> wrote:
> > >

---

From: "Beery" <[email-masked]>
Date: Thu, 24 Feb 2011 03:53:49 -0000

Tony,

Can you point me to a URL for the file.  Everywhere I look, I don't see something.   I'm not sure if I am blind, not understanding where you mentioned, or it's been moved.

Thanks.

Beery

---

From: Gregory McGill <[email-masked]>
Date: Wed, 23 Feb 2011 22:27:39 -0800

WIN-DRIVE isn't on that image that I can see..

Greg

On Wed, Feb 23, 2011 at 7:37 PM, Beery <[email-masked]> wrote:

> Under MESS, that emulation doesn't produce recognizeable sound on any files
> I have tested. It hasn't been any big deal to me as Barry pushed the
> envelope when he developed his sound player.
>

---

From: Gregory McGill <[email-masked]>
Date: Wed, 23 Feb 2011 23:22:46 -0800

BUT pfx doesn't need it :)  that's all folks! worked on the REAL geneve.
woot  :)

G

On Wed, Feb 23, 2011 at 10:27 PM, Gregory McGill <[email-masked]> wrote:

>> Under MESS, that emulation doesn't produce recognizeable sound on any
>> files I have tested. It hasn't been any big deal to me as Barry pushed the

---

From: Gregory McGill <[email-masked]>
Date: Thu, 24 Feb 2011 18:31:48 -0800

and it works on MESS latest svn i downloaded and compiled after Michael's
last announcement

Greg

On Wed, Feb 23, 2011 at 11:22 PM, Gregory McGill <[email-masked]> wrote:

> On Wed, Feb 23, 2011 at 10:27 PM, Gregory McGill <[email-masked]>wrote:
>

---

From: "Beery" <[email-masked]>
Date: Fri, 25 Feb 2011 03:37:55 -0000

I got PFX to work, as well as the original SFXER program I wrote.  PFX is a command line version of SFXER I wrote from code that worked for the TI-99/4A and Geneve/GPL mode that Barry Boone originally wrote.  SFXER gives one additional feature I think was stripped from the command line version and that was to play a sound file backwards.

Turns out the STARWARS sound clips I had were not compatible. I have no idea how long the sound was properly emulated and I didn't know it.

Beery

--- In [email-masked], Gregory McGill <arcadeshopper@...> wrote:
> On Wed, Feb 23, 2011 at 11:22 PM, Gregory McGill <mcgill@...> wrote:
> 
> > On Wed, Feb 23, 2011 at 10:27 PM, Gregory McGill <mcgill@...>wrote:
> >
> >> On Wed, Feb 23, 2011 at 7:37 PM, Beery <bmiller@...> wrote:
> >>
> >>>
> >>>
> >>> --- In [email-masked], Tony Knerr <tonyknerr@> wrote:
> >>> >
> >>> > Windows driver???
> >>> >