Subject: HELP Diagnosing FDC

From: "[email-masked]" <[email-masked]>
Date: Mon, 09 May 2011 04:28:15 -0000

I've been trying to diagnose a failed TI floppy drive controller. When I set CRU bit 1 to 0 the controller responds by turning on the LED, however, it fails to load the ROM into >4000. Mem inspection reveals all 0s.

I've tested the voltage points on all chips including the 1771, the ROMs, the special control chip (to the left of the ROMs) and all other chips. I've traced most lines for continuity breaks revealing no breaks. I've tested both regulators and they are within spec.

I pulled all Caps and resisters and they all appear to be in spec. Although -- on this point -- most of the .01uf caps used for the buffers read 10nf, but 2 or 3 rate as low as 9nf and a couple rate 12nf. I'm guesing this is in range given that the voltages appear ok.

Does anyone have some suggestions on where to go from here. I'd love to use a logic probe to trace what occurs when I set cru bit 1 to 1, but I'm not 100% where to test.

Does anyone have a broken FDC that I could have or borrow to swap out some chips?

Thoughts or ideas? I'm doing this for my personal education and appreciate any tips, pointers, and mentoring.

I should also point out that the drives do spin up on power on of the PEB, however setting cru bit 2 to 1 doesn't appear to pulse the drive, but I'm not 100% sure I've performed the test correctly.

All the best,

Cory

---

From: mark wills <[email-masked]>
Date: Mon, 9 May 2011 09:56:29 +0100 (BST)

Cory,

IIRC, it is CRU bit 0 that pages in the DSR:

LI R12,>1E00  (select floppy controller)
SBO 0         (map in the DSR)

The disk controller has multiple CRU bits that do different things.

Here's a very good write up on the disk controller:

http://nouspikel.group.shef.ac.uk//ti99/disks2.htm

Mark

>________________________________
>From: "[email-masked]" <[email-masked]>
>To: [email-masked]
>Sent: Monday, 9 May 2011, 5:28
>Subject: [TI994A] HELP Diagnosing FDC
>
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 09 May 2011 12:11:43 -0000

Oops, I should have proofread my email.  

The email should have read:

Setting CRU bit 0 to 1 enables the LED on the FDC, however, the controller does not respond by paging the DSR into >4000.  Even though the LED is on, the memory located at >4000 is 00.

At this point, I'm trying to figure out how best to determine whether the ROMs are bad or perhaps the special controller located at U18 is bad.  Or -- could it be something else entirely.

Thanks for the reference to Nouspikel's document.

All the best,
Cory

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> LI R12,>1E00� (select floppy controller)
> SBO 0�������� (map in the DSR)
> 
> >From: "coryklatt@..." <cory.klatt@...>

---

From: mark wills <[email-masked]>
Date: Mon, 9 May 2011 14:15:31 +0100 (BST)

Scope the chip select line on the DSR ROM. It should go low when paged in (I think! - Please check! ROMS are mostly active low).

The site I linked to this morning will have schematics of the circuit.

Is everything else in the PEB working (RS232 etc?) You sure it's not a problem with the fire-hose? A blown buffer in the flex-interface or the fire-hose will still allow the *console* to start up normally, however, it won't know that there's a PEB connected.

>Sent: Monday, 9 May 2011, 13:11
>Subject: Re: [TI994A] Re: HELP Diagnosing FDC
>
>> LI R12,>1E00ï¿½ (select floppy controller)
>> SBO 0ï¿½ï¿½ï¿½ï¿½ï¿½ï¿½ï¿½ï¿½ (map in the DSR)
>>

---

From: Cory Klatt <[email-masked]>
Date: Mon, 9 May 2011 07:22:07 -0700

I'm pretty certain the card is bad, but let me explain:

I've had peculiar issues with the 32K and RS232 Card in the past.  In a
prior post, I was trying to diagnose a problem that prevented me from
formatting disks.  After a fair amount of work and help from Larry C, we
determined that slot 2 in the PEB was bad and as soon as I moved the 32K
card from Slot 2 to another slot, disks formatted fine.  Another member, I
think it was Bill, then reminded me that DM2 doesn't use the 32K card so
that kinda left me wondering.

Anyway, it all was working fine.  I then built a SAMS 1Mb card for some
serious Forth programming :)  I installed the SAMS card and the TI would not
boot with the PEB attached.  I received a blue screen and a single
continuous tone from the console.  I removed the RS232 card (the 32K was
already removed for the SAMS) and the TI booted, but now DM2 failed to
recognize the FDC.  No LED, nothing.  DM would report Disk Error 0.  I
assumed, at this point the FDC had failed, but given the past experience and
the fact that the SAMS card somehow conflicted with the RS232 card, I
decided to replace the Firehose card with a spare.

Fast forwarding .... With the new PEB Interface card and just the FDC
controller in the PEB, DM2 still returns Disk Error 0.  Using MiniMemory, I
set CRU bit 0 to 1, which turned on the LED on the FDC.  I then inspected
the memory @ >4000 and see all 0s.

I think its odd that I lost both the Firehose and the FDC but I suppose it's
possible.

I then replaced the FDC with a loaner FDC (arrived a few days later),
re-installed the SAMS, and RS232 and ran all the diagnostics on the SAMS,
RS232 and floppy controller and everything seems to work.

I swapped back in the old Firehose (removing all cards that I valued :) and
noticed the FDC stopped working, however, the RS232 and 32K RAM appear to
pass diagnostics.  Replacing the Firehose with the new one, everything
passed including the loaner FDC.

I installed the suspect FDC and DM2 reports disk error 0, CRU bit 0 to 1
enables LED, Ram at >4000 00

I hope that made some sense.

I'll trace the line like you suggest and see what I can find.  I'm planning
on building an extender cable for my PEB so I can work on the FDC on my
bench while its still plugged in, but I haven't gotten around to that yet.
Any ideas on how long I can make the cable without loosing the address and
data lines?

Cory

On Mon, May 9, 2011 at 6:15 AM, mark wills <[email-masked]>wrote:

>
>
> Scope the chip select line on the DSR ROM. It should go low when paged in
> (I think! - Please check! ROMS are mostly active low).
>
> Is everything else in the PEB working (RS232 etc?) You sure it's not a
> problem with the fire-hose? A blown buffer in the flex-interface or the
> fire-hose will still allow the *console* to start up normally, however, it
> won't know that there's a PEB connected.
>
>
>
> ------------------------------
> *From:* "[email-masked]" <[email-masked]>
> *To:* [email-masked]
> *Sent:* Monday, 9 May 2011, 13:11
> *Subject:* Re: [TI994A] Re: HELP Diagnosing FDC
>
> Setting CRU bit 0 to 1 enables the LED on the FDC, however, the controller
> does not respond by paging the DSR into >4000.  Even though the LED is on,
> the memory located at >4000 is 00.
>
> At this point, I'm trying to figure out how best to determine whether the
> ROMs are bad or perhaps the special controller located at U18 is bad.  Or --
> could it be something else entirely.
>
> > >I've been trying to diagnose a failed TI floppy drive controller. When I
> set CRU bit 1 to 0 the controller responds by turning on the LED, however,
> it fails to load the ROM into >4000. Mem inspection reveals all 0s.
> > >
> > >I've tested the voltage points on all chips including the 1771, the
> ROMs, the special control chip (to the left of the ROMs) and all other
> chips. I've traced most lines for continuity breaks revealing no breaks.
> I've tested both regulators and they are within spec.
> > >
> > >I pulled all Caps and resisters and they all appear to be in spec.
> Although -- on this point -- most of the .01uf caps used for the buffers
> read 10nf, but 2 or 3 rate as low as 9nf and a couple rate 12nf. I'm guesing
> this is in range given that the voltages appear ok.
> > >
> > >Does anyone have some suggestions on where to go from here. I'd love to
> use a logic probe to trace what occurs when I set cru bit 1 to 1, but I'm
> not 100% where to test.
> > >
> > >Thoughts or ideas? I'm doing this for my personal education and
> appreciate any tips, pointers, and mentoring.
> > >
> > >I should also point out that the drives do spin up on power on of the
> PEB, however setting cru bit 2 to 1 doesn't appear to pulse the drive, but
> I'm not 100% sure I've performed the test correctly.
> > >
> > >
> > >All the best,
> > >
> > >Cory
> > >
> > >
> > >

---

From: mark wills <[email-masked]>
Date: Mon, 9 May 2011 16:58:46 +0100 (BST)

It is sounding like the card is hosed, though it's probably an easy enough repair. Did you (by any chance) insert the SAMS card the wrong way 'round at any point? It's easy to do, and could conceivably damage itself or other cards?

There are some extender boards in existence for the TI PEB which lift the board you are working on out of the PEB. Some kind soul here might send you one as a loaner. I don't have one, unfortunately.

Alternatively, Matthew Hagerty (IIRC) is offering to repair TI hardware for just the cost of the postage. He's over on Atariage. I don't think he frequents these boards anymore.

Mark

>From: Cory Klatt <[email-masked]>
>Sent: Monday, 9 May 2011, 15:22
>I've had peculiar issues with the 32K and RS232 Card in the past.  In a prior post, I was trying to diagnose a problem that prevented me from formatting disks.  After a fair amount of work and help from Larry C, we determined that slot 2 in the PEB was bad and as soon as I moved the 32K card from Slot 2 to another slot, disks formatted fine.  Another member, I think it was Bill, then reminded me that DM2 doesn't use the 32K card so that kinda left me wondering.
>
>Anyway, it all was working fine.  I then built a SAMS 1Mb card for some serious Forth programming :)  I installed the SAMS card and the TI would not boot with the PEB attached.  I received a blue screen and a single continuous tone from the console.  I removed the RS232 card (the 32K was already removed for the SAMS) and the TI booted, but now DM2 failed to recognize the FDC.  No LED, nothing.  DM would report Disk Error 0.  I assumed, at this point the FDC had failed, but given the past experience and the fact that the SAMS card somehow conflicted with the RS232 card, I decided to replace the Firehose card with a spare.
>
>Fast forwarding .... With the new PEB Interface card and just the FDC controller in the PEB, DM2 still returns Disk Error 0.  Using MiniMemory, I set CRU bit 0 to 1, which turned on the LED on the FDC.  I then inspected the memory @ >4000 and see all 0s.
>
>I think its odd that I lost both the Firehose and the FDC but I suppose it's possible.
>
>I then replaced the FDC with a loaner FDC (arrived a few days later), re-installed the SAMS, and RS232 and ran all the diagnostics on the SAMS, RS232 and floppy controller and everything seems to work.
>
>I swapped back in the old Firehose (removing all cards that I valued :) and noticed the FDC stopped working, however, the RS232 and 32K RAM appear to pass diagnostics.  Replacing the Firehose with the new one, everything passed including the loaner FDC.
>
>I installed the suspect FDC and DM2 reports disk error 0, CRU bit 0 to 1 enables LED, Ram at >4000 00
>
>I'll trace the line like you suggest and see what I can find.  I'm planning on building an extender cable for my PEB so I can work on the FDC on my bench while its still plugged in, but I haven't gotten around to that yet.  Any ideas on how long I can make the cable without loosing the address and data lines?
>
>Cory
>
>
>On Mon, May 9, 2011 at 6:15 AM, mark wills <[email-masked]> wrote:
>
>  
>>>> >I pulled all Caps and resisters and they all appear to be in spec. Although -- on this point -- most of the .01uf caps used for the buffers read 10nf,
 but 2 or 3 rate as low as 9nf and a couple rate 12nf. I'm guesing this is in range given that the voltages appear ok.

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 09 May 2011 16:19:19 -0000

I was very careful to make sure I inserted the card in the right direction.  I've learned enough through my explorations to be really concerned about swapping the 12V and 5V lines.  I'm really early in my learning, but it seemed like that wouldn't work out to good for the card and everything nearby :)  

I've welded enough screw drivers and probes to various electronic parts in my uneducated days -- too many to count in honesty -- that I decided perhaps it was time to learn how to read a schematic and learn some basic electronics theory, etc..  

I've sent an email to Matthew based on your suggestion, hoping he's willing to put up with some really dumb questions.  I'd like to learn how to do this.

I recently moved my Daughter to Colorado for College.  I had a 50" DLP Television that wasn't being used and I thought it'd be great for College Kid :) so we moved it to her place.  We were oh so careful transporting it to make sure it survived.  I unpacked it, plugged it in, and was presented a blinking green light of death (as I later learned).  Local electronic stores were quoting me 700+ for labor to repair it!

I couldn't see my way to junk it so I tore it apart and found many of the caps bulging (presumably the altitude must have caused this).  Anyway, I delsoldered them, replaced em, somehow got the whole thing back together - blew only a few fuses in the process - and plugged it in!  It worked!!  I was shocked - although I didn't show that to my Daughter :)  I asked her if she was surprised.  She said no, you looked like you knew what you were doing.  I wish the had Oscar awards for Parenting :)

Anyway, that piqued my interest in electronic repair.  For the cost of 12 caps - about 20.00 I repaired a perfectly good TV, saved a ton of money and really had fun.

You get the point!  :)

Cory

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> >From: Cory Klatt <cory.klatt@...>
> >I've had peculiar issues with the 32K and RS232 Card in the past.� In a prior post, I was trying to diagnose a problem that prevented me from formatting disks.� After a fair amount of work and help from Larry C, we determined that slot 2 in the PEB was bad and as soon as I moved the 32K card from Slot 2 to another slot, disks formatted fine.� Another member, I think it was Bill, then reminded me that DM2 doesn't use the 32K card so that kinda left me wondering.
> >
> >Anyway, it all was working fine.� I then built a SAMS 1Mb card for some serious Forth programming :)� I installed the SAMS card and the TI would not boot with the PEB attached.� I received a blue screen and a single continuous tone from the console.� I removed the RS232 card (the 32K was already removed for the SAMS) and the TI booted, but now DM2 failed to recognize the FDC.� No LED, nothing.� DM would report Disk Error 0.� I assumed, at this point the FDC had failed, but given the past experience and the fact that the SAMS card somehow conflicted with the RS232 card, I decided to replace the Firehose card with a spare.
> >
> >Fast forwarding .... With the new PEB Interface card and just the FDC controller in the PEB, DM2 still returns Disk Error 0.� Using MiniMemory, I set CRU bit 0 to 1, which turned on the LED on the FDC.� I then inspected the memory @ >4000 and see all 0s.
> >
> >I swapped back in the old Firehose (removing all cards that I valued :) and noticed the FDC stopped working, however, the RS232 and 32K RAM appear to pass diagnostics.� Replacing the Firehose with the new one, everything passed including the loaner FDC.
> >
> >I'll trace the line like you suggest and see what I can find.� I'm planning on building an extender cable for my PEB so I can work on the FDC on my bench while its still plugged in, but I haven't gotten around to that yet.� Any ideas on how long I can make the cable without loosing the address and data lines?
> >
> >Cory
> >
> >
> >On Mon, May 9, 2011 at 6:15 AM, mark wills <markrobertwills@...> wrote:
> >
> >� 
> >>>Oops, I should have proofread my email.� 
> >>>
> >>>Setting CRU bit 0 to 1 enables the LED on the FDC, however, the controller does not respond by paging the DSR into >4000.� Even though the LED is on, the memory located at >4000 is 00.
> >>>
> >>>At this point, I'm trying to figure out how best to determine whether the ROMs are bad or perhaps the special controller located at U18 is bad.� Or --
> >>>--- In [email-masked], mark wills <markrobertwills@> wrote:
> >>>>
> >>>> Cory,
> >>>> 
> >>>> >From:
>  "coryklatt@" <cory.klatt@>