Subject: Leaving For Da Faire

From: [email-masked]
Date: Thu, 04 Nov 2010 15:34:09 -0500 (CDT)

I'm heading out for Chicago via a stop at my son's place in Endicott. Should be there Saturday morning early and meet up for a coffee at the BK.  :)

---

From: "hjalmarii" <[email-masked]>
Date: Thu, 04 Nov 2010 21:57:15 -0000

Drive carefully, Richard.  See you at the BK. --Hal