Subject: XB - Making a man jump

From: "roundf" <[email-masked]>
Date: Fri, 08 Jul 2011 22:04:33 -0000

How can you make a moving "running man" sprite stay along the ground running left to right, but also make him jump? The "check lines" or boundaries that could keep him from running on rows above the ground area would also stop him from jumping several rows up.

If someone knows how to answer this, how could the man be made to jump with a "Major Havoc" style jump, where holding down the button continues the jump further?

James

---

From: Tony Knerr <[email-masked]>
Date: Fri, 08 Jul 2011 19:33:09 -0400

Start the running man, scan for a keypress, if the keypress is the one 
you want, redefine the running man and change his direction (probably 
several times).

Yea, that oughta do it. ;)

Tony

On 7/8/2011 6:04 PM, roundf wrote:
>
> How can you make a moving "running man" sprite stay along the ground 
> running left to right, but also make him jump? The "check lines" or 
> boundaries that could keep him from running on rows above the ground 
> area would also stop him from jumping several rows up.
>
> If someone knows how to answer this, how could the man be made to jump 
> with a "Major Havoc" style jump, where holding down the button 
> continues the jump further?
>
> James
>
> __

---

From: "roundf" <[email-masked]>
Date: Sun, 10 Jul 2011 20:43:38 -0000

I have the running man running around in 8 directions manified 4x and it took a lot of character sets from 72-140 or more i think. I also have it scanning for a joystick press and it beeps when you do. But how would you turn that button press into a jump? If K=18 then Call Motion whatever? ANd if you had something like ROW=(R>24)*(R<1), some kind of check line to keep a running on the ground boundary, wouldn't the jump conflict with the ground ROW limits?

James

---

From: [email-masked]
Date: Sun, 10 Jul 2011 22:28:22 +0000 (UTC)

Along with what Tony said you could change the pixel row by 8 for a brief amount of time like 
CALL MOTION(#S,current motion+45% angle up,current motion same):: CALL MOTION(#S,current motion+45% down) 

In RXB you could do a CALL GMOTION(#S,A,B) :: CALL MOTION(#S,A-62,B,#S,A-30,B,#S,A+30,B,#S,A+62,B) 

The Sprite would move up at a angle then slow the angle then reverse down then go the same direction, you might have to do a CALL DISTANCE to put in on the same exact old row number as you started with but the jump would be very smooth looking. It would not be jumpy or jerky looking. 
----- Original Message -----
From: "roundf" <[email-masked]> 
To: [email-masked] 
Sent: Sunday, July 10, 2011 1:43:38 PM 
Subject: [TI994A] Re: XB - Making a man jump 

James

---

From: "roundf" <[email-masked]>
Date: Thu, 21 Jul 2011 01:34:34 -0000

What about in plain XB?

> From: "roundf" <roundfilesilver@...>