Subject: TIFILES stripper

From: "atrax27407" <[email-masked]>
Date: Fri, 04 Feb 2011 22:58:53 -0000

Does anyone have a TI program that will strip the TIFILES header from an I/F 128 file?

---

From: Tony Knerr <[email-masked]>
Date: Fri, 04 Feb 2011 18:24:57 -0500

10 OPEN #1:"FILE1", INTERNAL, FIXED 128
20 OPEN #2:"FILE2", INTERNAL, FIXED 128
30 LINPUT #1:A$
40 LINPUT #1:A$
50 PRINT #2:A$
60 IF EOF(1) THEN 100
70 GOTO 40
100 CLOSE #1
110 CLOSE #2

That should work, though it's untested. XB, not Basic.

Tony

On 2/4/2011 5:58 PM, atrax27407 wrote:
> __

---

From: ti99_forever <[email-masked]>
Date: Fri, 4 Feb 2011 15:29:57 -0800 (PST)

I think they are D/F 128. If you have an I/F 128, you may have trouble writing a program like that in Basic.

For D/F128...

10 OPEN #1:"DSK1.INPUT",DISPLAY,FIXED,INPUT
20 OPEN #2:"DSK1.OUTPUT",DISPLAY,FIXED 128,OUTPUT
30 IF EOF(1) THEN 50
40 LINPUT #1:A$::PRINT #2:A$::GOTO 30
50 CLOSE #1::CLOSE #2
60 END

Substitute your disk files or change to input filenames as you wish...

--- On Fri, 2/4/11, atrax27407 <[email-masked]> wrote:
> From: atrax27407 <[email-masked]>
> Subject: [TI994A] TIFILES stripper
> To: [email-masked]
> Date: Friday, February 4, 2011, 5:58 PM
> Does anyone have a TI program that
> will strip the TIFILES header from an I/F 128 file?
> 
> 
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>     [email-masked]
> 
> 
>

---

From: ti99_forever <[email-masked]>
Date: Fri, 4 Feb 2011 15:31:43 -0800 (PST)

I'm sure it should be DISPLAY - INTERNAL, unless created by BASIC, is usually not readable by BASIC unless it follows the INTERNAL format discussed in the green & yellow URG. Try to read an archive file that is in INTERNAL format in BASIC for example.

--- On Fri, 2/4/11, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: Re: [TI994A] TIFILES stripper
To: [email-masked]
Date: Friday, February 4, 2011, 6:24 PM

  

    30 LINPUT #1:A$

    40 LINPUT #1:A$

    50 PRINT #2:A$

    60 IF EOF(1) THEN 100

    70 GOTO 40

    100 CLOSE #1

    110 CLOSE #2

    Tony

      
          
            Does anyone have a TI program that will strip the TIFILES
              header from an I/F 128 file?

          __