Subject: Pgram files and MESS

From: "Tony Knerr" <[email-masked]>
Date: Sat, 04 Dec 2010 23:30:10 -0000

I just uploaded my PGRAM UTILITIES v2.3 disk from 15+ years ago to the file section here. Just found it while going through some TI stuff. MESS seems to respond strangely to 2 of the gram file sets. The files in question are the TIWEA and DSKUARCMC file sets. I've created rpk's of the files as well as the dsk image to make things easier.

DSKUARCMC works ok in MESS TI as well as Geneve GPL emulation, the
quirk being when ARCHIVER and M-COPIER are exited by function <quit> 
in MESS TI emulation, the emulator locks up with the high pitched whine we all adore. This doesn't happen on a real TI.

TIWEA works ok in MESS Geneve GPL emulation, but the Assembler locks up while loading in MESS TI emulation. The problem exists using either the rpk's or the Gram Kracker with the file set loaded from the dsk image. 

I'm pretty sure both these file sets also work ok on a real TI with a 
Gram Kracker. If anyone feels up to it, would they mind verifying my
observations? It may help in getting the MESS emulation more accurate 
if the discrepancies can be tracked down.

Thanks,

Tony

---

From: Owen Brand <[email-masked]>
Date: Sat, 4 Dec 2010 18:31:33 -0500

Thanks Tony!!

Owen Brand

www.firebrandmusic.net
www.opry99er.com

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 05 Dec 2010 13:10:32 -0000

Hi Tony,

> in MESS TI emulation, the emulator locks up with the high pitched whine we all adore. This doesn't happen on a real TI.

you mean pressing FCTN-= (which maps to AltGr-ß on my keyboard; don't know about the english version; or using natural keyboard, mapping to F12)? I do not get a lockup, the emulation returns cleanly to the Master title screen. However, after 0.140 was out, I submitted lots of changes to subversion; I rewrote the complete peripheral system and the system board emulation. So if there was a problem it may have been cleaned away by this update.
 
> TIWEA works ok in MESS Geneve GPL emulation, but the Assembler locks up while loading in MESS TI emulation. The problem exists using either the rpk's or the Gram Kracker with the file set loaded fr…

I started with -cart1 TIWEA.rpk, then I selected TI-WRITER/ASSEMBLER, getting a menu with six items, pressed 3 and got the prompt "SOURCE FILE NAME?". I suppose the emulation already got past the point you have mentioned?

Sorry ... I know that a WORKSFORME is the least preferred answer to receive. Check the configuration? Recreate the mess.ini? What is your MESS version and operating system?

Michael

---

From: Tony Knerr <[email-masked]>
Date: Sun, 05 Dec 2010 09:10:46 -0500

Thanks for testing, Michael.
The TI-WRITER/ASSEMBLER option 3 locks up with the text "* ASSEMBLER *" 
at the top of the
screen, no prompt for filename.

I'm using messuipp.exe version 0.139 on Windows XP SP3. I tried a new 
mess.ini and
it didn't help. I will try upgrading to version 0.140.

It's odd that all the other cartridge software I have works except these 
2 new ones. :(
I'm glad it works for someone. :)

Tony

On 12/5/2010 8:10 AM, Michael Zapf wrote:
> > in MESS TI emulation, the emulator locks up with the high pitched 
> whine we all adore. This doesn't happen on a real TI.
>
> you mean pressing FCTN-= (which maps to AltGr-ß on my keyboard; don't 
> know about the english version; or using natural keyboard, mapping to 
> F12)? I do not get a lockup, the emulation returns cleanly to the 
> Master title screen. However, after 0.140 was out, I submitted lots of 
> changes to subversion; I rewrote the complete peripheral system and 
> the system board emulation. So if there was a problem it may have been 
> cleaned away by this update.
>
> > TIWEA works ok in MESS Geneve GPL emulation, but the Assembler locks 
> up while loading in MESS TI emulation. The problem exists using either 
> the rpk's or the Gram Kracker with the file set loaded from the dsk 
> image.
>
> I started with -cart1 TIWEA.rpk, then I selected TI-WRITER/ASSEMBLER, 
> getting a menu with six items, pressed 3 and got the prompt "SOURCE 
> FILE NAME?". I suppose the emulation already got past the point you 
> have mentioned?
>
> Sorry ... I know that a WORKSFORME is the least preferred answer to 
> receive. Check the configuration? Recreate the mess.ini? What is your 
> MESS version and operating system?
>
> Michael
>

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 05 Dec 2010 15:57:43 -0000

Hello Tony,

> screen, no prompt for filename.

I still could not find any problem with exiting from the utilities cartridge by QUIT. But I can confirm that MESS 0.140 shows the observed lockup in TIWEA (tested under Windows XP). 

There is a website offering nightly builds from subversion; you need to download and unpack it over your existing 0.140 installation. Or you have to wait for 0.141.

I cannot say what the problem was; the refactoring of the code (which indeed took much longer than expected, several months, being the reason why 0.140 has no new features for the TI family) seems to have at least a positive visible effect. :-)

Michael

---

From: Tony Knerr <[email-masked]>
Date: Sun, 05 Dec 2010 12:17:10 -0500

Hi Michael.

Thanks for the information. Version 0.140 did not solve the problem,
but the nightly build from Today did. All is working as it should now. :)

Thanks again,

Tony

On 12/5/2010 10:57 AM, Michael Zapf wrote:
> I still could not find any problem with exiting from the utilities 
> cartridge by QUIT. But I can confirm that MESS 0.140 shows the 
> observed lockup in TIWEA (tested under Windows XP).
>
> There is a website offering nightly builds from subversion; you need 
> to download and unpack it over your existing 0.140 installation. Or 
> you have to wait for 0.141.
>
> I cannot say what the problem was; the refactoring of the code (which 
> indeed took much longer than expected, several months, being the 
> reason why 0.140 has no new features for the TI family) seems to have 
> at least a positive visible effect. :-)
>
> Michael
>
> _