Subject: Re: Re: Re: [TI994A] Some problems

From: [email-masked]
Date: Fri, 15 Jul 2011 07:41:37 -0500 (CDT)

Remember, never run a WHT RAM disk without batteries. When installing new batteries charge them first then install them into the RAM disk holders. Always remove a battery for a minute when having problems reinstalling the ROS so that all "artifacts" will be eliminated from the ROS memory chip. Yes, any rat shack rechargeables should work fine.

On 07/15/11, jacques<[email-masked]> wrote:
Richard,

Thank you for the suggestion. I will replace the batteries and look for any
loose connections around the battery holder. The old batteries are AAA
marked Rechargeable Ni-Cd (NeXXtech brand probably bought from RS a few
years ago) . Should any rechargeable AAA batteries work?

Jacques

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Thursday, July 14, 2011 11:56 PM
Subject: Re: Re: [TI994A] Some problems

>
>
>
> Are you sure the batteries are good? This sounds like the kind of thing
> that can happen when batteries go bad and no longer take a charge or a
> battery holder problem.

---

From: Marc Hull <[email-masked]>
Date: Fri, 15 Jul 2011 07:17:13 -0700 (PDT)

At the risk of piling on ;-).....

I experienced the same issues a couple of years ago with a HRD 3000b and have a theory or two as to a possible issue with those cards.  

Speculation 1....
As per the construction guide and some tracing...  The 3000 and 4000 have a built in write protect circuit that holds *WE on U11 high during power down using the batteries.  If the power is low (as Rich suggested) the voltage at the pin may not be high enough to prevent spurious writes to U11 or may not be enough to back up U11 during periods of no power.  The net result is possible corruption of the ROS and since it takes control at power up there is no telling what can happen.

Speculation 2...
On the construction guide available on WHT there is some handwriting that says a 3.6v Lithium battery can be substituted for the 3 1.5v AA batteries.  This may work if all conditions are perfect but.....  In the card I had, the standby voltage at U11 was dropping to around 2.4 volts and the *WE line power was almost non existent even though the voltage at the other RAM chips was a good 3.6 v.  I don't know if this was cause by an out of spec transistor and/or diode in the backup circuit or just bad info on the construction guide.   After fussing for a year over the beast I finally changed the set up to use 3 AA batteries in series (4.5v) and the damn thing worked perfect.

I would suspect that the person who wrote and uploaded the construction guide onto WHT may have using their card on a Geneve where the state of U11 has no bearing on function (this is really wild speculation but seems to make sense.)

--- On Fri, 7/15/11, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: Re: Re: [TI994A] Some problems
To: [email-masked]
Date: Friday, July 15, 2011, 7:41 AM

  

       Remember, never run a WHT RAM disk without batteries. When installing new batteries charge them first then install them into the RAM disk holders. Always remove a battery for a minute when having problems reinstalling the ROS so that all "artifacts" will be eliminated from the ROS memory chip. Yes, any rat shack rechargeables should work fine.  On 07/15/11, jacques<[email-masked]> wrote:Richard,

Jacques

---

From: [email-masked]
Date: Fri, 15 Jul 2011 14:47:19 +0000 (UTC)

I think you are right. The Upgrade 2000 that I had to 3000 then 4000 has the same history. 

My 2000 was very stable, the 3000 and 4000 were prone to this problem way to often for comfort. 

My 4000 seemed to only work it I replaced the ROS battery like every 2 months. 

Oddly my Corcomp RAMdisk was the most reliable RAMdisk I ever owned, guess why? 

(It had a power supply separate from the TI) 

----- Original Message -----
From: "Marc Hull" <[email-masked]> 
To: [email-masked] 
Sent: Friday, July 15, 2011 7:17:13 AM 
Subject: Re: Re: Re: [TI994A] Some problems 

Speculation 1.... 

Speculation 2... 

Jacques

---

From: Tony Knerr <[email-masked]>
Date: Fri, 15 Jul 2011 17:24:09 -0400

I struggled with the rechargeables on my two Horizon 4000 ramdisks, 
also. My solution was to use alkalines along with the diode to prevent
the card from trying to charge them. They last about 2 years, and the 
cards are rock solid with them. I never have to reload the DSR unless
I inadvertently do something to write to it by mistake.

There is also another way to load the ROS without using the config 
program. Just load your ROS image like any EA5 program into the
 >4000 memory area with bit 1 of the card's CRU address turned on. I've 
been doing this for years as my 4P doesn't let my Horizon 4000
and SCSI cards play nice together. :)

Tony

On 7/15/2011 10:17 AM, Marc Hull wrote:
>
> ...    After fussing for a year over the beast I finally changed the 
> set up to use 3 AA batteries in series (4.5v) and the damn thing 
> worked perfect.
>
> I would suspect that the person who wrote and uploaded the 
> construction guide onto WHT may have using their card on a Geneve 
> where the state of U11 has no bearing on function (this is really wild 
> speculation but seems to make sense.)
>
>
>
>
>

---

From: "jacques" <[email-masked]>
Date: Fri, 15 Jul 2011 20:47:52 -0300

Tony,

Are you are using a short TI Basic program to load ROS without using the CFG 
program? If so, would you provide an example. I know how to toggle bit 1 of 
the HRD card to make the panel light come on. What do I do next to load ROS?

I am making some progress in solving my problems. I found a small HRD (192K) 
card that I had forgotten that I had. Its batteries are a bit corroded but I 
was able to load ROS and configure it as DSK5. However, it does not hold its 
ROS when I turn my TI off so I will have to replace the batteries. I was 
then able to archive a few files using Archiver on DSK5. This seems to 
indicate that there is nothing wrong with my BwG disk controller card and 
that previous versions of ROS on the other HRD cards may have become 
corrupted over time. I want to replace the ROS on my other small HRD card to 
see it the archiving problem has also disappeared with that card. Other than 
to go and buy some new batteries I have not yet done much with my HRD 4000 
card.
.
Regards,

Jacques

---

From: [email-masked]
Date: Sat, 16 Jul 2011 00:23:07 +0000 (UTC)

I did what Don O'neil told me and used a Radio shack wall power supply for about 4 months, then the card flaked out. 

----- Original Message -----
From: "Tony Knerr" <[email-masked]> 
To: [email-masked] 
Sent: Friday, July 15, 2011 2:24:09 PM 
Subject: Re: [TI994A] Some problems 

I struggled with the rechargeables on my two Horizon 4000 ramdisks, also. My solution was to use alkalines along with the diode to prevent 
the card from trying to charge them. They last about 2 years, and the cards are rock solid with them. I never have to reload the DSR unless 
I inadvertently do something to write to it by mistake. 

There is also another way to load the ROS without using the config program. Just load your ROS image like any EA5 program into the 
>4000 memory area with bit 1 of the card's CRU address turned on. I've been doing this for years as my 4P doesn't let my Horizon 4000 

Tony 

	... After fussing for a year over the beast I finally changed the set up to use 3 AA batteries in series (4.5v) and the damn thing worked perfect.

---

From: Tony Knerr <[email-masked]>
Date: Fri, 15 Jul 2011 21:15:02 -0400

Hi Jacques.

No, it's an assembly routine. It's not much, but I'll have to find the 
source and transfer it to pc.
It's a brute force routine with no error checking, but it works for me.

Gimmee a little time to find it, transfer it, & post it...

Tony

On 7/15/2011 7:47 PM, jacques wrote:
> the HRD card to make the panel light come on. What do I do next to 
> load ROS? ...
>

---

From: ti99_forever <[email-masked]>
Date: Fri, 15 Jul 2011 21:08:57 -0700 (PDT)

Yep, I wrote a similar routine just for those occasions when CFG doesn't recognize the card. Works well, if it is only corrupted...

--- On Fri, 7/15/11, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: Re: [TI994A] Some problems
To: [email-masked]
Date: Friday, July 15, 2011, 9:15 PM

  

    Hi Jacques. 

    No, it's an assembly routine. It's not much, but I'll have to find
    the source and transfer it to pc.

    It's a brute force routine with no error checking, but it works for
    me.

    

    Tony   

      
          
            Tony,

              Are you are using a short TI Basic program to load ROS
              without using the CFG 

              program? If so, would you provide an example. I know how
              to toggle bit 1 of 

              the HRD card to make the panel light come on. What do I do
              next to load ROS? ...

---

From: "Tony Knerr" <[email-masked]>
Date: Sat, 16 Jul 2011 22:27:45 -0000

me.
> Gimmee a little time to find it, transfer it, & post it...

Jacques, here's the code. As you can see, it's pretty simple. The >1500
in the START statement is the CRU address of the ramdisk. You have to
disassemble your ROS file into DATA statements and include it at the
ROSDAT statement instead of my data. Make sure it's >2000 bytes long,
pad it with zeros if necessary. I use Rag Linker to make a program image
file from the object code, another linker may require more labels.

Tony

* start of code
        DEF  START
START  LI   R12,>1500
        SBO  0
        LI   R2,ROSDAT
        LI   R3,>4000
        LI   R4,>2000
MOVER  MOVB *R2+,*R3+
        DEC  R4
        JNE  MOVER
        SBZ  0
        BLWP @>0000
ROSDAT DATA >AA81,>0000,>4036,>0000,>42EA,>422E   '....@6..B.B.'
A000
        DATA >4030,>0009,>0640,>0000,>0001,>00F4   '@0...@......'
A00C
        DATA >0643,>0001,>0000,>0000,>57EE,>574E   '.C......W.WN'
A018
        DATA >0830,>3132,>3334,>3536,>3700,>57F6   '.01234567.W.'
A024
<snip> tons more data statements here
        DATA >CC70,>0602,>16FD,>045B,>FF7E,>AA81   '.p.....[.~..'
BFBC
        DATA >0102,>0320,>2052,>4F53,>4D59,>524B   '...  ROSMYRK'
BFC8
        DATA >200B,>0C0D,>0004,>0506,>2038,>2E31   ' ....... 8.1'
BFD4
        DATA >342D,>4620,>2020,>0E0F,>1000,>0708   '4-F   ......'
BFE0
        DATA >0920,>3034,>2F32,>322F,>3933,>2011   '. 04/22/93 .'
BFEC
        DATA >1213,>0000,>0000,>0000               '........'
BFF8
SLAST  END
* end of code

---

From: "jacques" <[email-masked]>
Date: Sat, 16 Jul 2011 21:28:05 -0300

Tony,

Thank you very much. I will give it a try.

This afternoon my HRD 4000 card suddenly came alive and I was able to load 
ROS and restore the various files that I had. Seems to be solid since I have 
turned my TI on and off a few times since then.

Later my middle son and his family arrived from Ottawa and I have not been 
able to look into my BwG DC problem any further.

Jacques

----- Original Message ----- 
From: "Tony Knerr" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, July 16, 2011 7:27 PM
Subject: [TI994A] Re: Some problems

me.

Tony

* start of code
        DEF  START
START  LI   R12,>1500
        SBO  0
        LI   R2,ROSDAT
        LI   R3,>4000
        LI   R4,>2000
MOVER  MOVB *R2+,*R3+
        DEC  R4
        JNE  MOVER
        SBZ  0
        BLWP @>0000