Subject: Re: [TI994A] TI ROM checksum

From: Jeffrey White <[email-masked]>
Date: Mon, 18 Apr 2011 07:20:25 -0700 (PDT)

Tim,

Have you tried calculating a checksum each for even bytes and odd bytes?  Recall that there are two 4Kx8 ROM's.  The 16-bit checksum for ROM-even would be at 1FFC and 1FFE, for ROM-odd at 1FFD and 1FFF.

Note that the checksum might be part of the calculation to get an answer of 0000.

GROM's also have a checksum, I recall.

Jeff White

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 18 Apr 2011 11:33:44 -0500

Ah, perhaps that is the key.  Since I am doing this on the Geneve, I was not taking the physical hardware attriutes into account, Jeff.  I will try that tonight :)   
 
Ben - I don't think they could be 32 bit checksums, only because mathematically, you could never obtain the value in the two words even if the entire ROM were FFFF.  But very good thought on 16-bit; I will try that, too.

> To: [email-masked]
> From: [email-masked]
> Date: Mon, 18 Apr 2011 07:20:25 -0700
> Subject: Re: [TI994A] TI ROM checksum
> 
> Tim,
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: [email-masked]
Date: Mon, 18 Apr 2011 21:30:29 +0000 (UTC)

Jeff White 

Yea first one that comes to mind is the CS1 and CS2 have a built in Checksum. 

Rich 

----- Original Message ----- 
From: "Jeffrey White" <[email-masked]> 
To: [email-masked] 
Sent: Monday, April 18, 2011 7:20:25 AM 
Subject: Re: [TI994A] TI ROM checksum 

Tim, 

Jeff White