Subject: Slightly OT request. for the PC experts.

From: "Marc H" <[email-masked]>
Date: Mon, 24 Jan 2011 00:31:27 -0000

I am in need of a PC windows program that could perform the task of taking a group of files and prepending to all of them a character.  For example if the file is named "test123.whatever" after performing the change the file would be ">test123.whatever".  If there are 100 files in a folder then it would do this to each file automatically.

Does such a creature exist to the knowledge of anyone ?

Also for the TIDIR experts here.  Is there a way when converting files onto a disk to force TIDIR to have a default file type, record length and conversion process.  The program works just fine it is becoming a PITA thought to keep having to chose DF and then scroll to 128 and then select a conversion process.  I'm entirely too lazy I know but it would be nice if this were possible.

Thanks.

Marc

---

From: "epergrem" <[email-masked]>
Date: Mon, 24 Jan 2011 00:50:48 -0000

Marc,
The answer to your first question is that I've looked but haven't successfully found one. If you do then let me know.  Well truthfully, I did find one program, but when you specified prefix, it ignored it.  I emailed the author, but no response. 

As for number two, you can tell Ti99Dir to always treat a file of a certain suffix the same way.  Look at in the Ti99Dir ini file under the [Pc_Ti_File_Conversion] section.

Ernie

---

From: "Tursi" <[email-masked]>
Date: Sun, 23 Jan 2011 17:08:26 -0800

The simplest way might be to use cygwin to rename the files, you can use 
better patterns there than in DOS. ;)

But, I do have a tool that lets you run a batch file or command against 
every file in a folder - you could probably use that (and it's useful for 
other batching processes in Windows). 
http://harmlesslion.com/software/dircmd

Something like:

dircmd * "cmd /c rename" \"$f\" \"q$f\"

That would rename ALL The files in the folder from "whatever" to 
"fwhatever". Note there is no undo, so use it carefully! The command to 
execute is the whole "cmd /c rename", which is why it must be in quotes. The 
filenames we want to be quoted in the actual command output, so we have to 
escape them with backslashes. I've tested this and it works.

">" is not a legal character in a filename, so I assume that was just an 
example.

-----Original Message----- 
From: Marc H
Sent: Sunday, January 23, 2011 4:31 PM
To: [email-masked]
Subject: [TI994A] Slightly OT request. for the PC experts.

I am in need of a PC windows program that could perform the task of taking a 
group of files and prepending to all of them a character.  For example if 
the file is named "test123.whatever" after performing the change the file 
would be ">test123.whatever".  If there are 100 files in a folder then it 
would do this to each file automatically.

Also for the TIDIR experts here.  Is there a way when converting files onto 
a disk to force TIDIR to have a default file type, record length and 
conversion process.  The program works just fine it is becoming a PITA 
thought to keep having to chose DF and then scroll to 128 and then select a 
conversion process.  I'm entirely too lazy I know but it would be nice if 
this were possible.

Thanks.

Marc

------------------------------------

Yahoo! Groups Links

---

From: Tony Knerr <[email-masked]>
Date: Sun, 23 Jan 2011 20:10:17 -0500

You are looking for "Renamer 6.0 final" by Albert Bertilsson. Get it here:

http://www.albert.nu/Programs/Renamer/default.asp

Been using it for years, works great.
You're particular need is accomplished by >edit, >insert,
then fill in "insert" with ">", and "at position" with 0.
Then click ok.

Have fun with it.

Tony

On 1/23/2011 7:31 PM, Marc H wrote:
>
> I am in need of a PC windows program that could perform the task of 
> taking a group of files and prepending to all of them a character. For 
> example if the file is named "test123.whatever" after performing the 
> change the file would be ">test123.whatever". If there are 100 files 
> in a folder then it would do this to each file automatically.
>
> Also for the TIDIR experts here. Is there a way when converting files 
> onto a disk to force TIDIR to have a default file type, record length 
> and conversion process. The program works just fine it is becoming a 
> PITA thought to keep having to chose DF and then scroll to 128 and 
> then select a conversion process. I'm entirely too lazy I know but it 
> would be nice if this were possible.
>
> Thanks.
>
> Marc
>
> __

---

From: Marc Hull <[email-masked]>
Date: Mon, 24 Jan 2011 10:03:08 -0800 (PST)

Did you see Tony's and Mikes replies ?  That should simplify life somewhat.  The only issue now is deleting those pesky .STR, .PIC and .WDS files.  I'm about an hour into it and only half way ;-)

Does Michael's new program allow for converting files like TIDIR does or is it strictly transfer ?

--- On Sun, 1/23/11, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] Re: Slightly OT request. for the PC experts.
To: [email-masked]
Date: Sunday, January 23, 2011, 6:50 PM

  

      Marc,

Ernie

--- In [email-masked], "Marc H" <marc.hull@...> wrote:

---

From: "Michael Zapf" <[email-masked]>
Date: Mon, 24 Jan 2011 20:32:11 -0000

Hello,

> Did you see Tony's and Mikes replies ?Â  That should simplify life somewhat.Â  The only issue now is deleting those pesky .STR, .PIC and .WDS files.Â  I'm about an hour into it and only half way ;-)
> 

I have not yet tried TIDIR, so I cannot give an answer here. My tool is a disk image manager which allows you to look into disk images or import/export files. In this version you can only import TIFILES files, but I will also include a feature to create a TIFILES file form raw contents (and then, as a second step, import the file).

Disk images can be in sector dump ("v9t9") or track dump ("pc99") format. Hard disk images used in MESS must be extracted from the CHD container file, but after that they can also be viewed.

Michael