Subject: OT: components for custom computer

From: Owen Brand <[email-masked]>
Date: Sat, 26 Feb 2011 21:48:31 -0500

I'm in the planning stages of building my own Jupiter Ace computer... I am
in need of several components, many of which I have listed below.  I have
also linked a site that has the instructions, PCB layout, and pictures for
accomplishing this task.  If anyone here has any of these components they
wish to move, I'd be very interested in acquiring them.  I cannot find a kit
for this kind of thing, so I'll need to seek out each component
individually.

Also, I have absolutely no experience in this field... The extent of my
computer hardware work was assembling a cart board from the last run of
boards Jon put out.  So... several things I need to do, perhaps someone
could help me out with wisdom, parts, or service.

1) purchase components
2) study board design and layout (doing so now)
3) burn the EPROMs for system roms, etc.
4) assemble board (including soldering, tracing, wiring, etc)
5) have fun with my Jupiter Ace

The help site gives the following components as required for assembly:::

Z0         Z80  (cpu)
Z1,Z2      2732  (4K x 8 eprom) Z3-Z4      2114  (1K x 4 sram)  I recommend
using one 6264 to allow 5K RAM
Z5-Z6      2114  (1K x 4 sram)  I recommend using one cheaper 6116 (2k x
8)
Z7-Z8      2114  (1K x 4 sram)  I recommend using one cheaper 6116 (2k x
8)
Z9-Z11     74LS393
Z14-17     74LS367
Z19        74LS00
Z20        74LS08
Z21,22     74LS11
Z23        74LS86
Z24,25     74LS02
Z26        74LS32
Z27        74LS74
Z28        74LS166
Z29        74LS138

U27        7805  (+5V reg)

X1         6.5 MHz xtal

Q1         2N2369
Q2         2N3904

D1-11      1N4148

C1         39p ceramic
C2         100p ceramic
C3         47n
C4         47p ceramic
C5         -
C6         47n
C7         1u tantalum
C8         2n2
C9         100u electrolytic
C10        100n
C11,12     1u tantalum
C13-21     100n

R1         4k7
R2         47k
R3         1k5
R4         1k5
R5         12k
R6         1k
R7         1k8
R8         270
R9         220
R10        10k
R11-23     1k
R24        10k
R25        220k
R26        330

RN1,2      1k x 8

L1 RF choke

LS1 220r speaker
S1-40 SPST switch (keyboard)

JP1 3.5mm socket (audio out)
JP2 3.5mm socket (power in)
JP3 RCA phono (video out)
JP4 3.5mm socket (audio in)

This is the website detailing the steps reqired for assembly and with
pictures of the project
http://www.jupiter-ace.co.uk/hardware_diy_ace.html

I know this is OT, but I'm interested in hearing what you all think... is
this plausible?  I am a complete hardware novice, but I know these
components can be had for about $50 from an online electronics store--- The
actual Jupiter Ace (if you can find one) sells for about $500.  You can see
my reasoning.  Any help would be greatly appreciated!

---

From: Marc Hull <[email-masked]>
Date: Sat, 26 Feb 2011 19:29:14 -0800 (PST)

It would probably be cheaper to buy one of those craptonic z-80 beaters.  Pick and easier starter project Owen ;-).

--- On Sat, 2/26/11, Owen Brand <[email-masked]> wrote:

From: Owen Brand <[email-masked]>
Subject: [TI994A] OT: components for custom computer
To: [email-masked]
Date: Saturday, February 26, 2011, 8:48 PM

  

      I'm in the planning stages of building my own Jupiter Ace computer... I am in need of several components, many of which I have listed below.  I have also linked a site that has the instructions, PCB layout, and pictures for accomplishing this task.  If anyone here has any of these components they wish to move, I'd be very interested in acquiring them.  I cannot find a kit for this kind of thing, so I'll need to seek out each component individually.

Also, I have absolutely no experience in this field... The extent of my computer hardware work was assembling a cart board from the last run of boards Jon put out.  So... several things I need to do, perhaps someone could help me out with wisdom, parts, or service. 

1) purchase components

Z0         Z80  (cpu) 
Z1,Z2      2732  (4K x 8 eprom) Z3-Z4      2114  (1K x 4 sram)  I recommend using one 6264 to allow 5K RAM 
Z5-Z6      2114  (1K x 4 sram)  I recommend using one cheaper 6116 (2k x 8)    

Z7-Z8      2114  (1K x 4 sram)  I recommend using one cheaper 6116 (2k x 8)    
Z9-Z11     74LS393 
Z14-17     74LS367 
Z19        74LS00 
Z20        74LS08 
Z21,22     74LS11 
Z23        74LS86 
Z24,25     74LS02 

Z26        74LS32 
Z27        74LS74 
Z28        74LS166 
Z29        74LS138 

U27        7805  (+5V reg) 

X1         6.5 MHz xtal 

Q1         2N2369 
Q2         2N3904 

D1-11      1N4148 

C1         39p ceramic 
C2         100p ceramic 
C3         47n 
C4         47p ceramic 
C5         - 
C6         47n 
C7         1u tantalum 
C8         2n2 
C9         100u electrolytic 
C10        100n 

C11,12     1u tantalum 
C13-21     100n 

R1         4k7 
R2         47k 
R3         1k5 
R4         1k5 
R5         12k 
R6         1k 
R7         1k8 
R8         270 
R9         220 

R10        10k 
R11-23     1k 
R24        10k 
R25        220k 
R26        330 
  
RN1,2      1k x 8 

L1 RF choke 

LS1 220r speaker 

 
This is the website detailing the steps reqired for assembly and with pictures of the project
http://www.jupiter-ace.co.uk/hardware_diy_ace.html

I know this is OT, but I'm interested in hearing what you all think... is this plausible?  I am a complete hardware novice, but I know these components can be had for about $50 from an online electronics store--- The actual Jupiter Ace (if you can find one) sells for about $500.  You can see my reasoning.  Any help would be greatly appreciated!

---

From: Jon P Vogel <[email-masked]>
Date: Sat, 26 Feb 2011 21:54:01 -0600

Seriously, I agree with Marc, Owen. If you want to get into hardware, start with something easier. It's not so much that I think that you couldn't assemble this, but debugging your wiring when you are finished will be beyond your skill set. Also, do you have the EEPROM programmer that this requires?  I have actually built 8052-based standalone computer systems which are a magnitude easier than this and it was a challenge.  At the very least, you will need the help of a local hardware hacker.  Do you know one that lives close to you?

I hate to be a wet blanket, but I think you will be wasting your $50. 

Regards,

Jon

---

From: Owen <[email-masked]>
Date: Sat, 26 Feb 2011 23:24:36 -0500

Fair points, guys... 

I want the Ace because of it's unique traits--- particularly that it boots to Forth and the syntax is very interesting.  It's only a black and white computer, no colors, however the character sets are doubled--- the top half being the same as the bottom half, only inverted (black is white, white is black)... I typed in several of the example programs and I am just enamored with the design and simplicity.  1k CPU RAM, 3K VRAM.... No disk drives-- cassette only.  So limited, but elegant.  

The guys at the Ace forum are pushing me to try and build one--- one guy said he would program all the EPROMs for me and ship them.  It's something I want to do, but I believe you are right--- it is well beyond my skillset.

Perhaps I will commission one of the vets over there to build me one.  :)

The TI is still my favorite, by far.... I'm just interested in this little Ace computer... Don't know why, but I am.  :)

Thanks for talking sense into me, guys... I would have ended up with a big mess on my hands.

Firebrandmusic.net

---

From: Owen <[email-masked]>
Date: Sun, 27 Feb 2011 00:22:17 -0500

Okay, you got me...  What cool suggestions might you have for my first hardware project?  :) Should I buy a kit somewhere?  Someday I'm going to have to do some serious hardware work, and I don't want to be completely unprepared.  :)

Besides--- I want to build a /4a-Geneve-NES-SNES-Colecovision someday---- ;)

That board will be 10 feet long with a big ugly toggle knob that looks like the steering wheel from a Nash Rambler.... Wait--- I could actually USE an old Nash steering wheel for this project.... :)

(Alright, my insane drivel will stop now... Need sleep)

Firebrandmusic.net

---

From: Marc Hull <[email-masked]>
Date: Sat, 26 Feb 2011 21:27:37 -0800 (PST)

Get your feet wet first Owen.  Go to Main Bytes page and put a fast crystal with a switch in your console to start.  It's easy, fun and if you blow up your console.... rewarding (and I'll send you a new one.)  Go to Walmart or Radio Shack, buy yourself a soldering iron and cook some lead !  You can do it Owen... You can do it all night ;-)

Really,   it all starts with that first $8.00 iron and the pictures on Ron's site.......  No Kidding !

--- On Sat, 2/26/11, Owen <[email-masked]> wrote:

From: Owen <[email-masked]>
Subject: Re: [TI994A] OT: components for custom computer
To: "[email-masked]" <[email-masked]>
Date: Saturday, February 26, 2011, 10:24 PM

  

      Fair points, guys... 

Firebrandmusic.net

 

Regards,
Jon

    

 

1) purchase components

Z0         Z80  (cpu) 

Z26        74LS32 
Z27        74LS74 
Z28        74LS166 
Z29        74LS138 

U27        7805  (+5V reg) 

X1         6.5 MHz xtal 

Q1         2N2369 
Q2         2N3904 

D1-11      1N4148 

C1         39p ceramic 
C2         100p ceramic 
C3         47n 
C4         47p ceramic 
C5         - 
C6         47n 
C7         1u tantalum 
C8         2n2 
C9         100u electrolytic 
C10        100n 

C11,12     1u tantalum 
C13-21     100n 

R1         4k7 
R2         47k 
R3         1k5 
R4         1k5 
R5         12k 
R6         1k 
R7         1k8 
R8         270 
R9         220 

R10        10k 
R11-23     1k 
R24        10k 
R25        220k 
R26        330 
  
RN1,2      1k x 8 

L1 RF choke 

LS1 220r speaker

---

From: ti99_forever <[email-masked]>
Date: Sat, 26 Feb 2011 21:35:04 -0800 (PST)

I'd suggest buying a ZX81 kit... they are still available.http://www.zx81kit.com/

--- On Sat, 2/26/11, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] OT: components for custom computer
To: [email-masked]
Date: Saturday, February 26, 2011, 10:29 PM

 

 

1) purchase components

Z0         Z80  (cpu) 

Z26        74LS32 
Z27        74LS74 
Z28        74LS166 
Z29        74LS138 

U27        7805  (+5V reg) 

X1         6.5 MHz xtal 

Q1         2N2369 
Q2         2N3904 

D1-11      1N4148 

C1         39p ceramic 
C2         100p ceramic 
C3         47n 
C4         47p ceramic 
C5         - 
C6         47n 
C7         1u tantalum 
C8         2n2 
C9         100u electrolytic 
C10        100n 

C11,12     1u tantalum 
C13-21     100n 

R1         4k7 
R2         47k 
R3         1k5 
R4         1k5 
R5         12k 
R6         1k 
R7         1k8 
R8         270 
R9         220 

R10        10k 
R11-23     1k 
R24        10k 
R25        220k 
R26        330 
  
RN1,2      1k x 8 

L1 RF choke 

LS1 220r speaker

---

From: Owen Brand <[email-masked]>
Date: Sun, 27 Feb 2011 01:47:57 -0500

Thanks Marc.  I plan to do just such a thing.  I bought an 30 watt $11 iron
and some solder today...  I'm used to the gun for my wiring jobs, but I'm
pretty sure the iron will give me more precision.  I bought 1MM rosin core
solder... thinner than I'm used to, but it's pretty much the same stuff.

A friend has a bunch of blank boards and some components he's giving me to
start practicing precision soldering--- I don't want to hurt my TI.  =)

Of course, I DO have many TIs... Last I counted, 6.

While I was going through my gear today, I came across a very strange home
made cable/board.  I believe I got it from a farm lot up in Indiana, and it
was at the bottom of the box.  (Marc, this was the same lot I found the
CorComp 9900 disk controller as well)... I can't really accurately describe
it, but I'll try to take some pix and post them to Atariage... perhaps
someone could give me some clue about what I've got.  I also found about 15
CS1/CS2 cables and 5 or 6 joystick adapters.  It was a good day to
organize.  =)

On Sun, Feb 27, 2011 at 12:27 AM, Marc Hull <[email-masked]> wrote:

>
>
>   Get your feet wet first Owen.  Go to Main Bytes page and put a fast
> crystal with a switch in your console to start.  It's easy, fun and if you
> blow up your console.... rewarding (and I'll send you a new one.)  Go to
> Walmart or Radio Shack, buy yourself a soldering iron and cook some lead !
> You can do it Owen... You can do it all night ;-)
>

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 27 Feb 2011 02:08:49 -0600

Hey Owen, speaking of suggestions, have you started writing a song for this year's Faire??? 

To: [email-masked]
From: [email-masked]
Date: Sun, 27 Feb 2011 00:22:17 -0500
Subject: Re: [TI994A] OT: components for custom computer

Firebrandmusic.net

  

  

 
1) purchase components

Z0         Z80  (cpu) 

U27        7805  (+5V reg) 

X1         6.5 MHz xtal 

Q1         2N2369 
Q2         2N3904 

D1-11      1N4148 

C1         39p ceramic 
C2         100p ceramic 
C3         47n 
C4         47p ceramic 
C5         - 
C6         47n 
C7         1u tantalum 
C8         2n2 
C9         100u electrolytic 
C10        100n 
C11,12     1u tantalum 
C13-21     100n 

R1         4k7 
R2         47k 
R3         1k5 
R4         1k5 
R5         12k 
R6         1k 
R7         1k8 
R8         270 
R9         220 
R10        10k 
R11-23     1k 
R24        10k 
R25        220k 
R26        330 
  
RN1,2      1k x 8 

L1 RF choke 

LS1 220r speaker

---

From: ti99_forever <[email-masked]>
Date: Sun, 27 Feb 2011 00:36:51 -0800 (PST)

Now there's an idea!
How about using the TI as a "musical instrument" in this year's song? Get one of Marc's SID cards for the TI and start learning how to program your own SID music?

--- On Sun, 2/27/11, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] OT: components for custom computer
To: [email-masked]
Date: Sunday, February 27, 2011, 3:08 AM

 

 

 

#yiv1658903180 .yiv1658903180ExternalClass .yiv1658903180ecxygrp-photo-title
{clear:both;font-size:smaller;height:15px;overflow:hidden;text-align:center;width:75px;}
#yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxygrp-photo
{background-position:center;background-repeat:no-repeat;background-color:white;border:1px solid black;height:62px;width:62px;}
#yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxphoto-title 
         a, #yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxphoto-title a:active, #yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxphoto-title a:hover, #yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxphoto-title a:visited
{text-decoration:none;}
#yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxattach-table div.yiv1658903180ecxattach-row
{clear:both;}
#yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxattach-table div.yiv1658903180ecxattach-row div
{float:left;}
#yiv1658903180 .yiv1658903180ExternalClass p
{clear:both;padding:15px 0 3px 0;overflow:hidden;}
#yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxygrp-file
{width:30px;}
#yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxattach-table div.yiv1658903180ecxattach-row div div a
{text-decoration:none;}
#yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxattach-table div.yiv1658903180ecxattach-row div div span
{font-weight:normal;}
#yiv1658903180 .yiv1658903180ExternalClass div.yiv1658903180ecxygrp-file-title
{font-weight:bold;}

Firebrandmusic.net

  

  

 
1) purchase components

Z0         Z80  (cpu) 

U27        7805  (+5V reg) 

X1         6.5 MHz xtal 

Q1         2N2369 
Q2         2N3904 

D1-11      1N4148 

C1         39p ceramic 
C2         100p ceramic 
C3         47n 
C4         47p ceramic 
C5         - 
C6         47n 
C7         1u tantalum 
C8         2n2 
C9         100u electrolytic 
C10        100n 
C11,12     1u tantalum 
C13-21     100n 

R1         4k7 
R2         47k 
R3         1k5 
R4         1k5 
R5         12k 
R6         1k 
R7         1k8 
R8         270 
R9         220 
R10        10k 
R11-23     1k 
R24        10k 
R25        220k 
R26        330 
  
RN1,2      1k x 8 

L1 RF choke 

LS1 220r speaker

---

From: Owen <[email-masked]>
Date: Sun, 27 Feb 2011 08:20:12 -0500

I actually started writing one last year for the 2010 Faire--- but life came and swallowed my dreams and put me in Georgia instead of Chi-town that week.  I was too broken-hearted to finish the song.  But--- perhaps this year will be different.  :)

Firebrandmusic.net

---

From: fdos <[email-masked]>
Date: Sun, 27 Feb 2011 14:12:06 -0700

Owen,

Why?  I have 30 or so extra hardware projects that I won't get to in 
this decade, with all the extra time you have on your hands, you should 
be able to handle 4 or 5 of them this year.  Let me know. ;-)

Bill S

-- 
Bill R Sullivan (FDOS)
Go Forth+ or X4th99

---

From: [email-masked]
Date: Sun, 27 Feb 2011 14:45:39 -0800

Owen;

I would reccommend the micro-Kim. It is available from Briel Computers. They also have some other interesting kits available. It is totally different from the ZX80 kits, but it is easy to assemble and gives you some experience with one of the first of the computers available. Plus it may have had a Forth written for it which may still be available.

Regards,
Michael

> I know this is OT, but I'm interested in hearing what you all think... is this plausible?  I am a complete hardware novice, but I know these components can be had for about $50 from an online elect…

"Never take life too seriously. Nobody gets out alive anyway."

---

From: Owen <[email-masked]>
Date: Sun, 27 Feb 2011 17:59:51 -0500

Bill--- I'm actually buying an electronics kit at the local hobby shop Monday... Found it online.  It comes with a PCB, printed layout and instruction set, a microprocessor, small LCD screen, a few other components.... I want to build a Jupiter Ace.  But I need to start somewhere--- I will also (on Marc's suggestion with Ron's pics and notes) be modding one of my backup TI's with a faster crystal as well. (Not my "baby" though.... Not til I'm confident)--- Today I wrapped my oak desktop with newspaper and duct tape... :) I feel like a kid again when I used to build model airplanes with my dad on that same desk.  :)

As to your hardware projects, I'd love to help--- but I would more than likely screw up anything you sent me--- :) I'm still a complete beginner when it comes to electronics work.

Firebrandmusic.net

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 27 Feb 2011 17:11:13 -0600

Maybe if you build the Jupiter Ace you could rewrite Lemonade Stand in Forth?  Kill 3 birds with one stone.  :)

To: [email-masked]
From: [email-masked]
Date: Sun, 27 Feb 2011 17:59:51 -0500
Subject: Re: [TI994A] OT: components for custom computer

Firebrandmusic.net

  

Owen,

Bill S

-- 
Bill R Sullivan (FDOS)
Go Forth+ or X4th99

---

From: Owen <[email-masked]>
Date: Sun, 27 Feb 2011 18:36:26 -0500

If it's possible inside 3k of RAM (VDP and CPU) then I'll do it!!!!  It would probably have to revert to the old style "numbers-only" design though--- the character sets are bizarre and it is NOT easy to define graphics on the Ace.  It's all in binary pattern data, not hex... :)

I could try it though--- in emulation first. I run the 81 (eighty one) emulator and it does a pretty good job.  You need a pic of the keyboard layout though because some specialty characters are funny.  For instance the (") is FCTN+P.

Firebrandmusic.net

---

From: "Tursi" <[email-masked]>
Date: Sun, 27 Feb 2011 17:01:18 -0800

>I could try it though--- in emulation first. I run the 81 (eighty one) 
>emulator and it does a pretty good job.  You need a pic of the keyboard 
> >layout though because some specialty characters are funny.  For instance 
>the (") is FCTN+P.

That's the same keypress as for the TI. ;)

---

From: Owen <[email-masked]>
Date: Sun, 27 Feb 2011 20:03:47 -0500

And without your PS2 emulation in Classic99, I would need a pic of the TI keyboard too.  :)

Firebrandmusic.net