Subject: Rare TI-99 hardware II

From: mark wills <[email-masked]>
Date: Tue, 1 Mar 2011 12:04:43 +0000 (GMT)

While we're talking about weird hardware, have a look at this bad boy which can 
be found lurking in my PEB box...

http://markwills.co.uk/ti

????

---

From: Owen Brand <[email-masked]>
Date: Tue, 1 Mar 2011 13:15:26 -0500

That thing's awesome, Mark.  Looks like some kind of alien craft part.  =)