Subject: 2 April 2011 version of chdman.exe

From: "wmlucid" <[email-masked]>
Date: Sun, 08 May 2011 14:42:12 -0000

I am trying to use: 

chdman -createuncomphd inputhd.raw output.chd [ident.bin] [inputoffs [cylinders heads sectors [sectorsize [hunksize]]]]

I want to create a new blank hard drive image.

What is indent.bin and inputsoff?  I've searched for info on the web and have not found anything about these terms.

I am using: 1984 cylinders 16 heads 32 sectors 256 sectorsize and 4096 hunksize.  All I see is the result of typing chdman and pressing enter.

Wm

---

From: Tony Knerr <[email-masked]>
Date: Sun, 08 May 2011 14:51:09 -0400

This works for me:

chdman.exe -createuncomphd inputhd.raw output.hd 0 1984 16 32 256

Make sure chdman.exe and inputhd.raw are in the same directory. I was having problems until I looked at an example and saw that 0 had to be after the filenames and before any of the other options.

Tony

On 5/8/2011 10:42 AM, wmlucid wrote:
>
> I am trying to use:
>
> chdman -createuncomphd inputhd.raw output.chd [ident.bin] [inputoffs 
> [cylinders heads sectors [sectorsize [hunksize]]]]
>
> What is indent.bin and inputsoff? I've searched for info on the web 
> and have not found anything about these terms.
>
> I am using: 1984 cylinders 16 heads 32 sectors 256 sectorsize and 4096 
> hunksize. All I see is the result of typing chdman and pressing enter.
>
> Wm
>

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 08 May 2011 20:22:18 -0000

> > and have not found anything about these terms.

The mentioned parameters are not meaningful for TI hard disk images. CHD (Compressed Hunks of Data) is a container format for mass storage devices like CDs, Laserdiscs, and hard disks.

The ident.bin is a metadata file which we do not use for TI HDs. Could be that they are used for PC IDE drives. It describes additional information about the drive, like geometry and other operation paramaters.  

The inputoffs tells where the data starts in the raw sector dump file, which is 0 in our case. This is especially important when you want to import existing data into the hard disk image.

Michael