Subject: Bank Switch Mini

From: "Matthew" <[email-masked]>
Date: Tue, 28 Sep 2010 18:39:25 -0000

Another project I think most here would be interested in:

http://codehackcreate.com/archives/208

Matthew

---

From: mark wills <[email-masked]>
Date: Tue, 28 Sep 2010 21:54:41 +0000 (GMT)

Jaw dropping! See the site for my comments!

mark

----- Original Message ----
> From: Matthew <[email-masked]>
> To: [email-masked]
> Sent: Tue, 28 September, 2010 19:39:25
> Subject: [TI994A] Bank Switch Mini
> 
> ------------------------------------
> 
> Yahoo!  Groups Links
> 
> 
> 
>

---

From: "hexbus" <[email-masked]>
Date: Wed, 29 Sep 2010 02:33:20 -0000

Same here... I am in awe of the innovation popping up in this space.  Jim and Tursi working on the V6 board, your innovation with the daughter board for existing TI carts, and some other boards Jim is also working on... as well as Marc Hull's experimentation with the Sid Blaster, etc.

I am truly impressed...

Jon

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> > From: Matthew <matthew@...>

---

From: Owen Brand <[email-masked]>
Date: Wed, 29 Sep 2010 02:16:36 -0400

This mini-add-on board is freaking genius....  I'm thoroughly blown  
away... I have nothing more to add.  :) just awesome.

Owen Brand

http://firebrandmusic.net
http://www.Opry99er.com

On Sep 28, 2010, at 10:33 PM, "hexbus" <[email-masked]> wrote:

> Same here... I am in awe of the innovation popping up in this space.  
> Jim and Tursi working on the V6 board, your innovation with the  
> daughter board for existing TI carts, and some other boards Jim is  
> also working on... as well as Marc Hull's experimentation with the  
> Sid Blaster, etc.
>
> I am truly impressed...
>
> Jon
>

---

From: mark wills <[email-masked]>
Date: Wed, 29 Sep 2010 13:56:28 +0000 (GMT)

Yeah the TI 'scene' is really getting some steam behind it now...

Next step... TCP/IP STACK!

MWUH HA HA HA

(any takers?)

No?

----- Original Message ----
> From: hexbus <[email-masked]>
> Sent: Wed, 29 September, 2010 3:33:20
> Subject: [TI994A] Re: Bank Switch Mini
> 
> Same here... I am in awe of the innovation popping up in this space.  Jim  and 
>Tursi working on the V6 board, your innovation with the daughter board for  
>existing TI carts, and some other boards Jim is also working on... as well as  
>Marc Hull's experimentation with the Sid Blaster, etc.
> 
> I am truly  impressed...
> 
> Jon
>

---

From: "James W." <[email-masked]>
Date: Wed, 29 Sep 2010 16:18:20 -0000

Mark!

Shame on you! Use the gcc compiler that has been made available and use the code from Contiki! 

Unless for some reason TI'ers wish to reinvent everything and then complain that it never gets done.

<Rant mode off>

Seriously, take advantage of the new GCC compiler and use open-source to provide what we need. Just ask Gary, G2 Project, how much was open-source; except for the 9995 simulation.

So, the TCP/IP stack exists already-someone needs to compile and test.

James

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> > From: hexbus <jon@...>
> > --- In [email-masked], mark wills  <markrobertwills@> wrote:
> > >
> > > > From: Matthew <matthew@>

---

From: Owen Brand <[email-masked]>
Date: Wed, 29 Sep 2010 13:59:31 -0400

Yea, the GCC thread over at Atariage is pretty cool.  I haven't  
seenanyone try any compilations yet, so I don't know how well it  
works, but the developer is seeking feeback/input.  :)

Owen Brand

On Sep 29, 2010, at 12:18 PM, "James W." <[email-masked]> wrote:

> Seriously, take advantage of the new GCC compiler and use open- 
> source to provide what we need. Just ask Gary, G2 Project, how much  
> was open-source; except for the 9995 simulation.
>

---

From: mark wills <[email-masked]>
Date: Wed, 29 Sep 2010 18:55:01 +0000 (GMT)

Hiya James

Good call on the GCC compiler. I thought it was no more than a work in progress 
though?

Didn't think we could compile actual *stuff* with it yet? It's been a while 
since I saw any posts about it on Atariage, though I admit I only check in every 
few days...

?

Mark

----- Original Message ----
> From: James W. <[email-masked]>
> Sent: Wed, 29 September, 2010 17:18:20
> Seriously, take advantage of the new GCC compiler and use  open-source to 
>provide what we need. Just ask Gary, G2 Project, how much was  open-source; 
>except for the 9995 simulation.
>

---

From: "Matthew" <[email-masked]>
Date: Wed, 29 Sep 2010 18:55:55 -0000

You are never going to run a TCP/IP stack on the 99/4A itself, unless you don't plan on the machine doing anything else other than managing the communications.  If it was as easy as "compile and test" then we would have done it already.

The only way the 99/4A is going to get a *usable* network connection is via a device (microcontroller or FPGA) that handles the communications and makes the bytes of data available to the 99/4A via a memory-mapped port or DSR.

Saying "all the tools are available open source" is like saying all the parts you need are available at Mouser or DigiKey.  You still have to bring it all together and know what you are doing at a very low level.

Matthew

--- In [email-masked], "James W." <jwkrych@...> wrote:
> > > From: hexbus <jon@>

---

From: "James W." <[email-masked]>
Date: Wed, 29 Sep 2010 19:55:37 -0000

Matthew,

That is not true.

Is the 99/4A less powerful than a Commodore 64?

I'd recommend you look at the Contiki site and see for yourself before you make a statement like that.

http://www.sics.se/contiki/

But I do give you this, prior to the GCC compiler being made available, there was no way to compile the open source code for the TCP/IP stack.

But that is not a problem now.

Here are specs on the Contiki system:

"Contiki is a small, open source, highly portable, multitasking computer operating system developed for use on a number of memory-constrained networked systems ranging from 8-bit computers to embedded systems on microcontrollers, including sensor network motes. The name Contiki comes from Thor Heyerdahl's famous Kon-Tiki raft.

Despite providing multitasking and a built-in TCP/IP stack, Contiki only needs a few kilobytes of code and a few hundred bytes of RAM. A full system, complete with a graphical user interface, needs about 30 kilobytes of RAM."

"Contiki is designed for embedded systems with small amounts of memory. A typical Contiki configuration consumes 2 kilobytes of RAM and 40 kilobytes of ROM.

Contiki consists of an event-driven kernel on top of which application programs are dynamically loaded and unloaded at runtime. Contiki processes use light-weight protothreads that provide a linear, thread-like programming style on top of the event-driven kernel."

http://en.wikipedia.org/wiki/Contiki

Let's not be so close-minded as to what others have done.

And finally, don't tell me it can't be done:

http://120.146.162.194:8080/

James

--- In [email-masked], "Matthew" <matthew@...> wrote:
> --- In [email-masked], "James W." <jwkrych@> wrote:
> >
> > Mark!
> >

---

From: Owen Brand <[email-masked]>
Date: Wed, 29 Sep 2010 16:07:05 -0400

I thought the Commodore had 64k of built-in RAM... I'm a bit out of  
the loop on C64 specs--

I'd love to see this thing running on a TI, though.... Maybe with an  
HRD?

Owen Brand

On Sep 29, 2010, at 3:55 PM, "James W." <[email-masked]> wrote:

> But I do give you this, prior to the GCC compiler being made  
> available, there was no way to compile the open source code for the  
> TCP/IP stack.
>
> "Contiki is a small, open source, highly portable, multitasking  
> computer operating system developed for use on a number of memory- 
> constrained networked systems ranging from 8-bit computers to  
> embedded systems on microcontrollers, including sensor network  
> motes. The name Contiki comes from Thor Heyerdahl's famous Kon-Tiki  
> raft.
>
> Despite providing multitasking and a built-in TCP/IP stack, Contiki  
> only needs a few kilobytes of code and a few hundred bytes of RAM. A  
> full system, complete with a graphical user interface, needs about  
> 30 kilobytes of RAM."
>
> "Contiki is designed for embedded systems with small amounts of  
> memory. A typical Contiki configuration consumes 2 kilobytes of RAM  
> and 40 kilobytes of ROM.
>
> Contiki consists of an event-driven kernel on top of which  
> application programs are dynamically loaded and unloaded at runtime.  
> Contiki processes use light-weight protothreads that provide a  
> linear, thread-like programming style on top of the event-driven  
> kernel."
>
> > You are never going to run a TCP/IP stack on the 99/4A itself,  
> unless you don't plan on the machine doing anything else other than  
> managing the communications. If it was as easy as "compile and test"  
> then we would have done it already.
> >
> > The only way the 99/4A is going to get a *usable* network  
> connection is via a device (microcontroller or FPGA) that handles  
> the communications and makes the bytes of data available to the  
> 99/4A via a memory-mapped port or DSR.
> >
> > Saying "all the tools are available open source" is like saying  
> all the parts you need are available at Mouser or DigiKey. You still  
> have to bring it all together and know what you are doing at a very  
> low level.
> >
> > Matthew
> >
> >

---

From: "Matthew" <[email-masked]>
Date: Wed, 29 Sep 2010 20:51:40 -0000

> Is the 99/4A less powerful than a Commodore 64?

That is questionable.  The C64 is certainly better designed and has more RAM.

> I'd recommend you look at the Contiki site and see for yourself before you make a statement like that.

I have looked at it.

> But I do give you this, prior to the GCC compiler being made available, there was no way to compile the open source code for the TCP/IP stack.

The GCC port for the 9900 is not done or ready to compile anything like contiki.

> Despite providing multitasking and a built-in TCP/IP stack, Contiki only needs a few kilobytes of code and a few hundred bytes of RAM. A full system, complete with a graphical user interface, needs…

We don't have 30K of RAM.  We have 256 bytes on an system without a PEB, and only 32K with the PEB/32K expansion.  Are you willing to limit you applications to 2K?  I'm not.

As for the 16K of VRAM, it is not usable by GCC, it can't figure out stuff like RAM controlled via a custom chip and auto-incrementing addresses.  GCC needs addressable memory to set things up.

This is where a system like the C64, Apple, etc. kicks our ass.

> "Contiki is designed for embedded systems with small amounts of memory. A typical Contiki configuration consumes 2 kilobytes of RAM and 40 kilobytes of ROM.

You are not talking about using an embedded device...

> Contiki consists of an event-driven kernel on top of which application programs are dynamically loaded and unloaded at runtime. Contiki processes use light-weight protothreads that provide a linear…

Wonderful.  I don't want a kernel, GUI, or threads to slow down my game, which is mostly what people would do on a networked system like a 99/4A, C64, etc.  Some might use an email or a news list app as a novelty, but you will only have 2K to write that app...

> Let's not be so close-minded as to what others have done.

I'm not.  But it is not as simple as "compiling contiki".

> http://120.146.162.194:8080/

I did not say it could not be done.  I said:

"don't plan on the machine doing anything else other than managing the communications."

And I still stand by that statement, and the minimum specs for contiki support that statement.

That C64 driven website is neat, but you forgot something.  Where do you suppose they plug in the network cable to that unmodified C64??  Here are the specs of that system:

Specs - C64: Rev-A 1982 Ram: 64k - CPU: 8bit 6510 1MHz - Ethernet Adaptor:  FB-NET

That last part: "Ethernet Adapter", that is a pretty important piece, and something we currently don't have for the 99/4A.

http://cbm8bit.com/fotios/fbnet.php

The TQFP chip on that adapter is more powerful than the C64 or 99/4A ever was, and as long as you have to have an adapter like that, you may as well off-load the TCP/IP stack too and let the host computer worry about "using" the data instead of managing the communications.

I'm all for having a network connection on the 99/4A, but just having a C compiler and "compiling contiki" is not going to get it done.

Doing a NIC *is* on my list of hardware to make, but it is down the line a bit, after the F18A and 9900-FPGA.  If anyone else does it first, then great, but we need the hardware first.

Matthew

---

From: "Dan" <[email-masked]>
Date: Wed, 29 Sep 2010 17:03:17 -0400

I know it's not a Ti but i belive the current maintainer of mess for the Ti 
( Michael Zapf ) , wrote a tcp/ip stack for the geneve. He used to have a 
page documenting it.
dan

----- Original Message ----- 
From: "Matthew" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, September 29, 2010 2:55 PM
Subject: [TI994A] Re: Bank Switch Mini

> You are never going to run a TCP/IP stack on the 99/4A itself, unless you 
> don't plan on the machine doing anything else other than managing the 
> communications.  If it was as easy as "compile and test" then we would 
> have done it already.
>
> The only way the 99/4A is going to get a *usable* network connection is 
> via a device (microcontroller or FPGA) that handles the communications and 
> makes the bytes of data available to the 99/4A via a memory-mapped port or 
> DSR.

---

From: fdos <[email-masked]>
Date: Wed, 29 Sep 2010 15:07:39 -0700

How about 1MB of SAMS?

Bill S

On 9/29/2010 1:51 PM, Matthew wrote:
> --- In [email-masked], "James W."<jwkrych@...>  wrote:
>>
>> Matthew,
>>
>> That is not true.
>>

---

From: fdos <[email-masked]>
Date: Wed, 29 Sep 2010 14:57:03 -0700

This is correct.

Bill S

On 9/29/2010 2:03 PM, Dan wrote:
> From: "Matthew"<[email-masked]>
> To:<[email-masked]>

---

From: "James W." <[email-masked]>
Date: Wed, 29 Sep 2010 22:27:34 -0000

Matthew,

I never said to do this an an unexpanded TI. 

Even 9600 baud with pure text and TCP/IP is usable. 

And, I wouldn't speak for the GCC author unless he told you himself it isn't ready for Contiki. In fact, all we need is the TCP/IP PORTION. 

James

--- In [email-masked], fdos <fdosbrs@...> wrote:
> > --- In [email-masked], "James W."<jwkrych@>  wrote:
> >>
> >> Matthew,
> >>
> >> That is not true.
> >>

---

From: tursi <[email-masked]>
Date: Wed, 29 Sep 2010 18:21:35 -0700 (PDT)

> Next step... TCP/IP STACK!

To run what software? Ping? To connect over what interface? Serial? Then 
you need to implement SLIP too. And you still have no software for it.

Never seemed worth it to me. :)

But there may be other ways.... ;)

---

From: tursi <[email-masked]>
Date: Wed, 29 Sep 2010 18:26:00 -0700 (PDT)

> You are never going to run a TCP/IP stack on the 99/4A itself, unless 
> you don't plan on the machine doing anything else other than managing 
> the communications.  If it was as easy as "compile and test" then we 
> would have done it already.

Even though I don't think it's worth doing due to lack of interface and 
software, I disagree with this. I spent a lot of time looking at uIP and 
it should fit nicely on the 4A. You could build a dedicated program with 
uIP built in and it would run fine on the TI, IIRC last time I looked it 
needed about 2k of ROM and a hundred bytes of RAM.

I agree though, that the most practical approach is an external device to 
handle it. Long time listers will note that I've been talking about doing 
it for years. I'm closer than I've been in the past. ;)

---

From: tursi <[email-masked]>
Date: Wed, 29 Sep 2010 18:28:16 -0700 (PDT)

> Contiki consists of an event-driven kernel on top of which application 
> programs are dynamically loaded and unloaded at runtime. Contiki 
> processes use light-weight protothreads that provide a linear, 
> thread-like programming style on top of the event-driven kernel."

My problem with Contiki was primarily that all apps need to be compiled as 
well... I wish that they used a byte code approach instead, so you could 
run the apps natively. I suppose if someone wanted to take over all the 
management and provide a distribution, it would be pretty nice - they have 
Contiki running on some impressively small systems.