Subject: TI ROM checksum

From: Insane Multitasker <[email-masked]>
Date: Mon, 18 Apr 2011 01:23:51 -0500

In "TI994A Intern" there is a reference to a checksum at address 0x1FFC.  I've tried to compute the checksum but haven't succeeded in getting a match.   Anyone else notice this or try to compute it with a match?

---

From: ti99_forever <[email-masked]>
Date: Sun, 17 Apr 2011 23:46:02 -0700 (PDT)

Is it a 16-bit checksum, or 32-bit (including the word after)?And, no I have not...

--- On Mon, 4/18/11, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: [TI994A] TI ROM checksum
To: [email-masked]
Date: Monday, April 18, 2011, 2:23 AM

---

From: "Tursi" <[email-masked]>
Date: Mon, 18 Apr 2011 01:18:19 -0700

>In "TI994A Intern" there is a reference to a checksum at address 0x1FFC. 
>I've tried to compute the checksum but haven't >succeeded in getting a 
>match.   Anyone else notice this or try to compute it with a match?

heh, never noticed that before either. But nothing in the system actually 
uses the checksum!

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 18 Apr 2011 11:42:05 -0500

On the Geneve, images of the TI ROM/GROM are used for emulation.  I encountered
a problem where XB music files were locking my system up tight. After comparing
and disassembling a working and non-working ROM, I discovered the ROM file
I've been using all these years has 3 words of the CFI (Float to Integer) code corrupted, 
and the only time it really came to light was with negative numbers, which many
song programs use in the CALL SOUND command... arrrgghhhhh
 
The other three words are in the cassette routine which is of no value on a Geneve. 
 
I wonder if this bug explains some seemingly sporadic issues I've had with
other programs.  Hmmm

> To: [email-masked]
> From: [email-masked]
> Date: Mon, 18 Apr 2011 01:18:19 -0700
> Subject: Re: [TI994A] TI ROM checksum
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: fdos <[email-masked]>
Date: Mon, 18 Apr 2011 10:45:42 -0700

Tim,

Maybe a "bug" sniffing dog could find all of the remaining MDOS & GPL 
bugs for you. :-)  I hope you have a better day than I'm having.

Bill S

On 4/18/2011 9:42 AM, Insane Multitasker wrote:
>>> I've tried to compute the checksum but haven't>succeeded in getting a

-- 
Bill R Sullivan (FDOS)
Go Forth+ or X4th99