Subject: Floppy Problem

From: "BobK" <[email-masked]>
Date: Mon, 02 May 2011 02:58:29 -0000

Maybe someone can figure this out, I have been trying for two days now.
My PEB floppy drives (#2 & #3 ,#1 is O.K.) have for some reason forgotten that they are Double sided  double density, I can read the first side O.K. but when I try to load a program from the second side it sounds like the drive is seeking and not finding anything. 
I have a MYARC 80 Track controller, I tried formatting a few disk (DS\DD)and it goes alright for a bit then fails on a error, I get a message that my drive is a single sided drive and should note that when formatting a disk. 

Everything was working great Friday night and when I tried it Saturday morning it was doing this stuff, no lightning, power surges, dropped PEB, never took the drives out of the unit, just turned off the console and the PEB and that was it.

 I did have problems a few months ago with #1 drive and bought 2 new drives changed them out and everything was OK.
Any Ideas?
Thanks
Bob K.

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Mon, 2 May 2011 23:57:54 +0200

Check the floppy cable. Floppy Drive Pin # 32 is "Head Select". If that 
connection doesn't work, you will come across problems like yours.

However, if all four drives don't work, you may suspect the Myarc Disk 
Controller itself. A "cold soldering" case in your Disk Controller can 
sometimes be solved by carefully reheating all the dubious solder spots. 
It that doesn't work either, you may want to look around for hardware 
repair.

Paolo Bagnaresi

----- Original Message ----- 
From: "BobK" <[email-masked]>
To: <[email-masked]>
Sent: Monday, May 02, 2011 4:58 AM
Subject: [TI994A] Floppy Problem

Maybe someone can figure this out, I have been trying for two days now.
My PEB floppy drives (#2 & #3 ,#1 is O.K.) have for some reason forgotten 
that they are Double sided  double density, I can read the first side O.K. 
but when I try to load a program from the second side it sounds like the 
drive is seeking and not finding anything.
I have a MYARC 80 Track controller, I tried formatting a few disk 
(DS\DD)and it goes alright for a bit then fails on a error, I get a 
message that my drive is a single sided drive and should note that when 
formatting a disk.

Everything was working great Friday night and when I tried it Saturday 
morning it was doing this stuff, no lightning, power surges, dropped PEB, 
never took the drives out of the unit, just turned off the console and the 
PEB and that was it.

 I did have problems a few months ago with #1 drive and bought 2 new 
drives changed them out and everything was OK.
Any Ideas?
Thanks
Bob K.

---

From: "BobK" <[email-masked]>
Date: Mon, 02 May 2011 23:57:45 -0000

I have changed the cable already and am now taking the controller out of the PEB to check for cold connections as last night I took out the #2 drive and installed a spare floppy drive I have and now the #1 drives sounds like it is trying to tear it's guts out,#2 still acts like it did and #3 drive doesn't work at all. So I am going to assume that something is wrong with the cable or the controller pins as the only thing I could have done to effect the drives was connect the #2 drive and maybe pulled on the cable. 

Thanks for the suggestion.

Bob K. 

--- In [email-masked], "Paolo Bagnaresi" <paul.bagnaresi@...> wrote:
> From: "BobK" <bkaspar@...>

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 2 May 2011 20:53:21 -0500

do you have another controller card?  test the drives & cable with it if you can.
 
> To: [email-masked]
> From: [email-masked]
> Date: Mon, 2 May 2011 23:57:45 +0000
> Subject: [TI994A] Re: Floppy Problem
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: "BobK" <[email-masked]>
Date: Tue, 03 May 2011 02:17:03 -0000

Yes as a matter of fact I do have another controller, another MYARC but no 80 track chip, I installed it and everything seems to be working the only difference is that the floppy drives run so quiet that at first I thought they were not even running, SMOOOOOTH!!!

 Now I have to find out what is wrong with the original controller, I noticed that the area around the power tranister is pretty dark like it got hot, actually HOT to be more precise it isn't charred but it did get toasty at some time.

If I can't find anything obvious I will order a new one and try replacing that. I just remembered that I did change the power supply to a PC power supply and I see that I didn't jumper the regulator on the floppy controller (Nor any of the other cards I would bet.), will that do the "Crispy" thing?
Thanks-
Bob K.

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Tue, 3 May 2011 09:07:05 +0200

> If I can't find anything obvious I will order a new one and try 
> replacing that.
> I just  remembered that I did change the power supply to a PC power 
> supply and
> I see that I didn't jumper the regulator on the floppy controller (Nor 
> any of
> the other cards I would bet.), will that do the "Crispy" thing?

No, it won't. If anything, is the other way around. Possibly, the FDC 
doesn't get enough power as it is arranged now. Try jumper the voltage 
regulator (I believe is the 7805) and see if it works again. The "dark" 
you see on the board is probably due to time when you did not have the PC 
power supply installed.

Let us know.

Paolo Bagnaresi

----- Original Message ----- 
From: "BobK" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, May 03, 2011 4:17 AM
Subject: [TI994A] Re: Floppy Problem

Yes as a matter of fact I do have another controller, another MYARC but no 
80 track chip, I installed it and everything seems to be working the only 
difference is that the floppy drives run so quiet that at first I thought 
they were not even running, SMOOOOOTH!!!

 Now I have to find out what is wrong with the original controller, I 
noticed that the area around the power tranister is pretty dark like it 
got hot, actually HOT to be more precise it isn't charred but it did get 
toasty at some time.

If I can't find anything obvious I will order a new one and try replacing 
that. I just remembered that I did change the power supply to a PC power 
supply and I see that I didn't jumper the regulator on the floppy 
controller (Nor any of the other cards I would bet.), will that do the 
"Crispy" thing?
Thanks-
Bob K.

---

From: mark wills <[email-masked]>
Date: Tue, 3 May 2011 09:48:13 +0100 (BST)

Floppy problem?

Try Viagra.

(Sorry, couldn't resist!)

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Tue, 3 May 2011 12:43:18 +0200

Being a pharmacist, I can assure you your therapy will not solve Bob K.'s 
problems.

I couldn't resist either :-)

Paolo Bagnaresi
----- Original Message ----- 
From: "mark wills" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, May 03, 2011 10:48 AM
Subject: Re: [TI994A] Floppy Problem

Floppy problem?

Try Viagra.

---

From: "BobK" <[email-masked]>
Date: Wed, 04 May 2011 01:38:16 -0000

That's OK, I probably wouldn't care about the drive problem anymore.
I wouldn't have time to put question on the board anymore.

I took the PEB out of service and installed my CorComp Micro Expansion  Unit, I have just about given up on the PEB setups, I was doing alright until I shut the system down and restarted again and the drives (All 3 This Time.) starting jumping the heads around and making noises like the disks were going to come flying out, I said a few prayers over the piece of S#*t and tossed it out on the back porch, maybe sitting out there in the summer heat will help it cure itself. Look for a deal at Goodwill stores near me if it doesn't.

Thanks for your advice.

--- In [email-masked], "Paolo Bagnaresi" <paul.bagnaresi@...> wrote:
> From: "mark wills" <markrobertwills@...>

---

From: [email-masked]
Date: Wed, 4 May 2011 02:25:42 +0000 (UTC)

Doing that on restart sound exactly like a problem I had. It was a bad power supply. Voltage was unstable so very strange behavior resulted. 

The clue was it only did it on power up or restarts. I had several Disk Controller cards though so when all of them did it that was the real clue. 

----- Original Message ----- 
From: "BobK" <[email-masked]> 
To: [email-masked] 
Sent: Tuesday, May 3, 2011 6:38:16 PM 
Subject: [TI994A] Re: Floppy Problem 

Thanks for your advice. 

--- In [email-masked] , "Paolo Bagnaresi" <paul.bagnaresi@...> wrote: 
> To: < [email-masked] >

---

From: "BobK" <[email-masked]>
Date: Wed, 04 May 2011 05:17:02 -0000

That is what I am figuring, I will get around to replacing the power supplies  sometime and see if it makes a differance. I have changed just about everything else and that is pretty much all that is left, I thought perhaps it was the floppy cable but I bought a new one and got the same results,different controllers, TI-Corcomp-Myarc(2) all the same thing. I will stick with the CorComp 9900 system for awhile,atleast until I really miss the CALL DIR() command on the MYARC then I will tear everything apart and start from scratch.

I wanted to try putting my cards in someone else PEB box around here but I guess everyone has got rid off theirs or just don't care any more, we were the TICHIPS but I guess Glenn, Rich Polivka and I are the only TIers in the Cleveland area anymore.:-)

Bob K.

--- In [email-masked], richgilbertson@... wrote:
> --- In [email-masked] , "Paolo Bagnaresi" <paul.bagnaresi@> wrote: 
> > 
> > From: "mark wills" <markrobertwills@>

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Wed, 4 May 2011 10:56:33 +0200

Bob, did you jumpered (bypassed) the Voltage Regulator (7805) on the Myarc 
FDC?

If you haven't done that yet, the power supply in your FDC will not be 
right. The 7805 cannot output the required 5 Volts if it is fed with just 
5 Volts in input, as it is now from the PC power supply.

Please try that before givening up.

Paolo Bagnaresi

----- Original Message ----- 
From: "BobK" To: <[email-masked]>
Sent: Wednesday, May 04, 2011 7:17 AM
Subject: [TI994A] Re: Floppy Problem

That is what I am figuring, I will get around to replacing the power 
supplies  sometime and see if it makes a differance. I have changed just 
about everything else and that is pretty much all that is left, I thought 
perhaps it was the floppy cable but I bought a new one and got the same 
results,different controllers, TI-Corcomp-Myarc(2) all the same thing. I 
will stick with the CorComp 9900 system for awhile,atleast until I really 
miss the CALL DIR() command on the MYARC then I will tear everything apart 
and start from scratch.

I wanted to try putting my cards in someone else PEB box around here but I 
guess everyone has got rid off theirs or just don't care any more, we were 
the TICHIPS but I guess Glenn, Rich Polivka and I are the only TIers in 
the Cleveland area anymore.:-)

Bob K.

--- In [email-masked], richgilbertson@... wrote:
>
> Doing that on restart sound exactly like a problem I had. It was a bad 
> power supply. Voltage was unstable so very strange behavior resulted.
>
> The clue was it only did it on power up or restarts. I had several Disk 
> Controller cards though so when all of them did it that was the real 
> clue.
>
>
>
> I took the PEB out of service and installed my CorComp Micro Expansion 
> Unit, I have just about given up on the PEB setups, I was doing alright 
> until I shut the system down and restarted again and the drives (All 3 
> This Time.) starting jumping the heads around and making noises like the 
> disks were going to come flying out, I said a few prayers over the piece 
> of S#*t and tossed it out on the back porch, maybe sitting out there in 
> the summer heat will help it cure itself. Look for a deal at Goodwill 
> stores near me if it doesn't.
>
> Thanks for your advice.
>

---

From: ti99_forever <[email-masked]>
Date: Wed, 4 May 2011 02:07:08 -0700 (PDT)

The specs for the power supply replacement I've read tell you to use 12v for both the 12v and 5v connections... So, if he used the 5v, that would be too low.

--- On Wed, 5/4/11, Paolo Bagnaresi <[email-masked]> wrote:

> From: Paolo Bagnaresi <[email-masked]>
> Subject: Re: [TI994A] Re: Floppy Problem
> Date: Wednesday, May 4, 2011, 4:56 AM
> > --- In [email-masked]
> , "Paolo Bagnaresi" <paul.bagnaresi@> 
> > wrote:
> > >
> > > Being a pharmacist, I can assure you your therapy
> will not solve Bob 
> > > K.'s
> > > problems.
> > >
> > >
> > > To: < [email-masked]
> >
>     [email-masked]
> 
> 
>

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Wed, 4 May 2011 13:31:30 +0200

Mmmh, 12 V input for 5 V  output. Wouldn't that put an excessive burden on 
the cooling system (heatsink) of the Myarc FDC, that was not particularly 
efficient by design?

Paolo Bagnaresi

----- Original Message ----- 
From: "ti99_forever" To: <[email-masked]>
Sent: Wednesday, May 04, 2011 11:07 AM
Subject: Re: [TI994A] Re: Floppy Problem

The specs for the power supply replacement I've read tell you to use 12v 
for both the 12v and 5v connections... So, if he used the 5v, that would 
be too low.

---

From: ti99_forever <[email-masked]>
Date: Wed, 4 May 2011 04:45:58 -0700 (PDT)

I've asked that often, with no answer. I know the PEB outputs 8v unswitched, and the pc outputs 12v switched. Does that make a difference?

Another question I had was if the 5v was not enough for a 5v regulator, why would 12v be enough for a 12v regulator?

--- On Wed, 5/4/11, Paolo Bagnaresi <[email-masked]> wrote:

> Date: Wednesday, May 4, 2011, 7:31 AM
> Mmmh, 12 V input for 5 V 
> output. Wouldn't that put an excessive burden on 
> > If you haven't done that yet, the power supply in your
> FDC
> > will not be
> > right. The 7805 cannot output the required 5 Volts if
> it is
> > fed with just
> > That is what I am figuring, I will get around to
> replacing
> > the power
> > about everything else and that is pretty much all that
> is
> > left, I thought
> > perhaps it was the floppy cable but I bought a new one
> and
> > got the same
> > results,different controllers, TI-Corcomp-Myarc(2) all
> the
> > same thing. I
> > will stick with the CorComp 9900 system for
> awhile,atleast
> > until I really
> > miss the CALL DIR() command on the MYARC then I will
> tear
> > everything apart
> > and start from scratch.
> >
> > I wanted to try putting my cards in someone else PEB
> box
> > around here but I
> > guess everyone has got rid off theirs or just don't
> care
> > any more, we were
> > the TICHIPS but I guess Glenn, Rich Polivka and I are
> the
> > only TIers in
> > > Doing that on restart sound exactly like a
> problem I
> > had. It was a bad
> > > power supply. Voltage was unstable so very
> strange
> > behavior resulted.
> > >
> > > The clue was it only did it on power up or
> restarts. I
> > had several Disk
> > > Controller cards though so when all of them did
> it
> > that was the real
> > > clue.
> > >
> > >
> > >
> > > That's OK, I probably wouldn't care about the
> drive
> > problem anymore.
> > > I wouldn't have time to put question on the
> board
> > anymore.
> > >
> > > I took the PEB out of service and installed my
> CorComp
> > Micro Expansion
> > > Unit, I have just about given up on the PEB
> setups, I
> > was doing alright
> > > until I shut the system down and restarted again
> and
> > the drives (All 3
> > > This Time.) starting jumping the heads around
> and
> > making noises like the
> > > disks were going to come flying out, I said a
> few
> > prayers over the piece
> > > of S#*t and tossed it out on the back porch,
> maybe
> > sitting out there in
> > > the summer heat will help it cure itself. Look
> for a
> > deal at Goodwill

---

From: "Tursi" <[email-masked]>
Date: Wed, 4 May 2011 09:38:18 -0700

>for both the 12v and 5v connections... So, if he used >the 5v, that would 
>be too low.

You /can/ go either way, though if you use 5v then you must bypass all the 
5v regulators in the PEB cards and the flex cable. It's safer to run 12v on 
both lines - I did both ways and like the 12v approach better since the 
cards can run unmodified.

---

From: Tony Knerr <[email-masked]>
Date: Wed, 04 May 2011 12:46:29 -0400

I've measured a number of Pboxes' output voltages, and most of them 
output about 16v for the 8v line, so connecting the
12v line of the PC power supply to that line is actually less stressful 
on the 5v regulators. The 12v regulators actually drop
the voltage down to about 11v with a 12v input, but it is not a problem 
in most cases. I've heard that some RS232s are flakey
and need the 12v regulators removed, but it is not my experience. I've 
been using PC power supplies for about 15 years
connected this way with no ill effects.

Tony

ti99_forever wrote:
>  
>
> I've asked that often, with no answer. I know the PEB outputs 8v 
> unswitched, and the pc outputs 12v switched. Does that make a difference?
>
> Another question I had was if the 5v was not enough for a 5v 
> regulator, why would 12v be enough for a 12v regulator?
>

---

From: "Tursi" <[email-masked]>
Date: Wed, 4 May 2011 09:48:44 -0700

I can't speak for the Myarc FDC, but I've run in that configuration:

-TI Flex cable interface (obviously)
-TI Disk controller
-HRD-16
-Thierry's IDE controller (heat sink on 5V regulator is mandatory though, it 
does fail without!)
-TI RS232/PIO
-Marc's SID Blaster

.. and I /think/ I had a pCode card in there at some point, too, but I can't 
remember for sure if that was after I did the mod.

As long as there is a heatsink on the regulator, it should take it. Doesn't 
have to be a huge one in my experience.

-----Original Message----- 
From: Paolo Bagnaresi
Sent: Wednesday, May 04, 2011 4:31 AM
To: [email-masked]
Subject: Re: [TI994A] Re: Floppy Problem

Paolo Bagnaresi

---

From: "Tursi" <[email-masked]>
Date: Wed, 4 May 2011 09:54:58 -0700

>unswitched, and the pc outputs 12v switched. Does that >make a difference?

Sorry, Ben, I've never seen you ask that question. I've been running that 
configuration for years.

So the answer is, it's not, it under-volts the 12v line. These regulators 
usually have about a 1 to 3v drop. So when the 5v line drops to 2v, the 
circuitry doesn't work.

Not very many cards use the 12v line for electronics. The 32k card seems to 
be able to tolerate the difference, and I believe the RS232 card just passes 
it through (? I can't remember if I checked, I just remember it was my main 
concern when I did the mod, and it still talks to the PC). And of course it 
doesn't affect the floppy drives which definitely need the 12v. In cases 
where the circuit does expect 12v, you can expect higher current draw. The 
power supply on PCs is usually pretty beefy on the 12v line, maybe that's 
why it tends to work. It's not ideal, but in practice it seems to succeed.

---

From: fdos <[email-masked]>
Date: Wed, 04 May 2011 10:03:55 -0700

WARNING!

If you use just the 12VDC line from a PC power supply be sure that it's 
VA rating will handle both your 12VDC & 5VDC PEB requirements.  I know, 
I have the most power hungry TI/Geneve PEB cards made.  They are capable 
of toasting circuit boards to a crisp if proper heat-sinks and cooling 
is not used, so most users will not burn out two PC switching power 
supplies as I have done in the distant past.  Neither TI PEB has a spare 
card slot, and the Geneve is in a Miller Communications PC desktop case 
with modified switching power supply (invented specifically for the 
Myarc Geneve).

Bill S

On 5/4/2011 9:38 AM, Tursi wrote:
>> for both the 12v and 5v connections... So, if he used>the 5v, that would
>> be too low.
>

-- 
Bill R Sullivan (FDOS)
Go Forth+ or X4th99

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Wed, 4 May 2011 19:04:39 +0200

Ok Bob, then you have a real hardware problem on your Myarc FDC. Sorry, I 
can't be of further help. I wish you all the luck for an easy fixing.

Paolo Bagnaresi

---

From: "BobK" <[email-masked]>
Date: Thu, 05 May 2011 02:44:40 -0000

Actually, no I did not jumper them as I was following the instructions that stated Tim Tesch suggested that instead of bypassing the regulators simply wire the ATX +12 to both the TI+16v and +8v lines and let the card regulators take the 12v down to the required voltages. 

Is this now excepted as being incorrect?
Thanks
Bob K.

--- In [email-masked], "Paolo Bagnaresi" <paul.bagnaresi@...> wrote:
> --- In [email-masked], richgilbertson@ wrote:
> >
> > From: "BobK" <bkaspar@>

---

From: "BobK" <[email-masked]>
Date: Thu, 05 May 2011 02:53:10 -0000

I am planning to tear the PEBoxs apart and change the power supplies, I think I have a bad solder joint or something, at least it is worth a try and I want to figure this out. I'll just take the box apart and look and it will agrievate the ol lady to end when I take over her work table and spread parts all over, got to keep her blood pumping you know. :-)

Bob K.

---

From: Insane Multitasker <[email-masked]>
Date: Wed, 4 May 2011 22:29:42 -0500

My primary concern with jumpering regulators is that it takes but once to forget the card is jumpered.  Install the card in the wrong PEB and *poof*.  I have fixed my share of blown traces and fried logic chips - it is not something to relish.  Then there is the occasional regulator problem induced by jumpering across the input/output leads which, similar to thermal shutdown, can cause sporadic problems.
 
There are others who have modified their supplies to feed 12v to the bus (+12v to +5,+12 and -12v to -12) with success. I was an early adopter but not the first, as I followed Mike Maksimik's lead and jumpered my cards.  I ran my BBS on a 5-slot backplane and a PC power supply, with jumpered cards, for a few years.  
 
After seeing the problems jumpering could cause and having some troubles of my own, Don Walden helped me install new regulators in all my cards and we set up my case the "new" way.  I've changed cases since then but my Geneve has run nearly 10 years non-stop with this setup.   
 
No need to take my word for it -- the community at large has adopted and proved this works so long as your supply is sufficient. 
 
Good luck with your endeavors...
 
> Date: Thu, 5 May 2011 02:44:40 +0000