Subject: tidir question

From: Insane Multitasker <[email-masked]>
Date: Sat, 18 Sep 2010 00:44:34 -0500

I am trying to move a file from a "v9t9 disk" to the PC, with a TIFILES header, using TIDIR 4.2m.  I want to transfer the file from the PC to my TI via serial connection.

I can copy the file from the disk image and it shows up OK on the PC hard disk. But no matter what I do, I can't seem to get a TIFILES header added to the file.  I've tried converting from V9T9 to TIFILES, no dice. 

Anyone have suggestions?  Programmer amnesia?

tim

---

From: Owen Brand <[email-masked]>
Date: Sat, 18 Sep 2010 02:34:38 -0400

If it's a BASIC or XB file, you can view it in TIDir and copy an paste  
directly into Classic99.  Classic99 files are TIFILES, essentially.   
In any case, my process typically goes as follows:

1) DL .DSK file
2) Extract files using TI99Dir
3) Test new FIAD file(s) in Classic99
4) transfer using MFM with option for "Use TIFILES header"

If you have been unsuccessful to this point and have done all these  
steps, then your dilemma may be beyond my expertise.  :).

Classic99 can be a poor-man's format converter... As I said earlier, I  
often "View File Contents" using TI99Dir, copy and paste into  
Classic99, then SAVE.

once you've extracted the files from DSK, try to test it out in  
Classic99.  If it runs there, chances are pretty good it'll transfer  
fine and run on real iron.

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Sep 18, 2010, at 1:44 AM, Insane Multitasker <[email-masked]>  
wrote:

> I am trying to move a file from a "v9t9 disk" to the PC, with a  
> TIFILES header, using TIDIR 4.2m.  I want to transfer the file from  
> the PC to my TI via serial connection.
>
> I can copy the file from the disk image and it shows up OK on the PC  
> hard disk. But no matter what I do, I can't seem to get a TIFILES  
> header added to the file.  I've tried converting from V9T9 to  
> TIFILES, no dice.
>

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 18 Sep 2010 01:51:23 -0500

Thanks, Owen.  TIDIR creates the file on the PC with the FIAD info -- I can see that by looking at the raw data. But I can't seem to get the TIFILES header on it instead.  I thought there was a setting to force aTIFILES header on any file TIDIR "copied" but I am just not seeing it.  Looks like time for some sleep, I'll poke around more tomorrow ;)

To: [email-masked]
From: [email-masked]
Date: Sat, 18 Sep 2010 02:34:38 -0400
Subject: Re: [TI994A] tidir question

If it's a BASIC or XB file, you can view it in TIDir and copy an paste directly into Classic99.  Classic99 files are TIFILES, essentially.  In any case, my process typically goes as follows:
1) DL .DSK file2) Extract files using TI99Dir3) Test new FIAD file(s) in Classic994) transfer using MFM with option for "Use TIFILES header"
If you have been unsuccessful to this point and have done all these steps, then your dilemma may be beyond my expertise.  :). 
Classic99 can be a poor-man's format converter... As I said earlier, I often "View File Contents" using TI99Dir, copy and paste into Classic99, then SAVE.  
once you've extracted the files from DSK, try to test it out in Classic99.  If it runs there, chances are pretty good it'll transfer fine and run on real iron.  

Owen Brand
       **webmaster** http://www.Opry99er.com
On Sep 18, 2010, at 1:44 AM, Insane Multitasker <[email-masked]> wrote:

    

tim

---

From: "Michael Zapf" <[email-masked]>
Date: Sat, 18 Sep 2010 11:24:13 -0000

Hello Tim,

try my tifiles.jar which I recently uploaded to the files section. I don't know whether it solves your problem, but it's worth a try.

java -classpath tifiles.jar -h  = help
java -classpath tifiles.jar <command> <args> as shown in help

Michael

---

From: Owen Brand <[email-masked]>
Date: Sat, 18 Sep 2010 09:35:16 -0400

I do not know what it is, precisely, that you are trying to transfer,  
but I have never had any issue going from .DSK to hardware.  MFM adds  
the header on transfer, if I'm not mistaken....

Good luck, and keep us updated on the progress... This is a subject  
that is of some interest these days--- with games being written in  
emulation and transferred to iron.  Perhaps I have just been extremely  
lucky..  :)

As a side note, I have posted 4 transfer videos to YouTube--- two deal  
with TI->PC transfers and two (the most recent) deal with PC->TI.  I  
do not remember if I started with .DSK in the videos or started with  
FIAD.  In any case, you may wish to take a look, just as a reference.   
I doubt I showed anything in the videos that you don't know--- but  
sometimes it is helpful to review rudiments.  :)

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Sep 18, 2010, at 2:51 AM, Insane Multitasker <[email-masked]>  
wrote:

> Thanks, Owen.  TIDIR creates the file on the PC with the FIAD info  
> -- I can see that by looking at the raw data. But I can't seem to  
> get the TIFILES header on it instead.  I thought there was a setting  
> to force aTIFILES header on any file TIDIR "copied" but I am just  
> not seeing it.  Looks like time for some sleep, I'll poke around  
> more tomorrow ;)
>
>
> If it's a BASIC or XB file, you can view it in TIDir and copy an  
> paste directly into Classic99.  Classic99 files are TIFILES,  
> essentially.  In any case, my process typically goes as follows:
>
> 1) DL .DSK file
> Classic99 can be a poor-man's format converter... As I said earlier,  
> I often "View File Contents" using TI99Dir, copy and paste into  
> Classic99, then SAVE.
>

---

From: "fredkaal" <[email-masked]>
Date: Sat, 18 Sep 2010 14:27:07 -0000

It is Simple,

Select the V9T9 file you want to give the TIFILES header.
Now select in the menu: TOOLS->Convert V9T9 file to TIFILEs file or just press CTRL-7.

Fred ;-)

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:
> From: owenbrand@...
> On Sep 18, 2010, at 1:44 AM, Insane Multitasker <insane_m@...> wrote:
> 
> 
> 
> 
> 
> 
>  
> 
> 
> 
>     
>       
>       
>       
> 
>

---

From: Owen Brand <[email-masked]>
Date: Sat, 18 Sep 2010 10:36:37 -0400

Yea, that was going to be my first suggestion, but Tim said he had  
tried that already.  "no dice" he said...

Perhaps he has an old version or......

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Sep 18, 2010, at 10:27 AM, "fredkaal" <[email-masked]> wrote:

> not seeing it. Looks like time for some sleep, I'll poke around more  
> tomorrow ;)
> >
> > 1) DL .DSK file2) Extract files using TI99Dir3) Test new FIAD file 
> (s) in Classic994) transfer using MFM with option for "Use TIFILES  
> header"
> > If you have been unsuccessful to this point and have done all  
> these steps, then your dilemma may be beyond my expertise. :).
> > Classic99 can be a poor-man's format converter... As I said  
> earlier, I often "View File Contents" using TI99Dir, copy and paste  
> into Classic99, then SAVE.
> > I can copy the file from the disk image and it shows up OK on the  
> PC hard disk. But no matter what I do, I can't seem to get a TIFILES

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 18 Sep 2010 12:23:48 -0500

I used the option, Fred, but the file was not converting.  Then it dawned on me
that I was mis-reading the drive letters and was accessing a copy of the file
from another drive   <sheepish grin>   

Any chance of a "Copy as TIFILES" option versus "Copy as V9t9" when you
are poking around in the code down the road?  :)))

I got the file copied just fine.  Thanks to you and the others who replied!

> From: [email-masked]
> Date: Sat, 18 Sep 2010 14:27:07 +0000
> Subject: [TI994A] Re: tidir question
> 
> It is Simple,
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>