Subject: Re: [TI994A] Re: TurboForth Benchmarks

From: mark wills <[email-masked]>
Date: Sun, 6 Feb 2011 19:35:27 +0000 (GMT)

I think that's a great result! Nice one!

On Sun, 06 Feb 2011 19:31 GMT Stuart wrote:

>On my system takes around 6-7 seconds. Obviously delayed by the speed of printing the numbers over the RS-232 serial interface ... ;-)  ;-)
>
>Stuart.
>
>--- In [email-masked], mark wills <markrobertwills@...> wrote:
>>
>> Just substitute 1- with 1 -
>> 
>> That's a 1 a space and a minus sign. That should do it.
>> 
>> Mark
>> 
>> 
>> 
>> 
>> ----- Original Message ----
>> > From: Stuart <ti99@...>
>> > To: [email-masked]
>> > Sent: Sun, 6 February, 2011 19:16:48
>> > Subject: [TI994A] Re: TurboForth Benchmarks
>> > 
>> > Mark, how can I rewrite the 7th line to avoid the "1-" which isn't in my 
>> >version  of FIG Forth?
>> > 
>> > Stuart.
>> > 
>> > --- In [email-masked], mark wills  <markrobertwills@> wrote:
>> > >
>> > > Aint no thang!
>> > > 
>> > > : PRIMES ( n - )
>> > >   2 SWAP 2 . 3 . 5 
>> > >   DO DUP  DUP * I < 
>> > >   IF 1+ THEN 
>> > >   1 OVER 1+ 3 
>> > >   DO J I MOD 0= 
>> > >   IF 1- LEAVE THEN 
>> > >   2  +LOOP 
>> > >   IF I . THEN 
>> > >   2 +LOOP 
>> > >   DROP  ;
>> > > 
>> > > Test it with:
>> > > 
>> > > 1000 PRIMES
>> > > 
>> > >  Rock on brotha!
>> > > 
>> > > Mark
>> > > 
>> > > 
>> > > 
>> > > 
>> > > 
>> > > ----- Original Message ----
>> > > > From: Stuart  <ti99@>
>> > > > To: [email-masked]
>> > > >  Sent: Sun, 6 February, 2011 18:21:43
>> > > > Subject: [TI994A] Re:  TurboForth Benchmarks
>> > > > 
>> > > > Could you list the program, and  I'll give FIG Forth on the 990 a go  ...
>> > > > 
>> > > >  Stuart.
>> > > > 
>> > > > --- In [email-masked], mark  wills  <markrobertwills@> wrote:
>> > > > >
>> > > > > 
>> > > > > 
>> > > > >  ----Forwarded Message----
>> > >  > > From: markrobertwills@
>> > > > > To: [email-masked]
>> > >  > >  Sent: Sun, 06 Feb 2011 18:11 GMT
>> > > > > Subject:  Benchmarks
>> > > > > 
>> > > > >  Bob and I have been doing  some benchmarks.
>> > > > > 
>> > > > > A popular benchmark   is finding prime numbers, so we thought it might be 
>> >fun 
>> >
>> > > >to  benchmark finding,  and displaying primes up to 1000, since a routine 
>> >for 
>> >
>> > > >this is already published  in the wycove forth book.
>> > >  > > 
>> > > > > The test yielded the following   results:
>> > > > > 
>> > > > > TI forth: 10 seconds
>> > > >  > Wycove: 8 seconds
>> > > > >  Turboforth: 2 seconds
>> > >  > > 
>> > > > > The primes test is a good example because  it  tests:
>> > > > > * looping efficiency 
>> > > > > * math  computation 
>> > > > > *  stack juggling 
>> > > > > *  displaying numbers (successive division)
>> > > > > 
>> > > > > So  it's looking like turboforth is approximately 4 times faster than  
>> >wycove, 
>> >
>> > > >and 5 times faster than TI forth! 
>> > > >
>> > > > > 
>> > > > > Wowsers!
>> > > > > 
>> > > > > Bob also tested  copying blocks between different drives, to copy 40  
>> >blocks 
>> >
>> > >  >between floppy drives: 1 minute 20 seconds. (the disk drives being the  
>> > > >bottleneck)
>> > > > > 
>> > > > > To copy between  RAM disks: 12 seconds... not  bad!
>> > > > > 
>> > > > >  Mark
>> > > > > 
>> > > > > On Thu, 03 Feb 2011 18:02 GMT   rmcarmany@ wrote:
>> > > > > 
>> > > > > >I'll make an  announcement when they  have been debugged and are ready 
>> >for  
>> >
>> > >  > > >distribution.
>> > > > >  > 
>> > > > >  >Bob  Carmany
>> > > > > >
>> > > > > >
>> > > >  > >In a  message dated 2/3/2011 12:57:49 P.M. Eastern Standard  Time,  
>> > > > >  >rod.vanorden@ writes:
>> > > > >  >
>> > > > > >
>> > > > > >
>> > > > >   >
>> > > > > >Bob:
>> > > > > >I would like to buy one of  the TurboForth  Carts for the TI when you  
>> >are 
>> >
>> > > > >  >ready.
>> > > > > >How much,  and where do I send the  payment?
>> > > > > > 
>> > > > > > 
>> > > > > > 
>> > > > > >Rod Van Orden
>> > > > > >San Diego CA
>> > >  > > >
>> > > > >  >
>> > > > > >
>> > > >  > >
>> > > > > >
>> > > > >  >
>> > > >  >
>> > > > 
>> > > > 
>> > > > 
>> > > > 
>> > > >  ------------------------------------
>> > > > 
>> > > > Yahoo!   Groups Links
>> > > > 
>> > > > 
>> > > > 
>> > >  >
>> > >
>> > 
>> > 
>> > 
>> > 
>> > ------------------------------------
>> > 
>> > Yahoo!  Groups Links
>> > 
>> > 
>> > 
>> >
>>
>
>
>
>
>------------------------------------
>
>Yahoo! Groups Links
>
>
>

---

From: mark wills <[email-masked]>
Date: Sun, 6 Feb 2011 19:41:10 +0000 (GMT)

Agonized over pretty much every line of assembler!

Inner interpreter in pad RAM, registers in pad RAM, interrupt dispatcher in pad RAM, plus a clever system for displaying numbers, and the majority of forth words coded in assembler, rather than forth...

...still pleasantly surprised though.

On Sun, 06 Feb 2011 19:22 GMT Stuart wrote:

>So how have you got TurboForth so fast Mark? Is it purely down to coding efficiency, or do you have other tricks up your sleeve?
>
>
>> :-)
>> <blush>
>> >From: "rmcarmany@..." <rmcarmany@...>
>> >Sent: Sun, 6 February, 2011 18:33:16
>> >Subject: Re: [TI994A] Re: TurboForth Benchmarks
>> >
>> >  
>> >
>> >All,
>> > 
>> >Using Mark's TurboForth and the code:
>> > 
>> >: TEST 20000 FOR NEXT ;
>> > 
>> >The elapsed time between typing in TEST <enter> and the re-appearance  of the 
>> >cursor (end of execution) is between 3 and 4 seconds. (Sorry, Mark, I  couldn't 
>> >resist sharing this one!)
>> > 
>> >Bob Carmany 
>> > 
>> >In a message dated 2/6/2011 1:21:54 P.M. Eastern Standard Time,  
>> >ti99@... writes: