Subject: Myarc 512K memory expansion DSR?

From: "Michael Zapf" <[email-masked]>
Date: Thu, 02 Sep 2010 22:02:34 -0000

Hi,

while rewriting parts of the TI emulation in MESS I studied the Myarc 512K memory expansion manual and was surprised that there seems to be a DSR ROM. This DSR is not considered in the emulation, so does anyone have the ROM and the schematics of the Myarc 512K?

Second, is it correct that the base CRU address is >1000 for the card? I found that the card also had an entry for CRU >1900, but this may be a wrong line, just to be dropped.

Michael

---

From: fdos <[email-masked]>
Date: Thu, 02 Sep 2010 15:35:23 -0700

Michael,

It's been a long time since I've used a Myarc 512K card (lost years 
ago), so my memory may be a bit off.  The so-called DSR code (or just 
the 128KOS bank-switching part) is really transferred to the Myarc XB II 
Level 4 cartridge which is just 8K of SRAM or equivalent device (GK, 
etc.).  It's also true that it is located at CRU >1000, so the RAMDISK 
part can be set up to function as DSK1.

I only have a Foundation 128K card with Myarc EPROMS now, so I don't 
have the ability to setup the RAMDISK or Print Spooler any more, but as 
recall I did a CALL PART(128, 360, 24) when I had the Myarc 512K card. 
There are some other BASIC CALLs for selecting DSKx emulation, etc.

Bill S

On 9/2/2010 3:02 PM, Michael Zapf wrote:
> Second, is it correct that the base CRU address is>1000 for the card? I found that the card also had an entry for CRU>1900, but this may be a wrong line, just to be dropped.
>
> Michael
>
>

---

From: "Gary from O.P.A." <[email-masked]>
Date: Fri, 03 Sep 2010 02:13:01 -0000

I still have an working 512k plus both DSR's, the pre-xbii one and the 128kos one.

The card for some reasons maps at both cru address >1000 and >1900 with no jumpers or ways to change to disable this.

The DSR does an crappy ramdisk emulation and/or print spooler.

The original DSR allow you to partition the card between ramdisk and print spooler,

the later dsr for use with their xbii program, allow the user to reserve 128k for programs and then partition the rest between ramdisk and print spooler.

The card does full total 32k block pages, using cru bits. -- So the xbii module was just a plain 8k ram at >6000 to allow someplace for the banking code to go.

The later dsr called 128kos, looks for that totally blank module and if the card is parition to reserve the 128k of program space, it throws in a small program at the >6000 with module header to auto-load the rest of the xbii files so it can be display on the power-up screen.

If you want samples of the DSR or more in-depth knowledge, just ask away.

---

From: "Michael Zapf" <[email-masked]>
Date: Fri, 03 Sep 2010 10:08:09 -0000

Hello Gary,

> The card for some reasons maps at both cru address >1000 and >1900 with no jumpers or ways to change to disable this.

It seems that at least CRU >1000 is used for bank selection, but on bits 1 and 2, not 0. (I assume that the 512K version also uses bits 3 and 4 as well, but this was not explained in the manual.) 

Perhaps >1900 was used for the DSR? (Although this does not make too much sense, one could also use >1000, bit 0.)

So XBII was stored on the card ROM and expected a RAM cartridge in the cartridge slot? Well, this job could also be done by the SuperSpace cartridge, I suppose. (Just thinking whether it is required to create yet another cartridge type.)

Hmm ... if you have a dump of the pre and post versions it could be interesting to check whether the emulated card is working. 

OTOH, I should better drop this card emulation in MESS (and probably also the Foundation card, similar case) since we already have a working SuperAMS emulation there, and to fully use the Myarc card the ROMs would be required, and then there's the question where to get the ROMs, and all that copyright stuff ... Probably when we get a better handling of optional components we could revive it.

Michael

---

From: "Gary from O.P.A." <[email-masked]>
Date: Fri, 03 Sep 2010 14:53:47 -0000

The XBII was stored on floppy disk, and the module had just the 8K ram, with the DSR on the Myarc card, uploading an loader and header to the 8K >6000 space (if all blank) which added the title "128K OS" on the power-up screen, which if selected would then load the XBII files from floppy.

But it could in fact load other 128K programs, except XBII was the only one written.

If you still want I dig up the notes on the CRU bank switching for all versions of cards.

But yes, the ROM is a problem for MESS usage, unless we can totally get a written agreement from the DSR authors for a usage license.

Oh'tho, you don't need the DSR to do the bank-switching since it is CRU based, just for the RAMDISK or PRINT SPOOLER, but that would not be true emulation then.

---

From: "Beery" <[email-masked]>
Date: Fri, 03 Sep 2010 16:12:55 -0000

Michael,

I think Gary responded in a post.  XBII was on floppy.  I think it could also be loaded from ramdisk, so I think the search was done by DSK.something.  Just not sure anymore.

The module was all ram that had the module header written to during powerup of the console.

Myself, I liked version 2.10 better than 2.11 and 2.12.

I used to run a BBS from version 2.10 that wouldn't run under 2.11 and 2.12.  It was very fast, especially with the user database and some critical files on ramdisk.

Myself, I would love to see bidirectional RS232 support be able to be a pass thru to a WinVista COM port.

Beery

---

From: "epergrem" <[email-masked]>
Date: Fri, 03 Sep 2010 19:48:45 -0000

As I understand it, Richard Bell is now the owner of the Myarc copyrights.  That might be the place to start if you are interested in licensing anything.

Ernie

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 3 Sep 2010 17:23:42 -0500

Or emulated RS232 pass-through to an emulated UDS10 -  RS232 over Ethernet?  :)-

> To: [email-masked]
> From: [email-masked]
> Date: Fri, 3 Sep 2010 16:12:55 +0000
> Subject: [TI994A] Re: Myarc 512K memory expansion DSR?

---

From: "jhwhite_delphi" <[email-masked]>
Date: Fri, 03 Sep 2010 22:49:42 -0000

In the "TI Hardware Compendium" at:

ftp://ftp.whtech.com/datasheets%20and%20manuals/Hardware/ti%20hardware%20compendium.txt

you will find explanations of the CRU usage for the Myarc 512K.  Other memory cards, like the Corcomp 512K, are also described therein.

The manuals related to the Myarc 512K and Extended BASIC II are at the following:

http://pw2.netcom.com/~mjmw/online.htm#mymem

The Foundation 128K manual is located at:

ftp://ftp.whtech.com/datasheets%20and%20manuals/Hardware/Foundation/foundation%20128k%20card%20doc.pdf 

and it details that the card responds at DSR space CRU>1E00.

The hardware reason the Myarc 512K is at >1000 and >1900 is that address bits A4 and A7 are XOR'd in the logic that does the CRU decode.  I am not sure there is a software reason for >1900 to be used, but it could be to aid in support of print spooler operations.  I could be imagining that I knew that was the case at one time.

Jeff White
[email-masked]

---

From: "Gary from O.P.A." <[email-masked]>
Date: Sat, 04 Sep 2010 01:02:00 -0000

Yes, the XBII was fast, one of the reasons I got it, was to be able to run my TI-TOWER BBS better, which was alot of X/BASIC code, with just a bit added in assembly for some of the harder stuff, like modem auto-answer detect, and x/y/z modem transfer.

Come to think of it, if MESS emulator had the Myarc 512k in it, that would be one reason to make decide to try it out to be able to get my old TI-TOWER BBS running on a PC as-is without much changes.

I think you should connect with R. Bell regarding the copyright of the Myarc files, it would make the MESS system alot better!

--- In [email-masked], "Beery" <bmiller@...> wrote:
> --- In [email-masked], "Michael Zapf" <newsmail09@> wrote:
> >
> > 
> > 
> > Hello Gary,
> >

---

From: Owen Brand <[email-masked]>
Date: Sat, 4 Sep 2010 00:29:31 -0400

XBII... How much faster?  :) You got me curious... :)

Can someone link me to some info?  Did I understand correctly that  
XBII had a disk-based version?

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Sep 3, 2010, at 9:02 PM, "Gary from O.P.A." <[email-masked]>  
wrote:

> Yes, the XBII was fast, one of the reasons I got it, was to be able  
> to run my TI-TOWER BBS better, which was alot of X/BASIC code, with  
> just a bit added in assembly for some of the harder stuff, like  
> modem auto-answer detect, and x/y/z modem transfer.
>
> Come to think of it, if MESS emulator had the Myarc 512k in it, that  
> would be one reason to make decide to try it out to be able to get  
> my old TI-TOWER BBS running on a PC as-is without much changes.
>
> I think you should connect with R. Bell regarding the copyright of  
> the Myarc files, it would make the MESS system alot better!
>
> > I think Gary responded in a post. XBII was on floppy. I think it  
> could also be loaded from ramdisk, so I think the search was done by  
> DSK.something. Just not sure anymore.
> >
> > I used to run a BBS from version 2.10 that wouldn't run under 2.11  
> and 2.12. It was very fast, especially with the user database and  
> some critical files on ramdisk.
> >
> > > > The card for some reasons maps at both cru address >1000 and  
> >1900 with no jumpers or ways to change to disable this.
> > >
> > > It seems that at least CRU >1000 is used for bank selection, but  
> on bits 1 and 2, not 0. (I assume that the 512K version also uses  
> bits 3 and 4 as well, but this was not explained in the manual.)
> > >
> > > Perhaps >1900 was used for the DSR? (Although this does not make  
> too much sense, one could also use >1000, bit 0.)
> > >
> > > So XBII was stored on the card ROM and expected a RAM cartridge  
> in the cartridge slot? Well, this job could also be done by the  
> SuperSpace cartridge, I suppose. (Just thinking whether it is  
> required to create yet another cartridge type.)
> > >
> > > Hmm ... if you have a dump of the pre and post versions it could  
> be interesting to check whether the emulated card is working.
> > >
> > > OTOH, I should better drop this card emulation in MESS (and  
> probably also the Foundation card, similar case) since we already  
> have a working SuperAMS emulation there, and to fully use the Myarc  
> card the ROMs would be required, and then there's the question where  
> to get the ROMs, and all that copyright stuff ... Probably when we  
> get a better handling of optional components we could revive it.
> > >
> > > Michael
> > >
> >
>
>

---

From: Gregory McGill <[email-masked]>
Date: Fri, 3 Sep 2010 23:26:32 -0700

XBII requires a memory device and a 128kb memory card (myarc compat)  i have
it working with my gk and a 128 foundation card with the myarc compat roms

Greg

On Fri, Sep 3, 2010 at 9:29 PM, Owen Brand <[email-masked]> wrote:

> Can someone link me to some info?  Did I understand correctly that XBII had
> a disk-based version?
>
> Owen Brand
>
>        **webmaster**
> http://www.Opry99er.com
>
> On Sep 3, 2010, at 9:02 PM, "Gary from O.P.A." <[email-masked]> wrote:
>
>
>
> Yes, the XBII was fast, one of the reasons I got it, was to be able to run
> my TI-TOWER BBS better, which was alot of X/BASIC code, with just a bit
> added in assembly for some of the harder stuff, like modem auto-answer
> detect, and x/y/z modem transfer.
>
> Come to think of it, if MESS emulator had the Myarc 512k in it, that would
> be one reason to make decide to try it out to be able to get my old TI-TOWER
> BBS running on a PC as-is without much changes.
>
> I think you should connect with R. Bell regarding the copyright of the
> Myarc files, it would make the MESS system alot better!
>
>

---

From: "mizapf" <[email-masked]>
Date: Sat, 04 Sep 2010 12:27:31 -0000

Hello Beery,
 
> Myself, I would love to see bidirectional RS232 support be able to be a pass thru to a WinVista COM port.

on my list. I saw you also posted in the MESS forum. Sorry that currently no one seems to feel addressed. 

I'm currently rewriting the TI emulation core to a more modular design, so I cannot take care of that right now. When this will be done I'll check out the interfacing of MESS to the outside world, so probably by that time the serial port topic will come up again.

As I said, I took a note (http://www.ninerpedia.org/index.php/MESS_wish_list).

Michael

---

From: Owen Brand <[email-masked]>
Date: Sat, 4 Sep 2010 10:04:53 -0400

Hmm.... Very cool.  Kinda miss my old GK.  :). So, if I'm running an  
HRD and a GK, this would be sufficient?

Talking about the GK, is there any plan in the works to replicate the  
MG GK or Gramulator on a hardware level?  I know Michael has done some  
excellent work in emulation, but what about a card or chip that would  
do "SOME" of the GRAM functions...  It's a very cool thing to have  
access to--- just curious as to whether any kind of GRAM device could  
be put together to increase availability....

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Sep 4, 2010, at 2:26 AM, Gregory McGill <[email-masked]>  
wrote:

> XBII requires a memory device and a 128kb memory card (myarc  
> compat)  i have it working with my gk and a 128 foundation card with  
> the myarc compat roms
>
>
> Greg
>
>> Come to think of it, if MESS emulator had the Myarc 512k in it,  
>> that would be one reason to make decide to try it out to be able to  
>> get my old TI-TOWER BBS running on a PC as-is without much changes.
>>

---

From: "epergrem" <[email-masked]>
Date: Sat, 04 Sep 2010 14:50:18 -0000

Hi Owen,
Unfortunately not. You have to have either a Myarc 128K/512K card or a Foundation 128K card with the Myarc-compatible EPROM.  

Of course if you have a GK, then RXB2000 would work just find and that's suppose to be somewhat speedy.  BTW, using a non-standard version of XB is great for your own stuff, but if you're going to share it then you're sort of locked into sticking with the standard.

As for your last question.  The P-GRAM+ is probably the easiest GRAM emulator to reproduce since it's a p-box card and was sold as a DIY. That means no EPROMs, PALs, or other chips to program.  It doesn't have the GROM 0-1 emulation capabilities of other cards, but it's a decent card.

Ernie

---

From: Owen Brand <[email-masked]>
Date: Sat, 4 Sep 2010 11:05:53 -0400

Yes, I was asking specifically about these cards because it would be  
great to be able to tap into more memory-- but only if it were  
available to all.  I honestly am glad to hear of this limitation  
because it would have derailed my plans of assembly domination...  
<<Eeeeeeevil laugh forthcoming>>

MUAHAHAHAHA!!!!

My first assembly "project" is proving to be a monster of a "first  
go." Perhaps I should do something simpler than a full blown RPG or my  
first project.  :). I could do a cart version of Lemonade Stand... But  
that would require some cart boards.  I could put up a couple hundred  
bucks towards a run of a hundred boards from Jon's board company.  :)

Sorry to keep changing the subject line... :)

Owen Brand

        **webmaster**
http://www.Opry99er.com

On Sep 4, 2010, at 10:50 AM, "epergrem" <[email-masked]> wrote:

> Hi Owen,
> Unfortunately not. You have to have either a Myarc 128K/512K card or  
> a Foundation 128K card with the Myarc-compatible EPROM.
>
> Of course if you have a GK, then RXB2000 would work just find and  
> that's suppose to be somewhat speedy. BTW, using a non-standard  
> version of XB is great for your own stuff, but if you're going to  
> share it then you're sort of locked into sticking with the standard.
>
> As for your last question. The P-GRAM+ is probably the easiest GRAM  
> emulator to reproduce since it's a p-box card and was sold as a DIY.  
> That means no EPROMs, PALs, or other chips to program. It doesn't  
> have the GROM 0-1 emulation capabilities of other cards, but it's a  
> decent card.
>
> Ernie
>

---

From: Gregory McGill <[email-masked]>
Date: Sat, 4 Sep 2010 10:58:28 -0700

You can use a supercart also for XBII, all it needs is 8k at the cart port
for the cart side. The myarc ram card though is also required.

Greg

On Sat, Sep 4, 2010 at 7:04 AM, Owen Brand <[email-masked]> wrote:

>
>
> Hmm.... Very cool.  Kinda miss my old GK.  :). So, if I'm running an HRD
> and a GK, this would be sufficient?
>
> Talking about the GK, is there any plan in the works to replicate the MG GK
> or Gramulator on a hardware level?  I know Michael has done some excellent
> work in emulation, but what about a card or chip that would do "SOME" of the
> GRAM functions...  It's a very cool thing to have access to--- just curious
> as to whether any kind of GRAM device could be put together to increase
> availability....
>
> Owen Brand
>
>        **webmaster**
> http://www.Opry99er.com
>
> XBII requires a memory device and a 128kb memory card (myarc compat)  i
> have it working with my gk and a 128 foundation card with the myarc compat
> roms
>
> Greg
>
> On Fri, Sep 3, 2010 at 9:29 PM, Owen Brand < <[email-masked]>
> [email-masked]> wrote:
>
>>
>>
>> Can someone link me to some info?  Did I understand correctly that XBII
>> had a disk-based version?
>>
>> Owen Brand
>>
>>        **webmaster**
>> <http://www.Opry99er.com>http://www.Opry99er.com
>>
>> On Sep 3, 2010, at 9:02 PM, "Gary from O.P.A." < <[email-masked]>
>> [email-masked]> wrote:
>>
>>
>>

---

From: "Tursi" <[email-masked]>
Date: Sat, 4 Sep 2010 12:16:21 -0700

> be put together to increase availability....

Not me. I don't have a working GROM emulation on a single chip AVR or plans 
to work on the multiple GROM base support and write support this weekend. If 
I had I would have mentioned it a few times by now.

;)

Even if I did though, it wouldn't be a GK or Gramulator. It would be able to 
load GROM carts though, in theory.

---

From: "epergrem" <[email-masked]>
Date: Sat, 04 Sep 2010 22:01:46 -0000

You might consider the SAMS card. It can provide up to 1 MEG of switchable memory in the 32K space.  

Not everyone has one, but they are still available through Texin*Treasures.  

You would have to give some thought about how to use memory management, but it might help put those plans right back on track. ;-)

Ernie

Not everyone owns one, but it is available to everyone since Texin*Treasures still sells them.