Subject: Mechatronic XB - Silver Label

From: "epergrem" <[email-masked]>
Date: Sat, 02 Apr 2011 14:21:42 -0000

I found a copy of Mechatronic Extended Basic in Dave Connery's items.  It is the one with the silver label, not the XBII+ gold.

I had always assumed that it was just a licensed copy of TI Extended Basic, but it seems to contain both the high resolution graphics and the extended functions (CALL WAIT, VPOKE, etc.) of the XBII+ version.

The XBII+ manual indicates that XB owners can have their module upgraded, but I would have assumed that Mechatronics would have also placed a gold label on those carts as they did so.  Perhaps not.

Done anyone in the group know the history of Mechatronic Extended Basic module?  

Thanks,
Ernie

---

From: "Klaus L" <[email-masked]>
Date: Sun, 03 Apr 2011 21:16:52 -0000

Hi Ernie!

The first edition of the TI XB from Mechatronics came out in the year 1985 when there was no TI Extended Basic avaiable on the european market. There were more products simply unavaiable here - and for the first time prices for used hardware became higher than the retail prices for those very same products when still avaiable. That was one of the reasons why so many clubs started building their own hardware, and the other main reason was that commercial hardware was 200-250% of the prices in the USA. But back to the Mechatronics module! :)

Instead of the english manual book, that you all know, which came with the TI XB module here in europe as well, Mechatronics released XB for the first time ever with a german manual. The book they used was avaiable seperate as well and is called "TI Basic/Extended Basic für Anfänger und Fortgeschrittene", published by the Texas Instruments Learning Center. The title means something like "TI Basic/Extended Basic for Beginners and Advanced Users" and is a really great structured programming guide. It helped me learn basic when starting at the age of 11. :)

The content of the ROM is identical to the TI Extended Basic with the only difference in the Title on the Title Selection Screen.

There was an option for buyers of the first edition (silver) from Mechatronics to upgrade on the Mechatronics XB II+. If the upgrade included a label replacement is beyond my knowledge. Maybe there was a do-it-yourself upgrade kit without such a label. Or even the upgrade done by Mechatronics didn't include a label replacement. Or you have an example of a self burned Eprom chip.

The additional graphics commands included in the XBII+ are from the Apesoft Company, made in Austria (my country)! The graphic command package was avaiable seperate as well, as disk version and i think there even was a cassette version. The seperate graphics product came with an orange colored small binder including the manual and space for the disks.

I don't have the silver one but the XBII+ since friday! :)
On this weekend (TI meeting in germany) my brother and I got unbelievable much ti stuff for free.
The stuff will be spread in our club as well. You won't believe it but our club members demand an programming course from us.

Btw - if anyone is searching for the XBII+ cartridge, a guy from berlin (germany) offered it to me for 40 Euro.
I said no because I got one already but I can arrange contact for anyone interested, just give me a message.

Klaus

---

From: "Ksarul" <[email-masked]>
Date: Sun, 03 Apr 2011 20:07:31 -0400

I have both versions of the Mechatronics Extended BASIC cartridge—and my
Silver Label copy is pretty much a standard XB cartridge ala the versions
from MicroPal or Exeltek, while the Gold Label includes the ApeSoft routines
as an additional bonus.  I’m pretty sure Mechatronic would just switch out
the boards in the case when they upgraded, as I seem to remember that was
what they did for a couple of my friends who did the upgrade to their copies
back then.  

One other note on ApeSoft: the routines were sold on both Cassette and Disk
as Klaus thought he remembered (the cassette version was for the
MiniMemory).  They were also sold in the US by Amerisoft as Expanded
Graphics BASIC.     

Jim

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Klaus L
Sent: Sunday, April 03, 2011 5:17 PM
To: [email-masked]
Subject: [TI994A] Re: Mechatronic XB - Silver Label

Hi Ernie!

The first edition of the TI XB from Mechatronics came out in the year 1985
when there was no TI Extended Basic avaiable on the european market. There
were more products simply unavaiable here - and for the first time prices
for used hardware became higher than the retail prices for those very same
products when still avaiable. That was one of the reasons why so many clubs
started building their own hardware, and the other main reason was that
commercial hardware was 200-250% of the prices in the USA. But back to the
Mechatronics module! :)

Instead of the english manual book, that you all know, which came with the
TI XB module here in europe as well, Mechatronics released XB for the first
time ever with a german manual. The book they used was avaiable seperate as
well and is called "TI Basic/Extended Basic für Anfänger und
Fortgeschrittene", published by the Texas Instruments Learning Center. The
title means something like "TI Basic/Extended Basic for Beginners and
Advanced Users" and is a really great structured programming guide. It
helped me learn basic when starting at the age of 11. :)

The content of the ROM is identical to the TI Extended Basic with the only
difference in the Title on the Title Selection Screen.

There was an option for buyers of the first edition (silver) from
Mechatronics to upgrade on the Mechatronics XB II+. If the upgrade included
a label replacement is beyond my knowledge. Maybe there was a do-it-yourself
upgrade kit without such a label. Or even the upgrade done by Mechatronics
didn't include a label replacement. Or you have an example of a self burned
Eprom chip.

The additional graphics commands included in the XBII+ are from the Apesoft
Company, made in Austria (my country)! The graphic command package was
avaiable seperate as well, as disk version and i think there even was a
cassette version. The seperate graphics product came with an orange colored
small binder including the manual and space for the disks.

I don't have the silver one but the XBII+ since friday! :)
On this weekend (TI meeting in germany) my brother and I got unbelievable
much ti stuff for free.
The stuff will be spread in our club as well. You won't believe it but our
club members demand an programming course from us.

Btw - if anyone is searching for the XBII+ cartridge, a guy from berlin
(germany) offered it to me for 40 Euro.
I said no because I got one already but I can arrange contact for anyone
interested, just give me a message.

Klaus

--- In [email-masked] <mailto:TI994A%40yahoogroups.com> , "epergrem"
<epergrem@...> wrote:
>
> I found a copy of Mechatronic Extended Basic in Dave Connery's items. It
is the one with the silver label, not the XBII+ gold.
> 
> I had always assumed that it was just a licensed copy of TI Extended
Basic, but it seems to contain both the high resolution graphics and the
extended functions (CALL WAIT, VPOKE, etc.) of the XBII+ version.
> 
> The XBII+ manual indicates that XB owners can have their module upgraded,
but I would have assumed that Mechatronics would have also placed a gold
label on those carts as they did so. Perhaps not.