Subject: New version of TIImageTool

From: "Michael Zapf" <[email-masked]>
Date: Thu, 05 May 2011 20:27:54 -0000

Hello all,

I have just uploaded a new version of my TIImageTool, a Java-based tool which facilitates working with disk image files. Image files are used in emulators like MESS, holding the contents of real disks.

TIImageTool allows to import/export files from or to disk images, handles TIFILES files, allows to paste text into a new file on the image, check the allocation map of the disk, handles hard disk images, lists BASIC programs, disassembles assembler code, and more. Have a look at the included help file. 

You need to install Java support on your computer first. The zip package contains the JAR file which can be started with a double click. I am offering the complete package under the GPLv3 license; the source code is contained in the package. 

For a future version I'm planning to include an XModem sender/receiver based on RXTX for a direct communication with a real TI or Geneve. Related to that, another idea that came to my mind is to use such a serial connection to make it possible to act as a serial proxy for the MESS RS232 emulation.

Have fun,

Michael

---

From: mark wills <[email-masked]>
Date: Thu, 5 May 2011 22:05:41 +0100 (BST)

Very nice! Using it now. I like it!

The only feature that seems to be missing is the ability to copy/move a file from one disk image to another.

Regards

Mark

>________________________________
>From: Michael Zapf <[email-masked]>
>To: [email-masked]
>Sent: Thursday, 5 May 2011, 21:27
>Subject: Re: [TI994A] New version of TIImageTool
>
>Hello all,
>
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: "Michael Zapf" <[email-masked]>
Date: Fri, 06 May 2011 08:19:59 -0000

Hi Mark,
 
> a file from one disk image to another.

Well, right, but for the time being, it's exporting and importing a file or the complete image. :-)

Michael