Subject: Re: [TI994A] Sid Blaster update.....

From: [email-masked]
Date: Mon, 31 Jan 2011 12:01:22 -0600 (CST)

Woooot! Nice work guys!  :)

Marcus, I'm assuming your talking about software here? No revisions to the hardware?

On 01/31/11, Marc H<[email-masked]> wrote:Just and update....

The card and software are more or less done and out for beta testing as we speak. With the help of some very clever friends it is now a complete file browser front end/player combination. Barring any unforeseen bugs or problems It should be available in late March or early April.

The front end supports floppy, scuzzy, ram disk and the HFDC for now with full directory and sub directory browsing. The whole project has more or less morphed into a TI based I-pod ;-).

Additionally I have gotten permission to convert into .dsk form and post the entire CGSC collection which will be available from somewhere (not sure where yet but most likely from the WHT site unless someone wants to host a 40+ meg group of files here.) There are now 8500+ songs available of which I suspect about 90 percent are good dumps or playable on the TI at this point.

All that is really left other than the Beta testing is to finish converting all the songs and coming up with a manual.

Thanks go to Tim Tesch and Ernie Pergrem for writing the code that was way above my head. Those two are very valuable members of the TI scene and with their help at least this project would have died on the vine.

Marc

------------------------------------

Yahoo! Groups Links

<*> To visit your group on the web, go to:
http://groups.yahoo.com/group/TI994A/

<*> Your email settings:
Individual Email | Traditional

<*> To change settings online go to:
http://groups.yahoo.com/group/TI994A/join
(Yahoo! ID required)

<*> To change settings via email:
[email-masked]
[email-masked]

<*> To unsubscribe from this group, send an email to:
[email-masked]

<*> Your use of Yahoo! Groups is subject to:
http://docs.yahoo.com/info/terms/

---

From: Marc Hull <[email-masked]>
Date: Mon, 31 Jan 2011 10:09:06 -0800 (PST)

Not really.  The production board is laid out a bit differently and has provisions for a differnt model SID but functions the same.  Check your Email on THR.

--- On Mon, 1/31/11, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] Sid Blaster update.....
To: [email-masked]
Date: Monday, January 31, 2011, 12:01 PM

  

      Woooot! Nice work guys!  :) Marcus, I'm assuming your talking about software here? No revisions to the hardware?  On 01/31/11, Marc H<[email-masked]> wrote:Just and update....

Marc

Yahoo! Groups Links

---

From: mark wills <[email-masked]>
Date: Wed, 2 Feb 2011 10:02:27 +0000 (GMT)

Any idea how much they'll cost? Where we will get them from etc? For example, 
can we buy them from Texin Treasures as a kit, for example?

Are the SID chips difficult to get a hold of these days?

Ta

Mar[k]

>
>From: Marc Hull <[email-masked]>
>Sent: Mon, 31 January, 2011 18:09:06
>Not really.  The production board is laid out a bit differently and has 
>provisions for a differnt model SID but functions the same.  Check your Email on 
>THR.
>
>>The card and software are more or less done and out for beta testing as we 
>>speak. With the help of some very clever friends it is now a complete file 
>>browser front end/player combination. Barring any unforeseen bugs or problems It 
>>should be available in late March or early April.
>>
>>The front end supports floppy, scuzzy, ram disk and the HFDC for now with full 
>>directory and sub directory browsing. The whole project has more or less morphed 
>>into a TI based I-pod ;-).
>>
>>Additionally I have gotten permission to  convert into .dsk form and post the 
>>entire CGSC collection which will be available from somewhere (not sure where 
>>yet but most likely from the WHT site unless someone wants to host a 40+ meg 
>>group of files here.) There are now 8500+ songs available of which I suspect 
>>about 90 percent are good dumps or playable on the TI at this point.
>>
>>Thanks go to Tim Tesch and Ernie Pergrem for writing the code that was way above 
>>my head. Those two are very valuable members of the TI scene and with their help 
>>at least this project would have died on the vine.
>>
>>Marc
>>
>>
>>

---

From: "Stuart" <[email-masked]>
Date: Wed, 02 Feb 2011 14:55:14 -0000

>> Are the SID chips difficult to get a hold of these days? <<

Plenty of C64s on ebay  ;-)

Beware the buying of SID chips though - there are apparently lots of remarked chips out there ... some of which are from bad batches and others that aren't actually SID chips at all. Look for an ebay seller with good feedback - got mine from a chap in Portugal for ~£20.

Stuart.

--- In [email-masked], mark wills <markrobertwills@...> wrote:
> >From: Marc Hull <marc.hull@...>
> >--- On Mon, 1/31/11, swim4home@... <swim4home@...> wrote:
> >
> >
> >>From: swim4home@... <swim4home@...>
> >>  On 01/31/11, Marc H<marc.hull@...> wrote:Just and update....
> >>

---

From: Marc Hull <[email-masked]>
Date: Wed, 2 Feb 2011 07:04:12 -0800 (PST)

Not sure of the cost as of yet.  Need to do an analysis to determine that.  As far as where they will be available...  Most likely EBay as a buy it now.  Seems to work the best AFAIK.

The cards will most likely be sold as completed units available only in non Rohs countries and socket units for those afraid of a little lead.  I don't know how else to address the Rohs issue.  They will be bundled with the player software.

SID chips are a funny issue.  There are millions and millions of them out there  (here and in Europe.)  You can usually buy them on Ebay for an average cost of around $35-40 or....  You can buy a non functioning C64 for around $15-20 dollars and harvest the chip yourself.  I have done that about 20 times in stocking up and have only been stung once with a bad chip.  You may have to de-solder though as it seems every 5th or so board has the chip soldered in place.

--- On Wed, 2/2/11, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: Re: [TI994A] Sid Blaster update.....
To: [email-masked]
Date: Wednesday, February 2, 2011, 4:02 AM

  

      Any idea how much they'll cost? Where we will get them from etc? For example, can we buy them from Texin Treasures as a kit, for example?

 

Additionally I have gotten permission to
 convert into .dsk form and post the entire CGSC collection which will be available from somewhere (not sure where yet but most likely from the WHT site unless someone wants to host a 40+ meg group of files here.) There are now 8500+ songs available of which I suspect about 90 percent are good dumps or playable on the TI at this point.

Marc

Yahoo! Groups Links

---

From: ti99_forever <[email-masked]>
Date: Wed, 2 Feb 2011 08:47:58 -0800 (PST)

I've had less luck - it seems my breadbox and my newer 64 both seem to have bad SIDs. SIDs going bad seems to be a common issue...

--- On Wed, 2/2/11, Marc Hull <[email-masked]> wrote:

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Sid Blaster update.....
To: [email-masked]
Date: Wednesday, February 2, 2011, 10:04 AM

 

SID chips are a funny issue.  There are millions and millions of them out there  (here and in Europe.)  You can usually buy them on Ebay for an average cost of around $35-40 or....  You can buy a non functioning C64 for around $15-20 dollars and harvest the chip yourself.  I have done that about 20 times in stocking up and have only been stung once with a bad chip.  You
 may have to de-solder though as it seems every 5th or so board has the chip soldered in place.

 

Subject: Re: [TI994A] Sid Blaster
 update.....

 

Marc

Yahoo! Groups Links

---

From: Marc Hull <[email-masked]>
Date: Wed, 2 Feb 2011 09:03:34 -0800 (PST)

The usual suspect for dead SIDs is using monitor/video cables with RCA connectors on both outputs (like those ones for sale on Ebay that let you bypass the RF adapter on a TI.)  If you get the audio/video reversed then you will fry the SID instantly (been there, done that.)  Say what you will about TI but they did engineer the 99 for a not so perfect world.

Like I mentioned earlier out of 20 or so non working I have bought only 1 was a dud.  It's usually the DRAM on a 64 that gets fried and causes black screen.  It's good to know the black screen of death exists outside the TI world ;-).

--- On Wed, 2/2/11, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: Re: [TI994A] Sid Blaster update.....
To: [email-masked]
Date: Wednesday, February 2, 2011, 10:47 AM

  

        

SID chips are a funny issue.  There are millions and millions of them out there  (here and in Europe.)  You can usually buy them on Ebay for an average cost of around $35-40 or....  You can buy a non functioning C64 for around $15-20 dollars and harvest the chip yourself.  I have done that about 20 times in stocking up and have only been stung once with a bad chip. 
 You
 may have to de-solder though as it seems every 5th or so board has the chip soldered in place.

 

        

 

Marc

Yahoo! Groups Links

---

From: ti99_forever <[email-masked]>
Date: Wed, 2 Feb 2011 10:55:03 -0800 (PST)

Yes - worse yet is the power bricks toasting the computer when they short out internally.
Have to admit, TI's quality controls were much better... whoever got "shocked" due to the adapter recall? Not a one - it was just their testing that pointed to a potential flaw which cost them quite a pretty penny and possibly the market share at the time...

From: Marc Hull <[email-masked]>
Subject: Re: [TI994A] Sid Blaster update.....
To: [email-masked]
Date: Wednesday, February 2, 2011, 12:03 PM

 

From: ti99_forever
 <[email-masked]>

    

        

 

        

 

Marc

Yahoo! Groups Links

---

From: Keith Bergman <[email-masked]>
Date: Wed, 2 Feb 2011 14:58:57 -0500

If you haven't read it, Brian Bagnall's book "On the Edge," about
Commodore's rise and fall, is fascinating stuff.  The "quality control" at
that place in the heyday of the C64 was horrifying.  They'd pull chips out
of the defect box just to get units shipped to stores, figuring they could
get the Christmas sales and then deal with returns and warranty issues
later.  TI wasn't the only company to snatch defeat from the jaws of
victory, that's for sure.

This project is amazing, by the way.  SID chip music is a big favorite of
mine.

On Wed, Feb 2, 2011 at 1:55 PM, ti99_forever <[email-masked]> wrote:

> Have to admit, TI's quality controls were much better... whoever got
> "shocked" due to the adapter recall? Not a one - it was just their testing
> that pointed to a potential flaw which cost them quite a pretty penny and
> possibly the market share at the time...
>
> --- On *Wed, 2/2/11, Marc Hull <[email-masked]>* wrote:
>
>
>   The usual suspect for dead SIDs is using monitor/video cables with RCA
> connectors on both outputs (like those ones for sale on Ebay that let you
> bypass the RF adapter on a TI.)  If you get the audio/video reversed then
> you will fry the SID instantly (been there, done that.)  Say what you will
> about TI but they did engineer the 99 for a not so perfect world.
>
> Like I mentioned earlier out of 20 or so non working I have bought only 1
> was a dud.  It's usually the DRAM on a 64 that gets fried and causes black
> screen.  It's good to know the black screen of death exists outside the TI
> world ;-).
>
> --- On *Wed, 2/2/11, ti99_forever <[email-masked]>* wrote:
>
>
>   I've had less luck - it seems my breadbox and my newer 64 both seem to
> have bad SIDs. SIDs going bad seems to be a common issue...
>
> --- On *Wed, 2/2/11, Marc Hull <[email-masked]>* wrote:
>
>
>   Not sure of the cost as of yet.  Need to do an analysis to determine
> that.  As far as where they will be available...  Most likely EBay as a buy
> it now.  Seems to work the best AFAIK.
>
> The cards will most likely be sold as completed units available only in non
> Rohs countries and socket units for those afraid of a little lead.  I don't
> know how else to address the Rohs issue.  They will be bundled with the
> player software.
>
> SID chips are a funny issue.  There are millions and millions of them out
> there  (here and in Europe.)  You can usually buy them on Ebay for an
> average cost of around $35-40 or....  You can buy a non functioning C64 for
> around $15-20 dollars and harvest the chip yourself.  I have done that about
> 20 times in stocking up and have only been stung once with a bad chip.  You
> --- On *Wed, 2/2/11, mark wills <[email-masked]>* wrote:
>
>
>  Any idea how much they'll cost? Where we will get them from etc? For
> example, can we buy them from Texin Treasures as a kit, for example?
>
> *From:* Marc Hull <[email-masked]>
> *To:* [email-masked]
> *Sent:* Mon, 31 January, 2011 18:09:06
> *Subject:* Re: [TI994A] Sid Blaster update.....
>
>
>
> provisions for a differnt model SID but functions the same.  Check your
> Email on THR.
>
> --- On *Mon, 1/31/11, [email-masked] <[email-masked]>*wrote:
>
>
> browser front end/player combination. Barring any unforeseen bugs or
> problems It should be available in late March or early April.
>
> The front end supports floppy, scuzzy, ram disk and the HFDC for now with
> full directory and sub directory browsing. The whole project has more or
> less morphed into a TI based I-pod ;-).
>
> Additionally I have gotten permission to convert into .dsk form and post
> the entire CGSC collection which will be available from somewhere (not sure
> where yet but most likely from the WHT site unless someone wants to host a
> 40+ meg group of files here.) There are now 8500+ songs available of which I
> suspect about 90 percent are good dumps or playable on the TI at this point.
>
> All that is really left other than the Beta testing is to finish converting
> all the songs and coming up with a manual.
>
> Thanks go to Tim Tesch and Ernie Pergrem for writing the code that was way
> above my head. Those two are very valuable members of the TI scene and with
> their help at least this project would have died on the vine.
>
> Marc
>
>
>

---

From: mark wills <[email-masked]>
Date: Wed, 2 Feb 2011 22:05:49 +0000 (GMT)

That book is INCREDIBLE. One of the (maybe) one or two books that I have closed 
at the end, and *immediately* skipped to the beginning and re-read the whole 
thing again!

Brilliant book - highly recommended.

Mark

>
>From: Keith Bergman <[email-masked]>
>Sent: Wed, 2 February, 2011 19:58:57
>If you haven't read it, Brian Bagnall's book "On the Edge," about Commodore's 
>rise and fall, is fascinating stuff.  The "quality control" at that place in the 
>heyday of the C64 was horrifying.  They'd pull chips out of the defect box just 
>to get units shipped to stores, figuring they could get the Christmas sales and 
>then deal with returns and warranty issues later.  TI wasn't the only company to 
>snatch defeat from the jaws of victory, that's for sure.
> 
>This project is amazing, by the way.  SID chip music is a big favorite of mine.
> 
>
>
> 
>>Have to admit, TI's quality controls were much better... whoever got "shocked" 
>>due to the adapter recall? Not a one - it was just their testing that pointed to 
>>a potential flaw which cost them quite a pretty penny and possibly the market 
>>share at the time...
>>
>>>connectors on both outputs (like those ones for sale on Ebay that let you bypass 
>>>the RF adapter on a TI.)  If you get the audio/video reversed then you will fry 
>>>the SID instantly (been there, done that.)  Say what you will about TI but they 
>>>did engineer the 99 for a not so perfect world.
>>>
>>>Like I mentioned earlier out of 20 or so non working I have bought only 1 was a 
>>>dud.  It's usually the DRAM on a 64 that gets fried and causes black screen.  
>>>It's good to know the black screen of death exists outside the TI world ;-).
>>>
>>>>I've had less luck - it seems my breadbox and my newer 64 both seem to have bad 
>>>>SIDs. SIDs going bad seems to be a common issue...
>>>>
>>>>>Not sure of the cost as of yet.  Need to do an analysis to determine that.  As 
>>>>>far as where they will be available...  Most likely EBay as a buy it now.  Seems 
>>>>>to work the best AFAIK.
>>>>>
>>>>>The cards will most likely be sold as completed units available only in non Rohs 
>>>>>countries and socket units for those afraid of a little lead.  I don't know how 
>>>>>else to address the Rohs issue.  They will be bundled with the player software.
>>>>>
>>>>>SID chips are a funny issue.  There are millions and millions of them out there  
>>>>>(here and in Europe.)  You can usually buy them on Ebay for an average cost of 
>>>>>around $35-40 or....  You can buy a non functioning C64 for around $15-20 
>>>>>dollars and harvest the chip yourself.  I have done that about 20 times in 
>>>>>stocking up and have only been stung once with a bad chip.  You may have to 
>>>>>de-solder though as it seems every 5th or so board has the chip soldered in 
>>>>>place.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>