Subject: Power Basic Demo Graphics Program

From: "Stuart" <[email-masked]>
Date: Mon, 14 Feb 2011 12:20:31 -0000

Hopefully Yahoo won't screw up the formatting of this. Looks like line 110 is going to wrap but I'm sure you can work it out.

Stuart.

 10 GRAPH : XS=2: YS=2
 20 A=256: B=A*A: C=192
 30 FOR X=0 TO A STEP XS: S=X*X: P=SQR[B-S]
 40 FOR I=-P TO P STEP 6*YS
 50 R=SQR[S+I*I]/A
 60 Q=(R-1)*SIN[10*R]
 70 Y=INT[I/3+Q*C]
 80 IF I=-P THEN M=Y: N=Y
 90 IF Y>M THEN M=Y
 100 IF Y<N THEN N=Y
 110 IF (M=Y OR N=Y) THEN X1=X/2: Y1=100-Y/2: PLOT 128+X1,Y1: PLOT 128-X1,Y1
 120 NEXT I
 130 NEXT X
 140 K=KEY[0]
 150 IF K=0 THEN GOTO 140

---

From: Gregory McGill <[email-masked]>
Date: Mon, 14 Feb 2011 13:53:20 -0800

Painfully slow in classic99 in wine, but with cpuoverdrive its better.. very
nifty

G

On Mon, Feb 14, 2011 at 4:20 AM, Stuart <[email-masked]> wrote:

>
>
> Hopefully Yahoo won't screw up the formatting of this. Looks like line 110
> is going to wrap but I'm sure you can work it out.
>
> Stuart.
>
> 10 GRAPH : XS=2: YS=2
> 20 A=256: B=A*A: C=192

---

From: ti99_forever <[email-masked]>
Date: Mon, 14 Feb 2011 14:02:13 -0800 (PST)

I have noticed that for Classic99 to run at a real TI's speed, I must increase the slider to around 120-130%. 100% is too slow compared to a real TI...
BTW: the line graphics look horrible on my TI's LCD monitor using the standard background color. Inserting a COLOUR 1,1:TEXT before the GRAPH makes everything look much better.
I haven't run this yet - been dealing with financial issues - everybody wants more of my $$$... how can my insurance company raise my rates "due to inflation and rate changes"? What inflation?

--- On Mon, 2/14/11, Gregory McGill <[email-masked]> wrote:

From: Gregory McGill <[email-masked]>
Subject: Re: [TI994A] Power Basic Demo Graphics Program
To: [email-masked]
Date: Monday, February 14, 2011, 4:53 PM

 

Painfully slow in classic99 in wine, but with cpuoverdrive its better.. very nifty

G

 

    

Stuart.

10 GRAPH : XS=2: YS=2

 20 A=256: B=A*A: C=192

 50 R=SQR[S+I*I]/A

 60 Q=(R-1)*SIN[10*R]

 70 Y=INT[I/3+Q*C]

 80 IF I=-P THEN M=Y: N=Y

 90 IF Y>M THEN M=Y

 100 IF Y<N THEN N=Y

 120 NEXT I

 130 NEXT X

 140 K=KEY[0]

 150 IF K=0 THEN GOTO 140

---

From: tursi <[email-masked]>
Date: Mon, 14 Feb 2011 14:48:18 -0800 (PST)

> I have noticed that for Classic99 to run at a real TI's speed, I must increase the
> slider to around 120-130%. 100% is too slow compared to a real TI...

I've been looking at this lately, while fixing some bugs for Marc's SID 
player I was noticing speed issues. The math seems correct but before I 
dig too deep I need to hook up the logic analyzer again and see what I'm 
missing. It's possible (probable) that the cause is actually the Windows 
scheduler and not so much a cycle counting issue -- but it could still be 
a cycle counting issue. ;)

Anyway, that's why the slider is there!

---

From: Owen <[email-masked]>
Date: Mon, 14 Feb 2011 19:48:37 -0500

That's an interesting piece of information... I noticed while testing some recent code for a game project that Classic99 seems to take slightly longer to execute a fairly massive CALL LOAD than my TI... But I thought it had something to do with the fact that I was using a CF7....  I never considered that Windows might be causing that.  :) 

Firebrandmusic.net

---

From: Gregory McGill <[email-masked]>
Date: Mon, 14 Feb 2011 17:27:59 -0800

Windows causes everything bad! :-) even under linux

Greg

On Mon, Feb 14, 2011 at 4:48 PM, Owen <[email-masked]> wrote:

>
>
> That's an interesting piece of information... I noticed while testing some
> recent code for a game project that Classic99 seems to take slightly longer
> to execute a fairly massive CALL LOAD than my TI... But I thought it had
> something to do with the fact that I was using a CF7....  I never considered
> that Windows might be causing that.  :)
>
>
>
> Firebrandmusic.net
>
>