Subject: Need an IDE nudge....

From: "Marc H" <[email-masked]>
Date: Sun, 06 May 2012 19:46:55 -0000

When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 06 May 2012 20:35:05 -0000

> When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?

I don't have the IDE card, but I'd be surprised if you had to format to FAT, since we cannot process FAT on the TI. You should not require any preformatting; the CF offers nothing else but a sequence of sectors. 

FAT, NTFS, Ext2/3/4, Btrfs, ISO9660, ... are all file systems on top of the data access level of the device, and only for floppies or MFM HDs we had a special low-level format. Since SCSI and IDE the device cares for its own low-level access; you just get a block-level access.

Michael

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 07:49:40 -0000

Michael,

The IDE/CF Adapter is a seperate sub-system which uses the FAT 32.  The same disk is then initialized on a TI-99/4A for use on a TI-99/4A with Fred Kaal's program.  It is as was said:  A Low Level and Hight Level Disk Format.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: Marc Hull <[email-masked]>
Date: Tue, 8 May 2012 05:14:01 -0700 (PDT)

--- On Sun, 5/6/12, Michael Zapf <[email-masked]> wrote:

From: Michael Zapf <[email-masked]>
Subject: [TI994A] Re: Need an IDE nudge....
To: [email-masked]
Date: Sunday, May 6, 2012, 3:35 PM

  

      

< 
but I'd be surprised if you had to format to FAT, since we cannot process FAT on the TI.>
Not so fast ;-)....  The TI can actually access a FAT 32 formatted CF via a utility Fred created.  Allows you to load a CF with TI stuff from the PC in DOS format and transfer it directly on your TI to disk or other storage via the IDE card.

---

From: "epergrem" <[email-masked]>
Date: Tue, 08 May 2012 17:17:53 -0000

Windows 7 only allows display three formatting options NTFS, FAT (Default), or exFAT. 

Unfortunately, I don't have a CF reader on my XP, or Win98SE machines, so if it's got to be FAT32 I'm out of luck.  :-)

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

> 
> --- On Sun, 5/6/12, Michael Zapf <forums12@...> wrote:
> 
> From: Michael Zapf <forums12@...>

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 17:23:29 -0000

Ernie,

I did 10 of them last week.  Do you have neightbors or friends who may or can help do it?

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> --- In [email-masked], Marc Hull <marc.hull@> wrote:
> 
> > 
> > --- On Sun, 5/6/12, Michael Zapf <forums12@> wrote:
> > 
> > From: Michael Zapf <forums12@>

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 17:32:57 -0000

Ernie,

That is "FORMAT & INITALIZE"!

Postle  [:)]

--- In [email-masked], "Postle" <postle@...> wrote:
> --- In [email-masked], "epergrem" epergrem@ wrote:
> >
> > Unfortunately, I don't have a CF reader on my XP, or Win98SE
machines, so if it's got to be FAT32 I'm out of luck. :-)
> > > <Â
> > > Not so fast ;-)....Â  The TI can actually access a FAT 32
formatted CF via a utility Fred created.Â  Allows you to load a CF
with TI stuff from the PC in DOS format and transfer it directly on your
TI to disk or other storage via the IDE card.Â Â Â

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 17:46:27 -0000

Ernie,

On my machine the FAT, ex FAT is a pull down menu...

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ 

--- In [email-masked], "Postle" <postle@...> wrote:
> --- In [email-masked], "Postle" <postle@> wrote:
> >
> > Ernie,
> >

---

From: "Tursi" <[email-masked]>
Date: Tue, 8 May 2012 10:49:54 -0700

Ernie,

Try the command line. Start->Run, type "cmd.exe", then "format /?" for help. 
Make sure you know the correct drive letter for the flash card, then you 
should be able to do this:

format x: /FS:FAT32 /V:label /Q

'x' being the drive letter, and 'label' being your choice of label. The 
command prompt version enforces a lot fewer rules. See the help (/?) for the 
few rules that it does enforce. I just checked this on my Win7 machine.

-----Original Message----- 
From: epergrem
Sent: Tuesday, May 08, 2012 10:17 AM
To: [email-masked]
Subject: [TI994A] Re: Need an IDE nudge....

Windows 7 only allows display three formatting options NTFS, FAT (Default), 
or exFAT.

Unfortunately, I don't have a CF reader on my XP, or Win98SE machines, so if 
it's got to be FAT32 I'm out of luck.  :-)

Ernie

---

From: Gregory McGill <[email-masked]>
Date: Tue, 8 May 2012 10:54:52 -0700

http://geekdrop.com/content/how-to-format-hard-drive-to-fat32-in-windows-7-or-vista-or-in-general

On Tue, May 8, 2012 at 10:49 AM, Tursi <[email-masked]> wrote:

> **

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 18:02:42 -0000

Yes.  Or...  That what we are using.  Did not try anything else.  I do what I am told.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 21:38:12 -0000

Ernie,

I went to the electronic store.  Or... Maybe two.  So how are you doing with the IDE Card Project?

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: "epergrem" <[email-masked]>
Date: Tue, 08 May 2012 23:25:43 -0000

Hi All,

I formatted the card FAT32 using Tursi's suggestion.  The format went okay, but IDEDRIVE is reporting >FFFF across the board, CALL IDEST displays zeros and DU2K is still reporting no devices for IDE1 to IDE8, even after attempting to Initialize and/or Partition the CF card.  

The IDE card just isn't seeing the CF card. I already tried my 1GB Sansdisk CF card with the same results.  

In the old days I would have also tried an IDE drive, but those days are gone.  Not for lack of skill, but because I've either recycled or given away all of the spare parts.

You would be surprised how cleaning out Dave Connery's house changes my perspective. :-)

Ernie

--- In [email-masked], "Postle" <postle@...> wrote:
> --- In [email-masked], "Marc H" <marc.hull@> wrote:
> >

---

From: Jeff White <[email-masked]>
Date: Wed, 9 May 2012 08:32:43 -0400

Ernie,

If both CF cards work fine on W7 box, I think your problem is the IDE card.  It is possible that you formatted FAT32 CHS instead of FAT32 LBA, and maybe CF is smart enough to block the LBA needed by the DSR.  I have never used one of the CF cards.

You could try Thierry's IDEAL DSR instead of Fred's.  It is just a matter of loading different software.  If there is a hardware issue, IDEAL should not work with the CF.

Do you have a SCSI card and SCSI-CF adaptor?  A nanoPEB of CF7+?

Jeff White

---

From: "Michael Zapf" <[email-masked]>
Date: Wed, 09 May 2012 13:53:45 -0000

Just curious ...

so does this mean that the flash card still has a FAT file system which the DSR wraps into a TI file system?

This would mean that when you write a TI file, the DSR has to translate this to a FAT file write, same with file read, directory creation etc., also file name mapping (plain FAT has only 8.3 names, while the TI file names allow "\").

Can you read the TI files from a CF card plugged into a PC?

I once thought about some flash device in place of my SCSI system on the Geneve, but I guess it's too late to get one.

Michael

---

From: TIMOTHY KIRSCH <[email-masked]>
Date: Wed, 9 May 2012 10:10:14 -0500

The one I had you format the cf card and used his program to load disk files. Then you moved it over to the ti and initilzed the cf card to use it on the ti.From that point you could not use it on the ibm.It would show unformated.On the ti you use call mount or call unmount to access the disk.Tim

To: [email-masked]
From: [email-masked]
Date: Wed, 9 May 2012 13:53:45 +0000
Subject: [TI994A] Re: Need an IDE nudge....

Just curious ...

Michael

---

From: "epergrem" <[email-masked]>
Date: Wed, 09 May 2012 15:43:58 -0000

Hi Jeff,
Having had gone through several pages of stuff that Postle sent me I chose to take the coward's way out and send the card back to Marc.  

I hate to dump on him, but perhaps he will either confirm the issues that I've been having, or it work work like a champ for him and prove me an idiot.  

I would much rather prefer the later, because we don't need another non-working card in the TI community.

Ernie

---

From: Dan <[email-masked]>
Date: Wed, 09 May 2012 13:06:22 -0400

in addition to the command line in windows 7 there is an excellent 
utility to format fat32 drives here.
home page
http://www.ridgecrop.demon.co.uk/index.htm
Dos fat32 utility
http://www.ridgecrop.demon.co.uk/fat32format.htm
Windows GUI fat32 utility
http://www.ridgecrop.demon.co.uk/guiformat.htm

---

From: "Stuart" <[email-masked]>
Date: Wed, 09 May 2012 17:32:19 -0000

I'm sure it doesn't. Although Fred it seems has a utility which can interpret the FAT file system and *read* a file off the device - clever!

I suspect that this FAT32 business is a red herring and what is actually happening is this: at some point the (TI formatted) CF card is getting corrupted and the DSR is getting confused and won't play ball. Formatting the card on the PC as FAT32 is an easy way to 'destroy' the TI formatting so the DSR now thinks the card is not (TI) initialised and will play along. Using a sector editor on the PC to write all zeroes to the card would I suspect have exactly the same result.

---

From: "Postle" <[email-masked]>
Date: Wed, 09 May 2012 17:59:57 -0000

Ernie,

Years ago, I ran my Geneve on a 10 Meg Hard Drive.  A 256 Meg CF Solid state memory card is 25.6 time larger than my old hard drive.

Therefore I set up all 10 ~ 11 or more IDE Card I have for sale with a 256 Meg CF Cards. That makes things simple for me.  Ofcourse I also have an external read/write device connect to my PC which allows for the low lever format.

If I wish for something larger I can put two IDE/Card adapters in a external case.  And...  Still not have the problems you experience.  I don't know what I would do with 512 Meg of storage.  Do think you can do that with a SCSI Card.

Richard Bell has setup the 1 Gig CF cards.  I have a 1 Gif card or two here, but never did the sectioning.  It is all automatic save the FFFFF on the last section.  So I am told.

Sorry things did not work out for you.

Respectfully,

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> --- In [email-masked], Jeff White <ti994a@> wrote:
> >
> > Ernie,
> >

---

From: "Postle" <[email-masked]>
Date: Wed, 09 May 2012 18:19:14 -0000

Having one each (SCSI/CF & IDE/CF) being functional in two of my TI-99/4A Systems, I can tell the world that both are very nice...  Both are very fast to load a program.  Maybe a blink slower than a Memory Card Drive.  I feel very fortunite to have these systems.  The SCSI I found by accident.  Thank You Jon & the TI Community.  The IDE Card I have been with for a few years, 2002?  Thanking Fred Kaal for his excellent work with:  DM2K, DU2K and the updated and wonderful IDE Card Firmware (Disk Servide Routine).  "WE" In the TI-99/4A Community are very lucky to have a Fred Kaal. As well as many others...  Richard Bell, Jon Guidry, Timothy Kirsch and many many more.

Postle

--- In [email-masked], TIMOTHY KIRSCH <KIRSCHTF@...> wrote:
> From: forums12@...

---

From: "Michael Zapf" <[email-masked]>
Date: Wed, 09 May 2012 18:23:15 -0000

> Using a sector editor on the PC to write all zeroes to the card would 
> I suspect have exactly the same result.

This would be my bet as well. 

The last thing that was in need of a low-level formatting was the MFM hard disk. All following devices had block-level commands; any physical formatting was hidden inside the device.

I recently held a lecture on Ext2/Ext3/Ext4 and also had a look at FAT, so I had an opportunity to learn a bit about formats.

Michael

---

From: "epergrem" <[email-masked]>
Date: Wed, 09 May 2012 18:24:07 -0000

Yep, but then I can't imagine filling the EZ135 cartridge that I'm using now.  :-)

99/4A programs just aren't all that big, especially compared to my Microsoft Flight Simulator setup which is sitting at about 120GB. ;-)

Ernie

--- In [email-masked], "Postle" <postle@...> wrote:
> --- In [email-masked], "epergrem" <epergrem@> wrote:
> >
> > Hi Jeff,

---

From: "Postle" <[email-masked]>
Date: Wed, 09 May 2012 18:28:31 -0000

The wonderful thing about the CF Card Systems, SCSI & IDE, is they are Plug & Play once setup.  And...  They have no moving parts.

Postle

---

From: "Tony Knerr" <[email-masked]>
Date: Wed, 09 May 2012 21:12:04 -0000

You can still put a flash device together for SCSI, Michael.
It's a little more expensive than it used to be.
You'll need one of these:

http://www.span.com/product_info.php?products_id=1058&source=gbaseus&currency=USD

... and something like this, there are different models:

http://www.microcenter.com/single_product_results.phtml?product_id=0255159

... and a compact flash card.

I recently added a similar device to my Geneve system. It's a little faster than a traditional hard drive but not much, reliability is probably it's most appealing quality. A Ramdisk is still very much faster. 

Tony

--- In [email-masked], "Michael Zapf" <forums12@...> wrote:
> ...

---

From: Jeff White <[email-masked]>
Date: Wed, 9 May 2012 22:05:27 -0400

You can also try some of the devices from the "Amiga" market, such as:

http://a4000t.com/store/index.php?main_page=index&cPath=65_79

From the low-end $62 package you support 5 devices:

  lun0 is the PCMCIA slot(can be used with a PCMCIA to "any" card adapter also!)
lun1 is the Compact Flash card slot (recommended to use as a hard drive replacement)

lun2 is SONY Memory Stick slot

lun3 is SD/MMC card slot

lun4 is Smart Media slot

So I take it you could have SCSI drives 1-5 occupied by 5 types of memory sticks.

Jeff White

---

From: Jeff White <[email-masked]>
Date: Wed, 9 May 2012 22:24:17 -0400

Forgot to say that I do not have one of these, but the description mentions retro computers including the TI.

---

From: "Postle" <[email-masked]>
Date: Thu, 10 May 2012 03:24:02 -0000

Tony,

You say you have one of these up and running.  What are the jumper settings?

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], "Tony Knerr" <tonyknerr@...> wrote:
> --- In [email-masked], "Michael Zapf" <forums12@> wrote:
> > ...

---

From: Tony Knerr <[email-masked]>
Date: Thu, 10 May 2012 05:22:01 -0400

I said mine was similar to the one listed. It is not available anywhere 
I can find and has different jumper
attributes.

Tony

On 5/9/2012 11:24 PM, Postle wrote:
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, "Tony 
> Knerr" <tonyknerr@...> wrote:
> >
> <http://www.span.com/product_info.php?products_id=1058&source=gbaseus&currency=USD>
> >
> > I recently added a similar device to my Geneve system. It's a little 
> faster than a traditional hard drive but not much, reliability is 
> probably it's most appealing quality. A Ramdisk is still very much 
> faster.
> >
> > Tony
> >
>
>
>
>

---

From: Tony Knerr <[email-masked]>
Date: Thu, 10 May 2012 05:26:13 -0400

I was looking at these, Jeff. Someone correct me if I'm wrong, but I 
believe that the
current TI/Geneve SCSI Dsrs can only access lun0. So it would be a 
little crippled.

Tony

On 5/9/2012 10:05 PM, Jeff White wrote:
> <http://a4000t.com/store/index.php?main_page=index&cPath=65_79>
>
> On 09 May 2012, at 17:12, "Tony Knerr" <[email-masked] 
> <mailto:[email-masked]>> wrote:
>

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 10 May 2012 10:52:42 -0000

Hmm, well, looks a bit more complex, but could work. I'd hope for a simple solution if only for the sake of dropping the external SCSI drive. Maybe Thierry's USB/SM card or so.

Of course, my ultimate goal is to make MESS a perfect emulation of the Geneve, so it does not make sense for me to invest too much effort in  real hardware.

Michael

---

From: Jeff White <[email-masked]>
Date: Thu, 10 May 2012 08:05:09 -0400

Tony,

Now that I think about it, you are correct.  Been using HP-UX since 1995, which uses the c-t-d-s-designators: controller, target, disk, and slice.  The target is what corresponds to the SCSx drive in our TI/Geneve world.  The disk is the lun number.

So only the PCMCIA slot would function for us, but there are 2 packages that include a PCMCIA to CF adaptor.

Not sure that the current SCSI DSR's would be amenable to updating for lun support.

Jeff White

On 10 May 2012, at 05:26, Tony Knerr <[email-masked]> wrote:

> I was looking at these, Jeff. Someone correct me if I'm wrong, but I believe that the
> current TI/Geneve SCSI Dsrs can only access lun0. So it would be a little crippled.
> 
> Tony 
>

---

From: "Postle" <[email-masked]>
Date: Thu, 10 May 2012 14:36:57 -0000

Tony,

There is a IODATA Device and the ACARD Device.  What is it you are using and how is it pinned out.  How is yours different?  This so others may know.

The SCSI set-ups cost me about $255 each.  The SCSI Card was an extra $270.  Or...  A $525 investment.  I think the SCSI Set-up to worth the monies spent.  It brings the TI-99/4A into the 21 Century.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], Tony Knerr <tonyknerr@...> wrote:
> > Knerr" <tonyknerr@> wrote:
> > >

---

From: Tony Knerr <[email-masked]>
Date: Thu, 10 May 2012 17:47:28 -0400

My SCSI to IDE device is an IDSC21-E.  The jumper settings can be found 
here:

http://synack.net/~bbraun/IDSC21-E_Jumper_Settings.pdf

There is a photo of the device here:

http://gamesx.com/wiki/lib/exe/fetch.php?media=x68000:idsc21e.jpg

The jumper settings I use would be meaningless to someone else's system 
as it is unlikely
that 2 systems would be set up similarly as far as connected devices are 
concerned.
My IDSC21-E is in the middle of a chain containing an EZ135 and ZIP100 
drive. The
Zip100 is on the end, so it is the only one terminated. The IDSC21-E is 
set to SCSI id 0
and is accessed as SCS1, the EZ135 is at SCSI id 1 and is accessed as 
SCS2, and the
ZIP100 is set to respond at SCSI id 2 and is accessed as SCS3.

Should you have one of these devices and need assistance with the jumper 
settings, please
describe in detail the connected devices and I should be able to assist 
with the jumper settings.

Tony

On 5/10/2012 10:36 AM, Postle wrote:
>
> Tony,
>
> There is a IODATA Device and the ACARD Device. What is it you are 
> using and how is it pinned out. How is yours different? This so others 
> may know.
>
> The SCSI set-ups cost me about $255 each. The SCSI Card was an extra 
> $270. Or... A $525 investment. I think the SCSI Set-up to worth the 
> monies spent. It brings the TI-99/4A into the 21 Century.
>
> Postle
>

---

From: Marc Hull <[email-masked]>
Date: Thu, 10 May 2012 18:05:15 -0700 (PDT)

Hey Tony...

You fell into the same trap I did ( I think.....)   I have seen that data sheet before and although it is for the same model number it does not match the card.  Caused quite a bit of hair loss.

The jumper block on the card is 9 pins while the sheet shows 10.  The correct settings for the IO-Data card (at least the 9 pin model for the TI) can be found here.......

 http://www.dsapsc.com/useful-info.html.  

Did you find that sheet using the wayback machine or some other search ?

--- On Thu, 5/10/12, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: Re: [TI994A] Re: Need an IDE nudge....
To: [email-masked]
Date: Thursday, May 10, 2012, 4:47 PM

  

      

    My SCSI to IDE device is an IDSC21-E.  The jumper settings can be
    found here:

    The jumper settings I use would be meaningless to someone else's
    system as it is unlikely

    that 2 systems would be set up similarly as far as connected devices
    are concerned.

    My IDSC21-E is in the middle of a chain containing an EZ135 and
    ZIP100 drive. The 

    Zip100 is on the end, so it is the only one terminated. The IDSC21-E
    is set to SCSI id 0

    and is accessed as SCS1, the EZ135 is at SCSI id 1 and is accessed
    as SCS2, and the

    Should you have one of these devices and need assistance with the
    jumper settings, please

    describe in detail the connected devices and I should be able to
    assist with the jumper settings.

    Tony 

      
          
            Tony,

              There is a IODATA Device and the ACARD Device. What is it
              you are using and how is it pinned out. How is yours
              different? This so others may know.

              The SCSI set-ups cost me about $255 each. The SCSI Card
              was an extra $270. Or... A $525 investment. I think the
              SCSI Set-up to worth the monies spent. It brings the
              TI-99/4A into the 21 Century.

              Postle

---

From: "Postle" <[email-masked]>
Date: Fri, 11 May 2012 01:44:35 -0000

Tony,

Yes, I hold one of these devices.  I have notes times two from Mark on the units set-up.

Then, as I do now wish to know the correct pin out of the unit.  I then can store the pin out with the unit.  As stated before...  Mine has made a trip to the UK for firmware upgrade.  I was told that was necessary.

Regardless which unit is used.  The SCSI/IDE Bridge is very useful when connected to a Solid State Memory Card.  Again, no moving parts.  Once set-up the piece of art works in a flawless manner.  I am glad that I own a SCSI/IDE/CF System.  And...  A few IDE/CF Systems as well.  Welcome to the 21st Century for the TI-99/4A.

Postle

---

From: "Tony Knerr" <[email-masked]>
Date: Fri, 11 May 2012 02:03:36 -0000

Trap? No. The data sheet is correct in the pin assignments. 
The card clearly has a 1 next to pin 1. Pin 0 is never used for
anything, so they didn't physically put it on the board. I've done
a bunch of testing and the pins do indeed respond according to the
data sheet. Found it with Google, Mr. Peabody. :)

Tony

---

From: "Postle" <[email-masked]>
Date: Fri, 11 May 2012 02:11:30 -0000

My Card is SCSI Card ~ SCSI Bridge ~ SCSI/IDE/CF Adapter.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
> --- On Thu, 5/10/12, Tony Knerr <tonyknerr@...> wrote:
> 
> From: Tony Knerr <tonyknerr@...>

---

From: Marc Hull <[email-masked]>
Date: Thu, 10 May 2012 20:02:11 -0700 (PDT)

Ouchy...... ;-)
 
That explains why I couldn't get the card to work with the Data sheet.  Maybe I need to get my glasses updated.  Good sleuthing Sherman ;-).

From: Tony Knerr <[email-masked]>
Subject: [TI994A] Re: Need an IDE nudge....
To: [email-masked]
Date: Thursday, May 10, 2012, 9:03 PM

  

Tony

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

> You fell into the same trap I did ( I think.....)Â Â  I have seen that data sheet before and although it is for the same model number it does not match the card.Â  Caused quite a bit of hair loss.

> The jumper block on the card is 9 pins while the sheet shows 10.Â  The correct settings for the IO-Data card (at least the 9 pin model for the TI) can be found here.......

> Â http://www.dsapsc.com/useful-info.html.Â