Subject: Re: [TI994A] 3.5 drive on a Dell

From: Owen Brand <[email-masked]>
Date: Mon, 27 May 2013 22:21:48 -0600

Unfortunately Omniflop is not compatible with virtual machines, as it requires direct access to the hardware...  The documentation explicitly states that virtual machines will not be able to read or write floppies with Omniflop.  And I've never seen a Win7 machine with a floppy either.  This was a custom built machine for my uncle and he just gave it to me today, so I have no idea what im up against.  

It's a 64 but computer....  Is it possible to run XP on it?

Owen Brand
Opry99er

Jeff White <[email-masked]> wrote:

>Windows 7 has broken some software I have used since Win9x.  In such cases, I have resorted to Virtual PC:
>
>http://windows.microsoft.com/en-us/windows7/install-and-use-windows-xp-mode-in-windows-7
>
>Sometimes lucky, sometime not.  I have not tried OmniFlop under Win7, since I do not have a floppy drive on a Win7 computer.
>
>Jeff White
>
>On 27 May 2013, at 23:24, Owen Brand <[email-masked]> wrote:
>> Okay, so what is happening is this....
>> 
>> When I go to install the drivers, Windows comes back with "This driver will not work... Incorrect platform" or some s*** like that... But when I check what drivers are installed (In device manager) it tells me that the drivers are installed properly... Open Omniflop..... "Drivers are not correctly installed".
>> 
>> So, restart the computer ... On startup, Windows reinstalls default drivers for my floppy drive. Rinse and repeat.
>> 
>> I looked into this and then disabled my automatic updates... Same problem. I then disabled the signature verification "feature" on my Dell in an attempt to force the computer to accept the unsigned drivers. Same result. Rinse and repeat.
>> 
>> Im home now, so I am going to try to write a floppy anyway, just to verify that Omniflop TRULY can't see the installed drivers. 
>> 
>> Whatever....
>> 
>> Owen Brand
>> Opry99er
>> 
>> 
>

---

From: Jeff White <[email-masked]>
Date: Tue, 28 May 2013 00:54:13 -0400

In April 2003, AMD released the first x86-64 microprocessor.  Intel followed in 2004.  Microsoft released a 64-bit version of WinXP in 2005.

However, many of us are still running 32-bit operating systems and applications on our 64-bit systems.

Are you running Win7 64-bit?  I would think you could run WinXP 32-bit or 64-bit, but depending on the newness of the Dell, you might have trouble locating drivers for such things as video and audio.  Best to visit Dell to do a system checkup and see what is compatible.

Jeff White

---

From: Owen Brand <[email-masked]>
Date: Mon, 27 May 2013 23:45:20 -0700 (PDT)

This 64 bit crap is really angering me... nothing I have is "compatible"... My Term emulator for transferring doesn't work, Omniflop requires special drivers and a bunch of extra steps for it to work on the 64 bit system, and I still can't make it work... Put 4 hours into it today... Done with it.  I need to figure out how to install Win98 or 32 bit XP on this system... I'll look into that tomorrow... I'm wiped out.  Happy Memorial Day everyone

Owen

________________________________
From: Jeff White <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Monday, May 27, 2013 10:54 PM
Subject: Re: [TI994A] 3.5 drive on a Dell

Jeff WhiteOn 28 May 2013, at 00:21, Owen Brand <[email-masked]> wrote:
  
>Jeff White <mailto:ti994a%40sbcglobal.net> wrote:
>
>>On 27 May 2013, at 23:24, Owen Brand <mailto:owen.brand%40rocketmail.com> wrote:

---

From: "gregallenwarner" <[email-masked]>
Date: Tue, 28 May 2013 16:17:28 -0000

Have you tried using Tera Term on the PC side for serial transfers? I've had luck with that software on Windows 7 64-bit. Just a hint, though, you may not be able to get away with using a USB to RS232 adapter. You may have to use a real physical RS232 port on the PC. (Usually COM1) I don't know this for a fact, but all I know is I was having trouble getting Magic FM to work, and when I ditched the USB adapter and plugged into a real physical serial port, it magically started working. All this is on Windows 7 64-bit, by the way.

If the PC doesn't have a COM port, some motherboards may have headers on board for a COM port, which is intended to be used with an extension, but remains unused by the manufacturer. Have a look inside for any 2x5 blocks of 0.1" spaced headers with one pin missing labeled "COM1" or "COM2". Grab an extension that breaks this out into a DB-9 connector on a PCI slot cover, and you're good to go.

-Greg W

--- In [email-masked], Owen Brand <owen.brand@...> wrote:
> From: Jeff White <ti994a@...>
> Jeff WhiteOn 28 May 2013, at 00:21, Owen Brand <owen.brand@...> wrote:
>

---

From: tursi <[email-masked]>
Date: Tue, 28 May 2013 09:49:58 -0700 (PDT)

> don't know this for a fact, but all I know is I was having trouble 
> getting Magic FM to work, and when I ditched the USB adapter and plugged 
> into a real physical serial port, it magically started working. All this 
> is on Windows 7 64-bit, by the way.

I may be able to help with this, actually... USB is a packet-based 
protocol, where serial ports usually are character at a time. What this 
means is that USB to Serial drivers will buffer characters before sending 
them. In cases where handshake timing is important, this can cause 
protocols to fail.

It can be adjusted, however! If you look at the properties in device 
manager, most (not all) serial adapters have a page that let you configure 
the timing of the buffering. If you set the character counts to minimum 
and the timeouts as low as possible, this is usually enough to make it 
work.

I'll post some screenshots when I get home, because it's hard to be clear 
with such a vauge description (and I don't have an adapter here at work to 
check). This was something I had to do at one of my previous jobs to make 
file transfers work to our embedded device.

---

From: "Tursi" <[email-masked]>
Date: Tue, 28 May 2013 20:16:42 -0700

>and the timeouts as low as possible, this is usually enough to make it

As promised.. all but one of my USB serial adapters have this properties 
panel.

Go into device manager, right-click and select properties 
(http://harmlesslion.com/temp/Clip0001.jpg).
Select the Port Settings Tab, and click Advanced 
(http://harmlesslion.com/temp/Clip0002.jpg)
Most USB serial adapters give you this advanced panel 
(http://harmlesslion.com/temp/Clip0003.jpg)

Some display the standard serial port properties - there is little you can 
do there. Slide the buffers down to minimum and hope for the best. But if 
you have the advanced dialog in the screenshot, set receive and transmit 
down to the minimum (64 bytes) and set the latency timer to the minimum 
(1ms). Leave the timeouts at zero. This will cause more USB bandwidth but 
should provide the timing for file transfers (I was transferring files with 
a picky device at 750,000 bps using these settings).

Hope that's helpful!