Subject: Re: Re: [TI994A] More HRD questions....

From: [email-masked]
Date: Mon, 06 Feb 2012 16:08:32 -0600 (CST)

What's the physical setup? How many meg total? BTW, normal convention is to use CRU 1400 and 1600 for RAM disks. Other CRUs can be used but it's a pain when you put another card in like an RS232/2 at 1500 forgetting your RAM disk is there and you wipe the ROS on your next boot.

On 02/06/12, Marc Hull<[email-masked]> wrote:

So perhaps this is what led  me to believe that there is a Ramdisk limit per card.

When I get to end of the list while formatting the RD's I can't go past the 10th one.  Need some knowledge here Rich.

--- On Mon, 2/6/12, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] More HRD questions....
To: [email-masked]
Date: Monday, February 6, 2012, 3:21 PM

Ummm.....My main system is setup with two WHT 4000 series. One card is 8 meg (512 SRAMS) and the other is 2 meg (128 SRAMS). Disks are 5 thru 9 and F thru Z 1600 sectors each disk.

On 02/06/12, Marc H<[email-masked]> wrote:

Turns out the problem was in some crappy IC sockets. Who would of thunk it ??

I do have a couple of tech questions that hopefully someone can shed some light on.

It is apparent that the HRD 3000 is capable of holding and physically addressing around 6 MB of memory in a single layer configuration and around 12 MB in a double layer fashion. My understanding (which may be wrong) is that the traditional HRD access maxes out at about 3.5 meg.

I am assuming that this is because the ROS will only allow 9 drives at a max of 1600 sectors each.

Now the question..... Is this simply a convention of ROS (allowing 9 drives only which allow the 3.5 MB) or is there a deeper cause rooted in some TI DSR or ROM code ?

Thanks.

Marcus...

------------------------------------

Yahoo! Groups Links

<*> To visit your group on the web, go to:
http://groups.yahoo.com/group/TI994A/

<*> Your email settings:
Individual Email | Traditional

<*> To change settings online go to:
http://groups.yahoo.com/group/TI994A/join
(Yahoo! ID required)

<*> To change settings via email:
! [email-masked]
[email-masked]

<*> To unsubscribe from this group, send an email to:
[email-masked]

<*> Your use of Yahoo! Groups is subject to:
http://docs.yahoo.com/info/terms/

---

From: Marc Hull <[email-masked]>
Date: Mon, 6 Feb 2012 14:29:07 -0800 (PST)

This card is only a 2 MEG HRD3000 with 4-512's.  When I run configure and edit the drives then the program will list only 1 page (10 possibilities) so I am not getting how you can format more than 10 drives per card (I said 9 earlier but that is not correct.) Formatting at 360 sectors per drive leaves a shitload of memory after configing the tenth drive but I can't seem to go past that one.  Need some finesse here.  I'm out of brute force at the moment ;-).  Thanks Richard.

Hull...

From: [email-masked] <[email-masked]>
Subject: Re: Re: [TI994A] More HRD questions....
To: [email-masked]
Date: Monday, February 6, 2012, 4:08 PM

  

      What's the physical setup? How many meg total? BTW, normal convention is to use CRU 1400 and 1600 for RAM disks. Other CRUs can be used but it's a pain when you put another card in like an RS232/2 at 1500 forgetting your RAM disk is there and you wipe the ROS on your next boot.   On 02/06/12, Marc Hull<[email-masked]> wrote: 

  Ummm.....My main system is setup with two WHT 4000 series. One card is 8 meg (512 SRAMS) and the other is 2 meg (1!
 28 SRAMS). Disks are 5 thru 9 and F thru Z 1600 sectors each disk.  On 02/06/12, Marc H<[email-masked]> wrote: Turns out the problem was in some crappy IC sockets. Who would of thunk it ??

Thanks.

Marcus...

Yahoo! Groups Links

---

From: [email-masked]
Date: Tue, 7 Feb 2012 08:15:01 +0000 (UTC)

I had my Horizon set up at >1000 and my SCSI at >1200 so the PGRAM was at >1700 and everything worked fine. 

Rich 

----- Original Message -----
From: [email-masked] 
To: [email-masked] 
Sent: Monday, February 6, 2012 2:08:32 PM 
Subject: Re: Re: [TI994A] More HRD questions.... 

--- On Mon, 2/6/12, [email-masked] < [email-masked] > wrote: 

From: [email-masked] < [email-masked] > 
Subject: Re: [TI994A] More HRD questions.... 
To: [email-masked] 
Date: Monday, February 6, 2012, 3:21 PM 

On 02/06/12, Marc H< [email-masked] > wrote: 

Thanks. 

Marcus... 

Yahoo! Groups Links

---

From: [email-masked]
Date: Tue, 7 Feb 2012 08:18:52 +0000 (UTC)

Oh yea you may have run into the ROS problem they had in that it could only be used for so many small drives and the rest for memory. 

If memory serves me there were numerous programs that would use the extra memory not used for drives. 

I think one was a music program that Don O'Neil wrote to use that memory. I never messed with it but I think Bruce Harrison did. 

Rich 

----- Original Message -----
From: "Marc Hull" <[email-masked]> 
To: [email-masked] 
Sent: Monday, February 6, 2012 2:29:07 PM 
Subject: Re: Re: [TI994A] More HRD questions.... 

Hull... 

  

<blockquote>

  

Ummm.....My main system is setup with two WHT 4000 series. One card is 8 meg (512 SRAMS) and the other is 2 meg (1! 28 SRAMS). Disks are 5 thru 9 and F thru Z 1600 sectors each disk. 

Thanks. 

Marcus... 

Yahoo! Groups Links 

</blockquote>

---

From: "Jacques" <[email-masked]>
Date: Tue, 7 Feb 2012 07:31:29 -0400

I have 3 RD cards installed in my PEB. 

1 – HRD 4000 installed at >1000 and configured as 5 DSDD drives (4, 5, 6, 7, C) and a drive A of 896 sectors. Next to nothing left over for RAMBO. BTW OPA had a few programs that used RAMBO. Harry Wilhelm also wrote some programs that used this memory.

2 – A 512K HRD (vintage unknown) installed at >1400 and configured as 1 DSDD drive (8) and a second drive of 600 sectors (9).

3 – A 192K RD (not HRD) installed at >1600 and configured as a drive 3 of 760 sectors. This card has about 5 or 6 empty sockets and could be expanded.

I also have 2 floppy drives used as DSK1 and DSK2. My PEB is full because it also contains a SAMS and a HSGPL card.

My HRD 4000 card still has problems in retaining memory overnight so each day I must reload its 6 drives. The last time that I ran the ROS TST programs, all 3 TST programs ran without indicating any errors.

About a month ago all 3 RD cards went down and I had to use Mini Memory to reinstall ROS in each card. Since I was using Funnelweb in DSK5  I have now decided to move the FW files to DSK3. I started this task over the last weekend so that even though my HRD 4000 is down I would still have a workable TI-99/4A set-up although with access to fewer programs. I am also in the process of reviewing all the installed programs and removing those that I rarely use.

Jacques

From: [email-masked] 
Sent: Tuesday, February 07, 2012 4:18 AM
To: [email-masked] 
Subject: Re: [TI994A] More HRD questions....

Rich

--------------------------------------------------------------------------------

      Hull...

          

                  

                Thanks.

                Marcus...

                Yahoo! Groups Links

---

From: [email-masked]
Date: Tue, 7 Feb 2012 20:21:30 +0000 (UTC)

Looks to me like a hard ware problem. 

If the the card does not retain memory it might cause problems with other cards as the ROS errors creates colisions. 

Also I hope you have the disk drives on a seperated power supply as it appears you are over taxing the TI Power supply. 

The most RD I ever used was a Corcomp 512K with HRD 3000 with my SCSI card and 4 drives. 

But sold the Corcomp and wished I had kept it as the most reliable RD I ever owned. 

Sorry I think you have hardware problems more then a ROS problem. 

Rich 

----- Original Message -----
From: "Jacques" <[email-masked]> 
To: [email-masked] 
Sent: Tuesday, February 7, 2012 3:31:29 AM 
Subject: Re: [TI994A] More HRD questions.... 

  

  

Jacques 

Rich 

----- Original Message -----
From: "Marc Hull" <[email-masked]> 
To: [email-masked] 
Sent: Monday, February 6, 2012 2:29:07 PM 
Subject: Re: Re: [TI994A] More HRD questions.... 

Hull... 

  

<blockquote>

  

  

Thanks. 

Marcus... 

Yahoo! Groups Links 

</blockquote>