Subject: Re: [TI994A] Genmod

From: [email-masked]
Date: Sun, 02 Sep 2012 06:47:00 -0500 (CDT)

Believe I have Dan Eicher's gen mod here. I'll look and see later today and respond on the Heat Wave BBS.

On 09/02/12, Insane Multitasker<[email-masked]> wrote:

Hi folks,

I am repairing a troublesome Genmod Geneve but the associated blue switch box was lost by the owner.

Does someone out there have the pinout documented or have an actual switchbox to ohm out?

Thanks  -tim

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 2 Sep 2012 15:38:58 -0500

Thank you, Richard.   

This one has been a pain.  Found a cold solder joint on the genmod contraption near the card led, which was causing some memory pages to come up as partial now and then.  My guess is sometimes the Geneve was going to the memex and other times the on board ram.    But there is still something not quite right with the board and I'm hoping it isn't an internal trace... Those are next to impossible to find and fix.   

To: [email-masked]
From: [email-masked]
Date: Sun, 2 Sep 2012 06:47:00 -0500
Subject: Re: [TI994A] Genmod

Believe I have Dan Eicher's gen mod here. I'll look and see later today and respond on the Heat Wave BBS.   On 09/02/12, Insane Multitasker<[email-masked]> wrote: 

Hi folks,

 
Thanks  -tim

---

From: "Beery" <[email-masked]>
Date: Tue, 04 Sep 2012 18:25:19 -0000

I believe I was the first guy that had a GenMOD unit after Bud started selling Ron's setup.

If you are getting intermittent pages, what the issue was one or more of the chips either on the Memex or the chips that needed replacing on the Geneve were not up to the higher specifications Ron specified.

Ron had some chips that need response times that were a fraction of the time on the original chips.  If they didn't respond quickly enough, you got memory read (maybe write, not sure) errors.  

Those errors weren't that it was trying to read on board versus Memex memory, rather, it couldn't read the Memex's memory correctly as the chips were too slow.

I don't know if on whtech if Ron's original Memex installation notes about which chips needing to be replaced are on the site or not.  

I do know that initially, Bud had saved a few dollars and bought some chips that were not up to the specs Ron required that caused problems.  I had to send my Memex and Geneve/GenMOD to Ron to go through the chips and find the problem chip(s).  Some of those chips that weren't to Ron's standards I believe went on Memex's destined for non-GenMOD systems.

Beery

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:
> From: swim4home@...
> Believe I have Dan Eicher's gen mod here. I'll look and see later today and respond on the Heat Wave BBS.   On 09/02/12, Insane Multitasker<insane_m@...> wrote: 
> 
> Hi folks,
>

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 4 Sep 2012 15:43:12 -0500

This should add some excitement to trying to fix the card! I thought I had read in the documentation that if the switch was NOT connected, the Gemod defaults to 1 wait state and will use the on-board Geneve 512K for the first 64 pages.  Since I am seeing partial pages in the 0x40-0x7f range as well as 0x00-0x3F, your explanation might be the clue I needed.  I'm still a little perplexed about the TIMODE using the onboard RAM and how the switches play into this.  I will search the docs for notes about the chip replacements.  Very helpful lead, Beery. Thanks Tim > To: [email-masked]
> From: [email-masked]
> Date: Tue, 4 Sep 2012 18:25:19 +0000
> Subject: [TI994A] Re: Genmod
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: "Beery" <[email-masked]>
Date: Wed, 05 Sep 2012 01:19:55 -0000

I better refine my explanation just a bit more after reading what you posted.

When the chips weren't fast enough, it would generate an error or two (not 100's or 1000's) on an 8K block when the memory was tested.

If you are seeing lots of errors as I think there may be an accumulator reported somewhere on MEMTEST, then you could be having another issue.

I do know though that the memory speeds are critical and depended upon some other chips.  What those specs were for the chips, I never saw  posted anywhere and I can only conclude Bud may still have the specs.  If he does, hopefully he would share it so it can be captured for the future.

Beery

--- In [email-masked], Insane Multitasker <insane_m@...> wrote:
> > From: bmiller@...
> > --- In [email-masked], Insane Multitasker <insane_m@> wrote:
> > >
> > > Thank you, Richard.   
> > > 
> > > From: swim4home@
> > > Believe I have Dan Eicher's gen mod here. I'll look and see later today and respond on the Heat Wave BBS.   On 09/02/12, Insane Multitasker<insane_m@> wrote: 
> > > 
> > > Hi folks,
> > >