Subject: Super Extended Basic (Triton)

From: "Michael Zapf" <[email-masked]>
Date: Sun, 03 Feb 2013 13:45:48 -0000

I discovered some problems with running Super Extended Basic in MESS. 

1. The cartridge does not have real GROMs - this is fixed now. I defined a new cartridge type for GROM emulations. This made it start again, but it crashes when I hit a key.

2. I noticed that SXB does some writing to the cartridge area. The usual Extended Basic behavior is to write a value to that area (6000-7fff) to switch between two ROM banks. However, there seem to be more activities with SXB.

The area at 7c10-7c17 seems to be writable; the following values are written (but never read):

7c10: 41 01 14 00 00 00 00 00

Could it be that SXB has some internal RAM? Or could it be an EEPROM? Or is that another device (like a mapper) with 8 ports? 

The effect was that by writing to this area, and assuming the standard Extended Basic mapping, the banks were switched multiple times, and then caused the lockup. So this indicates that SXB behaves differently.

Michael

---

From: Jeff White <[email-masked]>
Date: Sun, 3 Feb 2013 11:50:20 -0500

I do not know of a cartridge that banks ROM by writing to  >7xxx area.  Standard TI XB banking is to write to even byte >6000 or >6002 to swap 4K ROM at >7000-7FFF.  Some Atarisoft titles bank entire 8K bank.  TI Calc has 4 banks selected by writes to >6000, >6002, >6004, and >6006.

Because of partial decoding of the address bus, writes to unintended addresses may bank ROM.

I think your best course of action is to not allow banking with writes to >7xxx.

Jeff

---

From: "Dan O'Quinn" <[email-masked]>
Date: Sun, 3 Feb 2013 12:01:29 -0500

seb uses an rom and eprom
http://www.mainbyte.com/ti99/software/seb/super.html

----- Original Message ----- 
From: "Michael Zapf" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, February 03, 2013 8:45 AM
Subject: [TI994A] Super Extended Basic (Triton)

> 1. The cartridge does not have real GROMs - this is fixed now. I defined a 
> new cartridge type for GROM emulations. This made it start again, but it 
> crashes when I hit a key.
>
> 2. I noticed that SXB does some writing to the cartridge area. The usual 
> Extended Basic behavior is to write a value to that area (6000-7fff) to 
> switch between two ROM banks. However, there seem to be more activities 
> with SXB.
>
> Could it be that SXB has some internal RAM? Or could it be an EEPROM? Or 
> is that another device (like a mapper) with 8 ports?
>
> The effect was that by writing to this area, and assuming the standard 
> Extended Basic mapping, the banks were switched multiple times, and then 
> caused the lockup. So this indicates that SXB behaves differently.
>
> Michael
>
>
>
> ------------------------------------
>
> Yahoo! Groups Links
>
>
>