Subject: Myarc 12/512K Question

From: "epergrem" <[email-masked]>
Date: Sat, 22 Oct 2011 14:39:17 -0000

I'm testing two Myarc 32/128/512K Memory Expansion cards and I have the same issue with both of them that I think is normal behavior, but need to confirm.

In TI BASIC, both cards: a) have 512K and all banks test good using CALL RDTEST; b) partition okay; c) can create DSK5 using CALL EMDK(5); d) can save a program to DSK5 in TI BASIC; e) can be cataloged using CALL RDDIR.

The problem seems to be that if I do a CALL MGR from my HRD, I can see DSK5, but if I try to copy to DSK5 I get a "DISK ERROR" and then DSK5 becomes unavailable.  

This happens on both cards, so I think it's the "AT EVERY POWER SHUTDOWN OR POWER INTERRUPTION ALL STORED MEMORY IS ERASED" issue that is mentioned in the manual.  

So, without a power supply, is the RAM disk portion of the Myarc 512K card only usable only in TI BASIC or Extended BASIC?

Thanks,
Ernie

---

From: ti99_forever <[email-masked]>
Date: Sat, 22 Oct 2011 08:16:33 -0700 (PDT)

No, as long as the PES power stays on, it should work.

But that isn't to say it plays well with everything...

>________________________________
>From: epergrem <[email-masked]>
>To: [email-masked]
>Sent: Saturday, October 22, 2011 10:39 AM
>Subject: [TI994A] Myarc 12/512K Question
>
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: "epergrem" <[email-masked]>
Date: Sat, 22 Oct 2011 20:38:50 -0000

I thought that also, but I now have three cards (one-128K and two-512K) that work as I described.  If I do a BYE in TI BASIC or Extended BASIC and then go into the other menu option, DSK5 is no longer available.

Perhaps the reset is acting as a power interruption to the card?

Ernie

--- In [email-masked], ti99_forever <ti99_forever@...> wrote:
> >From: epergrem <epergrem@...>
> >The problem seems to be that if I do a CALL MGR from my HRD, I can see DSK5, but if I try to copy to DSK5 I get a "DISK ERROR" and then DSK5 becomes unavailable.ï¿½ 
> >
> >This happens on both cards, so I think it's the "AT EVERY POWER SHUTDOWN OR POWER INTERRUPTION ALL STORED MEMORY IS ERASED" issue that is mentioned in the manual.ï¿½ 
> >

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 22 Oct 2011 16:29:56 -0500

What drive letter(s) are defined within the Horizon?  ROS may be trying to catalog the Horizon DSK5. post-reset.  I do not recall how well ROS plays with the Myarc RAMdisk.
 
Remove the Horizon RAMdisk then use CALL RDDIR to catalog before and after a reset.   If all functions work, you may consider setting the Horizon to a higher (or lower) CRU than the Myarc card.  It is conceivable the Horizon is intercepting the DSK5. call after the reset, something not noticable within BASIC given your documented sequence. 

> From: [email-masked]
> Date: Sat, 22 Oct 2011 14:39:17 +0000

---

From: "epergrem" <[email-masked]>
Date: Sat, 22 Oct 2011 23:48:33 -0000

Thanks 
I'll give it a try.  

It would be a shame if the Myarc doesn't work with the Horizon, but at least it would explain why all three cards react similar.
Ernie

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 22 Oct 2011 20:34:43 -0500

Fred - 
 
I had an idea for use with DM2K that might minimize or mask the SCSI DSR issue found when opening/using multiple and recursive folders.   Since the problem is DSR-specific, what if you were to track the number of SCSI folder "open" attempts and upon reaching 15 (since the problem occurs at 16) you called the SCSI DSR power-up routine?  Doing so should in theory reset all offending buffers and pointers.

---

From: fdos <[email-masked]>
Date: Sun, 23 Oct 2011 16:39:11 -0700

Ernie,

It has been several decades since I've had my Myarc 512K card and Myarc 
XB II going on a full time basis.  In fact, my 512K card was converted 
to Geneve operation in the early 1990's, and never very reliable as 
Geneve memory, so it got lost or was sent for repair and never returned 
like two other PEB cards I use to have.

In any case, I was living in Florida at the time, so I built a battery 
backed power supply for the external power jack of the 512K card due to 
the AC power failures and voltage spikes common to that area.  I'm 
reasonably sure that it's out in my garage some where.  Another reason 
for that backup supply was that my Geneve got all the best hardware in 
those days, but I still wanted to use that expensive investment that 
didn't pan out.  Therefore, I had a PEB system without an FDC, so I 
loaded up the 360K RAMDISK via serial communications with the Geneve 
after a CALL PART(128,360,24), and when I wasn't using Myarc XBII I was 
using the XB/EA combo created with the MG GK software which allowed CALL 
PART() to be done from a menu selection before selecting XB.

I know I didn't have to CALL PART() very often even though I loaded many 
different programs, and I know exiting from XB or TI BASIC with BYE did 
not trash or reset the RAMDISK.  I also know I used CALL EMDK() probably 
set to DSK1 as I didn't have an HRD in that PEB.

That's about all I recall.

Bill S

On 10/22/2011 1:38 PM, epergrem wrote:
> --- In [email-masked], ti99_forever<ti99_forever@...>  wrote:
>>
>>> From: epergrem<epergrem@...>

-- 
Bill R Sullivan (FDOS)
Go Forth+ or X4th99

---

From: "epergrem" <[email-masked]>
Date: Sun, 23 Oct 2011 23:54:27 -0000

Thanks Bill,
It turns out that Tim was spot on.  When I removed the Horizon RAM disk from the pbox, the Myarc 128/512K card worked as it should.  I was even able to load XBII into it.

I'm not sure why the issue, unless the HRD ROS has DSK5 hard coded, so it was grabbing the Myarc's DSK5, even though the HRD was set to DSK9.

Thanks for everyone's response. 

Ernie

---

From: Jeffrey White <[email-masked]>
Date: Mon, 24 Oct 2011 22:47:03 -0700 (PDT)

Ernie,

In order for a Myarc RAMdisk to play nice with a Horizon RAMdisk, the Horizon 
cannot have the 32K expansion RAM option.

The Myarc RAMdisk occupies CRU>1000 and CRU>1900.  If the disk manager you use 
starts at >1200 and cycles around to >1100 (the floppy controller) to get around 
the TI FDC bugs, then it may cause issues with the Myarc RAMdisk.

Jeff White

________________________________
From: epergrem <[email-masked]>
To: [email-masked]
Sent: Sun, October 23, 2011 7:54:27 PM
Subject: [TI994A] Re: Myarc 12/512K Question

Thanks Bill,
It turns out that Tim was spot on. When I removed the Horizon RAM disk from the 
pbox, the Myarc 128/512K card worked as it should. I was even able to load XBII 
into it.

I'm not sure why the issue, unless the HRD ROS has DSK5 hard coded, so it was 
grabbing the Myarc's DSK5, even though the HRD was set to DSK9.

Ernie