Subject: DSRLNK.... or not so much.....

From: "Marc H" <[email-masked]>
Date: Fri, 12 Oct 2012 00:11:57 -0000

So this little home brew DSRLNK I am cooking has hit a snag.  I can get as far as finding the correct DSR and deriving it's entry point.
I have verified this by checking my values against what I came up with using the easybug function of the MINIMEM cart.

Having done that I dove headlong into the routine via a BL *R1 (r1 contains the DSR entry point.)  The computer promptly freezes like ... well a frozen computer.

I am guessing that something other than the location of the name length byte needs to be set up before the routine is engaged.  What that is I really don't know.  If someone knows what I am missing or has a link to a doc that might shed some light on what the DSR's are expecting I sure would appreciate it.  I have a very finite amount of hair left and It's hard enough to spread it out enough to cover my scalp as it is ;-).

Thanks...

Marcus

---

From: mark wills <[email-masked]>
Date: Fri, 12 Oct 2012 20:08:44 +0100 (BST)

Marc,

Check out the Smart Programmer, 1986 issue 07. It has a universal DSRLNK routine - I know it works because I used it for TurboForth - with a few hacks to allow it to run from a ROM rather than RAM.

I've attached the issue to this email in electronic form. You need the MAX file viewer to read the file. I don't have a PDF version unfortunately.

Hope this helps,

Mark

>________________________________
> From: Marc H <[email-masked]>
>To: [email-masked] 
>Sent: Friday, 12 October 2012, 1:11
>Subject: [TI994A] DSRLNK.... or not so much.....
> 
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: [email-masked]
Date: Fri, 12 Oct 2012 20:24:17 +0000 (UTC)

Yea Marc, 

I did the same thing for a RXB version way back in the third version. 
Also I include a note asking for everyone to use this one as all the others people use fail or crash as non- compatible with some software. 
The common problem is when you use DSRLNK with the others it only works with files and not anything else. 

Rich 

----- Original Message -----
From: "mark wills" <[email-masked]> 
To: [email-masked] 
Cc: "Marc Hull" <[email-masked]> 
Sent: Friday, October 12, 2012 12:08:44 PM 
Subject: [TI994A] DSRLNK 

Marc, 

Hope this helps, 

Mark 

Thanks... 

Marcus 

Yahoo! Groups Links

---

From: Marc Hull <[email-masked]>
Date: Fri, 12 Oct 2012 15:05:32 -0700 (PDT)

Hey Mark, I found it on WHT.  Thanks for the heads up and it looks good except that it invades Low MEM and (as I should have stated earlier) I am trying to avoid that.  I want to use the 8K of low mem for data storage.  While on WHT I did find the FWeb source for a DSRLNK.  It seems pretty well commented so perhaps it will give me some insight.

Thanks again.

Marc.

--- On Fri, 10/12/12, mark wills <[email-masked]> wrote:

From: mark wills <[email-masked]>
Subject: [TI994A] DSRLNK
To: "[email-masked]" <[email-masked]>
Cc: "Marc Hull" <[email-masked]>
Date: Friday, October 12, 2012, 2:08 PM

  

      Marc,

So this little home brew DSRLNK I am cooking has hit a snag.  I can get as far as
 finding the correct DSR and deriving it's entry point.
I have verified this by checking my values against what I came up with using the easybug function of the MINIMEM cart.

Thanks...

Marcus

Yahoo! Groups Links

---

From: Tony Knerr <[email-masked]>
Date: Fri, 12 Oct 2012 18:41:28 -0400

Hi Marc.

Some good information on disk access and PABS  can be found in the 
document that I've linked to below.
A good source of info many overlook.

ftp://ftp.whtech.com/datasheets%20and%20manuals/Specifications/gpl%20interfce%20specs%20for%2099-4%20disk%20peripheral.pdf

I've also attached a commented source file of a routine I use to back up 
my Ramdisk to a DF128 file.
I just added the comments after about 15 years, so I hope I got 'em 
right. ;)
I think it's a good example of both file and sector access in one place.

Remember you've got to access a file in assembly the same way you do in 
Basic:
1. open it
2. do your business (read, write)
3. close it

Let me know if this helps or hurts.

Tony

On 10/12/2012 6:05 PM, Marc Hull wrote:
>
> Hey Mark, I found it on WHT.  Thanks for the heads up and it looks 
> good except that it invades Low MEM and (as I should have stated 
> earlier) I am trying to avoid that.  I want to use the 8K of low mem 
> for data storage.  While on WHT I did find the FWeb source for a 
> DSRLNK.  It seems pretty well commented so perhaps it will give me 
> some insight.
>
> Thanks again.
>
> Marc.
>
> -
>