Subject: DSR dump program

From: "epergrem" <[email-masked]>
Date: Sat, 07 Jan 2012 23:47:49 -0000

I'm looking for a program that can dump a DSR to a file after accepting the CRU
address as an input.

I have Disk Assembler that I can use in a crunch, but would prefer something
that does just a straight binary dump of the DSR space to disk.

Thanks,
Ernie

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 08 Jan 2012 11:15:50 -0000

Hi Ernie,

> that does just a straight binary dump of the DSR space to disk.

maybe that DSR is already dumped for MESS? 

The problem is that dumping is not always that easy and may require specific actions. For instance, the HFDC has four ROM pages that you have to select via CRU bit 3 and 4. So you have four different contents for the area >4000 to >4fff (>5000->5fff is RAM).

Most other cards, of course, just map the contents into the address space via bit 0.

Michael

---

From: "Jens-Eike Hartwig" <[email-masked]>
Date: Sun, 08 Jan 2012 17:09:12 +0100

Have you tried Harald Glaab's  Memory-Manager?
http://home.arcor.de/system-ninety-nine-user-group/evpc/index_e.htm
It can set CRU bits and save to disk (among many other functions, like
adding a header), be sure to read the documentation thoroughly!

GreeTIngs
Jens-Eike 

-----Original Message-----
Date: Sun, 08 Jan 2012 00:47:49 +0100
Subject: [TI994A] DSR dump program
From: "epergrem" <[email-masked]>
To: [email-masked]

I'm looking for a program that can dump a DSR to a file after accepting
the CRU
address as an input.

I have Disk Assembler that I can use in a crunch, but would prefer
something
that does just a straight binary dump of the DSR space to disk.

Thanks,
Ernie

------------------------------------

Yahoo! Groups Links

---

From: "epergrem" <[email-masked]>
Date: Sun, 08 Jan 2012 16:33:56 -0000

Thanks everyone!
I knew this was the place to post the message. 

In addition to the online replies I've gotten a couple dump program through email.  I haven't had a chance to try any, so that will be today's project.

By way of explanation; I was asked to sell a TI "TMR CONTROL" card, which fits in the expansion system. My guess is that it was something that TI was either playing with or doing for an industrial customer.  I want to get a better understanding of the card's function before I list it on eBay.

As for now, all I get is a "Simulator Error" message.  Based on the DSR dump I did using Disk Assembler, it appears that the card is expecting some software that I don't have.  Still, it's fun to play with. 

I'll post a DSR dump, printouts and card photos once it's a little more complete.

Thanks again,
Ernie