Subject: looking for an assist with a DSR test

From: Insane Multitasker <[email-masked]>
Date: Sat, 7 Jul 2012 02:14:27 -0500

I'm in need of some test results from a Myarc HFDC and Myarc FDC, installed in a TI (not Geneve) system.  
 
1. Format a 360K disk
2. Copy any one file to the disk
3. Delete the one file
4. Verify the disk is blank
5. In Extended BASIC type the following, replacing 'x' with the floppy disk number you formatted
 
100 OPEN #1:"DSKx.TEST",INTERNAL,FIXED 255,RELATIVE 4100
110 CLOSE #1
 
6. Run program
7. Report the error or success
8. Catalog the disk and report free/used and any files that show up in the catalog

In at least one instance,if I run this test I receive an error (expected) however, the floppy disk fills up and the filename from step 2 re-appears.  The test file is not present where one might expect the DSR to reserve the open space on the disk.  
 
FYI, the Relative 4100 tells the DSR to reserve 4100 records within the file.  Not possible on a 1438 sector disk.   I encountered the above error unexpectedly while working on some related DSR code. 
 
Thanks.

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 21 Jul 2012 23:46:04 -0500

I haven't had any takers so I did some tests of my own.  
 
Seems there are differences between controllers and handling fixed record allocation.  Also some differences with ROS DSR handling and error trapping.  Will post some results of initial tests as time permits.  Still could use a volunteer or two to confirm my findings. 
 
Tim

To: [email-masked]
From: [email-masked]
Date: Sat, 7 Jul 2012 02:14:27 -0500
Subject: [TI994A] looking for an assist with a DSR test

1. Format a 360K disk

6. Run program

 
Thanks.

---

From: ti99_forever <[email-masked]>
Date: Sun, 22 Jul 2012 04:17:42 -0700 (PDT)

Well, this interests me. I have seen some failures regarding fixed record allocation but it wasn't this situation.

Always liked the record allocation... I was shocked by TI titles that went through and wrote something to every record in a file. Yes, allocation doesn't set the records to what you want, but you can still program around it. ISTR it returns a certain error code if you try to read a preallocated but unused record. Most likely some input error because you are reading gibberish... and I've mostly used this in Basic, although I tried to expand Wycove Forth to handle it -- and wound up breaking something else.

But I have a BwG controller in my system.

Ben

>________________________________
> From: Insane Multitasker <[email-masked]>
>Sent: Sunday, July 22, 2012 12:46 AM
>Subject: RE: [TI994A] looking for an assist with a DSR test
> 
>
>  
>
>
>
>________________________________

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 22 Jul 2012 17:20:12 -0500

I wouldn't mind learning a bit about the BwG differences and similarities - the more test data the better.
 
You bring up a good point about preallocation and unused records.  If you create a large file and write to the last record, any records in between can be read though depending on the file attributes, the DSR may return gibberish (ie, whatever is on disk) or an error if the record length/data is not what was expected.  I usually bite the bullet and initialize all the records I reserve.  
 
The nicest feature of this allocation is that it reduces file fracturing, especially if you are writing two "growing" files on the same device.   

To: [email-masked]
From: [email-masked]
Date: Sun, 22 Jul 2012 04:17:42 -0700
Subject: Re: [TI994A] looking for an assist with a DSR test

Ben

 
 
Tim

 
1. Format a 360K disk

6. Run program

 
Thanks.

---

From: Tony Knerr <[email-masked]>
Date: Sun, 22 Jul 2012 18:57:23 -0400

If I can find 8 seconds to spare sometime I can help with the Myarc FDC 
test. :-[

Tony

On 7/22/2012 6:20 PM, Insane Multitasker wrote:
>
> I wouldn't mind learning a bit about the BwG differences and 
> similarities - the more test data the better.
>
> You bring up a good point about preallocation and unused records.  If 
> you create a large file and write to the last record, any records in 
> between can be read though depending on the file attributes, the DSR 
> may return gibberish (ie, whatever is on disk) or an error if the 
> record length/data is not what was expected.  I usually bite the 
> bullet and initialize all the records I reserve.
>
> The nicest feature of this allocation is that it reduces file 
> fracturing, especially if you are writing two "growing" files on the 
> same device.
>
>
> ------------------------------------------------------------------------
> Well, this interests me. I have seen some failures regarding fixed 
> record allocation but it wasn't this situation.
>
> Always liked the record allocation... I was shocked by TI titles that 
> went through and wrote something to every record in a file. Yes, 
> allocation doesn't set the records to what you want, but you can still 
> program around it. ISTR it returns a certain error code if you try to 
> read a preallocated but unused record. Most likely some input error 
> because you are reading gibberish... and I've mostly used this in 
> Basic, although I tried to expand Wycove Forth to handle it -- and 
> wound up breaking something else.
>
>     ------------------------------------------------------------------------
>     *From:* Insane Multitasker <[email-masked]>
>     *To:* [email-masked]
>     *Sent:* Sunday, July 22, 2012 12:46 AM
>     *Subject:* RE: [TI994A] looking for an assist with a DSR test
>
>
>
>     Seems there are differences between controllers and handling fixed
>     record allocation.  Also some differences with ROS DSR handling
>     and error trapping. Will post some results of initial tests as
>     time permits.  Still could use a volunteer or two to confirm my
>     findings.
>
>     Tim
>
>
>     ------------------------------------------------------------------------
>     In at least one instance,if I run this test I receive an error
>     (expected) however, the floppy disk fills up and the filename from
>     step 2 re-appears.  The test file is not present where one might
>     expect the DSR to reserve the open space on the disk.
>
>     FYI, the Relative 4100 tells the DSR to reserve 4100 records
>     within the file.  Not possible on a 1438 sector disk.   I
>     encountered the above error unexpectedly while working on some
>     related DSR code.
>
>     Thanks.
>
>

---

From: "Tony Knerr" <[email-masked]>
Date: Sat, 28 Jul 2012 13:15:21 -0000

Just got a chance to run this test using a TI with Myarc FDC.
The FDC has the 80 track eprom. Test was run on 40 track drive.

Got an I/O error on running the XB program.
In the disk catalog the original file showed back up, a 2 sector program image. The TEST program also showed up as a 1436 sector I/F 255 file.

Tony

---

From: [email-masked]
Date: Sat, 28 Jul 2012 20:35:33 +0000 (UTC)

Tony 

How did it work with RXB? 

On the RXB or EA side. 

I have a Myarc Controller 80 track and it works fine on the 80 track side for me. 

Though XB programs crash and I think the way it does the headers sector is messed. 

Rich 

----- Original Message -----
From: "Tony Knerr" <[email-masked]> 
To: [email-masked] 
Sent: Saturday, July 28, 2012 6:15:21 AM 
Subject: [TI994A] Re: looking for an assist with a DSR test 

Tony

---

From: Tony Knerr <[email-masked]>
Date: Sat, 28 Jul 2012 16:58:09 -0400

I didn't try RXB, just good 'ol XB. The point of the test is to keep it 
simple and nut muck up the results
by making the test exotic. Tim is looking for a specific problem in a 
disk controller DSR by gathering
information from others using a 360k disk and over-allocating the 
sectors on the disk. The test is
supposed to give an error.

Can you describe the exact results of your test, as I did? ...and are 
you using a 360k disk?

Tony

On 7/28/2012 4:35 PM, [email-masked] wrote:
> *From: *"Tony Knerr" <[email-masked]>
> *To: [email-masked]
> *Sent: *Saturday, July 28, 2012 6:15:21 AM
> *Subject: *[TI994A] Re: looking for an assist with a DSR test
>
> In the disk catalog the original file showed back up, a 2 sector 
> program image. The TEST program also showed up as a 1436 sector I/F 
> 255 file.
>
> Tony
>
>
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, 
> Insane Multitasker <insane_m@...> wrote:
> >
> >
> step 2 re-appears. The test file is not present where one might expect 
> the DSR to reserve the open space on the disk.
> >
> > FYI, the Relative 4100 tells the DSR to reserve 4100 records within 
> the file. Not possible on a 1438 sector disk. I encountered the above 
> error unexpectedly while working on some related DSR code.
> >
> > Thanks.
> >
>
> _

---

From: [email-masked]
Date: Sun, 29 Jul 2012 02:49:50 +0000 (UTC)

I formated using the Myarc Software and RXB could catalog them but if I remember the numbers were wrong. 

But that I could catalog them and run them was not a problem. 

So yea something is goofy, but I think it was the way that Myarc designed the format. 

Rich 

----- Original Message -----
From: "Tony Knerr" <[email-masked]> 
To: [email-masked] 
Sent: Saturday, July 28, 2012 1:58:09 PM 
Subject: Re: [TI994A] Re: looking for an assist with a DSR test 

I didn't try RXB, just good 'ol XB. The point of the test is to keep it simple and nut muck up the results 
by making the test exotic. Tim is looking for a specific problem in a disk controller DSR by gathering 
information from others using a 360k disk and over-allocating the sectors on the disk. The test is 
supposed to give an error. 

Can you describe the exact results of your test, as I did? ...and are you using a 360k disk? 

Tony 

  

Tony 

On the RXB or EA side. 

Rich 

----- Original Message -----
From: "Tony Knerr" <[email-masked]> 
To: [email-masked] 
Sent: Saturday, July 28, 2012 6:15:21 AM 
Subject: [TI994A] Re: looking for an assist with a DSR test 

Tony 

_

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 29 Jul 2012 16:42:01 -0500

Just so I am clear both the created file and the program you saved then deleted  showed up during the catalog?  

> From: [email-masked]
> Date: Sat, 28 Jul 2012 13:15:21 +0000
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: Tony Knerr <[email-masked]>
Date: Sun, 29 Jul 2012 18:41:53 -0400

Yes.

On 7/29/2012 5:42 PM, Insane Multitasker wrote:
>
> Just so I am clear both the created file and the program you saved 
> then deleted  showed up during the catalog?
>