Subject: MESS Chdman v5

From: "Tony Knerr" <[email-masked]>
Date: Sat, 07 Apr 2012 16:41:47 -0000

Has anyone been able to successfully update their hard drive images to v5? I've tried a few different versions of CHDMAN.EXE with no success.

Tony

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 08 Apr 2012 12:07:02 -0000

Converting to v5 should work this way:

chdman copy -i oldimage.hd -o newimage.hd -c none

(-i <inputfile> -o <outputfile> -c <compression>)

Do not forget to add the -c switch, or chdman will attempt to compress the image, which is not appropriate for hard disks.

Michael

---

From: Tony Knerr <[email-masked]>
Date: Sun, 08 Apr 2012 20:23:04 -0400

Thanks for the info, Michael.

At least that command tries to do the job, but I get a read error at 
about 21%.
The input drive verifies ok while running Mess, so I guess the new 
Chdman isn't bug free yet?

Tony

---

From: "Michael Zapf" <[email-masked]>
Date: Mon, 09 Apr 2012 10:09:06 -0000

Hi Tony,
 
> At least that command tries to do the job, but I get a read error at 

What program reports the error? Is it during chdman conversion or during usage within the emulation?

> Chdman isn't bug free yet?

I do hope it's bugfree, because I already converted my HD image some weeks ago. I have not got any read errors since I converted it, and I did quite some programming (the XMODEM program for MDOS).

Michael

---

From: Tony Knerr <[email-masked]>
Date: Mon, 09 Apr 2012 18:24:02 -0400

It's Chdman that reports the error, Michael. On a 248mb drive. it stops 
at around 67mb and issues the error.
I just tried it on a 96.3mb drive, and it was successful, but it 
compressed the drive to 27.0mb even with using
the -c none option. The version of Chdman is 0.145u3 (Feb 28 2012).

The 248mb drive  that gives the error verifies ok in Mess Geneve 
Emulation using MDM5, so that drive appears to be intact.

First time I've had a problem with Chdman. :(
I did notice a lot of reports of it being buggy while surfing around 
looking for it, though.

Perhaps it's best to wait for some more stability to upgrade?

Tony

On 4/9/2012 6:09 AM, Michael Zapf wrote:
> I do hope it's bugfree, because I already converted my HD image some 
> weeks ago. I have not got any read errors since I converted it, and I 
> did quite some programming (the XMODEM program for MDOS).
>
> Michael
>

---

From: "Michael Zapf" <[email-masked]>
Date: Tue, 10 Apr 2012 10:30:56 -0000

Hi Tony,

> the -c none option. The version of Chdman is 0.145u3 (Feb 28 2012).

ah, I see - no, it does not compress it: The new thing about CHDv5 is that empty tracks are skipped, so your v5 image only contains the non-empty tracks. As soon as you write to the track, the image expands by the length of that track.

> Emulation using MDM5, so that drive appears to be intact.

You mean that if you check the old v4 version in the Geneve there is no error, but still chdman fails to convert it, right?

Could you perhaps try the following: Download and start my new TIImageTool ( http://www.mizapf.de/ti99/tiimagetool.zip ) which works with both v4 and v5. Do a check of the file system (Utility) of your v4 image.

And while I'm writing this I got the idea that if everything else fails, you should create a new empty hard disk with chdman, format it with Myarc Disk Manager, and then use TIImageTool to copy all files from one hard disk to the other. Yes, it copies recursively.

Actually, you need to convert to v5 when you want to use the latest MESS versions, including my new expansion card handling, Horizon Ramdisk emulation, and so on.

I suppose there is no practical way for me to get a copy of your 248 MiB hard disk image so I could figure out the problem (let alone that you would allow me to peek into your data :-) )

Michael

---

From: "Michael Zapf" <[email-masked]>
Date: Wed, 11 Apr 2012 10:48:28 -0000

One more test: Try to extract the contents of the v4 image with chdman. If the conversion fails, the extraction should fail as well.

You could also copy the image file of your v4 image (on the PC, outside of the emulation), then use the Geneve to wipe the contents. If the v4 is OK for the emulation, it should be possible to delete all files. Or better format it - this should safely overwrite all sectors.

And if that works, try to convert with chdman. If that again fails, zip the file and send it to me. I'd be highly interested in that file in order to fix any possible bug in chdman.

Michael

---

From: Tony Knerr <[email-masked]>
Date: Wed, 11 Apr 2012 17:57:07 -0400

Hi Michael.

I've gotten the image converted to v5. I accomplished it by creating a 
fresh v4 image and XCOPYing all the
files from the non-convertable image to it from the running Geneve 
emulation.
I then created a v5 image from it per your  chdman copy example. The 
newly created image verifies ok
with Tidir, but it will not boot the Geneve with Mess or Messui 
v0.145u5. Neither will boot from a floppy image,
either. The floppy image works fine with v0.142.

Are there any other special procedures to getting the Geneve to boot 
with v0.145 and up?

Thanks,

Tony

On 4/11/2012 6:48 AM, Michael Zapf wrote:
>
> One more test: Try to extract the contents of the v4 image with 
> chdman. If the conversion fails, the extraction should fail as well.
>
> You could also copy the image file of your v4 image (on the PC, 
> outside of the emulation), then use the Geneve to wipe the contents. 
> If the v4 is OK for the emulation, it should be possible to delete all 
> files. Or better format it - this should safely overwrite all sectors.
>
> And if that works, try to convert with chdman. If that again fails, 
> zip the file and send it to me. I'd be highly interested in that file 
> in order to fix any possible bug in chdman.
>
> Michael
>

---

From: Tony Knerr <[email-masked]>
Date: Wed, 11 Apr 2012 17:58:54 -0400

Append "Tidir" to "tiimagetool".  Sorry.

On 4/11/2012 5:57 PM, Tony Knerr wrote:
>> If the v4 is OK for the emulation, it should be possible to delete 
>> all files. Or better format it - this should safely overwrite all 
>> sectors.
>>

---

From: "Michael Zapf" <[email-masked]>
Date: Wed, 11 Apr 2012 22:53:19 -0000

> Are there any other special procedures to getting the Geneve to boot 

Have you checked the parameters for starting up? They changed considerably from 0.144 to 0.145. In particular, you must specify that you have a HFDC in slot 7 or 8.

For instance, you start up with

mess geneve -peb:slot8 hfdc -hard1 myhardisk.hd

You get all options with

mess geneve -listslots

Using QMC you have to plug in the HFDC using the slot options on the right side.

The background of this change is the restructuring of the architecture to a more modular one, which also reflects the actual slots in the expansion box. You can, for instance, use both the HFDC and another floppy controller now which was impossible before 0.145. Or two RS232 cards.

Michael

---

From: Tony Knerr <[email-masked]>
Date: Wed, 11 Apr 2012 21:09:45 -0400

Thanks, Michael. I got it working.
My batch file to start Mess Geneve emulation went from 78 bytes to 180 
bytes.
Don't have much hair left, pulled about half of what little I have 
remaining out. :)

I think you keep making this harder just to see if we can keep up with 
you. ;)

Tony

On 4/11/2012 6:53 PM, Michael Zapf wrote:
> Have you checked the parameters for starting up? They changed 
> considerably from 0.144 to 0.145. In particular, you must specify that 
> you have a HFDC in slot 7 or 8.
>
> The background of this change is the restructuring of the architecture 
> to a more modular one, which also reflects the actual slots in the 
> expansion box. You can, for instance, use both the HFDC and another 
> floppy controller now which was impossible before 0.145. Or two RS232 
> cards.
>
> Michael
>

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 12 Apr 2012 11:35:10 -0000

Hi Tony and all,

I can imagine that all these changes in MESS are sometimes a nuisance. I hope that the 0.144/0.145 change was the biggest one for a longer time now. 

I did not like the CHD change either, especially because you have to convert your image. I believe it would have been possible to add an option to keep downward compatibility or employ an auto-detect mechanism (like in TIImageTool). But CHD is not within my responsibility.

In January/February I completed the rewrite of the TI emulation. Indeed, I had some free days and worked from morning till evening on it with high pressure, don't remember whether I ever invested that much effort in my job :-). Most of the changes are in the code, but some are visible on the command line. In turn, you don't have the configuration switches anymore (have a look at the menu). And you only get the DIP switches of those cards that are plugged in. 

Another advantage of this is that we can finally split up the ROMs for the cards and so avoid error messages like missing ROMs. Each card that I added in the past required its DSR ROM in the ZIP file, and I had to declare it optional, or the MESS emulation would not have started at all. Now it's more the way it should be: If you have, for instance, a BWG controller, you get a ROM dump from your card and use it in MESS, without messing around with licensing issues. 

..

In fact, the TI emulation is one of the most complex emulations within MESS; you can see that just by the extra ti99 folder in the codebase. However, all the work on the various expansion cards made it lag behind in technical view. Actually, shortly after I converted all implementations to C++, the legacy code support was removed from MESS ... seems as if the others have been waiting for me. 

But now the TI emulation is up front with all other emulations in MESS. The good thing about this is that now, no one of the other developers feels urged to upgrade the TI emulation by himself. While I believe all others are doing a great job, I'm possibly the person of choice to work on the TI stuff, since I have the means to do intensive debugging, also with the real device. If I leave that to the others, things may break, and well, question is how much they care.

I'm still not done; some more plans:

- I'm rewriting the CPU core, in particular to be able to implement a proper READY line handling. So that is deep inside, and you won't see anything on the surface. It will, however, improve the emulation quality in terms of timing.

- I already took some sound samples of floppy operations. One of my oldest wishes is to have an audible feedback from the floppy. Raaak-raaak ... tuk ... tuk ... tuk ... (This will, of course, only be available if you select real speed for floppies.)

With the new organisation of the P-Box as a collection of slots in MESS, we can also think of adding visible effects, like a picture of the P-Box with LEDs flashing. This is already possible by the concept of "artwork", but together with the sounds I'd suggest to enhance that to a "physical effect framework". I'll have to discuss this with the others.

...

What I can do for you is that I regularly update my pages on ninerpedia. It already contains some good hints for new people and those that encounter some problems while upgrading to a new version. I'll be happy to help anyone, but I'd also like to point everyone to the MESS pages on www.ninerpedia.org , especially when there is a new version.

Michael

---

From: ti99_forever <[email-masked]>
Date: Thu, 12 Apr 2012 04:42:04 -0700 (PDT)

I hope the "roar" of the P-box fan will be an option?  I used to fall asleep to that at night, while my TI chugged out some long-running program... often to be woken up by some error "honk" in the middle of the night if it was a Basic program... ;)

>________________________________
> From: Michael Zapf <[email-masked]>
>To: [email-masked] 
>Sent: Thursday, April 12, 2012 7:35 AM
>Subject: [TI994A] Re: MESS Chdman v5
> 
>
>
>Hi Tony and all,
>
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 12 Apr 2012 12:34:33 -0000

> I hope the "roar" of the P-box fan will be an option?  I used to fall 
> asleep to that at night, while my TI chugged out some long-running 
> program... often to be woken up by some error "honk" in the middle of 
> the night if it was a Basic program... ;)

Well, could think about that ... :-)

Another funny thing what is available to some of the emulations is the simulation of the PAL/NTSC picture on the CRT, including geometric distortion and color effects.

This is done via the HLSL layer which is a DirectX feature; I don't know whether and when this will be available via SDL. So this is only available in Windows. I don't know either whether this is a general feature or whether it requires some work in the specific emulations.

Michael