Subject: Plato

From: Teresa Masters <[email-masked]>
Date: Sun, 28 Apr 2013 14:16:53 -0700

With permission from Eric Bray.

> 
> Blog: Technical Musings 
> Link: http://drbray.blogspot.com/ 

I was so proud of Plato way back then and n ow I am reminded why.

Hugs,
Terrie

Teresa Masters

---

From: Eric Neuman <[email-masked]>
Date: Sun, 28 Apr 2013 15:59:01 -0700 (PDT)

I do have Plato Survey Diskette Grade 3-8 Reading Survey Part I & Part II, Survey Math Grade 3-8 Side 3 & 4 (both are original)

I do have copied of Plato Survey Disks 
Reading Part I,  Part II
Math Part III
Grammer
Reading understanding what you Read Part I, II, III and IV
Spanish
German

I can sell those disks if any one interested in.

Eric 

________________________________
 From: Teresa Masters <[email-masked]>
To: [email-masked] 
Sent: Sunday, April 28, 2013 3:16 PM
Subject: [TI994A] Plato

Hugs,
Terrie

Teresa Masters