Subject: MESS 148B Keyboard

From: "epergrem" <[email-masked]>
Date: Fri, 31 May 2013 21:44:18 -0000

I have installed MESS 148b as well as QMC2.  A bit more learning curve than version 137, which I had gotten comfortable with.

All seems to be going well, except I can't seem to find the option to allow me to swap the TI-99/4A keyboard for the Natural or IBM style.

I admit that I have never seen the fascination with trying to enforce the TI-99/4A keyboard on an emulator.  

So, if anyone knows how to set he keyboard to "natural" in v148b I would really appreciate it if you would share the how to with me.

Thanks,
Ernie

---

From: Chris and Veronica Schneider <[email-masked]>
Date: Fri, 31 May 2013 17:13:32 -0500

You should press Scroll Lock and then Tab to bring up the mess menu while
you are in the emulated system then select Keyboard Mode.

Chris 

From:  epergrem <[email-masked]>
Reply-To:  <[email-masked]>
Date:  Fri, 31 May 2013 21:44:18 -0000
To:  <[email-masked]>
Subject:  [TI994A] MESS 148B Keyboard

I have installed MESS 148b as well as QMC2.  A bit more learning curve than
version 137, which I had gotten comfortable with.

All seems to be going well, except I can't seem to find the option to allow
me to swap the TI-99/4A keyboard for the Natural or IBM style.

I admit that I have never seen the fascination with trying to enforce the
TI-99/4A keyboard on an emulator.

So, if anyone knows how to set he keyboard to "natural" in v148b I would
really appreciate it if you would share the how to with me.

Thanks,
Ernie

---

From: "Michael Zapf" <[email-masked]>
Date: Fri, 31 May 2013 23:21:38 -0000

> All seems to be going well, except I can't seem to find the option to 
> allow me to swap the TI-99/4A keyboard for the Natural or IBM style.

start with option "-natural". This should be somewhere in QMC2.
 
> the TI-99/4A keyboard on an emulator.  

The natural keyboard tries to map the PC keystrokes to matching key combinations on the TI.

I keep using the emulated keyboard because it is much more responsive than the natural keyboard. Moreover, the natural keyboard conflicts with the console key repeat, hence there is no repeat at all.

What I can offer is that I try to work along my backlog from last summer, including the PC keyboard interface of the SGCPU (TI-99/4P). Sorry for this sluggish progress in the last months, but as I said, my new job keeps me extremely busy right now ... until the lecture material is done the first time; hopefully this will calm down a bit in the next semesters.

At least I'll be able to release a new TIImageTool in the next weeks.

Michael

---

From: tursi <[email-masked]>
Date: Fri, 31 May 2013 17:36:16 -0700 (PDT)

> the TI-99/4A keyboard on an emulator.

Can't help with your MESS config, but, I thought I'd note that it's not so 
much as fascination as it is much easier to emulate. ;) The TI scans the 
keyboard using low level software-driven I/O, to emulate a full keyboard 
requires intermediate mapping (particularly for shifted and fctn keys), 
but to emulate the TI keyboard just requires an array of rows and columns.

---

From: "Michael Zapf" <[email-masked]>
Date: Sat, 01 Jun 2013 11:18:59 -0000

--- In [email-masked], tursi <yahoogroup@...> wrote:
> much as fascination as it is much easier to emulate. ;) 

yes, exactly. In the real TI the lines of the 9901 are directly connected to the keyboard matrix, and this is the way it is emulated in MESS. The PC keyboard is just an array of input switches.

I haven't had a deeper look at the keyboard translation yet; there is not really a reason why it performs worse.

Michael

---

From: "epergrem" <[email-masked]>
Date: Sat, 01 Jun 2013 17:45:25 -0000

Thanks for the explanation.

So what we really need then is either a) Tursi's PS2 mod, or WHT's PS2 mod or a version of the 99/4A with the RAVE Keyboard enhancement. :-)

That way we would be sticking true to the 99/4A.

Ernie

--- In [email-masked], "Michael Zapf" <forums12@...> wrote:
>
> 
> 
> --- In [email-masked], tursi <yahoogroup@> wrote:
> >

---

From: tursi <[email-masked]>
Date: Sat, 1 Jun 2013 11:07:04 -0700 (PDT)

my ps2 keyboard adapter remains available, it is just DIY because you 
haveto sort of patch it in, as i neverfound a source for the ribbon cables 
for the keyboard port. i use a floppy cable myself, but that is a but halt 
to sell as a kit. :-)

On Sat, 1 Jun 2013, epergrem wrote:

> ------------------------------------
>
> Yahoo! Groups Links
>
>
>