Subject: Hakko FX-888

From: [email-masked]
Date: Tue, 01 Nov 2011 15:07:34 -0500 (CDT)

I love my new Hakko FX-888 soldering station for working on TI hardware ( and LED lighting) since my old 926 died.  :)

---

From: "Postle" <[email-masked]>
Date: Tue, 01 Nov 2011 20:51:54 -0000

The FX-888 is to be the 926 replacement...

What tip and at what temperture?

Postle