Subject: READing DATA in XB

From: Owen Brand <[email-masked]>
Date: Fri, 26 Apr 2013 06:33:34 -0600

Not at the console now so I can't test, but Im doing some planning in my head while running errands.  If I want to randomize which DATA lines are READ into my program, Can I do a RND function to place a value into a variable, then do a RESTORE X?  If so, then what would the protocol be to select which value within that DATA line is READ?  Or will the READ necessarily begin with the first value in the DATA statement?

Sorry if this is obvious, im without a manual and terminal right now.  :)  Just hoping to get some stuff straight in my head so I can get a project finished this evening.

Thanks

Owen

Sent from Huawei Mobile

---

From: [email-masked]
Date: Fri, 26 Apr 2013 13:17:39 -0000

Owen...

You can't use variables with RESTORE.  Your randomizing will have to be with RESTORE statements via something like ON X GOTO ... or ON X GOSUB ..., I'm afraid.

...lee