Subject: TIImageTool 1.4

From: "Michael Zapf" <[email-masked]>
Date: Sat, 02 Feb 2013 11:45:07 -0000

Hi all,

the 1.4 release of TIImageTool is ready for download. New features:

* Full CHD support - offers chdman features like creating, converting, extracting, importing
* Archiver support - archive files on the TI image (produced by the standard Archiver) can be opened and worked with like a directory; pack, unpack, even with nested archives
* Geneve boot disk creation - turns your floppy or hard disk image into a boot disk for the Geneve emulation. (Contains the latest Geneve OS 6.50 redistributable release packed into the JAR file.)

Download from http://www.ninerpedia.org/index.php/TIImageTool

You need a Java Runtime Environment (Java platform SE, at least version 5). For the serial port features, the RXTX library must be installed also.

Michael

---

From: Tony Knerr <[email-masked]>
Date: Sat, 02 Feb 2013 18:03:48 -0500

Thank you very much, Michael!

This program remains by far the simplest way to transfer files to/from 
my PC to my TI and Geneve systems.
Move CF card back and forth, hard drive(CF) is updated. Haven't needed a 
floppy in about a year. :-)

Tony

On 2/2/2013 6:45 AM, Michael Zapf wrote:
> * Archiver support - archive files on the TI image (produced by the 
> standard Archiver) can be opened and worked with like a directory; 
> pack, unpack, even with nested archives
> * Geneve boot disk creation - turns your floppy or hard disk image 
> into a boot disk for the Geneve emulation. (Contains the latest Geneve 
> OS 6.50 redistributable release packed into the JAR file.)
>
> You need a Java Runtime Environment (Java platform SE, at least 
> version 5). For the serial port features, the RXTX library must be 
> installed also.
>
> Michael
>

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 4 Feb 2013 01:04:39 -0600

Michael,
 
I have EZ135 drives in my Geneve system and one in my PC.  Will TIImageTool let me access a Geneve-formatted platter in the PC to copy files between images and physical disk?   I can envision easily cleaning up my folder structure using the PC as the work-horse. Or manipulating from image to physical platter to remove fragmentation.
 
Secondly, will TIImageTool access raw image dumps?  I periodically dump my work platter to the PC, fix the VIB info to make it compatible with the HFDC, and then convert the image to CHD for use with MESS.  The reverse is also true; I often convert the CHD to a raw image, then copy back to a physical platter for use with my real hardware.

Tim

To: [email-masked]
From: [email-masked]
Date: Sat, 2 Feb 2013 18:03:48 -0500
Subject: Re: [TI994A] TIImageTool 1.4

This program remains by far the simplest way to transfer files to/from my PC to my TI and Geneve systems.
Move CF card back and forth, hard drive(CF) is updated. Haven't needed a floppy in about a year. :-) 

Tony

Hi all,

Michael

---

From: Tony Knerr <[email-masked]>
Date: Mon, 04 Feb 2013 18:21:09 -0500

I've done this with a both a Compact Flash and a zip drive, so it should 
work with an ez135, too.

TIimagetool can read the zip or Compact Flash drive directly, and copy 
files from it to either a sector dump (I use .bin for this)
or a chd (.hd) file.

To do the reverse at this point another step is required. You need to 
have another program that will take
a sector dump file and write the sectors to the disk. I've found Hex 
Workshop works well.

So to copy files from your PC to ez135 first use TIimagetool to copy 
them from the .hd to the .bin file.
This is really fast, TIimagetool is very efficient. Then you can write 
the .bin image back to the ez135
using Hex Workshop.

If you don't have a .bin image to start with, use Hex Workshop to read 
the sectors on the drive and create one.
TIimagetool also has a wonderful option in that you can delete 
directories without emptying them first, so it's
easy to make empty hard drive images.

To defragment, copy ez135 to .bin file. Then use TIimagetool to copy all 
files to an empty .bin image.
Write the target image file back to ez135 with Hex Workshop. Done.

Hopefully Michael can get the write routines straightened out so the
intermediate steps with Hex Workshop are not necessary.

Tony

On 2/4/2013 2:04 AM, Insane Multitasker wrote:
>
> Michael,
>
> I have EZ135 drives in my Geneve system and one in my PC. 
> Will TIImageTool let me access a Geneve-formatted platter in the PC to 
> copy files between images and physical disk?   I can envision 
> easily cleaning up my folder structure using the PC as the work-horse. 
> Or manipulating from image to physical platter to remove fragmentation.
>
> Secondly, will TIImageTool access raw image dumps?  I periodically 
> dump my work platter to the PC, fix the VIB info to make it compatible 
> with the HFDC, and then convert the image to CHD for use with MESS.  
> The reverse is also true; I often convert the CHD to a raw image, 
> then copy back to a physical platter for use with my real hardware.
>
>
>
> Tim

---

From: "Michael Zapf" <[email-masked]>
Date: Tue, 05 Feb 2013 00:11:14 -0000

Would be interesting to see how Hex Workshop gets the write access. I suppose you're using Windows Vista or newer.

Michael

---

From: Tony Knerr <[email-masked]>
Date: Mon, 04 Feb 2013 19:24:21 -0500

No, I'm still using XP.

Tony

On 2/4/2013 7:11 PM, Michael Zapf wrote:
>
> Would be interesting to see how Hex Workshop gets the write access. I 
> suppose you're using Windows Vista or newer.
>
> Michael
>
> __._,_

---

From: tursi <[email-masked]>
Date: Mon, 4 Feb 2013 16:33:39 -0800 (PST)

> No, I'm still using XP.

They changed the rules in Vista and later, that's why there's a problem..

---

From: Tony Knerr <[email-masked]>
Date: Mon, 04 Feb 2013 19:50:25 -0500

The problem is the same in XP.
No writes, only reads.

Tony

On 2/4/2013 7:33 PM, tursi wrote:
> __

---

From: Jeff White <[email-masked]>
Date: Mon, 4 Feb 2013 19:57:14 -0500

> They changed the rules in Vista and later, that's why there's a problem..

Staying on XP, too.  Maybe XP compatibility mode in Vista or Win7 would work.  Probably not.

Jeff White

---

From: tursi <[email-masked]>
Date: Mon, 4 Feb 2013 17:07:54 -0800 (PST)

> The problem is the same in XP.

Ah ha! That's a good datapoint, okay.

---

From: [email-masked]
Date: Tue, 5 Feb 2013 12:36:12 +0000

Just to clarify. Hex Workshop will write a sector dump to a physical disk, at least in XP. It is TIimagetool that won't write, it only reads. 

Sent from my Verizon Wireless BlackBerry

---

From: "Stuart" <[email-masked]>
Date: Tue, 05 Feb 2013 12:44:30 -0000

Windows 7 - I use a sector editor called WinHex and it has to be configured to "Run As Administrator" to be able to access a physical device at sector level. Compatability mode didn't help.

Stuart.

--- In [email-masked], Jeff White  wrote:
>
> 
> On 04 Feb 2013, at 19:33, tursi  wrote:
> > > No, I'm still using XP.
> >