Subject: Re: [TI994A] Need an IDE nudge....

From: [email-masked]
Date: Sun, 06 May 2012 17:15:59 -0500 (CDT)

You have to intialize the CF card on the TI with the DU2K utility. If you can't initialize, then format the CF card to FAT32 on a peecee that will do FAT32 and try to initialize again.

On 05/06/12, Marc H<[email-masked]> wrote:

When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?

------------------------------------

Yahoo! Groups Links

<*> To visit your group on the web, go to:
http://groups.yahoo.com/group/TI994A/

<*> Your email settings:
Individual Email | Traditional

<*> To change settings online go to:
http://groups.yahoo.com/group/TI994A/join
(Yahoo! ID required)

<*> To change settings via email:
[email-masked]
[email-masked]

<*> To unsubscribe from this group, send an email to:
[email-masked]

<*> Your use of Yahoo! Groups is subject to:
http://docs.yahoo.com/info/terms/

---

From: Marc Hull <[email-masked]>
Date: Sun, 6 May 2012 15:33:36 -0700 (PDT)

Thank you Richard.  My IDE card is on loan and I was trying to recall the facts and procedures.  Damn brain doesn't seem to be a filing cabinet like it used to.  

I sure hope Fred gets his site back up soon.  Ya don't what ya got... till it's gone. ;-)

--- On Sun, 5/6/12, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] Need an IDE nudge....
To: [email-masked]
Date: Sunday, May 6, 2012, 5:15 PM

  

      You have to intialize the CF card on the TI with the DU2K utility. If you can't initialize, then format the CF card to FAT32 on a peecee that will do FAT32 and try to initialize again.   On 05/06/12, Marc H<[email-masked]> wrote: When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?

Yahoo! Groups Links

---

From: "epergrem" <[email-masked]>
Date: Mon, 07 May 2012 12:27:43 -0000

Hi Richard et al.
I'm the guy that Marc loaned the IDE card too. :-)

The problem that I'm having is that IDETEST tests okay, the DSR loads and I can run all of the CALLs.  

The problem is the DU2K fails to find any devices on the IDE card.  it finds the IDE card okay at >1600, just no devices to initialize.

The LEDs on the IDE-CF adapter work okay and the 16MB Sansdisk CF appears to be okay.  I even tried my 1GB Sansdisk CF with the same results.

Any suggestions would be greatly appreciated because Marc loaned me the card to do some testing of the SID Play software and I'd like to make some progress. :-)

Thanks,
Ernie

> --- On Sun, 5/6/12, swim4home@... <swim4home@...> wrote:
> 
> From: swim4home@... <swim4home@...>
      
>       
>       You have to intialize the CF card on the TI with the DU2K utility. If you can't initialize, then format the CF card to FAT32 on a peecee that will do FAT32 and try to initialize again.   On 05/06/12, Marc H<marc.hull@...> wrote: When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?

---

From: Marc Hull <[email-masked]>
Date: Mon, 7 May 2012 16:20:05 -0700 (PDT)

I am speculating that trying to use a CF that has not been (for the lack of a better term) "fat 32'd" would be akin to using a hard disk with no low level formatting done to it.  I want to say Richard helped me with this when I first got the card from him but that was a while back.

--- On Mon, 5/7/12, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] Re: Need an IDE nudge....
To: [email-masked]
Date: Monday, May 7, 2012, 7:27 AM

  

      Hi Richard et al.

Thanks,

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

> Thank you Richard.Â  My IDE card is on loan and I was trying to recall the facts and procedures.Â  Damn brain doesn't seem to be a filing cabinet like it used to.Â  

>       You have to intialize the CF card on the TI with the DU2K utility. If you can't initialize, then format the CF card to FAT32 on aÂ peecee that will do FAT32 and try to initialize again.Â Â Â On 05/06/12, Marc H<marc.hull@...> wrote:Â When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?

---

From: [email-masked]
Date: Mon, 7 May 2012 23:21:37 +0000 (UTC)

Ernie 
Instead try to use the RXB Disk commands and see if that works as it does a GPLDSRLNK instead of assembly and uses the TI instead of over riding the TI OS. 

I would sugest first just go to RXB EA and do a catalog if that works then most of the other stuff will work, except for the sector access. 

Rich 

----- Original Message -----
From: "epergrem" <[email-masked]> 
To: [email-masked] 
Sent: Monday, May 7, 2012 5:27:43 AM 
Subject: [TI994A] Re: Need an IDE nudge.... 

Hi Richard et al. 

Thanks, 
Ernie

---

From: "Stuart" <[email-masked]>
Date: Tue, 08 May 2012 08:43:11 -0000

Hi Marc,

I don't think that is the case. In my opinion, low level formatting is laying out the sectors on the blank media, and high level formatting - formatting as FAT32 or the TI format - is initialising the tables that record which sectors are in use, disk name, number of sectors free, file allocation table, and so on. With an IDE device you can also completely ignore all the high level formatting stuff and just treat it as a memory device - "write the 512 bytes of data at memory address XYZ to sector ABC" - that is how the high level formatting is done.

Stuart.

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
> --- On Mon, 5/7/12, epergrem <epergrem@...> wrote:
> 
> From: epergrem <epergrem@...>
> --- In [email-masked], Marc Hull <marc.hull@> wrote:
> 
> >
> 
> > --- On Sun, 5/6/12, swim4home@ <swim4home@> wrote:
> 
> > 
> 
> > From: swim4home@ <swim4home@>
> 
> >       You have to intialize the CF card on the TI with the DU2K utility. If you can't initialize, then format the CF card to FAT32 on aÂ peecee that will do FAT32 and try to initialize again.Â Â Â On 05/06/12, Marc H<marc.hull@> wrote:Â When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?
>

---

From: Marc Hull <[email-masked]>
Date: Tue, 8 May 2012 04:29:13 -0700 (PDT)

My example was a bit too literal and vague.  Suffice it to say that the CF card must be formatted as FAT 32 (akin to low level formatting a drive) before the TI can format it (akin to high level formatting a drive.)  See Postals reply for a much better use of verbiage.

--- On Tue, 5/8/12, Stuart <[email-masked]> wrote:

From: Stuart <[email-masked]>
Subject: [TI994A] Re: Need an IDE nudge....
To: [email-masked]
Date: Tuesday, May 8, 2012, 3:43 AM

  

      Hi Marc,

Stuart.

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

> I am speculating that trying to use a CF that has not been (for the lack of a better term) "fat 32'd" would be akin to using a hard disk with no low level formatting done to it.Â  I want to say Richard helped me with this when I first got the card from him but that was a while back.

> Â 

> > Thank you Richard.Ã‚Â  My IDE card is on loan and I was trying to recall the facts and procedures.Ã‚Â  Damn brain doesn't seem to be a filing cabinet like it used to.Ã‚Â  

> >       You have to intialize the CF card on the TI with the DU2K utility. If you can't initialize, then format the CF card to FAT32 on aÃ‚Â peecee that will do FAT32 and try to initialize again.Ã‚Â Ã‚Â Ã‚Â On 05/06/12, Marc H<marc.hull@> wrote:Ã‚Â When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 15:09:13 -0000

Ernie,

I do not know how old the IDE Card is...  But, I have received e-mails where the cards do not work even immediately after the 512 SCRAM has been loaded with the Firmware.  Problem being the RTC Batteries are good for ten years.  Some for less.  So when the IDE Card is de-powered with the PE Box it will lose its infromation installed in the SCRAM and not be able to read the CF Card's DATA.  The information on the CF Card is always safe, just needs the Firmware.

With that said with IDE Cards, SCSI Card and Myarc Hard Drives it is always good to have a log of the Directories and Sub-Directories DATA AS to where what is storied where. 

I would hope a DIP Connector was used for the RTC so the change is easy.  If not, one should be used when replacing the RTC Chip ~ Device.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> >       You have to intialize the CF card on the TI with the DU2K utility. If you can't initialize, then format the CF card to FAT32 on a peecee that will do FAT32 and try to initialize again.   On 05/06/12, Marc H<marc.hull@> wrote: When formatting a CF card for the IDE card does it need to be formatted as FAT 32 ?
>

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 15:16:45 -0000

OH! I would Hope you are using the most recent of Fred Kaal' Firmware program?

There was once a discussion about a reset on startup.  That would cause the same type of situation to ocurr.  So all the little DIP switches should be in the "OFF" position.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], "Postle" <postle@...> wrote:
> --- In [email-masked], "epergrem" <epergrem@> wrote:
> >
> > Hi Richard et al.

---

From: "epergrem" <[email-masked]>
Date: Tue, 08 May 2012 16:40:09 -0000

I ran Fred's IDETEST, which I am guessing flushed the SRAM and reloaded his DSR.  I'm using the version that is in the "Kaal" directory on WHT, so it should be the latest, unless he updated it during his absence.

What is a bit frustrating, is that the card appears to work as it should, or at least the DSR does.  However, IDEDRIVE shows no devices attached, so I can't initialize or format the CF card to do a directory on it.

It's kind of like accessing DSK1, when there is no drive hooked up to the card.

Rich suggested RXB, but I've got to find a XB or EA5 version because the only GRAM device I had in my possession is on it's way to France.

Ernie

--- In [email-masked], "Postle" <postle@...> wrote:
> --- In [email-masked], "Postle" <postle@> wrote:
> >
> > Ernie,
> >

---

From: "Postle" <[email-masked]>
Date: Tue, 08 May 2012 17:18:29 -0000

To the best of my knowledge the Utility Program will not show anything until the CF Card is Formatted and Inilized.  I do the FAT 32 on the PC and Inilized on the TI.  Then you should get the DSR location...  A requirement to proceed.  DSR(Firmware) is Version 10.

IDETEST is just Front Light Rear Light stuff.

IDE Load is the one which loads the SCRAM ~ But, your DSR Loacation should be already readable?

Make sure the IDE Card is properly seated.  Something about screws on the bottom of the case...

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^