Subject: Other BBS software

From: Owen Brand <[email-masked]>
Date: Sun, 09 Jun 2013 09:02:58 -0600

S&T software is the definitive BBS software for the TI.. But I won't have the option of running it in the near future due to hardware limitations...  It will run with 3 disk drives, but it would be EXTREMELY limited in storage capacity...  Ernie suggested one called SmallTalk, I think it was...  Does anyone have any experience working with this software?

Also, are there any other BBS software packages for the /4a?  

I won't have much time to get a project like this started in the immediate future but here in a month or two, if everything goes to plan, I'll have a bit more freedom to do fun stuff and finish some projects that have been neglected far too long.  

Perhaps by then I will be able to get myself a hard drive/disk for my setup....  Then S&T would be more of an option.  :)  

Owen Brand
Opry99er

---

From: Chris and Veronica Schneider <[email-masked]>
Date: Sun, 09 Jun 2013 10:23:41 -0500

I have played with various BBS softwares of the TI, like Small Talk,
Citadel, Zyolog, S&T.

S&T is by far the best, my second choice is Zyolog.  I ran zyolog for years
(before S&T came out).

Smaltalk and Citadel I found very limiting and buggy.

I am hoping to have a new bbs out soon that uses Tim's Machine language
routines from S&T.  The ML for his bbs is by far the best I have seen and
the fastest.

Chris

From:  Owen Brand <[email-masked]>
Reply-To:  <[email-masked]>
Date:  Sun, 09 Jun 2013 09:02:58 -0600
To:  <[email-masked]>
Subject:  [TI994A] Other BBS software

S&T software is the definitive BBS software for the TI.. But I won't have
the option of running it in the near future due to hardware limitations...
It will run with 3 disk drives, but it would be EXTREMELY limited in storage
capacity...  Ernie suggested one called SmallTalk, I think it was...  Does
anyone have any experience working with this software?

I won't have much time to get a project like this started in the immediate
future but here in a month or two, if everything goes to plan, I'll have a
bit more freedom to do fun stuff and finish some projects that have been
neglected far too long.

Perhaps by then I will be able to get myself a hard drive/disk for my
setup....  Then S&T would be more of an option.  :)

Owen Brand
Opry99er

---

From: "epergrem" <[email-masked]>
Date: Sun, 09 Jun 2013 17:34:47 -0000

Hi Owen,
I ran it as a night-time BBS back in 1990 or 1991. It's a basic, vanilla BBS.  Easy to set up and maintain.

It has uploads, downloads, sysop-caller chat, etc. Just nowhere near the level of some of the more powerful software. 

Oddly, I seem to recall that it uses part of the screen table as a file transfer buffer, so while a file is transferring part of the screen gets trashed.  However, the screen is restored once the transfer is complete.

My experiences were different than Chris' in that I didn't find it buggy.  Just very, very simplistic.

I can email you a copy in PC99 format if you want to read the docs or give it a try.

Ernie

---

From: "Tursi" <[email-masked]>
Date: Sun, 9 Jun 2013 12:27:15 -0700

>Also, are there any other BBS software packages for the /4a?

I was always frustrated by the low speed of Extended BASIC based BBS 
packages, especially since I was invariably calling long distance back in 
the day. ;) I wrote my own, FlipTerm, in C99 and assembly. It was designed 
to be a message board, rather than a file board (though it supports the bare 
minimum of file transfers). It also supported online games, and I had a 
handful of them (they also had to be EA#5 program image files and return to 
the BBS, though).

It supported auto-baud selection between 300, 1200 and 2400, and managed DTR 
via the cassette port for hanging up. ;) It ran 80 column native to look 
"normal" to PC callers. It supported any number of message bases, had a 
line-based message editor, and during reading messages supported message 
threading (ie: going back and seeing what message the current one was a 
reply to) and automatic "read new" across all message bases.

The main downside is that besides the message bases and games, it was not 
designed to be configurable, so it was always a one-off. ;) It also required 
a RAMdisk to run, as it ended sessions with a reset and used the MENU 
program to take control at powerup. Still, it ran for about 4 years in 
Ottawa quite successfully. It was a lot of fun. I did post it a while back 
(http://www.harmlesslion.com/cgi-bin/onesoft.cgi?106) -- although I don't 
think it would be very easy for anyone besides myself to ever get running 
again. Might be fun to do so, though.

---

From: "jesse_slicer" <[email-masked]>
Date: Mon, 10 Jun 2013 14:02:14 -0000

I ran "The Manhattan Project" from 1987-1991. It used TI-Net software. TI-Net BBS was originally written by Erik Olson, Matt Storm, and Greg Donini.  I bought the software from Erik in 1987.  After going through many different /4A configurations and modifying the code for the new config, I thought I had a pretty good library of routines that could work on just about any configuration out there.

Around Christmas of 1991, Erik Olson stopped at my place for a couple of days to stay.  At that point, we finalized my completely rewritten source code for it.  My mother and I then had the distribution rights for the software.

Like much of the BBS software for the TI, this was an XB/AL hybrid. My mother did a good amount of the XB programming (primarily the Gameroom and Casino modules) and I tore into the AL.

When it was all said and done, it was 80-column and HFDC compatible amongst having other nifty features.

---

From: Jeff White <[email-masked]>
Date: Tue, 11 Jun 2013 07:40:45 -0400

Various BBS software packages, support routines, and related software can be found in these locations:

ftp://ftp.whtech.com/9640news/CAT09/
ftp://ftp.whtech.com/9640news/CAT13/

Read the text files FILES.40 or FILES.BBS for descriptions.  Also, see:

ftp://ftp.whtech.com/communications/bbs/

Jeff White

---

From: "Beery" <[email-masked]>
Date: Tue, 11 Jun 2013 20:47:00 -0000

I've said this before.....

My favorite BBS program up until about 1988 or so was the Pro'99er BBS program.  It would run under Myarc Extended Basic 2.10 (not 2.11 or 2.12).  For some reason, there was some conflict in the assembly routines in 2.11/2.12.

With a ramdisk I had at the time,  you would have thought it was running on a MS-DOS machine as it was superfast.

It had several games as I recall, up/downloading, and multiple message boards.

I believe the S&T BBS by Tim far exceeded anything else out there.

Beery