Subject: Thoughts?

From: Owen Brand <[email-masked]>
Date: Thu, 06 Jun 2013 23:59:41 -0600

S&T software running on a stock console, facilitating a BBS through a nanoPEB.....

Possible?  Worth a try?  :)

I have a CF7 which I love, but I have been thinking alot lately about the possibilities of the nanoPEB's serial port....  I never use the parallel port on my CF7 for anything, so why not get a nanoPEB and do something with the serial port?  Best thing I could think to do is create a BBS and host it without a regular PEB.  What you guys think? 

 Tim?  You'd know better than anyone... It's your software.  :)

Owen Brand
Opry99er

---

From: "epergrem" <[email-masked]>
Date: Fri, 07 Jun 2013 11:50:12 -0000

Owen,
I don't have a nanoPEB, but having ran S&T it occurs to me that without a hard drive, RAM disk, etc. you might be better off with something like Smalltalk. 

No where near as feature rich as S&T, but requires a very little footprint and is happy to run off of nanoPEBs three floppy drives.

Ernie

---

From: Chris and Veronica Schneider <[email-masked]>
Date: Fri, 07 Jun 2013 09:23:30 -0500

Owen,

Dano and I are currently coding a new BBS that uses S&T machine code, it
will not offer as many features of S&T, but it will offer transfers,
messages, chat, and much more.

I also need to redo my old Zyolog BBS.  I used the same code that the USS
Enterprise did back in the day.  That will run great on a stock system with
no issue.

Chris

From:  Owen Brand <[email-masked]>
Reply-To:  <[email-masked]>
Date:  Thu, 06 Jun 2013 23:59:41 -0600
To:  <[email-masked]>
Subject:  [TI994A] Thoughts?

S&T software running on a stock console, facilitating a BBS through a
nanoPEB.....

I have a CF7 which I love, but I have been thinking alot lately about the
possibilities of the nanoPEB's serial port....  I never use the parallel
port on my CF7 for anything, so why not get a nanoPEB and do something with
the serial port?  Best thing I could think to do is create a BBS and host it
without a regular PEB.  What you guys think?

Owen Brand
Opry99er

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 7 Jun 2013 13:09:14 -0500

As I recall, the nanoPEB only has one RS232 port, so the extra control line from RS232/2 that is used for carrier detect would need to be rerouted to either the joystick or cassette port.  We know this is do-able as I've already provided Chris code modifications for that purpose.  I suspect the code he has would work effectively with the nanoPEB SIO device.

The BBS can run from a floppy - that was its original design.  You would be fairly limited for message base and other space. Changing drive volumes from the BBS would be do-able with a few snips of assembly in place of the hard drive support code.  Managing the file transfer areas might be tricky without some creativity.

Short answer: yes, with some modifications to utilize the extra volumes. 

> To: [email-masked]
> From: [email-masked]
> Date: Thu, 6 Jun 2013 23:59:41 -0600
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>