Subject: Help!!! IDE card

From: "kory" <[email-masked]>
Date: Sat, 19 Nov 2011 09:38:14 -0000

Sooooo... My IDE card is not working. When I go to E/A and run IDELOAD I get to the first screen asking me to select a CRU. I tried 1000 and 1500 (Set the actual switch on the card) as they were the only ones I've read about to be good choices. The DIP switches are set to NONE on the rear of the card, TI on the one in the middle, and OFF for all four of the switches that are in a bank.

My questions are these. 1) Should there be 1 or 2 LED lights on, or should they flash at some point between turning the PEB on and getting to the E/A screen. 2) Will the CRU be set with or without a HD attached to the IDE card. 3) Do any of the slots on the PEB board have "hard-wired" CRU's that the card would need to be set to match. 4) Is pin #1 on the IDE card at the top of the connector or the bottom. 5) If the HD is not compatible with the card will I get stuck at the assign CRU page like I am. 6) There is a resistor at c23.. below the SRAM that someone mentioned should be removed, what will happen if it is still there, and what is the reason for removing it?

Clock is the 4847!

Thanks, as always!
-Kory

---

From: "fredkaal" <[email-masked]>
Date: Sat, 19 Nov 2011 12:25:53 -0000

1) LED's can only do something if the DSR is loaded
2) Doesn't matter. Can't set the switch without removing the card from the box anyway and it is also a bit difficult to do if a some hardware is dangling on the cabple when you do.
3)No
4)Can't check now, i'm in the middle of moving to another house.
5)No
6)It is a capacitor. Leave it.

Switch SW1 and SW2 should both be set to TI or GENEVE depends on  whatever you use. You only set SW1 to off when the card is misbehaving and you can't boot your TI anymore:
If so:
1) Switch off TI and PEBOX
2) Set switch S1 to off
3) Switch on PEBOX and TI
4) Set SW1 in correct position
5) Reload DSR

Any CRU addess will work, but don't choose one that is allready in use like >1300 for RS232, >1100 for TI disk controller. >1000 is the best choice because you can make use of the DSK and DSK1 directory feature.

Try the IDETEST program(s) first before jumping into the deep.

Fred ;-)

---

From: "Postle" <[email-masked]>
Date: Sat, 19 Nov 2011 22:23:33 -0000

Kory,

I am not the IDE Card expert.  I can write what I know as I did this like a week or two ago.

I think this to be a bit funny.  Well sort of.

Fred Kaal published a Check List of sorts.  Send me an e-mail and I will e-mail you the Check List.

Some things which are needed:

DM2K  Fred Kaal's Disk Manager
DU2K  Fred Kaal's Utility Disk

Fred Kaal's or Richard Bell's copy thereof, of the IDE DSR.

To see if the Card functions...  RUN "IDETEST" using Option 5.  Front LED Power.  Rear LED is what ever it is.  During the test the LEDs will be "ON" and "STEADY".

USE DU2K to view the IDE Card under IDE.  Drive must be connected.  Determine which CRU.  If everything is okay...  The Drive will be visible as well.  The drive must be present.

Set the switches and CRU... Install the IDE Card.

Nothing is standard...

Using Option 5 Run IDELoad.

C23, C26 & C24 are removed.  Why?  Ask Richard Bell.  If you ask me.  The card works and it is stable.  Keywork "STABLE"  Two people, two fixes and one resolve. "I THINK".

Richard places under separate Sub-Directories, the IDE DSR (IDE_RSR) Program and WHC's ROS (WHT_ROS)program.

Postle

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--- In [email-masked], "fredkaal" <fgkaal@...> wrote:
> --- In [email-masked], "kory" <shortbusalaboard@> wrote:
> >

---

From: "Postle" <[email-masked]>
Date: Sun, 20 Nov 2011 01:08:36 -0000

> > Sooooo... My IDE card is not working. When I go to E/A and run IDELOAD I get
to the first screen asking me to select a CRU. I tried 1000 and 1500 (Set the
actual switch on the card) as they were the only ones I've read about to be good
choices. The DIP switches are set to NONE on the rear of the card, TI on the one
in the middle, and OFF for all four of the switches that are in a > > My questions are these:

1) Should there be 1 or 2 LED lights on, or should they flash at some point between turning the PEB on and getting to the E/A screen.

During the Card's TEST within the IDETEST's operation the Front LED will come on steady first.  After input, the Rear LED will come on steady. Other times it is off.

2) Will the CRU be set with or without a HD attached to the IDE card.  To the best of my knowledge...  It does not matter.

3)  Do any of the slots on the PEB board have "hard-wired" CRU's that the card would need to be set to match. 

Using Fred Kaal's DU2K Program all CRUs in use can be identified. 

4) Is pin #1 on the IDE card at the top of the connector or the bottom.   It is on the "TOP".

5) If the HD is not compatible with the card will I get stuck at the assign CRU page like I am.  More than likely.  The Drive needs to be initialize/Formatted or it will not be reconized 

6) There is a resistor at c23.. below the SRAM that someone mentioned should be removed, what will happen if it is still there, and what is the reason for removing it?

To the best of my knowledge there was an interrupt signal problem with the IDE Card.  Two People, Two fixes.

My IDE Card did not work when it left.  It worked upon return with C-23 removed.  After that...  Mr. Bell did not tell me.

With a Right Angle IDE Connector installed on the IDE Card.  HX-168 CF-IDE40 Adapter (e-Bay) can be used.  Power for this adapter setup came from the IDE Card.  Neat and Professional.

I, in 2004/5 used a hole punch to put a hole behind the PE Box Drive Bay.  I used a lead connector with a clear plastic cover to connect the leads.  So there is a Lead on the back of my PE Box for the CF Adapter.

I also have several TI Floppy Drive External Drive boxes for the IDE Card's use.

All three methods work.  A CF Solid State Memory is probably best.

The rear LED should not stick up above the top edge of the IDE Card.  It will interfer with the PE Box Cover. 

Postle

> --- In [email-masked], "fredkaal" <fgkaal@> wrote:
> >

---

From: "kory" <[email-masked]>
Date: Tue, 22 Nov 2011 20:17:17 -0000

Thanks for the replies and help. I'm going to have to put this project on hold for a short while.. I had a box full of old hard drives that has disappeared, and just had to purchase a new PC.. when it rains it pours.

I'm going to go the CF route once I've got a little cash to spend..! I am planning to try the IDETEST program tonight. I'll post a reply with how it went.

Thanks!
-Kory