Subject: Horizon ram disk questions

From: "Cory Klatt" <[email-masked]>
Date: Mon, 31 Oct 2011 18:20:33 -0000

I have a Horizon Ram Disk with 182K installed.  What I'd like to do is know if it is possible to expand beyond the 182K that is installed on the card now.  I understand that there are various versions of the Horizon card.  How does one ID these cards?  

The back of my card says "88/10 Horizon Computer Limited Copyright 1986".  The front of the card has a serial number "001703" and "Horizon Computer Limited Copyright 1986" on the pcb.

The card is populated with 24 6264LP-15 Ram chips.  11 are stacked 2 high and 2 are not piggybacked.

I'd love to expand the RAM, if possible, but also ID which card this is.

Also, what is the function of the Green LED?  Only the Red LED seems to operate when accessing the disk?

Any help is greatly appreciated!  

Thanks.

---

From: "Cory Klatt" <[email-masked]>
Date: Tue, 01 Nov 2011 22:58:40 -0000

I've been studying my behind off and believe the card is the first generation Horizon Ram disks.  Why do I think this?  Well, I've read all the manuals on whtech and the HRD+ 2000 Ramdisk manual makes reference to the serial number starting in the 2000 range.  Therefore, I'm making the assumption that a serial number in the 1,000 range must be first generation.  Anyone care to agree / disagree?

A close inspection of my board to the fuzzy schematics in the HRD+ manual show a difference in that my board has a single 4 - 16bit decoder versus the 2 on the HRD+ RAM 2000.  There are a couple more differences, but the primary one that I believe impacts my ability to expand it is the decoders.

Does anyone happen to have a schematic / manual for the first gen ram disk?

I also remain curious about the green led.  Anyone know what that does? Perhaps a battery low indicator?

-ck

---

From: Tony Knerr <[email-masked]>
Date: Tue, 01 Nov 2011 20:28:03 -0400

Some limited info that I remember.

The original Horizon was 90k single layer, 180k double layer, and could 
be expanded to 256k with a partial 3rd layer.
The extra decoding comes from stacked decoder chips.
The green led is an indicator/current regulator for the battery charging 
circuit.

There are probably docs for it on Whtech, but I couldn't tell you where.

I'm willing to bet that there are a few here that know how to expand it 
to the max if they search the inner depths of their gray matter. :)

Hey, it's a start.

Tony

On 11/1/2011 6:58 PM, Cory Klatt wrote:
>
> I've been studying my behind off and believe the card is the first 
> generation Horizon Ram disks. Why do I think this? Well, I've read all 
> the manuals on whtech and the HRD+ 2000 Ramdisk manual makes reference 
> to the serial number starting in the 2000 range. Therefore, I'm making 
> the assumption that a serial number in the 1,000 range must be first 
> generation. Anyone care to agree / disagree?
>
> A close inspection of my board to the fuzzy schematics in the HRD+ 
> manual show a difference in that my board has a single 4 - 16bit 
> decoder versus the 2 on the HRD+ RAM 2000. There are a couple more 
> differences, but the primary one that I believe impacts my ability to 
> expand it is the decoders.
>

---

From: "Beery" <[email-masked]>
Date: Wed, 02 Nov 2011 17:28:25 -0000

I have one of those triple stacked 256K Horizon Ramdisks.  When I last used it,it worked fine.  I since pulled the batteries from it so they are missing.  I believe the battery "tray" needs to be reaffixed.

Make me an offer if someone wants it.

Beery

---

From: Tony Knerr <[email-masked]>
Date: Wed, 02 Nov 2011 19:47:13 -0400

Any chance that you could take a decent resolution pic of that ramdisk, 
Beery?
It may provide Cory with the info he needs for that 3rd layer.

Tony

On 11/2/2011 1:28 PM, Beery wrote:
>
> I have one of those triple stacked 256K Horizon Ramdisks. When I last 
> used it,it worked fine. I since pulled the batteries from it so they 
> are missing. I believe the battery "tray" needs to be reaffixed.
>

---

From: "Cory Klatt" <[email-masked]>
Date: Thu, 03 Nov 2011 00:17:50 -0000

Thanks Tony and Beery!  If it's possible, a picture would be great!  

I also found a bunch of great info scanning through disk images in the Lima Library.  This disk image has some great info:

ftp.whtech.com/User Groups/Lima/library/0189ADSK

But still no info / instructions on how to add the 3rd layer of chips.  One of the articles state:

There are three different
versions of the printed circuit board : 

- Horizon original
- Horizon 2000
- Horizon 3000

The original version is for 64 kbit (8 kbytes) static RAM chips
6264LP-15.  It was sold with 104 kbytes (13 RAM chips) or 192
kbytes (24 RAM chips). The RAM chips are stuck upon each other in
two layers for a 192 kbytes disk. 

The Horizon RAM disk uses CPU addresses >4000 - >5FFF when it is
activated. 6 kbytes of these 8 kbytes is used by the operating
system. The remaining 2 kbytes contain the disk sectors and it is
bank switched with 93 banks (RAM TRACKS) for a 192 kbytes disk.
Some parts of the operating system is also bank switched in the
same memory area as the RAM disk sectors. 

HISTORY

Horizon began selling in Feb 1986.  The original version had 64
kbit (8 kbytes) static RAM chips which must be mounted in two
layers on top of each other to get the maximum size of 192 kbytes
(24 chips). 

Elektronik-Service in Germany started to sell Horizon boards with
392 kbytes during 1987.  They used 32 kbytes chips and a small
daughter board to handle the coding.  One known serial number is
1216.  See photo in PB 88-4. 

HRD+ came in Feb 1988 with 32 kbytes chips which gave the
possibility to Horizon with 384 kbytes (12 chips) without any
need to stack RAM chips on top of each other.  Highest serial
number 1900. 

Horizon 2000 came in Sept 1988 and it does not need to stack the
control chips (U2).  Serial number 2000-2200. 

Horizon 3000 came in Feb 1989 and it can be used with 32, 128 or
512 kbytes chips.  Only 32 kbytes chips was used in the beginning
for economical reasons.  128 kbytes RAM chips was not used until
Apr 1990 when Horizon was made with 1536 kbytes (12 chips).
Change #0 - #2 is included as standard.  Serial number 3000-3399.  

Horizon 3000B has also change #3 included.  Serial number 3400- .  

Horizon 4000 came in Oct 1992 with RAMBO included as standard.
It now uses 512 kbytes static RAM chips so you can have up to 8
Mbytes. 

~ck

---

From: "Cory Klatt" <[email-masked]>
Date: Thu, 03 Nov 2011 00:26:12 -0000

Here's some info on the LED's I was curious about as well as a bit more info on upgrading the original card:

EXPANSION MEMORY 32 KBYTES

You must usually still have the 32 kbytes expansion memory board
as CPU RAM.  It is possible to mount this memory on the Horizon
RAM disk board.  Bud Mills sells a kit for 25 dollars which can
be mounted on any old Horizon RAM disk regardless of version.  It
has a 32 kbytes chip HM62256-ALP10 and an SN74LS08N together with
two diodes and sockets for the two chips. 

An installation guide was published in Micropendium March 89 and
May 89. 

RANDOM ACCESS MEMORY BLOCK OPERATOR (RAMBO) 

RAMBO is a small daughter board from OPA which is mounted on the
Horizon RAM disk.  It will give you the possibility to divide the
memory in one part for the RAM disk an in another part for CPU
memory which can be switched in 8 kbytes banks at CPU address
>6000.  See Micropendium Dec 1989.  Price 45 dollars. 

EXPAND 192 KBYTES TO 256 KBYTES

This expansion is only for the original RAM disk with 8 kbytes
chips and a total memory of 192 kbytes. 

Ed Hallet published in R/D Computing Ver 20 this upgrade with 8
kbytes chips which must be mounted in a third layer on the board.  

Garry Bishop published in Micropendium Sept 89 and Nov 89 a much
better upgrade with 32 kbytes chips.  Bud Mills sells this for 40
dollars. 

CHANGE #0: LED AND FEEDING CURRENT 

RAM disks with serial number up to #0600 will often only have red
LEDs.  The upper LED shall be green or yellow to insure that U11
will be protected at power-up. 

Serial number up to #1200 may have too high resistance in series
with the NiCd batteries.  This should be 66 ohms in total divided
in 33 ohms (orange-orange-black-gold) on each side of the
batteries to give enough charging. 

Examples of RAM disks (upper LED): 
192 kbytes #0694 yellow LED  33+27 ohms
392 kbytes #1216 green  LED  33+40 ohms

CHANGE #1: CONSOLE RESET LINE 

This change will replace a delay circuit at power-up by using the
console's RESET line.  This will give RESET to the RAM disk at
the same time as the console gets it. 

CHANGE #2: DISABLE SWITCH 

A switch is mounted on rear side of the board.  It will give you
the possibility to hide the board from the computer at power-up.
The operating system (ROS) can sometimes be partially destroyed
in a way that locks the computer at power-up if you do not have
the switch.  This switch shall then be off at the power-up and
then on before you reload the ROS.  A description was published
in Micropendium Aug 89.  The switch shall not be used during
normal power-up or power-down, but as a help when you need to
avoid lock-up. 

CHANGE #3: PROTECT AT POWER-DOWN

This change concern all boards with 32 or 128 kbytes chips.  The
original RAM disk with 8 kbytes (192 kbytes in total) chips shall
not be rebuilt. 

This bug is not noticed with ROS version 7 but can give serious
result with ROS version 8.  ROS 7 uses VDP RAM as disk buffer but
ROS 8 will instead use RAM on the Horizon board as disk buffer
(in the same way as Myarc disk controller).  This part of the
memory will be subject to random write at power-down.  ROS 7 will
not use this part of the memory but ROS 8 does.  Bud Mills sells
a kit and a description of this change.  There are different
descriptions for HRD+, Horizon 2000 and Horizon 3000.  All new
RAM disks with serial number #3400 and up will have this built
in, Horizon 3000B. 

CHANGE #4: DIODE PROTECTS AT POWER-UP 

This change from June 1992 concerns almost all Horizon RAM disks
and P-GRAM(+).  The upper green LED shall protect the memory from
access during power-up.  It shall have 2,3 V fire voltage but can
sometimes be 1,8 V.  The change is to mount a signal diode 1N914
(1,2 V) in series with the LED.  There is no danger in adding
this diode also when the LED is 2,3 V from the beginning . 

----

I've started to use peekbot as a way of scanning through the files on whtech.  What a great service and thanks to the people behind that technology.  I'm uncovering all kinds of lost gems!!

~ck

--- In [email-masked], "Cory Klatt" <cory.klatt@...> wrote:
> --- In [email-masked], Tony Knerr <tonyknerr@> wrote:
> >

---

From: "Cory Klatt" <[email-masked]>
Date: Thu, 03 Nov 2011 00:27:37 -0000

Here's the peekbot link for anyone else that would like to read the disk I'm referring to.

http://peekbot.jamtronix.com:6502/all_texts/ftp%3A%2F%2Fftp.whtech.com%2Fuser%2520groups%2FLima%2Flibrary%2F0813B.DSK

--- In [email-masked], "Cory Klatt" <cory.klatt@...> wrote:
> --- In [email-masked], "Cory Klatt" <cory.klatt@> wrote:
> >

---

From: "computerclassics2000" <[email-masked]>
Date: Thu, 03 Nov 2011 20:34:18 -0000

Does this help?

This is the original article for the HORIZON RAMDISK 256K modification
that I wrote for the SOUTHWEST 99ERS OCTOBER 86 newsletter.  It contains the COMPLETE INSTRUCTIONS to modify ALL PARTS of the HORIZON DSR software to work with the extra memory added by this modification.  Some reprints of this article have deleted parts of the software modification instructions.  This original article includes these instructions so that ALL FUNCTIONS including
the MULTIPLE RAMDISK LOADER, VERSION LOADER, CLEAR, ETC.  work exactly as they did originaly.  These software modifications are the same for VERSIONS 03 and 04 with the exception of the MEMORY TEST files.  John Johnson's MENU VER 5 and 5.5 for the HORIZON RAMDISK can also be modified for 256k using the same basic modification principles.

John Johnson's  MENU VER 6 requires NO modification to work with the 256k modification.  MENU VER 6 works with ALL of the HORIZON RAMDISK sizes including those expanded to 256k.  I highly recommend using Johnson's MENU VER 6 with HORIZON RAMDISKS expanded to 256K.  MENU VER 6 is a FANTASTIC program, is very easy to use, requires NO modification for 256K, and gives you 16 additional sectors (992 sectors total with the 256K modification).

EDWARD A. HALLETT   21 MAR 87
5600 S. COUNTRYCLUB #64
TUCSON AZ 85706 
PHONE:(602)889-6930

HORIZON RAMDISK 256K EXPANSION PROJECT

by EDWARD A.^HALLETT

SOUTHWEST NINETY-NINERS

The HORIZON RAMDISK is available in 90K SSSD (360 SECTOR) and 180K DSSD (720 SECTOR) sizes. This project expands the size to 256K (976 SECTORS) for an increase in storage capacity of 64K (256 SECTORS) or 35.5%.

This increase is accomplished by adding one 74LS154 (4 to 16 DECODER), one 74LS02 (NOR GATE), and eight 8K 6264LP-15 STATIC RAM chips, removing one 74LS138 (3 to 8 DECODER) chip, and modifying the DSR CODE to recognize the existance of the added memory. The original HORIZON RAMDISK CIRCUIT does not fully decode one of the five memory address lines from U9 limiting it to 180K.

By fully decoding this line we pick up eight more CHIP SELECT SIGNALS bringing us up to 256K (976 SECTORS).  This utilizes the original design to its fullest potential with only a few SIMPLE MODIFICATIONS.

The HORIZON SOURCE CODE VER_03 was used in this project but modifications to future versions should be very similar.

Note: VER_04 modifications were identical, except MEMTEST.  Use the modified MEMTEST from VER_03 or DM-II Disk Tests to check the memory added by this EXPANSION PROJECT.

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
CAUTION: THIS MODIFICATION IS UNDERTAKEN AT YOUR OWN RISK
^^^^^^^^^AND MAY VOID YOUR HORIZON WARRANTY ^^^^^^^^^^^^^
:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

CAUTION: REMOVE THE NICAD BATTERIES FROM THE RAMDISK BEFORE STARTING.
         USE CARE WHEN HANDLING THE RAM CHIPS TO AVOID DAMAGE FROM STATIC.
:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

1. Remove U1, the original 3 TO 8 DECODER CHIP, from its socket and DISCARD.

2. Remove the EIGHT PIGGYBACKED PAIRS of 8K RAM CHIPS from their sockets U3-U6 and U12-U16.

3. Remove U2, the original 4 TO 16 DECODER, from its socket.

4. Remove U10, the original NOR GATE, from its socket.

5. Install a THIRD ADDITIONAL 8K RAM CHIP PIGGYBACKED on top of EACH of the removed PIGGYBACKED PAIRS of 8K RAM CHIPS connecting EACH PIN to its CORRESPONDING PIN below with the EXCEPTION of PIN 20 (CHIP SELECT). BEND PIN 20 outward like PIN 20 on the CHIP below it.

Reinstall these EIGHT PIGGYBACKED TRIOS into their sockets (U3-U6 and U12-Y13) and RECONNECT the ORIGINAL lines from PIN 20 of the CENTER CHIPS to their ORIGINAL POINTS on the EXPANSION JACK next to U3.

6. Install the ADDITIONAL 4 TO 16 DECODER CHIP (74LS154) PIGGYBACKED on top of the ORIGINAL 4 TO 16 DECODER CHIP, U2.  Connect PIN 12 and PINS 20 THRU 24 to their corresponding PINS below.  Bend PINS 1 THRU 11 and PINS 13 THRU 19 OUTWARD. Reinstall the PIGGYBACKED PAIR of 4 TO 6 DECODERS in its U2 socket.

Connect lines from the UPPER CHIP PINS 1 THRU 8 as follows.

PIN 1 to U1 SOCKET PIN 15.^^^^^^^PIN 2 to U1 SOCKET PIN 14
PIN 3 to U1 SOCKET PIN 13.^^^^^^^PIN 4 to U1 SOCKET PIN 12
PIN 5 to U1 SOCKET PIN 11.^^^^^^^PIN 6 to U1 SOCKET PIN 10
PIN 7 to U1 SOCKET PIN^^9.^^^^^^^PIN 8 to U1 SOCKET PIN ^7

These provide the CHIP SELECT SIGNALS to the ORIGINAL (CENTER LAYER) of 8K RAM CHIPS.

Connect lines from the UPPER CHIP PINS 9 THRU 11 and 13 THRU 17 as follows.

PIN ^9 to PIN 20 U3^^TOP 8K CHIP.^^^PIN 10 to PIN 20 U4^^TOP 8K CHIP.
PIN 11 to PIN 20 U5^^TOP 8K CHIP.^^^PIN 13 to PIN 20 U6^^TOP 8K CHIP.
PIN 14 to PIN 20 U12 TOP 8K CHIP.^^^PIN 15 to PIN 20 U13 TOP 8K CHIP.
PIN 16 to PIN 20 U14 TOP 8K CHIP.^^^PIN 17 to PIN 20 U15 TOP 8K CHIP.

These provide the CHIP SELECT SIGNALS to the ADDITIONAL EIGHT 8K RAM CHIPS (TOP LAYER).

7.^Install a new NOR GATE (74LS02) PIGGYBACKED on top of the ORIGINAL NOR GATE, U10.  Connect PINS 2, 7, and 14 to the CORRESPONDING PINS below. BEND PINS 1, 3 THRU 6, and 8 THRU 13 outward. Reinstall the PIGGYBACKED PAIR of NOR GATES in its U10 socket.  Connect LINES from the UPPER CHIP as follows.

PIN 1 to PINS 18 and 19 U2 UPPER CHIP.^^^PIN 3 to U1 SOCKET PIN 6.

These provide the CHIP SELECT SIGNAL for U2 UPPER 4 TO 16 DECODER CHIP thus fully decoding the available MEMORY ADDRESS LINES.

PINS 4 THRU 6 and PINS 8 THRU 13 of the UPPER NOR GATE U10 are not used and are left NOT connected. They may be used in future modifications.

This completes the HARDWARE modifications to the RAMDISK CARD.  Next the DSR SOFTWARE must be modified so that this ADDITIONAL MEMORY can be accessed.

The original DSR CODE, CALL SUBPROGAMS, ETC.^are located in RACKS 90-92 at the top of the RAMDISK MEMORY MAP. The MODIFIED RAMDISK MEMORY MAP now extends to RACK 124 and the DSR must be moved to the new top, in RACKS 122-124.

NOTE: IF THE CODE IS NOT MOVED IT WILL BE ERASED WHEN THE RAMDISK IS
INITIALIZED TO MORE THAN 720 SECTORS.

The changes to the CODE, consist of changing ALL REFERENCES for the three upper 2K blocks of memory to a NEW LOCATION, changing the LOADER PROGRAMS to LOAD the NEW CODE at the NEW LOCATION, changing the MEMTEST PROGRAM to check THIRTY-TWO 8K CHIPS, changing the MAX SECTOR CALL, and modifying the FORMAT ROUTINE of the DSR.

Luckily, this is much EASIER than it might appear since the SOURCE CODE for the HORIZON RAMDISK was provided with the KIT and is very well Documented!

The following PROGRAMS will need to be modified and then REASSEMBLED with the EDITOR-ASSEMBLER.  CALL/S, CHECK/S, CLEAR/S, CREATE/S, FILL/S, LOADER/S, PARTA, SVXB/S, XB/S, and VERSION/S.

The BASIC program MEMTEST must also be modified. The other ORIGINAL SOURCE programs do not require modifications and are used as is.

1.^^MEMTEST^^^^Delete LINES 110, 130 thru 170, 190, 200, 320 thru 340. Change LINE 180 from "LENGTH=24" to "LENGTH=32".

2.^^CALL/S^^^^^Change "CI R2,1441" to "CI R2,977" at LABEL MAX02.

3.^^CHECK/S^^^^Change "CI R2,24" to "CI R2,32" (fourth LINE after LABEL CHK1).

4.^^CLEAR/S^^^^Change "LI R2,90" to "LI R2,123" (fourth LINE after LABEL LOOP1).

5.^^CREATE/S^^^Change "DATA >BB00" to "DATA >FB00" at LABEL LINK1.

Change "DATA >BD00" to "DATA >FD00" at LABEL LINK2.
Change "DATA >BF00" to "DATA >FF00" at LABEL LINK3.
Change "PARTA_03" to "PARTA256" in the TEXT LINE after LABEL PDATA.
Change "PARTB_03" to "PARTB256" in the TEXT LINE after LABEL LDATA.

6.^^FILL/S^^^^^Change "LI R5,93" to "LI R5,125" (one LINE before LABEL
FLOOP1).

7.^^LOADER/S^^^Change "DATA >BB00" to "DATA >FB00" at LABEL LINK.

Change "BYTE >BB" to "BYTE >FB" at LABEL MXL1.
Change "BYTE >BD" to "BYTE >FD" at LABEL MXL2.
Change "BYTE >BF" to "BYTE >FF" at LABEL MXL3.

8.^^PARTA^^^^^^Change "DATA 720" to "DATA 976" at LABEL MAXSEC.

Change "DATA 720" to "DATA 976" at LABEL FORSEC.
Change "DATA >BB00" to "DATA >FB00" at LABEL LINK1.
Change "DATA >BD00" to "DATA >FD00" at LABEL LINK2.
Change "DATA >BF00" to "DATA >FF00" at LABEL LINK3.

Add the LINES "C R8,@@MAXSEC" and "JEQ FFDONE" after the LINE "INC R8" (fourth LINE after LABEL FMTLP1).

Add the LINE "FFDONE MOV R8,R3" after the LINE "JNE FMTLP0" (sixth LINE after LABEL FMTLP1).

9.^^SVXB/S^^^^^Change "LI R1,>BF00" to "LI R1,>FF00" (fourth LINE after LABEL SVXB).

10.^VERSION/S^^Change "DATA >BB00" to "DATA >FB00" at LABEL LINK1.

Change "DATA >BD00" to "DATA >FD00" at LABEL LINK2.
Change "DATA >BF00" to "DATA >FF00" at LABEL LINK3.
Change "PARTA_03" to "PARTA256" in the TEXT LINE after LABEL PDATA.
Change "PARTB_03" to "PARTB256" in the TEXT LINE after LABEL LDATA.

11.^XB/S^^^^^^^Change "CI R2,1441" to "CI R2,977" at LABEL MAX02.

REASSEMBLE these FILES to create the NEW OBJECT FILES. Then REASSEMBLE the FILE "TEST/S" which ASSEMBLES the DSR FILES PARTA thru PARTE. Call this FILE "DSR256".  ASSEMBLE the ORIGINAL FILES "CHAR/S" and "DOWNLD/S" from the HORIZON SOURCE DISK.

Next RUN the "LOADER" program assembled from "LOADER/S" to LOAD the following:

"DSR256" into BLOCK 1.
"CALL" from the assembled FILE "CALL/S" into BLOCK 2.
"CHAR" from the assembled FILE "CHAR/S" into BLOCK 3.
"DOWNLD" form the assembled FILE "DOWNLD/S" into BLOCK 3.

Now RUN this BASIC program with the EDITOR-ASSEMBLER cartridge installed.

100 CALL INIT
110 CALL LOAD("DSK1.XB")
120 CALL LOAD("DSK1.SVXB")
130 CALL LINK("SVXB")
140 END

NOTE: The RAMDISK MUST be set at CRU 1000 for the SVXB program to work as it does NOT search for the HORIZON CARD CRU like the other programs do. If you have another CARD at CRU 1000 (like the MYARC 128K or 512K CARD) you can change the sixth LINE of the "SVXB/S" FILE from "LI R12,1000" to "LI R12,(CRU of your HORIZON CARD)".

The modified DSR CODE, CALL SUBPROGRAMS ETC.^are now LOADED in their NEW locations in RACKS 122 THRU 124. Next RUN the program "CREATE" from the assembled FILE "CREATE/S" (PROGRAM NAME "IMAGE").  This will create the FILES "PARTA256" and "PARTB256" on DSK1 for use with the VER256 LOADER from the assembled FILE "VERSION/S".

The SOURCE CODE for the program "UTIL1" (the multiple RAMDISK LOADER) was not provided on the HORIZON SOURCE CODE DISK. It can be modified by DISSASSEMBLING it with "MILLERS GRAPHICS DISkASSEMBLER", finding the four words >02D0, >BB00, >BD00, and >BF00, changing them to >03D0, >FB00, >FD00, >FF00, changing "PARTA_03" and "PARTB_03" to "PARTA256" and "PARTB256", REASSEMBLING the program, and then RUNning the SAVE UTILITY from the EDITOR/ASSEMBLER to change
it back to PROGRAM IMAGE FORMAT.

This completes the DSR modifications. All functions of the HORIZON RAMDISK will function as they did originally, but now being able to UTILIZE 976 SECTORS (256K).

When formatting the 976 SECTOR RAMDISK select DSDD format. The DISKMANAGER will show "974 SECTORS FREE" and "466 SECTORS USED".  This is because the DISKMANAGER is trying to format 1440 SECTORS and reads 466 USED during SECTOR VERIFICATION.  This does not affect RAMDISK OPERATION in any way but it can be corrected to show "974 SECTORS FREE" and "2 SECTORS USED" by changing BYTES 10 and 11 of SECTOR 0 from >05A0 to >03D0. The following program is used to
correct the SECTORS FORMATTED number.

DEF^^START
SECTOR DATA^>03D0
START^^LI^^^R12,>1200 CRU OF YOUR CARD
LI^^^R1,7
SWPB R1
LDCR R1,8
MOV^^@@SECTOR,@@>580A.
SBZ^^0
RT
END^^START

This completes the HORIZON RAMDISK 256K EXPANSION PROJECT.

Questions concerning this EXPANSION PROJECT should be sent to:
SOUTHWEST 99ER'S, 
P.O. BOX 17831, 
TUCSON AZ 85730.
ATTN: EDWARD HALLETT, V.P.

---

From: "Cory Klatt" <[email-masked]>
Date: Fri, 04 Nov 2011 15:38:11 -0000

This is exactly what I was looking for.  Thank you for posting it!