Subject: Heres a weird one

From: "BobK" <[email-masked]>
Date: Mon, 14 Nov 2011 05:36:40 -0000

I found a program and am trying to enter it in but came across a problem, in one of the statements it has ]$="DGL\OSV.DGL* The letter that is supposed to be where the astrix is looks like a S with a upside down caret over it (I believe it is called a caron.) Does anyone know how to enter this character from the TI keyboard?

Thanks-
Bob K.

---

From: Jeffrey White <[email-masked]>
Date: Tue, 15 Nov 2011 20:12:53 -0800 (PST)

Interesting.  That sounds like ASCII character 138 for uppercase S, and 
character 154 for lowercase s, with the caron.

Is this a TI BASIC program?  On the TI, neither console BASIC nor Extended BASIC 
have that character defined.

However, if you know that the letter A is ASCII character 65, then you can 
calculate what Control-A is by adding 64, or 129.  Reverse the process for 138 
by subtracting 64 to get the key you need, or ASCII character 74.  74 is 9 away 
from 65, and the ninth letter of the English alphabet is J.

To type ASCII character 138 in TI BASIC, type Control-J.

Now you know.

If you want, you can write a program to define characters 129 to 159, run it, 
type NEW, and then you will see the characters as you type in BASIC.

You can also use &CHR$(138) to append to a string, such 
as ]$="DGL\OSV.DGL"&CHR$(138)

If you want the double quote (") in a string, you need to use CHR$(34).

Jeff White 

________________________________
From: BobK <[email-masked]>
To: [email-masked]
Sent: Mon, November 14, 2011 12:36:40 AM
Subject: [TI994A] Heres a weird one

I found a program and am trying to enter it in but came across a problem, in one 
of the statements it has ]$="DGL\OSV.DGL* The letter that is supposed to be 
where the astrix is looks like a S with a upside down caret over it (I believe 
it is called a caron.) Does anyone know how to enter this character from the TI 
keyboard?

Thanks-
Bob K.

---

From: ti99_forever <[email-masked]>
Date: Wed, 16 Nov 2011 06:27:01 -0800 (PST)

Double quote within a string is done with two double-quotes...
S$="Jeff was a really ""bad"" boy"
print s$
Jeff was a really "bad" boy

>From: Jeffrey White <[email-masked]>
>Sent: Tuesday, November 15, 2011 11:12 PM
>Subject: Re: [TI994A] Heres a weird one
>
>
> 
>
>
>
>Interesting.  That sounds like ASCII character 138 for uppercase S, and character 154 for lowercase s, with the caron.
> 
>Is this a TI BASIC program?  On the TI, neither console BASIC nor Extended BASIC have that character defined.
> 
>However, if you know that the letter A is ASCII character 65, then you can calculate what Control-A is by adding 64, or 129.  Reverse the process for 138 by subtracting 64 to get the key you need, or ASCII character 74.  74 is 9 away from 65, and the ninth letter of the English alphabet is J.
> 
>If you want, you can write a program to define characters 129 to 159, run it, type NEW, and then you will see the characters as you type in BASIC.
> 
>You can also use &CHR$(138) to append to a string, such as ]$="DGL\OSV.DGL"&CHR$(138)
>

---

From: "BobK" <[email-masked]>
Date: Thu, 17 Nov 2011 03:45:24 -0000

I figured it would be something that could be ALT or Cntrl'd to get the correct letter, I will play with it to see what I can get.

This is from the XB program QUASIMODO that I found on a site and thought I would like to see how it was put together bur ran into the strange letter problem, I find this happens quite often on programs that come from Europe.
Thank-
Bob K.

---

From: ti99_forever <[email-masked]>
Date: Wed, 16 Nov 2011 20:06:26 -0800 (PST)

In that case, look in any printer manuals you have (Epson, for example), and look for that character in the tables - and use its number in the CHR$() function.

Ben

>Sent: Wednesday, November 16, 2011 10:45 PM
>Subject: [TI994A] Re: Heres a weird one
>
>
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: "BobK" <[email-masked]>
Date: Wed, 23 Nov 2011 01:28:26 -0000

Yep! Your right (0138) is the code for that figure but I have run the program and have not seen any difference with the 0138 in or out of the program, maybe at a later level it will make a difference 
Thanks-
Bob K.

--- In [email-masked], ti99_forever <ti99_forever@...> wrote:
> >From: BobK <bkaspar@...>
> >--- In [email-masked], Jeffrey White <ti994a@> wrote:
> >>

---

From: ti99_forever <[email-masked]>
Date: Tue, 22 Nov 2011 17:37:13 -0800 (PST)

There'd likely be a CALL CHAR somewhere with 138 being defined, or maybe just a CALL COLOR for the color group that has 138 in it...

>Sent: Tuesday, November 22, 2011 8:28 PM