Subject: HDX preorder is closed

From: Gregory McGill <[email-masked]>
Date: Thu, 21 Mar 2013 09:41:49 -0700

HDX pcboard pre-order is closed if anyone has committed to sending in
payment and has not yet please contact me directly and let me know when to
expect or I can send you a google wallet request for visa/mc payment if
necessary.

I am planning on placing the order tomorrow for the boards, estimated
delivery is 3-4 weeks.

Greg

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 08:39:02 -0700

Order shipped from the manufacturer, eta 2 weeks

Greg