Subject: HRD3000 not recognizing all memory

From: "epergrem" <[email-masked]>
Date: Sun, 18 Mar 2012 16:01:02 -0000

I have a HRD3000 that will only recognize the first 184K of memory, or the first half of RAM.  I've tested, or replaced all of the chips, both memory and logic with no change.

I don't see any broken traces.  I suppose that it could be a crappy socket not passing though a line.  I don't relish replacing sockets, but that may be the next step.

I've seen this on some of the Midwest Engineering boards, so it doesn't appear to be a rare occurrence.

Any suggestions on what to look for next, so maybe I don't have to replace any sockets? :-)

Thanks,
Ernie

---

From: Marc Hull <[email-masked]>
Date: Sun, 18 Mar 2012 09:34:28 -0700 (PDT)

If it's a 32K*8 (which the math points to) then something is wrong with the 7th SRAM or it's connection.  So I would bet that either U14 is bad or more likely the socket is bad.  Maybe you could get away with just replacing that one.  

If you OHM pin to pin from U14 to U13 you should only have 1 pin that does not show continuity.  If you have more then I would suspect the crappy single wipe sockets (if that is indeed what they are.)

Glad there is someone else to share in a little HRD pain.  Have a good weekend Ernie ;-).....

--- On Sun, 3/18/12, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] HRD3000 not recognizing all memory
To: [email-masked]
Date: Sunday, March 18, 2012, 11:01 AM

  

Thanks,

Ernie

---

From: "epergrem" <[email-masked]>
Date: Sun, 18 Mar 2012 23:02:00 -0000

Thanks Marc & Richard,
You are correct about it being 32K*8, which means fully populated and single-stacked it would be 384K.  According to the construction guide U11 should be an 8K chip, so I should be okay there also.  However, I tried a 32K*8 and still had the same issue.

You are also correct about only one pin not showing continuity. fifth or sixth from the bottom as I recall.  All sockets show similar results.  

Voltages are also consistent across all memory chips. 

Since I have the build manual I'm going to check the jumpers and make sure they are all correctly wired and check connections to the 6264.  (I'm really.. trying to avoid replacing that socket. ;-))

Ernie