Subject: Re: [TI994A] More HRD questions....

From: [email-masked]
Date: Mon, 06 Feb 2012 15:21:19 -0600 (CST)

Ummm.....My main system is setup with two WHT 4000 series. One card is 8 meg (512 SRAMS) and the other is 2 meg (128 SRAMS). Disks are 5 thru 9 and F thru Z 1600 sectors each disk.

On 02/06/12, Marc H<[email-masked]> wrote:

Turns out the problem was in some crappy IC sockets. Who would of thunk it ??

I do have a couple of tech questions that hopefully someone can shed some light on.

It is apparent that the HRD 3000 is capable of holding and physically addressing around 6 MB of memory in a single layer configuration and around 12 MB in a double layer fashion. My understanding (which may be wrong) is that the traditional HRD access maxes out at about 3.5 meg.

I am assuming that this is because the ROS will only allow 9 drives at a max of 1600 sectors each.

Now the question..... Is this simply a convention of ROS (allowing 9 drives only which allow the 3.5 MB) or is there a deeper cause rooted in some TI DSR or ROM code ?

Thanks.

Marcus...

------------------------------------

Yahoo! Groups Links

<*> To visit your group on the web, go to:
http://groups.yahoo.com/group/TI994A/

<*> Your email settings:
Individual Email | Traditional

<*> To change settings online go to:
http://groups.yahoo.com/group/TI994A/join
(Yahoo! ID required)

<*> To change settings via email:
[email-masked]
[email-masked]

<*> To unsubscribe from this group, send an email to:
[email-masked]

<*> Your use of Yahoo! Groups is subject to:
http://docs.yahoo.com/info/terms/

---

From: Marc Hull <[email-masked]>
Date: Mon, 6 Feb 2012 13:36:54 -0800 (PST)

Hey Rich.

I guess I never got past A,B,C,D,E,F,G,H,I  cause my 3 meg runs out of memory.  (there's a dirty joke there somewhere about yours being bi...  well you get the picture.;-)

I guess I should go back and do some experimenting and salvage my pride.

Thanks for the redirection. This might get pretty cool.

--- On Mon, 2/6/12, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] More HRD questions....
To: [email-masked]
Date: Monday, February 6, 2012, 3:21 PM

  

      Ummm.....My main system is setup with two WHT 4000 series. One card is 8 meg (512 SRAMS) and the other is 2 meg (128 SRAMS). Disks are 5 thru 9 and F thru Z 1600 sectors each disk.  On 02/06/12, Marc H<[email-masked]> wrote: Turns out the problem was in some crappy IC sockets. Who would of thunk it ??

Thanks.

Marcus...

Yahoo! Groups Links

---

From: Marc Hull <[email-masked]>
Date: Mon, 6 Feb 2012 13:54:46 -0800 (PST)

So perhaps this is what led  me to believe that there is a Ramdisk limit per card. 

When I get to end of the list while formatting the RD's I can't go past the 10th one.  Need some knowledge here Rich.

 

    

Thanks.

Marcus...

Yahoo! Groups Links

---

From: [email-masked]
Date: Tue, 7 Feb 2012 08:12:18 +0000 (UTC)

Marc 

So you are using a Horizon RD 4000 with 3 meg of memory? 

I had one custom layered by Bud Mills for me. I do not remember the size of each RD but I always used the max settings on all except the first 2 were DSDD ones. 

Never had more then 5 RD I think but then I also had 4 SCSI drives also. Also I had 2 DSDD floppys drives so that would be over 10 drives. 

What exactly is the problem? 

Rich 

----- Original Message -----
From: "Marc Hull" <[email-masked]> 
To: [email-masked] 
Sent: Monday, February 6, 2012 1:54:46 PM 
Subject: Re: [TI994A] More HRD questions.... 

  

  

Thanks. 

Marcus... 

Yahoo! Groups Links

---

From: Marc Hull <[email-masked]>
Date: Tue, 7 Feb 2012 04:19:58 -0800 (PST)

There is no problem.  At least I haven't broken anything yet....

I think RB and I were comparing apples and oranges as I don't think my question was clear enough.  What I am trying to get to the bottom of is.....

1) How many virtual drives can be formatted per "HRD 3000".  I believe the answer is 10.  Reading the HRD 4000 docs it looks like a maxed out (8 MB) card can indeed have 20 drives if it has the Phoenix modification (apparently this mod makes 1 card appear as 2 separate cards.) Without the mod then the card can only create 10 drives regardless of how much memory it has.  Bearing in mind this is just what I gleaned from the doc's. 

2) What is the maximum amount of memory that can be utilized by ROS on this HRD 3000 with no modifications.  I am confident that the number is 4MB ( 10 drives x 1600 sectors x 256 bytes = around 4 MB.)  Any more will still be there but cannot be used as RAM Disk space.

3)  What the hell does the Phoenix mod do ?  Is there any info about it ? Does it create another RD at a different CRU address or use other wizardry or am I confused as to it's function ?  

Now if some one has these particular answers then I would really appreciate being lined out before I step off a ledge in the dark or break something.....again     ;-).

Hull 

--- On Tue, 2/7/12, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: [TI994A] More HRD questions....
To: [email-masked]
Date: Tuesday, February 7, 2012, 2:12 AM

  

      Marc

 

Rich

  

  

 

Thanks.

Marcus...

Yahoo! Groups Links

---

From: "epergrem" <[email-masked]>
Date: Tue, 07 Feb 2012 13:10:02 -0000

Hi Marc,
My memory may be faulty, but someone will correct me if it is.

Regarding the Phoenix mod; my understanding is that it splits the HRD, so that it will use two CRU addresses rather than one.

The mod came about because the Geneve, at least at one time, was limited by the size of RAM disk that it could boot from. Something like 800k?   So, 800K or less got allocated to one CRU address, which could be used for booting and the remainder was allocated to the second CRU address, which wasn't confined to the 800K limit. 

The mod wasn't necessary for the 99/4A, though I suppose it could be used to get around the 10 drive limit you referred to.  

or at least that's how I recall it. ;-)

Ernie

---

From: Marc Hull <[email-masked]>
Date: Tue, 7 Feb 2012 14:17:10 -0800 (PST)

It appears that the Phoenix (is this the bird or the place ?) mod has morphed in the 4000 series to simply provide 2 maxed out 4 MB HRDs on one physical card.  If someone has an 8MB HRD...... Ahem.......Richard...... would you please run configure and report back how many HRD cards are reported and their size ?  I suspect it will be more than is physically present (number of cards that is ) but hopefully we will see.

For now I guess it is safe to assume that the actual MB limit that ROS can use is 4 MB (per card that is.....  or maybe better put.... 4 MB per CRU address.)  In fact since evidently you must load ROS in each card in your system then the max memory that ROS can use is 4 MB.  Assuming this is true does anyone know whether this is just ROS or has more sinister origins.

As an aside I am using the term "4 MB"  as an approximate.  It is slightly less in actuality.

And where the hell is Bud Mills when you need him ;-).  Really....... does any one know where the man is and whether or not he might chime in ?

--- On Tue, 2/7/12, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] Re: More HRD questions....
To: [email-masked]
Date: Tuesday, February 7, 2012, 7:10 AM

  

      Hi Marc,

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

> 3)Â  What the hell does the Phoenix mod do ?Â  Is there any info about it ? Does it create another RD at a different CRU address or use other wizardry or am I confused as to it's function ?Â  

> Now if some one has these particular answers then I would really appreciate being lined out before I step off a ledge in the dark or break something.....again Â  Â  ;-).

---

From: tursi <[email-masked]>
Date: Tue, 7 Feb 2012 14:52:48 -0800 (PST)

> system then the max memory that ROS can use is 4 MB.  Assuming this is true
> does anyone know whether this is just ROS or has more sinister origins.

There's nothing in the way that the TI accesses files that limits it to 
4MB on a device (in fact, the system has no concept of device sizes, only 
files).

TI accesses files and devices via the DSR interface, which is 
record-based. You can specify up to 65536 records in a random access file, 
and records can be up to 256 bytes each. That implies a maximum file size 
of 16MB, and of course devices can contain more than one file.

That's just convention, though. A DSR is free to invent alternate access 
modes. But for disk access you would want to stay compatible.

In order for ROS to access disk devices, it needs to reserve some memory 
for the names in the header chain. So the limit of 10 is likely based on 
that being how much space is reserved rather than any hard limit of the 
card. There is definately no hard limit in the TI device access mechanism.

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 7 Feb 2012 17:25:32 -0600

Hey Marc -  I think 4MB is the hardware addressing limitation versus a ROS limitation.   The Phoenix mod was used with the Geneve before Schroeder wrote his formatting programs.  
 To: [email-masked]
From: [email-masked]
Date: Tue, 7 Feb 2012 14:17:10 -0800
Subject: Re: [TI994A] Re: More HRD questions....

As an aside I am using the term "4
 MB"  as an approximate.  It is slightly less in actuality.

 

      Hi Marc,

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

---

From: Marc Hull <[email-masked]>
Date: Wed, 8 Feb 2012 13:53:07 -0800 (PST)

Well you may be right but I am getting more and more convinced that ROS only wants you to have 10 virtual drives per CRU address.  It looks like physically the card only has to address enough memory to cover one chip (IE a card with 512K chips  only need to be able to present an address up to around the 512K limit.  The other chips are banked in via the 154.

I would guess that the designers thought process was... "Who in they're right mind would want a RAM Disk bigger than 4 MB or want more than 10 drives ;-).

That bodes well for you and your plan to create a 12 MB hard drive complete with limited directory structure.  Have you actually started the software yet ?  This will be a neat project when you are done with it.  Please keep us abreast of progress.

Andrew......

--- On Tue, 2/7/12, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Re: More HRD questions....
To: [email-masked]
Date: Tuesday, February 7, 2012, 5:25 PM

  

      

        

 

      Hi Marc,

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

---

From: Insane Multitasker <[email-masked]>
Date: Wed, 8 Feb 2012 19:06:17 -0600

Yes, I modified a version of MDOS to use the entire RAMdisk as a 'hard drive' using the same format as the HFDC, SCSI, and IDE cards.  So if the card can address 3,6,12 or more MB, one could have a battery-backed up RAMdisk emulating a hard disk.  
 To: [email-masked]
From: [email-masked]
Date: Wed, 8 Feb 2012 13:53:07 -0800
Subject: RE: [TI994A] Re: More HRD questions....

Andrew......

--- On Tue, 2/7/12, Insane
 Multitasker <[email-masked]> wrote:

 

      

        

For now I guess it is safe to assume that the actual MB limit that ROS can use is 4 MB (per card that is.....  or maybe better put.... 4 MB per CRU address.)  In fact since evidently you must load ROS in each card in your system then the max memory that ROS can use is 4 MB.  Assuming this is true does anyone know whether this is just ROS or has more sinister
 origins.

 

      Hi Marc,

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

---

From: Marc Hull <[email-masked]>
Date: Wed, 8 Feb 2012 18:15:17 -0800 (PST)

That is exactly why you are such a stallion Tim !  Rock out with your sock out ;-).

Got some details ?

--- On Wed, 2/8/12, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Re: More HRD questions....
To: [email-masked]
Date: Wednesday, February 8, 2012, 7:06 PM

  

      

        

Andrew......

 

      

        

 

      Hi Marc,

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

---

From: Insane Multitasker <[email-masked]>
Date: Wed, 8 Feb 2012 20:49:17 -0600

Flattery may only induce me to locate hardware for you to destroy.  ;) Not much in the way of details  - format and go.  Not very sexy, huh?
 To: [email-masked]
From: [email-masked]
Date: Wed, 8 Feb 2012 18:15:17 -0800
Subject: RE: [TI994A] Re: More HRD questions....

Got some details ?

 

      

        

That bodes well for you and your plan to create a 12 MB hard drive complete with limited directory structure.  Have you actually started the software yet ?  This will be a neat project when you are done with it.  Please keep us abreast of
 progress.

Andrew......

 

      

        

 

      Hi Marc,

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

---

From: Marc Hull <[email-masked]>
Date: Wed, 8 Feb 2012 19:13:50 -0800 (PST)

Format with what ?( I have a feeling you are going to bark when this comes up.)

Seems we need a hardware description of the HRD huh.  Who's got one of those ?....

2/8/12, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Re: More HRD questions....
To: [email-masked]
Date: Wednesday, February 8, 2012, 8:49 PM

  

      

Flattery may only induce me to locate hardware for you to destroy.  ;)
 
Not much in the way of details  - format and go.  Not very sexy, huh?

        

Got some details ?

 

      

        

Andrew......

 

      

        

 

      Hi Marc,

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote: