Subject: TI-99/4A retro printing

From: "roundf" <[email-masked]>
Date: Mon, 25 Jun 2012 02:54:01 -0000

If you wanted to print from an emulator, say, Win99/4A to modern printer you could use TIDIR to get your program listing and print it out in modern fonts. But what if you wanted the listing like it is from the screen, in the old font? Is there a way to print the losing from RAM or disk and print it out on a modern printer, but it would look like a printing straight from the TI? I mean, aside from the green and white lines and tear off hole perforations, ha, the actual output should look just like the 80's but on different paper!

Anyway, I wonder if you can print a listing to disk to print as a file later, or if you have to load the program up and do some kind of rs232.ba or something like that. I think I asked a similar question awhile back, but this should be more specific as a question than the last time I asked 
about this subject.

---

From: ti99_forever <[email-masked]>
Date: Sun, 24 Jun 2012 22:16:08 -0700 (PDT)

It never really worked that way. When we sent output to the RS232 or PIO to our printer, it printed it in that printer's fonts.
Closest you could come was on an Alphacom 81 printer using the sidecar cable. You could open that up in a mode where it would use the TI's character definitions, or have it do a screen-dump.
Screen dumps were written for other printers as well - for printing graphic displays or small images. But generally, listings of programs were not done that way.

Ben

>________________________________
> From: roundf <[email-masked]>
>To: [email-masked] 
>Sent: Sunday, June 24, 2012 10:54 PM
>Subject: [TI994A] TI-99/4A retro printing
> 
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: "Brian Tristam Williams" <[email-masked]>
Date: Mon, 25 Jun 2012 14:59:18 -0000

You could do a screen dump of the emulator and print that. Even if it took several screens. In the 90s, I did redefine my PCs DOS fonts to those of the TI, including background and foreground colours. Pretty cool.