Subject: HDX TI99Dir TIImage tools

From: Insane Multitasker <[email-masked]>
Date: Sun, 26 May 2013 14:23:17 -0500

Fred, Michael,

The following request may be something you have either considered or implemented.  I am not able to test today, hence my email. 

In most of the programs I have written or modified, including PORT, S&T BBS, and Archiver, I enforce masking of the unused file type bits found in each file's FDR, byte 12.  I mask these same bits in incoming files transferred to the Horizon RAMdisks in ROS8.34 via the level 2 routine 0x15. (Note: one must be careful not to mask the emulate file type). 

I propose that your program(s) add similar functionality, either by default or as an option, to minimize the impact the bits have on programs that do not expect them to be set.  Doing so would help to alleviate a big problem inherent in transfering between various images and file libraries.  

Tim

---

From: "Michael Zapf" <[email-masked]>
Date: Mon, 27 May 2013 20:49:43 -0000

Hi Tim,

which bits are you specifically talking about? See:

http://www.ninerpedia.org/index.php/TIFILES_format#The_Flags_field

The flags field in TIFILES is a copy of the one in the FDR.

Michael

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 27 May 2013 16:14:59 -0500

Hi Michael,

The "modified" bit (also known as the 'archive' or 'backup' bit) is the most prevalant, set primarily by the HFDC.  When this bit is transferred to a floppy device via the level 2 IO routines (0x14, 0x15, 0x24,0x25,0x84,0x85,0x94,0x95) of the various controllers, many floppy-only programs fail to mask these bits causing improper file typing.   The Horizon MENU program demonstrates the issue quite nicely. 

I will need to review my notes regarding the two "reserved" bits and what use, if any, I have identified to data.  IIRC, no one has utilized the reserved bits in any of the newer DSRs. 

> To: [email-masked]
> From: [email-masked]
> Date: Mon, 27 May 2013 20:49:43 +0000
> Subject: [TI994A] Re: HDX TI99Dir TIImage tools
> 
> 
> 
> Hi Tim,
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>