Subject: DM2K and SCSI DSR bug

From: [email-masked]
Date: Sun, 23 Oct 2011 22:50:46 +0000 (UTC)

RXB does not have this problem. 

I have opened and created over 32 deep of folders and subfolders (Volumes/SubVolumes) so I suspect the way that DM2K does buffers is the problem. 

Now I am not saying RXB should be substitute for DM2K but when DM2K crashes RXB always works instead, now that says alot about the problem. 

Example: 

I create a subvolume (subfolder) and then try to create another but DM2K crashes. 

But in RXB I do a: 

P$="SCS1.GROM.CARTS.GAMES.CHILD." 

CALL MKDIR(P$, "SUBTRACTN3") 
P$=P$&"SUBTRACN3." 

CALL FCOPY(1,"MKSUB3",P$,"MKSUB3") 

The above uses P$ as the path then MKDIR makes the directory and new subdirectory is added to name and FCOPY then copies off DSK1 file MKSUB3 to new Volume. 

I do not remember the last time RXB has crashed with my SCSI, unless it was something that was a problem created by DM2K, like bad file copies or goofy names. 

Every single problem I have ever had with SCSI can be repaired with RXB including fixing sectors on the SCSI harddrive. 

Rich

---

From: ti99_forever <[email-masked]>
Date: Sun, 23 Oct 2011 15:53:12 -0700 (PDT)

But... I've been able to replicate this issue in XB... a simple program that shows you the tree listing crashes at the 15-16 level as well.

>________________________________
>From: "[email-masked]" <[email-masked]>
>To: [email-masked]
>Sent: Sunday, October 23, 2011 6:50 PM
>Subject: [TI994A] DM2K and SCSI DSR bug
>
>
> 
>
>
>
>

---

From: [email-masked]
Date: Sun, 23 Oct 2011 22:57:47 +0000 (UTC)

Do you have the updated SCSI EPROM like I do? I know for a fact that the older EPROMs had many problems. 

Don O'Neil installed the last EPROM update on my card for me. 

Rich 

----- Original Message -----
From: "ti99_forever" <[email-masked]> 
To: [email-masked] 
Sent: Sunday, October 23, 2011 3:53:12 PM 
Subject: Re: [TI994A] DM2K and SCSI DSR bug 

  
Example: 

Rich

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 23 Oct 2011 18:06:31 -0500

The problem is within the SCSI DSR and is dependent upon a few factors.  Buffers are independent from the platform and are controlled by the DSR.  I expect RXB to encounter the same issue with the same test(s).

To: [email-masked]
From: [email-masked]
Date: Sun, 23 Oct 2011 22:50:46 +0000
Subject: [TI994A] DM2K and SCSI DSR bug

 
Example:

Rich