Subject: Re: Interest check....

From: Brian Tristam Williams <[email-masked]>
Date: Mon, 23 Jul 2012 19:33:27 +0200

Not sure how this Yahoo Groups email knows what I'm replying to, but I'll
give it a bash.

Re: Interest check....

I'm going to throw my thoughts in here and suggest that maybe the PEB is a
big, unnecessary, noisy, power-guzzling behemoth that is perhaps not
necessary with today's microelectronics.

Most of what you're proposing would fit into a cartridge, but not all the
buses are available on the front port, and a PS/2 interface would be silly
there anyway. How about a board that plugs in between the console and the
speech synthesizer that does all of that for you? While you're there, you
would want to take care of the one last thing the PEB is good for: DSK1.
and DSK2. Since you want to make it easier to use, you will probably not
need the actual physical diskettes to be operable. Not a problem, since I
figure you can store over 180,000 x 90 KB diskettes on a 16 GB USB flash
drive, so if your expansion idea had a USB port with a DSR, you have made
the PEB irrelevant (unless you need RS-232...).

In any event, certainly a fun project. I sometimes fantasize about
everything you could squeeze onto a redesigned, swap-out motherboard for
the original console with today's surface-mount technology.

---

From: Marc Hull <[email-masked]>
Date: Mon, 23 Jul 2012 18:05:51 -0700 (PDT)

<I'm going to throw my thoughts in here and suggest that maybe the PEB is
 a big, unnecessary, noisy, power-guzzling behemoth that is perhaps not 
necessary with today's microelectronics.>

Probably right but it matches the TI.

USB is more than likely not an option.  It seems more difficult and CPU hungry than the PS/2 option does.  And more importantly,  if Fred can't crack that nut then I'd be a fool to think I can...

I think a PS/2 mouse interface can be done with TTL which means that there are a lot more people apt to understand, trouble shoot and repair it.   So unless someone has a sure fire method of getting USB to the TI then PS/2 is the most modern option IMO.

Surface mount is also not a viable option as far as I am concerned.  It's too difficult for these old eyes to work with and has proven less than reliable with the IDE card in some circles.  My philosophy is easy to design, easy to use and easy to repair.   Surface mount does not fit that category for most people.  A stand alone device is intriguing provided that a pass through is available to the PEB.  This means a separate PS and connectors and an enclosure of some sort.  Adds to the difficulty degree but not out of the realm.

Personally I am a PEB kind of guy.  Nothing like 50 pounds of steel humming on the desk.  Makes me feel important ;-).  

--- On Mon, 7/23/12, Brian Tristam Williams <[email-masked]> wrote:

From: Brian Tristam Williams <[email-masked]>
Subject: [TI994A] Re: Interest check....
To: [email-masked]
Date: Monday, July 23, 2012, 12:33 PM

  

      Not sure how this Yahoo Groups email knows what I'm replying to, but I'll give it a bash.

Re: Interest check....

I'm going to throw my thoughts in here and suggest that maybe the PEB is a big, unnecessary, noisy, power-guzzling behemoth that is perhaps not necessary with today's microelectronics.

Most of what you're proposing would fit into a cartridge, but not all 
the buses are available on the front port, and a PS/2 interface would be
 silly there anyway. How about a board that plugs in between the console
 and the speech synthesizer that does all of that for you? While you're 
there, you would want to take care of the one last thing the PEB is good
 for: DSK1. and DSK2. Since you want to make it easier to use, you will 
probably not need the actual physical diskettes to be operable. Not a 
problem, since I figure you can store over 180,000 x 90 KB diskettes on a
 16 GB USB flash drive, so if your expansion idea had a USB port with a 
DSR, you have made the PEB irrelevant (unless you need RS-232...).

In any event, certainly a fun project. I sometimes fantasize about everything you could squeeze onto a redesigned, swap-out motherboard for the original console with today's surface-mount technology.

---

From: Jeff White <[email-masked]>
Date: Mon, 23 Jul 2012 23:18:37 -0400

For nearly a decade, there has been the Thierry Nouspikel USB-SM card.  It has SRAM, EEPROM, and USB on it, plus a connector for SmartMedia.  I think the DSR has a rudimentary software interface to USB accessible from BASIC.  If BASIC can do it, then certainly assembly has to do it.  DSR source code is available.

Is there a standard communication protocol for a USB keyboard, mouse, or thumb drive?  Not sure.  Would be nice.  As I recall, there were 3 standard mouse communications protocols for the PC prior to USB.  

Anyone using their USB-SM card?

Jeff White

On 23 Jul 2012, at 21:05, Marc Hull <[email-masked]> wrote:

> <I'm going to throw my thoughts in here and suggest that maybe the PEB is a big, unnecessary, noisy, power-guzzling behemoth that is perhaps not necessary with today's microelectronics.>
>

---

From: "Brian Tristam Williams" <[email-masked]>
Date: Tue, 24 Jul 2012 12:20:37 -0000

Don't get me wrong - for the sake of looks, the PEB still belongs under your monitor, polished and shined. Just not sure it serves any purpose being turned on :)

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
> --- On Mon, 7/23/12, Brian Tristam Williams <briantw@...> wrote:
> 
> From: Brian Tristam Williams <briantw@...>

---

From: Marc Hull <[email-masked]>
Date: Tue, 24 Jul 2012 15:49:50 -0700 (PDT)

RS232, SCSI, IDE, RAM disks, MFM hard drives, Clock cards, SID cards, SAMS cards ?
Where would they go ?  Plus if you don't turn it on you can't watch the blinkenlights.

I am guessing you don't have/use a PEB which is cool.  But there a lot who do.

--- On Tue, 7/24/12, Brian Tristam Williams <[email-masked]> wrote:

From: Brian Tristam Williams <[email-masked]>
Subject: [TI994A] Re: Interest check....
To: [email-masked]
Date: Tuesday, July 24, 2012, 7:20 AM

  

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

> USB is more than likely not an option.Â  It seems more difficult and CPU hungry than the PS/2 option does.Â  And more importantly,Â  if Fred can't crack that nut then I'd be a fool to think I can...

> I think a PS/2 mouse interface can be done with TTL which means that there are a lot more people apt to understand, trouble shoot and repair it.Â Â  So unless someone has a sure fire method of getting USB to the TI then PS/2 is the most modern option IMO.

> Surface mount is also not a viable option as far as I am concerned.Â  It's too difficult for these old eyes to work with and has proven less than reliable with the IDE card in some circles.Â  My philosophy is easy to design, easy to use and easy to repair.Â Â  Surface mount does not fit that category for most people.Â  A stand alone device is intriguing provided that a pass through is available to the PEB.Â  This means a separate PS and connectors and an enclosure of some sort.Â  Adds to the difficulty degree but not out of the realm.

> Personally I am a PEB kind of guy.Â  Nothing like 50 pounds of steel humming on the desk.Â  Makes me feel important ;-).Â  

> Â

---

From: ti99_forever <[email-masked]>
Date: Tue, 24 Jul 2012 15:57:48 -0700 (PDT)

Maybe I'm alone in this, but sometimes I like to revisit the P(ower)-System, fire up UCSD Pascal or TI-Pilot...

Ben

>________________________________
> From: Marc Hull <[email-masked]>
>Sent: Tuesday, July 24, 2012 6:49 PM
>Subject: Re: [TI994A] Re: Interest check....
> 
>
>  
>
>
>

---

From: Tony Knerr <[email-masked]>
Date: Tue, 24 Jul 2012 20:07:56 -0400

I don't use a PEB either, both my TI and Geneve are in tower cases. ;-)

Tony

---

From: ti99_forever <[email-masked]>
Date: Tue, 24 Jul 2012 20:11:15 -0700 (PDT)

But I'd guess you are still using the backplane?

> From: Tony Knerr <[email-masked]>
>Sent: Tuesday, July 24, 2012 8:07 PM

---

From: "Tony Knerr" <[email-masked]>
Date: Wed, 25 Jul 2012 10:32:01 -0000

Well, yeah, you do have to keep that.
The cage is useful, too. :)