Subject: infocom / scott adams

From: Insane Multitasker <[email-masked]>
Date: Thu, 28 Mar 2013 10:28:53 -0500

Anyone out there have the source code to an infocom interpreter or the scott adams cartridge?

---

From: "Tursi" <[email-masked]>
Date: Thu, 28 Mar 2013 09:30:47 -0700

>Anyone out there have the source code to an infocom interpreter or the 

You can find an open source Infocom interpreter here: 
http://frotz.sourceforge.net/

I ported an older version of this ages ago to the Atari ST, it wasn't too 
hard.

---

From: Insane Multitasker <[email-masked]>
Date: Thu, 28 Mar 2013 12:14:53 -0500

Thanks Tursi.  I'm hoping someone has source to an existing TI version.  I 
have an idea that I want to pursue but do not have time to recreate the
interpreter(s)   ;)  
 
This is certainly some good reading though... thx!

> To: [email-masked]
> From: [email-masked]
> Date: Thu, 28 Mar 2013 09:30:47 -0700
> Subject: Re: [TI994A] infocom / scott adams
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: tursi <[email-masked]>
Date: Thu, 28 Mar 2013 10:47:24 -0700 (PDT)

> have an idea that I want to pursue but do not have time to recreate the

The GCC compiler works pretty well now.. you may be able to compile that 
code to the TI. It'll be much more flexible if you can, since the TI 
datafiles were not standardized to the rest of the systems.

---

From: Barry Boone <[email-masked]>
Date: Thu, 28 Mar 2013 18:55:59 +0000

The TI datafiles are interesting to say the least.  I will see if I can locate my infocom interpreter source code I used to port all of the newer games.  I'd done both 40 and 80 column versions, with variants that ran from supercart space so that the in-memory part of the game would fit, a few of the games needed more memory than was available with the interpreter in normal memory expansion, and relocating to the supercart space gave the headroom needed.

The TI datafiles were basically something like D/F 255 as I recall, and so what Infocom did was to take the 256th byte of each record and stick all of those in a record at the end of one of the files (cant remember if it was the first or second file), and as the data would get pulled in from the second file, it would fill in the 256th byte from that table stored in RAM.

The Infocom native interpreter also had several bugs that didn't show up unless you tried to use some of the newer games, there was one bug with the vocabulary search that would overflow if the table of words was larger than a certain size, and so with the newer games, some of the words would be unavailable.

The Infocom interpreter looked to me to have been cross assembled from VAX assembler.  There were a lot of unnecessary instructions, and it basically was emulating "PUSH" and "POP" type stuff.  Not surprising given how extremely similar VAX and 9900 assembler is from an architecture standpoint.

From: [email-masked] [mailto:[email-masked]] On Behalf Of tursi
Sent: Thursday, March 28, 2013 12:47 PM
To: [email-masked]
Subject: RE: [TI994A] infocom / scott adams

---

From: Barry Boone <[email-masked]>
Date: Thu, 28 Mar 2013 20:13:52 +0000

I may have located my old sources for these, I will have to check but if so I will try and find a way to make them available.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Insane Multitasker
Sent: Thursday, March 28, 2013 10:29 AM
To: [email-masked]; [email-masked]
Subject: [TI994A] infocom / scott adams

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 29 Mar 2013 00:17:29 -0500

Thank you, Barry, that would be awesome! 

To: [email-masked]
From: [email-masked]
Date: Thu, 28 Mar 2013 20:13:52 +0000
Subject: RE: [TI994A] infocom / scott adams