Subject: Back home

From: "[email-masked]" <[email-masked]>
Date: Tue, 09 Apr 2013 15:35:48 -0000

Man, it's good to be back home.  =)  Everyone well?

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 08:38:27 -0700

Reasonably well..  how you been Owen?

Greg

On Tue, Apr 9, 2013 at 8:35 AM, [email-masked] <
[email-masked]> wrote:

> **

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 08:50:10 -0700 (PDT)

Fine, fine.... Glad to be back in civilization where internet isn't a new-fangled futuristic idea to be feared.  

I've been back in atariage for over a week now, but I had to get back on the list too.  Been reading up on the back-posts.  =)

________________________________
 From: Gregory McGill <[email-masked]>
To: ti994a <[email-masked]> 
Sent: Tuesday, April 9, 2013 9:38 AM
Subject: Re: [TI994A] Back home

Greg

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 09:16:54 -0700

Very glad to see ya :) it's been too quiet without you!

Greg

On Tue, Apr 9, 2013 at 8:50 AM, Owen Brand <[email-masked]>wrote:

> **
>
>
> Fine, fine.... Glad to be back in civilization where internet isn't a
> new-fangled futuristic idea to be feared.
>
> I've been back in atariage for over a week now, but I had to get back on
> the list too.  Been reading up on the back-posts.  =)
>
>   ------------------------------
> *From:* Gregory McGill <[email-masked]>
> *To:* ti994a <[email-masked]>
> *Sent:* Tuesday, April 9, 2013 9:38 AM
> *Subject:* Re: [TI994A] Back home
>
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 09:37:46 -0700 (PDT)

Well, here's some noise...

I just rented a house and I'll have an extra room for my TI gear... I intend on setting up the most incredible TI-99 command station and dungeon the world has ever seen... I'm talkin' racks of gear floor to ceiling with filing cabinets filled with disks and docs, shelves filled with cartridges, tapes, peripherals, collectible bits...  I'm buying a big "L" desk with a second tier and I'm THIIIIIS close to getting a nice 32" flat screen for my monitor which I intend on mounting on the wall just above my desk.

I will get it set up and take photos of my triumph and post them.  =)  Exuberance overflows when I get my hardware out, man!  

Owen

Sent: Tuesday, April 9, 2013 10:16 AM

Greg

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 10:05:34 -0700

You'll need a HDX rs232 card then :)

Greg

On Tue, Apr 9, 2013 at 9:37 AM, Owen Brand <[email-masked]>wrote:

> I just rented a house and I'll have an extra room for my TI gear... I
> intend on setting up the most incredible TI-99 command station and dungeon
> the world has ever seen... I'm talkin' racks of gear floor to ceiling with
> filing cabinets filled with disks and docs, shelves filled with cartridges,
> tapes, peripherals, collectible bits...  I'm buying a big "L" desk with a
> second tier and I'm THIIIIIS close to getting a nice 32" flat screen for my
> monitor which I intend on mounting on the wall just above my desk.
>
> I will get it set up and take photos of my triumph and post them.  =)
>  Exuberance overflows when I get my hardware out, man!
>
> Owen
>
> *Sent:* Tuesday, April 9, 2013 10:16 AM
>

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 10:07:17 -0700

Here's my "command center"  to hold you over till your get yours done :)
https://sphotos-a.xx.fbcdn.net/hphotos-ash3/598707_10151819200115144_2016889359_n.jpg

Greg

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 10:14:07 -0700 (PDT)

That looks great man!  I used to have a nice command center... (See the TI-PC transfer videos on youtube) but alas.... since then, there hasn't been an opportunity to build the NORAD of TI gear... until now.

I've heard about the HDX project but not 100% sure what it is... And from what I understand, the ordering process is closed?

You'll have to enlighten me... or give me a link to read.

Sent: Tuesday, April 9, 2013 11:07 AM

Greg

On Tue, Apr 9, 2013 at 10:05 AM, Gregory McGill <[email-masked]> wrote:

>
>
>Greg
>
>
>
>On Tue, Apr 9, 2013 at 9:37 AM, Owen Brand <[email-masked]> wrote:
>
> 
>>

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 10:35:17 -0700

HDX is a serial "network like" connection for a pc to the 99/4a or Geneve.

http://home.vodafonethuis.nl//fgkaal/Software/sw_ti99hdx.html#ti99hdx
software
http://home.vodafonethuis.nl//fgkaal/Hardware/hw_ti99hdx.html#ti99hdx hardware

you can use the software with a stock TI and a serial cable and special hdx
disk manager CFHDX1 to access the files on the pc server OR build a HDX
RS232 mod to a TI card and use HDX1. device in any software that doesn't do
direct access routines to the disk.

I'll have a PCB here in 2 weeks or can build a RS232 card for you if you
are not a solderer :)
Greg

On Tue, Apr 9, 2013 at 10:14 AM, Owen Brand <[email-masked]>wrote:

> **
>
>
> That looks great man!  I used to have a nice command center... (See the
> TI-PC transfer videos on youtube) but alas.... since then, there hasn't
> been an opportunity to build the NORAD of TI gear... until now.
>
> I've heard about the HDX project but not 100% sure what it is... And from
> what I understand, the ordering process is closed?
>
> *Sent:* Tuesday, April 9, 2013 11:07 AM
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 10:57:53 -0700 (PDT)

Very cool stuff.  I AM looking for a more reliable way to transfer files from PC-TI, I assume this would qualify...

Really I need to be able to transfer stuff to my TI without the use of my CF7 because in many cases I will need the files to be on diskette for use of P-Box peripherals (like the SID card).  I don't have any way to write to a diskette directly from my PC, so I'm limited to MFM on the TI side and I'll need to get another PC to run XP if I want to use the file-transfer method I used for those videos.  Right now all I have is my Win7 PC.  

I assume this hardware/software combo gives a much more efficient (or maybe efficient is the wrong word... maybe "simple and reliable") method of transferring files to and from TI?

Owen

Sent: Tuesday, April 9, 2013 11:35 AM

http://home.vodafonethuis.nl//fgkaal/Software/sw_ti99hdx.html#ti99hdx   software

you can use the software with a stock TI and a serial cable and special hdx disk manager CFHDX1 to access the files on the pc server OR build a HDX RS232 mod to a TI card and use HDX1. device in any software that doesn't do direct access routines to the disk.

I'll have a PCB here in 2 weeks or can build a RS232 card for you if you are not a solderer :)  
Greg

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 12:00:51 -0700

Yes it is. I can just move files into a directory on the pc with tidir and
open them on the 4/a or Geneve, I have cards in both) the HDX software
should work with win7 if you have a good enough rs232 port. (hardware works
better than usb, ymmv)

The hw/sw gives you direct access from anything, dm2k, basic, ea etc.. I go
into ea and hit 5, then HDX1.EAGAMES,#PITFALL  and pitfall loads..  you can
also use the hw/sw set up to print to HDX1.PRINTER

On Tue, Apr 9, 2013 at 10:57 AM, Owen Brand <[email-masked]>wrote:

> **
>
>
> Very cool stuff.  I AM looking for a more reliable way to transfer files
> from PC-TI, I assume this would qualify...
>
> Really I need to be able to transfer stuff to my TI without the use of my
> CF7 because in many cases I will need the files to be on diskette for use
> of P-Box peripherals (like the SID card).  I don't have any way to write to
> a diskette directly from my PC, so I'm limited to MFM on the TI side and
> I'll need to get another PC to run XP if I want to use the file-transfer
> method I used for those videos.  Right now all I have is my Win7 PC.
>
> I assume this hardware/software combo gives a much more efficient (or
> maybe efficient is the wrong word... maybe "simple and reliable") method of
> transferring files to and from TI?
>
> Owen
>
> *Sent:* Tuesday, April 9, 2013 11:35 AM
>
> you can use the software with a stock TI and a serial cable and special
> hdx disk manager CFHDX1 to access the files on the pc server OR build a HDX

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 12:01:37 -0700

oops hit the wrong key and sent..  HDX1.PRINTER which prints to tiprint on
the pcside without having to turn off HDX.
http://home.vodafonethuis.nl//fgkaal/Software/sw_ti99print.html#ti99print
tiprint software

Greg

On Tue, Apr 9, 2013 at 12:00 PM, Gregory McGill <[email-masked]>wrote:

> The hw/sw gives you direct access from anything, dm2k, basic, ea etc.. I
> go into ea and hit 5, then HDX1.EAGAMES,#PITFALL  and pitfall loads..  you
> can also use the hw/sw set up to print to HDX1.PRINTER
>
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 12:10:38 -0700 (PDT)

Wow... that's pretty awesome.  

How does one come across one of these and what would it cost?

Owen

Sent: Tuesday, April 9, 2013 1:01 PM

oops hit the wrong key and sent..  HDX1.PRINTER which prints to tiprint on the pcside without having to turn off HDX. 
http://home.vodafonethuis.nl//fgkaal/Software/sw_ti99print.html#ti99print  tiprint software

Greg

On Tue, Apr 9, 2013 at 12:00 PM, Gregory McGill <[email-masked]> wrote:

Yes it is. I can just move files into a directory on the pc with tidir and open them on the 4/a or Geneve, I have cards in both) the HDX software should work with win7 if you have a good enough rs232 port. (hardware works better than usb, ymmv)  
>
>
>The hw/sw gives you direct access from anything, dm2k, basic, ea etc.. I go into ea and hit 5, then HDX1.EAGAMES,#PITFALL  and pitfall loads..  you can also use the hw/sw set up to print to HDX1.PRINTER
>
>
>
>On Tue, Apr 9, 2013 at 10:57 AM, Owen Brand <[email-masked]> wrote:
>
> 
>>

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 15:40:38 -0700

I am making pcboards they should be here in 2 weeks or so..  also will be
selling some pre-modded rs232 cards here soon as i get stock in and build
them.
Price for the pcb's are 5$ea + 5$ shipping if you want to source parts and
solder yourself..

Greg

On Tue, Apr 9, 2013 at 12:10 PM, Owen Brand <[email-masked]>wrote:

> *Sent:* Tuesday, April 9, 2013 1:01 PM
>

---

From: Tony Knerr <[email-masked]>
Date: Tue, 09 Apr 2013 18:41:02 -0400

Welcome back, Owen!

Attached is a photo of my TI/ Geneve setup in the ManCave.
Bad camera phone, but it's clear enough to make out the basic stuff.
Snug TI on left, Geneve on right. Both are in tower cases, both have SCSI
cards with CF cards used as the hard drive. Both use Samsung 910mp
monitors. TI is connected to Casio keyboard mounted on wall above for
Midi Master music.

Fun place to hang out. :)

Tony

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 15:41:36 -0700

holy crap that's blurry! :)

G

On Tue, Apr 9, 2013 at 3:41 PM, Tony Knerr <[email-masked]> wrote:

> **
>
>  [Attachment(s) <#13df0f5b58763881_TopText> from Tony Knerr included
> below]
>
> Welcome back, Owen!
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 15:55:47 -0700 (PDT)

Tony... COOL PIC, and thanks for the welcome back... I felt like a fish out of water being away for so long.  =)

Owen

Sent: Tuesday, April 9, 2013 4:41 PM

G

On Tue, Apr 9, 2013 at 3:41 PM, Tony Knerr <[email-masked]> wrote:

>  
>[Attachment(s) from Tony Knerr included below] 
>Welcome back, Owen!
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 15:56:39 -0700 (PDT)

pre-modded rs232s?  =)  

Would the price decrease any for one of those if I sent YOU and unmodded one?

Sent: Tuesday, April 9, 2013 4:40 PM

I am making pcboards they should be here in 2 weeks or so..  also will be selling some pre-modded rs232 cards here soon as i get stock in and build them.
Price for the pcb's are 5$ea + 5$ shipping if you want to source parts and solder yourself.. 

Greg

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 16:01:27 -0700

Sure.. has to be a TI card.. email me off list :)
Greg

On Tue, Apr 9, 2013 at 3:56 PM, Owen Brand <[email-masked]>wrote:

> *Sent:* Tuesday, April 9, 2013 4:40 PM
>

---

From: Tony Knerr <[email-masked]>
Date: Tue, 09 Apr 2013 19:17:12 -0400

OK, I enlisted my son with his REAL camera-phone to take a pic.

Can you see me now, Batman? :)

T

---

From: Gregory McGill <[email-masked]>
Date: Tue, 9 Apr 2013 16:19:12 -0700

much better! very nice set up

Greg

On Tue, Apr 9, 2013 at 4:17 PM, Tony Knerr <[email-masked]> wrote:

> **
>
>  [Attachment(s) <#13df116e27147c04_TopText> from Tony Knerr included
> below]
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 16:21:44 -0700 (PDT)

now THATS a great pic!

________________________________
 From: Tony Knerr <[email-masked]>
To: [email-masked] 
Sent: Tuesday, April 9, 2013 5:17 PM
Subject: Re: [TI994A] Back home [1 Attachment]

T

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 9 Apr 2013 19:59:56 -0500

So I just have to ask..... do you program sitting or standing up? 
 
:)-

To: [email-masked]
From: [email-masked]
Date: Tue, 9 Apr 2013 19:17:12 -0400
Subject: Re: [TI994A] Back home [1 Attachment]

T

G

Attachment(s) from Tony Knerr 
1 of 1 Photo(s) 

TonyKtigeneve.jpg

---

From: Tony Knerr <[email-masked]>
Date: Tue, 09 Apr 2013 21:08:16 -0400

I moved the chairs so you could actually see everything. 8-)
I only stand when I'm plagiarizing your code. :-P

On 4/9/2013 8:59 PM, Insane Multitasker wrote:
> ------------------------------------------------------------------------
>

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 20:51:56 -0700 (PDT)

Shared this with Atariage, wanted to share it with the lists.

*************************************************************************

So as I stated before, I was able to get into my grandmother's basement and recover a good portion of the TI gear my father left there 20 years ago.  I found some REALLY interesting stuff that I'd like to share.

I found a VERY neat collection of previously-undiscovered programs and audio stuff.  (At least I'm almost positive they've never seen the light of day)  It's all proprietary TRONICS stuff that I've never seen before.  

http://i830.photobucket.com/albums/zz222/Opry99er/IMG_20130409_211400_zps00f98ff3.jpg

As you can see, it's all cassette tape software and it's all branded TRONICS with different sets of programs and instructional audio stuff which is all in mint condition and 2 of the tapes are still sealed in cellophane.  

http://i830.photobucket.com/albums/zz222/Opry99er/IMG_20130409_211417_zpsa0ece432.jpg

Some of these tapes are audio tapes that were given out to TRONICS staff (and my dad was a TRONICS warehouse manager) about the TI, accessories, peripherals, software, hardware, etc... Some of the tapes contain programs and "learn how to code" stuff.  

It's probably not that cool to those just interested in games and such, but it's a very neat piece of history which I intend on sharing with the community.  When I get set up, I'll transfer all the programs from tape to DSK and then upload them onto the various sites... probably see that the CTIUG gets hard copies of everything too.

Anyway, just thought i'd share.  =)

Owen Brand

---

From: Jeff White <[email-masked]>
Date: Wed, 10 Apr 2013 00:44:45 -0400

On 09 Apr 2013, at 23:51, Owen Brand <[email-masked]> wrote:
 <snip>
> It's probably not that cool to those just interested in games and such, but it's a very neat piece of history which I intend on sharing with the community.  When I get set up, I'll transfer all the programs from tape to DSK and then upload them onto the various sites... probably see that the CTIUG gets hard copies of everything too.,

Owen, if you have not used your TI cassette player recently, I suggest trying it out with a cassette that you do not care to lose rather than something rare.  I have had old cassette players unwind and rip tapes, and I am not so fond of splicing.

So where is civilization now?  I thought you were on a band tour.

Jeff White

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 21:50:32 -0700 (PDT)

Good suggestion Jeff...

I've lived on a crazy farm in the dead center of Tennessee for the past couple years.  Literally "off the map" and "off the grid".  We had no internet, no tv, rare cell service... It was absolutely insane!  =)  Loved it for what it was, but it was insane.

I don't play on the road anymore.  Having my son close to me and in a stable environment is worth more than any tour or playing circuit.  He's learning to play baseball now and I've got him playing a few TI games in emulation.  I also have a little girl on the way... Just a couple more months now.  =)  Ive found that as I've gotten "less young".............  that family is the most important thing on this planet and if something gets in the way, it needs to be eliminated.  

Now I live in Denver with my wife, son, and little girl on the way... We're saving to buy a farm of our own.  =)  Hopefully with internet, though

Owen

________________________________
 From: Jeff White <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Tuesday, April 9, 2013 10:44 PM
Subject: Re: [TI994A] Very Cool Discovery

  

Jeff White

---

From: Jeff White <[email-masked]>
Date: Wed, 10 Apr 2013 00:54:40 -0400

Tony,

I do not see you.

Are you using the new wireless MIDI interface with the your systems?

Jeff White

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 21:59:33 -0700 (PDT)

I know this isn't a mercantile list or a marketplace, but I AM looking for a few items and if anyone has any of these items, I'd be willing to trade for them.

1) Strike Three! (original cartridge)
2) Red Baron Flight Simulator (original cartridge)
3) An rs232 1/2 splitter cable (to be able to use the new HDX interface)
4) Tickets to the Colorado Rockies game on Sunday

=)

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 22:10:18 -0700 (PDT)

My old setup... I miss it.  But my NEXT one will be MUUUUUCH better.  =)

http://www.youtube.com/watch?v=J3jqQgun3wI

Sent: Tuesday, April 9, 2013 7:08 PM

---

From: Owen Brand <[email-masked]>
Date: Tue, 9 Apr 2013 23:46:02 -0700 (PDT)

Quick question, and it might be pretty elementary, but I'm still catching up...

In the current program I am writing, I have 11,840 bytes of STACK free and 19,777 bytes of PROGRAM space free BEFORE I run the program.

After I run the program, the SIZE command registers 11,182 bytes of STACK free and 19,609 bytes of PROGRAM space free.

The XB manual says the following about the SIZE command:

The SIZE command displays the number of
unused bytes of memory left in the computer. If the Memory Expansion peripheral
is attached, the number of bytes available is given as the amount of stack free
and the amount of program space free. A byte is the memory space required for
such things as one character or digit, or one TI Extended BASIC keyword.
 
If the Memory Expansion is not attached,
the space available is the amount of space left after the space taken up by the
program, screen, character pattern definitions, sprite tables, color tables,
string values, and the like is subtracted.
 
If the Memory Expansion is attached, the
space available in the stack is the amount of space left after the space taken
up by string values, information about variables, and the like is subtracted.
Program space is the amount of space left after the space taken up by the
program and the values of numeric variables is subtracted.

This makes sense, except I'm not sure about one thing... Which number am I looking at for how much space I have left for my program?

Could someone let me know PRECISELY what the difference is here and how to determine what kind of space I have left?  When I call SIZE with no program loaded, the STACK also registers as 11,840 but PROGRAM is 24,488.  Does this mean that I've used 4,711 bytes out of 24,488 available bytes?  Is the post-run number the important one or is it the pre-run number?

Again, sorry if this is basic entry-level stuff.  =)

Owen

---

From: Tony Knerr <[email-masked]>
Date: Wed, 10 Apr 2013 05:41:00 -0400

Wires are behind wall. :-)

---

From: [email-masked]
Date: Wed, 10 Apr 2013 15:57:28 -0000

Owen...
Bruce Harrison did a pretty good job of explaining the situation in his Micropendium (July, 1995, p. 8) article, "Stacking it up".  A bit of a summary follows.

The XB SIZE command reports the free space in VDP RAM as free STACK space and the free space in high memory expansion CPU RAM as free PROGRAM space.  The STACK is used for variable names, look-up tables, string storage (assigned and temporary), a value stack (used in unrolling parenthetical math expressions, among other things) and probably more.  Re-assigning the contents of a string variable will leave holes in the stack that XB will periodically close up when it does a garbage collection.  It always does garbage collection just before it returns the results of the SIZE command, so you won't get a true picture of the running program's stack use.

In addition to tokenized program storage, the PROGRAM space is used to store variable values as 8-byte, radix-100 floating point values and probably other stuff.

...lee

---

From: [email-masked]
Date: Wed, 10 Apr 2013 22:57:46 +0000 (UTC)

Well this is the RXB source code for Size but it also does size for Assembly, AMS and regular XB size too. 

<0297> * RXB SIZE PATCH CODE ******** 
<0298> * SZSIZE CZ V@CRNBUF+1 Must have EOL 
<0299> 65C9 05,69,AA SZSIZE B NSIZE 
<0300> 65CC 49,7C BR ERRSYN 
<0301> 65CE 0F,70 G65CE XML COMPCT Garbage collect to free space 
<0302> 65D0 BD,5E,1A DST @STREND,@ARG2 Get end of string space 
<0303> 65D3 A5,5E,6E DSUB @VSPTR,@ARG2 Subtract stack pointer 
<0304> 65D6 A7,5E,00 DSUB 63,@ARG2 Require 64-byte buffer 
65D9 3F 
<0305> 65DA 0A GT If less then 64 bytes left 
<0306> 65DB 65,DF BS G65DF 
<0307> 65DD 87,5E DCLR @ARG2 Then indicate zero 
<0308> 65DF 0F,83 G65DF XML SCROLL Scroll the screen 
<0309> 65E1 BF,20,02 DST NLNADD+2,@VARW Begin a new line 
65E4 E4 
<0310> 65E5 06,6F,BA CALL DISO Display the number 
<0311> 65E8 8E,80,84 CZ @RAMTOP If no ERAM present 
<0312> 65EB 45,F7 BR G65F7 
<0313> 65ED 31,00,0A MOVE 10,G@MSGFRE,V@1(@VARW) 
65F0 E0,01,20 
65F3 62,D3 
<0314> 65F5 46,21 BR G6621 
<0315> 65F7 31,00,13 G65F7 MOVE 19,G@MSGSFR,V@1(@VARW) 
65FA E0,01,20 
65FD 62,DD 
<0316> 65FF 0F,83 XML SCROLL Scroll the screen 
<0317> 6601 BF,20,02 DST NLNADD+2,@VARW Beginning of line 
6604 E4 
<0318> 6605 BD,5E,80 DST @RAMFRE,@ARG2 Calculate space in ERAM 
6608 86 
<0319> 6609 A7,5E,A0 DSUB CPUBAS-1,@ARG2 Subtract base 
660C 3F 
<0320> 660D 06,6F,BA CALL DISO Display the number 
<0321> 6610 31,00,10 MOVE 16,G@MSGGFR,V@1(@VARW) 
6613 E0,01,20 
6616 62,F0 
<0322> * RXB SIZE PATCH CODE ******** 
<0323> 6618 0F,83 G6618 XML SCROLL 
<0324> 661A 31,00,0A MOVE 10,G@MSGGF1,V@NLNADD+4 
661D A2,E6,63 
6620 00 
<0325> 6621 0F,83 G6621 XML SCROLL Scroll the screen 
<0326> * RXB SIZE PATCH CODE ******** 
<0327> * BR TOPL15 Return to top-level 
<0328> 6623 00 G6623 RTN 
<0329> 6624 00 RTN RXB wasted byte. 

<0003> 69AA 8E,44 NSIZE CZ @PRGFLG * PROGRAM MODE? 
<0004> 69AC 49,B8 BR CSIZE 
<0005> 69AE 8E,A8,21 CZ V@CRNBUF+1 * NORMAL 
<0006> 69B1 51,4B BR ERROLP 
<0007> 69B3 06,69,C1 CALL SIZEAS 
<0008> 69B6 43,DD BR TOPL15 
<0009> 69B8 06,71,5A CSIZE CALL CHKEND * CALL SIZE 
<0010> 69BB 06,69,C1 CALL SIZEAS 
<0011> 69BE 06,00,12 CALL RETURN 
<0012> 69C1 06,65,CE SIZEAS CALL G65CE 
<0013> 69C4 8E,80,84 CZ @RAMTOP 
<0014> 69C7 7E,93 BS AMSSIZ 
<0015> 69C9 35,00,06 MOVE 6,@>2002,@FAC 
69CC 4A,8F,9D 
69CF 02 
<0016> 69D0 D7,4E,AA DCEQ >AA55,@FAC+4 
69D3 55 
<0017> 69D4 5E,93 BR AMSSIZ 
<0018> 69D6 BD,5E,4C DST @FAC+2,@ARG2 
<0019> 69D9 A5,5E,4A DSUB @FAC,@ARG2 
<0020> 69DC 06,69,31 CALL SDISO 
<0021> 69DF 31,00,11 MOVE 17,G@MESSAG,V@1(@VARW) 
69E2 E0,01,20 
69E5 7E,6A 
<0022> 69E7 06,66,18 CALL G6618 
<0023> 69EA 05,7E,93 B AMSSIZ 

<0324> * AMS SIZE 
<0325> 7E93 87,4A AMSSIZ DCLR @FAC * ISR ADDRESS BUFFER 
<0326> 7E95 06,D0,FE CALL ISROFF 
<0327> 7E98 06,D0,F4 CALL AMSMAP 
<0328> 7E9B 06,D0,FA CALL AMSON 
<0329> 7E9E BC,50,8F ST @>401C,@FAC6 * Page >E000 map 
7EA1 BD,1C 
<0330> 7EA3 BC,51,8F ST @>401E,@FAC7 * Page >F000 map 
7EA6 BD,1E 
<0331> 7EA8 D6,8F,BD CEQ >0F,@>401E * Initialized 
7EAB 1E,0F 
<0332> 7EAD 5F,05 BR NOAMS * Not Initalized, end SIZE. 
<0333> 7EAF BF,52,00 DST 31,@FAC8 * PAGE# 
7EB2 1F 
<0334> 7EB3 BC,8F,BD NXTPG ST @FAC9,@>401C * Set PAGE >E000 
7EB6 1C,53 
<0335> 7EB8 BC,8F,BD ST @FAC9,@>401E * Set PAGE >F000 
7EBB 1E,53 
<0336> 7EBD BD,54,8F DST @>E000,@FAC10 * Save word at >E000 
7EC0 5D,00 
<0337> 7EC2 BD,56,8F DST @>F000,@FAC12 * Save word at >F000 
7EC5 6D,00 
<0338> 7EC7 BF,8F,6D DST >AAAA,@>F000 * Test word 
7ECA 00,AA,AA 
<0339> 7ECD D5,8F,6D DCEQ @>E000,@>F000 * Test words? 
7ED0 00,8F,5D 
7ED3 00 
<0340> 7ED4 5F,05 BR NOAMS * Not a match 
<0341> 7ED6 BD,8F,5D DST @FAC10,@>E000 * Restore word 

99/4 GPL-ASSEMBLER (Pass 3) correct PAGE 0072 
EDIT-359 
7ED9 00,54 
<0342> 7EDB BD,8F,6D DST @FAC12,@>F000 * Restore word 
7EDE 00,56 
<0343> 7EE0 91,52 DINC @FAC8 * PAGE+1 
<0344> 7EE2 D7,52,01 DCEQ 256,@FAC8 * Largest PAGE # 
7EE5 00 
<0345> 7EE6 7E,F1 BS SHOWIT * Just show it 
<0346> 7EE8 E3,52,00 DSLL 1,@FAC8 * PAGE*2 
7EEB 01 
<0347> 7EEC 93,52 DDEC @FAC8 * PAGE-1 
<0348> 7EEE 05,7E,B3 B NXTPG * Continue loop 
<0349> 7EF1 BD,8F,5D SHOWIT DST @FAC10,@>E000 * Restore word 
7EF4 00,54 
<0350> 7EF6 BD,8F,6D DST @FAC12,@>F000 * Restore word 
7EF9 00,56 
<0351> 7EFB BC,8F,BD ST @FAC6,@>401C * Restore PAGE 
7EFE 1C,50 
<0352> 7F00 BC,8F,BD ST @FAC7,@>401E * Restore PAGE 
7F03 1E,51 
<0353> 7F05 8F,4A NOAMS DCZ @FAC * ISR? 
<0354> 7F07 7F,0C BS NOISR * No 
<0355> 7F09 06,D0,FC CALL ISRON * Turn on ISR HOOK 
<0356> 7F0C D6,8F,BD NOISR CEQ >0F,@>401E * AMS MAP? 
7F0F 1E,0F 
<0357> 7F11 5F,39 BR NOAMS2 * no 
<0358> 7F13 BD,5E,52 DST @FAC8,@ARG2 * Show PAGES 
<0359> 7F16 A7,5E,00 DSUB 16,@ARG2 * PAGE-16 
7F19 10 
<0360> 7F1A 06,69,31 CALL SDISO * Show it 
<0361> 7F1D 31,00,12 MOVE 18,G@AMSP,V@1(@VARW) 
7F20 E0,01,20 
7F23 7E,81 
<0362> 7F25 0F,83 XML SCROLL * Scroll up a line 
<0363> 7F27 E3,52,00 DSLL 2,@FAC8 * PAGE*4=K 
7F2A 02 
<0364> 7F2B BD,5E,52 DST @FAC8,@ARG2 * SHOW K 
<0365> 7F2E 06,69,31 CALL SDISO * Show it 
<0366> 7F31 31,00,06 MOVE 6,G@AMSK,V@1(@VARW) 
7F34 E0,01,20 
7F37 7E,7B 
<0367> 7F39 46,21 NOAMS2 BR G6621 * Done 
<0368> *********************************************************** 
<0369> END 

Rich ----- Original Message -----
From: [email-masked] 
To: [email-masked] 
Sent: Wednesday, April 10, 2013 8:57:28 AM 
Subject: [TI994A] Re: PROGRAM and STACK FREE 

Owen... 

...lee

---

From: Owen Brand <[email-masked]>
Date: Wed, 10 Apr 2013 19:36:11 -0700 (PDT)

So if I didn't have any 32k hooked up, STACK would be pretty much it as far as space available for code... (I'm guessing)

@Rich,
       Your post was impressive, but I had absolutely NO idea what any of that meant.  =)  

Maybe one day.....

Owen

________________________________
 From: "[email-masked]" <[email-masked]>
To: [email-masked] 
Sent: Wednesday, April 10, 2013 9:57 AM
Subject: [TI994A] Re: PROGRAM and STACK FREE

Owen...

...lee