Subject: Tmr Control Source Commenting

From: "epergrem" <[email-masked]>
Date: Tue, 17 Jan 2012 14:09:23 -0000

I have uploaded a copy of tmr-control-source.txt to the files section.  I'm attempting to comment it, but there are some things (obviously!) that I don't quite understand.

In three instances; >5FF3 is being written to.  Two of these are during CRU access.  >5FF3 is in the DSR and I didn't think that you could write to the DSR.  Another possibility is that the write is just being used to set the status byte.  In any event, if someone could clarify this I would appreciate it. 

Thanks,
Ernie

---

From: "Michael Zapf" <[email-masked]>
Date: Tue, 17 Jan 2012 14:36:08 -0000

If you have board schematics it would be easier to determine the function.

> In three instances; >5FF3 is being written to.  Two of these are 
> during CRU access.  >5FF3 is in the DSR and I didn't think that you 
> could write to the DSR. 

you mean "in the area used for the DSR". Disk controllers, for example, usually have an address decoder that looks for a pattern like 5FFx on the address bus, and if that appears, they route the bytes to the controller chip. 

Michael

---

From: "epergrem" <[email-masked]>
Date: Tue, 17 Jan 2012 15:56:31 -0000

Hi Michael,
Sorry, no schematics, or documentation.  I did just upload a fairly large photograph of the card.  It should be possible to see what chips are being used.

Is the address a physical IC, or in the PAL? 

Thanks,
Ernie

---

From: Marc Hull <[email-masked]>
Date: Tue, 17 Jan 2012 13:29:26 -0800 (PST)

The address >5FF3 may not be decoded (on the card) as DSR roms space.  It could be a register or something else.   Must be internal on the bus though as there doesn't seem to be any connectors anywhere.

Quirky question.....

Have you plugged this thing into your PEB ??  Awwww come Ernie.  I triple dog dare ya ;-).

--- On Tue, 1/17/12, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] Tmr Control Source Commenting
To: [email-masked]
Date: Tuesday, January 17, 2012, 8:09 AM

  

Thanks,

Ernie

---

From: "epergrem" <[email-masked]>
Date: Tue, 17 Jan 2012 22:19:29 -0000

Hi Marc,
Yep!  It's been plugged it.  All I get is a blinking message that says "Simulator Error".  Still, it was kind of cool. 

> Have you plugged this thing into your PEB ??  Awwww come Ernie.  I triple dog dare ya ;-).
\

---

From: "Michael Zapf" <[email-masked]>
Date: Tue, 17 Jan 2012 23:30:35 -0000

Hi Ernie,

the PAL is commonly used for address decoding; if it is a registered PAL (containing stateful registers inside) it is very difficult to determine its programming, but this one is not registered, as it seems (can see that by its name). That is, one can find out what it does by trying all input combinations and checking the outputs. 

Apart from that, we have some driver chips, flip-flop, latches, and logic chips (AND etc.). So what is the purpose of this whole card? I browsed over the chips in the picture, but I just can't figure out. 

MIchael

---

From: Tony Knerr <[email-masked]>
Date: Tue, 17 Jan 2012 19:51:14 -0500

Something to do with a timer emulator?

http://www.automation.siemens.com/WW/forum/guests/PostShow.aspx?PageIndex=1&PostID=64712&Language=en

Just shooting in the dark, here.

Tony

On 1/17/2012 6:30 PM, Michael Zapf wrote:
>
> Hi Ernie,
>
> the PAL is commonly used for address decoding; if it is a registered 
> PAL (containing stateful registers inside) it is very difficult to 
> determine its programming, but this one is not registered, as it seems 
> (can see that by its name). That is, one can find out what it does by 
> trying all input combinations and checking the outputs.
>
> Apart from that, we have some driver chips, flip-flop, latches, and 
> logic chips (AND etc.). So what is the purpose of this whole card? I 
> browsed over the chips in the picture, but I just can't figure out.
>
> MIchael
>
>

---

From: Tony Knerr <[email-masked]>
Date: Tue, 17 Jan 2012 19:53:02 -0500

Maybe related to this?

http://www.unitedti.org/forum/index.php?showtopic=7437

Still shooting...

Tony

---

From: Jeff White <[email-masked]>
Date: Tue, 17 Jan 2012 20:44:40 -0500

In looking at the card and DSR, there is not much to it.

What it seems to me is a means to test the Myarc personality card.  For what purpose would require more review.

It seems to load routines in high memory, then cycles through the other DSR's but skipping itself. 

This was what I got from a 2 minute review of the source code.  Could be wrong.

Jeff White

---

From: "epergrem" <[email-masked]>
Date: Fri, 20 Jan 2012 00:12:56 -0000

Some of the code access GROM at >9800.  I assume this is the cartridge.  I would like to understand this a bit more. 

Can anyone suggest a good reference source where I can learn about reading/writing to GROM/GRAM?  The E/A manual have a very small example, but no real explanations.

Thanks,
Ernie

---

From: tursi <[email-masked]>
Date: Thu, 19 Jan 2012 16:17:44 -0800 (PST)

Thierry's page has a very comprehensive description that includes hardware 
and software theory:

http://nouspikel.group.shef.ac.uk//ti99/groms.htm

---

From: [email-masked]
Date: Fri, 20 Jan 2012 07:35:41 +0000 (UTC)

Here you go and all my HOW2GPL videos also: 

http://www.atariage.com/forums/topic/153704-ti-994a-development-resources/ 

Good Luck  

Rich 

----- Original Message -----
From: "epergrem" <[email-masked]> 
To: [email-masked] 
Sent: Thursday, January 19, 2012 4:12:56 PM 
Subject: [TI994A] Re: Tmr Control Source Commenting 

Thanks, 
Ernie

---

From: "epergrem" <[email-masked]>
Date: Fri, 20 Jan 2012 12:01:51 -0000

Thanks Rich..

> Good LuckÂ