Subject: DSRLNK redux....

From: "Marc H" <[email-masked]>
Date: Sun, 14 Oct 2012 18:46:26 -0000

Please bear with me ;-)....

I am really a bit frustrated here by my lack of understanding as to this whole DSRLNK concept.  I will list what I assume that DSRLNK does (which is obviously not correct) and hope for some guidance.

As far as I understand.....

DSRLNK is only a subroutine that searches the PEB cards (or other off board devices) via CRU for a name that matches a user supplied device name.

Once it finds that name then it executes a BL to the correct address.

All info that the DSR itself needs is encoded into the PAB

When the DSR is completed it passes control back to DSRLNK and other than it's specific function only changes the status byte in the PAB.

What I am not specifically doing is....

Setting up any values in scratchpad other than the name length pointer.

I know my concept must be incomplete.  Anyone know what I am leaving out ?

---

From: ti99_forever <[email-masked]>
Date: Sun, 14 Oct 2012 14:11:08 -0700 (PDT)

PABs go in the VDP RAM... if you are looking for compatibility. Even the silly CALL subprograms, like CALL FILES...

>________________________________
> From: Marc H <[email-masked]>
>To: [email-masked] 
>Sent: Sunday, October 14, 2012 2:46 PM
>Subject: [TI994A] DSRLNK redux....
> 
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>