Subject: New version of Dm2k and Cf2k

From: "fredkaal" <[email-masked]>
Date: Thu, 11 Oct 2012 17:17:23 -0000

Hi all,

A new version of Dm2k (v2.5) and Cf2k (v2.1) is available here:

http://members.ziggo.nl/fredgkaal/index.html

I recently installed M. Haggerty's F18A board (see hardware section on the same website) and was fooling around with TurboForth and the 80 column editor which gave me the idea to add an 80 column mode of view file to the above programs. I had to change the function keys a bit:

View file as text: T in 40 column mode ctrl-T in 80 column mode
View file in hex: B in 40 column mode ctrl-B in 80 column mode

I tried both files on my real TI99/4A console and both programs seem to function properly. Had some problems with these programs running in my emulator Ti994w though and I don't know why. I keep getting some crashes when reading files in 80 column mode (???) but not always, So ... better save than sorry: Keep a copy of the previous version of both programs. I have some more experimenting to do.

Fred ;-)

---

From: "fredkaal" <[email-masked]>
Date: Tue, 16 Oct 2012 07:20:49 -0000

The problems I found has nothing to do with both programs or my Emulator. The problems occur when using the Ti994W emulator with 9938 VDP and a CF7A+ emulation with a compactflash image or TI-diskcontroller emulation with a floppy image. The diskbuffers used by both DSR ends at the 16K boundary of the VDP ram. Reading or writing the last byte of this 16K block results in a page register increment on the 9938 VDP and no problems occur when using the TMS9918 VDP. Now I found this I slightly remember a story I read about moving the diskbuffers two bytes down when using a 9938 VDP because of this problem.

---

From: ti99_forever <[email-masked]>
Date: Tue, 16 Oct 2012 03:46:58 -0700 (PDT)

Yes, this is what the Mechatronics 80-column card did. You had two bytes less "stack space" from a SIZE command in XB.

>________________________________
> From: fredkaal <[email-masked]>
>To: [email-masked] 
>Sent: Tuesday, October 16, 2012 3:20 AM
>Subject: [TI994A] Re: New version of Dm2k and Cf2k
> 
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>