Subject: Re: [TI994A] Re: Thoughts?

From: Owen Brand <[email-masked]>
Date: Fri, 07 Jun 2013 08:55:20 -0600

Okay...  What about using my PC as a hard drive?  The HDX interface opens up some cool possibilities...  Would it work?  Obviously quite a bit of file path modification would have to take place, but it seems like a viable option on the surface...  rs232/1 would be the BBS port, rs232/2 is the HDX interface...

Owen Brand
Opry99er

epergrem <[email-masked]> wrote:

>Owen,
>I don't have a nanoPEB, but having ran S&T it occurs to me that without a hard drive, RAM disk, etc. you might be better off with something like Smalltalk. 
>
>No where near as feature rich as S&T, but requires a very little footprint and is happy to run off of nanoPEBs three floppy drives.
>
>Ernie
>
>--- In [email-masked], Owen Brand <owen.brand@...> wrote:
>>
>> S&T software running on a stock console, facilitating a BBS through a nanoPEB.....
>> 
>> Possible?  Worth a try?  :)
>> 
>> I have a CF7 which I love, but I have been thinking alot lately about the possibilities of the nanoPEB's serial port....  I never use the parallel port on my CF7 for anything, so why not get a nanoPEB and do something with the serial port?  Best thing I could think to do is create a BBS and host it without a regular PEB.  What you guys think? 
>> 
>>  Tim?  You'd know better than anyone... It's your software.  :)
>> 
>> 
>> 
>> Owen Brand
>> Opry99er
>>
>
>

---

From: Chris and Veronica Schneider <[email-masked]>
Date: Fri, 07 Jun 2013 10:09:32 -0500

I believe it will work with no issue using the HDX.  I'm almost done
building one and I will let you know soon.

Chris

From:  Owen Brand <[email-masked]>
Reply-To:  <[email-masked]>
Date:  Fri, 07 Jun 2013 08:55:20 -0600
To:  <[email-masked]>
Subject:  Re: [TI994A] Re: Thoughts?

Okay...  What about using my PC as a hard drive?  The HDX interface opens up
some cool possibilities...  Would it work?  Obviously quite a bit of file
path modification would have to take place, but it seems like a viable
option on the surface...  rs232/1 would be the BBS port, rs232/2 is the HDX
interface...

Owen Brand
Opry99er

epergrem <[email-masked] <mailto:epergrem%40yahoo.com> > wrote:

>Owen,
>I don't have a nanoPEB, but having ran S&T it occurs to me that without a hard
drive, RAM disk, etc. you might be better off with something like Smalltalk.
>
>No where near as feature rich as S&T, but requires a very little footprint and
is happy to run off of nanoPEBs three floppy drives.
>
>Ernie
>
>--- In [email-masked] <mailto:TI994A%40yahoogroups.com> , Owen Brand
<owen.brand@...> wrote:
>> I have a CF7 which I love, but I have been thinking alot lately about the
possibilities of the nanoPEB's serial port....  I never use the parallel port on
my CF7 for anything, so why not get a nanoPEB and do something with the serial
port?  Best thing I could think to do is create a BBS and host it without a
regular PEB.  What you guys think?

---

From: Gregory McGill <[email-masked]>
Date: Fri, 7 Jun 2013 08:20:12 -0700

Most BBS file transfer routines do their own disk access so as to buffer
the files and rs232 data properly. Most likely will need to be recoded to
support HDX.

Greg

On Fri, Jun 7, 2013 at 8:09 AM, Chris and Veronica Schneider <
[email-masked]> wrote:

> **
> >I don't have a nanoPEB, but having ran S&T it occurs to me that without a
> hard drive, RAM disk, etc. you might be better off with something like
> Smalltalk.
> >
> >No where near as feature rich as S&T, but requires a very little
> footprint and is happy to run off of nanoPEBs three floppy drives.
> >
> >Ernie
> >
> >> I have a CF7 which I love, but I have been thinking alot lately about
> the possibilities of the nanoPEB's serial port.... I never use the parallel
> port on my CF7 for anything, so why not get a nanoPEB and do something with
> the serial port? Best thing I could think to do is create a BBS and host it
> without a regular PEB. What you guys think?
> >>

---

From: "epergrem" <[email-masked]>
Date: Fri, 07 Jun 2013 16:44:02 -0000

Owen,

S&T uses some low level subroutines to access the hard drive.  When Richard wanted to try the IDE card on his BBS, Tim had to be make some changes for the software to be compatible with Fred's DSR.

You might run into a similar issue using the HDX interface depending upon how it does disk access.

Ernie

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 7 Jun 2013 12:53:43 -0500

Correct, Ernie.  

The HDX interface uses different subroutine numbers for the low level routines.  With Greg's help I modified Archiver for the HDX as a test, and discovered a few things I need to account for in future code.   The S&T BBS will not natively work with HDX as it is coded for the HFDC and SCSI routines.  

Also Fred selected "HD" as the first two characters of the device name, which poses some dilemma for Geneve device tests that are notoriously two-characters  (e.g., "HDX1 vs. HDS1")

;)

> To: [email-masked]
> From: [email-masked]
> Date: Fri, 7 Jun 2013 16:44:02 +0000
> Subject: [TI994A] Re: Thoughts?
> 
> Owen,
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>