Subject: HDX boards

From: Gregory McGill <[email-masked]>
Date: Wed, 17 Apr 2013 20:16:09 -0700

HDX boards arrived today, I will be putting together the shipments and they
will start going out Friday

Greg

---

From: Owen Brand <[email-masked]>
Date: Thu, 18 Apr 2013 08:58:00 -0700 (PDT)

So I've started looking at taking a stripped down version of the Baseball99 Simulator I've been writing and converting it to a format usable by a BBS... Heatwave, Reef, etc... Maybe even The Keep... but Baseball doesn't really fit into that "theme" I don't guess.  =)

So, would simple PRINT statements in XB be the best way to go here?  It would take some re-arranging of my screen display, but there's not much there anyway.... I assume I could use PRINT USING statements as well?

Owen

---

From: Gregory McGill <[email-masked]>
Date: Thu, 18 Apr 2013 09:12:47 -0700

most bbs software is xbasic with assy routines for comm call
link("printthis","your text") and call link("input this", a$)

So print statements and input statements

Greg

On Thu, Apr 18, 2013 at 8:58 AM, Owen Brand <[email-masked]>wrote:

> **
>
>
> So I've started looking at taking a stripped down version of the
> Baseball99 Simulator I've been writing and converting it to a format usable
> by a BBS... Heatwave, Reef, etc... Maybe even The Keep... but Baseball
> doesn't really fit into that "theme" I don't guess.  =)
>
> So, would simple PRINT statements in XB be the best way to go here?  It
> would take some re-arranging of my screen display, but there's not much
> there anyway.... I assume I could use PRINT USING statements as well?
>
> Owen
>
>  
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 18 Apr 2013 09:19:20 -0700 (PDT)

Thanks Greg... I saw that post at the Reef but I was unclear on a couple things.  And it's a little easier to communicate via eMail.  =)

Would I need to create the assembly functions and have them LINKed via XB in the actual program itself, or is there something inherent in the BBS software which does this?

Also, is there a library for this?  I would actually like the challenge of building the assembly routines myself--- I'll need to brush up a little... Should be fun times.   =)

Owen

________________________________
 From: Gregory McGill <[email-masked]>
To: ti994a <[email-masked]> 
Sent: Thursday, April 18, 2013 10:12 AM
Subject: Re: [TI994A] Modifying a game for a BBS

most bbs software is xbasic with assy routines for comm call link("printthis","your text") and call link("input this", a$)

Greg

---

From: Gregory McGill <[email-masked]>
Date: Thu, 18 Apr 2013 10:07:52 -0700

the bbs loads the assy into himem..so you just call link to it..  best
thing to do is download the software he runs and look at the bbs code for
examples.. or one of the games
there's really no 'manual' other than what came with the bbs

I've converted many a tibasic game by just replacing the print and input
statements with call links, and the exit game function to a command to run
the bbs main software the call links themselves are specific to the bbs
software itself.. not every one uses the same routines..  i think tinet and
techie were the same calls but my memory isnt great from 20+ years ago :)
 i have most of the older bbs softwares in disk image if you want i can
email you the files, been archiving my library thanks to the hdx card and
dsk2pc :)  I don't think I have what Richard runs though that's too new :)

Greg

On Thu, Apr 18, 2013 at 9:19 AM, Owen Brand <[email-masked]>wrote:

> **
>
>
> Thanks Greg... I saw that post at the Reef but I was unclear on a couple
> things.  And it's a little easier to communicate via eMail.  =)
>
> Would I need to create the assembly functions and have them LINKed via XB
> in the actual program itself, or is there something inherent in the BBS
> software which does this?
>
> Also, is there a library for this?  I would actually like the challenge of
> building the assembly routines myself--- I'll need to brush up a little...
> Should be fun times.   =)
>
> Owen
>
>   ------------------------------
>  *From:* Gregory McGill <[email-masked]>
> *To:* ti994a <[email-masked]>
> *Sent:* Thursday, April 18, 2013 10:12 AM
> *Subject:* Re: [TI994A] Modifying a game for a BBS
>
>

---

From: Owen Brand <[email-masked]>
Date: Thu, 18 Apr 2013 10:33:32 -0700 (PDT)

That would be most helpful, thank you.

Can I DL the BBS version of the Golf game or the Battleship game??  I don't know if that particular modded version is available for DL... I'll have to look and see.

Owen

Sent: Thursday, April 18, 2013 11:07 AM

the bbs loads the assy into himem..so you just call link to it..  best thing to do is download the software he runs and look at the bbs code for examples.. or one of the games
there's really no 'manual' other than what came with the bbs

I've converted many a tibasic game by just replacing the print and input statements with call links, and the exit game function to a command to run the bbs main software the call links themselves are specific to the bbs software itself.. not every one uses the same routines..  i think tinet and techie were the same calls but my memory isnt great from 20+ years ago :)  i have most of the older bbs softwares in disk image if you want i can email you the files, been archiving my library thanks to the hdx card and dsk2pc :)  I don't think I have what Richard runs though that's too new :)

Greg

---

From: Gregory McGill <[email-masked]>
Date: Fri, 19 Apr 2013 22:37:38 -0700

mailed most of these today eta should be 2-5 business days to most people

On Wed, Apr 17, 2013 at 8:16 PM, Gregory McGill <[email-masked]>wrote:

> HDX boards arrived today, I will be putting together the shipments and
> they will start going out Friday
>
> Greg
>