Subject: Re: [TI994A] Disk drive issue

From: Owen Brand <[email-masked]>
Date: Tue, 04 Jun 2013 22:50:26 -0600

Okay....  Tried initializing a fresh disk....  40 tracks per side, double sides, single density...  It choked on a few spots.  Finished with:

Available=356
Used=2

This doesn't seem right to me....  

Owen Brand
Opry99er

Owen Brand <[email-masked]> wrote:

>So... I KNOW this MFM disk is good... or was before today... However when I just went to catalog it, it said that the disk was NOT INITIALIZED.... Problem..... big problem.  
> 
>When I tried to copy it earlier, it read the first file and then threw an error, so I KNOW there is or WAS something there just minutes ago... now it's NOT INITIALIZED?
> 
> 
>Owen
>
>
>________________________________
>From: Owen Brand <[email-masked]>
>To: "[email-masked]" <[email-masked]> 
>Sent: Tuesday, June 4, 2013 10:32 PM
>Subject: [TI994A] Disk drive issue
>
>  
>Okay.... so my 3.5 drives are working great.  No surprise there...
>
>Here's the issue... no matter what disk I try to BACKUP using the DM2 cart, it throws an error when trying to read my 5.25s.  This is strange, as I'm able to catalog and list each disk just fine from the DM2 cart reading DSK1 (my standard full height TI-issue floppy).  I'm attempting to back up some of my programs that lie in 5.25-land and it's just not working with me...  Is it probably that my 5.25 drive is failing me?  I do have another one in the garage, but it is untested and has not been used in over 25 years...  I'm afraid that I may be damaging my disks and don't really want to go on trying out other disks if the drive is faulty.  All I need is to lose all my old game projects and unique old software packages.....  
>
>Any tests I can run?  You guys have any ideas?  
>
>Right now I'm trying to make a copy of MFM for a guy... I want to make a 3.5 backup and then write the 5.25s from that.... but for some reason, my 5.25 is being fickle right now...  =(
>
>
>Owen

---

From: Owen Brand <[email-masked]>
Date: Tue, 04 Jun 2013 23:00:08 -0600

Okay....  Wrote 3 test programs which called one another from inside program execution...  Saved them to the newly initialized disk and they run like a charm...  DM2 recognizes the disk and catalogs properly and as expected....

So....  Is there anything to glean from this little test?  Are there any more thorough tests I can run before I ruin my LAST copy of MFM trying to copy it??  If the copy I attempted to duplicate last time was corrupted, that would explain what happened with it...  But I want to make ABSOLUTELY sure before I try again... I have one copy of MFM left that I haven't touched yet....

Owen Brand
Opry99er

---

From: Owen Brand <[email-masked]>
Date: Tue, 04 Jun 2013 23:10:20 -0600

NOW.....

Turned off the TI, turned it back on...  It's now reading the newly formatted disk as MFM?!?!?!? Where the hell did it get THAT?!

 Refuses to catalog the disk (IO error 6) and my saved programs are gone.

Now I'm REALLY confused.....

Owen Brand
Opry99er

---

From: Owen Brand <[email-masked]>
Date: Wed, 05 Jun 2013 06:57:41 -0600

No PM received on this end, boss...

I checked my filtered files too. Nada.  :)  I'll be out and about much of today.  When I get home I will be reseating all my cards and such in an attempt to figure this little doozie out!

Owen Brand
Opry99er

Tursi <[email-masked]> wrote:

>I agree with the suggestion to just let it sit for a bit. When you come back 
>to testing - reduce the variables - remove diskettes from the area that you 
>aren't actually testing with, and carefully double-check which disk is 
>inserted where.
>
>Check the cables are still tight, reseat the cards in the PEB in case they 
>have become dislodged, same with the firehose on the side of the TI. Then 
>just boot up your disk manager and run a format with verify - since that 
>will write and read back every sector on the disk, it's a pretty good test. 
>Try with at least two floppies.
>
>There's no caching mechanism on the TI disk controller, so there's no 
>conceivable way for the system to report your diskette as MFM if it's not 
>anymore. Something messed up and wrote to the disk you weren't expecting 
>(the simplest explanation is the most likely one). But back right up and do 
>a few formats to just test the drive(s).
>
>I sent you a few private messages tonight - did they not get through?
>
>Good luck!
>
>-----Original Message----- 
>From: Owen Brand
>Sent: Tuesday, June 04, 2013 11:12 PM
>To: [email-masked]
>Subject: Re: [TI994A] Disk drive issue
>
>I wrote some test programs in XB and was able to save, load, and run them.. 
>I chained the programs together to make sure I wasn't just accessing memory, 
>that I was actually accessing the drives and it worked fine... A few times. 
>After powering down and powering up the gear a few times, it choked out and 
>started giving me crazy info in DM2.  Now it won't run or list the tester 
>programs I wrote....
>
>
>Owen Brand
>Opry99er
>
>Gregory McGill <[email-masked]> wrote:
>
>>is it the same media?  I've seen drives with cockeyed cables say they wrote
>>to disks and it turns out they did not
>>
>>
>>On Tue, Jun 4, 2013 at 10:57 PM, Owen Brand 
>><[email-masked]>wrote:
>>
>>> **
>>>
>>>
>>> Hmmm.... Yes, I think I will do that. Seems as though something wacky has
>>> started happening here and I can't put my finger on it. Very odd that
>>> instead of cataloging as "TESTDSK", which is what I initialized it as, it
>>> would revert to being called MFM, a disk I had in the drive an hour
>>> before....
>>>
>>> That is the biggest mystery of them all to me.... It also showed that the
>>> disk in the box was 720k instead of the 358 it showed when I initialized
>>> it... Anyone ever hear of a 32k holding remnants of previous memory 
>>> access,
>>> even after being powered down?
>>>
>>> I am hoping my power issues have not contributed to the wackiness of this
>>> experience... I doubt it, but I WAS using my hardware when that crazy 
>>> power
>>> thing happened today....
>>>
>>> Ideas, Tursi? :) Im stumped!!
>>>
>>>
>>> Owen Brand
>>> Opry99er
>>>
>>> Tursi <[email-masked]> wrote:
>>>
>>> >Okay, good. Check the cables then, just to be sure. The drive heads may
>>> need
>>> >cleaning, too. It sounds like everything /mostly/ works, so that would 
>>> >be
>>> my
>>> >next thought.
>>> >
>>> >Good luck!
>>> >
>>> >-----Original Message-----
>>> >From: Owen Brand
>>> >Sent: Tuesday, June 04, 2013 10:34 PM
>>> >To: [email-masked]
>>> >Subject: Re: [TI994A] Disk drive issue
>>> >
>>> >I've had the 3.5s for a few years... I actually did a video showing how
>>> to
>>> >remove the terminator for the 5.25 in order to allow the 3.5 drives to
>>> >function properly... It's still on YouTube if I am remembering 
>>> >correctly.
>>> >Some title like "disk drive modification" or something of the like.
>>> >
>>> >This is a totally new problem... One that is perplexing me. :) I'll run
>>> >some more tests tomorrow. Thanks. :)
>>> >
>>> >Owen Brand
>>> >Opry99er
>>> >
>>> >Tursi <[email-masked]> wrote:
>>> >
>>> >>My first thought here is to check drive termination - I assume the 3.5"
>>> >>drive is a recent addition?
>>> >>
>>> >>There must be one and only one drive with termination on the floppy
>>> cable,
>>> >>and it must be the last drive on the chain. When you have too many
>>> >>terminators, not enough, or in the wrong place, you basically end up
>>> >>getting
>>> >>random failures. (Of course, if that is so, another test might be to
>>> remove
>>> >>the 3.5" drive and just see if the problems go away - or format the 
>>> >>same
>>> >>floppy again and see if the results are different - just to prove
>>> >>unreliable
>>> >>behaviour.)
>>> >>
>>> >>According to the notes I took some time ago, 3.5" drives tend to handle
>>> the
>>> >>termination, meaning you should remove it from any 5.25" drives on the
>>> same
>>> >>cable. ( http://harmlesslion.com/text/ti_35_inch_floppy.txt )
>>> >>
>>> >>If you aren't sure about the terminator packs let me know, and I'll 
>>> >>find
>>> >>some photos. I've been looking at Google without much luck so far. ;)
>>> >>
>>> >>-----Original Message-----
>>> >>From: Owen Brand
>>> >>Sent: Tuesday, June 04, 2013 9:32 PM
>>> >>To: [email-masked]
>>> >>Here's the issue... no matter what disk I try to BACKUP using the DM2
>>> cart,
>>> >>it throws an error when trying to read my 5.25s. This is strange, as 
>>> >>I'm
>>> >>able to catalog and list each disk just fine from the DM2 cart reading
>>> DSK1
>>> >>(my standard full height TI-issue floppy). I'm attempting to back up 
>>> >>some
>>> >>of my programs that lie in 5.25-land and it's just not working with 
>>> >>me...
>>> >>Is it probably that my 5.25 drive is failing me? I do have another one 
>>> >>in
>>> >>the garage, but it is untested and has not been used in over 25 
>>> >>years...
>>> >>I'm afraid that I may be damaging my disks and don't really want to go 
>>> >>on
>>> >>trying out other disks if the drive is faulty. All I need is to lose 
>>> >>all
>>> >>my
>>> >>old game projects and unique old software packages.....
>>> >>
>>> >>Right now I'm trying to make a copy of MFM for a guy... I want to make 
>>> >>a
>>> >>3.5
>>> >>backup and then write the 5.25s from that.... but for some reason, my
>>> 5.25
>>> >>is being fickle right now... =(
>>> >>
>>> >>
>>> >>Owen
>>> >>
>>> >>
>>> >>
>>> >>
>>> >>
>>> >
>>> >
>>> >------------------------------------
>>> >
>>> >Yahoo! Groups Links
>>> >
>>> >
>>> >
>>>
>>>
>>>
>
>
>------------------------------------
>
>Yahoo! Groups Links
>
>
>

---

From: Owen Brand <[email-masked]>
Date: Wed, 05 Jun 2013 17:46:11 -0600

Sigh.......

Yea.

I have zero time for jack these days...  Today was my off day...  I spent 3.5 hours going over month end reports with the regional manager, another 2 hours dealing with inventory, then I got to leave work.  Went to take my grandma to the grocery,came home, took a map with my son, and now it's almost 6:00 mountain time.  Off day my a##.

Tomorrow it's another 8:00-8:00 day full of stress and bullsh##.  I HAVE GOT TO FIND A DIFFERENT JOB.....

Owen Brand
Opry99er

Marc Hull <[email-masked]> wrote:

>Good point but if you have been running a bunch of those old disks from your granny's basement then there is a good chance they got gunked up pretty quick.  It only take one flaking disk to clog the heads.  You may have to get a Q-tip and some alcohol and get dirty ;-)...
>
>
>
>
>--- On Wed, 6/5/13, Owen Brand <[email-masked]> wrote:
>
>Date: Wednesday, June 5, 2013, 2:22 PM
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> 
>
>
>
>  
>
>
>    
>      
>      
>      2010
>
>
>
>:)
>
>
>
>But I haven't used them since then either....
>
>
>
>Owen Brand
>
>Opry99er
>
>
>
>Marc Hull <[email-masked]> wrote:
>
>
>
>>When was the last time you cleaned your drive ?
>
>>
>
>>--- On Tue, 6/4/13, Owen Brand <[email-masked]> wrote:
>
>>
>
>>Date: Tuesday, June 4, 2013, 11:32 PM
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>>
>
>> 
>
>>
>
>>
>
>>
>
>>  
>
>>
>
>>
>
>>    
>
>>      
>
>>      
>