Subject: Myarc 1.6 PC DSR

From: Dan Eicher <[email-masked]>
Date: Sun, 27 Jan 2013 17:54:21 -0500

I do not believe that Myarc every officially released a quad
density/80 Track EPROM for the Myarc FDC.

I purchased mine directly from Paul Charlton - hence the PC in 1.6 PC.

Paul mentioned:
 1. The dip switches no longer changed the head step rate, as they
where hard coded in (set to a make the most out of (then) modern half
height drives like Teac's.
 2. A few bug fixes.
 3. 80 track support (of course).

Dan

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Mon, 28 Jan 2013 01:15:41 +0100

I got my Quad Eprom for the Myarc FDC from Steve Lamberti of Texaments 
(Patchougue, NY), roughly on October - November1986. It was Eprom version 
 >03. I don't know where Lamberti took it from.
I simply assumed it was Myarc, because he was selling Myarc stuff at the 
time.

But he might have gotten it from Paul Charlton instead. That's very
possible :-)

Paolo Bagnaresi

----- Original Message ----- 
From: "Paolo Bagnaresi" <[email-masked]>
To: <[email-masked]>
Sent: Monday, January 28, 2013 1:05 AM
Subject: Re: [TI994A] Myarc 1.6 PC DSR

>
> ----- Original Message ----- 
> From: "Dan Eicher" <[email-masked]>
> To: <[email-masked]>
> Sent: Sunday, January 27, 2013 11:54 PM
> Subject: [TI994A] Myarc 1.6 PC DSR
>
>

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 27 Jan 2013 20:22:49 -0600

Do you still have the EPROM and if so, would you be willing/able to dump its contents for a comparison?

> To: [email-masked]
> From: [email-masked]
> Date: Mon, 28 Jan 2013 01:15:41 +0100
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 27 Jan 2013 20:27:16 -0600

Both 1.5 and 1.6PC contain a Paul Charlton 1986 copyright notice.  What is not yet
apparent from the current discussion is which version is better or why.  
 
The DIP switch makes sense, as in the 80 track scenario, each of the four switches
determines whether or not the DSR treats the drive as 40 or 80 track.   Thx for the
info Dan ;)

> From: [email-masked]
> Date: Sun, 27 Jan 2013 17:54:21 -0500

---

From: "Paolo Bagnaresi" <[email-masked]>
Date: Mon, 28 Jan 2013 04:09:51 +0100

Sorry Tim, but all my TI stuff is kept 400 km away from where I stay. 
Also, I don't have a working full TI or Eprom reader/burner any more.

Paolo

  ----- Original Message ----- 
  From: Insane Multitasker
  To: [email-masked]
  Sent: Monday, January 28, 2013 3:22 AM
  Subject: RE: [TI994A] Myarc 1.6 PC DSR

  Do you still have the EPROM and if so, would you be willing/able to dump 
its contents for a comparison?

---

From: Insane Multitasker <[email-masked]>
Date: Fri, 1 Feb 2013 12:24:41 -0600

Dan,
I noticed this card with the 1.6PC DSR also has a WD1772 chip installed. 
 
 Did you replace your WD1770 when you purchased the 80-track EPROM from Paul?

---

From: Jeff White <[email-masked]>
Date: Fri, 1 Feb 2013 20:48:02 -0500

The 1770 has step rates of 6, 12, 20, and 30 ms.  The standard 80-track DSR supports the 6 ms step.  The 1772 had 6, 12, 2, and 3 ms step rates, with 2 and 3 selected with the same code as the 1770 steps of 20 and 30.  To support the faster step rates with the 1772, the DSR needs to be updated.

Jeff White

---

From: Tony Knerr <[email-masked]>
Date: Fri, 01 Feb 2013 21:33:54 -0500

Hmm...

I had a v1.5 80 track eprom card. The v1.5 eprom was from Cecure.
The card had a 1770 and I replaced it with a 1772.
The drives were noticeably quieter and faster with the new chip,
there was no delay in the verifying of the sectors in the format routine 
as the
drive went to the next track. The 1770 had a delay.

If both chips were set at the 6 ms step rate as you suggest, there 
should have been no difference.
There was a difference.

Tony

On 2/1/2013 8:48 PM, Jeff White wrote:
> The 1770 has step rates of 6, 12, 20, and 30 ms.  The standard 
> 80-track DSR supports the 6 ms step.  The 1772 had 6, 12, 2, and 3 ms 
> step rates, with 2 and 3 selected with the same code as the 1770 steps 
> of 20 and 30.  To support the faster step rates with the 1772, the DSR 
> needs to be updated.
>
> Jeff White
>

---

From: [email-masked]
Date: Sat, 2 Feb 2013 11:52:23 +0000 (UTC)

I have a Myarc 80 Track Floppy controller. 
I bought it to test RXB CALL SECTOR routines on it. 
Never noticed any difference in speed. 

Rich 

----- Original Message -----
From: "Tony Knerr" <[email-masked]> 
To: [email-masked] 
Sent: Friday, February 1, 2013 6:33:54 PM 
Subject: Re: [TI994A] Myarc 1.6 PC DSR 

Hmm... 

there was no delay in the verifying of the sectors in the format routine as the 

If both chips were set at the 6 ms step rate as you suggest, there should have been no difference. 
There was a difference. 

Tony 

Jeff White

---

From: Tony Knerr <[email-masked]>
Date: Sat, 02 Feb 2013 07:00:10 -0500

Never noticed any difference in the speed of what?

Are you commenting on the 1770 vs 1772 chips, which is
the subject being discussed?

Tony

---

From: Jeff White <[email-masked]>
Date: Sat, 2 Feb 2013 12:20:48 -0500

What I recall is that the 4-dip switch selected between 6 and 20 ms step rates for the original 40-track DSR EPROM.  The 4-dip switch selects 40- or 80-track drive with 80-track DSR EPROM, which originally supported only 6 ms step rates for all drives.

Going from the 1770 to 1772 should only change 20 ms step pulses to 2 ms step pulses, and 30 ms to 3 ms.  The fastest a 1770 can do is 6 ms steps.

Maybe you had a marginal 1770 or the v1.5 DSR was using the 20 or 30 ms step rates for your drives.  I recall the 80-track DSR purchased with my card was v1.2 from Myarc.

Jeff White

---

From: [email-masked]
Date: Sat, 2 Feb 2013 21:28:35 +0000 (UTC)

Yea. The only real difference I ever noticed was sound as 40 vs 80 

Rich 

----- Original Message -----
From: "Tony Knerr" <[email-masked]> 
To: [email-masked] 
Sent: Saturday, February 2, 2013 4:00:10 AM 
Subject: Re: [TI994A] Myarc 1.6 PC DSR 

Tony 

Rich