Subject: OT: MESS build

From: Owen Brand <[email-masked]>
Date: Tue, 25 Jun 2013 10:55:20 -0600

Im working with Marc Hull's ASLP right now trying to code up a few tunes.  I was hoping to throw it onto my Linux USB so I could mess around with it at work on my very few breaks.  That requires a proper MESS build.

I was wondering, perhaps Michael Zapf or Greg McGill could chime in here, if different distros of Linux have different build protocols...  

I have XUBUNTU 13.04 on my stick right now but my coworker uses Mint.  Are either of these preferred over the other for MESS or are they interchangeable?

Owen Brand
Opry99er

---

From: "Michael Zapf" <[email-masked]>
Date: Tue, 25 Jun 2013 17:56:05 -0000

Owen, 

> I have XUBUNTU 13.04 on my stick right now but my coworker uses 
> Mint.  Are either of these preferred over the other for MESS or are 
> they interchangeable?

the only thing you have to make sure is that you know how to install the libraries. As an openSUSE user, I do not know Ubuntu too well, neither Mint. I just can say that you need the following packages on your system:

gcc
gcc-c++
subversion
make
Development package of the gconf2 library
Development package of the gtk2 library
Development package of the SDL library
Development package of the SDL_ttf library
Development package of the Qt4 library 

The development packages are usually named like *-devel. When you install them, the runtime packages should be automatically selected and installed as well.

If this is not enough I'd ask you to takes notes of everything you find necessary to make it compile so that I can put that on ninerpedia.

Michael

---

From: Gregory McGill <[email-masked]>
Date: Tue, 25 Jun 2013 14:21:55 -0700

http://www.ninerpedia.org/index.php/Building_MESS has the info you need for
the different versions of linux..

Ubuntu:
Ubuntu users need to make use of the apt-get command or check the software
repository tools. For Ubuntu 11.10 and newer, the following packages are
required:
sudo apt-get install subversion
sudo apt-get install libsdl1.2-dev
sudo apt-get install libgtk2.0-dev
sudo apt-get install libgconf2-dev
sudo apt-get install libsdl-ttf2.0-dev
This set of package installations also imports gcc/gcc-c++ and make.

Different distros have different package managers some use RPM's some use
apt.. debian based linux uses DEB files and others like red hat and suse
use RPM files to package applications drivers source etc..

The result is the same.. just the methods are different.

Greg

On Tue, Jun 25, 2013 at 9:55 AM, Owen Brand <[email-masked]>wrote:

> **
>
>
> Im working with Marc Hull's ASLP right now trying to code up a few tunes.
> I was hoping to throw it onto my Linux USB so I could mess around with it
> at work on my very few breaks. That requires a proper MESS build.
>
> I was wondering, perhaps Michael Zapf or Greg McGill could chime in here,
> if different distros of Linux have different build protocols...
>
> I have XUBUNTU 13.04 on my stick right now but my coworker uses Mint. Are
> either of these preferred over the other for MESS or are they
> interchangeable?
>
> Owen Brand
> Opry99er
>  
>