Subject: Do Disk controllers?

From: "atrax27407" <[email-masked]>
Date: Wed, 29 May 2013 14:09:33 -0000

Do Disk Controllers use CPU memory when accessing a disk drive on a read? TI? Myarc? CorComp? BWG? Does anyone know and what addresses (if any) do they use?

---

From: [email-masked]
Date: Wed, 29 May 2013 14:31:41 -0000

The only CPU memory involved that I can think of is indirectly at >8370,
which holds the highest available VRAM address, which is immediately
below the VRAM disk buffers.  This can be adjusted with the DSR level 2
subprogram >016 (buffer allocation routine), which updates >8370.  See
GPL Interface Specifications for the 99/4 Disk Peripheral and Software
Specifications for the 99/4 Disk Peripheral for details, both available
at whtech.com' FTP site.
...lee
--- In [email-masked], "atrax27407"  wrote:
>
> Do Disk Controllers use CPU memory when accessing a disk drive on a
read? TI? Myarc? CorComp? BWG? Does anyone know and what addresses (if
any) do they use?

---

From: Insane Multitasker <[email-masked]>
Date: Wed, 29 May 2013 11:32:37 -0500

That depends - what do you consider CPU memory?  :)

All controllers utilize scratchpad RAM (8300-83FF) for various routines and workspaces.  Certain routines also pass information via scratchpad.  

Some newer controllers can use non-VDP RAM for buffers and PABs.  The programmer must specify the memory address and memory type. 

> To: [email-masked]
> From: [email-masked]
> Date: Wed, 29 May 2013 14:09:33 +0000
> Subject: [TI994A] Do Disk controllers?
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>