Subject: TMS 9902 model

From: "James W." <[email-masked]>
Date: Sun, 28 Apr 2013 20:15:07 -0000

(Posted on the Facebook TI 99/4A site_

Okay, and this goes to Gregory Mcgill and others. One of the guys working with Gary Smith and I, Gregory Estrade, created a VHDL model of the TMS9902 UART. I have that code and would like to work with you guys on getting something similar to the F18A as a replacement part or as a new RS232 board-with the HDX functionality built in.

James

---

From: "RedskullDC" <[email-masked]>
Date: Wed, 01 May 2013 08:56:26 -0000

Hi James,et al.

> Okay, and this goes to Gregory Mcgill and others. One of the guys working with Gary Smith and I, Gregory Estrade, created a VHDL model of the TMS9902 UART. I have that code and would like to work w…

Thanks for uploading the design files.

That model still synthesizes ok with ISE14.x, despite the design being nearly 6 years old.

The 18pin DIP package of the original TMS9902 makes a drop in replacement somewhat tricky, but not impossible.

Design targets a Spartan xc3s200-5ft256.
Something like:
http://www.oho-elektronik.de/pics/UM_XC3S200.pdf
(with a XC3S200-VQ100 and 5V compatible I/O's) looks almost ideal.

Out of curiosity, I wondered in the design (as it stands) would fit in a 5V compatible Xilinx CPLD. Afraid not, even in a 95288 ...
"Cpld:837 - Insufficient number of macrocells. The design needs at least 312 but only 288 left after allocating other resources.
Device 95288XL144 was disqualified."

Cheers,
Red

---

From: Jeff White <[email-masked]>
Date: Wed, 1 May 2013 06:34:24 -0400

On 01 May 2013, at 04:56, "RedskullDC" <[email-masked]> wrote:
> The 18pin DIP package of the original TMS9902 makes a drop in replacement somewhat tricky, but not impossible.._,___
> 
With regards to getting the VHDL model 9902 into the 18-pin package, you might want to review the following:  http://www.fullcircuit.com/index.htm#9902

That website seems to have not been updated for several years, but there is contact information for the designer, Malcolm Robin Reeves in England.

Richard Bell may have 9902 chips available.  The nanoPEB by Jaime Malilong uses the 9902; see http://webpages.charter.net/nanopeb/ for documentation.  Jaime does/did have a source for 9902 chips.

Jeff White

---

From: "James W." <[email-masked]>
Date: Tue, 21 May 2013 02:09:03 -0000

Jeff,

I have thought my response to you carefully. I agree, there are, for now, replacement 9902's. But, I am taking the F18A approach here-functional equivalent but with some more power-especially with a faster baud rate utilizing a built-in fifo buffer. And depending on which FPGA is used, that can be quite substantial. Add a modified DSR with Fred's HDX, and we have a very nice card to use. 

I have seen Malcolm's work and wrote back with him regarding this, and the code was proprietary to him and his company. 

I don't know if I would go for an actual replacement, like Malcolm did. From what Matthew has done with the F18A, it CAN be done. It would be bigger than the original chip as a replacement-but the technology is there as we have a model AND the code is available too. 

I think this is something we should take advantage of and create a card. 

Respectfully,

James

--- In [email-masked], Jeff White <ti994a@...> wrote:
>
> On 01 May 2013, at 04:56, "RedskullDC" <layling@...> wrote:
> > Hi James,et al.
> > 
> > --- In [email-masked], "James W." <jwkrych@> wrote:
> > >