Subject: TI Portable Speech Lab

From: "Stuart" <[email-masked]>
Date: Sun, 20 Nov 2011 21:33:42 -0000

I've been very fortunate in that a contact has pointed me to the availability of a TI Portable Speech lab - basically speak into microphone, and out comes data for a TMS51xx/52xx speech chip. This can either be written direct to an EPROM, or downloaded over RS-232. This particular unit was used for setting up station announcement systems with British Rail.

<http://tinyurl.com/7vl2jb5>

If I can get it up and running (it all looks complete and in good condition), we'll have a way to generate voice data using a genuine 9900-based processing system.

The gory hardware details if anyone's interested:

-- TM990/101 – standard processor board. Two 2716 EPROMs labelled P.BUG V2.

-- TM990/201 – standard memory board with full complement of 2716 EPROMs and RAM. No IDs on EPROMs apart from socket numbers – looks like they're copies.

-- TMS52xx board – has a TMS5220 speech chip for immediate playback of data. Labelled "RTC990/VSP Voice Synthesis Processor". +8V and -8V voltage regulators. Audio output jacks. 8kHz/10kHz selection jumper.

-- Empty slot for TMS51xx board. Presumably for an older TMS51xx speech chip version of the above board.

-- TM990/302 – standard EPROM programmer board with adaptor board for 2716 EPROMs. Flying lead to the 48V supply socket on the chassis.

-- "Speech Analysis" board. Big IC - a 12-bit parallel multiplier/accumulator. 6 off 1K RAMs. Several PROMs. +/-15V voltage converter. 10-bit A/D converter. 2516 EPROM. Mic and Line input sockets, with selection switch.

All in a nice portable case with built-in PSU.

Stuart.

---

From: Marc Hull <[email-masked]>
Date: Sun, 20 Nov 2011 15:15:38 -0800 (PST)

Are you saying that your speech is converted into alaphones or LPC on the fly ?  Now that's cool.  Please post updates...  and yea gory and morbid details please....

--- On Sun, 11/20/11, Stuart <[email-masked]> wrote:

From: Stuart <[email-masked]>
Subject: [TI994A] TI Portable Speech Lab
To: [email-masked]
Date: Sunday, November 20, 2011, 3:33 PM

  

Stuart.

---

From: "Stuart" <[email-masked]>
Date: Mon, 21 Nov 2011 00:10:51 -0000

Converted to LPC.

If we got together Marc, we could do a "sing-along-a-SID".  ;-)

Stuart.

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
>
> Are you saying that your speech is converted into alaphones or LPC on the fly ?Â  Now that's cool.Â  Please post updates...Â  and yea gory and morbid details please....
> 
> --- On Sun, 11/20/11, Stuart <ti99@...> wrote:
> 
> From: Stuart <ti99@...>
> Â 
> -- TM990/101 â€" standard processor board. Two 2716 EPROMs labelled P.BUG V2.
> 
> 
> 
> -- TM990/201 â€" standard memory board with full complement of 2716 EPROMs and RAM. No IDs on EPROMs apart from socket numbers â€" looks like they're copies.
> 
> 
> 
> -- TMS52xx board â€" has a TMS5220 speech chip for immediate playback of data. Labelled "RTC990/VSP Voice Synthesis Processor". +8V and -8V voltage regulators. Audio output jacks. 8kHz/10kHz selection jumper.
> 
> 
> 
> -- TM990/302 â€" standard EPROM programmer board with adaptor board for 2716 EPROMs. Flying lead to the 48V supply socket on the chassis.
> 
> 
>

---

From: Marc Hull <[email-masked]>
Date: Sun, 20 Nov 2011 16:12:54 -0800 (PST)

Or better yet... a two part harmony  of 99/4a and 990 with speech to boot ;-)

From: Stuart <[email-masked]>
Subject: [TI994A] Re: TI Portable Speech Lab
To: [email-masked]
Date: Sunday, November 20, 2011, 6:10 PM

  

      Converted to LPC.

Stuart.

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

---

From: "Stuart" <[email-masked]>
Date: Tue, 22 Nov 2011 09:51:17 -0000

Well the digital side of things work, after replacing a shorted capacitor on one of the boards. Next step is to get hold of a microphone and speaker.

  **** 52XX PASS SOFTWARE VERSION 3.0 ****
 
COPYRIGHT (C) TEXAS INSTRUMENTS INCORPORATED
 
  ****  CHIP TYPE BEING USED IS 52??  ****
 
[]?
HELP? (Y/N) Y
COMMANDS ARE: R,A,S,B,Q,V,P,M,H,L,E,C,O,D,2..9,T,F
(R)eplay phrase
(A)nalyze another phrase
(S)et analysis parameters
(B)oundary set
(Q)uit/return to TIBUG
(V)olume (52XX ONLY)
(P)rogram EPROM
(M)odify concatenation
(H)ear  concatenation
(L)ist phrase
(E)dit phrase
(C)onvert to serial, program EPROM
(O)utput codepack
(D)ownload/speak codepack
(2..9)Variable speed replay
(T)est hardware
(F)ile Retrieval
 
[]T
HEX CHECKSUM = 8F09
 
PRESS ANY KEY TO STOP.
LO=000409E0 000235A0 HI=0003C860 449824C0 CRU=1111111111010111
[]
[]A
[]L
#  ERGY CE P    K1 K2 K3 K4 K5 K6 K7 8 9 0
001 0032 01 00   11 05 06 05
002 0032 01 00   12 06 06 05
003 0033 01 00   11 06 06 04
004 0031 01 00   11 05 05 05
005 0032 01 00   11 07 07 05
006 0031 01 00   12 05 05 06
007 0032 01 00   11 06 06 05
008 0032 01 00   12 06 06 05
009 0033 01 00   11 06 07 06
010 0032 01 00   12 06 06 06
011 0033 01 00   11 06 06 05
012 0032 01 00   12 06 06 05
013 0033 01 00   11 05 06 06
T-->
014 0033 02 00   12 07 07 05
015 0033 01 00   11 06 07 06
016 0032 01 00   12 06 06 05
017 0032 01 00   11 05 05 06
018 0033 01 00   11 06 06 04
019 0033 01 00   11 07 07 05
020 0033 01 00   11 06 07 05
021 0033 01 00   12 06 06 04
022 0033 01 00   11 07 06 05
023 0033 01 00   11 05 06 06
024 0033 01 00   11 06 06 06
025 0034 02 00   11 08 07 05
026 0033 01 00   11 06 06 05
027 0033 01 00   11 06 06 05
028 0034 02 00   12 07 06 05
029 0034 01 00   11 06 07 05
030 0033 01 00   11 05 06 05
031 0034 01 00   10 04 05 05
032 0033 01 00   11 05 06 05
033 0035 01 00   11 06 06 04
034 0034 01 00   11 06 06 05
035 0035 01 00   11 05 06 05
036 0034 01 00   11 06 07 05
037 0034 01 00   11 07 06 05
038 0035 01 00   11 06 06 05
039 0035 01 00   11 06 06 06
040 0035 01 00   11 06 07 05
041 0035 01 00   11 05 06 06
042 0035 01 00   11 06 06 05
043 0036 01 00   11 06 05 05
044 0035 01 00   10 06 06 04
045 0036 01 00   10 05 06 05
046 0036 01 00   11 06 06 05
047 0035 01 00   10 05 06 05
048 0036 01 00   11 06 06 05
049 0036 01 00   10 06 06 05
050 0036 01 00   10 06 07 05
051 0037 01 00   10 06 06 04
052 0036 01 00   11 06 06 05
053 0038 01 00   10 06 06 05
054 0036 02 00   11 06 07 06
B-->
055 0038 01 00   10 06 06 05
056 0036 01 00   10 05 06 05
057 0037 01 00   10 06 06 05
058 0037 01 00   10 05 06 05
059 0038 01 00   10 06 07 06
060 0037 01 00   10 05 06 05
061 0038 01 00   10 06 07 05
062 0038 01 00   10 06 06 05
063 0038 01 00   10 05 07 05
064 0038 01 00   11 05 06 05
065 0038 01 00   10 06 06 05
066 0038 01 00   10 05 06 04
067 0038 01 00   10 05 06 06
068 0038 01 00   10 06 06 05
069 0039 01 00   10 05 06 05
070 0038 01 00   10 05 05 04
071 0039 01 00   09 05 06 05
072 0038 01 00   10 05 06 06
073 0036 01 00   60 81 68 32
 
[]

---

From: "Jacques" <[email-masked]>
Date: Tue, 22 Nov 2011 07:50:54 -0400

This is a news item that appeared in the 99'er magazine Vol #1 Issue #6. 
Would this be the same board you are working with? I understand that a 
similar device was used to create the Bert and Ernie program.

Jacques

TI announces versatile tool for experimenting
with synthesized speech

A single-board microcomputer module that provides hands-on
experience in working with Linear Predictive Coding (LPC) synthesized
speech has been announced by Texas Instruments. The new Speech
Education Module features highly flexible hardware capabilities and an
interactive Forth monitor that allows extensive user-defined
experimentation. This makes the module well suited for use as a
speech-applications development aid or as a learning tool for
speech-synthesis technology. The version of Forth contained in the Speech 
Education Module features a
unique set of speech-oriented primitive functions that enables users to 
interact with the module at high
levels (such as concatenating words or speaking a phrase) or at very low 
levels of function (such as
state-by-state control of the module's voice-synthesis processor).
Through a set of experiments provided with the module, users can learn to 
specify their own unique Forth
commands and command sequences. Each of the high-level software operations 
is available for use in
defining new operations, eliminating the necessity for the user to get 
involved with the details of Assembly
Language. This allows quick adaptation of speech-output capability to almost 
any application or
experiment,
Measuring less than 9½" × 11", the Speech Education Module includes a 
TMS7000 8-bit microcomputer
chip, TMS5220A voice-synthesis processor, 4K bytes of RAM (random-access 
memory), 12K bytes of
EPROM (erasable programmable ROM), and a VM61002 vocabulary ROM (read-only 
memory) containing
206 pre-programmed words and phrases. It also has two RS232C serial ports 
with independent baud-rate
controls, an 8-bit switch register for user applications, four 
software-controlled LED (light-emitting diode)
status indicators, an 8-bit analog-to-digital converter, and an audio 
amplifier with user-selectable cutoff
frequencies for direct speaker drive.
On-board memory can be expanded to include up to 14K bytes of RAM or EPROM 
using any desired mix
of TMS2516 EPROMs and TMS4016 static RAMS. A second TMS6100 series 
voice-synthesis memory
ROM containing TMS5220-compatible speech data can be included on board or 
substituted in place of the
pre-programmed VM61002 vocabulary ROM. In addition, the TMS7000's control of 
the system bus can
be disabled by jumpers to permit external control of the module.
Minimal hardware is needed to set up the Speech Education Module for 
operation. For a basic
configuration, the user needs a standard RS232 data terminal, a 4 6 or 8 6 
loudspeaker, and a
three-voltage power supply (+5, +12, and -12 Volts) such as the TM990/519. 
External hardware can be
expanded via the module's second RS232 port to include an oscilloscope, 
printer, or serial link to a host
computer.
The Speech Education Module is available for $600. For additional 
information contact: Texas
Instruments Incorporated, Central Literature Response Center (SC-366), PO 
Box 202129, Dallas, TX
75220

-----Original Message----- 
From: Stuart
Sent: Tuesday, November 22, 2011 5:51 AM
To: [email-masked]
Subject: [TI994A] Re: TI Portable Speech Lab

Well the digital side of things work, after replacing a shorted capacitor on 
one of the boards. Next step is to get hold of a microphone and speaker.

<SNIP>

---

From: "Stuart" <[email-masked]>
Date: Tue, 22 Nov 2011 18:35:24 -0000

My system is actually 5 boards. But I've seen details of another single board system in a book: "... based on the TDS900 Eurocard Forth computer manufactured by Triangle Digital Services Ltd". Seems like Forth was the language of the day ...

Stuart.

---

From: mark wills <[email-masked]>
Date: Wed, 23 Nov 2011 12:22:50 +0000 (GMT)

WOW! That sounds AWESOME! I want one!

Speech is my favourite facility on the TI, I've always been fascinated with it ever since I was a kid!

>________________________________
>Sent: Sunday, 20 November 2011, 21:33
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: mark wills <[email-masked]>
Date: Wed, 23 Nov 2011 12:27:13 +0000 (GMT)

Oh be still my beating heart!

>Sent: Tuesday, 22 November 2011, 9:51

---

From: mark wills <[email-masked]>
Date: Wed, 23 Nov 2011 12:30:26 +0000 (GMT)

It's the language of today too - at least it is inside my head!

>Sent: Tuesday, 22 November 2011, 18:35

---

From: "Stuart" <[email-masked]>
Date: Sat, 26 Nov 2011 14:50:55 -0000

Looks like it all works - although some experimentation with the recording side of things should hopefully make the voice clearer.

If you want a demo, download the file ...

<www.avjd51.dsl.pipex.com/speech.zip>

... which contains a TIDisk file with the object file DEMO_O. This plays OK on Win994a, and hopefully on real hardware as well. Doesn't work on Classic99 as it can't handle the quick-and-dirty technique of just throwing data at the speech chip, whereas Win994A and the hardware can.

What it should be saying is "TI Portable Speech Lab" - the last word is rather muffled.

Stuart.

--- In [email-masked], "Stuart" <ti99@...> wrote:
> --- In [email-masked], Marc Hull <marc.hull@> wrote:
> >
> > --- On Sun, 11/20/11, Stuart <ti99@> wrote:
> > 
> > From: Stuart <ti99@>

---

From: Tony Knerr <[email-masked]>
Date: Sat, 26 Nov 2011 14:40:48 -0500

Hi Stuart.

For me, in Win994A, it makes no sound at all.
In MESS, it just makes a "cccchhhh" sound.

Tony

On 11/26/2011 9:50 AM, Stuart wrote:
>
> Looks like it all works - although some experimentation with the 
> recording side of things should hopefully make the voice clearer.
>
> ... which contains a TIDisk file with the object file DEMO_O. This 
> plays OK on Win994a, and hopefully on real hardware as well. Doesn't 
> work on Classic99 as it can't handle the quick-and-dirty technique of 
> just throwing data at the speech chip, whereas Win994A and the 
> hardware can.
>

---

From: Marc Hull <[email-masked]>
Date: Sat, 26 Nov 2011 13:38:15 -0800 (PST)

On my console it is somewhat intelligible but a bit lossy and whispery.

--- On Sat, 11/26/11, Stuart <[email-masked]> wrote:

From: Stuart <[email-masked]>
Subject: [TI994A] Re: TI Portable Speech Lab
To: [email-masked]
Date: Saturday, November 26, 2011, 8:50 AM

  

Stuart.

--- In [email-masked], "Stuart" <ti99@...> wrote:

---

From: "Stuart" <[email-masked]>
Date: Sat, 26 Nov 2011 22:54:08 -0000

Download again and try, Tony. I've tweaked the code to play it. It's a bit hissy and lossy, as Marc says. Recording next to a noisy PC fan is less than ideal ...

Stuart.

---

From: Tony Knerr <[email-masked]>
Date: Sat, 26 Nov 2011 19:35:16 -0500

Plays ok now in MESS, Stuart. Sounds like real TI speech!
But it locks up Win994A with a green screen, not a problem for me as I 
hardly ever use Win994A.

Tony

On 11/26/2011 5:54 PM, Stuart wrote:
>
> Download again and try, Tony. I've tweaked the code to play it. It's a 
> bit hissy and lossy, as Marc says. Recording next to a noisy PC fan is 
> less than ideal ...
>
> Stuart.
>
>

---

From: ti99_forever <[email-masked]>
Date: Sat, 26 Nov 2011 19:38:17 -0800 (PST)

A lot of things lock up Win994A... sad to say. But it is only a 'simulator', I here... we could ask Dr. Bray...

> From: Tony Knerr <[email-masked]>
>Sent: Saturday, November 26, 2011 7:35 PM
>Subject: Re: [TI994A] Re: TI Portable Speech Lab
> 
>
> 
>
>
>But it locks up Win994A with a green screen, not a problem for me as
    I hardly ever use Win994A.

---

From: ti99_forever <[email-masked]>
Date: Sat, 26 Nov 2011 19:40:08 -0800 (PST)

"hear"... I'm tired... been in South Carolina for my sister's wedding... and got food poisoning.
Kids drove us crazy on the way home, 9 hour trip, and they haven't stopped since.

> From: ti99_forever <[email-masked]>
>To: "[email-masked]" <[email-masked]> 
>Sent: Saturday, November 26, 2011 10:38 PM

---

From: "Stuart" <[email-masked]>
Date: Sun, 27 Nov 2011 10:51:36 -0000

Which version of Win994a are you using Tony? I've got V3.008 and its working fine on that on my Windows 7 PC. Presumably the speech in Alpiner or Parsec comes out OK if you try one of those cartridges?

Stuart.

---

From: Tony Knerr <[email-masked]>
Date: Sun, 27 Nov 2011 07:01:21 -0500

I've been trying it with v3.007 and v3.009 and just downloaded v3.008 
and got the same results. I guess it helps to look at the docs to find 
out how to turn on the speech synth .

Working now. :-)

Tony

On 11/27/2011 5:51 AM, Stuart wrote:
>
> Which version of Win994a are you using Tony? I've got V3.008 and its 
> working fine on that on my Windows 7 PC. Presumably the speech in 
> Alpiner or Parsec comes out OK if you try one of those cartridges?
>
> Stuart.
>

---

From: "Stuart" <[email-masked]>
Date: Fri, 23 Dec 2011 22:57:08 -0000

I've got speech playing on the TI-99 properly now - I had a timing delay wrong.

There's a new tidisk at <www.avjd51.dsl.pipex.com/speech.zip>. On the disk are two files, load with E/A option 3, program name START:

MERRYCM_O - a little message from Santa. It plays properly but the recording quality is pants.

ESTD_O - one of the professionally recorded and edited phrases that I found on an EPROM rattling round in the bottom of the system case. Those of you in the UK should be able to recognise the station name. The speech pitch is not quite right - it is recorded at 10kHz, while the TI speech synthesiser plays at 8kHz.

Plays OK on Win994a. Not so good on Classic99.

A Merry Christmas to all list subscribers.

Stuart.