Subject: Floppy drive Redux.......

From: "Marc H" <[email-masked]>
Date: Wed, 08 May 2013 00:57:39 -0000

Hey folks.

I have a question or two that you all may know the answer to.  It concerns using 5.25" 1.2 meg drives for the TI.  I have several that I would like to put into service and can jumper select them to 300 RPM but I am pretty sure they retain their 80 track nature which seems to cause problems reading disks formatted as 40 tracks.

I can format a disk with one of these drives and read/write to it fine but when it comes to reading/writing to a floppy formatted on a 40 track drive it ranges from a partial let down to a total flop.

SO.......  

Is it possible to set the "drive" (not the software) to 40 tracks or is this something physical in the mechanisms themselves.  

Is there a difference in any of the controllers (TI, CorComp or Myarc) that mitigate or reduce the problems ?  

And finally.....  

Anyone have any tricks that allow a 40 track, formatted floppy to be reliably read/written to/from an 80 track drive ?

Thanks crew....

Marc

---

From: Jeff White <[email-masked]>
Date: Tue, 7 May 2013 21:14:39 -0400

Marc,

If you have a Myarc FDC with 80-track EPROM, you can reliably read 40-track disks in an 80-track drive.  I suggest not writing to 40-track disks in an 80-track drive.  The Myarc FDC will double-step tracks when a 40-track disk is inserted into a drive set to 80-track.

The HFDCC works similarly.

Jeff White

---

From: [email-masked]
Date: Wed, 08 May 2013 01:34:06 -0000

Yeah, Marc.  Jeff is right.  The problem stems from the fact that the
heads on 5.25", 1.2MB drives have narrower magnetic gap (half, I think)
and use a higher write current than 360KB drives.  You should be able to
read 360KB disks that have been formatted and written by 360KB drives,
but you should never write to them with the 1,2MB drives because you'll
be laying down a higher-flux half-width track down the middle of the
360KB full-width track---guaranteed to be unreadable by a 360KB drive
after that.
You should be able to format and write to a pristine 360KB diskette as
such in a 1.2MB drive and then read it in a 360KB drive, but that's
probably not reliable because of the different magnetic flux and
because, believe it or not, the media designed for the two formats were
different.  I believe the coating was finer, more highly polished and a
different magnetic susceptibility.  Theoretically, you should be able to
write to the disk in this paragraph with a 360KB drive, but you probably
could not reliably overwrite/erase the bits written by the higher
density/higher flux drive.
...lee
--- In [email-masked], Jeff White  wrote:
>
> Marc,
>
> If you have a Myarc FDC with 80-track EPROM, you can reliably read
40-track disks in an 80-track drive.  I suggest not writing to 40-track
disks in an 80-track drive.  The Myarc FDC will double-step tracks when
a 40-track disk is inserted into a drive set to 80-track.
> On 07 May 2013, at 20:57, "Marc H" marc.hull@... wrote:
> > Hey folks.
> >
> > I have a question or two that you all may know the answer to. It
concerns using 5.25" 1.2 meg drives for the TI. I have several that I
would like to put into service and can jumper select them to 300 RPM but
I am pretty sure they retain their 80 track nature which seems to cause
problems reading disks formatted as 40 tracks.
> >
> > I can format a disk with one of these drives and read/write to it
fine but when it comes to reading/writing to a floppy formatted on a 40
track drive it ranges from a partial let down to a total flop.
> >
> > SO.......
> >
> > Is it possible to set the "drive" (not the software) to 40 tracks or
is this something physical in the mechanisms themselves.
> >
> > Is there a difference in any of the controllers (TI, CorComp or
Myarc) that mitigate or reduce the problems ?
> >
> > And finally.....
> >
> > Anyone have any tricks that allow a 40 track, formatted floppy to be
reliably read/written to/from an 80 track drive ?

---

From: Jeff White <[email-masked]>
Date: Tue, 7 May 2013 22:13:48 -0400

Marc,

On 07 May 2013, at 21:34, [email-masked] wrote:
<snip>
> You should be able to format and write to a pristine 360KB diskette as such in a 1.2MB drive and then read it in a 360KB drive, but that's probably not reliable because of the different magnetic flux and because, believe it or not, the media designed for the two formats were different.  I believe the coating was finer, more highly polished and a different magnetic susceptibility.  Theoretically, you should be able to write to the disk in this paragraph with a 360KB drive, but you probably could not reliably overwrite/erase the bits written by the higher density/higher flux drive.
> 
> ...lee

Coercivity, typically reported in oersteds, of standard and high density media is different.  You definitely want to stay with standard disks and not the high density disks if you want to go back and forth between 40-track and 80-track drives.  The floppy disk controllers for the 99/4A only support standard densities up to 720K.  There were 5.25-in, 720K floppy drives available, and I would suggest using those.

You still need a double-stepping DSR to handle both 40- and 80-track disks in a drive.

Jeff White

---

From: Marc Hull <[email-masked]>
Date: Tue, 7 May 2013 19:44:03 -0700 (PDT)

Thanks Jeff.

I do have a Myarc with 80 tracks so I'll give that a go.  At least then system 2 will have a 5.25" drive.

--- On Tue, 5/7/13, Jeff White <[email-masked]> wrote:

From: Jeff White <[email-masked]>
Subject: Re: [TI994A] Floppy drive Redux.......
To: "[email-masked]" <[email-masked]>
Date: Tuesday, May 7, 2013, 8:14 PM

  

      Marc,

 

      Hey folks.

SO.......  

And finally.....  

Thanks crew....

Marc

---

From: Owen Brand <[email-masked]>
Date: Wed, 8 May 2013 19:19:25 -0700 (PDT)

So I am fortunate enough to be the proud owner of a F18A VDP replacement, but I have not had any time to do ANYTHING, much less a hardware project.  Life keeps me away from sh** I want to do.

Anyway, I have this TI monitor... I love my TI monitor... but the thing went kaput on me when I went to set up my gear a couple of weeks ago.  SO... All that being said.... 

Are the components in the TI monitor rare?  Are there any proprietary components or the like that would preclude me from getting it repaired inexpensively?  It's not just that it's a monitor, it's that it was my dad's TI-branded monitor and I really want it to be operational.  I have two consoles that I use regularly, one which is completely stock and in magnificent, like-new shape (this will be my F18A console) and my #1 "beat-it-up-coding" console with the number pad modification I got from an old 99er in rural Indiana years ago.  I plan to have the F18A console plugged up to a very nice 22" monitor I bought second hand, but I want my "old faithful" beater to be hooked up to the TI monitor.  

I say all this to ask:  "Any thoughts on getting an original 10" TI monitor repaired?"

It seems to be the power... I plugged it in, adjusted the V-Hold, heard a frequency increasing in pitch until a "click" and now NOTHING.  No red indicator light, nothing.  I don't have any knowledge of repairing monitors and don't know if this is a simple fix or not. =) Any info would be greatly appreciated.

Owen

---

From: [email-masked]
Date: Thu, 09 May 2013 03:17:07 -0000

Owen...

I had a friend who used to service CRTs years ago tell me that units that had been out of service for long periods of time would often fail the way you describe when put back into service and that the problem was almost always in the high-voltage circuit and wasn't worth the risk of trying to fix it---he always replaced them.  That said, there are folks on this forum with more electronics know-how than I, so you may yet get a fix.

...lee

---

From: Owen Brand <[email-masked]>
Date: Wed, 8 May 2013 20:57:55 -0700 (PDT)

There may be hope yet!!!

While the monitor didn't work after the "death pop," I just plugged it in again and it turned on!!!!

BUT.... It is doing the same thing it was doing when I plugged it in a couple weeks ago... It has a highly mangled display and no amount of adjusting is doing any good.  I have tried two consoles, thinking that it was potentially a VDP issue, and have had the same results on both consoles... Here is a picture of what the screen looks like

http://i830.photobucket.com/albums/zz222/Opry99er/monitorpic_zps196eae28.jpg

So... Different problem, but same issue... How do I get my monitor working?  =)

________________________________
 From: Owen Brand <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Wednesday, May 8, 2013 8:19 PM
Subject: [TI994A] TI monitor

Owen