Subject: SCSI to PC

From: "epergrem" <[email-masked]>
Date: Sat, 16 Jun 2012 02:09:53 -0000

I seemed to have misplaced thinking cap, but other than MFM is there a "easy" way to move files from a SCSI drive to the PC?  

I thought about using Thierry's VDM99, but I think it only handles RAM and floppy drives.  I would also like to avoid the SCSI -> TI DISK - > PC route because I have way too many files.

I want to archive the files on a PC similar to what I've done with my disks and PC99.

Thanks,
Ernie

---

From: Tony Knerr <[email-masked]>
Date: Sat, 16 Jun 2012 05:49:44 -0400

The best way is to connect the SCSI drive directly to the PC, Ernie.
Then use the newest version of Michael's TI IMAGE TOOL to 'open device'.
Open another window in TI IMAGE TOOL of a hard or floppy image and
copy and paste to your heart's content. An entire hard drive can be copied
in just a few minutes.

Tony

On 6/15/2012 10:09 PM, epergrem wrote:
>
> I seemed to have misplaced thinking cap, but other than MFM is there a 
> "easy" way to move files from a SCSI drive to the PC?
>
> I thought about using Thierry's VDM99, but I think it only handles RAM 
> and floppy drives. I would also like to avoid the SCSI -> TI DISK - > 
> PC route because I have way too many files.
>

---

From: "Michael Zapf" <[email-masked]>
Date: Sat, 16 Jun 2012 10:57:11 -0000

I just wanted to answer something about using Linux and the dd command, but Tony is right - I should remember my own tools. :-)

Tell us whether it worked as expected.

TIImageTool is at http://www.ninerpedia.org/index.php/TIImageTool

Michael

---

From: "epergrem" <[email-masked]>
Date: Sat, 16 Jun 2012 14:57:02 -0000

Thanks Tony and Michael,

I've been offered the loan of a SCSI adapter, so that looks like that's the way I'll have to go.  I think that I have one of the four PCs that I own that has an open card slot.

I suppose that I should have held onto one of the SCSI-I PCMCIA cards that was in Dave's estate, but I was trying to get the estate as much money as I could, so I resisted the urge to covet any thing. :-)

Ernie

---

From: "epergrem" <[email-masked]>
Date: Sat, 16 Jun 2012 21:31:03 -0000

Tony,
I have a SCSI adapter on the way.  So how do I copy from a SCSI drive to PC using TI Image Tool?  

Not from a SCSI image that was created in MESS, but a physical SCSI drive that was formatted by a TI or Geneve?

I've done it with PC99 and V9T9 disk images, but never from a physical drive.

Thanks,
Ernie

> 
> --- In [email-masked], Tony Knerr <tonyknerr@> wrote:
> >

---

From: Tony Knerr <[email-masked]>
Date: Sat, 16 Jun 2012 18:02:40 -0400

start up TI IMAGE TOOL

click file
click open device
enter SCSI drive letter
click ok
scsi drive is now open in first tab (may take a while to build directory)

click file
click open
find your image file
open it
image file is now open in second tab

Copy whatever you want from the SCSI drive to your image file just like 
you would using windows explorer
(you can't copy from the image file to the SCSI drive, hopefully in the 
next version).

Tony

On 6/16/2012 5:31 PM, epergrem wrote:
> Not from a SCSI image that was created in MESS, but a physical SCSI 
> drive that was formatted by a TI or Geneve?
>

---

From: "epergrem" <[email-masked]>
Date: Sat, 16 Jun 2012 23:09:36 -0000

Excellent!

---

From: Tony Knerr <[email-masked]>
Date: Sat, 16 Jun 2012 19:27:33 -0400

Yes, it is.

Make sure you thank Michael, he added this function at my request.

Tony

On 6/16/2012 7:09 PM, epergrem wrote:
>
> Excellent!
>
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, Tony 
> Knerr <tonyknerr@...> wrote:
> >
> > start up TI IMAGE TOOL
> >
> > click file
> > click open device
> > enter SCSI drive letter
> > click ok

---

From: Marc Hull <[email-masked]>
Date: Sat, 16 Jun 2012 18:05:53 -0700 (PDT)

This strays off from your subject a bit but I thought I would throw it out there.  If you can get your hands on a SCSI-IDE adapter for using a CF on the original equipment you can make a PC backup up of your data easily.  You can use TI-DIR or just a binary copy to duplicate your drive (CF that is) as a PC based file (provided you have a PC with a CF slot.)  

Problem is getting one of those buggers anymore.  The boat seemed to sail on them about 2008 unless you really, really want one ($$$.)

I really haven't followed the TI Image Tool stuff yet but perhaps I should.  I seem to be missing something.  Perhaps Michael would post a brief (or not so brief) feature list and a synopsis of what it does.

--- On Sat, 6/16/12, Tony Knerr <[email-masked]> wrote:

From: Tony Knerr <[email-masked]>
Subject: Re: [TI994A] Re: SCSI to PC
To: [email-masked]
Date: Saturday, June 16, 2012, 6:27 PM

  

      

    Yes, it is.

    Tony

      
          
            Excellent! 

              --- In [email-masked],
              Tony Knerr <tonyknerr@...> wrote:

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 17 Jun 2012 11:27:22 -0000

> Perhaps Michael would post a brief (or not so brief) feature list and a synopsis of what it does.

It has become a bit difficult to summarize in a few lines, as more and more features were added. In short:

- Java-based tool (needs a Java Runtime)
- File management on disk image files (move, copy, rename, delete, single file, multi files, recurse through directories)
- Most useful when you use an emulator with image files; supports sector dumps ("v9t9") and track dumps ("pc99") transparently, no need to convert. 
- Also handles raw bytes dumps and MESS CHD, and since the latest release, direct device access (like Compact flash or SCSI drive)
- Built-in disassembler and BASIC lister
- File system check
- Serial bridge to be coupled to MESS's serial emulation, which gives you a real RS232 connection between the emulation and the outside world.
- If you download a copy, just unpack and start the jar file (double-click on it, or start in command line with "java -jar tiimagetool.jar"). Can take a disk image argument to be opened on start.
- In the program, see the menu item Help/Manual for a more detailed description.

Michael

---

From: "epergrem" <[email-masked]>
Date: Sun, 17 Jun 2012 13:17:13 -0000

Michael is already aware of this, but if you are creating a 'new' PC99 (track format) disk, then do not create any sizes other than DSSD or DSDD.  All other sizes are generated incorrectly. 

There are no issues with V9T9 (sector format) disks.

I recently had some 3.5" 2880 sector disks that I wanted to archive to the PC.  PC99 doesn't handle 2880 sector, so I used Paolo's TI99-PC.   I them opened the .img files in TI Image Tool and copied the files to smaller PC99 disks.  

It worked great since Paolo's .img format is basically a V9T9 disk with error information attached (if there was one).

Ernie

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 17 Jun 2012 14:40:50 -0000

> Michael is already aware of this, but if you are creating a 'new' 
> PC99 (track format) disk, then do not create any sizes other than 
> DSSD or DSDD.  All other sizes are generated incorrectly. 

Good reminder ... I just put a notice in the manual.

The background (for those who don't know) is that the TDF format I implemented in MESS assumes that single-sided images only contain one side. However, PC99 formats always contain both sides, even for single-side formats.

Michael

---

From: "epergrem" <[email-masked]>
Date: Wed, 20 Jun 2012 19:11:48 -0000

Michael,
I installed a SCSI adapter today and have started transfering the files from my SyQuest EZ135 to the PC.  I quickly ran into a problem with illegal Windows filename characters.  

Is it possible to add either an automatic, or user defined translation table?  You already allow that option with a couple of characters ("/","\" and "_"), but not for the others such as :*?"<>|. 

Thanks,
Ernie

---

From: "epergrem" <[email-masked]>
Date: Wed, 20 Jun 2012 19:18:20 -0000

BTW, I should add; this feature is truly awesome!

Ernie

--- In [email-masked], "epergrem" <epergrem@...> wrote:
> --- In [email-masked], "Michael Zapf" <forums12@> wrote:
> >

---

From: "Michael Zapf" <[email-masked]>
Date: Wed, 20 Jun 2012 23:35:51 -0000

Well, can be added, sure. I'll take a note.

By the way, you know you can directly copy the files to another image without going through the TIFILES conversion. Or do you need the files as TIFILES?

Michael

---

From: "Tony Knerr" <[email-masked]>
Date: Wed, 20 Jun 2012 23:59:02 -0000

I never had that issue come up, Ernie. (??)
Are you doing something other than a copy and paste to an image file?
(.dsk or .hd or .chd.)

Tony

---

From: "epergrem" <[email-masked]>
Date: Thu, 21 Jun 2012 00:24:51 -0000

Michael & Tony,
Problem arises when;

1) File -> Open Device (select F:, which is my EZ135)
2) Select All files on cartridge, or several -> Export Image.

Files and directories are copied to My Documents (or other location) until the tool attempts to write a file such as "**README.tfi" to the Windows folder.

So, I'm attempting multiple files and/or directories instead of a one at a times copy and paste, which with a EZ135 platter would take forever.

Thanks,
Ernie

--- In [email-masked], "Tony Knerr" <tonyknerr@...> wrote:
> --- In [email-masked], "epergrem" <epergrem@> wrote:
> >
> > Michael,

---

From: "epergrem" <[email-masked]>
Date: Thu, 21 Jun 2012 00:27:39 -0000

Tony,
Essentially you're staying within the 99/4A/Geneve, so you would never run into the issue.

Me?  I'm attempting to export the files and directories to Windows as TIFILES.

Ernie

---

From: "epergrem" <[email-masked]>
Date: Thu, 21 Jun 2012 00:35:35 -0000

Hi Michael,
Yes.  My original message asked if, other than MFM there was an easy ways to move files from a SCSI drive to the PC.

Typically, I do move files image to image, but in this particular case I'm trying to move about 20 EZ135 cartridges worth of data that I got from Dave Connery's estate to the PC.

Once on the PC I can run some duplicate finding software on the files and.

Ernie

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 21 Jun 2012 10:42:19 -0000

Try the new version at

http://www.mizapf.de/ti99/tiimagetool.zip

Michael

---

From: "epergrem" <[email-masked]>
Date: Thu, 21 Jun 2012 14:20:02 -0000

Michael,

Outstanding -- simply outstanding.  

I was able to move 504376 sectors from an EZ-135 platter to a folder on my WINXP PC in TIFILES format in about a minute or so.  

That's with the original folder structure being retained and invalid Windows filename character replacements. 

Ernie

---

From: Insane Multitasker <[email-masked]>
Date: Thu, 21 Jun 2012 09:42:15 -0500

Does the TIFILES header contain the original filename or is it modified with the replacement characters?   If the former, I could see Michael's tool being used to restore the platter while "defagging" it at the same time.  :)
> From: [email-masked]
> Date: Thu, 21 Jun 2012 14:20:02 +0000
> Subject: [TI994A] Re: SCSI to PC
> 
> Michael,
> 
> ------------------------------------
> 
> Yahoo! Groups Links
> 
> 
>

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 21 Jun 2012 14:48:06 -0000

Good!

It's just a pity that I could not get it to work in the other direction yet. The problem is that the device file \\.\e: refuses to be opened in read-write mode; I'm getting a FileNotFoundException. When trying to open in read-only mode the file is properly found and opened.

This is either a Java issue, or there is another way to open the device for writing. I have to find a proper forum to discuss that question.

Michael

---

From: "Michael Zapf" <[email-masked]>
Date: Thu, 21 Jun 2012 14:49:09 -0000

> Does the TIFILES header contain the original filename or is it 
> modified with the replacement characters?   If the former, I could 
> see Michael's tool being used to restore the platter while 
> "defagging" it at the same time.  :)

Yes, the TIFILES header has the original file name. The name change is only for storing on the PC.

Michael