Subject: TMS99xx reset on power-up

From: "Michael Zapf" <[email-masked]>
Date: Sat, 09 Jun 2012 21:29:10 -0000

Hi all,

a special question for the hardware people here. I could not fully prove it from the specifications, but maybe some of you know.

Is the TMS9900 / TMS9995 automatically reset on power-up, or it is required to explicitly trigger the reset? 

The background of this question is, again, MESS, and in particular the TM990/189 board. The TI-99/4(A) boards have a timer chip which resets the CPU on power-up. In contrast the TM990/189 board actually waits for a LOAD interrupt on power-up; its memory space starts with RAM and ends with ROM.

So the question is whether on power-up a RESET is always triggered, which would not make sense in this case (there is no vector at 0000). 

Michael

---

From: "Stuart" <[email-masked]>
Date: Sat, 09 Jun 2012 22:45:31 -0000

Hi Michael,

There's no automatic reset on power up. For the 9900, the circuit designer has a choice as to whether to active /RESET or /LOAD (or neither) on power up, usually using a resistor and capacitor to provide the delay.

Stuart.