Subject: Corcomp 9900 Mini PES Replacement Adapter

From: "hexbus" <[email-masked]>
Date: Fri, 09 Mar 2012 23:52:59 -0000

The WM113 Elpac adapter that I had with my 9900 Mini PES died today.. the magic smoke came out.  After dremeling the thing apart, it became apparent the transformer was toast on the non-AC side of the PCB (it stank to high heaven too).

So... would a datasheet for the WM113, and it looks like this one will work:

http://www.meanwell.com/search/p25a-t/P25A-T-spec.pdf
P25A13D-R1 is the model number, 12v, -12v, and 5v.

Anything that might have gotten zapped or anything in the 9900 Mini PES?  I didn't check the fuse in the old WM113 adapter, but I'm not sure it blew - either since I smelled (and saw) the smoke before it had a chance to overload the fuse, or it wasn't just drawing enough current to blow.

---

From: Marc Hull <[email-masked]>
Date: Fri, 9 Mar 2012 16:59:29 -0800 (PST)

I'd go ahead and get a new PS and find out ;-)......

Seriously if something failed in the 9900 bad enough to make the PS smell bad and get smokey then it may be a big project (doubtful) , but I would suspect that your PS simply STB and didn't take anything else down with it.  Either way you obviously need a new PS and that's as good a starting point as anywhere.

Guess your weekend is planned provided you can get all those females corralled ;-).

Marc

--- On Fri, 3/9/12, hexbus <[email-masked]> wrote:

From: hexbus <[email-masked]>
Subject: [TI994A] Corcomp 9900 Mini PES Replacement Adapter
To: [email-masked]
Date: Friday, March 9, 2012, 5:52 PM