Subject: Interest check....

From: "Marc H" <[email-masked]>
Date: Sun, 22 Jul 2012 00:20:54 -0000

I have been kicking around an idea for a while and would like to get some feedback and opinions as well as a general interest survey.

It's a hardware/software project designed to make using the TI a bit easier and bringing it into the future (well about 1990 anyway.)

The Hardware (PEB card) will consists of:

1) A PS/2 mouse interface.
2) 32k Memory expansion (with the ability to hide it.)
3) 8K DSR RAM (battery backed)
4) 512K RAM (also battery backed.)

The function of the hardware will be to support a mouse driven, pull down operating system.  Not quite a GUI as I don't think the VDP will support one very well but would be effective none the less.

The Op/Sys will be state saving so that when you boot the machine the system starts where it left off last time.  IE when you return from an external application or reboot the TI then your op/sys is in the same state as it was when you left down to the screen display and mouse position.

It would be flexible in that new routines could be added and accessed instantly by paging in a piece of the 512K RAM.

It's just in it's infancy obviously but sounds worthwhile and fun to me.  It would require the efforts of more than one person for sure so volunteers are needed.  Doesn't matter what your experience level is as you can learn on the go ;-).  

Thoughts ?

---

From: "epergrem" <[email-masked]>
Date: Sun, 22 Jul 2012 02:40:41 -0000

Hi Marc,
Sounds interesting, although I'm not sure how it would be used.  

Would it be compatible with a SAMS card?

Ernie

---

From: Marc Hull <[email-masked]>
Date: Sat, 21 Jul 2012 21:24:06 -0700 (PDT)

Hmmmm...

Don't know.  How does the SAMS card work ?

As of right now the current theory is that the OS would run in the 24K of high memory with support from the DSR space for paging and other essential features.  The 8K low memory would be used for temporary routines IE Calculator, text viewers, hex editors etc.  

I had thought about making the 32K memory portion selectable in case a user had a better option but I have not thought of the SAMS card or Rambo or any others.  My guess right now is that they might be incompatible because they are going to require memory space as well. 

But.....

Since the paging scheme I have been toying with is not CRU based but rather memory mapped via a register in DSR space there may actually be some hope.  The OS would definitely corrupt the SAMS card when it is running but once control is passed to the program utilizing it and the OS card is turned off then maybe.....

Good thought.

--- On Sat, 7/21/12, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] Re: Interest check....
To: [email-masked]
Date: Saturday, July 21, 2012, 9:40 PM

  

      Hi Marc,

Ernie

--- In [email-masked], "Marc H" <marc.hull@...> wrote:

---

From: "jesse_slicer" <[email-masked]>
Date: Sun, 22 Jul 2012 12:44:11 -0000

Replace PS/2 with USB and I think you have something very compelling.

---

From: Marc Hull <[email-masked]>
Date: Sun, 22 Jul 2012 11:49:13 -0700 (PDT)

Don't know if I can.  PS/2 seems much easier as the device does all the work and just sends completed data out.  It appears tha USB needs CPU cycles.  Again just starting the musing process so anything is possible and nothing is done ;-).

BTW PS/2 mice are readily available and most likely will be for a while to come.

--- On Sun, 7/22/12, jesse_slicer <[email-masked]> wrote:

From: jesse_slicer <[email-masked]>
Subject: [TI994A] Re: Interest check....
To: [email-masked]
Date: Sunday, July 22, 2012, 7:44 AM

  

--- In [email-masked], "Marc H" <marc.hull@...> wrote:

---

From: Gregory McGill <[email-masked]>
Date: Sun, 22 Jul 2012 12:42:43 -0700

Usb to ps2 adapter maybe?
On Jul 22, 2012 11:49 AM, "Marc Hull" <[email-masked]> wrote:

> **
>
>
> Don't know if I can.  PS/2 seems much easier as the device does all the
> work and just sends completed data out.  It appears tha USB needs CPU
> cycles.  Again just starting the musing process so anything is possible and
> nothing is done ;-).
>
> --- On *Sun, 7/22/12, jesse_slicer <[email-masked]>* wrote:
>
>
> --- In [email-masked]<http://mc/compose?to=TI994A%40yahoogroups.com>,
> "Marc H" <marc.hull@...> wrote:
> >
> > I have been kicking around an idea for a while and would like to get
> some feedback and opinions as well as a general interest survey.
> >
> > It's a hardware/software project designed to make using the TI a bit
> easier and bringing it into the future (well about 1990 anyway.)
> >
> > The function of the hardware will be to support a mouse driven, pull
> down operating system. Not quite a GUI as I don't think the VDP will
> support one very well but would be effective none the less.
> >
> > The Op/Sys will be state saving so that when you boot the machine the
> system starts where it left off last time. IE when you return from an
> external application or reboot the TI then your op/sys is in the same state
> as it was when you left down to the screen display and mouse position.
> >
> > It would be flexible in that new routines could be added and accessed
> instantly by paging in a piece of the 512K RAM.
> >
> > It's just in it's infancy obviously but sounds worthwhile and fun to me.
> It would require the efforts of more than one person for sure so volunteers
> are needed. Doesn't matter what your experience level is as you can learn
> on the go ;-).
> >
> > Thoughts ?
> >
>
>    
>

---

From: mark wills <[email-masked]>
Date: Mon, 23 Jul 2012 21:33:58 +0100 (BST)

Heck yeah!

>________________________________
> From: Marc H <[email-masked]>
>Sent: Sunday, 22 July 2012, 1:20
>Subject: [TI994A] Interest check....
> 
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: [email-masked]
Date: Mon, 23 Jul 2012 20:51:28 +0000 (UTC)

----- Original Message -----
From: "mark wills" <[email-masked]> 
To: [email-masked] 
Sent: Monday, July 23, 2012 1:33:58 PM 
Subject: Re: [TI994A] Interest check.... 

Heck yeah! 

  Make it USB and use a cheap SOC from a few years back so no CPU time or RAM is needed. $5 chips would work. 

<blockquote>

</blockquote>

  See above. 

<blockquote>

</blockquote>

  See above. 

<blockquote>

</blockquote>

  See above. 

<blockquote>

Thoughts ? 

Yahoo! Groups Links 

</blockquote>