Subject: Quality Software Protection

From: "atrax27407" <[email-masked]>
Date: Fri, 28 Dec 2012 18:51:59 -0000

Does anyone know what protection scheme Quality Software used to protect their disks? How can I defeat it to make a second copy of the software.

---

From: [email-masked]
Date: Fri, 28 Dec 2012 19:40:53 +0000

Which ones are you looking for? I've edited the copy protection out of all the ones I have, which is most of them. 

Sent from my Verizon Wireless BlackBerry

---

From: ti99_forever <[email-masked]>
Date: Fri, 28 Dec 2012 11:59:31 -0800 (PST)

Who here is a qualified protection hacker?
I see Tony Knerr already makes the list.

I have a piece of software that has a basic level of protection. I tried to crack it, but all I can do is produce duplicates of the software.

IIRC, the protection scheme only changes the # of sectors in sector 0 to be 1 less than usual for SSSD (359 instead of 360). If that isn't modified, it just goes back to the master title screen. There is more than one program on the disk that makes use of this scheme.

Who is willing to crack this? Once cracked, put it out to the community. No, I'm not saying what it is...

It'll take you probably less than half an hour, if you're good... I was never much at cracking.

Ben

---

From: [email-masked]
Date: Fri, 28 Dec 2012 21:31:11 +0000 (UTC)

Well I used Copy-C to do it. 
Another way is with a Load Interrupt switch and a EA Super Cart with 8K at Cart space. 
As long as the program does not need more disk access hit the switch and dump the contents of memory. 
Then what I did was create a loader and Ta Da it worked. 
The slowest way was to dump the memory and then disassemble the memory to make a new version. 

I think all of them have a unprotected version in PC99 or others.

---

From: ti99_forever <[email-masked]>
Date: Sat, 29 Dec 2012 22:56:38 -0800 (PST)

I'm ready for the jump... off the fiscal cliff!

Anyways, Happy New Year... and what country is there that will take in those of us disappointed and frustrated Americans?

Ben

---

From: Marc Hull <[email-masked]>
Date: Sun, 30 Dec 2012 07:32:19 -0800 (PST)

I hear N Korea is just beautiful this time of year ;-).....

Happy and prosperous New Year Ben.  Remember,  since the world was supposed to end a couple of weeks ago and didn't.....  We are all playing with house money now.  Live it up !

--- On Sun, 12/30/12, ti99_forever <[email-masked]> wrote:

From: ti99_forever <[email-masked]>
Subject: [TI994A] Happy New Year!
To: "[email-masked]" <[email-masked]>
Date: Sunday, December 30, 2012, 12:56 AM

---

From: Tony Knerr <[email-masked]>
Date: Mon, 31 Dec 2012 18:22:41 -0500

If the protection is that simple, you may want to try searching the disk 
(a copy,of course)
for >0167, and changing it to >168. Of course, you need to make sure you 
have the right value
in sector zero.

Alternately, disassembling the assembly code that checks for the data in 
sector zero would be
a more permanent fix. Either remove it completely, or let it do it's 
check and change the choice it
makes based on the result.

The procedure used on the Quality99 software was to have the code jump 
to the part of the code where
the correct result continued the execution of the program, regardless of 
the result obtained in checking
for the duplicate sector 2.

Tony

On 12/28/2012 2:59 PM, ti99_forever wrote:
> I have a piece of software that has a basic level of protection. I 
> tried to crack it, but all I can do is produce duplicates of the software.
>
> IIRC, the protection scheme only changes the # of sectors in sector 0 
> to be 1 less than usual for SSSD (359 instead of 360). If that isn't 
> modified, it just goes back to the master title screen. There is more 
> than one program on the disk that makes use of this scheme.
>
> Who is willing to crack this? Once cracked, put it out to the 
> community. No, I'm not saying what it is...
>
> _