Subject: CF2K - Does ANYONE have a WORKING copy?

From: "kevan064" <[email-masked]>
Date: Mon, 01 Jul 2013 03:14:29 -0000

Hi all,   I've been trying to get a WORKING copy of CF2K for some time
now.  I have no clue as to why it's get corrupted during the .ZIP
process., but every copy I find is corrupted and will NOT function, 
even the copy on Fred's site is FUBAR.
    Soooooooooooooooo, if someone would be so kind to email me a copy
(unzipped) in a .dsk file I'd REALLY, REALLY be appreciative!
Thanks!  [:)]

---

From: [email-masked]
Date: Mon, 01 Jul 2013 09:47:56 -0000

What about the copy on the nanoPEB & CF7+ website
<http://webpages.charter.net/nanopeb/>  ?
Is there a reason you don't use Fred's TI99Dir?  I use TI99Dir all the
time for transfers to/from my nanoPEB.  It works well.
...lee

---

From: "kevan064" <[email-masked]>
Date: Mon, 01 Jul 2013 13:28:53 -0000

Hi Lee,
  The program at <http://webpages.charter.net/nanopeb/> is CFMGR a variant of DM1000 and I DO use this program all the time on my NanoPEB.  However, from what I've been led to believe the CF2K program, is based on DM2K and apparently has the added ability of mounting and unmounting volumes. This would enable me to do a few 'extra' things without dropping to BASIC to perform the requisite commands. To confirm this, I actually need the program.

 With any program, one has to actually obtain a copy before they can determine if it actually fits their needs and requirements. In this case, I've not been able to accomplish the first step in getting a viable copy.

 As for Ti99Dir, that is a FANTASTIC program and I use it exclusively to transfer and convert my programs between the PC & CF card. And yes, it works VERY WELL on the PC side.

---

From: Mezzaluna3000 <[email-masked]>
Date: Mon, 01 Jul 2013 16:29:34 +0200

Hello, i use a cartdrige that i build using kaal program (is a mega mod 
with cf2, dk2, du2 and hdfx program) and ever program work well.. but i 
never used a disk program .. if you need i post a dump rom for build a 
cartdrige.

Il 01/07/2013 15.28, kevan064 ha scritto:
>
> Hi Lee,
> The program at <http://webpages.charter.net/nanopeb/> is CFMGR a 
> variant of DM1000 and I DO use this program all the time on my 
> NanoPEB. However, from what I've been led to believe the CF2K program, 
> is based on DM2K and apparently has the added ability of mounting and 
> unmounting volumes. This would enable me to do a few 'extra' things 
> without dropping to BASIC to perform the requisite commands. To 
> confirm this, I actually need the program.
>
> With any program, one has to actually obtain a copy before they can 
> determine if it actually fits their needs and requirements. In this 
> case, I've not been able to accomplish the first step in getting a 
> viable copy.
>
> As for Ti99Dir, that is a FANTASTIC program and I use it exclusively 
> to transfer and convert my programs between the PC & CF card. And yes, 
> it works VERY WELL on the PC side.
>
> --- In [email-masked] <mailto:TI994A%40yahoogroups.com>, 
> lee@... wrote:
> >

---

From: [email-masked]
Date: Mon, 01 Jul 2013 14:52:07 -0000

Kevan...
H-m-m-m...I somehow confabulated CF2K with CF2DSK, which is on the site,
but, obviously, not the same program.  Did you try correcting CF2K with
a hex editor as Fred suggested?
...lee
--- In [email-masked], "kevan064"  wrote:
>
> Hi Lee,
>   The program at  is CFMGR a variant of DM1000 and I DO use this
program all the time on my NanoPEB.  However, from what I've been led to
believe the CF2K program, is based on DM2K and apparently has the added
ability of mounting and unmounting volumes. This would enable me to do a
few 'extra' things without dropping to BASIC to perform the requisite
commands. To confirm this, I actually need the program.
>
>
>
> --- In [email-masked], lee@ wrote:
> >
> >   ?

---

From: "kevan064" <[email-masked]>
Date: Mon, 01 Jul 2013 16:15:44 -0000

Hi Again Lee,
  Yes, I used WinHEX and found the 9A and the CC in the respective program segments and replaced them with 00 as he suggested.  I still get the fatal error.  

  I have my limits on how far I will go to see if a program is worth using; I've reached my limit with this one.  It seems like nobody is using it either, as I've not found anyone with a viable copy and it's not for lack of trying.  Maybe they all had this problem and gave up too, I don't know.

--- In [email-masked], lee@... wrote:

> Did you try correcting CF2K with a hex editor as Fred suggested?
> ...lee

---

From: "kevan064" <[email-masked]>
Date: Mon, 01 Jul 2013 16:37:03 -0000

Grazie,
 In my case I doubt that would work.  The Mega Mod is an auto-bank switched cartridge.  I have a single 8K bank in my Cart that would not hold all four segments of the DF2K program.  So I'm stuck with requiring the disk version for now.  Unless I manage to get it from some kind person in the next day or two, I'm giving up on that program for good.  I just do not have that much time to devote to the pursuit of it.

Grazie per l'offerta,
Kevan

--- In [email-masked], Mezzaluna3000 <mezzaluna3000@...> wrote:
> > lee@ wrote:

---

From: "fredkaal" <[email-masked]>
Date: Mon, 01 Jul 2013 16:51:00 -0000

If you still find incorrect values in the header at offset >11 then you're not looking at the latest version.

I just checked: If you have done a new download then the Cf2k files in  the ZIP and Cf2k files in the DSK image are correct.

Fred

---

From: [email-masked]
Date: Mon, 01 Jul 2013 17:38:12 -0000

Thanks, Fred!

Kevan, I just downloaded what Fred currently has on his website and it works quite well on my nanoPEB.

...lee

--- In [email-masked], "fredkaal" <fredgkaal@...> wrote:
> --- In [email-masked], "kevan064" <kevan064@> wrote:
> >
> > Hi Again Lee,

---

From: "kevan064" <[email-masked]>
Date: Mon, 01 Jul 2013 18:24:57 -0000

REALLY!  What the....
Fudge!!  I'll try it ONE MORE time (quickly) as I have to go to work soon.

THANKS!  (I'll let you know late tonight how it worked out).

--- In [email-masked], lee@... wrote:
> --- In [email-masked], "fredkaal" <fredgkaal@> wrote:
> >

---

From: [email-masked]
Date: Mon, 1 Jul 2013 19:56:35 +0000 (UTC)

I would think someone would make a SAMS for the Console plug in on the side port that could be used with the Nano PEB or PBox or other devices. 
The SAMS is cheap to make according to many have made them. 

It does have software like: 

TI Opoly using 256K but can be patched to use 1Meg instead. 
RAG Assember 
RAG Disassember 
RAG Librarian 
RAG Linker 
RAG Macro Assembler 
RAG MultiPlan 
RAG TI Writer 
SAMS C99 

And my personal favorite RXB supports SAMS with a few demos and now a GAME that is being upgraded with Assembly. 

I have been told the SAMS could be designed to be faster then normal memory but I do not know if that is true or not. Does boggle the mind to have 1Meg or FAST RAM. 

----- Original Message -----
From: "kevan064" <[email-masked]> 
To: [email-masked] 
Sent: Monday, July 1, 2013 9:37:03 AM 
Subject: [TI994A] Re: CF2K - Does ANYONE have a WORKING copy? 

Grazie, 

Grazie per l'offerta, 
Kevan 

--- In [email-masked] , Mezzaluna3000 <mezzaluna3000@...> wrote: 
> > The program at < http://webpages.charter.net/nanopeb/ > is CFMGR a 
> > > < http://webpages.charter.net/nanopeb/ > ?

---

From: "kevan064" <[email-masked]>
Date: Tue, 02 Jul 2013 04:54:59 -0000

Hi Lee,
   Thanks for sending the image, but my bad luck is holding. The program runs on yours, but not mine.  For some reason my NanoPEB turns it's nose up on this one.  DM2K will run, but NOT CF2K.  I done screwing with it. It's not worth the hassle anymore.  I'm beginning to think it's the NanoPEB. Since other programs seem to run I'll just live with it.

   Actually the only other problem I have had so far was an error 15 when trying to access the RS-232.  I'll look that error up later.

    Lee, I even switched from the Win7 machine to the XP box just to download and install it on the CF card in the unlikely event something on my new machine was screwing with it. But since this version worked for you and was not zipped, I has to be a glitch in the Nano and not the program. 
it works quite well on my nanoPEB.

    Thanks again for you help in diagnosing the issue.