Subject: Re: RE: [TI994A] Re: More HRD questions....

From: [email-masked]
Date: Wed, 08 Feb 2012 16:15:55 -0600 (CST)

Ummm..................just for giggles, Marcus, is your ROS chip a 6264 or a 62256? You have to keep in mind how expensive SRAM memory was back in the day. A board fully populated with 512k chips would cost in the neighborhood of $600 - $700 bucks on a good day.

On 02/08/12, Marc Hull<[email-masked]> wrote:

Well you may be right but I am getting more and more convinced that ROS only wants you to have 10 virtual drives per CRU address.  It looks like physically the card only has to address enough memory to cover one chip (IE a card with 512K chips  only need to be able to present an address up to around the 512K limit.  The other chips are banked in via the 154.

I would guess that the designers thought process was... "Who in they're right mind would want a RAM Disk bigger than 4 MB or want more than 10 drives ;-).

That bodes well for you and your plan to create a 12 MB hard drive complete with limited directory structure.  Have you actually started the software yet ?  This will be a neat project when you are done with it.  Please keep us abreast of progress.

Andrew......

--- On Tue, 2/7/12, Insane Multitasker <[email-masked]> wrote:

From: Insane Multitasker <[email-masked]>
Subject: RE: [TI994A] Re: More HRD questions....
To: [email-masked]
Date: Tuesday, February 7, 2012, 5:25 PM

Hey Marc -  I think 4MB is the hardware addressing limitation versus a ROS limitation.   The Phoenix mod was used with the Geneve before Schroeder wrote his formatting programs.

To: [email-masked]
From: [email-masked]
Date: Tue, 7 Feb 2012 14:17:10 -0800
Subject: Re: [TI994A] Re: More HRD questions....

It appears that the Phoenix (is this the bird or the place ?) mod has morphed in the 4000 series to simply provide 2 maxed out 4 MB HRDs on one physical card.  If someone has an 8MB HRD...... Ahem.......Richard...... would you please run configure and report back how many HRD cards are reported and their size ?  I suspect it will be more than is physically present (number of cards that is ) but hopefully we will see.

For now I guess it is safe to assume that the actual MB limit that ROS can use is 4 MB (per card that is.....  or maybe better put.... 4 MB per CRU address.)  In fact since evidently you must load ROS in each card in your system then the max memory that ROS can use is 4 MB.  Assuming this is true does anyone know whether this is just ROS or has more sinister origins.

As an aside I am using the term "4 MB"  as an approximate.  It is slightly less in actuality.

And where the hell is Bud Mills when you need him ;-).  Really....... does any one know where the man is and whether or not he might chime in ?

--- On Tue, 2/7/12, epergrem <[email-masked]> wrote:

From: epergrem <[email-masked]>
Subject: [TI994A] Re: More HRD questions....
To: [email-masked]
Date: Tuesday, February 7, 2012, 7:10 AM

Hi Marc,
My memory may be faulty, but someone will correct me if it is.

Regarding the Phoenix mod; my understanding is that it splits the HRD, so that it will use two CRU addresses rather than one.

The mod came about because the Geneve, at least at one time, was limited by the size of RAM disk that it could boot from. Something like 800k? So, 800K or less got allocated to one CRU address, which could be used for booting and the remainder was allocated to the second CRU address, which wasn't confined to the 800K limit.

The mod wasn't necessary for the 99/4A, though I suppose it could be used to get around the 10 drive limit you referred to.

or at least that's how I recall it. ;-)

Ernie

--- In [email-masked], Marc Hull <marc.hull@...> wrote:

>
> 3)Â  What the hell does the Phoenix mod do ?Â  Is there any info about it ? Does it create another RD at a different CRU address or use other wizardry or am I confused as to it's function ?Â
>
> Now if some one has these particular answers then I would really appreciate being lined out before I step off a ledge in the dark or break something.....again Â  Â  ;-).
>
> Hull

---

From: Marc Hull <[email-masked]>
Date: Wed, 8 Feb 2012 16:16:22 -0800 (PST)

That's a good point Richard.  U11 is and was a 6264 but the storage ram was all 62256.  Isn't that way anymore but then the 512K's don't require a second mortgage these days ;-).

The whole point of this question series was to get a read on how big a single HRD 3000 RAM Disk could be.  It soon was amended to how big a single HRD 3000 RAM Disk with a single CRU address could be.

I think the answer is that a single RAM Disk at one CRU address and without any Bowser type modifications can be at least 12 MB in size.  ROS on the other hand is only capable of utilizing around 4 MB of this total so unless you have RAMBO installed then the rest is wasted.

If you get a chance would you run configure on your main system and post the data ?

Thanks RB...

--- On Wed, 2/8/12, [email-masked] <[email-masked]> wrote:

From: [email-masked] <[email-masked]>
Subject: Re: RE: [TI994A] Re: More HRD questions....
To: [email-masked]
Date: Wednesday, February 8, 2012, 4:15 PM

  

      Ummm..................just for giggles, Marcus, is your ROS chip a 6264 or a 62256? You have to keep in mind how expensive SRAM memory was back in the day. A board fully populated with 512k chips would cost in the neighborhood of $600 - $700 bucks on a good day.  On 02/08/12, Marc Hull<[email-masked]> wrote: 

Andrew......

 

  Hi Marc,

Ernie