Subject: Wanting to build a new PEB power supply

From: "gregallenwarner" <[email-masked]>
Date: Tue, 14 May 2013 15:47:12 -0000

Hello, all, I was just looking for some details about the PEB power supply, which I'm wanting to replace with a lighter-weight, more power efficient switching power supply.

I've read up on replacing it with an ATX PSU, by hooking the 12v lines to both the 8 and the 16v lines on the backplane, however, I'm sort of a perfectionist, and I was hoping to add boost and buck converters to the 12 volt rail of my ATX PSU to provide the actual 8 and 16 volts that the PEB expects. That way, my 5v regulators on all my cards aren't burning extra hot and the 12v regulators don't put out a lower voltage. Also, I don't want to modify any of my cards by bypassing the on-board regulators.

I know it's not expressly required, as many are successfully running with an ATX PSU 12v line hooked directly to both, but it's sort of a challenge to myself to do it the way I mentioned above with the buck/boost converters.

But I need to know what kind of amperage the PEB linear supply can provide on its 8, 16, and -16v rails, so I can select appropriate converters. Does anybody know where these values are listed? Anybody know how much amperage a fully loaded PEB will draw at any given time on those 3 rails?

Thanks,

-Greg W

---

From: Jeff White <[email-masked]>
Date: Tue, 14 May 2013 21:50:21 -0400

You probably want to read:

ftp://ftp.whtech.com/datasheets%20and%20manuals/Hardware/Texas%20Instruments/PHP1200%20Peripheral%20Expansion%20System/Peripheral%20Expansion%20System%20Theory%20Of%20Operation%20and%20Technical%20Traning%20Guide%201982-09-03.pdf

In there, you will find the recommendations for each card:

250 mA on +15V
500 mA on +8V
30 mA on -15V

So with 8 cards total:

2A on +15V
4A on +8V
240 mA on -15V

If you have a Geneve or HFDC, you could be pushing those per card limits.

Aside to Dano that Mike Bunyard wrote this document.

Jeff White

---

From: "gregallenwarner" <[email-masked]>
Date: Wed, 15 May 2013 13:45:05 -0000

Thank you! That's just the information I was looking for!

-Greg W

--- In [email-masked], Jeff White <ti994a@...> wrote:
> On 14 May 2013, at 11:47, "gregallenwarner" <gregallenwarner@...> wrote:
>