Subject: P-GRAM Help Needed

From: "computerclassics2000" <[email-masked]>
Date: Tue, 12 Jun 2012 17:33:33 -0000

I just decided to dust off my P-GRAM card, but can't get it to work. I put a new battery in it (the clock works) and set the CRU to >1700. I have a Horizon RAM Disk at >1000 (HRD 3000) and another one at >1400 (HRD 4000). 

I installed the DSR on DSKA and initialized the memory. However, I can't get anything to load, and the CALL PG, CALL PGON, CALL PGOFF and the CALL PGZAP don't work at all, stating "subprogram not found".

Any help would be appreciated.

BillG
06/12/2012

---

From: Tony Knerr <[email-masked]>
Date: Tue, 12 Jun 2012 17:11:07 -0400

Initialize memory (DSR space) first, then load DSR.

Use the version here:

ftp://ftp.whtech.com/utilities/Pgramy2k.ark

If still no joy, run the memory editor on the disk below with the EA 
cartridge:

ftp://ftp.whtech.com/utilities/MEMEDIT.DSK

It's the PGRAM memory editor in EA5 format.

Press F1 to set the CRU base & bits, make the values 1700 11.
Press F1 again to set the bits. Change the memory address to c4000.
Does it look like a DSR in the editor window? The first byte should be >AA.

It might be a good idea to reseat the chips if the card's been inactive 
for some time.
Let us know what you find.

Tony

On 6/12/2012 1:33 PM, computerclassics2000 wrote:
>
> I just decided to dust off my P-GRAM card, but can't get it to work. I 
> put a new battery in it (the clock works) and set the CRU to >1700. I 
> have a Horizon RAM Disk at >1000 (HRD 3000) and another one at >1400 
> (HRD 4000).
>
> I installed the DSR on DSKA and initialized the memory. However, I 
> can't get anything to load, and the CALL PG, CALL PGON, CALL PGOFF and 
> the CALL PGZAP don't work at all, stating "subprogram not found".
>

---

From: "computerclassics2000" <[email-masked]>
Date: Wed, 13 Jun 2012 14:04:10 -0000

Tony, I initialized the DSR per your instruction, and then used MEMEDIT to go see the results. 

After setting the DSR to 1700 11 I looked at c4000 at it was empty.

BillG

---

From: Tony Knerr <[email-masked]>
Date: Wed, 13 Jun 2012 17:20:43 -0400

Bill,

Were you successful in loading PGDSR & PGDSS after you initialized the 
memory space?
Normally one would get an error if they didn't load properly.

If the loading was successful,and you still have zeros in the DSR memory 
space,
try changing a value with the memory editor (after you've set the CRU 
bits, of course)
F9 toggles in and out of the editor window.

I forgot to mention that when you set the CRU bits (1700 11), the card 
led will remain on.
Is that the case? Does the change 'stick', or  does >00 replace the hex 
value you tried to change?

If the value 'sticks', chances are the card is ok and you're just doing 
something wrong in the
DSR loading procedure.
If it does not, there is most likely a hardware error with the card.

Tony