Subject: Wanted: Exceltec Extended Basic

From: "Eric" <[email-masked]>
Date: Mon, 04 Feb 2013 03:09:49 -0000

I am interested to purchase Exceltec Extended Basic Cartridge at negotiable price. I do have Exceltec Extended Basic manual. I have Paypal account to pay for this item include shipping cost.

---

From: "hexbus" <[email-masked]>
Date: Mon, 04 Feb 2013 04:23:44 -0000

Didn't Exceltec just use a clone of TI's V110 XB and slightly edit the manual?   I used to have a copy long ago, and it was pretty identical... even the cart board was a TI board inside.