Subject: Myarc FDC Issues

From: "epergrem" <[email-masked]>
Date: Tue, 10 Jul 2012 12:53:26 -0000

I'm having some issues one of my Myarc disk controller cards.  I reverted to the original 40-track EPROM to (hopefully) simplify the troubleshooting.  

When running the DMII Comprehensive Disk Test errors start appearing about sector 20.  I've tried both the drives and disks with my other Myarc card and it runs without error.  The tests are being ran as DSDD.

I successfully ran the drives and disks through DSSD tests using my TI controller.  So, it appears that neither the disks or drives are likely culprits.

Since the errors on my problem card appear in about the same place, on both DSK1 and DSK2 I'm thinking that it's definitely the card.  

So, where to begin?  BTW, It uses a WD1770 chip.

Thanks,
Ernie

---

From: ti99_forever <[email-masked]>
Date: Tue, 10 Jul 2012 10:06:04 -0700 (PDT)

What are the errors? The DMII has excellent error-reporting...
And, maybe it isn't the culprit, but is this the 16-sectors per track or the 18-sectors per track?

Ben

>________________________________
> From: epergrem <[email-masked]>
>To: [email-masked] 
>Sent: Tuesday, July 10, 2012 8:53 AM
>Subject: [TI994A] Myarc FDC Issues
> 
>------------------------------------
>
>Yahoo! Groups Links
>
>
>
>
>
>

---

From: "epergrem" <[email-masked]>
Date: Tue, 10 Jul 2012 17:08:20 -0000

To add to the discussion.

If it turns out to be a problem with the WD1770, then that becomes somewhat of an issue since WD1770 chips are a lot hard to find than the WD1772.  

However, according to the datasheet the differences between the two appears to only be the stepping rates that they deliver.  The WD1770 was meant to be compatible with the stepping rates of the FD1771 and has rates of 6, 12, 20, 30. The WD1772's rates are 2, 3, 5, 6.

I'm guessing that the 6ms & 20ms options in the 40-track EPROM and the 6ms rate in the 80-track EPROM are determined by the DSR.

Does anyone know if that's correct?  If correct, does anyone know how to change them so that a WD1772 compatible EPROM could be burnt?

Perhaps I'm overly simplifying it, but if possible it would give the ability to use the less expensive WD1772 in place of the WD1772.

Thanks,
Ernie

---

From: Tony Knerr <[email-masked]>
Date: Tue, 10 Jul 2012 17:02:13 -0400

Ernie,

Not over simplifying, over complicating.:-)

The 1772 is a plug in and go upgrade. One of my FDCs  had one and
one had the 1770. I didn't like the performance of the 1770, so I got a
1772 and plugged it in. Works like a champ. Both cards use the 80 track
eprom, IMHO it's much more reliable.

Tony

On 7/10/2012 1:08 PM, epergrem wrote:
> If it turns out to be a problem with the WD1770, then that becomes 
> somewhat of an issue since WD1770 chips are a lot hard to find than 
> the WD1772.
>
> However, according to the datasheet the differences between the two 
> appears to only be the stepping rates that they deliver. The WD1770 
> was meant to be compatible with the stepping rates of the FD1771 and 
> has rates of 6, 12, 20, 30. The WD1772's rates are 2, 3, 5, 6.
>
> I'm guessing that the 6ms & 20ms options in the 40-track EPROM and the 
> 6ms rate in the 80-track EPROM are determined by the DSR.
>
> Does anyone know if that's correct? If correct, does anyone know how 
> to change them so that a WD1772 compatible EPROM could be burnt?
>
> Perhaps I'm overly simplifying it, but if possible it would give the 
> ability to use the less expensive WD1772 in place of the WD1772.
>
> Thanks,
> Ernie
>

---

From: "epergrem" <[email-masked]>
Date: Wed, 11 Jul 2012 00:14:14 -0000

Ben,

To simplify testing and to eliminate the 16/18 sector issue I used SSSD as the test parameter.  

Also the disks and drives had completed several DMII tests using a TI controller, with zero errors reported.  Each drive used a different floppy disk.

The Myarc controller has the version F03C DSR, which should be 40-track.  All DIP switches are set to 6 ms.

On DSK1 & DSK2, the DMII Comprehensive/Destructive tests #1 to #4 ran without error, then came test #5 and #6

DSK1 : Completed Pass 1 Total Errors: 22  (#5:9, #6:13)
DSK2 : Completed Pass 1 Total Errors: 31  (#5:12, #6:19)

All of these were represented as BAD ADDRESS/CODE  xxx/xx.  The field in both #5 tests were 32 (e.g. 5/32, 33/32, etc.)  The second field for both #6 tests were either 32 or 99 (e.g. 34/32, 34/99, etc.).

In all cases the number sets that appeared on the DSK1 printout were also listed on the DSK2 printout, although DSK2 had some additional errors.

Not sure if any of that helps.. :-)

Ernie

---

From: "epergrem" <[email-masked]>
Date: Wed, 11 Jul 2012 00:15:20 -0000

Thanks Tony,

I doubt the WD chip is the issue, but it's nice to know that a cheaper replacement is available in a pinch.

Ernie

---

From: ti99_forever <[email-masked]>
Date: Tue, 10 Jul 2012 21:37:19 -0700 (PDT)

Interesting. Those are the two seek tests...I wonder if it has anything to do with the headstep you mentioned...

>Sent: Tuesday, July 10, 2012 8:14 PM
>Subject: [TI994A] Re: Myarc FDC Issues
> 
>Ben,
>