Subject: Da Fair

From: [email-masked]
Date: Wed, 31 Oct 2012 07:03:57 -0500 (CDT)

Hi All, Afraid I won't make it to Chicago this year. I'm on third day with the generator and no word yet on when the power company thinks we'll be back up. We were spared water damage in my area but we had tremendous tree damage from the wind. I had a small patch of roofing and a couple of pieces of white aluminum trim blown off my house but some nieghbors did much worse. It will take me a month to clean the broken trees/limbs out of the back yard.

Hope everyone enjoys "Da Fair" and I'm looking forward to attending next year.

Richard Bell

---

From: "Dont" <[email-masked]>
Date: Wed, 31 Oct 2012 21:38:42 -0000

Richard, I'm really sorry to hear that you have so much damage.  Hope you get your power back on soon.  We'll miss you at the Faire.  --Hal