Subject: Re: [TI-99/4A] chip programmer

From: Jeff White <[email-masked]>
Date: Tue, 16 Apr 2013 21:42:56 -0400

Sorry for the blind crosspost, but Owen is back and we are talking chip programmers there, too.

Tim, it appears that my Pocket Programmer will handle the Atmel 29C040.  I installed the latest software on my regular-use PC, but since it does not have an lpt1 port I cannot use the PP.

However, I found the win_PP2.txt (a "readme" file) interesting.  Here I quote:

"6. When Programming a Atmel 29CXXX device, DO NOT move the mouse as this will interrupt the programming process and not allow the device to program....

2.08 - Adjusted Program Timer Delay, Fixed AT29CXXX, Found No Problem w/27SF512...."

The only warning about mouse movement is for the Atmel 29CXXX chips.  Apparently it took awhile to get the Atmel EEPROM programming right.

My recommendation is stay away from these Atmel chips.

However, if you want me to try to program some, I have my Win98 box with lpt1 port close to ready.  Just need to sneakernet the software to it, since for some reason I pulled it off the network or never put it on it -- it was dialup-only.

Jeff White

On 13 Apr 2013, at 16:46, Insane Multitasker <[email-masked]> wrote:

> I have a GQ-4X programmer and recently discovered it won't properly program flash eproms such as the Atmel 29C040 or 29C040A.  
>  
> I have been trying to get an answer from the manufacturer with no luck.  
>  
> Does someone here have a programmer that allegedly supports the 29c040 that would be willing to test burning an image if I send a chip?
>  
> Richard Bell has a different programmer but like me, his won't program the chips properly.  For all I know they have a similar code base.   (grrr)
>  
> thanks
>

---

From: Jeff White <[email-masked]>
Date: Fri, 19 Apr 2013 21:14:00 -0400

I suppose it is bad form to reply to oneself.  WTH.

Sneakernet did not work.  I could not find my USB floppy drive to copy the Pocket Programmer software from my regular PC for the Win98 system.  So I pulled out a USB thumb drive to format on the Win98 box, but though it saw USB Disk it could not find a driver.

Tonight I located the NIC for the Win98 box.  I relocated my modem, WiFi router, and phone to the classic computer room, and the NIC would not pull an address, though it was "working properly".  Driver disk did not help.

Starting looking at the DeskNote USB Link Bridge Cable.  This is a USB-to-USB crosslink network connection cable.  Have the Win98 and Win2K drivers on CD, but not a Win2K computer.

Located another ethernet cable and the Win98 box pulls an address from the router.

Get the software from the xtronics.com webpage, install it and the Pocket Programmer, and every looks to work.  Was able to read a 2532 which was handy.

Guess I am ready to try the Atmel 29C040 with it, Tim.

Jeff White

> However, if you want me to try to program some, I have my Win98 box with lpt1 port close to ready.  Just need to sneakernet the software to it, since for some reason I pulled it off the network or…
<snip>

---

From: Tony Knerr <[email-masked]>
Date: Sat, 20 Apr 2013 04:51:21 -0400

Hi Jeff.

I've attached a photo of the pocket programmer model I formally owned.
It was the parallel port version. I can verify that it will properly program
an at29c040 chip, as I did so many times while experimenting with my 
HSGPL card.

Tony

On 4/19/2013 9:14 PM, Jeff White wrote:
> Sneakernet did not work.  I could not find my USB floppy drive to copy 
> the Pocket Programmer software from my regular PC for the Win98 
> system.  So I pulled out a USB thumb drive to format on the Win98 box, 
> but though it saw USB Disk it could not find a driver.
>
> Tonight I located the NIC for the Win98 box.  I relocated my modem, 
> WiFi router, and phone to the classic computer room, and the NIC would 
> not pull an address, though it was "working properly".  Driver disk 
> did not help.
>
> Starting looking at the DeskNote USB Link Bridge Cable.  This is a 
> USB-to-USB crosslink network connection cable.  Have the Win98 and 
> Win2K drivers on CD, but not a Win2K computer.
>
> Get the software from the xtronics.com <http://xtronics.com> webpage, 
> install it and the Pocket Programmer, and every looks to work.  Was 
> able to read a 2532 which was handy.
>
> On 16 Apr 2013, at 21:42, Jeff White <[email-masked] 
> <mailto:[email-masked]>> wrote:
>> Tim, it appears that my Pocket Programmer will handle the Atmel 
>> 29C040.  I installed the latest software on my regular-use PC, but 
>> since it does not have an lpt1 port I cannot use the PP.
>>
>> "6. When Programming a Atmel 29CXXX device, DO NOT move the mouse as 
>> this will interrupt the programming process and not allow the device 
>> to program....
>>
>> The only warning about mouse movement is for the Atmel 29CXXX chips. 
>>  Apparently it took awhile to get the Atmel EEPROM programming right.
>>
>> However, if you want me to try to program some, I have my Win98 box 
>> with lpt1 port close to ready.  Just need to sneakernet the software 
>> to it, since for some reason I pulled it off the network or never put 
>> it on it -- it was dialup-only.
> <snip>
> _

---

From: Jeff White <[email-masked]>
Date: Sat, 20 Apr 2013 08:31:16 -0400

Hello, Tony.

I have the original parallel port model of the Pocket Programmer in a black plastic case.  It sports the 32-pin ZIF socket like the model you had, and latest software seems to recognize it just fine.

Not sure if there are functional differences or limitations, as the web is majorly silent on my model.

Jeff White

On 20 Apr 2013, at 04:51, Tony Knerr <[email-masked]> wrote:

> [Attachment(s) from Tony Knerr included below]
> Hi Jeff.
> 
> an at29c040 chip, as I did so many times while experimenting with my HSGPL card. 
> 
> 
> Tony
<snip>

---

From: "Harald Glaab" <[email-masked]>
Date: Sat, 20 Apr 2013 14:17:04 -0000

If you own a ASCSI you can program a AT29C040 also.

Set the DIP switches according the manual to CRU >0700
Split the file in pieces of 8 kBytes and add a 10 Word-header as described in the manual of the DSRLDR3.

Start DSRLDR3 and press FCTN-N for Emergency-Loader, load the first file and do the programming.

I did so to program my telephone PABX Firmware.

You find the manuals at the snug homepage: http://home.arcor.de/system-ninety-nine-user-group there is an english section, too

Harald