Subject: Chicago TI International World Faire report

From: "Dont" <[email-masked]>
Date: Fri, 02 Dec 2011 18:52:31 -0000

The 29th edition of the Chicago TI International World Faire took place on November 4, 5, and 6, 2011, in Evanston, Illinois.  Those who attended judged it to be a success, and many are looking forward to the next one in 2012.
This year we were pleased to entertain more visitors from abroad than in most recent Faires.  Berry Harmsen, from Holland, Klaus Lukaschek, from Austria, Jens-Eike Hartwig, from Germany, and Mark Wills, from Scotland, gave the Faire a truly international flavor this year.  While Berry and Jens-Eike have been frequent attendees, for Klaus and Mark this was their first time here, but hopefully not their last.
The usual Friday night gathering started in Tommy Nevin's Pub, where a dozen or more et for dinner and drinks.  From there we went across the street to the Best Western Hotel, where many TI'ers chose to stay this year.  We went up to Matthew Hagerty's room for a peek at his TI with a F18A chip, running TurboForth.

Insert Matthew's report

Early the next morning, a group of us met for breakfast at the Burger King down the street from the Evanston Public Library, where the Faire has been held for many years.  At 9 a.m. the doors to the library opened and we were able to move in.  After a quick set-up, the seminars began.  As is traditional, Berry Harmsen led off with an overview of the TI scene in Europe.  This year I have asked each of the speakers to write a summary of their remarks, so here, in his own words is Berry's report:

TI IN EUROPE
I opened the series of seminars with a report of the European TI meetings of this year. I showed photos of these events.
 
The first venue was the spring meeting of the German TI Club Errorfree in Birkenau on April 3rd. Visitors I mentioned were Fred Kaal, Michael Zapf, Filip van Vooren and Harald Glaab. With more then 25 visitors this meeting was a great success.
 
On the 7th of June I visited the monthly meeting of the new Austrian TI Group. The meeting took place in Restaurant Napoleon in Vienna. The chairman of this group, Klaus Lukaschek, was present at the Chicago Faire to tell the visitors all about it.
 
The third meeting of mine was a workshop in Kirkby near Nottingham on August 6. In the Festival Hall of Kirkby Mark Robert Wills demonstrated his new module, TurboForth. As a surprise we were informed by pictures about the progress of the new Geneve 2 (Phoenix) computer with FPGA chips. Mark was also present at the Chicago Faire for a seminar.
 
The European TI groups decided to organize the 26th European TI Treff in Rome on October 1st. The Italian TI user Ermanno Betori was the man in charge. I was surprised about the number of Italian TI users that came to Hotel Jonico in Rome. The TI-er Ciro Barile was present to promote the new Italian TI users group.
 
The next TI Treffen will take place in the city of Augsburg (Bavaria). Oliver Arnold (Email: [email-masked]) will organize a four-day event from September 27 till September 30, 2012 with a lot of TI computing, and also a trip to 'das Oktoberfest' in Munich. We will stay in Guesthouse 'The Living Cube' in the center of Augsburg. More information will follow soon."  
 
Berry wished all visitors a pleasant and instructive Faire and said (in Dutch): 
HET IS TIJD VOOR EEN TI-99/4A (It is time for a TI-99/4A)

Klaus Lukaschek then took a few moments to tell us about the rebirth of the Austrian TI User Group.  Here is his report:

"Klaus Lukaschek was coming all the way from Vienna, Austria. There was no club activity in Austria for a long time, and since he and his brother Reinhard really enjoy using their TI-99, they wanted to change that. He is researching for old 99ers, tries to get in contact with them, tries to get them back into the TI, which is not easy if the computer is over 30 years old. The group held their first meeting in January 2011 and is meeting once a month. So far they are around 15 people, with an average of 8 people coming to the monthly meetings."

Jon Guidry was the next presenter, and had an elaborate PowerPoint presentation.  He includes details on how to view it online in his report:

"For my presentation, I demonstrated a floppy drive replacement for the TI - the HxC Floppy emulator.  

Background:

The HxC floppy emulator started out as a project in 2006 by Jean-François Del Nero (Jeff) to replace the a standard floppy drive (5.25" or 3.5") by emulating it in hardware.  His first HxC emulator was a USB version that was "slaved" from a PC - the PC was the peripheral that presented the disks to the target system.  Jeff later released a SDCard version that is stand-alone and lets the user store all of their floppy images on a SD card.  I own both versions.

The HxC supports a large variety of computers, music keyboards, CNC systems, etc.  You can also get it to work with other computers that used floppies - i.e. Amiga, Atari XT, PC-XTs, our TI, etc.  If it has a standard 34 pin floppy drive connector, you can likely hook the HxC to it!  

On the TI, the HxC supports HD, DD, and SD (MFM and FM) formats.  You can use it with the PEB controllers (TI Floppy Controller, Corcomp controller, Myarc controller, BwG controller) as well as sidecar controllers (TI sidecar floppy controller, Corcomp 9900 Mini Peripheral Expansion system, etc.)  You can make the HxC respond to DSK1-DSK4 (depending on your controller).  

Note that this article assumes that you already have TI disk images in PC99 or V9T9 format.  If you do not, you will need to obtain the proper programs to migrate your physical TI floppy collection from physical media to disk images.  Two sets of programs that I like are RSECTOR/WSECTOR that come with PC99 (http://www.cadd99.com) and Omniflop (http://www.shlock.co.uk/Utils/OmniFlop/OmniFlop.htm).  It is left up to the reader of this article to figure out how these programs work and transfer their physical disks to disk images.

USB Version:

The USB HxC can directly load the following TI disk images and present them to the TI:  PC99 disk images (both FMT21 and FMT22 disks (ftp://whtech.com/emulators/pc99/fmt21-22.txt) as well as V9T9 disk images (90K/180K/360K)
The USB version does not have any support for write mode, and there is no support (of which I'm aware) for HD images.  You simply hook the USB version up to a Windows 98/ME/2000/XP/Vista/7 system, load the HxC Floppy Emulator program, and present the disk (again, PC99 or V9T9).  The TI thinks a real disk has been given to it on the assigned drive you configure inside the HxC Floppy Emulator program (DSK1-DSK4).

SDCard Version:

The SDCard HxC is a standalone unit!  Therefore, unlike the USB version, you do not need a PC "slaved" to it to make it work.  All the floppy images are held on a SDHC card, which can be up to 32GB.  This unit has three buttons and a LCD screen that assist you in selecting floppy disk images from the SD Card.  A speaker also is present; it gives feedback when the disk is read as well as when the front buttons are pressed.  It has full read/write support for floppy images, and you can mix and match floppy images from different platforms on the SD Card if you choose to move the unit around between systems.

Unlike the USB HxC, the SDCard HxC does not support reading PC99 and V9T9 disk images directly.  Rather, the user needs to use the HxC Floppy Emulator program and batch convert the PC99 and V9T9 images to the HxC's native "HFE" format.  Once this is done, you can copy the disk images to the SD Card (FAT32 formatted) in whatever directory tree structure you like; this how the LCD on the SDCard HxC allows you to pick your images.

Purchasing:

You can purchase these units from Lotharek's web site: http://www.lotharek.pl/ ; he also sells the units on eBay (search for "SD floppy emulator" or seller lortharek1977).  With current exchange rates, the price hovers around $110 plus shipping.

Links:

Here are some links related to the HxC that might be helpful when researching it or once you have purchased one and have questions:

The 2011 Chicago Faire HxC Presentation in PDF format:  http://dl.dropbox.com/u/19597743/ti-99%3A4a/HxC_Presentation.pdf
HxC information and downloads: http://hxc2001.free.fr/floppy_drive_emulator/
Support forums: http://torlus.com/floppy/forum/index.php
Systems supported: http://hxc2001.free.fr/floppy_drive_emulator/support.htm
Jeff's e-mail address: http://hxc2001.free.fr/imiel.htm
For my presentation, I demonstrated a floppy drive replacement for the TI - the HxC Floppy emulator. " 

Between presentations, attendees at the Faire had the opportunity to walk around and visit the tables that lined the walls of the community room of the Library.  Especially interesting was Bud Mills' table.  Bud and his lovely wife brought several tables-full of TI gear, and gave it away.  Hard-to-find items, command modules, disk drives, and notebooks full of software were just a few of the numerous things on the tables that he donated to the participants.  Many left with complete systems.  

After a break for lunch, the presentations continued.  Ernie Pergrem led off with a demo of Marc Hull's SidBlaster card.  Here's Ernie's description:

"I did a demonstration of the SID Play 99 software for Marc Hull's SID Master 99.  Both the fully constructed and bare SID Master 99 boards were available for purchase at the faire.  The SID Master 99 uses the SID (Sound Interface Device) from the Commodore's CBM-II, 64, 128 and Commodore MAX Machine line of home computers.  Using the SID Play 99 software the card, which fits neatly in the expansion system, can play over 8,000 freely down-loadable music files converted for use by the TI-99/4A.  More information about the card, software, music files and links to demonstrations on YouTube can be found at Marc Hull's web site http://www.dsapsc.com/index.html ."

Berry Harmsen returned for another presentation, this time about a slightly different computer, with links to the TI, as you will see, in his report:

CORTEX BASIC
"I gave information about a home computer from 1982: the Powertran Cortex. The computer, sold as a self to be build kit, was designed by a few Texas Instruments engineers and totally based on TI technology. It had a TMS9995 as CPU processor and a TMS9928 as VDP processor. All the information and software concerning the Cortex can be found on the site: http://powertrancortex.com/ There is also an emulator to use on a PC. Cortex Basic will load when you start the emulation program.
 
I showed the Basic of the Cortex with a small program, running on the Cortex emulator. At the same time I ran that program on the Win994a simulator. The difference in speed was clear in favour of the Cortex. Jens-Eike Hartwig from Flensburg (Germany) had also made tests with the Cortex Basic. He could run Cortex Basic on a real TI-99/4A with a version of that program, adjusted by Stuart Connor. Jens came to the same conclusion: Cortex Basic is much faster than EX and TI Basic. The site of Stuart Connor can be found on http://www.avjd51.dsl.pipex.com/ti/ti.htm
 
The manual of Cortex Basic is available on that site and is totally corrected and retyped by Jim Fetzner. We will soon hear more of this interesting old/new and fast Basic language for our computer."

Gregg Lemke, of Emkelsoft, then gave us a demonstration of two of his programs, but I'll let him tell you about it:

   "I introduced, Ekmel Fish Tank 5.0 with the new shark tank option.    The shark tank features great white sharks and divers in a tank swimming.   I indicated last year for this format – going to a new format next year for program is too big to add on to.  I also showed a reissue of the popular game – The hunt for Bigfoot.   This is a text adventure/ puzzle game with a graphic ending.    Ekmelsoft also introduced their new software boxes at the Faire, moving to a more professional look." 
 
What Gregg modestly forgot to mention was that he donated copies of his programs as door prizes, and they were given out at the banquet. 

Walid Maalouli next showed us a project that was still a work-in-progress at the time of the Faire.  Although I am not a gamer like a lot of you, this was one thing I am really looking forward to seeing in its completed form.  But let's hear from Walid about it:

"I gave a short demonstration of the beta version of my upcoming XB game called Clear for Action, which is a simulation of naval combat in the age of sail and based on an original game concept by Michael W. Stradley for Avalon Hill in 1984. You assume the role of a captain of one of the great sail battleships of old and face off a computer opponent, using either one of the eight built in historical scenarios or a custom designed one of your own, and attempt to win the day through superior seamanship, tactics, and crew management. The game attempts to closely simulate many of the mechanics of these sea battles, from historically accurate gun ballistics to ship classes to sailing mechanics to crew management, with even grappling, fouling and boarding action, and the computer AI will give you no quarters! As a result, the game has ballooned to over 700 lines of code, thus necessitating dividing it into 3 separate but chained programs. While the game is mostly complete as of now, there are still a number of bugs present, along with the non-trivial challenge of reducing the load time of the chained programs as they call each other. I hope to be able to release it to the public domain by the end of 2011 along with a detailed manual, and that it will live up to its expectations."

As I said, I am waiting with `bated breath.  

For many of our visitors, the most intriguing part of the Faire was yet to come, and that was the demo that Mark Wills presented, namely TurboForth.  Mark showed us that all the hard work he had put into writing it really paid off.  If you missed his presentation, you will just have to come next time and ask him to do another.  This is what he wrote:

This year I had the pleasure of visiting the Chicago TI-99/4A Faire, in Evanston, Illinois. This was the first TI meeting on foreign soil for me, and indeed my first visit to the United States. For me, the reason to attend, apart from the opportunity to demonstrate TurboForth, was to finally, after all these years meet the TI people and personalities that I have come to call friends. It really was great to meet my TI hero's: Tursi, Matt Hagerty, Waalid Maloui, Tim Tesch, Hal, and my good friend Bob Carmany, who has been the driving force behind the development of TurboForth. In terms of 'TI Stuff', the highlight for me was seeing the F18A video chip in action. I actually got to bring an F18A home with me and will fitting it to my console this weekend with a view to writing some TurboForth code to target the chip!

I'm sure that most people would agree, a few years back, the TI community was in the doldrums. I don't think that is the case any more. Interest in the TI is gaining momentum; indeed new users appeared at the Faire, and were of course made welcome. New hardware and software and software is constantly in development, and the community is in good spirits and in constant communication via the mailing lists, Atariage, Facebook, Skype and good old fashioned email. There is plenty to feel good about with respect to our favourite hobby computer!

To people that are thinking about attending the Faire and haven't yet done so - please do attend. You won't regret it. Not only will you have a lot of fun (we had great fun on the Friday evening before the Faire, and laughed our heads off over a few beers) you'll actually get to meet the people you've been corresponding with over the years, and cement relationships. It was an expensive trip for me to come from the UK, but worth every penny.  If I can do it, you can do it too!

Finally, I'd like to thank Hal not only for arranging the Faire, but for ferrying us foreigners to and from the airport - he was back and forward constantly making sure people were collected and taken back to the airport - he does this out of the goodness of his heart, and would not even take money for fuel. Thank you Hal for your service to the TI community - this travel weary TIer is truly grateful for your help, and very happy to meet you."

Thus ended the formal presentations at the Faire, but there was still a lot of things left to do.  We packed up our computers, shut down our Ustreamtv live feeds, gathered up all our new goodies, and headed down the street for the Faire Banquet, at the room we reserved at the local Panera restaurant.  Shortly after we ate, the part of the Faire that I look forward to each year took place.  It has been my privilege to present the John Birdwell Award.  This is given to someone whom the John Birdwell Trustees select as being most noteworthy in the TI community.  This is considered the oldest and most prestigious honor in the TI community.  The recipient this year was Paolo Bagnaresi, from Milan, Italy.  All those of us who have known Paolo and his many and ongoing contributions to this community are pleased that he has been chosen for this award. 

That more or less ended my labors for the evening, because I was able to turn the banquet over to Berry for our final action.  We'll let him tell you about it:

"The last item of the Chicago TI International World Faire of 2011 was the judging for the 2011 Rob Tempelmans Plat Award, an initiative of the Dutch TI User Group (TIGG) and the Chicago TI User Group (CTIUG) to honour the designer of the best website devoted to the TI. A jury of twelve Faire visitors reviewed the sites and gave marks for the main aspect of the sites. The differences were very small but one website was the clear winner of the RTP Award of this year. The designer of the website`TI-99/4A Home Computer Book Archive' Ernest Pergrem, was chosen for the Rob Tempelmans Plat Award of this year. The site is on URL:  http://pergrem.com/tibooks/ Ernie was congratulated for the Award and thanked for his work to support the TI community by all TI-ers in the room."
 
That was it for all the scheduled activities of the Faire, but before I describe the famous (or infamous) Pub Crawl, I just want to take a few moments to offer some thanks to a lot of people who richly deserve it.  Let's begin with Vic Steerup, President of the CTIUG, and the guy who brings all the TI gear and software to every CTIUG monthly meeting and show.  Next Al Antonowitz, our membership chairman, who sits all day greeting new arrivals at the Faire.  Right beside him is found our treasurer, Irv Levinson, who brings all those delicious doughnuts. Thanks, too, to Bud Mills this year for the immense amount of stuff he brought and donated.  Special thanks to my son, John Shanafield, who set up and maintained the live show on Ustreamtv.com, on which the whole show and all the demos can be seen.  Thanks to my long-suffering wife, Almut, who puts up with me as I go a little bananas each year around Faire time.  And, of course, thanks to all our international guests, our presenters, and to all the folks who come from all over to Evanston each year to share themselves with all of us, and show us that the Chicago TI International World Faire is still worth doing.

Now, if the kiddies are out of the room, we can talk about the Pub Crawl.  Actually, this year the visits to our local watering holes were both more restrained and more stretched out.  Although we didn't try to drink Evanston dry on Saturday night, we gave it another shot on Sunday night.  Some of us made it last even longer than that.  We ended up back at Tommy Nevin's thirty hours after the Faire closed, but you'll have to supply your own details.  My lips are sealed…  I will say, however, that we are looking forward to next year's Faire, which will take place on November 3, 2012, right here in Evanston, and we hope that everyone reading this will come.  `Til then, keep on TI'ing!

                                                                                           --Hal Shanafield

---

From: Tony Knerr <[email-masked]>
Date: Fri, 02 Dec 2011 20:52:27 -0500

Ok, gang. Here's a new up-to-date whtech.com torrent. My plan is to 
update this every few months and make it easy on everyone to keep their
whtech.com files up to date with as little as effort as possible.

I have a way to sync my fileset according to filename date and time, and 
can add new files to the set relatively easily without disturbing the 
existing files. So an updated torrent will only require the user to 
point the torrent file at his existing fileset, which would check the 
set and only download the newer files.

My plan is to do this every few months as additions to the website 
warrant. That way, everyone can have a complete set of all the TI 
software anyone may want at their fingertips. I encourage anyone 
possessing anything not yet on the whtech site to upload it there, so we 
can all share in preserving our shared history in knowledge in as many 
places as possible.

Here we go, file is attached to this message.

Tony

---

From: Tony Knerr <[email-masked]>
Date: Sat, 10 Dec 2011 07:30:36 -0500

Is everyone finished downloading this torrent that wants it?
If so, we seeders can stop seeding 'till next time.

I'll wait a few days for someone to shout "I'm not done!"

:)

Tony

---

From: "hexbus" <[email-masked]>
Date: Sun, 11 Dec 2011 18:20:31 -0000

I'm still downloading it... has about 1 day 5 hours left :)

Jon