Subject: 2017 Jim Peterson Hardware Achievement Award

From: [email-masked]
Date: Thu, 1 Jun 2017 19:45:41 -0400

I need the land mail address or E-mail address for  Ralph Benzinger in 
order for me to be able to send him his 2017 Jim Peterson  Hardware Achievement 
Award certificate.
Glenn Bernasek, Administrator
Jim Peterson Achievement Awards
[email-masked]

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 18 Jun 2017 00:55:11 +0000

I've thought about this for a while now and have decided, like others, that it is time for me to unsubscribe from the TI994A and TI99-4A Yahoo groups.  If you need to reach me, please PM me via AtariAge, or via the AtariAge TI forums, or via direct email.

I haven't yet decided how I will handle the now-dormant Geneve Yahoo group. I will post to that group when it is appropriate.

Tim  (insane_m 'at' Hotmail.com)