Subject: Re: [TI994A] Re: CF2K - Does ANYONE have a WORKING copy?

From: [email-masked]
Date: Sat, 6 Jul 2013 20:14:50 -0400 (EDT)

Anything that uses the extended VDP addressed by a 9938/9958, or has a 9938 
 "sense" built in, will not work properly with the F18A - there are more 
than 5  of them. Besides, one of the reasons I got an AVPC card in the first 
place was  to be able to use the extended VDP space. I don't want to give up 
that  functionality if I don't have to do so. The expanded text buffers in 
F'WEB are  extremely valuable both for storage of long D/V 80 files and 
cutting and pasting  between for both text and source code. The fact is, I was 
all set to buy a F18A  until Matt told me that it only addressed 16K of VDP. 
Maybe if another  version comes out . . .
 
As far as transferring programs between systems, TI99DIR works great when  
paired with PC-Transfer. Incidentally, PC-Transfer works just fine on 720K  
3-1/2" disks even if the author only wrote it for 360K disks. You can format 
 720K disks on Windows XP quite nicely.
 
I find that my 3 meg HRD and twin 40 meg hard drives hold significantly  
more programs than I ever use on a regular basis. I never have seen the need 
for  "super" storage devices like the nanopeb. It becomes difficult to fill 
them with  meaningful programs. My current project is to convert my entire 
library to  archived files from my 3-1/2" disks that I can save on a DVD and 
load them  back to the TI with TI99DIR should I ever need to do so.   
 
The question then becomes - why should I spend money on something that  
causes me to lose functionality or doesn't have a currently compatible  DSR?  
 
Bob Carmany

In a message dated 7/6/2013 5:44:24 P.M. Eastern Daylight Time,  
[email-masked] writes:

actually it's quite useful, once things are updated for  his changes it 
will be an excellent HDX device, in addition to my f18  installed machine which 
is also quite usable other than what..5 programs that  use a 9938 80 col 
mode don't work.. the rest work great..    

Not sure why your so upset, or maybe it's the wording of your  message.

Greg

---

From: [email-masked]
Date: Sun, 7 Jul 2013 01:12:04 +0000 (UTC)

I have to agree, though the F18 is really cool and new I do not see the point of a new device that is not compatible with the best software the TI has ever seen. 
i.e. Funnelweb, Telco (useless today), Y.A.P.P. (TI Artist on steroids) , XHI (Missing Link upgrade), X80 a 80 column Editor just to name a few. 
I really miss my TIM card. 

Rich 

----- Original Message -----
From: [email-masked] 
To: [email-masked] 
Sent: Saturday, July 6, 2013 5:14:50 PM 
Subject: Re: [TI994A] Re: CF2K - Does ANYONE have a WORKING copy? 

Anything that uses the extended VDP addressed by a 9938/9958, or has a 9938 "sense" built in, will not work properly with the F18A - there are more than 5 of them. Besides, one of the reasons I got an AVPC card in the first place was to be able to use the extended VDP space. I don't want to give up that functionality if I don't have to do so. The expanded text buffers in F'WEB are extremely valuable both for storage of long D/V 80 files and cutting and pasting between for both text and source code. The fact is, I was all set to buy a F18A until Matt told me that it only addressed 16K of VDP. Maybe if another version comes out . . . 

As far as transferring programs between systems, TI99DIR works great when paired with PC-Transfer. Incidentally, PC-Transfer works just fine on 720K 3-1/2" disks even if the author only wrote it for 360K disks. You can format 720K disks on Windows XP quite nicely. 

I find that my 3 meg HRD and twin 40 meg hard drives hold significantly more programs than I ever use on a regular basis. I never have seen the need for "super" storage devices like the nanopeb. It becomes difficult to fill them with meaningful programs. My current project is to convert my entire library to archived files from my 3-1/2" disks that I can save on a DVD and load them back to the TI with TI99DIR should I ever need to do so. 

The question then becomes - why should I spend money on something that causes me to lose functionality or doesn't have a currently compatible DSR? 

Bob Carmany 

In a message dated 7/6/2013 5:44:24 P.M. Eastern Daylight Time, [email-masked] writes: 

actually it's quite useful, once things are updated for his changes it will be an excellent HDX device, in addition to my f18 installed machine which is also quite usable other than what..5 programs that use a 9938 80 col mode don't work.. the rest work great.. 

Greg

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 6 Jul 2013 21:38:21 -0500

I think you guys are missing the real point of the F18A which is to provide display compatibility with VGA/LCD monitors.  The 80 column feature was added as a bonus, never touted as a replacement for the V9938 or V9958 in the various 80-column devices. 

Bob, I had not seen anyone mention the 9938 "sense" problem.  That may be something Matthew would want to know about, if he doesn't already.  My programs generally look for the extra RAM and if they don't find it, they abort or revert to 40 columns.  I'm not sure how other programs are sensing the chip type.

To: [email-masked]
From: [email-masked]
Date: Sun, 7 Jul 2013 01:12:04 +0000
Subject: Re: [TI994A] Re: CF2K - Does ANYONE have a WORKING copy?

Rich

From: [email-masked]

 

Bob Carmany

Greg

---

From: Gregory McGill <[email-masked]>
Date: Sat, 6 Jul 2013 20:18:37 -0700

Yes..exactly. The f18a at 78 bucks..  is not a TIM nor a 80 col card.. its
a vga vdp that does some 80 col stuff

Greg

On Sat, Jul 6, 2013 at 7:38 PM, Insane Multitasker <[email-masked]>wrote:

> **
>
>
> I think you guys are missing the real point of the F18A which is to
> provide display compatibility with VGA/LCD monitors.  The 80 column
> feature was added as a bonus, never touted as a replacement for the V9938
> or V9958 in the various 80-column devices.
>
> Bob, I had not seen anyone mention the 9938 "sense" problem.  That may be
> something Matthew would want to know about, if he doesn't already.  My
> programs generally look for the extra RAM and if they don't find it, they
> abort or revert to 40 columns.  I'm not sure how other programs are sensing
> the chip type.
>
>
>
>  ------------------------------
> I have to agree, though the F18 is really cool and new I do not see the
> point of a new device that is not compatible with the best software the TI
> has ever seen.
> i.e. Funnelweb, Telco (useless today), Y.A.P.P. (TI Artist on steroids) ,
> XHI (Missing Link upgrade), X80 a 80 column Editor just to name a few.
> ------------------------------
> *From: [email-masked]
> *To: [email-masked]
> *Sent: *Saturday, July 6, 2013 5:14:50 PM
> *Subject: *Re: [TI994A] Re: CF2K - Does ANYONE have a WORKING copy?
>
>
>
> Anything that uses the extended VDP addressed by a 9938/9958, or has a
> 9938 "sense" built in, will not work properly with the F18A - there are
> more than 5 of them. Besides, one of the reasons I got an AVPC card in the
> first place was to be able to use the extended VDP space. I don't want to
> give up that functionality if I don't have to do so. The expanded text
> buffers in F'WEB are extremely valuable both for storage of long D/V 80
> files and cutting and pasting between for both text and source code. The
> fact is, I was all set to buy a F18A until Matt told me that it only
> addressed 16K of VDP. Maybe if another version comes out . . .
>
> 3-1/2" disks even if the author only wrote it for 360K disks. You can
> format 720K disks on Windows XP quite nicely.
>
> more programs than I ever use on a regular basis. I never have seen the
> need for "super" storage devices like the nanopeb. It becomes difficult to
> fill them with meaningful programs. My current project is to convert my
> entire library to archived files from my 3-1/2" disks that I can save on a
> DVD and load them back to the TI with TI99DIR should I ever need to do so.
>
>
> *Bob Carmany
> *
>  *In a message dated 7/6/2013 5:44:24 P.M. Eastern Daylight Time,
> [email-masked] writes:*
>
>
>
> *actually it's quite useful, once things are updated for his changes it
> will be an excellent HDX device, in addition to my f18 installed machine
> which is also quite usable other than what..5 programs that use a 9938 80
> col mode don't work.. the rest work great..   *
>
> *Not sure why your so upset, or maybe it's the wording of your message.*
> *
> *
> *Greg*
> *
> *
>
>
>
>
>
>
>
>   
>

---

From: "Michael Zapf" <[email-masked]>
Date: Sun, 07 Jul 2013 09:47:21 -0000

Hi Tim,

> My programs generally look for the extra RAM and if they don't find 
> it, they abort or revert to 40 columns.  I'm not sure how other 
> programs are sensing the chip type.

you can read VDP status register 4 and check its value to be 0xfe or 0xff.

The chips from the TMS 9918 family only have a single status register, so they will ignore the attempt to select a different status register (via control register 15), returning the default status register, which can only be fe or ff when there is a vertical scan interrupt plus five sprites in a row plus two sprites are colliding plus the fifth sprite is number 30 or 31. 

That is a pretty safe way to check, I'd say.

There are programs that failed on startup in MESS; trying to trace that problem I found out about this test.

Michael

---

From: "kevan064" <[email-masked]>
Date: Sun, 07 Jul 2013 13:41:55 -0000

Personally I think the F18A is one of the greatest things to come out
for the TI-99/4A (and other computers) in quite some time.
Sure, it's not a Mechatronics, Foundation or TIM ,or any of the other
assorted cards that RESIDED IN THE PERIPHERAL EXPANSION BOX.
Now while I would 'LIKE' the F18A do more, I'm still going to buy it,
because quite frankly it's:
  (1) SMALL (fits in the console) (2) EASY AS HECK TO INSTALL (even a
noob can do it) (3) I DO NOT HAVE ROOM TO PUT A PBOX (lack of space) (4)
REALLY WANT THE FANTASTIC VIDEO (5) I'VE READ NO REPORTS OF PROBLEMS
(unlike the Nano PEB)
Now sure, you could go on Ebay and buy a used card for twice as much,
but I've been reading the boards, and many of these older cards are
starting to fail and WILL require work (more money).  To be honest if I
buy something I want it to work, and I do not want to replace old
capacitors or hunt down exotic obsolete microchips just to get it
working again.
I'll go for the Plug & Play option.

---

From: [email-masked]
Date: Sun, 7 Jul 2013 22:41:59 +0000 (UTC)

The TIM and 2 other video cards also did not go in the PBox. Tim was in the Console and the others were side port. 

----- Original Message -----
From: "kevan064" <[email-masked]> 
To: [email-masked] 
Sent: Sunday, July 7, 2013 6:41:55 AM 
Subject: [TI994A] Re: CF2K - Does ANYONE have a WORKING copy? 

Personally I think the F18A is one of the greatest things to come out for the TI-99/4A (and other computers) in quite some time. 

Sure, it's not a Mechatronics, Foundation or TIM ,or any of the other assorted cards that RESIDED IN THE PERIPHERAL EXPANSION BOX . 

Now while I would ' LIKE ' the F18A do more, I'm still going to buy it , because quite frankly it's: 

( 1 ) SMALL ( fits in the console ) 
( 2 ) EASY AS HECK TO INSTALL ( even a noob can do it ) 
( 3 ) I DO NOT HAVE ROOM TO PUT A PBOX ( lack of space ) 
( 4 ) REALLY WANT THE FANTASTIC VIDEO 
( 5 ) I'VE READ NO REPORTS OF PROBLEMS ( unlike the Nano PEB ) 

Now sure, you could go on Ebay and buy a used card for twice as much, but I've been reading the boards, and many of these older cards are starting to fail and WILL require work (more money). To be honest if I buy something I want it to work, and I do not want to replace old capacitors or hunt down exotic obsolete microchips just to get it working again.