Subject: EPROM/device programmers

From: Jeff White <[email-masked]>
Date: Thu, 23 Oct 2014 18:29:17 -0400

What is the consensus on value EPROM/device programmers?  Specifically, the cheap ones?  Here are the USB ones I read about:

Genius G540
MiniPro TL866
Willem CQ-4X

I have a serial interface EPROMmer that does up to 28-pin DIP EPROMs, and a parallel interface EPROMmer that does up to 32-pin DIP EPROMs.  They also do EEPROM and other devices.

The day of the com1 (RS232) and lpt1 (parallel) ports, except through converters, is disappearing.  Especially on notebook computers.  Getting the timing right with converters would probably be a challenge.

I believe I have read recommendations here on the "better" USB-to-RS232 converters.  Anyone have experience with a good value USB-to-parallel converter?  

Of the G540, TL866, or CQ-4X, which do you have and why?  Is the software good or marginal? Close all other Windows, or works okay with other applications running?

I know Tim has a CQ-4X, but it does not handle the Atmel 29C040 EEPROM.  Not sure that is an issue except for the PFM.

Jeff White

---

From: [email-masked]
Date: Thu, 23 Oct 2014 18:46:14 -0400

The MiniPro is the best of the lot. I have it and the Genius.

It does the 29C040 chip that you mentioned as well as the 1284P used in 
the Ubergrom cart...
... as well as anything else I've thrown at it with the exception of a 
bunch of AT49F040 chips that I suspect are bad.

Tony

On 10/23/2014 6:29 PM, Jeff White [email-masked] [TI994A] wrote:
>
> What is the consensus on value EPROM/device programmers? Specifically, 
> the cheap ones? Here are the USB ones I read about:
>
> Genius G540
> MiniPro TL866
> Willem CQ-4X
>
> I have a serial interface EPROMmer that does up to 28-pin DIP EPROMs, 
> and a parallel interface EPROMmer that does up to 32-pin DIP EPROMs. 
> They also do EEPROM and other devices.
>
> The day of the com1 (RS232) and lpt1 (parallel) ports, except through 
> converters, is disappearing. Especially on notebook computers. Getting 
> the timing right with converters would probably be a challenge.
>
> I believe I have read recommendations here on the "better" 
> USB-to-RS232 converters. Anyone have experience with a good value 
> USB-to-parallel converter?
>
> Of the G540, TL866, or CQ-4X, which do you have and why? Is the 
> software good or marginal? Close all other Windows, or works okay with 
> other applications running?
>
> I know Tim has a CQ-4X, but it does not handle the Atmel 29C040 
> EEPROM. Not sure that is an issue except for the PFM.
>
> Jeff White
>
> 
> ------------------------------------------------------------------------
> Posted by: Jeff White <[email-masked]>
> ------------------------------------------------------------------------
> <https://groups.yahoo.com/neo/groups/TI994A/conversations/messages/9036;_ylc=X3oDMTJxb2Q1dTdhBF9TAzk3MzU5NzE0BGdycElkAzMyMzIxMDU5BGdycHNwSWQDMTcwNTExNTM4NgRtc2dJZAM5MDM2BHNlYwNmdHIEc2xrA3JwbHkEc3RpbWUDMTQxNDEwMzM2MA--?act=reply&messageNum=9036>
> 	
> 	
> 	
> 	
> 	
> 	
> 	
> 	
>

---

From: Gregory McGill <[email-masked]>
Date: Thu, 23 Oct 2014 17:50:00 -0700

I have a pocket programmer (parallel) and a minipro.. minipro is great for
my desktop and i keep the pocket for programming older devices

On Thu, Oct 23, 2014 at 3:46 PM, [email-masked] [TI994A] <
[email-masked]> wrote:

> What is the consensus on value EPROM/device programmers? Specifically, the
> cheap ones? Here are the USB ones I read about:
>
> Genius G540
> MiniPro TL866
> Willem CQ-4X
>
> I have a serial interface EPROMmer that does up to 28-pin DIP EPROMs, and
> a parallel interface EPROMmer that does up to 32-pin DIP EPROMs. They also
> do EEPROM and other devices.
>
> converters, is disappearing. Especially on notebook computers. Getting the
> timing right with converters would probably be a challenge.
>
> I believe I have read recommendations here on the "better" USB-to-RS232
> converters. Anyone have experience with a good value USB-to-parallel
> converter?
>
> Of the G540, TL866, or CQ-4X, which do you have and why? Is the software
> good or marginal? Close all other Windows, or works okay with other
> applications running?
>
> I know Tim has a CQ-4X, but it does not handle the Atmel 29C040 EEPROM.
> Not sure that is an issue except for the PFM.
>
> Jeff White
>    ------------------------------
> Posted by: Jeff White <[email-masked]> <[email-masked]>
> ------------------------------
>

---

From: Insane Multitasker <[email-masked]>
Date: Thu, 23 Oct 2014 23:42:20 -0500

Richard sent me a 29c040 or two, maybe we can test out whether your minipro will properly program it or if it just 'thinks' it can program it....  :)

To: [email-masked]
From: [email-masked]
Date: Thu, 23 Oct 2014 18:46:14 -0400
Subject: Re: [TI994A] EPROM/device programmers

    

    The MiniPro is the best of the lot. I
      have it and the Genius.

      It does the 29C040 chip that you mentioned as well as the 1284P
      used in the Ubergrom cart...

      ... as well as anything else I've thrown at it with the exception
      of a bunch of AT49F040 chips that I suspect are bad.

      Tony

      On 10/23/2014 6:29 PM, Jeff White [email-masked] [TI994A]
      wrote:

            What is the consensus on value EPROM/device programmers?
              Specifically, the cheap ones? Here are the USB ones I read
              about:

              Genius G540

              MiniPro TL866

              Willem CQ-4X

              I have a serial interface EPROMmer that does up to 28-pin
              DIP EPROMs, and a parallel interface EPROMmer that does up
              to 32-pin DIP EPROMs. They also do EEPROM and other
              devices.

              The day of the com1 (RS232) and lpt1 (parallel) ports,
              except through converters, is disappearing. Especially on
              notebook computers. Getting the timing right with
              converters would probably be a challenge.

              I believe I have read recommendations here on the "better"
              USB-to-RS232 converters. Anyone have experience with a
              good value USB-to-parallel converter? 

              Of the G540, TL866, or CQ-4X, which do you have and why?
              Is the software good or marginal? Close all other Windows,
              or works okay with other applications running?

              I know Tim has a CQ-4X, but it does not handle the Atmel
              29C040 EEPROM. Not sure that is an issue except for the
              PFM.

              Jeff White

          
             Posted by: Jeff White
            <[email-masked]>

---

From: [email-masked]
Date: Fri, 24 Oct 2014 17:32:11 -0400

I believe that's the flash chip on the HSGPL card. I'll check this 
weekend and if it is, I'll dump it, erase it, and reprogram it.
Stay tuned.

Tony

On 10/24/2014 12:42 AM, Insane Multitasker [email-masked] [TI994A] 
wrote:
>
> Richard sent me a 29c040 or two, maybe we can test out whether your 
> minipro will properly program it or if it just 'thinks' it can program 
> it....  :)
>
>
>

---

From: [email-masked]
Date: Tue, 28 Oct 2014 17:33:47 -0400

The chips used by the HSGPL are the 'A' version chips, I don't know if 
that makes a difference or not.
The MiniPro can correctly program them. I first removed the chip from 
the HSGPL and read it with the MiniPro, saving the contents.
I put it back in the HSGPL and blanked it. The MiniPro read it as blank. 
I wrote the file I had saved with the MiniPro back
to the chip and it showed the correct content on the HSGPL card.

I think my test was thorough enough to give you a certain yes to your 
question. I would assume if the MiniPro can program the
'A' version chips that it can also do the non-'A' chips as well.

What's the difference between the 'A' and non-'A' chips, anyway?

Tony

---

From: Insane Multitasker <[email-masked]>
Date: Tue, 28 Oct 2014 22:08:21 -0500

The only difference is the sector size used when programming. One is 256 bytes the other is 128 bytes if I recall correctly. 

To: [email-masked]
From: [email-masked]
Date: Tue, 28 Oct 2014 17:33:47 -0400
Subject: Re: [TI994A] EPROM/device programmers

    

    The chips used by the HSGPL are the 'A'
      version chips, I don't know if that makes a difference or not.

      The MiniPro can correctly program them. I first removed the chip
      from the HSGPL and read it with the MiniPro, saving the contents.

      I put it back in the HSGPL and blanked it. The MiniPro read it as
      blank. I wrote the file I had saved with the MiniPro back

      I think my test was thorough enough to give you a certain yes to
      your question. I would assume if the MiniPro can program the

      Tony

      On 10/24/2014 12:42 AM, Insane Multitasker [email-masked]
      [TI994A] wrote:

            

            Richard sent me a 29c040 or two, maybe we can
              test out whether your minipro will properly program it or
              if it just 'thinks' it can program it....  :)

---

From: Jeff White <[email-masked]>
Date: Thu, 6 Nov 2014 01:25:29 -0500

Tim and Tony, did you test the 29C040 (non-A) with the MiniPro in Evanston?

On to my challenge:

I have my parallel port Pocket Programmer on an old Dell Latitude notebook running WinXP.  I am running the latest, that I know, Windows version of its software.  

1.  It reads 2516 and 2532 EPROMs just fine.  I load the buffer multiple times and the checksum confirms.

2.  I have two AMD AM27C010 32-pin EPROMs that are supposed to have the same contents, but I cannot find the file and I want to recreate it.  With both EPROMs, I clear and load the buffer multiple times.  I do not get a consistent checksum.  I perform a buffer comparison of the loaded buffer to the EPROM just loaded to the buffer and there are several failed comparisons, but no discernible pattern and not all bytes.

Is there a failure mode of EPROMs such that they would not give consistent readings for a byte?  Since the 2516 and 2532 read fine every time and are slower access, I would think the read speed of the AM27C010 would not be overly fast.

Jeff White

---

From: [email-masked]
Date: 06 Nov 2014 16:13:24 -0800

Jeff, 

Tim and Bob checked the 29C040 (I was on the other side of the room at the time) and it wouldn't program correctly with the MiniPro. It was so hectic I didn't get a chance to play around trying to get it to work. I'd like to get my hands on one of them, because I'm not the kind of soul to give up easily. :) 

Your problem with the 27C010 sounds to me like a faulty connection, I haven't had chips read differently on successive tries, it's usually one bit that's stuck and it stays stuck. You may try putting the chip to one side or the other in the socket to see if you can get successive reads of the same data. Or hold the chip slightly up out of the socket while locking it in place.

If all else fails, I can try reading the chips for you and see if I get similar results.

Tony