Subject: Sad news

From: [email-masked]
Date: 24 Jul 2014 20:18:01 -0700

It is my sad duty to report that my good friend, and long time treasurer of the CTIUG, Irv Levinson, has died.  Irv was 83, and was battling pancreatic cancer.  --Hal

---

From: ti99_forever <[email-masked]>
Date: Thu, 24 Jul 2014 22:10:55 -0700

I'm really sorry to hear that, Hal. He seemed to be such a nice guy.
How are you doing, my friend? I'll never forget the bar crawl we had and the stories you told... even though I try to forget some of them!

Ben

On Thursday, July 24, 2014 11:18 PM, "[email-masked] [TI994A]" <[email-masked]> wrote:

---

From: [email-masked]
Date: Fri, 25 Jul 2014 12:30:39 +0000 (UTC)

Sad to hear that. 

Wish his family well. 

----- Original Message -----

From: "Gilbertson, Rich" <[email-masked]> 
To: "Gilbertson, Rich" <[email-masked]> 
Sent: Thursday, July 24, 2014 8:18:01 PM 
Subject: [TI994A] Sad news