Subject: TI9900 Minimal Breadboard Setup?

From: <[email-masked]>
Date: 19 Jan 2014 08:02:18 -0800

I have a broken TI-99/4A.  I was thinking it would be a fun project to either isolate the processor on the original mainboard or attempt to unsolder it and put on a breadboard.  Is anyone aware of links to similar projects already done?  In particular, I'm looking for a minimal circuit that would let me test basic processor function before going further with it (something like blinking a LED light).

---

From: <[email-masked]>
Date: 19 Jan 2014 14:28:03 -0800

I've got minimal breadboard projects for the TMS9995 and 99110 on my web site - www.stuartconner.me.uk http://www.stuartconner.me.uk.

 If it's specifically the TMS9900 you want to use, then there's a fair bit of wiring to do because you need two RAMs and two EPROMs for the high and low bytes, and you'll need to program the EPROMs in pairs. Will also need the TIM9904 clock generator. Perfectly do-able, but the 9995 is easier if you're new to this sort of thing.

 Wouldn't bother trying to isolate or unsolder a 9900 - they're normally available cheap on ebay (might want to avoid Chinese sources), or someone might have a spare you could have. If you're in the UK, I've got some spares somewhere.

---

From: "Ksarul" <[email-masked]>
Date: Sun, 19 Jan 2014 20:21:33 -0500

One note, it is really easy to get TMS9900 IC chips.  Here's an auction
(ended) for a seller that always has the S9900P version available (it was
the alternate source version from another manufacturer that TI had to have
to get military contracts):

http://www.ebay.com/itm/4PC-LOT-VINTAGE-S9900P-PROCESSOR-64PIN-DIP-/19103046
1221

He always has them in groups of 4 for the nice low price of $10 plus
shipping.  It works out to about $4 per chip, shipped.

Just wait a bit and look for S9900P and they'll turn up again.

Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Sunday, January 19, 2014 5:28 PM
To: [email-masked]
Subject: [TI994A] RE: TI9900 Minimal Breadboard Setup?

I've got minimal breadboard projects for the TMS9995 and 99110 on my web
site - www.stuartconner.me.uk.

If it's specifically the TMS9900 you want to use, then there's a fair bit of
wiring to do because you need two RAMs and two EPROMs for the high and low
bytes, and you'll need to program the EPROMs in pairs. Will also need the
TIM9904 clock generator. Perfectly do-able, but the 9995 is easier if you're
new to this sort of thing.

Wouldn't bother trying to isolate or unsolder a 9900 - they're normally
available cheap on ebay (might want to avoid Chinese sources), or someone
might have a spare you could have. If you're in the UK, I've got some spares
somewhere.

---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com

---

From: <[email-masked]>
Date: 20 Jan 2014 07:29:38 -0800

Thanks for the chip pointers.  However, this broken board has been collecting dust for awhile now and I really want to do something with it...even if it ends up being unsolder practice.  

 Thanks for the stuartconner link.  I've seen that, bookmarked, and been studying.  I've also been reading the TMS9900 PDF.   

 I was thinking minimally minimal.  For example can I just connect power lines and clock, perform a RESET, then (safely) measure voltages to look for default values?  Safely measure impedance (the PDF mentions 3 states)?

---

From: Marc Hull <[email-masked]>
Date: Mon, 20 Jan 2014 08:05:43 -0800 (PST)

This may save you some trouble if you can bring yourself to do it.....

The 9900 is a real PITA to take out with an iron and suction device.  I have removed several but most find it fairly barbaric as to how.  I can say though that it works successfully.

Get a heat gun (kind used for stripping pain not a hair dryer) and heat up the back side of the board until the solder wets.  Keep it moving so you get even heat.  When the solder runs smack the board face up against a workbench to knock most of the solder off from the back side.  Obviously don't do this on your wife's dining room table or you might get killed in the process.  You may have to do this a couple of times to get the bulk of the metal out of the holes.  The object of this step is to minimize chip cleanup when you get it out.

When things look fairly clean set the board upside down supported by a couple of bricks.  Reheat the chip legs from the bottom and tap in between the two rows with a screw driver until the IC falls to the table.  You may have to clean up the pins a bit if step 1 didn't go as smoothly as planned.

Obviously this method is not very good on the board but is great for removing chips.    Good luck Conan ;-)....

________________________________
 From: "[email-masked]" <[email-masked]>
To: [email-masked] 
Sent: Monday, January 20, 2014 9:29 AM
Subject: [TI994A] RE: TI9900 Minimal Breadboard Setup?