Subject: Re: [TI994A] Sad news

From: [email-masked]
Date: Fri, 25 Jul 2014 09:39:26 -0400 (EDT)

In a message dated 7/24/2014 11:18:03 P.M. Eastern Daylight Time,  
[email-masked] writes:

long  time treasurer of the CTIUG, Irv Levinson, has died.  Irv was 83, and 
was  battling pancreatic cancer.
Irv's fight is now over.  He can rest, and will be missed by all who  knew 
him.
 
Glenn

---

From: Gregory McGill <[email-masked]>
Date: Fri, 25 Jul 2014 11:01:42 -0700

Very sorry to hear.... :(     condolences to his friends and family

Greg