Subject: OT: Update winxp until 2019 from MS was Re: [TI-99/4A] Cartridge Manipulator Program

From: Dan O'Quinn <[email-masked]>
Date: Wed, 04 Jun 2014 14:51:27 -0400

On 6/3/20o14 10:35 PM, Alexandre Souza [email-masked] [TI99-4A] wrote:

Eh...
Mind compiling the program for WinXP, for us, people with old computers not willing to upgrade to Win7? :) :) :)

Thanks!

for those that dont / cant /wont replace xp.
I can confirm this is still working as of  6-4-14
save the text between the arrows >>>  as reg file
( I called mine xppos)  then merge (run) it
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\WPA\PosReady]
"Installed"=dword:00000001
The work around makes use of updates for Windows Embedded Industry (formerly known as Windows Embedded POSReady). This is based on Windows XP Service Pack 3, and the security updates which are being released for it are essentially the same ones Microsoft would have pushed out for XP, if it was still doing so.

http://betanews.com/2014/05/26/how-to-continue-getting-free-security-updates-for-windows-xp-until-2019/
http://www.sebijk.com/community/board15-other/board73-tutorials/2985-getting-xp-updates/

ms says dont do that (will they stop it?)
http://www.eyeonwindows.com/2014/05/27/microsoft-warns-against-updating-windows-xp-via-registry-trick/

---

From: [email-masked]
Date: Thu, 5 Jun 2014 00:11:32 +0000 (UTC)

Why are people attempting to use Windows XP when clearly it is like my Mac Pro G5 PPC and has zero support. 
I have run Windows 7 on my old XP computers and it is slower but does run. Windows 8 will not even load at all. 

No one wants to support a OS that as times goes on will be more of a hassle to use then just upgrading. 
Get a hacked copy of Vista for free and use that, or just take the plunge and go Linux or upgrade the Computer. 

----- Original Message -----

From: "Gilbertson, Rich" <[email-masked]> 
To: "TI99/4A" <[email-masked]> 
Sent: Wednesday, June 4, 2014 11:51:27 AM 
Subject: [TI994A] OT: Update winxp until 2019 from MS was Re: [TI-99/4A] Cartridge Manipulator Program 

Eh... 

Thanks!

---

From: Charlie Jackson <[email-masked]>
Date: Wed, 4 Jun 2014 17:19:30 -0700 (PDT)

Vista was the worst OS that Microsoft ever put out. If you know how to edit your registry in Windows XP you can still get upgrades through Microsoft until 2019 (A little known secret)
XP was the most stable of OS's from Microsoft and Windows 7 would probably be the next best in my opinion but just run's too slow on those oldie but goodie machines.

On Wednesday, June 4, 2014 6:11 PM, "[email-masked] [TI994A]" <[email-masked]> wrote:

________________________________

Eh...

---

From: Dan O'Quinn <[email-masked]>
Date: Thu, 05 Jun 2014 12:16:10 -0400

On 6/4/2014 8:11 PM, [email-masked] [TI994A] wrote:

some may not have the funds for a newer pc. even a good "refurb" with a legit copy of win7 can cost 150 to 200 bucks, for some that's unaffordable for an item that's not a necessity

encouraging software theft with a "hacked copy" of a newer OS is wrong
software piracy is  one of the downfalls of TI software

I have a client running custom controls for large scale irrigation system (written by a division of motorola) that says they have no plans to update the software before 2017 at the earliest so they are stuck with xp. this same hardware and software is also used to control municipal water systems in a number of cities. I feel better knowing they can easily get updates from MS using the registry "hack". Last thing we need is some bored hacker opening and closing vales at a water treatment plant and sending "crap" into the fresh water supply.

these are just a few of the reasons

---

From: Charlie Jackson <[email-masked]>
Date: Thu, 5 Jun 2014 09:50:23 -0700 (PDT)

The nice thing about the registry hack is that you DO need a legitimate copy of Windows XP for it to work. It will NOT work on pirated copies which is a good thing. A lot of people are not aware that MS is still supporting XP until 2019 for industries that have the correct versions such as the Utility Companies and etc. The Mass Media and I am sure the computer industry wants everyone to upgrade and attempts to scare them into purchasing newer versions of Windows which most likely results (as you mentioned) having to spend additional money on hardware as well. We have to remember that XP is still on 25% of computers today.

On Thursday, June 5, 2014 10:13 AM, "Dan O'Quinn [email-masked] [TI994A]" <[email-masked]> wrote:

>Get a hacked copy of Vista for free and use that, or just take the plunge and go Linux or upgrade the Computer.
some may not have the funds for a newer pc. even a good "refurb"
    with a legit copy of win7 can cost 150 to 200 bucks, for some that's
    unaffordable for an item that's not a necessity

encouraging software theft with a "hacked copy" of a newer OS is
    wrong
software piracy is  one of the downfalls of TI software

I have a client running custom controls for large scale irrigation
    system (written by a division of motorola) that says they have no
    plans to update the software before 2017 at the earliest so they are
    stuck with xp. this same hardware and software is also used to
    control municipal water systems in a number of cities. I feel better
    knowing they can easily get updates from MS using the registry
    "hack". Last thing we need is some bored hacker opening and closing
    vales at a water treatment plant and sending "crap" into the fresh
    water supply.

---

From: "Ksarul" <[email-masked]>
Date: Thu, 05 Jun 2014 18:59:26 -0400

Actually, it won’t matter that much if the OS is WIN XP on those Industrial Control Systems or some newer OS—they are and will almost always be unbelievably vulnerable. The protocols they use to control the systems weren’t designed with security in mind, were expected to last for 30-40 years, and have to maintain compatibility with all of the older hardware because of the expected design life. I have to design workarounds to effectively shield systems like this from the network at large so that I can minimize the risk—because there is pretty much no way to completely eliminate it so long as it is on a network. It is actually a lot of fun to design, because you have to wrap your head around stuff that was designed to work all the time—without any concern for security, and then fit it into a security box. J

Jim

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, June 05, 2014 12:16 PM
To: [email-masked]
Subject: Re: [TI994A] OT: Update winxp until 2019 from MS was Re: [TI-99/4A] Cartridge Manipulator Program

---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com