Subject: nanoPEB - SIO

From: Barry Peterson <[email-masked]>
Date: Mon, 8 Jul 2013 17:53:50 -0400

I have one of the above that I purchased recently and want to report on my
experience.

1: The nanoPEB works fine, although I've not yet tried the SIO part.

2: I have been able to copy a single file from this computer (running XP)
to the nanoPEB and back. It took a lot of experimentation but I've got it
down pat now.

3: I have copied from a .DSK file to the CF card and the TI recognizes all
of the files.

4: I have a couple of CF cards that I've had forever; a SanDisk 128MB and a
LEXAR 64MB. I have copied volume 1 from the nanoPEB CF card to a file that
I named nano.dsk, then copied from nano.dsk to the 128MB card and it works
fine. Now I have a backup for the 2GB card that came with the nanoPEB!

5: When I copied nano.dsk to the 64MB card, it won't work in the nanoPEB.
Copying from the 64MB card to a file nano1.dsk results in a jumbled mess. I
assume that LEXAR cards are not found good for my purposes.

My advice to those having nanoPEB problems; follow the syntax in the manual
exactly. cf2dsk and dsk2cf are not very forgiving. I'm going to set up a
MS-DOS computer when I can find the space, then I'll run more tests.

AND, I'm going to try the same tactics on my CF7+ soon.

---

From: Gregory McGill <[email-masked]>
Date: Mon, 8 Jul 2013 15:49:37 -0700

I just purchased a nanopeb..

SIO and RS232 as a device did not work, it is now COM1 for some reason
cf2k does not work as SIO isn't there..
cfhdxs1 does not work as SIO isnt there..

Fred Kaal has been notified of these issues. As has the ebay seller.

Greg

On Mon, Jul 8, 2013 at 2:53 PM, Barry Peterson <[email-masked]>wrote:

> **
> 4: I have a couple of CF cards that I've had forever; a SanDisk 128MB and
> a LEXAR 64MB. I have copied volume 1 from the nanoPEB CF card to a file
> that I named nano.dsk, then copied from nano.dsk to the 128MB card and it
> works fine. Now I have a backup for the 2GB card that came with the nanoPEB!
>
> My advice to those having nanoPEB problems; follow the syntax in the
> manual exactly. cf2dsk and dsk2cf are not very forgiving. I'm going to set
> up a MS-DOS computer when I can find the space, then I'll run more tests.
>
>

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 8 Jul 2013 20:51:00 -0500

From the ebay site:

Serial Port "COM1" - uses standard DB-9 cables (needs null modem cable to connect to PC). Baud rate up to 115200! 

If this is true, he is either using an emulated 9902 or a different UART.  I suspect the latter as 115,200 is difficult if not impossible to configure on the 9902 due to how the chip divides frequencies.  

This could be very unfortunate.  More details are needed to further assess and understand. 

To: [email-masked]
From: [email-masked]
Date: Mon, 8 Jul 2013 15:49:37 -0700
Subject: Re: [TI994A] nanoPEB - SIO

Greg

On Mon, Jul 8, 2013 at 2:53 PM, Barry Peterson <[email-masked]> wrote:

I have one of the above that I purchased recently and want to report on my experience. 

2: I have been able to copy a single file from this computer (running XP) to the nanoPEB and back. It took a lot of experimentation but I've got it down pat now.

3: I have copied from a .DSK file to the CF card and the TI recognizes all of the files.

4: I have a couple of CF cards that I've had forever; a SanDisk 128MB and a LEXAR 64MB. I have copied volume 1 from the nanoPEB CF card to a file that I named nano.dsk, then copied from nano.dsk to the 128MB card and it works fine. Now I have a backup for the 2GB card that came with the nanoPEB!

5: When I copied nano.dsk to the 64MB card, it won't work in the nanoPEB. Copying from the 64MB card to a file nano1.dsk results in a jumbled mess. I assume that LEXAR cards are not found good for my purposes.

My advice to those having nanoPEB problems; follow the syntax in the manual exactly. cf2dsk and dsk2cf are not very forgiving. I'm going to set up a MS-DOS computer when I can find the space, then I'll run more tests.

---

From: James Abbatiello <[email-masked]>
Date: Mon, 8 Jul 2013 22:19:00 -0400

On Mon, Jul 8, 2013 at 9:51 PM, Insane Multitasker <[email-masked]>wrote:

> **
>
> If this is true, he is either using an emulated 9902 or a different UART.
> I suspect the latter as 115,200 is difficult if not impossible to configure
> on the 9902 due to how the chip divides frequencies.
>

I got one from the latest batch.  The chip on the board is labeled:
(TI logo)
TL16C550CFN
86AV07W
       G4

Looks like a 16550.  There's also a MAX3232 transceiver.

-- 
James Abbatiello

---

From: "kevan064" <[email-masked]>
Date: Tue, 09 Jul 2013 02:39:17 -0000

Well, trying to look on the bright-side, with a 16550 UART it MIGHT now
be fast enough (with software yet to be developed) to link up to the
internet to do basic text-based email or even possibly make a device to
go from the 'COM1' to a RS-232 to a USB converter and use a USB Wifi to
communicate with the PC.  But in the mean time, sans software, it's
pretty worthless.  [:-s]

--- In [email-masked], James Abbatiello  wrote:
>
> On Mon, Jul 8, 2013 at 9:51 PM, Insane Multitasker insane_m@...wrote:

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 8 Jul 2013 22:09:22 -0500

The TI RS232 can connect at 38.4K (and higher speeds with some caveats); however, overall throughput is almost always less less due to system speed and disk IO requirements.  Faster RS232 does not equate to faster throughput.  

To: [email-masked]
From: [email-masked]
Date: Tue, 9 Jul 2013 02:39:17 +0000
Subject: Re: FW: [TI994A] nanoPEB - SIO

Well, trying to look on the bright-side, with a 16550 UART it MIGHT now be fast enough (with software yet to be developed) to link up to the internet to do basic text-based email or even possibly make a device to go from the 'COM1' to a RS-232 to a USB converter and use a USB Wifi to communicate with the PC.  But in the mean time, sans software, it's pretty worthless.

---

From: "kevan064" <[email-masked]>
Date: Tue, 09 Jul 2013 03:24:10 -0000

Good point, thanks for mentioning that.  I do wonder though if a decent buffer on the external device could make up for some of inherent issues inside the TI.  I only know enough to wonder and ask questions....