Subject: CC-40 ROMs all dumped....

From: [email-masked]
Date: 08 Jun 2014 16:00:53 -0700

Thanks to quite a few people helping, everything we have related to CC-40 ROMs has been dumped so that MESS emulation work can commence.

 The last part, the CC-40 32K BIOS (bank switched) has been dumped.

 With that... I present to the community, every existing CC-40 cartridge binary + the 32K BIOS + 2K on-CPU ROM.

 https://dl.dropboxusercontent.com/u/19597743/ti-99-4a/CC-40%20DUMPS.zip https://dl.dropboxusercontent.com/u/19597743/ti-99-4a/CC-40%20DUMPS.zip

 Hap is working on the emulation in MESS.  Ksarul helped with lending an ear (during a very long phone conversation).  JGardner from the Vintage Computing forum helped with giving me the correct assembly to force a bank switch (and then copy to a 32K SRAM) to enable the ROM to be dumped.  Lee, who just sold his entire CC-40 collection, also gave me some ROMs to compare against.  

 Enjoy, everyone.  Let's hope Hap gets us a good CC-40 emulator going here soon

---

From: Gregory McGill <[email-masked]>
Date: Sun, 8 Jun 2014 20:24:27 -0700

very nice!   great work guys

Greg

On Sun, Jun 8, 2014 at 4:00 PM, [email-masked] [TI994A] <
[email-masked]> wrote:

>
>
> Thanks to quite a few people helping, everything we have related to CC-40
> ROMs has been dumped so that MESS emulation work can commence.
>
>
> https://dl.dropboxusercontent.com/u/19597743/ti-99-4a/CC-40%20DUMPS.zip
>
>
> Hap is working on the emulation in MESS.  Ksarul helped with lending an
> ear (during a very long phone conversation).  JGardner from the Vintage
> Computing forum helped with giving me the correct assembly to force a bank
> switch (and then copy to a 32K SRAM) to enable the ROM to be dumped.  Lee,
> who just sold his entire CC-40 collection, also gave me some ROMs to
> compare against.
>
>