Subject: RS232 cru address

From: Insane Multitasker <[email-masked]>
Date: Sat, 22 Feb 2014 14:50:50 -0600

The TI RS232 by default responds to CRU address 0x1300 and can be jumpered to respond to CRU address 0x1500.

I would like to modify one of my cards to respond to something other than 1300 or 1500.  Has anyone ever tried this?

My first thought was to enable both the 1300 and 1500 jumpers, resulting in CRU 1700.  I'm not sure if the card logic is set up to allow this...

Any suggestions?

---

From: ti99_forever <[email-masked]>
Date: Sun, 23 Feb 2014 00:36:13 -0800 (PST)

Try it...

---

From: Jeff White <[email-masked]>
Date: Sun, 23 Feb 2014 12:29:57 -0500

The card logic is such that pulling down pin 19 of U7 through R5 to ground selects 0x1300.  Moving R5 to PTH1 pulls up pin 19 to +5V to choose 0x1500.

0x1300 has A4=0, A5=0, A6=1, A7=1

0x1500 has A4=0, A5=1, A6=0, A7=1

0x1700 has A4=0, A5=1, A6=1, A7=1

Pin 19 of U7 must determine how A5 an A6 are used.  In fact, A5 and A6 go to U7 on pins 6 and 7 respectively.

From this, we can deduce that if A5 is inverted prior to U7, then pulling pin 19 of U17 through R5 to ground will select operation at 0x1700.

U14 has an unused NAND gate, inputs 4 and 5 tied inactive to ground.  Cut the leads of pin 4 and 5 of U14, and the lead of pin 6 of U7.  Wire A5 from pin 7 of U4 to pins 4 and 5 of U14.  Pin 6 of U14 will be inverted A5, or !A5.  Connect pin 6 of U14 to pin 6 of U7.

This all is based on the schematics of the TI RS232 you provided to Ron Reuter:

http://www.mainbyte.com/ti99/schematic/schematics.html

Jeff White

---

From: Insane Multitasker <[email-masked]>
Date: Mon, 24 Feb 2014 12:33:54 -0600

Ah, not so simple. :)   

I will tuck this away for the weekend and assuming I find the time to modify the card, report results shortly thereafter.  

Thank you, Jeff.   -tim

CC: [email-masked]; [email-masked]
To: [email-masked]
From: [email-masked]
Date: Sun, 23 Feb 2014 12:29:57 -0500
Subject: Re: [TI994A] RS232 cru address

Jeff White

  

 
 
Any suggestions?

---

From: Jeff White <[email-masked]>
Date: Tue, 25 Feb 2014 21:38:55 -0500

Another option is to swap out U7 logic chip with one programmed for the CRU address you want.  The equations are in the Bunyard manual, IIRC.

Jeff White

---

From: "Ksarul" <[email-masked]>
Date: Wed, 26 Feb 2014 07:10:19 -0500

If they're not, I'm pretty sure I have them.

Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jeff White
Sent: Tuesday, February 25, 2014 9:39 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [TI-99/4A] RE: [TI994A] RS232 cru address

Another option is to swap out U7 logic chip with one programmed for the CRU
address you want.  The equations are in the Bunyard manual, IIRC.

Jeff White

Ah, not so simple. :)   
 
I will tuck this away for the weekend and assuming I find the time to modify
the card, report results shortly thereafter.  
 
Thank you, Jeff.   -tim

---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com