Subject: 64K Cartridge Boards

From: <[email-masked]>
Date: 16 Nov 2013 22:29:46 -0800

Is anyone planning a run of the Jon Guidry-type cartridge boards? Or know where there is a small supply of them?

---

From: Gregory McGill <[email-masked]>
Date: Sun, 17 Nov 2013 00:44:06 -0800

I was considering doing one.

---

From: Chris and Veronica Schneider <[email-masked]>
Date: Sun, 17 Nov 2013 09:29:23 -0600

I would be interested in a few if you are doing them.

Chris

From:  Gregory McGill <[email-masked]>
Reply-To:  <[email-masked]>
Date:  Sun, 17 Nov 2013 00:44:06 -0800
To:  ti994a <[email-masked]>
Subject:  Re: [TI994A] 64K Cartridge Boards

---

From: [email-masked]
Date: Sun, 17 Nov 2013 15:44:05 -0000

I would be interested in a few, as well.

...lee

--- In [email-masked], Gregory McGill <arcadeshopper@...> wrote:
> On Sat, Nov 16, 2013 at 10:29 PM, <rmcarmany@...> wrote:
> 
> >
> >

---

From: <[email-masked]>
Date: 17 Nov 2013 21:21:49 -0800

I also am interested,  

---In [email-masked], <lee@...> wrote:

 ...lee

---

From: Bill R Sullivan <[email-masked]>
Date: Mon, 18 Nov 2013 09:59:04 -0700

I thought we were expecting 512K cartridge boads soon?  They're what I'm 
waiting for, as it has an option for storing XB modules, and maybe my 
TIB+ MSAVE'd BASIC programs.

Bill R Sullivan (fdos)

On 11/17/2013 10:21 PM, [email-masked] wrote:
>     --- In [email-masked] <mailto:[email-masked]>,
>     Gregory McGill <arcadeshopper@...> wrote:
>     >
>     > > Is anyone planning a run of the Jon Guidry-type cartridge
>     boards? Or know
>     > > where there is a small supply of them?
>     > >
>     > >
>     > 
>
>

---

From: [email-masked]
Date: Mon, 18 Nov 2013 18:01:28 -0000

We're talking here about bare boards for cartridge development, Bill.  I, for example, want to hoist fbForth into cartridge space ere long and it would be fun to build it myself.  Of course, I will need to get a small supply of the components I will need to populate the boards—not to mention an EPROM programmer.

...lee

--- In [email-masked], Bill R Sullivan <br911sullivan@...> wrote:
> On 11/17/2013 10:21 PM, bkaspar@... wrote:
> >
> > I also am interested,
> >
> >
> >
> > ---In [email-masked], <lee@> wrote:
> >
> >     Gregory McGill <arcadeshopper@> wrote:
> >     >
> >     > On Sat, Nov 16, 2013 at 10:29 PM, <rmcarmany@> wrote:
> >     >
> >     > >
> >     > >

---

From: Gregory McGill <[email-masked]>
Date: Mon, 18 Nov 2013 10:57:12 -0800

With this amount of interest I will go ahead and get a quote for the boards
and put up a pre-order like I did for HDX.

Greg

On Mon, Nov 18, 2013 at 10:01 AM, <[email-masked]> wrote:

>
>
> We're talking here about bare boards for cartridge development, Bill. I,
> for example, want to hoist fbForth into cartridge space ere long and it
> would be fun to build it myself. Of course, I will need to get a small
> supply of the components I will need to populate the boards—not to mention
> an EPROM programmer.
>
> ...lee
>
>

---

From: Bill R Sullivan <[email-masked]>
Date: Mon, 18 Nov 2013 14:29:13 -0700

I can't do the same with X4th99 as it depends on a minimum of 256K AMS/SAMS.

Bill R Sullivan (fdos)

On 11/18/2013 11:01 AM, [email-masked] wrote:
>
> We're talking here about bare boards for cartridge development, Bill. 
> I, for example, want to hoist fbForth into cartridge space ere long 
> and it would be fun to build it myself. Of course, I will need to get 
> a small supply of the components I will need to populate the 
> boards---not to mention an EPROM programmer.
>
> ...lee
>

---

From: Bill R Sullivan <[email-masked]>
Date: Mon, 18 Nov 2013 14:40:44 -0700

So Greg,

By how much did miss the original HDX offer?  I did not go back into the 
OLUG archives.  I signed back up on 9-16-2013.

Bill R Sullivan (fdos)

On 11/18/2013 11:57 AM, Gregory McGill wrote:
> With this amount of interest I will go ahead and get a quote for the 
> boards and put up a pre-order like I did for HDX.
>
> Greg
>
>
> On Mon, Nov 18, 2013 at 10:01 AM, <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     We're talking here about bare boards for cartridge development,
>     Bill. I, for example, want to hoist fbForth into cartridge space
>     ere long and it would be fun to build it myself. Of course, I will
>     need to get a small supply of the components I will need to
>     populate the boards---not to mention an EPROM programmer.
>
>     ...lee
>
>
>
>     Bill R Sullivan <br911sullivan@...> wrote:
>     >
>     > > ---In [email-masked] <mailto:[email-masked]>,
>     <lee@> wrote:
>     > >
>     > > --- In [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>,
>

---

From: Jeff White <[email-masked]>
Date: Mon, 18 Nov 2013 22:47:01 +0100

E/A, Multiplan, and TI Writer are cartridges that all require 32K RAM.  Nothing says you could not have an X4th99 cartridge that requires AMS/SAMS.

Jeff White

---

From: Gregory McGill <[email-masked]>
Date: Mon, 18 Nov 2013 14:19:25 -0800

http://www.arcadeshopper.com/wp/?page_id=11#!/~/product/category=5051340&id=30370736

Greg

---

From: Gregory McGill <[email-masked]>
Date: Mon, 18 Nov 2013 14:21:28 -0800

March..   There are bare boards still available, have been on my site the
whole time.
http://www.arcadeshopper.com/wp/?page_id=11#!/~/category/id=5051340&offset=0&sort=nameAsc

Greg

On Mon, Nov 18, 2013 at 1:40 PM, Bill R Sullivan <[email-masked]>wrote:

>> --- In [email-masked], Bill R Sullivan <br911sullivan@...><br911sullivan@...>wrote:
>> >

---

From: Bill R Sullivan <[email-masked]>
Date: Mon, 18 Nov 2013 16:15:59 -0700

Not possible Jeff,

Because most of the kernel is in paged memory, so not suitable for 
distribution as a cartridge.  I would have to revamp it, and have enough 
cartridge memory to contain the entire kernel, which is at least 6 pages 
of 4K now.  All the code libraries are coming from Forth+ for the 
Geneve, so 8K pages, but I have a way of handling this.  However, I 
haven't even started converting all the XOP support code, so I don't 
know what effect that will have on the kernel size.

I am looking forward to getting back to X4th99 development as I much 
prefer coding in Forth than BASIC.  Especially any AL code as that is so 
much easier to do in and for Forth than doing AL code for TI BASIC, even 
though much is borrowed from other sources, and much came from members here.

Bill R Sullivan (fdos)

On 11/18/2013 2:47 PM, Jeff White wrote:
> E/A, Multiplan, and TI Writer are cartridges that all require 32K RAM. 
>  Nothing says you could not have an X4th99 cartridge that requires 
> AMS/SAMS.
>
> Jeff White
>
> On 18 Nov 2013, at 22:29, Bill R Sullivan <[email-masked] 
> <mailto:[email-masked]>> wrote:
>>

---

From: Bill R Sullivan <[email-masked]>
Date: Mon, 18 Nov 2013 16:30:15 -0700

Wow!  I have so much hobby stuff to keep me busy until I retire to a 
rocking chair on the front porch (hopefully not before 2020 or 2025).  
It looks like I could fix two more TI RS-232 cards for HDX mods, instead 
of trying to fix SCSI and IDE systems for my TI-99/4P (SNUG-TI) system 
and one 9640 2MB Geneve system.  I just have to find a 4 port serial 
switch to replace the 2 port switch I'm currently using or stick a 4 
port USB hub on the Win98SE PC and add RS-232 to USB adapters.

Bill R Sullivan (fdos)

On 11/18/2013 3:21 PM, Gregory McGill wrote:
> March.. //There are bare boards still available, have been on my site 
> the whole time.
> <http://www.arcadeshopper.com/wp/?page_id=11#%21/%7E/category/id=5051340&offset=0&sort=nameAsc>
>
> Greg
>
>
> On Mon, Nov 18, 2013 at 1:40 PM, Bill R Sullivan 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     So Greg,
>
>     By how much did miss the original HDX offer?  I did not go back
>     into the OLUG archives.  I signed back up on 9-16-2013.
>
>     Bill R Sullivan (fdos)
>
>>     With this amount of interest I will go ahead and get a quote for
>>     the boards and put up a pre-order like I did for HDX.
>>
>>     Greg
>>
>>
>>         We're talking here about bare boards for cartridge
>>         development, Bill. I, for example, want to hoist fbForth into
>>         cartridge space ere long and it would be fun to build it
>>         myself. Of course, I will need to get a small supply of the
>>         components I will need to populate the boards---not to
>>         mention an EPROM programmer.
>>
>>         ...lee
>>
>>
>>
>>         --- In [email-masked]
>>         <mailto:[email-masked]>, Bill R Sullivan
>>         <br911sullivan@...> <mailto:br911sullivan@...> wrote:
>>         >
>>         > > ---In [email-masked]
>>         <mailto:[email-masked]>, <lee@> wrote:
>>         > >

---

From: ti99_forever <[email-masked]>
Date: Thu, 21 Nov 2013 02:55:54 -0800 (PST)

I have a bunch of the first run that Jon did. Is that what we're talking about?

Ben

On Monday, November 18, 2013 6:30 PM, Bill R Sullivan <[email-masked]> wrote:

>
>
>Wow!  I have so much hobby stuff to keep me busy until I retire to a rocking chair on the front porch (hopefully not before 2020 or 2025).  It looks like I could fix two more TI RS-232 cards for HDX mods, instead of trying to fix SCSI and IDE systems for my TI-99/4P (SNUG-TI) system and one 9640 2MB Geneve system.  I just have to find a 4 port serial switch to replace the 2 port switch I'm currently using or stick a 4 port USB hub on the Win98SE PC and add RS-232 to USB adapters.
>
>
>Bill R Sullivan (fdos)
>
>
On 11/18/2013 3:21 PM, Gregory McGill wrote:
>
>  
>March..   There are bare boards still available, have been on my site the whole time.  
>On Mon, Nov 18, 2013 at 1:40 PM, Bill R Sullivan <[email-masked]> wrote:
>
>  
>>So Greg,
>>
>>By how much did miss the original HDX
                            offer?  I did not go back into the OLUG
                            archives.  I signed back up on 9-16-2013.
>>>With this amount of interest I will go ahead and get a quote for the boards and put up a pre-order like I did for HDX. 
>>>
>>>
>>>Greg
>>>
>>>
>>>
>>>>> I thought we
                                                      were expecting
                                                      512K cartridge
                                                      boads soon?
                                                      They're what I'm 
>>>>> waiting for,
                                                      as it has an
                                                      option for storing
                                                      XB modules, and
                                                      maybe my 
>>>>> Bill R
                                                      Sullivan (fdos)
>>>>> > I also
                                                      am interested,
>>>>> > I would
                                                      be interested in a
                                                      few, as well.
>>>>> > Gregory
                                                      McGill
                                                      <arcadeshopper@>
                                                      wrote:
>>>>> > > I
                                                      was considering
                                                      doing one.
                                                      > Is anyone
                                                      planning a run of
                                                      the Jon
                                                      Guidry-type
                                                      cartridge
>>>>> > boards?
                                                      Or know
                                                      > where there
                                                      is a small supply
                                                      of them?

---

From: Bill R Sullivan <[email-masked]>
Date: Thu, 21 Nov 2013 08:52:26 -0700

Ben,

I think the first RUN Guidry carts were 16K, and they're looking for 64K 
cart kits.  I have two or three of the 16K boards myself.   I'll have to 
use one for another TF module if I don't find my original soon.  That 
was it's purpose any way--TF spare.

Bill R Sullivan (fdos)

On 11/21/2013 3:55 AM, ti99_forever wrote:
>     Wow! I have so much hobby stuff to keep me busy until I retire to
>     a rocking chair on the front porch (hopefully not before 2020 or
>     2025).  It looks like I could fix two more TI RS-232 cards for HDX
>     mods, instead of trying to fix SCSI and IDE systems for my
>     TI-99/4P (SNUG-TI) system and one 9640 2MB Geneve system.  I just
>     have to find a 4 port serial switch to replace the 2 port switch
>     I'm currently using or stick a 4 port USB hub on the Win98SE PC
>     and add RS-232 to USB adapters.
>
>     Bill R Sullivan (fdos)
>
>     March.. //There are bare boards still available, have been on my
>     site the whole time.
>         By how much did miss the original HDX offer?  I did not go
>         back into the OLUG archives.  I signed back up on 9-16-2013.
>
>         Bill R Sullivan (fdos)
>
>>         With this amount of interest I will go ahead and get a quote
>>         for the boards and put up a pre-order like I did for HDX.
>>
>>         Greg
>>
>>
>>             development, Bill. I, for example, want to hoist fbForth
>>             into cartridge space ere long and it would be fun to
>>             build it myself. Of course, I will need to get a small
>>             supply of the components I will need to populate the
>>             boardsâEUR"not to mention an EPROM programmer.
>>
>>             ...lee
>>
>>
>>             <mailto:[email-masked]>

---

From: Gregory McGill <[email-masked]>
Date: Fri, 13 Dec 2013 11:39:26 -0800

eta for shipping is 12/18 takes 7-14 days to get here

Greg