Subject: Scratching my head......

From: "Marc H" <[email-masked]>
Date: Sun, 06 Oct 2013 03:52:57 -0000

My CF card on my SCSI decided to STB today with about 200MB of stuff on it.  Really bites and would be a real nut crusher but I have a backup from about 6 months ago made with TIDIR.  I'll lose some but not all if I can figure out how to get the image written back.....

When I try to use TIDIR to write it back the program complains that the media I am trying to write to is not big enough for the image.  Seems odd as both cards are 256MB.  They are different brands though so that may have something to do with it, I don't know.

I can use TI Image Tool to look at the old image and everything seems to be OK.  Only problem is I can't see a way to get TIT to write it to my card.  Surely there is a way to make this happen ?

Barring this is there a way to force TIDIR to write regardless of the potential size difference ?

Thanks 

Marcus

---

From: [email-masked]
Date: Sun, 06 Oct 2013 09:07:25 -0400

Is the Image a straight sector dump?
If so, a hex editor should be able to write the image back to the CF card.
I use HEX WORKSHOP for this very purpose. I think there's another 
program that functions the same, also.

Tony

On 10/5/2013 11:52 PM, Marc H wrote:
>
> My CF card on my SCSI decided to STB today with about 200MB of stuff 
> on it. Really bites and would be a real nut crusher but I have a 
> backup from about 6 months ago made with TIDIR. I'll lose some but not 
> all if I can figure out how to get the image written back.....
>
> When I try to use TIDIR to write it back the program complains that 
> the media I am trying to write to is not big enough for the image. 
> Seems odd as both cards are 256MB. They are different brands though so 
> that may have something to do with it, I don't know.
>
> I can use TI Image Tool to look at the old image and everything seems 
> to be OK. Only problem is I can't see a way to get TIT to write it to 
> my card. Surely there is a way to make this happen ?
>

---

From: Gregory McGill <[email-masked]>
Date: Sun, 6 Oct 2013 06:11:09 -0700

Dump the new card. Use tools to copy everything to the new dump from the
old one then load it back to the card
On Oct 5, 2013 8:53 PM, "Marc H" <[email-masked]> wrote:

> **
>
>
> My CF card on my SCSI decided to STB today with about 200MB of stuff on
> it. Really bites and would be a real nut crusher but I have a backup from
> about 6 months ago made with TIDIR. I'll lose some but not all if I can
> figure out how to get the image written back.....
>
> When I try to use TIDIR to write it back the program complains that the
> media I am trying to write to is not big enough for the image. Seems odd as
> both cards are 256MB. They are different brands though so that may have
> something to do with it, I don't know.
>
> I can use TI Image Tool to look at the old image and everything seems to
> be OK. Only problem is I can't see a way to get TIT to write it to my card.
> Surely there is a way to make this happen ?
>

---

From: "Ksarul" <[email-masked]>
Date: Sun, 06 Oct 2013 10:11:16 -0400

You might also want to try to use Hex Workshop to pull whatever data it can
find off of the card that crashed-you may be able to recover some of it.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Gregory McGill
Sent: Sunday, October 06, 2013 9:11 AM
To: ti994a
Subject: Re: [TI994A] Scratching my head......

Dump the new card. Use tools to copy everything to the new dump from the old
one then load it back to the card

My CF card on my SCSI decided to STB today with about 200MB of stuff on it.
Really bites and would be a real nut crusher but I have a backup from about
6 months ago made with TIDIR. I'll lose some but not all if I can figure out
how to get the image written back.....

I can use TI Image Tool to look at the old image and everything seems to be
OK. Only problem is I can't see a way to get TIT to write it to my card.
Surely there is a way to make this happen ?

Barring this is there a way to force TIDIR to write regardless of the
potential size difference ?

Thanks 

Marcus

---

From: Marc Hull <[email-masked]>
Date: Sun, 6 Oct 2013 08:32:13 -0700 (PDT)

It's whatever TIDIR creates.   The card that crashed out is not even recognized as a scuzzy card anymore.  I'll try and dump it raw for posterity and reload the backup.  Really hope this works ;-)...

________________________________
 From: "[email-masked]" <[email-masked]>
To: [email-masked] 
Sent: Sunday, October 6, 2013 8:07 AM
Subject: Re: [TI994A] Scratching my head......

Is the Image a straight sector dump?
If so, a hex editor should be able to write the image back to the
      CF card.
I use HEX WORKSHOP for this very purpose. I think there's another
      program that functions the same, also.

Tony

On 10/5/2013 11:52 PM, Marc H wrote:

>When I try to use TIDIR to write it back the program
              complains that the media I am trying to write to is not
              big enough for the image. Seems odd as both cards are
              256MB. They are different brands though so that may have
              something to do with it, I don't know.
>
>I can use TI Image Tool to look at the old image and
              everything seems to be OK. Only problem is I can't see a
              way to get TIT to write it to my card. Surely there is a
              way to make this happen ?
>
>Barring this is there a way to force TIDIR to write
              regardless of the potential size difference ?

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 6 Oct 2013 13:18:55 -0500

Agree -dump it raw and save it.  Dump it twice just in case the first image is bad.

If the file structure got corrupted, that is generally recoverable with some effort. 

To: [email-masked]
From: [email-masked]
Date: Sun, 6 Oct 2013 08:32:13 -0700
Subject: Re: [TI994A] Scratching my head......

  

Is the Image a straight sector dump?
If so, a hex editor should be able to write the image back to the CF card.
I use HEX WORKSHOP for this very purpose. I think there's another program that functions the same, also.

Tony

Thanks 

Marcus

---

From: Marc Hull <[email-masked]>
Date: Sun, 6 Oct 2013 17:21:12 -0700 (PDT)

I dumped the bad card twice and saved it using a raw disk copy tool.  Seemed to do the job.  Re-initialized the card and DL'd the backup to it so it's good to go.

Found a loose ground wire on my power switch that runs the IDE/SCSI bridge card so I am assuming that glitched it.

Couple of quick questions....

Are not all 256MB CF cards 256MB ?  Or is there some card specific problems I am seeing ?

It appears that my directory or allocation table or whatever you call it on the saved image from the crash out has been thrashed.  The volume name has been changed to the last file I saved to it and a search for a directory I would like to get back returns no match so I imagine all the directory names are gone which begs the question how do I find the files ?  I guess search for a file name and hope for the best ?

________________________________
 From: Insane Multitasker <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Sunday, October 6, 2013 1:18 PM
Subject: RE: [TI994A] Scratching my head......

 

  

Tony