Subject: New Carts

From: Dan Eicher <[email-masked]>
Date: Mon, 7 Sep 2015 09:46:26 -0400

Hi,
 I have Bill Gaskill's book, Collecting Cartridges. I've not been able to
contact Bill in the recent past via email.

  Does anyone have a list of the cartridges released in the last 5 years
and the authors?

Thanks,
Dan

PS.. Is it me, or have posting on this list been *REALLY* sparse?

---

From: Gregory McGill <[email-masked]>
Date: Mon, 7 Sep 2015 09:44:52 -0700

Carts that have been released in the last 5 years that I know of are turbo
forth 3 in 1 Rasmus games, flappy bird, Jet Set Willy, sabrewulf and then
there are the multi carts that have been released that include 5/game
cartridges with all of the TI games released on them and a utility
cartridge then also there is an extended basic 2.7 suite cartridge and an
RxB cartridge and the three xB cartridge

All these have been talked about on the Atariage TI 99 forums... and most
of them are available via my website arcadeshopper.com

Greg
On Sep 7, 2015 6:46 AM, "Dan Eicher [email-masked] [TI994A]" <

---

From: Jeff White <[email-masked]>
Date: Tue, 8 Sep 2015 19:51:36 -0400

In addition to Mark Wills' Turbo Forth (http://turboforth.net) that you mentioned, there is also Lee Stewart's fbForth cartridge.

I keep wondering where the 4A Forthers Bill Sullivan and John Carver have been during this Forth revival.

Jeff White

> On 07 Sep 2015, at 12:44, "Gregory McGill [email-masked] [TI994A]" <[email-masked]> wrote:
> 
> Carts that have been released in the last 5 years that I know of are turbo forth 3 in 1 Rasmus games, flappy bird, Jet Set Willy, sabrewulf and then there are the multi carts that have been released that include 5/game cartridges with all of the TI games released on them and a utility cartridge then also there is an extended basic 2.7 suite cartridge and an RxB cartridge and the three xB cartridge
> 
> All these have been talked about on the Atariage TI 99 forums... and most of them are available via my website arcadeshopper.com
> 
> Greg
> 
>> On Sep 7, 2015 6:46 AM, "Dan Eicher [email-masked] [TI994A]" <[email-masked]> wrote:
>>  
>> 
>> Hi, 
>>  I have Bill Gaskill's book, Collecting Cartridges. I've not been able to contact Bill in the recent past via email.
>> 
>>   Does anyone have a list of the cartridges released in the last 5 years and the authors?
>> 
>> Thanks,
>> Dan
>>

---

From: "John H. Carver Jr." <[email-masked]>
Date: Tue, 08 Sep 2015 21:25:58 -0400

*I can't speak for Bill but I'm right 
here where I've always been.  I do not 
have a working 4A console anymore, just 
the Geneve.  Was interested in Mark's 
Forth but can't use the cartridge on the 
Geneve.  With the connection I have I 
can't download anything from the net as 
my most consistent connect speed is 3.8 
kbps and drops the connection every half 
hour or so.  Since my surgeries of a 
year ago I'm pretty much stranded here 
on the compound.  Don't drive anymore, 
don't have a working vehicle anymore and 
get off the compound once a month when I 
can find someone to give me a ride to 
the grocery store for supplies.

But I still Forth when I can.  I have 
followed every Forth discussion that's 
ever been on this list.  Just can't use 
the new products.

As best as I can remember Bill had to 
move and had some health problems also.  
Haven't heard from him since the last 
time he posted on this list.

Nice to hear from you Jeff.  I was 
beginning to think the list was dead.  
My connection won't allow me to go on 
the web to the TI sites.  Hell, it takes 
an hour just to load Amazon's front page.

                            John
                            Forther2
*

On 9/8/2015 7:51 PM, Jeff White 
[email-masked] [TI994A] wrote:
>
>
> In addition to Mark Wills' Turbo Forth 
> (http://turboforth.net) that you 
> mentioned, there is also Lee Stewart's 
> fbForth cartridge.
>
> I keep wondering where the 4A Forthers 
> Bill Sullivan and John Carver have 
> been during this Forth revival.
>
> Jeff White
>

---

From: Jeff White <[email-masked]>
Date: Wed, 9 Sep 2015 20:29:14 -0400

Good to read you, John.

Mark's Turbo Forth is only 2 banks of 8K, so I would think it would run on a Geneve.  Just need to convert it to the common Gram Kracker format use by Gram Kracker, P-GRAM, Geneve.  I have perused the source code on the website ( http://turboforth.net ), and it appears to use the standard link to the keyscan routine rather than direct CRU polling, except for joysticks.  

The Geneve swaps the CRU selects for joysticks, IIRC, so software that bangs CRU directly for joysticks will have 1 and 2 swapped, while software that uses the standard GPL OS keyscan will have them corrected.  Not a big deal with a splitter.

Jeff White

> On 08 Sep 2015, at 21:25, "'John H. Carver Jr.' [email-masked] [TI994A]" <[email-masked]> wrote:
> I can't speak for Bill but I'm right here where I've always been.  I do not have a working 4A console anymore, just the Geneve.  Was interested in Mark's Forth but can't use the cartridge on the Geneve.
> 
>

---

From: Insane Multitasker <[email-masked]>
Date: Wed, 9 Sep 2015 20:23:50 -0500

Jeff,
4-6 years ago at a Chicago Faire, Mark and I tested his then current Turbo Forth files on my Geneve.  As you suggest, I had to 'convert' the files to the common GK format.  I do not recall any other changes with the possible exception of using the TI BASIC groms versus Jim S.'s GPO/GPP menu.  Mark has (had?) a Geneve, maybe he has GK-ready files that could be released.

John, I agree with Jeff, good to see a message from you.

-tim

To: [email-masked]
From: [email-masked]
Date: Wed, 9 Sep 2015 20:29:14 -0400
Subject: Re: [TI994A] New Carts

Good to read you, John.

    

    
I can't speak for Bill but I'm right
        here where I've always been.  I do not have a working 4A console
        anymore, just the Geneve.  Was interested in Mark's Forth but
        can't use the cartridge on the Geneve.