Subject: Re: [TI994A] 512k Cart

From: Jeff White <[email-masked]>
Date: Thu, 22 May 2014 01:22:20 -0400

Is there a document covering these carts and what size (E)EPROM's are supported?

I understand at full 512K there are 64 pages of 8K each.  With a 64K EPROM, 8 pages, does it just mirror them 8 times? Or does it disable paging with all but the first 8 addresses of cartridge ROM?  Or are the "missing" 56 pages randomly selected or phantom pages?

Jeff White

> On 21 May 2014, at 22:11, "'Ksarul' [email-masked] [TI994A]" <[email-masked]> wrote:
> 
> Note one thing—there are a LOT of jumpers on the board—and it works with both 28 and 32 pin EPROMS. You have to make sure the jumpers are set for the proper size EPROM when you assemble it (and if it is a 28 pin EPROM—64K or less, it has to go into the part of the socket furthest away from the 74LS378 with the notch towards the 378). Failure to do so does very bad things to the chip. . .but if you’re planning on installing 512K chips, I’ll make sure your jumpers are set for that and then all you have to do is pop the EPROMs in.
> 
>  
> 
> Jim
> 
>

---

From: "Ksarul" <[email-masked]>
Date: Thu, 22 May 2014 06:29:34 -0400

Jeff, the jumpers on the board set the board to respond to the size of the EPROM you’re using. It will support anything from 8K to 512K, and with the jumpers set to the correct EPROM size, only the pages available in the EPROM are addressed. Paging always starts from the first page at >6000 and works its way upward to the limit of the EPROM. The board is a non-inverting extension of the scheme Jon Guidry used for the 16K and 64K cartridge boards a few years ago.

Jim

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, May 22, 2014 1:22 AM
To: 'Ksarul' [email-masked] [TI994A]
Subject: Re: [TI994A] 512k Cart

Jeff White

Jim

---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com

---

From: [email-masked]
Date: 05 Jun 2014 17:04:24 -0700

It's my understanding that with the jumpers set correctly for the eprom size that is being used, there will be no response to a write to an 'out of bounds' banking address. So no 'Ghosting'.

Tony

---

From: "Ksarul" <[email-masked]>
Date: Thu, 05 Jun 2014 21:13:00 -0400

Tony is correct. The jumpers only route the signals necessary for the
selected chip size to the chip.

Jim

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, June 05, 2014 8:04 PM
To: [email-masked]
Subject: Re: [TI994A] 512k Cart

It's my understanding that with the jumpers set correctly for the eprom size
that is being used, there will be no response to a write to an 'out of
bounds' banking address. So no 'Ghosting'.

Tony  

---