Subject: A couple of quick questions....

From: "kevan064" <[email-masked]>
Date: Tue, 16 Jul 2013 19:10:11 -0000

It's getting closer to order day for the F18A, so in preparation I want
to plan a few things, because while the console is open, I might as well
take care of everything else too.
1) The CAP's LOCK Modification (it's an easy one to do).2) RESET BUTTON
(which pins do I solder the button leads to?)
3) Am I missing something that YOU would do or modify?

Oh, BTW - Is this the best deal on the VGA cable or does someone know a
better
place?http://www.mycablemart.com/store/cart.php?m=product_detail&p=892
<http://www.mycablemart.com/store/cart.php?m=product_detail&p=892>
Thank's!  [:)]

---

From: Marc Hull <[email-masked]>
Date: Tue, 16 Jul 2013 12:20:58 -0700 (PDT)

*RES from the CPU to one side of the switch.  Ground on the other. Use a momentary contact switch with an electrolytic for debounce.

PAUSE Switch =    *HOLD from CPU to one side of a SPST switch.  Ground to the other with an electrolytic for debounce.

32K mods......  See mainbyte....

Trash Can mod (use only if you totally botch the others ;-).......  Just kidding, good luck.

________________________________
 From: kevan064 <[email-masked]>
To: [email-masked] 
Sent: Tuesday, July 16, 2013 2:10 PM
Subject: [TI994A] A couple of quick questions....

It's getting closer to order day for the F18A, so in preparation I want to plan a few things, because while the console is open, I might as well take care of everything else too.

1) The CAP's LOCK Modification (it's an easy one to do).
2) RESET BUTTON (which pins do I solder the button leads to?)

Oh, BTW - Is this the best deal on the VGA cable or does someone know a better place?
http://www.mycablemart.com/store/cart.php?m=product_detail&p=892

Thank's!

---

From: "kevan064" <[email-masked]>
Date: Tue, 16 Jul 2013 19:38:23 -0000

Okay, thanks I'll look up the manual...

I've never seen the mod anywhere, I know it exists and I even see one one the NAVARONE WIDGET, so I figured I'd just make the additions to this little thing inside the TI...
http://i.ebayimg.com/t/New-TI-99-4A-TI99-4-HOME-COMPUTER-Console-GROM-CARTRIDGE-PORT-Part-/00/s/NTcyWDEwMjQ=/z/0XAAAOxyzfNRukpp/$T2eC16ZHJIQE9qUHuEt2BRukpph0jw~~60_57.JPG
... but did not know which traces to use.  Oh yeah, how many pico farad should I use?

THANKS!!

---

From: "Tony Knerr" <[email-masked]>
Date: Tue, 16 Jul 2013 22:39:23 -0000

I suggest not using the Grom port reset. It won't work all the time, been there done that. Use the 9900 reset pin instead as Marc suggests.
You can do the same with a load interrupt switch if you're interested in that.

Tony

---

From: Marc Hull <[email-masked]>
Date: Tue, 16 Jul 2013 17:46:59 -0700 (PDT)

Just use any old can lying around.  I doubt you will find one in the pF range but I guess ideally a 2.2 uF would do the trick.  All you are trying to do is prevent false clocks (any slow charge AKA electrolytic cap will do.)  DL a 9900 data sheet and find the RESET or HOLD pins.  put a dab of flux on them and then a splotch of solder.  Tin the end of a wire and then touch the wire (firmly) to the pin and put your iron on it.  Watch the junction and when the solder rises remove the iron (but hold the wire still until is shines.)  OHM from the pin you soldered to each adjacent pin just to verify that you haven't cemented them together and you are off to the races.  If you have bridged a pin the just heat it up and wick it off.....or suction it off or slap it off or whatever get's the job done.  I have slapped many a board against the wall to get floaters off.  Don't swing for the fences...just enough to flick off the blobs.

It's a bit scary to to heat a CPU pin for the first time but it's not that big a deal.  As long as you don't use an arc welder I'm sure it will work.)  TI gear is designed to be used and abused and lord know I have assaulted my fair share and like a Timex.... It takes a licken and keeps on ticken.....  

Long story short you seem to be enthusiastic and I would say proceed.  You can't make an omelet if you don't break some eggs..... The future belongs to the bold etc...etc....  I am out of euphemisms and we need more people who want to do this kind of stuff so.......

Take a chance and just do it.   If it goes bad then get another console and do it again.  Eventually you will get what you want and we get a new hardware guy....

Damn worth the effort I can promise you ;-)....

________________________________
 From: kevan064 <[email-masked]>
To: [email-masked] 
Sent: Tuesday, July 16, 2013 2:38 PM
Subject: [TI994A] Re: A couple of quick questions....

THANKS!!

---

From: Jeff White <[email-masked]>
Date: Tue, 16 Jul 2013 21:36:52 -0400

Remind me, what does this reset do that the slide switch in front of the coffee warmer does not do?

Jeff White

---

From: Marc Hull <[email-masked]>
Date: Tue, 16 Jul 2013 20:37:31 -0700 (PDT)

Makes for a cooler system (unless you don't have the nards to work on your own) then it's the same.  Hardware guy's have to start somewhere though don't they ?

________________________________
 From: Jeff White <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Tuesday, July 16, 2013 8:36 PM
Subject: Re: [TI994A] Re: A couple of quick questions....

Jeff White

---

From: "kevan064" <[email-masked]>
Date: Wed, 17 Jul 2013 06:01:40 -0000

Thanks, I'll take advantage of your experience and advice and not use the GROM port method.   I'm not sure that I'd ever use a load interrupt, but hey, there is always room to grow in the hobby so why not do it now?  I'll try to locate a suitable button and switch for the project that is aesthetically pleasing .

--- In [email-masked], "Tony Knerr" <tonyknerr@...> wrote:
>
> I suggest not using the Grom port reset. It won't work all the time, been there done that.

---

From: "kevan064" <[email-masked]>
Date: Wed, 17 Jul 2013 06:05:29 -0000

Okay, I found RESET to be Pin 6 and VSS or GND to be pin 40.  Correct?  

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
>
> *RES from the CPU to one side of the switch.Â  Ground on the other. Use a momentary contact switch with an electrolytic for debounce.
>

---

From: "kevan064" <[email-masked]>
Date: Wed, 17 Jul 2013 06:13:13 -0000

<GRIN>  Oh, we're being practical? ;)
I was just thinking it would be quicker, save some wear and tear on that 30 year old switch and.... it would just look cool!  

I guess it just comes down to, "It's my hobby and I want to play."  I suppose I could have saved a lot of money and just stuck with an emulator, after all, that is what a lot of people do, and they enjoy it too. I on the other hand wanted the real thing to give me something to do, relive my youth, and have some fun with.

---

From: "kevan064" <[email-masked]>
Date: Wed, 17 Jul 2013 06:19:21 -0000

It's been over 23 years since I opened one up.  Back when consoles could be picked up for $5.00 at garage sales I operated on quite a few, nothing extensive though, mainly just the CAPS LOCK fix, swapping a few keyboards and power supplies and installing a fan or two.

You know what would be really cool?  If someone with a 3D printer started making side-car boxes like the one pictured in this link:

http://aug.99er.net/images/TI99_4A/dscn1608.jpg

Can you imagine what guys could or would would put in them?

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
>
> Makes for a cooler system (unless you don't have the nards to work on your own) then it's the same.Â  Hardware guy's have to start somewhere though don't they ?
> 
> 
> 
>  From: Jeff White <ti994a@...>
> Â  
> On 16 Jul 2013, at 18:39, "Tony Knerr" <tonyknerr@...> wrote:
> 
> Â

---

From: Jeff White <[email-masked]>
Date: Wed, 17 Jul 2013 08:36:12 -0400

I think it would be cooler to have the switch disable reset function unless active.  This would allow swapping cartridges without reset and prevent execution of power up routines.

Thierry Nouspikel's modifications to remove wait states on 8-bit bus are worth exploring.  Jeff Brown's interrupt modification is neat.  Scroll down to bottom of the page http://www.nouspikel.com/ti99/titechpages.htm for console modifications.

Jeff White

---

From: "kevan064" <[email-masked]>
Date: Wed, 17 Jul 2013 14:55:29 -0000

Hey, that looks pretty slick!  I've printed it out and will check it out when I have a little more time.  Thanks for pointing me in the right direction.

---

From: "sgrub00" <[email-masked]>
Date: Wed, 17 Jul 2013 19:27:10 -0000

A Raspberry Pi?

--- In [email-masked], "kevan064" <kevan064@...> wrote:
> --- In [email-masked], Marc Hull <marc.hull@> wrote:
> >
> >  From: Jeff White <ti994a@>
> > On 16 Jul 2013, at 18:39, "Tony Knerr" <tonyknerr@> wrote:
> > 
> > Â

---

From: "kevan064" <[email-masked]>
Date: Thu, 18 Jul 2013 00:27:48 -0000

I suppose you could.  It's not my thing, but I've read how the inventor of the Nano-PEB & CF7 is playing with the Pi and wants to connect the two.  It would be the ultimate connection for the two from an a completely aesthetic point of view.

Jeez, come to think of it, it would be perfect type box for the Nano too!  A guy could drill a few holes, extend the LEDs, make a slot for the CF card.  

A 3D printer could be a solution to a lot of projects with the TI.  One could print out cartridges that were 'just a tad larger' for new projects.  Or, how about a base/box that the TI could sit on? This box could hide a breadboard arrangement for hardware designers.  If it was like an inch and a half thick and slightly sloped a person could store a lot of stuff underneath and not take up any extra desk space.  

Do they have silver plastic for 3D printers?  I know it would not look exactly the same, but a two-tone side car for stuff I would buy.

---

From: Marc Hull <[email-masked]>
Date: Wed, 17 Jul 2013 19:15:26 -0700 (PDT)

Remind me.... what would an anti-reset switch do that a little tape over the pin on the cart would not ?

Sent: Wednesday, July 17, 2013 7:36 AM

Jeff White

---

From: Marc Hull <[email-masked]>
Date: Wed, 17 Jul 2013 19:19:50 -0700 (PDT)

yes *RES is pin 6 and *hold is pin 64.  You can pick up you grounds anywhere you can find one.  You are simply driving the lines low.  Both are protected by pull ups (IIRC) so no need to redo that bit.  The cap is not really needed in my experience but probably good practice.

Sent: Wednesday, July 17, 2013 1:05 AM

---

From: "kevan064" <[email-masked]>
Date: Thu, 18 Jul 2013 02:35:52 -0000

Marc,  Thank you so much for your excellent help & advice!  I'm going to
take what you told me and implement it!  [:)]
   I guess all I have to do now is find the appropriate switch & button
(hopefully matching)!  Any advice on that too?  [:-/]
   I'll run with the caps, they are cheap and any job worth doing is
worth doing right.
   Someday I'll even put the speech in the console, but I'm to chicken to
try that right now!  [:">]
--- In [email-masked], Marc Hull  wrote: >
> yes *RES is pin 6 and *hold is pin 64.Â  You can pick up you
grounds anywhere you can find one.Â  You are simply driving the lines
low.Â  Both are protected by pull ups (IIRC) so no need to redo that
bit.Â  The cap is not really needed in my experience but probably
good practice.

---

From: Marc Hull <[email-masked]>
Date: Thu, 18 Jul 2013 05:37:10 -0700 (PDT)

Radio shack has buttons that fit the bill.  Round with colored caps (red for reset and black for pause is what I did) so all that is required is drilling a hole and wiring it up.  Make sure you get the momentary contact for the reset and the SPST for the pause.  As far as speech in the console goes there is another method that moves most of the soldering to the cart connector instead of tying straight to the expansion fingers.  It is a bit easier to do.  it is contained in the manual----> Chicago TI/99 User's Group Presents User's Groups Hardware Reprints <--- available on Ernie's book archive (along with a bunch of other useful mods.)  Good luck and have fun.

Hull

Sent: Wednesday, July 17, 2013 9:35 PM

Marc,
  Thank you so much for your excellent help & advice!  I'm going to take what you told me and implement it!   

  I guess all I have to do now is find the appropriate switch & button (hopefully matching)!  Any advice on that too? 

  I'll run with the caps, they are cheap and any job worth doing is worth doing right.

  Someday I'll even put the speech in the console, but I'm to chicken to try that right now! 

--- In [email-masked], Marc Hull  wrote:
>
> yes *RES is pin 6 and *hold is pin 64.Â  You can pick up you grounds anywhere you can find one.Â  You are simply driving the lines low.Â  Both are protected by pull ups (IIRC) so no need to redo that bit.Â  The cap is not really needed in my experience but probably good practice.
>

---

From: "kevan064" <[email-masked]>
Date: Thu, 18 Jul 2013 14:42:26 -0000

Hey Marc,
   That is quite the hand book, filled with lots of tempting goodies.  Damn, I really love these PDF files; find something you like on one page, press PRINT, and you're good to go! 

 I will be doing the RESET & HOLD for sure, but I'm not sure I'd ever use the LOAD button.  Have you?

---

From: Gregory McGill <[email-masked]>
Date: Thu, 18 Jul 2013 07:46:33 -0700

http://pergrem.com/tibooks/   Ernie's book archive for those with weak
googlefu

On Thu, Jul 18, 2013 at 5:37 AM, Marc Hull <[email-masked]> wrote:

> **
>
>
> Radio shack has buttons that fit the bill.  Round with colored caps (red
> for reset and black for pause is what I did) so all that is required is
> drilling a hole and wiring it up.  Make sure you get the momentary contact
> for the reset and the SPST for the pause.  As far as speech in the console
> goes there is another method that moves most of the soldering to the cart
> connector instead of tying straight to the expansion fingers.  It is a bit
> easier to do.  it is contained in the manual ----> Chicago TI/99 User's
> Group Presents User's Groups Hardware Reprints <--- available on Ernie's
> book archive (along with a bunch of other useful mods.)  Good luck and have
> fun.
>
> Hull
>
>
>
>
>   ------------------------------
>  *From:* kevan064 <[email-masked]>
> *To:* [email-masked]
> *Sent:* Wednesday, July 17, 2013 9:35 PM
>
> *Subject:* [TI994A] Re: A couple of quick questions....
>
>
>  Marc,
>   Thank you so much for your *excellent* help & advice!  I'm going to
> take what you told me and implement it! 
>
> (hopefully matching)!  Any advice on that too? 
>
> try that right now! 
> > yes *RES is pin 6 and *hold is pin 64.Â  You can pick up you grounds
> anywhere you can find one.Â  You are simply driving the lines low.Â  Both
> are protected by pull ups (IIRC) so no need to redo that bit.Â  The cap is
> not really needed in my experience but probably good practice.
> >
>
>
>   
>

---

From: Marc Hull <[email-masked]>
Date: Thu, 18 Jul 2013 13:56:35 -0700 (PDT)

If you program in assembly it can come in handy or if you want to do a screen dump but usually not much....

Sent: Thursday, July 18, 2013 9:42 AM

Hey Marc,

---

From: "kevan064" <[email-masked]>
Date: Fri, 19 Jul 2013 01:49:27 -0000

I detest, Rip Shock, but I went in there today on your suggestion anyway...  I left without anything.  $5.00 per switch X 3 and $1.99 per capacitor?  I'd like to be able to tell you what I think of their prices, but Yahoo has a community standards policy, and I do not want to get into trouble. Nuff said on that!  

Sooooo, if anyone has a suggestion for an online place to buy nice looking switches, I'll check it out.  Even paying a moderate shipping fee is better than rewarding the place I just came from. 

--- In [email-masked], Marc Hull <marc.hull@...> wrote:
>
> Radio shack has buttons that fit the bill.

---

From: Marc Hull <[email-masked]>
Date: Thu, 18 Jul 2013 20:07:03 -0700 (PDT)

Maybe if you look at it from a convenience standpoint it will make a bit more sense.  Where else can you walk in and buy small electronic switches and other parts ?  There is no place around here that does it anyway.  heck you can't go to a movie with the old lady for 16 bucks and it's over in under two hours and you got popcorn stuck in your teeth.

Try Mouser or Jameco or Digikey.  They carry these parts online.

Sent: Thursday, July 18, 2013 8:49 PM

---

From: "Ksarul" <[email-masked]>
Date: Thu, 18 Jul 2013 23:47:36 -0400

Unicorn Electronics.  Note their Minimum order is $25+shipping.

Jameco

Digikey

Mouser Electronics

Arrow Electronics

Minimum orders are about the same for all of them. . .

Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of
kevan064
Sent: Thursday, July 18, 2013 9:49 PM
To: [email-masked]
Subject: [TI994A] Re: A couple of quick questions....

I detest, Rip Shock, but I went in there today on your suggestion anyway...
I left without anything. $5.00 per switch X 3 and $1.99 per capacitor? I'd
like to be able to tell you what I think of their prices, but Yahoo has a
community standards policy, and I do not want to get into trouble. Nuff said
on that! 

Sooooo, if anyone has a suggestion for an online place to buy nice looking
switches, I'll check it out. Even paying a moderate shipping fee is better
than rewarding the place I just came from.

---

From: "hexbus" <[email-masked]>
Date: Fri, 19 Jul 2013 18:27:37 -0000

Mouser has no minimum order, and will ship first class mail if you put at in the comments box.  I get small orders of stuff there all the time.

Jon

--- In [email-masked], "Ksarul" <vze23g4a@...> wrote:
> <marc.hull@> wrote: