Subject: Tom Freeman

From: [email-masked]
Date: 16 Mar 2017 19:16:23 +0000

For anyone who remembers Tom, his wife Joan passed away last week. Memorial is April 2, I will be attending.

 Hugs
 Terrie

 Sure missing my TI Buddies. Did have a short conversation with Walt Howe recently, very short.

---

From: Winston <[email-masked]>
Date: Thu, 16 Mar 2017 15:32:31 -0400

I'm so sorry to hear that!

Sent from my iPhone

> On Mar 16, 2017, at 15:16, [email-masked] [TI994A] <[email-masked]> wrote:
> 
> 
>

---

From: [email-masked]
Date: Thu, 16 Mar 2017 21:19:31 +0000 (UTC)

Best wishes to Tom at this time. 

Rich 

----- Original Message -----

From: "[email-masked] [TI994A]" <[email-masked]> 
To: [email-masked] 
Sent: Thursday, March 16, 2017 12:16:23 PM 
Subject: [TI994A] Tom Freeman 

Hugs 

Terrie