Subject: IDE DSR V11 is out

From: [email-masked]
Date: 17 Dec 2014 11:04:42 -0800

Finally ... it is finished and I'm satisfied with it ... IDE DSR V11.

The IDE DSR is available at http://www.ti99-geek.nl http://www.ti99-geek.nl

It was brought under my attention that the IDE DSR had some errors with relative files. I've spent a lot of time from oktober 1st 2013 until now debuging and testing. The last phase was writing 25 testprograms in good old TI-basic for reading and writing all kind of files (input, output, update, append in sequential and relative mode).

All these test programs creates the same file on both a DSK and an IDE device. At the end all records of the file on the IDE device was compared with the records of the file on the DSK device. All 25 programs finishes now with no errors when run in my emulator Ti994w and on a TI99/4A with TI diskcontroller and IDE card. However, two programs always failed on my Geneve with HFDC diskcontroller and IDE card (?) and it seemed to me that the file on the floppy had the problems (scrambled records) and that the file on the IDE card was correct.

I was using a PC version of Asm990 but again found some problems with this assembler that also causes errors in the DSR: some silly syntax error stayed unnoticed (if I remember correctly it was something like MOV R8,  R9 which was translated into something like MOV R8,@>0 and that is something completely different). Because I didn't wan't to fix this assembler again (allready did that a few times) I decided to write my own cross assembler and I'm using this one from now on for every project. This assembler generates (mostly) the same object file format and listing format as the assembler of the editor/assembler module. This simplyfies things a lot when comparing object and listing files when trying to find problems. This assembler will get its own page one of these days.

Anyway ... enjoy the new DSR

Fred ;-)

---

From: [email-masked]
Date: 17 Dec 2014 14:43:22 -0800

Thanks Fred! 

Now that you have a DSR that is bug free, it's a good time for us to start building those through-hole IDE cards that are being designed.

Tony

---

From: "Chris Schneider" <[email-masked]>
Date: Wed, 17 Dec 2014 16:59:16 -0600

I’d take a couple of the Through-hole IDE boards!

From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, December 17, 2014 4:43 PM
To: [email-masked]
Subject: [TI994A] Re: IDE DSR V11 is out

Thanks Fred! 

Tony