Subject: Corcomp 9900 Mini Expansion System

From: [email-masked]
Date: Mon, 03 Nov 2014 10:06:33 -0500

There is a new DSR available for the Corcomp 9900 Mini Expansion System.

Owners of the device have suffered from the same problem as those with 
the Corcomp Disk Controller DSR before the Millers Graphics eproms were 
created. The original Corcomp code takes control of the powerup sequence 
of the TI and provides it's own menu. Unfortunately this menu creates 
incompatibilities with a number of TI devices and programs.The Millers 
Graphics eproms for the Corcomp Disk Controller removed the menu and 
associated code, fixing this incompatibility for the card. The Mini 
Expansion System DSR code recently became available and a quick 
disassembly showed a simple fix to remove the Menu. There is only a 10 
byte difference in the code, NOPs were used to replace the part in the 
code that branched to the hostile takeover by the menu code. The code 
was tested on real hardware at the Chicago Faire, and normal operation 
of the TI menu is restored, along with proper operation of the Corcomp 
hardware.

  The fixed Eprom code is attached to this message. Bob Carmany has 
possession of the code and has agreed to supply Eproms for those that 
are interested.

  Tony

---

From: Gregory McGill <[email-masked]>
Date: Mon, 3 Nov 2014 08:06:24 -0800

Awesome!

On Mon, Nov 3, 2014 at 7:06 AM, [email-masked] [TI994A] <
[email-masked]> wrote:

>
>  [Attachment(s) <#14976312528d2226_TopText> from [email-masked]
> included below]
>

---

From: Gregory McGill <[email-masked]>
Date: Mon, 3 Nov 2014 08:07:58 -0800

I can also burn eproms will be adding this to the arcadeshopper.com TI
eproms store item

On Mon, Nov 3, 2014 at 8:06 AM, Gregory McGill <[email-masked]>
wrote:

>>  [Attachment(s) <#1497668420d908a8_14976312528d2226_TopText> from
>> [email-masked] included below]
>>

---

From: Barry Peterson <[email-masked]>
Date: Mon, 3 Nov 2014 16:30:44 -0500

On Mon, Nov 3, 2014 at 10:06 AM, [email-masked] [TI994A] <
[email-masked]> wrote:

>
>          Bob Carmany has possession of the code and has agreed to supply
> Eproms for those that are interested.
>

 I'm interested, if Bob can drop one by on his next trip to my
neighborhood...

---

From: Jeff White <[email-masked]>
Date: Tue, 4 Nov 2014 03:28:50 -0500

Did the source code for any of the Corcomp or Miller Graphics DSR's get released?

When I quickly scanned your message in preview, I thought you had gotten the MG EPROM to work with the CC 9900 MES.  I understand now that it is the CC DSR with power-up menu removed.  Still a good thing.

Jeff White

> On 03 Nov 2014, at 10:06, "[email-masked] [TI994A]" <[email-masked]> wrote:

---

From: [email-masked]
Date: 04 Nov 2014 14:27:59 -0800

I've never seen the source for any of the MG DSRs. I asked about the Disk Controller DSR a few years back in hopes of adding an 80 track option using the dip switches. Nobody ever came up with the source, though. It's too tough a project for me to use a disassembly for, I would need original source.

Tony

---

From: Jeff White <[email-masked]>
Date: Thu, 6 Nov 2014 00:14:54 -0500

There were a few versions of the CC FDC.  Some used the 2793, some the 1773, some a daughterboard converting one to the other.  I am pretty sure the 2793 and 1773 were software compatible.  I.e., the command registers were bitwise the same.

I have a CC 9900 MES, but I am not sure what is in it or if it uses the same DSR as the FDC.  I do not think I have a CC FDC, but I recall seeing it and the 9901.

So none of the CC- or MG-written DSR source codes are available.  Does anyone know who wrote them?  Maybe we could ask for the source?

Jeff White

> On 04 Nov 2014, at 17:27, "[email-masked] [TI994A]" <[email-masked]> wrote: