Subject: A SCON problem

From: "Jacques" <[email-masked]>
Date: Sun, 20 Apr 2014 16:45:53 -0300

I find that I can no longer access CALL SCON with my HSGPL card. The CALL statement seems to be accepted but Super Cart programs will not run. I believe that I can use most of the other HSGPL CALL statements.

As an attempt at a partial work around I was able to transfer the contents of the db_super_space_2.rpk file from a HSGPL configuration on MESS to my TI-99/4A. It does not work exactly the same on my TI as it does in MESS. On MESS I run FW from the EA section of the SSII module and then most super cart programs can be run from FW. On my TI I have to do a CALL BANK(8) followed by CALL RAM6000 and even then some SC programs will not work.

While on the subject of the HSGPL card, what is the purpose of the file HSGPK.p99 that is on the SNUG site. This file contains a reference to HSGPLDSR2.

I have back up copies of the contents of my HSGPL banks, but since I never had to initiate the card when I first acquired it I would not know where to start if that is how to solve my SCON problem.

Jacques

---

From: <[email-masked]>
Date: 22 Apr 2014 06:09:36 -0700

Jacques,

if you have evidence that the observed behavior of your real HSGPL differs from the emulation, please notify me (in case you know that your HSGPL is working correctly, of course). The behavior of the emulation is the consequence of what I understood from the manual. I may be wrong.

Michael

---

From: "Jacques" <[email-masked]>
Date: Tue, 22 Apr 2014 11:06:49 -0300

Michael,

My MESS version is 148. Somewhere on my ‘To Do’ list is an item to update to a more current version of MESS. When I first installed HSGPL on MESS it did not support SCON and you suggested that the module for Super Space II be used instead. This works but is a bit more awkward than using CALL SCON with HSGPL. I was trying to use the same work around for my problem with SCON on my real TI. 

Once I have resolved my TI problem and upgraded my MESS installation I will pass on any differences I see in using HSGPL.

Regards,

Jacques 

From: [email-masked] 
Sent: Tuesday, April 22, 2014 10:09 AM
To: [email-masked] 
Subject: [TI994A] Re: A SCON problem

Jacques,

Michael