Subject: RE: [TI994A] MPES50

From: Marc Hull <[email-masked]>
Date: Sat, 28 Jun 2014 13:57:46 -0700

32k tests fine.  Rs233 & pio work.

Pdm module reports no disk controller.  XB tries but times out.

Drive light doesn't come on.

------------------------------
On Sat, Jun 28, 2014 3:40 PM CDT Insane Multitasker [email-masked] [TI994A] wrote:

>Marc,  I don't think there are schematics available for any Myarc products with the exception of the HFDC and Geneve.  I definitely do not recall having access to any during my days @ Cecure.  Then again, stranger information has surfaced in the TI world :)
>
>What are the symptoms?
>
>To: [email-masked]
>From: [email-masked]
>Date: Sat, 28 Jun 2014 10:42:06 -0700
>Subject: [TI994A] MPES50
>
>
>
>
>
>
>
>
>        
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>Does anyone have a schematic for the Myarc MPES50 ?  I have one with a dead FDC that I'd like to get operational again.
>
>Thanks in advance
>
>Marc
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 28 Jun 2014 16:19:06 -0500

I'd double-check the power and cables to the drives.   The timeout infers (to me) the controller is probably functioning, at least well enough to know you are trying to access a disk.  If the EPROM wasn't accessible, and the buffer chips between RAM/EPROM were toast, you would get a more immediate device not found error. 

> To: [email-masked]
> Date: Sat, 28 Jun 2014 13:57:46 -0700
> Subject: RE: [TI994A] MPES50
> 
> 
> 
> ------------------------------------
> Posted by: Marc Hull <[email-masked]>
> ------------------------------------
> 
> 
> ------------------------------------
> 
> Yahoo Groups Links
> 
> 
>

---

From: [email-masked]
Date: Sat, 28 Jun 2014 17:28:43 -0400

You might also want to try a memory editor, turn on the CRU for the disk 
controller (>1100) and look to see if the DSR code shows up at c>4000.

Tony

On 6/28/2014 5:19 PM, Insane Multitasker [email-masked] [TI994A] 
wrote:
>
> I'd double-check the power and cables to the drives.   The timeout 
> infers (to me) the controller is probably functioning, at least well 
> enough to know you are trying to access a disk.  If the EPROM wasn't 
> accessible, and the buffer chips between RAM/EPROM were toast, you 
> would get a more immediate device not found error.
>
>

---

From: [email-masked]
Date: Sat, 28 Jun 2014 18:07:10 -0400

Is anyone else having problems with the 7805 on their SCSI card going 
bad every year or so?
I'm thinking of drilling a few more holes in the bottom right corner of 
the card to mount a 5 amp TO3 regulator there,
or maybe putting header pins in the regulator holes and running a cable 
to a TO3 mounted on the case somewhere.

Tony

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 28 Jun 2014 17:43:03 -0500

I have not had this problem with either my original "E" or modified "F" cards.

I am using a PC power supply with 12v connected to the 5v input.

Was a second regulator added to some cards?  I guess Richard would probably know best.

Is the dying regulator associated with termination? Are you using the SCSI card but not turning on all of the devices on the chain? 

> Date: Sat, 28 Jun 2014 18:07:10 -0400
> Subject: [TI994A] SCSI card vr
> 
> Posted by: [email-masked]

---

From: [email-masked]
Date: Sat, 28 Jun 2014 19:35:40 -0400

Modified 'F' card. Original unmodified 'E' card has always been rock 
stable, knock on wood.

PC power supply also.

There's a spot for a 2nd regulator, but it's connections are jumpered to 
the 1st regulator.
Maybe I should undo the jumpers and install a 2nd regulator?

Termination ok, 3 drives 2 terminators.

I'm sort of partial to mounting the TO3, I don't get to break out the 
drill much. (Tim the tool man grunt) :-)

Tony

On 6/28/2014 6:43 PM, Insane Multitasker [email-masked] [TI994A] 
wrote:
> Is the dying regulator associated with termination? Are you using the 
> SCSI card but not turning on all of the devices on the chain?
>

---

From: Insane Multitasker <[email-masked]>
Date: Sat, 28 Jun 2014 19:51:39 -0500

Both of my Rev "F" cards have two regulators installed, with heat sinks.  Not sure what if anything is required to use one versus two.  Richard modified the cards when the daughterboard was added.  

"E" card has only one regulator with heat sink.  Like yours, rock solid, though I only use it for MDOS testing these days.

To: [email-masked]
From: [email-masked]
Date: Sat, 28 Jun 2014 19:35:40 -0400
Subject: Re: [TI994A] SCSI card vr

    

    Modified 'F' card. Original unmodified
      'E' card has always been rock stable, knock on wood.

      PC power supply also.

      There's a spot for a 2nd regulator, but it's connections are
      jumpered to the 1st regulator.

      I'm sort of partial to mounting the TO3, I don't get to break out
      the drill much. (Tim the tool man grunt)  :-) 

      Tony

      On 6/28/2014 6:43 PM, Insane Multitasker [email-masked]
      [TI994A] wrote:

            

            I have not had this problem with either my
              original "E" or modified "F" cards.

              I am using a PC power supply with 12v connected to the 5v
              input.

              Was a second regulator added to some cards?  I guess
              Richard would probably know best.

              Is the dying regulator associated with termination? Are
              you using the SCSI card but not turning on all of the
              devices on the chain?

---

From: [email-masked]
Date: Sat, 28 Jun 2014 21:08:13 -0400

Can you post a pic of the front and back of the card in that area?

Maybe I'll forgo the drill in deference to 2 properly connected 
regulators. :-)

Tony

On 6/28/2014 8:51 PM, Insane Multitasker [email-masked] [TI994A] 
wrote:
>
> Both of my Rev "F" cards have two regulators installed, with heat 
> sinks.  Not sure what if anything is required to use one versus two.  
> Richard modified the cards when the daughterboard was added.
>
> "E" card has only one regulator with heat sink.  Like yours, rock 
> solid, though I only use it for MDOS testing these days.
>
>
>
> ------------------------------------------------------------------------
> There's a spot for a 2nd regulator, but it's connections are jumpered 
> to the 1st regulator.
> <mailto:[email-masked]> [TI994A] wrote:
>
>
>     Is the dying regulator associated with termination? Are you using
>     the SCSI card but not turning on all of the devices on the chain?
>
>

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 29 Jun 2014 01:38:01 -0500

If my unaided visual inspection is accurate one regulator powers the chips. The second regulator output routes to header 4's right-most through-hole, which connects to Diode D1, which feeds to capacitor C3 and one leg of each of the three terminating resistors installed on the card near the SCSI connectors.  I do not know if all "F" cards are configured in this manner. The card I looked at is serial #87, built 5-97 if the tag is accurate.

Give me a few days to locate my loupe and ohmmeter. There are five capacitors installed yet only four marked on the board.   I'll try to sort out exactly what's going on.  I'll even try to get a picture or two.  

To: [email-masked]
From: [email-masked]
Date: Sat, 28 Jun 2014 21:08:13 -0400
Subject: Re: [TI994A] SCSI card vr

    

    Can you post a pic of the front and
      back of the card in that area?

      Tony

      On 6/28/2014 8:51 PM, Insane Multitasker [email-masked]
      [TI994A] wrote:

            

            Both of my Rev "F" cards have two regulators
              installed, with heat sinks.  Not sure what if anything is
              required to use one versus two.  Richard modified the
              cards when the daughterboard was added.  

              "E" card has only one regulator with heat sink.  Like
              yours, rock solid, though I only use it for MDOS testing
              these days.

              

                

                Modified 'F' card.
                  Original unmodified 'E' card has always been rock
                  stable, knock on wood.

                  PC power supply also.

                  There's a spot for a 2nd regulator, but it's
                  connections are jumpered to the 1st regulator.

                  Maybe I should undo the jumpers and install a 2nd
                  regulator?

                  I'm sort of partial to mounting the TO3, I don't get
                  to break out the drill much. (Tim the tool man grunt)  :-) 

                  Tony

                

                    I have not had this problem with
                      either my original "E" or modified "F" cards.

                      I am using a PC power supply with 12v connected to
                      the 5v input.

                      Was a second regulator added to some cards?  I
                      guess Richard would probably know best.

                      Is the dying regulator associated with
                      termination? Are you using the SCSI card but not
                      turning on all of the devices on the chain?

---

From: Insane Multitasker <[email-masked]>
Date: Thu, 3 Jul 2014 20:48:15 -0500

Here are three pictures of the front.  The back of the card has nothing of interest.  

(if the attachments are stripped I'll send a Dropbox link)

        

      Tony

      

              

                

                Modified 'F' card.

                  PC power supply also.

                  Tony