Subject: Floppy Disk Services dual disk drive for TI-99/4A

From: Barry Peterson <[email-masked]>
Date: Tue, 30 Jul 2013 13:45:29 -0400

If I ever sell one of my drive boxes, I hope it's worth more than $7.50

http://www.ebay.com/itm/151088146359?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1423.l2649

(Not mine but I have some nearly identical)

---

From: "kevan064" <[email-masked]>
Date: Thu, 01 Aug 2013 02:44:20 -0000

$52.25 was the winning bid, so I guess it came down to 'the wire' on that one! ;)