Subject: RE: [TI994A] MPES50

From: Marc Hull <[email-masked]>
Date: Sat, 28 Jun 2014 18:05:34 -0700

That did it.  Thanks.

------------------------------
On Sat, Jun 28, 2014 7:01 PM CDT 'Ksarul' [email-masked] [TI994A] wrote:

>Try DSKU, it is optimized for Myarc controllers. . .
>
> 
>
>Jim
>
> 
>
>From: [email-masked] [mailto:[email-masked]] 
>Sent: Saturday, June 28, 2014 7:26 PM
>To: [email-masked]
>Subject: RE: [TI994A] MPES50
>
> 
>
>  
>
>
>
>Huh. Bad data cable I guess, at least so far. I can save sand load from DB
>but no luck formatting. DM II complains and DM 1000 STB and locks up. Is
>there a prefered DM for this beast ?
>
>------------------------------
>On Sat, Jun 28, 2014 4:19 PM CDT Insane Multitasker [email-masked]
>[TI994A] wrote:
>
>>I'd double-check the power and cables to the drives. The timeout infers (to
>me) the controller is probably functioning, at least well enough to know you
>are trying to access a disk. If the EPROM wasn't accessible, and the buffer
>chips between RAM/EPROM were toast, you would get a more immediate device
>not found error. 
>>
>>
>> To: [email-masked]
>> From: [email-masked]
>> Date: Sat, 28 Jun 2014 13:57:46 -0700
>> Subject: RE: [TI994A] MPES50
>> 
>> 
>> 
>> 32k tests fine. Rs233 & pio work.
>> 
>> Pdm module reports no disk controller. XB tries but times out.
>> 
>> Drive light doesn't come on.
>> 
>> ------------------------------
>> On Sat, Jun 28, 2014 3:40 PM CDT Insane Multitasker [email-masked]
>[TI994A] wrote:
>> 
>> >Marc, I don't think there are schematics available for any Myarc
>products with the exception of the HFDC and Geneve. I definitely do not
>recall having access to any during my days @ Cecure. Then again, stranger
>information has surfaced in the TI world :)
>> >
>> >What are the symptoms?
>> >
>> >To: [email-masked]
>> >From: [email-masked]
>> >Date: Sat, 28 Jun 2014 10:42:06 -0700
>> >Subject: [TI994A] MPES50
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> > 
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >Does anyone have a schematic for the Myarc MPES50 ? I have one with a
>dead FDC that I'd like to get operational again.
>> >
>> >Thanks in advance
>> >
>> >Marc
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> > 
>> 
>> 
>> ------------------------------------
>> Posted by: Marc Hull <[email-masked]>
>> ------------------------------------
>> 
>> 
>> ------------------------------------
>> 
>> Yahoo Groups Links
>> 
>> 
>> 
>> 
>
>
>
>
>
>---
>This email is free from viruses and malware because avast! Antivirus protection is active.
>http://www.avast.com

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 29 Jun 2014 13:52:24 -0500

There's also Myarc Disk Manager III   (MDM3)  if DSKU doesn't cut it.  This is not the same program as the HFDC's disk management program MDM5. 

> Date: Sat, 28 Jun 2014 18:05:34 -0700

---

From: [email-masked]
Date: Sun, 29 Jun 2014 15:00:35 -0400

I wonder if the DSR eprom in that beast could be replaced with the 80 
track version from the Myarc FDC.

Tony

On 6/29/2014 2:52 PM, Insane Multitasker [email-masked] [TI994A] 
wrote:
>
> There's also Myarc Disk Manager III   (MDM3) if DSKU doesn't cut it.  
> This is not the same program as the HFDC's disk management program MDM5.
>
>

---

From: Insane Multitasker <[email-masked]>
Date: Sun, 29 Jun 2014 14:22:47 -0500

ftp://ftp.whtech.com/datasheets%20and%20manuals/Hardware/Myarc/Myarc%20Mini%20Peripheral%20Expansion%20System%20manual.pdf

The manual talks about a "Disk Manager cartridge". The disk capacity table makes no reference to 18 sectors/track, only 16.   I think Marc needs to snap some pictures of the insides while it is torn apart :)

To: [email-masked]
From: [email-masked]
Date: Sun, 29 Jun 2014 15:00:35 -0400
Subject: Re: [TI994A] MPES50

    

    I wonder if the DSR eprom in that beast
      could be replaced with the 80 track version from the Myarc FDC.

      Tony

      On 6/29/2014 2:52 PM, Insane Multitasker [email-masked]
      [TI994A] wrote:

            

            There's also Myarc Disk Manager III   (MDM3) 
              if DSKU doesn't cut it.  This is not the same program as
              the HFDC's disk management program MDM5.

---

From: [email-masked]
Date: 29 Jun 2014 13:42:26 -0700

OK so so far it seems to work.  Took it apart and swapped some sockets out and now it seems bullet proof.  

It has a funny format.  DSDD yields 1280 sectors which is 320K.  Don't know if this is the way it should be or whether something is still amiss.  Not gonna sweat it right now as it is really damn hot out and my beer level is getting low ;-)...  I'll see if I can upload some pics now.

---

From: [email-masked]
Date: Sun, 29 Jun 2014 17:27:42 -0400

The format you're getting is consistent with the original Myarc FDC 
eprom. That's why I suggested the 80 track upgrade, it defaults to 18 
sectors per track instead of 16. But I don't see any dipswitches on the 
board, so I wonder whether it would default to 40 or 80 tracks. Do you 
have a way to dump the eprom so we can look at the code?

Tony

On 6/29/2014 4:42 PM, [email-masked] [TI994A] wrote:
> It has a funny format.  DSDD yields 1280 sectors which is 320K.  Don't 
> know if this is the way it should be or whether something is still 
> amiss.  Not gonna sweat it right now as it is really damn hot out and 
> my beer level is getting low ;-)...  I'll see if I can upload some 
> pics now.
>
> _